
Quick Reference

SAP® Sybase® PowerDesigner®

16.5 SP02

Windows



DOCUMENT ID: DC38094-01-1652-01
LAST REVISED: May 2013
Copyright © 2013 by SAP AG or an SAP affiliate company. All rights reserved.
No part of this publication may be reproduced or transmitted in any form or for any purpose without the express permission of
SAP AG. The information contained herein may be changed without prior notice.
Some software products marketed by SAP AG and its distributors contain proprietary software components of other software
vendors. National product specifications may vary.
These materials are provided by SAP AG and its affiliated companies ("SAP Group") for informational purposes only,
without representation or warranty of any kind, and SAP Group shall not be liable for errors or omissions with respect to the
materials. The only warranties for SAP Group products and services are those that are set forth in the express warranty
statements accompanying such products and services, if any. Nothing herein should be construed as constituting an additional
warranty.
SAP and other SAP products and services mentioned herein as well as their respective logos are trademarks or registered
trademarks of SAP AG in Germany and other countries. Please see http://www.sap.com/corporate-en/legal/copyright/
index.epx#trademark for additional trademark information and notices.

http://www.sap.com/corporate-en/legal/copyright/index.epx#trademark
http://www.sap.com/corporate-en/legal/copyright/index.epx#trademark


Contents

Core Features Quick Reference ...........................................1
Manipulating Symbols .....................................................3
Manipulating Link Symbols .............................................5

Glossary Quick Reference ....................................................7
Requirements Model Quick Reference ................................9
Enterprise Architecture Model Quick Reference ..............11
Business Process Model Quick Reference .......................13
Conceptual and Logical Data Model Quick Reference .....15
Physical Data Model Quick Reference ...............................17
Data Movement Model Quick Reference ............................19
Object-Oriented Model Quick Reference ...........................21
XML Model Quick Reference ..............................................23
Free Model Quick Reference ..............................................25
SAP Platform Quick Reference ...........................................27
Extensions Quick Reference ..............................................29
Shortcut Keys ......................................................................31
Index ..................................................................................35

Quick Reference iii



Contents

iv SAP Sybase PowerDesigner



Core Features Quick Reference

SAP® Sybase® PowerDesigner® is a graphical enterprise modeling solution supporting
standard methodologies and notations and providing automated code reverse engineering and
generation through customizable templates. PowerDesigner provides powerful reporting
capabilities, is highly extensible, and offers a scalable enterprise repository solution with
strong security and versioning capabilities to aid multi-user development.

Creating Models and Projects
Models are the basic working unit in PowerDesigner, and contain one or more diagrams.
Projects contain one or more models and can also include a framework diagram or matrix to
guide how your project should be modeled:

• To create a new model, select File > New Model.
• To create a new model by importing an Excel, Word, ERwin, XMI, Rational Rose, or

SIMUL8 file, select File > Import > type.

Core Features Quick Reference

Quick Reference 1



• To create a new model by reverse-engineering a database, process or object language files,
or an XML schema, select File > Reverse Engineer > type.

• To create a new project, select File > New Project.

Setting Up Your Modeling Environment

• To connect to a repository, select Repository > Connect.
• To set model options including naming conventions for your objects, select Tools > Model

Options.
• To control the look of and information displayed on your diagram symbols, select Tools >

Display Preferences.
• To set general options for dialog boxes, editors, variables, etc, select Tools > General

Options.
• To customize the commands in your menus and tools in your toolbars, select Tools >

Customize Menus and Tools.

The PowerDesigner Interface
These core features are available in all or many models:

• To create an object in a diagram, select the appropriate tool in the Toolbox and then click in
the diagram.

• To create an object in the Browser, right-click the model or a package and select New >
Object Type.

• To open an object property sheet, double-click its Browser entry or diagram symbol.
• To add a diagram to your model, right-click the model node in the Browser and select New

> Diagram Type.
• To find objects, select Edit > Find Objects (or press Ctrl+F).
• To find the Browser entry for an object symbol, right-click the symbol and select Find in

Browser.
• To find the diagram symbol for an object in the Browser, right-click the Browser item and

select Find in Diagram.
• To check the validity of your model, select Tools > Check Model (or press F4).
• To add a dependency matrix to your model, right-click the model node in the Browser and

select New > Dependency Matrix.
• To create a report on your model, select Report > Report Wizard (or press Ctrl+F12).
• To enable the use of the glossary in your model, select Tools > Model Options, choose the

Naming Convention category, and select Use glossary for autcompletion and
compliance checking .

Linking and Syncing
These features help you to create and review connections in and between your models:
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• To create a connection from one object to any other object, open its property sheet and
click the Traceability Links tab.

• To generate one model from another (where available), select Tools > Generate type
Model.

• To generate objects from one model to another, select Tools > Generate Objects > Define
New Object Generation.

• To create a shortcut to an object in another model or package, right-click on the target
object in the Browser (or its symbol in a diagram) and drag and drop it into the diagram
where you want to create the shortcut (or onto a model or package in the Browser). Release
the right mouse button, and select Create Shortcut(s) Here.

• To create a synchronized replica of an object in another model or package, right-click on
the target object in the Browser (or its symbol in a diagram) and drag and drop it into the
diagram where you want to create the replica (or onto a model or package in the Browser).
Release the right mouse button, and select Replicate Here.

• To create or review mappings between two models (where available), select Tools >
Mapping Editor

• To compare two models, select Tools > Compare Models (or press Ctrl+F6).
• To merge two models, select Tools > Merge Models (or press Shift+F6).
• To analyze the impact of a change to an object, select Tools > Impact and Lineage

Analysis (or press Ctrl+F11).

Documentation
For detailed documentation, see Core Features Guide.

Manipulating Symbols
You can select symbols in a PowerDesigner diagram using standard gestures. You can edit
properties of the selected symbol's object or it's sub-objects, and resize the symbol by clicking
and dragging on its handles.

Click on a symbol with the default Pointer tool to select it. To select:

• Additional symbols, press and hold Shift while clicking them.
• All symbols in an area, click and hold while dragging the pointer over the area.
• All symbols connected to a symbol, click the symbol and then select Edit > Select

Connected Symbols
• All symbols in the diagram, press Ctrl+A, click the Grabber tool, or select Edit > Select

All

In the following example, the Customer table is selected, and can be moved by dragging or
resized by dragging on one of its handles:
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Note: To resize all the symbols in a diagram at once, click the Grabber tool and then drag one
of the handles.

When a symbol is selected, clicking on one of its object properties lets you edit its value. Now,
the table name is selected for editing:

When an object property is selected for editing, you can navigate through its editable
properties and on into its sub-object properties by pressing the Tab or Shift+Tab keys.

Note: You can control the object and sub-object properties that appear on a symbol using
display preferences (Tools > Display Preferences).

When a symbol is selected, clicking on one of its sub-objects selects that sub-object. Now, the
Customer activity column sub-object is selected:

You can navigate up and down in the list of sub-objects by pressing the Up Arrow or Down
Arrow keys. When a sub-object is selected, clicking on one of its properties lets you edit its
value. Now the Customer activity column name is selected for editing:
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To create a new sub-object at the end of the list, press Ctrl+N. To insert a new sub-object above
the selected sub-object, press Ctrl+I. To delete the selected sub-object, press Del. Right-
clicking a sub-object opens a contextual menu offering useful commands.

When a sub-object property is selected for editing, you can navigate right and left along the
line of its editable properties by pressing the Tab or Shift+Tab keys.

Note: The following kinds of properties are not editable via object symbols:

• Boolean properties, such as the Abstract property on OOM class symbols.
• Custom indicators, such as those used to identify keys and indexes on PDM table symbols.
• Certain calculated properties, such as Domain or Datatype on PDM table symbols.

Manipulating Link Symbols
You can add and remove corners to and from link symbols, and change the objects that they
connect.

1. Draw a link between two objects:

2. Press Ctrl and click a point on the line to create a handle where you want to insert a corner:

3. You can add a second handle, or as many as you need:

4. To create a corner, click and hold the handle and then drag it to where you want the corner
to be:
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5. You can drag the other handles too:

6. To remove a handle (and corner), press Ctrl and click on the handle to remove:

Note: To move an extremity of a link symbol from one object to another, click to select the
link, and then drag the end handle to the new object.

Core Features Quick Reference

6 SAP Sybase PowerDesigner



Glossary Quick Reference

The glossary model (GLM) helps you capture and organize the terminology to be used for
naming your model objects. An administrator deploys the glossary, and users enable it in their
models to provide autocompletion for object names and model checks to ensure compliance.
The glossary appears in the Browser Glossary tab and updates are pushed to users each time
they connect to the repository, or on demand. Only one glossary is permitted per repository.

Administering the Glossary
An administrator performs the initial deployment of the glossary to the repository by adding
terms to it and checking it into the repository:

• To control access to the glossary, right-click the Glossary node, and select Permissions.
By default, all users have Read permission on the glossary.

• To import terms from the names of objects from a PowerDesigner model open in your
workspace, right-click the Glossary node, and select Import from Model.

• To import terms from an Excel or CSV file, right-click the Glossary node, and select
Import from Excel File.

• To create a glossary terms list, right-click the Glossary node, and select New > Glossary
Terms List.

Using the Glossary

• To consult the glossary, click the Browser Glossary tab.
• To enable the use of the glossary in your model, select Tools > Model Options, then click

Naming Convention in the category list and select Use glossary for autocompletion and
compliance checking.

• To check glossary compliance, select Tools > Check Model and select the Name/Code
contains terms not in glossary and Name/Code contains synonyms of glossary terms
for the types of objects whose names you want to verify.

Glossary Quick Reference
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Documentation
For detailed documentation, see Core Features Guide > Modeling with PowerDesigner > The
Browser > The Glossary.
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Requirements Model Quick Reference

A requirements model (RQM) helps you analyze any kind of written requirements and link
them with users and groups who will implement them and with design objects in other models.
You can use an RQM to represent any structured document (e.g. functional specification, test
plan, business goals, etc.) and import and export hierarchies of requirements as MS Word
documents.

Creating an RQM

• To create a new RQM - Select File > New Model, and choose Requirements Model.
• To create a new RQM by importing a Word document - Select File > Import > Word

Document.

The following types of views are available:

• A requirements document view displays a list of written requirements in a hierarchic grid.
Multiple views can be created with different filters to display various subsets of
requirements.

• A traceability matrix view displays the links between requirements and objects from other
types of models, external files or other requirements.

• A user allocation matrix view displays the links between requirements and the users and
groups who will fulfill them.

Linking Requirements with Design Objects and External Files
You can link requirements to objects from other types of models, external files, and other
requirements on the Requirement Traceability Links tab of the requirement property sheet.

Documentation
For detailed documentation, see Requirements Modeling.
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Enterprise Architecture Model Quick
Reference

An enterprise architecture model (EAM) helps you analyze and document your organization
and its business functions, along with the applications and systems that support them and the
physical architecture on which they are implemented.

Creating an EAM

• To create a new EAM - Select File > New Model, and choose Enterprise Architecture
Model.

• To create a new EAM by importing a Visio diagram - Open your diagram in Visio and
select PowerDesigner > Export to PowerDesigner Model.

The following types of diagrams are available:
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• A process map provides a graphical view of your business architecture, and helps you
identify your business functions and high-level processes, independent of the people and
business units who fulfill them.

• An organization chart provides a graphical view of your organization as a tree structure,
and helps you analyze and display the relationships between organization units (divisions,
groups, teams, etc), individuals, and roles.

• A business communication diagram provides a graphical view of your organization, and
helps you analyze, the relationships, flows, and other connections between business
functions, organization units, roles, and sites.

• A city planning diagram provides a graphical view of the big picture of your enterprise
architecture, using the metaphor of planning the infrastructure of a city to represent the
organization of systems, applications, etc into architectural areas.

• A service-oriented diagram provides a graphical view of your business and application
services and the relationships between them, and helps you associate applications and
other application layer objects with business services and processes to assist with SOA
design.

• An application architecture diagram provides a high-level graphical view of the
application architecture, and helps you identify applications, sub-applications,
components, databases, services, etc, and their interactions.

• A technology infrastructure diagram provides a high-level graphical view of the physical
architecture required to support the application architecture.

Exporting and Importing Objects to and from Other Models
The EAM provides wizards to export EA objects to lower-level models and to import
implementation objects to be represented in the EAM:

• To export EAM objects to another model - Select Tools > Export Objects Wizard
• To import objects from other models into an EAM - Select Tools > Import Objects

Wizard

Documentation
For detailed documentation, see Enterprise Architecture Modeling.
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Business Process Model Quick Reference

A business process model (BPM) helps you identify, describe, and decompose business
processes. You can analyze your system at various levels of detail, and focus alternatively on
control flow (the sequence of execution) or data flow (the exchange of data). SAP® Sybase®

PowerDesigner® supports Analysis, SOA, DFD, SAP® Solution Manager, BPMN (including
for SAP NetWeaver®), and BPEL process languages, and process simulation through
SIMUL8.

Creating a Business Process Model

• To create a new, empty BPM, select File > New Model, and choose Business Process
Model.

• To reverse engineer a new BPM from process language files, select File > Reverse
Engineer > Process Language.

The following types of diagrams are available:

• A business process diagram (or process flow diagram) provides a graphical view of the
control flow (the sequence of execution) or data flow (the exchange of data) between
processes at any level in your system.
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• A process hierarchy diagram (or functional decomposition diagram) provides a graphical
view of the functions of a system and helps you decompose them into a tree of sub-
processes.

• A process service diagram provides a graphical view of the services, operations, and
interfaces available in your system.

Working with Data in a BPM
PowerDesigner provides various methods for linking data in your BPM to data items, entities,
tables or classes in other PowerDesigner models:

• To link data in a BPM with other PowerDesigner objects, use the Definition field on the
General tab of the data property sheet.

• To export data in a BPM to other PowerDesigner objects, select Tools > Data Export
Wizard.

• To import other PowerDesigner objects as data in a BPM, select Tools > Data Import
Wizard.

Working with Process Language Definitions
The process language definition file defines features specific to the language being modeled:

• To open the process language definition file in the Resource Editor, select Language >
Edit Current Process Language.

• To change the process language to model with, select Language > Change Current
Process Language.

Documentation
For detailed documentation, see Business Process Modeling.
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Conceptual and Logical Data Model Quick
Reference

A conceptual data model (CDM) helps you analyze the conceptual structure of an information
system, to identify the principal entities to be represented, their attributes, and the
relationships between them. A CDM is more abstract than a logical (LDM) or physical (PDM)
data model.

A logical data model (LDM) helps you analyze the structure of an information system,
independent of any specific physical database implementation. An LDM has migrated entity
identifiers and is less abstract than a conceptual data model (CDM), but does not allow you to
model views, indexes and other elements that are available in the more concrete physical data
model (PDM).

Creating a CDM or LDM

• To create a new CDM, select File > New Model, and choose Conceptual Data Model.
• To create a new LDM, select File > New Model, and choose Logical Data Model.
• To create a new CDM or LDM by importing one or more ERwin files, select File > Import

> ERwin File or File > Import > Multiple ERwin Files.
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Specifying a Modeling Notation and Other Options

• To specify a modeling notation and set other model options, select Tools > Model
Options.

Generating Other Models
You can generate other PowerDesigner models from a CDM or LDM by selecting Tools >:

• Generate Conceptual Data Model (or press Ctrl+Shift+C)
• Generate Logical Data Model (or press Ctrl+Shift+L)
• Generate Physical Data Model (or press Ctrl+Shift+P)
• [CDM only] Generate Object-Oriented Model (or press Ctrl+Shift+O)

Documentation
For detailed documentation, see Data Modeling.
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Physical Data Model Quick Reference

A physical data model (PDM) helps you to analyze the tables, views, and other objects in a
database, including multidimensional objects necessary for data warehousing. A PDM is
more concrete than a conceptual (CDM) or logical (LDM) data model. You can model,
reverse-engineer, and generate for all the most popular DBMSs.

Creating a Physical Data Model

• To create a new, empty PDM, select File > New Model, and choose Physical Data
Model.

• To reverse engineer a new PDM from a live database connection, select File > Reverse
Engineer > Database.

• To create a new PDM by importing one or more ERwin files, select File > Import >
ERwin File or File > Import > Multiple ERwin Files.

The following types of diagrams are available:

• A physical data diagram provides a graphical view of your database structure, and helps
you analyze its tables (including their columns, indexes, and triggers), views, and
procedures, and the references between them.
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• A multidimensional data diagram provides a graphical view of your datamart or data
warehouse database, and helps you identify the facts and dimensions that will be used to
build its cubes.

Specifying a Modeling Notation and Other Options

• To specify a modeling notation, column, reference, and ownership defaults and set other
model options, select Tools > Model Options.

Interacting with Databases

• To connect to a database, select Database > Connect.
• To generate a database, select Database > Generate Database.
• To modify a database, select Database > Apply Model Changes to Database.
• To reverse engineer from a live database connection into an existing PDM, select

Database > Update Model from Database.
• To generate test data to a database, select Database > Generate Test Data.
• To estimate the size of a database, select Database > Estimate Database Size

Generating Other Models
You can generate other PowerDesigner models from a PDM by selecting Tools >:

• Generate Conceptual Data Model (or press Ctrl+Shift+C)
• Generate Logical Data Model (or press Ctrl+Shift+L)
• Generate Physical Data Model (or press Ctrl+Shift+P)
• Generate Object-Oriented Model (or press Ctrl+Shift+O)
• Generate XML Model (or press Ctrl+Shift+M)

Working with DBMS Definitions
The DBMS definition file defines features specific to the DBMS being modeled:

• To open the DBMS definition file in the Resource Editor, select Database > Edit Current
DBMS.

• To change the DBMS to model with, select Database > Change Current DBMS.
• To set default DBMS-specific physical options, select Database > Default Physical

Options.

Documentation
For detailed documentation, see Data Modeling.
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Data Movement Model Quick Reference

A data movement model (DMM) provides a global view of the movement of information in
your organization. You can analyze and document where your data originates, where it moves
to, and how it is transformed on the way, including replications and ETL.

Creating a Data Movement Model

• To create a new, empty DMM - Select File > New Model, and choose Data Movement
Model.

• To reverse engineer replication processes into a DMM from a consolidated database
connection - Select Tools > Reverse Engineering Replication Server.

The following types of diagrams are available:

• A data movement diagram provides a high-level graphical view of the movement of your
information, including data sources, replications, and ETL operations.

• A data transformation diagram provides a graphical view of the inputs, outputs, and steps
involved in a data transformation task.

• A transformation control flow diagram provides a graphical view of the order in which a
series of data transformation tasks is linked together in a control flow.

Creating Replication and Transformation Environments

• To create a replication environment, select Tools > Replication Wizard.
• To create a transformation process to transform data from a PDM, select Tools >

Transformation Wizard.
• To create a transformation process from existing PDM-to-PDM mappings, select Tools >

Convert Mappings to ETL Wizard.

Documentation
For detailed documentation, see Data Movement Modeling.
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Object-Oriented Model Quick Reference

An object-oriented model (OOM) helps you analyze an information system through use cases,
structural and behavioral analyses, and in terms of deployment, using the Unified Modeling
Language (UML). You can model, reverse-engineer, and generate for Java, .NET and other
languages.

Creating an Object-Oriented Model

• To create a new, empty OOM - Select File > New Model, and choose Object Oriented
Model.

• To reverse engineer a new OOM from a object language files - Select File > Reverse
Engineer > Object Language.

• To import a Rational Rose model into an OOM - Select File > Import > Rational Rose
File.

• To import an XMI file into an OOM - Select File > Import > XMI File.

The following types of diagrams are available:

• A use case diagram is a UML diagram that provides a graphical view of the requirements
of your system, and helps you identify how users interact with it.

• A class diagram is a UML diagram that provides a graphical view of the classes, interfaces,
and packages that compose a system, and the relationships between them.

• An object diagram is a UML diagram that provides a graphical view of the structure of a
system through concrete instances of classes (objects), associations (instance links), and
dependencies.

• A composite structure diagram is a UML diagram that provides a graphical view of the
classes, interfaces, and packages that compose a system, including the ports and parts that
describe their internal structures.

Object-Oriented Model Quick Reference
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• A package diagram is a UML diagram that provides a high-level graphical view of the
organization of your application, and helps you identify generalization and dependency
links between the packages.

• A sequence diagram is a UML diagram that provides a graphical view of the chronology of
the exchange of messages between objects and actors for a use case, the execution of an
operation, or an interaction between classes, with an emphasis on their chronology.

• A communication diagram is a UML diagram that provides a graphical view of the
interactions between objects for a use case scenario, the execution of an operation, or an
interaction between classes, with an emphasis on the system structure.

• An interaction diagram  is a UML diagram that provides a high-level graphical view of the
control flow of your system as it is decomposed into sequence and other interaction
diagrams.

• An activity diagram is a UML diagram that provides a graphical view of a system behavior,
and helps you functionally decompose it in order to analyze how it will be implemented.

• A statechart diagram is a UML diagram that provides a graphical view of a State Machine,
the public behavior of a classifier (component or class), in the form of the changes over
time of the state of the classifier and of the events that permit the transition from one state to
another.

• A component diagram is a UML diagram that provides a graphical view of the
dependencies and generalizations among software components, including source code
components, binary code components, and executable components.

• A deployment diagram is a UML diagram that provides a graphical view of the physical
configuration of run-time elements of your system.

Generating Other Models
You can generate other PowerDesigner models from an OOM by selecting Tools >:

• Generate Conceptual Data Model (or press Ctrl+Shift+C)
• Generate Physical Data Model (or press Ctrl+Shift+P)
• Generate Object-Oriented Model (or press Ctrl+Shift+O)
• Generate XML Model (or press Ctrl+Shift+M)

Working with Object Language Definitions
The object language definition file defines features specific to the language being modeled:

• To open the object language definition file in the Resource Editor, select Language > Edit
Current Object Language.

• To change the process language to model with, select Language > Change Current
Object Language.

Documentation
For detailed documentation, see Object-Oriented Modeling.

Object-Oriented Model Quick Reference

22 SAP Sybase PowerDesigner



XML Model Quick Reference

An XML model (XSM) helps you analyze an XML Schema Definition (.XSD), Document
Type Definition (.DTD) or XML-Data Reduced (.XDR) file. You can model, reverse-
engineer, and generate each of these file formats.

Creating an XML Model

• To create a new, empty XSM - Select File > New Model, and choose XML Model.
• To reverse engineer a new XSM from an XML schema definition - Select File > Reverse

Engineer > XML Definition.

Generating Other Models
You can generate other PowerDesigner models from an XSM by selecting Tools >:

• Generate Physical Data Model (or press Ctrl+Shift+P)
• Generate XML Model (or press Ctrl+Shift+M)

Working with XML Language Definitions
The XML language definition file defines features specific to the language being modeled:

• To open the XML language definition file in the Resource Editor, select Language > Edit
Current Language.

• To change the XML language to model with, select Language > Change Current
Language.

Documentation
For detailed documentation, see XML Modeling.
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Free Model Quick Reference

A free model (FEM) provides a context-free environment for modeling any kind of objects or
systems. It is generally associated with a set of extensions, which allow you to define your own
concepts and graphical symbols.

Creating a Free Model

• To create a new, empty FEM - Select File > New Model, and choose Free Model.

Changing a Symbol Image
PowerDesigner provides a library of high-quality symbols to use in your models. To change
the image associated with a symbol, right-click the symbol and select Change Image.

Documentation
See the Extensions Quick Reference on page 29. For detailed documentation, see
Customizing and Extending PowerDesigner > Extension Files.

Free Model Quick Reference
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SAP Platform Quick Reference

PowerDesigner provides support for various components in the SAP platform.

SAP HANA
PowerDesigner supports round trip reverse-engineering and generation of SAP HANA® v1.0
SP05 and SP06 tables and analytic and attribute views.

For detailed documentation, see Data Modeling > DBMS Definition Reference > SAP HANA
Database.

SAP Business Suite
An SAP Business Suite installation is built on a complex database structure, which comprises
many thousand tables with often cryptic names, and may include large numbers of
customizations. In certain environments, there may be multiple servers, each with different
customizations. PowerDesigner allows you to browse the application component and package
hierarchy and to import them and their supporting logical objects for analysis, comparison,
and merging of data dictionaries, and can also help you prepare a HANA table structure to
allow consolidated reporting on one or more SAP® Business Suite installations.

PowerDesigner supports importing any recent version of SAP® Business Suite.

For detailed documentation, see Data Modeling > DBMS Definition Reference > SAP
Business Suite.

SAP BusinessObjects
PowerDesigner supports generation of a SAP® BusinessObjects™ universe from your PDM
for editing in the BusinessObjects Universe Design or Information Design tools, or for direct
consumption by the Web Intelligence rich client. Generating a universe from your PDM gives
you access to table, view, and column names and comments and more reliable cardinality
information than if you create a universe directly from your database.

To use this feature, you must have SAP® BusinessObjects™ SBOP BI Platform Clients 4.0
SP04 Patch 3 (v14.0.4.819) or higher installed on your workstation. On Windows Vista or
Windows 7 machines, if PowerDesigner fails to recognize a valid BusinessObjects
installation, it may be necessary separately to launch the Universe Design tool one time with
administrator privileges to enable the BusinessObjects SDK.

For detailed documentation, see Data Modeling > Building Data Models > Generating and
Reverse-Engineering Databases > Generating a BusinessObjects Universe.
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SAP Solution Manager
PowerDesigner supports round-trip importing and exporting of SAP® Solution Manager v7.1
SP07 and SP08 projects. You can import and modify existing business scenarios and
processes; create new ones, and re-export your project to your Solution Manager server.

For detailed documentation, see Business Process Modeling > SAP Solution Manager

SAP NetWeaver
PowerDesigner supports round-trip importing and exporting of SAP NetWeaver® BPM v7.3
and higher BPMN2 files.

For detailed documentation, see Business Process Modeling > Business Process Modeling
Notation (BPMN) > Importing and Exporting BPMN2 Files.

SAP Platform Quick Reference
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Extensions Quick Reference

Extensions files (*.xem) allow you to customize and extend the PowerDesigner metamodel
to support your exact modeling needs. You can define additional properties for existing
objects or specify entirely new types of objects, modify the PowerDesigner interface
(reorganizing and adding property sheet tabs, Toolbox tools and menu items), and define
additional generation targets and options.

Creating Extensions from a Property Sheet

• To create an extended attribute directly from an object property sheet, click the menu
button, and select New Attribute.

• To create a new collection directly from an object property sheet, click the menu button,
and select New List of Associated Objects.

Working with Extension Files

• To attach an existing extension file to a model, select Model > Extensions, and click the
Import tool.

Extensions Quick Reference
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• To create a new extension file, select Model > Extensions, click the Add a Row tool, enter
a name for the file, and then click the Properties tool.

Types of Extension
You can extend the metamodel in the following ways:

• Create or sub-classify new kinds of objects:
• Metaclasses – drawn from the metamodel as a basis for extension.
• Stereotypes [for metaclasses and stereotypes only] – sub-classify metaclasses by

stereotype.
• Criteria – sub-classify metaclasses by evaluating conditions.

• Add new properties and collections to objects and display them:
• Extended attributes – to add metadata.
• Extended collections and compositions – to enable manual linking between objects.
• Calculated collections – to automate linking between objects.
• Dependency matrices – to show dependencies between two types of objects.
• Forms – to modify property sheets and add custom dialogs.
• Custom symbols – to change the appearance of objects in diagrams.

• Add constraints and validation rules to objects:
• Custom checks – to test the validity of your models on demand
• Event handlers – to perform validation or invoke methods automatically.

• Execute commands on objects:
• Methods – VBScripts to be invoked by menus or form buttons.
• Menus [for metaclasses and stereotypes only] – to add commands to PowerDesigner

menus.
• Generate objects in new ways:

• Templates – to extract text from object properties.
• Generated Files - to assemble templates for preview and generation of files
• Transformations – to automate changes to objects at generation or on demand.

• Map correspondences between different metamodels:
• Object generations - to define mappings between different modules in the

PowerDesigner metamodel for model-to-model generation.
• XML imports - to define mappings between an XML schema and a PowerDesigner

module to import XML files as models.

Documentation
For detailed documentation, see Customizing and Extending PowerDesigner > Extension
Files.
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Shortcut Keys

PowerDesigner provides many shortcut keys to accelerate your workflow.

Toolbox Shortcuts

Shortcut Action

Double-click Pointer tool / Ctrl+A Select all symbols in diagram.

Double-click Delete tool Delete all selected symbols (with confirmation).

Double-click Grabber tool Zoom to whole diagram.

Double-click any object tool Select all symbols of this type.

Shift+Double-click any object tool Retain current selection and add all symbols of this type.

Right-click Release tool and select pointer.

Browser Shortcuts

Shortcut Action

* (number pad) Expand all nodes.

+ (number pad) Expand subnodes.

- (number pad) Collapse subnodes.

F2 Rename selected item.

Ctrl+Shift+F Find selected item in Diagram.

Diagram Shortcuts

Shortcut Action

DEL and Shift+DEL Delete object (with and without confirmation).

Alt+ENTER Open object property sheet.

Ctrl+K Paste as shortcut.

Ctrl+H [on selected link] Force link to horizontal.

Ctrl+L [on selected link] Force link to vertical.

Ctrl+Page Up and Ctrl+Page Down Bring symbol to front and send symbol to back.

Shortcut Keys
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Shortcut Action

Ctrl+Home and Ctrl+End Align selection on vertical and horizontal axis.

Ctrl+T Open Symbol Format dialog.

Ctrl+J Auto-resize the symbol to display all the text it contains up
to the value specified for word wrapping in the diagram.

Ctrl+Resize Resize object while keeping same center point.

Ctrl+Shift+Resize Resize object while keeping same center point and propor-
tions.

F2 or Ctrl+Right-click on Name Rename object.

Drag and Drop Shortcuts

Shortcut Action

Shift+Drag and drop Move object.

Ctrl+Drag and drop Copy object.

Shift+Ctrl+Drag and drop Create shortcut of object.

Alt+Drag and drop Create replica of object.

Right-click+Drag and drop Open menu to choose an action.

Window and General Shortcuts

Shortcut Action

F4 Check model.

F5 Zoom to actual size.

F6 Zoom in.

F7 Zoom out.

F8 Zoom to whole diagram.

F9 Previous view.

F10 Display used pages.

Shift+F5 Redisplay.

Shift+F9 Next view.

Shortcut Keys

32 SAP Sybase PowerDesigner



Shortcut Action

Shift+Click item Select consecutive items.

Alt+0 Show/hide Browser.

Alt+1 Show/hide Output view.

Alt+2 Show/hide Result List view.

Alt+3 Show/hide Welcome page.

Alt+F6 Cycle between active windows.

Ctrl+Double-click / Ctrl++ (plus) [on package or other composite symbol] Open subdiagram.

Ctrl+Tab Cycle through property sheet tabs.

Ctrl+Page Up / Ctrl+Page Down Cycle through property sheet tab subtabs.

Ctrl+B Find selected object in Browser.

Ctrl+D Select diagram.

Ctrl+E Open list of reports.

Ctrl+F Find objects.

Ctrl+F4 Close diagram.

Ctrl+Alt+F4 Close model.

Ctrl+F6 / Ctrl+Shift+F6 Cycle between property sheets.

Ctrl+U Go to parent diagram.

Shift+F2 Open workspace.

Shift+F3 Save workspace.

Shift+F4 Close workspace.

List Shortcuts

Shortcut Action

F2 Select text for edit.

F4 Select cell to add text.

Ctrl+Shift+Spacebar Select line.

Ctrl+A Select all.
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Shortcut Action

Ctrl+Shift+A Deselect all.

Ctrl+N Add entry.

Ctrl+I Insert entry.

Ctrl+D Delete entry.

Code Preview Tab Shortcuts

Shortcut Action

F2 Next bookmark.

F3 Find next.

Shift+F11 Menu.

Ctrl+F2 Insert/Remove bookmark.

Ctrl+I Insert file.

Shortcut Keys
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