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PART I

Modeling with PowerDesigner

The chapters in this part introduce you to the SAP® Sybase® PowerDesigner® interface and
the core concepts available for all kinds of models.

Core Features Guide 1



2 SAP Sybase PowerDesigner



CHAPTER 1 Getting Started with
PowerDesigner

SAP® Sybase® PowerDesigner® is a graphical enterprise modeling solution supporting
standard methodologies and notations and providing automated code reverse engineering and
generation through customizable templates. PowerDesigner provides powerful reporting
capabilities, is highly extensible, and offers a scalable enterprise repository solution with
strong security and versioning capabilities to aid multi-user development.

The default PowerDesigner window displays the following views:

• The Browser - displays your models and the objects belonging to them (see Chapter 2, The
Browser on page 35). The Browser also allows you to view a PowerDesigner repository
(see Chapter 10, The Repository on page 287) and may display an enterprise library of
shared models (see The Library on page 39) and an enterprise glossary (see The Glossary
on page 36).

• The Canvas - is a tabbed view that displays your open diagrams (see Diagrams on page
169) and report outlines (see Chapter 12, Reports on page 363).
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• The Toolbox - displays graphical tools to help you quickly build model diagrams. The
available tools depend on the type of the currently selected diagram (see Creating Objects
from the Toolbox on page 89).

• The Result List - displays the results of a search or a model check.
• The Output view - (grouped, above, with the Result List) displays the progress of any

PowerDesigner process, such as checking a model or generating or reverse engineering a
database.

For information about moving, docking, grouping, splitting, and hiding these views, see 
Organizing Views on page 268.

In addition, you will work extensively with:

• Object property sheets - which permit you to view and edit the object's properties. You can
access an object's property sheet by double-clicking its symbol or browser entry, or right-
clicking it and selecting Properties (see Object Properties on page 98).

• Object lists - provide a spreadsheet-like presentation of, and allow for the easy creation and
modification of objects in your model. Lists are available under the Model menu and on
the property sheets of composite objects such as entities, tables, and classes, which contain
sub-objects (see Object Lists on page 108).

The Welcome Page
The Welcome page gives you one-click access to all your recent projects, workspaces, and
models, as well as providing a direct link to the New Model and New Project dialogs and a

CHAPTER 1: Getting Started with PowerDesigner
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range of help materials. To suppress this page, select the Do not show this page again check
box. You can redisplay it at any time by selecting View > Welcome Page.

By default, the following items are available:

• Getting Started
• Create Model - Opens the New Model dialog to let you create a model (see Creating a

Model on page 9).
• Create Project - Opens the New Project dialog to let you create a project (see Creating

a Project on page 48).
• Open Model or Project - Opens a standard Open dialog to let you browse for a model

or project to open.
• Examples - Opens the PowerDesigner Examples folder to let you select an example

model to open.
• Help - Opens the PowerDesigner online help.
• What's New in PowerDesigner - Opens the PowerDesigner New Features Summary.

CHAPTER 1: Getting Started with PowerDesigner
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• Documentation and Videos - Opens a Web page listing the available PowerDesigner
documentation and videos.

• PowerDesigner Web Site - Opens the PowerDesigner page on the Sybase® website.
• PowerDesigner Newsgroup - Opens the PowerDesigner newsgroup page on the

Sybase website.
• Recent projects and workspaces - Lists your most recent projects and workspaces. Click

a project or workspace to open it.
• Recent models - Lists your most recent models. Click a model to open it.

PowerDesigner Models
PowerDesigner enables you to closely integrate the design and maintenance of your
application's core data layers with your project requirements, business processes, OO code,
XML vocabularies, and database replication information and to align these with your overall
enterprise architecture and corporate standards. By providing you with a comprehensive set of
models at all levels of abstraction, PowerDesigner helps you broaden the reach of your
iterative design process to all aspects of your system architecture, from conception to
deployment, and beyond.

The following types of PowerDesigner models are available:

Icon Description

A requirements model (RQM) helps you analyze any kind of written requirements and link
them with users and groups who will implement them and with design objects in other
models. You can use an RQM to represent any structured document (e.g. functional speci-
fication, test plan, business goals, etc.) and import and export hierarchies of requirements as
MS Word documents.

File extension: .rqm Backup: .rqb
An enterprise architecture model (EAM) helps you analyze and document your organization
and its business functions, along with the applications and systems that support them and the
physical architecture on which they are implemented.

File extension: .eam Backup: .eab
A business process model (BPM) helps you identify, describe, and decompose business
processes. You can analyze your system at various levels of detail, and focus alternatively on
control flow (the sequence of execution) or data flow (the exchange of data). SAP® Sybase®

PowerDesigner® supports Analysis, SOA, DFD, SAP® Solution Manager, BPMN (includ-
ing for SAP NetWeaver®), and BPEL process languages, and process simulation through
SIMUL8.

File extension: .bpm Backup: .bpb
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Icon Description

A conceptual data model (CDM) helps you analyze the conceptual structure of an infor-
mation system, to identify the principal entities to be represented, their attributes, and the
relationships between them. A CDM is more abstract than a logical (LDM) or physical
(PDM) data model.

File extension: .cdm Backup: .cdb
A logical data model (LDM) helps you analyze the structure of an information system,
independent of any specific physical database implementation. An LDM has migrated entity
identifiers and is less abstract than a conceptual data model (CDM), but does not allow you to
model views, indexes and other elements that are available in the more concrete physical data
model (PDM).

File extension: .ldm Backup: .ldb
A physical data model (PDM) helps you to analyze the tables, views, and other objects in a
database, including multidimensional objects necessary for data warehousing. A PDM is
more concrete than a conceptual (CDM) or logical (LDM) data model. You can model,
reverse-engineer, and generate for all the most popular DBMSs.

File extension: .pdm Backup: .pdb
A data movement model (DMM) provides a global view of the movement of information in
your organization. You can analyze and document where your data originates, where it
moves to, and how it is transformed on the way, including replications and ETL.

File extension: .dmm Backup: .dmb
An object-oriented model (OOM) helps you analyze an information system through use
cases, structural and behavioral analyses, and in terms of deployment, using the Unified
Modeling Language (UML). You can model, reverse-engineer, and generate for Java, .NET
and other languages.

File extension: .oom Backup: .oob
An XML model (XSM) helps you analyze an XML Schema Definition (.XSD), Document
Type Definition (.DTD) or XML-Data Reduced (.XDR) file. You can model, reverse-engi-
neer, and generate each of these file formats.

File extension: .xsm Backup: .xsb
A free model (FEM) provides a context-free environment for modeling any kind of objects or
systems. You can use it to sketch simple visualizations or create entirely new forms of model
by defining your own concepts and graphical symbols through an extension file. See Chap-
ter 6, The Free Model (FEM) on page 219.

File extension: .fem Backup: .feb
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Icon Description

The glossary model (GLM) helps you capture and organize the terminology to be used for
naming your model objects. An administrator deploys the glossary, and users enable it in
their models to provide autocompletion for object names and model checks to ensure com-
pliance. The glossary appears in the Browser Glossary tab and updates are pushed to users
each time they connect to the repository, or on demand. Only one glossary is permitted per
repository. See The Glossary on page 36 and Deploying an Enterprise Glossary on page
541.

File extension: .glm Backup: .geb
A multimodel report (MMR) is a PowerDesigner report that can document any number of
models together and show the links between them. To create such a report, you must have at
least one model open in the workspace, and you can add additional models at any time. See
Chapter 12, Reports on page 363.

File extension: .mmr Backup: .bmr

PowerDesigner does not impose any particular software engineering methodology or process.
Each company can implement its own workflow, defining responsibilities and roles,
describing what tools to use, what validations are required, and what documents to produce at
each step in the process.

A development team will comprise multiple user roles, each of whom will use different
PowerDesigner models:

• Business Analysts – define the architecture of the organization, the business requirements
and high-level business flows, and may use:
• EAM - for providing a big picture of the organization, defining its structure, and

analyzing high-level functions, processes, and flows. These architectural objects can
be attached to implementation objects in any of the other models.

• RQM - for defining business requirements to be refined into technical requirements by
Analysts and Designers.

• BPM - to define the high-level business process flows in existing and new systems, and
to simulate business processes to improve productivity.

• Data Analysts and Designers - map technical requirements to business requirements, and
may use:
• OOM - to define use cases and map them to requirements.
• BPM - to write functional specifications and define more precisely the nature and

details of each process, the application and its data structure.
• CDM - to provide a clear view of business data across all systems.

• Database Administrators use the well-defined data structure to optimize, denormalize, and
create the database, and may use:
• PDM - to represent a database running on a server with complete information on the

structure of the physical objects, such as tables, columns, references, triggers, stored
procedures, views, and indexes, and to generate to and reverse-engineer from scripts or
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a live database connection. By maintaining a PDM and a CDM, you can ensure that
your analysis and design efforts are reflected exactly in your actual systems.

• LDM - which can act as a bridge between a CDM and a PDM, allowing you to resolve
many-to-many and super/sub-type relationships, de-normalize your data structures,
and define indexes, without specifying a particular RDBMS.

• DMM - to represent the replication of information from a source database to one or
several remote databases.

• Developers model the application, defining object structures and behaviors, and Object/
Relational mappings, and may use:
• RQM - to write technical specifications.
• OOM - to represent objects and their interactions in UML, and to generate and reverse

engineer OO code. Close integration with your BPM, CDM, and PDM can greatly
simplify the maintenance and development of your system.

• XSM - to graphically model the complex structure of an XML file and to generate and
reverse-engineer DTDs, and XSDs and link them to your PDM and OOM.

• Testers will use the RQM, CDM, and other models, together with the design documents to
understand how the application should work and how it is developed.

Creating a Model
You create a new model by selecting File > New Model.

Note: A project can provide a convenient environment for working with multiple
interconnected models and other files (see Chapter 3, Projects and Frameworks on page
47).

The New Model dialog is highly configurable, and your administrator may hide options that
are not relevant for your work or provide templates or predefined models to guide you through
model creation. When you open the dialog, one or more of the following buttons will be
available on the left hand side:

• Categories - which provides a set of predefined models and diagrams sorted in a
configurable category structure.

• Model types - which provides the classic list of PowerDesigner model types and
diagrams.

• Template files - which provides a set of model templates sorted by model type.
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1. Select File > New Model to open the New Model dialog.

2. Click a button, and then select a category or model type ( as appropriate ) in the left-hand
pane.

For a list of PowerDesigner model types, see PowerDesigner Models on page 6.

3. Select an item in the right-hand pane. Depending on how your New Model dialog is
configured, these items may be first diagrams or templates on which to base the creation of
your model.

Use the Views tool on the upper right hand side of the dialog to control the display of the
items.

4. Enter a model name. The code of the model, which is used for script or code generation, is
derived from this name using the model naming conventions.

5. [BPM, PDM, OOM, and XSM] Select a target resource file , which customizes
PowerDesigner's default modifying environment with target-specific properties, objects,
and generation templates.

By default, PowerDesigner creates a link in the model to the specified file. To copy the
contents of the resource and save it in your model file, click the Embed Resource in
Model button to the right of this field. Embedding a file in this way enables you to make
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changes specific to your model without affecting any other models that reference the
shared resource.

6. [optional] Click the Select Extensions button and attach one or more extensions to your
model.

7. Click OK to create and open the model .

Note: Sample models are available in the Example Directory.

Note: For information about creating new models in the PowerDesigner Eclipse plugin, see
Creating a Model in Eclipse on page 240.

Attaching Extensions At Model Creation Time
The Select Extensions dialog allows you to attach extensions to your model at creation time.
Extensions may contain additional types of objects or extensions to standard objects, along
with additional generation targets and other extensions to PowerDesigner's standard
capabilities.

1. Click the Select Extensions tool in the New Model dialog.

2. Review the different sorts of extensions available by clicking the sub-tabs and select one or
more to attach to your model.

By default, PowerDesigner creates a link in the model to the specified file. To copy the
contents of the extension file and save it in your model file, click the Embed Resource in
Model button in the toolbar. Embedding a file in this way enables you to make changes
specific to your model without affecting any other models that reference the shared
resource.

3. Click OK to close the dialog and return to the New Model dialog.

Note: You can attach extensions to your model after creation by selecting Model >
Extensions and clicking the Attach an Extension tool.

Model Templates
A model template is a shell model that contains a set of model options, display preferences,
extensions, and/or objects, which you can reuse in multiple models of the same type. For
example, a BPM model template can be used to create other BPMs, but not an OOM or PDM.
Model templates are stored in the model templates directory, which is, by default, the
PowerDesigner installation directory.

You can make any model available as a model template by saving it to the model templates
directory. Alternatively, you can manage your model templates from the New Model dialog
(select File > New Model, or click the New Model tool, and then select the Templates button.

Note: The New Model dialog is highly customizable and its display is controlled by the Model
Creation general options. If the Enable model template files option is deselected or if no valid
template directory is selected then the Templates button will not be available. For information
about these options, see Model Creation Options on page 264.
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The New Model dialog lists the model templates that are available, sorted by model type, and
provides the following tools:

Tool Description

Copy Model as Model Template – allows you to select one or more models as model
templates, and copies them to the model templates folder.

Change Model Templates Folder – allows you to select a folder for use as the model
templates folder.

For information about using the New Model dialog, see Creating a Model on page 9.

Accessing the Repository
You can access the repository directly, via the repository proxy, or through a web browser (via
the PowerDesigner Portal). Your administrator will tell you which methods are available to
you.

The following diagram shows the various ways that users can connect to the repository:

• Proxy Access [if the repository proxy is installed] - see Setting up PowerDesigner for
Access Via the Proxy on page 14

• Direct Access – see Setting up PowerDesigner for Direct Access on page 13
• Web Browser [if the PowerDesigner Portal is installed] – see Chapter 11, The

PowerDesigner Portal on page 337

Note: Before you can access the repository, an administrator must install and configure it and
provide you with a user name and password. For information about installing the repository,
see Installation Guide.
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Setting up PowerDesigner for Direct Access
To create a direct repository definition, you must have a login name and password for the
repository AND a user name and password for the database where it is stored. You may also
need to install a database client or driver in order to connect to the repository database. Your
repository administrator will supply you with this information.

If your administrator has installed the repository proxy, see Setting up PowerDesigner for
Access Via the Proxy on page 14.

Note: For information about installing the repository and making the first connection to it as
an administrator, see the Installation Guide.

1. Select Repository > Repository Definitions to open the List of Repository Definitions.

2. Click the Add a Row tool and type a name in the Repository Name column to identify the
definition for future use.

3. Type your user name in the Repository User column. If you are an administrator and are
creating the first repository definition that will be used to initialize the repository (see 
Chapter 18, Controlling Repository Access on page 521), you must use the ADMIN
repository user name.

4. Press F4 or click the Ellipsis button in the Data Source Name column to open the Select a
Data Source dialog:

5. Select one of the following options:

• ODBC machine data source
• ODBC file data source
• Connection profile (for native or JDBC connections)

Use the tools to the right of the data source field to browse to a new connection profile file
or directory, and the Modify and Configure buttons to change your existing data source
connection.
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For detailed information about creating, configuring, and using connection profiles, see 
Configuring Connection Profiles on page 21.

6. Select a data source and click OK to return to the List of Repository Definitions, where it
will be displayed in the Data Source Name column.

7. Click Apply to apply your changes, and then click the Properties tool to open the Direct
Repository Definition dialog:

This window has two group boxes:
• Repository – specifies the name of the repository definition.
• Database – specifies the name of the data source that hosts the repository database, and

the user name and password that you will use to connect to it. The user name and
password are optional, but if you do not specify them here you will need to enter them
each time you connect to the repository.
For non-Oracle unicode or multi-byte character set databases, you should also specify
the bytes per character used by the database:
• 1-byte - [default] For SBCS (Single-Byte Character Set)
• 2-byte - For DBCS (Double-Byte Character Set)
• 3-byte - For Unicode or MBCS (Multi-Byte Character Set)

8. Test the definition by clicking the Test button. A message box will state whether your
connection succeeds or fails.

9. Click OK to return to the List of Repository Definitions.

Setting up PowerDesigner for Access Via the Proxy
To create a proxy repository definition, you must have a login name and password for the
repository and know the server on which the proxy is installed. Your repository administrator
will supply you with this information.

If you are connecting directly, see Setting up PowerDesigner for Direct Access on page 13.
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1. Select Repository > Repository Definitions to open the List of Repository Definitions.

2. Click the Add a Row tool and type a name in the Repository Name column to identify the
definition for future use.

3. Type your user name in the Repository User column, and select Proxy in the Connection
Type column (you may need to widen the window to see this column).

4. Click Apply to apply your changes, and then click the Properties tool to open the Proxy
Repository Definition window:

This window has two group boxes:
• Repository – specifies the name of the repository definition.
• Proxy – specifies the name of the server where the repository proxy is installed, the

port number, and the name of the repository instance that you will connect to.

5. Test the definition by clicking the Test button. A message box will state whether your
connection succeeds or fails.

6. Click OK to return to the List of Repository Definitions.

Connecting to a Repository
Before you can connect to a repository, an administrator must install and configure it and
provide you with a user name and password, and you must have created a repository definition.

For information about creating a repository definition, see Accessing the Repository on page
12.

1. Select Repository > Connect (or double-click the root in the Browser Repository tab) to
open the Connect dialog.

CHAPTER 1: Getting Started with PowerDesigner

Core Features Guide 15



2. Select a repository to connect to and enter your login name and password. To review the
repository definition, click the Properties tool.

3. Click OK to connect.

The contents of the repository are displayed in the Repository tab of the Browser. The root
node displays the name of the repository and your login.

If any of the local copies of Library files (see The Library on page 39) are not up to date,
the Library Synchronization dialog will open to invite you to update them:

4. Select documents to update in your local library folder. Select Remember selection to
retain the same selection next time you connect to the repository and select Do not show
this dialog next time to have the library silently update from now on.
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Note: You can display the Library Synchronization dialog and change your settings at any
time by selecting Repository > Synchronize Library.

5. Click OK to perform any requested updates and begin modeling.

Note: To disconnect from the repository, select Repository > Disconnect (or right-click
the root in the Browser Repository tab and select Disconnect).

Connecting Automatically to the Default Repository
You can specify that you want to connect automatically to a repository each time you open
PowerDesigner. On opening PowerDesigner will prompt for your password to the repository
to which you were last connected.

1. Select Tools > General Options to open the General Options dialog and click the
Repository category.

2. Select Auto-connect in the Connection group box, and then click OK.

For information about the other options on this tab, see Repository Options on page
265.

Changing Your Repository Password
You can change the password that you use to connect to the repository at any time. You may be
required to change your password if it has expired or if the password policy has become more
restrictive.

Note: In the event that you have forgotten your password or have been blocked for multiple
failed logins or inactivity, you must ask your administrator to reset your password (see 
Unblocking Blocked Users on page 536).

1. Select Repository > Change Password to open the Change Password dialog.

The dialog lists the rules of the repository password policy that all passwords must respect
(see Defining a Password Policy on page 528).

2. Enter your old password, and then enter your new password twice.
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When your new password conforms to all the policy rules and the values entered in the
New password and Confirm password fields are identical, the OK button becomes
available.

3. Click OK to complete the change and return to the repository.

Connecting to a Database
PowerDesigner allows you to define data connections to access information in different
database management systems (DBMSs) using Structured Query Language (SQL).

A data connection processes function calls and SQL requests coming from PowerDesigner
and sends them to a data source, and returns results to PowerDesigner.

The PowerDesigner physical data model (see Data Modeling) and data movement model (see
Data Movement Modeling) allow you to define data connections for target databases in order
to generate your models and reverse engineer your data sources, while the repository (see 
Chapter 10, The Repository on page 287) requires a database to store your models and other
design documents.
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PowerDesigner supports various forms of connection, and your choice will depend on the
interface that you have already installed:

You have... Configure a connection of type...

ODBC driver ODBC machine or file data source (see Configuring ODBC Machine and
File Data Sources on page 19).

DBMS client Native connection profile (see Configuring Connection Profiles on page
21).

JDBC driver JDBC connection profile (see Configuring Connection Profiles on page
21).

Configuring ODBC Machine and File Data Sources
There are three types of Open Database Connectivity (ODBC) data sources:

Data source Description

Machine Data source is created on the client machine, and is available to the user currently
logged onto the system. Machine data sources are stored in the part of the registry
containing settings for the current user.

System Data source is created on the client machine, and is available to all users regard-
less of whether a user is logged onto the system or not. System data sources are
stored in the part of the registry containing settings for the current machine.

File Data source is stored as a file. A file data source has the extension .dsn. It can be
used by different users if it is placed in the default location for file data sources.
File data sources are usually managed by database administrators.

You define data sources using the Windows ODBC Administrator, which you can access
directly from PowerDesigner:

1. Select Database > Configure Connections to open the Configure Data Connections
window, and click the ODBC Machine Data Source or ODBC File Data Sources tab.
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2. Click the Add Data Source tool (see Data Connection Tools on page 26) to open the
Create New Data Source window, and select a File, User, or Machine data source as
appropriate and click Next.

3. Select the appropriate driver for your DBMS and click Next and then Finish to access a
driver-specific configuration dialog:
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4. Enter the appropriate parameters and then click OK to return to the Configure Data
Connections window.

5. Click OK to return to your model.

Configuring Connection Profiles
Before you can connect to a database through a DBMS client or JDBC driver, you must create
an appropriate connection profile.

1. Select Database > Configure Connections to open the Configure Data Connections
Window, and click the Connection Profiles tab:

CHAPTER 1: Getting Started with PowerDesigner

Core Features Guide 21



2. Click the Add Data Source tool (see Data Connection Tools on page 26) to open a
Connection Profile Definition window:
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3. Enter the properties (see Connection Profile Properties on page 24) appropriate to your
method of connection.

4. Click the Test Connection button to open the Test Connection window, and click OK to test
your connection.

5. Click OK to close the profile definition, and return to the Configure Data Connections
window

6. Click Ok to return to your model
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Connection Profile Properties
The Connection Profile Definition window lets you specify all the necessary properties for
connecting to your database.

Property Description

Connection profile
name

Specifies the name of the connection profile.

Directory Specifies the directory in which the .dcp connection file will be created. By
default .dcp files are stored in the Connection Profiles directory directly
beneath the PowerDesigner installation directory.

Description Optional additional description of the connection profile.

Connection type Specifies the type of connection profile. You can choose between:

• Native
• JDBC

The choice of connection type will affect the remaining fields to be com-
pleted.

DBMS type Specifies the DBMS to which the connection profile will connect. The list
includes only those DBMSs supported for the specified connection type.

Server name [Native only] Specifies the name of the database server to connect to.

Database name [Native only] Specifies the name of the database to connect to.

Service [Oracle Native only] Specifies the service name of the database to connect
to.

User name Specifies the username to use when connecting.

Password Specifies the password to use when connecting.

JDBC driver class [JDBC only] Specifies the driver class to use for the connection.

JDBC connection URL [JDBC only] Specifies the connection URL to use for the connection.

JDBC driver jar files [JDBC only] Specifies the driver jar file to use for the connection.

Connection parameters Specifies advanced connection parameters. Click the parenthesis tool to the
right of this field to access the Connection Parameters window.

Connection Parameters Window
You access this window by clicking the parenthesis tool to the right of the Connection
parameters field in the Connection Profile Definition window.

1. Click the Add a Row tool to create a new parameter.

2. Enter a name and value pair in the two columns.
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3. Click OK to return to the Connection Profile Definition window. All the parameters are
listed in the read-only Connection parameters field.

Native Connection Profile Example
In the example below, I have installed the Oracle DBMS client, and so create a Native
connection to the "Delphes" service.
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JDBC Connection Profile Example
In the example below, I have installed the Sybase ASE JDBC driver. I specify the appropriate
driver class in the jar file, and assemble the connection URL to create a JDBC connection to
my database, "Green", on my server "Rainbow".

Data Connection Tools
The Configure Data Connections window provides tools to manipulate your connections to
data sources.

Tool Description

Properties – Opens the ODBC Setup or Connection Profile Definition dialog for the se-
lected profile.

Add Data Source – Creates a new connection.

Browse Data Source File [ODBC file data sources and connection profiles] – Opens a file
browser to select a .dcp profile file.

Delete – Deletes the selected connection.
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Tool Description

Test Connection – Tests the selected connection.

ODBC Administrator [ODBC machine and file data sources] – Opens the ODBC Data
Sources Administrator window.

Change Connection Profiles Directory [Connection profiles] – Opens a file browser in
which to search for profiles. The default directory is install_dir/Connection Profiles.

Refresh – Refreshes the list of connections.

Select All – Selects all the connections in the list. Connections that are selected will be
displayed in lists in the PowerDesigner interface.

Unselect All - Unselects all the connections in the list. Connections that are not selected will
not be displayed in lists in the PowerDesigner interface.

Connecting to a Data Source
When you connect to your database, PowerDesigner can communicate with it for reverse-
engineering, generation or any other form of request.

1. Select Database > Connect to open the Connect to a Data Source window:

2. Select one of the following radio buttons, depending on your chosen method for
connecting to your data source:

• ODBC machine data source (see Configuring ODBC Machine and File Data Sources
on page 19)
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• ODBC file data source (see Configuring ODBC Machine and File Data Sources on
page 19) - use the tool to the right of the data source field to browse to a new file

• Connection profile (see Configuring Connection Profiles on page 21) - use the tools to
the right of the data source field to browse to a new directory or file

You can use the Modify and Configure buttons to modify or configure the selected
connection.

3. Enter your user ID and password, and then click Connect. If prompted by your data
source, you may need to enter additional connection parameters.

Note: You stay connected until you disconnect or terminate the shell session.

Running SQL Queries Against Your Database
You can use the Execute SQL Query dialog to query your database.

In addition to the standard tools (see Text Editor Tools on page 204), the following tools are
available in this dialog:

Tool Description

Run (F5). Executes the current script

[n/a] Insert Bookmark ( Ctrl+F2) – inserts a blue bookmark box at the cursor position. Press
Ctrl+F2 to delete the bookmark.

[n/a] Go to Next Bookmark (F2)

[n/a] Go to Previous Bookmark (Shift+F2)

License Management
You can evaluate PowerDesigner by obtaining a fully featured trial version, which expires 15
days after installation. If you need more than 15 days to evaluate PowerDesigner, you can
obtain an extension from Sybase, which will be provided as a standalone local license granted
for a limited period of time. To continue to use PowerDesigner after the trial period, you must
purchase a regular license from Sybase or a reseller.

PowerDesigner is licensed as a package of modules, or types of model. Various packages are
available, each regrouping some or all of the modules. Your permission to use these modules is
controlled by the Sybase licensing system, SySam (see Installation Guide > Planning Your
PowerDesigner® Installation or visit http://www.sybase.com/sysam).

The following types of license are available:

• Standalone seat (local) – installed on a specific machine and cannot be used on other
machines. PowerDesigner reviews the local license file and authorizes only the use of
modules for which a valid license is present. This type of license is convenient for smaller
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teams as it does not require a license server, but does not allow you to centralize license
management.

• Standalone seat (served) – assigned to a specific machine but served from a license server.
You must be connected to the license server to obtain the license when you start
PowerDesigner, and connect to the server at least once every 30 days in order to retain it.
This type of license is convenient for larger teams, when you want the security of
centralized license activation and management.

Note: A 15 day grace period is granted for users with standalone licenses when the license
server cannot be contacted or the license file cannot be read. There is no grace period for
floating licenses.

• Floating license (served) – licenses can be requested from the license server by any
machine, and are returned after use, or after 3 hours of inactivity. This type of license is
convenient for teams of all sizes where usage patterns allow the sharing of licenses.
You must be connected to the license server in order to obtain a license, and must remain in
contact (brief losses of contact only are permitted) in order to continue using it. When a
user begins to work after a period of inactivity, PowerDesigner will automatically try to
obtain a license, and if it is unable to do so, will display a message suggesting that you save
your work.

Note: For periods when you must be out of contact with the server, you can request a
mobile license (see Obtaining a Mobile License on page 31) for up to 30 days.

License Management Wizard
The License Management Wizard provides the same licensing options as the PowerDesigner
setup program. Note that you do not need to be administrator on your machine to access the
License Management Wizard.

You may need to access the wizard when:

• Moving from a trial license to a regular license - You may need to rerun the setup program
before launching the wizard if you need to install additional modules.

• Extending a trial license – After having requested your extension (which will be in the
form of a time-limited standalone local license) from Sybase.

• Obtaining a trial of a new package – You must rerun setup to install the additional modules
before launching the wizard.

• Moving from a standalone local to a standalone served license or from a standalone to a
floating license – You must be able to connect to the license server to make this change.

Note: The PowerDesigner plugin for Sybase Workspace is licensed with the other
components of Workspace, and the following procedure is not available for Workspace users.
For more information about licensing in Workspace, see the Sysam documentation provided
with Workspace.

1. Select Tools > License Parameters to open the Wizard.
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Note: If you have taken a mobile license, you will be prompted to return it before accessing
the wizard. If you are using a served license and the server cannot be contacted, an error
message will be displayed and you will not be able to access the wizard.

2. Select a type of license (see License Management on page 28) and then click Next:

• [local licenses] You must provide a valid license key. Follow the instructions to load the
key and then click Finish to validate your license and exit the wizard.

• [if you select to use a served license] Specify the name of the license server (and if your
administrator has specified one, a port number), and click Next

3. Specify the PowerDesigner package that you want to use, and then click Finish to validate
your license and exit the wizard.

Note: The list displays all the packages that are available on the server but does not
necessarily mean that a license for a particular package is available. If no license is
available for the selected package, you must select an alternate package or click Cancel to
restore your previous license configuration.

• If you are in trial mode, a license agreement dialog box is displayed.
• If you have selected a standalone local license, the license file information is added to

the license folder as a new license file.
• If you have selected a served option (standalone or floating) a new license file is created

to store the server name and port number.
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• If you have selected a different package, the new models of the package will be
available the next time you start PowerDesigner.

Obtaining a Mobile License
When you are using a floating license and anticipate being out of contact with the license
server, you can borrow a mobile license to allow you to continue using PowerDesigner for up
to 30 days.

1. Select Tools > Take Mobile License.

A confirmation dialog box is displayed.

2. Click Yes to obtain a mobile license and click OK to confirm.

Once you have obtained a mobile license, the 30 day limit is renewed automatically each
time you connect to the license server. If you do not contact the server for 30 days, the
mobile license is returned to the pool and you will not be able to use PowerDesigner until
you reconnect.

Note: When you no longer need the mobile license you should return it to the server to
make your license seat available to the general license pool. To do so, select Tools >
Return Mobile License.

Troubleshooting Licensing Problems
In rare cases, PowerDesigner may repeatedly fail to obtain authorization from a local license
file or the license server. If this happens, you can troubleshoot as follows:

1. Exit PowerDesigner and navigate to the following directory:

C:\Documents and Settings\All Users\Application Data\PowerDesigner x

2. Move any file with the .lic extension this folder to a safe place.

3. Make a backup copy of the file sysam.properties, and open it in a text editor. Remove the
lines starting "Pd.LicenseMode" and "Pd.Package" at the end of the file and save the file.

4. Restart PowerDesigner.

You will be prompted to open the License Management Wizard (see License Management
Wizard on page 29). Re-load your local license key or select the appropriate served license
type.

PowerDesigner Documentation
Full documentation is provided as context-sensitive help by pressing F1 and as PDFs by
selecting Help > Online Documentation.

The following manuals are provided with your PowerDesigner installation:
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• New Features Summary
• Quick Reference
• Installation Guide
• Core Features Guide
• Requirements Modeling
• Enterprise Architecture Modeling
• Business Process Modeling
• Data Modeling
• Data Movement Modeling
• Object-Oriented Modeling
• XML Modeling
• Customizing and Extending PowerDesigner

This documentation is also available for consultation or download from http://
sybooks.sybase.com.

Demonstration videos are also available. They can be installed with PowerDesigner (select
Help > Tutorial Videos) or viewed from the installation CD.

For documentation of the PowerDesigner metamodel, click Help > Metamodel Objects
Help (or click the Find in MetaModel Objects Help button at the bottom-right of the
Version Info tab of the property sheet of any object).

SAP Platform Support
PowerDesigner provides support for various components in the SAP platform.

SAP HANA
PowerDesigner supports round trip reverse-engineering and generation of SAP HANA® v1.0
SP07 tables and analytic and attribute views.

For detailed documentation, see Data Modeling > DBMS Definition Reference > SAP HANA
Database.

SAP Business Suite
An SAP Business Suite installation is built on a complex database structure, which comprises
many thousand tables with often cryptic names, and may include large numbers of
customizations. In certain environments, there may be multiple servers, each with different
customizations. PowerDesigner allows you to browse the application component and package
hierarchy and to import them and their supporting logical objects for analysis, comparison,
and merging of data dictionaries, and can also help you prepare a HANA table structure to
allow consolidated reporting on one or more SAP® Business Suite installations.

PowerDesigner supports importing any recent version of SAP® Business Suite.
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For detailed documentation, see Data Modeling > DBMS Definition Reference > SAP
Business Suite.

SAP BusinessObjects
PowerDesigner supports generation of a SAP® BusinessObjects™ universe from your PDM
for editing in the BusinessObjects Universe Design or Information Design tools, or for direct
consumption by the Web Intelligence rich client. Generating a universe from your PDM gives
you access to table, view, and column names and comments and more reliable cardinality
information than if you create a universe directly from your database.

To generate universes, you must have SAP® BusinessObjects™ SBOP BI Platform Clients 4.0
SP04 Patch 3 (v14.0.4.819) or higher installed on your workstation. On Windows Vista or
Windows 7 machines, if PowerDesigner fails to recognize a valid BusinessObjects
installation, it may be necessary separately to launch the Universe Design tool one time with
administrator privileges to enable the BusinessObjects SDK.

For detailed documentation, see Data Modeling > Building Data Models > Generating and
Reverse-Engineering Databases > Generating an SAP BusinessObjects Universe.

SAP Solution Manager
PowerDesigner supports round-trip importing and exporting of SAP® Solution Manager v7.1
SP08 projects. You can import and modify existing business scenarios and processes; create
new ones, and re-export your project to your Solution Manager server.

For detailed documentation, see Business Process Modeling > SAP Solution Manager

SAP NetWeaver
PowerDesigner supports round-trip importing and exporting of SAP NetWeaver® BPM v7.3
and higher BPMN2 files.

For detailed documentation, see Business Process Modeling > BPMN 2.0 Descriptive and
Executable > Importing and Exporting BPMN2 Files.

Next Steps
Now that you are familiar with the PowerDesigner Interface, you will want to start
experimenting with a particular type of model suitable to your needs.

• Requirements Model (RQM) - Now turn to the Requirements Modeling guide where you
will learn how to:
• Add, modify, promote and demote requirements in the requirements hierarchy
• Allocate requirements to particular team members and add traceability links to other

model components
• Import requirements from a structured MS Word document
• View traceability and user allocation reports
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• Enterprise Architecture Model (EAM) - Now turn to the Enterprise Architecture Modeling
guide where you will learn how to:
• Create diagrams in the business, application, and technology layers
• Import Visio diagrams
• Export and Import objects to and from other models

• Business Process Model (BPM) - Now turn to the Business Process Modeling guide where
you will learn how to:
• Create Process Hierarchy, Business Process, Process Service, and Composite Process

diagrams
• Manipulate Service Description Objects
• Generate an executable BPM, and implement processes

• Conceptual Data Model (CDM), Logical Data Model (LDM), or Physical Data Model
(PDM) - Now turn to the Data Modeling guide where you will learn how to:
• Create CDM entities and relationships between them
• Create LDM or PDM tables, columns, primary keys, indexes, and references and

define referential integrity
• Create PDM views, triggers, and abstract data types
• Create business rules, domains, and data items
• Generate a PDM from your CDM or LDM
• Reverse engineer from and generate to database scripts
• Work with PDM multidimensional diagrams

• Data Movement Model (DMM) - Now turn to the Data Movement Modeling guide where
you will learn how to:
• Define databases, replication processes, event scripts, and other replication objects
• Reverse engineer from and generate to the SAP® Sybase® Replication Server®

replication engine
• Design extract, transform, and load (ETL) operations to move data between databases

• Object-Oriented Model (OOM) - Now turn to the Object-Oriented Modeling guide where
you will learn how to:
• Design class, use case, and other standard UML diagrams
• Generate a PDM with O/R mapping
• Create an EJB
• Deploy a component

• XML Model (XSM) - Now turn to the XML Modeling guide where you will learn how
to:
• Define elements, entities, and other components of an XML schema
• Reverse engineer from and generate to DTD, XSD, and XDR files
• Generate an XSM from a PDM or OOM
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CHAPTER 2 The Browser

The Local tab of the Browser provides a hierarchical view of all the model objects in your
workspace. If the Browser is not visible, select View > Browser (or press Alt+0) to display
it.

To expand all nodes, press the numpad plus sign (+). To collapse all nodes, press the numpad
minus sign (-). To filter the Browser tree, start typing the name of an object that you want to
find in the Filter box:

PowerDesigner monitors your local documents against the versions stored in the repository,
and communicates their status using icons to the left of the document icons:

Status No Locks Locked by You
(Green Padlock)

Locked by Other
(Red Padlock)

Up to Date (Green Circle)

Local Changes (Red Check-
mark)

Changes on Server (Yellow
Exclamation)

Local and Server Changes

Note: You can control the display of status icons with the Display status icons in Local
Browser general option (see Repository Options on page 265).

A typical hierarchy of objects in the Browser Local tab may include:
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• Workspace - The root of every Browser tree, which contains and organizes all your models
and supporting documents (see Workspaces on page 42).

• Library - A folder containing enterprise models that are pushed automatically to all users
when they connect to the repository (see The Library on page 39)

• Projects – Act as containers for models and other documents, allowing you to save them as
a single unit in the repository (see Chapter 3, Projects and Frameworks on page 47).

• Folders - Organize models and other files (see Folders on page 42).
• Models - Are the basic design unit in PowerDesigner and contain one or more diagrams

and any number of model objects (see Models on page 43).
• Packages - Divide large models into smaller "sub-models" to avoid manipulating large sets

of objects, and can be used to assign different tasks or subject areas to different
development teams (see Packages on page 44).

• Diagrams - Graphical views of model objects (see Diagrams on page 169).
• Model objects – Include all items belonging to a model (see Chapter 4, Objects  on page

89).
• Reports – Are generated to document your models (see Chapter 12, Reports on page

363).

You can create objects from the Browser (see Creating Objects from the Browser on page
90) and drag, drop, and copy objects in the Browser, or between the Browser and the Canvas
(see Moving, Copying, and Deleting Objects on page 122).

To find the Browser entry for a diagram symbol, right-click it and select Edit > Find in
Browser. To find the diagram symbol for a Browser entry, right-click it and select Edit > Find
in Diagram.

The Glossary
In environments with a repository, administrators can deploy an enterprise glossary to help
everyone to use the same approved terms between projects for enterprise-wide consistency.
Updates to the glossary are pushed to users each time they connect to the repository or on
demand. The glossary appears in the Browser Glossary tab.

The glossary can contain the following objects:

• Terms - are words or phrases that are approved for use in naming model objects. When you
enable the glossary for your model, glossary terms are proposed as you enter object names.

• Synonyms - are words or phrases that are not approved for use in naming objects, and
which are associated with the terms that should be used instead. The approved terms are
proposed when you begin entering a synonym as an object name.

• Categories - to organize your terms. Each term can only appear in a single category.
• Glossary terms lists (see Glossary Terms Lists on page 546), dependency matrices (see 

Dependency Matrices on page 180), and reports (see Chapter 12, Reports on page 363) -
to present glossary terms in various ways.
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• Business Rules - see Business Rules on page 131.

Use the Glossary browser tab to review the approved terms, and double-click a term or
synonym to open its property sheet, to view supporting information or references. Start typing
the word you want to find in the Filter box at the top of the Browser to filter the glossary in real
time:

Note: You can only edit the glossary if you have Write permission on the glossary model (see
Deploying an Enterprise Glossary on page 541).

Select Tools > General Options and select the Glossary category to control the appearance of
the Glossary tab with the following options:

Option Description

Show glossary tab Shows the Browser Glossary tab.

Display Controls whether names or codes appear in the Browser Glossary tab.

Using Glossary Terms in Your Models
Enabling the glossary in your model provides autocompletion for object names (including
guidance to discourage the use of synonyms) and enables model checks to guide your models
toward glossary compliance.

1. Select Tools > Model Options, then click Naming Convention in the category list and
select Use glossary for autocompletion and compliance checking to enable the use of
the glossary in your model.

2. When entering the names of objects in property sheets, diagram symbols, object lists, or in
the Browser, glossary terms are suggested to autocomplete the name. Continue typing or
use the down arrow to descend to a term in the list, and press Enter to select it.
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If you click the object's Dependencies tab, the link to the chosen term is listed there:

3. [optional] Perform a model check to see which objects have names containing terms that
are not included in the glossary (see Checking Glossary Compliance on page 142).
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Term Properties
To view a term's properties, double-click its Browser entry. The property sheet tabs and fields
listed here are those available by default, before any customization of the interface by you or
an administrator.

The General tab contains the following properties:

Property Description

Name/Code Identify the object. The name should clearly convey the object's purpose to non-
technical users, while the code, which is used for generating code or scripts, may
be abbreviated, and should not normally include spaces. By default the code is
generated from the name by applying the naming conventions specified in the
model options. To decouple name-code synchronization, click to release the =
button to the right of the Code field.

Description Provides an explanation for the definition of the term. For information about
using the RTF editing tools, see Text Editor Tools on page 204.

Stereotype Extends the semantics of the object. You can enter a stereotype directly in this
field, or add stereotypes to the list by specifying them in an extension file.

Reference URL Specifies a site, which provides more information about the term.

The following tabs are also available:

• Synonyms - Specifies the synonyms of the term, which are not approved for use. The
Parent property of a synonym specifies the term with which the synonym shares a
meaning, and which should be used instead of the synonym.

• Related Terms - Specifies other terms associated with the term.

Note: Only an administrator or other user with Write permission on the glossary can edit terms
(see Creating Terms, Synonyms, and Related Terms on page 541).

The Library
In environments with a repository, administrators can deploy an enterprise library containing
reference models, resource files, and other documents to share generic modeling objects
between projects. Updates to the library are pushed to users each time they connect to the
repository or on demand. Models and other documents appear in a special folder in the
Browser Local tab.

The library appears by default at the top of your workspace as a folder named .Library and
provides access to enterprise reference models (such as a data dictionary or a PDM containing
standard domains) for reuse in your projects as shortcuts or replicas, and other reference
documents:
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You can rename your local library folder, move it in the Browser tree or detach it from your
workspace. To reinstate your Library if you have removed it, select Repository > Reinitialize
Local Library.

The library documents and resource files are automatically updated whenever you connect to
the repository (see Connecting to a Repository on page 15) and you can control which ones
will be pushed to your workspace. You can, at any time, confirm that you have the very latest
version of library documents by selecting Repository > Synchronize Library.

Resource files, such as DBMS or language definition files and extensions, are not displayed in
the Browser, but appear automatically in the new model dialog, resource file lists, and
anywhere in the interface where a resource file can be selected.

Note: By default, library documents are checked out to a subfolder inside My Documents/
PowerDesigner Libraries, controlled by the _SHARED named path (see Named
Paths on page 259). You can only check in changes to library documents if you have write
permission on the library folder or on one or more of its children (see Deploying an Enterprise
Library on page 549).

Reusing Library Objects in Your Models
Library models can contain reference objects that are intended for reuse in your models in the
form of shortcuts or replicas.

1. Expand the library model in the Browser to show the object that you want to reuse:
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2. Right-click on the object in the library model and drag and drop it into your model diagram
where you want to reuse it (or onto a model or package in the Browser).

3. Release the right mouse button, and select one of the following:

• Create Shortcut(s) Here - when you want create a reference to the library object.
• Replicate Here - when you want to create a local copy of the library object and make

changes to one or more of its properties

The shortcut or replica is created in your model, and can be connected to any appropriate
locally-created objects. In this example, a shortcut to the Create User library object is
connected to other locally-created objects:

If the library object subsequently changes, any updates will cascade automatically to your
model.

Note: For detailed information about working with shortcuts and replicas, see Chapter 15,
Shortcuts and Replicas on page 455.

The Repository Browser
The Repository tab in the Browser displays the content of the repository to which you are
currently connected.

For more information, see Browsing the Repository on page 287.
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Workspaces
The Local tab of the Browser contains a workspace to organize all your modeling and
supporting files. You can create projects, models, and folders in a workspace. To add external
files, drag and drop them from Windows Explorer.

We recommend that you save your workspace regularly:

• To perform a standard save - select File > Save Workspace or right-click the workspace
node in the Browser and select Save. You will be prompted to save any models that contain
changes.

• To save the workspace under another name - select File > Save Workspace As to open a
standard Save As dialog, or right-click the workspace node in the Browser and select Save
As. You will be prompted to save any models that contain changes.

• To save the workspace and all the models it contains - select File > Save All, or click the
Save All tool.

Note: Workspace files (*.sws) contain only the structure of the workspace. Deleting the
workspace file in Windows Explorer will not delete any projects, models, or other referenced
files.

To create a new workspace, simply close the current workspace by selecting File > Close
Workspace. You will be prompted to save the workspace and any models that contain
changes, and a new, empty workspace will open.

You can create multiple workspaces, but only one can be open at a time. To change workspace,
select File > Open Workspace. You will be prompted to save the current workspace and any
models that contain changes, and the selected workspace will open. The models contained in
the workspace are not open by default.

Folders
You can use folders to organize the projects, models, and other files in your workspace. The
folder structure is saved in the workspace file.

To create a folder, right-click the workspace root or another folder and select New > Folder,
then enter a name in the highlighted area. Folder names must be unique in the workspace.

To create a project, model, or multi-model report in a folder, select the folder and use the
standard tools, or right-click the folder and select New >  New item .

To add an existing project, model, or multi-model report to a folder from another location in
the Browser, drag and drop it onto the folder. You can also drag and drop PowerDesigner and
other files from Windows Explorer to the Browser.
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To delete a folder, select it and click the Delete tool or right-click it and select Edit >
Delete.

Note: Deleting a folder cannot be undone. When you delete a folder, you remove the models
and reports it contains from the workspace, but you do not delete them.

Models
Models are the basic work unit in PowerDesigner. You can create a model directly in the
workspace, in a folder, or as part of a project.

To create a model, click the New tool or select File > New Model (see Creating a Model on
page 9). For a list of available types of models, see PowerDesigner Models on page 6. For
detailed information about a particular type of model, and for information about creating a
model by importing, generating or reverse engineering, see the appropriate modeling guide.

To add an existing model to the workspace, click the Open tool or select File > Open, browse
to the model file, and click Open. To open the model as read-only, select the Open as read-
only check box.

Note: By default, when you open a workspace, its models are closed and bear a red dot in their
bottom-left corners. To open a closed model, double-click it or right-click it and select Open
or Open as Read-only. To close an open model to free up memory, right-click it and select
Close.

When a model contains unsaved changes, an asterisk is appended to its name in the Browser.
When you save a model or a multi-model report, PowerDesigner assigns it a unique
identifying number called GUID (Global Unique ID, which is used to identify documents in
the Repository and during model generation), and creates a backup copy of your file with the
same identifying number:

• To perform a standard save - select File > Save, click the Save tool, or right-click the model
entry in the Browser and select Save.

• To save the model as a backup version with the same GUID - select File > Save As, or
right-click the model node in the Browser and select Save As.

• To save the model as a new model with a new GUID - select File > Save As New Model, or
right-click the model node in the Browser and select Save As New Model. If you check the
new model into the repository, it must be as a new model without any revision history.
Other models with shortcuts pointing to the original model will continue to be connected
to that model.

• To save the workspace and all the model it contains - select File > Save All, or click the
Save All tool.

Note: The following formats are available when you save a model:
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• XML - [default] Larger and somewhat slower to load, but editable in a text editor.
Recommended for small to medium-sized models.

• Binary - Smaller and faster to load, but not editable outside of PowerDesigner.
Recommended for large models.

To change the display name of a model in the Browser, select it and press F2, or right-click it
and select Rename.

To delete a model from the workspace, select it and click the Delete tool, press Del, or right-
click it and select Detach From Workspace. The model is removed from the workspace, but
the file is not deleted from your disk.

Packages
A package is a piece of a model. When working with large models, you can split them into
smaller subdivisions in order to avoid manipulating the entire model at once. Packages can be
used to organize your model into different tasks and subject areas, and to assign parts of it to
different development teams.

You can create as many packages as you need in a model. The name of each package must be
unique in the model. You can decompose a package into other packages, and there is no
limitation to the decomposition depth.

Packages can contain the same kinds of items as models:

• Model objects
• Other packages
• Diagrams, in order to have different views of the contents of the package. Each package

has a default diagram

In the example below, a package called "Lending Records" (with a diagram of the same name)
has been added to the model "Library OOM":
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Note that you cannot save a package individually. When you save the model you also save all
the packages it contains.

Creating a Package
You can create package from the Toolbox, Browser, or Model menu.

• Use the Package tool in the diagram Toolbox.
• Select Model > Packages to access the List of Packages, and click the Add a Row tool.
• Right-click the model or package in the Browser and select New > Package.

When you create a package in models with multiple kinds of diagrams, you may be required to
specify the type of diagram to create in the package.

For general information about creating objects, see Core Features Guide > Modeling with
PowerDesigner > Objects.

Package Properties
To view or edit a package's properties, double-click its diagram symbol or Browser or list
entry. The property sheet tabs and fields listed here are those available by default, before any
customization of the interface by you or an administrator.

Note: The same properties (except where noted) are also available for project folders.

The General tab contains the following properties:

Property Description

Name/Code/
Comment

Identify the object. The name should clearly convey the object's purpose to non-
technical users, while the code, which is used for generating code or scripts, may be
abbreviated, and should not normally include spaces. You can optionally add a
comment to provide more detailed information about the object. By default the code
is generated from the name by applying the naming conventions specified in the
model options. To decouple name-code synchronization, click to release the = but-
ton to the right of the Code field.

Stereotype Extends the semantics of the object. You can enter a stereotype directly in this field,
or add stereotypes to the list by specifying them in an extension file.

Default dia-
gram

[package only] Specifies the diagram to display by default when you open the
package.

Use parent
namespace

[package only] Specifies that the package does not represent a separate namespace
from its parent and thus that objects created within it must have names that are
unique within the parent container. If this property is not selected, then the package
and its parent package or model can both contain objects that are called Object A.
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Property Description

Keywords Provide a way of loosely grouping objects through tagging. To enter multiple key-
words, separate them with commas.

Controlling the Namespace of a Package
PowerDesigner applies uniqueness checks on the names of objects. The namespace defines an
area in which the name and the code of an object of a given type must be unique. You can
decide whether an individual package must represent a separate namespace or not with the
Use parent namespace property.

Depending on the type of model where you create a new package, this option may be selected
by default:

• For the EAM, CDM, LDM, PDM, DMM, and FEM - the entire model is, by default, a
single namespace, and all the packages have the Use parent namespace. PowerDesigner
applies checks on uniqueness at the model level.

Note: The Glossary and XSM do not support packages. For information on namespaces in
the XSM, see XML Modeling.

• For the OOM, RQM and BPM – each package is, by default, a separate namespace and the
property is not selected. PowerDesigner applies checks on uniqueness at the package level.

In the following example, the class Printer is located in the Peripheral Package of an OOM
where each package is, by default, a separate namespace:
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CHAPTER 3 Projects and Frameworks

A project allows you to group together all the models and other types of documents you need
for a particular modeling task, and save them as a simple entity in your repository.

A project can contain one or more project diagrams (see Project Diagrams on page 50),
which show the connections between models and other documents:

Your project can also contain one or more framework diagrams and/or a framework matrix,
which direct how your project must be modeled and list the documents that are needed (see 
Completing Framework Diagrams and Matrices on page 56).

You can create a project from scratch or from a template. PowerDesigner provides a set of
predefined project templates, and you can also create your own (see Project and Framework
Templates on page 78).

Note: Projects and framework diagrams and matrices are only available with Enterprise
versions of PowerDesigner.
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Creating a Project
Every project (.prj) contains at least one diagram, and any number of model or file documents.
The project can also contain one or more framework diagrams, a framework matrix, and one or
more dependency matrices.

1. Select File > New Project to open the New Project dialog box.

2. Select a type of project in the tree. You can choose to create:

• An empty project.
• A project based on a template (see Project and Framework Templates on page 78).

Click the Change Template Directory tool to search for templates in another location.

3. Enter a project name and location, and select the Append Name To Location check box if
you want to add the project name to the root directory.

4. Click OK to close the dialog box, and create the project.

The project opens. You can add models and other documents to your project (see Adding
Model and File Documents to a Project on page 49 and Completing Framework
Diagrams and Matrices on page 56).
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Adding Model and File Documents to a Project
You can create models in your project and add existing models and files to it. Project
documents are listed in the Browser and displayed as icons in the project diagram. You can
open a model or file by double-clicking its icon in the diagram or in the Browser.

Creating Models Adding Existing Models and Docu-
ments

• Click the New Model tool in the Toolbox, and
click in the diagram to open the New Model
dialog (see Creating a Model on page 9).

• Right-click a project or a project folder, select
New > Model to open the New Model dialog.

• Click the Add Project Document tool in the
Toolbox, and click in the diagram to open an
Open dialog box. Browse to and select one or
more documents and then click Open.

• Drag and drop one or more documents from
the Browser, or the Windows Explorer to the
project node in the Browser or to the project
diagram.

Note: If you drag a folder with sub-folders
from Windows Explorer, the hierarchy is pre-
served but, since projects are not synchron-
ized with the file system, any files you sub-
sequently add to these folders outside Pow-
erDesigner will not be displayed in the
Browser.

The models contained in your project are visible in the Browser, beneath the project node and
also in the List of Models available (when the project has context) by selecting Model >
Models.

When you add existing documents from other locations to your project, they are listed under
the project node in the Browser, but are not moved to the project directory. Such documents
display a shortcut overlay on their symbols in the Browser and project diagrams to indicate
that they are located outside the project folder, and their entries in the List of Models have the
read-only [I]nside Project check box deselected.

In the following example, Object Model is inside the project and Physical Model is outside the
project:

In order to profit from the convenience of the project as a container, we recommend that you
create (or place) all its models and files inside the project directory in your file system.
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To move a document from outside to inside the project, right-click its Browser entry or its
symbol in the project diagram, and select Move to Project Directory. The file is moved to
inside the project directory in your file system, the shortcut overlay disappears, and the
[I]nside Project check box is selected in the List of Models.

Project Diagrams
A project diagram allows you to display project documents and the relationships between
them.

You can create one or more project diagrams in an existing project to display different views of
your project in any of the following ways:

• Right-click a project in the Browser, and select New > Project Diagram.
• Right-click the background of any project diagram, and select Diagram > New Diagram

> Project Diagram.
• Select View > Diagram > New Diagram > Project Diagram.

In the following example, the models and other documents for the WebLibrary project are
organized into sub-folders, and the connections between them (by reference, mapping, and
generation) are displayed in the Main Diagram project diagram:

The following tools are available in the Toolbox of a project diagram:
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Tool Description

New Model – Creates a PowerDesigner model in the project.

Add Project Document – Adds an existing document to the project, which can be:

• A PowerDesigner model (PDM, OOM, LDM etc.).
• An external file (PDF, text file etc.).

N/A Dependency links, such as generation, mapping, reference, and file links, are automatically
created between documents. These links cannot be created, but you may need occasionally
to rebuild them (see Rebuilding Dependency Links on page 52).

Converting a Set of Repository Documents into a Project
You can retrieve a set of documents checked into the repository and convert them into a project
to benefit from the convenience of the project as a container.

1. In the Repository Browser, create a project root folder to contain the project documents.

2. [optional] Create project sub-folders to organize documents according to your needs.

3. Drag and drop repository documents into these folders.

4. Right-click the project root folder, and select Convert to Project to convert it and all its
contents into a project.

In the following example, repository documents in the Examples folder are are transformed
into the WebLibrary Project:
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Opening Project Documents
Once you have added a PowerDesigner model to a project, you should only open the model
within the context of the project, as links between it and any other models in the project are
managed by the project file. If you attempt to open the model outside of the project, you will be
prompted to cancel the operation, and to open the project instead.

You can open a project document in the context of its project by double-clicking it in:

• a framework matrix or diagram
• a project diagram
• the Browser under its parent project

Similarly, models that belong to a project should only be checked in and out of the repository
via the project.

Viewing Dependency Links
You can explore the details of any of the dependency links in your diagram by right-clicking it
and selecting Show Dependencies.

Each type of link has its own viewer:

• Generation – displays the generation links between models in the Generation Links
Viewer (see The Generation Links Viewer on page 450).

• Mapping – displays the mapping links between models in the Mapping Editor (see The
Mapping Editor on page 477).

• Reference – displays the shortcuts and replications between models in the Shortcuts and
Replications dialog box.

In the following example, right-clicking the reference link between Data ETL and Replication
and Data Warehouse models opens the Shortcuts and Replications dialog box which displays
Data Warehouse object shortcuts:

Rebuilding Dependency Links
Dependency links are automatically generated in your project diagram when you add
documents that are linked to each other by, for example, generation, mappings, shortcuts, etc.

Rebuilding dependency links can be useful to update:

• Links between closed models you add to your project.
• Links deleted by error in your diagram.

1. Select Tools > Rebuild Dependency Links to open the Rebuild Dependency Links dialog
box.
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2. [optional] Clear the Open closed models check box to rebuild only those links in a limited
number of models.

3. Select the check boxes that correspond to the dependency links you want to rebuild.

4. Click OK to close the dialog box and return to the diagram. Any missing links are updated
in the diagram.

Project and Framework Display Preferences
PowerDesigner display preferences allow you to customize the format of object symbols, and
the information that is displayed on them.

To set project display preferences, select Tools > Display Preferences (or right-click the
diagram background and select Display Preferences).

Note: For information about changing the format of symbols, see Format Display Preferences
on page 212. Note that only framework architects (see Designing Framework Diagrams and
Matrices on page 63), are allowed to modify the framework diagram and matrix format
display preferences (see Symbol Format Properties on page 193).
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To set display preferences for a particular object, select it under the Content category. The
following table lists the display preferences available. The objects available to be customized
in the Display Preferences window depend upon the current diagram type.

Preference Description

Code Displays the code of the object.

Comment Displays the comment of the object.

Completion status [node and cell only] Displays a rectangle, which represents the work completion
status according to the percentage entered in node and cell floating lists and
property sheets.

Documents [node and cell only] Displays the list of documents in the node or cell, instead of
in floating lists.

Stereotype Displays the stereotype of the object.

Type [dependency link only] Displays the type of the dependency link, which can
include mapping links, shortcut links, generation links, etc.
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Project Checks
You can check the validity of your project at any time by pressing F4, selecting Tools > Check
Project, or right-clicking the diagram background, and selecting Check Project.

For information about using the Check Project Parameters dialog, see Checking Models on
page 137.

Model and File Checks
PowerDesigner provides default model checks to verify the validity of models and files.

Check Description and Correction

Model and file loca-
tion uniqueness

Multiple models or files cannot have the same location.

• Manual correction - Delete unnecessary model or file.
• Automatic correction - None.

Model location emp-
ty

[model only] There must be a path in the model document Location field.

• Manual correction - Save the model to specify a model location.
• Automatic correction - None.

External document
URL not under a
named path

A model or file is defined outside the project directory.

• Manual correction - Right-click the model or file, and select Move to
Project Directory.

• Automatic correction - None.

Target models not in
project

[model only] One or more target models of a model contained in the project is
missing.

• Manual correction - Add missing target model with appropriate depend-
ency link.

• Automatic correction - Yes.

Framework Node and Cell Checks
PowerDesigner provides default model checks to verify the validity of framework diagram
nodes and matrix cells.

Check Description and Correction

Name/Code unique-
ness

Object names must be unique in the namespace.

• Manual correction - Modify the duplicate name or code.
• Automatic correction - Appends a number to the duplicate name or code.
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Check Description and Correction

Documents not con-
sistent with node/cell
actions

A document in a node and cell must be consistent with its source action.

• Manual correction - Modify the node's and cell's content according to its
specified actions.

• Automatic correction - None

Mandatory actions
not executed

A mandatory action in a node and cell must be executed.

• Manual correction - Execute the mandatory action.
• Automatic correction: None

Completing Framework Diagrams and Matrices
Your project may contain one or more framework diagrams and/or a framework matrix, which
direct how your project should be built.

• A framework diagram - lets you model a framework with nodes and links, which you can
style as necessary.
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• Framework matrix - lets you model a framework in a matrix, in which columns usually
represent various aspects of the enterprise that can be described or modeled, and the rows
represent various viewpoints from which the aspects can be described. Each cell formed by
the intersection of a column and a row represents an aspect of the enterprise modeled from
a particular viewpoint.
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PowerDesigner provides a set of predefined framework diagrams and matrices, and users with
framework design rights can also create their own (see Designing Framework Diagrams and
Matrices on page 63). You complete a framework diagram or matrix by creating (or adding
existing) documents in nodes, cells, and additional areas according to predefined rules:

• Documents — can be of different types and can each be associated with multiple nodes,
cells, and additional areas:
• Model – a PowerDesigner model, such as a BPM or a PDM, created from scratch,

based on a template, or generated from another model.
• Diagram – a PowerDesigner model diagram, such as an OOM use case diagram.
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• Dependency matrix – a grid that displays the links between model objects (see 
Dependency Matrices on page 180).

• List – a list of PowerDesigner model objects, such as BPM processes, or PDM tables.
• File – an external file, such as a .doc or .txt file.

• Nodes and cells [when active] — must be completed by particular kinds of documents.
• Additional areas [framework matrix only] — can be defined outside of the grid (for

example, the global view in the FEAF framework matrix that is created at the end of the
enterprise architecture implementation).

Navigating in Framework Diagrams and Matrices
You can interact with framework diagram and matrix elements using various mouse actions.

• Hover over a framework element – to display its name and any comment.
• Click a node or cell – to open a floating list, which lets you manage the documents attached

to the node or cell (see Working with Floating Lists on page 62).
• Right-click a node or cell – to opens contextual menu (see Working with the Framework

Node and Cell Contextual Menu on page 63).
• Double-click a framework matrix element [framework architects only] – to open the

property sheet of the element (see Framework Matrix Properties on page 83).

Attaching a Document to a Framework Node or Cell
You can attach new (or existing) documents to each node of a framework diagram and cell of a
framework matrix.

1. Open the framework diagram or matrix by double-clicking its Browser entry.

2. Click the node or cell to which you want to add the document to open its floating list, which
displays the documents attached to it.

3. Click one of the following tools:

• New Document – to create a document of the specified kind:
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• Model [from scratch or based on a template] – creates the model and opens it in the
diagram window.

• Model [generated from another PowerDesigner model] – opens the Model
Generation Options dialog box to let you create a model (see Generating Models on
page 435).

• Diagram – opens a model selection dialog box to let you select a new or existing
model to create the diagram.

• Dependency matrix – opens a model selection dialog box to let you select a new or
existing model to create the dependency matrix (see Dependency Matrices on page
180).

• List – opens the List of Objects dialog box to let you create objects in a new or
existing model.

• File – opens a standard Save As dialog box to let you enter a file name. Click Save to
open the file in the application corresponding to the file extension.

• Add Document, and select:
• Attach Project Document – to add documents already in the project. Select the

type of document you want to attach.
• Add Document – to add documents from outside the project. Select the type of

document you want to add.

Note: You can also drag a project document from the Browser and drop it onto a node, a
cell or a floating list, or right-click a node or a cell, and select the New Document,
Attach Project Document, and Add Document commands. Documents can also be
moved from one node or cell to another.

4. [optional – New Document only] Complete the creation of the new document by, for
example, adding objects to the model or diagram, or entering text in the file, etc.

The document is displayed in the floating list.

Example: Creating a PDM from a Cell's Floating List
In this example, we create a PDM, which has been specified as a requirement to complete a
framework matrix cell.

1. Click a cell to open its floating list, which displays the documents attached to the cell.

2. Click the New Document tool, and then select New PDM to create the required PDM.

The new PDM document is displayed in the cell, and in the Browser in the folder specified
by the framework architect.

For information about specifying a model as a requirement to complete a framework node
or cell, see Example: Specifying a Model Action on page 66.
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Example: Creating a List of Processes from a Node's Contextual Menu
In this example, we create a list of BPM processes, which has been specified as a requirement
to complete a framework diagram node.

1. Right-click a node, and select New > Document > List of processes to open the List of
Processes dialog.

2. Create an appropriate number of processes in the list, entering a name for each, and then
click OK  to close the dialog box.

The list of processes document is displayed in the node, and in the Browser under a BPM
node in the folder specified by the framework architect.

For information about specifying a list as a requirement to complete a framework node or
cell, see Example: Specifying a List Action on page 68.

Deleting Documents from Framework Nodes and Cells
You can delete documents from framework nodes and cells. You can choose to simply detach a
document from the node or cell or completely remove it from the project.

1. Click a node or cell to open its floating list, select one or more documents in the list, and
then click the Delete tool.

Alternatively, select one or more documents in a node or cell and press the Del key or
right-click a document and select Edit > Delete.

The Confirm Deletion dialog box is displayed.

2. Choose one of the following delete options:

• Detach the document from the node or cell - the document is detached from the node or
cell but remains available in the project to be used elsewhere.

• Remove the document and any supporting file or model from the project - their deletion
from the project may affect files or models used elsewhere in the project.

3. Click OK to close the dialog box and confirm the deletion.
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Working with Floating Lists
You open a floating list by clicking a framework diagram node or matrix cell.

Note: Floating lists are not available when you select the Documents display preference (see
Project and Framework Display Preferences on page 53).

Floating lists contain the following tools to let you manage project documents in the
framework diagram and matrix:

Tool Description

Properties – opens the property sheet of the selected document.

Open Document – opens the selected document.

Add Document – contains the following tools:

• Attach Project Document – lets you select a document of the specified kind
from inside the project.

• Add Document – lets you select a document of the specified kind from
outside the project.

New Document – creates a document of the specified kind.

Delete – deletes the selected document from the node and cell. You can choose
to:

• Detach the document from the node and cell.
• Remove the document and any supporting file or model from the project.

For information see Deleting Documents from Framework Nodes and Cells on
page 61.

Customize Columns and Filter – allows the definition of filter expression on the
columns of the floating list (see Customizing Object List Columns and Filtering
Lists on page 113).

Enable/Disable Filter – enables or disables the filter.

Views – controls the display of documents in the floating list. You can choose
between:

• Large Icons – displays documents as large icons.
• List – displays documents in multiple columns to optimize space.
• Details – displays documents in a grid, which can be filtered.

Status Status – indicates the percentage of work completed in the node and cell.
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Working with the Framework Node and Cell Contextual Menu
The contextual menu available on framework nodes and cells allows you to perform various
actions.

The contextual menu of a framework node and cell contains the following commands. For
information about the additional commands available only in Framework Design Mode, see
Styling Framework Nodes and Cells on page 78):

Command Description

List of Documents Opens the node's or cell's floating list.

New Document Creates a document of the specified kind in the node or cell. An action
must be specified in the node or cell in order for this command to be
available.

Attach Project Document Attaches a document from inside the project to the node or cell.

Add Document Adds a document from outside the project to the node or cell.

Designing Framework Diagrams and Matrices
Framework architects (users who have selected the Authorize Framework Design user profile
when installing PowerDesigner) can create, design, and delete framework diagrams and
matrices in projects, by enabling the Framework Design Mode.
Select Tools > Framework Design Mode.

In the framework matrix, you can alternately right-click the framework matrix top-left corner,
and select Framework Design Mode. The design icon displays in the matrix top-left corner.

In the framework diagram, the Toolbox displays in the diagram.

Creating a Framework Diagram
Framework architects can create one or more framework diagrams to guide their modeling
teams through building a project. You can specify actions for each node in the framework
diagram that control what kind of document (model, diagram, model objects list etc.) must be
attached to them.

1. Right-click a project in the Browser, and select New > Framework Diagram to open the
framework diagram property sheet.

2. Enter a name for the framework diagram on the General tab, and click OK to close the
property sheet.

3. Click the Node tool in the Toolbox, click in the diagram, and create an appropriate number
of framework diagram nodes.
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4. Click the Link tool in the Toolbox, click in the diagram, and create an appropriate number
of framework diagram links between the nodes to express connections between them.

5. [optional] Decompose one or more nodes to analyze them in more detail (see 
Decomposing a Framework Node on page 64).

6. Create actions for each node to specify the types of documents that your modelers can
attach to the node (see Specifying Framework Node and Cell Actions on page 65).

7. [optional] Select File > Save As Template to open the Project Template Wizard, and
convert the project containing your framework diagrams into a template to allow it to be
reused as the basis for future projects (seeProject and Framework Templates on page
78).

Decomposing a Framework Node
You can decompose one or more nodes in the framework diagram to analyze them in more
detail. The decomposed node has its own sub-diagram, which models the links between its
sub-nodes. Sub-nodes can, themselves, be decomposed into further sub-nodes, and so on until
you obtain a sufficient level of detail.

You can decompose a node in a framework diagram in any of the following ways:

• Press ctrl and double-click the node symbol (this will open the sub-node directly)
• Open the property sheet of the node and, on the General tab, select the Composite check

box.

Decomposed node symbols in a framework diagram carry a plus-sign symbol to indicate that
they contain further detail

The sub-diagram of the decomposed node is empty at first. You have to create the appropriate
number of nodes and links between them to show their connections (see Creating a
Framework Diagram on page 63).

Creating a Framework Matrix
Framework architects can create a framework matrix to guide their modeling teams through
building a project. You can specify actions for each cell in the framework matrix that control
what kind of document (model, diagram, model objects list etc.) must be attached to them.

1. Right-click a project in the Browser, and select New > Framework Matrix Diagram to
open the framework matrix property sheet, or right-click the background of any project
diagram, and select Diagram > New Diagram > Framework Matrix, or select View >
Diagram > New Diagram > Framework Matrix.

Note: You can create only one framework matrix per project.

2. Enter a name for the framework matrix on the General tab (see Framework Matrix
Properties on page 83).
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3. Click the Columns tab, and create an appropriate number of framework matrix columns,
entering a name for each.

4. Click the Rows tab, and create an appropriate number of framework matrix rows, entering
a name for each.

5. [optional] Click the Additional Areas tab, and create an appropriate number of additional
areas, which will be displayed outside the main matrix grid, entering a name for each.

6. Click OK to close the property sheet and create your framework matrix.

7. Create actions for each cell to specify the types of documents that your modelers can attach
to the cell (see Specifying Framework Node and Cell Actions on page 65).

8. [optional] Select File > Save As Template to open the New Template Wizard, and convert
the project containing your framework matrix into a template to allow it to be reused as the
basis for future projects (see Project and Framework Templates on page 78).

Specifying Framework Node and Cell Actions
Actions control the types of documents that can be attached to nodes and cells when
completing framework diagrams and matrices. You can specify one or more action types per
node and cell.

1. Double-click a node or a cell to open its property sheet.

2. On the General tab, enter a node or a cell name, and any other appropriate properties (see
Framework Node, Cell and Additional Area Properties on page 84).

3. Click the Actions tab, and click the Add a Row tool to create a new action.

4. Double-click the action to open its property sheet and, on the General tab, enter an action
name, and any other appropriate properties (see Framework Action Properties on page
86).

5. Click the Detail tab, and select one of the following types of actions as a means to populate
the node or cell:

• Model – a PowerDesigner model (see Example: Specifying a Model Action on page
66).

• Diagram – a PowerDesigner model diagram (see Example: Specifying a Diagram
Action on page 67).

• List – a list of PowerDesigner model objects (see Example: Specifying a List Action
on page 68).

• Model Generation –a PowerDesigner model generated from another model (see 
Example: Specifying a Model Generation Action on page 70).

• Object Generation –a PowerDesigner model populated with one type of objects
generated from another model (see Example: Specifying an Object Generation Action
on page 71).

• File – an external file (see Example: Specifying a File Action on page 72).
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• Matrix – a PowerDesigner dependency matrix showing links between model objects
(see Example: Specifying a Matrix Action on page 74).

• Script - a VB script that can define any scriptable action (see Example: Specifying a
Script Action on page 75).

6. Specify any other appropriate properties to refine the action.

7. Click OK to close the action and node or cell property sheets and return to the framework
diagram or matrix.

The action is now available for use by framework users (see Attaching a Document to a
Framework Node or Cell on page 59). Note that only fully-defined actions are available for
selection.

Example: Specifying a Model Action
The Model action lets a framework user (add or) create one or more models of the specified
kind in the node or cell. The model will be displayed in the Browser under the project node and
as a document in the node or cell to which it has been attached.

In the following example, we will specify an action in a framework diagram node that enables
the user to create one or more Java OOMs with the EJB 3.0 xem attached.

1. Double-click a framework node to open its property sheet, and click the Actions tab.

2. Click the Add a Row tool to create a new action, and double-click it to open its property
sheet.

3. On the General tab, enter "Detailed object model" in the Name field.

4. Select the Multiple check box to specify that more than one OOM can be attached to the
node.

5. Click the Detail tab, and specify the following properties:

Property Select or enter

Type Model

Default document name Java Model

Model type Object-Oriented Model

Document template Leave blank

Model language Java

Diagram type Class Diagram
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Property Select or enter

Extension EJB3.0

6. Click OK to close the action and node property sheets and return to the framework
diagram.

The Model action is now available for use by framework diagram users (see Attaching a
Document to a Framework Node or Cell on page 59).

Example: Specifying a Diagram Action
The Diagram action lets a framework user (add or) create one or more diagrams of the
specified kind in the node or cell. The diagram will be displayed in the Browser under an
existing or new model node and as a diagram in the node or cell to which it has been attached.

In the following example, we will specify an action in a framework matrix cell that enables the
user to create exactly one BPM process hierarchy diagram from a previously defined template.

1. Double-click a framework cell to open its property sheet, and click the Actions tab.

2. Click the Add a Row tool to create a new action, and double-click it to open its property
sheet.

3. On the General tab, enter "Process high level view" in the Name field.

4. Clear the Multiple check box to specify that exactly one BPM process hierarchy diagram
can be attached to the cell.

5. Click the Detail tab, and specify the following properties:
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Property Select or enter

Type Diagram

Default document name PHD

Default model name Processes

Model type Business Process Model

Document template Click the Ellipsis button to select the Orders.bpm template.

For information about creating model templates see Model Tem-
plates on page 11.

Diagram type Business Process Diagram

6. Click OK to close the action and cell property sheets and return to the framework matrix.

The Diagram action is now available for use by framework matrix users (see Attaching a
Document to a Framework Node or Cell on page 59).

Example: Specifying a List Action
The List action lets a framework user (add or) create one or more model object lists of the
specified kind in the node or cell. The list will be displayed in the Browser under the
appropriate model node and as a document in the node or cell to which it has been attached.

In the following example, we will specify an action in a framework diagram node that requires
the user to create at least one list of PDM clusters.
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1. Double-click a framework node to open its property sheet, and click the Actions tab.

2. Click the Add a Row tool to create a new action, and double-click it to open its property
sheet.

3. On the General tab, enter "List of PDM clusters" in the Name Field.

4. Select the Mandatory check box to specify that at least one list of PDM clusters must be
attached to the node.

5. Click the Detail tab, and specify the following properties:

Property Select or enter

Type List

Default document name List of clusters

Default model name Clusters

Model type Physical Data Model

Document template Leave blank

Model language ORACLE Version 11g

Extension <none>

List object type PDM::Cluster (click the Select Object tool, navigate to Oracle
Version 11g, and select the Cluster node)

6. Click OK to close the action and node property sheets and return to the framework
diagram.
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The List action is now available for use by framework diagram users (see Attaching a
Document to a Framework Node or Cell on page 59).

Example: Specifying a Model Generation Action
The Model Generation action lets a framework user generate one or more models from another
model. The generated model will be displayed in the Browser under the project node and as a
document in the node or cell to which it has been attached.

In the following example, we will specify an action in a framework matrix cell that enables the
user to generate exactly one Sybase AS Enterprise 15.0.2 PDM from a Logical Data Model.

1. Double-click a framework cell to open its property sheet, and click the Actions tab.

2. Click the Add a Row tool to create a new action, and double-click it to open its property
sheet.

3. On the General tab, enter Generate from Logical Model in the Name field.

4. Clear the Multiple check box to specify that exactly one generated PDM can be attached to
the cell.

5. Click the Detail tab, and specify the following properties:

Property Select or enter

Type Model Generation

Model type Physical Data Model

Model language Sybase AS Enterprise 15.5

Source model type Logical Data Model

Source location Logical data model
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6. Click OK to close the action and cell property sheets and return to the framework matrix.

The Model Generation action is now available for use by framework matrix users (see 
Attaching a Document to a Framework Node or Cell on page 59).

Example: Specifying an Object Generation Action
The Object Generation action lets a framework user generate objects from one model to
another. The generated model will be displayed in the Browser under the project node and as a
document in the node or cell to which it has been attached.

In the following example, we will specify an action in a framework matrix cell that enables the
user to generate exactly one Java OOM containing classes from a list of entities.

1. Double-click a framework cell to open its property sheet, and click the Actions tab.

2. Click the Add a Row tool to create a new action, and double-click it to open its property
sheet.

3. On the General tab, enter Classes from Entities in the Name field.

4. Clear the Multiple check box to specify that exactly one generated OOM can be attached
to the cell.

5. Click the Detail tab, and specify the following properties in the fields:

Property Select or enter

Type Object Generation
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Property Select or enter

Object type Click the Select Object tool, navigate to PdOOM > Class in the
dialog, and click OK to select it.

Model language C# 2.0

Source object type Click the Select Object tool, navigate to PdCDM > Entity in the
dialog, and click OK to select it.

Source location List of Business Objects

6. Click OK to close the action and cell property sheets and return to the framework matrix.

The Object Generation action is now available for use by framework matrix users (see 
Attaching a Document to a Framework Node or Cell on page 59).

Example: Specifying a File Action
The File action lets a framework user (add or) create one or more files of the specified kind in
the node or cell. The file will be displayed in the Browser under the project node and as a
document in the node or cell to which it has been attached.

In the following example, we will specify an action in a framework diagram node that requires
the user to create at least one MS Word file from a predefined template.

1. Double-click a framework node to open its property sheet, and click the Actions tab.
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2. Click the Add a Row tool to create a new action, and double-click it to open its property
sheet.

3. On the General tab, enter "MS Word File" in the Name field.

4. Select the Mandatory check box to specify that at least one MS Word file must be attached
to the node.

5. Click the Detail tab, and specify the following properties in the fields:

Property Select or enter

Type File

Document template Click the Ellipsis button to select the Functional specifications.doc
template.

File type .doc

6. Click OK  to close the action and node property sheets and return to the framework
diagram.

The File action is now available for use by framework diagram users (see Attaching a
Document to a Framework Node or Cell on page 59).
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Example: Specifying a Matrix Action
The Matrix action lets a framework user (add or) create one or more dependency matrices of
the specified kind in the node or cell. The dependency matrix will be displayed in the Browser
under the project node and as a document in the node or cell to which it has been attached.

In the following example, we will specify an action in a framework matrix cell that enables the
user to create exactly one dependency matrix between PDM tables and users connected by the
Owner dependency.

1. Double-click a framework cell to open its property sheet, and click the Actions tab.

2. Click the Add a Row tool to create a new action, and double-click it to open its property
sheet.

3. On the General tab, enter Table-User Matrix in the Name field.

4. Clear the Multiple check box to specify that only one dependency matrix can be attached
to the cell.

5. Click the Detail tab, and specify the following properties:

Property Select or enter

Type Matrix

Default model name Table-User Matrix

Model type Physical Data Model

Document template Leave blank

Model Language Sybase AS Enterprise 15.5

Extension <none>

Dependency matrix Click the Create tool to open the dependency matrix property sheet
and specify the following values:
• Matrix rows object type – Table
• Matrix columns object type – User
• Matrix cells dependency – Owner

6. Click OK to close the dependency matrix property sheet, and return to the action property
sheet.
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7. Click OK to close the action and cell property sheets and return to the framework matrix.

The Matrix action is now available for use by framework matrix users (see Attaching a
Document to a Framework Node or Cell on page 59).

Example: Specifying a Script Action
The Script action lets a framework user execute a script in the node or cell. You can use the
script to create a project document and attach it to the node or cell.

In the following example, we will specify an action in a framework diagram node that enables
the user to execute a script that generates a model from another model. The result of this
example is the same as that of a Generation action, but the script is intended to demonstrate the
possibilities that you can script in your own projects. You could, for example, write a script to
connect to a live database and reverse engineer it into a cell. For information about writing
scripts for use in your models and projects, see Customizing and Extending PowerDesigner >
Extension Files > Methods (Profile).

Before you can specify a script action, you have to create a method script on the
FrameworkAction metaclass in an extension, and then attach it to your project. In this case, the
following script is called GenerateModel, and will generate a PDM:

Sub %Method%(obj)

   ' This is a sample method that can be used in a script action
   ' It generates a PDM from a source cell CDM and attaches it to the 
current cell
   ' Steps:
   ' 1- Get the source cell: found by its code "mySourceCell"
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   ' 2- Get the source model: first document in the source cell
   ' 3- Generate a PDM from the source model
   ' 4- Attach the generated model to the current cell
   ' 5- Set current action as source action for the new document
   ' => That will prevent generating twice if the action is not 
multiple
   
   If obj Is Nothing Then Exit Sub

   Dim sourceCell, targetCell, modelDoc, sourceModel, targetModel

   ' The script is defined on the action so the current cell is simply 
the action parent
   Set targetCell = obj.Parent

   ' First check if we can execute the action on the current cell
   ' for non multiple actions, the CanExecute should return true only 
the first time
   If obj.CanExecute(targetCell) Then
      ' Get Source cell
      Set sourceCell = FindCellByCode(targetCell.Parent, 
"mySourceCell") ' See function code below End Sub statement

      ' Get source model (supposed to be the first in its artifact 
document list)
      Set modelDoc = sourceCell.ArtifactDocuments.Item(0)
      Set sourceModel = modelDoc.TargetModelObject

      ' Generate PDM Model
      Set targetModel = sourceModel.GenerateModel (Nothing, 
PdPDM.cls_Model)

      ' Attach generated model to current cell
      Set modelDoc = targetModel.SourceModelDocument
      targetCell.AttachDocument(modelDoc)

      ' Set current action as source for the new model document
      obj.SetAsSource(modelDoc)
   Else
      ' In this sample, the action is supposed to be non-multiple
      ' Therefore, CanExecute fails if it's already a source action 
for an existing document
      output "The action has already been executed"
   End If
End Sub

' FindCellByCode function (Global Script function):

Function FindCellByCode (fmx, Code)
   Set FindCellByCode = Nothing
   Dim Cell
   For Each Cell In fmx.cells
      If Cell.Code = Code Then
         Set FindCellByCode = Cell
         Exit For
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      End If
   Next 
End Function

>>

1. Double-click a framework node to open its property sheet, and click the click the Actions
tab.

2. On the General tab, enter Generate Model Script in the Name field.

3. Clear the Multiple check box to specify that exactly one generated model can be attached
to the node.

4. Click the Detail tab, and specify the following properties in the fields:

Property Select

Type Script

Method GenerateModel

5. Click OK to close the action and node property sheets and return to the framework
diagram.
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The Script action is now available for use by framework diagram users (see Attaching a
Document to a Framework Node or Cell on page 59).

Styling Framework Nodes and Cells
Framework architects have access to additional commands that allow them to change the
format of framework nodes and cells.

Command Description

Format Opens the Symbol Format dialog box to let you specify line and fill colours,
fonts and formatting for each textual element, and an image for the node or cell
(see Symbol Format Properties on page 193).

Change Image Opens the Select Image dialog box to let you insert an image in the node or cell
(see Browsing for Images on page 200).

Get Format Copies the format of the selected node or cell for pasting in other nodes or
cells.

Apply Format Pastes a previously copied node or cell format into the selected node or cell.

Properties Opens the property sheet of the selected node or cell.

For information about the standard commands available outside design mode, see Working
with the Framework Node and Cell Contextual Menu on page 63.

Project and Framework Templates
A project template can provide predefined content, rules, and formatting for your project, and
can also include a framework matrix or framework diagram.

For example, you could create:

• A data project template - containing a CDM, LDM, and PDM targeting your preferred
DBMS

• An application project template - containing an OOM with the UML diagrams required for
your modeling practices, along with a PDM and XSM to handle data persistance and
format

• A framework project template - containing a FEAF or other framework matrix

1. Create a project (see Creating a Project on page 48).

2. [optional] Add any appropriate models or files (see Adding Model and File Documents to
a Project on page 49).

3. [optional] Create one or more framework diagrams (see Creating a Framework Diagram
on page 63).
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4. [optional] Create a framework matrix (see Creating a Framework Matrix on page 64).

5. [optional] Specify any appropriate display preferences (see Project and Framework
Display Preferences on page 53).

6. Select File > Save As Template

7. [optional] Specify a template directory in which to save the template. By default, the
project template directory is selected. You can click the Change Template Directory tool
to select another location.

8. Select a template category from the list or enter a template category name that will be
available for when you create other projects. You can use the \ character to create sub-
directories, or right-click the project in the Browser, and select Save As Template  to open
the Template Wizard.

9. Click Next, and enter a description for the new template that will be displayed in the New
Project Wizard when you create projects with the new template. You can modify a
template description by right-clicking a project template in the Browser, and selecting
Edit Template.
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10. Click Finish to close the wizard and create the template.

The project (.prj) and the models and files it contains are copied to the template directory.

Note: If any documents are outside the project and only attached to it they will not be
copied to the template directory and thus may not be available to a user when she creates a
project from the template.

11. [optional] Select New > Project to open the New Project dialog box. The template you
have created is available for selection in the Project type tree.
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Project and Framework Properties
Projects, model and file documents, and framework diagrams and matrices have a variety of
properties that you can configure to control their behavior.

Project Properties
To view or edit a project's properties, double-click its Browser or list entry. The property sheet
tabs and fields listed here are those available by default, before any customization of the
interface by you or an administrator.

The General tab contains the following properties:

Property Description

Name/Code/Com-
ment

Identify the object. The name should clearly convey the object's purpose to
non-technical users, while the code, which is used for generating code or
scripts, may be abbreviated, and should not normally include spaces. You can
optionally add a comment to provide more detailed information about the
object. By default the code is generated from the name by applying the naming
conventions specified in the model options. To decouple name-code synchro-
nization, click to release the = button to the right of the Code field.
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Property Description

File name Specifies the location of the project file. This field is empty if the project has
never been saved.

Author Specifies the author of the project. If you enter nothing, the Author field in
diagram title boxes displays the user name from the project property sheet
Version Info tab. If you enter a space, the Author field displays nothing.

Version Specifies the version of the project. You can use this box to display the re-
pository version or a user defined version of the project. This parameter is
defined in the Title page of the project display preferences.

Default diagram Specifies the diagram displayed by default when opening the project.

Keywords Provide a way of loosely grouping objects through tagging. To enter multiple
keywords, separate them with commas.

Model and File Document Properties
To view or edit a document's properties, double-click its diagram symbol or Browser or list
entry. The property sheet tabs and fields listed here are those available by default, before any
customization of the interface by you or an administrator.

The General tab contains the following properties:

Property Description

Name/Code/Com-
ment

Identify the object. The name and code are read-only for model documents.
You can optionally add a comment to provide more detailed information about
the object.

Stereotype Extends the semantics of the object. You can enter a stereotype directly in this
field, or add stereotypes to the list by specifying them in an extension file.

Location Specifies the path or URL to the document. Read-only for model documents.

[read-only] The property sheet provides read-only information on the extension, size, and
creation and modification dates of the document, as well as noting whether it
is inside the project or simply referenced by it.

Keywords Provide a way of loosely grouping objects through tagging. To enter multiple
keywords, separate them with commas.

Dependency Link Properties
To view or edit a dependency link's properties, double-click its diagram symbol or Browser or
list entry. The property sheet tabs and fields listed here are those available by default, before
any customization of the interface by you or an administrator.

The General tab contains the following properties:
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Property Description

Type [read-only] Specifies the type of the dependency link, which can include
generation links, reference links, mapping links, and file links.

Influent object [read-only] Specifies the source object of the dependency link. Click the
Properties tool beside the list to open its property sheet.

Dependent object [read-only] Specifies the target object of the dependency link. Click the
Properties tool beside the list to open its property sheet.

Keywords Provide a way of loosely grouping objects through tagging. To enter
multiple keywords, separate them with commas.

Framework Matrix Properties
Framework architects can modify a framework matrix properties from its property sheet by
enabling the Framework Design Mode, and double-clicking the framework matrix top-left
corner.

For more information on enabling the Framework Design Mode, see Designing Framework
Diagrams and Matrices on page 63.

The General tab contains the following properties:

Property Description

Name/Code/
Comment

Identify the object. The name should clearly convey the object's purpose to non-
technical users, while the code, which is used for generating code or scripts, may
be abbreviated, and should not normally include spaces. You can optionally add a
comment to provide more detailed information about the object. By default the
code is generated from the name by applying the naming conventions specified in
the model options. To decouple name-code synchronization, click to release the
= button to the right of the Code field.

Stereotype Extends the semantics of the object. You can enter a stereotype directly in this
field, or add stereotypes to the list by specifying them in an extension file.

Keywords Provide a way of loosely grouping objects through tagging. To enter multiple
keywords, separate them with commas.

In addition to the General tab, the framework matrix property sheet contains the following
tabs:

• Rows tab – displays a sortable list of rows, in which you can create, edit or delete rows. See
Framework Column and Row Properties on page 84.

• Columns tab – displays a sortable list of columns, in which you can create, edit or delete
columns. See Framework Column and Row Properties on page 84.

• Cells tab – displays a list of cells, which is computed from the intersection of columns and
rows or from the creation of additional areas. You can edit cells but you cannot delete them
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unless you delete the columns or rows to which they belong. See Framework Node, Cell
and Additional Area Properties on page 84.

• Additional Areas tab – displays the four additional areas available to the framework
matrix. You can create, edit or delete additional areas. See Framework Node, Cell and
Additional Area Properties on page 84.

Framework Column and Row Properties
[Framework architects] To view or edit a column or row's properties, enable the Framework
Design Mode, and double-click a column or row header in the framework matrix.

For more information about enabling the Framework Design Mode, see Designing
Framework Diagrams and Matrices on page 63).

The General tab contains the following properties:

Property Description

Name/Code/Com-
ment

Identify the object. The name should clearly convey the object's purpose to
non-technical users, while the code, which is used for generating code or
scripts, may be abbreviated, and should not normally include spaces. You can
optionally add a comment to provide more detailed information about the
object. By default the code is generated from the name by applying the naming
conventions specified in the model options. To decouple name-code synchro-
nization, click to release the = button to the right of the Code field.

Stereotype Extends the semantics of the object. You can enter a stereotype directly in this
field, or add stereotypes to the list by specifying them in an extension file.

Help file Specifies a location for the help file associated with the row or column.

Default folder Specifies a default folder for the creation of the cell's documents. If no default
folder is specified in the cell's property sheet, the row's default folder is used
first, then the column's default folder.

Keywords Provide a way of loosely grouping objects through tagging. To enter multiple
keywords, separate them with commas.

Framework Node, Cell and Additional Area Properties
[Framework architects] To view or edit a node, cell or additional area's properties, enable the
Framework Design Mode, and double-click a node in the framework diagram or a cell or an
additional area in the framework matrix.

For more information about enabling the Framework Design Mode, see Designing
Framework Diagrams and Matrices on page 63.

The General tab contains the following properties:
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Property Description

Name/Code/Comment Identify the object. The name should clearly convey the object's purpose
to non-technical users, while the code, which is used for generating code
or scripts, may be abbreviated, and should not normally include spaces.
You can optionally add a comment to provide more detailed information
about the object. By default the code is generated from the name by
applying the naming conventions specified in the model options. To de-
couple name-code synchronization, click to release the = button to the
right of the Code field.

Stereotype Extends the semantics of the object. You can enter a stereotype directly in
this field, or add stereotypes to the list by specifying them in an extension
file.

Help file Specifies a location for the help file associated with the node and cell.

Default folder Specifies a default folder for the creation of the node's and cell's docu-
ments.

Cell location [framework matrix only - read-only]

[cell] Specifies the name of the column and row for which the cell is the
intersection. Click the Properties tool beside Row and Column fields to
open their property sheet.

[additional area] Specifies the location of the additional area: Left, Top,
Right, or Bottom area.

Completion status Controls the percentage of work completed in the node and cell. Enter a
value between 1 and 100 in the box. This value is also displayed in the
node's and cell's floating list and a rectangle on the node and cell shows
the work progression if you have selected the Completion status display
preference.

Inactive [cell only] Specifies a cell which is not available.

Constrain content Specifies a node and cell, whose content can only be completed by its
defined actions.

Composite [node only] Specifies whether the node is decomposed into sub-nodes
displayed in sub-diagrams. When selected a Sub-Nodes tab is displayed
in the property sheet to list these sub-nodes. If you deselect this property,
then any sub-nodes that you have created will be deleted.

Keywords Provide a way of loosely grouping objects through tagging. To enter
multiple keywords, separate them with commas.

In addition to the General tab, the framework node and cell property sheet contains the
following tabs:

• Actions tab – displays a list of actions, in which you can create, edit or delete actions (see
Framework Action Properties on page 86).
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• Documents tab – displays a list of documents, in which you can create or add existing
documents, and also edit or delete documents (see Attaching a Document to a Framework
Node or Cell on page 59).

Framework Action Properties
[Framework architects] To view or edit an action's properties, enable the Framework Design
Mode, and double-click an action on the Actions tab of a node or cell property sheet.

Note: For information about enabling the Framework Design Mode, see Designing
Framework Diagrams and Matrices on page 63.

The General tab contains the following properties:

Property Description

Parent [read-only] Specifies the name of the parent node and cell to which the
action belongs.

Name/Code/Comment Identify the object. The name should clearly convey the object's purpose
to non-technical users, while the code, which is used for generating code
or scripts, may be abbreviated, and should not normally include spaces.
You can optionally add a comment to provide more detailed information
about the object. By default the code is generated from the name by
applying the naming conventions specified in the model options. To de-
couple name-code synchronization, click to release the = button to the
right of the Code field.

Stereotype Extends the semantics of the object. You can enter a stereotype directly in
this field, or add stereotypes to the list by specifying them in an extension
file.

Multiple When selected, specifies that one or more documents of the selected type
can be created.

Mandatory When selected, specifies that at least one document of the selected type
must be created.

Keywords Provide a way of loosely grouping objects through tagging. To enter
multiple keywords, separate them with commas.

Detail Tab
The Detail tab specifies the nature of the action.

Property Description

Type Specifies the nature of the document to attach to the framework nodes and
cells (see Specifying Framework Node and Cell Actions on page 65).
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Property Description

Default document name [Model, Diagram, and File only] Specifies the model, diagram or file name
created by default in the Browser.

Model type [not for File and Dependency Matrix] Specifies a model type to create, for
example Enterprise Architecture Model.

Document template [not for Generation and Dependency Matrix] Specifies the model or file
template on which the model or file to create is based, for example a PDM,
an LDM, or a .doc, a .xls etc. Click the Ellipsis button to browse for a file on
your system.

Model language [not for File and Dependency Matrix] Specifies a target language associ-
ated with the model to create, for example Analysis for a BPM or Java for
an OOM. Select a model language in the list. If you do not specify a
language, your system default model language is used.

Diagram type [Model and Diagram only] Specifies a diagram type for the model, for
example Class Diagram for an OOM, or Business Process Diagram for a
BPM.

Extension [not for File and Dependency Matrix] Specifies an extension file attached
to the model, for example SIMUL8 for a BPM.

Object type [List only] Specifies the model object type in the list, for example entity,
process, table, class etc.

Object stereotype [List only] Specifies a stereotype to filter the metaclass, for example a
<<cluster>> stereotype on an extended object in a PDM targeted for the
Oracle Version 9i DBMS.

Dependency matrix [Dependency Matrix only] Specifies a dependency matrix definition be-
tween model objects. Click the Create tool to create a new dependency
matrix.

File type [File only] Specifies the extension of the file to create, for exam-
ple, .doc, .xsl, .txt, etc.

Source model type [Generation only] Specifies the model type from which to generate the
model, for example Business Process Model, Conceptual Data Model etc.

Source cell [Generation only] Specifies the node and cell containing the model type
from which to generate the new model.
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Framework Link Properties
[Framework architects] To view or edit a framework link's properties, double-click its diagram
symbol or Browser or list entry. The property sheet tabs and fields listed here are those
available by default, before any customization of the interface by you or an administrator.

For more information about enabling the Framework Design Mode, see Designing
Framework Diagrams and Matrices on page 63.

The General tab contains the following properties:

Property Description

Name/Code/Comment Identify the object. The name should clearly convey the object's pur-
pose to non-technical users, while the code, which is used for gener-
ating code or scripts, may be abbreviated, and should not normally
include spaces. You can optionally add a comment to provide more
detailed information about the object. By default the code is generated
from the name by applying the naming conventions specified in the
model options. To decouple name-code synchronization, click to re-
lease the = button to the right of the Code field.

Stereotype Extends the semantics of the object. You can enter a stereotype directly
in this field, or add stereotypes to the list by specifying them in an
extension file.

First object Specifies the node that the link leads from. You can click the Properties
tool to the right of the list to view the properties of the selected object.

Second object Specifies the node that the link leads to. You can click the Properties
tool to the right of the list to view the properties of the selected object.

Keywords Provide a way of loosely grouping objects through tagging. To enter
multiple keywords, separate them with commas.
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CHAPTER 4 Objects

Modeling objects, such as tables and entities, are the building blocks of your models. All the
objects in a model are listed as items in the Browser and they may also appear as symbols in
your diagrams.

Each type of model diagram (see Diagrams on page 169) supports certain specific types of
objects, and each object created in a diagram is represented by a symbol (see Symbols on page
185). A single object can have multiple symbols associated with it to allow it to appear in
multiple diagrams or multiple times in the same diagram (see Creating Graphical Synonyms
for Object Symbols on page 199).

Note: For detailed information about a specific type of model or object, see the appropriate
modeling guide. The following sections describe generic features available for all objects.

Creating Objects from the Toolbox
The toolbox is a toolbar that lets you quickly create objects in diagrams. To create an object,
click the appropriate tool and then click in the diagram. When you release the mouse button,
the object is created, and you can click again elsewhere to create a second object and so on.

To release the tool, simply select another tool or right-click in free space. To revert to a
previously selected tool, hold down Ctrl and perform a double right-click.

To create a link, click the appropriate link tool, click in the object from which you want the link
to begin and hold the mouse button as you drag the pointer to the object in which you want the
link to end. When you release the mouse button, the link is created.

The toolbox contains four categories that can be collapsed or expanded by clicking on the up
and down arrows:
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• Standard - containing the basic tools available in all diagrams:

Icon Action

Pointer [default] – Selects, moves, and resizes individual symbols. Double-click to
select all the objects in the diagram. To switch back to the Pointer from another tool,
right-click anywhere in the diagram.

Grabber – allows you to select, move and resize the entire diagram. Double-click to
display the entire diagram, centered.

Zoom in

Zoom out

Open the diagram of a composite object or packages

Delete a symbol and, optionally, its associated object.

Open the property sheet of an object

Create a package

• Type Diagram - containing tools specific to the current diagram. For details, see the
appropriate modeling guide diagram chapter.

• Free Symbols - containing tools for drawing free shapes and links to decorate your
diagrams (see Decorative Symbols on page 203).

• Predefined Symbols - containing tools for drawing standard flowchart shapes.

Note: To rename an object from its symbol, select it and then press F2. If the symbol carries
additional editable properties (but not lists of sub-objects), you can navigate to the next with
Tab (or the previous with Shift+Tab). Select the Edit in place after creation general option
to have the name of each object that you create immediately selected for editing (see General
Options on page 255).

Creating Objects from the Browser
You can create any object, including objects that do not have symbols, from the Browser. If the
Browser is not visible, select View > Browser (or press Alt+0) to display it.

1. Right-click the model, package, object, or category where you want to create the object,
and select New >  object type .

2. Type an object name and code in the General tab of the property sheet, and then add any
other relevant properties (see Object Properties on page 98).

3. Click OK to confirm the creation of the object.
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The object is created in the appropriate category in the Browser. If the object has a symbol,
it will also be added (where possible) to the current diagram.

Creating Objects from an Object List
You can create most types of objects in object lists, available under the Model menu. Some
property sheet tabs, such as a table's Columns tab or a class's Attributes or Operations tabs
also contain object lists. Lists provide a method to quickly create multiple objects and change
their properties simultaneously.

1. Select Model >  object type  (or open an appropriate property sheet tab).

2. Click the Add a Row tool or, if the list is ordered, the Insert a row tool.

A new item is added at the end, or before the selected row, of the list.

3. Enter an object name and code and, for link objects, a source and destination object.

4. Repeat as necessary to create additional objects of the same type, and then click OK.

For detailed information about object lists, see Object Lists on page 108.

Importing Objects from Excel Files
The Excel Import extension provides a wizard to guide you through mapping tables of objects
in an Excel file (v2003 and higher) to PowerDesigner objects and properties, to import them to
your model. For example, you could create a list of database tables in an Excel file, specifying
any appropriate properties, and then import them into a PDM.

You can import any number of different types of objects from a single Excel file, so long as
they can all be imported to a single type of model. Each type of object should be listed in its
own table on a separate worksheet of the Excel file. Each row in a table represents one object to
import, and each column represents one property (an attribute or list of associated objects) of
the object.

In the following example, the Excel file contains worksheets listing tables, keys, references,
and reference joins. The Table sheet, contains a list of three table to import. The columns
Name, Owner, and Columns will be imported as the corresponding table properties:

For detailed information about how to organise the file, see Preparing Your Excel File for
Import on page 94. An example Excel file for importing into a PDM is provided at
install_dir\Examples\excel_import.xls.
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1. [optional] Create extensions to allow you to easily import objects or properties not defined
in the standard PowerDesigner metamodel (see Extension Files on page 275).

If you do not predefine extensions, the wizard will allow you to specify them during the
definition of the mappings prior to beginning the import, but predefined extensions can be
more sophisticated and allow the import to proceed more quickly.

2. Open the Excel Import Wizard:

• To a create a new model, select File > Import > Excel File. Specify the kind of model
you want to create in the New Model dialog (see Creating a Model on page 9), and then
click OK.

• To import objects into an existing model, attach the Excel Import extension (available
for all model types on the Import subtab of the Select Extensions dialog) to your
model (see Attaching Extensions to a Model on page 277), then right-click the model
in the Browser, and select Import Excel File.

3. Click the Select File tool, browse to and select the Excel file to import, and click Open to
return to the wizard.

4. [optional] Click the Options button to open the Import Options dialog (see Excel Import
Options on page 96), specify any appropriate options and then click Close to return to the
wizard.

5. Click Next to go to the Import Table page:

On this page, you must either:
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• Select a PowerDesigner object type to import the table lines As from the list.
• Select to import the table lines as a new object type by clicking the New tool to the right

of the list to open the New Object Type dialog.
• Deselect the check box to not import this table. When you click Next, PowerDesigner

will search the Excel file for another table of objects to import.

6. Click Next to go to the Import Column page:

On this page, you must either:
• Select a PowerDesigner attribute to import the table column as from the Attribute list.

To create a new attribute, click the New tool to the right of the list.
• Select the List of associated objects radio button to import the column as a list,

selecting the List to use and (if the list can contain multiple types of objects), the
appropriate Object. To create a new list, click the New tool to the right of the list.

• Deselect the check box to not import this table column.

7. Click Next. The wizard will search for the next column in the table and if there is none (or if
you have selected to skip importing the table), will search for the next sheet containing a
table of objects.

When all the worksheets and columns have been processed, the import will begin. You can
stop the import at any time by clicking the Cancel button in the bottom-right corner. When
the import is complete, a dialog will appear showing how many objects have been created.

8. Click OK to return to your model and review the imported objects.

If you have instructed PowerDesigner to create new object types or new properties, a new
embedded extension called Import Extensions is created under the Extensions
category in the Browser to hold the definitions of these extensions.

In addition to the objects that you have created, PowerDesigner creates an Excel Import object
that contains your import parameters, along with a Table Mapping object for each of the
imported tables, which lists the column mappings used. Right-click the Excel Import Object to
access the following commands:
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• Import - to re-import your file based on the options and mappings you have already
defined. All the objects will be reimported, overwriting any existing objects based on their
names. If you have added new objects to your worksheet tables they will be added to the
model, but any objects that you have deleted from your worksheet will not be deleted from
the model.

• Change Mappings - to re-import your file via the Excel Import Wizard in order to modify
your table or column mappings.

• Change Options - to change the import options preparatory to re-importing with the
command Import

• Properties - to open the Excel Import properties sheet.

Note: Advanced users may want to modify the Excel Import XEM to enable the import of data
from other external file types. For detailed documentation about its implementation, open the
XEM (which is located at  install_dir\Resource Files\Extended Model
Definitions\ExcelImport.xem in the Resource Editor and read the detailed
commentary on the root element.

Preparing Your Excel File for Import
By following certain simple rules, you can greatly help PowerDesigner to recognize the
information in your Excel files, and thus improve the accuracy and speed of the import.

Follow these rules to ensure that your import goes as smoothly and quickly as possible:

• Determine your extensions strategy – The wizard can create simple extensions (new
object types or new properties not included in the PowerDesigner metamodel) for you
during the import. However, to define more complex extensions or to speed up the import
process, you may prefer to predefine your extensions beforehand (see Extension Files on
page 275) and have the import automatically map them.

• Insert only one table of objects per worksheet – If you have more than one table on a
worksheet, only the first will be recognized and imported.

• Name your worksheet after the object to import – If the name of your worksheet
matches the name of a PowerDesigner object type, then the wizard will suggest mapping
the table to that object type. The wizard does not recognize plural forms so, if your sheet
contains tables, you should call it Table, and if it contains classes, call it Class.

For sub-objects (objects linked to their parent by composition), you must prefix the name
of the object with that of its parent object, (eg Table.Key) or it will not be recognized.

• Name table columns after the property they contain –  If you name each of your
columns after the attribute or collection that it contains, then the wizard will suggest
mapping the column to that attribute or collection. As a general rule, attributes are singular
and collections plural so that, for example, you should name the column that contains your
tables' names Name and the column containing its columns, Columns.
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• Determine how you will reference other objects – Properties can contain references to
other objects. For example, a table Owner property contains a reference to a user object
and a business process references the organization unit that performs it. The import tries to
resolve references first by searching for an appropriate object in the Excel file, and then in
any of the models open in the Workspace (creating a shortcut to the referenced object).
Follow these suggestions to optimize your references:

• Control whether references will be made via object names or codes using the
Reference associated objects by option.

• To maximize the clarity of dependencies between objects, place objects that are to be
referenced on a worksheet before the objects that will reference them.

• Ensure that the necessary target models are open in the Workspace to create shortcuts,
if appropriate, and select the Search for referenced objects in other models option.

• Use the Create associated objects if not found option to instruct PowerDesigner to
create the necessary objects if it cannot resolved references either in the Excel file or in
models open in the Workspace.

• Quickly create collections by listing objects in a single cell – You can create a collection
simply by listing its items in a single cell, separated by commas:

To change the separator, use the List value separator option.
• Represent relationships of composition using a Parent column – To specify

composition relationships (such as columns in a table, classes in a package, or attributes in
a class) between objects on different worksheets, specify the parent or location for the
sub-object in a Parent column. You can specify a multi-level hierarchy of parents
separated by a qualified name separator.

Note: Whereas specifying a collection of sub-objects in a single cell on the parent
worksheet allows you to quickly populate the collection, specifying sub-objects on a
separate worksheet allows you to detail all their properties.
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Excel Import Options
The Excel Import Wizard provides a number of options to allow some flexibility in the format
of the data it can import.

Option Description

Auto-map columns to
properties

Instructs the wizard to automatically map Excel tables and columns to ob-
jects and properties in the PowerDesigner metamodel. If all your Excel
worksheets and table column headings are named from the PowerDesigner
metamodel (or your predefined extensions), this option can make the import
run without requesting further input (see Preparing Your Excel File for
Import on page 94).

Default: Unselected

Create symbols in ac-
tive diagram

Instructs the wizard to create symbols, where appropriate, for the imported
objects in the currently selected diagram.

Default: Unselected

Create associated ob-
jects if not found

Instructs the wizard to create objects referenced by the imported objects, if
they cannot be found in the Excel file (or in an open model, if the Search for
referenced objects in other models option is selected).

For example, in a list of PDM tables, the Owner, property references a user
object. If you do not supply a list of users on another worksheet or in an open
model (or if your list is incomplete), PowerDesigner will create user objects
for any references that cannot be resolved.

Default: Selected

Search for referenced
objects in other mod-
els

Instructs the wizard to search any models open in the workspace to resolve
references as shortcuts if the referenced object cannot be found in the Excel
file.

Default: Unselected

Reference associated
objects by

Specifies whether the object's name or code (the latter of which does not
usually permit spaces or special characters) is used in columns that reference
the object. In the example above, you could use the user's name or code to
reference it in the Owner column of the list of tables.

Default: Name

Qualified name sepa-
rator

Specifies the character used to separate namespaces in a qualified name,
which is used to specify the location or parent of an object. For example, to
specify that architecture area Area3 is inside Area2, which is in turn
inside Area1, you would enter Area1.Area2 in the Parent column
for Area3.

Default: Dot
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Option Description

List value separator Specifies the character used to separate items in a list in an Excel cell. For
example, you could list all the columns of a table in a cell as follows:
ID,Name,Email,Password.

Default: Comma

String literal for 'True'
value

Specifies the string used to signify 'True' for boolean attributes. False is
signified by an empty cell.

Default: X ('Y', 'Yes', 'True', and '1' also always signify 'True'.

Importing Objects from XML Files
PowerDesigner allows you to import objects from an XML file by defining mappings between
the elements in the XML schema and objects in the PowerDesigner metamodel (and any
extensions). The import mappings are defined in an extension file, can be shared with all users
through the repository library, and are accessed by selecting File > Import > Import Name.

Once an import is defined for a particular XML schema, any XML data files conforming to the
schema can be imported. If you do not have access to the schema, PowerDesigner can infer a
schema from a data file.

Note: The following procedure gives an overview of the process for defining an XML import.
If an administrator has already defined an import and provided the resource file to you, you can
perform an import directly by selecting File > Import > Import Name.

1. Select Tools > Resources > Extensions > Model Type to open the appropriate extension
file list.

Note: As XML imports are mapped to a specific set of objects in the PowerDesigner
metamodel, you must choose the correct type of extension file. For example, if you are
importing business processes, you should create the import definition in a business process
model extension file. If the objects defined in your schema do not relate to any of the
standard PowerDesigner model types, you should choose a free model (see Chapter 6, The
Free Model (FEM) on page 219) extension file. If appropriate you can, alternately, define
the import in a DBMS or language definition file (see Creating and Copying Resource
Files on page 274).

2. Create a new extension file in the list to contain your XML import definition (see Creating
an Extension File on page 276).

3. Create an XML import definition in the extension file (see Customizing and Extending
PowerDesigner > Extension Files > XML Imports (Profile)).

4. Save the extension file and test the import by selecting File > Import > Import Name.
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5. [optional] Check the extension file into the repository library to have it automatically
deployed to all users (see Sharing Resource Files via the Library on page 551).

Object Properties
All model objects created in PowerDesigner have property sheets, which organize object
properties on tabs.

You can open an object property sheet in any of the following ways:

• In the Browser, double-click the object symbol or its entry.
• Right-click the object symbol or its Browser entry, and select Properties.
• Select the object from an object list or in the property sheet of its parent object, and click

the Properties tool.
• Select an object symbol and press Alt+Enter.

Property sheets let you assign extensive and sophisticated properties to objects. Most
PowerDesigner objects have the following tabs and properties, but many others, specific to the
particular object type, may be available:

• General – provides basic information about the object. Almost all objects have these
properties:
• Name - clearly identifies the object. By default, names can have up to 254 characters,

and can include uppercase, lowercase, and mixed-case strings. Names are controlled
by naming conventions (see Naming Conventions on page 143) and must be unique
within a namespace (see Object Namespaces on page 107). If the enterprise glossary is
enabled in the model, then autocompletion and glossary compliance checking is
available (see The Glossary on page 36).

• Code – is used in scripts generated from the model. Codes are controlled by naming
conventions and must be unique within a namespace. By default, codes are
synchronized with names, but you can decouple them by unselecting the equal sign
button to the right of this field. You control this synchronization of codes with names
with the Name to Code mirroring general option (see Dialog Box Options on page
256) and can modify the transformations performed on codes with naming
conventions.

• Comment – provides a more detailed description of the object.
• Stereotype - extends the semantics of the object. You can enter a stereotype directly in

this field, or add stereotypes to the list by specifying them in an extension file.
• Keywords - Provide a way of loosely grouping objects through tagging. Separate

multiple keywords with commas. You can use keywords as criteria for finding objects
(see Finding Objects on page 127), and in impact and lineage analysis (see Chapter 17,
Impact and Lineage Analysis on page 499).

Property sheets of link objects display a picture of the link together with its extremities.
Additional information, such as the cardinality value and the role, may also appear.
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• Notes – lists additional information about the object. See Notes Tab on page 101.
• Rules – lists the business rules with which the object must comply. A business rule may be

a government-imposed law, a customer requirement, or an internal guideline. See 
Business Rules on page 131.

• Version Info - provides details about the object owner, creation, and modification date and
allows you to access help for the PowerDesigner metamodel metaclass on which the object
is based. See Version Info Tab on page 106

• Dependencies - lists all the objects that depend on the object. See Dependencies Tab on
page 106

• Traceability Links - lists all the objects on which the object depends. See Creating
Traceability Links on page 431

• Requirements – lists the project requirements that the object is intended to satisfy. By
default, this tab does not appear. See Requirements Tab on page 105

Note: Use Ctrl+Page Down or Ctrl+Page Up to move to the next or to the previous tab and
display the corresponding object type tab.

By default, property sheets open to the General tab. You can choose to open property sheets at
the last accessed tab by selecting Tools > General Options > Dialog, and selecting Keep Last
Tab in the Property Sheets groupbox.

You can customize, create, and hide properties and property sheet tabs using extension files
(see Customizing and Extending PowerDesigner > Extension Files). Administrators can
prepare customized property sheets through permission profiles (see Chapter 20, Customizing
the PowerDesigner Interface on page 553).

You can control the form of the symbols, the background color, and the text format with
display preferences (see Display Preferences on page 206). For display preferences to be
applied to the mini-diagrams in link object property sheets, click Set As Default in the Display
Preferences dialog for each modification.

Customizing a Property Sheet
Since PowerDesigner can hold a rich variety of information about your model objects,
property sheets can become overloaded.

The More or Less button at the bottom left corner of the property sheet allows you to toggle
between displaying all the available property sheet tabs, and a subset called "favorite" tabs.

You can customize your list of favorite tabs, and access various other property sheet features,
from the property sheet menu, which is accessible from the bottom-left corner of all property
sheets.

Command Description

Find in Diagram Finds the object in the diagram, found object is displayed centered and
selected.
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Command Description

Find in Browser Finds the object in the Browser and highlights it.

Impact Analysis Opens the Impact Analysis dialog box.

Parent Properties Opens the property sheet of the parent object.

New Attribute Opens the New Attribute dialog, which lets you add new properties to your
object property sheets. For more information, see Adding a New Attribute to
an Object on page 154.

New List of Associ-
ated Objects

Opens the New List dialog, which lets you add new lists of associated objects
to your object property sheets. For more information, see Adding a New
Collection to an Object on page 157.

Manage Object Ex-
tensions

Opens the Manage Object Extensions dialog, which lets you access the
metaclass on which the object is based in the Resource Editor. For more
information, see Managing Extensions on page 159.

Find in Metamodel
Objects Help

Opens the MetaModel Objects Help for the metaclass on which the object is
based.

Customize Favorite
Tabs

Opens a sub-menu, which allows you to define favorite tabs:

• Help – opens this help topic
• Display All Tabs - Displays all available property tabs for the current

property sheet
• Display Favorite Tabs for All - Displays favorite tabs for all property

sheets throughout all models
• Display All Tabs for All - Displays all tabs for all property sheets

throughout all models

Beneath the sub-menu are listed all the tabs available for the present object.
Favorite tabs have a check against them.

Click a tab in the list to select or remove it from the list of favorite tabs. Note
that the General tab cannot be unchecked.

When you check or uncheck a tab such as Notes, Rules, and Dependencies,
which are common to many objects, you are asked to confirm the change for
all other objects. If you click No, only the current property sheet is modified.

In the following example, all the tabs except Implementation are checked and are displayed:
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Any changes in the display of tabs are immediately applied to the current property sheet but
not to other property sheets that are currently open. The changes become the default setting for
any property sheet of the same type.

Note: You can choose to display tabs on one or several rows in property sheets by selecting
Tools > General Options > Dialog, and selecting the Tabs on one row option or the Tabs on
one several rows option in the Property sheets groupbox.

Notes Tab
The Notes tab in an object property sheet contains the sub-tabs Descriptions and Annotations,
intended to hold additional information about the object.

• Descriptions - in general, includes important information that does not fit into the General
tab. For example, a description of the Employee entity might read: This entity has one
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occurrence for each employee in our worldwide operations. This base should grow by 20
percent in 2002.

• Annotations - contains notes regarding the implementation of a model or the objects it
contains. For example, an annotation of the Employee entity might read: Verify list of
attributes with Director of Human Resources.

Both are editable directly in the tab with the internal PowerDesigner RTF editor. For
information about the tools available, see Text Editor Tools on page 204.

You can insert the content of an existing text or RTF file in the RTF editor to use it as a standard
for your descriptions or annotations. This can be very helpful to standardize objects notes as
you can have a description or annotation RTF file for each object type, and open it when
needed.

1. Open the object's property sheet, click the Notes tab, and select either the Description or
Annotation sub-tab.

2. Click the Editor Menu tool and select Insert, browse to the file you want to insert and
click Open.

The content of the file is displayed in the field.

Note: To see which objects have notes, open the appropriate object list and review the [N]otes
checkbox. For information about customizing the display of a list, see Customizing Object
List Columns and Filtering Lists on page 113.

Preview Tab
Click the Preview tab in the property sheet of the model, packages, and various other model
objects in order to view the code that will be generated for it.

The following tools are available on the Preview tab toolbar:
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Tools Description

Editor Menu [Shift+F11] - Contains the following commands:

• New [Ctrl+N] - Reinitializes the field by removing all the existing content.
• Open... [Ctrl+O] - Replaces the content of the field with the content of the se-

lected file.
• Insert... [Ctrl+I] - Inserts the content of the selected file at the cursor.
• Save [Ctrl+S] - Saves the content of the field to the specified file.
• Save As... - Saves the content of the field to a new file.
• Select All [Ctrl+A] - Selects all the content of the field.
• Find... [Ctrl+F] - Opens a dialog to search for text in the field.
• Find Next... [F3] - Finds the next occurence of the searched for text.
• Find Previous... [Shift+F3] - Finds the previous occurence of the searched for

text.
• Replace... [Ctrl+H] - Opens a dialog to replace text in the field.
• Go To Line... [Ctrl+G] - Opens a dialog to go to the specified line.
• Toggle Bookmark [Ctrl+F2] Inserts or removes a bookmark (a blue box) at the

cursor position. Note that bookmarks are not printable and are lost if you refresh
the tab, or use the Show Generation Options tool

• Next Bookmark [F2] - Jumps to the next bookmark.
• Previous Bookmark [Shift+F2] - Jumps to the previous bookmark.

Edit With [Ctrl+E] - [OOM only] Opens the previewed code in an external editor.
Click the down arrow to select a particular editor or Choose Program to specify a new
editor. Editors specified here are added to the list of editors available at Tools >
General Options > Editors.

Save [Ctrl+S] - Saves the content of the field to the specified file.

Print [Ctrl+P] - Prints the content of the field.

Find [Ctrl+F] - Opens a dialog to search for text.

 Cut [Ctrl+X], Copy [Ctrl+C], and Paste [Ctrl+V] - Perform the standard clipboard
actions.

 Undo [Ctrl+Z] and Redo [Ctrl+Y] - Move backward or forward through edits.

Refresh [F5] - Refreshes the Preview tab.

You can debug the GTL templates that generate the code shown in the Preview tab. To
do so, open the target or extension resource file, select the Enable Trace Mode option,
and click OK to return to your model. You may need to click the Refresh tool to
display the templates.
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Tools Description

Select Generation Targets [Ctrl+F6] - Lets you select additional generation targets
(defined in extensions), and adds a sub-tab for each selected target. For information
about generation targets, see Customizing and Extending PowerDesigner > Extension
Files > Generated Files (Profile) > Generating Your Files in a Standard or Extended
Generation.

Show Generation Options [Ctrl+W] - Opens the Generation Options dialog, allow-
ing you to modify the generation options and to see the impact on the code.

Ignore Generation Options [Ctrl+D] - [PDM only] Ignores changes to the genera-
tion options made with the Show Generation Options tool.

Finding Text Using Regular Expressions
You can use regular expressions to find script text displayed in the Preview or Script tab of a
table property sheet, as well as in the Edit/Run Script editor, the Resource Editor, and various
other windows.

In order to be able to search for text using regular expressions, you must select the Regular
Expression check box in the dialog box and enter a regular expression in the Find What box.

Regular expressions can contain ordinary characters and the following metacharacters:

Character Description

\ Matches a special character

Examples:

"n" matches "n". "\n" matches a newline character. "\\" matches "\" and "\(" matches
"("

^ Matches the position at the beginning of the input string

Examples:

"^Win" matches strings beginning with "Win

$ Matches the position at the end of the input string

Examples:

"then$" matches strings ending with "then"

* Matches the preceding character zero or more times

Examples:

"zo*" matches "z" and "zoo"

+ Matches the preceding character one or more times

Examples:

"zo+" matches "zo" and "zoo", but not "z"
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Character Description

? Matches the preceding character zero or one time

Examples:

"to?" matches either "t" or "to"

. Matches any single character except the newline \n

Examples:

".ork" matches "Work", "Fork" etc

[ ] Matches any one of the enclosed character

Examples:

"[abc]" matches "a", "b", or "c" A range of character can be indicated with a dash
"[a-z]"

For a complete list of metacharacters and their behavior in regular expressions, see the Visual
Basic Documentation.

Requirements Tab
You can attach one or more requirements to an object using the Requirements tab in the object
property sheet. This tab is not displayed by default, and can only be used if one or more
requirements models is open in the workspace.

Note: To display the Requirements tab, select Tools > Model Optionsand select the Enable
links to requirements option.

1. Open the object's property sheet and click the Requirements tab.

2. Click the Add Objects tool to open a selection dialog.

3. Select a Requirements model and, optionally, a package to display a list of the
requirements contained therein.

4. Select the requirements that you want to attach to the object and click OK.

The selected requirements appear in the Requirements tab.

5. [optional] Select the requirement in the list and click the Properties tool to open its
shortcut property sheet. To open the property sheet of the requirement itself, click the
Target Object Properties button to the right of the Name field.

Note: To access the property sheet of the requirement directly instead of passing by the
shortcut, select Tools > General Options > Dialog, and select the Target Object radio
button beside the External Shortcut option.

6. Click OK to close the property sheet and return to the model.
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Version Info Tab
PowerDesigner automatically manages version information about model objects on the read-
only Version Info tab of the object's property sheet.

Property Description

Creation User Specifies the name of the User who created the object.

Creation Date Specifies the date of creation of the object

Last Modification User Specifies the Name of the user who made the last modification to the object.

Last Modification Date Specifies the date of the last modification of the object

Replicated From [replicated objects only]Specifies the name of the origin object from which
the object was replicated.

Click the button to the right of this field to open the origin object property
sheet

Generated From [generated objects only]Specifies the name of the origin object from which
the object was generated.

Click the button to the right of this field to open the origin object property
sheet

Note: In addition to the standard help accessible via F1 or by clicking the Help button, you can
obtain information about the PowerDesigner metamodel metaclass on which this object is
based by clicking the small question mark button at the bottom right of the tab.

Dependencies Tab
The PowerDesigner metamodel provides the capability to link objects to other objects in a
variety of semantic ways. For example, when you create an external shortcut, or when you
attach a business rule to an object, a dependency link is created between models or objects.
The Dependencies tab of the object's property sheet displays these links.

Dependencies can be:

• Internal - to other objects within the model. These dependencies are saved in the model and
are always available on the Dependencies tab of an object property sheet

• External - to objects in other models via shortcuts or generation links (see Creating Links
Between Models on page 430). These dependencies are available on this tab only if the
linked model is open in your workspace, or if you have checked both models into the
repository and have checked your model out with the Check out dependencies option (see
Checkout Parameters on page 315).
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Object Namespaces
In PowerDesigner, each package can be a namespace. It is however possible to expand the
namespace to the parent of a given package. You can cascade the expansion until you reach the
level of the model itself.

Objects that appear in the Browser obey the general rules that follow:

In Browser Namespace Uniqueness rule

Objects directly under a package or a
model (table, process, class)

Model Unique name and code in model

Package Unique name and code in package

Objects under parent object (column, at-
tribute)

Not applicable Unique name and code in parent

Linking objects (reference, relationship) Not applicable Unique name and code between
same end objects (i.e., parallel links
with same name and code are not al-
lowed between same end objects)

However, you may encounter some exceptions to those rules. For example only the code of a
reference allows to identify the object in the entire model, when the "Unique code" option is
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selected in the Model Options dialog box. PowerDesigner warns you when a general rule is
not respected.

Object Lists
PowerDesigner object lists provide a spreadsheet-like interface for manipulating large
quantities of objects. They offer you an overview of the objects in your model and can save you
time and effort in managing your metadata. While property sheets provide depth of detail for
individual objects, lists allow you to select and manipulate multiple objects simultaneously to
streamline creation and improve consistency.

Lists of all the major objects in your model are available under the Model menu or by right-
clicking your model in the Browser and selecting List of objects . Each list shows all the
objects of that type in the currently selected package or model, including those that do not have
symbols in the current diagram:

The properties of the listed objects are organized in columns. You can order the list by a
particular columns values by clicking on its column header. To filter the values in a column,
click the down-arrow on the right of the column header and enter your filter (see Filtering a
List Using In-Column Filters on page 111).

You can control which property columns are displayed, and also filter the list based on the
values in any of the columns (see Customizing Object List Columns and Filtering Lists on
page 113).

You can select multiple items in a list by Ctrl-clicking them in the far-left, numbered column.
To select all the items in a list, click the top-left corner box. When multiple items are selected,
any edits you make to properties are applied to all the selected items.
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Note: By default, you must click the Apply button to commit changes or the OK button to
commit and close the list. To have changes commited immediately when you enter them in a
field, enable the Auto commit general option (see Dialog Box Options on page 256). You can
always use the Undo tool to cancel the change.

All or some of the following tools are available on object lists:

Tool Description

Properties - Opens the property sheet of the selected item (see Object Properties on page
98).

Insert a Row - [ordered lists only] Inserts a row before the selected row in the list.

Add a Row - Adds a row at the end of the list.

Add Objects - Opens an object selection dialog box to select objects and copy them to the
list (see Adding an Item from a Selection List on page 118).

Create Object - Creates a new object and opens its property sheet to allow you to complete
its definition.

Reuse/Replicate Objects - Opens an object selection dialog box to reuse objects. When
you select an item you create a link to the original instead of copying it to the list.

Cut - Cuts the row and stores it in the Clipboard.

Copy - Copies the selected row to the Clipboard.

Paste - Pastes the contents of the Clipboard.

Delete - Deletes the row.

Find a Row - Opens the Find dialog to search for an item in the list.

Find Symbol in Diagram - Finds the object's symbol in the diagram.

Customize Columns and Filter - Opens a dialog to change the columns displayed in the
list or define a filter (see Customizing Object List Columns and Filtering Lists on page
113).

Enable/Disable Filter - Toggles the filter specified in the Customize Columns and Filter
dialog.

Include Sub-Packages - Includes objects in sub-packages in the list.

Include Composite Objects - Includes composite objects (such as sub-processes, sub-
activities, sub states, etc.) in the list.
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Tool Description

Include Shortcuts - Includes object shortcuts (see Creating Shortcuts on page 457) in the
list. Shortcuts are grayed as they cannot be modified. When you include shortcuts whose
target model is closed, some information may be unavailable.

Open Diagrams - [Related Diagrams tab] Opens a target model or a diagram (see Spec-
ifying Diagrams as Related Diagrams on page 172).

Shortcut - Opens an object selection list to change the target object of a shortcut

Export to Excel - Saves the list to a *.xls, *.xlsx, or *.csv format (specify the format in the
Save as type field in the Save as dialog).

Print - Prints the list. Click the arrow to the right of the button to view a print preview or to
access the Page Setup dialog.

Sub-Object Lists
Many objects have property sheets that contain sub-object lists, which list all of the child
objects of that type belonging to the object. For example, the Columns tab in a table property
sheet displays the list of columns in the selected table:

These lists provide the same features as the lists of objects available from the Model menu.
Depending on the properties of the listed objects, the list may have a natural order that you can
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control. For example, a list of columns has such an order, and you can move objects in the list
by selecting them and then clicking on one of the arrows at the bottom left corner of the list.

Filtering a List Using In-Column Filters
To filter a list by the values in a column, click the down arrow on the right of the column header
to display the in-column filter dialog.

Note: If the in-column filter arrows are not displayed, click the Customize Columns and
Filter tool and select the Show column filter buttons option.

1. Select an operator from the first list and, if appropriate, select or enter an expression value
to test against it. In this example, the list will be filtered to show only rows where the Name
column contains values beginning with Cust*.

For an explanation of the available operators and the syntax for the expressions, see 
Defining a Filter Expression on page 116.

2. When you are satisfied with your criteria, click OK to apply the filter. The down arrow is
overlaid with a filter symbol to show that a filter is applied, and any rows not meeting the
criteria are hidden. In addition, to Enable/Disable Filter button is pressed. In this
example, the Name=Cust* filter is applied:
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3. [optional] Further restrict the rows displayed by defining a filter on any number of other
columns. In this example, both the Name=Cust* filter and a Length<80 filter are
applied:

Note: The filter criteria are stored in the Customize Columns and Filter dialog and remain
applied until you remove them. To remove all filters, click to release the Enable/Disable
Filter. To remove a filter from a single column, click the filter button in the column header,
and then click the Clear Column Filter button.
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Customizing Object List Columns and Filtering Lists
You can choose which property columns to display in object lists, reorder them, and filter the
rows to be displayed from the Customize Columns and Filter dialog.

1. Click the Customize Columns and Filter tool on an object list toolbar to open the
Customize Columns and Filter dialog.

2. Perform any of the following functions to filter the list:

• Select columns to display - by checking the [D]isplay column checkbox.
• Reorder the columns in the list - by using the arrows at the bottom left of the dialog. To

move all the selected rows to the top of the list, press SHIFT+ENTER.
• Define one or more filter expressions - by selecting an operator in the Operator

column and entering an expression to filter by in the Expression column.

The [U]sed checkbox is automatically selected when you enter a filter expression. To
disable the expression but keep it in memory, clear the checkbox.

• Enable or disable in-column filtering directly in the list (see Filtering a List Using In-
Column Filters on page 111) by selecting the Show column filter buttons option.

3. Click OK to return to the list. The filter is applied by default, and the Enable/Disable filter
tool is depressed. Click this tool to toggle between enabling and disabling the filter.

Customizing Columns in Lists Containing Multiple Types of Objects
PowerDesigner supports lists containing multiple types of objects. As each type of object has
different sets of properties, by default only properties common to all the object types are
available for selection to display in the list. However, you can customize display properties
specific to one or more object types by using the Add Attribute button at the bottom of the
Customize Columns and Filter dialog.
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Note: The Add Attribute button is only available when the list can contain multiple types of
objects.

The button opens a dialog that lets you select any attribute for any object that is available in this
context:

When you select an attribute and click OK, it is added to the list in the Customize Columns and
Filter dialog and all instances of the attribute (if it is available for multiple objects) are
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removed from the Add Attribute dialog. You can add as many attributes as necessary and apply
filters on them as appropriate.

Note: If you deselect an attribute in the Customize Columns and Filter dialog and click OK, it
will be removed from the list of properties available for display. If you change your mind and
want to display it once again, you will need to re-add it with the Add Attributes button.

For example, the EAM architecture area can contain many different types of objects, and these
are listed on the Attached Objects tab of its property sheet. Here, I've added the following
attributes:

• Application::Type - though I selected the Type attribute for the Application
metaclass, the Type attribute present in any other metaclasses available in this context will
be displayed too.

• Database::DBMS
• Database::DBMS Version

When I return to the list tab, my new attributes are displayed as columns with values where
appropriate. Both my applications and databases have Type properties, but only my databases
display values for the DBMS and DBMS Version columns:
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Defining a Filter Expression
You can define expressions to filter PowerDesigner lists directly in the list with the in-column
filters or through the Customize Columns and Filter dialog.

The following operators are available

Operator Finds items that are...

= [default] Equal to the expression.

> Greater than the expression.

>= Greater than or equal to the expression.

< Less than the expression.

<= Less than or equal to the expression.

Not Equal Different from the expression.

In List Within the comma-separated list of values given in the expression (or the items
selected in the list in the in-column filter). For example:

"global", "Architecture", "proc*"

Not In List Outside the comma-separated list of values given in the expression (or the items
selected in the list in the in-column filter).

CHAPTER 4: Objects

116 SAP Sybase PowerDesigner



Operator Finds items that are...

Between Located in the range between defined by the two values given in the expression and
separated by a comma. For example, to find values between A and E, enter:

A,E

Not Between Located outside the range defined by the two values given in the expression and
separated by a comma. For example, to find values outside of the range between A
and E, enter:

A,E

Empty Null. No expression is necessary with this operator.

Not Empty Not null. No expression is necessary with this operator.

You can use the following wildcards when entering a filter expression:

Wildcard Description

* Any string (from none to any number of characters). For example P* finds "pro-
tocol" and "Paris".

? Any character. For example ????? finds "Table" and "inner" but not "Seller".

\ Escapes the special characters *, ?, and \ . For example, \?\\ finds "?\".

Examples
The following examples show some possible combinations of operators and expressions:

Operator Expression Find

= W* Work, Washington

= *CODE AREA CODE, COUNTRY CODE, CITY CODE

> 1?? 200, 405, 609

Between O,8 0,1,2,3,4,5,6,7,8

In List *_emp_???,
*_grp_???

div_emp_fun, _emp_idn, div_grp_fun, _grp_idn

= *\? Is this book ready for production?

Adding Items to and Reordering Items in a List
If a list is ordered you can choose to add an item at the end or at a certain point in the list, and
you can reorder the items in the list. When you add a new item to a list, it is created with a
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default name and code that you can edit. Objects are not actually created until you click Apply
or OK.

Note: In general, you are not required to provide any specific properties when you create an
object. However, when you create a link object, such as a reference, association link, or
inheritance link, you must specify the source and the destination.

Adding Items at the End or at a Particular Point in a List
The following tools are available for adding items to a list:

Tool Description

Add a Row - Adds an item to the end of the list. You can also add an item to the end of a list
by clicking in any empty row.

Insert a Row [ordered lists only] - Adds an item in the row above the selected row. You
can always reorder items in an ordered list by selecting and dragging and dropping them
or by using the arrow tools at the bottom left of the list.

Arranging Items in an Ordered List
In ordered lists, you can drag and drop objects to reorder them, or use the following buttons at
the bottom of the list:

Tool Description

Move the selected items to the top of the list.

Move the selected items up one page

Move the selected items up one line

Move the selected items down one line

Move the selected items down one page

Move the selected items to the bottom of the list

Adding an Item from a Selection List
Selection lists allow you to select items from a list in order to associate them with another
object.

Most selection lists display objects contained in the current model or in individual packages
contained in that model. Other selection lists, such as the following, allow you to display both
objects contained in the current model and other models:

• Select Diagrams. From this dialog box you can select the diagram to which you want to
apply pre-defined display preferences.
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• Add Shortcuts. From this dialog box you can select objects to include them as shortcut in
your model or package.

• Add Objects. From this dialog box you can select objects to which you want to attach
traceability links.

The following tools are available in selection lists:

Tool Description

- Model list - Lets you specify a model as the basis for the list.

- Package list - Lets you specify a package as the basis for the list.

- Owner List - [PDMs only] Lets you specify a user as the basis for the list. The list will
contain only objects owned by the specified user or by no user. If you select User
<NONE>, then all the objects are displayed.

Include Sub-Packages - Includes objects contained in sub-packages (Include Sub-
Packages) in the list.

As this tool allows you to display all objects, regardless of their package, some objects
in the list may have the same name and be difficult to identify. In this situation, you can
use the Customize Columns and Filter tool, to display the Object Location column to
identify where the objects are defined.

Include Composite-Objects - Includes composite objects, such as sub-process, sub-
activity, sub state, in the list

Include External Shortcuts - Includes shortcuts to objects in other models in the list. The
model containing the original objects must be open for external shortcuts to be available
for selection. When generating, external shortcuts are generated as ordinary objects.

Select All - Selects all the objects in the current object type tab. To select all check boxes
in all object type tabs, click the arrow and select All Lists or you can press the Ctrl key
and click the Select All tool.

Deselect All - Deselects all the objects in the current object type tab. To clear all check
boxes in all object type tabs, click the arrow and select All Lists or press the Ctrl key and
click the Deselect All tool.

Use Graphical Selection - Selects only the objects currently selected in the diagram. To
apply the graphical selection in all object type tabs, press the Ctrl key and click the Use
Graphical Selection tool.

Move Selected Items to Top - Moves all selected objects to the top of the list.

Move Selected Items to Bottom - Moves all selected objects to the bottom of the list.

Customize Columns and Filter - Opens the Customize Columns and Filter dialog (see
Customizing Object List Columns and Filtering Lists on page 113), which allows you
to define a filter expression to apply to the selection list.
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Tool Description

Enable/Disable Filter - Applies the filter defined in the Customize Columns and Filter
dialog to restrict the list of objects available for selection to those meeting its criteria.
The currently defined filter is displayed in the Filter box underneath the object list.

Use Filter for Selection - Applies the filter defined in the Customize Columns and Filter
dialog to select all objects meeting its criteria from the list. This selection by criteria is
persistent for as long as the tool is applied.

Ctrl + se-
lection tool

Applies the action of the selection tool to all object types in the different tabs.

Saving Object Selections
In some selection lists, you can save sets of object selections in your model, so that you can
reuse them easily. To save a selection, enter a name in the Selection list at the bottom of the
Selection tab then click the Save tool beside the list. The selection is saved as part of the model
file.

Note: When reverse engineering from a live data source, object selections are saved into
separate files, as you need not have any model open in the Workspace (see Data Modeling >
Building Data Models > Generating and Reverse-Engineering Databases > Reverse
Engineering a Database into a PDM > Database Reverse Engineering Selection Window). In
this case, you must select a folder before being able to save the object selection.

Confirming Object Selections
In a selection list, the display of your object selection may be modified whenever you perform
one of the following actions:

• Change the folder selection using the Model or Package list
• Deselect the Include Sub-Packages/Sub-Objects tool
• Deselect the Include Shortcuts tool
• Apply a filter using the Enable Filter tool
• Change the database or owner in the Reverse Engineering from a data source dialog box

In this case, some objects that have already been selected will no longer be displayed, and a
dialog opens prompting you to:

• Select only the objects displayed - Other objects that are no longer displayed are
deselected.

• Keep the hidden objects in the selection – All the previously selected objects are retained,
including those that are no longer shown. This allows you to take into account object
selections you have made in several packages for example.

• Cancel - The commit of the selection list is canceled and the selection page now displays
all objects and sub-objects in the model to let you modify your selection if necessary.

If you confirm your selection by clicking OK, the confirmation dialog will not be displayed
again, even if you again modify your parameters.
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Selecting an Object from a Selection Tree
Certain selection dialogs allow you to choose objects from a tree view or by searching by
name.

The Browse tab allows you to choose an object from a tree view:

The Index tab lets you search for an object by entering all or part of its name (or code
depending on the Display Name/Code model option). Objects are sorted alphabetically in the
list and dynamically update as you type. Select an object and click the Properties button to
view its property sheet:
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You can select an object on either tab and then click the other tab to retain the choice and view
it in that context. Double-click an object, or select it and click OK, to commit the selection and
close the selection dialog.

Moving, Copying, and Deleting Objects
Objects in the PowerDesigner working environment are easy to manipulate and to reuse from
one model or package to another.

Dragging and Dropping Objects
You can drag objects from one package or model to another to copy, move, or create a shortcut
or replica. You can drag objects from the Browser, a diagram, an object list, or the Result List
to the Browser or a diagram. By default, you perform a move when the start or drop point is the
Browser or create a shortcut when dragging between diagrams. You can change this behavior
temporarily, set a different default, or right-click and drag to obtain a contextual menu listing
all the available drop actions.

To temporarily change the behavior; press and hold the following keys while dragging:

• Shift - Move
• Ctrl - Copy
• Shift+Ctrl - Create shortcut (see Creating Shortcuts on page 457
• Shift+Alt - Create replica (see Creating Replicas on page 463)
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To modify the default Browser drag and drop behavior, select Tools > General Options and
select the appropriate radio button:

To obtain any behavior without modifier keys, right-click and drag. When you release the right
mouse button, a contextual menu opens listing all the available drop actions.

Copying and Pasting Objects
You can copy objects from the Browser, a diagram, an object list, or the Result List and paste
them into the Browser, a diagram, or an object list. Symbols can be pasted as images into MS
Word or image applications, while lines from object lists or the Result List can be pasted in
CSV format into Excel, Word, or other text editors.

Note: To create a graphical synonym of a symbol, which is merely a second instance of the
object in the diagram to improve readability or reduce link lengths, see Creating Graphical
Synonyms for Object Symbols on page 199

1. To copy one or more objects, select them, and then:
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• Select Edit > Copy from the menu bar.
• Press Ctrl+C.
• Right-click and select Edit > Copy.

Note: You can copy an object by drag and drop by holding down the Ctrl key as you drop
it, or copy it as a shortcut by holding down Ctrl+Shift (see Dragging and Dropping
Objects on page 122).

2. Click in the place where you want to paste the object and then:
• Select Edit > Paste from the menu bar.
• Press Ctrl+V.
• Right-click and select Edit > Paste.
• [to paste as a shortcut] Select Edit > Paste As Shortcut from the PowerDesigner menu

bar, or right-click and select Edit > Paste As Shortcut. For more information,
including the rules governing the creation of shortcuts, see Chapter 15, Shortcuts and
Replicas on page 455.

When you copy an object, you also copy its child objects, and any references to other
objects. For example, if you copy a CDM entity, you also copy its attributes and any
references to business rules attached to that entity. When you paste an object, you transfer
all of its properties from the Clipboard and create a new object, and not a graphical
synonym or a new instance of the copied object.

When you paste in PowerDesigner, the creation of the object must not violate name
uniqueness rules (see Object Namespaces on page 107). If an object with the same name
and code already exists in the model or package, PowerDesigner will append a number to
the name and code, and display a message in the Output pane to warn you that the object
was renamed.

Note: When a paste conflict occurs on a CDM entity, the copied entity is given a new name
and code and, if the Allow Reuse model option is not selected, new attributes will be
created, with the same names as those being copied. If the Unique Code model option is
not selected, the codes because they are in the context of the new entity)a new identifier is
created (which will have the same namerenamed according to the data item options set in
the model.

Deleting Objects
You can delete an object from a diagram, the Browser, or an object list.

Since PowerDesigner gives you the freedom to create multiple symbols in multiple diagrams
to represent the same object, when deleting a symbol in a diagram, you can choose to delete
just the symbol or the entire object.

When you delete an object, you also delete any sub-objects it contains (for example, when you
delete a table from a PDM, you delete its columns, keys, triggers and indexes), along with all
its diagram symbols. If you delete an object that is connected to another object via a link, the
link is also deleted.
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To delete an object, do one of the following:

• Select its symbol in a diagram and press the Del key or right click it and select Edit >
Delete. A dialog will open asking you whether you want to delete the object itself
(including any sub-objects it contains) or just the symbol:

You can review the impact that deleting the object would have on other objects in your
environment by clicking the Impact button on the confirmation dialogs (see Chapter 17,
Impact and Lineage Analysis on page 499). You can undo a deletion by clicking the Undo
tool.
Make your choice and click OK. If you delete only the symbol, you can restore it to the
diagram, by selecting Symbol > Show Symbols and reselecting the object in the Show
Symbols dialog.

• Select its symbol in a diagram and press Shift+Del. The object, any sub-objects it contains,
and any associated diagram symbols will be deleted immediately without the need for
confirmation.

• Select it in the Browser and press the Del key or right click it and select Edit > Delete. A
dialog will open asking you to confirm the deletion:

Click OK to delete the object, any sub-objects it contains, and any associated diagram
symbols.

• Select it in an object list and click the Delete tool or press the Del key. The object, any
sub-objects it contains, and any associated diagram symbols will be deleted immediately
without the need for confirmation.

Note: You can suppress the display of the Confirmation dialogs by deselecting the Confirm
Object Deletion general option (see General Options on page 255).

Deleting Domains and Data Items
If you have specified that domains and data items can be reused by multiple objects in a CDM
or PDM and you delete a parent object to which they belong, these sub-objects will not be
deleted with their parent. For more information, see Data Modeling.
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Moving Objects from One Package to Another
You can move objects from one package to another by drag and drop or cut and paste. Moving
an object does not involve copying it, but a shortcut will be created in the original model or
package, which points to the object's new location. You can only move an object to a model
that supports this kind of object, and global objects (such as business rules, domains, storages
etc.) cannot be moved into packages.

When you move an object from a package to another, linking objects that you move keep their
links in the target package and a shortcut is usually created in the source package. The general
rule being that conceptual modeling must be preserved.

When you move an object with a non-oriented link:

Source package Target Package

A shortcut of the moved entity is created: The moved entity is displayed:

When you move an object with an oriented link:

Move Table Source Package Target Package

Parent TA-
BLE_2

A shortcut of the parent TABLE_2 is

created:

The parent TABLE_2 is displayed:
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Move Table Source Package Target Package

Child TABLE_1 Only the parent TABLE_2 is dis-

played:

The child TABLE_1 is displayed with

the reference link and a shortcut is cre-
ated for the parent TABLE_2.

When moving CDM entities containing data items, the data items will be moved to the new
package or model with the entity unless they are reused by other entities, in which case copies
will be made.

For more information about shortcut and copy rules, see Creating Shortcuts on page 457.

Finding Objects
PowerDesigner lets you search for objects within all the models currently open in your
workspace.

Note: For information about searching in the repository and PowerDesigner Portal, see 
Finding Objects in the Repository on page 332 and PowerDesigner Portal Search on page
344.

1. Select Edit > Find Objects (or press Ctrl+F) to open the Find Objects dialog.

2. Specify the appropriate constraints on these tabs:

• Name and Location - to search on the name and location of PowerDesigner objects.
• User and Date - to search on the user and date of creation/modification of

PowerDesigner objects.
• Advanced - to search on other criteria.
• Glossary - to search on keywords, terms, related terms, and synonyms.

For detailed information about these tabs, see Find Parameters on page 128.

3. Click Find Now.

Note: Once you have started the Find Objects process, you can stop it at any time by
clicking the Stop button.

The Find Object dialog remains open, displaying messages in the Output pane, until the
end of the process, when the Result List displays the result:
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Right-click an object in the list to find it in a diagram or the Browser, to open its property
sheet or perform an impact and lineage analysis on it.

The following operations are available by right-clicking an object in the Results List:
• Properties - to open the object's property sheet (see Object Properties on page 98).
• Impact and Lineage Analysis - to analyze the object (see Chapter 17, Impact and

Lineage Analysis on page 499).
• Find in Browser - to highlight the object in the Browser (see Chapter 2, The Browser

on page 35).
• Find in Diagram - to open the diagram (see Diagrams on page 169) with the symbol

centered. If the object has symbols in multiple diagrams, you see a list. If the object has
no symbol, a warning message appears.

• Copy - to copy the object (seeCopying and Pasting Objects on page 123). Select a
destination in the Browser or a diagram and select Edit > Paste or Edit > Paste as
Shortcut.

Find Parameters
The Find Objects dialog contains tabs that let you precisely specify your search criteria.

Name and Location Tab
The Name & Location tab provides basic search parameters:

Parameter Description

Look in Specifies the scope of the search. You can select the entire workspace, a project,
folder, model, or package.

Model type Specifies the type of PowerDesigner model to search. The options available in
this list are affected by your choice in the Look in field.

Object type Specifies the type of model objects to be searched. The options available in this
list are affected by your choice in the Model type field.
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Parameter Description

Include shortcuts Instructs PowerDesigner to include object shortcuts that match your criteria in
the results.

Name Specifies the object name to search for. You can use the following special char-
acters:

• * - none to any number of characters. For example:

• W* finds "Work" and "Washington"

• *96 finds "01/11/96" and "26/08/96"

• ? – exactly one character. For example:

• *_emp_??? finds "Div_emp_idn" but not "Div_emp_ident"

• \ - escapes *, ?, or \. For example:

• \?\\ - finds ?\

• true/false - Boolean value (True is when the check box is selected)

Code Code of the object. You can type the exact code of the object or use a string
expression.

Case sensitive Specifies that the results must match the case of the criteria.

User and Date Tab
The User & Date tab lets you constrain your search based on when and by whom the object
was created and modified:

Parameter Description

Created Enables searching on creation parameters. You can search against the name of the
user who created the object and against the creation date using the following
options:

• Before the specified date

• After the specified date

• Between the two specified dates

• In the specified number of days since today

Modified Enables searching on modification parameters.

Advanced Tab
The Advanced tab allows you to specify additional search constraints for each property of the
selected object type in the following format:
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Parameter Description

U (Used) Specifies a property on which to apply the search. Select this option for a property
without entering an expression to find objects for which the property is null.

Operator Specifies an operator to use for the search. Click in the Operator column to
display the list of available operators.

Expression Specifies a string expression to search for. For detailed information about the
operators and the expression syntax, see Defining a Filter Expression on page
116.

Note: If you do not select an object type on the Name & Location tab, then you can only
search on the name and code properties on this tab.

Glossary Tab
The Glossary tab allows you to specify additional search constraints in relation to glossary
objects (see The Glossary on page 36) with which objects may be associated:

Parameter Description

Search by Specifies that the objects searched for must be associated with a glossary object
whose name contains the specified string.

Search Range Specifies the glossary objects to search on. You can select one or more of Key-
words, Terms [default], Related Terms, and Synonyms.

Case sensitive Specifies that the search string must match the case of the glossary object.
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Business Rules
A business rule is a rule that your business follows. It is a written statement specifying what an
information system must do or how it must be structured. It could be a government-imposed
law, a customer requirement, or an internal guideline.

Business rules often start as simple observations, for example "customers call toll-free
numbers to place orders." During the design process they develop into more detailed
expressions, for example what information a customer supplies when placing an order or how
much a customer can spend based on a credit limit.

You can attach business rules to your model objects to guide and document the creation of your
model. For example, the rule "an employee belongs to only one division" can help you
graphically build the link between an employee and a division.

Business rules complement model graphics with information that is not easily represented
graphically. For example, some rules specify physical concerns in the form of formulas and
validation rules. These technical expressions do not have a graphical representation.

In the case of the PDM and OOM, you can generate business validation rules attached to
domains as check parameters.

Before you create business rules, formulate your rules by asking yourself the following
questions:
• What business problems do I want to address?
• Are there any procedures that my system must respect?
• Do any specifications dictate the scope of my project?
• Do any constraints limit my options?
• How can each of these procedures, specifications, and constraints be described?
• How can each of these descriptions be classified? Possible classifications are definitions,

facts, formulas, requirements or validation rules

Creating a Business Rule
You can create a business rule from the Model menu, from the Browser of from a property
sheet.
• Select Model > Business Rules to access the List of Business Rules, and click the Add a

Row tool.
• Right-click the model or package in the Browser, and select New > Business Rule.
• Open the property sheet of the object to which you want to apply the rule, click the Rules

tab, and click the Create an Object tool.

Business Rule Properties
You can modify an object's properties from its property sheet. To open a business rule property
sheet, double-click its Browser entry in the Business Rules folder. The following sections
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detail the property sheet tabs that contain the properties most commonly entered for business
rules.

The General tab contains the following properties:

Property Description

Name/Code/
Comment

Identify the object. The name should clearly convey the object's purpose to non-
technical users, while the code, which is used for generating code or scripts, may
be abbreviated, and should not normally include spaces. You can optionally add a
comment to provide more detailed information about the object. By default the
code is generated from the name by applying the naming conventions specified in
the model options. To decouple name-code synchronization, click to release the =
button to the right of the Code field.

Stereotype Extends the semantics of the object. You can enter a stereotype directly in this
field, or add stereotypes to the list by specifying them in an extension file.

Type Specifies the nature of the business rule. You can choose between:

• Constraint – a check constraint on a value. In a PDM, constraint business rules
can be generated in the database. For example, "The start date should be
inferior to the end date of a project."

• Definition – a property of the element in the system. For example; "A customer
is a person identified by a name and an address".

• Fact – a certainty in the system. For example, "A client may place one or more
orders".

• Formula – a calculation. For example, "The total order is the sum of all the
order line costs".

• OCL constraint [OOM only] – An Object Constraint Language expression.
• Requirement – a functional specification. For example, "The model is de-

signed so that total losses do not exceed 10% of total sales".
• Validation – a constraint on a value. For example, "The sum of all orders for a

client must not be greater than that client's allowance".

The following tabs are also available:

• Expression Tab - Though business rules typically start out as descriptions, as you develop
your model and analyze your business problem, you can enrich them by adding technical
expressions on this tab. Expressions are used primarily in CDMs and PDMs. Each rule can
include two types of expression, which you define on the appropriate sub-tab:
• Server
• Client

• OCL Constraint Tab - This tab is only available for business rules with a type of OCL
Constraint. The Object Constraint Language is the UML expression language. Enter your
OCL expression in the text field.
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Applying a Business Rule to a Model Object
You can apply business rules that you have created to your model objects.

1. Open the property sheet of an object, and then click the Rules tab:

2. Click the Add Rules tool to open a selection window listing all the business rules available
in the model:
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3. Select the business rules you want to add to the object, and then click OK to return to the
object's property sheet.

4. Click OK to close the object property sheet and return to the model.

Note: When you apply a business rule to an object, its U (Used) column in the List of
Business Rules is automatically checked. This column allows you to see what rules are
unused, and delete them if necessary.

File Objects
A file object is a representation in a PowerDesigner model of an external application file (for
example, a Java file, script SQL, or MS Word file). The file itself can be kept external to the
model or embedded within and saved with it.

For example you could:

• Attach a file object to any PowerDesigner object to enrich its description
• Attach a generated OOM class to a target Java file

You open the file in its associated editor by double-clicking its diagram symbol or browser
entry. To change the associated editor, right-click the file object and select Open With >
Choose Program (see Text Editors on page 258).

Creating a File Object
You can create a file object from the Toolbox, Browser, or Model menu.

• Use the File tool in the Toolbox.
• Select Model > Files to access the List of Files, and click the Add a Row tool.

CHAPTER 4: Objects

134 SAP Sybase PowerDesigner



• Right-click the model or package in the Browser, and select New > File.
• Drag a file from Windows Explorer and drop it in the diagram or Browser.

File Object Properties
To view or edit a file object's properties, double-click its diagram symbol or Browser or list
entry. The property sheet tabs and fields listed here are those available by default, before any
customization of the interface by you or an administrator.

Property Description

Name/Code/
Comment

Identify the object. The name should clearly convey the object's purpose to non-
technical users, while the code, which is used for generating code or scripts, may be
abbreviated, and should not normally include spaces. You can optionally add a com-
ment to provide more detailed information about the object. By default the code is
generated from the name by applying the naming conventions specified in the model
options. To decouple name-code synchronization, click to release the = button to the
right of the Code field.

Stereotype Extends the semantics of the object. You can enter a stereotype directly in this field, or
add stereotypes to the list by specifying them in an extension file.

Location type Specifies the nature of the file object. You can choose from the following:

• Embedded file – the file is stored within the model and is saved when you save the
model. If you subsequently change the type to external, you will be warned that
the existing contents will be lost.

• External file – the file is stored in the Windows file system, and you must enter its
path in the Location field. If you subsequently change the type to embedded, you
will be prompted to import the contents of the file into the model.

• URL – the file is on the web and you must enter its URL in the Location field

Location [External and URL types only] Specifies the path or URL to the file.

Extension Specifies the extension of the file object, which is used to associate it with an editor.
By default, the extension is set to txt.

Generate Specifies to generate the file object when you generate the model to another model.

Artifact Specifies that the file object is not a piece of documentation, but rather forms an
integral part of the application.

If an artifact has an extension that is defined in the Editors page in the General
Options dialog linked to the <internal> editor, a Contents tab is displayed in the
artifact property sheet, which allows you to edit the artifact file in the PowerDesigner
text editor.

Keywords Provide a way of loosely grouping objects through tagging. To enter multiple key-
words, separate them with commas.
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Attaching a File to a Model Object
You can attach file objects to other model objects through traceability links.

• Right-click an object symbol in the diagram and select Edit > File > Add File.
• Use the Link/Traceability Link tool in the toolbox to draw a link from the object symbol

to the file object symbol.
• Select the Traceability Links tab of the object property sheet, click the Add Objects tool,

select the file, and click OK (see Creating Traceability Links on page 431).

The connection between the object and the file object takes the form of a traceability link, and
is visible:

• In the form of a link in the diagram.
• On the Dependencies tab of the file object property sheet and on the Traceability Links

tab of the dependent object property sheet.
• Under the File command in the contextual menu of the dependent object symbol.

Extended Objects, Sub-Objects, and Links
Extended objects, sub-objects, and links let you model concepts that are not natively
supported by PowerDesigner. For example, you can add extended objects to a PDM to model
new database objects. You can specify generated files and templates in the definition of your
extended objects in order to enable their generation and reverse-engineering.

Extended objects and extended links are available by default in the free model (see Chapter 6,
The Free Model (FEM) on page 219), and can be added to any other type of model through the
Profile category in the model's resource file or in an extension file (see Customizing and
Extending PowerDesigner > Extension Files).

To view or edit an extended object's properties, double-click its diagram symbol or Browser or
list entry. The property sheet tabs and fields listed here are those available by default, before
any customization of the interface by you or an administrator.

Property Description

Name/Code/
Comment

Identify the object. The name should clearly convey the object's purpose to non-
technical users, while the code, which is used for generating code or scripts, may be
abbreviated, and should not normally include spaces. You can optionally add a
comment to provide more detailed information about the object. By default the code
is generated from the name by applying the naming conventions specified in the
model options. To decouple name-code synchronization, click to release the = but-
ton to the right of the Code field.

Source [extended links only] Specifies the name of the origin object of the extended link.
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Property Description

Destination [extended links only] Specifies the name of the destination object of the extended
link.

Stereotype Extends the semantics of the object. You can enter a stereotype directly in this field,
or add stereotypes to the list by specifying them in an extension file.

Keywords Provide a way of loosely grouping objects through tagging. To enter multiple key-
words, separate them with commas.

Note: You can use the CanLinkKind event handler to restrict the kind of objects you want to
link together. This event handler is called when you create a link using the Toolbox tool or
when you try to modify the ends of a link from its property sheet. For more information, see
Customizing and Extending PowerDesigner > Extension Files > Event Handlers (Profile).

Checking Models
You can check the validity of your model at any time. We recommend that you check your
model before generating code or another model from it. The Check model option is enabled by
default in the Generate dialog box and, if an error is found, the generation is stopped.

1. Press F4, select Tools > Check Model, or right-click the diagram background and select
Check Model to open the Check Model Parameters dialog.

The Options tab lists the types of objects to be checked, and the individual checks to be
performed are displayed with symbols indicating their severity:
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2. [optional] Select or deselect types of objects to check, and expand object nodes to enable,
disable, vary the severity of, and enable or disable automatic correction of individual
checks with the following tools:

Tool Description

Select All – Click the arrow to select all checks, all error checks, or all warning checks.

Deselect All - Click the arrow to deselect all checks, all error checks, or all warning
checks.

Error – Sets the selected check to error level. When errors are encountered, any model
generation is stopped.

Warning - Sets the selected check to error level. Warnings do not allow model generation
to proceed.

Automatic correction – [if available for the selected check] Enables automatic correc-
tion for the selected check and places a small red cross on the bottom-right corner of the
check icon.

Automatic corrections may have unexpected effects, and you might want to disable
them in some cases. For example, in a PDM, if a column code length is longer than the
length specified in the DBMS MaxColumnLen entry, then PowerDesigner will
truncate the code, but may also change the code to avoid duplicating an existing code.

Note: Right-click a check and select Help to display its documentation.

CHAPTER 4: Objects

138 SAP Sybase PowerDesigner



3. [optional] Click the Selection tab, and select or deselect individual objects for checking.
Sub-tabs are available for each type of object:

Note: If you had previously selected symbols in your diagram, you can select them for
checking with the Use Graphical Selection tool. For detailed information about these
tools, see Adding an Item from a Selection List on page 118.

4. Click OK to begin the model check.

The Check Model Result List displays errors and warnings based on the check options you
have defined. For information about how to correct errors, see Correcting Errors in the
Check Model Result List on page 139.

Correcting Errors in the Check Model Result List
When errors and warnings are encountered during model checking, they are listed in the
Check Model Result List pane. You can correct the problems either by invoking a automatic

CHAPTER 4: Objects

Core Features Guide 139



correction (if available) or by opening the property sheet of the affected object and correcting
it manually.

The following tools are available to assist you in correcting problems with your model. If this
toolbar is not displayed, select Tools > Customize Toolbars, select Check, and click OK.

Tool Description

Correct error – Opens the property sheet of the affected object to allow you to correct the
error.

Display help – Provides documentation for the error or warning.

Check again – Re-performs the check, to allow you to verify your correction.

Automatic correction – Only available if an automatic correction is defined for this kind of
error. Performs the automated correction.

First error – Goes to the first error in the list.

Previous error - Goes to the previous error in the list.

Next error - Goes to the next error in the list.

Last error - Goes to the last error in the list.

Note: These and other options are also available by right-clicking an item in the Check Model
Result List.

Checking Generic Objects
Generic objects are available in all types of models and have standard checks defined for them.
For model-specific checks, see the appropriate modeling guide.

Business Rule Checks
PowerDesigner provides default model checks to verify the validity of business rules.

Check Description and Correction

Name/Code contains terms not in glos-
sary

[if glossary enabled] Names and codes must contain only
approved terms drawn from the glossary.

• Manual correction - Modify the name or code to contain
only glossary terms.

• Automatic correction - None.
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Check Description and Correction

Name/Code contains synonyms of
glossary terms

[if glossary enabled] Names and codes must not contain
synonyms of glossary terms.

• Manual correction - Modify the name or code to contain
only glossary terms.

• Automatic correction - Replaces synonyms with their
associated glossary terms.

Name/Code uniqueness Object names must be unique in the namespace.

• Manual correction - Modify the duplicate name or code.
• Automatic correction - Appends a number to the dupli-

cate name or code.

Unused business rule The business rule you have created is not used in the model.

• Manual correction: Apply the business rule to an object
in the model

• Automatic correction: None

Extended Object/Link Checks
PowerDesigner provides default model checks to verify the validity of extended objects/links.

Check Description and Correction

Name/Code contains terms not in glos-
sary

[if glossary enabled] Names and codes must contain only
approved terms drawn from the glossary.

• Manual correction - Modify the name or code to contain
only glossary terms.

• Automatic correction - None.

Name/Code contains synonyms of
glossary terms

[if glossary enabled] Names and codes must not contain
synonyms of glossary terms.

• Manual correction - Modify the name or code to contain
only glossary terms.

• Automatic correction - Replaces synonyms with their
associated glossary terms.

Name/Code uniqueness Object names must be unique in the namespace.

• Manual correction - Modify the duplicate name or code.
• Automatic correction - Appends a number to the dupli-

cate name or code.
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File Checks
PowerDesigner provides default model checks to verify the validity of files.

Check Description and Correction

Name/Code contains terms not in glos-
sary

[if glossary enabled] Names and codes must contain only
approved terms drawn from the glossary.

• Manual correction - Modify the name or code to contain
only glossary terms.

• Automatic correction - None.

Name/Code contains synonyms of
glossary terms

[if glossary enabled] Names and codes must not contain
synonyms of glossary terms.

• Manual correction - Modify the name or code to contain
only glossary terms.

• Automatic correction - Replaces synonyms with their
associated glossary terms.

Name/Code uniqueness Object names must be unique in the namespace.

• Manual correction - Modify the duplicate name or code.
• Automatic correction - Appends a number to the dupli-

cate name or code.

Existence of external file location External file objects should have a valid path location.

• Manual correction: Define a valid path location
• Automatic correction: None

Replication Checks
PowerDesigner provides default model checks to verify the validity of replications.

Check Description and Correction

Partial replication A replica object is partially synchronized with its replicated object.

• Manual correction: Modify the list of replicated attributes from the replica-
tion property sheet

• Automatic correction: Enforces the replication of desynchronized attributes
of the replica object in the replication property sheet

Checking Glossary Compliance
When you enable the use of glossary terms for your object naming conventions, additional
model checks help you monitor glossary compliance for object names and automate the
replacement of unapproved synonyms with approved glossary terms. You can restrict the
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scope of your compliance efforts by disabling the checks for certain object types on a model-
by-model basis.

The following checks are enabled for all model objects when you select Use glossary for
autcompletion and compliance checking for your naming conventions (see Naming
Conventions on page 143):

Check Description and Correction

Name/Code con-
tains terms not in
glossary

[if glossary enabled] Names and codes must contain only approved terms drawn
from the glossary.

• Manual correction - Modify the name or code to contain only glossary terms.
• Automatic correction - None.

To disable this check for a given object type, clear its check box in the tree in the
Check Model Parameters dialog. To reduce its severity from Error to Warning,
right-click the check and select Warning. The check icon changes to a warning
sign.

Name/Code con-
tains synonyms of
glossary terms

[if glossary enabled] Names and codes must not contain synonyms of glossary
terms.

• Manual correction - Modify the name or code to contain only glossary terms.
• Automatic correction - Replaces synonyms with their associated glossary

terms.

To enable the automatic replacement of synonyms with approved glossary terms
for a given object type, right-click the check in the Check Model Parameters
dialog, and select Automatic Correction. A small overlay with a red cross
appears at the bottom-right of the check icon.

In addition, the following check is enabled for models and packages to allow administrators to
add terms used in object names to the glossary:

Check Description and Correction

List of missing
terms in object
names/codes in
package

[if glossary enabled] This special check lists all the terms that are used in the
names or codes of all the objects contained in the model or package.

• Manual correction - An administrator with write permission on the glossary
can double-click the line for this check in the Result List to open a merge
window in which you can select to add some or all of these missing terms, as
appropriate, to the glossary.

• Automatic correction - None.

Naming Conventions
You can use naming conventions to specify a case, maximum length, and valid characters for
object names and codes, and enforce compliance with an enterprise glossary. You can also
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invoke conversion scripts and conversion lists to generate appropriate object codes from
names (or names from codes).

To set naming conventions to control the names and codes of all objects, select Tools > Model
Options and click the Naming Convention node. To set naming conventions for a particular
kind of object, select its node under the Naming Convention node.

These options are available only on the Naming Convention node and apply to all objects:

Option Description

Use glossary for
autcompletion
and compliance
checking

Enables the use of the enterprise glossary in the model. When this option is
selected, auto-completion is enabled for object names and codes using the glos-
sary terms (see The Glossary on page 36), and additional checks are made to
ensure that all model objects use only approved glossary terms in their names and
codes (see Checking Glossary Compliance on page 142).

For information about administering the glossary, see Deploying an Enterprise
Glossary on page 541.

Display Specifies whether object names or codes appear in the Browser and on diagram
symbols. You can override this setting for diagram symbols by setting the ap-
propriate display preferences (see Display Preferences on page 206).
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Option Description

Enable name/
code conversions

By default, when you enter an object name, the object code is autogenerated by
applying the naming conventions specified on the Code subtab. Select this option
to additionally apply the conversion scripts and conversion tables specified on the
Name to Code tab (see Name and Code Conversion Scripts on page 146).

You can decouple an object's code from its name by clicking to release the =
button to the right of the Code field in the object property sheet and entering your
own code (which will still be subject to the naming conventions). You can au-
togenerate a name from a code by clicking the = button to the right of the Name
field.

These options are available on both the Name and Code subtabs of the Naming Convention
node (where they apply to all objects) and on each subnode (where they apply to the selected
object):

Option Description

Naming template Specifies a naming template to supply the naming conventions for the name or
code. A naming template contains the same fields as on this tab, but in a format
that can be reused for other objects (see Creating a Naming Template on page
146). Click the ellipsis button to the right of this field to open the List of Naming
Templates, or click the Properties tool to view and edit the selected template.

Maximum length Specifies the maximum number of characters permitted in a name or code. In a
PDM, you can set the maximum here and in the DBMS definition file. If you
specify both, then PowerDesigner applies the stricter constraint. For example, if
you set 128 here and the DBMS file specifies 30, PowerDesigner applies the 30
character limit.

Character case Specifies the case to apply to the name or code. You can choose between:

• UPPERCASE
• lowercase
• Mixed CASe
• Title Case (Name only)
• UpperCamelCase (Code only)
• lowerCamelCase (Code only)

Valid characters Specifies the list of characters permitted in the name or code. Enter character
ranges between single quotes, separated by a dash. Enter individual or multiple
characters between double quotes. Separate valid items by a comma. By default,
PowerDesigner allows the following valid characters for codes:

'a'-'z','A'-'Z','0'-'9',"_"
Select All valid to the right of this field to permit any character.
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Option Description

Invalid characters Specifies the list of characters not permitted in the name or code. By default,
PowerDesigner excludes the following characters for names:

"+-*/\.,!:;"
Select No accents to the right of this field to remove accents from accented
characters.

Default character Specifies the character that is used to replace any invalid characters that are
entered.

Creating a Naming Template
You can create a naming template to specify naming conventions for names or codes and reuse
it for multiple types of objects.

1. Select Tools > Model Options and click the Naming Convention node in the Category
tree.

2. Click the Ellipsis button to the right of the Naming Template field to open the List of
Naming Templates.

3. Click the Add a Row button and enter a name for the new naming template.

4. Click the Properties tool to open the template property sheet, complete all the appropriate
properties (see Naming Conventions on page 143), and then click OK to return to the list.

5. Click OK to return to the Model Options page.

Your template is now available for selection in the Naming Template field. Click the
Properties tool to the right of this field to modify the selected template.

Name and Code Conversion Scripts
Conversion scripts permit more complex transformations, including adding prefixes or
suffixes and the use of conversion tables. You specify the script on the Name to Code or Code
to Name tab, depending on which direction you want to perform the conversion.

Note: To enable the use of your conversion script, you must select Enable name/code
conversions in the upper part of the Naming Convention page of the Model Options dialog.
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The following options are available on each of these tabs:
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Option Description

Conversion script The default Name to Code conversion script is:

.convert_name(%Name%,"_")
This script takes the value of the Name field (represented by the GTL variable
%Name%) and generates a Code by replacing any nonalphanumeric characters
with an underscore.

It also calls a conversion table (if one is selected in the Conversion table field) to
perform conversions on specific strings encountered in the name or code.

You can modify the conversion script. For example, to insert the prefix tbl_
before the code of each table, use:

.convert_name(tbl_%Name%,"_")
If the stdnames conversion table is selected then, for a table with the name
Customer, PowerDesigner automatically provides a code tbl_CUST.

You can enter any valid GTL code (including macros such as .fore-
ach_part, .lowercase, .uppercase, .replace, and .de-
lete), but only the .convert_name and .convert_code macros
call a conversion table if one is selected.

For detailed information about GTL, see Customizing and Extending Power-
Designer > Customizing Generation with GTL .

Conversion table Specifies the conversion table to use to perform conversions on specific strings
encountered in the name or code (see Creating a Conversion Table on page
149).

PowerDesigner provides an example conversion table called
stdnames.csv. For example, an object name Customer_1 is trans-
formed into the object code CUST_1 if stdnames is selected.

To use your glossary term names and codes (see The Library on page 39) as a
conversion table, select glossary terms.

Apply name to
code conversion/
Apply code to
name conversion
to all objects

Applies the conversion script (and conversion table) when you click OK:

• To synchronized objects - those objects in which the object code is currently
synchronized with the name.

• To all objects - all objects in the model regardless of whether the object code
is synchronized with the name.

The option on the Code to Name tab always applies your changes to all objects in
the model.

Note: When generating one model from another, you can use name to code conversion to
provide appropriate codes for the target model objects (see the Convert Names into Codes
options on the Model Generation Options on page 436).
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Creating a Conversion Table
Conversion tables are .csv files containing a list of strings that may appear in object names
matched with equivalent (generally shorter) strings with which to replace them when
generating object codes.

For example, each instance of the word customer could be converted to cust. To review
the example conversion table provided with PowerDesigner navigate to and open
install_dir/Resource Files/Conversion Tables/stdnames.csv.

1. Select Tools > Resources > Conversion Tables to open the List of Conversion Tables.

To review an existing conversion table, select it in the list and click the Properties tool.

2. Click the New tool, enter a name and click Save to create the file and open the Conversion
Table dialog.

3. Click the Add a Row tool and then enter a name and the code into which you want to
convert it:

You can create as many conversion Name-Code pairs as required. The values in these
columns are not case-sensitive.

Note: It may be that several different names are converted the same code. For example,
client and customer may both be converted to CUST. If a table containing these lines
were used to convert codes to names, then the first value encountered in the Name column
is always used and there is a risk that multiple objects will be given the same name.

4. Click OK to return to the list of conversion tables, and then click Close to return to your
model.

Your conversion table is now available to be selected in the Model Options dialog.
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.convert_name and .convert_code Macros
These macros convert the object name to its code (or vice versa) and can search for and apply
values found in an associated conversion table.

Use the following syntax to convert a name to a code:

.convert_name (expression[,"separator"[,"delimiters"],case])

Use the following syntax to convert a code to a name:

.convert_code (expression[,"separator"[,"delimiters"]])

The following parameters are available:

Parameter Description

expression Specifies the text to be converted. For .convert_name, this is generally the %Name
% variable and may include a suffix or prefix.

Type: Simple template

separator [optional] Character generated each time a separator declared in delimiters is found
in the code. For example, "_" (underscore).

Type: Text

delimiters [optional] Specifies the different delimiters likely to exist in the input code or name,
and which will be replaced by separator. You can declare several separators, for
example "_ " and "-"

Type: Text

case [optional for .convert_name only] Specifies the case into which to convert
the code. You can choose between:

• firstLowerWord - First word in lowercase, first letters of subsequent
words in uppercase

• FirstUpperChar - First character of all words in uppercase

• lower_case - All words in lowercase and separated by an underscore

• UPPER_CASE - All words in uppercase and separated by an underscore

Examples

In this example, the template is applied to class name Corporate Customer:

.convert_name (cls_%Name%[,,,FirstUpperChar])
Result:

clsCorporateCustomer
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Examples

In this example, the template produces a list of column names before and after conversion:

.foreach_item(Columns)
 %Name%,
 .foreach_part(%Name%)
  .convert_name(%CurrentPart%,,,lower_case)
 .next()
.next(\n)
Result:

Column 1, column_1
 Column 2, column_2
 Column 3, column_3

.delete and .replace Macros
These macros delete or replace all instances of the given string in the text input.

.delete (string)
    block-input
.enddelete
.replace (string,new-string)
    block-input
.endreplace

The following parameters are available:

Parameter Description

string Specifies the string to be deleted.

Type: Text

new-string [.replace only] Specifies the string with which to replace string.

Type: Text

block-input Specifies the text to be parsed for instances of the string to delete or replace.

Type: Complex template

Examples Result

.delete(Get)
    GetCustomerName
.enddelete

CustomerName

.replace(Get,Set)
GetCustomerName
.endreplace

SetCustomerName
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Examples Result

.replace(" ", _)
Customer Name
.endreplace

Customer_Name

.foreach_part Macro
This macro iterates over the parts of a string divided by a delimiter using the special
%CurrentPart% local variable.

.foreach_part (input [,"delimiter" [,head [,tail]]])
    output
.next[(separator)]

The following parameters are available:

Parameter Description

input Specifies the text over which to iterate.

Type: Simple template

delimiter Specifies the sub-string that divides the input into parts. You can specify multiple
characters including ranges. For example [A-Z] specifies that any capital letter
acts as a delimiter.

By default, the delimiter is set to ' -_,\t' (space, dash, underscore, comma,
or tab).

Note: The delimiter must be surrounded by single quotes if it contains a space.

Type: Text

head [optional] Specifies text to be generated before the output, unless there is no
output.

Type: Text

tail [optional] Specifies text to be generated after the output, unless there is no output.

Type: Text

output Specifies the text to output for each part in the input.

Type: Complex template

separator [optional] Specifies text to be generated between each part of output.

Type: Text

For example:
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Examples

This template is applied to My class:

.foreach_part (%Name%)
%.FU:CurrentPart%
.next
Result:

MyClass

This template is applied to My class:

.foreach_part (%Name%,' -_',tbl_)
%.L:CurrentPart%
.next(_)
Result:

tbl_my_class

This template is applied to MyClass:

.foreach_part (%Name%,[A-Z])
%.L:CurrentPart%
.next(-)
Result:

my-class

Spell Checking
You can spell check your PowerDesigner models if you have MS Word 2000 or higher
installed on your machine, and if your system code page is consistent with the model
language. For example, for the spell checker to work properly on a Chinese model, your
system code page should be Chinese.

Note: You must enable the Spell Checker add in before use. To do so, select Tools > General
Options, click the Add-Ins category, and select the Spell Checker add in in the list, then click
OK to return to your model. To set preferences, select Tools > Spell Checking Options and
choose the model objects properties for which you want to check the spelling. If you select
Check sub-objects, then all the child objects of any object you check will also be checked.
You can also specify the dictionary language to use when spell checking.

1. Right-click an object or a model node in the Browser and select Spell Check. If an error is
found the Spell Checking dialog opens.

2. For each error, you can:

• Click Change to accept the suggested replacement word.
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• Type your own replacement and click Change
• Click Change All to apply the change to the entire object or model.
• Click Add to add the word to your custom dictionary

A message is displayed to inform you that spell checking is successful.

Extending Objects
PowerDesigner includes powerful tools to extend and customize your modeling objects.
Many extensions are defined in the resource files that are provided with PowerDesigner to
support a particular language or DBMS, and you can add your own to add new attributes and
attribute lists to objects, create entirely new objects, and customize object generation.

Note: Many extended attributes are displayed in standard or custom property sheet tabs, but if
any are not so assigned, an Extended Attributes tab will be displayed, listing all the extended
attributes in alphabetical order and giving their datatypes, values, and a column, [R]edefined,
in which the checkbox is selected if you have modified the attribute's default value.

For detailed information about working with extensions, see Customizing and Extending
PowerDesigner > Extension Files.

Adding New Properties to an Object
To quickly add new attributes and collections to an object or to customize its property sheet,
use the commands available from the property sheet menu. Extensions added to an object are
immediately available for all other objects of that type in the model.

Adding a New Attribute to an Object
The PowerDesigner metamodel specifies the attributes available by default for an object (for
example, name and comment). To quickly extend the metamodel and add a new attribute from
an object property sheet, click the menu button, and select New Attribute. The new attribute is
immediately available on all objects of this type.

Note: The definition of the new attribute is stored in a PowerDesigner extension file. For
detailed information about working with these files, see Customizing and Extending
PowerDesigner > Extension Files.

1. Open the property sheet of the object you want to extend, click the menu button, and select
New Attribute to open the New Attribute dialog:
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2. Enter a Name and Datatype for the new attribute and complete any other appropriate
fields.

3. [optional] Click Next to specify the property sheet tab on which you want the attribute to
appear. If you choose to create a new property sheet tab, you must enter a tab label to
display.
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By default, the attribute is inserted on the tab from which you launched the New Attribute
dialog, if the tab is editable.

4. [optional] If you want to view the new attribute in the PowerDesigner Resource Editor,
select the Open Resource Editor on Finish checkbox.

For information about working with the Resource Editor, see Customizing and Extending
PowerDesigner > PowerDesigner Resource Files

5. Click Finish to close the dialog and create the new attribute.

The attribute appears on the specified property sheet tab:
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Adding a New Collection to an Object
The PowerDesigner metamodel specifies the collections of related objects available by default
for an object (for example table columns or class attributes). To quickly extend the metamodel
and add a new collection from an object property sheet, click the menu button, and select New
List of Associated Objects. The new collection is immediately available on all objects of this
type.

Note: The definition of the new collection is stored in a PowerDesigner extension file. For
detailed information about working with these files, see Customizing and Extending
PowerDesigner > Extension Files.

1. Open the property sheet of the object you want to extend, click the menu button, and select
New List of Associated Objects.
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2. Enter a Name for your list. This name is used as the name of the property sheet tab on
which the list appears.

3. Select the type of associated object that you want your list to display. You can choose from
any of the object types available in your model.

4. [optional] To limit the objects of the selected type that your object can be associated with,
specify a stereotype that objects must bear in order to appear in the list.

5. [optional] If you want to view the new collection in the PowerDesigner Resource Editor,
select the Open Resource Editor on OK checkbox.

For information about working with the Resource Editor, see Customizing and Extending
PowerDesigner > PowerDesigner Resource Files

6. Click OK to exit the dialog and create the new list.

The list appears as a new tab in your property sheet, containing tools that let you associate
existing and new objects of the specified type with your object:

Customizing an Object Property Sheet Tab
The PowerDesigner interface includes a standard property sheet for each type of object. To
quickly customize a property sheet tab, click the menu button, and select Customize This
Tab. The customized tab is immediately available on all objects of this type.

Note: The definition of the customized tab is stored in a PowerDesigner extension file. For
detailed information about working with these files, see Customizing and Extending
PowerDesigner > Extension Files.
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1. Open the property sheet of the object whose property sheet you want to customize, select
the tab to change, click the menu button, and select Customize this Tab.

2. [optional] Modify the Name that will be displayed as the tab name.

3. Use the Add Attribute and Add Collection tools in the Form tab toolbar to add new
properties to your form. You can reorder controls in the form control tree by dragging and
dropping them.

For detailed information about these and other form tools and properties click the Help
button, or see Customizing and Extending PowerDesigner > Extension Files > Forms
(Profile).

4. Click OK to close the dialog and return to the modified property sheet.

Managing Extensions
To review your object extensions in the Resource Editor, select Manage Object Extensions
from the property sheet menu.

You can create basic new properties and lists using the wizards available from the property
sheet menu. To perform more advanced editing of extensions, you must open the appropriate
extension.

1. Open the property sheet of the object, click the menu button, and select Manage Object
Extensions.

2. Select the Extension file that you want to open from the list of files attached to the model,
or select <New> to create a new embedded extension file.

3. [optional] Select the checkbox to set the chosen extension file as the default. The default
extension file is used to contain the extensions created from the property sheet menu

4. Click OK to open the chosen extension in the Resource Editor.

For detailed information about editing these files, see Customizing and Extending
PowerDesigner > Extension Files.
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Customizing the Generation of Files for an Object
In PowerDesigner, you can define a generated file on a selected metaclass (or stereotype or
criterion), in this case a file is generated for each instance of the metaclass existing in your
model.

The generated files mechanism is defined in Customizing and Extending PowerDesigner >
Extension Files > Generated Files (Profile).

You can modify the default generation of files using artifacts. Artifacts are used to generate
files only for selected instances of a metaclass in order to:

• Design a source file that includes the code of several objects in a single file.
• Generate only for selected instances of a metaclass.
• Customize the generated file name and path.

C# and VB .NET Reverse Engineering Use Case
Artifacts are visible in the C# and VB .NET object languages. This is to support round-trip
engineering for these languages: when you reverse engineer C# or VB .NET code, each source
file in the source code becomes an artifact in PowerDesigner. The artifact allows you to re-
generate the same collection of objects while preserving file structure.

Using Artifacts in a Model
To be able to use an artifact in a model, you have to declare it in a resource file attached to your
model. You must create a template called "DefaultTemplate" under an artifact stereotype or
criterion bearing the name of the corresponding file type to generate.

In the C# resource file, if you expand the Artifact folder, you can see that the stereotype
"Source" and the template "DefaultTemplate" are defined by default. This means that when
you create a new artifact and assign the Source stereotype, this artifact inherits the default
template defined below:
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Example
You define the following artifact criterion in an extension:
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This criterion verifies that the last 4 characters of the artifact name are .TXT. You also need to
create the default template in order to define the content of the generated file. In this example,
DefaultTemplate is defined as follows:

This is a text file.

.foreach_item(ProductionObjects)
%ShortDescription%
.next(\n)

You can now create artifacts in the model using the New > Artifact command in the model
contextual menu. If you create an artifact with the .TXT extension and select the correct target
in the Template tab of the artifact property sheet, the default template is automatically
assigned to this artifact. This means that the short description of each instance of object
associated with the current artifact will be written in the generated file:
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You can now define instances of objects you want to include in the file generated from the
current artifact:
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Defining an Artifact
Artifacts can replace the standard generation of files; by default, an artifact generates the same
code as the generated file but only for selected instances of a metaclass.

An artifact has the following properties:

Property Description

Name Name of the artifact.

Comment Descriptive comment for the artifact.

Stereotype Sub-classification used to extend the semantics of an object without changing its
structure; it can be predefined or user-defined.

Encoding Allows you to modify the default file encoding of the files to reverse engineer.

An artifact definition also includes the following properties:

Property Description

Template Template used to generate the content of the generated file.

Objects List of objects associated with the current artifact.

Prerequisites List of artifacts that must be generated before the current artifact.

Preview Allows to visualize the generated code of the artifact.

1. Double-click the symbol of an object with generated files, for example a class in C#
language.

2. Click the Generated Files tab.

The Target column displays the resource file where the generated file is defined and the
File Type column displays the type of the generated file.

Each row in the list corresponds to a generated file type available for the current instance of
a metaclass, you can customize the generation of this file using an artifact.

3. Click the Create tool in the Artifact(s) column to add an artifact. This artifact will replace
the standard file generation for the current object.
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4. Click Apply and click the Properties tool to define artifact properties.

5. Click OK in both property sheets.

Managing Artifacts
Artifacts appear in the Artifact category of the Browser. You can perform the following actions
to customize an artifact. You can drag and drop authorized objects from the diagram or the
Browser onto an artifact in order to add the code of this instance to the artifact.

You can use folders to create an artifact hierarchy for generation by right-clicking the Artifact
category or a sub-folder and selecting New > Artifact Folder. You can create as many folder
levels as necessary and create or place artifacts at any level.

CHAPTER 4: Objects

Core Features Guide 165



Generated Files Tab
In the Generation dialog box, the Generated Files tab displays a checkbox tree with generated
files (with a dimmed icon) and artifacts. You can select or deselect the files you want to
generate.

You can modify generation options from this dialog box, and you can also check artifact
generation completeness: if an exclamation mark is displayed on the artifact icon it means that
one or several prerequisite artifacts are missing.

If you click the Enforce Dependencies tool in the upper part of the dialog box, the artifacts that
are prerequisites of other artifacts are automatically selected in the tree view in order to
properly generate artifacts.

Generate from an Artifact Folder
If you click the Generate command in the artifact folder contextual menu, a Generation dialog
box is displayed to let you manage the generation of a given artifact folder. This dialog box
also displays a checkbox tree with children artifacts of the selected artifact folder.
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You can enforce dependencies in the Generation dialog box to make sure all prerequisites are
selected for generation.

Applying Transformations to Objects
Transformations are used to perform generic modifications to your model objects. You can
apply transformations to your model as a sort of design pattern. You can design a pattern using
the transformation feature and play it in your model in order to modify objects. For example, in
an OOM, you could use a transformation to convert all analysis classes with the
<<control>> stereotype into components in order to add an implementation layer to your
model.

In order to apply transformations, you must have either defined transformation profiles in your
model's language definition file (for PDM, OOM, BPM, or XSM) or in an extension file (see
Customizing and Extending PowerDesigner > Extension Files > Transformations (Profile)).

Note: Pre- and post-generation transformations can be applied during model-to-model
generation (see Applying Pre- and Post- Generation Transformations on page 442). You can
only invoke post-generation transformations outside of a generation.

1. Select Tools > Apply Transformations.
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2. Select the profiles and transformations to be applied. If you deselect a profile, none of its
transformations will be executed. You can drag and drop profiles to modify the order of
execution of transformations.

3. [optional] Click the Selection tab and deselect any objects that you want to exclude from
the transformation.

4. Click OK to apply the transformations.

The object tree of the model is traversed from the model object down and, for each type of
object for which one or more post-generation transformation profiles is defined, each
profile is applied in the order in which they appear on the tab, with each transformation
being applied in the order in which they are defined in the profile.

Exporting Objects to Troux Semantics
The Troux Upload extension files provide a framework for mapping PowerDesigner metadata
to Troux Semantics domains. An extension file with the export mechanism is provided for
each type of PowerDesigner model along with instructions for how you can define mappings
to export your model objects in the Troux Upload XML format. Example mappings are
provided to map certain EAM objects to the Troux Application and Software domains

The extension files (along with developer and user documentation) are installed at
PD_install_dir\Resource Files\Extended Model Definitions
\Troux, and should be copied into the parent Extended Model Definitions
directory in order to be developed and used.
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CHAPTER 5 Diagrams, Matrices, and
Symbols

Most PowerDesigner models contain diagrams, in which your model objects are represented
by symbols. You can add a dependency matrix to any model to show relationships between
objects.

Diagrams
A diagram is a graphical view of a model or a package. All models and packages have at least
one diagram, and you can add additional diagrams as necessary. Objects can appear in
multiple diagrams, and their symbols can show different kinds of information in each
diagram.

For example, in a Publishing model, different diagrams could define the different activities
involved in this industry: the printing diagram, the sales diagram, the accounting diagram, the
book selection committee diagram.

When you save the model you also save all the diagrams it contains. You cannot save a diagram
separately.

Note: In requirements models (see Requirements Modeling), there are no diagrams, but rather
views.

Creating a Diagram or a Diagram from a Selection
By default, any model or package opens with a default diagram. You can create as many
diagrams as you want in a model or in a package. You can also select two or more symbols in an
existing diagram and create a new diagram from your selection.

You can create a diagram in any of the following ways:

• Select View > Diagram > New Diagram >  Diagam type . If you have previously selected
any object symbols, then the selected symbols will be copied into the new diagram.
Alternatively, if you have selected two or more symbols in a diagram, you can right-click a
selected symbol and choose Create Diagram from Selection.

Note: Since PowerDesigner objects can appear in multiple diagrams, the selected objects
are not duplicated in the Browser, but they are now present in both the original and the new
diagram.

• Right-click the background of your diagram and select Diagram > New Diagram >
Diagram type .
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• Right-click the model node in the Browser and select New >  Diagram type .

In each case you will be invited to specify a name, code, and optional comment for the new
diagram.

Diagram Properties
You can modify an object's properties from its property sheet. To open a diagram property
sheet, right-click its Browser entry and select Properties from the contextual menu, or right
click the diagram background and select Diagram > Properties from the contextual menu.

The General tab contains the following properties:

Property Description

Name Specifies the name of the item which should be clear and meaningful, and should
convey the item's purpose to non-technical users

Code Specifies the technical name of the item used for generating code or scripts, which
may be abbreviated, and should not generally include spaces

Comment Additional information concerning the diagram

Parent Specifies the name of the parent model or package

Stereotype Specifies a stereotype for the diagram. For example, a statechart diagram can serve to
model page flows in JSF and other web frameworks.

You can use a profile to provide special processing for diagrams and other objects
carrying stereotypes. For more information, see Customizing and Extending Pow-
erDesigner > Extension Files.

Page scale Sets a default display for page scale. The page scale percentage lets you define a page
size according to your modeling needs. If you have a lot of objects on several pages,
you can reduce the page scale percentage in order for all the objects to fit on a single
printable page

Default Dia-
gram

Diagram by default. This check box is automatically selected if the diagram is the first
created diagram

Opening and Viewing Diagrams
You can open a diagram from the Browser or from the View menu, and move between open
diagrams using the tabs above the canvas or by pressing Ctrl+Tab or Ctrl+Shift+Tab.

• Double-click the diagram entry in the Browser.
• Press Ctrl +D, or select View > Diagram > Select Diagram to open the Select Diagram

dialog box, select a diagram node in the tree and click OK.
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• To access diagrams beneath package or other composite object symbols:
• Select the Open Diagram tool from the Toolbox and click the symbol.
• Press Ctrl and double-click the symbol.
• Right-click the symbol and select Diagram > Open Diagram.

The following diagram viewing tools are available in the Toolbox or from the View menu:

Tool Description

Zoom In (F6) - Select the Zoom In tool and click anywhere in the diagram. The point
clicked on is centered.

Alternatively, you can select View > Zoom In, or turn your mouse scroll wheel away from
you while holding the Ctrl key.

To zoom in to a particular area, select the Zoom In tool and click and drag a rectangle
around the area to be displayed. When you release the mouse button, the diagram zooms
to the selected area.

Zoom Out (F7) - Select the Zoom Out tool and click anywhere in the diagram. The point
clicked on is centered.

Alternatively, you can select View > Zoom Out, or turn your mouse scroll wheel towards
from you while holding the Ctrl key.

View the whole diagram (F8) - Double-click the Global View tool or select View >
Global View.

[none] View actual size (F5) - Select View > Actual Size.

[none] View the current (printable) page (Ctrl+F10) - Select View > Page View > Current
Page.

[none] View all pages that contain symbols (F10) - Select View > Page View > Used Pages.
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Tool Description

[none] View all pages in the diagram - Select View > Page View > All Pages.

[none] Center on selected symbols - Select View > View Selection.

[none] Return to previous view (F9) - Select View > Previous View.

This and the Next View option allows you to toggle back and forth between various
selections and zooms you have used to navigate in your diagram, for example between a
limited view and a global view of the diagram.

[none] Go to next view (Shift+F9) - Select View > Next View.

[none] Refresh View (Shift+F5) - Select View > Redisplay.

Finding an Object Symbol in the Diagram
You can locate any object with a symbol in a diagram or among several diagrams using Find in
Diagram (or, for an RQM, Find in Document View). Objects without graphical symbol such as
domains cannot be found in the diagram.

If the object has only one symbol, the appropriate diagram is opened with the object symbol
centered. If the object has several symbols, a dialog box opens to allow you to select one.

This feature can be very useful if you are looking for the target object of shortcut symbols, as
you can access the target object from the shortcut property sheet and then locate the target
object in the diagram.

Find in Diagram (or Find in Document View) is available from:

• The Browser — Right-click an object in the Browser and select Find in Diagram (or Find
in Document View) from the contextual menu.

• The Result List — Right-click an object in the Result List and select Find in Diagram (or
Find in Document View) from the contextual menu.

• The object property sheet dropdown menu — Open an object property sheet and select
Find in Diagram (or Find in Document View) from the dropdown menu at the bottom-left
corner.

• An objects list — From an objects list, select an object in the list and click the Find Symbol
in Diagram tool in the list toolbar.

Specifying Diagrams as Related Diagrams
Related Diagrams are diagrams that provide additional information about an object. You can
use related diagrams to further define the behavior and implementation of objects and to view
them from different angles and in terms of semantic relationships. You can associate any type
of diagram open in the workspace with an object, including diagrams from other packages or
models, by opening the property sheet of the object and clicking the Related Diagrams tab.

The following tools are available to attach new related diagrams or work with existing ones:
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Tool Description

Properties - Opens the property sheet of the selected diagram.

Open Diagram - Opens the selected diagram.

Add Objects - Opens an object selection dialog to select diagrams and add
them to the list (see Adding an Item from a Selection List on page 118).

Create an Object - Creates a new diagram, which will be added to the list as a
related diagram. You must specify the location (model) and type of diagram to
create and give it an appropriate name.

Note: You can navigate to a related diagram from an object symbol by right-clicking the
symbol and selecting Related Diagram > Diagram Name. To create a new diagram and
associate it to the object as a related diagram, right-click the symbol and select Related
Diagram > New.

You can only attach related diagrams to objects that have a Related Diagrams tab in their
property sheet.

Deleting a Diagram
When you delete a diagram, you delete a view of a model or a package. This action does not
affect the objects in the model or package.

You can delete a diagram in any of the following ways:

• Select the diagram node in the Browser and press the Del key.
• Right-click the diagram window background and select Diagram > Delete from the

contextual menu.
• Select View > Diagram > Delete.

Printing Diagrams
You can print the currently selected diagram at any time. You can print the whole diagram, a
selection of pages, or a selection of objects.

Note: To print detailed information about model objects, create a model report (see 
Chapter 12, Reports on page 363).

1. [optional] Select symbols in the diagram in order to print them and exclude the others.

2. Select File > Print, or click the Print tool to open the Print Diagram dialog, which displays
default print options and the number of printed pages needed for the diagram.
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3. [optional] Specify the pages to print in the Page range groupbox or by clicking in the
Preview pane (see Print Diagram Options on page 174). Only pages with an overlaid page
frame will be printed.

4. [optional] Specify a page scale or set of pages to fit to (see Print Diagram Options on page
174). By default, diagrams are printed at 100% scale on as many pages as necessary.

5. [optional] Click the Page Setup button to open the Page Setup dialog and specify your page
layout (see Page Setup Options on page 175).

6. Click OK to start printing.

Print Diagram Options
You can preview the selection to be printed and specify various options in the Print diagram
dialog box.

Option Description

Number of copies Specifies the number of copies to print.
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Option Description

Page range Specifies which pages to print. You can choose between:

• All - Prints all the pages of the diagram.
• From / To - Prints a range of pages covered by the diagram. The corre-

sponding pages are framed in the Preview window.
• Selected - Prints the pages you select in the Preview window.

Number of pages Displays the number of pages required based on your zoom options.

Page scale Specifies the scale at which the diagram will be printed.

Fit to pages Reduces the scale of the diagram to print it on the number of pages specified,
for example 1x3. The Number of pages option is updated and the Center in
pages option is unavailable. To apply these changes to your diagram, select
Symbol > Fit to Page File and File > Page Setup for paper orientation.

Center in pages Centers the diagram in the pages that it covers. The Fit to pages option is
unavailable.

Frame Draws a solid line border around the image on all pages.

Corner Specifies the printing of crop marks in each corner to help align multiple
pages.

Mode Specifies whether the diagram will be printed in Black & White or Color.

Printer Select a printer from the Name list. Click the Page Setup button to modify
printer parameters.

Page Setup Options
The Page Setup dialog allows you to modify standard printer parameters, such as Paper,
Orientation and Margins, and to add various kinds of information to the Header, Footer and
Page of your printed diagram.

You can arrive at the Page Setup dialog by selecting File > Page Setup, or by clicking the Page
Setup button in the Print Diagram dialog (see Printing Diagrams on page 173).

The following fields let you specify the content of the header and footer:
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Option Description

Header Specifies the content of the page header. You can insert fixed text and use the arrow
button to the right of the field to insert one or more of the following variables:

• Current Date - inserts the date

• Current Time - inserts the time

• Current Page - inserts the content of the Page field

• Last Page - inserts the number of the last page

• Diagram - inserts the diagram name

• Location - inserts the file path

• Model - inserts the model name

• Package - inserts the package name

• Module - inserts the model type

• Application Name - inserts "PowerDesigner"

Footer Specifies the content of the page footer. You can insert fixed text and use the arrow
button to the right of the field to insert the same variables as for the page header.

Page Specifies the page number format to use in the header and footer. You can insert fixed
text and use the arrow button to the right of the field to insert one or more of the
following variables:

• Page Row - inserts the diagram pagination grid row number. This can be useful to
help assemble large diagrams printed on multiple pages. You may need to zoom
out to see the diagram pagination grid:

• Page Column - inserts the diagram pagination grid column number

• Page Number - inserts the standard page number
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Converting a Diagram to a Package
PowerDesigner lets you convert a diagram to a package. You can move all the objects in the
diagram to the new package or specify only certain objects. Other objects will stay in their
original package and be represented via shortcuts in the new package.

The linking objects that you move keep their links in the target package and a shortcut is
usually created in the source package. The general rule being that conceptual modeling must
be preserved.

Shortcuts creation rules in PowerDesigner also apply to moving objects between packages
(see Chapter 15, Shortcuts and Replicas on page 455).

1. Select View > Diagram > Convert to Package (or right-click the diagram background
window and select Diagram > Convert to Package or right-click the diagram node in the
Browser and select Convert to Package) to open the Convert Diagram to Package wizard.
By default the package takes the name of the diagram.

2. Click Next to open the Selecting Objects to Move page, which lists all the objects in the
diagram available to move to the new package. Objects are organized by object type, with a
sub-tab for each object type. By default, all the objects are selected.
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3. [optional] Deselect any objects you do not want to move to the new package. Objects
deselected here will remain in the original package and be represented in the new package
via shortcuts.

4. Click Finish to create the new package and move the selected objects to it.

The new package and diagram are added in the Browser.

Moving a Diagram to a Package
In some cases, you may want to move a diagram and some or all of the objects it contains into
another package or composite object, such as a process or activity.

The linking objects that you move with the diagram keep their links in the target package and a
shortcut is usually created in the source package. The general rule being that the design of the
original diagram must be preserved.

Shortcuts creation rules in PowerDesigner also apply to moving objects between packages
(see Chapter 15, Shortcuts and Replicas on page 455).

You can simply drag and drop the diagram from one package to another in the Browser to
move all the objects in the diagram to the target package. To control which objects are moved,
use the wizard.

1. Select View > Diagram > Move to Package (or right-click the diagram background
window and select Diagram > Move to Package or right-click the diagram node in the
Browser and select Move to Package) to open the Move Diagram to Package wizard.
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2. Select the target package to which you want to move the current diagram and click Next to
open the Selecting Objects to Move page, which lists all the objects in the diagram
available to move to the new package. Objects are organized by object type, with a sub-tab
for each object type. By default, all the objects are selected.
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3. [optional] Deselect any objects you do not want to move to the new package. Objects
deselected here will remain in the original package and be represented in the new package
via shortcuts.

4. Click Finish to move the diagram to the new package.

If the last diagram is moved or deleted from a package, a new diagram is automatically
created as all packages must contain at least one diagram.

Moving Entities Between Packages in a CDM
In a CDM, when moving entities containing data items from one package to another, different
rules apply depending on where the data items are used.

Data items Namespace Move result

Only used by selected en-
tity

Move within the same
namespace

The data items are moved with the entity.

Reused among different
entities

Move within the same
namespace

Shortcuts of data items are created for reused
data items.

Used only by one entity
or reused among differ-
ent entities

Change namespace The data items are copied in the other name-
space.

Dependency Matrices
You can create dependency matrices to review and create links between any kind of objects.
You can create an individual matrix from the Browser or define a matrix in a resource file for
reuse.

In the following enterprise architecture model (EAM) example, systems are listed along the
top of the matrix, and linked to the sites where they are in use, via traceability links:
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1. Right-click a model or package node in the Browser and select New > Dependency
Matrix to open the matrix property sheet to the Definition tab.

2. Select an object type from the current model to populate your matrix rows and an object
type from the current or another model type to populate the columns.

3. Specify how the rows and columns of your matrix will be associated by selecting a
dependency from the list.

In the following example, PDM tables are associated to users by the Owner dependency:

Only direct dependencies are available from the list. To specify a more complex
dependency, click the Advanced button to open the Dependency Path Definition dialog
(see Specifying Advanced Dependencies on page 182).

4. For certain dependencies, the Object type on which the dependency is based will be
displayed, and you can select an Object attribute to display in the matrix cells along with
the No value symbol, which is displayed if that attribute is not set in any particular
instance.

5. Click the General tab and enter a name for the matrix (for example Table Owners
Matrix).

6. Click OK to complete the definition and open your matrix.

Note: For information about defining a dependency matrix in a resource file (such as a DBMS
definition file, object language file or extension file) and for detailed information about its
properties, see Customizing and Extending PowerDesigner > Extension Files.
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Specifying Advanced Dependencies
You can examine dependencies between two types of objects that are not directly associated
with each other, using the Dependency Path Definition dialog, which is accessible by clicking
the Advanced button on the Definition tab, and which allows you to specify a path passing
through as many intermediate linking objects as necessary.

Each line in this dialog represents one step in a dependency path:

Property Description

Name Specifies a name for the dependency path. By default, this field is populated with
the origin and destination object types.

Dependency Specifies the dependency for this step in the path. The list is populated with all the
possible dependencies for the previous object type.

Object Type Specifies the specific object type that is linked to the previous object type by the
selected dependency. This field is autopopulated if only one object type is available
through the selected dependency.

In the following example, a path is identified between business functions and roles, by passing
from the business function through the processes it contains, to the role linked to it by a role
association:
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Working with Dependency Matrices
The dependency matrix displays the connections between the objects of the types specified in
your definition. You can add and delete connections in the matrix as well as filter the rows and
columns displayed and print or export the matrix.

In the following example, the same hierarchy of business processes is shown in the row and
column headers in order to analyze the dependencies between them:

You can modify the links in the following ways:

• To add a link, click in the appropriate cell, and then click the Create link button at the
bottom of the matrix (or press the Spacebar or V).

• To delete a link, click in a cell containing a link, and then click the Delete link button at the
bottom of the matrix (or press the Spacebar or Del).

• To select all the cells in a row or column, click the appropriate header. To select multiple
cells, rows, or columns, use the Ctrl key. To select ranges, use the Shift key or drag the
cursor over the required area.

The following tools are available above the dependency matrix:
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Tool Description

Properties – opens the property sheet of the object associated with the selected row,
column, or cell.

Copy – Copies the entire matrix for pasting into a CSV environment such as Excel or
a plain text file.

Select Rows/Columns (Ctrl + N) – Opens a selection box which allows you to select
rows and columns to display in the matrix either by hand or by defining a filter (see
Adding an Item from a Selection List on page 118).

Display only Non-Empty Rows/Columns (Ctrl+R) – Filters the display to show only
rows/columns that are populated.

Display only Empty Rows (Ctrl+E) – Filters the display to show only empty rows.

Vertical/Horizontal Column Header - Toggles between vertical and horizontal ori-
entation of column headers.

Shrink to Fit - Shrinks row and column headers to fit their contents.

Show Parents in Row Header - Displays the hierarchy of objects that are ancestors to
the row objects.

Show Parents in Column Header - Displays the hierarchy of objects that are ancestors
to the row objects.

Show Packages in Headers - Displays the hierarchy of packages that contain the row
and column objects.

Refresh - Refreshes the display of dependencies in the matrix.

Export to Excel - Exports the matrix as an MS Excel file. If the specified file already
exists, you will be given the option to overwrite it or append a new worksheet in the
file.

Note: You can modify the definition of the dependency matrix at any time by right-clicking its
Browser node, selecting Properties, and clicking the Definition tab.
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Symbols
PowerDesigner gives you wide control over the formatting and arrangement of your object
symbols.

• To change the format or content of a single symbol, right-click it and select Format (see
Symbol Format Properties on page 193) Use the commands Get Format and Apply
Format to copy the format of one symbol to another.

• To change the format or content of all the symbols in a diagram, select Tools > Display
Preferences (see Display Preferences on page 206).

• To arrange and manipulate groups of symbols, use the Symbol menu (see Aligning,
Ordering, Grouping, and Hiding Symbols on page 188).

The following symbol modes are available:

Mode Details

Icon: Most EAM and DMM objects support icon or picture symbols that
display a name or other limited information beneath them. To switch
between icon and detail mode, right-click the symbol and toggle the
Show Detail command.

To change any object symbol to an icon, select a Custom Shape of
type Bitmap in the Symbol Format or Display Preferences dialog.

Detail: All objects support detail symbols (rectangles or other shapes) that
can contain extensive information about the object inside the symbol,
including lists of sub-objects. To control the information displayed,
use the Content tab in the Symbol Format or Display Preferences
dialog.

Editable Composite: Many EAM objects (and CDM and LDM entities using the Barker
notation) support editable composite symbols that allow you to create
or drag and drop sub-objects on the symbol.

To switch between composite and detail mode, right-click the symbol
and use the Composite View submenu.

Read-Only Composite: Decomposed BPM processes and OOM activities and packages in all
types of models support read-only composite symbols that display the
object's sub-diagram. To descend into the sub-diagram for editing,
press Ctrl and double-click the symbol. To go back up to the parent
diagram, press Ctrl+U.
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Manipulating Symbols
You can select symbols in a PowerDesigner diagram using standard gestures. You can edit
properties of the selected symbol's object or it's sub-objects, and resize the symbol by clicking
and dragging on its handles.

Click on a symbol with the default Pointer tool to select it. To select:

• Additional symbols, press and hold Shift while clicking them.
• All symbols in an area, click and hold while dragging the pointer over the area.
• All symbols connected to a symbol, click the symbol and then select Edit > Select

Connected Symbols
• All symbols in the diagram, press Ctrl+A, click the Grabber tool, or select Edit > Select

All

In the following example, the Customer table is selected, and can be moved by dragging or
resized by dragging on one of its handles:

Note: To resize all the symbols in a diagram at once, click the Grabber tool and then drag one
of the handles.

When a symbol is selected, clicking on one of its object properties lets you edit its value. Now,
the table name is selected for editing:

When an object property is selected for editing, you can navigate through its editable
properties and on into its sub-object properties by pressing the Tab or Shift+Tab keys.

Note: You can control the object and sub-object properties that appear on a symbol using
display preferences (Tools > Display Preferences).
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When a symbol is selected, clicking on one of its sub-objects selects that sub-object. Now, the
Customer activity column sub-object is selected:

You can navigate up and down in the list of sub-objects by pressing the Up Arrow or Down
Arrow keys. When a sub-object is selected, clicking on one of its properties lets you edit its
value. Now the Customer activity column name is selected for editing:

To create a new sub-object at the end of the list, press Ctrl+N. To insert a new sub-object above
the selected sub-object, press Ctrl+I. To delete the selected sub-object, press Del. Right-
clicking a sub-object opens a contextual menu offering useful commands.

When a sub-object property is selected for editing, you can navigate right and left along the
line of its editable properties by pressing the Tab or Shift+Tab keys.

Note: The following kinds of properties are not editable via object symbols:

• Boolean properties, such as the Abstract property on OOM class symbols.
• Custom indicators, such as those used to identify keys and indexes on PDM table symbols.
• Certain calculated properties, such as Domain or Datatype on PDM table symbols.

Manipulating Link Symbols
You can add and remove corners to and from link symbols, and change the objects that they
connect.

1. Draw a link between two objects:
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2. Press Ctrl and click a point on the line to create a handle where you want to insert a corner:

3. You can add a second handle, or as many as you need:

4. To create a corner, click and hold the handle and then drag it to where you want the corner
to be:

5. You can drag the other handles too:

6. To remove a handle (and corner), press Ctrl and click on the handle to remove:

Note: To move an extremity of a link symbol from one object to another, click to select the
link, and then drag the end handle to the new object.

Aligning, Ordering, Grouping, and Hiding Symbols
The Symbol menu provides various options for formatting and arranging your symbols.

Menu Item Function

Format [Ctrl+T] Opens the Symbol Format dialog, which allows you to control appearance and
content of the selected symbols (see Symbol Format Properties on page 193).

Get Format Copies the format of the selected symbol, making it available for applying to other
symbols. Only available if a single symbol is selected.

Apply Format Applies the format copied with Get Format to the selected symbols.
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Menu Item Function

Shadow [Ctrl
+W]

Applies the standard shadow effect specified in the Symbol Format dialog to the
selected symbols.

Adjust to Text
[Ctrl+J]

Expands or shrinks the width of the selected objects to fit the length of their names.

Normal Size Applies the default size specified in Display Preferences to the selected objects.

Fit to Page Opens the Fit to Page dialog, which gives the number of pages currently used and
allows you to specify a display scale, the number of pages to use, or to center the
symbols on pages.

Auto-Layout Rearranges the symbols in the diagram (see Auto-Layout on page 190).

Align Provides various means for aligning the selected symbols (see Aligning Selected
Symbols on page 191).

Disposition Arranges the selected symbols in various ways:

• Horizontal [Ctrl+H]/Vertical [Ctrl+L] – Straighten selected link objects and
makes them horizontal or vertical where possible.

• Flip Horizontal/Flip Vertical – Reverses the relative positions of two or more
selected symbols. In the case where Table_1 is directly above Table_2,
selecting them and then choosing Flip Horizontal, will reverse their places so
that Table_2 is now directly above Table_1.

• Arrange Symbols – Spaces the selected symbols evenly.
• Arrange Connectors – Straightens the selected link symbols and centers their

endpoints in the objects that they connect.
• Arrange Attach Points - Centers the endpoints of the selected link symbols in

the objects that they connect.
• Arrange Attached Text – Reverts labels associated with the selected link

symbols to their default positions.

Order Promotes or demotes the selected symbols in relation to other overlapping sym-
bols in the diagram. You can:

• Bring to Front
• Send to Back
• Bring Forward
• Send Backward

By default, when you place a free symbol such as a note on a design object symbol
such as a table, the free symbol is placed behind the object, as free symbols are
usually used as backgrounds.

When symbols overlap, it may not be possible to select the symbol in the back-
ground, even if its handles are visible, without moving the symbol in front of it.
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Menu Item Function

Group Symbols Groups selected symbols, allowing them to be selected, moved, and resized as a
single block.

Ungroup Sym-
bols

Separates selected objects that were previously grouped together.

Hide Symbols Hides (makes invisible) the selected symbols. You may want to do this to make a
large model more readable, or to focus on only a particular part of a model.

Show Symbols Opens the Show Symbols dialog, which lets you select symbols in the diagram to
show or hide (see Showing and Hiding Symbols on page 192).

Protect Symbols Protects the selected symbols, making them impossible to select and edit.

Unprotect Sym-
bols

Unprotects the selected symbols, making them available to select and edit.

Auto-Layout
The auto-layout command automatically rearranges symbols in diagrams in order to simplify
the routing by minimizing node and link overlaps and reducing the distances between related
nodes.

Note: Auto-layout is not available for the OOM sequence diagram or any diagram containing
swimlanes.

1. Select Symbol > Auto-Layout to open the Auto-Layout window.

2. Only the styles relevant for the current diagram can be selected. Choose one of the
available styles:
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• Basic – Provides minimal rerouting for any diagram style.
• Hierarchical – Highlights the main direction or flow within a directed graph. You can

additionally specify an orientation for the flow within the graph.
• Organic – For undirected graphs.
• Orthogonal - For undirected graphs. You can additionally specify an orientation for the

flow within the graph.
• Circular – Produces interconnected ring and star topologies to emphasize group and

tree structures within a network. You can additionally specify a cycle or radiation
shape.

• Tree – For directed or undirected trees. You can additionally specify an orientation for
the flow within the graph.

3. [if you have selected one or more symbols] Specify if you want to apply the auto-layout to
all or only the selected symbols.

When applying Auto-Layout to a selection, you can additionally check the Move selection
to free space option to extract the selected symbols from the main body of the diagram and
place them in free space. PowerDesigner may create graphical synonyms (see Creating
Graphical Synonyms for Object Symbols on page 199) for certain symbols in (or
adjoining) the selection to minimize the length of connecting links.

4. Click OK to apply the auto-layout and return to the diagram.

Note: You can, at any time, click the Default button to revert to the default auto-layout
settings. Click the Set As Default button to set the currently selected style as the default.

Aligning Selected Symbols
The Alignment toolbar and Symbol Align submenu both provide multiple tools for aligning
symbols selected in the diagram.

Tool Action

Left - Aligns left borders of selected symbols with leftmost selected symbol

Center on vertical axis - Centers selected symbols on the most central selected symbol

Right - Aligns right borders of selected symbols with rightmost selected symbol

Same width - Stretches selected symbols to the width of the selection area (from the
leftmost symbol to the rightmost symbol)

Evenly space horizontally - Assigns equal space between three or more symbols on a
horizontal axis

Top - Aligns tops of selected symbols with topmost selected symbol

Center on horizontal axis - Centers selected symbols on the most central selected
symbol
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Tool Action

Bottom - Aligns bottom borders of selected symbols with lowest selected symbol

Same height - Stretches selected symbols to the height of the selection area (from the
topmost symbol to the lowest symbol)

Evenly space vertically - Assigns equal space between three or more symbols on a
vertical axis

Showing and Hiding Symbols
For PowerDesigner objects that have symbols, the symbol is automatically displayed in the
diagram when you create the object. Hiding some symbols can improve the readability of your
diagram. When you hide a symbol you do not delete it or the object.

To open the Show Symbols dialog, select Symbol > Show Symbols or right-click the diagram
background and select Diagram > Show Symbols:

Object symbols are organized by type in sub-tabs. If shortcuts, traceability links and/or free
symbols are present in the package, they appear on their own sub-tabs. You show and hide
symbols by selecting or deselecting them.

The following tools are available for selecting symbols:

Tool Description

Allows you to select objects from other packages to display them in the current diagram.

Selects all objects in the current tab. You can select all objects on all tabs by pressing the
Ctrl key as you click or by clicking the arrow and selecting All Pages.
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Tool Description

Deselects all objects in the current tab. You can deselect all objects on all tabs by pressing
the Ctrl key as you click or by clicking the arrow and selecting All Pages.

Moves all selected object to the top of the list

Moves all selected object to the bottom of the list

Note: To hide one or more symbols directly from the diagram, select them and then choose
Hide Symbols from the Symbol or contextual menu. To show a symbol without using the
dialog, drag the object from the Browser or another diagram into the diagram. If you drag the
symbol from another package or model, a shortcut to the object will be created in the
destination model.

When you hide or show links or objects with links, the following rules apply:

• Hide an object - Links attached to the hidden object are also hidden
• Show an object - Links attached to the object are shown if the object at their other extremity

is already visible.
• Show a link - The objects at both ends are also shown.

In a CDM, the following rules apply:

• Hide a parent entity - Inheritances for which the hidden entity is the parent are also hidden.
• Show an association - Entities and association links attached to the association are also

shown.
• Show an association link - Entities and associations attached to the association link are also

shown.
• Show an inheritance - Parent and child entities and inheritance links attached to the

inheritance are also shown.
• Show an inheritance link - Parent and child entities and inheritances attached to the

inheritance link are also shown.

Symbol Format Properties
You can change the size, line style, fill, shadow, font, alignment, shape and content of symbols
in the Symbol Format dialog. Some items may not be available if your modeling methodology
restricts the modification of symbol format or content.

You may arrive at the Symbol Format dialog when changing the format of:

• One or more individual symbols – select the symbols and then press Ctrl+T, select
Symbol > Format, or Format from the contextual menu.

• All symbols - via display preferences (see Display Preferences on page 206).
• Custom symbols defined for extensions – see Customizing and Extending PowerDesigner

> Extension Files.
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Note: When defining the format of custom symbols in the Resource Editor, each tab in the
Symbol Format dialog contains two additional options, Apply format to symbols, and
Allow users to modify symbol format , which allow you to control the default format of
symbols and whether users can modify them to a very fine degree. For more information
on these options, see Controlling the Format of Custom Symbols on page 197.

Size Tab
The Size tab controls the size of the symbol and how the size can be manipulated:

Property Description

Current size Specifies the width and height (in pixels) of the symbol.

Normal size [read-only] Specifies the default width and height (in pixels) for symbols of this
kind.

Auto-adjust to text
[Ctrl+J]

[Default] Auto-resizes the width of the symbol to display all the text it contains
up to the value specified for word wrapping in the diagram (see General Settings
Display Preferences on page 208).

This option is disabled if you select the Keep size preference or manually resize
the symbol and can be reapplied by selecting the symbol and pressing Ctrl+J.

Keep aspect ratio Maintains the ratio of height to width when manually resizing the symbol.

Keep center Maintains the center position of the symbol when resizing it.

Keep size Prevents the resizing of symbols through:

• Manual resizing

• The Auto-adjust to text preference (which is mutually exclusive with this
preference).

• The creation of sub-object symbols in editable composite symbols (see 
Using Composite View to Display Sub-Objects within a Symbol on page
198). Selecting this option prevents the symbol from growing to accomo-
date the addition of sub-symbols and may cause their display to be truncated
due to lack of space.

Line Style Tab
The Line Style tab controls the color, size and format of lines (for link and other one-
dimensional symbols) and borders (for two-dimensional symbols, such as classes or tables).
You can modify the line style of any symbol in the model.

Property Description

Color Specifies the color of the line or border.

Width Specifies the thickness of the line or border.
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Property Description

Style Specifies the format of the line or border, such as invisible, solid, dashed or
dotted.

Corners [Link and line symbols only] Specifies the format of corners, such as sharp or
rounded right-angles and free angles.

Arrow [Link and line symbols only] Specifies the format of the link or line symbol at its
Beginning, Center, and End.

Use perpendicular
arrow

[Link and line symbols only] Specifies that the link or line object always touches
objects at its ends at a right angle. This option allows you to use free angles for
the body of a link or line object, while retaining a connection at right angles for
its beginning and end.

Note: These options may be overridden by the design semantics of a link symbol (such as a
PDM reference).

Fill Tab
The Fill tab controls the color, content, and effects for symbol filling.

Fill effects Description

Fill color Specifies the color to use for the fill.

The Fill color check box is available for free symbols, packages, interaction frag-
ments, and swimlanes, and when cleared will create a transparent symbol. This can
be useful when you wish to use an "in-box" UML representation, for packages for
example.

Note that transparent objects can only be selected by clicking near their borders.

Image Specifies a graphic file to display within the symbol. Click the Modify button to
select a file.

Display Mode Specifies the alignment of the image within the symbol.

Gradient Specifies the gradient fill options. Click the Modify button to open a dialog al-
lowing you to control Start and End colors, End Color Luminosity, Shading Style
and Gradient Mode.

Shadow Tab
The Shadow tab allows you to add a standard, 3D effect or gradient shadow to objects in a
diagram.
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Font Tab
The Font tab allows you to define the display preferences for the font, size, style, and color of
text associated with symbols in the model. When you modify font preferences, they apply to
all existing and new symbols.

Text Alignment Tab
The Text Alignment tab allows you to define the alignment of text in text boxes and rectangles,
ellipses, rounded rectangles, and polygons.

Note: You can only control the text alignment for these shapes, and not for model object
symbols. When working with RTF, all the options but Vertical are disabled.

Parameter Description

Center Centers the text horizontally and vertically.

Word wrapping Auto-wraps text in the symbol.

Horizontal Aligns text to the left, center, or right on the horizontal axis.

Vertical Aligns text to the top, center, or bottom on the vertical axis

Custom Shape Tab
The Custom Shape tab allows you to define a new symbol shape for most non-link symbols.

Note: Custom shapes with the Content position set to Under cannot display collections or
attribute icons.

Property Description

Enable custom
shape

Enables or disables the customization of a symbol shape

Shape Type Specifies the type of shape to be used. Choose one of the following values, and
then click the Browse button to select an image (see Browsing for Images on page
200):

• Predefined symbol - Default shape assigned to symbols in PowerDesigner.

• Metafile (EMF, WMF) - Representation using geometrical formulas allow-
ing for resizing and stretching.

• Bitmap (DIB, RLE, JPG, JPEG, TIF, TIFF, PNG) - Representation of a
graphics image consisting of rows and columns of dots.

• Icon (ICO) - Small picture representing an object, usually smaller than
standard PowerDesigner symbols.
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Property Description

Shape Name List of the available shapes of the selected type. Click the Browse button to select
shapes.

Content position Specifies where the object name and any other properties should be displayed on
(or under) the symbol (Center option is not available for icon shapes).

Content Tab
The Content tab allows you to specify the information that you want to display on the symbol.
The properties that are listed on this tab as being available for selection are controlled by the
content display preferences (see Content Display Preferences on page 210).

Sub-Objects Tab
The Sub-Objects tab is only available when you open the Format tab after having selected a
single object. It allows you very fine control over the sub-objects (such as PDM table columns
or OOM class attributes and operations) that you want to display inside your object symbol.
For each individual sub-object, you can decide whether to display it or not, and what font to
use for its display.

Note: For a collection of sub-objects to be available for selection and customization here, the
collection must be selected for display in the object's content display preferences (see Content
Display Preferences on page 210). Where the number of lines to display for a collection is
limited in the display preferences, that limit will take precedence over any choices you make
here.

Each collection of sub-objects that is enabled in the display preferences has its own sub-tab.
For each sub-object, you can:

• Select to display or hide it in the parent object symbol by selecting or deselecting its
checkbox in the [D]isplay column.

• Apply a specific font to its display by clicking the Select font tool or the ellipsis button in
the Specific Font column.

Note: When not all sub-objects in a collection are selected for display, the parent object
symbol will display ellipses to indicate that more items are available.

Controlling the Format of Custom Symbols
When defining custom symbols for your object extensions, you may want to enforce certain
aspects of the symbol format, while allowing users some liberty to change others. If you open
the Symbol Format dialog from a custom symbol in the Resource Editor, you can control the
default format options for the symbol, and whether users can edit them, on a per-tab basis.

For example, you could extend the PDM table metaclass with a criteria to specify a custom
symbol with a red border for tables that are anticipated to contain more than 1m records. You
may want to enforce this border style for all such tables while allowing users to change the
font, size, content, and other aspects of the symbol format.
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When you access the Symbol Format dialog from a custom symbol in the Resource Editor,
the following additional options are available at the top of each tab:

Option Description

Apply format
to symbols

Specifies that the format options on the tab will be applied to custom symbols at
creation time or whenever the appropriate criteria are met or the specified stereotype
applied.

If this option is not selected, the standard display preferences for the format options
on the tab will be applied and users are free to modify them.

Allow users to
modify sym-
bol format

Specifies that users can modify the format options for the symbol and that any
changes that are made will be respected in the event that the definition of the custom
symbol is updated.

If Apply format to symbols is selected and this option is unselected, then the format
options specified on this tab cannot be changed by the user.

Click the Advanced button to open the Customize Content dialog to add or removed
properties from this tab (see Customizing Content Display Preferences on page 213).

For detailed information about extending objects and creating custom symbols for them, see
Customizing and Extending PowerDesigner > Extension Files.

Finding Symbols from the Browser, Object Lists, and the Result List
You can find all the symbols representing an object listed in the Browser, in a model list, or in
the Result List window by right-clicking the object and selecting Find in Diagram.

If the object has only one symbol associated with it, the appropriate diagram is opened in the
canvas with the symbol centered.

If the object has several symbols in the present package or there are symbols representing
shortcuts to the object (see Chapter 15, Shortcuts and Replicas on page 455) in other packages
or models open in the Workspace, the Select Symbol dialog opens listing all the available
symbols with their parent model and diagram. To show only the symbols in the present
package in this dialog, deselect the Show symbols from other packages option. Select a
symbol and click OK to open its diagram in the canvas.

Using Composite View to Display Sub-Objects within a Symbol
Many objects (packages, processes, classes, activities, states, EAM objects, etc.) have the
capability to display sub-objects within their symbols through one or more composite view
modes. Depending on the type of object, the sub-objects can be displayed either as a static
sub-diagram within the symbol or as dynamically editable symbols that you can create and
arrange directly from the parent diagram.

To toggle between the different composite view modes, right-click a symbol and select
Composite View and then one of the following commands:
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• None - display the parent symbol only without any sub-objects
• Read-only (Sub-Diagram) - display sub-objects in a non-editable sub-diagram that can be

resized as necessary. To access the sub-diagram, press Ctrl and double-click the symbol
• Editable - allow the creation and arrangement of sub-objects directly within the symbol in

the parent diagram.
• Adjust to read-only view - resizes the symbol to display all the objects in the read-only

view.

Note: Not all modes are available for all objects that support composite view. Certain objects
(for example, processes in the BPM) must be decomposed before you can access composite
view.

For information about the specific objects supporting composite view, see the appropriate
modeling guide.

Creating Graphical Synonyms for Object Symbols
Graphical synonyms let you depict an object more than once within a diagram. This can
improve readability by reducing the length or complexity of links when you have an object that
is linked to many other objects. You create a graphical synonym by right-clicking a symbol
and selecting Edit > Create Graphical Synonym. You can create as many graphical
synonyms as you want within the same diagram, including graphical synonyms of graphical
synonyms and of shortcuts. Each graphical synonym displays the name of the object followed
by a colon and the number of the synonym.

Note: A graphical synonym is merely a second symbol representing an object within the same
diagram. You can add the same object to other diagrams in the same package or model by
dragging and dropping it to them to create an ordinary symbol. If the object must be referenced
in another model (or in another package in the model), you need to create a shortcut (see 
Chapter 15, Shortcuts and Replicas on page 455).

In the following example, Employee : 1 and Employee : 2 both represent the
Employee table:

If you move an object for which you have created graphical synonyms from one package or
model to another, shortcuts are created for the graphical synonyms in the original package.

Note: To find any graphical synonyms of a symbol, right-click the symbol, select Edit > Find
Graphical Synonym, and then select a graphical synonym from the list. The graphical
synonym is centered and selected in the diagram window.

You can create graphical synonyms for link objects but only if both they and the symbols at
both their extremities (which will also be duplicated) support them. The following object
symbols do not support graphical synonyms:
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• CDM - inheritances and inheritance links
• OOM - swimlanes, synchronizations, decisions, transitions, instance links, messages,

association class links, and interaction frames, fragments, and references
• BPM - swimlanes, synchronizations, decisions, and flows
• All - free symbol line

Note: Though you cannot visually distinguish a graphical synonym of a link from a normal
link (unless you display the name attribute), when you select a link symbol, it is identified as a
graphical synonym in its tooltip:

Browsing for Images
The Select Image dialog lets you manage the images that you use in your model diagrams, and
to insert them into your models as object symbols, diagram backgrounds, etc.

1. Open the Select Image dialog in any of the following ways:

• Right-click a diagram symbol and select Change Image.
• From the Symbol Format dialog Custom Shape tab, click the Enable Custom Shape

check box, and then click the Browse button next to the Shape type property (see 
Symbol Format Properties on page 193).

• From the Symbol Format dialog Fill tab, click the Modify button in the Fill Effects
group box (see Symbol Format Properties on page 193).

• Select Edit > Import Image (see Importing and Exporting Model Graphics on page
218).
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2. Click a collection in the Collections pane to display its available images in the Images
pane.

The following tools are available for this pane:

Tool Description

Open Image File - Lets you browse to an image file to select it directly without
passing by an image collection.

Add Directory – Adds a directory to the list of collections. When you add a
directory, any sub-directories containing images are also added along with any
intermediate directories required to represent the directory tree.

Add Executable or DLL - Adds an executable or DLL and all the images
associated with it to the list of collections.

Remove Directory, Executable, or DLL – Removes a directory from the list of
collections. Predefined directories, such as Recent Images or Microsoft Office
Clip Art cannot be removed.

Up – Moves up a level in the collections tree.

3. [optional] In the Images tab, select an image type and/or dimension to filter by from the
Type and Dimension lists.

The following tools are available for this pane:
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Tool Description

Type Filters images by type, such as PNG, Bitmap, Cursor, etc.

Dimension Filters images by dimension, such as 16, 48, 128, etc.

Refresh Preview – Refreshes the list of available images.

Delete Recent Image – Deletes a selected recent image.

 0 Extra Large / Large / Medium / Small Icons – Change the display size of images
in the Images pane.

4. Select an image and click OK to return to the Symbol Format dialog or to display the image
in the diagram.

Searching for Images
You can search for images among your collections on the Search Images tab of the Select
Image dialog.

1. Specify the appropriate search criteria in the Search Criteria pane. You can specify:
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• Search for – Enter all or part of a filename to search against. Wildcards are
automatically applied so that for example, entering "ec" will return an image named
"vector.png".

• Type – Select the type of image to search for, such as PNG, Bitmap, Cursor, etc.
• Search in collections – Specifies the scope of the search by selecting or deselecting

collections to search in.

2. Click the Search button to display the result of the search in the Images pane.

3. Select an image in the Images pane, and click OK to return to the Symbol Format dialog or
to display the image in the diagram.

The Clear button resets the search criteria to the default values.

Decorative Symbols
Lines, ellipses, rectangles, and other decorative symbol tools available in the Toolbox have no
technical meaning, but can help with readability. You can use them to surround parts of a
model to, for example, distinguish domains of activity.

With each of the following tools, click and hold to draw, and release to complete the shape. To
resize a completed shape, click it and drag a handle.

Tool Description

Insert an area where you can write free notes

Draw either a graphical link between free symbols, a note link between a note and an object,
or a traceability link between objects (see Creating Traceability Links on page 431)

Title - A diagram title box retrieves from the model properties and displays such infor-
mation as: the model and the package to which the diagram belongs, the name of the
diagram itself, the author and version of the model and the date of modification.

If no Author is specified in the model property sheet, the user name specified in the Version
Info page is used.

You can choose to display the repository version number of the model or a user-defined
version number on the Title display preferences page.

Text - You can insert free text in your model independently of any shape, and can select and
move it like any symbol.

Line

Arc

Rectangle - Press Ctrl while drawing to create a square.

Ellipse - Press Ctrl while drawing to create a circle.
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Tool Description

Rounded Rectangle - Press Ctrl while drawing to create a rounded square.

Polyline - Release the mouse button at each point where you want to create a corner. Right-
click to finish.

Polygon - Release the mouse button at each point where you want to create a corner. Right-
click to finish and close the polygon.

Note: To add text to the symbol, double-click it to open an editor window. Lines and polylines
support the display of text at their center, source, and destination (see Text Editor Tools on
page 204).

To change the format of the symbol, right-click it and select Format (see Symbol Format
Properties on page 193).

Creating a Graphical Link Between Any Two Symbols
You can create a graphical link between any two symbols in the diagram. This link is purely
graphical and does not convey any semantics.

1. Select the Polyline tool in the Toolbox.

2. Click inside the first symbol and while continuing to hold down the mouse button, drag the
cursor to a second symbol. Release the mouse button inside the second symbol and right-
click.

A link is created. You can double-click the link symbol to open the Link Symbol Text
dialog box and edit the link.

Text Editor Tools
PowerDesigner provides an internal rich text format (rtf) editor, and supports the use of
external text editors.

The following tools are available on the editor toolbar (the Edit With command and various
formatting commands and tools are only available in RTF editors):
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Tools Description

Editor Menu [Shift+F11] - Contains the following commands:

• New [Ctrl+N] - Reinitializes the field by removing all the existing content.
• Open... [Ctrl+O] - Replaces the content of the field with the content of the selected

file.
• Insert... [Ctrl+I] - Inserts the content of the selected file at the cursor.
• Save [Ctrl+S] - Saves the content of the field to the specified file.
• Save As... - Saves the content of the field to a new file.
• Select All [Ctrl+A] - Selects all the content of the field.
• Find... [Ctrl+F] - Opens a dialog to search for text in the field.
• Find Next... [F3] - Finds the next occurence of the searched for text.
• Find Previous... [Shift+F3] - Finds the previous occurence of the searched for

text.
• Replace... [Ctrl+H] - Opens a dialog to replace text in the field.
• Go To Line... [Ctrl+G] - Opens a dialog to go to the specified line.
• Format... [Ctrl+M] - Opens a dialog to specify fonts and styles.
• Remove All Formats [Ctrl+L] - Removes all formatting from the content of the

field.
• Paragraph... [Ctrl+R] - Opens a dialog to specify paragraph indentation, spacing,

and alignment.
• Tabs... [Ctrl+B] - Opens a dialog to specify tab stop positions and alignment.

Edit With - Opens the content of the field in an external editor. Click the down arrow to
select a particular editor or Choose Program to specify a new editor. Editors specified
here are added to the list of editors available at Tools > General Options > Editors.

Save [Ctrl+S] - Saves the content of the field to the specified file.

Print [Ctrl+P] - Prints the content of the field.

Find [Ctrl+F] - Opens a dialog to search for text.

 Cut [Ctrl+X], Copy [Ctrl+C], and Paste [Ctrl+V] - Perform the standard clipboard
actions.

 Undo [Ctrl+Z] and Redo [Ctrl+Y] - Move backward or forward through edits.

Format [Ctrl+M] - Opens a dialog to specify fonts and styles.

 Bold, Italic, and Underline - Format the selected text.
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Tools Description

 Align Left, Align Center, and Align Right - Align the selected text.

Bullets - Indent and bullet the selected text.

Note: When editing free text on decorative symbols, use the radio buttons at the bottom of the
dialog to switch between

• Plain text - text formatting is controlled by the display preferences for free symbols
• RTF – text formatting can be controlled directly in the text input window

Display Preferences
Display preferences control the format of the symbols in your diagrams and the information
displayed on them. You can control the default display preferences for all objects, or set
preferences for all, selected, or new objects in the current diagram.

1. [optional] Select one or more symbols to which you want to apply format or content
changes. If you do not select any symbols, you can choose to apply any changes to all
objects or only to objects created after your changes.

2. Select Tools > Display Preferences to open the Display Preferences dialog.

3. Select an object in the Category list and change the preferences as appropriate in the right-
hand panel. The General Settings category controls preferences for the diagram as a whole
(see General Settings Display Preferences on page 208).

On each of the pages, you can, at any time click:
• the Default button, which reverts any changes to their default values
• the Set As Default button, which assigns the current values to defaults.

4. [optional] Click the Apply To button to open the Select Diagrams dialog, select the
diagrams to which you want to apply your changes, and click OK:
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You will be asked whether you want to apply your changes to all the symbols in the
selected diagrams. If you click:
• Yes – All existing and new symbols will reflect your changes to the Format, General

and Content display preferences.
• No – New symbols only will reflect your changes. Only the General and Content

display preferences are applied to existing symbols. The Format changes are canceled.
• Cancel – Your changes will not affect any symbols in any diagrams except the current

one.

In each case, you return to the Display Preferences dialog.

5. On the Display Preferences dialog box, click OK. The Changing Formats dialog box will
open:

The choices in this dialog apply only to the present diagram and will not override your
choices made in the Select Diagrams dialog.

6. Click OK to apply your changes
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Note: If you make changes in the Display Preferences dialog and these are not reflected in
some or all of the symbols in your diagram, this may be because of display constraints
enforced by your modeling methodology. For detailed information about how such
constraints are defined, see Customizing and Extending PowerDesigner > Extension
Files.

General Settings Display Preferences
The General Settings category allows you to control the overall look of the diagram.

The following preferences are available on the General tab:

Property Description

Window color Sets the background color for the diagram.

Unit Specifies the measurement unit for symbol size. You can choose between inches,
millimeters, and pixels.
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Property Description

Snap to grid Automatically aligns all objects in the diagram to the anchor points of a grid.
Control the visibility of the grid, and the number of anchor points per square inch
with the Display and Size options:

Show page de-
limiter

Displays lines showing the limit of pages on the diagram background.

Constrain labels Limits the distance to which you can displace labels from link objects. Uncheck
this option to be able to move link labels anywhere in your diagram.

Show bridges at
intersections

Creates a bridge (or "line hop") when two links cross to show that they do not
intersect. This preference has no effect on link symbols with free curve corners or
CDM association links.

Automatic link
routing

Calculates link paths to avoid crossing object symbols and to space links regularly.
You can manually move routed links, and the algorithm will respect your choices
and exclude such links from its calculations. To revert a manually moved link to its
automatically routed position, right-click it and select Reroute Link.

This preference has no effect on links with free curve or free angle corners, CDM
association links, or any links in EAM organization charts, BPM process hierarchy
diagrams, OOM sequence diagrams, or XSM XML diagrams.

Organization
unit swimlane

[diagrams with swimlanes] Specifies that organization units will be displayed as
swimlanes. You must also specify whether swimlanes have a Horizontal or Ver-
tical orientation.

Darken Child
Symbol

[diagrams with composite symbols] Specifies that the symbols of child objects are
darker than those of their parents in order to make them stand out more.

Orientation [diagrams with tree structures] Specifies whether branches expand in a Horizon-
tal (left to right) or Vertical (top to bottom) orientation.

The following preferences are available on the Word Wrapping tab:
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Preference Description

Word wrapping Controls the display of text on symbols and links. You can choose between:

• None

• Truncation - Truncates name (or code), to the specified length

• Word wrapping - Wraps name and code text onto additional lines (up to the
specified length) after the specified wrap character

This preference is overriden if you manually resize a symbol or link text label. To
reapply the wrapping specified here, select the symbol or link text label and press
Ctrl+J.

Wrap characters Specifies a set of characters after which word wrapping is possible.

Display overlay
for non-local ob-
jects

Enables the display of an overlay on objects being reused in the same container but
with distinct location. For instance an activity can be reused under another activity
of the same package or an inner class can be referenced by another class of the
same package. The overlay is a mirror image of the shortcut overlay (see Creating
Shortcuts on page 457).

The Format tab can be used to set the default size for all symbols in the diagram. Values
entered here can be overridden for specific objects on the Format tab for each object type (see
Format Display Preferences on page 212).

Content Display Preferences
The Content category allows you to control what information is displayed in object symbols.

You can modify the information displayed on each type of object by selecting it in the list.
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Choose the information that you want to display by selecting the appropriate checkboxes. You
can customize the properties that are available to be displayed by clicking the Advanced
button (see Customizing Content Display Preferences on page 213).

The following special preferences are available for certain objects that can act as containers
for other objects:

Preference Description

Default display mode Specifies the way the object will be displayed by default:

• Icon

• Detail – a rectangle permitting the display of additional information

This preference is only available if the object supports both modes.

Note: Multi-line fields and collections (such as table columns or class op-
erations) cannot be displayed in icon mode or on link symbols
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Preference Description

Detail mode Specifies the additional information that will be displayed in Detail mode:

• Comment – from the General tab of the object's property sheet

• [collections] – for example, sub-sites, applications, etc.

• Composite view - displays child objects as symbols within the object
symbol. If this option is present, it cannot (unlike the other preferences)
be removed from this screen

Format Display Preferences
The Format tab allows you to control the look of object symbols and provides a preview for
the preferences selected.

Click the Format tab of the General Settings category, to set the default horizontal and
vertical size of all symbols in the diagram containing text (measured in units of 1/7200 of an
inch).

For objects, click the Modify button to change the line style, fill, shadow, font, and custom
shape of symbols (see Symbol Format Properties on page 193).
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Customizing Content Display Preferences
Click the Advanced button in the bottom-right corner of an object's Content tab to organize
the information that is available for display on the symbol.

The list in the left hand pane shows the properties that are currently available to display on the
symbol in the Display Preferences dialog. In the case of link symbols the list contains three
sublists, Source, Center, and Destination, which allow you to specify different content to
display on each of these parts of the link symbol.

You can drag and drop items to reorder the list, and use the following tools to modify it:

Tool Description

Add Attributes – allows you to select additional attributes to add to the list (see Config-
uring the Display of Attributes on page 215).

Add Collections – allows you to select additional collections (such as table columns, class
operations, etc) to add to the list (see Configuring the Display of Collections on page
216).

Add Separator Line – inserts a separator line after the item selected in the list. Separators
added to horizontal layouts display as vertical lines.
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Tool Description

Add Exclusive Choice - inserts an item under which you can group properties from which
your users will choose one to display (see Configuring the Display of Exclusive Choices on
page 217).

Add Horizontal Layout - inserts a horizontal layout. To arrange attributes to display side
by side, drag them onto the horizontal layout in the list.

Add Vertical Layout - inserts a vertical layout. To arrange attributes to display one under
the other, drag them onto the vertical layout in the list. Vertical layouts are often used in
conjunction with a horizontal layout, to provide columns of attributes.

Delete – removes the selected item from the list.

The following options control the overall look of symbols:

Tool Description

Small
icon

Places a small object icon in the top-left corner of the symbol in detail mode.

Force
top
align

Forces top alignment in the symbol for object attributes, such as Name. If this option is not
selected, these properties are centered on the vertical axis.
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Configuring the Display of Attributes
An attribute is any single value property. To enable the display of an attribute, click the Add
Attributes tool, select attributes or extended attributes to display, and click OK.

Click on an attribute in the list to set the following options:

Option Description

Label Specifies a label to use in the Display Preferences dialog in place of the attribute's
name.

Prefix/Suffix [text items] Insert a prefix and suffix before and after the value of the attribute.

Alignment [text items] Specifies the alignment of the text.

True/False [booleans] Specifies a value to display for true and false. For example, for an
attribute Annotated, you could specify Annotated and Not Anno-
tated for true and false. By default, boolean properties are displayed if they are
true and do not appear if they are false.

Mandatory Specifies that the attribute must be displayed on the symbol, and is not available
for deselection in the Display Preferences dialog.
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Configuring the Display of Collections
A collection is a group of sub-objects or related objects. To enable the display of a collection,
click the Add Collections tool, select collections or extended collections to display, and click
OK.

Click on a collection in the list to set the following options:

Option Description

Label Specifies a label to use in the Display Preferences dialog in place of the collec-
tion's name.

List columns Specifies the properties displayed for each object in the collection. Click the
Select tool beside the field to select attributes for display.

Filters Specifies one or more filters to offer as radio buttons under the checkbox to select
the collection in the Display Preferences dialog. Click the Select tool beside the
field to open the Define Available Collection Filters dialog, enter a name for the
filter and then click the ellipsis button in the Filter Expression column to define
the parameters of the filter (see Defining a Filter Expression on page 116).

Mandatory Specifies that the collection must be displayed on the symbol, and is not available
for deselection in the Display Preferences dialog.

Limit number of
lines

Enables a field in the Display Preferences dialog allowing the user to limit the
display of collection members to the number that they enter.
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Option Description

Hide when empty Specifies that the symbol compartment containing the collection is hidden when
there is nothing to display.

Configuring the Display of Exclusive Choices
An exclusive choice groups two or more attributes in the Display Preferences dialog, from
which the user can choose to display one To add an exclusive choice, click the Add Exclusive
Choice tool, and drag attributes onto it.

Click on an exclusive choice in the list to set the following options:

Option Description

Label Specifies a label to use for the choice in the Display Preferences dialog.

Display Specifies whether the choice displays as horizontal or vertical radio buttons or as
a combo list.

Mandatory Specifies that the choice must be displayed on the symbol, and is not available for
deselection in the Display Preferences dialog.
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Importing and Exporting Model Graphics
You can import graphics to and export graphics from your PowerDesigner models.

To import an image into PowerDesigner, select Edit > Import Image to open the Select Image
window (see Browsing for Images on page 200), select an image and click OK to display it in
the diagram. Imported images are saved in the model.

To export one or more symbols from PowerDesigner, select them in the diagram and then click
Edit > Export Image to open a Save As dialog, select a format in the Save As Type list, enter
the filename and click OK.

You can export symbols in any of the following file type formats:

File type Extension

Enhanced Metafile EMF

Bitmap BMP, DIB, RLE

JPEG Compliant JPG, JPEG

Portable Network Graphic PNG

Graphics Interchanged Format GIF

Tagged Image File Format TIF, TIFF

Scalable Vector Graphics SVG

Note: If you export symbols or cut or copy them to the Clipboard, you must select Edit >
Export in Color to retain them in color.
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CHAPTER 6 The Free Model (FEM)

A free model (FEM) provides a context-free environment for modeling any kind of objects or
systems. You can use it to sketch simple visualizations or create entirely new forms of model
by defining your own concepts and graphical symbols through an extension file.

To create a new, empty FEM - Select File > New Model, and choose Free Model.

For information about extending objects from their property sheets, see Extending Objects on
page 154. For detailed information about all the extension mechanisms available in
PowerDesigner, see Customizing and Extending PowerDesigner > Extension Files.

Sketching Objects with the Free Model
You can quickly sketch a visualization of any concepts by creating extended objects in a free
model and giving them appropriate symbols.

1. [optional] Select Tools > General Options and select the Edit in place after creation tool
to allow you to name objects immediately after creating them without opening their
property sheets.

2. Select File > New Model, select Free Model, specify a model name, and click OK.

3. Use the Extended Object tool in the Free Diagram toolbox to create a basic object.
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4. Right-click anywhere in the diagram to drop the tool and then right-click on your object
and select Change Image to select a new image for the image (see Browsing for Images on
page 200).

5. Create additional objects as necessary and link them as appropriate using theExtended
Link tool.

Creating New Types of Model with the Free Model
You can define a set of extensions and attach them to a free model to model entirely new
concepts.

1. Select Tools > Resources > Extensions > Free Models.

2. Click the New button, enter an appropriate name, select to copy from the default template,
and click OK to open your extension file in the resource editor.

3. Right-click the Profile category, select Add Metaclasses, click the PdCommon sub-tab,
select the ExtendedObject metaclass, and click OK.

4. For each new concept that you want to define, right-click the ExtendedObject
metaclass and select New > Stereotype, enter an appropriate name, and select the Use as
metaclass and the Toolbox custom tool options.

Stereotypes with these options selected have their own object lists under the Model menu,
their own Browser categories and a tool to create them in the Toolbox

5. Right-click a stereotype and define extended attributes (new properties) and other
extensions under it as necessary.

For detailed information about working with extensions, see Customizing and Extending
PowerDesigner > Extension Files.

6. To model with your extensions, select File > New Model, select Free Model, specify a
model name, click the Select Extensions button, select your extension to attach it to the
model, and click OK.

7. Begin modeling with your new concepts. You can, at any time, double-click your
extension file in the Extensions category under your model in the Browser to modify
your extensions.
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CHAPTER 7 Comparing and Merging Models

PowerDesigner provides powerful tools for comparing models and merging them.

Comparing Models
You can compare the content of two PowerDesigner models or two resource files of the same
type at any time. You may want to compare models or resource files to review evolutions in
models or resources manipulated by different development teams or to evaluate the
differences that exist between the models or resources before merging them.

1. Select Tools > Compare Models to open the Select Models to Compare dialog box.

The current model is displayed in the Model 2 field.

2. Select a model to compare in the Model 1 list. Only models of the same type in the
workspace are available for comparison.

3. [optional] Click the Options button to open the Comparison Options window and specify
which objects and properties you want to include in the comparison (see Excluding
Objects and Properties from a Compare or Merge on page 230).

4. Click OK to open the Compare Models window, which displays the objects contained
within the models or resource files in a tree format, and highlights the differences between
them (see Reviewing Differences when Comparing Models on page 223). You can apply a
filter to simplify the list of differences (see Filtering Objects and Changes During a
Compare or Merge on page 232).

Reviewing Differences when Comparing Models
The Compare Models window displays the models to compare as two trees of objects in left
and right panes (with the model from which you launch the comparison on the right), and a
third pane at the bottom with three columns, listing each of the properties of the selected
object, and the values assigned to these properties in the two models.
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Explore the tree by opening nodes to reveal categories, objects, and sub-objects. To expand all
nodes, press the numpad star (*). To collapse all nodes, press the numpad minus sign (-).

The following types of differences can be detected during a comparison:

Symbol Description

Existence - The object is present in one model
(blue text) and absent in the other (greyed text and
icon).
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Symbol Description

Properties pane:
Modification (red warning triangle) - One or
more attributes of the object has different values
in each of the models. To review the differences in
properties, look for the red warning triangles in
the list of properties in the bottom pane.

Note: To open the property sheet of any object in
either model, right-click it in the tree and select
Properties.

Child Modification (yellow warning triangle) -
One or more sub-objects beneath the object has
differences.

Movement (green triangle with arrow) - The ob-
ject is in a different position in the collection or in
a different package. The normal icon and text
represent the object's position in the present mod-
el and the greyed text and icon represent its po-
sition in the other model. The green triangle be-
comes red if the object also has modifications.

Note: To go to the other instance of the object,
right-click it in the tree and select either Next
Occurrence or Previous Occurrence.

The following tools are available in this window:

Tool Description

Filter - Apply one or more of the predefined filters to control the types of differences that
are displayed (see Filtering Objects and Changes During a Compare or Merge on page
232).

Properties - Open the property sheet of the selected object.

Options - Open the Comparison Options dialog to control the types of metaclasses,
attributes, and collections that are displayed (see Excluding Objects and Properties from a
Compare or Merge on page 230

Manually Synchronize Two Objects - Select an object in either model and then click this
tool to link it to an object in the other model or to break such a link (see Repairing or
Breaking Links Between Objects on page 232).

First/Last Difference - Jump to the first or last difference in the tree.

Previous/Next Difference - Jump to the previous or next difference in the tree.
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Tool Description

Compare Preview - Open the Compare Preview window, which gives a list of the dif-
ferences in textual or list formats (see Previewing, Printing, and Saving Comparison
Results on page 233).

Merging Models
You can merge the content of two PowerDesigner models or two resource files of the same
type at any time.

1. Select Tools > Merge Models to open the Select Models to Merge dialog.

The current model is displayed in the To field.

2. Select a model to merge in the From list. Only models of the same type in the workspace
are available for merging.

Note: If you want to merge two PDMs, BPMs, OOMs or XSMs, you have to select two
models with the same target DBMS or language.

3. [optional] Click the Options button to open the Comparison Options dialog and specify
which objects and properties you want to include in the comparison and possible merging
(see Excluding Objects and Properties from a Compare or Merge on page 230).

4. Click OK to open the Merge Models window, which displays the objects contained within
the models or resource files in a tree format, and highlights the differences between them
(see Selecting Merge Actions on page 226). You can apply a filter to simplify the list of
differences (see Filtering Objects and Changes During a Compare or Merge on page
232).

5. Selecting the merge actions that you want to perform, and then click OK.
The Merge Models dialog box closes and the merge begins, with messages displayed in the
Output pane. A final message informs you that the models were successfully merged.

Selecting Merge Actions
The Merge Models window displays the anticipated result of your proposed merge as a tree of
objects, with check boxes to the left of each potential change to allow you to approve or reject
it. The properties pane lists each of the properties of the selected object, and allows you to
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select or reject the values proposed in the To column. Select or deselect actions as appropriate
and then click OK to perform the merge.

Explore the tree by opening nodes to reveal categories, objects, and sub-objects. To expand all
nodes, press the numpad star (*). To collapse all nodes, press the numpad minus sign (-). Use
the Show/Hide Source Model toggle at the top left of the pane to split the pane and display the
source model to the left of the target model.

The following types of merge actions can be approved by selecting or rejected by deselecting
the check box:

Symbol Description

(blue plus sign and greyed
text and icon)

Creation - The object is absent from the model to
be modified and present in the model to apply.

Selected: The object will be created.
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Symbol Description

(purple minus sign and blue
text)

Deletion - The object is present in the model to be
modified and absent in the model to apply.

Selected: The object will be deleted.

 (red equals sign)

Properties pane:

(red warning triangle)

Modification - One or more attributes of the ob-
ject has different values in each of the models. To
review the differences in properties, look for the
red warning triangles in the list of properties in
the bottom pane.

Note: Double-click a property to display differ-
ences in textual format between models. The val-
ue to be applied is in blue, preceded by >>, and

the value to be deleted is in red preceded by <<.

Selected (object): All values in the model to be
applied are copied to the model to be modified.

Selected (property): The value in the From col-
umn is applied to the model to be modified.

 (yellow warning triangle) Child Modification - One or more sub-objects
beneath the object has differences. Expand the
tree beneath the object to review and approve
these changes.

 (green circle with arrow and
greyed text and icon and green triangle with ar-
row)

Movement - The object is in one position in the
model to be modified (green circle with arrow and
greyed text and icon) and in a different position in
the collection or in a different package in the
model to be applied (green triangle with arrow).
The green triangle becomes red if the object also
has modifications.

Selected: The object is moved from the position
with the green circle to the position with the green
triangle.

Note: To go to the other instance of the object,
right-click it in the tree and select either Next
Occurrence or Previous Occurrence.

By default, merge actions are selected as follows:
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• During merge of unrelated models - all creation, modification and move actions are
selected, but deletion actions are deselected to preserve the superset of all objects in the
two models as far as possible.

• During check in/check out from the repository - based on when the latest changes were
saved in the model.

• When updating a generated model - based on whether changes have been made to the
generated model (if the Preserve modifications generation option is selected).

The following tools are available in this window:

Tool Description

Select/Deselect All - Select or deselect all merge actions. Click the arrow to the right of
the button to select or deselect all creation, deletion, modification, or move actions.

Filter - Apply one or more of the predefined filters to control the types of merge actions
that are displayed (see Filtering Objects and Changes During a Compare or Merge on
page 232).

Note: The filters control only what is displayed in this window. Even if an action is not
displayed, if it is selected, it will be applied when you click OK.

Properties - Open the property sheet of the selected object.

Options - Open the Comparison Options dialog to control the types of metaclasses,
attributes, and collections that are displayed (see Excluding Objects and Properties from
a Compare or Merge on page 230.

Note: The options control whether merge actions will be applied to objects. If you
exclude a metaclass, attribute, or collection, then it will not appear in the window, and no
merge actions will be applied to it.

Manually Synchronize Two Objects - Select an object in either model and then click
this tool to link it to an object in the other model or to break such a link (see Repairing or
Breaking Links Between Objects on page 232).

First/Last Difference - Jump to the first or last difference in the tree.

Previous/Next Difference - Jump to the previous or next difference in the tree.

Merge Preview - Open the Merge Preview window, which gives a list of the differences
in textual or list formats (see Previewing, Printing, and Saving Comparison Results on
page 233).
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Excluding Objects and Properties from a Compare or Merge
You can control what types of objects will appear in the comparison or merge window along
with the attributes and collections to compare for them through the Comparison Options
dialog. By default, all objects and properties are selected.

Note: When merging models, differences between the two models that concern deselected
metaclasses, attributes, or collections are disregarded, and will not be merged.

1. Click the Options button in the Select Models to Compare/Merge or the Compare/
Merge Models window.

The Comparison Options dialog lists Metaclasses in the left pane, and the Attributes
and Collections of the selected metaclass in the two right panes.

2. To exclude an attribute or collection from comparison, click on the name of the metaclass
in the left pane and then deselect the appropriate check boxes in the right panes.

For example, to exclude the Number ID attribute and Associated Business
Rules collection under the Process metaclass from comparison, click on the
Process metaclass name, and then deselect the relevant check boxes:

Metaclasses with one or more attributes or collections deselected have their check box
greyed.
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To exclude the same attribute or collection from every metaclass where it appears, right
click it and select Deselect for All Metaclasses.

You can select multiple metaclasses at once using the CTRL or SHIFT keys, in which case
only the attributes and collections available under all the selected metaclasses are
displayed in the right panes.

Note: To exclude all the properties (attributes and collections) of a metaclass from
comparison, deselect its check box in the Metaclasses list. Doing so will only exclude any
changes in properties from comparison, but will not exclude the metaclass itself and will
leave any creations or deletions to be detected.

3. To exclude a metaclass from comparison (both modifications of properties and creations
and deletions), click on the model metaclass name, and then deselect the check box of the
appropriate collection.

For example, in a BPM, to exclude the Data, Data Formats, and Data Items
collections from comparison, click on the Business Process Model metaclass, and
then deselect these collections:

To ensure that these metaclasses will not be considered, even if objects appear under a
package, right-click each collection and select Deselect for All Metaclasses.

4. [optional] Click the Set as Default button to save your exclusions as the default for future
comparisons or merges for this type of model.

5. Click OK to return to your comparison or merge dialog.
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Filtering Objects and Changes During a Compare or Merge
Click the arrow next to the Filter tool in the Compare or Merge window to select a filter to
apply to the object trees and display only certain types of changes, conflicts or, any
combination thereof.

The following filters are available:

• All Objects - [default] Remove all filters.
• All Changes - Show only objects that have some difference.
• Only Created Objects - Show only objects that will be created during a merge (or that are

absent from Model 2 in a comparison).
• Only Deleted Objects - Show only objects that will be deleted during a merge (or that are

absent from Model 1 in a comparison).
• Only Modified Objects - Show only objects that have differences between attribute

values
• Only Moved Objects - Show only objects that have moved in a collection or to another

package or parent. In the Advanced Filters dialog, you can distinguish between:
• Show Moved Objects (Parent Change) - When moving to a new parent, package, or

collection
• Show Changes of Position with Collection - When remaining in the same parent,

package, or collection. For example, when you change the order of attributes within the
same entity.

• Only Identical Objects - Show only objects that have no changes.
• Only Selected Objects - [merge only] Show only objects that have merge actions selected.
• Only Conflicts - [repository and generation merge only] Show only objects that have

conflicting modifications in both models A merge conflict occurs when the same object
has been modified differently in the origin and generated model or the local and
Repository model.

• Hide All Preservations - [generation merge only] Show only changes made in the origin
model since the last generation.

• Advanced Filters – Opens the Comparison Filters dialog, which allows you to combine
several filters

Repairing or Breaking Links Between Objects
Sometimes, when an object has been renamed or modified outside PowerDesigner, its link
with the corresponding object in another model may be lost, and the two objects are shown
independently, with a creation and a suppression in each model tree. You can manually repair
the link between the objects or, in rare cases, break a link between objects that you do not want
to compare or merge.
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Select the item for which you want to repair or break the link, click the Manually
Synchronize Two Objects tool, and select the object with which to pair it in the From or To
box as appropriate.

For example, if the Activities entity in your model needs to be link to the Activity
entity in the other model:

Problem Solution

Note: To break a comparison link, select an object that is linked to an object in the other model,
click the tool, and select None in the other field.

Previewing, Printing, and Saving Comparison Results
You can preview, save, and export the results of the comparison by clicking the Compare
Preview tool to launch the Compare Preview window.

This window provides three formats viewing the comparison results on the following tabs:

• Comparison Text – a textual representation of the differences between the models. This is
the most exhaustive format, and provides complete information about the whole object
tree. Select the Show Legend and/or Show Model Identification options to display
additional information at the beginning of the text.
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• Actions Description – a list of the actions that would need to be taken to render the models
the same. This will often be the most readable format as it represents each change in the
form of a sentence:
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• List – a columnar representation of the required actions. This format is the most easily
manipulated. You can sort by any of the columns, and export the list in a variety of formats
to allow for various kinds of transformation:

The following tools are available on each of the tabs:

Tool Description

Use Filter Filters the changes using the filter specified in the main window (see Filtering
Objects and Changes During a Compare or Merge on page 232). If no filter has
been specified before the preview is launched, then this option is not visible.

Print

Save - Saves the comparison in text format for Comparison Text and Actions
Description , and in XML, CSV, RTF, or HTML format for List.

The following columns appear on the List tab:
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Column Description

Action Type Specifies the type of action to perform. Can be any of the following:

• Create – creates an object
• Delete – deletes an object
• Modify – modifies an object
• Move Object – moves an object to a new parent
• Col Insert – inserts an object into a collection
• Col Remove – removes an object from a collection
• Col Move – moves an object from one position to another within a collection

Parent Specifies the parent of the object to be changed (the original parent, in the case of an
object that will be moved). For example, a class for an operation, or a diagram for a
symbol.

Type Specifies the type of the object to be changed.

Object Specifies the name of the object to be changed

Property Specifies the object property or collection to be changed. Empty for a Create, Delete,
or Move Object action.

Old Value Specifies the original value of the property to be changed. Empty in the case of a
Create or Col Insert

New Value Specifies the updated value of the property. Empty in the case of a Delete or Col
Remove.

For example, changing the datatype of attribute MyVariable from int to long would yield the
following column entries:

Action Type  Parent Type   Object  Property  Old Value  New Value
Modify   MyClass  Attribute  MyVariable  DataType  int    long
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CHAPTER 8 The PowerDesigner Plugin for
Eclipse

During your installation of PowerDesigner, you can choose to install a plugin to allow you to
use PowerDesigner within your Eclipse environment. The PowerDesigner plugin for Eclipse
is available for Eclipse v3.2 to v4.3.

The PowerDesigner plugin for Eclipse has the following limitations:

• You cannot use the Copy/Paste/Rename features available in the Eclipse contextual menu
for PowerDesigner resources.

• In the standalone PowerDesigner application, you can modify the source code of a class or
interface from its property sheet Preview tab. This feature is not available in the plugin for
Eclipse.

• You cannot export an Eclipse project containing PowerDesigner resources. If you want to
export a project, you must deselect any PowerDesigner resources on the File system page
of the Export wizard or the export will fail.

Note: The PowerDesigner plugin for Sybase Workspace, which is called Enterprise
Modeling, includes all the features of the standard PowerDesigner plugin for Eclipse. When
modeling within the Sybase Workspace environment, we recommend that you use the
Enterprise Modeling perspective.

Activating the PowerDesigner Perspective
Click the title bar of a view to make it active. (The title bar turns blue). The name of the active
perspective is shown in the title bar of the window and its icon is pushed-in in the shortcut bar.
We recommend you use the PowerDesigner perspective.

1. Click the Open a Perspective icon in the shortcut bar and select Other, or select Window >
Open Perspective > Other, to open the Select Perspective dialog box:
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2. Select PowerDesigner in the list of perspectives, and then click OK to display the
PowerDesigner perspective in the workbench window. The PowerDesigner perspective
contains the following components:

• Model Explorer – Equivalent to the standard PowerDesigner Browser. Allows you to
manage the objects you use to perform a modeling task. It displays your models and the
objects belonging to them in a tree view, and allows you to rapidly navigate between
them. The Model Explorer also has a tab that gives you access to a PowerDesigner
repository, where you can store all your models and associated files.

• Navigator - displays a tree view of all the resource files attached to Eclipse projects
open in the workbench window. These resource files can be model files, diagram files,
source code files, specification files, or any type of file. You can use the Navigator to
open models, create new projects and models, or even open object property sheets.

• Editor Area – Equivalent to the standard PowerDesigner canvas. The primary pane that
displays your present model diagram or report outline.

• Modeling Output - shows the progress of any PowerDesigner process, such as
checking a model or generating or reverse engineering a database.

• Modeling Result List - displays the results of a search or a model check.

Note: Once you have activated the PowerDesigner perspective, an icon to switch to it is
displayed in the shortcut bar. You can use the Window menu to open, customize, and reset this
and other perspectives.
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Manually Activating PowerDesigner Toolbars
Specific toolbars are available in the PowerDesigner perspective. If they do not appear, you
can activate them manually.

1. Select Window > Customize Perspective or right-click the toolbar section and select
Customize Perspective in the contextual menu, to open the Customize Perspective dialog
box.

2. Select the Shortcuts tab, and:

• Select New in the Submenus list, then select PowerDesigner in the Shortcut
Categories list, and select Model and Modeling Project in the Shortcuts list.

• Select Open Perspective in the Submenus list, and select PowerDesigner in
the Shortcuts list.

• Select Show View in the Submenus list, then select PowerDesigner in the
Shortcut Categories list, and select Model Explorer, Modeling Output,
Modeling Result List, and Tool Palette in the Shortcuts list.

3. Select the Toolbar Visibility tab, and select PowerDesigner Diagram,
PowerDesigner Standard and PowerDesigner View in the Tool Bar
Structure list.

4. Click OK.

The PowerDesigner toolbars that are common to all PowerDesigner modules appear.
Additional, module-specific toolbars will appear automatically when you open or create a
model.

Setting PowerDesigner Eclipse Preferences
The PowerDesigner plugin for Eclipse provides options to customize your environment.

1. In Eclipse, select Window > Preferences to open the Preferences dialog.

2. Select Sybase, Inc > PowerDesigner or Enterprise Modeling and set preferences as
appropriate:

Preference Description

Close diagram editors on exit By default, when you restart Eclipse, any diagrams that were
previously open will be automatically reloaded. Select this
option to prevent reloading.

Flag diagram editor as dirty if
parent model requires save

Select this option if you want to be reminded that a model has
been modified before you save the changes.

Automatically merge models on
code-to-model synchronization

Select this option if you want the merge process to be silent
during reverse engineering.

CHAPTER 8: The PowerDesigner Plugin for Eclipse

Core Features Guide 239



3. Click OK.

For information about the standard PowerDesigner options and preferences, see 
Chapter 9, Customizing Your Modeling Environment on page 249.

Creating a Modeling Project in Eclipse
You can create a modeling project in Eclipse to group together all your models and other
resources.

1. Select File > New > Project to open the New Project window:

2. Select PowerDesigner > Modeling Project in the list of Wizards and click Next to open
the PowerDesigner New Project window.

3. Specify the project name and location, and select the type of PowerDesigner project to
create. PowerDesigner project templates allow you to create projects that are already
populated with models and/or that contain matrices that help you to follow various
modeling frameworks, such as FEAF.

4. Click OK to create the project.

For detailed information about working with projects, see Chapter 3, Projects and
Frameworks on page 47.

Creating a Model in Eclipse
A model is the basic work unit in PowerDesigner. Every model is contained within a project,
and contains at least one diagram and any number of other objects. Though a model may be
split into packages for organizational reasons or may contain several diagrams, it remains the
fundamental basis for your modeling work.

1. Select File > New > Model to open the New Model dialog box.

2. Select a model type and specify whether you want to create an empty model or one based
on a template, then click Next to go to the Destination Container page.

3. Select a project or project folder in which to create the model. Use the buttons to create a
project (see Creating a Modeling Project in Eclipse on page 240) or folder if necessary, and
then click Next to go to the Model Definitions page.

4. Enter a name for your model and (for BPM, PDM, OOM, and XSM) select the target of the
model. Depending on the type of model, you may also need to specify the first diagram to
create.

5. Click Next to go to the Extensions page, and select any extension files that you want to
attach to the new model.
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6. Click Finish to create the model in your project in the Model Explorer, and open its default
diagram in the editor area.

Importing an Existing Model into Eclipse
To open an existing model you have to import it into Eclipse.

1. Select File > Import to open the Import dialog box.

2. Select Model in the list and click Next.

3. Type a model filename in the corresponding box or click the Browse button to select a
model from a selection dialog box.

4. Select the Create a linked resource check box if you want to associate the model to the
current project without copying the file to the project location.

5. Select an existing project or create a new project where to open the existing model and
click Finish.

The model default diagram is displayed in the Editor area.

Generating an Eclipse Java Project from an OOM
You can model the structure of your Java application (including EJBs, Servlets, and JSPs) in a
PowerDesigner OOM and then generate an Eclipse Java Project in which you will complete
the implementation of the classes, and from which you will compile, package, deploy, and
debug the application.

You can use the PowerDesigner plugin for Eclipse to enable round-trip engineering for Java
development:

• Perform high level analysis and design using PowerDesigner
• Design and create Java components in PowerDesigner
• Generate an Eclipse Java project containing the following files:

• A .project file - that defines the name of the project and the build commands

• A .classpath file - that defines the source directory, the binary directory and the
list of libraries

• Source files and other files
• A build.xml for Ant build script - to specify the necessary build tasks and libraries.

• Finish the implementation of Java classes within the generated Eclipse project
• Compile, package, deploy and debug the application
• Reverse engineer the final Java code to synchronize the PowerDesigner model

1. Select Tools > General Options and click the Variables category, then add the following
variables if they are not already present:

CHAPTER 8: The PowerDesigner Plugin for Eclipse

Core Features Guide 241



• ECLIPSE_HOME - your Eclipse home directory
• J2EE_HOME - your J2EE SDK home directory
• JWSDP_HOME - [optional] your Java Web Service Developer Pack home directory

2. [optional] Preview the Eclipse .project, .classpath and Ant build.xml files by
right-clicking the model node in the Browser and selecting Properties. Each of the files is
available on its own sub-tab on the Preview tab of the property sheet.

3. Select Language > Generate Java Code to open the Generation dialog.

4. Enter the project folder where you want to generate the files in the Directory field. The
name of this folder will be used as the project name.

5. Verify that Eclipse is selected on the Targets tab.

6. [optional] Click the Selection tab and specify the packages, classes and interfaces that you
want to generate. By default, all objects are generated.

7. Click the Options tab and review the generation options, including those that control the
Eclipse version to generate for and whether to overwrite existing .project
and .classpath files.

8. [optional] Click the Generated Files tab and specify which files will be generated. By
default, all files are generated

9. Click OK to generate the Eclipse Java project.

If you are generating a new project from the PowerDesigner plugin for Eclipse, the project
opens automatically.

When generating code for an existing project, you must refresh the project by right-
clicking the project in the Eclipse Package Explorer and selecting Refresh.

If you have generated the Eclipse project from outside Eclipse, you will need to import the
project into Eclipse by selecting File > Import.

Synchronizing an OOM with Its Java Source
You can synchronize an Object Oriented Model (OOM) with its Java source code, so that each
time you modify the model, a source code file is automatically created or updated, and when
you modify and save a source code file, the changes appear in the model. Synchronization is
only available for Java OOMs.

You can activate synchronization from the Model Explorer or Navigator. A model is
synchronized per package.

Note: You can only synchronize each package with one set of source files and each set of
source files with one package. If you try to synchronize a second model with a package, its
check box is unavailable.

1. In the Model Explorer, right-click the model and select Synchronize, then select the
Synchronized check box:
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Note: You can, alternatively, enable synchronization from the Navigator by right-clicking
the model, selecting Properties, selecting PowerDesigner in the left pane and the
Synchronized check box in the PowerDesigner page.

2. Select the packages you want to synchronize with their source code. The default package
regroups all the objects at the root of the model.

3. Click Finish.

In the Navigator, the model bears a synchronized label, each synchronized package bears a
synchronized symbol overlay, and a Java file (.java) and compiled file (.class)
appear for each synchronized object:
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You can double-click a Java or compiled file, to display its source code in the Editor view.

Example: Modifying Attributes in a Synchronized Model
This example is developed from the example synchronized OOM, demo.oom, and
demonstrates the creation and deletion of attributes in a synchronized model.

Note: If you change generation templates, you can regenerate source code manually by right-
clicking a class, interface, synchronized package, or model, in the Model Explorer or in a class
diagram, and selecting Refresh Source Code.

1. Open the property sheet of the printer class, click the Attributes tab, and add a
usbPort attribute with a boolean data type and public visibility.
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2. Click OK to return to the class diagram, where the usbPort attribute is displayed in the
printer symbol:

3. Right-click the printer symbol or the printer item in the Model Explorer and select Edit
Source Code to open the source code file of the printer class in a pane directly under the
diagram:
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Note that the usbPort attribute is displayed in the synchronized source code.

4. Delete the code concerning the usbPort attribute.

5. Select File > Save in the Eclipse menu bar.

The usbPort attribute disappears from the printer symbol because the printer class in the
OOM has been synchronized with its source code.
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Deactivating Synchronization
If you decide to deactivate synchronization, the model and its source code remain as they were
after the last synchronization.

You can deactivate synchronization:

• In the Model Explorer, by right-clicking the model and selecting Synchronize,
unselecting  Synchronized, and clicking  Finish.

• In the Navigator, by right-clicking the model and selecting Properties, unselecting
Synchronized in the PowerDesigner page, and clicking OK.

• In the Navigator, right-clicking a synchronized package and selecting Unsynchronize.

Navigating Between an OOM and Its Java Source Code
Once you have synchronized an OOM with its Java source code, you can find its diagram
symbols and open its property sheet from the Model Explorer, the Navigator, or source code
files.

To locate an object symbol in a diagram:

• In the Navigator, right-click an object Java file and select Find In Diagram.
• In Outline view, select an object to automatically find in diagram.

Note: To open the Outline view, select Window > Show View > Outline.

• Double-click the name of an object in a source code file in order to select it, then right-click
the object name and select Find In Diagram.

To open an object property sheet:

• In the Navigator, right-click an object Java file and select Model Object Properties.
• Double-click the name of an object in a source code file in order to select it, then right-click

the object name and select Model Object Properties.
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CHAPTER 9 Customizing Your Modeling
Environment

PowerDesigner is highly customizable. You can modify its interface to suit your work habits,
set default naming conventions, change the appearance of object symbols, add new properties
to objects, and even create your own types of objects.

Note: Administrators can prepare customizations to the PowerDesigner interface and push
them to users (see Chapter 20, Customizing the PowerDesigner Interface on page 553).

User Profiles
User profiles help you to standardize the look and feel of your models and to support standards
by making groups of options and preferences portable for sharing and reuse across your
organization. Various user profiles are provided with PowerDesigner, and you can create your
own.

Various kinds of PowerDesigner options and preferences are stored in your model files and/or
in your Windows registry. User profiles can contain default values for:
• Display Preferences – [model or registry] to control the color, shape, size, etc. of your

diagram symbols and the information that is displayed upon them (see Display
Preferences on page 206).

• Model Options – [model only] to control naming conventions (see Naming Conventions
on page 143), case sensitivity, notation, default values, etc (see the appropriate modeling
guide).

• General Options – [registry only] to control dialog preferences, environment variables,
fonts, etc (see General Options on page 255).

• Other options – [registry only] such as the layout of toolbars and windows (see Organizing
Views on page 268), favorite property tabs (see Customizing a Property Sheet on page
99), default columns for object lists (see Customizing Object List Columns and Filtering
Lists on page 113), etc.

Note: An administrator can prepare customized preference profiles, which are made available
to users on their first connection to the repository (see Controlling Defaults for Options and
Preferences on page 566).

To view the list of user profiles, select Tools > Resources > User Profiles. For information
about the tools available in resource file lists, see PowerDesigner Resource Files on page
272.

User profiles can contain any number of default preferences and options, the application of
which is cumulative. Thus, if you apply a user profile that contains display preferences
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specifying that PDM table symbols are by default red, and view symbols blue, and then apply a
second user profile that sets tables by default to green, then table symbols will be green, and
view symbols blue. You can, of course, override these default preferences and options locally
in the model.

Applying a User Profile
You can apply a user profile at any time. The defaults, preferences, and options contained
within the profile will overwrite the existing values for those defaults, preferences and
options, while leaving all others unchanged. Note that while general options take effect
immediately, model options and display preferences only take effect when you create a new
model.

Note: To return to a default user profile prepared for you by an administrator(see Controlling
Defaults for Options and Preferences on page 566), select the General Preferences
entry in the Personal Profiles category. To return to your default UI profile, select the UI
Preferences entry.

1. Select Tools > Apply User Profile to open the Apply User Profile dialog:

2. [optional] Click the Change User Profile Directory button, and browse to a folder where
you have saved user profiles. By default they are saved in the install_dir/
Resource Files/Profiles directory.

3. Select a profile from the list and click OK.

The user profile is applied, and overwrites the defaults, preferences, and options contained
within it with the values it defines.
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Creating a User Profile
You can create a user profile by copying an existing profile, or by copying values from an open
model or from your registry.

1. Select Tools > Resources > User Profiles to open the List of User Profiles:

The following tools are available above the list:

Tool Description

Properties – opens the selected profile in the resource editor.

New – creates a new profile.

Save – saves the selected profile.

Save All – saves all the profiles.

Path – Specifies a directory from which to populate the list.

Compare – Opens the Compare window to compare the structure of two profiles.

Merge – Updates the selected profile by merging preferences from another profile, a
model, or the registry (see Updating a User Profile on page 252).

Check In - [if the repository is installed] Checks the selected resource file into the
repository. For information about storing your resource files in the repository, see 
Sharing Resource Files via the Library on page 551.

Update from Repository - [if the repository is installed] Checks out a version of the
selected file from the repository to your local machine.
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Tool Description

Compare with Repository - [if the repository is installed] Compares the selected file
with a resource file stored in the repository.

Apply to Registry – Applies the selected profile to your registry, overwriting your
previous defaults and preferences. This has the same effect as selecting Tools > Apply
User Profile (see Applying a User Profile on page 250).

2. Click New to open the New User Profile dialog:

3. Enter a name for your profile and select a source from which to copy from. You can choose
between:

• Another user profile – makes a copy of the existing profile.
• <Registry> - copies all your PowerDesigner defaults from your Windows registry.
• <Model> - opens the Model for User Profile dialog which allows you to specify the

preferences to copy from an open model (see Copying Preferences from a Model on
page 253).

4. Specify a name and a location to create the profile and click Save.

The user profile is created and opened for review in the resource editor.

Updating a User Profile
You can update a user profile by copying values from an existing profile, from an open model,
or from the registry.

1. Select Tools > Resources > User Profiles to open the List of User Profiles, select the
profile to update and click the Merge tool to open the Select User profiles to Merge dialog.

2. In the From field, select a source from which to copy from. You can choose between:

• Another user profile
• <Registry> - copies all your PowerDesigner defaults from your Windows registry.

Note that model check options and generation options are not stored in the registry and
can only be extracted from a model or another user profile.

• <Model> - opens the Model for User Profile dialog which allows you to specify the
preferences to copy from an open model (see Copying Preferences from a Model on
page 253). Note that general options, and options relating to the PowerDesigner
interface (such as toolbar and window layout, favorite property sheet pages and grid

CHAPTER 9: Customizing Your Modeling Environment

252 SAP Sybase PowerDesigner



layouts) are not stored in models and can only be extracted from the registry or another
user profile.

3. Click OK to open the Merge window, which lets you review and approve each proposed
change before committing it. For detailed information about using this window, see 
Chapter 7, Comparing and Merging Models on page 223.

4. When you are satisfied, click OK to update the profile and return to the list.

Copying Preferences from a Model
You can create or update a user profile by copying preferences from a model.

Select which model open in the Workspace to copy from and then select which of the
following options and preferences to capture:

• Model Options
• Generation, and other options.
• Diagram Display Preferences - Select the diagrams to copy preferences from in the tree. To

avoid conflicts, you can only select one instance of each diagram type.

Reviewing and Editing User Profiles in the Resource Editor
You can open any user profile in the Resource Editor to review and edit it. Since the registry
key names and values are not necessarily easy to read, we recommend that you restrict your
edits in this environment to deleting unwanted defaults. You can always make additions or
adjustments to the values of user profiles by extracting them from models or other profiles.

In the following example, the Corporate user profile contains display preferences for CDMs,
LDMs, and PDMs, along with a general option and some model options:
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To delete an item, simply right-click it and select Remove.

The profile root node has the following properties:

Property Description

Name/Code Specifies the name and code (used for scripting) for the profile.

File name [read-only] Specifies the path to the profile file.

Family Specifies the family in which the profile will appear in the Apply User Profile
window (see Applying a User Profile on page 250) and if it is added to the Power-
Designer installer image. If no value is entered, the profile is added to the General
family.

Subfamily Specifies a subfamily within the profile family.

Making Custom User Profiles Available in the PowerDesigner Installer
Once you have developed your own user profiles, you may want to add them to your
PowerDesigner install image in order to allow your users to install them when they install
PowerDesigner.

The user profiles that are installed with PowerDesigner are stored in the following directory on
the first install CD:
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Setup/User Profiles

To include your profiles in the install, simply copy them to this directory in your install image.

For information about installing PowerDesigner, see Installation Guide > Installing
PowerDesigner.

General Options
You can control the look and behavior of the PowerDesigner interface through the general
options, the values for which are saved in the registry of your local machine.

To set general options, select Tools > General Options. The following options are available
under the General category:

Option Description

Autosave Save recovery backup file every x minutes - Instructs PowerDesigner to save
changes to all open models to a recovery backup file at the specified interval.
Enabling this option provides you with a recovery option if PowerDesigner or
your computer crash before you have had a chance to save your changes.

The save will take place after the interval has passed, but only when Power-
Designer is idle for more than ten seconds. Note that saving large or multiple
models may take several seconds, and that PowerDesigner will not be respon-
sive while it is performing the save.

In the event that your modeling session exits abnormally, when next you open
PowerDesigner you will be invited to restore your unsaved models. You can
choose:

• Yes - to open the recovered models in the Browser allowing you to review
and save or delete them as necessary.

• No - to reject the recovered models and return your Browser to its last saved
state.

Note: This option is not supported for the PowerDesigner plugin for Eclipse.

Delete Confirm object deletion - Controls the display of a confirmation dialog box
when you delete an object. If you disable this option, the confirmation dialog
will no longer be shown and the default behavior is as follows:

• Deleting an object symbol - the symbol only is deleted.
• Deleting an object in the browser - the object, any sub-objects it contains,

and any associated diagram symbols are deleted.

You can delete any object without confirmation at any time by selecting its
symbol in a diagram and pressing Shift+Delete.

For more information, see Deleting Objects on page 124.
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Option Description

Startup Auto-reload last workspace - Opens the last-edited workspace when you
launch PowerDesigner. If this option is unchecked, PowerDesigner will open
with an empty workspace.

Show welcome page - Displays the Welcome Page when starting PowerDe-
signer. If you select the Do not show this page again check box in the Welcome
page, this option is deselected.

Browser Drag and drop: Default action - Specify the default result of dragging and
dropping an object (without any modifier key) in the Browser. You can choose
from the following:

• Move (Shift) – The object is displaced to the new location (parent object,
package, model, etc).

• Copy (Ctrl) – A copy of the object is created in the new location.
• Create Shortcut (Ctrl+Shift) – A shortcut to the object (see Creating

Shortcuts on page 457) is created in the new location.
• Create replica (Alt+Shift) – A replica of the object (see Creating Replicas

on page 463) is created in the new location.

The modifier keys given after the option are valid no matter what the default
behavior.

Show shortcuts - Specifies that shortcuts are displayed in the Browser.

Output log Log path - Specifies the path to the log file where PowerDesigner records all of
its outputs.

Graphical tool be-
havior

Edit in place after creation - Allows you to directly modify the name of an
object from the object symbol in the diagram without opening its property sheet
whenever you create an object with the Toolbox.

Sort Natural Sort - Treats numbers numerically when sorting objects in the
Browser. For example, a naturally sorted list of tables would have the order:
Table_1, Table_3, Table_12, Table_20.

Dialog Box Options
To review and edit options that control the look and behavior of dialog boxes, select Tools >
General Options, and click the Dialog category in the left pane.

The following options are available:
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Operating Modes

Option Description

Auto Commit Specifies that any change made in a property sheet is automatically committed in
the object definition. You cancel a change by using the Undo feature.

If this option is disabled, you must click Apply or OK to commit your changes.

Name to Code
mirroring

Automatically keeps the code of an object synchronized with its name via the
application of any naming conventions (see Naming Conventions on page 143).
To disable Name to Code mirroring on an individual object, click to deselect the
equal sign button to the right of the code field.

This option is independent of (but required by) the Enable name/code conver-
sions model option, which permits more complex transformations on codes via
controls the application of conversion scripts (see Name and Code Conversion
Scripts on page 146).

Property Sheets
In PowerDesigner, property sheets appear by default with a certain size and a series of tabs in
the upper part of the dialog box. The following options are available for property sheets:

Option Description

Keep size Preserves the customized size you have defined

Keep last tab Opens the property sheet to the last selected tab

Open mode Controls how property sheets are opened. You can choose between:

• Open each object in the same property sheet

• Open each object in its own property sheet

Tabs mode Controls the display of tabs. You can choose between:

• Tabs on one row - Aligns all tabs on a single line with arrow buttons < and >
for browsing

• Tabs on several rows - Displays tabs on two lines, their size corresponding to
the length of their title.

Shortcut Property Sheets
The following options are available:
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Option Description

Internal Shortcut Controls whether double-clicking an internal shortcut opens the property sheet
for the shortcut or for the target object.

You can switch from one mode to the other by pressing the Shift key while
opening the property sheet. If the target object cannot be found (target model is
closed for example), the shortcut property sheet automatically opens.

External Shortcut Controls whether double-clicking an external shortcut opens the property sheet
for the shortcut or for the target object.

For more information, see Creating Shortcuts on page 457.

Object Lists
The following options are available:

Option Description

Auto-insert rows Specifies that a new item is created automatically in a list when you click an
empty row

Use default name Specifies that new items are given default names upon creation, allowing you to
create multiple new objects without having to supply names or other properties.

Text Editors
By default, all files are edited using PowerDesigner's internal editor. To define external editors
for editing various kinds of text, such as object descriptions and annotations or PDM SQL
scripts or OOM Java files, select Tools > General Options, and click the Editors category in
the left pane.

By default, all files are edited using PowerDesigner's internal editor. You can define an
external text editor to launch automatically for editing various kinds of objects. You can define
as many text editors as you need, and the same file extension can have several text editors
allocated, with the first listed acting as the default.

1. Select Tools > General Options and click the Editors category in the left-hand pane.

2. Click the Insert a Row tool, and enter a file extension (such as .DOC, .RTF, .TXT, .XLS) in
the Extension column.

The Editor Name and Editor Command columns are both set to <internal> to indicate that
the internal PowerDesigner editor will be used to edit files with this extension.

3. [optional] Enter an editor name (such as MS Word, Notepad, MS Excel) in the Editor
Name column, and enter an editor command (such as winword.exe) in the Editor
Command column. You can click the ellipsis button in this field to browse to the relevant
directory.
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4. Click OK to close the dialog box.

Environment Variables
Environment variables provide access to paths and executables on your workstation for use in
generation commands and GTL templates. To review and edit variables, select Tools >
General Options, and click the Variables category in the left pane.

Click in the row of an existing variable in order to edit its value. To create a new variable, click
the Add a Row tool and specify a name and value. The following variables are defined by
default:

Variable Description

CMD Windows command interpreter.

Default: command.com or cmd.exe

HOME Home directory.

J2EEVERIF Batch program for verifying if the deployment jar for an EJB is correct

Default: verifier.bat

JAR Command for archiving java files

Default: jar.exe

JAVA Command for running JAVA programs

Default: java.exe

JAVAC Command for compiling JAVA source files

Default: javac.exe

JAVADOC Command for defining JAVA doc comments

Default: javadoc.exe

Note: To use a variable in GTL (see Customizing and Extending PowerDesigner >
Customizing Generation with GTL ), prefix it with a dollar sign, and wrap it in percent signs.
For example, %$CMD%.

Named Paths
Named paths allow you to resolve links between models and resource files in different
environments. To review and edit named paths, select Tools > General Options, and click the
Named Paths category in the left pane.

When you save a PowerDesigner model, project, or workspace, the name of a named path is
saved in place of the actual path, and when you open a file, the named path is replace with the
locally defined value . For example, if the _DBMS named path is defined as C:\DBMS and you
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have the path C:\DBMS\syase1550.xdb in your model, then the path will be saved as
%DBMS%\syase1550.xdb to allow the model to be opened by another user who stores
their DBMS definition files elsewhere.

To view the existing named paths, select Tools > General Options, and then click the Named
Paths category.

To add a new named path, click the Add a Row tool and enter a name and a path for the named
path.

Note: An administrator may push named paths to users in a general preferences profile (see
Controlling Defaults for Options and Preferences on page 566).

The following paths are initialized by default:

Name Path

_DBMS Folder where DBMS definition files are stored.

_EXAMPLES Folder where demo examples are stored.

_HOME PowerDesigner installation folder. This path facilitates the installation of your
add-ins without having to modify your XEM or your XML or ActiveX add-ins
commands. For example:

%_HOME%\add-ins\SpellChecker\SpellCheckAddIn.dll

_JSF Folder where JSF libraries are stored.

_LIBRARY Folder where object libraries are stored.

_MODELCATE-
GORY

Folder where model category files are stored (see Model Creation Options on
page 264).

_OBJLANG Folder where object language definition files are stored.

_PRCSLANG Folder where process language definition files are stored.

_RTPLANG Folder where report language definition files are stored.

_RULESET Folder where impact and lineage rule set files are stored (see Chapter 17,
Impact and Lineage Analysis on page 499).

_SHARED Folder where the glossary and library model files are stored (see The Glossary
on page 36 and The Library on page 39).

_SMARTWIN-
FORM

Folder where smart winform files are stored.

_WINFORM Folder where winform files are stored.

_XEM Folder where extension files are stored.

_XMLLANG Folder where XML language definition files are stored.
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Note: You should not modify the name of a predefined named path. If you do so, the
predefined named path is preserved in the list and a new path is created with the modified name
and value. If you want to cancel a change to a predefined named path, simply delete it and close
the General Options dialog. When you reopen the dialog the path is recreated with its default
value.

If you open a file containing a named path not defined on your machine, a dialog will open,
offering you the following options:

• Ignore the named path and keep the file name unresolved - The link between files is broken
and you may have update problems.

• Define a new named path ... - Allows you to define the path on your machine.
• Browse another existing variable to replace with – Allows you to resolve the path using one

of your existing names paths.
• Directly browse the target file – Allows you to browse for another target file. The selected

file will replace the file you were trying to open
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Interface Fonts
To review and modify the fonts used in the general user interface, code and rtf editors, and
matrices, select Tools > General Options, and click the Fonts category in the left pane.

Add-Ins
To review and enable add-ins to provide additional features and services in PowerDesigner,
select Tools > General Options, and click the Add-Ins category in the left pane.

Add-ins installed with PowerDesigner are called system add-ins, and are declared in a Local
Machine registry key. The following system add-ins are installed by default:

• Microsoft SQL Server 2005 Analysis Services - Generates and reverse engineers
multidimensional objects for Microsoft SQL Server 2005 (see Data Modeling > DBMS
Definition Reference > Microsoft SQL Server). Require the client for the appropriate
version of SQL Server.
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• Microsoft Word Import - Imports and exports MS Word documents to and from
requirements models (see Requirements Modeling > Working with Word Documents and
RQMs).

• SAP BusinessObjects - Generates universes from physical data models (see Data
Modeling > Building Data Models > Generating and Reverse-Engineering Databases >
Generating an SAP BusinessObjects Universe). Requires BusinessObjects 4.0 or higher.

• SAP ERP - Imports SAP Business Suite Data Dictionary and allows its generation it to
HANA (see Data Modeling > DBMS Definition Reference > SAP Business Suite)

• SAP HANA - Generates database schemas using the HANA API (see Data Modeling >
DBMS Definition Reference > SAP HANA Database).

• SAP Solution Manager - Generates and reverse engineers objects to a Solution Manager
server (see Business Process Modeling > SAP Solution Manager).

• Spell Checker - Uses the MS Word spell checker to check PowerDesigner object names,
codes, comments, descriptions, and annotations (see Spell Checking on page 153).
Requires Word 2000 or higher.

• Sybase IQ Reference Architecture - Analyzes the architecture required to deploy a
SAP® Sybase® IQ data warehouse solution suitable for your workload (see Enterprise
Architecture Modeling > Sybase IQ Reference Architecture Model).

• XML Validation - Checks that an XML document conforms to the schema in the XML
model (see XML Modeling). Requires MSXML 4.0.

Note: If you modify system add-in properties, you can click the Reset Values For System
Add-In tool to recover the parameters registered in the registry.

You enable an add-in by selecting its checkbox.

You can create your own XML or ActiveX user add-ins, which are declared in a Current
User registry key:

1. Click one of the following tools:

• Add New ActiveX Add-In - An ActiveX add-in implements an interface that defines
methods, which are invoked by PowerDesigner in order to dialog with menus and
execute commands that are defined by the ActiveX.

• Add New XML Add-In - An XML add-in defines a menu structure for calling scripts
or executables from within PowerDesigner.

For information about developing these add-ins, see Customizing and Extending
PowerDesigner > Scripting PowerDesigner > OLE Automation and Add-Ins

2. Enter the name of your add-in and click the Select File tool to browse to the .xml, .dll,
or .exe file.

3. [ActiveX only] Enter the name of the ActiveX implementation class in the Class field.
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4. Click OK.

If your add-in has been correctly defined, it will immediately be available under the
appropriate PowerDesigner menu.

Model Creation Options
To review and modify options for creating models in the New Model dialog, select Tools >
General Options, and click the Model Creation category in the left pane.

The following options are available:
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Option Description

Enable Categories Enables the display of the Categories button in the New Model dialog, which
lets you create models from predefined templates. Select the model category
set to use in the Default category set list. If no valid model category set is
selected then the Categories button will not be available.

Click the Select Path tool to the right of this field to browse to another folder
containing model category sets or click the Properties tool to open the cur-
rently-selected set in the Resource Editor. For more information about cate-
gory sets, which are often developed by an administrator, see Customizing the
New Model Dialog on page 553.

Enable Model
Types

Enables the display of the Model types button in the New Model dialog, which
lets you create models from the classic list of model types.

Enable model tem-
plate files

Enables the display of the Template files button in the New Model dialog,
which lets you create models from model templates. If no valid template
directory is selected then the Templates button will not be available.

Click the Select Path tool to the right of this field to browse to another folder
containing model templates. For more information about model templates, see
Model Templates on page 11.

For information about using the New Model dialog, see Creating a Model on page 9.

Repository Options
To review and modify options for connecting to the repository, controlling the Repository
Browser tab, and setting various defaults, select Tools > General Options, and click the
Repository category in the left pane.

Connection
The following options are available in the Connection group box:

Option Description

Auto-connect Automatically connects to the last connected repository when you start a
PowerDesigner session (see Connecting Automatically to the Default Repo-
sitory on page 17.

Apply profiles Re-applies all UI preferences profiles and general preferences profiles that are
associated with the user (either directly, or by membership of groups) at each
connection to the repository (see Using Profiles to Control the PowerDesigner
Interface on page 560). This option is selected by default and may cause local
customizations to your interface, options, and preferences to be overwritten.
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Option Description

Default bytes per
char

Specifies the default number of bytes per character used by the repository
database. This value is used to initialize the Bytes per char parameter in the
Direct Repository Definition dialog (see Setting up PowerDesigner for Direct
Access on page 13).

Browser
The following options are available in the Browser group box:

Option Description

Auto-refresh Refreshes the Repository Browser at the interval specified in the Refresh
every box.

Display Specifies whether the name or code of items is displayed in the Repository
Browser.

Display model con-
tents

Enables the display of model diagrams and objects in the Repository Browser.

Display version
numbers

Enables the display of version numbers for items in the Repository Browser.

Display status icons
in Local Browser

Enables the display of status icons (which track whether items are locked and
if changes have been made locally and/or in the repository since check out) in
the Local Browser (see Chapter 2, The Browser on page 35).

Check Out
The following options in the Check Out group box control the default selection of options in
the Check Out dialogs (see Checkout Parameters on page 315):

Option Description

Merge document Specifies that the Merge document option is selected by default.

Add to workspace Specifies that the Add to workspace option is selected by default.

Check out dependen-
cies

Specifies that the Check out dependencies option is selected by default.

Automatic resources
update

Enables the automatic checking out and updating of shared resource files.

Note: This option controls a legacy feature, which has been superceded by the
library (see Sharing Resource Files via the Library on page 551).
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Check In
The following options in the Check In group box control the default selection of options in the
Check In dialogs (see Check-In Parameters on page 297):

Option Description

Batch update Specifies that the Batch update option is selected by default.

Freeze after check
in

Specifies that the Freeze after check in option is selected by default.

Save diagrams for
PowerDesigner Por-
tal

Specifies that the Save diagrams for PowerDesigner Portal option is selected
by default.

Local Cache
The following options in the Local cache group box control the caching of models checked
into and out of the repository on your local workstation. The cache, which is enabled by
default, saves a local copy of models you check out in the cache directory, and can speed up
check ins and check outs when you are primarily working with models that are rarely modified
by other users. The following options are available:

Option Description

Path Specifies the location of the cache.

Maximum size
(MB)

By default, the maximum size is set to 50MB. Click the Clear Cache button to
empty the contents of the cache.
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Organizing Views
The PowerDesigner window contains the Browser, Toolbox, Canvas, Result List, and Output
sub-windows or views, which you can move, group, split, hide, or auto-hide to suit your
workflow.

To move a view, click on its title bar or upper or lower tab and drag and drop it onto the docking
control that appears as you hover over a view. You can perform the following kinds of
movement in this way:

• To group the view with another view - drop it on the central dock selector:

The dropped view is stacked on the other view, and each has a tab at the bottom of the group
to select it.
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• To place the view next to, above, or below a view - drop it on the left, right, top, or bottom
dock selector. You can use this to divide the canvas and show multiple diagrams together.

• To place the view next to, above, or below a view, and have it extend the full height or
breadth of the PowerDesigner window - drop it on the separate left, right, top, or bottom
dock selectors that appear near the extremities of the window:

• To promote a view to an independent window - drop it anywhere except on a dock selector.

Note: The Canvas is a special view that displays diagrams as tabbed documents.You can drag
other views onto the Canvas, but you cannot drag Canvas diagrams elsewhere in the
PowerDesigner window (though you can promote them to independent windows). Right-click
a diagram tab to access a menu that lets you close the diagram, close every diagram except this
one, or split the canvas horizontally or vertically.

All views except the canvas have a menu available on their title bar to:

• Float - promote the view to an independent window.
• Show - disable auto-hiding (or click the sideways pin to pin the view open).
• Dock as Tabbed Document - add the view as a tab to the Canvas.
• Auto Hide - hide the view as a small tab on the side of the screen, that re-expands when you

hover over it (or click the vertical pin to unpin the view).
• Hide - remove the view from your window. To show a hidden view, select View > View

Name.

Note: The Browser is a single view with up to three sub-views (Local, Glossary, and
Repository). These sub-views cannot be moved independently.

Organizing Toolbars
The PowerDesigner window provides various toolbars, which you can show, hide, organize,
and customize to suit your workflow.

• To move a toolbar in the toolbar tray, click and hold on the four dots on the left edge of the
toolbar and drag it to the desired position.

• To show a hidden toolbar or hide a visible toolbar - right-click the toolbar tray and select
Toolbars and check or uncheck the toolbar.

• To access tools on a toolbar that is not fully visible due to lack of space - click on the down
arrow on the right edge of the toolbar.
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• To lock all toolbars to protect them from accidental movements - right-click the toolbar
tray and select Toolbars > Lock Toolbars.

• To add tools to or remove them from a toolbar, or to create new toolbars - right-click the
toolbar tray and select Toolbars > Customize Menus and Tools (see Customizing
Menus, Toolbars, and Toolboxes on page 270).

Note: The Toolbox (see Creating Objects from the Toolbox on page 89) is not a toolbar, and
you cannot add Toolbox tools (such as those for creating a PDM table or OOM class) to a
toolbar, nor add toolbar tools to the Toolbox.

Customizing Menus, Toolbars, and Toolboxes
To customize PowerDesigner menus, toolbars, and toolboxes, select Tools > Customize
Menus and Tools.

Note: An administrator can prepare customized UI profiles, which are made available to users
on their first connection to the repository (see Controlling Defaults for Menus, Toolbars, and
Toolboxes on page 565).

1. Select Tools > Customize Menus and Tools. The dialog opens to the Menus tab,
initialized to your current view (here, the PDM Physical Diagram):

Note: Search for any command available in the present context by entering it in the Search
for field and clicking Find. Methods and menus defined in resource files and custom
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commands are not available for selection and cannot be moved in this dialog (see
Customizing and Extending PowerDesigner > Extension Files > Menus (Profile)).

2. [optional] Select a different view to customize. The following views are available:

• No View - when PowerDesigner is running but no model is open and selected.

• Type Diagram - each diagram is listed separately.

• All Views - provides a union of all the menus available in all possible views.

Note: You can make changes in multiple different views. All your UI preferences are saved
in a single resource file.

3. Navigate to and select a command group (menu or submenu) to modify in the tree in the
left panel. The commands that are available on the selected menu, submenu, toolbar, or
toolbox are listed in the middle panel.

The middle panel shows the contents of only one level at a time. To see the contents of a
submenu, double-click it to descend into its commands. Click the Go Up One Level tool to
return to the parent menu. For example, to see the contents of the Repository >
Administration submenu, expand the Repository node in the left panel, and select the
Administration node, or click the Repository node in the left panel, and double-click the
Administration node in the middle panel.

Note: The special commands in the format <Command> such as <Recent Files> and
<New Diagrams> are placeholders for points where the menu dynamically calculates
commands to insert. The <Stereotypes used as Metaclass> placeholder,
which is present by default in the Model menu, instructs PowerDesigner to insert a
command to open a list of objects for each type of new object defined in a model definition
or extension file (see PowerDesigner Resource Files on page 272). If you remove this
command from this menu, then all such object lists will be hidden. If you want to display
such object lists under another menu, then you must add both the parent metaclass from
which they are derived and the <Stereotypes used as Metaclass>
placeholder.

4. Use the tools in the middle panel to add, remove, reorder, or otherwise modify the
commands of the selected command group:

To
ol

Description

Create New Menu - Creates a new sub-menu to add to the command group. The sub-menu
acts as a container for commands.

Add Commands - Opens a selection dialog to add a command to the selected command
group. The Add Commands dialog has a Pick Command tab to let you select available
commands from a tree and a Filter Commands tab to let you filter the list of available
commands by entering a string. When you have located the command to add, select it and
click OK.
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To
ol

Description

Go Up One Level - Displays the commands of the parent menu of the currently selected
menu.

Remove - Deletes the selected command from the command group.

Reset List - Undoes any changes to the command group.

Move Up - Moves the selected command up one place in the list.

Move Up - Moves the selected command down one place in the list.

5. [optional] Select a command in the middle pane and use the fields in the right pane to
change its name, tooltip, and display method (text and/or image).

Note: Inserting an ampersand sign in the Name field before a letter enables its use as an Alt
key menu shortcut. For example, the File menu has, by default, its name defined as &File
so that users can press Alt+F to activate this menu.

6. [optional] Select the Toolbars (see Organizing Toolbars on page 269) or Toolboxes (see
Creating Objects from the Toolbox on page 89) tab to customize these UI elements.

7. Click OK to save your changes and apply them to your environment.

PowerDesigner Resource Files
The SAP® Sybase® PowerDesigner® modeling environment is powered by XML-format
resource files, which define the objects available in each model along with the methods for
generating and reverse-engineering them. You can view, copy, and edit the provided resource
files and create your own in order to customize and extend the behavior of the environment.

The following types of resource files, based on or extending the PowerDesigner public
metamodel are provided:

• Definition file: customize the metamodel to define the objects available for a specific
DBMS or language:
• DBMS definition files (.xdb) - define a specific DBMS in the PDM (see Customizing

and Extending PowerDesigner > DBMS Definition Files).
• Process, object, and XML language definition files (.xpl, .xol, and .xsl) – define a

specific language in the BPM, OOM, or XSM (see Customizing and Extending
PowerDesigner > Object, Process, and XML Language Definition Files).

• Extension files (.xem) – extend the standard definitions of target languages to, for
example, specify a persistence framework or server in an OOM. You can create or attach
one or more XEMs to a model (see Extension Files on page 275).
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• Report templates (.rtp) - specify the structure of a report. Editable within the Report
Template Editor (see Report Templates on page 417).

• Report language files (.xrl) – translate the headings and other standard text in a report (see
Customizing and Extending PowerDesigner > Translating Reports with Report Language
Resource Files).

• Impact and lineage analysis rule sets (.rul) - specify the rules defined for generating impact
and lineage analyses (see Analysis Rule Sets on page 512).

• Object permission profiles (.ppf) - customize the PowerDesigner interface to hide models,
objects, and properties (see Controlling the Availability of Models, Objects, and
Properties on page 560).

• User profiles (.upf) - store preferences for model options, general options, display
preferences, etc (see User Profiles on page 249).

• Model category sets (.mcc) - customize the New Model dialog to guide model creation (see
Customizing the New Model Dialog on page 553).

• Conversion tables (.csv) - define conversions between the name and code of an object (see
Creating a Conversion Table on page 149).

You can review all the available resource files from the lists of resource files, available by
selecting Tools > Resources > type.

The following tools are available on each resource file list:

Tool Description

Properties - Opens the resource file in the Resource Editor.

New - Creates a new resource file using an existing file as a model (see Creating and
Copying Resource Files on page 274).

Save - Saves the selected resource file.

Save All - Saves all the resource files in the list.

Path - Specifies the directories that PowerDesigenr should search to populate the list (see 
Specifying Directories to Search for Resource Files on page 274).

Compare - Selects two resource files for comparison.

Merge - Selects two resource files for merging.

Check In - [if the repository is installed] Checks the selected resource file into the reposi-
tory. For information about storing your resource files in the repository, see Sharing Re-
source Files via the Library on page 551.

Update from Repository - [if the repository is installed] Checks out a version of the selected
file from the repository to your local machine.
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Tool Description

Compare with Repository - [if the repository is installed] Compares the selected file with a
resource file stored in the repository.

Sharing and Embedding Resource Files
Resource files can be shared and referenced by multiple models or copied to and embedded in
a single model. Any modifications that you make to a shared resource are available to all
models using the resource, while modifications to an embedded resource are available only to
the model in which it is embedded. Embedded resource files are saved as part of their model
and not as a separate file.

Note: You should never modify the original extensions shipped with PowerDesigner. To
create a copy of the file to modify, open the List of Extensions, click the New tool, specify a
name for the new file, and then select the .xem that you want to modify in the Copy from
field.

The File Name field displays the location of the resource file you are modifying is defined.
This field is empty if the resource file is embedded.

Creating and Copying Resource Files
You can create a new resource file in the appropriate resource file list. To create a copy of an
existing resource file, select it in the Copy from field of the New... dialog.

Warning! Since each resource file has a unique id, you should only copy resource files within
PowerDesigner, and not in Windows Explorer.

1. Select Tools > Resources >  Type  to open the appropriate resource file list.

2. Click the New tool, enter a name for the new file and select an existing file to copy. Select
the <Default template> item to create a minimally completed resource file.

3. Click OK to create the new resource file, and then specify a filename and click Save to
open it in the Resource Editor.

Note: You can create an extension file directly in your model from the List of Extensions.
For more information, see Creating an Extension File on page 276.

Specifying Directories to Search for Resource Files
Use the Path tool in the resource list toolbar to specify directories to search to populate the list.
If you plan to modify the standard resource files or create your own, you must store these files
in a directory outside the PowerDesigner installation directory.

By default, only the directory inside the Program Files folder containing the standard
resource files appears in the list, but PowerDesigner does not allow you to save modifications
there, and will propose an alternative location if you try to do so, adding the selected directory
to the list. You can add additional directories as necessary.
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Note: If you have created or modified resource files inside Program Files before 16.5,
when this rule was introduced, your files may no longer be available as Windows Vista or
Windows 7 actually store them in a virtual mirror at, for example, C:\Users\username
\AppData\Local\VirtualStore\Program Files\Sybase
\PowerDesigner 16\Resource Files\DBMS. To restore these files to your lists,
optionally move them to a more convenient path, and add their location to your list using the
Path tool.

The first directory in the list is the default location, which is proposed whenever you save a file.
The root of the library belonging to your most recent repository connection is searched
recursively before the directories in the list (see Sharing Resource Files via the Library on
page 551), .

Note: In rare cases, when seeking resource files to resolve broken references in models, the
directories in the list are scanned in order, and the first matching instance of the required
resource is used.

Extension Files
Extensions files (*.xem) allow you to customize and extend the PowerDesigner metamodel
to support your exact modeling needs. You can define additional properties for existing
objects or specify entirely new types of objects, modify the PowerDesigner interface
(reorganizing and adding property sheet tabs, Toolbox tools and menu items), and define
additional generation targets and options.

Extension files have an .xem extension and are located in install_dir/Resource
Files/Extended Model Definitions.

Lists of extension files by model type are available by selecting Tools > Resources >
Extensions > model type. For information about the tools available in resource file lists, see
PowerDesigner Resource Files on page 272.

Note: Extensions, such as the Excel Import extension, which can be attached to any model
type, are available in the list at Tools > Resources > Extensions > All Model Types.

Each extension file contains two first-level categories:

• Generation - used to develop or complement the default PowerDesigner object generation
(for BPM, OOM, and XSM models) or for separate generation. For more information, see
Customizing and Extending PowerDesigner > Object, Process, and XML Language
Definition Files > Generation Category.

• Profile - used for extending the metaclasses in the PowerDesigner metamodel. You can:
• Create or sub-classify new kinds of objects:

• Metaclasses – drawn from the metamodel as a basis for extension.
• Stereotypes [for metaclasses and stereotypes only] – sub-classify metaclasses by

stereotype.
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• Criteria – sub-classify metaclasses by evaluating conditions.
• Add new properties and collections to objects and display them:

• Extended attributes – to add metadata.
• Extended collections and compositions – to enable manual linking between

objects.
• Calculated collections – to automate linking between objects.
• Dependency matrices – to show dependencies between two types of objects.
• Forms – to modify property sheets and add custom dialogs.
• Custom symbols – to change the appearance of objects in diagrams.

• Add constraints and validation rules to objects:
• Custom checks – to test the validity of your models on demand
• Event handlers – to perform validation or invoke methods automatically.

• Execute commands on objects:
• Methods – VBScripts to be invoked by menus or form buttons.
• Menus [for metaclasses and stereotypes only] – to add commands to

PowerDesigner menus.
• Generate objects in new ways:

• Templates – to extract text from object properties.
• Generated Files - to assemble templates for preview and generation of files
• Transformations – to automate changes to objects at generation or on demand.

• Map correspondences between different metamodels:
• Object generations - to define mappings between different modules in the

PowerDesigner metamodel for model-to-model generation.
• XML imports - to define mappings between an XML schema and a PowerDesigner

module to import XML files as models.

Note: Since you can attach several resource files to a model (for example, a target language
and one or more extension files) you can create conflicts, where multiple extensions with
identical names (for example, two different stereotype definitions) are defined on the same
metaclass in separate resource files. In case of such conflicts, the extension file extension
usually prevails. When two XEMs are in conflict, priority is given to the one highest in the List
of Extensions.

Creating an Extension File
You can create an extension file directly in your model or from the appropriate list of extension
files.

Note: Extensions, such as the Excel Import extension, which can be attached to any model
type, can only be created from the All Model Types extension list. For information about
creating an extension file from a list of extension files, see Creating and Copying Resource
Files on page 274.

CHAPTER 9: Customizing Your Modeling Environment

276 SAP Sybase PowerDesigner



1. Open your model, and then select Model > Extensions to open the List of Extensions.

2. Click the Add a Row tool and enter a name for the new extension file.

3. Click the Properties tool to open the new extension file in the Resource Editor, and create
any appropriate extensions.

4. When you have finished, click OK to save your changes and return to the List of
Extensions.

The new XEM is initially embedded in your model, and cannot be shared with any other
model. For information about exporting your extensions and making them available for
sharing, see Exporting an Embedded Extension File for Sharing on page 278.

Attaching Extensions to a Model
Extensions can be stored in *.xem files that you can attach to one or more models. You can
attach one or more extension files to a model at creation time by clicking the Select
Extensions button on the New Model dialog. You can subsequently attach extension files to
your model at any time from the List of Extensions.

1. Select Model > Extensions to open the List of Extensions, which contains extensions
attached to the model.

2. Click the Attach an Extension tool to open the Select Extensions dialog.

3. Review the different sorts of extensions available by clicking the sub-tabs and select one or
more to attach to your model.

By default, PowerDesigner creates a link in the model to the specified file. To copy the
contents of the extension file and save it in your model file, click the Embed Resource in
Model button in the toolbar. Embedding a file in this way enables you to make changes
specific to your model without affecting any other models that reference the shared
resource.

4. Click OK to return to the List of Extensions.

CHAPTER 9: Customizing Your Modeling Environment

Core Features Guide 277



Extension files listed in grey are attached to the model, while those in black are embedded
in the model.

Note: If you embed an extension file in the model, the name and code of the extension may
be modified in order to make it respect the naming conventions of the Other Objects
category in the Model Options dialog.

Exporting an Embedded Extension File for Sharing
If you export an XEM created in a model, it becomes available in the List of Extensions, and
can be shared with other models. When you export an XEM, the original remains embedded in
the model.

1. Select Model > Extensions to open the List of Extensions, which contains extensions
attached to the model.

2. Select an embedded extension in the list and click the Export an Extension tool.

3. Enter a name and select a directory to which to save the extension file and click Save.

Note: For the extension to be available for attaching to other models, you must save it to a
directory that is listed by the Path tool in the appropriate extension list (see Specifying
Directories to Search for Resource Files on page 274).
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Reconnecting to Missing Extensions
If you rename, move or delete extension files that are attached to a model, you may lose the
links to them in your model. When you next open a model sharing the affected extensions,
PowerDesigner will try to help you reconstruct the broken links.

The following tools are available in this dialog:

Tool Description

Open – Lets you browse to, and re-attach, the missing XEMs.

Update from Repository – Lets you check out the missing XEMs from the repository.

Delete – Lets you remove the links between the model and the missing XEMs.

Shortcut Keys
PowerDesigner provides many shortcut keys to accelerate your workflow.

Toolbox Shortcuts

Shortcut Action

Double-click Pointer tool / Ctrl+A Select all symbols in diagram.

CHAPTER 9: Customizing Your Modeling Environment

Core Features Guide 279



Shortcut Action

Double-click Delete tool Delete all selected symbols (with confirmation).

Double-click Grabber tool Zoom to whole diagram.

Double-click any object tool Select all symbols of this type.

Shift+Double-click any object tool Retain current selection and add all symbols of this type.

Right-click Release tool and select pointer.

Browser Shortcuts

Shortcut Action

* (number pad) Expand all nodes.

+ (number pad) Expand subnodes.

- (number pad) Collapse subnodes.

F2 Rename selected item.

Ctrl+Shift+F Find selected item in Diagram.

Diagram Shortcuts

Shortcut Action

DEL and Shift+DEL Delete object (with and without confirmation).

Alt+ENTER Open object property sheet.

Ctrl+K Paste as shortcut.

Ctrl+H [on selected link] Force link to horizontal.

Ctrl+L [on selected link] Force link to vertical.

Ctrl+Page Up and Ctrl+Page Down Bring symbol to front and send symbol to back.

Ctrl+Home and Ctrl+End Align selection on vertical and horizontal axis.

Ctrl+T Open Symbol Format dialog.

Ctrl+J Auto-resize the symbol to display all the text it contains up
to the value specified for word wrapping in the diagram.

Ctrl+Resize Resize object while keeping same center point.
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Shortcut Action

Ctrl+Shift+Resize Resize object while keeping same center point and propor-
tions.

F2 or Ctrl+Right-click on Name Rename object.

Drag and Drop Shortcuts

Shortcut Action

Shift+Drag and drop Move object.

Ctrl+Drag and drop Copy object.

Shift+Ctrl+Drag and drop Create shortcut of object.

Alt+Drag and drop Create replica of object.

Right-click+Drag and drop Open menu to choose an action.

Window and General Shortcuts

Shortcut Action

F4 Check model.

F5 Zoom to actual size.

F6 Zoom in.

F7 Zoom out.

F8 Zoom to whole diagram.

F9 Previous view.

F10 Display used pages.

Shift+F5 Redisplay.

Shift+F9 Next view.

Shift+Click item Select consecutive items.

Alt+0 Show/hide Browser.

Alt+1 Show/hide Output view.

Alt+2 Show/hide Result List view.

Alt+3 Show/hide Welcome page.
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Shortcut Action

Alt+F6 Cycle between active windows.

Ctrl+Double-click / Ctrl++ (plus) [on package or other composite symbol] Open subdiagram.

Ctrl+Tab Cycle through property sheet tabs.

Ctrl+Page Up / Ctrl+Page Down Cycle through property sheet tab subtabs.

Ctrl+B Find selected object in Browser.

Ctrl+D Select diagram.

Ctrl+E Open list of reports.

Ctrl+F Find objects.

Ctrl+F4 Close diagram.

Ctrl+Alt+F4 Close model.

Ctrl+F6 / Ctrl+Shift+F6 Cycle between property sheets.

Ctrl+U Go to parent diagram.

Shift+F2 Open workspace.

Shift+F3 Save workspace.

Shift+F4 Close workspace.

List Shortcuts

Shortcut Action

F2 Select text for edit.

F4 Select cell to add text.

Ctrl+Shift+Spacebar Select line.

Ctrl+A Select all.

Ctrl+Shift+A Deselect all.

Ctrl+N Add entry.

Ctrl+I Insert entry.

Ctrl+D Delete entry.
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Code Preview Tab Shortcuts

Shortcut Action

F2 Next bookmark.

F3 Find next.

Shift+F11 Menu.

Ctrl+F2 Insert/Remove bookmark.

Ctrl+I Insert file.
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PART II

Storing, Sharing, and Reporting
on Models

PowerDesigner provides a robust repository solution to store models and other project files
and make them available to other PowerDesigner users. The optional PowerDesigner Portal
allows any user with an account to review models in a Web browser. You can produce model
reports in HTML and RTF format for wider distribution.
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CHAPTER 10 The Repository

The PowerDesigner repository is a tool for storing and sharing versioned models and other
files used in your modeling process. It provides robust, granular security, and supports full
access from within PowerDesigner and viewing and some administration via a Web browser.

Note: Before you can access the repository, an administrator must install and configure it and
provide you with a user name and password.

The following sections provide information about installing and administering the repository:

• Installing and maintaining the repository (see Installation Guide > Installing the
Repository)

• Providing access to the repository by managing rights and permissions (see Chapter 18,
Controlling Repository Access on page 521)

• Providing customization of the PowerDesigner interface through permission, UI, and
general profiles (see Chapter 20, Customizing the PowerDesigner Interface on page
553)

• Deploying an enterprise glossary and library of reference models and other documents to
be shared with all users (see Chapter 19, Deploying an Enterprise Glossary and Library on
page 541)

• Adding resource files to the repository and managing their sharing (see Sharing Resource
Files via the Library on page 551)

Browsing the Repository
The Repository tab of the Browser displays the contents of the repository.

To expand all nodes, press the numpad plus sign (+). To collapse all nodes, press the numpad
minus sign (-). To filter the Browser tree by branch (see Branching Version Trees on page
325), click the Customize Branch Filter tool and select the branches you want to view in the
Branch Filter Selection dialog. The filter works simply by name, so that branch names that
are reused in different folders are treated as the same. You can toggle the use of the filter with
the Enable/Disable Branch Filter tool:
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Note: You can only see repository objects if you have at least List permission on them (see 
Granting Access Permissions on Repository Items on page 534).

A typical hierarchy of objects in the Browser Repository tab may include

• Root - [when connection is established] Displays the repository definition name, the user
login, and the current branch (see Repository Root Properties on page 290).

• Folders - Used to organize documents in the repository (see Repository Folders on page
288).

• Library - A folder containing enterprise models that are pushed automatically to all users
when they connect to the repository (see The Library on page 39).

• Branches - Allow concurrent development of multiple versions of documents (see 
Branching Version Trees on page 325).

• Projects - Container for models and other files (see Chapter 3, Projects and Frameworks on
page 47).

• Documents - Models, multi-model reports, resource files, and external application files
such as MS Office files, or graphics.

• Packages - Model packages (see Packages on page 44).
• Diagrams, object categories, and objects - Are displayed only if the Show objects general

option is selected (see Repository Options on page 265).

Repository Folders
You can use folders to organize the contents of the repository by, for example, creating
separate folders for each subject area, or each team working on a project. You must have write
permission on the location where you want to create the folder. Documents checked in inside a
folder inherit its permissions.

Note: A PowerDesigner project (see Chapter 3, Projects and Frameworks on page 47) acts as
both a repository document and a folder. Use the project permissions to control working with
the project file itself (project diagram and any framework or dependency matrices) and the
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folder permissions to grant access to the models contained within the project, as you would for
a repository folder.

You create a folder by right-clicking the root node, a project, or a folder, selecting New >
Folder, and entering a name for the folder in the property sheet. Click the Permissions tab to
add permissions for all appropriate users and groups for the folder and its contents (see 
Granting Access Permissions on Repository Items on page 534).

You can rename a folder from its property sheet or by selecting its node in the Browser and
pressing the F2 key.

You can move folders and documents in the repository by drag and drop. You cannot move a
single document version nor can you move objects from one model to another. To move a
folder or a model you must have Full permission on the folder or model to be moved, and
Write permission on the target folder. You cannot move a project inside another project.

For information about deleting a folder, see Deleting Documents, Document Versions, and
Folders on page 334.

Repository Document Properties
Double-click any item in the repository to see its repository property sheet.

The General tab displays read-only information about the object:

Property Description

Name/Code/
Comment

Display the name, code, and comment of the object. Repository folders have an
editable name, but no code or comment.

Type [not available for folders] Specifies whether the item is a PowerDesigner model or
package, or another type of document or object.

Location [folders, documents, and model objects] Displays the full path to the folder or
document.

[model packages]: Displays the hierarchy of packages in the model.

Status [not available for folders] Indicates the status of the document, which can be
Updatable, Frozen (see Freezing and Unfreezing Document Versions on page
320), or Locked (see Locking and Unlocking Document Versions on page 321).

Version Info Tab
The Version Info tab displays information about the current version of the object:

Property Description

Creation Displays the name of the user who created the item in the repository, and the date
of creation.
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Property Description

Last modifica-
tion

Displays the name of the user who last modified the item, and the date of this
modification.

Generated From
Origin Object

[model objects only] When the current object has been generated from another
object, displays the name of the origin object. Click the Properties button to the
right of this field to open the origin object property sheet.

Version [not available for folders] Displays the number, branch name, and check-in com-
ment for the current version.

Versions Tab
The Versions tab displays a tree of the versions of the document including any versions under
branches. For more information about this tab, see Document Versions on page 318.

The following tabs are also available:

• Notes [models, packages, and model objects only] - contains annotations and descriptions
of the object (see Notes Tab on page 101)

• Attributes [models, packages, and model objects only] - displays additional properties for
these items.

• Collections [models, packages, and model objects only] - displays a list of collections or
related objects (but not sub-objects) for the item. For example, the Collections tab in the
property sheet of a CDM entity may display the business rules attached to the entity, but
will not display entity attributes.

• Permissions [models, packages, folders and other documents only] – lists those users and
groups with permissions on the document (see Granting Access Permissions on
Repository Items on page 534).

Repository Root Properties
Right-click the root of the Repository tab of the Browser, and select Properties to open its
property sheet.

The Connection tab contains the following properties:

Property Description

Repository name Specifies the name of the repository to which you are connected.

Login name Specifies the login name through which you are connected.

In addition, the following tabs are available:

• LDAP - lists LDAP configuration parameters to enable remote LDAP users to access the
repository (see Connecting to an LDAP Server for User Authentication on page 524).
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• SMTP - lists parameters for connecting the repository to an SMTP server (see Connecting
to an SMTP Server for Notifications on page 527).

• Passwords - lists the requirements of the policy which controls the qualities of user
passwords for the repository (see Defining a Password Policy on page 528).

• Permissions – lists those users and groups with permissions on the entire repository (see
Granting Access Permissions on Repository Items on page 534).

• Version Info – specifies when the repository was created and last modified (see Version
Info Tab on page 106).

Note: In addition to the standard version properties, the repository root also has a
Repository ID, specifying the unique identifier of the repository, which is used to identify
the associated glossary (see The Glossary on page 36) and library (see The Library on page
39).

Checking Documents into the Repository
You check documents into the repository to share them with others. You must have at least the
Submit permission on a document (or on one of its packages) to be able to check it into a
change list for approval or at least the Write permission to make changes directly to the
repository version.

1. In the Local tab of the Browser, select the documents to check in, then right-click and
select Check In to open the:

• Check In Project window - if you selected a project (see Checking In a Project on page
292).

• Check In Document window - if you selected a single model or file (see Checking In a
Model, Resource File, or Other Document on page 293).

• Check In Multiple Documents window - if you selected multiple files, the workspace
root, or a folder containing multiple files (see Checking In Multiple Documents on
page 295).

2. Select whether to check into a change list (see Change Lists on page 303). You can choose
from:

• <None> - [if you have Write permission on the target folder] Allows you to check the
item in directly without review.

• <New change list> - To create a new change list to contain the checked in item.

• Change list_xxxx - To add the item to an existing draft change list. Click the
Properties tool to the right of this field to access the property sheet of the change list.

Note: If you are checking in a new version of an item that is already contained in a draft
change list, then this field is read-only.

3. Select any other appropriate parameters (see Check-In Parameters on page 297), and click
OK to check in the document.
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If you check into a change list, you can add other documents to it as necessary through
other check ins before submitting it (see Creating, Building, and Submitting a Change List
on page 305). Once the change list has been approved by the reviewers, your changes are
integrated into the official repository versions of the models and made available to other
users. If an administrator has connected the repository to an SMTP server (see Connecting
to an SMTP Server for Notifications on page 527) you will receive an email at the moment
of submission of your change list and when it is approved, rejected, or returned to you for
further revision.

4. If you are checking in a document that is already stored in the repository, the Merge
Changes to Repository Document dialog (see Resolving Conflicts During Check In on
page 299) may open to let you review the differences between your local document and
the version in the repository. When you are satisfied, click OK to complete the check in.

Note: If you have changed the target (DBMS, OO language, etc) of the model outside of
the target family (such as moving from Oracle 11g to Sybase ASE 15.7), you will not be
able to create a new version of the existing repository document and will need to save the
model as a new document in the repository.

Checking In a Project
The Check In Project dialog guides you through checking in a PowerDesigner modeling
project along with all the models and other documents it contains.

You arrive here by right-clicking a Project in the Local tab of the Browser, and selecting
Check In. The dialog is populated with any project documents that have changes. The first
time you check in a project, you must check in all its documents; subsequently, only
documents with changes are listed and can be deselected if desired.
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For information about the parameters available in this dialog, see Check-In Parameters on
page 297.

Checking In a Model, Resource File, or Other Document
The Check In Document dialog guides you through checking in a PowerDesigner model,
resource file, or other document.

You can arrive here by:

• Right-clicking a model or file in the Local tab of the Browser, and selecting Check In.
• Selecting a model or file in the Check In Multiple Documents dialog (see Checking In

Multiple Documents on page 295), and clicking the Settings tool.
• Clicking the  Add Document tool in the Check In Multiple Documents window (see 

Checking In Multiple Documents on page 295). You must specify the model or file to
check in in the Local Document group box.

• Selecting a resource file, and clicking the Check In tool in the resource file list (see 
Sharing Resource Files via the Library on page 551).

Depending on the context, this window can take various forms:
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• Simplified (checking in a document for the first time) - Select a folder to check into (and a
changelist if required or desired), enter a comment, and click OK:

• Simplified (checking in updates to a document already in the repository) - Choose whether
to review your changes (see Resolving Conflicts During Check In on page 299) (and a
changelist if required or desired), enter a comment, and click OK:

• Advanced (when you click the Advanced button on either of the simplified dialogs):
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For information about the parameters available in this dialog, see Check-In Parameters on
page 297.

Checking In Multiple Documents
The Check In Multiple Documents dialog is used when you select more than one document for
check in.

You can arrive here by:

• Right-clicking the workspace root or a folder containing multiple documents (or manually
selecting multiple documents) in the Local tab of the Browser, and selecting Check In.

• Selecting Repository > Check In (or pressing Ctrl+Alt+C).

Note: You cannot select projects, which themselves contain multiple documents (see 
Chapter 3, Projects and Frameworks on page 47), to check in through this dialog.
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The following tools are available to manage the documents in the list:

Tool Description

Settings – Opens the Check In Document window to let you specify check in parameters for
the selected document (see Checking In a Model, Resource File, or Other Document on
page 293).

Add Document - Opens the Check In Document window to let you to specify a document to
add to the list (see Checking In a Model, Resource File, or Other Document on page 293).

Add Modified Documents in Workspace - Adds all the documents modified in the work-
space during the current session to the list.

Add All Documents in Workspace - Adds all the documents in the workspace (including
closed documents) to the list.

Add Related Document Versions – Adds all documents related to the selected document
through shortcuts or generation or other links to the list. When you check in PowerDesigner
models related by shortcuts, the models being referenced are checked in before the models
containing the shortcuts.

Delete – Removes the selected document from the list.

Check In Options – Opens the Check In Options window to allow you to specify the update
mode for changes (see Resolving Conflicts During Check In on page 299).

Move Up – Moves the selected document up in the list.

Move Down - Moves the selected document down in the list.
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Check-In Parameters
These check-in parameters allow you to control details of your check in.

Note: You can set default values for some of these parameters (see Repository Options on
page 265). Each check in is processed as one transaction. When you first check in a large
model, the server creates large rollback logs and uses a large number of locks, which may
require you to configure your server to allow such large transactions. Check ins of subsequent
versions use much smaller transactions.

The Local Document group box contains the following parameters:

Parameter Description

Workspace or File [not for project] Specifies and displays the document name by its workspace
name or file name and path.

Name Specifies the name of the document to check in. Depending on whether you have
selected Workspace or File, this is a:

• Model name - click the Properties tool to open its property sheet

• File name and path - click the Browse tool to open a file selection dialog.

Version [not for project – read-only] Specifies the current version of the model or file in
the repository, if available.

Change list Specifies the change list to check the item into (see Change Lists on page 303).
You can choose from the following:

• <None> - [if you have Write permission on the target folder] Allows you to

check the item in directly without review.

• <New change list> - To create a new change list to contain the

checked in item.

• Change list_xxxx - To add the item to an existing draft change list.

Click the Properties tool to the right of this field to access the property sheet
of the change list.

Note: If you are checking in a new version of an item that is already contained
in a draft change list, then this field is read-only.

Check out after
check in

[models and resources only] Updates the local version after check in by checking
out the repository version to ensure that you have the most up-to-date version
where other users may be working concurrently.
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Parameter Description

Check out de-
pendencies

[projects and models only] Checks out additional information about cross-model
depencies during the check out after check in, to enrich dependencies and impact
analysis information in future situations where you may be without a repository
connection (see Obtaining Cross-Model Dependencies Without a Repository
Connection on page 511).

The Repository Document group box contains the following parameters:

Parameter Description

Folder/Project [read-only after first check-in] Specifies the location where the document is
checked in. Click the Properties tool to open the property sheet of the folder.

If you do not specify a target folder, the document is checked in at the root of the
browser. You should grant individual access permissions to this document.

Name [not for project – read-only] Specifies the name of the document to apply your
changes to. Click the Properties tool to open the property sheet of the document.

Version [not for project – read-only] Specifies the version of the document to apply your
changes to.

Comment Specifies a comment to describe the purpose of the check in.

Freeze before
check in

Freezes the previous versions of any modified objects in the repository, and
creates a new version to accept the changes to be checked in (see Freezing and
Unfreezing Document Versions on page 320).

Freeze after check
in

Freezes all modified object versions after check in to ensure that no further
changes can be made to them. Future changes to objects are made to new ver-
sions (see Freezing and Unfreezing Document Versions on page 320).

Create baseline
version

Creates a completely new version of the model, instead of simply versioning the
objects that have changed. This option is available only if you have Full
permission on the document. The Merge Changes to Repository Document
dialog does not open. Baseline versions may be quicker to check in and out, but
they require considerably more disk space than standard versions.

Occasionally, the repository cannot process a standard version; in this situation,
you should try to create a baseline version that can be used as a starting point for a
new development step.

Unlock after
check in

[locked documents only] Unlocks the document version after check in (see 
Locking and Unlocking Document Versions on page 321).
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Parameter Description

Save diagrams for
PowerDesigner
Portal

[not for resources] Prepares snapshots of the model diagrams that can be viewed
in the PowerDesigner Portal (see Chapter 11, The PowerDesigner Portal on page
337). Dependency matrices cannot be viewed in the Portal.

The Project Documents group box lists the model and file documents associated with the
project, and lets you select them for check in with the project. Only project documents that are
inside the project are listed here. Documents that are outside the project and only attached to it
must be checked in separately.

Resolving Conflicts During Check In
The Merge Changes to Repository Document dialog lets you inspect and approve (or reject)
the changes you are checking into the repository. To filter the tree and show only the changes,
click the Change Filter tool and select Show All Changes. By default, all your changes are
selected to be applied.

The window is divided in three parts:
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• The Object comparison pane in the upper part of the window displays the anticipated result
of the merge on the target model. Click the Show Source Model button at the top left of the
pane to split the pane between the source and target models.

• The Property comparison pane in the middle of the window displays the properties of the
nodes selected in the model tree, listing the name of the property and its values in the From
and To models.

• The Check in comment pane lets you edit the comment that will be associated with this
check in.

For detailed information about using this dialog, see Merging Models on page 226.

You can instruct PowerDesigner to handle all or some of these conflicts (and thus suppress the
display of the Merge dialog) by deselecting the Review changes option in the simplified
Check In Document dialog or from the Check In Options dialog, which you open by:

• Clicking the Options button at the bottom of the advanced Check In Document dialog.
• Clicking the Check In Options tool in the Check In Project or Check In Multiple

Documents dialog. The options specified will apply to all the models and files being
checked in.

The following modes are available:

• Interactive - [default] Always opens the Merge Changes to Repository Document dialog to
let you review and approve or reject each change before check in.

• Batch - Automates the merging of changes and treats conflicts (where the same object has
been modified both by you and by another user) using one of the following rules:
• Use my changes – applies your changes and overwrites changes in the repository

version (even if they are to different attributes).
• Keep repository changes – retains the changes in the repository and rejects your

changes (even if they are to different attributes).
• Resolve manually – opens the Merge Changes to Repository Document dialog to let

you review and resolve conflicts.
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Checking In Packages
If you check a model into the repository, you also check in the packages it contains.

While, generally, you need the Write or Full permission to check a document into the
repository, you can check in a model on which you only have Read permission if it contains at
least one package for which you have Write or Full permission. However, note that any edits
made to packages for which you do not have Write or Full permission will be lost during check
in.

For information about checking out package, see Checking Out Packages on page 317.

Checking In External Application Documents
The link between the local document and the repository document is saved in the current
workspace. This link allows you to update a document, model or external application file, in
the repository.

To be able to update an external application document that does not belong to the current
workspace, you have to check the document out from the repository, select the Add to
Workspace check box and then save the workspace. This allows you to update the document
the next time you check it in.

Duplicating Models in the Repository
If you want to duplicate a model that has been checked into the repository, you must first check
it out and then save it as a new model (with a new GUID).

1. Select the model to duplicate in the repository, right-click it, and select Check Out to
check it out into your local workspace.

2. Select the model in your local workspace and click File > Save as New Model.

3. Select an appropriate folder and filename and click Save to create the duplicate model.

Note: The duplicate model replaces the original model in the workspace, but you can
verify that the duplication has succeeded by reading the new path in the PowerDesigner
window title bar.

4. Right-click the duplicate model and select Check In to open the Check in Document
dialog.

5. Specify the folder to check the model into and any other check-in options (see Check-In
Parameters on page 297), and click OK.

CHAPTER 10: The Repository

Core Features Guide 301



Undoing a Check In
If you want to undo a check in, you can only delete the document version created by the check
in.

Since a check in to the repository does not necessarily create a new document version (see 
Freezing and Unfreezing Document Versions on page 320), such a deletion may not always
be possible.

Temporary Protection for Updates to Repository Documents
When you check in, freeze, lock, or delete a document in the repository, all the versions of the
document are protected until the transaction is completed, and other users will receive an error
message if they attempt to update the document. For example, you cannot lock a version that
another team member is checking in, or freeze a version that someone is locking.

In rare cases, if the connection to the repository is interrupted during an update to a document,
the document may remain protected, and you may not be able to update the document in the
future until you bypass the protection or cancel the action:

• If the interruption occured during an operation launched from your workstation
(PowerDesigner verifies the machine name, not the connected user), then you can bypass
the temporary protection and continue your operation:

Note: If you have two PowerDesigner sessions running on your workstation and are
performing an operation on a document in one session, and want to perform another
operation on the same document from the second session, then you should wait for the first
operation to complete.

• If the interruption occured during an operation launched from another machine, you
should ask an administrator to unblock it. The administrator will verify that no other users
are currently updating the document and then perform an action on the document (for
example, locking it) to display the message box and click Yes to release it:
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Warning! Bypassing the protection when you are not entitled to may severely damage the
document.

Moving a Document in the Repository
You can move a document from one folder to another in the repository by drag and drop. You
must have Full permission on the document and at least Write permission on the folder you
are moving it to.

Note: You can move a document that is not in any branch structure to beneath a branch, but you
cannot move a document from beneath a branch to another branch or to outside any branch.

Change Lists
Users with the Submit permission on a repository folder or model cannot write directly to
that location, but must instead check their changes into a change list, to be reviewed by one or
more reviewers. You can add one or more models or other documents to a change list all at
once or over several check ins. Documents checked into a change list are stored in a special
folder in the repository and their contents are not available to other users until they have been
approved and integrated into the mainline.
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An administrator will determine the policies by which documents can be checked into the
repository on a global or folder-by-folder basis (see Chapter 18, Controlling Repository
Access on page 521). PowerDesigner supports the following kinds of review policy:

• Simple review - Change lists submitted by users with the Submit permission are
reviewed by a single user with the Write or Full permission.

• Peer review - Users with the Write or Full permission voluntarily submit change lists
for review.

• Direct check in - The Submit permission and change lists are not used, and users all
check in changes without review.

You can consult all the open change lists that you have created and those which are awaiting
your review under the Change Lists folder in the Browser Repository tab:
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To consult any change list, whether open or closed, containing models for which you have at
least Read permission, select Repository > Change Lists.

Creating, Building, and Submitting a Change List
When you check one or more documents into a change list, the change list is created in the
repository. You can check further changes to these documents into the change list or add other
documents to it. Once you are satisfied with the set of changes contained in your change list,
you can submit it for review. After submission, you can no longer edit it.

Note: If you have only Submit permission on a document, you are required to check your
changes into a change list, while if you have Write permission or higher, you can check the
document in directly or choose to create a change list to have your changes reviewed by a
peer.

1. Choose one or more models, projects, or other documents in your local workspace, right-
click them, and select Check In (see Checking Documents into the Repository on page
291).

2. Choose New change list in the Change list field, enter a Comment to explain your
changes, set any other appropriate options (see Check-In Parameters on page 297), and
click OK.

If you are checking in a document that is already stored in the repository, the Merge
Changes to Repository Document dialog (see Resolving Conflicts During Check In on
page 299) may open to let you review the differences between your local document and the
version in the repository. When you are satisfied, click OK to complete the check in.

The change list is created in the repository, and your model updates are saved to it. You can
consult the change list under the Change Lists folder in the Browser Repository tab, and
has a draft icon:
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3. [optional] Check in further changes to the documents in your change list or add other
documents to it by selecting it in the change list dialog, until you have a complete set of
changes that you want to submit for approval.

Note: The documents that you add to a change list must form a coherent set of changes that
can be appropriately reviewed.You can only add documents to a change list if one or more
other users has explicit Write permission on all the documents included. If you try to add a
document that does not share at least one competent reviewer with the documents already
included in the change list, then your check in will be canceled and the change list not
updated.

4. Right-click the change list in the Repository tab of the Browser and select Submit to open
its property sheet.

5. Enter a final comment, and click Submit to submit your change list for review.

The icon of the change list changes to show that it has been submitted:

You can no longer edit it or check further changes into it. If an administrator has connected
the repository to an SMTP server (see Connecting to an SMTP Server for Notifications on
page 527), you will receive an email confirming the submission, and any users with
Write or higher permission on all the documents included in the change list will receive
an email inviting them to review it. When the change list is approved, rejected, or returned
to you for revision, you will receive a further email.

Reviewing a Change List
If you have Write or higher permission on all the documents included in a change list
submitted by another user, then you can review it and determine whether to approve the
changes, reject them, or return the change list to the user requesting her to revise it. When you
connect to the repository a message in the Output window notifies you if you have change lists
to review.

Note: If an administrator has connected the repository to an SMTP server (see Connecting to
an SMTP Server for Notifications on page 527), you will receive an email when the user
submits the change list, inviting you to review it.

1. Open the Repository tab of the Browser and expand the Change Lists folder to view all the
change lists awaiting your review, which are identified by their "submitted" icon:

2. Double-click a change list to view its properties (see Change List Properties on page 310),
and read the Comment field to understand the reason for the changes.

3. Click the Documents tab and review the documents that are included in the change list.
The documents in the list display status icons to identify whether further changes have
been checked into the mainline version by other users since the change list version was
created:
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Change List Docu-
ment Status

No Locks Mainline Locked
by You (Green
Padlock)

Mainline
Locked by Oth-
er (Red Pad-
lock)

Change list creates new
document (red cross)

N/A N/A

Changes in change list ver-
sion (red checkmark)

Changes in both change list
and mainline versions (yel-
low exclamation point and
red checkmark)

4. [recommended] Right-click any models that are shown as having subsequent changes on
the mainline and select Update from Mainline to merge these changes into the change list
version (see Resolving Conflicts During Check In on page 299).

Merging modifications from the mainline ensures that you are reviewing the change list
changes in the most up-to-date context, and will also simplify the approval process.

5. Perform the following actions on a document by right-clicking it or using the toolbar:

• Check Out - Check the submitted version of the document out into your local
workspace to review it in more detail (see Checking Documents Out of the Repository
on page 311).

• Compare - Compare the submitted version of the document in the change list with the
mainline version in the repository (see Comparing Models on page 223).

• Find in Open Change Lists - Open the List of Change Lists filtered to display only
open change lists containing the document.

6. Document your agreement with the changes proposed or explain why you will reject the
changes or return them to the submitter for modification in the Comment field of the
change list.

7. When you have completed your review, if the property sheet of the change list is open,
close it in preparation to approve, return, or reject the changes it contains.

Approving, Returning, or Rejecting a Change List
Once you have reviewed a change list, you can approve it and apply the changes to the
mainline, or to reject it or return it to the submitter for modification.

1. Open the Repository tab of the Browser and expand the Change Lists folder to view the
change list that you want to approve, reject, or return for revision.

2. [recommended] Open the change list property sheet to the Documents tab. Right-click
any models that are shown as having subsequent changes on the mainline and select
Update from Mainline to merge these changes into the change list version (see Resolving
Conflicts During Check In on page 299).
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Merging modifications from the mainline ensures that you are reviewing the change list
changes in the most up-to-date context, and will also simplify the approval process.

3. If the property sheet of the change list is open, close it, then right-click the change list in the
Browser and select:

• Approve - to approve the changes in the included documents and merge them into the
mainline to make them available to all users with the necessary permissions. Enter any
appropriate final comment and click the Approve button. For each PowerDesigner
model included in the change list, an Integration dialog is displayed, in which you can
review the changes one last time before integrating them into the mainline (see 
Resolving Conflicts During Check In on page 299).

Warning! Once you begin the approval process, the mainline versions of all the
documents in the change list are locked (see Locking and Unlocking Document
Versions on page 321) to enable the changes to be integrated as a coherent transaction.
If you click Cancel before having integrated the entirety of the changes in each of the
documents, then all the documents will remain locked until you complete the approval
process. You can recommence the approval process at any time from the point at which
you canceled it.

• Return for Revision - to return the change list to the user with a request to make any
changes required for you to approve it. Enter a comment explaining the changes to be
made and click the Return button.

• Reject - to reject the changes submitted in the change list. Enter a comment explaining
your reasons for rejecting the change list and click the Reject button.

In each case, if an administrator has connected the repository to an SMTP server, the
change list owner and any other potential reviewers receive emails notifying them of the
approval, rejection, or return of the change list.
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Consulting the List of Change Lists
To consult any change list, whether open or closed, containing models for which you have at
least Read permission, select Repository > Change Lists.

In addition to the standard in-column filters, this list features the following meta-filters above
the list:

• User - Shows only change lists for which the selected user is the creator or reviewer.
• Location - Shows only change lists containing models or other documents in the selected

folder.
• Document - Shows only change lists containing documents beginning with the characters

entered. The list filters dynamically after you have entered the first few characters.

You can filter on all three criteria in combination and your filter is remembered the next time
you open the list. To remove all filters, click the Clear button.

Note: Though the list displays all relevant results for direct connections to the repository
hosted on most DBMSs, when connecting via the proxy or through certain DBMSs, an option
is displayed below the list to allow you to restrict the number of results to improve
performance:
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Change List Properties
Change list property sheets provide information about the change list and give you tools to
review the documents it contains.

The General tab displays information about the change list itself:

Property Description

Name / Code Specify the name and code of the change list. The name is editable, and the change
list is listed in the repository browser as code - name (for example 1234 -
My Changes.

Comment /
Comment His-
tory

The comment field contains your comments, including any comments entered
when checking in models. The read-only comment history lists the comments
entered by all users who have worked with the change list.

Location Displays the full path to the change list in the repository.

Status Displays the current status of the change list, which may be:

• Draft - Not yet submitted for review, or returned for revision.

• Submitted - Awaiting review.

• Approved - Closed with changes integrated to mainline.

• Rejected - Closed with changes rejected.

Owner Displays the user who created the change list.

Documents Tab
The Documents tab lists the documents included in the change list. The following
management tools are available:

Tool Description

Properties - Click the arrow to the right of the tool to open the property sheet of the :

• Original Mainline Version - the version of the document stored in the mainline at the
time of the change list's creation.

• Change List Version - the version of the document included in the change list.

• Updated Mainline Version - the version of the document stored in the mainline, which
includes the changes merged from the change list version.

Check Out - Checks out the change list version of the document (see Checking Documents
Out of the Repository on page 311).
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Tool Description

Compare - Opens the Select Models to Compare dialog, initialized to compare the change
list version of the selected document with the current mainline version (see Comparing
Models in the Repository on page 333).

The following tabs are also available:

• Activities - Lists the actions taken on the change list (submission, approval, etc).
• Permissions – lists those users and groups with permissions on the change list (see 

Granting Access Permissions on Repository Items on page 534). For draft change lists,
the owner has Full permission. For submitted change lists, the owner has Read
permission and reviewers have Write permission. For closed change lists, the
permissions are restricted to the lowest permission that a user has on all of the included
documents.

• Version Info - Displays the user who created the change list and the last user to modify it,
along with the dates of creation and last modification.

Checking Documents Out of the Repository
You check out documents from the Repository in order to work on them in your local
workspace. You must have at least the Read permission on a document (or on one of its
packages) to be able to check it out.

1. To check out a document not currently in your workspace, select the Repository tab of the
Browser. If you are updating an existing file, select the Local tab.

2. Select the documents to check out, then right-click and select Check Out to open the:

• Check Out Project window - if you selected a project (see Checking out a Project on
page 312).

• Check Out Document window - if you selected a single model or file (see Checking
Out a Document on page 312).

• Check Out Multiple Documents window - if you selected multiple files, the workspace
root, or a folder containing multiple files (see Checking Out Multiple Documents on
page 313).

3. Select the appropriate parameters (see Checkout Parameters on page 315), and click OK
to check out the document.

4. If you are checking out a document that is already present in your workspace (and you have
selected the Merge document option), the Check Out Document window (see Resolving
Conflicts During Check Out on page 316) will open to allow you to review the differences
between the version in the repository and your local version. When you are satisfied, click
OK to complete the check out.
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Checking out a Project
The Check Out Project dialog guides you through checking out a PowerDesigner modeling
project along with all the models and other documents it contains.

You can arrive here by:

• Right-clicking a project in the Repository tab of the Browser, and selecting Check
Out.

• Right-clicking a project in the Local tab of the Browser, and selecting Update from
Repository.

For information about the parameters available in this dialog, see Checkout Parameters on
page 315.

Checking Out a Document
The Check Out Document dialog guides you through checking out a PowerDesigner model or
other document.

You can arrive at this window in any of the following ways:
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• Right-clicking a model or file in the Repository tab of the Browser and selecting Check
Out.

• Right-clicking a model or file in the Local tab of the Browser and selecting Update from
Repository.

• Selecting a model or file in the Check Out Multiple Documents window (see Checking Out
Multiple Documents on page 313) and click the Settings tool.

• Clicking the Add Document tool in the Check Out Multiple Documents window (see 
Checking Out Multiple Documents on page 313). You must specify the model or file to
check out in the Local Document group box.

• Select a resource file, and click the Update from Repository tool in a resource file list.

For information about the parameters available in this dialog, see Checkout Parameters on
page 315.

Checking Out Multiple Documents
The Check Out Multiple Documents dialog is used when you select more than one document
for check out.

You can arrive here by:

• Right-clicking the workspace root or a folder containing multiple documents (or manually
selecting multiple documents in the Repository tab of the Browser, and selecting Check
Out.

• Right-clicking the workspace root or a folder containing multiple documents (or manually
selecting multiple documents in the Local tab of the Browser, and selecting Update from
Repository.

• Selecting Repository > Check Out(or pressing Ctrl+Alt+E).
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Note: You cannot select projects, which themselves contain multiple documents (see 
Chapter 3, Projects and Frameworks on page 47), to check out through this dialog.

The following tools are available in this window:

Tool Description

Settings – Opens the Check Out Document window to let you specify check out param-
eters for the selected document (see Checking Out a Document on page 312).

Add Document Version - Opens the Check Out Document window to let you to specify a
document to add to the list (see Checking Out a Document on page 312).

Add Related Document Versions – Adds all documents related to the selected document
through shortcuts or generation links to the check out list.

Add Document Versions from a Configuration – Opens a selection window allowing you
to add all the document versions included in a configuration to the list (see Grouping
Document Versions in a Configuration on page 322).

Delete - Removes the selected document from the list.

Move Up - Moves the selected document up in the list.

Move Down - Moves the selected document down in the list.
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Checkout Parameters
The checkout parameters allow you to control details of your check out.

Note: You can set default values for some of these parameters (see Repository Options on
page 265).

The Repository (Document) group box contains the following parameters:

Parameter Description

Name Specifies the name of the document to be checked out from the repository.

Version [not for projects] Specifies the version of the document to check out.

Configuration [projects only] Specifies the configuration containing the project models and
files to check out or (if no configuration is specified) the latest project models and
files versions held in the repository. You create a project configuration by right-
clicking a project node in the Repository tab of the Browser (see Grouping
Document Versions in a Configuration on page 322).

Packages [models only] Click the button to open a package selection dialog box to specify
individual packages to check out instead of the entire model (see Checking Out
Packages on page 317).

Check out de-
pendencies

[projects and models only] Checks out additional information about cross-model
dependencies, to enrich dependency and impact analysis information in future
situations where you may be without a repository connection (see Obtaining
Cross-Model Dependencies Without a Repository Connection on page 511).

Lock before
check out

Locks the selected version of the document before checking it out, to prevent
other users from modifying it. This option is available only to users who have the
Lock Versions right.

The Check Out To File or Local group box contains the following parameters:

Parameter Description

Check out to file Checks out the model to a file on your local machine. This option can be unse-
lected only for PowerDesigner models, which can be loaded in memory and
added to your workspace without creating a file.

Path Specifies the path of the file or (projects only) folder to which the document will
be checked out. Click the Select File tool to the right of this field to browse for a
location.
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Parameter Description

Merge document Opens the Check Out Model window (see Resolving Conflicts During Check Out
on page 316), to allow you to compare the local and repository versions of a
document, and to review and approve or reject differences for checking out. If
you check out multiple documents, they automatically replace the existing docu-
ment versions, and are not merged with them.

This option is available only if you have specified a path to an existing file or
folder on your machine.

Read-only Sets the read-only flag on the file or folder after checking it out.

Open document [models and files only] Opens the document after checking out, either in the
current PowerDesigner workspace or in an external application.

Add to workspace [models and files only] Adds the checked out document to the current workspace.

The Project Documents group box lists the model and file documents associated with the
project, and lets you select them to be checked out with the project. Only project documents
that are inside the projects are listed here. Documents that are outside the project and only
attached to it are not listed and must be checked out separately.

Resolving Conflicts During Check Out
The Merge Changes to Local Document dialog lets you inspect and approve (or reject) all the
changes you are checking out of the repository.

This dialog will open if you are checking out a PowerDesigner model to an existing file on
your computer and you have selected the Merge model option.
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The repository version of the model that you are checking out is displayed in the left pane, and
the local version is in the right pane. To filter the tree and show only the changes, click the
Change Filter tool and select Show All Changes. By default, all the changes from the
repository are selected to be applied. For detailed information about using this dialog, see 
Merging Models on page 226.

Checking Out Packages
By default, when you check out a PowerDesigner model, all its packages on which you have
Read, Write, or Full permissions are checked out with the model. Packages with List or no
permissions cannot be checked out.

If you do not want to check out a complete model, you can select one or more packages to
check out from the Select Packages dialog box, which displays the packages on which you
have Read, Write, or Full permissions.

If you select a parent package, PowerDesigner automatically extends the selection to sub-
packages. If you deselect some sub-packages in the package tree, the selection of the parent
packages is grayed to indicate this. If you select a sub-package, PowerDesigner automatically
extends the selection to parent packages to preserve the context of the sub-package.
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Action Selection Impact

Select modelingproject Package 1, 2, and 3 are automati-
cally selected

Deselect Package 1 Package 2, and 3 are automatically
deselected

Select Package 3 Package modelingproject, 1, and 2
are automatically selected

Deselect Package 3 Selection check boxes in package
modelingproject, 1, and 2 are
grayed

Note: When you check out a package containing shortcuts, the package selection is extended
to include the target packages referenced by shortcuts even if you do not have the Read
permission on these packages.

Document Versions
The repository provides version tracking for changes made to documents. Details of the
current version of the document are displayed on the Version Info tab of its repository object
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property sheet, and all the previous versions including versions on other branches appear as a
tree on the Versions tab.

The following version icons can appear on this tab:

Tool Description

Branch - You create a new branch in the tree by branching (see Branching Version Trees on
page 325).

Note: Branches are displayed twice; both beneath the document version from which the
branch was created, and also as a root.

Version from direct check in - Created directly in the repository without passing by a
change list. You create a new version by freezing (see Freezing and Unfreezing Document
Versions on page 320).

Version from change list - Submitted in a change list (see Change Lists on page 303) and
approved by a reviewer.

 Version integrated from/to another branch (see Integrating Changes from One Branch to
Another on page 328).

In the example above, the document is first checked in directly, and then three versions are
checked in via change lists Robert Brown checks in the first version of the document, and
Steve Jones checks in a second version which is branched from the Existing System branch to
become the first version in the Future System Branch.
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The following tools are available on this tab:

Tool Description

Properties - Opens the property sheet of the selected version.

Change List - Opens the property sheet of the change list from which the selected version
was approved (see Change Lists on page 303).

Check Out - Checks out the selected version (see Checking Documents Out of the Repo-
sitory on page 311).

Compare - Compares two versions (see Comparing Models in the Repository on page
333).

 Freeze/Unfreeze - Freezes or unfreezes the selected version (see Freezing and Unfreezing
Document Versions on page 320).

 Lock/ Unlock - Locks or unlocks the selected version (see Locking and Unlocking Docu-
ment Versions on page 321).

Delete - Deletes the selected version (see Deleting Documents, Document Versions, and
Folders on page 334).

Note: When you check in a document, the local date is converted to GMT. It is converted again
to local time when you check the document out. This is to let you to compare document
versions stored in the repository when you are working in different time zones.

All repository documents and model objects can be versioned, but repository folders, projects,
users, and groups are not versioned. Versions other than the first or baseline version are stored
as differences from the previous version. As a rule of thumb, the baseline version of a model
stored in the repository takes twice the size as it does when saved as an XML file.

Freezing and Unfreezing Document Versions
Unlike many repository systems, the PowerDesigner repository does not require you to create
a new version of a document each time you check it in. You create a version only when you
want to, by freezing the document.

Freezing a document creates a version in the repository that you can go back to and view its
state at the point in time when it was frozen. You could choose to freeze a document (and thus
create a new version) each time you check it in, once a day, once a week, or at any other
interval.

Note: To freeze a document, you must have the Freeze versions right (see Granting
Rights to Users and Groups on page 533) and the appropriate permissions on the document.

You can freeze a document during check in (see Checking Documents into the Repository on
page 291) by selecting one or both of the following options:

• Freeze before check in - to preserve the state of the model before your changes
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• Freeze after check in - to preserve the state of the model including your changes (this
option can be selected by default if you select the Freeze after check in general option (see
Repository Options on page 265.

If you have the Write or Full permission on a document that is frozen, you can unfreeze it's
most recent version. Unfreezing a document version allows you to make further changes to the
existing version, but means that you will no longer be able to go back and view the previously
frozen state.

You can freeze a document or unfreeze its latest frozen version at any time by:

• Right-clicking the document, folder, project, or root node and selecting Freeze or
Unfreeze.

Note: To freeze or unfreeze all the documents inside a folder or branch, right-click it and
select Freeze or Unfreeze. You must have the appropriate permissions on all the contained
documents.

• By clicking the Freeze or Unfreeze tool on the property sheet of a:
• Document - on the Versions tab.
• Configuration - on the Members tab.

Note: You cannot individually control the freezing and versioning of PowerDesigner model
objects. Each changed object has its version frozen and version number increased by one each
time you freeze its parent model's version.

Locking and Unlocking Document Versions
You can lock a repository document to prevent other users from making changes to it. Only
you or a user with the Full permission on the document can check in changes to the
document until you unlock it. Generally, you will release the lock when you check in the
document.

Locked documents display a lock icon in the repository browser:

Icon Description Icon Description

Blue, if you have set the lock. Red, if another user has set the lock.

Note: To lock a document, you must have the Lock versions right (see Granting Rights to
Users and Groups on page 533) and the appropriate permissions on the document.

You can lock a document during check out (see Checking Documents Out of the Repository on
page 311) by selecting the Lock before check out option, and remove the lock during check-
in (see Checking Documents into the Repository on page 291) by selecting the Unlock after
check in option.

If you have locked a document (or have the Full permission on a document locked by another
user, you can unlock it. Unlocking a document version allows any user with the appropriate
permissions to check in changes to it.
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You can lock or unlock a document at any time by

• Right-clicking the document and selecting Lock or Unlock.

Note: To lock or unlock all the documents inside a folder or branch, right-click it and select
Lock or Unlock. You must have the appropriate permissions on all the contained
documents.

• Clicking the Lock or Unlock tool on the property sheet of a:
• Document - on the Versions tab.
• Configuration - on the Members tab.

• Selecting Repository > Administration > Locks and using the tools available on the List
of Locks:

Tool Description

Settings – Opens the Lock Document dialog for the selected document, which shows
details of the lock upon it.

Add Lock – Opens the Lock Document dialog. Select a document to lock in the Name
list and a comment, and click OK to lock it and return to the List of Locks.

Add Related Document Versions - [models only] Locks any models that the selected
model references through external shortcuts. The related models are automatically
added to the List of Locks.

Add Document Versions from a Configuration – Opens the Select Configuration dialog
box, which allows you to select a configuration for locking. Document versions con-
tained within the configuration are locked and added to the List of Locks.

Delete – Unlocks the selected document, and deletes it from the List of Locks. Note that
this tool does not delete the document version.

Grouping Document Versions in a Configuration
A configuration is a container for grouping a set of repository documents versions together to
mark a particular point in a project, such as a release or other project milestone. You must have
the Manage Configurations right to create configurations.

1. Select Repository > Configurations to open the List of Configurations.

2. Click the Add a Row tool to create a new configuration, and then click the Properties tool
to open its property sheet.

3. Enter an appropriate Name, Code, and Comment to describe the configuration.
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4. Click the Members tab to add document versions to the configuration, using the following
tools.

Tool Description

Properties – Opens the selected repository document property sheet.

Add Document Version – Opens the Add Document to Configuration dialog, which
allows you to specify the version of a document to add to the configuration.

Add Related Document Versions – [models only] Adds any models that the selected
model references through external shortcuts. The related models are automatically
added to the configuration.

Add Document Versions From a Configuration – Opens the Select Configuration
dialog, which lets you select a configuration, whose members will be added to the
configuration.

Check Out – Checks out the selected version (see Checking Documents Out of the
Repository on page 311).

Freeze/Unfreeze - Freezes or unfreezes the selected version (see Freezing and Un-
freezing Document Versions on page 320).

Lock/ Unlock - Locks or unlocks the selected version (see Locking and Unlocking
Document Versions on page 321).

Delete – Deletes the selected version from the configuration (see Deleting Documents,
Document Versions, and Folders on page 334).
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5. Click OK to return to the List of Configurations.

In the following example, the versions used for a minor release are included in a configuration
called Minor Release:
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Creating a Configuration from a Project or Folder
You can quickly create a configuration from the current versions of all the documents in a
project or repository folder by right-clicking it and selecting Create Configuration.

The property sheet of the new configuration opens. You can modify the default name and add a
comment on the General tab and modify the document versions it contains on the Members
tab (see Grouping Document Versions in a Configuration on page 322).

Checking Out a Configuration
When you check out a configuration, you check out all the document versions it contains.

1. Select Repository > Check Out to open the Check Out Multiple Documents dialog (see
Checking Out Multiple Documents on page 313).

2. Click the Add Document Versions from a Configuration tool, select the configuration to
check out, and click OK to add the document versions it contains to the list.

3. Click OK to check out the documents.

Note: When you check out a configuration containing resource files, these files may
overwrite any modifications in your local resource files. If you need to preserve your
changes, modify the path to which the configuration will be checked out.

Branching Version Trees
Users with the Manage Branches right can create branches in the repository to support
concurrent development of multiple versions of documents. Standard permissions control
read and write access to individual branches (including integrating changes made in one
branch into another).

Note: Prior to v16.1, the repository browser only supported displaying a single branch at a
time. When you upgrade an existing repository to v16.1 or higher, all branches will become,
by default, visible for all users. You may wish to simplify viewing the repository by deleting
documents and branches that are no longer used, by using permissions to hide certain branches
from users or groups who have no need of them, or by migrating active models to a new
repository (see Installation Guide > Installing the Repository > Upgrading the Repository).

You can branch the contents of any folder in the repository, but we strongly recommend
creating at least one level of sub-folders beneath the repository root and creating your
branches on one of these sub-folders.

Warning! Once you have branched a folder, you cannot add a new folder directly beneath the
branched folder as a sibling to the branches, because the entire contents of the folder is now
branched and every document and folder must necessarily belong to one or more of the
branches. If you branch the repository root, you will not be able to create any other sub-folders
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at the root level and will be constrained to placing all of your repository documents inside a
single global branch structure.

Branch names must be unique for the folder, but may be reused in another folder. In the
example above, three branches (Development, Testing, and Production) are created
in the folder /Repository/Back Office/HR, and branches with the same names are
also created in the folder /Repository/Web
Users can filter the Browser Repository tab to display only the Branches that interest them
(see Browsing the Repository on page 287).

1. Right-click the folder that you want to branch (and on which you have at least Write
permission), and select New > Branch.

Note: You cannot create sub-branches under a branch and nor can you create branches
inside a project.

2. Enter a name for the branch and select a base branch from which to copy the initial contents
of the new branch:
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The base branch can be any of the sibling branches (or Default if this is your first branch
in this location), and all the contents of the base branch will be copied to the new branch.
Alternatively, you can select None to create an empty branch.

The selected base branch is the default branch selected when you integrate items from the
new branch to another branch (see Integrating Changes from One Branch to Another on
page 328).

3. Click OK to complete the creation of the branch.

The new branch is displayed in the Browser. If it is the first branch created in this location,
then a <Default> branch is created next to the new branch. You can change the name by
right-clicking the branch and selecting Properties.

Controlling Branch Permissions
Administrators and users with the Full permission on a folder containing branches can grant
permissions on the branches from the Permissions tab of its repository property sheet.

1. Right-click a branch in the repository browser and select Permissions to open the branch
property sheet at the Permissions tab:
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2. Click the Add tool to select any users or groups that should have access to the branch for
adding to the list, and then click OK.

3. Set the Granted Permission for each user and group to an appropriate level (see Granting
Access Permissions on Repository Items on page 534).

4. Select any users or groups in the list that should not have even List access to the branch
and click the Delete tool.

Note: Users can filter the Browser Repository tab to display only the Branches that
interest them (see Browsing the Repository on page 287).

5. Click OK to complete the changes to the branch permissions.

Integrating Changes from One Branch to Another
You can integrate changes made to a model or other document (or to a project or the contents of
a folder) in one branch to another branch. You must have at least Write permission on the
branch to which you want to integrate the changes.You can select individual changes to
integrate on an object-by-object basis, and your choices are retained as defaults for subsequent
integrations.

1. Right-click the document, project, or folder in the branch containing the changes you want
to merge to another sibling branch and select Integrate. Depending on the item selected,
one of the following dialogs will open:

• For a single document, you must select the version of the document you want to
integrate and the target branch to integrate your changes to. You can optionally enter a
comment, and click the Advanced button to access the same options as are available in
the Check In Document dialog (see Check-In Parameters on page 297):
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• For a folder or project, you must select a target branch to integrate your changes to and
can optionally enter a comment:
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Note: Only documents with changes since the creation of the branch (or the last
integration) are listed and you can deselect documents in the list to exclude them from
the integration.

2. Click OK to begin merging changes from the current branch to the target branch. For
PowerDesigner models, a merge dialog (see Merging Models on page 226) opens to allow
you to review changes to individual objects:

3. Select or reject each change as appropriate and then click OK to merge the selected
changes from the current branch model to the target branch model.
If you are integrating a project or folder, an additional merge window will open for each of
the models to be integrated, to allow you to inspect and select or reject their changes. When
the final model merge window is closed, the integration is complete.

Deleting a Branch
Administrators and users with the Manage Branches right can remove unused branches
by right-clicking them and selecting Delete.

Before deleting a branch, you must delete all its contents (see Deleting Documents, Document
Versions, and Folders on page 334).

Warning! Deleting a branch cannot be undone.

CHAPTER 10: The Repository

330 SAP Sybase PowerDesigner



Impact and Lineage Analysis in the Repository
You can analyze the impact of a change to an object (impact analysis) and identify the objects
that take part in the definition of the object (lineage analysis) on any model object in the
repository by right-clicking it in the Repository tab of the Browser and selecting Impact and
Lineage Analysis.

By default, the analysis descends to only three levels of dependencies, but you can select more
or fewer levels by selecting a number in the Repository analysis level list.
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For detailed information about using this dialog, see Chapter 17, Impact and Lineage Analysis
on page 499. For information about the limitations of repository analyses, see Repository
Rule Set Limitations on page 518.

Note: By default, analyses launched from the Repository tab use the standard Global
Impact Analysis and Global Lineage Analysis rule sets delivered with
PowerDesigner and available in the Library folder. You can check additional rule sets into the
library or into another repository folder (see Checking Rule Sets into the Repository on page
517). To change the folder where PowerDesigner looks for rule sets for selection in the dialog,
use the Choose Path tool above the rule set fields.

Finding Objects in the Repository
You can search for PowerDesigner model objects in the repository. You do not need special
user rights and the List permission is sufficient for searching.

1. Press Ctrl+Alt+F, select Repository > Find Objects, or right-click the repository root, a
folder, or model in the Repository tab of the Browser and select Find Objects to open the
Find Objects dialog:

2. Specify the appropriate parameters in the different tabs of the dialog box.

For detailed information about these tabs, see Find Parameters on page 128. The repository
Find Objects dialog allows you to search by both local and repository dates.

3. Click the Find Now button. You can stop the process at any time by clicking the Stop
button.

Progress is reported in the Output pane, and the dialog remains open until the process
completes and the Result List displays the result.
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If you right-click an object in the Result list you can select:
• Properties - to display the properties of the found objects.
• Check Out Model - to check out the model containing the found object.

Comparing Models in the Repository
You can compare two PowerDesigner models to obtain a detailed list of the differences
between them. You can compare two versions of the same repository model, two different
repository models, or one repository model and one local model.

Warning! You can only compare models of the same type (for example, PDM, OOM, EAM).

1. Press Ctrl+Alt+M, select Repository > Compare, or right-click a model in the
Repository tab of the Browser, and select Compare.

2. For each of Model 1 and Model 2, select:

• A Location to specify whether the model to compare is located in your local
workspace or in the repository.
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• The Name of the model to compare. Click the Properties tool to open the property
sheet of the selected model. Select the same model in both lists if you want to compare
different versions.

• The Version of the model to compare – the most recent version is selected by default.

Note: The Version list includes only the versions in a particular branch (see Branching
Version Trees on page 325). To select a version in another branch, select the model in
the Name list and then select a version.

3. Click OK to open the Compare Models dialog:

For detailed information about using this dialog, see Comparing Models on page 223.

Deleting Documents, Document Versions, and Folders
If you have the Full permission on a document, you can delete the most recent version of the
document or delete the document (and all its versions). When you delete a document, you also
delete all the objects it contains. If you have Full permission on a folder and all its contents,
you can delete it and all the versions of all the documents it contains.
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Warning! Deleting a version, document, or folder (see Repository Folders on page 288)
cannot be undone. If you delete a document that contains objects referenced by shortcuts in
other models, these shortcuts will be shown as unresolved.

You can delete the latest version of a document by:

• Right-clicking the document in the Browser Repository tab and selecting Delete
Version.

• Opening the repository document property sheet to the Versions tab (see Document
Versions on page 318), selecting the latest version of the document (or the latest version in
a branch), and clicking the Delete tool.

To delete all the versions of a document in a branch, right-click the document and select Delete
Document.

To delete a folder, right-click it and select Delete. You must have Full permission on the
folder and all its contents.
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CHAPTER 11 The PowerDesigner Portal

The PowerDesigner Portal allows you to view the contents of your PowerDesigner repository
in your web browser. You can share your models with a wide audience, including those who
are not PowerDesigner users. Users with the appropriate rights can edit object descriptions
directly in the Browser.

Note: Before you can access the PowerDesigner Portal, an administrator must install and
configure it and provide you with a user name and password. For information about installing
the PowerDesigner Portal, see Installation Guide > Installing the PowerDesigner Portal
Server.

For information about the PowerDesigner repository, see Chapter 10, The Repository on page
287.

Logging into the PowerDesigner Portal
In order to log into the PowerDesigner Portal, you must have a repository user account, and
obtain the appropriate address for the site from your administrator. Your administrator must
also advise you which connection profile to use to connect to your repository.

1. In your web browser navigate to the web site address provided by your administrator (for
example http://server:3030/cmr):

2. Select the connection profile recommended by your administrator and enter your
repository user name and password.
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Click Show profile information to display details of the selected profile or Advanced
options to manually enter a host name and port instead of using a profile.

3. Click Logon to go to the PowerDesigner Portal home page.

Each PowerDesigner Portal page includes the following links in the top-right corner of the
screen:

• Help – to access this help document
• Language – to change the interface language
• Preferences – to review your connection parameters and change your password
• Refresh – to refresh the display
• Logout - to logout

PowerDesigner Portal Repository Explorer
The Repository Explorer is the main page of the PowerDesigner Portal, which contains a tree
view of the contents of the repository ( with a Branch Filter at the top) and, on the right, the
properties of the selected item.

To filter the Explorer tree by branch (see Branching Version Trees on page 325), click the
Filter by Branch tool and select the branches you want to view in the Branch Filter
Selection dialog. The filter works simply by name, so that branch names that are reused in
different folders are treated as the same. You can toggle the use of the filter with the Enable/
Disable Branch Filter tool.
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The explorer can contain the following types of node.

• Repository root - Displays the repository name.
• Folders - Subdivide and organize the documents in the repository.
• Branches - Allow concurrent development of multiple versions of documents.
• Projects – Group related models and other documents.
• Documents – Projects, models, multi-model reports, and external application files such as

MS Office files, or graphic files.
• Packages - Subdivide and organize model objects in models.
• Object categories - Organize model objects in models.
• Diagrams - Requires that models are checked in with the Save diagrams for the

PowerDesigner Portal option (see Check-In Parameters on page 297). You can click on
object symbols in the diagrams to go to the relevant object. Dependency matrices cannot
be viewed in the Portal.

• Model objects - Tables, classes, etc.

Repository Document and Object Properties
Click any document or model object in the repository explorer to view its property sheet.

The following tabs are available:

• General - displays basic information about the object. Users with the appropriate rights
can edit the object comment, description, and annotation. For shortcuts, click the entry in
the Target object field to open the object that the shortcut references.

• Properties - [models, packages, and model objects] displays the properties of the object.
• Diagram - [diagrams] displays the diagram. Requires that models are checked in with the

Save diagrams for the PowerDesigner Portal option (see Check-In Parameters on page
297). Click on symbols in the diagram to go to the related object.

• Sub-objects - [objects] displays a list of this type of sub-object (for example, table
columns, keys, or indexes, or class attributes or operations).

• Relationships - [objects] displays lists of the other objects with which the object is related.
• Versions - displays the various versions of the document stored in the repository, along

with information about the current version of the document, its creation and last
modification. For external application files, click the icon in the Download column to
download the file.

• Analysis - displays the impact of a change to the object (impact analysis) and identifies the
objects that take part in the definition of the object (lineage analysis) (see Impact and
Lineage Analysis in the PowerDesigner Portal on page 341).

• Permissions - [models, packages and other documents] lists those users and groups with
permissions on the document (see Adding User or Group Permissions for a Repository
Item on page 340).

• Compare - [models and objects] allows you to compare different versions of models and
objects (see Comparing Model and Object Versions on page 341).
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• Subscriptions - [projects, folders, and models] allows you to subscribe to email
notifications of changes to the object (see Subscribing to Change Notifications on page
340).

Adding User or Group Permissions for a Repository Item
You can change access permissions on an item from the PowerDesigner Portal.

Note: These permissions can also be controlled through PowerDesigner (see Granting Access
Permissions on Repository Items on page 534).

1. Click the object in the repository explorer to display its property sheet, and then click the
Permissions tab.

2. Click Add to open a selection box listing all the available users and groups.

3. Select one or more users and groups, selecting the appropriate permission for each from
the drop down list box in the Granted Permission column. The following permissions are
available:

• List - View the document or folder in the browser and in search results, and display
read-only property sheets. Users who do not have even this permission on an item
cannot see it in the repository Browser.

• Read - Additionally compare documents, and check documents out from the
repository.

• Submit - Additionally check the document into a changelist for review by a user with
Write permission.

• Write - Additionally check in (with or without a changelist), freeze, and lock
document versions.

• Full - Additionally manage permissions granted to users or groups and remove locks
on documents.

4. [optional – for projects, folders, models] Select Cascade permission changes to folder
contents to apply your changes to children of the node.

5. Click Save to save your changes and return to the Permissions tab.

The Granted Permission column shows the permissions explicitly granted to groups and
users, and Effective Permission column displays their actual permissions, the most
extensive permission granted either explicitly or by way of membership in a group.

Subscribing to Change Notifications
You can subscribe to be notified of changes made to any project, model, external application
document, or folder on which you have at least Read permission.

1. Navigate to the project, model, or folder for which you want to subscribe in the Repository
Explorer, and then click on the Subscriptions tab.
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2. Select the Email checkbox against your name in the Notification Method column, and
then click Save.

Note: If you have the Manage users right, click New on the Subscriptions tab to open a list of
users and groups, select all those whom you want to subscribe to change notifications, and
then click Save.

Comparing Model and Object Versions
You can compare two versions of a PowerDesigner model or object in the PowerDesigner
Portal to obtain a detailed list of the differences between them.

1. Click the object in the repository explorer to display its property sheet, and then click the
Compare tab.

2. Select the branches and versions numbers of the two versions of the model or object that
you want to compare.

3. [optional] Click Expand All to open all the nodes.

4. [optional] Click any of the child nodes to view changes to their properties.

For detailed information about working with this feature, see Comparing Models on page
223.

Impact and Lineage Analysis in the PowerDesigner Portal
You can analyze the impact of a change to an object (impact analysis) and identify the objects
that take part in the definition of the object (lineage analysis) on any model object in the
repository by selecting it in the Repository Explorer and clicking the Analysis tab.

By default, the analysis descends to only three levels of dependencies, but you can select more
or fewer levels by selecting a number in the Analysis level list.
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Note: By default, impact and lineage analyses launched from the PowerDesigner Portal use
rule sets checked into the Library folder at the root of the repository.

For detailed information about using this feature, see Chapter 17, Impact and Lineage
Analysis on page 499.

Editing Object Comments and Descriptions
Users with the Submit, Write, or higher permission on a model can edit the Comment,
Description, and Annotation properties of its objects directly in the PowerDesigner Portal.

Note: For information about object permissions, see Adding User or Group Permissions for a
Repository Item on page 340.

1. Navigate to the object whose properties you want to edit in the Repository Explorer and
select the General tab.

2. Make any appropriate modifications directly in the text-only Comment field and the RTF
Description or Annotation fields.
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The RTF fields provide integrated toolbars to allow you to modify the font (Arial, Comic
Sans, Courier New, Tahoma, Times New Roman, and Verdana), font size, and appearance,
to change justification and add bulleted lists, images (BMP, JPEG, non-animated GIF, and
PNG), tables, and links.

3. Click the Save button to save your changes.

Warning! If you navigate to another object without clicking Save, all of your changes will
be lost.

If you have the Write permission or higher, your check in is completed and is
immediately available to other users.

4. [if you have the Submit permission] A message box warns that you may not directly
submit changes to the model and invites you to create a change list for review. Click OK to
proceed with creation of the change list.

Note: If you click Cancel your proposed changes will be lost.

The change list is created, and the new version of the model is created under the change
list.

5. [optional] Make further edits to the objects in the model in the change list.

Note: Only one model can be added to a change list created in the PowerDesigner
Portal.

6. When all your changes to the model have been completed, click the Submit button on the
change list or any object in the model, enter a comment to describe the changes contained
in the change list, and click OK.
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The change list is now submitted and you can no longer make edits to the model contained
in it. The change list will be reviewed by a user with the Write permission or higher and,
if approved, integrated into the mainline, where your changes can be seen by other users.

For general information about change lists, see Change Lists on page 303.

PowerDesigner Portal Search
You can search for PowerDesigner model objects in the PowerDesigner Portal via the Search
box in the header. You cannot search external application documents. You must have at least
the Read permission to find objects.

1. Enter your search string in the search field.

The following special operators are supported:

Example Returns

sales Objects containing the text sales.

sales AND account (or +sales
+account)

Objects containing the text sales and ac-
count.

sales AND NOT account (or
+sales -account)

Objects containing the text sales but not ac-
count.

sales OR account (or sales
account)

Objects containing the text sales or ac-
count.

CHAPTER 11: The PowerDesigner Portal

344 SAP Sybase PowerDesigner



Example Returns

sales~ Objects containing text like sales.

"sales account" Objects containing the exact string sales ac-
count.

sal?s Objects containing text such as sales or
salts (? represents a single wild card charac-
ter).

sal*s Objects containing text such as sales or sal-
aries (* represents one or more wild card
characters).

2. Click the Quick search button to display your results in the Search tab:

Click on a result line to display the object's property sheet.

Advanced PowerDesigner Portal Search
You can perform searches with more complicated and multiple criteria from the Search tab.
To use a saved search, click its Run button.
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1. Click the Search tab and then click New Search.

2. [optional] Select a node in the Repository Explorer tree such as a branch, project, or model
to restrict the scope of your search. By default, you search the entire repository.

Note: Searching the entire repository may take a long time. You should, wherever
possible, try to restrict the scope of your search.

3. [optional] Select a model type and an object type to search. By default, you search all
model types and all object types.

In this example, I select Physical Data Model and Table:

4. Select a property, operator and value to search against. Depending on the property that you
select, the choice of operator may be restricted and/or values may be suggested. Note that
the case sensitivity of your searches depends on your repository DBMS.

When using the Contains operator, the following special characters allow you to use
basic regular expressions for text searches:
• * - none to any number of characters

For example: W* finds "Work" and "Washington"
• ? – exactly one character

For example: ????ER finds "Writer" and "Seller" but not "inner"
• \ - escapes *, ?, or \
• true/false - Boolean value (True is when the check box is selected in the interface)

5. Click the Add button to add the complete search clause to the Search clause table.

In this example, I choose to search for tables that are selected for generation:
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6. [optional] Create additional search clauses and add them to the Search clause table,
choosing one of the following conjunctions:

• AND – results must satisfy all clauses
• OR – results must satisfy one of the clauses

In this example, I refine my search to look only for tables that are estimated to have more
than 100 records:

7. [optional] Click the User & Date tab and specify additional search clauses based on user
names and creation and modification dates.
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8. [optional] Click the Glossary tab and specify additional search clauses based on glossary
objects (terms, related terms, synonyms, and keywords) with which objects may be
associated.

9. [optional] Click the Result Columns tab and select the columns that you want to display
on the result page. By default, only the object type and name are shown.

10. [optional] Select the Include Shortcuts check box to include shortcuts to objects in your
search results.

11. Click the Search button to start your search.

Your search results are displayed. Click on an object to display all its available properties:

12. [optional] After performing a search, you can:

• Select either pdf or xls and click the Report button to generate an Excel or PDF version
of your results.

• Select an attribute, enter a value in the search box at the top of the screen and click the
Search within results button to further refine your search.

• Click the Back button and:
• Modify your search string.
• Enter a Saved search name and description and then click the Save button to make

your search available for reuse on the Search page.
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PowerDesigner Portal Users and Groups
Repository users with the Manage users right can view, create, modify, and deactivate
users and groups, and manipulate their assignment to groups via the PowerDesigner Portal.

Users and groups can be created here or through PowerDesigner (see Chapter 18, Controlling
Repository Access on page 521).

Creating a Repository User
You can create users on the Users and Groups tab.

1. Click the Users and Groups tab and click on Users on the left of the screen to display the
list of users.

2. Click New, select to create a PowerDesigner or external user, and enter a login name.

Note: External users and groups are those for whom authentication is delegated to an
LDAP server. Note that remote users and groups can be added to local groups, but local
users and groups cannot be added to remote groups.

3. [local users only] Enter a full name, email, and description for the user. An email address is
required if the user is to receive change notifications.

4. [optional] Click the Parent Groups tab and add the user to any appropriate groups (see 
Adding a Member to a Group from the Member's Property Sheet on page 351).

5. [optional] Click the Rights tab and assign the user any appropriate rights (see Granting
Rights to Users and Groups on page 350).

Note: When you create a user, make sure you grant him/her access rights on repository
documents, either by inserting this user into a group, or directly. If a user connects to the
repository without access rights, he cannot see any documents in the browser.

6. Click Save to create the user and return to the list of users.
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Creating a Repository Group
You can create groups on the Users and Groups tab.

1. Click the Users and Groups tab and click on Groups on the left of the screen to display
the list of groups.

2. Click New, select to create a local or remote group, and enter a group and full name.

3. [optional] Enter an email address and/or a description for the group.

4. [optional] Click the Members tab and add any appropriate users to the group (see Adding
a Member to a Group from the Group's Property Sheet on page 351)

5. [optional] Click the Rights tab and assign the group any appropriate rights (see Granting
Rights to Users and Groups on page 350)

Note: Rights granted to a group are inherited by its members. If a user connects to the
repository without access rights, he cannot see any document in the browser.

6. Click Save to create the group and return to the list of groups.

Granting Rights to Users and Groups
Each repository user and group has a set of rights that govern its interactions with the
repository. A new user has only the Connect right assigned by default, and a new group has
no rights. You can assign rights to users and groups on the Rights tab of their property sheets.

User and group rights can be associated with permissions on documents to define the actions a
user or group can effectively perform on a document.

1. Click the Users and Groups tab, select Users or Groups on the left of the screen, and click
the appropriate entry in the list to go to its property sheet.

2. Click the Rights tab and select the check boxes corresponding to the rights you want to
assign. The following rights are available:

• Connect - To connect to the repository.

• Freeze - To freeze document versions.

• Lock - To lock document versions.

• Edit PowerDesigner Portal Objects - To edit objects in a Web browser
(see Editing Object Comments and Descriptions on page 342).

• Manage branches - To create, modify, and delete branches.

• Manage configurations - To create, modify, and delete configurations.

• Manage all objects - To create, check in, check out, unlock, unfreeze, define
permissions, and delete any document version.

Note: This right is typically granted to data administrators, and implicitly includes
Full permission on all repository documents to allow them to check in, freeze, lock,
and delete any document.
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• Manage users - To create, modify and delete repository users and groups, grant
rights to users and groups, and add users or groups to a group.

• Manage repository - To create, upgrade, and delete the repository database.

3. Click Save to save your changes and return to the list of users or groups.

Adding a Member to a Group from the Member's Property Sheet
You can add a user or a group to a group from the prospective member's property sheet. When
the member is added to the group he will benefit from the rights associated with that group.

1. Click the Users and Groups tab, select Users or Groups on the left of the screen, and click
the appropriate entry in the list to go to its property sheet.

2. Click the Groups tab to display the list of available groups and the list of groups to which
the user or group belongs:

3. Select one or more groups from the Available groups list, and then click the right-pointing
arrow to move them to the Parent groups list.

4. Click Save to save your changes and return to the list of users or groups.

Adding a Member to a Group from the Group's Property Sheet
You can add a user or a group to a group from the receiving group property sheet. When the
member is added to the group he will benefit from the rights associated with that group.

1. Click the Users and Groups tab, select Groups on the left of the screen, and click the
appropriate entry in the list to go to its property sheet.

2. Click the Members tab to display the list of available members and the list of child
members:
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3. Select one or more members from the Available members list, and then click the right-
pointing arrow to add them and move them to the Child members list.

4. Click Save to save your changes and return to the list of groups.

Deactivating a User
The repository administrator or a user with the Manage Users right can deactivate users,
canceling their rights and permissions in the repository. A user cannot deactivate himself.

1. Click the Users and Groups tab, and select Users on the left of the screen to display the
list of users.

2. Select a user in the list, click the Deactivate button, and then confirm the deletion by
clicking OK.

The user remains in the List of Users but his rights and permissions are canceled. Select the
Show deactivated members checkbox above the list of users to see users who are no
longer active. You cannot add a new user with the same username as a deactivated member.

Deleting a Group
The repository administrator or a user with the Manage Users right can delete groups from the
repository. When you delete a group you do not delete the members (either users or groups) of
the group.

1. Click the Users and Groups tab, and select Groups on the left of the screen to display the
list of groups.

2. Select a group in the list, click the Delete button, and then confirm the deletion by clicking
OK.

The group is removed from the list. Deleting a group has the following effects:
• The users who belonged to the group lose the group rights
• All permissions on documents granted by the group and subscriptions via the group are

canceled
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• The group is removed from the groups to which it belonged
• The group is no longer displayed in the list of groups

PowerDesigner Portal Settings
The Settings tab lists various parameters that administrators can use to control the server and
client components of the PowerDesigner Portal.

PowerDesigner Portal Client Settings
The PowerDesigner Portal provides a number of client settings that you can modify on the
Settings page.

Logging
The following settings allow you to control logging:

Setting Description

Log file name Specifies the name to give to the log file.

Log level Specifies the minimum level of importance for the messages to be written to the
log file.

Rollover by Specifies how the log file should be rolled over. You can choose between:

• Time/Date – the file rolls over after a certain time. Specify the duration and the
format of the log file name in the date pattern field below.

• File size – the file rolls over when it reaches a certain size. Specify the max-
imum file size in the field below.

Truncate the log
file after the
server starts

Specifies to create a new log file each time the server is restarted.

To view the log file directly in the browser, select the level of message that you want to view
and, optionally, a keyword to search on, and then click the Search button. Click the View
button to view the file in a separate window.

SSL Connection
The following settings allow you to control SSL connections. You must log out and log back in
again for changes to take effect:
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Setting Description

Keystore file
name

Specifies the name of the keystore file, a database used by the security provider to
store public and private key certificates, used by the security socket connection. A
default client.keystore file is provided for the test environment.

KeyStore file
path

Specifies the path to the keystore file. The default is CMR_HOME/keystore.

TrustStore pass-
word

Specifies the TrustStore password, used to access the keystore file. The default for
the test environment file is "changeit". We recommend that you change the Trust-
Store password and regenerate the certificates and keystore files.

Theme
The following settings allow you to control the look of the site:

Setting Description

Color theme Specifies the color scheme used for the site pages.

Logo picture Specifies the logo image used in the site title bar. Use the Browse button to locate
an image to use, and the Upload button to upload it to the site.

Logo title Specifies the title used in the site title bar.

Creating a New Color Theme
You can create new color themes for the PowerDesigner Portal. To do so, you will need to be
comfortable editing image and css files.

1. Go to install_dir\Tomcat\webapps\cmr\theme and make a copy of one of
the existing color theme directories to use as the basis of your new theme.

2. Rename the copied directory to the name that you want to see in the Color theme list on the
Settings page.

3. Go to new_theme_dir\images\css-images\dgm to view all the component
images that are used to construct the PowerDesigner Portal site.

4. Open each of the images in turn in your image editor, make appropriate, consistent
changes to their color schemes, and then save them back into the folder.

5. Go to new_theme_dir\css and open cmr.css in your text editor to view the css
code that controls the look of other elements of the PowerDesigner Portal site.

6. Make appropriate changes to the background-color and color statements and then save
your changes.

7. Navigate to the PowerDesigner Portal site in your Web browser and click the Settings tab.
Click Refresh to ensure that your changes are taken into account by the server.

8. Click Settings > Client settings > Theme and select your new color theme from the list.
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9. [optional] Select an image to use as your site logo and enter a new logo title for your site.

10. Click Save to apply your changes.

PowerDesigner Portal Server Settings
The PowerDesigner Portal provides a number of server settings that you can modify on the
Settings page.

General
The following general settings are available. You must restart the PowerDesigner Portal for
changes to take effect:

Setting Description

Name Specifies the name of the repository.

Comment Describes the repository.

Session timeout
(min)

Specifies the amount of time that the browser session is permitted to be idle before
it is automatically logged out.

Max users Specifies the maximum number of users that may connect to the PowerDesigner
Portal at any one time.

Object cache
size (MB)

Specifies the amount of memory assigned to object caching. The default is
128MB. Increasing this value will improve performance.

LDAP
The following LDAP settings are available and can be set here or through PowerDesigner (see
Connecting to an LDAP Server for User Authentication on page 524). You must restart the
PowerDesigner Portal for changes to take effect:

Parameter Description

Server type Specifies the type of the LDAP server and sets default values for the server. The
following types are available:

• Active Directory - if your environment supports anonymous binding, you may
be able to connect without further configuration. Click the Test Connection
button and follow the instructions on the dialog.

• Netscape Directory Server

• OpenLDAP

• Oracle Directory Server

• Other

If you edit any parameters and want to revert to the defaults, click the Default
Settings button.
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Parameter Description

Provider URL Specifies the URL for the LDAP provider. By default, for Active Directory, Pow-
erDesigner will automatically detect the nearest LDAP server and use this for
authentication, initializing this field to:

LDAP://_ldap.domain:389
For other servers, this field is initialized to:

LDAP://ldap.domain:389

and you should replace ldap with the name or IP address of your LDAP server.

Use Secure
Socket Layer
(SSL)

Instructs PowerDesigner to connect to the LDAP server using SSL, changing the
LDAP provider port to the standard secure 636. If you have deployed the Pow-

erDesigner Portal, you must obtain and register a certificate authority certificate in
the Java installation (see Importing an LDAPS Certificate for the PowerDesigner
Portal on page 360).

Note: In most corporate environments using Active Directory, the necessary cer-
tificate is already registered on client machines. If this is not the case, or for other
LDAPS servers, users installing PowerDesigner will need to contact their admin-
istrator to obtain a certificate and use \Windows\Sys-
tem32\certmgr.msc to register it. Right-click Trusted Root Certifica-

tion Authorities and select All Tasks > Import, then follow the wizard instruc-
tions.

Default search
base

Specifies the level at which the query begins its search for users in the LDAP tree.
By default this is initialized to the domain components (DCs) of the LDAP server.
For example:

dc=sybase, dc=com
You could include the location of the User directory such as OU=Users,
dc=devpd, dc=local . If the location of the User directory is not specified

here, then you must include it in the Authentication Search Base.

Anonymous
bind

[default] Specifies that the LDAP server supports anonymous access. If you de-
select this parameter, you must specify a bind user distinguished name (DN) and
password for an account that has permissions to query the LDAP server.

Note: If the Bind user DN is in the same DN as the Authentication search base
then you can simply enter the user id for the search. Otherwise, you must enter the
full DN for that account. For example, if the Default search base is ou=peo-
ple,dc=Onebridge,dc=qa, and you have a user cn=csit-
est,cn=users,dc=Onebridge,dc=qa, then the Bind DN must be

cn=csitest,cn=users,dc=Onebridge,dc=qa.
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Parameter Description

Auto-create user
accounts in re-
pository

Specifies that any users corresponding to the LDAP authentication search filter can
connect to the repository, and will have an account created for them in the repo-
sitory when they do so. If you do not select this option, then an administrator must
create an account for each user before they can connect.

Search filter Specifies the LDAP query that selects users for authentication. By default this is
initialized to (for Active Directory):

(&(objectClass=person)(userPrincipalName={uid}))
and for other servers:

(&(objectClass=person)(cn={uid}))
To determine an alternative filter, you must know the properties of the users de-
fined in the Active Directory, and which property (for example, name or sa-
mAccountName) is being used as the login name.

Search base Specifies the location of the User list in your LDAP server. By default this is
initialized to the same value as the Default search base. If the default search base
does not include your users you must specify an appropriate search base here.
Users may be in a common node such as cn=Users or an organization unit such

as OU=Users. To determine the correct search base, you should use an LDAP

browser to look at the full distinguished name of a user. Note that your Bind DN
may be a user in a different node in the tree than general users so it is very important
that you have the correct information for each.

Search scope Specifies the scope of the authentication search. You can choose between:

• subtree - [default] the search begins at the level of the Search base and also
searches any subnodes.

• onelevel - only the level specified in the the Search base is searched

Authentication
method

Specifies the method to use for authentication requests. You can choose between:

• simple - [default] clear text authentication. If SSL is enabled, then the pass-
word will be encrypted.

• DIGEST-MD5 - hashed password authentication. If you select this option, you
must specify a digest format.

Logging
For information about the Logging settings, see PowerDesigner Portal Client Settings on page
353.

CHAPTER 11: The PowerDesigner Portal

Core Features Guide 357



Database
The following database settings are available. You must restart the PowerDesigner Portal for
changes to take effect:

Setting Description

Database type Specifies the type of DBMS that hosts the repository.

Database driver Specifies the driver used to connect to the repository database.

Host [required] Specifies the name of the host machine for the repository database.

Port [required] Specifies the port number of the host machine through which the re-
pository database is available.

Database name Specifies the name of the repository database.

User name Specifies the database user name that the repository uses to access the DBMS.

Password Specifies the database password that the repository uses to access the DBMS.

Isolation level Specifies the isolation level used to isolate transactions in a multi-user environ-
ment. By default, level 1 is used for ASA databases and level 2 for ASE. See your
DBMS documentation for information about the behavior of each level in your
environment.

Initial pool size Specifies the initial number of connections in the connection pool. The default is
1.

Min idle Specifies the minimum connection idle time.

Max idle Specifies the maximum connection idle time.

Max wait (msec) Specifies the maximum connection wait time.

Max active Specifies the maximum permitted number of connections to the database.

Charset [ASE only] Specifies the character set used by the database.

Search
The following search settings are available. You must restart the PowerDesigner Portal for
changes to take effect:

Setting Description

Index Informa-
tion

Specifies the last time the search index was rebuilt, the next time it will be built, its
location, size, and the number of attributes indexed.
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Setting Description

Index rebuild in-
terval

Specifies the interval between rebuilds of the search index in minutes. By default,
the index is rebuilt every 120 minutes. Click the Rebuild Index button to perform
an immediate rebuild.

Security
The following password policy settings are available and can be set here or through
PowerDesigner (see Defining a Password Policy on page 528). You must restart the
PowerDesigner Portal for changes to take effect:

Setting Description

Password length Specifies the minimum and maximum permitted length of pass-
words. This option cannot be disabled. The minimum minimum
length for a password is 6 characters.

Password must contain Specifies that passwords must contain at least one of each of the
character types selected.

Disallow reuse of previous x
passwords

Prevents users from reusing the specified number of old pass-
words.

Enforce changing of passwords
after x days

Requires that users change their passwords after the specified
number of days.

Block inactive users after x days
without connection

Blocks users if they try to log in after the specified number of days
of inactivity.

Temporarily block users for x
minutes after y failures to log in

Blocks users for the specified number of minutes if they submit an
invalid combination of username and password the specified
number of times.

Temporary passwords issued by
an administrator are valid for x
days

Specifies the period for which temporary passwords (which are
issued when a user is created or unblocked) are valid. Users at-
tempting to use a temporary password after this time will be
blocked.

Notification
The following change notification settings are available and can be set here or through
PowerDesigner (see Connecting to an SMTP Server for Notifications on page 527):

Setting Description

SMTP host Specifies the host name of the SMTP server used to send mail.

SMTP port Specifies the port number of the SMTP server used to send mail.

CHAPTER 11: The PowerDesigner Portal

Core Features Guide 359



Setting Description

Sender's email address Specifies the email address from which to send mails.

Use Secure Socket Layer (SSL) Specifies to connect to the SMTP mail server through SSL.

Server requires authentication Specifies that the SMTP server requires authentication. If you
select this option, then you must specify an SMTP account and
password, and can instruct PowerDesigner to use Secure Password
Authentication (SPA).

In addition, you can control the content of notification emails by selecting items in the Mail
template list and overriding the default text associated with them.

Importing an LDAPS Certificate for the PowerDesigner Portal
If you are required to connect to your LDAP server using SSL, then you must request a
certificate from the LDAP server administrator and import it into your PowerDesigner Portal
installation. Importing the certificate allows the PowerDesigner Portal to contact the LDAPS
server to authorize users wanting to connect.

This procedure explains the process for importing the certificate into the default Tomcat
keystore file at install_dir/keystore/common.keystore. For security purposes, we recommend
that you generate your own key and keystore file. The keystore information is saved in the
following file: install_dir/keystore/config/cmrcommon.xml.

1. [recommended] Create a backup of the JRE certificates file, $JAVA_HOME\jre\lib
\security\cacerts.

2. Copy the LDAP server certificate to $JAVA_HOME\jre\lib\security.

3. Import the certicate into the keystore with the command:

keytool -import -file certificate_name.pem -keystore
cacerts

4. Enter the keystore password to complete the import.

5. Restart the PowerDesigner Portal to allow it to obtain the certificate.

PowerDesigner Portal Server Status Settings
The PowerDesigner Portal provides a number of server status settings that you can modify on
the Settings page.

Setting Description

Server Informa-
tion

Displays the host name, port, version, and status of the server, along with the
number of users currently logged in. Click the Restart button to restart the Pow-
erDesigner Portal service.
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Setting Description

Change Notifi-
cation Informa-
tion

Displays the SMTP host, port, and status of the notification service. Click the
Suspend button to suspend the notification service. Click the Resume button to
resume the notification service. When resuming, you can optionally select the
Include suspended notification items checkbox to send all notifications that would
have been sent during the period since the suspension.

Troubleshooting the PowerDesigner Portal
These sections contain information to help you troubleshoot problems with the
PowerDesigner Portal.

Unicode Encoding with Sybase SQL Anywhere V10
If you are using a SAP® Sybase® SQL Anywhere® v10 database to store your repository
information in a unicode format, you must create the database with the -z option set to an
appropriate value.

For example, to create a database to correctly store Japanese characters, you should use the
following option:

-z 932JPN -zn UTF8BIN 

For a list of the -z options for all the supported languages, see the SQL Anywhere
documentation, available at: http://sybooks.sybase.com/nav/detail.do?docset=1333

Increasing Tomcat Memory
By default 256MB of memory is allocated to Tomcat. If you will be browsing large models
(20MB or more) or if you anticipate many concurrent users, you may need to increase this
amount to 512M or 1GB. See your Tomcat documentation for information about how to
modify this allocation.
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CHAPTER 12 Reports

PowerDesigner reports allow you to publish information about your models in HTML or RTF
format.

You can create the following types of report:

• A model report – provides information about all or some of the objects in a model, and is
shown in the Browser in the Reports folder beneath its parent model (see Creating a Model
Report on page 363).

• A multi-model report – provides information about one or more models, and is shown in
the browser as an independent item, saved as a .mmr file (see Creating a MultiModel
Report on page 376).

• A list report – provides information about a single type of object, and is shown in the
Browser in the List Reports folder beneath its parent model (see Creating a List Report on
page 370).

This version of PowerDesigner supports two kinds of model and multi-model reports:

• Legacy reports - use the traditional Report Editor, which is deprecated and will be removed
from a future version (see The Legacy Report Editor on page 398).

• New format reports - use the new graphical Report Editor, which provides synchronized
Design and Outline views, seamless inclusion of model extensions, simplified
WYSIWYG formatting, and modernized HTML and RTF generation (see The Report
Editor on page 377).

Note: The initial version of the new Report Editor has the following limitations:
• No global selection of objects to display in the report - Define any appropriate

selections on object books.
• Not available in the plugin for Eclipse.

Creating a Model Report
You can create a model report using the Report Wizard or manually, refine it in the Report
Editor, and generate it in HTML or RTF format, or print it at any time.

1. Create the report in your model using the Report Wizard (see Creating a Report with the
Report Wizard on page 364) or from the list of reports (see Creating a Report from a
Template or an Empty Report on page 369).

2. [optional] Refine the content and format of your report in the report editor (see The Report
Editor on page 377).
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Note: The report is saved as part of its model. If your model is very large, you may want to
create the report as a multi-model report, which is saved separately (see Creating a
MultiModel Report on page 376).

3. Generate the report as HTML or RTF, or print it directly (see Generating a Model Report
on page 415).

Creating a Report with the Report Wizard
The Report Wizard provides an easy way to create a report, select model objects and format
them. The wizard can be launched from your model to create a new report, or from the Report
Editor to configure an existing report. You can complete as much of the Wizard as you want.
At each step, you click Next to advance to the next stage, or Finish to create a report based on
your selections so far.

1. Select Report > Report Wizard (or select Report > Reports to open the List of Reports,
and then click the Report Wizard tool) to launch the wizard.

2. Specify a name for the report and the language in which you want its titles to appear, and
then click Next.

Note: [optional] To use the new report format and editor (see The Report Editor on page
377), deselect Use legacy Report Editor.
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3. Select whether you want to prepare your report for publishing as HTML or RTF, or for
direct printing, select a presentation template, and then click Next.

Note: For HTML and RTF reports, you can use the tools to the right of the template field to
preview and edit the template and to change the folder in which to search for templates.

4. Specify the types of information that you want to appear in your report, and click Next.
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The preview pane on the left hand-side displays a sample report that changes dynamically
according to your selections. You can select any or all of the following options:
• Introduction section – Inserts a page break followed by an introduction section,

which can contain a paragraph of Introduction text (click the Define button to enter
text), and a card listing the Model properties.

• Short description section – Inserts a page break followed by a short description
section, which can Display diagrams (including the Diagram book with a picture of
each diagram with its description and annotation) and List objects (with a list for each
type of object in the model).

Note: RQM views are not diagrams and cannot be published graphically.

• Full description section – Inserts a page break followed by a full description section
sub-heading, which can display all the elements from the short description section plus
the Objects detailed description (a book item for each object type).

• List objects diagram by diagram - [except RQM] Instead of a flat display of object
types, displays objects sorted by the diagram in which they are displayed. Global
objects, such as business rules, do not belong to a specific diagram, and are therefore
listed in their own section under the root.

5. [if your model contains packages] Specify whether you will report on the whole model or
only a package and whether you will ignore the package structure, or organize objects
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under a flat list of packages or a hierarchical list of packages (where sub-packages are
children of their parent package), and then click Next.

The preview pane (on the left hand-side) changes dynamically in order to preview your
selection.

Note: Global objects, such as business rules, are always included, even if you select a
package, and composite objects, such as OOM activities or processes, are always
displayed hierarchically, even if you have selected a different package option. Only the
hierarchical structure is supported for HTML reports or RQM reports.

6. Specify the types of object that will be included in your report, along with the properties
that will be displayed in each of their list and card report items, and then click Next.
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• To include an object type in the report, select its check box in the list. You must select at
least one object type. Click on the plus sign to the left of an object to select sub-objects.
Use the Move Up and Move Down tools to reorder the list (sub-objects cannot leave
their parent scope). New types of objects defined in extensions (stereotypes used as
metaclasses) are listed after their parent object type.

• To control the properties included for an object type in lists and cards, select the List
Layout or Card Layout tab and use the following columns
• Attribute Name – Use the arrows at the bottom of the list to reorder the list.
• D[isplayed] – Select the check box to display the attribute.
• Width [List Layout] – Specify the width of the column either as a percentage or in

millimeters.

7. Optionally preview your report, and select to open it in the report editor and or directly
generate or print it, and then click Finish.
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Creating a Report from a Template or an Empty Report
You can create a model report directly from one of the standard report templates without
making any object or format selections. Whether you choose a template or create an empty
report, you can modify it in the Report Editor.

1. Select Report > Reports to open the List of Reports, and click the New Report tool.

2. Enter a Report name, and select a Language for the report's titles and other framing text.

3. [optional] Select a report template from the list to prepopulate the report. The following
standard templates are available:

• Full– provides lists of all the types of objects in the model, together with detailed
information on each main and sub-object.

• List – provides lists of all the types of objects in the model.

• Standard – provides lists of all the types of objects in the model, together with
detailed information on each main object.

• <None> – creates an empty report.

Note: For more information about report templates, including how to create your own, see
Report Templates on page 417.
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4. [optional] To use the new report format and editor (see The Report Editor on page 377),
deselect Use legacy Report Editor.

5. Click OK to create the report and open it in the Report Editor (see The Report Editor on
page 377).

6. [optional] Generate or print the report by clicking the appropriate toolbar tool.

Note: Report templates can also be applied at generation time (see Generating a Model
Report on page 415).

Creating a List Report
A list report documents a single object type within a model, and is displayed as a customizable
list with columns and rows that you can filter as necessary. A list report is saved in the model
and can be exchanged between models of the same type.

You can create snapshots (called result sets) of a list report to keep a history of the execution of
a list report in your model. Result sets are listed in the browser beneath their parent list report,
and are saved with the model (see Creating Result Sets on page 374).

1. Launch the List Report Wizard by selecting Report > List Report Wizard, and select the
object for which you want to create the report. By default the list report is based on the
model and excludes shortcuts and sub-packages:
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2. Click Next to go to the Column Filter page, which allows you to specify which of the
object's properties will be included in the list report. Select a property in the left-hand pane
to add it to the list in the right-hand pane. You can promote or demote properties in the list
using the arrows at the bottom of the pane:

3. Click Next to go to the Row Filter page allows you to specify filters to restrict the objects
that will be included in the list report. Select a property in the left-hand pane to add it to the
list in the right-hand pane, select an operator, and then enter an expression to filter by (see
Defining a Filter Expression on page 116). You can specify to sort the list on the values of a
property by selecting the S[ort] checkbox.
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4. Click Next to go to the Content Preview page allows you to visualize the results of your
choices so far:
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To alter the definition click the Back button.

5. Click Next to go to the End page, which allows you to specify a name and code for the list
report, and to add a comment. You can also specify whether to generate the report to an
external file.

6. Click Finish to exit the wizard and create the report.

The list report is added to the model and listed in the Browser under the List reports folder.
If you have selected to generate the report to an external file, you will be asked to specify a
file name.

List Report Properties
You can modify an object's properties from its property sheet. To open a list report property
sheet, double-click its Browser entry in the List Reports folder or in the List of List Reports.
By default, the property sheet of a list report always opens on the Content tab.

The General tab contains the following properties:

Property Description

Name Specifies the name of the list report.

Code Specifies the code of the list report.

Comment Descriptive comment for the object.
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Property Description

Object type Specifies the type of the object the list report will be based on. You must select an
object type to have any content in your list report.

Model or Package Specifies the model or package from which the objects will be drawn. Package
selection is unavailable for global objects such as users.

Include shortcuts Specifies whether the list report includes shortcuts.

Include sub-pack-
ages

Specifies whether the list report includes sub-packages. This option is unavail-
able for global objects such as users.

The following tabs are also available:

• Column Filter - Lets you choose the object properties to be used as column titles in the list
report and the order in which they will be displayed.

• Row Filter - Lists the filters that restrict the rows included in the list report. Select a
property in the left-hand pane to add it to the list in the right-hand pane, select an operator,
and then enter an expression to filter by (see Defining a Filter Expression on page 116).
You can specify to sort the list on the values of a property by selecting the S[ort] checkbox.

• Content - Displays the current values for the list report. Properties selected in the Column
Filter tab are displayed as column headings and property values in rows must satisfy filter
expressions defined in the Row Filter tab. You can open the property sheet of any object
included in the list report by clicking the Properties tool.
Note that data displayed on this tab does not dynamically change when you perform a
change to your model that may affect your list report. To update the data, you must click the
Refresh List Report tool.
Use the generation tools to generate a list report result set as an RTF, HTML, XML, or
XLS/CSV file (see Generating a List Report on page 375).

• Result Sets - lists the result sets stored for the list report (see Creating Result Sets on page
374). Click the Properties tool to open a result set for generation.

Creating Result Sets
A result list is a snapshot of the content of a list report at a given system date and time. You can
create as many result sets as you want for the same list report, in order to keep a history of a
given list report for future reference.

You can create a result set in any of the following ways:

• Open the property sheet of a list report, click the Result Sets tab, and then click the Create
Result Set tool.

• Right-click a list report in the Browser and select New > List Report Result Set from the
contextual menu.

Result sets are stored within the model and display under the list report to which they are
related in the Browser:
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Result Set Properties
You can modify an object's properties from its property sheet. To open a result set property
sheet, double-click its Browser entry in the List Reports folder just beneath the list report to
which it applies. The following sections detail the property sheet tabs that contain the
properties most commonly entered for result sets.

The General tab contains the following properties:

Property Description

List Report Name of the list report to which the result set applies.

Report Date Date and time when the result set was created.

Comment Descriptive comment for the result set that allows you to identify it.

The Content tab shows the contents of the result set. Use the generation tools to generate the
result set as an RTF, HTML, XML, or XLS/CSV file.

Generating a List Report
You can generate a list report to a CSV, XLS, RTF, HTML, or XML file.

• Right-click the list report in the Browser and select Generate > Format.
• Open the property sheet of the list report, select the Content tab, and click the Generation

Format tool.
• Select Report > Generate List Report to open the Generate List Report dialog box.

You can also right-click a result set in the Browser and select Preview or Print.

Importing and Exporting List Report Files
It can be useful to exchange list report files between models of the same type. For example,
you may want to compare the properties of a certain subset of classes in two OOMs. You can
import and export list reports to and from your model using the List of List Reports (Report >
List Reports).

The following tools are available on the List of List Reports:

Tool Description

List Report Wizard - Launches the List Report Wizard (see Creating a List Report on page
370).
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Tool Description

Import List Report from File - Opens a standard Open dialog, which allows you to browse
to the list report file to import. A list report file has a .LRT extension.

Export List Report to File - Opens a standard Save As dialog, which allows you to browse
to the location to save the list report.

Creating a MultiModel Report
A multimodel report (MMR) is a PowerDesigner report that can document any number of
models together and show the links between them. To create such a report, you must have at
least one model open in the workspace, and you can add additional models at any time.

1. Select File > New Model and choose Multi-Model Report.

This item may be in the left or right hand pane, depending on the configuration of your
New Model dialog (see Creating a Model on page 9). It is not available if you do not have at
least one model open in your workspace.

2. Enter a Report name, specify the Language to use for report titles and other framing text,
and select a model from the Model name list as the basis for the first section of the report.

3. [optional] Select a template (see Creating a Report from a Template or an Empty Report on
page 369) for this first section from the Report Template list.

Note: If you choose a template in a language different from the one specified for the report,
standard report titles and framing text will be presented in the report language and any
user-defined text in the template will be in the template language.

4. [optional] To use the new report format and editor (see The Report Editor on page 377),
deselect Use legacy Report Editor.

5. Click OK to create the multimodel report and open it in the Report Editor.

6. [optional] To add a second model open in the workspace, select Report > Add Section,
select the model to add (and, optionally, a template), and click OK.

Each model in the report belongs to a separate section. You can only add models that are
currently open in the workspace, but once a model has been added, you can edit the report
even if the source model has been closed.

Note: To add a section to a legacy report, use the report property sheet Sections tab (see
Report Properties on page 418).

7. [optional] Launch the Report Wizard to populate and format the section (see Creating a
Report with the Report Wizard on page 364).

8. [optional] Edit the report in the Report Editor (see The Report Editor on page 377).

9. [optional] Generate the report (see Generating a Model Report on page 415).
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The Report Editor
You can edit model reports, multi-model reports, and report templates in the Report Editor. To
open a report in the editor, double-click its entry in the Browser or select Report > Reports,
select your report in the list, and click the Edit Report tool.

Reports are composed of report items, which provide various ways of documenting model
objects (books, cards, lists) and other report ornamentation such as a table of contents, page
breaks, and free text (see Adding Items to a Report on page 379).

The Report Editor provides four views:

• Outline (left) - Provides an overview of the tree structure of your report, and supports
reordering by drag and drop and various other operations by right-clicking items.

• Design (center) - Provides a detailed graphical view of the report, and supports wysiwyg
editing of item layout and formatting. The following tools are available on the command
bar, which appears when you select a report item in the Design view or by right-clicking an
item in the Design or Outline views):

Tool Description

Quick View - Previews the item (see Previewing a Report or Report Item on page
397).

No Tool Up / Down - Moves the item up or down one place in the report.

No Tool Promote / Demote - Moves the item up or down one level in the report.
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Tool Description

Properties - Selects properties to display in cards or lists, and reorder them (see List
and Card Report Items on page 382).

Collection - [books, cards, lists] Changes the type of object that will be published to the
item.

Selection - [books, cards, lists] Specifies the individual objects that will be published to
the item (see Selecting Objects to Display for a Report Item on page 393).

 Format/Styles - Modifies the specific format for the item or the default styles for all
items of this type (see Specifying Global Styles and Local Formats for Report Items on
page 391).

No Tool Show Title - Toggles the display of the item's title in the body of the report.

No Tool Hierarchical Display - [composite object books] Toggles the organization of com-
posite object book items, such as those representing packages, OOM activities, or BPM
processes between List (where they are all displayed on one level as siblings) and
Hierarchical (where child objects are displayed inside their parent).

No Tool Show Title in HTML TOC/Show Contents in HTML TOC - Toggles the display of
the book item title and the the book's sub-item titles in HTML report table of contents.

No Tool Delete - Hover over an item and then click the X in its upper right corner to delete the
item.

• Toolbox (right) - Lists the report items you can add to your report by double-clicking or
dragging and dropping them onto the Design or Outline views (see Adding Items to a
Report on page 379). By default, only items associated with objects present in your model
are displayed. To show all items, deselect the Hide unavailable components check box at
the top of the Toolbox.

• Properties (right, hidden) - Lists the properties of the report item selected in the Design or
Outline views.

The following tools are available from the Report toolbar:

Tool Description

 
Print Preview/Print - (see Previewing a Report or Report Item on page 397).

  
Generate HTML/RTF/XPS - Generates the report in the specified format.

Styles - Opens the Default Styles dialog (see Specifying Global Styles and Local
Formats for Report Items on page 391).

Show/Hide Header/Footer - Toggles the display of the report header and footer (see
Modifying Report Section Headers and Footers on page 395).

 
Up / Down - Moves the selected item up or down one place in the report.

CHAPTER 12: Reports

378 SAP Sybase PowerDesigner



Tool Description

 
Promote / Demote - Moves the item up or down one level in the report.

Adding Items to a Report
You can add report items by double-clicking or dragging and dropping tools in the report
Toolbox. Generic report items are available under the General Components section of the
report Toolbox, while items instantiated for the objects present in your model are available
under the Model section. Standard and extended objects and properties are all available for
selection. You can insert the same item multiple times in a report.

To add an item to a report:

• Below the selected item - double-click the appropriate tool in the Toolbox.
• Anywhere in a report - drag the tool from the Toolbox and drop it in the appropriate

position in the Design or Outline views. When the cursor is over an existing report item in
the Design view, arrows appear to guide the placement of the new item. To place the item
next to, above, or below the existing item, drop it on the left, right, top, or bottom arrow. To
add the item as a child of the existing item, drop it on the center guide arrows.

The following tools are available to insert report items to document model objects:

Icon Description

Book – Groups together cards, lists, and text items to display all or most of the properties of
an object and may contain sub-books to describe any sub-objects (see Book Report Items on
page 381).

Note: To display packages or other composite objects (such as BPM processes that can
contain other processes) hierarchically with children shown beneath their parent instead of
all at a single level, add the appropriate book item, right-click it, and select Hierarchical
Display. HTML reports always use hierarchical display.

Card – Displays a configurable subset of properties of an object in a two-column table with
the property name in the left column and the value in the right column (see List and Card
Report Items on page 382).

List - Displays a list of objects in a multi-column table with one property in each column.
(see List and Card Report Items on page 382).

Text – Displays an object property or free text (see Text Property and Free Text Report Items
on page 383).

Diagram - Inserts a PowerDesigner diagram (see Diagram Report Items on page 384).

Chart - Inserts a chart to visualize statistics about a collection of objects (see Chart Report
Items on page 384).

Matrix - Inserts a dependency matrix (see Dependency Matrices on page 180).
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Icon Description

Section - Inserts a section. Sections are only supported in multimodel reports, where each
section contains a report relating to a specific model (see Creating a MultiModel Report on
page 376).

Note: By default, a report item will generate information for every object of the appropriate
type in the model. For example, the Table book will generate information for every table in
your model. To generate for only a subset of objects defined by name or criteria, use the
Selection tool in the item's command bar (see Selecting Objects to Display for a Report Item
on page 393).

The following tools are available to add miscellaneous additional report items:

Icon Description

Cover Page - Inserts a set of text items followed by a page break to create a cover page:

Image File - Displays an image, selected via a file chooser.

Column Panel - Inserts a container element that holds two report items side-by-side. A
column panel is automatically created when you drag an item onto the Design view and drop
it on the left or right guiding arrow of an existing item.

Page break – Inserts a page break. Right-click the inserted item and deselect Generate in
HTML to disable it when generating HTML reports.

Table of contents – Inserts a table of contents followed by a page break.

Text – Inserts a text item. This can be a free text paragraph or, if you specify a data source,
the value of a property.

Text file – Inserts the contents of a text file, selected via a file chooser.

Title - Inserts a titled container. Add items to the container, which inherits the scope of its
parent item, as necessary.
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Note: You can move items from one report to another report of the same type of model by drag
and drop. Press the Ctrl key while dragging and dropping to copy the item to the second
report.

Book Report Items
Book report items can contain cards, lists, text items, and sub-object books to give detailed
information about your model objects.

1. To insert a book item, click in the Design or Outline view in the position where you want to
add the item and then double-click or drag and drop the appropriate Toolbox item.

A book is displayed in the Outline view as a node with a number of subitems, and the same
series of items are shown in the Design view:

2. To remove unwanted sub-items from the book, select them in the Outline view and press
Delete or hover over them in the Design view and click the X in the upper-right corner of
the item.

3. To reorder sub-items inside the book, drag and drop them in the Outline or Design view.

4. For composite objects (such as packages that can contain other packages or BPM
processes or OOM classes that can contain other processes or classes) you can choose
between two presentations:

• List Display - [default] Objects, their children, grandchildren, and subsequent
descendants are all generated at the same level.

• Hierarchical Display - Children are generated as sub-items inside the parent object
book, grandchildren are generated as sub-items inside the child book, and so on to any
level of decomposition. Select the Hierarchical Display option in the Properties view.

5. To modify the selection of objects that will be generated in the report from this book and
how they will be sorted, click the command bar Selection tool and specify filter and sorting
criteria or a manual selection of objects (see Selecting Objects to Display for a Report Item
on page 393).
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6. To modify the default styles for a sub-item, click its icon to display the command bar, and
then click the Styles tool (see Specifying Global Styles and Local Formats for Report
Items on page 391). To override the default styles for this instance, click the Format tool.

List and Card Report Items
List and card report items are generated as tables. A list displays all objects, with one column
per property and one row per object. A card displays a single object, with one row per property.
You can specify which attributes will be displayed, in which order, and the width of the
columns.

1. To insert a list or card item, click in the Design or Outline view in the position where you
want to add the item and then double click or drag and drop the appropriate Toolbox item.

Note: Cards and lists are commonly added to the report as part of a book (see Book Report
Items on page 381).

2. To modify the properties displayed, click the card or list icon in the Design view to display
the command bar, and then click the Properties tool to display a list of available
properties, with properties selected for display on the right, and unselected properties
listed in alphabetical order on the left:
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3. Select or deselect properties as appropriate and then click outside the list to close it.
Properties selected will be added as columns in a list or rows in a card.

Note: All properties, including extended attributes are available for selection in this list.

4. To reorder list columns or card rows click in a list column header or card row header to
select it, and then click again and drag and drop it to the desired position.

5. To modify the width of list columns or the column separating the card row header from the
property values, hover over a dividing line until the double-arrow cursor appears, and then
click and drag to increase or decrease the width.

6. To modify the default styles for a list or card item, click its icon to display the command
bar, and then click the Styles tool (see Specifying Global Styles and Local Formats for
Report Items on page 391). To override the default styles for this instance, click the
Format tool.

Text Property and Free Text Report Items
Multi-line text properties, such as the Comment or Code Preview, are provided by default as
text items. You can also add free text items wherever necessary.

1. To insert a text property report item, click in the Design or Outline view in the position
where you want to add the item and then double click or drag and drop the appropriate
Toolbox item.

Note: Text properties are commonly added to the report as part of a book (see Book Report
Items on page 381).

2. To edit a free text item, double-click the item in the Design view and enter text as
appropriate.

3. To modify the property referenced by a text property item, enter the name of the property in
the format %(Property).
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4. To modify the default styles for a text item, click its icon to display the command bar, and
then click the Styles tool (see Specifying Global Styles and Local Formats for Report
Items on page 391). To override the default styles for this instance, click the Format tool.

Diagram Report Items
Diagram report items are generated as images. If a report is generated as HTML, diagram
symbols are clickable targets, with links to the corresponding object card.

1. To insert a diagram item, click in the Design or Outline view in the position where you
want to add the item and then double click or drag and drop the appropriate Toolbox item.

Note: You can display objects organized by the diagram in which they appear by dropping
the appropriate book, card, or list items and dropping them onto a diagram item.

2. To modify the default styles for a diagram, click its icon to display the command bar, and
then click the Styles tool (see Specifying Global Styles and Local Formats for Report
Items on page 391). To override the default styles for this instance, click the Format tool.

The zoom option offers the following settings:
• Fit to page - Shrinks the diagram to fit on a single report page.

• Custom zoom - Zooms by the given percentage.

• Keep diagram layout - Each diagram page appears full size on its own report
page.

Chart Report Items
Chart report items provide a way to visualize statistics about a collection of objects as a
column, bar, or pie chart.

1. To insert a chart item, click in the Design or Outline view in the position where you want to
add the item and then double-click or drag and drop the Chart tool.

The position in which you drop the chart determines the statistics that you can visualize. In
this example, the chart is a child of the Table book, which provides access to the Columns
sub-object collection. To analyze tables or any other collection of standard objects, you
should drop the chart at the top level of your report. You can base a chart on any of the
standard collections in the PowerDesigner metamodel, or create you own extended or
calculated collection to analyze (see Customizing and Extending PowerDesigner >
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Extension Files).

2. Select the type of visualization to use. You can choose between:

• Column chart - vertical columns and/or line graphs.
• Bar chart - horizontal bars or and/or line graphs.
• Pie chart - a circle divided into sectors.

3. Specify the parameters of the chart:

• Object set - Specifies the collection of objects that the chart will analyze.
• Recursive - Specifies that the chart should include all sub-objects in the case of

composite objects such as EAM architecture areas or BPM processes, and objects
in packages. In the case of composite objects, selecting the Leaves-only sub-option
restricts the data set to only those final objects in the tree that are not further
decomposed.

Note:
• Group by - Specifies the property that will be used to categorize objects for display. If

you select nothing or the Name property, then one bar or segment will be displayed for
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each object. If you select a property of type date, you can choose to group by day, week,
month, quarter, or year.

• Measure(s) - Specifies how the size of bars or segments will be calculated. While a pie
chart can only support one measure, column and bar charts can support multiple
measures. For each measure, you can also specify:
• The measure type - Count is always available, and sum and average are available for

numeric properties.
• The base color from which the color scheme is determined and the label to give to

the measure. For column or bar charts, you can also specify whether the measure is
represented as bars/columns or as a graph line.

4. Replace the placeholder text to the left of, below, and above the chart to give labels to the x
and y axes and to provide a title for the chart.You can specify to print the column or bar
names diagonally using Primary and Secondary Axis Labels Rotation Angle properties
in the Properties view.

Note: The graphic displayed in the Design view is for illustration purposes only. To
preview your chart with actual data, click the chart background and then click the Quick
View tool.

5. To modify the default styles for a chart item, click its icon to display the command bar, and
then click the Styles tool (see Specifying Global Styles and Local Formats for Report
Items on page 391). To override the default styles for this instance, click the Format tool.

Example: Creating Charts for Hardware Servers
In this example, we will create three charts to visualize information about a set of hardware
servers modeled in an enterprise architecture model. We will analyze the distribution of
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servers by geographic site, the operating system split, and the quarterly spend on servers
(using extended attributes).

Before creating the report, the EAM model was created and populated with hardware servers
assigned to various sites, and two new properties were added to the Hardware Server property
sheet (see Adding New Properties to an Object on page 154) as extended attributes:

Name Data Type

Purchase Date Date

Purchase Cost Integer

1. Create a report, expand the General Components category in the report Toolbox, and
double-click the Title tool to add a title. Click the default title text and enter Hardware
Servers.

2. Click the Chart tool and drag and drop it onto the center of the guide arrows on the title item
to create a chart in the Hardware Servers item:

3. Drag the Chart tool again and drop it onto the bottom guide arrow on the first chart item to
create a new chart underneath it. Then drag the Chart tool a third time and drop it on the
right guide arrow on the second chart to create a new chart next to it:
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4. Enter the following chart parameters:

Parameter First Chart Second Chart Third Chart

Visualization Column Pie Column

Object Set Hardware Servers Hardware Servers Hardware Servers

Group by Site Operating System Purchase Date/
([Q]uarter)

Measure [None]/Count/Bar [None]/Count Purchase Cost/Sum/
Line

Top Title Servers by Site Operating System Quarterly Hardware
Spend

Left Title [Space] N/A Euros

Bottom Title [Space] N/A [Space]
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Note: The representation of the chart in the Design view does not change as you complete
the parameters. You can, at any time, click the background of a chart and then click the
Quick View tool to preview it with the data from your model.

5. Click the Generate Web Report (HTML) tool in the report tool bar and select to open it in
your browser:
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Dependency Matrix Report Items
Dependency matrix report items are generated as tables with one row per object and one
column per dependent object with an X or other value in matrix cells to indicate a dependency.

1. To insert a dependency matrix item, click in the Design or Outline view in the position
where you want to add the item and then double click or drag and drop the appropriate
Toolbox item.

Note: Dependency matrices are commonly added to reports as part of the Dependency
Matrix book item, which also describes the properties of the matrix. To add only the matrix
itself, expand the matrix book and then double-click or drag and drop the matrix item.

2. To modify the default styles for the matrix cells, column header, or row header, click in the
appropriate field to display the command bar, and then click the Styles tool (see Specifying
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Global Styles and Local Formats for Report Items on page 391). To override the default
styles for this instance, click the Format tool.

3. To modify or override the default styles for row and column header dividers, the horizontal
and vertical cell dividers and the overall format of the matrix, click in the top left field and
then click the Styles or Format tool.

Specifying Global Styles and Local Formats for Report Items
The formatting of your report is highly customizable. You can set global default styles and
override them for individual report items by specifying local formats.

Use the following tools on the Design view command bar to access global default styles and
individual formats:

Tool Description

Format - Specifies the format for the selected report item

Styles - Specifies the default global style for all report items of this type.

1. Select Report > Styles from the Report Editor window to open the Styles dialog:

2. Select the report item element for which you want to specify a default style in the left pane.
The following elements are available:
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• Text / Image File
• Title Component - Control the borders, fill, and spacing around the container headed

by a title report item.
• Title 1-9
• Header / Footer
• Free Text
• Table of Contents Title / Entry
• Card / List / Matrix - Control the borders, fill, and spacing around the item (including

its title).
• Card Row Header / List Column Header / Matrix Row / Column Header - Control the

font and spacing of the header cells.
• Card Content / List Content / Matrix Content. - Control the font and spacing of the

content cells.
• Card Table / List Table / Matrix Table - Control the borders and spacing of the table and

the internal dividers between the header and the cells and between the cells.

3. Specify the default styles for the selected element using the following tools. Changes are
visible immediately in the Design window:

Tool Description

Font

Font Size

   Bold / Italic / Underline / Strikethrough

Font Color

   Align Left / Center / Right / Justify

  
Borders / Border Color / Fill

 Increase / Decrease Vertical Spacing - Increase or decrease the spacing
above and below the element equally.

   Increase / Decrease Top / Bottom Spacing - Increase or decrease the
vertical spacing above or below the element.

 Increase / Decrease Horizontal Spacing - Increase or decrease the
spacing to the left and right of the element equally.

   Increase / Decrease Left / Right Spacing - Increase or decrease the
horizontal spacing to the left or right of the element.

 Row / Column Header Divider - Toggle the display of a dividing line
between the table row or column header and the content cells.
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Tool Description

 Horizontal / Vertical Cell Dividers - Toggle the display of dividing
lines between the table content cells.

Selecting Objects to Display for a Report Item
You can refine the selection of objects for individual report items and control their order by
criteria or by selecting individual objects from the list of objects included in the report. For
example you can have a list of all the tables in your PDM, but you need detailed information
about only some of them, and so specify a selection for the Table Book.

1. Right-click a book or list item and select Selection (or, for matrix items, Row Selection or
Column Selection) to open the Define Sort and Filter dialog.

2. To define a filter and sorting criteria:

• Select columns to sort on - by checking the [S]ort column checkbox.
• Reorder the columns in the list - by using the arrows at the bottom left of the dialog. To

move all the selected rows to the top of the list, press SHIFT+ENTER.
• Define one or more filter expressions - by selecting an operator in the Operator

column and entering an expression to filter by in the Expression column. For
information about the operators and expression syntax, see Defining a Filter
Expression on page 116.

The [U]sed checkbox is automatically selected when you enter a filter expression. To
disable the expression but keep it in memory, clear the checkbox.

Note: For lists containing multiple types of objects, to display properties other than those
that are common to all the object types, click the Add Attribute button (see Customizing
Columns in Lists Containing Multiple Types of Objects on page 113).
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3. To select individual objects from the list of objects included in the report, click the Switch
to Selection button:

Warning! You can specify either a filter or a selection, but not both. When you click this
button, any information entered in the Define Sort and Filter dialog will be lost.

Note: If you have made a selection of objects at the report level (see Selecting Objects to
Display in the Report on page 403), objects excluded there will not be available for
selection at the report item level.

4. By default, all the objects are selected. Select the objects that you want to display using this
report item. You can reorder the objects in the list by using the arrow buttons at the bottom
of the dialog.

Note: If you define a selection of ordered objects on a package for which you have selected
the Hierarchical Display option (see Adding Items to a Report on page 379), any
reordering you do here is ignored.

5. When you are satisfied with your filtering or selection, click OK to return to the Report
Editor. Note that only the last of the filter or selection from which you clicked OK will be
applied.

Modifying or Suppressing the Titles of Report Items
Most report items are preceded by a title item. To modify the title, select the item and then click
the title text to enter edit mode. To suppress an item title from the body of the report, right-click
the item and deselect the Show Title option.

You can reference object properties using the syntax %(Property). For example, you could
modify the title of the table card and use reference the Code property instead of the Name
property:
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Before After

Card of Table %(Name) Table %(Code) Card

Note: You can edit the default titles of all report items in the report language resource file that
is attached to your report. For more information, see Customizing and Extending
PowerDesigner > Translating Reports with Report Language Resource Files.

Modifying Report Section Headers and Footers
You can review and modify the report header and footer in the Report Editor Design view. In
multi-model reports, you can specify a different header and footer for each section (model).

For more information about the default header and footer, including specifying separate
headers and footers for each section of your RTF report, see Report Properties on page
418.

1. Click the Header & Footer tool to display the header and footer at the top and bottom of
the Design view:

Both the header and footer contain left, center, and right fields, which can contain a
mixture of text and variables.

2. Click once in a field to display the command bar, from which you can launch a preview of
the field or modify its format. Click again to edit the contents of the field, including
modifying the variables referenced (see Referencing Object and Model Properties on page
396).

3. [optional] Click the Preview tool in the command bar to review your changes.

4. Click the Header and Footer tool to return to your report.

CHAPTER 12: Reports

Core Features Guide 395



Referencing Object and Model Properties
You can reference object and model properties in your reports using their public names as
defined in the PowerDesigner Public Metamodel.

To reference object properties, use the following syntax:
%(Property)

For example, to reference the object code, use:
%(Code)

The following additional report variables are available:

Variable Description

%(!CurrentDate) Report date defined in report property sheet.

%(!CurrentTime) Report generation time.

%(Model.Name)

%(Model.Code)

Model name or code of a report section.

%(Model.Metaclass.Li-
brary.LocalizedName)

Module name of a report section.

%(!ApplicationName) Application name (PowerDesigner).

%(!PageNumber) [RTF] Current page number.

CHAPTER 12: Reports

396 SAP Sybase PowerDesigner



Previewing a Report or Report Item
You can preview your report by selecting Report > Print Preview or by clicking the Preview
tool in the End page of the Report Creation Wizard. You can preview a report item by selecting
it in the Design or Outline view and clicking the Quick View tool.

The following tools are available in this window:

Tool Goes to preview

Print - Prints the report.

Copy - Copies the selected text.

 
Zoom In/Zoom Out.

Zoom to:

• 100%
• Page Width
• One Page
• Two Pages

To search for text in your preview, enter the string in the search box at the bottom of the
window and click the right or left arrow to search forward or backward.
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The Legacy Report Editor
You can edit model reports, multi-model reports, and report templates in the Report Editor. To
open a report in the Report Editor, double-click it in the Browser or select Report > Reports to
open the List of Reports, select your report and click the Edit Report tool.

The left pane, Available Items, lists the items you can include in the report, while the right
pane, Report Items, displays the structure of your report.

The Available Items pane lists only the report items that correspond to objects that exist in the
current model. For example, if you have not created any interfaces in your OOM, then the List
of Interfaces and Interface book will not be listed. Select Show All Items at the top of the pane
to display all the report items available for this kind of model. By default, in the Multi-Model
Report Editor, all available report items are displayed if the associated model is not open in the
workspace.

The following tools are available from the Report toolbar:

Tool Description

Report Wizard - Opens the Report Wizard (see Creating a Report with the Report Wizard
on page 364).

Print Preview - Displays a report print preview (see Previewing Your Report (Legacy
Reports) on page 413)

Print - Prints the report.

Generate RTF - Generates the report as an RTF file.

Generate HTML - Generates the report as an HTML file.

Add Item - Adds an item to the Report Items pane.
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Tool Description

Up One Level - Moves item up one level.

Down One Level - Moves item down one level.

Raise Level - Moves item at the same level as the book item (item that contains other items)
that precedes.

Lower Level - Moves item within the book item that follows.

Adding Items to a Report (Legacy Reports)
The Available Items pane of the Report Editor lists the items that you can add to your report.

You can add an item to the Report Items pane in any of the following ways:

• Double-click the item in the Available Items pane to place it below the currently selected
item in the Report Items pane.

• Drag the item from the Available Items pane and drop it at the desired position in the
Report Items pane. Use the Ctrl or Shift key to select multiple items. If the pointer
becomes a barred circle, that means the drop target is unauthorized. Note that you can drag
and drop an item only when the Report Items pane already contains at least one item.

• Right-click the item in the Available Items pane and select Add from the contextual menu

The following kinds of report items are available:

Icon Description

Table of contents – Inserts a table of contents. PowerDesigner automatically inserts a
following page break.

Title - Free text to introduce what is next.

Paragraph – the following types are available, depending on the context:

• Text paragraph – free text that can be inserted anywhere
• Description – contents of the Description sub-tab of the Notes tab of the model or object

property sheet
• Annotation – contents of the Annotation sub-tab of the Notes tab of the model or object

property sheet
• Other – text paragraphs are available as necessary to display code preview, scripts,

validation rules, etc

Text file – Inserts the contents of a text file, selected via a file chooser.

Graphical file - Inserts the contents of a graphics file, selected via a file chooser.
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Icon Description

Page break – Inserts a page break. Right-click the inserted item and deselect Generate in
HTML to disable it when generating HTML reports.

Card – Inserts a table listing the properties of the model or package. Right-click the item
after insertion and select Layout to control the properties listed (see Controlling the Layout
of Card Report Items (Legacy Reports) on page 410)

List - Inserts a table listing the objects of a given type belonging to the model or another
object. Right-click the item after insertion and select Layout to control the properties listed
(see Controlling the Layout of List Report Items (Legacy Reports) on page 409)

Graphics – Inserts an image of a diagram.

Book – Inserts a set of sub-items to report on a particular type of object. May contain cards,
lists, text items, graphics, and other books as necessary.

When you add a book item to a report, you automatically add its dependent items. You can
delete any dependent item that you do not need.

When you add an item to the Report Items pane, the item remains in the Available Items pane.
You can insert the same item several times in the same report contents.

Notes:

• Composite objects - BPM processes can contain other processes, OOM activities can
contain other activities, and CDM entities can contain other entities. Such composite
object hierarchies are not included by default in the report, but you can display them by
adding a second instance of the appropriate report item inside the first. In the following
example, the second Entity book is added inside the first Entity book to display child
entities inside their parent entities:

• Package and composite object hierarchy - When you add a package or composite object
book item to a report, you can select the Hierarchical Display command in the item
contextual menu to display the package or composite object hierarchy in the generated
report. You do not need to use this command when you generate for an HTML report, as
HTML reports always provide a hierarchical display.

• Drag and drop between reports - You can drag and drop items between reports of the same
type. If you simply drag and drop an item from one report to another without pressing any
key, you move the item from one report to another. You can copy an item by pressing the
Ctrl key while dragging and dropping it. The report in which you want to drop the item
must already contain at least one item.

Note: When you generate an HTML report that contains a diagram graphic and the object
cards of the symbols, hyperlinks are created between the diagram symbols and the
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corresponding object cards. You can click a symbol in the diagram to access the object card
that corresponds to it in the HTML page.

Modifying Items in the Report Items Pane (Legacy Reports)
You can move items in the Report Items pane by dragging and dropping them.

To copy an item, hold down the Ctrl key while dragging it.You can copy any item within the
Report Items pane except for the root folder. Any formatting applied to the copied item is
preserved. When you copy a book item, you also copy its dependent items.

Contextual Menu
The following actions are available by right-clicking items that you have added to the report in
the Report Items pane:

Command Description

Show Title Controls the display of the item title in generated reports.

Show Book Title in
HTML TOC

[book items] Controls the display of the book item title in the table of contents
of HTML reports.

Show Contents in
HTML TOC

[book items] Controls the display of the sub-item titles in the table of contents
of HTML reports.

Up Moves the item up one line in the tree.

Down Moves the item down one line in the tree.

Raise Level Moves the item up one level in the tree.

Lower Level Moves the item up one level in the tree.

Format Opens the dialog allowing you to modify the formatting of the item (see 
Formatting Textual Report Items (Legacy Reports) on page 405 and For-
matting Graphical Report Items (Legacy Reports) on page 409).

Layout [list and card items] Opens a dialog allowing you to modify the layout of the
item (see Controlling the Layout of List Report Items (Legacy Reports) on
page 409 and Controlling the Layout of Card Report Items (Legacy Reports)
on page 410).

Collection [list and book items] Opens a dialog allowing you to define the collection to
which the report item will be applied (see Modifying the Collection of an Item
(Legacy Reports) on page 402).

Selection [list and book items] Opens a dialog allowing you to refine the selection of
objects to which the report item will be applied (see Selecting Objects to
Display for a Report Item on page 393).
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Command Description

Edit Title Opens the item in a dialog allowing you to edit its title (see Modifying the Title
of an Item (Legacy Reports) on page 402).

Delete Removes the item from the Report Items pane. You can delete any item except
the root.

Quick View Generates a preview of the item (see Previewing Your Report (Legacy Re-
ports) on page 413).

Modifying the Title of an Item (Legacy Reports)
Package, object, and object-dependent items all have default titles, and you can insert Title
items anywhere in the Report Items pane and as often as you want. You can edit the default text
of these report items.
1. Right-click an item in the Report Items pane and select Edit Title to open it in the Editor

dialog box.

2. Enter any appropriate changes to the title text. The user-defined check box will be
automatically selected. To revert to the default value, clear this check box.

3. [optional] Clear the Show Title check box if you do not want to show the title of the item in
the previewed or generated report.

4. [optional] Insert GTL variables that represent the name of the object, its parent, or model,
etc at the cursor, by selecting them with the Insert button.

5. [optional] Click the Format button to open the Format dialog box, and select the
appropriate formatting.

6. Click OK to return to the Report Editor. The first line of the title is displayed next to the
item in the Report Items pane.

Note: You can edit the default titles of all report items in the report language resource file
that is attached to your report. For more information, see Customizing and Extending
PowerDesigner > Translating Reports with Report Language Resource Files.

Modifying the Collection of an Item (Legacy Reports)
You can extend the PowerDesigner metamodel to, for example, add new properties to an
existing object (extended attributes), to create new objects (extended objects), and to create
new connections between object types (extended and calculated collections and extended
compositions). These latter collection extensions are not included, by default, in the object
book report items in the Available Items pane of the Report Editor and must be added by
hand.

Note: If you create extended or calculated collections in your model and use the Report
Wizard (see Creating a Report with the Report Wizard on page 364) to create your report, the
generated report automatically creates a list for each type of extended and calculated
collection inside the book item for each affected metaclass.
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You can add any object list or book inside any other object book to allow you to represent any
extended or calculated collection. Since there is no control over the location where you drop
report items, and you are responsible for the global consistency of items and collections in
your report. Once you have dropped the appropriate item, you can modify its collection and
select a calculated or extended collection.

In the following example, a calculated collection is created on the operations metaclass that
retrieves the diagrams where messages using a given operation are displayed. To display these
diagrams in the report, a diagram item must be inserted inside the operation book item and the
appropriate calculated collection selected for its collection:

In the following example, in order to manage the "schedule" and "event" concepts, the
extended object <<event>> has been created, along with an extended collection of extended
objects <<schedule>>. The Extended Object report item is added to the report and filtered on
the stereotype Event (see Selecting Objects to Display for a Report Item on page 393) and the
List of Extended Objects is added to the Extended Object book, with its collection set to
Schedule:

1. Drag and drop the appropriate book or list item under the selected book item in the Report
Items pane.

2. Right-click the book or the list item and select Collection to open its Collection dialog
box.

3. Select a collection in the Collection list and click OK to return to the Report Editor.

Selecting Objects to Display in the Report
By default, the report includes all the objects in your model. You can restrict the objects
included by making a selection, which is saved with the report.

1. Select Report > Select Objects from the Report Editor to open the Report Object
Selection dialog box. All the objects (except any external shortcuts) are selected by
default.
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2. Select a report section from the Section list (see Report Properties on page 418).

3. [optional] Select a package from the package list.

4. Select the objects that you want to include in the report from each of the object-specific
sub-tabs.

5. [optional] Specify a name for your selection in the Selection list and click the Save tool
beside the list. The selection is saved as part of the model file (or in the .mmr file for a
multi-model report).

6. Click OK to confirm your selection and return to the Report Editor.

For information about the tools in this dialog, see Adding an Item from a Selection List on
page 118.

Specifying Default Fonts for Report Items (Legacy Reports)
You can specify default fonts for report items, report templates and reports. The default fonts
are saved in the registry.

1. Select Report > Change Fonts from the Report Editor window to open the Change Fonts
Properties dialog box:
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2. Select one or more available items in the left-hand list, and specify a font, style, size, and
effects as appropriate.

3. Click OK to return to the Report Editor.

Formatting Textual Report Items (Legacy Reports)
The Format dialog allows you to specify formatting for the selected report items.

You can access this dialog in any of the following ways:

• Select one or more text or list report items in the left-hand Available Items pane, and select
Report > Format in order to set default formatting for them.
Each instance of the item that you subsequently add to the right-hand Report Items pane
will have this same formatting, but your changes will not affect any report items already in
the Report Items pane.

• Select one or more text or list report items in the right-hand Report Items pane, and select
Report > Format to change their formatting.
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Available Items
Some report items contain more than one text element. You can format each separately or use
the Ctrl or Shift keys to select several at once:

Report Item Text Selections

Card items The following selections are available for card items (lists of properties), which
are output in table format:

• Title - Title of the item, eg "Card of the Table"

• Label - Property name on a list of properties, eg "Table Code"

• Text – Value of a property, eg "EMPLOYEE"

CRUD Matrix
items

The following selections are available for CRUD Matrix items, which are output
in table format:

• Matrix title – Title of the item, eg "CRUD Matrix "

• Matrix row and column – Resource and process name, eg " Check item
(process name in rows)" and " Stock (resource name in columns)"

• Matrix text – CRUD value, eg " RU "
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Report Item Text Selections

Model- and ob-
ject-dependent
items

The following selections are available for model- and object-dependent items,
which are output in text format:

• Title – Title of the item, eg " Table Description "

• Text – Text of the description, annotation, or script, eg "This table describes
different employee characteristics "

List items The following selections are available for list items, which are output in table
format:

• Title – Title of the item, eg " List of Indexes "

• Column Header – Heading of column, eg " Code "

• Text – Value in the column, eg " PK_EMPLOYEE "

Title page The following selections are available for the title page (see Report Properties on
page 418), which is output in text format:

• Title – Title of the report, eg "OOM Report"

• Optional Fields – Text of the author, date, version or summary, eg " VB,
09.15.99, draft, report with lists only "

Table of contents The following selections are available for the table of contents, which is output in
text format:

• TOC title – Title of the table of contents, eg " Table of contents "

• Level x– Text of the different hierarchy levels in the table of contents, eg "2.1
Model information "

Note: Select the levels to display from the Show levels list beneath the Available items pane of
the Format dialog . To define the levels to be shown in the TOC of an HTML report, see 
Report Properties on page 418.

Font Tab
The Format dialog Font tab allows you to specify a font, style, size, and effects for the text
elements that you select in the left-hand Available items list.

Paragraph Tab
The Format dialog Paragraph tab allows you to specify indentation, spacing, and alignment for
the text elements that you select in the left-hand Available items list.

Border Tab
The Format dialog Border tab allows you to specify elements of a frame around the text
elements that you select in the left-hand Available items list. The following border formatting
is available:
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Option Description

Left / Right /
Top / Bottom

Inserts a line to the left, right, top, or bottom of all the occurrences of the selected text
elements.

Box [card and list items only] Inserts a rectangle around all the occurrences of the
selected text elements.

For card items, inserts a rectangle that groups all the occurrences of Text Label
(property names) including Text (corresponding property values).

For list items, inserts a rectangle that groups all the occurrences of Column Header
(heading of column, example Code), and also a rectangle that groups all the occur-
rences of Text (value in the column), if you have previously highlighted each of these
text selections in the Available Items pane.

Width Specifies the line width for the Left, Right, Top and Bottom frame options

Box width Specifies the line width of the box frame

From text Specifies the amount of space from text to top, bottom, left, and right border

Tab Tab
The Format dialog Tab tab allows you to specify tab positions and alignment for the text
elements that you select in the left-hand Available items list, which is particularly useful for
the layout of headers and footers (see Modifying Report Section Headers and Footers (Legacy
Reports) on page 412).

The following tab formatting is available:

Option Description

Tab stop position Specifies the measurement for a tab stop

Default tab stops Specifies the default spacing between tab stops

Alignment Specifies how text is to be aligned at the tab stop. To change the alignment
for an existing tab stop, click it in the Tab Stop Position box, and then click
the new alignment option

Editing Textual Report Items (Legacy Reports)
You can edit the text of a text paragraph or a text file in a text editor by double-clicking it or
right-clicking it and selecting Edit.

For text paragraphs, you can select the following kinds of content:

• User-defined - Enter text directly into the box. Click the Format button to apply formatting
to selected text.

• Object attribute - Select an attribute from the list.

CHAPTER 12: Reports

408 SAP Sybase PowerDesigner



Formatting Graphical Report Items (Legacy Reports)
You can access the report items Graph Format dialog in any of the following ways:

• Select one or more graphical report items in the left-hand Available Items pane, and select
Report > Format in order to set default formatting for them.
Each instance of the item that you subsequently add to the right-hand Report Items pane
will have this same formatting, but your changes will not affect any report items already in
the Report Items pane.

• Select one or more graphical report items in the right-hand Report Items pane, and select
Report > Format to change their formatting.

The following options are available in the Graph Format dialog:

Option Description

Zoom Specifies the resizing of the graphic in the report. You can choose between:

• Fit to page

• Custom zoom

• Keep diagram layout - one page of the diagram per report page

Frame Specifies the borders to insert around the graphic.

Controlling the Layout of List Report Items (Legacy Reports)
List report items are published as tables, ordered by the name or code of the objects. You can
specify which attributes will be displayed, in which order, and the width of their columns.

1. Select one or more list report items in the Report Items pane and select Report > Layout to
open the List Layout dialog, which lists all the attributes available for the object:
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2. Enter any appropriate layout changes as follows:

• Use the arrow buttons at the bottom of the dialog to reorder columns in the table.
• Select the D column next to a property to display it in the table.
• Enter a width in the width column. You can specify the width in millimeters (mm),

inches (in) or as a percentage of the table width.

3. Click OK to return to the Report Editor.

Note: If extended attributes are specified for the object, they will be available for selection in
the List Layout dialog. You can choose to select all extended attributes or only those whose
value has been modified using the Display > All and Display > Only modified ones
commands from the list item contextual menu.

Controlling the Layout of Card Report Items (Legacy Reports)
Card report items represent the property sheets of individual objects and are published as
two-column tables. You can specify which attributes will be displayed, and in which order.

1. Select one or more card report items in the Report Items pane and select Report > Layout
to open the Card Layout dialog, which lists all the attributes available for the object:
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2. Enter any appropriate layout changes as follows:

• Use the arrow buttons at the bottom of the dialog to reorder properties in the table.
• Select the D column next to a property to display it in the table.

3. Click OK to return to the Report Editor.

Note: Select the Displayed check box for the Class Name attribute to distinguish shortcuts
cards from the other object types cards in the generated report.

Suppressing the Titles of Report Items (Legacy Reports)
You can suppress the title of any item in your report. The following illustration shows a portion
of a report, with the title of the process card displayed:

This illustration shows the same report with the title of the process card suppressed:

Right-click an item in the Report Items pane and deselect the Show Title command.

or

Double-click an item to open the Editor dialog box, clear the Show Title check box, then click
OK.
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Modifying Report Section Headers and Footers (Legacy Reports)
The Report includes a default header and footer that you can modify.

For more information about the default header and footer, including specifying separate
headers and footers for each section of your RTF report, see Report Properties on page
418.

1. Right-click the root section item in the Report Items pane and select Header/Footer (or
click the Header & Footer button in the Presentation Options page of the Report Creation
Wizard) to open the Header and Footer dialog:

2. Enter any appropriate changes to the header text. Edit the Footer text by clicking on the
Footer sub-tab. You can use any of the variables available to the RTF template (see RTF
Presentation Templates on page 424).

If you change the default header or footer text, then the User-Defined check box is
selected, to indicate that you have overridden the default values in the associated report
language resource file. To revert to the default value, clear the check box. For more
information about report language resource files, see Customizing and Extending
PowerDesigner > Translating Reports with Report Language Resource Files.

Note: Use the key combination Ctrl+Tab to insert tabulations in a header or open the Tabs
tab in the Format dialog box (see Formatting Textual Report Items (Legacy Reports) on
page 405) to set tab stop values.

3. Click OK to return to your report.
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Previewing Your Report (Legacy Reports)
You can preview your report by selecting Report > Print Preview or by clicking the Preview
tool in the End page of the Report Creation Wizard. You can preview a report item by right-
clicking it in the Report Items pane and selecting Quick View.

The following tools are available in this window:

Tool Goes to preview

Print the report.

 Preview the report one or two pages at a time.

   Go to the first, previous, next, or last page of the report.

 
Generate the report in HTML or RTF format.
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Tool Goes to preview

Open the Find Objects dialog. Specify the model (for multi-model reports),
object type, and object you want to find, and then click Find to display a list
of topics that mention the object. Then select a topic in the list and click
Display to go to that topic in the report preview:

Help

Close the preview.

Upgrading Legacy Reports for Use with the Graphical Editor
You can upgrade a legacy report to allow it to be edited in the new graphical Report Editor at
any time from the Browser or the List of Reports. You can upgrade a legacy report template
from the List of Report Templates.

Note: Upgrading a legacy report cannot be undone. You may want to copy your legacy report
(see Copying and Pasting Objects on page 123) before upgrading it, to use it for reviewing the
upgraded version

To upgrade a report from the Browser, right-click it and select Upgrade to New-Style
Report.
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To upgrade a report from the List of Reports, select Report > Reports to open the list, select
the report to upgrade, and then click the Upgrade to New-Style Report tool.

To upgrade a report template from the List of Report Templates, select Report > Report
Templates to open the list, select the template to upgrade, and then click the Upgrade to
New-Style Report tool.

In both the Browser and list, new-style reports display a small overlay to identify them:

Generating a Model Report
You can generate your report directly from the Report Editor by clicking the Generate Web
Report or Generate Rich Text Document tools in the toolbar or selecting the corresponding
commands from the Report menu. You can generate any report in the model or a generic
report from a template from the Generate Report dialog.

1. Select Report > Generate Report to open the Generate Report dialog.
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2. Select whether to generate your report from a:

• Report template – Select a standard template or one of your own (see Report
Templates on page 417). Click the Browse button to change the folder where your
templates are stored.

• Model report – Select any report defined in the model.

Note: To generate a report directly from its Browser entry, right-click it, and select
Print, Generate > RTF, or Generate > HTML.

3. Select how you want to generate your report:

• Generate HTML – Generates a set of files to display your report in a Web browser.
• Generate RTF - Generates a Rich Text Format file for opening in Microsoft Word or

another RTF editor.
• Print report – Prints the report directly.
• Print preview – Generates a preview of the report (see Previewing a Report or Report

Item on page 397.

4. [for HTML or RTF only] Specify a Report name and File name for the generated files.

5. Specify the report Language to use for generating item titles and other report artifacts.

6. Click OK to begin the generation.
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Report Templates
A report template specifies content and formatting for a report (or, for a multimodel report, a
section). PowerDesigner provides a set of standard report templates, and you can create your
own.

Creating a Template from the List of Report Templates
You can create a report template from scratch, or based on an existing template, from the List
of Report Templates.

1. Select Tools > Resources > Report Templates to open the List of Report Templates:

2. Click the New tool and enter a name for your template:
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3. Select a language and model type for the template, and then click OK to open the empty
template in the Report Template Editor.

4. Edit the report template as necessary (see The Report Editor on page 377).

5. Select File > Save to save the template and make it available for selection when you create
a report.

Saving a Report or Report Section as a Report Template
You can save your report (or a section in a multimodel report) as a report template for use with
other reports.

1. In the Outline or Design view, click in the section you want to save as a template.

Note: For legacy reports, click the tab at the bottom of the Report items pane to select the
section you want to save.

2. Select Report > Create Template From Section.

3. Select File > Save, enter a name for the template, and click OK to save it for future use.

Modifying and Saving a Template
You can modify a report template from the List of Report Templates.

1. Select Report > Report Templates to open the List of Report Templates

Note: You can open the List of Report Templates from the List of Reports by clicking the
Manage Report Templates tool.

2. Select a template type to display the list of available templates of that type.

3. [optional] Click the Path tool to select a different directory in which to search for
templates.

4. Select a template and click the Properties tool to open it in the Report Editor.

5. Make any appropriate changes to the template and then click the X at the top right of the
Design view to close it and be prompted to save your changes.

Report Properties
To open the report property sheet, select Report > Report Properties from the Report Editor
window or right-click the report in the Browser and select Properties.

The report property sheet General tab contains the following properties:
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Property Description

Name/Code/
Comment

Identify the object. The name should clearly convey the object's purpose to non-
technical users, while the code, which is used for generating code or scripts, may
be abbreviated, and should not normally include spaces. You can optionally add a
comment to provide more detailed information about the object. By default the
code is generated from the name by applying the naming conventions specified in
the model options. To decouple name-code synchronization, click to release the =
button to the right of the Code field.

Language Specifies the language of the report. Click the tools to the right of this field to edit
the selected report language resource file or to change the path that populates the
list. For more information see Customizing and Extending PowerDesigner >
Translating Reports with Report Language Resource Files.

No paragraph
numbering

Suppresses section numbers in RTF and printed reports. Paragraph numbering is
not used in HTML reports.

Generate empty
paragraphs

Generates titles for all book items, even if they have no content.

Title Page Tab (Legacy Reports)
The report property sheet Title Page tab allows you to specify the contents of a title page for
your report:

Property Description

No title page/ In-
clude title page

Select whether to include a title page. Selecting Include title page enables the
other fields on this tab.

Title Specifies the title of the report. Default: The name of the report.

Author Specifies the report author. Default: User shown on the Version Info tab.

Date Specifies the date of the report. Default: Today's date.

Version Specifies the version number of the report. Default: Version in the model property
sheet.

Summary Specifies any additional text to be printed on the title page.

Click the Format button to customize the formatting of these fields.

Note: For HTML reports, a home page is generated instead of a title page. Title pages are never
generated for RTF reports generated with a report template.

RTF Format Tab
PowerDesigner provides a set of predefined RTF presentation templates, style sheets, and
header and footer files for generating RTF reports, which are located in the Resource
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Files\RTF Report Templates directory. You can use these files as a basis to create
your own templates.

The report property sheet RTF Format tab allows you to specify an RTF presentation template
for your report, and contains the following properties:

Property Description

Template Specifies the RTF presentation template to be used to style the report. Click the tools
to the right of this field to edit the selected template (see Referencing Object and
Model Properties on page 396) or browse to an alternate template directory.

Use sections
header and
footer

Specifies to use the header and footer defined in each report section instead of those
defined in the RTF presentation template (see Modifying Report Section Headers
and Footers on page 395. If you want to preserve the header and footer of the title
page and of the table of contents page, you should add a section break after the table
of contents.

This option is recommended when formatting a multi-model report, as otherwise all
the pages of the report will have the same header and footer.

Note: Click the Set As Default button to specify your current settings as the default for RTF
reports. To revert to the previously saved values, click the Default button.

HTML Format Tab
PowerDesigner provides a set of predefined HTML presentation templates, style sheets and
header and footer files for generating HTML reports, which are located in the Resource
Files\HTML Report Style Sheets directory. You can use these files as a basis to
create your own templates.

The report property sheet HTML Format tab allows you to specify HTML presentation
options for your report, and contains the following properties:

Property Description

Template Specifies the HTML presentation template to be used to style the report. Click the
tools to the right of this field to preview, save, or delete the selected template, or to
browse to an alternate template directory.

Style sheet Specifies the style sheet to be used to style the report as an absolute or relative path or
a URL. Click the tools to the right of this field to edit the selected stylesheet (see 
Referencing Object and Model Properties on page 396) or browse to an alternate
style sheet.
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Property Description

Header / Foot-
er

Specifies the HTML file to be used as the report header or footer as an absolute or
relative path or a URL. Click the tools to the right of the field to edit the selected file
(see Referencing Object and Model Properties on page 396) or browse to an alter-
nate file.

You can also specify the height, in pixels, of the header and footer.

Home page Specifies the HTML file to be used as the report homepage as an absolute or relative
path or a URL. Click the tools to the right of this field to edit the selected file (see 
Referencing Object and Model Properties on page 396) or browse to an alternate
file.

Table of con-
tents

These options control the format of the table of contents. You can specify:

• Level - the maximum number of levels to display in the HTML table of contents.
Default: 4.

• Width - the width of the frame as a percentage of the total width of the report
window. Default: 25%.

• TOC at right - whether the TOC will be generated on the left (default) or right
side of the screen.

You can reduce the size of the HTML TOC by right-clicking book report items and
selecting:

• Show contents in HTML TOC - deselect this option to display only the title of
the item without its contents in the TOC.

• Show book title in HTML TOC - deselect this option to remove the title of the
book item from the table of contents. Automatically deselects the Show contents
in HTML TOC option.

Image Format Specifies the file format for graphic files to be generated and embedded in the report:

• SVG - XML-based language for Web graphics, which allows you to interact
with the graphics. Note that SVG is not supported for graphics embedded in RTF
in PowerDesigner property fields, and such graphics will be generated as PNG.

• PNG – higher quality than JPEG.

• JPEG – smaller file size than PNG.

List format Specifies the format for lists. You can specify the number of rows you want to
display per page in the list results and the number of links to additional results
displayed below the list. Additional results are numbers with hyperlinks to other
pages containing the next rows of the list.
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Property Description

Web browser [legacy reports] Specifies the primary type of browser that will be used to view the
HTML report in order to correctly generate SVG graphics. You can specify
HTML5-compliant browsers or Internet Explorer 6,7, or 8 (which support SVG via
the Adobe SVG plug-in).

Add page
break for top
level list and
cards

[legacy reports] Inserts a page break before each top level list and card to avoid long
HTML pages.

Note: Click the Set As Default button to specify your current settings as the default for HTML
reports. To revert to the previously saved values, click the Default button.

Depending on the type of location (local or UNC paths, or URL), style sheet files, header and
footer files and home page files are used as follows:

Location Use

Local path or UNC path The file is copied into the report generation folder.

URL The file is referenced in its location.

We recommend that you gather your style sheets and header and footer files in a subfolder with
the same name as the presentation template file with which they are associated to ensure that
the structure of links between them is simplified.

For example, the Header_Blue.html header uses files that are gathered in the
Header_Blue_files folder:

Sections Tab (Legacy Reports)
You can use sections to structure your report. Reports must contain at least one section, and
sections are displayed as tabs at the bottom of the Report Items pane of the Report Editor. Each
section can only report on one type of model so, in a multi-model report, each different type of
model (PDM, OOM, BPM, etc) must have its own section.

The report property sheet Sections tab allows you to create, configure, and delete report
sections, and contains the following properties:
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Property Description

Name Specifies the name of the section, which will be displayed on the sub-tab at the
bottom of the Report Editor window. You can also change the name of a section by
right-clicking the section node in the Report Editor and selecting Rename.

Model [multi-model reports only] Specifies the model on which the section will report.

Template Specifies the template upon which the section is based. You can choose between:

• None [default] – creates an empty section.

• Full  Model Type  Report – provides lists of all the types of objects in the model,
together with detailed information on each object.

• List  Model Type Report – provides lists of all the types of objects in the model.

• Standard  Model Type  Report – provides lists of all the types of objects in the
model, together with detailed information on each of the main objects.

Apply Tem-
plate

Re-applies the specified template to the section, deleting any modifications you may
have made.

Note: You cannot undo this action.

Note: You can launch the Report Wizard (see Creating a Report with the Report Wizard on
page 364) from the Report Editor to configure the present section. The wizard configures only
one section at a time, and will delete the current contents of the section. To configure a second
section, select it using the section tabs at the bottom of the window, and relaunch the wizard.

Valid Codepage
By default, PowerDesigner generates in the HTML page a character set (charset) built from
the current language of the report. If this is not correct for your needs, you can change the
charset.

1. Right-click the report in the Browser, and select Properties from the contextual menu to
open its property sheet.

2. On the General tab, click the Properties button to the right of the Language field to open the
Report Language resource file in the Resource Editor.

3. Expand the Report Titles > Common Objects category, and set the appropriate values for
the CharSet and CodePage items.

For information about working with charsets and coding pages, see: http://www.w3.org/
International/tutorials/tutorial-char-enc/.

Note: You can translate the navigation buttons (Previous, Next, Home) generated by default in
your HTML report using HtmlNext, HtmlPrevious and HtmlHome items in the Report Titles
\Common Objects category of the Report Language Editor. For more information, see

CHAPTER 12: Reports

Core Features Guide 423

http://www.w3.org/International/tutorials/tutorial-char-enc/
http://www.w3.org/International/tutorials/tutorial-char-enc/


Customizing and Extending PowerDesigner > Translating Reports with Report Language
Resource Files.

RTF Presentation Templates
An RTF presentation template file has an .RTF extension and allows you to define the header,
footer, title page, table of contents, and general style of your RTF report. You can insert
pictures, page borders and variables in an RTF presentation template.

The presentation template takes into account all the presentation options that you have defined
in the Report Wizard or Report Editor, except the table of contents report item as this is defined
in the RTF presentation template.

Note: If you open a report saved in a previous version, the RTF Template list is set to <None>.

HTML Presentation Templates
An HTML presentation template file (*.htmltpl) allows you to define the header, footer,
home page, and style sheet (for font, color, background, size, margin, and alignment) for your
HTML report. The formatting defined in your style sheet will override any defined in the
Report Wizard or Report Editor.

Note: If you open a report saved in a previous version, the HTML presentation template has
the values of the default HTML presentation template or the Presentation template box will be
set to (<None>).

Style Sheet Structure
The following table describes the use of class names in the report style sheets:

Class names Description

BODY Background styles for all report pages, except the home page
frame and the browser frame page.

.BROWSERBODY Background styles for the browser page.

.HOMEBODY Background styles for the home page.

.TEXT Font styles for text blocks, like description, annotation, etc.

.TITLE Font styles for the title of the home page.

TABLE Styles for tables.

TD Styles for table cells.
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Class names Description

Table.GRID

TABLE.GRID TD.HEADER

TABLE.GRID TD

TABLE.GRID TD TD2

Styles for the tables, header cells, even row, and odd row cells
of object lists.

Table.FORM

TABLE.FORM TD.HEADER

TABLE.FORM TD

Styles for the tables, row header cells, and value cells of object
cards.

Table.TEXT

TABLE.TEXT TD

Styles for the tables and the cells of tables around the text
blocks.

Table.TITLE

TABLE.TITLE TD

Styles for the tables and the cells of tables around the home
page title.

Table.GRAPHICS

TABLE.GRAPHICS TD

Styles for the tables and the cells of tables around graphics.

H1, H2, H3 Styles for level 1, 2, and 3 headings.

HR Styles for separator lines.

A:LINK

A: VISITED

A: HOVER

Colors for non-visited, visited, and highlighted hyperlinks.

.BROWSER Font styles for the browser.

A.BROWSER:LINK

A.BROWSER:VISITED

A.BROWSER:HOVER

Colors for non-visited, visited, and highlighted hyperlinks of
the browser.

TABLE.NAVGROUP

TABLE. NAVGROUP TD

Styles for the tables and the cells of tables around the navi-
gation buttons.

.NAVBUTTON

A.NAVBUTTON:LINK

A.NAVBUTTON:VISITED

A.NAVBUTTON:HOVER

Font styles for navigation buttons and for non-visited, visited,
and highlighted hyperlinks of navigation buttons.
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PART III

Linking and Synchronizing
Models

The chapters in this part describe the PowerDesigner features that help you create links
between models and trace the impact of changes between models.
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CHAPTER 13 Getting Started with Linking and
Syncing

The PowerDesigner Enterprise Modeling environment allow you to create and exploit
complex interdependencies between objects to model interconnected systems and view them
in many different ways.

A single data item such as a product name can be implicated in multiple systems, which are
modeled in a number of interdependent models. It may also be represented at various levels of
abstraction in conceptual, logical, and physical data models, or in different contexts such as
object-oriented, XML, business process, and enterprise architecture models.

Instead of defining this same object and all its accompanying metadata multiple times,
PowerDesigner allows you to generate these instances or in other ways link them together, and
provides powerful tools for tracking and analyzing the dependencies between them.
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Note: When working with multiple connected models, we recommend that you group your
models together into a project (see Chapter 3, Projects and Frameworks on page 47).

Creating Links Between Models
PowerDesigner provides many ways to link the objects of your models together.

You can create the following kinds of links between models:

• Generation links - are created during model or object generation. Each generated object is
linked with its origin object.
• Model Generation - generates one model from another and allows subsequent

synchronization on demand (see Generating Models on page 435).
• Object Generation - allows you to define the generation of objects from one model to

another with subsequent synchronization on demand (see Generating Model Objects
on page 447).

• Shortcuts - create a reference to an object in another model. You either create shortcuts
explicitly in order to share or reuse an object in another model (see Creating Shortcuts on
page 457) or implicitly when creating other kinds of links. To create any of the kinds of
links in this list, the target model in which the referenced object resides must be open in
your workspace:
• RQM Traceability Links - link requirements with design objects that are intended to

satisfy them (see Requirements Modeling > Requirements Views > Requirements
(RQM) > Linking Requirements with Design Objects and External Files).

• EAM Object Export/Import - link enterprise architecture objects with the design
objects that will implement them (see Enterprise Architecture Modeling > Importing
to and Generating and Exporting from an EAM > Exporting and Importing Objects to
and from Other Models).

• BPM Data Export/Import - link data objects in the BPM with objects in other models
(see Business Process Modeling > Analysis BPM > Data (BPM)).

• Extended Attributes and Collections - allow you to extend the PowerDesigner
metamodel to define new kinds of links between objects (see Extending Objects on
page 154).

• Object Mappings - specify connections between certain predefined types of objects
(see Chapter 16, Object Mappings on page 473).

• Related Diagrams - specify connections between objects and other diagrams in which
they are not present (see Specifying Diagrams as Related Diagrams on page 172).

• Extended Dependencies - specify connections between any objects without
restrictions (see Creating Traceability Links on page 431).

• Object Replications - duplicate an object from one model to another and allow you to vary
the properties you choose while keeping the rest synchronized with the original object (see
Creating Replicas on page 463).

CHAPTER 13:  Getting Started with Linking and Syncing

430 SAP Sybase PowerDesigner



Viewing Links Between Models
PowerDesigner provides an array of tools to allow you to view and analyze the links created
between your models.

Some or all of the following tools are available to you to view, analyze and edit the links
between your models:

• Project Diagram - provides a high-level read-only view of the links between the models in
your project (see Project Diagrams on page 50).

• Dependency Matrix - provides an editable view of all the links between the two object
types that you specify in the matrix definition (see Dependency Matrices on page 180).

• Generation Links Viewer - provides a read-only view of all the model or object generation
links between the present model and any models it is associated through generation (see
The Generation Links Viewer on page 450).

• Mapping Editor - provides an editable view of all the mappings between the present model
and any models it is associated with through mappings (see The Mapping Editor on page
477).

• Multi-Model Report - provides a configurable report in HTML or RTF format
documenting your models and the links between them (see Creating a MultiModel Report
on page 376).

• Impact and Lineage Analysis - provides a configurable analysis of the objects that impact
and/or are impacted by the selected objects (see Chapter 17, Impact and Lineage Analysis
on page 499).

• Object Lists - can include shortcuts to objects of the selected type if the Include Shortcuts
tool is selected (see Object Lists on page 108).

• Object property sheets (see Object Properties on page 98) - provide information on various
forms of links on the following tabs:
• Related Diagrams (see Specifying Diagrams as Related Diagrams on page 172)
• Traceability Links (see Creating Traceability Links on page 431)
• Mappings - where available (see Chapter 16, Object Mappings on page 473)
• Requirements - if enabled (see Requirements Tab on page 105)
• Dependencies - lists the objects that depend on the object (see Dependencies Tab on

page 106)

Creating Traceability Links
You can specify any kind of connection between PowerDesigner objects through traceability
links. These links can be created between objects of any type of model. They are used for
documentation purposes only, and are not interpreted or checked by PowerDesigner.

You create an traceability link between objects in the same diagram by selecting the Link/
Traceability Link tool in the Toolbox. Click inside the influent object symbol and, while

CHAPTER 13:  Getting Started with Linking and Syncing

Core Features Guide 431



continuing to hold down the mouse button, drag the cursor and release it on the dependent
object symbol.

In the following example, the CDM entities School and Work do not have any direct
calculable connection, but Work is shown as being dependent on School through a
traceability link:

You can refine the meaning of traceability links by applying stereotypes to them to identify the
kind of dependency represented. You can enter a stereotype name by hand in the Stereotype
column of the Traceability Links tab of the dependent object, or select a value from the list if
you have previously defined stereotypes in an extension (see Extension Files on page 275).

Creating Traceability Links Between Objects from Different Models
You can create traceability links between any objects (including objects in different models)
from the dependent object's property sheet. The model that contains the influent object must
be open in the workspace.

1. Open the property sheet of the object, and click the Traceability Links tab.

2. Click the Add Objects tool to open the Add Objects dialog box.

3. Select a model from among the models open in the workspace from the Model box,
(optionally) a package from the list, and an object from one of the sub- tabs and then click
OK to add a traceability link to it.

The traceability link you have created is listed in the List of Traceability Links (available
from Model > Traceability Links) and, if the objects are in the same diagram, as an
oriented link symbol.

4. [optional] Enter a type to further identify the traceability link you have just created in the
Link Type column. You can specify link types for selection (see Creating New Types of
Traceability Links on page 432).

5. Click OK to close the property sheet and return to the diagram.

Creating New Types of Traceability Links
You can enter a type directly into the Link Type column, or populate the list with link types for
re-use.

1. Open the Traceability Links tab of any object.

2. Click the Types and Grouping tool and select New Link Type.

3. Enter a Name for the link type and, optionally, a Comment to explain its purpose. The
name will appear in the list in the Link Type column.

4. [optional] If you want to view the new type in the PowerDesigner Resource Editor, select
the Open Resource Editor checkbox.
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All extensions are stored in PowerDesigner resource files. For detailed information about
working with these files, see Customizing and Extending PowerDesigner > Extension
Files.

5. Click OK to exit the dialog and return to the Traceability Links tab.

The new type is available for selection in the Link Type column.

Grouping Traceability Links by Object or Link Type
You can display the links on an object's Traceability Links tab as a single list or grouped by
object type or link type by clicking the Types and Grouping tool and selecting the
appropriate grouping command.

When you select Group by Object Type or Group by Link Type, the different types of
objects or links are displayed on separate sub-tabs. To add a link to a new object type or with a
new link type, click the plus sign on the leftmost sub-tab.
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CHAPTER 14 Generating Models and Model
Objects

PowerDesigner provides a number of predefined model-to-model generation paths along with
mechanisms for generating any model objects into any other objects in another type of model.

Generating Models
PowerDesigner provides powerful capabilities for generating one model from another, and
keeping the two models synchronized. Thus, you could model your data at an abstract level in
a CDM, generate an LDM to model implementation-neutral features, and then generate
multiple PDMs for various DBMSs.

The following table shows which model types you can generate from each model type. The left
column lists the source model and the column headings the model types that can be generated
from it:

BPM CDM LDM PDM DMM OOM XSM

BPM X

CDM X X X X

LDM X X X

PDM X X X X X

DMM X

OOM X X X X

XSM X X

1. Select Tools, and then one of the following to open the appropriate Model Generation
Options Window:

• Generate Business Process Model... Ctrl+Shift+B
• Generate Conceptual Data Model... Ctrl+Shift+C
• Generate Logical Data Model... Ctrl+Shift+L
• Generate Physical Data Model... Ctrl+Shift+P
• Generate Data Movement Model...
• Generate Object-Oriented Model... Ctrl+Shift+O

Core Features Guide 435



• Generate XML Model... Ctrl+Shift+M

2. On the General tab, select a radio button to generate a new or update an existing model,
and complete the appropriate options. For more details, see Model Generation Options on
page 436.

3. [optional – PDM-PDM generation only] Click the DBMS Preserve Options tab and set
any appropriate options.

4. [optional] Click the Detail tab and set any appropriate options.

5. [optional] Click the Target Models tab and specify the target models for any generated
shortcuts.

6. [optional] Click the Selection tab and select or deselect objects to generate. For
information about using the tools on this tab, see Adding an Item from a Selection List on
page 118.

7. Click OK to begin generation.

Model Generation Options
You can customize the generation of your models by selecting model generation options.

General Tab
The General tab lets you specify the new model to be generated or existing model to be
updated.When generating a new model, you must specify the following options:

Option Description

DBMS, Object,
XML, or Process lan-
guage

Specifies the definition file for the model to be generated. By default, Pow-
erDesigner creates a link to this file. To copy the definition and save it in your
model file, click the Embed Resource in Model button.

Name / Code Specifies the name and code for the model to be generated.

Click the Configure Model Options button to specify naming conventions
(see Naming Conventions on page 143) and other model options for the model
to be generated.

When updating an existing model, you must specify the following options:

Option Description

Select model Specifies the target model to be updated. Select a model that has already been
generated from the current model from the list, or click the ellipsis button to
the right to open a list of other models of the same type open in the workspace.

DBMS, Object,
XML, or Process lan-
guage

Displays the definition file of the model to be updated.
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Option Description

Preserve modifica-
tions

Allows you to review the changes to be made to the model (see Chapter 7,
Comparing and Merging Models on page 223). If this option is not selected,
generated objects will replace objects with the same name in the model.

DBMS Preserve Options Tab
This tab is only available when you generate a PDM from another PDM, and allows you to
choose to preserve, where possible, the values associated with:

• Physical options - for relevant objects
• Triggers and stored procedures – If the target belongs to a different DBMS family, triggers

are automatically rebuilt.
• Database objects – Only objects supported by the target DBMS will be generated.
• Extended attributes

Detail Tab
The Detail tab contains options to control the generation of model objects.

Option Description

Check Model Invokes a model check before generation, and stops generation if errors are
found. You can configure specific model checks before generation by select-
ing Tools > Check Model (see Checking Models on page 137).

Save Generation De-
pendencies

Instructs PowerDesigner to retain links between each source object and the
corresponding target object, which allow objects to be subsequently identi-
fied, even if they have been modified (see The Generation Links Viewer on
page 450).

Generate Mappings Defines the source model as the data source of the generated model and
creates mappings between all source and target objects (see Chapter 16, Ob-
ject Mappings on page 473). This option is dependent on the Save Genera-
tion Dependencies option.

Rebuild Triggers [CDM/OOM-PDM] Instructs PowerDesigner to rebuild triggers with un-
modified templates after the PDM generation.
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Option Description

Convert Names into
Codes

Instructs PowerDesigner to generate target model object codes using a con-
version script. This option can be useful when generating models with very
different naming conventions. If it is not selected, target object codes are
generated from source object codes.

For example, generate an OOM Java class attribute with a code of cus-
tomerName to a PDM table column called CUSTOMER_NAME by click-

ing the Configure Model Options button on the General tab, selecting the
appropriate conversion script (see Name and Code Conversion Scripts on
page 146), and selecting this option.

Preserve n-n rela-
tionships

[CDM-LDM only] Specifies that many-to-many relationships created in the
CDM will be generated to the LDM if the destination model permits them.

Enable transforma-
tions

Displays the Extensions tab, the Pre-generation tab (if your model has
transformations defined) and the Post-generation tab (if you are updating an
existing model that has transformations defined) to select transformations to
perform before and/or after generation (see Applying Pre- and Post- Gener-
ation Transformations on page 442).

Skip single root ele-
ment

[XSM-PDM only] Specifies that the single root element is ignored, and its
immediate child elements are treated as multiple roots, which will be gener-
ated as tables.

Generate root ele-
ment

[PDM/OOM-XSM only] Specifies that a single root element representing the
PDM or OOM model is generated. Deselecting this option means that all the
tables or classes are generated as multiple roots.

Generate tables/
classes as

[PDM/OOM-XSM only] Specifies how PDM tables or OOM classes are
generated. You can choose between:

• Elements - [default] each table/class is generated as an untyped element
directly linked to its columns/attributes generated as attributes or sub-
elements.

• Elements with complex types - each table/class is generated as an element
typed by a complex type, generated in parallel, to contain the columns/
attributes.

You can override this option for individual tables or classes (see Customizing
XSM Generation for Individual Objects on page 445).
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Option Description

Generate columns/
attributes as

[PDM/OOM-XSM only] Specifies how PDM columns or OOM attributes are
generated. You can choose between:

• Elements - [default] each column/attribute is generated as an sub-element
of its table/class element or complex type.

• Attributes - each column/attribute is generated as an attribute of its table/
class element or complex type.

You can override this option for individual columns or attributes (see Cus-
tomizing XSM Generation for Individual Objects on page 445).

Class Prefix [OOM only] Specifies a prefix to apply to the codes for all classes generated.

PDM Generation Options
The following additional options are available when generating a PDM:

Option Description

Table: Table Pre-
fix

Specifies a prefix for the names of generated tables.

Table: ID col-
umn type

[XSM-PDM only] Specifies the type to use for ID columns, and which will be
used to generate xs:ID types.

Default: numeric
Index: PK index
names

Specifies the naming convention for primary keys. You can use the following
variables in this and the Key index fields:

• %TABLE% - Generated code of the table. This is the table code that is gen-
erated in the database. It may or may not be truncated if the code contains
characters not supported by the DBMS

• %TNAME%, %TCODE% - Table name and code

• %TLABL% - Table comment

Default: %TABLE%_PK
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Option Description

Index: AK index
names

Specifies the naming convention for alternate keys. You can use the following
variables in this field:

• %REFR% - Generated code of the reference

• %REFNAME%, %REFRCODE% - Reference name and code

• %PARENT% - Generated code of the parent table

• %PNAME%, %PCODE% - Parent table name and code

• %CHILD% - Generated code of the child

• %CNAME%, %CCODE% - Child table name and code

• %PQUALIFIER% - Parent table qualifier

• %CQUALIFIER% - Child table qualifier

The generated code of a variable is the code defined in the object property sheet,
which may be truncated when generated if the code contains characters not sup-
ported by the DBMS

Default: %TABLE%_AK

Index: FK index
names

Specifies the naming convention for foreign keys, by default %REFR%_FK

Index: FK
threshold

Specifies the minimum number of estimated occurrences of an entity necessary to
create an index on a foreign key. The estimated number of occurrences can be
specified in the entity property sheet. If this property is not set, foreign key indexes
are generated by default.

Reference: Up-
date Rule

Specifies the default update constraint for referential integrity.

Reference: De-
lete Rule

Specifies the default delete constraint for referential integrity.
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Option Description

Reference: FK
column name
template

Specifies the naming convention for migrated foreign keys. You can select one of
the default templates from the list or enter your own using the following variables:

• %REFR% - Name / Code of the reference

• %PARENT% - Name / Code of the parent table

• %COLUMN% - Name / Code of the parent column

• %KEY% or %CONSTNAME% - Name / Code of the key constraint attached
to the reference

• %PROLE% - Role of the entity that generated the parent table, this variable
proceeds from the conceptual environment. If no role is defined on the rela-
tionship or association, %PROLE% takes the content of %PARENT% to
avoid generating a column with no name

The following example checks the %PROLE% value; if it is equal to the parent
name (which is the replacement value) then the template "%.3:PARENT%_
%COLUMN%" will be used, otherwise template "%PROLE%" will be used be-
cause the user has entered a parent role for the relationship:

[%PROLE%=%PARENT%?%.3:PARENT%_%COLUMN%:%PROLE%]
Customized naming templates reappear in the generation dialog box the next time
you open it, but are not saved to the list of predefined templates.

For more information about PowerDesigner variables, see Customizing and Ex-
tending PowerDesigner > DBMS Definition Files.

Reference: Use
template

Controls when the FK column name template will be used. You can choose be-
tween the following radio buttons:

• Always use template

• Only use template in case of conflict

Note: If you modify a primary key in a PDM, then regenerate the PDM from a CDM, the
modified primary key is not preserved. If you want to preserve a modified primary key, you
need to modify the identifier in the CDM before regeneration.

When you reverse engineer a database into a PDM and then generate an OOM, you can add an
appropriate package hierarchy in the OOM by right-clicking the OOM in the Browser,
selecting Add Package Hierarchy, and entering an appropriate hierarchy (for example,
com.mycompany.myproduct.oom).

Target Models Tab
This tab contains a list of target models referenced by shortcuts or replications in the current
model, and the appropriate generated models that the generated model will reference (see 
Generating Shortcuts and Replicas on page 470). If any target model does not have a
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generated model listed, the generation of shortcuts or replications referencing it will fail. This
tab will be empty if your model does not contain shortcuts to other models or if these shortcuts
are set to generate as independent objects.

Applying Pre- and Post- Generation Transformations
Click the Enable transformations button on the Model Generation Options Detail tab to
display additional tabs for selecting transformations to apply to the source model objects
before generation and to apply to generated objects after generation.

In order to apply transformations, you must have either defined transformation profiles in your
model's language definition file (for PDM, OOM, BPM, or XSM) or in an extension file (see
Customizing and Extending PowerDesigner > Extension Files > Transformations (Profile)).

1. Select Tools > Generate Model to open the Model Generation Options dialog.

2. Click the Enable transformations button on the Detail tab to display the Extensions tab,
the Pre-generation tab (if your model has transformations defined) and the Post-
generation tab (if you are updating an existing model that has transformations defined).

3. Click the Extensions tab to select extensions containing transformations.

4. Click the Pre-generation tab and select the profiles and transformations to be applied
before generation. If you deselect a profile, none of its transformations will be executed.
You can drag and drop profiles to modify the order of execution of transformations.

5. Click the Post-generation tab and select the profiles and transformations to be applied
after generation.
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6. Click OK to begin the generation. The following steps are performed:

a. The object tree of the source model is traversed from the model object down and, for
each type of object for which one or more pre-generation transformation profiles is
defined, each profile is applied in the order in which they appear on the tab, with each
transformation being applied in the order in which they are defined in the profile.

b. The transformed source model is generated to the target model.
c. The object tree of the generated target model is traversed and type of object and, for

each type of object for which one or more post-generation transformation profiles is
defined, each profile is applied in the order in which they appear on the tab, with each
transformation being applied in the order in which they are defined in the profile.

Note: You can apply post-generation transformation profiles to your model at any time by
selecting Tools > Apply Transformations (see Applying Transformations to Objects on
page 167).

Customizing Data Type Mappings
When generating another PDM from your PDM, PowerDesigner maps the existing column
datatypes to appropriate data types in the new model. If the standard mappings are not
sufficient for you, you can use the Enhance Data Type Mapping extension to specify
alternative mappings, including on a column-by-column basis.

To review the conversions that PowerDesigner makes by default between the data types of a
database or other modeling target and its standard conceptual types (which are also used in the
CDM), select Tools > Resources > Type, select the appropriate file in the list and click the
Properties tool. Expand the Script > DataType (for DBMSs) or Settings > DataType (for
other resource files), and review each of the entries (which are described in their Comment
field):
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1. Select Tools > Generate Physical Data Model, enter the appropriate generation options
(see Core Features Guide > Linking and Synchronizing Models > Generating Models and
Model Objects).

2. On the Detail tab, click the Enable Transformations button to display the Extensions
tab, and select the Enhance Data Type Mapping extension.

3. Click OK to start the generation. The Data Type Mappings dialog appears, with the
existing data types present in the model listed in the Original type column, and those that
PowerDesigner proposes in the new DBMS in the Target data type column:
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4. You can change data type mappings in two ways:

• To change the mapping for all columns of a certain data type, select the desired new
data type from the list in the Target data type column.

• To change the mapping for one column only, click the Add Specific Column
Mapping button, select the column from the tree, click OK, choose the new data type
for the column, and click OK to add this mapping to the list.

5. When you have modified all the necessary data types, click Close and the generation will
continue, using your custom mappings where appropriate.

Note: You can also customize data type mappings when changing the DBMS of your
model with the Database > Change Current DBMS command. To do so, you must first
attach the Enhance Data Type Mapping extension, by selecting Model >
Extensions, clicking the Attach an Extension tool, select the extension, and clicking OK
to attach it to your model.

For more information about data types, see Customizing and Extending PowerDesigner >
DBMS Definition Files > Script/Data Type Category and Customizing and Extending
PowerDesigner > Object, Process, and XML Language Definition Files > Settings
Category: Object Language.

Customizing XSM Generation for Individual Objects
When generating an XSM from a PDM or OOM, you can specify global generation options to
generate tables/classes as elements with or without complex types and columns/attributes as
elements or attributes. You can override these options for individual objects by attaching the
PDM XML Generation or OOM XML Generation extension to your source model and
selecting from their XML generation options.
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Note: The extension provides new property sheet tabs for setting generation options for
individual objects, but you can also set these options with or without the extension by selecting
Model > objects to open the appropriate object list, clicking the Customize Columns and
Filter tool, and selecting to display the XML Generation Mode column.

For example, if you want to generate the majority of your table columns to an XSM as XML
attributes, but want to generate certain columns as elements, you should:

• Modify the XML generation options for those columns that you want to generate as
elements.

• Select to generate columns as attributes on the Model Generation Options Detail tab.

1. Select Model > Extensions to open the List of Extensions, and click the Attach an
Extension tool.

2. On the General Purpose tab, select PDM XML Generation or OOM XML
Generation and click OK to attach the extension to your model and OK to close the
List of Extensions.

These extension files enable the display of the XML tab in all table and column or class
and attribute property sheets.

3. Open the property sheet of the table, column, class, or attribute whose generation you want
to customize, and click the XML tab.

4. Use the radio buttons to specify how you want to generate the object in an XSM.

• For tables and classes, you can specify to generate them as:
• Elements - the table/class is generated as an untyped element directly linked to its

columns/attributes generated as attributes or sub-elements.
• Elements with complex types - the table/class is generated as an element typed by a

complex type, generated in parallel, to contain the columns/attributes.
• Default - generation of the table/class is controlled by the option selected in the

XML Generation group box on the Model Generation Options Detail tab.
• For tables, you can additionally specify to generate keys as:

• Key - [default] The primary
key columns are generated and also KEY and KEYREF wherever the table is ref
erenced.

• ID attribute - The primary key columns are not generated and an ID attribute, id,  is
generated to replace them.
Wherever the table is referenced, an IDREF attribute is generated to reference th
e appropriate element. If the reference role name is assigned, this attribute is
given this
name. Otherwise, the referenced table name is used and the standard renaming m
echanism is enforced.

• Key and ID attribute - In many cases the primary
key columns have significant data and you may want to generate them, as well as
an ID attribute.
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In this case an ID attribute is generated for the element and IDREF is  used syste
matically for any reference to the table:

The following rules apply to the generation of keys:
• If a Table generates an ID, all its child tables will generate an ID attribute.
• If a Table generates Key columns, all its child tables will generate Key columns.
• If a child table is flagged to generate PK only, ID Attribute will be automatically

 generated.
• If a table generates ID attribute, No Key nor KeyRef will be generated, and ALL

 references will generate IDREF attribute.. (Even if the table generates also Key 
Columns)

• If a table generates ID attribute ONLY, All Foreign Key Columns referencing its
 Key columns will be systematically removed and replaced by an IDREF attribute

• For columns and attributes, you can specify to generate them as:
• Elements - [default] the column/attribute is generated as an sub-element of its

table/class element or complex type.
• Attributes - the column/attribute is generated as an attribute of its table/class

element or complex type.
• Default - generation of the column/attribute is controlled by the option selected in

the XML Generation group box on the Model Generation Options Detail tab.

5. Modify the XML generation options for any other objects that you want to generate in a
different manner.

6. Select Tools > Generate XML Model, ensure that the appropriate options are set in the
XML Generation group box on the Model Generation Options Detail tab, and start your
generation.

Generating Model Objects
You can define your own model-to-model object generation commands. You can define as
many commands as you need, and generate any of your model's objects as any kinds of objects
in any other model. The generated objects are linked to the original objects and can be
resynchronized at any time.

Before you can generate model objects, you must define the details of the generation (see 
Defining Simple Object Generations on page 448)

Note: This procedure deals with generating one or more object types to another model. For
information about generating your entire model to another model, see Generating Models on
page 435).

1. Select Tools > Generate Objects >  Menu command name  to open the Object Generation
Options window for the generation that you have previously defined (see Defining Simple
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Object Generations on page 448 or Defining Advanced Object Generations on page
449).

2. On the General tab, select a radio button to generate a new or update an existing model,
and complete the appropriate options (see Model Generation Options on page 436).

3. [optional] Click the Detail tab and set any appropriate options.

4. [optional] Click the Target Models tab and specify the target models for any generated
shortcuts.

5. [optional] Click the Selection tab and select or deselect objects to generate (see Adding an
Item from a Selection List on page 118).

6. Click OK to begin generation.

Defining Simple Object Generations
Simple object generations allow you to generate a single type of object (eg, Tables or Classes)
to any other type of object. You can define multiple object generations. They are stored as
objects in your model and are accessed by selecting Tools > Generate Objects > Generation
Name.

To generate more than a single type of object or to have greater control over how individual
properties will be generated, use an advanced object generation (see Defining Advanced
Object Generations on page 449).

1. Select Tools > Generate Objects > Define New Object Generation to open the Object
Generation Properties dialog.

2. Select the type of model object you want to generate other model objects from in the
Source model objects list.

3. Click the Choose Metaclass tool to the right of the Target model objects field to open the
Select Object Type dialog, which allows you to select the type of objects you want to
generate.
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You can choose any object (including extensions) from any PowerDesigner model type,
but some choices will be more appropriate than others.

4. [optional] Edit the Menu command name that PowerDesigner suggests, and which will
appear under the Tools > Generate Objects menu to allow you to launch the generation.

5. Click Generate to launch the generation immediately or OK to save the generation
definition for use later.

Once you have defined an object generation, you can launch it at any time by selecting
Tools > Generate Objects >  Menu command name .

Defining Advanced Object Generations
Advanced object generations allow you to generate one or more types of object to any other
types of object, with complete control over how all the attributes, compositions (sub-objects),
and aggregations (related objects) will be mapped to the generated objects' properties. The
generation mappings are defined in an extension file, can be shared with all users through the
repository library, and are accessed by selecting Tools > Generate Objects > Generation
Name.

Note: The following procedure gives an overview of the process for defining an advanced
object generation. If an administrator has already defined a generation and provided the
extension file to you, you can perform the generation directly by selecting Tools > Generate
Objects > Generation Name. You can also define simple object generations for a single type
of object directly in your model (see Defining Simple Object Generations on page 448).

1. Select Tools > Resources > Extensions > Model Type to open the appropriate extension
file list.

Note: As object generations are defined on the source objects, you must choose the correct
type of extension file. For example, if you are generating EAM organization units and
processes to a BPM, you should create the generation definition in an enterprise
architecture model extension file.

2. Create a new extension file in the list to contain your object generation definition (see 
Creating an Extension File on page 276).
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3. Create an object generation definition in the extension file (see Customizing and
Extending PowerDesigner > Extension Files > Object Generations (Profile)).

4. Save the extension file, attach it to a test model, and test the generation by selecting Tools >
Generate Objects > Generation Name.

5. [optional] Check the extension file into the repository library to have it automatically
deployed to all users (see Sharing Resource Files via the Library on page 551).

Managing Object Generation Commands
You can review the object generations that you have defined by selecting Tools > Generate
Objects > Manage Object Generations.

To review the definition of a generation, select it and click the Properties tool; to launch it,
select it and click the Run Object Generation tool.

Note: You can also create object generations directly in this list by clicking the Add a Row
tool and specifying a menu command name and source and target object kinds.

The Generation Links Viewer
The Generation Links Viewer allows you to view (but not edit) the generation links of a given
model, which allow you to identify the origin of each generated or derived object of the model.

Note: Links are created between models during model generation only if the Save Generation
Dependencies option on the Detail tab of the generation dialog box is selected.

You can choose to view the:
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• Links to the model(s) derived from the present model, by selecting Tools > Generation
Links > Derived Models - the current model is shown in the Source pane and the derived
models in the Target pane.

• Links to the model(s) from which the present model was derived, by selecting Tools >
Generation Links > Origin Model - the current model is shown in the Target pane and the
origin models in the Source pane.

The Generation Links Viewer dialog box is divided in three parts:

• The Source pane - which is on the left-hand side, and displays the structure of the source
model

• The Target pane - which is on the right-hand side, and displays the structure of the target
model(s)

• The Generation Links pane – shows you the sources or the targets of the selected object in
the current model as a tree view. The root object is the source or target object from the
current model, and the generation link name is composed of the object type and name
(followed by, for link objects, the names of its extremities) followed by its parent model.
You can double click a generation link in this pane to view the properties of the source or
target object.
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Source object icons have a small green arrow symbol and target object icons have a small red
target symbol on their bottom right-hand corners.

Non-editable links are drawn from the origin object in the Source pane to the derived object in
the Target pane. Double-click the link in either pane to open the appropriate object's property
sheet, or in the area between the two panes to display its details in the Generation Links pane.

The following tools are available in the Generation Links Viewer:

Tool Description

Properties - Opens the property sheet of the selected source or target object.

Find Source Object - Finds an object in the Source pane and highlights it.

Find Target Object - Finds an object in the Target pane and highlights it.

Filter Generation Links – You can choose to filter by:

• All generation links
• Only generation links of the selected object
• Only generation links of the selected object and its child objects

Filter Objects - You can choose to filter by:

• All objects
• Only objects with generation links
• Only objects without generation links
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Using Impact Analysis with Generated Models
To use impact analysis on generated models, consolidate them in the Repository and extract
them with the Extract Dependencies option selected to display the Generated As subtab in
the Dependencies tab of source objects.

In the Impact Analysis dialog box, this link does not appear by default, you have to click the
Extract Dependencies tool to display the generation links:

CHAPTER 14: Generating Models and Model Objects

Core Features Guide 453



CHAPTER 14: Generating Models and Model Objects

454 SAP Sybase PowerDesigner



CHAPTER 15 Shortcuts and Replicas

Shortcuts and object replications allow you to reuse objects defined in one model or package
elsewhere. You should use a shortcut when you want to reference an object in another model or
package, and a replica when you want to create a local copy of the object and make changes to
one or more of its properties.

Note: You cannot transform a shortcut into a replica, or vice versa. When choosing to create a
shortcut or replica, you should identify how you want to use it. For example, if you want to
reuse an existing table in your PDM, you should create a:

• Shortcut - If you do not require the table to belong to your domain or namespace, and you
just want to reference it without modifying its structure (adding, removing or otherwise
changing columns or other sub-objects).

• Replica - If you need a synchronized copy of the table in your namespace, or you want to
modify its structure.

• Graphical synonym - If you merely want additional instances of the object symbol in your
diagram to improve its readability and simplify linking (see Creating Graphical Synonyms
for Object Symbols on page 199).

A shortcut or replica is:

• Internal – if it points to an object in a different package in the same model.
• External – if it points to an object in a different model.

Shortcuts and replications allow you to benefit from:

• Reusability - You can create libraries of reusable objects whose properties are inherited by
multiple objects in different models. For example, the Person entity and its four
attributes (Name, Age, Nationality and Address) can be used via inheritance links
in any model where you have need of a customer, employee, etc.
In the following example, a Person entity is created in the Dictionary CDM, and a
shortcut to it is created in the Sales CDM, where the Employee and Customer entities
inherit from it:
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• Automatic updates - When the target object changes, the updates cascade automatically (if
both the referencing and target models are open in the workspace) to all the shortcuts and
replicas.

You can create shortcuts or replicas for most PowerDesigner objects (including composite
objects and other shortcuts or replicas). When you replicate an object, its sub-objects are also
replicated. You cannot create shortcuts or replicas for the following types of objects:

Module No Shortcuts For... No Replicas For...

All Diagrams, Links Diagrams, Links, Packages

RQM Traceability link, user allocation -

EAM - -

BPM Decisions, synchronizations Starts, ends, synchronizations

CDM/LDM Associations, Inheritances Associations, Inheritances

PDM Privileges Privileges

DMM - Replications not supported

OOM Decisions, synchronizations, interac-
tion fragments, interaction referen-
ces, messages

Starts, ends, synchronizations, interaction
fragments, interaction references, messages
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Module No Shortcuts For... No Replicas For...

XSM Internal shortcuts not supported for
any object. External shortcuts not
supported for imports, includes, rede-
fines, annotations

-

Note: You cannot create internal shortcuts or replicas to global objects, such as organization
units, or business rules, because they belong to the model and cannot be displaced into a sub-
package. You can reuse data item shortcuts only if they are internal (same namespace). A
duplicated data item shortcut has the same characteristics as the original data item shortcut.

Creating Shortcuts
You can create shortcuts to target objects from another package in the current model, or from
another model open in the workspace through copy and paste, drag and drop, or from the List
of Shortcuts.

• Drag and Drop - Right-click on the target object in the Browser (or its symbol in a diagram)
and drag and drop it into the diagram where you want to create the shortcut (or onto a
model or package in the Browser). Release the right mouse button, and select Create
Shortcut(s) Here.
You can also create shortcuts of objects by left-clicking and dragging and dropping them
while holding down Shift+Ctrl.
For more information about dragging and dropping objects, including how to change the
default behavior, see Dragging and Dropping Objects on page 122.

• Copy and Paste - Select the target object in the Browser (or its symbol in a diagram) and
press Ctrl+C (or select Edit > Copy), then right-click in the diagram where you want to
create the shortcut (or on a model or package in the Browser), and select Edit > Paste as
Shortcut.
For more information about copying and pasting objects, including how conflicts are
managed, see Copying and Pasting Objects on page 123.

• List of Shortcuts - Select Model > Shortcuts to open the List of Shortcuts and click the
Add Shortcuts tool:
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Select the target model and package in the upper part of the dialog and objects in the sub-
tabs in the lower part of the dialog, and then click OK to add them as shortcuts to the
current model.
For more information about the tools in this dialog, see Adding an Item from a Selection
List on page 118.

If you select two linked objects in a model and create shortcuts from them, a shortcut of the
link between them will also be created. If, after having created shortcuts from two objects, you
subsequently create a link between them in the target model, you can update the referencing
diagram to display the new link by opening it and selecting Tools > Complete Links.

Link shortcuts do not display the shortcut overlay symbol. In the following example, both
classes and the association are shortcuts, but only the classes display the shortcut overlay:

The following rules restrict the use of shortcuts:

• You cannot create more than one shortcut to the same target object in the same model or
package.

• You cannot create a shortcut for a CDM data item outside the current namespace.
• You cannot create links between two shortcuts if the link implies a parent/child hierarchy

(for example, you cannot create a reference link between two table shortcuts in a PDM).
• You cannot create a link between an entity and the shortcut of an inheritance.

When you create a shortcut in a diagram, the following rules apply. If the model or package
where you create the shortcut:
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• Does not contain the shortcut - a shortcut and symbol are created
• Already contains the shortcut, but there is no symbol in the diagram - a symbol is created
• Already contains the shortcut, and there is a symbol in the diagram - a shortcut synonym

symbol is created:

For more information about synonyms, see Creating Graphical Synonyms for Object
Symbols on page 199.

Shortcut Properties
To open the property sheet of a shortcut and view or edit its properties, double-click its
Browser entry or diagram symbol. The information that you will see depends on your settings
for the Internal Shortcut and External Shortcut general options and the External Shortcut
Properties model option

To view the target object property sheet in place of the shortcut, click Tools > General
Options > Dialog and select Target object in Internal Shortcut and External Shortcut. To
maximize the information on external shortcut property sheets and symbols, click Tools >
Model Options > Dialog and select All in External Shortcut Properties.

Note: External shortcuts can display properties defined in the standard PowerDesigner
metamodel and in extensions that are attached to the target model, but not any that are defined
in extensions embedded in the target model. If you want to display such embedded extensions,
you should export the extension file from the target model and then attach it as a shared
extension.

The following properties are available on the General tab of a shortcut property sheet or on the
Shortcut tab of a target object property sheet:

Property Description

Target type Specifies the type of the target model and the type of object which the shortcut
references.
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Property Description

Name Specifies the name of the target object. Click the Properties tool to the right of this
field to view or edit its properties.

Click the Change Target Object at the bottom of the dialog to open a dialog to allow
you to choose a different target object (which must be of the same type, and cannot
already be referenced by another shortcut in the same package).

Code Specifies the code of the target object.

Target model Specifies the name of the model to which the target object belongs. Click the Prop-
erties tool to the right of this field to view or edit its properties.

Target package Specifies the name of the model package to which the target object belongs. Click
the Properties tool to the right of this field to view or edit its properties.

Shortcut type Specifies whether the shortcut is external (from another model) or internal (from
another package in the present model).

Status Specifies the status of the target model, which may affect what information is
available for external shortcuts if the target model is closed or not found.

For external shortcuts, (and you have not selected to display all properties), only the
name of the shortcut and target model are available. Otherwise, all properties can
appear in accordance with the display preferences.

Object1 and
Object2

[link shortcut only] Specify the names of the source and target objects which the link
connects

Generate [external shortcut only] Specifies that the shortcut should be generated when gen-
erating another model from the referencing model (see Chapter 14, Generating
Models and Model Objects on page 435).

Generated as [external shortcut only] Specifies how the shortcut will be generated (see Generating
Shortcuts and Replicas on page 470). You can choose between:

• Shortcut - the shortcut is generated as a shortcut and retains its link to its target
object

• Object – the shortcut is generated as an independent object and is no longer
linked to its target object

A shortcut property sheet also includes the following tabs:

• Dependencies - Lists the objects with connections to the shortcut (see Viewing Shortcut
and Replica Dependencies on page 468)

• Version Info - Specifies the shortcut owner, modification and creation details
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Viewing Shortcuts
Shortcuts can be identified in the referencing model in the Browser and diagrams by the
shortcut arrow overlay on their bottom left corners.

In the following example, the Orders table is a shortcut. It appears in the Browser with the
other tables that belong to the model. Both the Browser entry and the diagram symbol display
the shortcut arrow overlay:

Note: To hide shortcuts in the Browser, deselect the Show shortcuts general option (see 
General Options on page 255).

For external shortcuts, if you have selected to display all properties (see Shortcut Properties on
page 459) or if the target model is open in the workspace, the properties that appear on its
symbol are controlled by the standard display preferences for that type of object.

Otherwise, only the name will appear, and you can modify the display preferences specific to
shortcuts by clicking Tools > Display Preferences, and selecting the Shortcut category. The
following preferences are available:

Prefer-
ence

Description

Icon Displays the shortcut icon on shortcut symbols

Model [external shortcuts only] Displays the name of the target model on shortcut symbols

Package Displays the package name on shortcut symbols. If you select this option, you must
choose to display the:

• Full path – displays the full path to the package
• Last package only –displays the last package name only

To view all the shortcuts in a model, select Model > Shortcuts to open the List of Shortcuts.
All the entries are greyed because you cannot modify a shortcut directly in this list:
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The U[sed] column is checked when the shortcut has a symbol in a diagram or if it is
referenced by at least one other object. If this column is not checked, the shortcut is not used in
the model and you can safely delete it.

To view all the shortcuts for a particular type of object in a model, open the appropriate list by
selecting Model > Objects, and click the Include Shortcuts tool:

For information about working with these lists, see Object Lists on page 108.
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Creating Replicas
You can create replicas to target objects from another package in the current model, or from
another model open in the workspace through drag and drop, or from the Replicate Objects
dialog.

• Drag and Drop - Right-click on the target object in the Browser (or its symbol in a diagram)
and drag and drop it into the diagram where you want to create the replica (or onto a model
or package in the Browser). Release the right mouse button, and select Replicate Here.
You can also create replicas of objects by left-clicking and dragging and dropping them
while holding down Shift+Alt.
For more information about dragging and dropping objects, including how to change the
default behavior, see Dragging and Dropping Objects on page 122.

• Replicate Objects dialog - Select Edit > Replicate Objects to open the Replicate Objects
dialog:

Select the target model and package in the upper part of the dialog and objects in the sub-
tabs in the lower part of the dialog, and then click OK to add them as replicas to the current
model.
For more information about the tools in this dialog, see Adding an Item from a Selection
List on page 118.

Sub-objects (such as table columns or class attributes and operations) are automatically
replicated when you replicate their parent object. You can replicate sub-objects individually
through drag and drop only. You could, for example, create library models to group sub-
objects that you regularly use, ready for replication.
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Name uniqueness rules are respected when you replicate objects, so that replicas are renamed
upon creation in the referencing model when objects with the same name already exist.

Desynchronizing Replica Properties
By default, replicas have read-only property sheets appropriate to their object type. To
desynchronize one or more properties and make them editable, select the Version Info tab,
click the Replication Properties button to open the replication property sheet, select the
Attributes or Collections tab, and deselect the properties that you want to override in the
replica.

Note: To break the replica's link to its target and turn it into an independent object, click the
Delete Replication button. To make multiple replicas into independent objects, select Model
> Replications to open the List of Replications, and delete the relevant replications.

The General tab of the replication property sheet contains the following properties:

Property Description

Original Object
Model

Specifies the name of the model to which the target object belongs. Click the
Properties tool to the right of this field to view or edit its properties.

Full Name Specifies the full path to the target object. Click the Properties tool to the right of
this field to view or edit its properties.

Type Specifies the type of the target object.

Status Specifies the status of the target model, which can be closed, open, or not found.

Replica Object
Full Name

Specifies the full path to the replica object. Click the Properties tool to the right of
this field to view or edit its properties.

Generate Specifies to generate the replica along with standard models in a model-to-model
generation (seeGenerating Shortcuts and Replicas on page 470).

A replication definition also includes the following tabs:

• Attributes - Lists the attributes of the replicated object. Deselect the check box of an
attribute to make it editable for the replica.
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• Collections - Lists the collections of the replicated object. Deselect the check box of a
collection to make it editable for the replica.

• Sub-Replications - Lists the sub-objects replicated as part of the object replication. Click
the Properties tool to open the property sheet of the sub-replication in order to make
editable one or more of its properties.

Viewing Replicas
Replicas look identical to normal objects in the Browser and diagrams, but all or part of their
property sheets are grayed out and uneditable. Replications, which maintain the link between
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the replica and the original object, are not accessible from the Browser or diagrams, but can be
viewed by selecting Model > Replications to open the List of Replications.

As each replica requires a replication, you can view all the replicas present in the model from
this list. You cannot create replicas here (see Creating Replicas on page 463), but you can
access the property sheets of replications and, from there, the property sheets of replicas and
their target or original objects (see Desynchronizing Replica Properties on page 464).

If you delete a replication from the list, the associated replica will lose its link to the original
object and become an independent object.

To view all the replicas for a particular type of object in a model, open the appropriate list by
selecting Model > Objects, and look for checkmarks in the R[eplica] column:
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If this column is not visible, click the Customize Columns and Filter tool, and select the
Replica attribute to add it to the list.

Any property that is synchronized (and thus not editable) is grayed.

Comparing and Merging Replicas
You can compare and merge the properties of a replica with those of the original object. When
merging models, to merge a replica as a replica, you must merge the replica and its associated
replication. If you merge only the replica and not the replication (which links it to the original
object), the replica will be transformed into an independent object.

For more information about comparison and merging see Chapter 7, Comparing and Merging
Models on page 223.

Synchronizing Shortcuts and Replicas
When you make changes to a target object, the shortcut or replica is synchronized instantly or,
if the referencing model is closed, when it is next opened. Both the referencing and target
models must be open for synchronization to occur.

If you create an external shortcut or a replica from a target model that has never been saved,
you should save the target model before the referencing model in order to allow
synchronization between the models. If you attempt to save the referencing model first, you
will be prompted to save the target model.
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Viewing Shortcut and Replica Dependencies
To view all the objects that are linked to or otherwise depend on a shortcut or replica, open the
property sheet of the shortcut or replica and click the Dependencies tab. To view all the
shortcuts or replicas that have been created from a target object, open the property sheet of the
target object and click the Dependencies tab and the Shortcuts or Replicas subtab.

The Dependencies tab on a shortcut or replica property sheet lists all the objects dependent on
the shortcut or replica in all the models open in your workspace, and we recommend that you
review this tab before deleting the object from your model. You can double-click an entry in
the list to display the dependent object's property sheet, or click the Impact and Lineage
Analysis button to determine the impact of deleting the shortcut or replica.

The Shortcuts and Replicas subtabs on an object property sheet Dependencies tab list all the
shortcuts and replicas that have been created from the object in all the models open in your
workspace:
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Working with Target Models
Shortcuts and replicas that you create yourself, as well as the shortcuts that PowerDesigner
creates automatically when you link or map objects or perform other tasks, all point to objects
in other models, which are called target models.

These models are listed in the Browser in the Target Models category with status icons to
indicate whether your local copies are the latest available in the repository (see Chapter 2, The
Browser on page 35).

This list of models is also available by selecting Model > Target Models.
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You can use the tools on this list to open a target model, view its properties, or change or delete
it. For information about all the tools available on this list, see Object Lists on page 108.

Note: If you delete a target model from the List of Target Models, you will also delete all the
shortcuts that reference it in the present model and transform any replicas that reference it into
independent objects. You cannot undo deleting or changing a target model.

Generating Shortcuts and Replicas
If you generate another model from your model, you can choose not to generate your shortcuts
and replicas. If you generate your shortcuts, you can choose to generate them as shortcuts or to
transform them into independent objects. If you intend to generate to another type of model
(for instance, a PDM from an OOM) and want to retain your shortcuts and replicas, then you
should first generate the target models from which they were created, so that your generated
model will have appropriate target objects to synchronize them with.

For instance, if you have shortcuts of classes in your OOM, and want to generate a PDM from
it, you should generate your target OOMs to PDMs, so that the table shortcuts generated from
your class shortcuts will have target table objects to synchronize with. In the following
example, the class shortcuts in OOM2 are generated to table shortcuts in a PDM2:
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The necessary steps for correctly generating the class shortcuts and replicas as table shortcuts
and replicas are:

1. Create the classes in OOM1, and create shortcuts or replicas to them in OOM2. Ensure that
the Generate option on the shortcut properties sheet is selected and that the Generated as
option is set to Shortcut (see Shortcut Properties on page 459). For replicas, you must
ensure that the Generate option on the associated replication property sheet is selected
(see Desynchronizing Replica Properties on page 464). If this option is not selected, the
replica will not be generated.

2. Generate OOM1 to PDM1 to provide target table objects for the shortcuts and replicas to
be generated from OOM2.

3. Before generating OOM2 to PDM2, review the Target Models tab of the model
generation dialog (see Model Generation Options on page 436) to ensure that PDM1 is
listed in the Generated Models column. If OOM1 is closed in the workspace, you should
click in the Generated Models column to open it, and you can then select PDM1 from the
list in the cell:
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4. Click OK to perform the generation. Your shortcuts and replicas will be retained in the
generated model.
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CHAPTER 16 Object Mappings

Object mapping allows you to establish connections between objects belonging to
heterogeneous models and diagrams. You create mappings between objects to model O/R
(Object-Relational) mappings, which associate classes with tables to store OOM objects into a
relational database, or simply to express a correspondence between objects in different
models.

The following table lists the supported types of model-to-model mapping in PowerDesigner:

Source
Model

CDM Tar-
get

LDM Target PDM Target OOM Tar-
get

XSM Target

CDM X X X X

LDM X X X X

PDM X X X X X

OOM X X X X

XSM X

Note: Mappings are also used to define data replications in the DMM. For more information,
see Data Movement Modeling > Data Movement Diagrams > Replication Processes
(DMM).

You can create mappings:

• in the Mapping Editor - which gives you a global view of all the mappings to objects in the
current (target) model (see The Mapping Editor on page 477)

• on the Mapping tab of the property sheet of the target object (see Creating Mappings from
an Object's Property Sheet on page 491)

• During model generation, by selecting the Generate Mappings option in the Model
Generation Options window (see Generating Models on page 435).

Each mapping is recorded in a query, a textual expression or an XPATH expression defined in
the target object, which permits the selection of data from the data source and its transfer to the
target model. You can view and refine these mappings in the Mapping Editor.

The following tables list the objects that can be mapped for each kind of model.

CDM Mappings
CDM objects can be mapped to other model objects as follows:
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CDM Source
Objects

CDM Target
Objects

LDM Target
Objects

PDM Target
Objects

OOM Target
Objects

Entity Entity, Associa-
tion, Relationship

Entity, Relation-
ship

Table Class, Associa-
tion

Entity attribute Entity attribute,
Association at-
tribute

Entity attribute Column Class attribute

Relationship Entity, Associa-
tion, Relationship

Entity, Relation-
ship

Table, Reference Class, Associa-
tion

Inheritance Inheritance Inheritance - -

Inheritance attrib-
ute

Inheritance attrib-
ute

Inheritance attrib-
ute

- -

Association Entity, Associa-
tion

Entity, Relation-
ship

Table, Reference Class, Associa-
tion

Association At-
tribute

Association at-
tribute, Entity at-
tribute

Entity attribute Column Attribute

Data item Data item - - -

Domain Domain Domain Domain Domain

Note: You can map inheritances with CDM objects only when its child entities are not
generated, i.e. when the "Generate children" option is deselected in the Generation tab of the
inheritance property sheet.

LDM Mappings
LDM objects can be mapped to other model objects as follows:

LDM Source
Objects

CDM Target
Objects

LDM Target
Objects

PDM Target
Objects

OOM Target
Objects

Entity Entity, Relation-
ship, Association

Entity, Relation-
ship

Table Class, Associa-
tion

Entity attribute Entity attribute Entity attribute Column Attribute

Relationship Entity, Relation-
ship

Entity, Relation-
ship

Table, Reference Class, Associa-
tion

Inheritance Inheritance Inheritance Reference Generalization
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LDM Source
Objects

CDM Target
Objects

LDM Target
Objects

PDM Target
Objects

OOM Target
Objects

Inheritance attrib-
ute

Inheritance attrib-
ute

Inheritance attrib-
ute

- -

Domain Domain Domain Domain Domain

PDM Mappings
PDM objects can be mapped to other model objects as follows:

PDM
Source Ob-
jects

CDM Tar-
get Objects

LDM Target
Objects

PDM Target
Objects

OOM Tar-
get Objects

XSM Target
Objects

Table Entity, Rela-
tionship

Entity, Rela-
tionship

Table,
Fact,Dimen-
sion

Class, Associ-
ation

Element,
Complex type

Table column Entity attrib-
ute

Entity attrib-
ute

Table column,
Measure, Di-
mension at-
tribute

Attribute Element,
Complex type

View - - Fact,Dimen-
sion

Class -

View column - - View column,
Table column,
Measure, Di-
mension at-
tribute

Attribute -

Reference Relationship Relationship Reference Class, Associ-
ation

-

Domain Domain Domain Domain Domain -

OOM Mappings
OOM objects can be mapped to other model objects as follows:

OOM Source
Objects

CDM Target
Objects

LDM Target
Objects

OOM Target
Objects

XSM Target
Objects

Class Entity, Associa-
tion, Relationship

Entity, Relation-
ship, Inheritance

Class Element, complex
type
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OOM Source
Objects

CDM Target
Objects

LDM Target
Objects

OOM Target
Objects

XSM Target
Objects

Attribute Entity attribute,
Association at-
tribute

Entity attribute,
Inheritance attrib-
ute

Attribute Element, Com-
plex type

Generalization - Inheritance Generalization -

Association Association Entity, Relation-
ship

- -

Domain Domain Domain Domain -

XSM Mappings
XSM elements and complex types and their attributes can only serve as source objects for
mapping to other XSM elements, complex types and attributes, but they can serve as the
targets for mappings from OOM or PDM source objects.

Creating a Data Source
A data source provides a connection to one or more other models for mappings and (in the
PDM) can also provide a connection to a database. You are prompted to create a data source
with a wizard the first time you open the Mapping Editor or click the Create Mapping tool on
an object property sheet Mappings tab.

1. On the Data Source Identification page, enter an appropriate name for the data source, and
then specify an access type, which, for PDM data sources, controls the types of queries
available in the Mappings pane, and the availability of forward (Source > Target) and
reverse (Target > Source) mappings. You can choose between:

• Read/Write – Enables Criteria, Select, Insert, Update and Delete queries.
• Read-Only - Enables Criteria and Select queries. You can only create forward

mappings, and the data source is not displayed during reverse mapping (see Creating
Reverse Mappings on page 490).

• Write-Only - Enables Criteria, Insert, Update and Delete queries. You can only create
reverse mappings, and the data source is not displayed during forward mapping.

2. Select the type of the model to use as the data source, and click Next to go to the Source
Model Selection page.

3. Select one or more models from the list of open models in the workspace, and then:

• For data sources created from an object's Mapping tab - click Finish to create the data
source and open a selection dialog to choose the external object to map to.

• For data sources created from the Mapping Editor - click Next to go to the Options
page. By default, the Create default mappings option, which creates mappings where
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possible based on shared names, is selected. Click Finish to create the data source and
proceed to the Mapping Editor.

To view or edit a data source's properties, double-click its Browser or list entry. The
property sheet tabs and fields listed here are those available by default, before any
customization of the interface by you or an administrator.The General tab contains the
following properties:

Property Description

Name/Code/Com-
ment

Identify the object. The name should clearly convey the object's purpose to
non-technical users, while the code, which is used for generating code or
scripts, may be abbreviated, and should not normally include spaces. You
can optionally add a comment to provide more detailed information about
the object. By default the code is generated from the name by applying the
naming conventions specified in the model options. To decouple name-code
synchronization, click to release the = button to the right of the Code field.

Model Type Specifies the type of the models referenced in the data source.

Access type For PDM data sources, controls the types of queries available in the Map-
pings pane, and the availability of forward and reverse mappings.

Keywords Provide a way of loosely grouping objects through tagging. To enter multiple
keywords, separate them with commas.

The following tabs are also available:
• Models - Lists the models associated with the data source. Use the Add Models tool to

add models open in the current workspace.
• Database Connection - [for data sources created in a PDM] Contains the parameters

needed to connect to the database associated with the data source. Click the Select a
Data Source tool to specify an ODBC data source or connection profile (see 
Connecting to a Data Source on page 27).

• Cost - [for data sources created in a PDM that supports lifecycle modeling] Lets you
specify the cost per GB of storage for the data source along with the compression rate,
which is used to estimate the relative size of the data once it has been loaded to the data
warehouse (where 100% indicates no compression).

• Data Movement (Lifecycle) - [for data sources created in a PDM that supports
lifecycle modeling] Lets you define parameters to connect to a remote database, whose
data will be loaded into the warehouse.

Note: For information about the Create Data Source and Add Model to Data Source
tools available in the Mapping Editor, see Mapping Editor Tools on page 489.

The Mapping Editor
The Mapping Editor provides a graphical interface for creating and viewing mappings
between models or between metamodels. It provides a global view of all the mappings to
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objects in your model, allowing you to quickly identify those which are mapped and
unmapped.

To open the Mapping Editor, select Tools > Mapping Editor. If no data source is defined in
your model, you will be prompted to create one (see Creating a Data Source on page 476).

The Mapping Editor window is divided into three panes:

• Source – on the left side has a gray background and contains one or more data sources,
which each contain one or more models. Expand the model nodes to display all their
mappable objects and sub-objects.

Note: To expand all nodes, click in the pane and press the number pad * key.
• Target – on the right side has a white background and contains all the mappable objects

and sub-objects in your model. The details of any mappings you create are saved in the
objects in this model.

• Mappings - at the bottom contains either a list of mappings (when a model, package or
folder is selected) or the selected object's property sheet Mappings tab (see Object and
Sub-Object Mapping Properties on page 493).

Mappings are represented as links drawn between a source and a target object, with an arrow at
one or both ends to indicate in which directions data can flow. Double-clicking the link in the
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Source or Target pane opens the property sheet of the source or target object, while clicking it
in the area between the panes, displays the properties of the mapping in the Mappings pane.

An overlay is displayed on the bottom right corner of objects bearing mappings (and, for sub-
objects, their parent objects) and a smaller overlay on the containing model, package or folder
(or, for XSM elements, ancestor elements):

Mapped Object Containing Model, Package, or Folder

Source Target Source Target

Note: Click the Play Demo tool in the lower-left corner of the Mapping Editor window to
launch a video that briefly illustrates its main features.

Model-to-Model Mappings
You can create mappings in the Mapping Editor by drag and drop, or by using the Create
Mapping tool or contextual command. You can select multiple objects and sub-objects in the
Source pane using the Ctrl or Shift keys, but only one object in the Source pane.

To create a mapping, perform one of the following actions:

• Drag and drop - Select one or more objects and sub-objects in the Source pane and drag
and drop them onto an object or sub-object in the Target pane. The pointer becomes a
barred circle when it is over an object to which the selected objects cannot be mapped, and
if one source object in a multi-selection would create an invalid mapping, the whole
selection is rejected.

• Target pane - Select an object or sub-object in the Target pane and (optionally for
objects), one or more objects and sub-objects in the Source pane and click the Create
Mapping tool (or right-click one of the selected objects and select Create Mapping). If
the selected source objects are ambiguous or would create an invalid mapping, a selection
dialog opens, allowing you to select the source objects to map to.

• Mappings pane - Select an object or sub-object in the Target pane and click the Create
Mapping tool in the Mappings pane. For objects, a selection dialog opens, allowing you
to select the source objects to map to. For sub-objects, an empty mapping is created, which
you should complete by selecting a source object on the Sources sub-tab.

• Default mappings - To create default mappings between source and target objects that have
the same name, right-click a data source and select Generate Default Mappings.

Note: If a mapping already exists between a source and target object, then dragging and
dropping will reuse and add additional information to the existing mapping object, while
using the Create Mapping tool or contextual command will create a second mapping object.
Each mapping object is available in the Mapping list at the top of the Mappings pane.

Mappings can be created for combinations of source and target objects and sub-objects as
follows:
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• Source object mapped to target object - The objects are mapped together, and any sub-
objects that have the same name and code are also mapped together. A mapping overlay is
displayed on each of the source and the target objects and sub-objects mapped, and a link is
drawn between them:

The mapping details are shown in the Mappings pane. The source objects are shown on
the Sources sub-tab, and any sub-objects are shown on the Sub-object Mappings sub-
tab.

• Source sub-object mapped to target sub-object – The sub-objects and their parent objects
are mapped together and the mapping is added to the list on the Sub-object Mappings
sub-tab of the parent object.

• Source sub-object mapped to target object – The parent source object is mapped to the
target object.

• Source object mapped to target sub-object – Not permitted.

Mappings (including sub-object mappings) are always stored in target objects (for example, a
mapping between a source CDM entity attribute and a target PDM table column will be stored
in the table).

Note: In an XSM, elements can appear at any level in the hierarchy, and objects and sub-
objects can be freely mapped to any element. Each element (whether parent, child, or
grandchild) stores its own mappings, except in the case of elements bearing a complex type,
where all mappings to any sub-elements are stored on the element bearing the type (though
they are displayed on the sub-elements).

If you open the Mapping Editor with a source or target XSM containing shortcuts to complex
types in a closed model, PowerDesigner will offer to open the model for you. If you choose not
to open the model at this time, you can do so at any time by right-clicking a shortcut and
selecting Open Model:

Shortcuts Closed Shortcuts Open
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Object to Relational (O/R) Mappings
Developers tend to use object-oriented programming languages like Java, to develop business
objects and components. These objects can be stored in a database. A problem arises when the
user tries to store objects in a relational database because object modeling describes a system
through objects that have identity, behavior and encapsulated state whereas relational
modeling describes a system by its data.

In addition, object language object codes are often different than the codes used to identify
tables and columns in a relational database, so that you will need to modify them when
generating an OOM into a PDM or vice versa.

You can use object mapping to bypass this impedance-mismatch.

The following schema illustrates the link between classes and tables to store objects in a
relational database:

Object persistence implies to store and extract objects in a relational database.
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Mapping Classes with PDM Objects
When a class inherits from a non-generated class via a generalization link, the attributes of the
class appear in the Selection dialog box in order to let you create a mapping with these
inherited attributes. The attributes of a non-generated derived class also appear in the
Selection dialog box.

Mapping Associations with PDM Objects
O/R mapping on an association allows you to define the role navigability of an association in
the database. When an association role is not navigable, there is no need to design a mapping
for the association since no information is transmitted between the classes. However, when an
association role is navigable, you have to set up the structure for data transmission within the
database. In relational databases, data transmission is implemented via foreign keys designed
to relate a record in one table with a record in another.

The type of mapping for an association depends on the association multiplicity:

• One-to-one or one-to-many associations can be mapped to a reference in the source model.
This reference is used in the database to transfer data and migrate key columns to the
appropriate table

• Many-to-many associations have to be mapped to an associative table. This table is created
to maintain a relationship between two or more tables in a relational database. The
columns contained in the associative table are the combination of the keys in the tables
involved in the reference. For example, the following classes have a many-to-many
association:

In a relational database, this association is mapped to the following associative table:

SQL Queries
When the association roles are navigable, the following queries are automatically computed:
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Query Action

Select (Role A) Retrieves related class A instances for the role A defined on class B

Insert (Role A) Associates an instance of class A with class B. It is computed only when the
source association is an associative table

Delete (Role A) Deletes from class B the association with class A. This query is computed only
when the source association is an associative table

Select (Role B) Retrieves related class B instances for the role B defined on class A

Insert (Role B) Associates an instance of class B with class A. This query is computed only
when the source association is an associative table

Delete (Role B) Deletes from class A the association with class B. This query is computed only
when the source association is an associative table

Operational to Warehouse Data Mappings
Data warehousing requires the extraction, transformation, and loading of data from
operational systems to a data warehouse database. You can create mappings between
operational and data warehouse data and from the data warehouse data and OLAP cubes. To
review or edit these mappings, open your multidimensional diagram, and then select Tools >
Mapping Editor.

You can model operational and data warehouse data structures in PDMs, and specify
mappings between the operational data sources and the data warehouse to generate extraction
scripts to populate the data warehouse with operational data. In this kind of relational-to-
relational mapping, operational tables are mapped to data warehouse tables with a type of fact
or dimension, and operational columns are mapped to warehouse columns.

The Generate Cube wizard automatically creates mappings between source tables and facts
and dimensions and you can modify these or manually create mappings between these objects:
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The Select sub-tab displays the SQL statement used to select data in the data source. The
Generate Cube Data wizard uses this SQL statement to fill the text files used to populate cubes
in an OLAP database.

XML Import Mappings
You control how elements defined in an XML schema are imported by mapping them and their
attributes, compositions, and aggregations to objects in the PowerDesigner metamodel. The
XML schema is analyzed and presented as a list of metaclasses on the left side of the Mapping
Editor and the PowerDesigner metamodel (and any extensions) are displayed on the right
side.

Note: It is not necessary to map all metaclasses (or all their contents), but only those with
which you want to work. If the PowerDesigner metamodel does not contain appropriate
metaclasses, attributes, compositions, or aggregations to map against, you can create them
dynamically here or save any existing mappings, close the Mapping Editor, define or attach
appropriate extensions, and then reopen the Mapping Editor to map to them.

1. Drag and drop an external metaclass to a PowerDesigner metaclass to create an import
mapping. Any external attributes and collections are automatically mapped to
PowerDesigner attributes with which they share a name:
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By default, the Mapping Editor lists the standard attributes and collections of metaclasses,
which are normally displayed in object property sheets. To display all available properties,
click the Filter Properties tool, and select Show All Properties. You can also filter
the tree by using the Filter Mappings and Filter Objects tools.

Note: If no suitable metaclass exists, to create and map to a new extended metaclass based
on the ExtendedObject metaclass, drag and drop the external metaclass onto the
PowerDesigner metamodel root.

2. Drag and drop additional attributes under the metaclass to PowerDesigner attributes with
compatible data types to create mappings for them. Attributes are contained in a folder
under the metaclass and represent individual properties such as Name, Size,
DimensionalType, which have boolean, textual, numeric, or object ID values:

PowerDesigner identifies sub-object metaclasses in the schema that are limited to a single
instance and displays a 1 overlay on their icons. Attributes under such metaclasses are
treated as belonging to the parent metaclass and can be mapped to attributes under the
PowerDesigner object with which the parent is mapped:

Note: If no suitable attribute exists, to create and map to a new extended attribute, drag and
drop the external attribute onto the PowerDesigner metaclass to which its parent is
mapped.

3. Drag and drop external sub-object metaclasses (compositions) under the metaclass to
PowerDesigner compositions to create mappings between them:
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Any attributes under the sub-object metaclass are automatically mapped to
PowerDesigner attributes with which they share a name. Map other sub-object attributes as
necessary.

Note: In certain circumstances, it may be appropriate to map an external sub-object
metaclass to a PowerDesigner object metaclass, and so such mappings are also permitted.

4. Drag and drop external collections (aggregations) under the metaclass to PowerDesigner
collections to create mappings between them:

5. In certain schemas, it may be necessary to identify attributes as references and identifiers
to link one metaclass to another through aggregation:

a) Right-click an attribute and select Declare as Object Reference to specify that it acts
as a pointer to another object. Such attributes often have a type of GUID, Token, or
NCName (PowerDesigner automatically identifies attributes of type IDRef as
references). A rounded arrow overlay is added to the attribute icon:

b) Open the metaclass that the object reference points to, select its identifying attribute,
right-click it, and select Declare as Unique Identifier. A key overlay is added to the
attribute icon:
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c) The object reference attribute can now be mapped to a PowerDesigner attribute of type
object (which also bears a rounded arrow overlay):

6. [optional] Select a metaclass and enter an initialization or post-processing script to modify
the objects at or after creation (see Metamodel Mapping Properties on page 495).

7. [optional] Click the target model (root node) to display the global list of mappings in the
Mappings pane at the bottom of the dialog and use the arrows at the bottom of the list to
change the order in which objects are imported to ensure that dependencies are respected.

Note: To control the order in which attributes, compositions, and aggregations are
imported within objects, select the target metaclass to display its mappings in the
Mappings pane, and use the arrows at the bottom of the lists on the Attribute Mappings,
Collection Mappings, and Sub-Object Mappings sub-tabs.

8. Click Apply to save your changes.

Model-to-Model Generation Mappings
You control how metaclasses from one PowerDesigner model type will be generated to
metaclasses in another model type by mapping them and their attributes and collections in the
Mapping Editor. Any extensions defined for the source or target metamodels are displayed
and available for mapping.

Note: It is not necessary to map all metaclasses (or all their contents), but only those with
which you want to work. If the PowerDesigner metamodel does not contain appropriate
metaclasses, attributes, compositions, or aggregations to map against, you should save any
existing mappings, close the Mapping Editor, define or attach appropriate extensions, and
then reopen the Mapping Editor to map to them.

1. Drag and drop a metaclass from the source pane on the left to a metaclass in the Target pane
on the right. Any source attributes are automatically mapped to target attributes with which
they share a name:
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Note: By default, the Mapping Editor lists the standard attributes and collections of
metaclasses, which are displayed, by default, in object property sheets. To display all
available properties, click the Filter Properties tool, and select Show All
Properties. You can also filter the tree by using the Filter Mappings and Filter
Objects tools.

2. Drag and drop additional source attributes under the metaclass to target attributes with
compatible data types to map them. Attributes are contained in a folder under the
metaclass and represent individual properties such as Name, Size, DimensionalType,
containing boolean, textual, numeric, or object ID values:

3. Drag and drop source sub-object metaclasses (compositions) under the metaclass to target
compositions to create mappings between them:

Any attributes under the source sub-object metaclass are automatically mapped to target
attributes with which they share a name. Map other sub-object attributes as necessary.

Note: In certain circumstances, it may be appropriate to map a source sub-object metaclass
to a target object metaclass, and so such mappings are also permitted.

4. Drag and drop source collections (aggregations) under the metaclass to target collections
to create mappings between them:

5. [optional] Select a metaclass and enter an initialization or post-processing script to modify
the objects at or after creation (see Metamodel Mapping Properties on page 495).

6. [optional] Click the target model (root node) to display the global list of mappings in the
Mappings pane at the bottom of the dialog and use the arrows at the bottom of the list to
change the order in which objects are generated to ensure that dependencies are respected.

Note: To control the order in which attributes, compositions, and aggregations are
generated, select the target metaclass to display its mappings in the Mappings pane, and
use the arrows at the bottom of the lists on the Attribute Mappings, Collection
Mappings, and Sub-Object Mappings sub-tabs.

7. Click Apply to save your changes.
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Mapping Editor Tools
The Mapping Editor Source and Target panes contain tools to help you create and review
your mappings.

The following tools are available in the Source pane:

Tool Description

Properties - Opens the property sheet of the selected source object.

Create Data Source - Launches the Data Source Creation Wizard (see Creating a Data
Source on page 476).

Delete Data Source - Deletes the selected data source, along with any associated mappings.

You can delete all the mappings from a source object by selecting it and pressing Delete or
right-clicking it and selecting Delete Mapping. You can delete a source object from the
source model by selecting it and pressing Shift+Del or right-clicking it and selecting
Delete).

Add Model to Data Source - Adds one or more source models of the same type to the
selected data source.

Remove Model from Data Source - Deletes the selected model from the data source, along
with any associated mappings.

Find Source Object - Opens a Find dialog to search for an object in the Source pane.

The following tools are available in the Target pane:

Tool Description

Properties - Opens the property sheet of the selected target object.

Create Mapping - Creates a mapping between the selected source and target objects (see 
Model-to-Model Mappings on page 479).

Delete Mappings - Deletes all the mappings for the selected target object. Alternately, press
Delete or right-click the object and select Delete Mapping. You can delete a target object
from its model by selecting it and pressing Shift+Del or right-clicking it and selecting
Delete.

Filter Mappings - Filters the display of mapping lines to show all mappings or only the
mappings on the selected object or those on the selected object and its sub-objects.

Filter Objects - Filters the display of both the Source and Target trees to show all objects or
to show only those objects with or without mappings.
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Tool Description

Find Target Object - Opens a Find dialog to search for an object in the Target pane.

Creating Reverse Mappings
The default forward mappings define how to populate the objects of the current model with
those of the data source model. Reverse mappings are typically used in PDM-OOM mapping
when, for example, data has several sources and you want to define how the data in the OOM is
inserted, updated or deleted in the PDM.

To switch to reverse mapping mode, click the left arrow at the top of the area between the
Source and Target panes. The left pane is renamed to Target and the right pane to Source, and
the mapping tools which appear at the top of each pane are switched:

Note: Mappings are always saved in the model on the right-hand side (the model from which
you launched the Mapping Editor), whether the pane is called Target or Source.

If the access type of your data source is Read/Write (see Creating a Data Source on page 476),
then each mapping that you create is, by default, bi-directional (with an arrow at each end). To
create a:

• Read-only (ie forward-only mapping), create the mapping in forward mode and then
switch to reverse mode and select and delete it. The mapping link now becomes dotted and
has an arrow only on its right end.

• Write-only (ie reverse-only mapping), create the mapping in reverse mode and then switch
to forward mode and select and delete it. The mapping link now becomes dotted and has an
arrow only on its left end.

When you create uni-directional mappings in this way, the following types of link line can be
visible:

Forward Mode Mapping Type Reverse Mode

Forward and reverse (read-write) map-
ping

Forward only (read-only) mapping

Reverse only (write-only) mapping

Solid lines indicate that you can edit the details of the mapping in the Mappings pane (which,
in reverse mode, is renamed to Reverse Mappings). In reverse mode, you can modify the
default reverse mapping by editing the Insert, Update and Delete sub-tabs.
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Creating Mappings from an Object's Property Sheet
You can create mappings to an individual object on the Mapping tab of its property sheet.
Mappings created in this way will be visible the next time you open the Mapping Editor.

1. Open the property sheet of the object you want to create mappings to and click the
Mapping tab.

2. Click the Create Mapping tool to the right of the Mapping list to create a new mapping
for the target object. If:

• No data source has yet been created in the model you will be prompted to create one
(see Creating a Data Source on page 476).

• Several data sources are available, you will be prompted to select one and click OK.

3. Select the object from the data source to map to the present object and click OK to create
the mapping.

The new mapping is added in the Mapping list and the mapped object is displayed in the
Object Sources sub-tab:

4. [optional] Click the Add Objects tool to select more source objects to map with the object.

5. Click the Sub-Object Mapping sub-tab and add or remove mappings between sub-
objects (see Object and Sub-Object Mapping Properties on page 493)
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To automatically generate mappings for sub-objects that share a name, click the Generate
Mapping tool.

6. [optional] Review the other mapping sub-tabs (which are the same as those available from
the mapping's own property sheet (see Object and Sub-Object Mapping Properties on page
493) and edit them as appropriate.

7. [optional] Use the Mapping list and the tools to its right to review and edit the other
mappings defined on the object:

Tool Description

Create Mapping - Creates a new mapping with the object as a target.

Delete Current Mapping - Deletes the currently selected mapping.

Properties - Opens the property sheet of the currently selected mapping (see Object and
Sub-Object Mapping Properties on page 493).

Launch Mapping Editor - Opens the Mapping Editor (see The Mapping Editor on page
477).

CHAPTER 16: Object Mappings

492 SAP Sybase PowerDesigner



Object and Sub-Object Mapping Properties
Mappings are sub-objects of the target object on which they are defined. Mappings do not have
diagram symbols or Browser entries, and are only accessible from the Mapping Editor or from
the Mapping tab of their parent object property sheet.

To open a mapping property sheet, select the mapping from the list at the top of the Mapping
Editor Mappings pane or parent object property sheet Mapping tab and click the Properties
tool.

The tabs available on a particular mapping property sheet depend on the objects being
mapped. The General tab contains the following properties:

Property Description

Data Source Specifies the name of the data source in which the source object is defined. Click the
Properties tool to open the property sheet of the data source.

Target Specifies the name of the target object that owns the mapping.

Parent [Sub-object mappings] Specifies the name of the parent of the target object.

Name/Code/
Comment

Identify the mapping. The name should clearly convey the object's purpose to non-
technical users, while the code, which is used for generating code or scripts, may be
abbreviated, and should not normally include spaces. You can optionally add a com-
ment to provide more detailed information about the mapping. By default the code is
generated from the name by applying the naming conventions specified in the model
options. To decouple name-code synchronization, click to release the = button to the
right of the Code field.

Mapped to Specifies the mapping expression. You can edit the expression directly in this field, or
click the Edit tool to open it in a dedicated SQL or Object Expression editor. In the
editor, select an object type from the list in the upper left corner, to display a list of
available objects of that type in the upper right corner. Double-click an available
object to add it at the insertion point in the expression displayed in the lower half of
the editor.

To undo your changes and recover the default expression click to release the User-
Defined button.

The following tabs are also available:

• Sources - Lists the source objects mapped to the object. Use the Add Sources tool to add
additional source objects to the list.
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• Sub-Object Mappings - Lists the sub-objects of the mapped object that are mapped with
sub-objects of the object. The following tools are available on this tab.

Tool Description

Properties - Opens the property sheet of the selected sub-object mapping.

Add Mapping - Select additional source sub-objects to map. After adding sub-objects,
select the sub-objects to map them against in the Mapped to column.

Create from Sources - Copy sub-objects from the source object to the object. The name,
code , description, annotation, and comment are copied and the data types are converted
in order to match the current model.

Generate Mapping - Automatically generate mappings between sub-objects with the
same name or code in the source and target models.

Click the Ellipsis button in the Mapped to column to edit the source expression for the
sub-objects.

• Operation Mappings - [OOM classes only] Lists the operations and queries associated
with the mapping. Allows you to associate a SQL query to the operation. When an
operation implies action on the database, like data retrieval or data update, you can
associate this operation with a SQL query that will execute an action in the database.
Usually, this query is a SELECT statement used to retrieve one or several instances of the
current class according to the operation parameter. It can also be an UPDATE query. In the
context of an EJB, the SQL query mapped to an operation is used to implement finder or
select methods.

• Criteria - Allows you to specify join criteria between source objects. For example:
EMPLOYEE.ID < 100

• Query - Computes a SQL query from the information in the other tabs to retrieve or update
data in the database. If you modify the SQL query, it can no longer be automatically
calculated, even when you update the mapping. You can recover the computed expression
by clicking to release the User-Defined tool.
A Select query is available for a forward mapping, and Insert, Update and Delete queries
for a reverse mapping:
• The Select tab retrieves attribute values of class instances from the database using the

class identifying attributes. For example:
select
  USER.USERNAME "USERNAME",
  USER.PASSWORD "PASSWORD"
from  USER

• The Insert tab creates an instance of the class and saves it with its attributes. For
example:
insert into USER(
   USER.USERNAME,
   USER.PASSWORD)
values (
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   %USERNAME%,
   %PASSWORD%)

• The Update tab displays a statement that allows you to update attribute values of class
instances apart from identifying attributes. For example:
update USER
set USER.USERNAME = %USERNAME%,
  USER.PASSWORD = %PASSWORD%

• The Delete tab displays a statement that allows to delete a class instance from the
database using its identifying attributes. For example:
delete line* from USER

To modify the default syntax of the queries, edit the SelectStatement,
InsertStatement, UpdateStatement, and DeleteStatement entries in the
Profile category of the object language or extension (see Customizing and Extending
PowerDesigner > Extension Files).

Metamodel Mapping Properties
Metamodel mappings are mappings between metamodel objects, which control how objects
are imported or generated. Metamodel mappings are sub-objects of the PowerDesigner
metamodel object on which they are defined.

To open a metamodel mapping property sheet, select the mapping from the list at the top of the
Mapping Editor Mappings pane or parent object property sheet Mapping tab and click the
Properties tool.

The tabs available on a particular mapping property sheet depend on the objects being
mapped. The General tab contains the following properties:

Property Description

Source object Specifies the metamodel object being mapped to the target object.

Target object Specifies the metamodel object being mapped from the source object. This object is
the parent of the mapping itself.
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Property Description

Transforma-
tion script

[metaattribute mappings] Specifies a script to set the value of the attribute. In the
following example, from an XML import, the notnullable attribute is imported

to the Mandatory attribute and, because the sense of the attributes is reversed, the

boolean value imported is set to the opposite of the source value:

Sub %Set%(obj, sourceValue)
   obj.SetAttribute "Mandatory", not sourceValue
End Sub

In the following example, from an object generation, the NumberID attribute is

generated to the Comment attribute and a text string is prepended to make clear the

origin of the value:

Function %AdjustValue%(sourceValue, sourceObject, tar-
getObject)
   Dim targetValue
   targetValue = "The original process NumberID is " 
+cstr(sourceValue)
   %AdjustValue% = targetValue
End Function

The following tabs are also available for metaclass mappings:

• Initialization - Specifies a script to initialize the metaclass to be created. In the following
example, the value of the Stereotype attribute is set to SimpleType:
Sub %Initialize%(obj)
   obj.Stereotype = "SimpleType"
End Sub

• Attribute Mappings - Lists the mappings of attributes under the metaclass. Select a
mapping and click the Properties tool to open its property sheet. To control the order in
which attributes are created, in order to respect dependencies between them, use the
arrows at the bottom of the list.

• Collection Mappings - Lists the mappings of collections under the metaclass.
• Post-Process - Specifies a script to modify the metaclass after creation and execution of

mappings. In the following example, the value of the Code attribute is copied to the Name
attribute:
Sub %PostProcess%(obj)
   ' Copy code into name
   obj.Name = obj.Code
End Sub
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Metamodel Object Properties
To view the properties of metaclasses, metaattributes, and metacollections displayed in the
Mapping Editor, double-click the object node in the Mapping Editor or right-click the node
and selecting Properties.

The General tab contains the following properties:

Property Description

Parent [metaattributes and metacollections] Specifies the metaclass to which the metaobject
belongs.

Parent collec-
tion

[sub-objects/compositions] Specifies the name of the composition collection that
contains the sub-objects under the parent object.

Name Specifies the name of the metaclass in the PowerDesigner metamodel or XML sche-
ma.

Data type [metaattributes] Specifies the data type of the attribute.

Identifier [metaattributes] Specifies that the attribute is used to identify the metaclass for ref-
erencing by another metaclass.

Reference /
Reference
path

[metaattributes and metacollections] Specifies that the attribute or collection is used
to point to another metaclass to form an aggregation.

Singleton [metaclasses] Specifies that only one instance of the metaclass is possible under each
parent object.

Comment Provides additional information about the metaobject.

The following tabs are also available for metaclasses:

• Attributes - Lists the metaattributes belonging to the metaclass. Select an attribute in the
list and click the Properties tool to open its property sheet.

• Collections - Lists the metacollections belonging to the metaclass. Select a collection in
the list and click the Properties tool to open its property sheet.
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CHAPTER 17 Impact and Lineage Analysis

Before you perform an action on a model object, such as deleting a table or changing the
datatype of a primary key column, you can preview which other objects will be impacted
(impact analysis) and identify the objects that take part in the definition of the object (lineage
analysis). You can generate the analysis to an impact analysis model (IAM) to review it in a
diagram and save it for future reference.

1. Open an impact and lineage analysis in any of the following ways:

• Select one or more objects in the diagram and select Tools > Impact and Lineage
Analysis (or press Ctrl+F11).

• Right-click an object in the Browser Local tab or diagram and select Impact and
Lineage Analysis.

• [when deleting an object] Click the Impact button on the Confirm Deletion dialog
box.

• In an object's property sheet, select the Dependencies tab, and click the Impact and
Lineage Analysis button.

Note: This feature is also available in the repository (see Impact and Lineage Analysis in
the Repository on page 331) and the PowerDesigner Portal (see Impact and Lineage
Analysis in the PowerDesigner Portal on page 341)

The analysis applies rules to the initial objects to generate a tree view of influencing
(lineage) and dependent (impacted) objects, which appears instantly in the dialog. The
following example shows all the objects that will be impacted by a change to the
Employee table, and all the objects that influence it (lineage analysis):

Core Features Guide 499



2. [optional] Select Use Repository and specify a Repository analysis level to search for
additional impacted or lineage objects in the repository. If you are not currently connected
to the repository, the Connect dialog opens to allow you to do so.

In the example, you see an additional impacted object, an entity that was generated from
the table to the Project Management CDM. The blue overlay in the bottom-left
corner of the object indicates that it is located in the repository.
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3. [optional] Enter a name for your analysis result, which is then used as the name of any
generated model.

4. [optional] Change the impact rule set to apply to your analysis:

• Conceptual Impact Analysis – identifies the objects impacted by changes to the
object.

• Data Impact Analysis – identifies uses of values contained in the object.
• Delete Impact Analysis – [default when deleting] identifies the objects impacted by

the deletion of the object.
• Global Impact Analysis – [default when not deleting] identifies all the objects that

depend on the object.
• None – no impact rule set is selected.

Note: Click the Properties tool to the right of the field to review the selected rule set. Click
the Select Path tool above the list to change the folder containing rule sets, or the List of
Rule Sets tool to open any rule set (see Analysis Rule Sets on page 512).

5. [optional] Change the lineage rule set to apply to your analysis:

• Conceptual Lineage Analysis – identifies the objects that justify the existence of the
object, and ensure it fulfills a well-identified need.

• Data Lineage Analysis – identifies the origin of values contained in the object.
• Global Lineage Analysis – [default when not deleting] identifies all the objects that

influence the initial object.
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• None – [default when deleting] no lineage rule set is selected.

6. [optional] Click the Generate Diagram button to save the analysis to a diagram in an
impact analysis model (IAM). The following example shows the 'Employee' table in the
center of the diagram with its influencing objects above it and its dependent objects
beneath it:

Reviewing and Modifying an Analysis
The Impact and Lineage tab displays the result of the analysis in a tree format, showing all the
impacted and lineage objects. Each item in the tree displays either an [action] suffix to indicate
the effect on an impacted object or a [lineage] suffix to designate lineage items

In this example, the analysis shows that:

• A change on the Participate entity will result in changes to the Task and
Employee entities with which it has relationships (and that the change will cascade down
from the Task entity to the Project and Customer entities).

• The business rules Task date control and Participate date control
form part of the definition of the Participate entity, which was generated from the
Participate table in Project Management (PDM).

Note: If an object is dependent multiple times then, for performance reasons, only the first
entry appears in detail in the tree. Right-click subsequent undeveloped entries and select Go to
First Occurrence to jump to the detail.

CHAPTER 17: Impact and Lineage Analysis

502 SAP Sybase PowerDesigner



The following tools are available on this tab:

Tool Description

Properties – Opens the property sheet of the selected item.

Add Initial Objects – Opens a selection dialog to add objects to analyze.

Re-Analyze – Recalculates the analysis from the selected point in the tree downwards.
Select the root object to re-analyze the entire tree.

You can modify your analysis in the following ways:
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• To extend the analysis to include objects in the repository, select Use Repository and
specify a Repository analysis level to control the number of levels of dependencies to
search for.

• To add objects to analyze, click the Add Objects tool to open a selection dialog, select one
or more objects, and click OK.

• To simplify the tree, right-click any object or collection and select Remove to remove it
and its descendants.

Note: Right-click any node in the tree and select Re-analyze to replace any objects or
collections that have been removed in this way. To view the available collections and
modify those that appear for an object, right-click it and select Change Impact Analysis
Objects or Change Lineage Analysis Objects (see Controlling the Display of Object
Collections on page 506).

• To change the action being analyzed for any object, right-click it and select one of Change
Action to [Change], Change Action to [Delete], or Change Action Description to open
the Action Description dialog (and select one or more of Delete, Change, and any User-
defined actions separated by semicolons).

• To change the rule set used in the analysis, select a new rule set from the lists at the top of
the dialog.
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Viewing the Preview as a List
The List tab displays a tabular report of all the objects contained in the impact and lineage
analysis. You can customize the report by filtering which attributes you want to view, save the
report in RTF or CSV format, and print it.

The following tools are available on the preview List tab:

Tool Description

Properties – Displays the property sheet of the selected object in the list.

Save – Saves the list in RTF (for MS Word) or CSV (for MS Excel) format.
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Tool Description

Print – Prints the list.

Copy – Copies the list in RTF or CSV format.

Find a Row – Opens the Find dialog box to let you search the list for a specific object.

Customize Columns and Filter – Opens the Customize Columns and Filter dialog to select
attributes to display in the list and specify expressions to filter by (see Customizing Object
List Columns and Filtering Lists on page 113).

Enable/Disable Filter - Enables or disables the filter on the list.

Controlling the Display of Object Collections
You cannarrow or widen the analysis by changing the collections of impact and lineage
objects that appear.

1. Open the Impact (or Lineage) Analysis Objects dialog box in any of the following ways:

• [from preview] Right-click an object in the preview tree, or in the IAM Browser or
diagram, and select Change Impact Analysis Objects or Change Lineage Analysis
Objects to open a list of available collections of objects. A collection is listed here only
if one or more impact (or lineage) objects belonging to the collection are present in the
current analysis:

2. Select or unselect the following check boxes to control the display of collections:

• S [Selected] - enables the display of the collection in your analysis.
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• L [Replace link object by extremity] - If the object is a link, this option hides it to
simplify the display and view only the object at the other end of the link.

• R [Recursive] - Displays recursive collections in a single list.

3. [optional] Click the Properties tool to open and review or edit the analysis rule set in the
Resource Editor (see Analysis Rule Sets on page 512).

4. [optional] Click the Apply Changes to Rule Set tool to apply your changes to the rule set
so that they are automatically applied next time.

5. Click OK to close the dialog box.

The display of the selected object collections is updated in the preview tree or IAM. If you
re-analyze your model, then the collection rules specified in the rule set are reapplied.

Reviewing and Modifying an IAM Model
You generate an impact analysis model (IAM) by clicking the Generate Model button on the
Impact and Lineage Analysis dialog box. An IAM provides a graphical view of your analysis
and allows you to save the analysis as a snapshot for later reference.

In the above example, the Employee table shows influencing (lineage) objects on the left and
dependent (impacted) objects on the right. Links between the objects represent the analysis
rules that propagate actions on objects.

The following types of objects are available in an IAM:
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Symbol Description

Initial objects - The model objects being analyzed have symbols surrounded by
dotted lines. In the Browser, click to expand the initial object to view the tree of its
incoming references (impacted objects) and outgoing references (lineage ob-
jects). You can also see the list of initial objects by selecting Model > Analysis
Objects.

Impacted and lineage objects - The model objects that are impacted by or influ-
encing the initial objects. In the Browser, these collections of objects are inside
folders bearing a downward arrow ( ) for impacted objects or an upward arrow
( ) for lineage objects.

Link - Analysis rule between initial objects and impacted objects.

[none] Impacted Models - The models that are impacted by the change. You can see the
list of impacted models in the Browser or by selecting Model > Analysis Mod-
els.

Note: You can add graphical objects, such as notes or decorative symbols, to your diagram.

You can modify your analysis in the following ways:

• To extend the analysis to include objects in the repository, select Tools > Change Analysis
Options to open the Impact and Lineage Analysis Options dialog, select Use
Repository and specify a Repository analysis level to control the number of levels of
dependencies to search for.

• To add or remove initial objects to analyze, click Tools > Change Analysis Options,
select the Initial Objects tab, and use the Add Objects or Delete tool.

• To remove any object or collection and its descendants to simplify the tree, select it in the
Browser or diagram and press Delete.

Note: Right-click any node in the Browser or diagram and select Re-analyze to replace
any objects or collections that have been removed in this way. To view the available
collections and modify those that appear for an object, right-click it and select Change
Impact Analysis Objects or Change Lineage Analysis Objects (see Controlling the
Display of Object Collections on page 506).

• To change the action being analyzed for any object, right-click it and select one of Change
Action to [Change], Change Action to [Delete], or Change Action Description to open
the Action Description dialog (and select one or more of Delete, Change, and any User-
defined actions separated by semicolons).

• To change the rule set used in the analysis, click Tools > Change Analysis Options to
open the Impact and Lineage Analysis Options dialog, select a new rule set and click
OK.
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IAM Model Properties
The model property sheet displays the definition of the current IAM. You can check the last
analysis date of your model or add a comment, for example.

To open an IAM property sheet, double-click its Browser entry. The General tab contains the
following properties:

Property Description

Name / Code / Comment Identify the model. The name should clearly convey the model's purpose
to non-technical users, while the code, which is used for generating code
or scripts, may be abbreviated, and should not normally include spaces.
You can optionally add a comment to provide more detailed information
about the model. By default the code is auto-generated from the name by
applying the naming conventions specified in the model options. To de-
couple name-code synchronization, click to release the = button to the
right of the Code field.

Filename Specifies the location of the model file. This field is empty if the model
has never been saved.

Author Specifies the author of the model. If you enter nothing, the Author field in
diagram title boxes displays the user name from the model property sheet
Version Info tab. If you enter a space, the Author field displays nothing.

Version Specifies the version of the model. You can use this box to display the
repository version or a user-defined version of the model. This parameter
is defined in the Title page of the model display preferences.

Default diagram Specifies the diagram that appears by default when you open the model.

Last analysis date [Read-only] Computed date of the last model analysis, which is updated
every time you re-analyze the model.

Keywords Provide a way of loosely grouping objects through tagging. To enter
multiple keywords, separate them with commas.

Setting IAM Display Preferences
PowerDesigner display preferences let you customize the format of object symbols and the
information that appears on them. To set IAM display preferences, select Tools > Display
Preferences, or right-click the diagram background, and select Display Preferences.

These display preferences are available for analysis objects:

Preference Description

Model name Displays the model name of the analysis object.

Object type Displays the type of the analysis object.
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Preference Description

Action Displays the action name of the analysis object.

Highlight initial
object

Displays a dotted line around the symbol of the initial object.

The following display preferences are available for analysis links:

Preference Description

Name Displays the name of the link.

For information about changing the format of symbols, see Format Display Preferences on
page 212.

Comparing Two IAM Models
Select Tool > Compare Models to view the differences between two IAMs. The comparison
window displays the objects contained within the models in a tree format, and highlights the
differences between them.

For detailed information about comparing models, see Chapter 7, Comparing and Merging
Models on page 223.

Printing an Analysis
You can print the preview list or the IAM model diagram, or create a list report in the IAM to
document and discuss proposed changes.

You can print the analysis in any of the following ways:

• [from Preview] Click the List tab (see Viewing the Preview as a List on page 505) and
select the Print tool.

• [from the IAM] Select File > Print to print the diagram (see Printing Diagrams on page
173).

• [from the IAM] Select Reports > List Report Wizard to create a list report for an object
type and print it (see Creating a List Report on page 370).

IAM Custom Checks
PowerDesigner does not provide any predefined checks for the data testing of an IAM.
However, you can create custom checks in an extension.

For information about developing custom checks, see Customizing and Extending
PowerDesigner > Extension Files.
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You can check an IAM in any of the following ways:

• Press F4.
• Select Tools > Check Model.
• Right-click the diagram background and select Check Model.

The Check Model Parameters window opens, which allows you to specify the kinds of checks
to perform, and the objects to apply them to. For detailed information about this window and
correcting problems reported, see Checking Models on page 137.

Obtaining Cross-Model Dependencies Without a Repository
Connection

If you anticipate needing to obtain information about cross-model dependencies with models
not in your workspace in a situation where you will not have a repository connection, you can
obtain this information in advance by checking your model out with the Check out
dependencies option.

For models checked out with the Check out dependencies option (see Checkout Parameters
on page 315) objects that are implicated in an impact or lineage analysis but that are not
currently available display a red overlay in their bottom-left corner to indicate that the analysis
cannot proceed beyond this point without connecting to the repository or otherwise obtaining
the parent model. This option also ensures the cross-model dependencies appear on the
Dependencies tab of objects even when the other models are not open in the workspace.

In the following example, the Employee table, which is generated from the Employee
entity, is present in the analysis even though its model is not available, because the model from
which the analysis was launched was checked out with dependencies:
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Analysis Rule Sets
Impact and lineage analysis uses sets of analysis rules derived from relationships between
metaclasses in the metamodel to construct the trees of impacted and lineage objects.
PowerDesigner provides standard rule sets (XML resource files with a .rul extension), and
you can create your own.

Each rule represents a potential collection of objects, and is represented as a folder in the
analysis tree. In the following example, deleting the Employee table also deletes all the
members of the Columns, Keys, Indexes, and Incoming and Outgoing
References collections:
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You can open an analysis rule set in any of the following ways:

• From an analysis preview, click the Properties tool next to the rule set.
• From an IAM, select Tools > Change Analysis Options, and click the Properties tool

next to the rule set.
• From any model, select Tools > Resources > Impact and Lineage Analysis Rule Sets,

select an available rule set, and click the Properties tool. For information about the tools
available in resource file lists, see PowerDesigner Resource Files on page 272.

Analysis rule sets contain a list of analysis rules for each metaclass in the PowerDesigner
metamodel. All analysis rule set files have the same basic category structure, with a library for
each model type containing the metaclasses of that module. Clicking a metaclass displays the
rules associated with that metaclass:

CHAPTER 17: Impact and Lineage Analysis

Core Features Guide 513



The following properties are available for each analysis rule:

Property Description

E Enables the rule for use in the analysis.

Action Specifies the action performed on the metaclass that triggers the application of
the rule. Select an action from the list or enter your own (see Creating a User-
Defined Action on page 515). For lineage analysis rules, Lineage is the only
possible value.

Collection Specifies the metaclass collection whose members the rule is applied to. Col-
lections defined in extensions (see Customizing and Extending PowerDesigner >
Extension Files) are included in one of the Extended... collections.

Effect Specifies the effect on the objects in the collection caused by the action on the
metaclass. Select an action from the list or enter your own (see Creating a User-
Defined Action on page 515). For lineage analysis rules, Lineage is the only
possible value.

L Replace Link Object by Extremity - Simplifies the preview tree and the IAM
Browser and diagram by hiding the link and showing only the object at the other
end of the link.

R Recursive - Propagates the effect recursively to the dependent objects of the
objects in the collection.

The root node of each file contains the following properties:
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Property Description

Name/Code/
Comment

Identify the object. The name should clearly convey the object's purpose to non-
technical users, while the code, which is used for generating code or scripts, may
be abbreviated, and should not normally include spaces. You can optionally add a
comment to provide more detailed information about the object. By default the
code is generated from the name by applying the naming conventions specified in
the model options. To decouple name-code synchronization, click to release the =
button to the right of the Code field.

File name / Type [read-only] Specify the path to the .rul file and the type of the rule set (impact or
lineage).

Creating an Analysis Rule Set
You can create your own rule sets, which are then available from the List of Impact and
Lineage Analysis Rule Sets.

1. Select Tools > Resources > Impact and Lineage Analysis Rule Sets to open the List of
Impact and Lineage Analysis Rule Sets, which shows all the available rule sets.

2. Click the New tool, enter an appropriate name for the rule set, and select the appropriate
type of rule set.

3. Select a rule set from the Copy From list to create a new rule set that is identical to the
original set apart from the name.

4. Click OK to open a Save As dialog, enter a file name and then click OK to open the new
rule set in the Resource Editor.

Creating a User-Defined Action
You can specify a user-defined action on an object to analyze its consequences. You must
already have created the appropriate analysis rule in the Resource Editor.

In the following example, create an impact analysis rule to specify that a ModifyDataType
action on the Data Item metaclass will also change its attributes.

1. In the Resource Editor, open an impact analysis rule set (see Analysis Rule Sets on page
512).

2. Click the PdCDM library to expand its available metaclasses tree.

3. From the tree, select Data Item and create the appropriate rule by specifying the
following options:

• Action – enter ModifyDataType, which specifies the action on the data item, and
triggers the impact analysis rule. The Enable check box is automatically selected.

• Collection – select Attributes, which specifies the metaclass collection for which
you define the impact rule.

• Effect – enter ModifyDataType, which specifies the action that is propagated to
attributes.
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4. Click OK to save the rule set and close the Resource Editor.

5. Open the Action Description dialog:

• [from preview] Right-click a data item in the tree, and select Change Action
Description.

• [from the IAM] Right-click a data item in the Browser or in the diagram, and select
Change Action Description.

6. Enter ModifyDataType in the User-defined Actions field:

You can enter several actions in a single word using semicolons as separators.

7. Click OK to close the dialog box.
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The following example shows how the [ModifyDataType] action on the Employee number
data item affects its Employee number2 attribute, which in turns affects its Idtf_2 identifier:

Checking Rule Sets into the Repository
When an administrator creates or upgrades the repository, default rules sets are checked into
the Library folder at the root of the repository to enable impact and lineage analyses in the
Repository tab of the Browser. To use other rule sets to perform analyses in the repository, you
must check them in manually.

Note: If you have stored customized rule sets delivered with a previous version of
PowerDesigner in the repository, they cannot be used for repository analyses until you have
upgraded them by re-checking them into the latest version of the repository. For general
information about updating resource files, see Installation Guide > Planning Your
PowerDesigner Installation > Upgrading PowerDesigner.

1. Select Tools > Resources > Impact and Lineage Analysis Rule Sets and create your
custom rule set (see Creating an Analysis Rule Set on page 515).

2. Select the rule set in the list and click the Check In tool.

3. In the Check In Document dialog (see Check-In Parameters on page 297), select the
Folder to which you want to check in the rule set.

You can check rule sets into any folder for which you have write permission. For example,
you might want to create custom rule sets for a particular project and check them into that
project's folder.

4. Click OK to complete the check in.
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The rule set is now available for use in the repository. If you have checked your rule set into
a folder that did not previously contain rule sets, you must use the Select Path tool to make
your rule set available in the analysis dialog (see Impact and Lineage Analysis in the
Repository on page 331).

Note: All impact and lineage analyses launched from your local workspace, even those
that use the repository, are performed with your local rule sets.

Repository Rule Set Limitations
While the majority of rules are supported in analyses launched or extended into the repository,
many calculated collections and some other collections are not accessible to the repository
analysis engine. In addition, shortcuts which point to a different branched folder may not be
immediately available.

The following list indicates the main categories of collections that are not supported in the
repository:

• All collections involving symbols. For example, Symbols, Objects in Related Diagrams.
• In the EAM, calculated collections based on application link types. For example,

Implement Objects, Implemented By Objects, Produce Objects, Produced By Objects,
Use Objects, Used By Objects.

• In the EAM, the Responsible For collection, which lists the objects for which people or
organization units are responsible.

• In the OOM, calculated collections based on generalization or realization links or
navigable roles. For example, Implemented Operations, Inherited Associations, Inherited
Attributes, Inherited Operations, Navigable Associations.

• In the OOM, the Operations collection for the component metaclass.
• In the CDM, Barker notation, the SubEntities and SuperEntities collections.
• In the BPM for BPMN 2.0 the Participants collection for the choreography task metaclass.

Where one model in a branched folder contains a shortcut to a model in a different branched
folder in another part of the repository tree, the shortcut may not be followed during an
analysis if the shortcut is the first link between the models and the referencing model is
checked in before the target model. In such a situation, checking out both the model containing
the shortcut and the target model and checking them back in will enable PowerDesigner to
follow the shortcut correctly.
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PART IV

Administering PowerDesigner

The chapters in this part explain the tools available for administering the PowerDesigner
environment through the repository.

For information about creating, upgrading, and troubleshooting a repository, see Installation
Guide > Installing the Repository.
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CHAPTER 18 Controlling Repository Access

The repository administrator is responsible for controlling access to the documents stored in
the repository by creating users and groups and assigning them rights, permissions, and
profiles. The administrator may connect PowerDesigner to an LDAP server for
authentication, an SMTP server for automating notifications, and specify a policy to control
the strength and duration of passwords.

Repository rights give users access to general repository features, while permissions give
them access to particular locations in the repository. The following rights and permissions are
available:

Rights (Entire Repository) Permissions (Per Folder or Item)

• Connect - Connect to the repository.

• Freeze Versions - (see Freezing and
Unfreezing Document Versions on page
320).

• Lock Versions - (see Locking and Un-
locking Document Versions on page 321).

• Manage Branches - (see Branching
Version Trees on page 325).

• Manage Configurations - (see 

Grouping Document Versions in a Configu-
ration on page 322).

• Manage All Documents - Perform

any action on any document version. Implic-
itly includes Full permission on all repo-

sitory documents.

• Manage Users - Create, modify, and

delete repository users and groups, grant
them rights, and add them to groups.

• Manage Repository - Create, up-

grade, and delete the repository database.

• List - View the document or folder in the

browser and in search results, and open prop-
erty sheets. Without this permission, users
cannot even see the item.

• Read - Also compare documents, and check

documents out from the repository.

• Submit - Also check the document into a

changelist for review by a user with Write
permission.

• Write - Also check in (with or without a

changelist), freeze, and lock document ver-
sions.

• Full - Also manage permissions granted to

users or groups and remove locks on docu-
ments.

1. [optional] Connect the repository to an LDAP server to manage user access (see 
Connecting to an LDAP Server for User Authentication on page 524).

2. [recommended] Connect PowerDesigner to an SMTP server to enable the automatic
sending of emails for passwords, changelist submissions, and other notifications (see 
Connecting to an SMTP Server for Notifications on page 527).
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3. If some or all your users will not be managed by LDAP, specify an appropriate password
policy (see Defining a Password Policy on page 528).

4. Create high-level functional groups (see Creating Repository Groups on page 531) to
organize users by type and assign appropriate rights to them to govern general actions that
they can perform in the repository (see Granting Rights to Users and Groups on page
533).

For example:

Groups Rights

Administrators Connect, Manage All Documents, Manage Users, Manage Repository

Senior Architects Connect, Freeze Versions, Lock Versions, Manage Branches, Manage Con-
figurations

Architects Connect, Freeze Versions, Lock Versions

Business Ana-
lysts

Connect, Freeze Versions, Lock Versions

Stakeholders Connect (to provide read-only access via the PowerDesigner Portal).

Note: There is no requirement to create groups - you can assign rights and permissions to
individual users - but we recommend that in all but the smallest deployments, you do create
groups to simplify the process.

5. [optional] Use the supplied profiles or develop others and apply them to your groups as
necessary to filter the PowerDesigner interface to hide or render read-only types of
models, objects, and properties, and to specify defaults for interface elements, options and
preferences for different kinds of users (see Using Profiles to Control the PowerDesigner
Interface on page 560).

In our example, business analysts need only contribute to requirement models, enterprise
architecture models, and conceptual data models and all other types of models are hidden
from them. We could imagine dividing the Architects group into subgroups such as
enterprise architect and information architect and hiding or rendering read-only models
that do not concern them.

6. Create an appropriate folder structure in the repository (see Repository Folders on page
288) to enable you to group documents by project or in any other appropriate way, and to
simplify the granting of permissions.

In the example, the team will use the library folder to share reference models and other
documents, and to push targets, extensions, and other resource files to users (see 
Deploying an Enterprise Library on page 549). In addition, two modeling projects are
proposed, and all the documents related to them will be kept in the two top-level folders.

7. Determine your review policy either at a global or project by project level. PowerDesigner
supports the following kinds of policy:
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• Simple review - Change lists submitted by users with the Submit permission are
reviewed by a single user with the Write or Full permission.

• Peer review - Users with the Write or Full permission voluntarily submit change
lists for review.

• Direct check in - The Submit permission and change lists are not used, and users all
check in changes without review.

8. Create development groups and implement your review policies by assigning appropriate
permissions to control what actions users and groups can perform on particular repository
documents and folders such as your library, glossary model, and modeling projects.
In the example, we propose:
• A Compliance Committee who can modify the reference models and shared resource

files contained in the library and can submit changelists for inclusion in the glossary
model.

• A Terminology Committee who can modify the glossary model.
• For each project, lead architects are able to check in changes to the project (and submit

changelists for inclusion in the glossary), and regular architects can submit changelists
to the project.

• A cross-project stakeholder groups with read-only access (though we could imagine
sub-folders within each project for which these users would have write or submit
permission for storing their own documents).

Group Library Glossary
Model

Project A Project B

Administrators Full Full Full Full

Compliance
Committee

Write Submit Read Read

Terminology
Committee

Read Write Read Read

Project A Leads Submit Submit Write Read

Project A Team Read Read Submit Read

Project B Leads Submit Submit Read Write

Project B Team Read Read Read Submit

Business Stake-
holders

Read Read Read Read

9. Create as many users as necessary either manually (see Creating Repository Users on page
529) or via LDAP (see Creating Repository Users Managed by LDAP on page 530) and
assign them to appropriate groups (see Adding Users and Groups to a Group on page
532) according to their roles and project responsibilities.
There is no limit to the number of groups to which a user or group can be assigned, and
users benefit from the cumulative total of all the rights and permissions they receive. In our
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example, if a business stakeholder is also a member of the Terminology Committee group,
then she will have Write permission on the glossary model.

Connecting to an LDAP Server for User Authentication
A repository administrator can delegate the authentication of repository users to an LDAP
server. PowerDesigner supports authentication via Active Directory and a number of other
LDAP implementations. You can optionally allow automatic creation of repository accounts
when an LDAP user connects to the repository for the first time.

Note: PowerDesigner LDAP integration provides only authentication. Authorization is still
managed via the rights and permissions granted within the repository environment.

1. Connect to the repository and select Repository > Administration > LDAP Parameters
(or right-click the root node, and select Properties to open the repository property sheet,
and then click the LDAP tab).

2. Select the appropriate Server type from the list to set default values for the other
parameters.

For Active Directory, if your environment supports anonymous binding, you may be able
to connect without further configuration. Click the Test Connection button and follow the
instructions on the dialog. If your connection succeeds then consider enabling the Use
Secure Socket Layer (SSL) and Auto-create user accounts in repository options and go
directly to step 6.

3. Modify any appropriate parameters in the General group box:

Parameter Description

Server type Specifies the type of the LDAP server and sets default values for the server. The
following types are available:
• Active Directory - if your environment supports anonymous binding, you

may be able to connect without further configuration. Click the Test Con-
nection button and follow the instructions on the dialog.

• Netscape Directory Server
• OpenLDAP
• Oracle Directory Server
• Other
If you edit any parameters and want to revert to the defaults, click the Default
Settings button.
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Parameter Description

Provider URL Specifies the URL for the LDAP provider. By default, for Active Directory,
PowerDesigner will automatically detect the nearest LDAP server and use this
for authentication, initializing this field to:

LDAP://_ldap.domain:389
For other servers, this field is initialized to:

LDAP://ldap.domain:389
and you should replace ldap with the name or IP address of your LDAP
server.

Use Secure
Socket Layer
(SSL)

Instructs PowerDesigner to connect to the LDAP server using SSL, changing
the LDAP provider port to the standard secure 636. If you have deployed the
PowerDesigner Portal, you must obtain and register a certificate authority
certificate in the Java installation (see Importing an LDAPS Certificate for the
PowerDesigner Portal on page 360).

Note: In most corporate environments using Active Directory, the necessary
certificate is already registered on client machines. If this is not the case, or for
other LDAPS servers, users installing PowerDesigner will need to contact their
administrator to obtain a certificate and use \Windows\Sys-
tem32\certmgr.msc to register it. Right-click Trusted Root Certifi-
cation Authorities and select All Tasks > Import, then follow the wizard
instructions.

Default search
base

Specifies the level at which the query begins its search for users in the LDAP
tree. By default this is initialized to the domain components (DCs) of the LDAP
server. For example:

dc=sybase, dc=com
You could include the location of the User directory such as OU=Users,
dc=devpd, dc=local . If the location of the User directory is not
specified here, then you must include it in the Authentication Search Base.

Anonymous
bind

[default] Specifies that the LDAP server supports anonymous access. If you
deselect this parameter, you must specify a bind user distinguished name (DN)
and password for an account that has permissions to query the LDAP server.

Note: If the Bind user DN is in the same DN as the Authentication search base
then you can simply enter the user id for the search. Otherwise, you must enter
the full DN for that account. For example, if the Default search base is
ou=people,dc=Onebridge,dc=qa, and you have a user
cn=csitest,cn=users,dc=Onebridge,dc=qa, then the
Bind DN must be cn=csitest,cn=users,dc=One-
bridge,dc=qa.
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Parameter Description

Auto-create
user accounts in
repository

Specifies that any users corresponding to the LDAP authentication search filter
can connect to the repository, and will have an account created for them in the
repository when they do so. If you do not select this option, then an adminis-
trator must create an account for each user before they can connect.

4. Modify any appropriate parameters in the Authentication group box:

Parame-
ter

Description

Search filter Specifies the LDAP query that selects users for authentication. By default this is
initialized to (for Active Directory):

(&(objectClass=person)(userPrincipalName={uid}))
and for other servers:

(&(objectClass=person)(cn={uid}))
To determine an alternative filter, you must know the properties of the users
defined in the Active Directory, and which property (for example, name or sa-
mAccountName) is being used as the login name.

Search base Specifies the location of the User list in your LDAP server. By default this is
initialized to the same value as the Default search base. If the default search base
does not include your users you must specify an appropriate search base here.
Users may be in a common node such as cn=Users or an organization unit such
as OU=Users. To determine the correct search base, you should use an LDAP
browser to look at the full distinguished name of a user. Note that your Bind DN
may be a user in a different node in the tree than general users so it is very important
that you have the correct information for each.

Search
scope

Specifies the scope of the authentication search. You can choose between:
• subtree - [default] the search begins at the level of the Search base and also

searches any subnodes.
• onelevel - only the level specified in the the Search base is searched

Authentica-
tion method

Specifies the method to use for authentication requests. You can choose between:
• simple - [default] clear text authentication. If SSL is enabled, then the pass-

word will be encrypted.
• DIGEST-MD5 - hashed password authentication. If you select this option, you

must specify a digest format.

5. Click the Test Connection button and follow the instructions on the dialog to verify your
connection.

6. Click OK to save your changes.

If you have not selected the Auto-create user accounts in repository option, you must
create repository accounts for each user that you want to be able to connect.
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Note: Even if you select this option, we recommend that you create appropriate user
accounts in advance in order to grant appropriate rights and permissions on your various
repository folders and documents. By default, LDAP users connecting to the repository are
added to the External users and All users groups, and are limited to read access
on the repository.

Connecting to an SMTP Server for Notifications
The repository administrator can automate the sending of emails for passwords, changelist
submissions, and other notifications to users by specifying an SMTP server for
PowerDesigner to use.

If an SMTP server is not specified, the administrator must distribute passwords manually and
notifications related to change lists cannot be sent. The SMTP server can also be used to send
change notifications from the PowerDesigner Portal (see Subscribing to Change Notifications
on page 340).

1. Connect to the repository and select Repository > Administration > SMTP Parameters
(or right-click the root node, and select Properties to open the repository property sheet,
and then click the SMTP tab).

2. Enter appropriate values for each of the following settings:

Setting Description

SMTP host Specifies the host name of the SMTP server used to send mail.

SMTP port Specifies the port number of the SMTP server used to send mail.

Sender's email address Specifies the email address from which to send mails.

Use Secure Socket Layer
(SSL)

Specifies to connect to the SMTP mail server through SSL.

Server requires authentication Specifies that the SMTP server requires authentication. If you
select this option, then you must specify an SMTP account and
password, and can instruct PowerDesigner to use Secure Pass-
word Authentication (SPA).

3. Click the Test button to send a test email to the sender's email address.

4. Click OK to save your changes.
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Defining a Password Policy
The repository administrator is responsible for defining a password policy to ensure that
passwords are sufficiently secure and are changed at appropriate intervals. The password
policy governs only users who are not managed by LDAP.

1. Connect to the repository and select Repository > Administration > Password Policy (or
right-click the root node, and select Properties to open the repository property sheet, and
then click the Passwords tab).

2. Select policy settings as appropriate:

Setting Description

Password length Specifies the minimum and maximum permitted length of
passwords. This option cannot be disabled. The minimum min-
imum length for a password is 6 characters.

Password must contain Specifies that passwords must contain at least one of each of the
character types selected.

Disallow reuse of previous x
passwords

Prevents users from reusing the specified number of old pass-
words.

Enforce changing of passwords
after x days

Requires that users change their passwords after the specified
number of days.

Block inactive users after x
days without connection

Blocks users if they try to log in after the specified number of
days of inactivity.

Temporarily block users for x
minutes after y failures to log in

Blocks users for the specified number of minutes if they submit
an invalid combination of username and password the specified
number of times.

Temporary passwords issued
by an administrator are valid for
x days

Specifies the period for which temporary passwords (which are
issued when a user is created or unblocked) are valid. Users
attempting to use a temporary password after this time will be
blocked.

3. Click OK to save your changes.

Changes made to the policy take effect immediately. If your policy becomes more
restrictive, users whose passwords are no longer compliant will be instructed to change
their password when next they connect.
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Creating Repository Users
The repository administrator is responsible for creating user accounts to enable users to
connect to the repository and access the content that they need.

When you create the PowerDesigner repository, the user ADMIN is created by default, with all
available rights on everything in the repository. This user is responsible for creating other
users and groups as necessary either in the repository or through an external LDAP server (see
Connecting to an LDAP Server for User Authentication on page 524) and granting
permissions on the contents of the repository (see Granting Access Permissions on Repository
Items on page 534).

Note: The repository has separate groups and users from the DBMS.

1. Select Repository > Administration > Users to open the List of Users and click the Add
a Row tool.

2. Enter a name in the Login Name column and click the Properties button to open the
property sheet of the user.

3. If you have enabled user authentication via LDAP, select the External (managed by
LDAP) check box, and click the Check Name button to verify the login name and auto-fill
the remaining fields. Otherwise, manually enter an email address, and any other
appropriate properties.

The following properties are on the General tab:

Property Description

Login Name Specifies the name used for logging in to the repository.

External (man-
aged by LDAP)

Specifies that authentication of the user is handled by an LDAP server (see 
Connecting to an LDAP Server for User Authentication on page 524). Click the
Check Name button to verify the login name in the LDAP server and to auto-
fill the remaining fields. Selecting this check box disables the Full name and
Email fields.

Full Name Specifies the real name of the user.

Email Specifies the email address of the user. If you have specified an SMTP server
(see Connecting to an SMTP Server for Notifications on page 527) this address
will be used to send the password.

Comment Specifies any additional information about the user.
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Property Description

Status Specifies the status of the user, which can be one of:
• Active - the user can access the repository.
• Blocked - the user has violated one of the rules of the password policy (see

Defining a Password Policy on page 528), and cannot access the repository
until an administrator unblocks her account (see Unblocking Blocked
Users on page 536).

• Inactive - the user is no longer active in the repository (see Deactivating
Users on page 536) and may not connect. The user remains in the List of
Users and can be reactivated at any time.

4. If you have not enabled delivery of passwords by email (see Connecting to an SMTP
Server for Notifications on page 527), click the Reset Password button and then select the
Show checkbox to display the password and note it for transmission to the user.

5. Click the Groups tab and add the user to any appropriate groups (see Adding Users and
Groups to a Group on page 532).

By default, all users are added to the Public group, from which they inherit the Read
permission on all the contents of the repository (see Granting Access Permissions on
Repository Items on page 534).

6. Click the Rights tab and specify any appropriate rights for the user (see Granting Rights to
Users and Groups on page 533). By default, all users are granted the Connect right,
which entitles them to connect to the repository.

7. Click the Profiles tab and associate the user with appropriate object permissions, UI, and
general preferences profiles (see Applying Profiles to Users and Groups on page 566).

8. Click OK to complete the creation of the user. If an SMTP server is configured, the
password will be sent to the user at the recorded email address.

Users must log in with their temporary password before the delay specified in the
password policy (see Defining a Password Policy on page 528). When they first log in they
will be required to change the temporary password.

Creating Repository Users Managed by LDAP
If you have not selected the Auto-create user accounts in repository option, you must create
repository accounts for each user that you want to be able to connect. Even if you select this
option, we recommend that you create appropriate user accounts in advance in order to grant
appropriate rights and permissions on your various repository folders and documents.

1. Select Repository > Administration > Users to open the List of Users and click the Add
a Row tool.

2. Enter a name in the Login Name column and click the Properties button to open the
property sheet of the user.
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3. Select the External (managed by LDAP) check box, and click the Check Name button to
verify the login name and auto-fill the remaining fields, which are set, with the exception
of Comment, to read-only.

4. Click the Groups tab and add the user to any appropriate groups.

By default, all LDAP users are added to the External and Public groups, from which
they inherit the Read permission on all the contents of the repository.

5. Click the Rights tab and specify any appropriate rights for the user. By default, all users are
granted only the Connect right, which entitles them to connect to the repository.

6. Click the Profiles tab and associate the user with appropriate object permissions, UI, and
general preferences profiles.

7. Click OK to complete the creation of the user.

Creating Repository Groups
The repository administrator is responsible for creating groups of users in the repository.
Users are added to groups in order to simplify the granting of rights and permissions and the
use of profiles. You can create hierarchies of groups. For example, you could insert the
Designers, Quality Assurance, and Documentation groups into the R&D group, to which you
assign permissions to documents that all these groups must use.

When you create the PowerDesigner repository, the following groups are created by default:

• Administrators, [ADMN] - has all available rights.
• All users [PUBLIC] - has the Connect right and Read permission on the repository root

(see Granting Access Permissions on Repository Items on page 534). All users belong to
this group and can thus connect to the repository and check out any document.

• External users [EXTERNAL] - has the Connect right. Remote LDAP users (see 
Connecting to an LDAP Server for User Authentication on page 524) are automatically
added to this group when they connect for the first time.

1. Select Repository > Administration > Groups to open the List of Groups.

2. Click the Add a Row tool and enter a name for the group.

3. Click the Properties tool to open the property sheet of the new group. The following
properties are available on the General tab:
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Property Description

Name/Code/
Comment

Identify the object. The name should clearly convey the object's purpose to non-
technical users, while the code, which is used for generating code or scripts, may
be abbreviated, and should not normally include spaces. You can optionally add a
comment to provide more detailed information about the object. By default the
code is generated from the name by applying the naming conventions specified in
the model options. To decouple name-code synchronization, click to release the
= button to the right of the Code field.

4. Click the Members tab and add any appropriate users and groups to the group (see Adding
Users and Groups to a Group on page 532).

5. Click the Parent Groups tab and add the group to any appropriate groups (see Adding
Users and Groups to a Group on page 532).

6. Click the Rights tab and specify any appropriate rights for the group (see Granting Rights
to Users and Groups on page 533). By default, groups do not have any rights.

7. Click the Profiles tab and associate the group with an appropriate object permissions, UI,
and general preferences profile (see Applying Profiles to Users and Groups on page
566).

8. Click OK to complete the creation of the group.

Adding Users and Groups to a Group
You can add users and groups as members of a group from either the user or the group property
sheet.

There are three ways to add members to a group:

• To add a user to a group from the user's property sheet, select the Groups tab, which lists
the groups to which the user belongs. Click the Add Groups tool to open a list of groups,
select one or more, and then click OK to add the user to them.

Note: Click the Show All Parent Groups tool to show all the parent groups of the groups
of which the user is a member, and from which she may inherit additional rights,
permissions, and profiles.

• To add a group to a parent group from the child group's property sheet, select the Parent
Groups tab, which lists the groups to which the group belongs. Click the Add Groups tool
to open a list of groups, select one or more, and then click OK to add the group to them.

• To add a user or group to a group from the parent group's property sheet, select the
Members tab, which lists the users and groups which are members of the group. Click the
Add tool to open a dialog with lists of users and groups on sub-tabs, select one or more, and
then click OK to add them to the group.

Note: Click the Show All Children Members tool to show all the groups and users that
belong to the members of the group, and who will inherit rights, permissions, and profiles
assigned to the group.
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Deleting a Group
When you delete a group from the repository you do not delete the members (either users or
groups) of the group.

1. Select Repository > Administration > Groups to open the List of Groups.

2. Select a group in the list and click the Delete tool. The group is removed from the list,
and:

• Any document permissions granted to the group are revoked.
• Any members of the group lose whatever rights or permissions they had inherited from

the group.
• The group is removed from membership of any groups to which it belonged.

3. Click OK to close the List of Groups.

Granting Rights to Users and Groups
A new user has only the Connect right assigned by default and belongs only to the PUBLIC
group, which has no rights. In order for the user to be able to do anything, the repository
administrator must grant rights to her either directly or by adding her to other groups.

For examples of combining rights to define roles, see Chapter 18, Controlling Repository
Access on page 521.

Note: The rights a user or group receive when they become members of a group (see Adding
Users and Groups to a Group on page 532) are cumulative. For example, a user with the
Manage Branches right will not lose this right when he becomes a member of a group that
has only the Freeze Versions and Lock Versions rights.

1. Select Repository > Administration > Users (or Repository > Administration >
Groups), select the appropriate user or group in the list, and click the Properties tool.

2. Click the Rights tab and select the check boxes corresponding to the rights you want to
assign. The following rights are available:

• Connect - Connect to the repository.

• Freeze Versions - (see Freezing and Unfreezing Document Versions on page
320).

• Lock Versions - (see Locking and Unlocking Document Versions on page 321).

• Manage Branches - (see Branching Version Trees on page 325).

• Manage Configurations - (see Grouping Document Versions in a
Configuration on page 322).

• Manage All Documents - Perform any action on any document version.
Implicitly includes Full permission on all repository documents.
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• Manage Users - Create, modify, and delete repository users and groups, grant them
rights, and add them to groups.

• Manage Repository - Create, upgrade, and delete the repository database.

3. Click OK to save your changes and close the user property sheet.

Note: User rights are associated with document permissions (see Granting Access
Permissions on Repository Items on page 534) to define the actions a user can effectively
perform on a document. Some user rights are automatically implied by permissions:
• A user with the Write permission on a repository document automatically has the

Lock Versions and Freeze Versions rights for it.
• A user with the Full permission on a document can unlock or unfreeze a version he

did not lock or freeze.

Granting Access Permissions on Repository Items
The repository administrator or a user with Full permission on a document or folder can
grant permissions on it from the Permissions tab of its repository property sheet. You can
grant permissions on the repository root, folders, PowerDesigner models and model packages,
and external application files, but not on individual model diagrams or objects.

In order for a user to check documents out of and into the repository, she must have the
following permissions:

• Check out - Read permission. When you create a user, she is inserted into the Public
group, which by default is granted Read permission on the repository root.

• First check in (to create a document in the repository) or creating a folder - Write
permission on the target location (the repository root or a folder) or Submit to propose
the addition.
The user who creates a repository item has, by default, Full permission over it, though
this permission can be reduced by an administrator. Other permissions are cascaded down
from the parent folder or root, so that if another user has Write permission on the parent
folder, then he will have Write permission on the new item.

• Subsequent check ins (to update an existing document) - Read permission on the target
location and Write permission on the document (including, for PowerDesigner models,
all impacted packages).

Note: Object permissions should be viewed in conjunction with the rights granted to users or
groups (see Granting Rights to Users and Groups on page 533). For examples of granting
rights and permissions, see Chapter 18, Controlling Repository Access on page 521.

1. Right-click the item in the Repository Browser, and select Permissions to open the item's
property sheet at the Permissions tab.

Note: A PowerDesigner project (see Chapter 3, Projects and Frameworks on page 47) acts
as both a repository document and a folder. Use the project permissions to control working
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with the project file itself (project diagram and any framework or dependency matrices)
and the folder permissions to grant access to the models contained within the project, as
you would for a repository folder.

2. Click the Add tool to open a list of available users and groups, select one or more, and click
OK to add them to the list.

3. For each user or group, select the permission you want to grant in the Granted Permission
column. The following permissions are available:

• List - View the document or folder in the browser and in search results, and open
property sheets. Without this permission, users cannot even see the item.

• Read - Also compare documents, and check documents out from the repository.

• Submit - Also check the document into a changelist for review by a user with Write
permission.

• Write - Also check in (with or without a changelist), freeze, and lock document
versions.

• Full - Also manage permissions granted to users or groups and remove locks on
documents.

4. [optional] Click the Copy Permissions to All Children tool to propagate changes to the
item's children.

When you create a folder or check in a model or project, the permissions defined on its
parent are propagated to it. However, subsequent changes made to the permissions for the
parent are not applied to its children unless you click this tool. For example, if a you grant
write permissions to the Major Project folder, to the Development Team 2
group, then they will not automatically be granted write access on its contents.

5. [optional] Click the Show All Authorized Users tool to display all the users and groups
who have a permission on the item, including those inheriting permissions from groups.

Consult the read-only Effective Permission column to see the highest level of permission
that each user or group has either directly or via a group. A user who has no directly granted
permission on an item may inherit a Write permission by virtue of membership in a
group, and will appear in the list when the Show All Authorized Users tool is pressed.

Note: If you delete a group from the list while the Show All Authorized Users tool is
pressed, it and its members remain visible in the list with their granted and effective
permissions reduced to <none>, until you click Apply or OK.

6. Click OK to save your changes.

CHAPTER 18: Controlling Repository Access

Core Features Guide 535



Unblocking Blocked Users
The repository administrator or a user with the Manage Users right can unblock users blocked
for password policy violations.

1. Select Repository > Administration > Users to display the List of Users.

2. Select the user in the list and click the Properties tool to open his property sheet.

3. Click the Reset Password button.

4. If you have not enabled delivery of passwords by email (see Connecting to an SMTP
Server for Notifications on page 527), select the Show checkbox to display the password
and note it for transmission to the user.

5. Click OK to assign the temporary password to the user. If an SMTP server is configured,
the password will be sent to the user at the recorded email address.

Users must log in with their temporary password before the delay specified in the
password policy (see Defining a Password Policy on page 528). When they first log in they
will be required to change the temporary password.

Deactivating Users
The repository administrator or a user with the Manage Users right can deactivate users. An
inactive user cannot connect to the repository, but the information about his checkins and other
repository actions remains available to other users.

Warning! A user cannot deactivate himself, even if he has the Manage Users right.

1. Select Repository > Administration > Users to display the List of Users dialog.

2. Select the user in the list and then select the [D]eactivate check box.

The user remains in the list but may no longer connect to the repository. If an inactive user
is later reactivated (by deselecting [D]eactivate) he will have lost all previous rights,
permissions, and group memberships, and will begin with only the Connect right.

Auditing Repository Activities
Users with the Manage All Documents right can use the List of Activities to audit operations
performed on repository documents, analyze user behavior patterns, and highlight activity
sequences. Activities are actions that modify repository documents, such as check in,
freezing, and deleting.

1. Press Ctrl+Alt+V or select Repository > Activities to open the List of Activities:
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2. [optional] Click the Customize Columns and Filter tool to customize the list. The
following columns can be useful for monitoring repository activities:

Column Description

Activity Type Specifies the type of action performed on the document:
• Check In - see Checking Documents into the Repository on page

291.
• Change List Submission / Approval / Rejection /

Return for Revision - see Change Lists on page 303

• Freeze / Unfreeze - see Freezing and Unfreezing Document Ver-
sions on page 320.

• Lock / Unlock - see Locking and Unlocking Document Versions on
page 321.

• Version Deletion / Document Deletion - see Deleting
Documents, Document Versions, and Folders on page 334. If a version of
the document being deleted is included in a configuration (see Grouping
Document Versions in a Configuration on page 322), then though it will
no longer be available through the repository Browser, the version will not
be deleted from the configuration, and the Document Removal
action will be shown.

• Branch Creation - see Branching Version Trees on page 325.

• Integration - seeIntegrating Changes from One Branch to Another
on page 328.

• Document Move - see Moving a Document in the Repository on page
303.

• Repository Upgrade - see Installation Guide > Installing the
Repository > Upgrading the Repository.
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Column Description

Name/Code Specify the name and code of the repository document affected.

Location Specifies the repository folder in which the document is stored.

Comment Specifies the comment entered to account for the activity.

Version Specifies the document version number.

Activity Date Specifies the date when the operation was performed.

User Specifies the user who performed the operation.

3. [optional] Select an item in the list and click the Properties tool to open the property sheet
of the affected object. You can use the Versions tab of the property sheet to check out or
lock the document version.

Querying the Repository Using SQL
Administrators can run basic SQL SELECT queries against the repository through the
Execute Query window. For more complex queries, you should use your DBMS query editor.

Note: You cannot execute SQL queries when connecting to the repository via the repository
proxy.

1. Connect to the repository and then select Repository > Administration > Execute SQL
to open the Execute Query window.

2. Enter one or more SQL queries in the appropriate syntax for your DBMS in the window
and click the Execute button.

The results of your query are displayed in the Results pane.

Obtaining Emergency Access to the Repository
In the event that no administrator is able to log in to a running repository, it is possible to create
an emergency administrator account to regain access.

1. If the repository proxy is not already in use in your environment, install it on the repository
server or a nearby machine for which you are an administrator (see Installation Guide >
Installing the Repository Proxy).

2. Launch the Repository Proxy Configuration utility (pdproxyconf16.exe).

Note: On a Windows 7 machine, you must open the utility by right-clicking its icon or
menu item and selecting Run as administrator.
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3. If an instance is not already available for the repository in question, create one, specifying
the appropriate data source, user name, password, and port to connect to the repository
database.

4. Select the appropriate instance and click the Create Emergency User button to open the
Emergency Password dialog, and then select Show password to see an automatically
generated password, for use with the special _ADMIN account.

5. Within 15 minutes, open PowerDesigner and select Repository > Connect, select the
appropriate repository, enter _ADMIN as the login name and the generated password in the
Password field and click OK.

Note: If you do not access the repository within 15 minutes, you must repeat the procedure
to generate a new temporary password.

6. Reset the administrator's password or create a new administrator account as appropriate
(see Creating Repository Users on page 529).

7. Select Repository > Disconnect to disconnect the emergency user from the repository.

Note: The emergency user is deleted after disconnection.
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CHAPTER 19 Deploying an Enterprise
Glossary and Library

An administrator can deploy a glossary and a library of enterprise reference models, resource
files, and other documents, which will be pushed to and automatically updated for all users. By
default, only administrators can edit the glossary or add models to or edit the library. You can
provide access to other users using the standard repository permissions.

Deploying an Enterprise Glossary
The glossary model (GLM) helps you capture and organize the terminology to be used for
naming your model objects. An administrator deploys the glossary, and users enable it in their
models to provide autocompletion for object names and model checks to ensure compliance.
The glossary appears in the Browser Glossary tab and updates are pushed to users each time
they connect to the repository, or on demand. Only one glossary is permitted per repository.

For information about using the glossary, see The Glossary on page 36.

Creating Terms, Synonyms, and Related Terms
An administrator can define new glossary terms in the Glossary tab of the Browser.

Note: You can quickly populate the glossary by performing a mass import of terms from a
model (see Importing Terms from a Model on page 544) or a CSV or Excel file (Importing
Terms from an Excel or CSV File on page 545), or from the results of the List of
Missing Terms glossary compliance model check (see Checking Glossary Compliance
on page 142). You can also add terms in a glossary terms list (see Glossary Terms Lists on page
546).

1. Select the Glossary tab of the Browser, right-click the Glossary node, and select New >
Term.

2. Enter the Name and Code of the term, which should be approved for use in your
organization's models.

3. [optional] Enter a description of the term in the Comment field, and a Reference URL
leading to a site giving further information about the term.
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4. [optional] Click the Synonyms tab and enter one or more synonyms for the term.

Note: Synonyms are words that have a similar meaning to the term, but are not approved
for use in object names. For example, Customer may be specified as a synonym for the
approved term Client. When naming an object, if a user begins to enter a synonym, the
approved term is suggested in the autocompletion list. Modelers can use the Object name
contains synonyms of glossary terms model check to find and replace synonyms in
object names (see Checking Glossary Compliance on page 142).
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5. [optional] Click the Related Terms tab and use the Add Objects and Create an Object
tools to associate other terms with the term.

Note: Related terms are other glossary terms that are in some way associated with the
present term. For example, Bank may be entered as a related term for the term Current
Account.
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6. Click OK to save your changes and add the term to the glossary.

Importing Terms from a Model
You can import the names of objects from any kind of PowerDesigner model as terms to
quickly populate your glossary.

1. Right-click the Glossary node, and select Import from Model to open the Import Object
Names as Glossary Terms Wizard.

2. Select a model open in the workspace from which to import object names, and then click
Next.

3. Select the kind of object whose names you want to import as glossary terms and,
optionally, a property of the object to specify the category of the imported terms, and then
click Next.

4. Select the objects whose names you want to import as glossary terms, and then click
Finish.

The selected objects' names are imported as glossary terms. To import other objects' names
as glossary terms, restart the wizard.

Note: Though a repository can only contain one glossary, in multi-repository
environments or in other situations where you want to import terms from another glossary
file, right-click the Glossary node, and select Import from Another Glossary Model.
Navigate to the glossary file and click Open to open the Merge Models dialog (see 
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Merging Models on page 226), which will allow you to review and modify the proposed
changes before clicking OK to complete the import.

Importing Terms from an Excel or CSV File
You can import terms from an Excel or CSV file to quickly populate your glossary.

To simplify the import of terms from an Excel file, we recommend that you create a worksheet
called Term, with the following format:

Name Code Comment Reference
URL

Syno-
nyms

Related
Terms

Catego-
ry

Client CLIENT Specifies... www.diction-
ary.com

Customer,
User

Account,
Invoice

Sales

Supplier SUPPLI-
ER

Specifies... www.diction-
ary.com

Provider,
Seller

Account,
Invoice

Purchas-
ing

etc etc etc etc etc etc etc

Using these exact column headings allows the Excel import to automatically recognize them
as the appropriate properties. Only the Name column is required. You can enter multiple
values in a column by separating them with commas.

1. Right-click the Glossary node, and select Import from Excel File to open the Excel
Import wizard.

2. Click the Options button to open the Import Options dialog, select Auto-map columns to
properties, and click OK to return to the wizard.

3. Click the Select File button, navigate to and select the file you want to import, and click
OK to return to the wizard.

4. Click Next to begin the wizard. If you have named your columns as suggested above, the
wizard recognizes and imports the terms and all their properties without further input from
you.

Note: For detailed information about the PowerDesigner Excel Import Wizard, see 
Importing Objects from Excel Files on page 91.

Organizing Terms in Categories
You can organize terms in the glossary by placing them in categories. You can create
categories under the root or under other categories, and drag and drop terms and categories to
move them between categories.

To create a category, right-click the glossary root or a category and select New > Category, or
use the tools on the Categories tab of a category property sheet.

To add terms to a category, drag and drop them onto the category node in the Browser or use the
Add and Create tools on the Terms tab of the category property sheet.
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Warning! If you delete a category, you also delete any categories and terms that it contains.

Adding Other Views and Objects to, and Extending the Glossary
Although the Glossary's primary purpose is to manage enterprise terminology, you can also
add business rules and create reports on glossary objects. You can create lists and dependency
matrices to display the glossary terms and their relationships with other objects. You can also
extend the glossary using all the standard extension mechanisms including adding new
properties to glossary terms and creating new types of objects.

These features are available from the glossary contextual menu. Right-click the glossary and
select New >:

• Glossary Terms List - to create a terms list in the canvas (see Glossary Terms Lists on
page 546).

• Dependency Matrix - to create a dependency matrix (see Dependency Matrices on page
180).

• Business Rule - to create a business rule (see Business Rules on page 131).
• Report - to create a report on the glossary (see Chapter 12, Reports on page 363).
• List Report - to create a list report on terms or other glossary objects (see Creating a List

Report on page 370).
• Extension - to add an extension file (see Extension Files on page 275) to the glossary to

allow you to extend glossary objects or define new extended objects. You can also add
extended attributes to a glossary term, synonym, or related term directly from its property
sheet using the standard mechanism (see Adding New Properties to an Object on page
154)

Glossary Terms Lists
You can create glossary terms lists to help users browse the glossary and to simplify glossary
editing. You can create terms directly in a list and define custom filters for each list. To create a
list, right-click the Glossary node and select New > Glossary Terms List.

The following tools are available on the glossary terms list toolbar:

Tools Description

Properties [Alt+Enter] - Opens the property sheet of the selected term.

Add a Row [Ctrl+N] - Create a new term.

 Show Titles and Texts and Show Titles Only - Shows the titles and descriptions
or only the titles of all terms in the view.

Show Current Title and Text / Show Current Title Only - Toggle between
showing the title and description or only the title of the selected term.
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Tools Description

  Cut [Ctrl+X], Copy [Ctrl+C], and Paste [Ctrl+V] - Perform the standard
clipboard actions.

Delete [Ctrl+D] - Deletes the selected term.

Customize Columns and Filter - Opens a dialog to change the columns dis-
played in the list or define a filter (see Customizing Object List Columns and
Filtering Lists on page 113).

Enable/Disable Filter - Toggles the filter specified in the Customize Columns
and Filter dialog.

Find [Ctrl+F] - Opens a dialog to search for text.

Format [Ctrl+M] - Opens a dialog to specify fonts and styles.

  Bold, Italic, and Underline - Format the selected text.

  Align Left, Align Center, and Align Right - Align the selected text.

Bullets - Indent and bullet the selected text.

New Glossary Terms List - Creates a new list.

Open Glossary Terms List - Opens a dialog to select another terms list to view.

Export to Excel - Saves the list to a *.xls, *.xlsx, or *.csv format (specify the
format in the Save as type field in the Save as dialog).

Note: Right-click the glossary node in the Browser and select Model Options to set default
formats for the term names and descriptions in your glossary terms lists (see Glossary Model
Options on page 549).

Checking the Glossary
To perform a model check on the glossary, right-click the glossary root and select Check
Model. PowerDesigner provides default model checks to verify the validity of terms,
synonyms, and categories.

For detailed information about working with model checks, see Checking Models on page
137. By default, these checks are provided for glossary objects:
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Check Description and Correction

Name and code
uniqueness

Term, synonym, and category names and codes must be unique in the glossary.

• Manual correction: Modify the duplicate name/code.

• Automatic correction: Appends a number to the duplicate name/code.

Missing term def-
inition

Terms should be defined.

• Manual correction: Enter a definition in the Description field.

• Automatic correction: None.

Deploying the Glossary
Once you have created your glossary and added your terms, check it into the repository to
automatically deploy it to all users connecting to the repository.

1. Right-click the Glossary root, and select Check In to open the Check In Document dialog
(see Checking Documents into the Repository on page 291).

2. Enter an appropriate comment and click OK to complete the check in.

The glossary is now deployed to the repository and will be pushed to all users the next time
they connect.

Note: You can continue to make modifications to your local glossary model, and each time
that you check it in, your changes are pushed to users the next time they connect to the
repository.

Glossary Model Properties
The model property sheet displays information about the glossary model.

To open the glossary property sheet, double-click its entry in the Browser Glossary tab. The
General tab contains the following properties:

Property Description

Name / Code / Comment Identify the model. The name should clearly convey the model's purpose
to non-technical users, while the code, which is used for generating code
or scripts, may be abbreviated, and should not normally include spaces.
You can optionally add a comment to provide more detailed information
about the model. By default the code is auto-generated from the name by
applying the naming conventions specified in the model options. To de-
couple name-code synchronization, click to release the = button to the
right of the Code field.

Filename Specifies the location of the glossary model file.
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Property Description

Conjunctions Specifies a comma-separated list of small words that are excluded from
glossary compliance checks. For example: and, of, to, the.

Name / Code separators Specify lists of characters that indicate the end of a word in the name and
code fields to provide bounding of words for the compliance checking
and auto-completion. By default, the characters  . (space and dot) are set
as separators for the name field and _ (underscore) for the code field.

Author Specifies the author of the model. If you enter nothing, the Author field in
diagram title boxes displays the user name from the model property sheet
Version Info tab. If you enter a space, the Author field displays nothing.

Version / Repository Specify the version of the model. You can enter any value in the first field,
while the second field displays the repository version.

Glossary Model Options
You can set glossary model options by right-clicking the glossary node and selecting Model
Options.

You can set the following options on the Model Settings page:

Option Description

Name/Code case
sensitive

Specifies that the names and codes for all objects are case sensitive, allowing you
to have two objects with identical names or codes but different cases in the same
model. If you change case sensitivity during the design process, we recommend
that you check your model to verify that your model does not contain any duplicate
objects.

External Short-
cut Properties

Specifies the properties that are stored for external shortcuts to objects in other
models for display in property sheets and on symbols. By default, All properties
appear, but you can select to display only Name/Code to reduce the size of your
model.

Note: This option only controls properties of external shortcuts to models of the
same type (PDM to PDM, EAM to EAM, etc). External shortcuts to objects in
other types of model can show only the basic shortcut properties.

Click the Terms Fonts page to control the fonts and formatting used for the various types of
text in your glossary terms lists (see Glossary Terms Lists on page 546).

Deploying an Enterprise Library
An administrator or other user with Write permission on the .Library folder can check
models, resource files, and external files such as Word documents or PDFs into the library and

CHAPTER 19: Deploying an Enterprise Glossary and Library

Core Features Guide 549



have them pushed to repository users. Once one or more documents are added to the library,
users connecting to the repository are invited to check them out into the library folder in their
local workspace.

Note: For information about managing permissions, see Granting Access Permissions on
Repository Items on page 534.

1. Select a model or other type of file (such as a Word document or PDF) that you want to
deploy to all users, and connect to the repository.

Note: You cannot check projects into the library. For information about checking resource
files into the library, see Sharing Resource Files via the Library on page 551)

2. Right-click the document in the Local tab of the Browser and select Check In.

3. Select the Library folder as the destination for your check in and enter an appropriate
comment:

4. Click OK to check in the model.

The document is checked into the library in the repository:

The next time users connect to the repository (or select Repository > Synchronize
Library, they will be invited to check the model out into the library in their local
workspace (see Connecting to a Repository on page 15).

Note: Branching (see Branching Version Trees on page 325) is not supported for the
library.
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Sharing Resource Files via the Library
You can check DBMS definition files, extension files and other PowerDesigner resource files
into the library. Resource files are pushed to repository users in the same way as other
repository documents, and appear automatically in the new model dialog, resource file lists,
and anywhere in the interface where a resource file can be selected.

1. [recommended] In the repository browser, create one or more folders inside the library
folders to hold the resource files.
You could create a single folder to hold all resource files, or one folder for each type of
resource file that you want to share. PowerDesigner recursively scans all folders in the
library to populate resource file lists with shared resources.

2. Select Tools > Resources > type to open the list of resource files containing the file that
you want to share (see PowerDesigner Resource Files on page 272).

3. Select the resource file to check in from the list and click the Check In tool.

4. Select the folder inside the library into which you want to check in the file, and enter an
appropriate comment.

Note: If you check the resource into a folder outside the library and it is referenced by any
models, PowerDesigner will try to resolve the reference when these models are checked
out, but the resource will not be automatically synchronized in users' library folders and so
will not be available for selection in lists of resource files.

5. Click OK to check in the resource.

The next time users connect to the repository (or select Repository > Synchronize
Library, they will be invited to check the resource out into their local library, and it will
immediately be available for use wherever a resource file can be selected.

Note: Resource files are not displayed inside the library folder in the Local workspace
browser.

Controlling Library and Glossary Write Permissions
Since library models and other documents are intended to be a reference for users, many
administrators will want to closely control who can edit them. You control access to the
Library folder with standard repository permissions. By default, all users can see the Library
folder and have updates pushed to them as necessary, but only administrators have the right to
modify the glossary and other library models.

The following are common uses of permissions on the Library folder and individual models
within it:

• To allow a restricted group of users to modify library models - Create a Compliance
Committee or Library Administrators group with Write permission on the
Library folder. Sometimes a separate Terminology Committee or Glossary
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Administrators group is created and Write permission on the glossary model is
restricted to this subset of users.

• To allow other users to propose changes to library models via change lists - Grant them
Submit permission on the Library folder. Changes proposed are only applied to the
library models if they are approved by your administrators (see Change Lists on page
303).

• To hide library models while they are being developed - Remove the All Users group
from the permissions list of individual models until they are ready for deployment.

For detailed information about setting repository permissions, see Granting Access
Permissions on Repository Items on page 534.
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CHAPTER 20 Customizing the PowerDesigner
Interface

You can customize the New Model dialog to guide model creation through templates and use
profiles to hide types of models, objects, and object properties, and to customize menus,
commands, and preferences.

Customizing the New Model Dialog
A model category set is a PowerDesigner resource file that contains one or more categories,
which in turn contain templates to guide users through model creation in the New Model
dialog. Using categories and templates for model creation simplifies the model creation
process by preselecting appropriate targets, extensions, and diagrams, and by hiding irrelevant
choices from users.

To view the list of model category sets, select Tools > Resources > Model Category Sets. For
information about the tools available in resource file lists, see PowerDesigner Resource Files
on page 272.

You can deploy model category sets to users (see Sharing Resource Files via the Library on
page 551) to ensure that everyone on your team is creating models using the same centralized
targets and extensions checked out automatically from the repository. You can create different
category sets for different users so that, for example, data architects will have different choices
from business analysts when they open the New Model dialog.

In the following example, the Information category is selected and provides eight templates to
choose from:
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Note: You can also hide model types from certain types of users with object permission
profiles (see Controlling the Availability of Models, Objects, and Properties on page 560).

Selecting a Model Category Set to Display in the New Model Dialog
The model category set you select in the Model Creation general options will be displayed in
the New Model window.

1. Select Tools > General Options, and click the Model Creation category in the left hand
pane.
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2. Verify that the Enable categories check box is selected, and select the category set you
want to display from the Default category set list.

3. [optional] Click the Path tool to the right of this field to browse to another folder
containing model category sets or the Properties tool to open the currently-selected set in
the Resource Editor.

4. Click OK to close the General Options dialog.
The selected category set and the templates it contains will be displayed in the New Model
dialog next time you open it.

Creating a Model Category Set
You can create as many different model category sets as you need, creating different sets for
different types of users, for example.

1. Select Tools > Resources > Model Category Sets to open the List of Model Category
Sets.

2. Click the New tool to open the New Model Category Set dialog.

3. Enter a name for your model category set, and select a source to copy it from. You can
choose between:

CHAPTER 20: Customizing the PowerDesigner Interface

Core Features Guide 555



• <Default template> – creates an empty set that you complete by adding categories and
templates.

• Another model category set – makes a copy of an existing set that you can edit as
necessary.

4. Specify a name and a location to create the set and click Save.

The model category set is created and opened for review in the Resource Editor.

5. For each category that you need, right-click the root node, and select New. In the right-
hand pane, enter a name for the category and, optionally, click the Browse for icon tool to
change the default icon.

Note: You can reorder the categories if necessary by drag and drop.

6. When you have created your categories, you add templates to them by right-clicking the
category and selecting New and then one of the following:

• Model - creates a simple model template that can specify a default target, extensions,
and an empty first diagram (see Adding a Model Template to a Model Category Set on
page 557).

• Model from Template - which points to an actual model file that, in addition to
specifying a target and extensions, can contain multiple diagrams, display preferences,
general and model options, etc (see Adding a Model from Template to a Model
Category Set on page 558)

7. When you have finished creating categories and templates, click OK to close the resource
editor and click the Save tool in the List of Model Category Sets to save your edits.
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You can test your category set by selecting it in the General Options dialog (see Selecting a
Model Category Set to Display in the New Model Dialog on page 554) and selecting File >
New Model.

Adding a Model Template to a Model Category Set
Model templates are simple templates that can specify a default target, extensions, and an
empty first diagram.

1. Right-click the category to which you want to add the template, and select New >
Model.

2. On the General tab, enter a template name and select a model and diagram type.

3. [optional, for model types with targets] Specify a target (DBMS, object or process
language, etc). If you select None, then the user can select any available target language in
the New Model dialog.

4. [optional] On the Icon tab, click the Browse for icon tool to change the default template
icon.

5. [optional] On the Extensions tab, click the Select Extensions tool to attach one or more
extensions to the model (see Attaching Extensions At Model Creation Time on page 11).

6. [optional] Select the Allow additional extensions at model creation check box if you
want to allow users to attach additional extensions to those you have specified. The
Extensions button in the New Model dialog is not available if you do not select this check
box.

In the following example, the Physical Data template is specified to create a Physical Data
Model with a physical diagram, and since no DBMS is specified, the user will be able to
choose one at model creation time:
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Adding a Model from Template to a Model Category Set
Models from templates are templates that point to existing model files that, in addition to
specifying a target and extensions, can contain multiple diagrams, display preferences,
general and model options, etc.

In order to add a model from template to a category, you must have a model file that contains
all the appropriate parameters ready to point to.

1. Right-click the category to which you want to add the template, and select New > Model
from Template.

2. On the General tab, enter a template name and click the Select File tool to the right of the
Model file field to browse to and select the model file to use as the template.

3. [optional] On the Icon tab, click the Browse for icon tool to change the default template
icon.

In the following example, the Data Flow Diagram template is specified to create a
Business Process Model from an existing dfd.bpm model, and will inherit its pre-
configured options, preferences, extensions, and objects:
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Pushing Model Category Sets to Users
You can deploy your model category sets to the library to make them available to other users.

1. Select Tools > Resources > Model Category Sets to open the List of Model Category
Sets.

2. Select the category set you want to push to other users and click the Check In tool.

3. Select the folder inside the library into which you want to check in the category set, and
enter an appropriate comment.

Note: If you check the category set into a folder outside the library, it will not be available
for selection in the General Options dialog. For more information about the library, see 
Deploying an Enterprise Library on page 549.

4. Click OK to check in the category set.

The next time users connect to the repository (or select Repository > Synchronize
Library, they will be invited to check the category set out into their local library, and it will
immediately be available for selection when they click Tools > General Options, and
click the Model Creation category in the left pane.
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Using Profiles to Control the PowerDesigner Interface
An administrator can create profiles in the repository to customize and simplify the
PowerDesigner interface for users by hiding types of models, objects, and object properties,
by reconfiguring menus, toolbars, and toolboxes, and by setting appropriate defaults for
options and preferences. You can define multiple profiles to customize the interface in
different ways for different kinds of users and apply them as appropriate to individual user
accounts or to repository groups.

Three types of profiles are available to administrators to customize the PowerDesigner
interface for users:

• Object permissions profiles - to hide types of models or make them read-only, and to hide
model objects and object properties. Use these profiles to simplify the modeling
environment by presenting users with only the concepts that they need:
• Hiding a module - prevents the creation or opening of models of this type.
• Hiding an object - removes it from the Toolbox, Browser, Model menu, New

contextual menu, and property sheets.
• Hiding an attribute or collection - removes it from object symbols and property sheets.

• UI preferences profiles - to customize the commands available in menus, toolbars, and
toolboxes. Use these profiles to reorganize and simplify the PowerDesigner interface for
users. They provide the same kind of customization as users can perform using the Tools >
Customize Menus and Tools command (see Customizing Menus, Toolbars, and
Toolboxes on page 270).

• General preferences profiles - to set default display preferences and model and general
options. Use these profiles to guide users toward making appropriate option and
preference choices. They provide the same kind of customization as users can perform
using user profiles (see User Profiles on page 249).

Controlling the Availability of Models, Objects, and Properties
An administrator can define object permissions profiles to hide models, objects, and
properties, or make models available in read-only form for users or group of users. By default,
all types of models, objects, and properties are available and you hide them (or make them
read-only) by adding entries to an object permissions profile.

1. Connect to the repository and then select Repository > Administration > Object
Permission Profiles.

2. Click the Create an Object tool, enter a name for the profile, select a template to start
from, and click OK to create and open it in the Resource Editor.

3. [optional] Click the Import Items tool to import an existing profile, review the items to be
imported in the Merge dialog, and then click OK to complete the import.
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For detailed information about working with this dialog, see Merging Models on page 226.
You can repeat this step as many times as necessary to import additional profiles.

Note: PowerDesigner provides a number of example profiles, which you can combine as
necessary and edit to support your particular workflow (see Example Permission Profiles
on page 564).

4. To modify the status of model types (modules) for users associated with this profile, right-
click the root element and select Add Modules to Customize (or click the equivalent tool
in the toolbar), select the modules and click OK to add them to the profile. Then select the
appropriate status:

• Undefined - [default] The module's availability is not specified in the profile. This
status is useful when the profile will be combined with others, and these other profiles
will determine the availability of the module. The module can be customized by hiding
objects, object attributes, and collections.

• Enable - The module is available to users associated with the profile, and can be
customized by hiding objects, attributes, and collections.

• Disable (Hide) - The module and all models of this type are hidden to users associated
with the profile. No further customization is possible.

• Read-Only - The module is available to users associated with the profile, but they may
not edit models of this type. No further customization is possible.

In this example, the OOM, DMM, LDM, and PDM are added to the profile to hide them
from business users:
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5. To modify the status of object types (metaclasses) for users associated with this profile,
right-click the parent module, select Add Metaclasses to Customize (or click the
equivalent tool in the toolbar), select the metaclasses and click OK to add them to the
profile. Then select the appropriate status:

• Undefined - [default] The metaclass's availability is not specified in the profile. This
status is useful when the profile will be combined with others, and these other profiles
will determine the availability of the metaclass. The metaclass can be customized by
hiding attributes and collections.

• Enable - The metaclass is available to users associated with the profile, and can be
customized by hiding attributes and collections.

• Disable (Hide) - The metaclass and all objects of this type are hidden to users
associated with the profile. No further customization is possible.

Note: To add a metaclass defined in a DBMS, language definition, or extension file to a
permission profile, enter it by hand in the format metaclass::stereotype. For
example, to hide Sybase IQ events, enter ExtendedObject::Event, and select the
checkbox in the H column.

In this example, the Application Architecture Diagram and Service Oriented Diagram
metaclasses are added to the profile to hide them from business users:
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6. To modify the status of object properties (attributes and collections) for users associated
with this profile, right-click the parent metaclass and select Add Meta-attributes to
Customize or Add Metacollections to Customize (or click the equivalent tool in the
toolbar), select the attributes or collections and click OK to add them to the profile. Then
select the appropriate status:

• Undefined - The attribute or collection's availability is not specified in the profile.
• Enabled - The attribute or collection is available to users associated with the profile.
• Disabled (Hidden) [default] - The attribute or collection is hidden to users associated

with the profile.

Note: To add an extended attribute defined in a DBMS, language definition, or extension
file to a permission profile, enter it by hand. For example, to hide the DBSpace attribute
for Sybase IQ tables, enter DBSpace, and select the checkbox in the H column.

In this example, the entity Code attribute is added to the profile to hide it from business
users:
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Note: You can propagate customizations of properties to other metaclasses, including to
metaclasses in other types of models. Select a metaclass with customized properties and
click the Apply to All Metaclasses in This Module or Apply to All Metaclasses in All
Modules tool or right-click a meta-attribute or metacollection and select:
• Apply to All Metaclasses in This Module - to propagate its customization to all other

metaclasses that include this property in the present module. PowerDesigner will add
the minimum number of metaclasses necessary to apply the customization by
exploiting inheritance in the metamodel. This often involves adding the Named Object
and a handful of other metaclasses.

• Apply to All Metaclasses in All Modules - to propagate its customization to all other
metaclasses that include this property in all the modules that are included in the profile.
PowerDesigner will not add additional modules to the profile, so if you want to
customize the property everywhere it appears, you must first add all relevant modules.

7. Click OK to save the profile in the repository.

Example Permission Profiles
PowerDesigner provides a set of permission profiles that you can merge into your own
profiles, combining, editing, or adding to them as appropriate for your team's working
practices.

There are four kinds of example profiles available in the Install_dir/Resource
Files/Profiles directory:

• Hide Objects - Remove one or more types of objects from the Toolbox, Browser, Model
menu, New contextual menu, and property sheets:
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• Hide Objects - Business Rules
• Hide Objects - EAM Application Objects
• Hide Objects - EAM Business Objects
• Hide Objects - EAM Technology Objects
• Hide Objects - Traceability Links

• Hide Properties - remove attributes and collections from object symbols and property
sheets:
• Hide Properties - Codes for Non-Data Objects
• Hide Properties - Keywords
• Hide Properties - Mappings
• Hide Properties - Related Diagrams
• Hide Properties - Stereotype
• Hide Properties - Technical Properties

• Lock - Prevent the user from changing special model properties:
• Lock - Extensions (removes extension files from the Browser, Model menu, and New

contextual menu to prevent users changing extensions)
• Lock - Model Options (removes the Model Options command from the Tools menu to

prevent users changing model options)
• Role - Control the availability of modules for various types of users:

• Role - Developer (hides the BPM and EAM, and makes the CDM, LDM, and RQM
read-only)

• Role - Enterprise Architect (hides or makes read-only all models except the EAM)
• Role - Information Architect (hides the RQM, and makes the BPM, EAM, and OOM

read-only)
• Role - Process Architect (hides or makes read-only all models except the BPM)

Controlling Defaults for Menus, Toolbars, and Toolboxes
An administrator can define UI preferences profiles to control the default configuration of
menus, toolbars, and toolboxes for users or group of users.

1. Connect to the repository and then select Repository > Administration > UI Preference
Profiles.

2. Click the Create an Object tool, enter a name for the profile, select a template to start
from, and click OK to create and open it in the Customize Menus and Tools dialog.

3. Select and modify the menus, toolbars, and toolboxes for the appropriate views using the
various panels in the dialog (see Customizing Menus, Toolbars, and Toolboxes on page
270).

4. Click OK to save the profile in the repository.
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Controlling Defaults for Options and Preferences
An administrator can define general preferences profiles to control the default values for
display preferences, model options, general options, and other preferences for users or group
of users.

1. Connect to the repository and then select Repository > Administration > General
Preference Profiles.

These profiles are the same as those that individual users can use to customize their options
and preferences (see User Profiles on page 249).

2. Click the Add a Row tool, enter a name, and click the Properties tool, to create the profile
and open it in the resource editor.

3. Click the Create an Object tool, enter a name for the profile, and select a source from
which to copy from. You can choose between:

• Another user profile – Makes a copy of the existing profile.
• <Registry> - Copies all your PowerDesigner defaults from your Windows registry.

• <Model> - Opens the Model for User Profile dialog, which allows you to specify
preferences to copy from an open model (see Copying Preferences from a Model on
page 253).

4. Click OK to open the profile in the Resource Editor.

5. [optional] Click the Import Items tool to import an existing profile, review the items to be
imported in the Merge dialog (see Merging Models on page 226), and then click OK to
complete the import.

You can repeat this step as many times as necessary to import additional profiles.

6. Edit the profile as necessary (see Reviewing and Editing User Profiles in the Resource
Editor on page 253).

7. Click OK to save the profile in the repository.

Applying Profiles to Users and Groups
An administrator applies object permissions profiles, UI preferences profiles, and general
preferences profiles to a user or group via their repository property sheet Profiles tab.

Note: Though you can apply only one of each type of profile to each user or group, you can
apply multiple profiles to a user or group by inserting them into multiple groups or by using a
hierarchy of groups (see Adding Users and Groups to a Group on page 532).

Where a user or group is associated with multiple profiles through membership in multiple
groups, the following rules apply:

• Object Permissions Profiles - The most permissive superset of permissions is applied and
the order of group membership is unimportant. For example, if the user is associated with
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one profile which hides the EAM module and another which enables it, then it will be
visible for him.

• UI and General Preference Profiles - Preferences are applied starting from the bottom of
the list on the Groups tab and finishing with any profile applied directly to the user, with
the last applied preferences being used in the case of conflicts. In the following example,
any UI or preference profile applied to the All users group will be applied, followed by
those for the Acme Corp, Manufacturing Division, and Developers groups, and finally any
profile applied to Gemma herself:

1. Create appropriate object permission, UI preference, and general preference profiles in the
repository.

2. Select Repository > Administration > Users (or Repository > Administration >
Groups) and select the user or group to whom you want to apply the profile.

3. Click the Properties tool to open the user's property sheet, and then click the Profiles
tab.

4. Select the appropriate profile in one or more of the Object Permissions, UI Preferences,
and General Preferences fields, and click OK.
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When the user next connects to the repository, the selected profiles will be pushed to their
installation of PowerDesigner.

Note: Permissions profiles are enforced (the user cannot access types of models or objects
that are hidden from her), and the defaults specified in the UI and general preference
profiles are re-applied each time the user connects to the repository (if the Apply profiles
option is selected in the user's repository general options (see Repository Options on page
265).
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CHAPTER 21 Securing Your PowerDesigner
Environment

A typical PowerDesigner environment comprises a number of networked components that an
administrator is responsible for securing through appropriate encryption and authentication
policies.

Administrators should consider the following when planning to secure your PowerDesigner
environment:

• Encrypt communications with the repository (see Encrypting PowerDesigner Network
Communications on page 570).

• Delegate repository user authentication to an existing LDAP server (see Connecting to an
LDAP Server for User Authentication on page 524).

• Enforce security and renewal of passwords by defining an appropriate password policy
(see Defining a Password Policy on page 528).

• Control access to specific repository features through rights (see Granting Rights to Users
and Groups on page 533).

• Control access to specific repository documents through permissions (see Granting
Access Permissions on Repository Items on page 534).

• Review proposed changes to repository documents through the use of change lists (see 
Change Lists on page 303).

• Be aware of the possibility for emergency access to the repository (see Obtaining
Emergency Access to the Repository on page 538).

The following forms of monitoring are available:

• The list of repository activities (see Auditing Repository Activities on page 536).
• The repository proxy log file (see Installation Guide > Installing the Repository Proxy).
• If you are experiencing problems with memory usage or repository database performance,

contact customer support to obtain access to further debugging features.
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Encrypting PowerDesigner Network Communications
The majority of PowerDesigner Network Communications, including all those over which
sensitive information may transit can be encrypted or are encrypted by default.

The network connections shown in the diagram can be encrypted as follows:

• PowerDesigner Client to Repository - encryptable through options in the appropriate
connection profile (see Password and Data Encryption on page 573).

• PowerDesigner Client to Proxy - encrypted by default.
• PowerDesigner Client to SySAM - not encryptable.
• PowerDesigner Client and Portal Server to LDAP Server - can be encrypted by enabling

SSL (see Connecting to an LDAP Server for User Authentication on page 524).
• PowerDesigner Client and Portal Server to SMTP Server - can be encrypted by enabling

SSL (see Connecting to an SMTP Server for Notifications on page 527).
• Web Browser to Portal Server - can be encrypted by enabling SSL (seeEnabling SSL for

the PowerDesigner Portal on page 571).

The components installed to the PowerDesigner Repository Server can be installed on
separate servers, to make use of an existing database server, for instance, or to spread the
processor load to maximize performance:
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In this situation, the additional network connections can be encrypted as follows:

• Proxy Server to Repository - encryptable through options in the appropriate connection
profile (see Password and Data Encryption on page 573).

• Portal Server to Repository - encryptable through options in the appropriate connection
profile (see Password and Data Encryption on page 573).

• Portal Server to SySAM - not encryptable.

Enabling SSL for the PowerDesigner Portal
This topic provides guidance for setting up SSL security for the PowerDesigner Portal
environment. For detailed information, please see your application server’s documentation.

Using the Default Tomcat Server
You will need to edit the Tomcat server.xml file to set the keystoreFile attribute to
use the default keystore file for SSL connections and have clients connect using the default
client.keystore file.

For example, if you have installed the PowerDesigner Portal at c:\sybase\cmr:

<Connector port="8443" maxHttpHeaderSize="8192"
  maxThreads="150" minSpareThreads="25" maxSpareThreads="75"
  enableLookups="false" disableUploadTimeout="true"
  acceptCount="100" scheme="https" secure="true"
  clientAuth="false" sslProtocol="TLS"
  keystoreFile="C:\sybase\cmr\keystore\server.keystore">
</Connector>

For more information , see http://tomcat.apache.org/tomcat-5.5-doc/ssl-howto.html

Using an Existing SSL Implementation
If you deploy the PowerDesigner Portal to an existing Tomcat server running SSL, you will
need to export the certificate from your existing keystore file by using your keystore tool. If the
keystore file contains many certificates, make sure you export the certificate which the Tomcat
server uses. For example, using the JDK’s keytool:
keytool –export –alias tomcat –file 
  tomcat.cert –keystore <keystorefile>

Once the certificate is exported, you must import it to the %CMR_HOME%\keystore
\client.keystore file using the JDK’s keytool. For example:

keytool –import -alias tomcat –file tomcat.cert 
  –keystore %CMR_HOME%\keystore\client.keystore

CHAPTER 21: Securing Your PowerDesigner Environment

Core Features Guide 571

http://tomcat.apache.org/tomcat-5.5-doc/ssl-howto.html


The password to the client.keystore is changeit.

Using an Existing Client Keystore
If you already have a client keystore file to connect to the server and don’t want to use the the
supplied default client.keystore file, you can either manually edit the web-inf/config/
cmrclient.xml file or login to the PowerDesigner Portal as an administrator and change
the following parameters:
<bean class="java.lang.Object" id="cmr.client.config.ssl">
        <param name="keyStoreFile" value="client.keystore"/>
        <param name="keyStoreFilePath" value=""/>
        <param name="keystorePass" value="changeit"/>
        <param name="truststorePass" value="changeit"/>
    </bean>

Controlling SSL Encryption for the PowerDesigner Portal
All passwords saved in the repository configuration files are encrypted and are decrypted at
runtime. User passwords are encrypted when making connection to the repository.

The default keys used for the encryption and decryption process are saved in the following
file:

install_dir/keystore/common.keystore

For security purposes, we recommend that you generate your own key and keystore file. The
keystore information is saved in the following file:

install_dir/keystore/config/cmrcommon.xml

This file contains the following XML structure:

<cmrcommon>
    <!-- Keystore Configuration -->
    <bean class="java.lang.Object" id="cmr.common.config.keystore">
        <!-- if value is empty, default to cmr home\keystore folder 
-->
        <param name="keyStoreFilePath" value=""/>
        <param name="keyStoreFileName" value="common.keystore"/>
        <param name="keyStoreAlias" value="cmrenkey"/>
        <param name="keyStorePassword" value="changeit"/>
    </bean>
</cmrcommon>

You can edit the following nodes:

• keyStoreFilePath – Specifies the path to the keystore file. Default value: install_dir/
keystore/.

• keyStoreFileName – Specifies the name of the keystore file.
• keyStoreAlias – [required] Specifies the name of the alias of the key in the keystore.
• keyStorePassword – [required] Specifies the password to read the keystore.

You can use the following command to generate a 512 byte key and keystore file:
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JDK_HOME\bin\keytool -genkey -keyalg RSA -keysize 512 –alias 
keyStoreAlias -keypass keyStorePassword -keystore keyStoreFilePath
\keyStoreFileName -storepass keyStorePassword

For example: to generate a new key using the default values specified in the cmrcommon.xml
file:

JDK_HOME\bin\keytool –genkey –keyalg RSA –keysize 512 –alias 
cmrenkey –keypass changeit –keystore install_dir\keystore
\common.keystore –storepass changeit

Note: All PowerDesigner Portal web application layer installations that need to connect to a
PowerDesigner Portal Server must use the same keyStore file.

Password and Data Encryption
PowerDesigner supports encryption of both passwords and data for direct and proxy
connections to a repository and for connections to other databases using most of the supported
DBMSs via one or more of native, ODBC, and JDBC connection profiles.

The following table provides information and examples for encrypting passwords and data
with each type of connection:

Type Encryption

Native Password and data encryption can generally be enabled with connection parameters.

For example, the password for Sybase Adaptive Server Enterprise is encrypted by default,
and you can enable data encryption by setting the Sec_Confidential connection
parameter to 1.

ODBC Password and data encryption can generally be enabled in the ODBC Configuration
dialog.

For example, to encrypt the password for Sybase SQL Anywhere, select the Encrypt
password option on the Login tab, and to encrypt data, select an encryption method on
the Network tab.

JDBC It is not possible to control password and data encryption through the PowerDesigner
connection profile interface, but you may be able to enable encryption directly in your
database client.

For more information about using PowerDesigner connection profiles, see Connecting to a
Database on page 18. For detailed information about encryption and other parameters for your
database, see your DBMS documentation.
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save 43
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validate 137
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properties 82
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model generation 430
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eclipse 247
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Multi-Model Report Editor 398
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named path

create 259
namespace
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New Model dialog
customizing 264
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node (framework)
decomposed 64

note
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attach a requirement 105
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delete 124
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drag and drop 122
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object generation 430
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merge 226
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window 3
Output 268
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text editor
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format 405
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save 42
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