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SAP Mobile Platform Tutorials

SAP Mobile Platform Tutorials

The SAP® tutorials demonstrate how to develop, deploy, and test mobile business objects,
device applications, online mobile applications (native OData and REST services based), and
Hybrid App packages. You can also use the tutorials to demonstrate system functionality and
train users.

« Learn mobile business object (MBO) basics, and use this tutorial as a foundation for the
Object API application development tutorials:

o Tutorial: Mobile Business Object Development

Note: For all Object API tutorials, if you opt to use the Mobile Business Object
example project instead of performing the Mobile Business Object Tutorial, you must
deploy the mobile application project to SAP Mobile Server as a prerequisite.
» Create native Object APl mobile device applications:
o Tutorial: Android Object API Application Development
e Tutorial: BlackBerry Object APl Application Development
e Tutorial: iOS Object API Application Development
o Tutorial: Windows Object APl Application Development
o Tutorial: Windows Mobile Object API Application Development
« Create a mobile business object, then develop a hybrid app package that uses it:
o Tutorial: Hybrid App Package Development
« Create an OData mobile application with REST Services
« Tutorial: Android OData Application Development with REST Services
e Tutorial: iOS OData Application Development with REST Services
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Getting Started with SAP Mobile Platform (On-Premise)

Getting Started with SAP Mobile Platform (On-
Premise)

Install and learn about SAP Mobile Platform and its associated components.

Complete the following tasks for all tutorials, but you need to perform them only once.

Installing SAP Mobile Platform
Install SAP Mobile SDK and SAP Mobile Platform Runtime.

Before starting this tutorial, install all the requisite SAP Mobile Platform components. See the
SAP Mobile Platform documentation at At4p.//sybooks.sybase.com/sybooks/sybooks. xhtml?
[ad=1289&c=firsttab&a=0&p=categories.

o Release Bulletin
» [nstallation Guide for SAP Mobile SDK
» [nstallation Guide for Runtime

1. Install these SAP Mobile Platform Runtime components:
» Data Tier (included with single-server installation)
e SAP Mobile Server

2. Install SAP Mobile SDK, which includes:

» Development support for native Object APl and OData SDK applications, as well as
HTML5/JS Hybrid Apps.

« SAP Mobile WorkSpace, the Eclipse-based development environment for MBOs and
Hybrid Apps.

Starting SAP Mobile Platform Services

Start SAP Mobile Server, SAP Control Center, the sample database, the cache database
(CDB), and other essential services.

The way in which you start SAP Mobile Platform Services depends on the options you
selected during installation. You may need to manually start SAP Mobile Platform Services.
Select Start > (All) Programs > SAP > Mobile Platform > Start SAP Maobile Platform
Services.

The following services will be started:

e SAP Control Center <\ersion>

* SAP Mobile Platform Cache DB
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Getting Started with SAP Mobile Platform (On-Premise)

* SAP Mobile Platform SampleDB
* SAP Mobile Server

SAP Mobile Platform Services enable you to access the SAP Mabile Platform runtime
components and resources.

Note: The SAP Mobile Platform installer creates the Windows service (SAP Mabile Platform
Sample DB) that runs the sampledb server only when you install SAP Mobile Server with a
Personal or Enterprise Development license. If you installed SAP Mobile Server with an
Enterprise Server (production) license, you must create this service using the
sampledb.bat command line utility. See Create or Remove the Windows Service for
sampledb Server (sampledb) Utility in System Administration for more information about
using this command line utility.

Starting SAP Mobile WorkSpace

Start the development environment, where you can create mobile business objects (MBOs),
create connection profiles and manage SAP Mobile Server connections, develop Hybrid
Apps, and generate Object API code.

Select Start > (All) Programs > SAP > M obile Platform > Mobile Wor kSpace 2.3.

The SAP Mabile WorkSpace opens in the Mobile Development perspective. The Welcome
page displays links to the product and information.

Next
To read more about SAP Mobile WorkSpace concepts and tasks, select Help > Help
Contents.

Connecting to SAP Control Center

Open SAP Control Center to manage SAP Mobile Server and its components.

From SAP Control Center, you can:

* View servers and their status

» Start and stop a server

* View server logs

« Deploy a mobile application package

* Register application connections

e Set role mappings

« Assign/Unassign a hybrid application to a device

For information on configuring, managing, and monitoring SAP Mobile Server, click Help >
Help Contents.
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1. Select Start > (All) Programs > SAP > SAP Control Center.

Note: If SAP Control Center does not launch, make sure that the SAP Control Center
service is started in the Windows Services dialog.

2. Log in by entering the credentials set during installation.

SAP Control Center gives you access to the SAP Mobile Platform administration features
that you are authorized to use.

Learning SAP Mobile WorkSpace Basics

SAP Mobile WorkSpace features are well integrated in the Eclipse IDE. If you are unfamiliar
with Eclipse, you can quickly learn the basic layout of SAP Mobile WorkSpace and the
location of online help.

» To access the online help, select Help > Help Contents. Some documents are for SAP
Mobile WorkSpace, while others are for the Eclipse development environment.

e The Welcome page provides links to useful information to get you started.
* To close the Welcome page, click X in the upper right corner of the page.
« Reopen the Welcome page by selecting Help > Welcome.
* To learn about tasks you must perform, select the Development Processicon.

« In SAP Mobile WorkSpace, look at the area (window or view) that you will use to access,
create, define, and update mobile business objects (MBOSs).
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Window

Description

WorkSpace Navigator view

Use this view to create Mobile Application projects,
and review and modify MBO-related properties.

This view displays mobile application project fold-
ers, each of which contains all project-related re-
sources in subfolders, including MBOs, datasource
references to which the MBOs are bound, personal-
ization keys, and so on.

Enterprise Explorer view

A view that provides functionality to connect to var-
ious enterprise information systems (EIS), such as
database servers, SAP® back ends, and SAP Mobile
Server.

Mobile Application Diagram

The Mobile Application Diagram is a graphical ed-
itor where you create and define mobile business
objects.

Use the Mobile Application Diagram to create
MBOs (including attributes and operations), then
define relationships with other MBOs. You can:

« Create MBOs in the Mobile Application Dia-
gram using Palette icons and menu selections —
either bind or defer binding to a datasource,
when creating an MBO. For example, you may
want to model your MBOs before creating the
datasources to which they bind. This MBO de-
velopment method is sometimes referred to as
the top-down approach.

¢ Dragand drop items from Enterprise Explorer to
the Mobile Application Diagram to create the
MBO - quickly creates the operations and at-
tributes automatically based on the datasource
artifact being dropped on the Mobile Applica-
tion Diagram.

Each new mobile application project generates an
associated mobile application diagram.
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Window

Description

Palette

The Palette is accessed from the Mobile Application
Diagram and provides controls, such as the ability to
create MBOs, add attributes and operations, and de-
fine relationships, by dragging and dropping the
corresponding icon onto the Mobile Application Di-
agram or existing MBO.

Properties view

Select an object in the Mobile Application Diagram
to display and edit its properties in the Properties
view. While you cannot create an MBO from the
Properties view, most development and configura-
tion is performed here.

Outline view

Displays an outline of the active file and lists struc-
tural elements. The contents are editor-specific.

Problems view

Displays validation errors or warnings that you may
encounter in addition to errors in the Diagram editor
and Properties view. Follow warning and error mes-
sages to adjust MBO properties and configurations
to avoid problems, and use as a valuable source for
collecting troubleshooting information when report-
ing issues to Customer Service and Support.

Error Log view

Displays error log information. This is a valuable
source for collecting troubleshooting information.
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Developing a BlackBerry Application

Generate object API code containing mobile business object (MBO) references for the
BlackBerry platform, develop a BlackBerry device application using that code and sample
files, and test the application's functionality on a simulator.

Prerequisites

Note: This tutorial was created using SAP Mobile Platform 2.3, BlackBerry Java SDK
7.1.0.10, BlackBerry Java Plug-in (core) 2.0.0, and run on an BlackBerry SDK 9900 device
simulator. If you use a different version, some steps may vary.

1. Complete the tasks in Getting Started with Mobile Platform.
2. Either:
« create the MBO project by completing Tutorial: Mobile Business Object
Development, or
« download and deploy the MBO SMP101 example project (complete project files) from
the SAP® Community Network: Attp.//scn.sap.com/docs/DOC-88083.

Note: If you upgrade SAP Mobile SDK after completing the tutorial, you can convert the
project to the current SDK by importing the earlier project into the SAP Mobile
WorkSpace and then accepting the confirmation prompt.

3. (Optional) To use as a reference and copy source code when completing this tutorial,
download the BlackBerry SMP 101 example project (source code only) from the SAP®
Community Network: Attp.//scn.sap.com/docs/DOC-8803.

4, Download the supported versions of the BlackBerry Java Plug-in for Eclipse.

See the Supported Hardware and Software guide at http.//sybooks.sybase.com/sybooks/
sybooks.xhtml?id=1289&c=firsttab&a=0&p=categories. Select the appropriate version
of the SAP Mobile Platform document set.

Task
Create a BlackBerry native application that communicates with the mobile business objects
that are deployed to Unwired Server.

Installing the BlackBerry Java Plug-in for Eclipse

Install the supported version of BlackBerry Java Plug-in in the SAP Mobile WorkSpace
Eclipse environment.

See RIM BlackBerry Versions for Object APIin Supported Hardware and Software at http.//
sybooks.sybase.com/sybooks/sybooks.xhtml?id=1289& c=firsttab&a=0&p=categories.
Select the appropriate version of the SAP Mobile Platform document set.
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The BlackBerry Java Plug-in for Eclipse enables you to finish developing the BlackBerry
application using smartphone-specific development, debugging, and simulation tools.

1. Confirm that your system meets the requirements at Atips.//developer.blackberry.com/
Java/download/eclipse/.

2. Start SAP Mobile WorkSpace, then select Help > Install New Software.
3. In the Available Software window, click Add.

4. Inthe Add Repository dialog, enter BlackBerry Pluginforthenameandhttp://
www.blackberry.com/developers/jar/win/java for the location. Click
OK.

5. In the Available Software dialog, select BlackBerry Java Plug-in (core) and the
appropriate version of the BlackBerry Java SDK, for example, 7.1.0.10, then click
Next.

6. Review the items to be installed, then click Next again.
7. Accept the license agreements, then click Finish.

Note: If you get a security warning about the authenticity or validity of the software, click
OK.

8. When the installation completes, restart SAP Mobile WorkSpace.
9. Click Finish.

Generating Java Object API Code

Use the Generate Code wizard to generate object API code for the SMP101 mobile application
project. Code generation creates the business logic, attributes, and operations for the mobile
business objects (MBOs) in the project.

Prerequisites

In Enterprise Explorer, you must be connected to both My Sample Database and My Mobile
Server. Code generation fails if the server-side (runtime) enterprise information system (EIS)
datasources referenced by the MBOs in the project are not running and available to connect to
when you generate object API code.

Task

1. In SAP Mobile WorkSpace, open the SM P101 mobile application project.

In WorkSpace Navigator, right-click the SMP101 folder and select Open in Diagram
Editor.

2. In WorkSpace Navigator, expand SMP101. Under Generated Code add a folder named
BlackBerry.
The Generated Code directory was created automatically during the MBO tutorial.

10
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3. Right-click anywhere in the SMP101 - Mobile Application Diagram and select Generate

Code.

4. Inthe Generate Code wizard, click Next to select the default configuration and continue

without any changes.

5. In the Select Mobile Business Objects window, select the Customer MBO, then click

Next.

Ignore any warning about unresolved mobile business object dependencies. The warning
appears because you selected the customer data only.

6. In the Configure Options window, specify these values and click Finish.

Option Description
Language Select Java.
Platform Select Java ME for BlackBerry.

Mobile server

Select My Mobile Server (or the server to
which you deployed the SMP101 project, if you
used another).

Server domain

Accept default value.

Page size

Accept default value of 1024.

The page size should be larger than the sum of
all attribute lengths for any MBO that is inclu-
ded with all the MBOs selected, and must be
valid for the database. If the page size is not set,
the default page size is 4KB at runtime.

Package

Entercom.mycorp.smpl0l.bb.mbo.

Bundling groups of related types into packages
makes types easier to find and use, avoids nam-
ing conflicts, and controls access.

Project path

Enter \SMP101\Generated Code
\BlackBerry

Third-party jar file

You do not need to choose one for this tutorial.

You see a warning at the top of the page: The
dependent third-party class
'net.rim.device.api.sys-
tem.ApplicationDescriptor’
cannot be found. You can ignore this
warning; it does not affect code generation.

Tutorial: BlackBerry Object API Application Development 11
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Option Description

Generate Metadata Classes Select for this tutorial to generate metadata for
the attributes and operations of each generated
client object.

Generate JavaDoc Unselect for this tutorial.

You are not creating automatic documentation
from comments in the code.

Note: For more about the configuration options, see Developer Guide: BlackBerry Object

APl Applications.
Generate Code L= |E|M |
Configure options —

I, Thethird-party class 'net.orim.device.api.system.ApplicationDescriptor’ cannot be found

Code generation options

Language: [Java v]
Platform: [Java ME for BlackBerry v]
Mohbile server: [My Mobile Server 'l
Server demain:  default -
Page size: [1024 v]
Package: com.mycerp.smplil.bb.mbo
Destination
@ Project path: \SMP101\Generated Code\BlackkBerry
() File system path: Browse...

[7] Clean up destination before code generation

Third-party jar file:

Generate metadata classes

[TlIncluding object manager classes

[7] Generate JavaDoc

@ Next > Finish | [ Cancal
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You can ignore the error icons that appear in WorkSpace Navigator under
SMP101\Generated Code\BlackBerry\src\, and the error in the Problems
View: net cannot be resolved.

The error occurs because the package Javafile called by SMP101DB. jar isnotyetinthe
project build path. The errors resolve later, when you build the application in the
BlackBerry Java Plug-in for Eclipse.

7. Inthe Success dialog, click OK.
Inthe Generated Code directory, you see a \BlackBerry\src\ folder.

Creating the BlackBerry Project

Create a new BlackBerry project in SAP Mobile WorkSpace. Add library resources to the
project and set other application properties.

Prerequisites

To help create your project, and in a subsequent topic, build the user interface, download the
SMP101 BlackBerry Object API (2.2 SP02) example project from the SAP Community
Network (SCN) Web site at Attp.//scn.sap.com/docs/DOC-8803.

Task

1. Start SAP Mobile WorkSpace.

2. Select File> New > Project.

3. Inthe New Project window, select BlackBerry Project and click Next.
4

. Inthe Create a BlackBerry Project window, enter SMP101BlackBerry for the project
name and click Next.

Tutorial: BlackBerry Object API Application Development 13
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¢\ Mew BlackBerry Project

Create a BlackBerry Project

Create a BlackBerry project in the workspace or in an external location,

Project name:  SMP101BlackBerry
Contents

@ Create new project in workspace

() Create project from existing source

JRE

C\Users\i833885\workspaceTutorials2 3\5MP101BlackB

Browse...

@ Use a project specific JRE: BlackBerry JRE7.1.0 -

() Use default JRE (currently 'JDE1.6.0_31")

Working sets
[T Add project to working sets

The default compiler compliance level for the current workspace is 1.6, The new
project will use a project specific compiler compliance level of 1.3

Configure JREs...

Select...

@ | <Back | Net> |[ Finish

] [ Cancel

b,

5. In the Java Settings page, modify the build path to the sup _client2.jar and

UltraLiteJl12.jar files:

a) Click the Librariestab.

b) Click Add External JARs.

c) Browse to SMP HOME\MobileSDK23\ObjectAPI\BB.
d) Select the two JAR files, then click Open.

14
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Developing a BlackBerry Application

e) Click the Order and Export tab.

f) Make sure the sup_client2.jar is selected.
Selectonly sup client2.jar in this tab because it is a third-party JAR file that
does not have a cod file. You add the UltraLiteJ12.cod file in Copying SAP
Mobile Platform Files to the Sample Project.

The sup_client2.jarfileisforthe ObjectAPlclient,and UltraliteJl2.jaris
the client database library.

6. Click Next.
7. In the Templates window, accept the default BlackBerry Application and click Next.
8. In the Application Details window, enter these values and click Finish.

e Package Name — com.mycorp.smpl01.bb.app

* Application Class Name — CustomerSample

e Screen Class Name — CustomerSampleScreen

e Screen Title— SMP101 BlackBerry

UL Application =l P

Application Details =..: I |_.

Please provide details that are used to generate the application,

Package Mame: com.mycorp.smplil.bb.app
Application Class Mame: CustomnerSample
Screen Class Name: CustomerSampleScreen

Screen Title: SMP101 BlackBerry

i
'\‘?J' Mext = Einish ] [ Cancel

9. If prompted to use a different perspective, click No.

Configuring BlackBerry Application Properties

Modify the BlackBerry application description to define the general BlackBerry properties
used in an application.

1. In WorkSpace Navigator, expand the SM P101BlackBerry project.
2. Double-click the BlackBerry App Descriptor.xml file.
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3.
4,
5.

6.

Select the Application tab.

In the Title, enter SMP101 BlackBerry.

(Optional) Enter a version, vendor, and description.
You can review the other options in the Application Descriptor window, such as general
attributes, resources, and build settings of the project. For this tutorial, leave all other
settings unchanged.

82 SMP101BlackBerry &3 =0

BlackBerry Application Descriptor - Application
General Information Locale Resources

This section describes the general BlackBerry properties used in this This section describes the resources used in this application.
application. * Description is shown on Desktop Manager only.

Title: SMP101 BlackBerry Internationalized resource bundle available
Version: 100

Vendor: BlackBerry Developer

Description:

Application type: BlackBerry Application -

Application Icons
Specify icons to be used by this application.
Application argument:

i Add...
Home screen position: 0 Rollover Icon File

icon.png - res/im Add External... |
Auto-run on startup png - res/img Add External...
7 A il t Remaove

De not display the application icon on the BlackBerry home screen

Application | Build | Alternate Entry Points

Select File> Save.

Copying SAP Mobile Platform Files to the Sample Project

Copy SAP Mobile Platform BlackBerry runtime files and the object API code you generated
using the Generate Code wizard to the SMP101BlackBerry project.

1

In Windows Explorer, browse to SMP_HOME\MobileSDK23\ObjectAPI\BB.

2. CopytheUltraLiteJ12.cod file.

The client database library is required.

Paste the copied COD file into the BlackBerry Java Plug-in simulator directory, located in
SMP HOME\MobileSDK23\Eclipse\plugins
\net.rim.ejde.componentpack<version>\components\simulator.

Generate the application key file SMP . key using
BlackBerrySigningAuthorityTool 1.0.exe,and copy itto the project root
folder.

See BlackBerry Password Based Code Signing Authority at: Atp.//

supportforums.blackberry.com/t5/Java-Development/Protect-persistent-objects-from-
access-by-unauthorizedsta-p/524282.

16
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Developing a BlackBerry Application

5. In WorkSpace Navigator, select the SM P101 project and copy the com folder under
\Generated Code\BlackBerry\src.

6. InWorkSpace Navigator, go to the SMP101BlackBerry project and paste the com folder
in to the src directory. Select Yesto All to copy over existing folders.

Creating the User Interface

Copy the Java code files, which provide the functionality and layout of the user interface, from
the SMP101 BlackBerry Project example project archive to the SMP101 BlackBerry project.

1. In Windows Explorer, browse to the directory where you saved the SMP101 BlackBerry
Project example project file.
2. Copy these Java files:
* CustomerDBCallback.java—implementsthe CallbackHandler to demonstrate
how to track changed entities in the onSynchronize callback method.
e CustomerList.java — populates the customer list.
e CustomerSample.java — creates the main customer application.
* CustomerSampleScreen.java — creates the customer screen.
* ObjectAPIUtil.java-—governshow theapplication initializes and synchronizes
data in the background.
3. In WorkSpace Navigator, go to SMP101BlackBerry and expand \ src\com\mycorp
\smpl01\bb\app, then paste the copied Java files, copying over any existing files.
4. Modify the host name or IP address in the ObjectAPIUtil. java file to point to the
SAP Mobile Server.
a) In WorkSpace Navigator, expand the SM P101BlackBerry project.
b) Under the \src\com\mycorp\smpl01\bb\app folder, double-click the
ObjectAPIUtil.java file.
¢) Modify the host name or IP address, and verify the username and password are valid.
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1 —
u5. WorkSpace Navigator 23 B

P ﬁ SMP101ElackBerry -
[ = bin
[+ [ res i
4 = src
4 4= com
4 = mycorp
a f= smplll
4 = bb
4 = app
4J] CustomerDBCallback.java
[J] CustomerListjava
4] CustomerSample java
4] CustomerSampleScreen.java
4J] ObjectAPIUtil java
4 = mbo

[+ = intrnl
[J] Changeloglmpljava

m

[J] Changelogkey.java

[J] Customerjava

[J] EntityType.java

[J] KeyGenerator.java

[J] KeyGeneratorPK java

[J] KeyPackageMame.java

[J] LocalKeyGenerator,java
[J] LocalkKeyGeneratorPK java
[J] LogRecordImpl.java

[J] OfflineAuthentication.java
[J] PackageProperties.java
[J] PersonalizationParameters.java

[J] SessionPersonalization.java
[J] SMP101DB.java
=2 BlackBerry_App_Descriptoraml -
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Developing a BlackBerry Application

Creating a Launch Configuration for the Project

Create a new launch configuration for the SMP101BlackBerry project. The configuration
specifies how the application launches, and defines the target BlackBerry platform.

1

o ok~ w

In WorkSpace Navigator, right-click the SM P101BlackBerry project, and select Run As
> Run Configurations.

Select BlackBerry Simulator and the New launch configuration icon.

= —*l,
MERILEE

k3

|New launch configuratinn|
EI--- BlackEerry Simulataor

In the Projects tab, select the SMP101BlackBerry project.
In the Name field, enter SMP101BlackBerry.
In the JRE tab, select the Project JRE (BlackBerry JRE Version).

In the Simulator tab, select Launch Mobile Data System Connection Service (MDS
CS) with simulator. Then select BlackBerry-SDK - Version as the device.

Tutorial: BlackBerry Object API Application Development 19



Developing a BlackBerry Application

Run Configurations

TEX|ER-
type filter text
[@] Android Application
[@] SMP10L
J5 Android JUnit Test
BlackBerry Simulator
Mew_configuration
[E] €/C++ Application
& Eclipse Application
&4 Eclipse Data Tools
8 HTTP Preview
4] Java Applet
[3] Java Application
Ju JUnit
J5 JUnit Plug-in Test
= Launch Group
[# Operational QVT Interg
“# 05Gi Framework
= KSL

4 n 2

Filter matched 17 of 17 items

@

Create, manage, and run configurations

Mame: SMP101BlackBerry

1= Projects | =, JRE Simulator

E# Source | =] Comman

General ‘ Debugging | Memory | Networkl Ports | View | Advanced

Device:

Launch Mobile Data System Connection Service (MD5-C5) with simulator
Launch app or URL on startup:

[BlackBermy-5DK - 3300

0
PIM:
(021000004
ESM:

MEID:

[T]Enable device security

System Locale:

Keypad Locale:

[] Automatically use default values for all prompts

Specify the number of seconds to wait before the automated response is selected:

m

[ apply || Revenr |

[ B J[ close |

If you are running the BlackBerry JDE 7.0 with the BlackBerry Java Plug-in v1.5 instead
of the BlackBerry plug-in for Eclipse, you must launch the Mobile Data System (MDS)
manually for the BlackBerry simulator to run by following the sub-task below. Otherwise,
proceed to step 7.

MDS is a framework that offers security, wireless connectivity, manageability options, and
development methods. You need it to run the simulator. It is a known issue, which has been
fixed in BlackBerry JDE 7.1, that the simulator cannot launch MDS.

From a command prompt, go to <Eclipse InstallDir>\plugins
\net.rim.ejde.componentpack7.0.0 7.0.0.33\components

a)

b)

c)

\MDS.

Start MDS by entering:
start run.bat

Press any key to bypass this message.
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Developing a BlackBerry Application

ERROR: Your java version does not meet the minimum
requirement of 1.6.0 20. Press any key to continue...

MDS starts, and you can now launch the BlackBerry simulator. Leave the command
window open.

7. Inthe Network tab, verify that Disable Registration is selected. If it is not, the sample
application cannot get data from SAP Mobile Server.

8. Click Apply, then Close.

Testing the Device Application on the BlackBerry Simulator

Run the SMP101BlackBerry application on the BlackBerry simulator, and change customer
information to update the interface.

1. In WorkSpace Navigator, right-click SMP101BlackBerry and select Run As >
BlackBerry Simulator.
It may take several minutes for the BlackBerry simulator's Setup screen to appear. If this is
the first time you have run the simulator, cancel the Setup screen.
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. *i:BlackBerry

Simulated Network edge L.l

01:05

2. On the main window, click All to access the applications screen, then scroll until you see
the SMP101BlackBerry application.

22

SAP Mobile Platform



Developing a BlackBerry Application

*:BlackBerry

1 Simulated Metwork
Wed 1 Aug U‘E.DE

)4

/
)
=
) 0

3. Click SMP101 BlackBerry to launch the application.
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The application registers and synchronizes data from the server in the background.

During initialization, the system enables the operation to target change notifications using:

SynchronizationGroup
sg=SMP101DB.getSynchronizationGroup ("default") ;
sg.setEnableSIS (true) ;

sg.save () ;

After the application initializes, the device application shows the SMP101BlackBerry
application with a list of customer data. You can scroll through the customer list to see
more data, search, and make changes. The data loads from the database on demand.

When the application queries the customer list, it uses a named query findAll. If the
customer list is long, it uses a SMP101DB.executeQuery() API to get only columns that
are needed, such as (fname, Iname...), instead of the entire customer object; this results in
better performance.
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| “:*BlackBerry
Search:
al Dente
aloerto Yost

Alfred Mewman

Al fredo Margolis

4. Select the customer to update.
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“:2 BlackBerry

Update Customer
irst name: Bliberto
ast name: Yost
ompany: Custom Designs
ddress: 375 White Harse Road

ity: Spokane
Phone: 5095559276
ip: 99216

submit cancel

5. Change the first name of the customer and click submit.
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The submit button maps to the update operation of the customer mobile business object.
The synchronize operation uses SMP101DB.beginSynchronize in the background so the
user interface is not affected. When the application synchronizes, any pending operations
are uploaded to SAP Mobile Server.

Any back-end changes initiate notifications from the server. The device application uses a
ChangeLog API, specifically ObjectList changelLogs =
SMP101DB.getChangeLogs(query);, to query those managed items and update the user
interface if needed.

The customer list appears, and shows the name change you made.

6. Close the simulator to stop the SMP101BlackBerry application.
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Learn More About SAP Mobile Platform

Once you have finished, try some of the other samples or tutorials, or refer to other
development documents in the SAP Mobile Platform documentation set.

Check the Product Documentation Web site regularly for updates: Attp.//sybooks.sybase.com/
sybooks/sybooks.xhtml?id=1289&amp, c=firsttab&amp,a=0&amp,p=categories, then
navigate to the most current version.

Tutorials
Try out some of the other getting started tutorials available on the Product Documentation
Web site to get a broad view of the development tools available to you.

Example Projects

An example project contains source code for its associated tutorial. It does not contain the
completed tutorial project. Download example projects from the SAP® Community Network
(SCN) at Attp.//scn.sap.com/docs/DOC-8803.

Samples
Sample applications are fully developed, working applications that demonstrate the features
and capabilities of SAP Mobile Platform.

Check the SAP® Development Network (SDN) Web site regularly for new and updated
samples: https.//cw.san.sap.com/cw/groups/sup-apps.

Online Help
See the online help that is installed with the product, or available from the Product
Documentation Web site.

Developer Guides
Learn best practices for architecting and building device applications:

e Mobile Data Models.: Using Data Orchestration Engine — provides information about
using SAP Mobile Platform features to create DOE-based applications.

*  Mobile Data Models: Using Mobile Business Objects— provides information about
developing mobile business objects (MBOs) to fully maximize their potential.

*  SAP Mobile WorkSpace: Mobile Business Object Development — provides information
about using SAP Mobile Platform to develop MBOs and generate Object API code that
can be used to create native device applications and Hybrid Apps.

Use the appropriate API to create device applications:

»  Developer Guide: Android Object APl Applications
»  Developer Guide: BlackBerry Object APl Applications
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Learn More About SAP Mobile Platform

»  Developer Guide: iOS Object API Applications

»  Developer Guide: Windows and Windows Mobile Object API Applications
o Developer Guide: Hybrid Apps

o Developer Guide: OData SDK

»  Developer Guide: REST API Applications

Customize and automate:

o Developer Guide: SAP Mobile Server Runtime > Management APl — customize and
automate system administration features.

Javadoc and HeaderDoc are also available in the installation directory.
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