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Sybase Unwired Platform Tutorials

Sybase Unwired Platform Tutorials

The Sybase® Unwired Platform tutorials demonstrate how to develop, deploy, and test mobile
business objects, device applications, and mobile workflow packages. You can also use the
tutorials to demonstrate system functionality and train users.

Learn mobile business object (MBO) basics, and create a mobile device application:
o Tutorial: Mobile Business Object Development

Create native mobile device applications:

»  Tutorial: BlackBerry Application Development

e Tutorial: iOS Application Development

e Tutorial: Windows Mobile Application Development

Create a mobile workflow package:

o Tutorial: Mobile Workflow Package Development

The tutorials demonstrate a cross section of basic functionality, which includes creating
MBOs, and using various Sybase Unwired WorkSpace development tools, independent
development environments, and device types. Tutorial projects are available if you want the
finished tutorial without going through the steps.

Tutorial: Mobile Business Object Development
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Task Flow

Task Flow

Sybase Unwired WorkSpace Eclipse tutorials explain how to develop, deploy, and run a

mobile application.

Table 1. Eclipse tutorials

Task

Goals

Steps required to complete the
task

Getting Started

 Install all required WorkSpace
components and external re-
sources.

e Start Unwired Server.

*  Open the Mobile Development
perspective, and become famil-
iar with the views of the per-
spective and the Mobile Appli-
cation Diagram.

Installing Sybase Unwired Platform
on page 5

Starting Unwired Server on page

6

Starting Sybase Unwired Work-
Space on page 6

Connecting to Sybase Control Cen-
feron page 6

Learning the Basics on page 7

Note: These tasks are prerequisites for
all the other tutorials. You need to per-
form them only once.

Developing Data-
base Mobile Busi-
ness Objects

» Create a mobile application
project and a connection to the
database.

» Create two mobile business ob-
jects, and create a relationship
between them.

» Deploy the mobile business ob-
jects to Unwired Server.

Creating the SUP101 Mobile Appli-
cation Projecton page 11
Connecting to the Sample Database
on page 9

Creating Database Mobile Business
Objects on page 12

Creating a Relationship Between
Mobile Business Objects on page
14

Deploying the Database Mobile
Business Objects on page 17
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Getting Started

Getting Started

Install and learn about Sybase Unwired Platform and its associated components.

Complete the following tasks for all tutorials, but you need to perform them only once.

1

Installing Sybase Unwired Platform

Install Sybase Unwired Platform.

Starting Unwired Platform Services

Start Unwired Server and the sample database.
Starting Sybase Unwired WorkSpace

Start Unwired WorkSpace.

Connecting to Sybase Control Center

Open the Web-based Sybase Control Center administration console to manage Unwired
Server and its components.

Learning the Basics
Learn about Sybase Unwired WorkSpace and how to access help (optional).

Installing Sybase Unwired Platform

Install Sybase Unwired Platform.

Before starting this tutorial, be sure you have all the requisite Unwired Platform components
installed. For complete installation instructions, see:

Release Bulletin for Sybase Mobile SDK
Installation Guide for Sybase Mobile SDK
Release Bulletin for Runtime

Installation Guide for Runtime

Install Sybase Mobile SDK, which includes:

« Development support for Native Object APl applications, HTML5/JS Hybrid (Mobile
Workflow) applications, and OData SDK applications.

« Sybase Unwired WorkSpace, the Eclipse-based development environment for MBOs
and Mobile Workflows.

Install Unwired Platform Runtime:

< Data Tier (included with single-server installation)

e Unwired Server

Tutorial: Mobile Business Object Development 5
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Starting Unwired Platform Services

Start Unwired Server and the sample database.

Click Start > Programs > Sybase > Unwired Platform > Start Unwired Platform
Services.

The Unwired Server services enable you to access the Unwired Platform components and
resources.

Starting Sybase Unwired WorkSpace

Start Unwired WorkSpace.
Select Start > Programs > Sybase > Unwired Platform > Unwired Wor k Space.

The Sybase Unwired Workspace opens in the Mobile Development perspective. The
Welcome page displays links to product information, and to the product.

Next
To read more about Sybase Unwired WorkSpace concepts and tasks, select Help > Help
Contents from the main menu.

Connecting to Sybase Control Center

Open the Web-based Sybase Control Center administration console to manage Unwired
Server and its components.

From Sybase Control Center, you can:

* View servers and their status

» Start and stop a server

* View server logs

« Deploy a mobile application package
» Register devices

« Set role mappings

For information on configuring, managing, and monitoring Unwired Server, select Help >
Online Documentation.

1. Select Start > Programs > Sybase > Sybase Control Center.

Note: If the Sybase Control Center service does not open, make sure that the Sybase
Unified Agent service is started. See the /nstallation Guide for Runtime.

6 Sybase Unwired Platform



Getting Started

2. In the Sybase Control Center Authentication window, log in by entering the supAdmin
user name and the password that was specified during the Unwired Server installation.

Logging in to Sybase Control Center allows you access to Unwired Platform
administration features that you are authorized to use.

Learning the Basics

Learn about Sybase Unwired WorkSpace and how to access help (optional).

Prerequisites
Start Unwired WorkSpace.

Task

1. In the Welcome page, click any of the links to explore the Unwired WorkSpace
environment.

2. To enter the Sybase Unwired WorkSpace development environment, click Start
Development or close the Welcome tab.

The default Mobile Development perspective provides ready access to most of the tools
you need to create, update, and manage mobile business objects (MBOSs). This table
describes the main windows and views of the Mobile Development perspective. Note that
not all the views are open initially; some views become available only after you begin
developing your MBOs:

View or Window Description

WorkSpace Navigator A view of mobile application projects. Each project folder includes
resources and data source references to which the MBOs are
bound, personalization keys, and so on.

Use this view to review and modify MBO-related properties.

Enterprise Explorer A view of enterprise back-end resources, such as database servers,
SAP® servers, and Sybase Unwired Server.

Tutorial: Mobile Business Object Development 7
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View or Window

Description

Mobile Application Dia-
gram

A graphical editor for designing mobile business objects. A Mobile
Application Diagrem is associated with each project.

Use the Mobile Application Diagram to create MBOs (including
attributes and operations), then define relationships with other
MBOs. You can:

« Create MBOs in the Mobile Application Diagram using Palette
icons and menu selections. Either bind to a data source now or
or defer binding. For example, using a top-down approach, you
might model your MBOs before creating the data sources to
which they bind.

» Drag items from Enterprise Explorer and drop them onto the
Mobile Application Diagram to create the MBO — quickly
creates the operations and attributes automatically based on the
data source of the items. This is sometimes called a bottom-up
approach.

Palette

A view from which you can drag controls onto an open Mobile
Application Diagram and define their attributes, operations, and
relationships to your application.

Properties

A view that shows the properties of the object currently selected in
the Mobile Application Diagram, and lets you edit them. You can-
not create an MBO from the Properties view, but generally, most
development and configuration is performed here.

Outline

An outline of the file that is currently open in an editor, listing
structural elements. The contents are editor-specific.

Problem

A view that displays problems, errors, or warnings.

3. To access the online help, click Help > Help Contentsin the main menu bar.
4. Expand any of the documents that appear in the left pane.
Some documents are for Sybase Unwired Platform, while others are for the Eclipse

development environment.
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Developing Database Mobile Business
Objects

Create two mobile business objects, each using a database as its data source, create a
relationship between the two MBOs, and deploy them to Unwired Server.

Prerequisites
Complete the tasks in Getting Started.

Task
Develop the database mobile business objects by completing the following tasks, in order.

1. Connecting to the Sample Database
Use the default database connection profile to test and connect to the sample database.
2. Creating the SUP101 Mobile Application Project

Create a Mobile Application project to store the mobile business objects and resources you
are developing.

3. Creating Database Mobile Business Objects
Create two mobile business objects, each from a database object.
4. Creating a Relationship Between Mobile Business Objects

Create a relationship between mobile business objects to associate related data and
maintain data synchronization on the device.

5. Deploying the Database Mobile Business Objects
Deploy the project that contains the database mobile business objects to the server.

Connecting to the Sample Database

Use the default database connection profile to test and connect to the sample database.

Installing Sybase Unwired Platform also installs a sample database, sanpl edb, which you
can use to create and test mobile business objects (MBOs). A default connection profile (My
Sample Database), included with the installation, is configured to access the sampledb
database.

Sybase Unwired Platform Services can start the database automatically, depending on your
license type: Sybase Unwired Platform Development Edition normally starts the database
automatically. However, if you are running Deployment Edition, you must start the database
manually.

Tutorial: Mobile Business Object Development 9
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Sybase Unwired Platform development edition servers normally start the database
automatically. However, the Personal Edition requires you to start the database manually.

In this task you connect to the sample database using the default connection profile, after
starting the database, if necessary. This task is required for all tutorials, but you need to
perform it only once.

1. Inthe Enterprise Explorer, expand Database Connections.
2. Right-click My Sample Database and select Ping.

 If the ping fails, go the next step to correct the problem.
« If the ping succeeds, click OK and go to Step 4.

Ping confirms whether the sample profile can connect to the sample database.

3. If the ping fails, verify that Unwired Platform Services, including the Sybase Unwired
sample database, are running:

a) On your Windows desktop, open the Services window.
For example (using the the Windows XP Classic View), click Start > Settings >

Control Panel. Inthe Control Panel, double-click Administrative Tools, then double-
click Services.

Your installation options (for example, license type, whether or not you installed a
cluster, and so on) determine which Sybase services are running.
Mame 7 | Descripkion | Status | Startup Ty;l

%S‘y‘hase Urwwired CacheDB Svbase Unwired CacheDE Started  Automatic
%Sybase Urwired MessagingDE  Svbase Messaging Server Database  Started  Automatic

ase Uriwired SampleDE Svbase Urmwired SampleDE Started  Automatic
%Syhase Urwired Server Manages Svbase Unwired Platform...  Started  Automatic
%Svstem Ewent Matification Tracks system events such as Win,.,  Started  Automatic
%System Reskare Service Performs system restore functions, .. Starked  Automatic
—— ° : . - ;I_I

b) In the Services window, check the Status column of the Sybase Unwired SampleDB
service. If the status is not Started, right-click the service and select Start.
c) Go back to Step 2.

4. Right-click My Sample Database and select Connect.

In Enterprise Explorer, the Database Connections folder contains the sanpl edb database.

10
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i .
ﬁ Enterprise Explorer &4 = O

D& s | @ wed| Bla
== Database Connections
: Elﬂ My Sample Database (3L Arvyvwhere v, 12.0.1,3359)
T
(= REST Web Services
----- = SAP Servers
== Unwired Servers
- 3 My Urnwired Server
e WWeb Services

Creating the SUP101 Mobile Application Project

Create a Mobile Application project to store the mobile business objects and resources you are
developing.

Several tutorials use the SUP101 Mobile Application project to store mobile business objects.

1. Click File> New > Mobile Application Project to create the project.
2. Inthe New Mobile Application Project window, enter SUP101 as the Project Name and
click Finish.

The SUP101 project is added to the WorkSpace Navigator and opens in the Mobile
Application Diagram.

T WorkSpace Mavigataor &3 = O |||l sur1n1 - Mobile Application Diagram 23 =g
=h1= SUP101 [Wersion 1.0] IR NI SE R TR IR R I
=l |

E? Mobile Business Cbjects . -
[5_,": Data Source References -

; ™ Cache Groups

™ Personalization keys
: [ Roles .
7o Synchronization Groups -
7= Deployvment - -
[ Filkers )

------ = Generated Code -

1 | o]

3. Right-click in the Mobile Application Diagram and select Switch developer profile >
Advanced.
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Unwired WorkSpace provides two developer profiles, basic and advanced. The default
basic profile provides most of the features you need. However, the tutorial requires
additional features, like configuring code generation, that the advanced profile provides.

Creating Database Mobile Business Objects

Create two mobile business objects, each from a database object.

Prerequisites
Complete Connecting to the Sample Database on page 9 and Creating the SUP101 Mobile
Application Project on page 11.

Task

1. Open the SUP101 mobile application project if it is not already open:

In WorkSpace Navigator, right-click the SUP101 folder and select Open in Diagram
Editor.

2. In Enterprise Explorer, expand Dat abase Connecti ons/ My Sanpl e
Dat abase. If the sanpl edb database folder is not listed, right-click My Sanpl e
Dat abase and select Connect. Enter SQL as the password if prompted.

3. Expand sanpl edb\ Tabl es.
4. Drag the cust omer table from the Enterprise Explorer to the Mobile Application

Diagram.
EEnterprise Explorer &3 =08 SUPIDI—MDbiIe #pplication Diagram &3 =8
I TS [ IR SRR R S

&

E@ sampledb {3QL Anvwhere v, 12.0,1 .Eﬂ
=B sampledb ]
[:I Daka Types -

""" [ Proxy Tables
- Stored Procedures ] —»
E[:l Tahles - /

7= bonus (dba) )
-+ call_track {dba) N
- contact (dba) / - ]
B8l o stomer (dba) _
‘B department (dba)

E employes (dba) | -
1 | > 1| | >

5. In the Quick Create wizard, accept the defaults and click OK.
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4 Quick Create

Quick create a Mobile Business Object

Mobile Business Object Mame: | Luskomer

—S0L Skaternent

SELECT id, -
Frame,
Iname,
address,
ciky,
skate,
zip,

phone, o
4] b

—Generated Cperation

I hamme I Type I Definition I
v creake creake INSERT IMTO sampledb, dba. cuskaom...
[l update update UPDATE sampledb, dba.customer SE...
vl delete delete DELETE FROM sampledb.dba. cuskanm, ..

} Runtime Data Source Credential

™ Do not show this dislog again,
(7 QK | Cancel

6. Create another MBO from the sal es_or der table:

a) Drag the sal es_or der table from Enterprise Explorer to the Mobile Application
Diagram.

b) In the Quick Create wizard, accept the defaults and click OK.
The Mobile Application Diagram displays the customer and sales_order MBOs.

Tutorial: Mobile Business Object Development 13
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Eé Enterprise Explarer &3 =0 *SUP101 - Mabile Application Diagram &3 =8
ca e mdlBle | T
El+[= Database Connections =1 ;I
Eﬂ My Sample Database (SQL Anywhere -
=-E4 sampledh 3 - ibutes (9) N
(71 Data Types ~ iTRING(1S) = T
-7 Events - TRING(20) @ cust_id | INT
(2 Praxy Tables | STRING(3S) £ arder_date : DATE
[_:I---[:I Stored Procedures - {INGE(E0) & fin_code_id : STRING(Z)
= Tables - [RIMG(Z) & region ; STRING(7)
-2 bonus (dba) _ NGL1m &0 sales_rep 1 INT
= call_track {dba) - FTRING(12) @ +id : INT
= conkact fdba) N | name ; STRING(33) = Operations (3)
= customer (dba) | - £l updated)
= department (dba) ations (3) e deletef)
= employes (dba) - £¥ createl)
= fin_code (dba) ¥
: E fin_data {dba) o /,/
+-- || product {dba) m =
E sales_order _items {dba) ___d____,__—-f""f—f/
2 sales_order (dba) —— - |
] sales_regions (dba) -

- 5o activity (dba =\ - =
4| » ] | »

7. Click File> Save.

Creating a Relationship Between Mobile Business Objects

Create a relationship between mobile business objects to associate related data and maintain
data synchronization on the device.

Prerequisites
Complete Creating Database Mobile Business Objects on page 12.

Task
In this step, you create a relationship between the customer and sales_order MBOs.

1. Create a link between the two MBOs:

a) In the Palette, click Relationship.

When you hover over any part of the Mobile Application Diagram, the cursor changes
to a relationship arrow. If the cursor does not change, click Relationship again.
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*5|P101 - Mobile Application Diagram 53

I e

=0

=

Attributes (9)
) Fname : STRING{15)
&) Iname : STRIMG(20)
&) address : STRING(35)
) city 1 STRINGI20)
) state : STRINGIZ)
&) zip 1 STRING{10}
&) phane : STRING(12)
&) compary_narme | STRING{35)
&) +id  INT
Cperations (3)
28 updatel)
8 delete()
28 createl)

7]

"~ Attributes (5)
&) cust_id : INT

N &) order_date : DATE
&) fin_code_id : STRING(Z)

&) region : STRING(7}
&) sales_rep : INT
& +id : INT

| .2 Palette [

Cperations (3)
£3 update()
£ deletel)
£ created)

ol

[y 8L~

[-= Mobile Application Diagram <
E] Mobile Business Object
EIEI Local Business Object
g Relationship
Akkriboke
8 Operation

b) In the Mobile Application Diagram, drag the mouse from the customer MBO to the
sales_order MBO to draw a relationship link.

2. In the New Relationship wizard, define the relationship between the MBOs:
a) Inthe General section, accept the default settings.

b) In the Mappings section, drag the mouse to draw a line from the id attribute in the
Source Mobile Business Object to the cust_id attribute in the Target Mobile Business

Object.

Alternatively, click each attribute in turn to draw the line.

Tutorial: Mobile Business Object Development
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o3 New Relationship _ [

Create a relationship between two mobile business objects

Configure mapping For the relationship

iaeneral
Source object: |Cust0mer j Atbtribute name: |'§alesOrders
Target object: |56|es_|:|rder j Attribute name: |cust0mer
Zorniment: |
" One ko many " One to one o Marry to one
[~ composite
W Bi-directional
—Mappings
Source Mobile Busines: ] Target Maobile Busin
=l l2 Customer =l (5 Sales_order
- Aktributes E1-[) Aktributes
..... & +id[INT] 5+ id[INT]

----- &) Frame[STRING(15)]
----- &) Iname[STRIMGZ0)]
----- &) address[STRING(IS)]
----- &) city[STRING(20)]
----- &) state[STRING(Z)]
----- &) Zip[STRIMNG(10)]
----- &) phone[STRIMG{121]
----- &) company_name[STRING(35)] -

&0 cusk_jd[INT]

&) order_date[DATE]

50 fin_code_id[STRINGZ)]
5 region[STRIMNGI7)]

&) sales_rep[INT]

OO0 MO

mmmmmmmm/a

ey i I
I\\?_) Finish Zancel |

3. Click Finish to close the New Relationship wizard.
In the Mobile Application Diagram, a connection arrow links the customer and
sales_order MBOs.
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[5] #5UP101 - Mobile Application Diagram &2 =B
R T T e p
=
- =
. Atkributes (9) E
- | @ fname : STRING(15) "~ Attributes (6)
- &) Iname : STRING{Z20) & cust_id 1 INT
|| @ address : STRING(3S) < ) order_date  DATE
- &) ity §TRING(20} > £ fin_code_id : STRINGIZ)
% sFatES};Iﬁéﬂsféjz) ) reqion : STRING(7)
; zZip : &) sales_rep : INT
-| | @ phone : STRING(12) @ +id: INT
- & cumpanv_name ! STRIMG(3S) Cperations (31
. & +id: INT £% updater)
r:: ; Operations (3) e delete()
& s Fomn
- 5 created)

Select File> Save.

Deploying the Database Mobile Business Objects

Deploy the project that contains the database mobile business objects to the server.

Prerequisites

Getting Started on page 5
Creating Database Mobile Business Objects on page 12

Task

Right-click in the SUP101 Mobile Application Diagram and select Deploy Project.

In the Deploy Mobile Application Project wizard, accept the defaults (including
Replication-based), and click Next.

In the Contents page, select the Customer and Sales_order MBOs and click Next.
In the Package Jars page, click Next.

In the Target Server page, select My Unwired Server from the list of available servers,
then click Connect. Accept the default Domain and Security configuration settings, and
click Next.

If you have multiple server connections, the Server Connection Mapping page opens.
Choose a server connection:

« If the runtime database connection is on your local machine, select sampledb.

Tutorial:

Mobile Business Object Development 17



Developing Database Mobile Business Objects

< |If the runtime database connection is on a remote machine, select New Server
Connection, which allows you to create a connection from an existing template.

Zonnection profile | Server connection ~
&y sample Database sampledb -
default
monitardb
<Mew Server Conneckion ... =
| ] i
7. Click Next.

8. In the Save as a Deployment Profile, accept the default settings and click Finish to close

the Deploy Mobile Application Project wizard.
The Executing Deployment window closes when the deployment finishes.

9.

In the Deployment Status window, click OK.

10. In the Enterprise Explorer, you can see the deployed project in Unwired Servers >

Domains > default > Packages > SUP101:1.0. The two MBOs you deployed are in the
Mobi | e Busi ness Obj ect s subfolder.

i'r = ™
ﬁ Enterprise Explorer &4 B

2 || @ | B &~
F-[= Database Conneckions
: Elﬂ My Sarmple Database (30L Arywhere v, 12.0.1,3389)
. -4 sampledh
[ REST Web Services

L= SAP Servers
== Unwired Servers
: Elgf My Urnwired Server (Unwired Server v, 2,1.0,149)
IEI[:I Domains
Y default
EI[:I Packages
E Elﬁ-il;. supl0lil.o
-] Mobile Business Objects
: [:I Personalization Keys
: H-] Security Configurations
- whorkflows

18
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The MBOs are now available for access by device applications or for deploying in a
production environment. You will use this project in other Getting Started'tutorials.

Tutorial: Mobile Business Object Development 19
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Learn More about Sybase Unwired Platform

Once you have finished, try some of the other samples or tutorials, or refer to other
development documents in the Sybase Unwired Platform documentation set.

Check the Sybase Product Documentation Web site regularly for updates: access Attp.//
sybooks.sybase.com/nav/summary.do?prod=1289, then navigate to the most current version.

Tutorials
Try out some of the other getting started tutorials available on Product Documentation to get a
broad view of the development tools available to you.

Tutorial Projects

Tutorial projects are available for download, if you want the finished tutorial without going
through the steps. Download tutorial projects from: Attp.//www.sdn.sap.com/irj/sdn/mobile?
rid=/webcontent/uuid/40ea4956-b95¢-2e10-11b3-e68¢c73b2280e.

Samples
Sample applications are fully developed, working applications that demonstrate the features
and capabilities of Sybase Unwired Platform.

Check the SAP Development Network (SDN) Web site regularly for new and updated
samples: https.//cw.san.sap.com/cw/groups/sup-apps.

Online Help
See the online help that is installed with the product, or the Product Documentation Web site.

Developer Guides
Learn about using the API to create device applications:

»  Developer Guide: BlackBerry Native Applications

»  Developer Guide: iOS Native Applications

o Developer Guide: Windows and Windows Mobile Native Applications
o Developer Guide: Mobile Workflow Packages

Customize and automate:

»  Developer Guide for Unwired Server Management APl — customize and automate system
administration features.

»  Developer Guide: Unwired Server— customize and automate server-side implementations
for device applications, and administration, such as data handling.

Javadoc and HeaderDoc are also available in the installation directory.

Tutorial: Mobile Business Object Development 21
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