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Sybase Unwired Platform Tutorials

The Sybase® Unwired Platform tutorials demonstrate how to develop, deploy, and test mobile
business objects, device applications, and mobile workflow packages. You can also use the
tutorials to demonstrate system functionality and train users.

• Learn mobile business object (MBO) basics, and create a mobile device application:
• Tutorial: Mobile Business Object Development

• Create native mobile device applications:
• Tutorial: BlackBerry Application Development
• Tutorial: iOS Application Development

• Create a mobile workflow package:
• Tutorial: Mobile Workflow Package Development

The tutorials demonstrate a cross section of basic functionality, which includes creating
MBOs that can be used in replication-based or message-based synchronization; and using
various Sybase Unwired WorkSpace development tools, independent development
environments, and device types.

Table 1. Tutorial summary

Tutorials Mobile
business
objects
(MBOs)

Synchroni-
zation types

Development
tools

Device
types

Tutorial: Mobile Business Ob-
ject Development

Create new
MBOs

Replication-
based

Sybase Unwired
WorkSpace

N/A

Tutorial: BlackBerry Applica-
tion Development

Create new
MBOs

Replication-
based

Sybase Unwired
WorkSpace

BlackBerry

Tutorial: iOS Application De-
velopment

Create new
MBOs

Message-based Sybase Unwired
WorkSpace

iPhone

Tutorial: Mobile Workflow
Package Development

Create new
MBOs

Message-based Mobile Workflow
Forms Editor

Windows
Mobile

iPhone

Sybase Unwired Platform Tutorials
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Task Flow

Use this tutorial to develop two Mobile Business Objects with a relationship in Sybase
Unwired WorkSpace. This tutorial is a pre-requisite for other Sybase Unwired Platform
tutorials.

Table 2. Eclipse tutorials

Task Goals Steps required to complete the
task

Getting Started • Install all required WorkSpace
components and external re-
sources.

• Start Unwired Server.

• Open the Mobile Development
perspective, and become famil-
iar with the views of the per-
spective and the Mobile Appli-
cation Diagram.

• Installing Sybase Unwired Platform
on page 5

• Starting Unwired Server on page
5

• Starting Sybase Unwired Work-
Space on page 6

• Learning the Basics on page 7

Note: These tasks are prerequisites for
all the other tutorials. You need to per-
form them only once.

Developing Data-
base Mobile Busi-
ness Objects

• Create a mobile application
project and a connection to the
database.

• Create two mobile business ob-
jects, and create a relationship
between them.

• Deploy the mobile business ob-
jects to Unwired Server.

• Creating the SUP101 Mobile Appli-
cation Project on page 11

• Creating the sampledb Connection
Profile on page 13

• Creating Database Mobile Business
Objects on page 16

• Creating a Relationship Between
Mobile Business Objects on page
19

• Deploying the Database Mobile
Business Objects on page 22

Task Flow
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Getting Started

Goal: Install and learn about Sybase Unwired Platform and its associated components.

The following tasks are required, unless otherwise noted, for all tutorials, but you need to
perform them only once.

1. Installing Sybase Unwired Platform on page 5

2. Starting Unwired Platform Services on page 5

3. Starting Sybase Unwired WorkSpace on page 6

4. Connecting to Sybase Control Center on page 6

5. (optional) Learning the Basics on page 7

Installing Sybase Unwired Platform
Goal: Install Sybase Unwired Platform.

Install these Sybase Unwired Platform components:

• Data Tier
• Unwired Server
• Unwired WorkSpace

If Unwired Platform is already installed and any of these components are missing:

1. Start the Sybase Unwired Platform installer.
2. Follow the instructions in the installation wizard.
3. Select the required components, and complete the installation.

For complete installation instructions, see the Sybase Unwired Platform Installation Guide
and Release Bulletin.

Starting Unwired Platform Services
Goal: Start Unwired Server and the sample database.

Select Start > Programs > Sybase > Unwired Platform  > Start Unwired Platform
Services.

Getting Started
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Starting Sybase Unwired WorkSpace
Goal: Start Unwired WorkSpace.

1. Select Start > Programs > Sybase > Unwired Platform > Unwired WorkSpace.

The Welcome page displays links to product information, and to the product.

2. To read more about Sybase Unwired WorkSpace concepts and tasks, select Help > Help
Contents from the main menu.

Connecting to Sybase Control Center
Goal: Open the Web-based Sybase Control Center administration console to manage
Unwired Server and its components.

From Sybase Control Center, you can:

• View servers and their status
• Start and stop a server
• View server logs
• Deploy a mobile application package
• Register devices
• Set role mappings

For information on configuring, managing, and monitoring Unwired Server, select Help >
Online Documentation.

1. Select Start > Programs > Sybase > Sybase Control Center.

Note: If Sybase Control Center does not launch, make sure that the Sybase Unified Agent
service is started. See the Installation Guide for details.

2. Log in using the default login:

• User name – supAdmin

• Password – s3pAdmin

Logging in to Sybase Control Center allows you access to Unwired Platform
administration features that you are authorized to use.

Getting Started
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Learning the Basics
Goal: Learn about Sybase Unwired WorkSpace and how to access help.

Prerequisites
Start Unwired WorkSpace.

Task

1. From the Welcome page, select any of the links to familiarize yourself with the Unwired
WorkSpace environment.

To close this page, click the X. You can reopen this page by selecting Help > Welcome.

2. Select Start Development  to access the Sybase Unwired WorkSpace development
environment.

Look at the area (window or view) that you will be working in to access, create, define, and
update mobile business objects (MBOs).

View Description

WorkSpace Navigator This view displays mobile application project fold-
ers, each of which contains all project-related re-
sources in subfolders, including MBOs, data source
references to which the MBOs are bound, personal-
ization keys, and so on.

Use this view to review and modify MBO-related
properties.

Enterprise Explorer A window that provides functionality to connect to
various enterprise back-end systems; for example,
database servers, SAP® servers, and Sybase Un-
wired Server.

Getting Started
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View Description

Mobile Application Diagram A graphical editor where you create and define mo-
bile business objects.

Use the Mobile Application Diagram to create
MBOs (including attributes and operations), then
define relationships with other MBOs. You can:

• Create MBOs in the Mobile Application Dia-
gram using Palette icons and menu selections –
either bind or defer binding to a data source,
when creating an MBO. For example, you may
want to model your MBOs before creating the
data sources to which they bind. This is some-
times called the top-down approach.

• Drag items from Enterprise Explorer and drop
them onto the Mobile Application Diagram to
create the MBO – quickly creates the operations
and attributes automatically based on the data
source being dropped on the Mobile Application
Diagram. This is sometimes called the bottom-
up approach.

Each new mobile application project generates an
associated Mobile Application Diagram.

Palette Access the Palette from the Mobile Application Di-
agram. It provides controls, such as the ability to
create MBOs, add attributes and operations, and de-
fine relationships, by dragging and dropping the
corresponding icon onto the Mobile Application Di-
agram or existing MBO.

Properties view Select an object in the Mobile Application Diagram
to display and edit its properties in the Properties
view. You cannot create an MBO from the Properties
view, but generally, most development and configu-
ration is performed here.

Outline view Displays an outline of the file that is currently open in
the editor area, and lists structural elements. The
contents are editor-specific.

Problem view Displays problems, errors, or warnings that you may
encounter.

3. To access the online help, select Help  > Help Contents from the main menu bar.

Getting Started
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4. Expand any of the documents that appear in the left pane.

Some documents are for Sybase Unwired Platform, while others are for the Eclipse
development environment.

Getting Started
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Developing Database Mobile Business
Objects

Goal: Create two mobile business objects, each using a database as its data source; create a
relationship between the two, and deploy them to Unwired Server.

Prerequisites

Complete Getting Started on page 5.

Task

Develop the database mobile business objects by completing the following tutorials, in order.

1. Creating the SUP101 Mobile Application Project on page 11

2. Creating the sampledb Connection Profile on page 13

3. Creating Database Mobile Business Objects on page 16

4. Creating a Relationship Between Mobile Business Objects on page 19

5. Deploying the Database Mobile Business Objects on page 22

Creating the SUP101 Mobile Application Project
Goal: Create a Mobile Application project to store the mobile business objects and resources
you are developing.

Several tutorials use the SUP101 Mobile Application project to store mobile business objects.

1. Select File > New > Mobile Application Project to create the project. If you do not find
the Mobile Application Project, then select: File >New >Other >Sybase >Mobile
Development >Mobile Application Project.

2. The New Mobile Application Project wizard appears. For Project Name, enter SUP101
and click Finish.
The project appears in the WorkSpace Navigator and the Mobile Application Diagram
opens.

Developing Database Mobile Business Objects

Tutorial: Mobile Business Object Development    11



3. Right-click in the Mobile Application Diagram Panel and select Switch developer profile
> Advanced.

Unwired WorkSpace provides two developer profiles (basic and advanced). You should be
able to complete the tutorial using the basic profile. However, as you explore Unwired
WorkSpace features you may want to work in the Advanced profile.

Developing Database Mobile Business Objects
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Creating the sampledb Connection Profile
Goal: Create a database connection profile and test the sample database connection.

Installing Sybase Unwired Platform also installs a sample database sampledb, which you
can use to create and test mobile business objects (MBOs). Starting Sybase Unwired Platform
Services automatically starts the database, depending on your license type. A default
connection profile (My Sample Database) is included with the installation, and provides
access to the sampledb database. This tutorial shows you how to create and use a new
connection profile named sampledb.

This task is required for all tutorials, but you need to perform it only once. If the sampledb
connection profile already exists, you do need not perform this task.

1. From the Enterprise Explorer, right-click the Database Connections folder and select
New to open the Wizard Selection Page.

2. Select Sybase ASA, enter sampledb as the name, and click Next.

3. Select Sybase ASA v11.x for Unwired Server Default as the driver and keep the default
settings, including dba as the User name and SQL as the Password. Select Save
Password.

Developing Database Mobile Business Objects
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4. Click Test Connection.

If Test Connection fails, verify Unwired Platform Services, including the sampledb
database, are running.

a) Select the Windows Start > Settings > Control Panel menu.
b) Select Administrative Tools, then select Services.
c) Depending on your installation options (for example, license type, whether or not you

installed a cluster, and so on) determines which Sybase services are running.

Developing Database Mobile Business Objects
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Note: If the sampledb database is not running, you can install and start it from the
command line. To install it, use the command sampledb install auto/manual. For
example:
C:\Sybase\UnwiredPlatform\Servers\UnwiredServer\bin> sampledb 
install auto

To start it from the command line, run the command sampledb start. For example:
C:\Sybase\UnwiredPlatform\Servers\UnwiredServer\bin> sampledb 
start

5. In the Ping Succeeded message, click OK.

6. Click Finish.

View the sampledb connection profile from Enterprise Explorer by expanding the Database
Connections folder.

Developing Database Mobile Business Objects
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Creating Database Mobile Business Objects
Goal: Create two mobile business objects, each from a database object.

Prerequisites

Complete Creating the sampledb Connection Profile on page 13and Creating the SUP101
Mobile Application Project on page 11.

Task

1. Open the SUP101 mobile application project if it is not already open:

In WorkSpace Navigator, right-click on the SUP101 folder and select Open in Diagram
Editor.

2. In the Enterprise Explorer, expand the Database folder, right-click sampledb, and select
Connect, if not already connected. Enter SQL as the password if prompted.

3. Expand the sampledb database, then expand the Tables folder.

4. Select the customer table, while holding the mouse button drag the customer table onto the
Mobile Application Diagram.

Developing Database Mobile Business Objects
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The Quick Create wizard launches.

5. In the Quick Create wizard, accept the defaults and click OK.

Developing Database Mobile Business Objects
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6. Create another MBO from the sales_order table:

a) Drag the sales_order table from Enterprise Explorer, and drop it onto the Mobile
Application Diagram.

b) In the Quick Create wizard, accept the defaults and click OK.

The customer and sales_order MBOs display on the Mobile Application Diagram.

Developing Database Mobile Business Objects
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7. Select File > Save.

Creating a Relationship Between Mobile Business Objects
Goal: Create a relationship between mobile business objects to associate related data and
maintain data synchronization on the device.

Prerequisites

Complete Creating Database Mobile Business Objects on page 16.

Task

In this tutorial, you create a relationship between the customer and sales_order mobile
business objects (MBO).

1. In the Palette, click Relationship.

Developing Database Mobile Business Objects
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2. Select the customer MBO and, keeping the mouse button pressed, drag the Relationship
link to the sales_order  MBO to establish the relationship link.

The Relationship Creation wizard opens.

3. Accept the General default settings. In the Mappings section, select the id attribute in the
Source object pane and cust_id in the Target object pane, or drag id from the Source
Object to cust_id in the Target Object.

Developing Database Mobile Business Objects
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A line connects the two attributes.

4. Click Finish.

The mobile application diagram now shows the link from the customer MBO to the
sales_order MBO.

Developing Database Mobile Business Objects
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5. Select File > Save.

Deploying the Database Mobile Business Objects
Goal: Deploy the project that contains the database mobile business objects to the server.

Prerequisites

• Getting Started on page 5
• Creating Database Mobile Business Objects on page 16

Task

1. Right-click in the SUP101 Mobile Application Diagram , and select Deploy Project.
The Deploy Mobile Application Project wizard appears.

Developing Database Mobile Business Objects
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2. Accept the defaults (including Replication-based), and click Next.
The Contents page appears.

3. Select the customer and sales_order MBOs and click Next.
The Package Jars page appears.

4. Click Next.
The Target Server page appears.

5. Select My Unwired Server from the list of available servers, then select Refreshor
Connect.

Accept the default Domain and Security configuration settings, and click Next.

6. If you have multiple server connections, the Server Connection Mapping page appears.
Select the sampledb server connection from the drop-down list and click Finish.

Developing Database Mobile Business Objects
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If the runtime database connection were on a remote machine, you would select New
Server Connection, which allows you to create a connection from an existing template.

The deployment progress window appears.

7. Click OK when the deployment status window appears.

A status window indicates progress and a successful deployment.

8. Connect to Unwired Server and view the deployed project, by expanding Domains >
default > Packages. The server package SUP101:1.0 into which you deployed the MBOs
appears in the Packages folder. The two MBOs, appear in the Mobile Business Objects
folder.

Developing Database Mobile Business Objects
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The MBOs are now available for access by device applications or for deploying in a
production environment. You will use this project in other getting started tutorials.

Developing Database Mobile Business Objects
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Learn More about Sybase Unwired Platform

Once you have finished, try some of the other samples or tutorials, or refer to other
development documents in the Sybase Unwired Platform documentation set.

Check the Sybase Product Documentation Web site regularly for updates: http://
infocenter.sybase.com/help/index.jsp?topic=/com.sybase.infocenter.pubs.docset-
SUP-2.0.0/doc/html/title.html.

Tutorials
Try out some of the other getting started tutorials to get a broad view of the development tools
available to you.

Samples
Sample applications are fully developed, working applications that demonstrate the features
and capabilities of Sybase Unwired Platform.

Check the SAP Development Network (SDN) Web site regularly for updates: http://
www.sdn.sap.com/irj/sdn/mobile. Click on Sybase Unwired Platform and navigate to
Samples.

Online Help
See the online help that is installed with the product, or the Product Documentation Web site.

Developer Guides
Learn about using the API to create device applications:

• Developer Guide for BlackBerry
• Developer Guide for iOS
• Developer Guide for Mobile Workflow Packages
• Developer Guide for Windows and Windows Mobile

Customize and automate:

• Developer Guide for Unwired Server Management API  – customize and automate system
administration features.

• Developer Guide for Unwired Server – customize and automate server-side
implementations for device applications, and administration, such as data handling.

Javadoc and HeaderDoc are also available in the installation directory.

Learn More about Sybase Unwired Platform
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