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CHAPTER 1 Getting Started with
Requirements Modeling

A requirements model (RQM) helps you analyze any kind of written requirements and link
them with users and groups who will implement them and with design objects in other models.
You can use an RQM to represent any structured document (e.g. functional specification, test
plan, business goals, etc.) and import and export hierarchies of requirements as MS Word
documents.

You can create an SAP® Sybase® PowerDesigner® RQM by importing an MS Word
document, and keep the model and document synchronized along with all the design models
and objects:
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The following example shows a Requirement Model containing various views and an attached
Word document, which specifies the requirements of the CyberFridge project:

Special thanks to Dr Gregory Abowd and his team, Jeffrey Corn (Manager), Travis Works
(Architect), John Garrard (Programmer), Kesniel Acton (Technical Writer), and Dinesh
Krishna (Quality Assurance), who designed the CyberFridge project – Copyright 2004,
Georgia Tech Research Corporation, Atlanta, Georgia 30332-0415, All Rights Reserved

Note: Demo requirements models are available in the Examples directory.

Suggested Bibliography

• INCOSE (International Council on Systems Engineering) – http://www.incose.org

Creating an RQM
You create a new requirements model by selecting File > New Model.

Note: In addition to creating an RQM from scratch with the following procedure, you can also
create a model by importing an existing MS Word document (see Chapter 4, Working with
Word Documents and RQMs on page 43).

CHAPTER 1: Getting Started with Requirements Modeling
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The New Model dialog is highly configurable, and your administrator may hide options that
are not relevant for your work or provide templates or predefined models to guide you through
model creation. When you open the dialog, one or more of the following buttons will be
available on the left hand side:

• Categories - which provides a set of predefined models and diagrams sorted in a
configurable category structure.

• Model types - which provides the classic list of PowerDesigner model types and
diagrams.

• Template files - which provides a set of model templates sorted by model type.

1. Select File > New Model to open the New Model dialog.

2. Click a button, and then select a category or model type ( Requirements Model ) in the
left-hand pane.

3. Select an item in the right-hand pane. Depending on how your New Model dialog is
configured, these items may be first diagrams or templates on which to base the creation of
your model.

CHAPTER 1: Getting Started with Requirements Modeling
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Use the Views tool on the upper right hand side of the dialog to control the display of the
items.

4. Enter a model name. The code of the model, which is used for script or code generation, is
derived from this name using the model naming conventions.

5. [optional] Click the Select Extensions button and attach one or more extensions to your
model.

6. Click OK to create and open the requirements model .

Note: Sample RQMs are available in the Example Directory.

RQM Properties
You open the model property sheet by right-clicking the model in the Browser and selecting
Properties.

Each requirements model has the following model properties:

Property Description

Name/Code/Comment Identify the model. The name should clearly convey the model's purpose to
non-technical users, while the code, which is used for generating code or
scripts, may be abbreviated, and should not normally include spaces. You
can optionally add a comment to provide more detailed information about
the model. By default the code is auto-generated from the name by applying
the naming conventions specified in the model options. To decouple name-
code synchronization, click to release the = button to the right of the Code
field.

Filename Specifies the location of the model file. This box is empty if the model has
never been saved.

Author Specifies the author of the model. If you enter nothing, the Author field in
diagram title boxes displays the user name from the model property sheet
Version Info tab. If you enter a space, the Author field displays nothing.

Version Specifies the version of the model. You can use this box to display the
repository version or a user defined version of the model. This parameter is
defined in the display preferences of the Title node.

Default view Specifies the view displayed by default when you open the model.

Keywords Provide a way of loosely grouping objects through tagging. To enter mul-
tiple keywords, separate them with commas.

The following tabs are also available:

• Detail - Provides fields to record workloads assigned to four individuals or groups. Model
workloads are read-only fields calculated as the sums of all requirement workloads.

CHAPTER 1: Getting Started with Requirements Modeling
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• Requirement Traceability Links - Lists links to design objects and external files.

Customizing your Modeling Environment
The PowerDesigner requirements model provides various means for customizing and
controlling your modeling environment.

Setting Model Options
You can set RQM model options by selecting Tools > Model Options or right-clicking the
diagram background and selecting Model Options.

You can set the following options on the Model Settings page:

Option Description

Name/Code case
sensitive

Specifies that the names and codes for all objects are case sensitive, allowing you
to have two objects with identical names or codes but different cases in the same
model. If you change case sensitivity during the design process, we recommend
that you check your model to verify that your model does not contain any duplicate
objects.

External Short-
cut Properties

Specifies the properties that are stored for external shortcuts to objects in other
models for display in property sheets and on symbols. By default, All properties
appear, but you can select to display only Name/Code to reduce the size of your
model.

Note: This option only controls properties of external shortcuts to models of the
same type (PDM to PDM, EAM to EAM, etc). External shortcuts to objects in
other types of model can show only the basic shortcut properties.

For information about controlling the naming conventions of your models, see Core Features
Guide > Modeling with PowerDesigner > Objects > Naming Conventions.

Customizing Requirement Codes
Requirement codes are automatically computed from the other attributes of the requirement.
You can customize requirement codes in the Code Template tab of the Requirement page of
the Model Options dialog.

1. Select Tools > Model Options to open the Model Options dialog, and then select Naming
Convention > Requirement in the Category tree view.

2. Click the Code Template tab and enter a GTL script in the Conversion Script field.

The default script is REQ_%-4:Increment% in which the RQM-specific
%increment% variable ensures code uniqueness. For detailed information about writing
GTL scripts, see Customizing and Extending PowerDesigner > Customizing Generation
with GTL .

CHAPTER 1: Getting Started with Requirements Modeling
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3. [optional] Select a conversion table.

4. Click OK to return to your model.

Note: You can modify individual requirement codes directly in the requirement property
sheet or the document view. If you modify a code, the User-Defined button is depressed to
indicate that the modified code no longer follows the code template definition. To return to
the default code template click the User-Defined button to release it.

For detailed information about working with naming conventions, including conversion
tables, see Core Features Guide > Modeling with PowerDesigner > Objects > Naming
Conventions.

Extending your Modeling Environment
You can customize and extend PowerDesigner metaclasses, parameters, and file generation
with extensions, which can be stored as part of your model or in separate extension files
(*.xem) for reuse with other models.

To access extension defined in a *.xem file, simply attach the file to your model. You can do
this when creating a new model by clicking the Select Extensions button at the bottom of the
New Model dialog, or at any time by selecting Model > Extensions to open the List of
Extensions and clicking the Attach an Extension tool.

In each case, you arrive at the Select Extensions dialog, which lists the extensions available,
sorted on sub-tabs appropriate to the type of model you are working with:

CHAPTER 1: Getting Started with Requirements Modeling
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To get started extending objects, see Core Features Guide > Modeling with PowerDesigner >
Objects > Extending Objects. For detailed information about working with extensions, see
Customizing and Extending PowerDesigner > Extension Files.

Linking Objects with Traceability Links
You can create traceability links to show any kind of relationship between two model objects
(including between objects in different models) via the Traceability Links tab of the object's
property sheet. These links are used for documentation purposes only, and are not interpreted
or checked by PowerDesigner.

For more information about traceability links, see Core Features Guide > Linking and
Synchronizing Models > Getting Started with Linking and Syncing > Creating Traceability
Links.

CHAPTER 1: Getting Started with Requirements Modeling
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CHAPTER 2 Requirements Views

A requirements model contains a set of requirements and other objects, which can be
displayed and manipulated in any number of requirements views.

You can create the following kinds of objects in an RQM:

Object Description

Requirement A feature that must be provided by the development process, which should be
defined as precisely as possible, and can be assigned to a user or group for
implementation (see Requirements (RQM) on page 19).

User A person that is involved in the implementation of one or more requirements (see
Users and Groups (RQM) on page 33).

Group A group of users that is involved in the implementation of one or more require-
ments (see Users and Groups (RQM) on page 33).

Glossary term [deprecated] A word used in a requirements model, which should be defined as
precisely as possible to avoid misunderstandings and to set a common vocabulary
(see Glossary Terms (RQM - Deprecated) on page 34).

Business rule Written statements describing rules that your business must follow (see Business
Rules (RQM) on page 35).

You can create requirement views to organize your requirements and other objects from the
Browser or the toolbar:

• In the requirements view toolbar, select one of the following tools:

Tool Description

Create a Requirements Document View - To list requirements in a hierarchy (see 
Requirements Document Views on page 10).

Create a Traceability Matrix View - To display the links between requirements and
design objects (from other types of models), external files or other requirements (see
Traceability Matrix Views on page 15).

Create a User Allocation Matrix View - To display the links between requirements
and the users and groups who will fulfill them (see User Allocation Matrix Views on
page 18).

• Right-click the model in the Browser and select New > [Type] View.

You can navigate between requirements views in the Browser or by selecting View > Diagram
> Select View to open the Select View dialog box, and double-clicking the view to open.
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Requirements Document Views
A requirements document view displays a list of written requirements in a hierarchic grid.
Multiple views can be created with different filters to display various subsets of requirements.

A requirements model can have as many requirements document views as necessary. You can
filter the requirements displayed in views (see Customizing Columns and Filtering Rows on
page 12) or separate your hierarchy of requirements into packages (see Packages (RQM) on
page 31), which can have their own views.

The following tools are available on the requirements view toolbar:

Tools Description

Properties [Alt+Enter] - Opens the property sheet of the selected requirement.

 Insert an Object [Ctrl+I] and Insert a Sub-Object [Ctrl+Shift+I]- Create a
new requirement as a sibling, or as a child to the selected requirement.

 Promote and Demote - Raises or lowers the selected requirement by one level.

CHAPTER 2: Requirements Views
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Tools Description

 Show Titles and Texts and Show Titles Only - Shows the titles and descriptions
or only the titles of all requirements in the view.

Also available from Requirements > Show Titles and Texts and Require-
ments > Show Titles Only.

Show Current Title and Text / Show Current Title Only - Toggle between
showing the title and description or only the title of the selected requirement.

Also available from Requirements > Show Current Title and Text / Show
Current Title Only

 Expand all Objects and Collapse all Objects – Opens or closes all levels in the
requirements hierarchy.

Also available from Requirements > Expand all Objects and Requirements >
Collapse all Objects

  Cut [Ctrl+X], Copy [Ctrl+C], and Paste [Ctrl+V] - Perform the standard
clipboard actions.

Delete [Ctrl+D] - Deletes the selected requirement.

Customize Columns and Filter - Opens a dialog to change the columns dis-
played in the list or define a filter (see Customizing Columns and Filtering Rows
on page 12).

Enable/Disable Filter - Toggles the filter specified in the Customize Columns
and Filter dialog.

Find [Ctrl+F] - Opens a dialog to search for text.

Format [Ctrl+M] - Opens a dialog to specify fonts and styles.

  Bold, Italic, and Underline - Format the selected text.

  Align Left, Align Center, and Align Right - Align the selected text.

Bullets - Indent and bullet the selected text.

  Create a Requirements Document View, Create a Traceability Matrix View,
and Create a User Allocation Matrix View - Creates a new view.

Create a Package - Creates a package, which you use to subdivide your re-
quirements. You will be prompted to specify a first view in the package.

Open a Requirements View - Opens a dialog to move to another view.

Export to Excel - Saves the list to a *.xls, *.xlsx, or *.csv format (specify the
format in the Save as type field in the Save as dialog).

CHAPTER 2: Requirements Views
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Customizing Title and Description Fonts
To set model options for requirements fonts, select Tools > Model Options, and select the
Requirements Fonts sub-category in the left-hand Category pane.

You can specify the font and its characteristics for any of the requirement levels by selecting
the level in the Text box and the necessary requirements in the other fields.

Customizing Columns and Filtering Rows
You can customize the columns displayed and use criteria to filter the rows in a requirements
document view.

1. Click the Customize Columns and Filter tool:

CHAPTER 2: Requirements Views
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2. To specify columns to display, select or clear check boxes in the Displayed (D) column.

3. To reorder the display of columns, use the arrow buttons at the bottom-left corner of the
list.

4. To filter the rows displayed, enter an expression in the expression column (see Defining a
Filter Expression on page 13).

5. Click OK to return to the view with the changes applied.

Defining a Filter Expression
You can define expressions to filter PowerDesigner lists directly in the list with the in-column
filters or through the Customize Columns and Filter dialog.

The following operators are available

Operator Finds items that are...

= [default] Equal to the expression.

> Greater than the expression.

>= Greater than or equal to the expression.

< Less than the expression.

<= Less than or equal to the expression.

Not Equal Different from the expression.

In List Within the comma-separated list of values given in the expression (or the items
selected in the list in the in-column filter). For example:

"global", "Architecture", "proc*"

CHAPTER 2: Requirements Views
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Operator Finds items that are...

Not In List Outside the comma-separated list of values given in the expression (or the items
selected in the list in the in-column filter).

Between Located in the range between defined by the two values given in the expression and
separated by a comma. For example, to find values between A and E, enter:

A,E

Not Between Located outside the range defined by the two values given in the expression and
separated by a comma. For example, to find values outside of the range between A
and E, enter:

A,E

Empty Null. No expression is necessary with this operator.

Not Empty Not null. No expression is necessary with this operator.

You can use the following wildcards when entering a filter expression:

Wildcard Description

* Any string (from none to any number of characters). For example P* finds "pro-
tocol" and "Paris".

? Any character. For example ????? finds "Table" and "inner" but not "Seller".

\ Escapes the special characters *, ?, and \ . For example, \?\\ finds "?\".

Examples
The following examples show some possible combinations of operators and expressions:

Operator Expression Find

= W* Work, Washington

= *CODE AREA CODE, COUNTRY CODE, CITY CODE

> 1?? 200, 405, 609

Between O,8 0,1,2,3,4,5,6,7,8

In List *_emp_???,
*_grp_???

div_emp_fun, _emp_idn, div_grp_fun, _grp_idn

= *\? Is this book ready for production?

CHAPTER 2: Requirements Views
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Requirements Views Properties
To view or edit a requirement view's properties, double-click its Browser or list entry. The
property sheet tabs and fields listed here are those available by default, before any
customization of the interface by you or an administrator.

The General tab contains the following properties:

Property Description

Name/Code/Com-
ment

Identify the object. The name should clearly convey the object's purpose to
non-technical users, while the code, which is used for generating code or
scripts, may be abbreviated, and should not normally include spaces. You can
optionally add a comment to provide more detailed information about the
object. By default the code is generated from the name by applying the
naming conventions specified in the model options. To decouple name-code
synchronization, click to release the = button to the right of the Code field.

Stereotype Extends the semantics of the object. You can enter a stereotype directly in this
field, or add stereotypes to the list by specifying them in an extension file.

Traceability matrix
type

[traceability matrix views only] Use the list to select the type of linked
objects (Design Object, File or Requirement) displayed in the traceability
matrix view

Parent Name of the model or package to which the requirements view belongs

Default view If checked, the current requirements view (document, traceability or user
allocation view) is displayed by default when opening the model

Traceability Matrix Views
A traceability matrix view displays the links between requirements and objects from other
types of models, external files or other requirements.

You can create as many traceability matrix views as you need. You can add and delete links,
filter the rows and columns displayed, and print or export the matrix.

CHAPTER 2: Requirements Views
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The Current cell properties group box displays the type of the link and, for MS Word files, the
associated bookmark (see Creating a Bookmark in an MS Word Document on page 27). You
can modify the links in the following ways:

• To add a link, click in the appropriate cell, and then click the Create traceability link
button at the bottom of the matrix (or press the Spacebar or V). You can optionally specify
the type of link. To define additional link types, see Customizing a List of Values on page
21.

• To delete a link, click in a cell containing a link, and then click the Delete traceability link
button at the bottom of the matrix (or press the Spacebar or Del).

• To select all the cells in a row or column, click the appropriate header. To select multiple
cells, rows, or columns, use the Ctrl key. To select ranges, use the Shift key or drag the
cursor over the required area.

The following tools are available on the traceability matrix view toolbar:

Tools Description

Properties [Alt+Enter] - Opens the property sheet of the selected requirement.

CHAPTER 2: Requirements Views
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Tools Description

Copy [Ctrl+C] - Copies the entire grid to the clipboard.

Select Rows/Columns [Ctrl+N] - Opens a selection box which allows you to select
rows and columns to display in the matrix either by hand or by defining a filter.

 
Display Only Non-Empty Rows/ Columns [Ctrl+R] and Display Only Empty
Rows/Columns [Ctrl+E] - Displays only full rows and columns (to focus on re-
quirements with links) or only empty rows and columns (that need to be linked).

Also available from Requirements > Display Only Full Rows/Columns and Re-
quirements > Display Only Empty Rows/Columns.

Vertical/Horizontal Column Header - Toggles between vertical and horizontal
orientation of column headers.

Shrink to Fit - Shrinks row and column headers to fit their contents.

  Create a Requirements Document View, Create a Traceability Matrix View, and
Create a User Allocation Matrix View - Creates a new view.

Create a Package - Creates a package, which you use to subdivide your requirements.
You will be prompted to specify a first view in the package.

Open a Requirements View - Opens a dialog to move to another view.

Export to Excel - Saves the list to a *.xls, *.xlsx, or *.csv format (specify the format in
the Save as type field in the Save as dialog).

Change Traceability Matrix Type - Opens a dialog to let you specify the type of
objects you want to link to your requirements. You can choose between:

• Design objects (from other types of models) – To show how requirements are
fulfilled in the analysis and design processes.

• External files (MS Word, MS Excel, etc) - The links with MS Word are managed
automatically. You can also link requirements with pieces of various documents
(e.g. a planning document).

• Requirement objects - to manage interconnected requirements. For example,
you could link customer requirements to design requirements, and on to specifi-
cation requirements. The requirement-to-requirement matrix view allows you to
check that all requirements are present at each level.

For information about linking requirements to other objects via their property sheet
Requirement Traceability Links tab, see Linking Requirements with Design Ob-
jects and External Files on page 22.

CHAPTER 2: Requirements Views
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User Allocation Matrix Views
A user allocation matrix view displays the links between requirements and the users and
groups who will fulfill them.

You can create as many user allocation matrix views as you need. You can add and delete links,
filter the rows and columns displayed, and print or export the matrix.

Note: User allocation matrix views are completed in the same way as traceability matrix views
(see Traceability Matrix Views on page 15).

CHAPTER 2: Requirements Views
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Requirements (RQM)
A requirement is a clear and precise description of an action that must be implemented during
a development process. Requirements can have a priority, status, workload, and other
properties assigned to them, and can contain sub-requirements.

Note: All columns (except Title ID) are editable.

Creating a Requirement
You can create a requirement in a requirements document view or from the Browser or Model
menu.

• Click in an empty row in a requirements document view.
• Click the Insert an Object or Insert a Sub-Object tool in the toolbar at the top of a

requirements document view.
• Select Model > Requirements to access the List of Requirements, and click the Add a

Row tool.
• Right-click the model, a package, or a requirement in the Browser, and select New >

Requirement.

For general information about creating objects, see Core Features Guide > Modeling with
PowerDesigner > Objects.

Requirement Properties
To view or edit a requirement's properties, double-click its Browser or list entry. The property
sheet tabs and fields listed here are those available by default, before any customization of the
interface by you or an administrator.

The General tab contains the following properties:

Property Description

Parent [read-only] Displays the name of the parent requirement. For top-level require-
ments this is the model name.

CHAPTER 2: Requirements Views
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Property Description

Title ID [read-only] Displays the number expressing the place of the requirement in the
requirements hierarchy. For example: 1.3.2.

Title Specifies the name of the requirement.

Code Generates a unique code for the requirement. You can override an individual
requirement code by typing directly in this field. You can also modify the template
used to generate the codes (see Customizing Requirement Codes on page 5).

Description Specifies a detailed description of the requirement. This field is also available on
(and synchronized with) the Notes tab.

Keywords Provide a way of loosely grouping objects through tagging. To enter multiple
keywords, separate them with commas.

The Detail tab contains the following properties:

Property Description

Comment Provides space for any comment on the requirement.

Stereotype Extends the semantics of the object. You can enter a stereotype directly in this
field, or add stereotypes to the list by specifying them in an extension file.

Type Specifies the type of the requirement, as viewed from the process point of view.
You can specify your own types (see Customizing a List of Values on page 21).

Status Specifies the present validation status for the requirement. You can specify your
own status levels (see Customizing a List of Values on page 21).

If you change the status of a requirement containing sub-requirements, a message
is displayed warning that the change will be propagated to all its sub-require-
ments. If you change the status of a sub-requirement, it may change the status of its
parent requirement, which can only have the lowest status held by any of its sub-
requirements.

Priority Specifies the priority level attached to the requirement. Select a value in the list or
type a value. The value cannot be null or negative, and is limited to one decimal
(for example: 1.9).

Selected Specifies that the requirement has been selected to be implemented in the project.
If this checkbox is cleared, the requirement is excluded from the project and the
sum of workloads.

Risk Specifies the level of risk associated with implementing the requirement. You can
specify your own risk levels (see Customizing a List of Values on page 21).

CHAPTER 2: Requirements Views
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Property Description

Verification Specifies the type of testing to be applied to the development of the requirement.
You can specify your own verification types (see Customizing a List of Values on
page 21).

Workload 1-4 Specifies the workloads assigned to four individuals or groups (see Assigning
Workloads on page 30). Workloads for requirements with sub-requirements are
read-only fields calculated as the sums of all sub-requirement workloads.

The following tabs are also available:

• Requirement Traceability Links - Lists links to design objects, other requirements, and
external files (see Linking Requirements with Design Objects and External Files on page
22).

• Related Glossary Terms - Lists terms attached to the requirement (see Glossary Terms
(RQM - Deprecated) on page 34).

Note: The RQM glossary terms are deprecated and are replaced by the enterprise glossary
model (see Core Features Guide > Administering PowerDesigner > Deploying an
Enterprise Glossary and Library).

• User Allocations - Lists the users and groups attached to the requirement (see Users and
Groups (RQM) on page 33).

Customizing a List of Values
Some requirement properties such as Risk, Status, and Type, come with predefined lists of
values, which you can modify by creating an extension.

1. Select Model > Extensions to open the List of Extensions and click the Add a Row tool.

2. Type a name and a code for the new extension, click Apply, and then click the Properties
tool to open it in the Resource Editor.

3. In the left pane, expand the Settings > Custom Values > Requirement category and
expand the entries to display the lists available for customization:

• Priority
• Risk
• Status
• Type
• Verification Method
• TraceabilityLink/Link Type (under the category)
• UserAllocation/Type

4. Select a list to display the currently available values in the right-hand panel.

5. In the Value table, click the Add a Row tool, and then type a new name (which is used
internally) and value (which will appear in the property list):

CHAPTER 2: Requirements Views
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6. Add additional values as necessary, and then click OK to save your changes and return to
the List of Extensions.

7. Click OK to return to your model. The new values are now available in the appropriate
property list.

Note: If you have several extensions defining list values attached to your RQM, the union
of all the different values defined for each property will be available.

Linking Requirements with Design Objects and External Files
You can link requirements to design objects (objects from other types of models), external
files, and other requirements on the Requirement Traceability Links tab. You can,
optionally, specify a Link Type for each link.

The following tools are available on this tab:

Tool Description

Properties - opens the property sheet representing the linked object in the requirements
model.

Open External File - opens the linked external file.

Add Links to Design Objects - attaches design objects to the requirement (see Attaching
Design Objects to Requirements from the RQM on page 23).
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Tool Description

Add Link to External File – attaches any external file to the requirement. For MS Word
files, you can link to a specific bookmark in the file (see Creating a Bookmark in an MS
Word Document on page 27).

Add Links to Other Requirements – attaches another requirement (from the current or
another RQM) to the requirement.

Note: Requirement traceability links are similar to but separate from the traceability links that
are available for linking any object with any other object, and which are listed on the
Traceability Links tab (see Linking Objects with Traceability Links on page 7).

Attaching Design Objects to Requirements from the RQM
When a design object fulfils a requirement, you should attach it to the requirement. Both
models must be open in your workspace.

1. Open the property sheet of the requirement and click the Requirement Traceability
Links tab.

2. Click the Add Links to Design Objects tool to open the Select Design Objects dialog.

3. Choose the appropriate design model in the Model list, and then select the design objects
you want to attach to the requirement.

4. Click OK.

The design objects are attached to the requirement and listed on its Requirement
Traceability Links tab:
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5. Click OK to return to your model.

To open the property sheet of a design object from the Requirement Traceability Links tab
of a requirement property sheet, select it in the list and click the Properties tool. As design
objects are stored as shortcuts in requirements models, you must click the Properties tool to
the right of the Name field in the shortcut properties sheet to access the full properties of the
design object

The requirement is listed on the Requirements tab of the design object:
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Attaching Requirements to Design Objects from the Design Model
To verify that the design process fulfills the requirements, you should attach requirements to
objects in your design models.

Note: Before you can attach requirements to your design objects from your design model you
may need to activate the display of the Requirements tab by selecting Tools > Model Options
and selecting the Enable links to requirements option in the All Objects group box of the
Model Settings tab.

1. Open the property sheet of the design object and click the Requirements tab.

2. Click the Add Objects tool to open a dialog listing all the requirements available in the
selected RQM.
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3. [optional] Change the selected model to select another RQM open in the workspace or
click the Include Sub-Objects tool to display all the sub-requirements.

4. Select the requirements you want to attach to the design object, and click OK.

The selected requirements are attached to the design object and listed on its Requirements
tab.

5. Click OK to return to your model.
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To open the property sheet of a requirement from the Requirements tab of a design object
property sheet, select it in the list and click the Properties tool. As requirements are stored as
shortcuts in design models, you must click the Properties tool to the right of the Name field in
the shortcut properties sheet to access the full properties of the requirement.

The design object is listed as a linked object in the Requirement Traceability Links tab of the
requirement:

Creating a Bookmark in an MS Word Document
You can create bookmarks in a MS Word document attached to the model.

1. Open the property sheet of a requirement and click the Requirement Traceability Links
tab

2. Click the Add Link to External File tool and select an MS Word file. A message is
displayed indicating that the system is parsing the MS Word document to extract its
paragraph titles.

3. When the parsing is over, a dialog is displayed inviting you to select a place in the
document to which to attach the requirement. Expand the Entry points node, to
reveal the headings hierarchy, and select a heading:

CHAPTER 2: Requirements Views

Requirements Modeling 27



4. Click OK. The selected heading is displayed in the Bookmarks column on the
Requirement Traceability Links tab, and is also available in any traceability matrix view
featuring the requirement.

To open the Word document at the selected location, select the linked file in the
Requirement Traceability Links tab of the requirement property sheet, and click the
Properties tool.

To modify the location, click the bookmark cell in the Requirement Traceability Links
tab and click the Ellipsis button.

Exporting Requirements as Design Objects
The Requirement Export Wizard allows you to export requirements as design objects in other
PowerDesigner models. The resulting design objects bear the same name and code as their
originating requirements and are connected to them via requirement traceability links.

1. Select Requirements > Export Requirements as Design Objects to open the Export
Requirements Wizard:
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2. Specify the requirements that you want to export as design objects, and then click Next.

3. Specify the model to which you want to export the requirements from among the models
open in the workspace, and then click Next.

4. Specify the kind of objects that you want to create in the target model (for example, classes
in an OOM), and then click Finish to start the export.

The design objects created from the requirements appear in the specified design model.

Note: By default, the symbols of the new design objects do not appear in the diagram. To
display them, you can either drag and drop the design objects from the Browser to the diagram,
or select Symbol > Show Symbols, in the menu bar, and select the symbols in the Show
Symbols dialog box.

Importing Design Objects as Requirements
The Requirement Import Wizard allows you to import design objects as requirements. The
resulting requirements bear the same name and code as their originating design objects and are
connected to them via requirement traceability links.

1. Select Requirements > Import Design Objects as Requirements to open the Import
Requirements Wizard:
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2. Specify the model from which you want to import the requirements from among the
models open in the workspace, and then click Next.

3. Specify the design objects that you want to import to the RQM by selecting them from
among the sub-tabs in the selection field, and then click Next.

4. Specify the location within the RQM where you want to create the requirements, and then
click Finish.

The requirements created from the design objects appear in the RQM at the specified
location.

Assigning Workloads
A workload is the time assigned to a person or team to satisfy a requirement. Values must be
greater than or equal to zero, and limited to one decimal place (for example: 3.5).

No time unit is enforced to measure workloads but, in order to allow PowerDesigner to
properly calculate totals, you should decide on and consistently use the same unit (hour or day)
for all workloads.

You assign workloads to requirements on their Detail tab, where there are fields to record
workloads assigned to four individual people or groups.

You can only assign workloads to requirements that have no sub-requirements. Workloads for
parent requirements, packages, and the model are read-only fields calculated as the sums of all
their sub-requirement workloads.
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Packages (RQM)
You can divide your requirements model into packages in order to avoid manipulating the
entire set of requirements and to provide views on particular logical subsets of the
requirements. You could create packages to represent different tasks, domains, or subject
areas.

In the following example, one package contains functional requirements and the other
contains non-functional requirements:

You can create packages as peers and divide packages into subpackages as necessary. Each
package has its own default requirements view (document, traceability or user allocation
view) and you can create others if required.

In a requirements model, packages only appear in the Browser tree view. To add requirements
to a package, you can:

• Create requirements directly in the package document view(s).
• In the Browser, select requirements from the model Requirements folder, and drag and

drop them onto the package or one of its sub-requirements.

You can link requirements in different packages of the same model together from the
Requirement Traceability Links tab of the requirements property sheet (see Linking
Requirements with Design Objects and External Files on page 22).

Creating a Package
You can create a package in a requirements document view, or from the Browser or Model
menu.

• Click the Create a Package tool in the toolbar at the top of a requirements document
view.
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• Select Model > Packages to access the List of Packages, and click the Add a Row tool.
• Right-click the model or package in the Browser, and select New > Package.

For general information about creating objects, see Core Features Guide > Modeling with
PowerDesigner > Objects.

Package Properties
To view or edit a package's properties, double-click its diagram symbol or Browser or list
entry. The property sheet tabs and fields listed here are those available by default, before any
customization of the interface by you or an administrator.

The General tab contains the following properties:

Property Description

Name/Code/
Comment

Identify the object. The name should clearly convey the object's purpose to non-
technical users, while the code, which is used for generating code or scripts, may be
abbreviated, and should not normally include spaces. You can optionally add a
comment to provide more detailed information about the object. By default the
code is generated from the name by applying the naming conventions specified in
the model options. To decouple name-code synchronization, click to release the =
button to the right of the Code field.

Stereotype Extends the semantics of the object. You can enter a stereotype directly in this field,
or add stereotypes to the list by specifying them in an extension file.

Use parent
namespace

[package only] Specifies that the package does not represent a separate namespace
from its parent and thus that objects created within it must have codes that are
unique within the parent container. If this property is not selected, then the package
and its parent package or model can both contain objects with the same code.

Default view Specifies the requirements view displayed by default when you open the package

Keywords Provide a way of loosely grouping objects through tagging. To enter multiple
keywords, separate them with commas.

The following tabs are also available:

• Detail - Provides fields to record workloads assigned to four individuals or groups.
Package workloads are read-only fields calculated as the sums of all requirement
workloads (see Assigning Workloads on page 30).

• Requirement Traceability Links - Lists links to design objects and external files (see 
Attaching Design Objects to Requirements from the RQM on page 23).

CHAPTER 2: Requirements Views

32 SAP Sybase PowerDesigner



Users and Groups (RQM)
Users are all the people concerned by at least one requirement defined in a requirements
model. Groups are teams of users (e.g. a QA team) concerned by at least one requirement
defined in a requirements model.

Users and groups are attached to requirements via the User Allocations tab of the
requirements property sheet, or via user allocation matrix views.

The Dependencies tab of a user or group property sheet displays:

• The list of requirements assigned to that user or group
• The groups or child groups linked to that user or group

Creating a User or Group
You can create a user or group from the Browser or Model menu.

• Select Model > Users to access the List of Users or Model > Groups to access the List of
Groups, and click the Add a Row tool.

• Right-click the model or package in the Browser, and select New > User or New >
Group.

For general information about creating objects, see Core Features Guide > Modeling with
PowerDesigner > Objects.

User and Group Properties
To view or edit a user or group's properties, double-click its Browser or list entry. The property
sheet tabs and fields listed here are those available by default, before any customization of the
interface by you or an administrator.

The General tab contains the following properties:

Property Description

Name/Code/
Comment

Identify the object. The name should clearly convey the object's purpose to non-
technical users, while the code, which is used for generating code or scripts, may
be abbreviated, and should not normally include spaces. You can optionally add a
comment to provide more detailed information about the object. By default the
code is generated from the name by applying the naming conventions specified in
the model options. To decouple name-code synchronization, click to release the =
button to the right of the Code field.

Stereotype Extends the semantics of the object. You can enter a stereotype directly in this
field, or add stereotypes to the list by specifying them in an extension file.
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Property Description

Email address E-mail address of the user or group.

In addition, the Group property sheet contains the following tabs:

• Group Users - lists the users and groups who belong to the group.

Attaching Users and Groups to a Group
You can attach users and groups to a group from the group's property sheet.

1. Open the property sheet of a group, and click the Group Users tab.

2. Click the Add Objects tool to open the Add Objects dialog box.

3. The User sub-tab lists the available users in the model. Select the users you want to attach
to the current group.

4. Click the Group sub-tab. This sub-tab lists the available groups in the model. Select the
groups you want to attach to the current group and click OK to return to the Group property
sheet.

The selected users and child groups are displayed on the Group Users tab.

Warning! You must not select child groups that are, at the same time, parent groups of the
current group (see Group Checks on page 39).

Glossary Terms (RQM - Deprecated)
Glossary terms are clearly defined words used to avoid misinterpretations in a requirements
model. Use the Description sub-tab on the Notes tab of a glossary term property sheet, to give
a full and precise description of a glossary term.

Warning! The RQM glossary terms are deprecated and are replaced by the enterprise glossary
model (see Core Features Guide > Administering PowerDesigner > Deploying an Enterprise
Glossary and Library).

Glossary terms are attached to requirements via the Related Glossary Terms tab of the
requirements property sheet. The Dependencies tab of a glossary term property sheet displays
the requirements associated with the glossary term.

Creating a Glossary Term
You can create a glossary term from the Browser or Model menu, or from the Related
Glossary Terms tab in the property sheet of a requirement.

• Select Model > Glossary Terms to access the List of Glossary Terms, and click the Add a
Row tool.
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• Open the Related Glossary Terms tab in the property sheet of a requirement, and click the
Create an Object tool.

• Right-click the model or package in the Browser, and select New > Glossary Term.

For general information about creating objects, see Core Features Guide > Modeling with
PowerDesigner > Objects.

Glossary Term Property Sheet General Tab
To view or edit a glossary term's properties, double-click its Browser or list entry. The property
sheet tabs and fields listed here are those available by default, before any customization of the
interface by you or an administrator.

The General tab contains the following properties:

Property Description

Name/Code/
Comment

Identify the object. The name should clearly convey the object's purpose to non-
technical users, while the code, which is used for generating code or scripts, may be
abbreviated, and should not normally include spaces. You can optionally add a com-
ment to provide more detailed information about the object. By default the code is
generated from the name by applying the naming conventions specified in the model
options. To decouple name-code synchronization, click to release the = button to the
right of the Code field.

Stereotype Extends the semantics of the object. You can enter a stereotype directly in this field, or
add stereotypes to the list by specifying them in an extension file.

Business Rules (RQM)
A business rule is a rule that your business follows. It is a written statement specifying what an
information system must do or how it must be structured. It could be a government-imposed
law, a customer requirement, or an internal guideline.

In the case of the Requirements Model, a business rule should be used as a super requirement,
i.e. a requirement defined for requirements. For instance, a business rule could be a
methodological rule for writing requirements.

Business rules are not available by default in a requirements model and must be activated
before you can use them.

Activating Business Rules in an RQM
Business rules are not available by default in an RQM, and must be activated through an
extension.

1. Select Model > Extensions to open the List of Extensions and click the Add a Row tool.
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2. Type a name and a code for the new extension, click Apply, and then click the Properties
tool to open it in the Resource Editor.

3. In the left pane, right-click the Profile category and select Add Metaclasses to open the
Metaclass Selection dialog, click the PdCommon sub-tab, select BusinessRule, and click
OK to add this metaclass to your profile:

4. Click OK to save your changes and return to the List of Extensions.

5. Click OK to return to your model.

You can now create business rules from the List of Business Rules (available at Model >
Business Rules), and attach them to your requirements from the Rules tab of your
requirements property sheets.

For detailed information about using business rules, see Core Features Guide > Modeling
with PowerDesigner > Objects > Business Rules.
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CHAPTER 3 Checking an RQM

The requirements model is a very flexible tool, which allows you quickly to develop your
model without constraints. You can check the validity of your RQM at any time.

A valid RQM conforms to the following kinds of rules:

• Each object name or code must be unique a RQM
• Each user must be allocated to at least one requirement
• Each glossary term should be attached to at least one requirement

Note: We recommend that you check your requirements model before generating another
model from it . If the check encounters errors, generation will be stopped. The Check model
option is enabled by default in the Generation dialog box.

You can check your model in any of the following ways:

• Press F4, or
• Select Tools > Check Model, or

The Check Model Parameters dialog opens, allowing you to specify the kinds of checks to
perform, and the objects to apply them to. The following sections document the RQM -
specific checks available by default. For information about checks made on generic objects
available in all model types and for detailed information about using the Check Model
Parameters dialog, see Core Features Guide > Modeling with PowerDesigner > Objects >
Checking Models.

Requirement Checks
PowerDesigner provides default model checks to verify the validity of requirements.

Check Description and Correction

Name/Code con-
tains terms not in
glossary

[if glossary enabled] Names and codes must contain only approved terms drawn
from the glossary.

• Manual correction - Modify the name or code to contain only glossary terms.
• Automatic correction - None.
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Check Description and Correction

Name/Code con-
tains synonyms of
glossary terms

[if glossary enabled] Names and codes must not contain synonyms of glossary
terms.

• Manual correction - Modify the name or code to contain only glossary terms.
• Automatic correction - Replaces synonyms with their associated glossary

terms.

Name/Code
uniqueness

Object names must be unique in the namespace.

• Manual correction - Modify the duplicate name or code.
• Automatic correction - Appends a number to the duplicate name or code.

Empty descrip-
tion on atomic re-
quirement

An atomic requirement (as opposed to a composite requirement) should have a
description.

• Manual correction: In the requirement property sheet, enter a description in
the Description box of the General tab.

• Automatic correction: None.

User Checks
PowerDesigner provides default model checks to verify the validity of users.

Check Description and Correction

Name/Code con-
tains terms not in
glossary

[if glossary enabled] Names and codes must contain only approved terms drawn
from the glossary.

• Manual correction - Modify the name or code to contain only glossary terms.
• Automatic correction - None.

Name/Code con-
tains synonyms of
glossary terms

[if glossary enabled] Names and codes must not contain synonyms of glossary
terms.

• Manual correction - Modify the name or code to contain only glossary terms.
• Automatic correction - Replaces synonyms with their associated glossary

terms.

Name/Code
uniqueness

Object names must be unique in the namespace.

• Manual correction - Modify the duplicate name or code.
• Automatic correction - Appends a number to the duplicate name or code.
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Check Description and Correction

Existence of user
allocation

A user should be allocated to at least one requirement.

• Manual correction: Attach the user to a requirement, by using the User
Allocations tab of the requirement property sheet, or delete the user.

• Automatic correction: None

Group Checks
PowerDesigner provides default model checks to verify the validity of groups.

Check Description and Correction

Name/Code con-
tains terms not in
glossary

[if glossary enabled] Names and codes must contain only approved terms drawn
from the glossary.

• Manual correction - Modify the name or code to contain only glossary terms.
• Automatic correction - None.

Name/Code con-
tains synonyms of
glossary terms

[if glossary enabled] Names and codes must not contain synonyms of glossary
terms.

• Manual correction - Modify the name or code to contain only glossary terms.
• Automatic correction - Replaces synonyms with their associated glossary

terms.

Name/Code
uniqueness

Object names must be unique in the namespace.

• Manual correction - Modify the duplicate name or code.
• Automatic correction - Appends a number to the duplicate name or code.

Existence of user A group must contain at least one user or another group of users.

• Manual correction: Attach a user or another group to the group, by using the
Group Users tab of the group property sheet, or delete the empty group.

• Automatic correction: None

Circular group
definition

One group cannot be at the same time parent and child of another group.

• Manual correction: Remove a group (parent group) from the Group Users
tab of another group (child group) property sheet. The parent group is dis-
played in the Dependencies tab of the child group property sheet.

• Automatic correction: None
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Package Checks
PowerDesigner provides default model checks to verify the validity of packages.

Check Description and Correction

Name/Code con-
tains terms not in
glossary

[if glossary enabled] Names and codes must contain only approved terms drawn
from the glossary.

• Manual correction - Modify the name or code to contain only glossary terms.
• Automatic correction - None.

Name/Code con-
tains synonyms of
glossary terms

[if glossary enabled] Names and codes must not contain synonyms of glossary
terms.

• Manual correction - Modify the name or code to contain only glossary terms.
• Automatic correction - Replaces synonyms with their associated glossary

terms.

Name/Code
uniqueness

Object names must be unique in the namespace.

• Manual correction - Modify the duplicate name or code.
• Automatic correction - Appends a number to the duplicate name or code.

List of missing
terms in object
names/codes in
package

[if glossary enabled] This special check lists all the terms that are used in the
names or codes of all the objects contained in the model or package.

• Manual correction - An administrator with write permission on the glossary
can double-click the line for this check in the Result List to open a merge
window in which you can select to add some or all of these missing terms, as
appropriate, to the glossary.

• Automatic correction - None.

Glossary Term Checks
PowerDesigner provides default model checks to verify the validity of glossary terms.

Check Description and Correction

Name/Code con-
tains terms not in
glossary

[if glossary enabled] Names and codes must contain only approved terms drawn
from the glossary.

• Manual correction - Modify the name or code to contain only glossary terms.
• Automatic correction - None.
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Check Description and Correction

Name/Code con-
tains synonyms of
glossary terms

[if glossary enabled] Names and codes must not contain synonyms of glossary
terms.

• Manual correction - Modify the name or code to contain only glossary terms.
• Automatic correction - Replaces synonyms with their associated glossary

terms.

Name/Code
uniqueness

Object names must be unique in the namespace.

• Manual correction - Modify the duplicate name or code.
• Automatic correction - Appends a number to the duplicate name or code.

Unused glossary
term

A glossary term should be attached to at least one requirement.

• Manual correction: Attach the glossary term to a requirement, by using the
Related Glossary Terms tab of the requirement property sheet, or delete the
glossary term

• Automatic correction: None
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CHAPTER 4 Working with Word Documents
and RQMs

PowerDesigner provides an optional addin, which allows you to import a Word document into
an RQM and to export an RQM to MS Word format. The RQM and the Word document will be
linked, allowing you to keep the two versions synchronized.

You can leverage the capabilities of PowerDesigner to link requirements to design objects in
other models, while retaining a requirements document in a format familiar to less technical
users. You can either start from a Word document and create an RQM, or start from an RQM
and create a Word document. In both cases, the Word document and the RQM can be linked to
allow easy updating.

Note: The MS Word addin is not installed by default during the PowerDesigner installation
process. In order to install it, you must expand the Requirements Model node on the Features
page of the PowerDesigner installer, and select the Word Addins feature. For detailed
information about installing PowerDesigner, see Installation Guide > Installing
PowerDesigner.

In order to link an RQM with a Word document, your environment must conform to all of the
following requirements:

• MS Word 2000 or higher is installed on your machine
• You have selected to install the Word Addins during your installation of PowerDesigner.

To do so, expand the Requirements Model node on the Features page of the
PowerDesigner installer, and select the Word Addins feature.

• You have enabled the Microsoft Word Import Export add-in in PowerDesigner. To do so,
select Tools > General Options, click the Add-Ins category and then select Microsoft
Word Import Export. Note that the add-in only works if the system code page is consistent
with the model language. For example, if you are working with a Chinese model, your
system code page must be Chinese.

• You have selected the WordToRqm.dot template in MS Word (select Tools > Templates
and Add-Ins).

• The titles in the Word document are formatted with Word heading styles, and use only MS
Word numbering.

• Heading styles must not increase by more than one level. For example, a title with Heading
1 must not be followed by a subtitle with Heading 3
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Installing the RQM Menu and Toolbar
The first time you open or create an RQM, the MS Word Import Export add-in is registered in
HKEY_CURRENT_USER\Software\Microsoft\Office and by default the Requirements
menu and toolbar should appear in the MS Word interface.

The following tools are available in the toolbar:

Tool Description

Create/Update a Requirements Model from the Document

For more information, see Creating an RQM from a Word Document on page 44 and 
Updating a Word Document Linked to an RQM on page 57.

Detach the Document from the Requirements Model

For more information, see Unlinking RQMs and Word Documents on page 58.

If the menu and toolbar do not appear in MS Word, you can install them manually:

1. In Word, select Tools > Customize, click the Commands tab, and select Tools in the
Categories pane.

2. Select COM Add-Ins in the Commands pane, and drag this command to any menu item.

3. Select the COM Add-Ins command to display the COM Add-in dialog box, and select the
PowerDesigner Requirements COM Add-Ins for MS Word check box. If you deselect
the check box, the add-in menu and toolbar disappear from your MS Word environment.

Creating an RQM from a Word Document
You can create an RQM from a Word document by exporting it from within Word or importing
it from within PowerDesigner.

Note: To import a Word document into an existing RQM or one of its packages, right-click the
model or package in the Browser, and select Import from Word Document.

1. In PowerDesigner, select File > Import > Word Document, navigate to the document to
be imported, and then click Open.

or

In Word, with the document open, select Requirements > Create/Update a
Requirements Model, or click the Create/Update a Requirements Model tool.
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If PowerDesigner is not presently open, it will be launched at this time, and the Import
Requirements Wizard opens:

2. Choose whether you want to:

• Import requirements from document headings (default), and/or
• Import requirements from document tables

You can also specify that the document will from now on be linked to the Rqm, enabling
easy synchronization of the two.

3. Click Next to go to the next screen:
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4. This screen lists requirement models open in the PowerDesigner workspace. You can
select an existing model or create a new one by clicking the New tool.

5. Click Next to go to the next screen. If the selected model is not saved you will be prompted
to save it now:
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6. This screen lists all the headings available in the Word document. All are selected by
default. You can deselect and reselect headings using the tools above the list. When your
selections are complete, click Next to go to the next screen:
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7. If there are tables in your document and you have selected to import requirements from
them, this screen lists the tables and invites you to specify mapping between any
unresolved table headings and their equivalent requirement attributes in the RQM. If there
is no suitable attribute, you can choose Extended Attribute, and PowerDesigner will create
a new extended attribute to hold this column's entries. You can also specify a heading to
insert before the table.

8. Click Next to go to the next screen:
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9. This screen allows you to link values in any column that you have mapped to a boolean
attribute to true or false for that attribute. Select an appropriate value for each pair of values
in each boolean column, and then click Next to go to the next screen:
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10. This final screen invites you to save your current settings as the default. Click Finish to
begin the import.

The RQM is created in the PowerDesigner workspace, and the Files folder in the Browser
contains the file of the linked Word document:

You can also import a Word document into an existing RQM or one of its packages as follows.
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Links Between an RQM and a Word Document
If you select to create a link between the RQM and Word document during the import process,
then they will be synchronized and can be updated when either changes.

Word Document Properties Sheet
A Word document is linked to an RQM (or package) through custom properties and
requirement tags, and the link details are displayed on the Custom tab of the Word document's
property sheet.

To display the document property sheet, select File > Properties from within Word.

Custom Tags
The actual linking is performed by custom tags in the document:
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Each requirement is placed between a [PDRQM] tag with a unique ID to indicate its start, and
a [/PDRQM] tag to indicate its end. To display the requirement tags, click the Show/Hidetool:

Browser Files Folder
The linked Word document is shown in the PowerDesigner Browser in a Files folder attached
to the model (or package).

When an RQM contains packages, each package can be linked to a specific Word document. A
package cannot be linked to more than one document.

If the model is itself linked to a document, only the requirements which do not belong to a
package are linked to the document.

For example:
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Note: The Files folder of the model item contains the model file and a shortcut for each
package file.

Traceability Links
The link to the document is also shown on the Requirement Traceability Links tab of the
property sheet of the model and each of the individual requirements:
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Creating a Word Document from an RQM
You can export an RQM (or a package containing at least one requirement) into Word format
to produce a document in a more portable format.

The following procedure assumes you have an RQM open in the workspace. Word need not be
open.

1. In PowerDesigner, select Tools > Export as Word Document.

2. [If the RQM has not been saved] The Save As dialog box will open. Select a directory and
enter a file name for the model, and then click Save.

3. Word opens with the New dialog box:
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4. In the General tab, click Blank Document or a template icon (with a .dot extension - you
might want to use a template for predefined Word heading styles), and click OK.

5. The Save As dialog box opens. Select a directory and enter a file name for the document,
and then click Save.

6. The Export Table Mapping dialog opens. You can choose to:

• Export composite requirements as headings and subheadings, or
• Export composite requirements as table rows – you can additionally select which

properties to export in this mode, by selecting or deselecting the checkboxes to the left
of the list, and the titles of table columns by editing the text in the Table Header column.

7. Click OK to begin the export. The requirements are written to the document. Each
requirement is placed between a [PDRQM] tag with a unique ID to indicate its start, and a
[/PDRQM] tag to indicate its end:

The RQM and the Word document are automatically linked, and the Word file is attached
to the model (or the package), in the Files folder in the Browser:
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Inserting an RQM into an Existing Word Document
You may want to insert an RQM or one of its packages into an existing Word document. This
would allow you to insert a list of requirements maintained in an RQM into a more general
project document.

The following procedure assumes you have an RQM open in the workspace, which is not
linked to an existing document. Word need not be open.

1. In PowerDesigner, select Tools > Merge with an Existing Word Document to display the
Open dialog box.

2. Navigate to the required Word file and click Open. Note that, if Word is already open, you
may need to click its blinking taskbar button.

PowerDesigner parses the document to determine its structure and then the Select a Place
in Document dialog box opens:

3. Expand the Entry points node and all its sub-nodes, and select a title beneath which you
want to insert the requirements:
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4. Click OK to begin the insertion of the RQM in the document. When the process is
complete, the RQM and the Word document are automatically linked, and the Word file is
attached to the model (or the package), in the Files folder in the Browser.

5. Double-click the Word file in the Browser tree view to open it and view the added
requirements.

Updating a Word Document Linked to an RQM
You can update a Word document linked to an RQM so that it includes any changes made in the
model.

Note: If you add graphics to a linked Word document, do not try to update the document from
the RQM, you will lose the graphics. Modify the document and then update the model from
the document.

1. In PowerDesigner, open an RQM previously linked to a Word document and make any
necessary changes.

2. Right-click the model or package entry in the Browser and select Update Word
Document. Word is launched and the document is parsed and updated.

Updating an RQM Linked to a Word Document
You can update an RQM linked to a Word document so that it includes any changes made in the
document.

1. In Word, open a document previously linked to an RQM and make any necessary changes.

Note: When editing a Word document linked to an RQM we strongly recommend that you
make visible the Field Codes (select Tools > Options, and select Field Codes in the Show
group box). Edits to an existing requirement must be made within its [PDRQM] tags, and
new requirements must be added outside of these tags.

2. Select Requirements > Create/Update a Requirements Model to open the Import
Requirements Wizard to step 3, which displays all the requirements titles in a tree format.
The titles already linked to a requirement have their check box selected and grayed. You
cannot deselect them. Any new requirements are selected but not grayed and requirements
that have been deleted are no longer visible-.

3. Select or deselect headings to import as required, and then click Finish to begin the update.
The Merge Models dialog box opens, with the structure of the modified Word document
displayed in the left panel, and the existing RQM displayed in the right panel:
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4. Review your changes and then click OK to update the RQM.

Unlinking RQMs and Word Documents
You can detach an RQM from a Word document in Word by selecting Requirements >
Detach the Document from the Requirements Model or in PowerDesigner by deleting the
Word file in the Browser.
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The requirement tags are deleted from the Word file, which is removed from the Requirement
Traceability Links tab of the model, package, and requirements property sheets.
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