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About This Manual

Subject

This book describes the creation and generation of reports in
PowerDesigner. It shows you how to do the following:

¢

L4

L4

Build and generate model reports in various languages and formats
Build and generate multi-model reports in various languages and formats

Build and generate list reports in various languages and formats

Audience

This book is for anyone who will be building reports with PowerDesigner.

Documentation primer

The PowerDesigner modeling environment supports several types of models:

¢

Conceptual Data Model (CDM) to model the overall logical structure of
a database, independent from any software or data storage structure
considerations

Physical Data Model (PDM) to model the overall physical structure of a
database, taking into account DBMS software or data storage structure
considerations

Object Oriented Model (OOM) to model a software system using an
object-oriented approach for Java or other object languages

Business Process Model (BPM) to model the means by which one or
more processes are accomplished in operating business practices

XML Model (XSM) to model the structure of an XML file using a DTD
or an XML schema

Requirements Model (RQM) to list and document the customer needs
that must be satisfied during a development process

Information Liquidity Model (ILM) to model the replication of
information from a source database to one or several remote databases
using replication engines

Free Model (FEM) to create any kind of chart diagram, in a context-free
environment
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This book only explains the creation and generation of reports in
PowerDesigner. For information on models or other aspects of
PowerDesigner, consult the following books:

General Features Guide To get familiar with the PowerDesigner interface
before learning how to use any of the models.

Conceptual Data Model User’s Guide To work with the CDM.
Physical Data Model User’s Guide To work with the PDM.
Object Oriented Model User’s Guide To work with the OOM.
Business Process Model User’s Guide To work with the BPM.
XML Model User’s Guide To work with an XSM.

Requirements Model User’s Guide To work with the RQM.
Information Liquidity Model User’s Guide To work with the ILM.

Repository User’s Guide To work in a multi-user environment using a
central repository.

Typographic conventions

PowerDesigner documentation uses specific typefaces to help you readily
identify specific items:
4 monospace text (normal and bold)

Used for: Code samples, commands, compiled functions and files,
references to variables.

Example: declare user_defined..., the BeforeInsertTrigger
template.

¢ bold text
Any new term.

Example: A shortcut has a target object.

¢ SMALL CAPS
Any key name.

Example: Press the ENTER key.



CHAPTER 1

Creating Model and Multi-Model Reports

About this chapter This chapter describes the basics of creating model and multi-model reports
in PowerDesigner.

Contents Topic: page
Introduction to PowerDesigner Model Reports 2
Creating a Model Report 3

Creating a Multi-Model Report 14



Introduction to PowerDesigner Model Reports

Introduction to PowerDesigner Model Reports

A report allows you to publish information about your model, and can be
used to provide documentation for your system. You can create either:

¢ A model report — documents the contents of a model, listing all or a
selection of its objects, and showing how they are associated with one
another. Listed in the browser within the Reports folder beneath its parent
model, and saved with the model. See “Creating a Model Report” on
page 3.

¢ A multi-model report — documents one or more models, and can help
you to see, for example, to which table in a physical data model (PDM)
an entity in a conceptual data model (CDM) corresponds. Listed in the
browser as a top-level object, and saved as a .mmr file. See “Creating a
Multi-Model Report” on page 14.

PowerDesigner also lets you create list reports, which focus on a single type
of object within a model. For more information, see the “Creating List
Reports” chapter.
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Creating a Model Report

There are two steps to creating a PowerDesigner model report:

¢ Define the contents and format of the report - PowerDesigner provides
a variety of ways to define model reports:
¢ Standard Report Templates — to generate a model report directly,
without any configuration. See “Creating a report with a standard
template” on page 3.

¢ The Report Wizard — to easily control the generation of a model
report with minimal intervention. See “Creating a report with the
Report Wizard” on page 4.

¢ The Report Editor — to have full control over the content and format
of your reports. See “Creating a report with the Report Editor” on
page 11.

¢ Generate the report — PowerDesigner supports generating reports in
HTML or RTF, or will print them directly. See “Generating a model
report” on page 12

You can combine these methods as necessary. For example, you could create
an initial report with a standard template, refine your selection of objects
with the wizard, and then fine-tune formatting in the editor.

The following sections describe the various ways in which you can create a
model report.

Creating a report with a standard template

The easiest way to create a model report without any configuration is to use
one of the standard model report templates. These allow you to generate a
report directly in HTML or RTF format, without specifying objects or
formats.

The following standard templates are available:

¢ Full <Model Type> Report — provides lists of all the types of objects in
the model, together with detailed information on each object.

¢ List <Model Type> Report — provides lists of all the types of objects in
the model.

+ Standard <Model Type> Report — provides lists of all the types of
objects in the model, together with detailed information on each of the
main objects.



Creating a Model Report

These templates are available in the Generate Report window. To generate a
report using a standard template, see “Generating a model report” on
page 12.

Creating a report with the Report Wizard

The Report Wizard is an easy way to select which objects will appear in
your report, and to control their formatting.

You can complete as much of the Wizard as you want. At each step, you
click Next to advance to the next stage, or Finish to exit the wizard and
create a report based on your selections so far.

The Report wizard can be launched from your model, to create a new report,
or from the Report Editor window of an existing report.

% To create a report using the Report Creation Wizard

1. Select Report » Report Wizard (or select Report » Reports, and then
click the Report Wizard tool) to launch the wizard:

Report Creation Wizard

“welcome to the Report Creation ‘wizard. Thig wizard helps pou to publish
a report on your madel.

Welcome
Provide a name for wour report:

Presentation Options |Executable BPM repart

Select a language for the titles of report iters:

Feport Structure —
K French j |EI

Package Options

Feport Layout

End

< Back I Mest > I Finizh | Cancel | Help |

2. The Welcome page allows you to specify a name for the report and the
language in which you want its titles to appear. Note that this page is not
displayed if you launch the wizard from the Report Editor.

When you are satisfied, click Next:
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Report Creation Wizard

Select the format for your report:

Welcome = HTHL, for publizhing your report on the internet or intranet

& ATF, for publishing your report in a Rich Text Format fils

Presentation Dptions " Local, for printing the repart directly from its editor

Feport Structure
Select a presentation template for your report:

Package Options Professianal j |EI
Feport Layout
End

< Back I Mext > I Finizh | Cancel | Help |

3. The Presentation Options page allows you to specify a format for your
report. You can choose between:
¢ HTML, for publishing your report on the internet or intranet —
you can additionally select, and preview, a presentation template using
the tools to the right of the template field.

¢ RTF, for publishing your report in a Rich Text Format file — you
can additionally select, preview, and edit, a presentation template using
the tools to the right of the template field.

¢ Local, for printing the report directly from its editor.

When you are satisfied, click Next:
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Choosge what information you want to see in your report,
Fieport Structure The preview pane on the left hand-side shows your choices in
a sample repart.
Table of Contents — ¥ Irtroduction section
1'1l_qt[[0)g§g::3[;on IV Introduction text Define... |
1.2 Card of model -
2. Short model description ¥ Modsl propetties
2.1 Diagram 1
2.2 List of objects ¥ Short description section
2.3 List of links . :
3. Full model description ¥ Display diagrams
3.1 Diagram 1 v List ohiect
3.2 Objects F' List objects
3.2.1 List of object
322 Dlzieocto‘] =e v Full description section
3221 Card of Object 1 2 .
323 Object 2 . V¥ Dizplay diagrams
3231 Card of Object 2 [¥ List objects before full description
33Llinks
3.3.1 List oflinks ¥ Obijscts detailed description
3.3.2 Link 1

3.3.21 Card of Link 1

I™" iList objects diagram by diagram

< Back I Mest > I Finizh | Cancel | Help |

4. The Report Structure page allows you to specify the kinds of information
that will appear in your report. The preview pane on the left hand-side
displays a sample report that changes dynamically according to your
selections. You can select any or all of the following options:
¢ Introduction section — specifies an introduction sub-heading,

preceded by a page break. Makes available the following sub-options:

¢ Introduction text - Text paragraph. Click the Define button to open
an editor.
¢ Model properties - Model card
¢ Short description section — specifies a short description section
sub-heading, preceded by a page break. Makes available the following
sub-options:
¢ Display diagrams - [not for RQM] Diagram book, Graphics,
Diagram description, Diagram annotation
¢ List objects - List item for each object type in the model
¢ Full description section — specifies a full description section
sub-heading, preceded by a page break. Makes available the following
sub-options:
¢ Display diagrams - [not for RQM] Diagram book, Graphics,
Diagram description, Diagram annotation
¢ List objects before full description - Title item and list item for
each object type
e Objects detailed description - Book item for each object type
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*

List objects diagram by diagram - [not for RQM] Diagram book -
Instead of a flat display of object types, it allows you to display objects
sorted by diagram in which they are displayed. Global objects, such as
business rules for example do not belong to a diagram but to the whole
model, and therefore are listed under a specific Title book.

When you are satisfied, click Next:

Report Creation Wizard
“Your model iz decompozed inta packages.
Package Optians “r'ou can build a repart on the entire model or on selected

objects belonging to a specific package:

Table of Contents ﬁgﬂ egistry j

1. Root Object 1

2, HU_Ut Dbll_?Ct 2 Choosze how you want to organize wour report items:

3. Object 1 in Package

4. Object 2 in Package & ‘without packages, all objects are described at the
. Object 1 in Sub-Package zame level

E. Object 2 in Sub-Package
One zection per package, objects are described under
their package

Hierarchical sections, each sub-package iz a
sub-gection in the document

The preview pane on the left hand-side shows your choices in a
zample report containing packages.

< Back I Mest » I Finigh | Cancel | Help |

5. The Package Options page is displayed only if your model contains
packages, and allows you to control the treatment of packages within the
report. The preview pane (on the left hand-side) changes dynamically in
order to preview your selection. You can select whether to base the report
on the entire model or on a sub-package, and then choose between the
following options:

¢

Without packages, all objects are described at the same level [not
available for HTML or an RQM] — Lists all the objects together on the
top level, whether or not they belong to a package.

One section per package, objects are described under their
package [not available for HTML or an RQM] — Groups objects by the
package to which they belong.

Hierarchical sections, each sub-package is a sub-section in the
document - Groups objects by the package to which they belong, and
groups packages beneath their parents to recreate the package
hierarchy.

Note that:
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¢ Global objects (such as business rules) are always included, even when
you select a package.

¢ Composite objects (such as activities, or processes in an OOM) are
always displayed in an Hierarchy, even if you have selected a different
package option.

When you are satisfied, click Next:

Report Creation Wizard

“ou can now customize the layout of report items.
“ou can choose which types of objects will appear, and the order in which
Welcome they will appear.
“fou can alzo specify which attributes to display for each twpe of object in
the ligt and card lapouts.
Presertation Options Select an object type: Configure the layout:
3 .
Feport Structure B3 List Lapout | Card Layout I
Aftibute Name | D | ‘Width | =]
) Shart D escriptin: [v 100 3%
Package Options Bk =
Object Type [ 50 mm
Report Layout Creation Date [~ 50 mm
[ 50mm
< Desision [ 50 mm
End = —
= Flow L 50 mm
Class Name 50 mm
Object Location: [~ 50 mm
Stereatype [ 50 mm =
Model [ 20mm 2
| nral Warahle ST 520 mm 1=
4| [ 5 S S K W

< Back I Mest > I Finizh | Cancel | Help |

6. The Report layout page allows you to select the types of object to include
in the report and to configure the layout of the object lists and cards.

To specify the inclusion of an object type, select its checkbox in the list.
The list includes only those objects that are present in the selected model
or package. Click on the plus sign to the left of an object to reveal and
select or deselect its sub-objects.

Stereotypes used as metaclass display in the list of object types, below
those of their parent object. See “Use as metaclass stereotype” below.

The Select All and Deselect All tools are available above the list. You
must select at least one object type to proceed with the wizard. The Move
Up and Move Down tools allow you to promote or demote the position of
an object (though child object types cannot be moved beyond the scope
of their parents.

7. Select an object type in the object type list, and the click the List Layout
or Card Layout tab in the right-hand pane to configure its display. These
tabs list the object attributes that can be displayed in the report. The
following parameters are available:
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¢ Attribute Name — You can use the arrows at the bottom of the list to
promote or demote the attribute in the list

¢ Dlisplayed] — Select the checkbox to enable the display of the attribute
¢ Width [List Layout only] — Each attribute selected for display will be a

column in the list. Use this parameter to specify the width of the
column either as a percentage or in millimeters.

8. When you are satisfied, click Next:

Report Creation Wizard

Congratulations, vour repart is now ready to be published |

‘wielcome *Y'ou can now preview the whale report:

Prezentation Options
*f'ou can chooze what to do when you click Finish:

Feport Structure V¥ Open the repart in the Report Editor to fine-tune mare options.
[ Directly generate or print the repart.
Package Options

Feport Layout

End

< Back | et > | Finizh I Cancel | Help |

9. The End page allows you to decide what you will do with your newly
created report. Click the Preview button to preview your report in:
¢ your Browser — for HTML reports
¢ your RTF Editor — for RTF reports
¢ the PowerDesigner preview window — for reports to be printed directly.
Before clicking Finish to complete the report creation, you can select one
or both of the following options:
¢ Open the report in the Report Editor to be able to fine-tune more

options

¢ Directly generate or print the report
When you are satisfied, click Finish to exit the wizard and create the

report.
Use as metaclass When a stereotype is defined as “Use as metaclass” in a language, DBMS or
stereotype extended model definition, it inherits the attributes of a standard metaclass.

The report wizard support metaclass stereotypes as follows :
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+ Lists metaclass stereotypes in the list of object types, below the parent
object in the Report Layout page.

+ Generates a book and a list separately for each metaclass stereotype,
below those of the parent object in the Report Editor.

For example, you create a stereotype “used as metaclass” (called metaclass
stereotype) in the process language associated with a BPM, then you
associate the metaclass stereotype to a process in the diagram and launch the
Report Wizard. The metaclass stereotype is listed in the object type list
below the parent object in the Report Layout page. Its associated extended
attributes if any, are listed in the List Layout and Card Layout tabs.

Report Creation Wizard

Welcome

Prezentation Options

Report Structure

Report Layout

End

they will appear.

Yol can also specify which attibutes to display for eaqu twpe of object in

the fist and card lapouts.,

Select an object type:

By o &

‘You can how customize the layout of report items.
‘Yo can choose which types of objects will appear, and the order in which

Configure the lapout:

List Layeut | Card Layout I

e c& Organization Lt
- ?‘ Role Azsociation
{wd] Process

~fIEC BinaryCollaboration
~Iw[BT] BusinessTranzaction
Vjﬁﬂ MultiPartyCollaboratior
' metaclass sterentype

Attibute Mame | D [ width| =
Marme v 332
[V 33%
arent Organization i 33
Pareni Tor20m

Diizplay Mame

-] @ Start
-¥®) End
~{]—* Flow

4

Creatar

hodiication Ciate

W odifier

M odificati

| >

M ame: R rpm
A ARARAE JESE] I

+ Back I Mewt» I

Finizh | Cancel |

Help |

And the generated report shows the list and the book for the metaclass
stereotype below those of the parent object in the Report Editor:
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Creating a report with the Report Editor

The Report Editor gives you complete control over the content and format of
your report. You can create a blank report from the List of Reports, open it
in the Report Editor, and build it using Report Items.

% To create a report with the Report Editor

1. Select Report » Reports to open the List of Reports, which shows an
alphabetical list of all reports saved in the model.

2. Click the New Report tool to open the New Report dialog box:
i New Report
Report name:
Language: IEninsh j |§I
Repart ternplate: |<N|:|ne> j |EI
lTl Cancel | Help |

3. Enter a report name, and select a language for the report’s titles from the
list.

11
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4. [optional ] Select a report template from the list.
5. Click OK to create the report and open it in the Report Editor. For more

information, see the Using the Report Editor chapter.

Generating a model report

The Generate Report window also allows you to access the standard report
templates, or templates or reports that you have previously created, and to
generate them in HTML or RTF format, or to print them directly.

% To generate a model report

1. Select Report » Generate Report to open the Generate Report window.

=

— [aenerate repart

¢ Feport kemplate = Model report

Ligt Object Report
Standard Object Report

— Generation action
% Generate HTML " Print repart
" Generate ATF = Print presiew

File name: Il:: W pProjectzib odels\Full Object Report. bt

0K I Cancel | Help |

2. Select a Generate report option. You can choose from the following
options:
¢ Report template — PowerDesigner provides standard report templates
to select the objects to include in your report and to provide formatting.
You can also create your own templates. You can select an alternative
folder to look for additional templates by clicking the Browse button to
the right of the radio button.

¢ Model report — lists any reports that you have previously created in the
model.

3. Select the appropriate template or report from the list.

4. Select a Generation action. You can choose from the following options:

12
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¢ Generate HTML — Generates a frameset named after the File name
field, together with a folder containing the necessary HTML and GIF
files. For example MyReport.html would have an associated folder
called MyReport_files.

¢ Generate RTF - Generates a Rich Text Format file named after the File
name field.

¢ Print report — Opens the Windows Print window to allow you to
directly print the report.

¢ Print preview — opens the print preview window, from which you can
choose to print the report, or to generate it as HTML or RTF.

5. [for HTML or RTF only] Specify a file name for the generated file. You
can select a new path with the Browse tool to the right of the field.

6. Click OK to begin the generation. The Generation action specified above
will be performed.

Quick report generation from the Browser

If you want to quickly generate a report that you have already defined, and
which is visible in the Browser, right-click its Browser entry, and select
Print, Generate » RTF, or Generate » HTML from the contextual menu.

13



Creating a Multi-Model Report

Creating a Multi-Model Report

A multi-model report is a report that documents one or more models. To
create such a report, you must have at least one model open in the
workspace. You can add additional models at any time after the creation of
your report.

% To create a multi-model report

1. Select File » New to open the New dialog box:

New 1]

Mode type: 2 ' Mew model " New model from template

@ Business Process Model General |
B Conceptual Diata Model
&Free hodel Report name: IMullirModel Repart 1

£ Information Liquidity Madel . - =
‘Ml Model Report LR [Englch ==l
(St Dbject-Oriented Madel First section
%;:ﬁi:ﬂz:: mz:z: Madel name: IEusmess Inteligence - D:4Program Fllas\Sybas(j
@XML fdadel Model type: IF’hysicaI Drata kModel
Repart template: |<Nune> d @

Ok I Cancel | Help |

2. Select Multi-Model Report in the left-hand pane (this option is only
available if you have a model open in the workspace).

3. Enter a name for the report in the Report Name field.

4. Select a language for the report from the Language list.
=" For more information about languages in reports, see the “Using the
Report Language Editor” chapter.

5. Select a model as the basis for the first section of the report from the
Model Name list.

6. [optional] Select a standard template (see “Creating a report with a
standard template” on page 3) from the Report Template list.

Template languages

When you use a template in a language different from the one specified
for the report, only user-defined items such as Title or Text paragraph

will retain the language of the template. Other items will be displayed
in the report language.

14
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7. Click OK to create the multi-model report.

The report opens in the Report Editor, and is added to the Browser:

=] =l ulti-Model Report. Multi-Model Report 1
EI Workspace E bleitems  Show All ltems [ [Repart items
[T Physical Data Model 1 wailable iems - @ 00 List
; Conceptual D ata Model ]| Table of contents : Table of contents
S Object-Oriented Model 1 - Title Page break.
----- Text paragraph [ Title - O0M Graphs
B Text fie B Title - Lists
Graphic file

U3 Package
(7] Model Card

EI Local Ii Heposiloryl »

8. Select File » Save to save your report.

=g Page break
Diagram Graphics

Madel Description
Maodel Annotation

=[50 oom List PO st COM List

Quick multi-model report generation from the Browser

If you want to quickly generate a multi-model report from an existing
one without modifying it, right-click a multi-model report node in the
Browser and select Print or Generate » RTF or Generate » HTML.

Adding a second model to a Multi-Model Report

It is perfectly acceptable to create a multi-model report that contains only
one model, but in the majority of cases, you will want to add additional
models.

Each model in the report belongs to a separate “section”, which can be
accessed via the tabs at the bottom of the Report Editor window. For more
information about sections, see “Report Sections” in the Using the Report
Editor chapter.

You can only add models that are currently open in the workspace to the
report. However, once a model has been added, you can edit the report even
if the source model has been closed.

% To add an additional model to a multi-model report

1. Open the multi-model report, and select Report » Report properties to
open its property sheet.

Click the Sections tab, and click the Add a Row tool.
3. In the Model column, select the model you want to add from the list.

In the Sections column, enter the name that you want the model to have
in the Report Editor.

15
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5. Click OK to return to the Report Editor, open to the new model section

Configuring a multi-model report with the Report Wizard

You can use the Report Wizard to configure a multi-model report. The
wizard works on a single section at a time, and will delete any content
currently in the section.

< To configure a multi-model report section with the Report Wizard

1. Open the multi-model report, and select the section you want to work on
by clicking the appropriate tab at the bottom of the Report Editor window.

2. Click the Report Wizard tool in the Reports toolbar to launch the Report
Wizard, and follow the procedure in “Creating a report with the Report
Editor” on page 11.

Configuring a multi-model report with the Report Editor

You can use the Report Editor to configure a multi-model report. For more
information, see the Using the Report Editor chapter.

Generating a multi-model report

You can generate a multi-model report from within the Report Editor by
clicking one of the Generate <format> tools on the Reports toolbar.

Alternatively, you can right-click the multi-model report entry in the
Browser, and select Generate » <format> from the contextual menu.

16
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Creating List Reports

About this chapter This chapter describes PowerDesigner list reports and how to use them.
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Creating a List Report
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A list report documents a single object type within a model, and is displayed
as a customizable list with columns and rows that you can filter as necessary.

You can create snapshots (called result sets) of a list report to keep a history
of the execution of a list report in your model. Result sets are listed in the
browser beneath their parent list report, and are saved with the model. For
more information, see “Creating Result Sets”” on page 25.

A list report is saved in the model and can be exchanged between models of
the same type.

You can also right-click a list report in the Browser and select Generate »
Format .

You can right-click a list report in the Browser and select Preview to preview
the list report before printing. You can also right-click a list report in the
Browser and select Print without previewing the list report.

You can create a list report in any of the following ways:

# Select Report » List Report Wizard to launch the List Report Wizard.
You can complete all the steps or click the Finish button at any time after
having selected an object type for the report.

¢ Select Report » List Reports to access the List of List Reports, and click
the Add a Row tool.

¢ Right-click the model, package or object category in the Browser, and
select New » List Report.
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< To create a list report using the List Report Wizard

1. Select Report » List Report Wizard (or select Report » List Reports and
click the List Report Wizard tool in the toolbar) to launch the Wizard:

List Report Wizard : Introduction [Step 1/5]

Welcome to the List Report Wizard, This wizard helps you create a list repart far an object type.
Select the object type you want ta list in the repart.

Object type:

Select the model or package.

ID Process

|

todel or package: |EHecutahIe BFM

Include shortouts: v

Include sub-packages: v

< Back |

Mext > | Finish | Cancel | Help |

2. The Introduction page allows you to specify an object type for the list
report. You can also select whether to base the list report on the model or
on a package, and whether to include shortcuts and objects in

sub-packages.

When you are satisfied, click Next:

List Report Wizard : Column Filter [Step 2/5]

‘f'ou can choose which properties will appear and the order in which they will appear.

] 5y MName
¥ 5y Code

{5y Parent

-] By Object Tpe

-] %y Creation D ate
{1 %y Creator

-] %y Modification D ate
-1 %y Modifier

-] By Clasz Mame

- 1%y Shart Description
-] By Object Location
-] By Annatation Test
-] %y Description Text
{5y Comment

-] %y Generation Origin
-] By Stersotype

Colurmn Heading -

|»

1 M ame

2 Code

=
[14 ] ]« |

Fltlel+]$[2]4]

Finish | Cancel | Help |
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3. The Column Filter page allows you to specify which of the object’s

properties will be included in the list report. Select a property in the
left-hand pane to add it to the list in the right-hand pane. You can promote
or demote properties in the list using the arrows at the bottom of the pane.

When you are satisfied, click Next:
List Report Wizard - Bow Filter [Step 3/5]

*Y'ou can chooze properties and specify expressions by which ta filker the list.
Select the column 5 to specify one or more properties by which to sort the list.

] %y Object Location ;I Aftribute hd Ewpression =)
-] Sy Annatation Text 1 Mame &
-~ ] %y Description Text = |Code “CODE

] Ty Stereotype

-] D efault Diagram

-] 5y Model

~{] %y Composite

FH-{1 B Implementer

-]y Reusable Process

#-{] § Output Comrelation b

#-{] F Input Carelation Ke

-] %y Message Mapping

{1 %y Received Message
-] s Outout messaae miZ

d .-

~{] %y Comment 3 Stersotype
-~ ] %y Generation Origin

*

IR

gl N L O

F]#|e|*|E[2]4]

< Back I Mest > I Finizh | Cancel | Help I

4. The Row Filter page allows you specify filters to restrict the objects that

will be included in the list report. Select a property in the left-hand pane
to add it to the list in the right-hand pane and then enter an expression to
filter by. You can specify to sort the list on the values of a property by
selecting the S[ort] checkbox. For more information about filter
expressions, see “Defining a filter on a list” in the “Using the
PowerDesigner Interface” chapter in the General Features Guide .

When you are satisfied, click Next:
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List Report Wizard : Content Preview [Step 4/5]

This preview displays the content of your list repaort.

REN - Code 1=
3 Send request for item t: Send_request_for_item_to_be_d
4 Send email to custome: Send_email_to_customer
15 Send email to acknowl:Send_email_to_acknowledge_or

4

i CY KN

| »

< Back I Mest » I Finish | Cancel |

Help |

5. The Content Preview page allows you to visualize the results of your
choices so far. To alter the definition click the Back button. Otherwise,

click Next:

List Report Wizard : End [Step 5/9]
Congratulations, you have created a list report!

Tupe aname, a code and a comment for the list report in order ko identify and describe it.

T

MName: IProcess_List_F! eport
LCode: |PF|DCESS_LIST_F|EPDF|T
Commert:

& ML

v Generate the list report to an external file
File format: ¢ CSY " RTF  HTML

< Back I

Hews> | Fiish |

Cancel I

Help |

6. The End page allows you to specify a name and code for the list report,
and to add a comment. You can also specify whether to generate the

report to an external file.
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Click Finish to exit the wizard. If you have selected to generate the report
to an external file, you will be asked to specify a file name.

The list report is added to the model and listed in the Browser under the
List reports folder
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List Report Properties

You can modify an object’s properties from its property sheet. To open a list
report property sheet, double-click its Browser entry in the List Reports
folder or in the List of List Reports. By default, the property sheet of a list
report always opens on the Content tab. The following sections detail the
property sheet tabs that contain the properties most commonly entered for

list reports.

List report property sheet General tab

The General tab contains the following properties:

Property Description

Name Specifies the name of the list report.

Code Specifies the code of the list report.

Comment Descriptive comment for the object.

Object type Specifies the type of the object the list report will be based
on. You must select an object type to have any content in
your list report.

Model or Specifies the model or package from which the objects will

Package be drawn. Package selection is unavailable for global objects

Include short-
cuts

Include sub-
packages

such as users.

Specifies whether the list report includes shortcuts.

Specifies whether the list report includes sub-packages. This
option is unavailable for global objects such as users.

List report property sheet Column Filter tab

The Column Filter tab lists the columns that are included in the list report.
Select a property in the left-hand pane to add it to the list in the right-hand
pane. You can promote or demote properties in the list using the arrows at
the bottom of the pane.

List report property sheet Row Filter tab

The Row Filter tab lists the filters that restrict the rows included in the list
report. Select a property in the left-hand pane to add it to the list in the
right-hand pane and then enter an expression to filter by. You can specify to
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sort the list on the values of a property by selecting the S[ort] checkbox. For
more information about filter expressions, see “Defining a filter on a list” in
the “Using the PowerDesigner Interface” chapter in the General Features
Guide .

List report property sheet Content tab

The Content tab displays the current values for the list report. Properties
selected in the Column Filter tab are displayed as column headings and
property values in rows must satisfy filter expressions defined in the Row
Filter tab.

You can open the property sheet of any object included in the list report by
clicking the Properties tool.

Note that data displayed in the Content tab does not dynamically change
when you perform a change to your model that may affect your list report.
To update the Content tab, you must click the Refresh List Report tool.

You can use any of the generation tools in the toolbar to generate the list
report content into a CSV, an RTF, an HTML, or an XML format.

List report property sheet Result Sets tab

24

The Result Sets tab lists the result sets stored for the list report. For more
information, see “Creating Result Sets” on page 25.

You can use any of the generation tools in the toolbar to generate a list report
result set into a CSV, an RTF, an HTML, or an XML format.
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Creating Result Sets

A result list is a snapshot of the content of a list report at a given system date
and time. You can create as many result sets as you want for the same list
report, in order to keep a history of a given list report for future reference.

Result sets are stored within the model and display under the list report to
which they are related in the Browser:

You can use the Comment box in the result set property sheet to identify a
result set.

Creating a result set

You can create a result set in any of the following ways:

# Open the property sheet of a list report, click the Result Sets tab, and then
click the Create Result Set tool.

¢ Right-click a list report in the Browser and select New » List Report
Result Set from the contextual menu.

Result Set Properties

You can modify an object’s properties from its property sheet. To open a
result set property sheet, double-click its Browser entry in the List Reports
folder just beneath the list report to which it applies. The following sections
detail the property sheet tabs that contain the properties most commonly
entered for result sets.

Result set property sheet General tab

The General tab contains the following properties:

Property Description

List Report | Name of the list report to which the result set applies.
Report Date | Date and time when the result set was created.

Comment Descriptive comment for the result set that allows you to
identify it.
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Result set property sheet Content tab

The Content tab shows the contents of the result set.

You can use any of the generation tools in the toolbar to generate the result
set as an external file in CSV, RTF, HTML, or XML format.
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Generating a List Report
You can generate a list report as an external file in CSV, RTF, HTML, or
XML format in any of the following ways:

# Right-click the list report in the Browser and select Generate » Format
in the contextual menu

¢ Open the property sheet of the list report, select the Content tab, and click
the Generation Format tool

+ .Select Report » Generate List Report to open the Generate List Report
dialog box.

You can right-click a result set in the Browser and select Preview to preview
the result set before printing. You can also right-click a result set in the
Browser and select Print without previewing the result set.
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It can be useful to exchange list report files between models of the same
type. For example, you may want to compare the properties of a certain
subset of classes in two OOMs.

You export and import list report files from the List of List Reports. A list
report file has a .LRT extension.

To export a list report

1.
2.

Select Report » List Reports to open the List of List Reports.

Select the list report to export in the list and click the Export List Report
in File tool.
Select a location and file name in the Save As dialog box, and click Save.

The list report is saved with an .LRT extension and can be imported to
another model as needed.

To import a list report

1.
2.

Select Report » List Reports to open the List of List Reports.
Click the Import List Report from File tool.

In the Open dialog box, browse to the location of the .LRT file to be
imported, and click Open.

The list report is displayed in the List of List Reports.
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Using the Report Editor

About this chapter This chapter describes how to manage reports for a model report or a
multi-model report.
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Introduction to the Report Editor

Introduction to the Report Editor

You can edit model reports, multi-model reports, a,nd report templates in the
Report Editor. It displays the structure of the report or template as a tree

view.

The Report Editor window contains two panes:

¢ The Available Items pane (left pane), from which you can select items to

include in the report.

¢ The Report Items pane (right pane), in which you add the items that
compose your report. It can also be filled with the items of a template that
you select at the creation of your report.

e ]
orkspace

-4 Physical Data Model 1

. Conceptual D ata Model

-84 Object-Oriented Model 1

: Wult-odel Report 1

ki |
£

[+

[

2l |

SI Lacal Ii Hepositoryl

By default, the Available Items pane displays only the report items that
correspond to objects that exist in the current model. For example a database
package (which is an Oracle specific object) is not displayed in the Report

& Multi-Model Report. Multi-Model Report 1

wailable items

Show Al Items [~

Fepart items

Available iterns
Table of contents
Title

----- ] Test paragraph
{5 Text file
Graphic file

..... = Page break
Diagram Graphics

l_lJ Package
-[] Model Card

Model Annotation

----- Madel Description
B

| [l 0OM List

=] Table of contents
=

Page break
- Title - OO Graphs
- Title - Lists

x| [EIEI\ oom List APDM Lst ), COM Lt/

Editor with a model for Sybase ASE.

You can select the Show All Items check box at the top of the Available

Items pane to display all available report items, even if they do not
correspond to any object in the current model.

By default, in the Multi-Model Report Editor, all available report items are

displayed if the associated model is not open in the workspace.

Displaying the Report toolbar

The Report toolbar provides quick access to the most commonly used
commands for report management.
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% To display the Report toolbar

1. Select Tools » Customize Toolbars to display the Toolbars dialog box.

2. Select the Report check box to display the Report toolbar, and then click
Close.

=" For more information about managing toolbars, see “Managing
toolbars” in the “Using the PowerDesigner Interface” chapter in the
PowerDesigner General Features Guide .

The following table lists the tools in the Report toolbar:

Tool Description

M Report Wizard - Displays the Report Creation Wizard.

53

Print Preview - Displays a report print preview.

|

Print - Prints a report.

| Generate RTF - Generates a report as an RTF file.

| Generate HTML - Generates a report as an HTML file.

i

Add Item - Adds an item to the Report Items pane.

|i

Up One Level - Moves item up one level.

Down One Level - Moves item down one level.

E =

Raise Level - Moves item at the same level as the book item (item
that contains other items) that precedes.

Lower Level - Moves item within the book item that follows.

|
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Using Report ltems

In the Report Editor, whichever model you are working with, the Available
Items pane (left pane) always displays the following items in the same order:

Report item Description

Independent Customizable items that allow you to structure your report
items (for example, a table of contents, a title or a page break)
Model- Contain information about a model or a package (for

dependent items | example, a card, a list of attached rules or a description)

Object lists Contain tables listing objects from a model or a package
(for example, for an Information Liquidity Model (ILM),
can be the list of servers, list of replication processes,
etc.)

Books Expandable object folders that contain dependent items
(for example, for an ILM, the Server book item contains
detailed properties for the server object)

Object- Detailed properties of a specific object type. Can only
dependent items | appear under an object folder (book item)

The following illustration shows how the Available Items pane looks like in
a report for an Information Liquidity Model (ILM):
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A#| InformationLiquidityModel_1. Report - Report ilm

vailable items Show All ltems W
|| K@) Section_1
=] Table of contents
---- Title:
..... E Text paragraph Independent ikem
&b Teutfile
Graphical file
----- = Page break

Model Card
List of Model Extended Attributes
----- =] Model Description

----- =] Model Arnotation

----- =] Model Code Preview Model-dependeant item
Ligt of Agzzociated Requirements of Model
List of Model Extended Collections

List of Model Attached Rules

Lizt of Model Extended Dependencies
Lizt of Model Calculated Collections

Lizt of Generated Objects of Model

Lizt of Generation Source Objects of Model
Ligt of Diagrams

Ligt of Packages

List of Business Rules

Lizt of Databazes

Lizt of =ML Documents

Lizst of Replication Processes Object list
List of Transformation Processes
List of Data Connections

List of Process Connections

List of Servers

Lizt of Extended Objects

Lizt of Extended Links |
Lizt of Files

Lizt of Replications
Diagram B ook
Graphics

Object-dependent item

Adding items to a report

You can add an item to the Report Items pane in any of the following ways:

¢ Double-click the item in the Available Items pane to place it below the
currently selected item in the Report Items pane

¢ Drag the item from the Available Items pane and drop it at the desired
position in the Report Items pane. If the pointer becomes a barred circle,
that means the drop target is unauthorized. Note that you can drag and
drop an item only when the Report Items pane already contains at least
one item.
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¢ Right-click the item in the Available Items pane and select Add from the
contextual menu

When you add an item to the Report Items pane, the item remains in the
Available Items pane. You can insert the same item several times in the same
report contents.

Notes:

¢ Table of contents - When you insert a table of contents in a report, you do
not need to have it followed by a page break because PowerDesigner
automatically provides one.

¢ Multi-selection - Press cTRL while selecting items with the Pointer tool,
or use the SHIFT key to select a continuous list of items.

¢ Book item - When you add a book item to a report, you automatically add
its dependent items. You can delete any that you do not need.

¢ Package and composite object hierarchy - When you add a package or
composite object book item to a report, you can select the Hierarchical
Display command in the item contextual menu to display the package or
composite object hierarchy in the generated report. You do not need to
use this command when you generate for an HTML report, as HTML
reports always provide a hierarchical display.

¢ When you drag an item in the Report Items pane, you must choose a drop
position. A box or a line is displayed, it indicates where the drop will
occur. You can only drop the item when the barred circle becomes a
pointer again.

¢ While you drag an item over a book item - If a line is displayed, drop
positions the item at the line and if a box around the book item is
displayed, drop positions the item last in the book item.

¢ If you want to add an item at the same level as a book item, press the ALT
key while you drag and drop the item.

¢ While you drag an item over another item - If a line is displayed, drop
positions the item at the line and if a box around the item is displayed,
drop positions the item immediately after the item surrounded by the box.

¢ Drag and drop between reports - You can drag and drop items between
reports of the same type. If you simply drag and drop an item from one
report to another without pressing any key, you move the item from one
report to another. You can copy an item by pressing the cTRL key while
dragging and dropping it. The report in which you want to drop the item
must already contain at least one item.
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Independent items

Independent items do not contain information about specific models or
objects. They can appear anywhere in a report. You can customize them to
structure your report.

You can insert the following independent items anywhere in the report:

Icon Item Generated result
=1 Table of con- Complete report table of contents
tents

@ Title Free text to introduce what is next. Double-click
the item after adding it to launch an editor window
to enter content.

a Text para- Paragraph of free text. Double-click the item after

graph adding it to launch an editor window to enter

content.

= Text file Contents of a text file. When you add a text file a
file chooser opens to allow you to select the file.

= Page break Prints next item on the following page. For a
report generated as an RTF file, a page break is
inserted at the position you place the page break
icon. However, when you use the icon to insert a
page break in an HTML file, you need to right-click
the icon and select Generate in HTML.

& Graphics Graph of model (or package if under a Package
folder)

& Graphical file Contents of a graphical file. When you add a
graphical file a file chooser opens to allow you to
select the file.

Model-dependent items

Model-dependent items provide information about a model or a package. If
you insert a model-dependent item under a package book, the item contains
information related to the package.

You cannot insert model-dependent items into object book items.

The following table lists model-dependent items:
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Icon ltem Content
= Card List of properties of the model or package
E | Description Text paragraph describing the model or package
E | Annotation Text paragraph annotating the model or package

E | Code preview Text paragraph displaying the generated code of
the model that is available in the Preview tab of the
model property sheet

EH Object list Table that lists all objects of a given type in the
model

Object-dependent items

Book items provide information about objects in the model. These items
have a restricted set of dependent items called object-dependent items.

You can delete and change the order of object-dependent items in the Report
Items pane. You cannot insert object-dependent items into object books of a
different type.

For example, in the following report structure, the book item Class precedes
its object dependent items:

=4 Class
Clazz card

] Class description
Clazs annotation

=] Class attributes list

Clazs attributes
Class methods list

{8 Class methods

The report generator prints object-dependent items once for each book item.
If an item does not have information for a particular object, it does not
appear in the resulting report.

For example if a domain does not have any associated rules or check
parameters, the domain description prints directly after the domain card.

All book items have the following object-dependent items:
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Icon ltem Content
= Card List of properties of the object
E | Description Text paragraph describing the object
E | Annotation Text paragraph annotating the object

In addition to the items mentioned above, each book item has dependent
items related to the object type. For example, a business rule book item has a
dependent item for server expression.

Moving items in the Report Items pane

You can change the order of items by dragging and dropping them in the
Report Items pane.

A book item (such as a title, package, object and object-dependent item) is
an item that can contain other items. When you drag a book item, you also
drag its dependent items.

Items can be positioned at the same level as book items or within book items.

Note that object-dependent items that must remain below a book item.

To change the depth level of an item
1. Select an item in the Report Items pane.

2. Select Report » Raise Level or Report » Lower Level.

The item is moved to the same level as the book item that precedes it or
moved to within the book item.

Contextual menus
You can right-click any item to access its contextual menu and display the
commands that apply to it.

Copying and deleting report items

You can copy any item within the Report Items pane except for the root
folder. Any formatting applied to the copied item is preserved. When you
copy a book item, you also copy its dependent items.
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% To copy an item

1. Press cTRL while you drag an item to a second location within the Report
Items pane.

You can delete any item in the Report Items pane except for the root folder.
When you delete a book item, you also delete its dependent items.

% To delete an item from a report

1. Select an item in the Report Items pane and press DEL or right-click the
item and select Delete from the contextual menu

Modifying the title of an item

You can associate title text with items in your report. The title prints above
the item that follows in the Report Items pane. A title contains free text.

Package, object, and object-dependent items have default titles that
incorporate variable information.

The following table summarizes the different types of items to which you
can associate title text:

Item type Default title Variable syntax

Title None —

Package Package name %ITEM %

Object Object name 9%ITEM %

Object-dependent | Object name %ITEM%
%PARENT %

You can insert Title items anywhere in the Report Items pane and as often as
you want. These are independent items that you can use to organize a report
into chapters.

You can modify the title of an item using the Editor dialog box. The default
editor is NOTEPAD.EXE

The title of package, object, and object-dependent items can include the
following variables available from the Insert list:

¢ Date
¢ Time

¢ Application Name
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¢ Item

¢ Item Code

¢ Item Name

¢ Model Code

¢ Model Name
¢ Module Name
¢ Parent

¢ Parent Code

¢ Parent Name

Modify default titles using You can modify the default title of an item using a report language. To do so,
a report language you should create a copy of the report language you are currently using and
modify item titles in the Report Titles folder of the Report Language Editor.

You can also modify the default title of a column in a table using a report
language. In this case, you have to perform the title change in the Object
Attributes folder of the language editor.

< To modify the title of an item

1. Right-click an item in the Report Items pane and select Edit Title to open
the Editor dialog box.

1 Editor

¥ Show Title

Format... Inzert - 0k I Cancel I Help |
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2. Type changes to the title text.

3. [optional] Clear the Show Title check box if you do not want to show the
title of the item in the previewed or generated report.

4. Place the cursor in the text where you want to insert variable information

for object name or package name, click the Insert button, and select a
field in the list.

5. [optional] Click the Format button to open the Format dialog box, and
select the appropriate formatting.

6. Click OK to return to the Report Editor. The first line of the title is
displayed next to the item in the Report Items pane.

@ Section_1

Table of contents
-|%| Diagram Graphics
SR Package - Package °
=] Tahle of contents
“-|#| Diagram Graphics

User-Defined check box

When you type changes in the edit box, the User-Defined check box
is automatically selected as you are no longer using the default values
used in the report language resource file you selected for your report.
To revert to the default value, clear the User-Defined check box. For
more information about report language resource files, see the “Using
the Report Language Editor” chapter.

Modifying the collection of a report item

40

A collection is a list of child objects associated with a parent object. For
example, the collection of a class is the list of classes in the current model.
By default, each pre-built package, object or object-dependent item in the
Auvailable Items pane is associated with a collection.

You can create calculated collections and extended collections.

A calculated collection is a list of associated objects with a particular
semantic, these associated objects are not directly linked to the current
object in the PowerDesigner metamodel. You define a calculated collection
on an object when you want to highlight a specific aspect of that object, like
for example the sequence diagrams that display a specific operation. A
calculated collection corresponds to a dependency list in the report.

=" For more information about how to create a calculated collection, see
the “Defining a Calculated Collection in a Profile” section in the “Managing
Profiles” chapter of the Advanced User Documentation .
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Book item

List item

An extended collection is used to define an additional link between a
selected metaclass or stereotype, and another metaclass or stereotyped
metaclass. For example, to attach documents containing use case
specifications to the different packages of a model you can create an
extended collection in the package metaclass and define FileObject as the
target metaclass. An extended collection corresponds to a list of objects in
the report.

IF" For more information about how to create an extended collection, see
the “Defining an Extended Collection in a Profile” section in the “Managing
Profiles” chapter of the Advanced User Documentation .

In order to represent a collection in a report, you can change the collection
associated with a book or list item and set it to display the content of a
calculated or extended collection to document a specific aspect of the model.

Since calculated or extended collections can associate objects that are not
directly linked in the metamodel, you can drag and drop any item under any
other item in the report. There is no control over the location where you drop
report items, and you are responsible for the global consistency of items and
collections in your report.

Once you have dropped the appropriate item, you can modify its collection
and select a calculated or extended collection.

In the following example, you define on operations a calculated collection
that retrieves the diagrams where messages using a given operation are
displayed. In the report, if you want to have these diagrams displayed, you
have to insert a diagram item under the operation item and select the
calculated collection for the diagram item.

| Section_1
=4[] Class - Class ZITEMZ
IEI.‘],EJJ Clazs Operation - Operation ZITEM % of the clazs XPARENT
SR} Dviram - Diiagram 22| TEM

As aresult, the generated report displays for each operation, the diagrams
showing the messages used by this operation.

In the following example, you have stereotyped extended objects used to
complement a PDM. In order to manage the “schedule” concept and the
“event” concept, the extended objects < <event>>> have an extended
collection of extended objects < <schedule>>. To represent in the report
the list of schedules for each event, you build the following report:
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Report Wizard

,_ir_l Section_1 I/,.with filker steratype = Event
E-4L]] Extended Object - Extended object %I TEMZ

i -=] Extended Object Card - Card of extended object %I TEMX
. 'ﬁ Lizt of Extended Objects - List of extended obiecls\"

attached to extended collection Schedule

Note that if you create extended or calculated collections in your model and
use the Report Wizard to create your report, the generated report
automatically creates a list for each type of extended collection and one for
each type of calculated collection:

EI\\¢ Title - List of extended objects

ﬁ Lizt of Extendad Objects - List of extended objects

i) Page break

B A1) Extended Object - Extended object ZITEMXZ

-] Extended Object Card - Card of extended object ZITEM3

J Extended Object Description - Description of extended object ZITEMZ

- | Extended Object Annatation - Annotation of extended object ZITEM

List of Extended Object Attached Rules - List of business ules attached to the exstended object 2PARENT %

------ = Page breal

=" For more information about the Report Wizard, see the Creating a report
with the Report Wizard section in the “Creating Model and Multi-Model
Reports” chapter.

% To modify the collection of an item

1. Drag and drop the appropriate item (book or list) under the selected book
item in the Report Items pane.

2. Right-click the book or the list item and select Collection to display the
Item Collection dialog box.

3. Select a collection in the Collection list.

4. Click OK.

Making a global object selection for the report

42

You create a report to document objects in models and packages. You first
make a global selection of objects to appear in the report using the Report »
Select Objects dialog box from the Report Editor window. This selection is
saved with the report.

You can then fine-tune the object selection from individual items the Report
Items pane. For more information see the ““Refining the report object
selection” on page 45” section.

You can use the following tools in the Report Object Selection dialog box:
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Tool Name Action
£ Include Sub-Objects Displays sub-objects (like sub-process or
sub-activity) and objects contained in the
sub-packages.
= Include Sub-Objects in | Displays sub-objects (like sub-process or

E B

B E e

e

Same Namespace

Include External Short-
cuts

Select All

Deselect All

Use Graphical Selec-
tion

Move Selected Items to
Top

Move Selected Items to
Bottom

Customize Columns
and Filter

Enable/Disable Filter

sub-activity) and objects contained in the
sub-packages that use the same namespace
(with the Use Parent Namespace check
box selected).

Displays shortcuts to objects in other
models or package. Note that the model
containing the original objects must be
open for external shortcuts to be available
for selection. If both the Include Shortcuts
and Include Sub-Objects tools are enabled
in the selection list, all the shortcuts to
objects of the current package and those of
the sub-packages appear.

=" For more information about shortcuts,
see the “Managing Shortcuts” chapter in
the General Features Guide.

Selects all objects in the object type tab.

Deselects all objects in the object type tab.

Adds graphically selected objects in the
model diagram window.

Moves the selection to the top of the object
list.

Moves the selection to the bottom of the
object list.

Opens a Filter dialog box to define a filter
on the list.

Enables the filter on the list.

43



Using Report Items

Tool ‘ Name Action

E Use Filter for Selection | Selects objects based on the filter parame-
ters.

Saving object selections  In some selection lists, you can save sets of object selections in your model,
so that you can reuse them easily.

To save a selection, you have to enter a name in the Selection list at the
bottom of the dialog box then click the Save tool beside the list. The
selection is saved as part of the model file for a model report and in the
.MMR file for a multi-model report.

+ To make a global object selection for the report

1. Select Report » Select Objects from the Report Editor.

The Report Object Selection dialog box is displayed. All the objects are
selected by default, except shortcuts if any.

i Report Object Selection _ (O x|
Section: IM_I,I section j
E\:{Pmiect Managerment [F'Ej E = 2 | By ~ Oy » = A dl | V) \Elég Yﬁ

MName I Code I Parent -
W] Division DIVISION Phwzical Data Model 'Prai...
Ve Employes EMPLOYEE Phwzical Data Model 'Prai...
W Custamer CUSTOMER Phwzical Data Model 'Prai...
Ve Project PROJECT Phwzical Data Model 'Prai...
W Team TEAM Phwzical Data Model 'Prai...
W Task TASE Phwzical Data Model Proj.. =
W Material MATERIAL Phwzical Data Model 'Prai...
Ve Participate PARTICIPATE Phyzical Data Model Proj..
T.:... . e o ..._I.’

] r |\Diagrams )\Tables KReferences _}\Domains )\Llsers _;\Elusiness Rules f
Filter; | Obiject(s] zelected: ’W

Selection: Ij Al tables j @ g
oK I Cancel | Help |

2. Select a section from the Section list.

3. Select a package from the package list.

4. Select the objects to include in the report from the object list in each
object type tab.
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5. <optional> Click the Use Graphical Selection tool to automatically
select the check boxes of objects selected in the diagram.

6. <optional> Name your selection in the Selection list and click the Save
tool beside the list.

7. Click OK.

Refining the report object selection

If you need to refine the global selection of objects in your report you can
define object selections and filter criteria on the report items displayed in
the Report Items pane of the report window.

In the final report, both object selection and filter criteria are taken into
account to edit the final selection of objects of your report.

Sorting CRUD matrix items

You can use object selections and filter criteria to sort rows and columns
in a CRUD matrix table using the Row Selection and Column Selection
commands in the CRUD matrix contextual menu in the Report Items pane.

Defining an object selection for a selected report item

When you call the Select Objects dialog box from a report item in the Report
Items pane, you can select instances of objects and order them in the printed
report.

Note: the Select Objects dialog box only displays instances of object
selected at the global level, in the Report Object Selection dialog box. For
more information about the global selection, see the “““Making a global
object selection for the report” on page 42” section.

To order selected objects, use the arrows in the lower left corner. You can
also automatically sort objects alphabetically in ascending or descending
order by clicking a column header. You have to click OK to commit the
selection in the report.

If you click the Switch to Criterion button you display the Define Sort and
Filter dialog box and you do not commit the selection of ordered objects.
+ To define an object selection for a selected report item

1. Right-click a book or a model-dependent list item in the Report Items
pane and select Selection.

or
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(Matrix items only) Right-click a matrix item in the Report Items pane
and select Row Selection or Column Selection.

The Define Sort and Filter dialog box is displayed.

2. Click the Switch to Criterion button in the lower left corner of the dialog
box to display the Select Objects dialog box.

Select Objects _ O] x|
I@Tutorial j =] | - G- VW Ez
Marme | Code |
WD Record order request Record_order_reguest
[WIDD Check item availabity in stock  Check_item_availabity_in_stock
Wi Check credit card details Check_credit_card_details
WD Send email to customer Send_email_to_customer
Wi Email notice of unavailability Email_notice_of_unavailability

Wi Send email to acknowledge or... Send_email_to_acknowledge_order
[WITD Dispatch item Dispatch_item
WD Send request for item to be de...  Send_request_for_tem_to_be_deli...

E\Processes /
T4+ ¥ % Object(s) selected: 8/8

Cancel | Help |

Switch ta Criterion |

The list displays objects selected in the Report Object Selection dialog
box.

3. Select or clear the check box beside objects you want to display or
remove from the report.

4. Use the arrows in the lower left corner to define a display order for the
objects.

5. Click OK.

Hierarchical Display command

If you define a selection of ordered objects on a package for which you also
select the Hierarchical Display command, objects in the selection are taken
into account when you generate the report but the order in the selection is
ignored. For more information about the Hierarchical Display command,

see the ““Adding items to a report” on page 33" section.

Defining a filter criterion for a selected report item

The Define Sort and Filter dialog box lets you refine the selection of objects
in your report by adding a filter criterion to the list of objects. You can set
the following parameters to define the criterion:
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Extended attribute as
filter criterion

Parameter To define

S column Means sorted, indicates the attribute will be taken into
account for the sort

EAE AR TESE Used to set an order and define a priority among
attributes

Expression column | Used to restricts the selection to a defined expression

U column Applies the filter expression to the corresponding
column

The expression syntax uses standard wildcards as in the Customize Columns
and Filter dialog box.

=" For more information about the expression syntax, see the “Defining a
filter on a list” section in the “Using the PowerDesigner Interface” chapter in
the General Features Guide .

You have to click OK to commit the criterion. If you click the Switch to
Selection button you display the Select Objects dialog box and you do not
commit the criterion.

Lists in books
The Switch to Selection button is not available if the list you are sorting
belongs to a book item.

You can select an extended attribute as filter criterion for the list of objects,
if your model has an associated language, DBMS or extended model
definition containing extended attributes. For example, extended attributes
defined for tables in the DBMS associated with a PDM are available for
selection in a book or list item.

=" For more information about extended attributes see the “Managing
Profiles” chapter of the Advanced User Documentation .

< To define a filter criterion

1. Right-click a book or a list item in the Report Items pane and select
Selection.

or

(Matrix items only) Right-click a matrix item in the Report Items pane
and select Row Selection or Column Selection.

The Define Sort and Filter dialog box is displayed.

2. Type an expression in the Expression column to restrict the selection in
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the column to a defined expression.

3. Select the U column to apply the filter expression to the corresponding
column.

4. Select the S column to take the attribute into account for the sort.

5. Click the Include Sub-Objects tool to apply the filter on all the
sub-objects recursively.

6. Click the Include Shortcuts tool to apply the filter on all the shortcuts
recursively.

Define Sort and Filter =] E3

E]

5 Colurmn Heading Enprezsion L ;l
Check. Constraint Mame [
Primary Key

Cluster

Type

Annotated

Haz Syrmbal

Feplica

Diate Ewtat

Perzsiztent True
ExtGlobalTemporaryT able

Fle|e]|+]£]2]4]
Switch to Selectionl QK I Cancel Help

7. Click OK.

Cancel filter expression

If you want to keep the expression in memory but disable this filter for a
while, you can clear the corresponding check box in the U column. The
expression parameter will no longer be taken into account.
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Formatting ltems

In a report, the available format options depend on the print format:
¢ Text format
¢ Graph format

¢ Table format

Contextual menus
You can right-click any item to access its contextual menu and display the
commands that apply to it.

Defining global format for an item

Global formats apply to all new items that you add to a report structure. You
apply global format to items in the Available Items pane. After you define
global format, it applies every time you add that item to the Report Items
pane.

Global format does not apply to items already in the Report Items pane.

R
0‘0

To define a global format
1. Select an item in the Available Items pane.

2. Select Report » Format.

A Format dialog box that corresponds to the type of the item is displayed.
For example, if you select a graph, the Graph Format dialog box is
displayed.

3. Type format changes.
4. Click OK.

Every time you add that item to the Report Items pane, it retains the
global format.

Multi-selection

You can also change format options for several items at once by pressing
cTRL while selecting items of the same type or not with the Pointer tool or
using the SHIFT key to select a continuous list of items.

Formatting individual items

You can change the format of an individual item already in the Report Items
pane.
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% To format an individual item
1. Select an item in the Report Items pane.

2. Select Report » Format.
A Format dialog box that corresponds to the type of the item is displayed.

3. Type format changes.

4. Click OK.

The format is applied to the selected item only. If you want to apply the
defined format to all items of that type, you must define global format
options for that item in the Available Items pane.

=" For more information about default format options, see the
““Defining global format for an item” on page 49” section.

Defining a default report font

You can easily change the default font proposed for report items, report
templates and reports using the Change Fonts Properties dialog box. That
default font is saved in the registry.

You can simultaneously define a default font for items with different print
formats.

After you define a default font for an item, it applies every time you add that
item to the Report Items pane.
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% To define a default report font

1. Select Report » Change Fonts from the Report Editor window.
or

Click the Default Fonts button in the Presentation Options page of the
Report Creation Wizard.

The Change Fonts Properties dialog box is displayed.
Change Fonts

Available jtems: Fant I

Level 4 j‘ Eont: Font shyle: Size:

Lewvel 5
Level 6 Times New Roman Italic: |1 0
Lewel 7

Lovel & Monotyupe Sortz :I Fegular .

Lewvel 3
Title

MT Eutra n
BEold 12
Bold Italic _I 14

L[>

alum Effect
’7 ™ Strikeout ™ Urndering |
Book Title

Folder Title Previe
Card Title

Card Label

Card Test

Text Attribute Title
Text Attribute

Text File

fimes new roman

KNl

QK. I Cancel Help

2. Select Font format options.
3. Click Ok.
Selecting text to format
Some items include more than one text selection. You can format each text

selection independently or altogether using the CTRL or SHIFT key to select
several text selections at once from the Available Items pane of the Format

dialog box.
Card items The following text selections are available for card items (lists of properties),
which print in table format.
Text selection Description Example
Title Title of the item Card of the Table
Text Label Property name on a list of | Table Code
properties
Text Value of a property EMPLOYEE
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CRUD Matrix items

Model- and
object-dependent items

List items

Title page

Table of contents

52

The following text selections are available for CRUD Matrix items, which
print in table format.

Text selection

Description

Example

Matrix title

Matrix row and
column

Matrix text

Title of the item

Resource and process

name

CRUD value

CRUD Matrix

Check item (process name in
rows) Stock (resource name in
columns)

RU

The following text selections are available for model- and object-dependent
items in text format.

Text selection

Description

Example

Title

Text

Title of the item

Text of the description,
annotation, or script

Table Description

This table describes different
employee characteristics

The following text selections are available for list items, which print in table

format.

Text selection

Description

Example

Title
Column Header

Text

Title of the item

Heading of column

Value in the column

List of Indexes
Code
PK_EMPLOYEE

The following text selections are available for the title page, which print in

text format.

=" For more information about the title page, see ““Including a title page”
on page 89” section.

Text selection Description Example
Title Title of the report OOM Report
Optional Fields Text of the author, date, VB, 09.15.99, draft, report

version or summary

with lists only

The following text selections are available for the table of contents, which
prints in text format.
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Simultaneous selection

Text selection

Description

Example

TOC title

Level 1
Level 2
Level 3
Level 4

etc.

Title of the table of contents

Text of the different hier-
archy levels in the table of
contents

Table of contents

2 Association information
2.1 Model information

2.1.1 Card of the model
OOM

etc.

You can select the levels to display from the Show levels to list in the Format
dialog box. For an HTML report, you must define the depth level of the table
of contents in the HTML Format tab of the Report properties dialog box.

=" For more information about the HTML Format tab, see the ““Managing
HTML format” on page 95 section.

Format E3
Awailable jterms: Font |F'aragra|:|h| Borderl Tabs I
TitIE’ Font: Font gtyle: Size:
Level 2 [ Bold [0
Lovel 3 | :
Arnial Black. n
Arial Mamow 12 —
Bookman Old Style Bold Italic 14
Bookshelt Symbol 1 I -1 s =l
— Effects
™ Stikeout ¥ Underline
— Preview
Arial
Shaow |evels ta:
QK. I Cancel Help

In addition, you can simultaneously select items with different print formats
and apply to them the format options corresponding to the type of the item.
For example, if you select a card item and a list item, the text selections that
you can format for both items appear in the Available Items pane of the

Format dialog box:
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Selecting a font
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Fant |F‘aragraph| Eorderl Tabs I

Ford L abel tht: Faont style: Size:
Card Tent Jial Bold [ra
Lt Tie I =
Lizt Calumn Header ;
! Arial Black 11
List Text Arial Narrow 12 -
Bookman Old Style 14
Bookshelf Symbol 1 | 1 7
— Effects
™ Stikeout ¥ Undeiline
r— Preview
Arial

ak. I Cancel Help

You can select a font for any item, except for the graph and page break.

If you call the Format dialog box from the Available Items pane, the font
formatting becomes the default format, as explained in section ““Defining
global format for an item” on page 49”.

If you call the Format dialog box from the Report Items pane, the font
formatting applies to the selected report item, as explained in section
““Formatting individual items” on page 49”.

The following font formatting is available from the Format dialog box:

¢ Font
¢ Font style
¢ Size
¢ Underline

¢ Strikeout

< To select a font

1. Select an item.

2. Select Report » Format.

The Format dialog box opens to the Font tab.
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Format
Available tems: Font |Paragraph| Borderl Tabs |

TOC Title . . [

Level 1 Font; Font style: Size:
Times Mew Roman| I Regular I n

Level 3 MT Extra -
Palatino Linotype 11
S ymbal 1 =
T shoma 14
Timez Mew Foman ;I 16 ;I

Effect:
’7 ™ Strikeout ™ Underline ‘

Preview

Titnes Mew Roman
Shaow levels to:

ILeveI 3 VI

oK I Cancel | Help |

3. Select an item in the Available Items pane of the Format dialog box.
The item is highlighted.

4. Select font format options.

5. Click OK.
Formatting a paragraph

You can select a paragraph format for any item, except for graphs and page
breaks.

If you call the Format dialog box from the Available Items pane, the
paragraph formatting becomes the default format, as explained in section
““Defining global format for an item” on page 49”.

If you call the Format dialog box from the Report Items pane, the paragraph
formatting applies to the selected report item, as explained in section
““Formatting individual items” on page 49”.

The following paragraph formatting is available from the Format dialog box:

¢ Indentation (left, right, first line)
+ Spacing (before, after, internal line spacing)

¢ Justification (alignment)
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< To format a paragraph
1. Select an item.

2. Select Report » Format.
The Format dialog box opens to the Font tab.

3. Click the Paragraph tab to select Indentation, spacing and justification

formats.
Format B
Awailableems:  Font  Paragraph | Border | Tabs |
TOC Title — Indent Space
Lewel 1 .
Level 2 Left  [o28" Befor= Opt
Bight 000" Alter. Opt
- Line spacing:
First line:  {0.00 = ISingIe j |‘I.DD ﬁ
Aligriment: I Left - l
— Preview
AaBbvulz
Show |evels to:
ILeveI 3 - I
Ok I Cancel | Help |

4. Select an item in the Available Items pane of the Format dialog box.
The item is highlighted.

5. Define paragraph format.
6. Click OK.

Selecting border format
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You can define border formatting in the report.

If you call the Format dialog box from the Available Items pane, the border
formatting becomes the default format, as explained in section “Defining
global format for an item” on page 49.

If you call the Format dialog box from the Report Items pane, the border
formatting applies to the selected report item, as explained in section
“Formatting individual items” on page 49.

The following border formatting is available from the Format dialog box:
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Frame op- Result in the generated Result
tion report
1.1 Card of the entity Activity
Name A ctivity
C T Code ACTIVITY
Left Inserts a vertical line to the Parent Models
left of all the occurrences Generate FALSE
of the highlighted text Nunher
selection in the Available
Items pane
1.1 Card of the entity Activity
Name Activity
Right Inserts a vertical line to the e semnrt
right of all the occurrences | e T
of the highlighted text
selection in the Available
Items pane
1.1 Card of the entity Activity
Tame A ctivity
Top Inserts an horizontal line Code ACTIVITY
Parent “Model>
on top of all the occur- Generate FALSE
rences of the highlighted Mumber
text selection in the Avail-
able Items pane
1.1 Card of the entity Activity
Nate Auctivity
Bottom Inserts an horizontal line Pt S
at the bottom of all the N ==
occurrences of the high-
lighted text selection in the
Available Items pane
1.1 Card of the entity Activity
Name A clivity
. Code ACTIVITY
Box Inserts a unique rectangle Parent odes
around all the occurrences Generate FALSE
of the highlighted text Tumber
selection in the Available [y e ey AT m,
Items pane (only available Bewon seain
for card and list items)
Width Indicates the line width for | In the following exam-

the Left, Right, Top and
Bottom frame options

ple only Top and Bottom
frame options are selected:

1 uitotoumre U

o =3 Tk D

e~ ACITY DAL CQNTICL | s
Tublan cral AT DAIE CONIICL, .
PAMIAIE DAIE CORTIOL | Famds
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Box option
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Frame op- Result in the generated Result
tion report
Box width | Indicates the line width of
the box frame
1 LhrtoT busine i ruler
From text Sets the amount of space var GBI ALE

from text to top, bottom,
left, and right border

The Box option is only available for:

¢ Text Label in card items

¢ Column header and Text in list items

Aoty ak oontrl
Tuhdan couml
Fartcipen dam conal

ACTIVITY, DATE_CONIECL
1ASE_DATE CONTEOL
PARIICTPATE DWIE CONTEOL

If you select the Box option in the Format dialog box of a card item

You insert a unique rectangle that groups all the occurrences of Text Label
(property names) including Text (corresponding property values) by default.

If you select the Box option in the Format dialog box of a list item You
insert a unique rectangle that groups all the occurrences of Column Header
(heading of column, example Code). You also insert a unique rectangle that

groups all the occurrences of Text (value in the column), if you have

previously highlighted each of these text selections in the Available Items

pane.
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+ To select frame format
1. Select an item.

2. Select Report » Format.
The Format dialog box opens to the Font tab.

3. Click the Border tab to select border format.

Format
Available tems: Font I Paragraph  Border | Tahs |
TOC Title — Fran
tg:g:; - [CRight [ Top [ Bottom I Box

“widths ISM pt 'I Box 'width: ISM pt 'l

Show |evels to:

— Fram text
Top: 1pt Left: 4pt
Bottar: |1 At Right: |4 pt
— Preview
AsBbvyLz

ILeveI 3 Yl

o]

Cancel | Help |

4. Select an item in the Available Items pane of the Format dialog box.

The item is highlighted.
5. Define border format.

6. Click OK.
Selecting tab spacing format

You can define tab formatting in the report.

If you call the Format dialog box from the Available Items pane, the tabs
formatting becomes the default format, as explained in section ““Defining

global format for an item” on page 49”.

If you call the Format dialog box from the Report Items pane, the tabs
formatting applies to the selected report item, as explained in section

““Formatting individual items” on page 49”.

The following tab formatting is available from the Format dialog box:
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Tab formatting

Description

Tab stop position
Default tab stops

Alignment

Allows you to type the measurement for a tab stop
Sets the default spacing between tab stops

Allows you to select the way you want text to be
aligned at the tab stop. To change the alignment for an
existing tab stop, click it in the Tab Stop Position box,
and then click the new alignment option

This paragraph formatting is particularly useful for the layout of headers and

footers.

=" For more information about headers and footers, see the ““Modifying a

report header or footer” on page 83" section.

< To select tab spacing format

1. Select an item.

2. Select Report » Format.
The Format dialog box opens to the Font tab.

3. Click the Tabs tab to select Tab spacing format.

Format
Lrveailable ems: Faont IParagraphI Border Tabs |
TOC Title
Lewel 1
Lg:gIZ Tab stop pogition; Default tab stops: 050"
Alignment
= Left
" Center
= Right
Set | clewr | Cleara|
Shaow levels to:
ILeveIS Yl
oK I Cancel | Help |

4. Select an item in the Available Items pane of the Format dialog box.

The item is highlighted.

5. Type a value in the Tab stop position box.
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6. Select an Alignment type in the Alignment groupbox.
7. Click Set to set your tabs definition.
8. Click OK.

Editing text

You can modify the text of a text paragraph or a text file in a text editor. The
default editor is NOTEPAD.EXE.

< To edit text

1. Double-click a text paragraph or a text file in the report items pane to
open the Editor dialog box.

2. Type modifications to the text, and then click OK.

Formatting a graph

You can apply zoom options and frame options to graphs.

The following zoom options are available for graphs:

Format Option What it does

Fit to Page Centered Centers the graph on a page and, if nec-
essary, reduces the graph to fit on one

page
As Paragraph Prints the graph on the next line in the

report and, if necessary, reduces the graph
to fit on one page

Custom Zoom Prints the graph on the number of pages
required at a percentage print scale

Keep Diagram — Respects the diagram layout and adapts
Layout the zoom to generate one page of the

diagram per report page

You can also frame a graph using the Left, Right, Top and Bottom frame
options in the Graph Format dialog box.

=" For more information about how to frame a graph, see the ““Selecting
border format” on page 56” section.
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+ To format a graph

1. Double-click a Graph item in the Report Items pane.
The Graph Format dialog box is displayed.

Graph Format Ed
— Zoom — Frame

Fitto page | L

£ Centered [ Right

% Az paragiaph [ Top
[~ Eottam

 Custom

Zoorm; |84 %

& Keep diagram layout

Sdicdth: |3.-"4 pt 'l

ak. I Eancell

Help |

2. Select graph format options.

3. Click OK.

Formatting a list item

Default order in list items
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List items print in the form of tables. You can format a list item using the
List Layout dialog box, which displays the attributes of the selected item in
columns.

From this dialog box you can:

¢ Select attributes to include in a list item
¢ Modify column width in a table

In a generated report, the default order for objects in list items is the object’s
name or code.

Note that sub-object lists (such as table columns for example) are never
ordered, together with calculated or extended collection lists which are
already ordered collection.

Example:

In a free model diagram, you have created the following extended objects in
this order:

Camera

Laptop
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Extended attributes in list
items

Video Recorder

Mobile Phone

Camera hobile Phaone

Wideo Recorder

Laptop

In the generated report, using a list item, the created extended objects
display ordered by their name:

Free Model Freehlodel 1

1 List of extended objects

MName Code
Camera Camera
Laptop Laptop
Iiobile Phone Iobile_Phone
WVideo Recorder Wideo_Recorder

You can select extended attributes to display in a list item, if your model has
an associated language, DBMS or extended model definition containing
extended attributes. For example, extended attributes defined for processes
in the process language associated with a BPM are available for selection in
a list item. You can choose to select all extended attributes or only those
whose value has been modified using the Display » All and the Display »
Only modified ones commands from the list item contextual menu.

=" For more information about extended attributes see the “Managing
Profiles” chapter of the Advanced User Documentation .

Selecting attributes for a list item

You can choose the attributes to include in a list item.

< To select attributes for a list item

1. Click a list item in the Report Items pane and select Report » Layout.

The List Layout dialog box corresponding to the selected item is
displayed. It displays the attribute names available for the list item. A
check in the Displayed column indicates an attribute to include in the list
item.
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Modifying column width in a table
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Attibute Name D Width |
Dirnensional Type [ 20 rm
Check Conztraint Mame [ 50 mm
Frimary Key [ 20 mm
Cluster [ 20 mm
Type [v 50 rm
Annotated [ 10 mm
Haz Symbal [ 10 mm
Replica [ 10 mm
Dlate_Extat [v 50 mm ~
ExtGlobalT emporamnT able [~ 10 mm =
Fl#[e| | $]2]4] | »
QK. I Cancel | Help |

2. Select the Displayed check box to include the attribute in the list item.

or

Clear the Displayed check box to remove the attribute from the list item.

3. Click OK.

You can indicate column width in tables in one of the following ways:

Width Abbreviation Description

Inches inch Indicates column width in inches
Millimeters mm Indicates column width in millimeters
Percentage % Indicates column width in percentage of the

remaining space left by columns defined

by inches or mm
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% To modify column width in a table

1. Click a list itemin the Report Items pane and select Report » Layout.
The List Layout dialog box is displayed. The column width is displayed

in the Width column.
List Layout H=] B3
Attibute Name D Wficth =]
Dimensional Type [ 20 mm
Check Conztraint M ame [ 50 mm
Prirmary Key [ 20 mm
Cluster [ 20 mm
Type [v 50 rm
Apnotated [ 10 mm
Haz Symbal [ 10 mm
Feplica [~ 10 mm
Date Extat [v 50 rm ~
EwtGlobalT emporamT able [ 10 mm -
Fl#[e|4]4]2]4] |»
QK I Cancel | Help |

2. Type a width followed by inch for inches, mm for millimeters, or % for
a percentage of the remaining space left by the columns defined by inches
or mm for each displayed attribute.

3. Click OK.

Selecting object properties to display in a card

Extended attributes in
card items

A card is the property sheet of an object. Each object type in a model
diagram has its own property sheet, which displays in columns the properties
that define the object.

In a report, card items print in the form of tables. You can select columns to
include in a table using the Card Layout dialog box, which displays the
properties included in the property sheet of the selected item.

You can select extended attributes to display in Card items, if your model
has an associated language, DBMS or extended model definition containing
extended attributes. For example, extended attributes defined for classes in
the object language associated with an OOM are available for selection in a
class card.

=" For more information about extended attributes see the “Managing
Profiles” chapter of the Advanced User Documentation .
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% To select information to display in a card
1. Click a Card item in the Report Items pane and select Report » Layout.

The Card Layout dialog box corresponding to the selected item is
displayed. It lists the attribute names available for the table. A check in
the Displayed check box indicates a corresponding attribute to include in
the table.

Card Layout M=l

Attibute Mame
Dimenzional Type
Check, Congtraint Name
Frimary F.ep
Cluster
Type
Apnmotated
Haz Symbal
Replica
Date Ewtat
E«tGlobalT emporaryT able

Fl4[e]¥] 3[4 | »

QK I Cancel | Help |

2. Select the Displayed check box to include the attribute in the table.

4

A5 =

4| H

or

Clear the Displayed check box to remove the attribute from the table.

3. Click OK.

Shortcuts cards
Select the Displayed check box for the Class Name attribute to distinguish
shortcuts cards from the other object types cards in the generated report.

Hyperlinks for object cards in HTML report

When you generate an HTML report that contains a diagram graphic and
the object cards of the symbols, hyperlinks are created between the diagram
symbols and the corresponding object cards. You can click a symbol in the
diagram to access the object card that corresponds to it in the HTML page.
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Report Sections

PowerDesigner model reports must contain at least one section. When you
create a model or multi-model report, a section is automatically created by
default. Sections are displayed as tabs at the bottom of the Report Items
pane of the Report Editor.

Sections can only contain section items for one model type. In a
multi-model report, you can create sections relating to different model types.
For example, a multi-model report can contain a PDM section, an OOM
section, and a BPM section.

You can use sections to segment your model in order to facilitate your
analysis. You can create, delete, modify and rename as many sections as you
want from within the report property sheet. You can create an empty section
or a section based on a template.

You can launch the Report Wizard from the Report Editor to configure the
present section. The wizard configures only one section at a time, and will
delete the current contents of the section. To configure a second section,
select it using the section tabs at the bottom of the window, and relaunch the
wizard. For information about using the wizard, see “Creating a report with
the Report Wizard” in the Creating Model and Multi-Model Reports chapter.

Creating a report section

You create a section in order to add a model to a multi-model report or to
divide a single model report.
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% To create a section in a model or multi-model report

1. Open the report in the Report Editor, select Report » Report Properties to
open the report property sheet, and click the Sections tab. The list of
report sections contains a section by default.

% Report Properties - BPM_Report [BEPM_REPORT] | [3] x|
Generall Title F'age' RTF Formatl HTML Farmat  Sections |
E,A | 4 B X M T
Hame todel Type Template | Ap 1=
= |Section_1 Executable {Buziness Froce (<Nones rd
Fle[e|+]E[2]4] [T
More > | - 0k I Cancel Apply | Help |

2. Click the Add a Row tool to create a new section, and type the name that
you want to see appear on the section tab in the name column.

3. [multi-model report only] In the Model column, select a model from the
list of models open in the workspace. The type column changes to reflect
the model type chosen.

4. [optional] In the Template column, select a standard template from the
list. You can choose between:

¢ None [default] — creates an empty section.

¢ Full <Model Type> Report — provides lists of all the types of objects
in the model, together with detailed information on each object.

¢ List <Model Type> Report — provides lists of all the types of objects
in the model.
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¢ Standard <Model Type> Report — provides lists of all the types of
objects in the model, together with detailed information on each of the
main objects.

\# Report Properties - BPM_Report [BPM_REPORT)

Genelall Title F'agel RTF Folmatl HTHL Format  Sections |
3,3 A B EX ML
Mame tdodel Type Template | Ap =
1 List Executable (Buzines: Proce | <hone: [
= |Process Executable | Business Proce : SYEEES =k
Full Businesf[
List Buzines} —
Standard B =
AkIRIRAEIEIR] [
More > | - (0] 4 Cancel Apply | Help |

5. Click OK to close the report property sheet and return to the Report
Editor. The tab for the new section is available at the bottom of the
Report Items pane.

6. Click the section tab to view the new section. The section will either be
empty or, if you have selected a template, will contain the report items
specified by the template:
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| Executable BPM. Report - BPM_Report _ O]
Auvailable items Show All ltemns Fepart iterms
';@ Available itemns = @ Process
i=1] Table of contents i=]] Table of corterts
ae Title Title - BPM Diagrams
: Text paragraph Title - Model level object listz
ik Textfile @ Package - Package %I TEME
Graphical file @ Process - Process ZITEME
Page break,
=] Model Card

Lizt of Model Extended Attributes
] Model Code Preview

Ligt of all Dependencies

Ligt of Generation Source Objectz of Model —
Ligt of Diagramsz

Ligt of Organization Unitz

Lizt of Role Association:

Ligt of Mezzage Formatz

5] List of Processes

Lizt of Data Transformations

Lizt of Variables

Ligt of Startz

| - Llst UfEnd§_ = | [EIETList \Frocess /

Modifying the structure of a report section
You can modify the structure of any report section.

« To modify the structure of a report section

1. Click the section tab that you want to modify at the bottom of the Report
Items pane.

The corresponding report is displayed in the Report Items pane.

A Executable BPM. Report - BPM_Report 1 [=]
Evailable items Shaw Al ltems [ Feport items
';Q Available tems = @ Process
~{£]] Table of contents i=]] Table of corterits
e Title R Title - BPM Diagrams
- Test paragraph Title - Model level object lists
i Textfile @ Package - Package ZITEMZ
Graphical file @ Process - Process ZITEME
Page break
[ Model Card

- List of tMaodel Extended Attibutes
-[2] Model Code Preview

List of all Dependencies

List of Generation Source Objects of Model —
List of Diagrams

List of Organization Units

EEE] List of Fole &szociations

List of Message Formats

Ligt of Processes

Ligt of Data Transtormations

List of Yariables

List of Starts

Lizt of Ends

| =

j 4|>|\Lis‘t )Processp‘
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2. Modify the report.

=" For more information about modifying a report structure, see the
““Adding items to a report” on page 33” section.

Undo functionality not available
You cannot use the Undo functionality in reports.

Reapplying the template default values to a report section
You can easily delete the modifications you applied to a report in the Report
Editor and return to its initial state without deleting the selection of objects.

To do so, you have to reapply the template default values to the section using
the list of report sections.

+ To reapply the template default values to a report section

1. Select Report » Report Properties from the Report Editor window and
click the Sections tab.

The list of report sections is displayed. The Apply Template check box
corresponding to the section on which your are working has been cleared
because you have changed the default parameters.
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% Report Properties - BEPM Report [(BPFM_REPORT] _ [O] x|
Generall Title Page' RTF Formatl HTML Fomat  Sections |
== e Y 7
Mame Ohbiject Type Type Template Apl| =
=+ |2 FieportSection (Business Proce | List Business Repoc [
2 Process FieportSection iBusiness Proce | <Mokes o
Flale]#]$]2]4] |2
Mare >3 | - oK I Cancel Apply | Help |

2. Select the Apply template check box to reapply the template default

values to the section.
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i Report Properties - BPM_Report (BPM_REPORT]
General | Title Page | RTF Format | HTML Format  Sections
B, 4B R X M T
Hame M odel Type Template | Ap 1=
1 List Executable | Buziness Froce | <Mones [V
= |Process Executable | Business Proce iR =l v
Full Busines|
List Busgines} [~
Stahdard B =
Fle[e|+]£]2]4] [T
Mare »» | - (n] 4 Cancel Apply | Help |

3. Click OK.

You return to the Report Editor. The section is displayed with the
template default parameters and the object selection is preserved.

Renaming a report section

You rename a report section using the Sections tab in the report property
sheet.

% To rename a report section

1. Select Report » Report Properties from the Report Editor window and
click the Sections tab.

The list of report sections is displayed.

2. Click the Name column of the section you want to rename.

An arrow is displayed at the beginning of the line.

3. Type a new name for the section.
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4. Click OK.

The Report Editor window is displayed. The section is renamed in the
Report Items pane.

Renaming a section in the Report ltems pane
You can rename a section directly in the Report Items pane by right-
clicking the section node at the root of the tree and select Rename.

Deleting a report section

74

You delete a report section using the Sections tab in the report property
sheet.

< To delete a report section

1. Select Report » Report Properties from the Report Editor window and

click the Sections tab.

The list of report sections is displayed.

. Select the section you want to delete.

An arrow is displayed at the beginning of the line.

. Click the Delete tool.
. Click OK.

The Report Editor window is displayed. The section you deleted is no
longer displayed in the Report Items pane.

Section deletion
You cannot delete all the sections contained in a report because a report
must always contain at least one section.
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Report Templates

You can use a report template to generate a report for a selected model.
Report templates are reusable, they list information to include in reports.

You can create your own template in a given language, modify it and save it
in an RTP file. However, when you use a template created in a language
different from the one you select to create your report, only user-defined
items such as Title or Text paragraph will keep the language of the template.
Other items will be displayed in the report language.

You can also use standard report templates that ship with PowerDesigner.

You can apply a template to a report when you create the report using the
List of Reports or afterwards, using the list of report sections in the report
property sheet.

For each report section, you can apply a different template, but all sections
are always of the same type as the model, for which you generate the report.

The Report Template Editor is an independent module. It allows template
creation and modification. You can open the Report Template Editor with no
model attached to it.

A report template is an independent and reusable file saved on your hard
disk, which indicates what information to include in your report.

You can use this file to quickly generate model reports or multi-model
reports (several models in the same report).

With the Report Template Editor, you can:
¢ Create a template

¢ Modify a template

¢ Save a template in a .RTP file

You can use standard PowerDesigner templates (see “Creating a report with
a standard template” in the Creating Model and Multi-Model Reports
chapter) or create your own templates.

Creating a report template

A report template is a file that you can use to quickly generate a report. You
can use standard templates that ship with PowerDesigner or create your own
templates.

You can also create a template in the Report Editor using a report section.
For more details, see “Creating a template from a report section” on page 78.
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When you create a template, you indicate what information you want to
include in the report. You can select a language to display information in the
desired language.

When you create a template you need to provide the following information:

Option Description

Name Name of the template

Language Language in which you want to edit your template. English is
the default language

Type Type of the model for which you create the template

< To create a template

1. Select Report » Report Templates to display the List of Report

Templates.

i List of Report Templates | x|
pujj=

Repa
Full Conceptual Repart
Full Object Repart
Full Phypzical Report
Full Requirement repart
Full *kML Repart
List Buzinezs Report
Ligt Conceptual Report
Lizt D ata Liquidity repart
Lizt Object Repart
List Phpzical Report
Lizt Requirement Feport ﬂ

Path: I

File name: Ibpmfulus.rtp

Cloze I Help |

2. Click the New tool and type a template name in the Name box.

3. Select a language from the Language list. It displays the available
languages. English is the default language in which the report is printed.

=" For more information on languages in reports, see the Using the
Report Language Editor chapter.

4. Select a template type in the Type box.
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Report Template Type E3

Harme:

Language:

IM_I,I BFM template

Free Model
Inforrnation Liguidity Model
Object-Ornented Model
Physical Data Model
Requirements bodel

QK. I
Cancel |
Help |

5. Click OK.

The Report Template Editor window is displayed.

6. Add items to the Template Items pane. They display in the language you

selected.

\#j Report Template, My BPH template
Available itemns

Template items

To[x]|

';Q Awvailable items
~{&]] Table of contents
N Title
Text paragraph
Al Teut file
Graphical file
Page break
Model Card
List of Model Extended Attributes
Madel Description
Model Annatation
Model Code Preview
List of Related Diagrams of Model
[0y Related Diagram
List of Associated Fequirements of Model
List of Model Extended Collections
List of Model Attached Rules
Lizst of Model Extended Dependencies
Lizt of all Dependencies

4]

-

1of

% ty BPM template

tdodel Descripti
ist of Pron

List of Flows - L

Model Card - Fiche du modéle %ZITEM?

on - Description du modéle %I TEM=
des

iste des flux

=" For more information on adding items to the Report Items pane, see
“Using Report Items” on page 32.

. Select File » Save.

A Save As dialog box is displayed.

The name you type at creation in the Report Template Type dialog box is
displayed by default with an RTP extension. You can choose another

name.

Click Save.

The next time you create a report, you will be able to use this new
template that is displayed in the List of Report Templates.
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Language in a template

When you use a template created in a language different from the one
you select to create your report, only user-defined items such as Title or
Text paragraph will keep the language of the template. Other items will

be displayed in the report language.

=" For more information on creating a report, see the “Creating Model

and Multi-Model Reports” chapter.

Undo functionality not available

You cannot use the Undo functionality in reports.

Creating a template from a report section

Once you have created a report section, you can save it as a template. You
can use that template to create other reports.

This feature can be useful when you want to create a template with extended
attributes or with extended or calculated collections. You begin with creating
a report for a model, which has an associated extension (DBMS, language or
extended model definition) containing extended attributes or extended or
calculated collections. Then you use the Create Template From Section
command from the Report menu.

< To create a template from a report section

1. Click the tab corresponding to the section you want to save as a template.

The corresponding report displays in the Report Items pane.

W Executable EPM, Report - BPM_Report

Available items Shove &l Iterns

Feport items

H[=1E3

"U@ Available itemns

~{Z]] Table of contents

Title

----- ] Text paragraph

&) Test file

Graphical file

Page break

| Model Card

£ List of Model Extended Attributes
tModel Code Preview

Z| Lizt of all Dependencies

List of Generation Source Objects of Maodel

List of Diagrams

List of Organization Units

Lizst of Role Associations
List of Message Formats

f] List of Processes

Lizt of Data Tranzformations
List of Yariables
List of Startz

-] List of Ends
I

- @ Process
=] Table of contents

Title - BPM Diagrams

Title - Model level object listz
@ Package - Package %ITEMZE
@ Process - Process %ITEM

x| [EIETNList \Process /
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2. Select Report » Create Template From Section.

The Report Template Editor is displayed. The items which were listed in
the Report Items pane of the Report Editor is displayed now in the
Template Items pane

A% Report Template., List
Available items

=] B3

Template items

) Avalable terns
Table of contents
e Title

----- ] Text paragraph

iy List
~1]] Table of contents
w2 Title - BPM Diagrams

Title - Madel level object lists

@ FPackage - Package XITEMX

g Test file :
ey Graphical file @ Process - Process XITEMX
----- e Page break.

| Model Card

List of Madel Extended Attibutes

----- 2] Model Description

=] Model Annotation

2] Model Code Preview

22| List of Felated Diagrams of Model
Ay Related Diagram

List of Azsociated Requirements of kodel
List of Model Extended Collections
List of Madel Attached Rules

List of Model Extended Dependencies
List of all Dependencies

List of Maodel Calculated Collections

3. Select File » Save.

A Save As dialog box is displayed.

4. Type a template name and click Save.

The next time you create a report, you will be able to use this new
template that is available in the List of Report Templates.

Modifying and saving a template

You can modify an existing template and save it in an RTP file.
Existing templates can be:

+ Standard templates delivered with the product

¢ Templates you have created

For example, you can wish to keep the global structure of a template but
display only object lists.

You can reuse a modified template to create other reports.
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< To modify and save a template

1. Select Report » Report Templates to display The List of Report

Templates.
i List of Report Templates
FIE

Full Busineszs Repart
Full Conceptual Repart
Full Object Report

Full Phyzical Report
Full Requirement repart

Full ML Report

List Buzinezs Report

Lizt Conceptual Repart

List D ata Liquidity repart

List Object Report

Lizt Phyzical Repart

Lizt Requirement Feport ;I

Path: I

File name: Ibpmfulus.rtp

Cloze Help
| |

Opening the List of Report Templates from the List of Reports

You can open the List of Report Templates from the List of Reports by
selecting Report » Reports from the model diagram window. In the List
of Reports, click the Manage Report Templates tool.

2. Select a template type in the Type list.

The list of available templates corresponding to the selected type is
displayed. You can use the Path tool to select a template in another folder.
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i List of Report Templates

Al Report Templates
Conceptual Data Model
#ML Madel

Infarmation Liquidity Model
Requirements Model

Free Model

Phyzical Data kodel
Object-Oriented Model
Business Process Model

Full Object
List Object
Standard O

Path: I

File name: Ioomfulus.rtp

Cloze I Help

3. Select a template and click the Properties tool.

The template is displayed in the Template Items pane.

Available items Template items

i - @ Standard Object Report

=] Table of contents

Title - OOM Diagrams

v Title - Model level object lists

@ Package - Package 2ITEME

Activity - Activity ZITEME

Page break

Title - Class Diagrams main objects

Title - Uze caze main objects

Title - Sequence diagrams main objects
Title - Component diagrams main objects
Title - Activity diagrams main objects
Title - Object diagrams main objects
Title - Deployment diagrams main objects
Title - Statechart diagrams main objects

Graphical file

Page break
Model Card

Model Code Preview
List of Related Diagrams of Model
Fielated Diagram
2] List of &sszociated Requirements of Model
Lizt of Model Extended Callections
Lizt of Model Attached Rules
List of Model Extended Dependencies
-] List of all Dependencies hd
| | »

4. Modify the template in the Template Items pane.

5. Select File » Save.

Renaming a template
You can rename a template in the Template Items pane by right-clicking
the Template node at the root of the tree and select Rename.

=" For more information on modifying a template, see “Using Report
Items” on page 32.
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Accessing a report template from the Browser

You can also access a report template from the Browser by right-clicking
the Workspace node and select Add. From the standard Open dialog
box that is displayed, select an RTP file and click Open. The template
file is displayed in the Browser. You can then open it.
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Setting up Report Pages

Page setup

Paragraph numbering

Before you publish a report, you can set up its pages as follows:

¢ Include a header and footer in each report section.

¢ Remove the title of items.

¢ Modify report properties

When you define a page setup, it only applies to the current section.

If you do not want the paragraphs of your report to be numbered when
printed or generated as RTF, select the check box No paragraph numbering
in the report property sheet. Paragraph numbering does not apply to HTML
reports.

Modifying a report header or footer

Header

The Report includes a default header and footer, which you can modify.

Headers and footers that you modify from the Report menu only apply to
RTF reports. Headers and footers in HTML reports are defined in the HTML
Format tab of the report property sheet.

=" For more information about headers and footers in HTML reports, see
“Managing HTML format” on page 95.

Each report section has its own header and footer.

Headers and footers can include the following variable information that
apply to RTF reports only:

¢ Current Date
¢ Current Time
¢ Page Number
¢ Model Name
¢ Model Code
¢ Module Name

¢ Application Name
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% To modify a report header

1.

Right-click the root folder in the Report Items pane and select
Header/Footer.

or

Click the Header & Footer button in the Presentation Options page of the
Report Creation Wizard.
The Header and Footer dialog box opens to the Header tab.

Header and Footer

™ User-defined headsr
WMODULE¥  %MODELNAMEY:

" Header AFooter /
Format.. | ()4 I Cancel Help

Type changes to header text.

The User-Defined Header check box is automatically selected, as you are
no longer using the default values of the report language resource file you
selected for your report.

Tabs in a header

Use the key combination CTRL+TAB to insert tabulations in a header or
open the Tabs tab in the Format dialog box to set tab stop values.

Position the cursor in the header text where you want to add variable
information.

Click the Insert button and select a field from the list.

Click the Format button.
The format dialog box opens to the Font tab.
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Format

Available jtems: Fart IParagraphl Borderl Tabs |

[ Font: Font style: Size:
Footer
Times New Roman IF!eguIar |1 1]
Monotyupe Sortz a
MT Extra n
Bold 12 =
—! |Bold Italic 14
e =
Effect
’7 ™ Strikeout ™ Urndering |
Previe

Times New Roman

Ok I Cancel Help

6. Select format options.

7. Click OK in each of the dialog boxes.

R

« To modify a report footer
1. Click the root folder in the Report Items pane.
2. Select Report » Header/Footer.

3. Click the Footer tab.

Header and Footer

™ User Defined Footer

HAPPNAMEY  %DATE% Page %PACGEY

4 | 3 |\ Header ) Footer /

Inzert | Format Ok I Cancel Help

4. Type changes to footer text.

The User-Defined Footer check box is automatically selected as you are

no longer using the default values of the report language resource file you
selected for your report.

Tabs in a footer
Use the key combination CTRL+TAB to insert tabulations in a footer or
open the Tabs tab in the Format dialog box to set tab stop values.
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Position the cursor in the footer text where you want to add variable
information.

Click the Insert button and select a field from the list.

Click the Format button.
The format dialog box opens to the Font tab.

Format

Available jtems: Forit IParagraphI Borderl Tabs I

M Eont: Font style: Size:
Times New Foman |F|egular |1 i)
Monotype Sorts -
MT Extra 1
Symbal Eold 12 =
Tshora —! 1Bold Italic 14
Times New Foman LI 16 LI

Effect

’V ™ Strikeout ™ Underine ‘
— Preview

Times New Roman

Ok I Cancel Help

8. Select format options.

9. Click OK in each of the dialog boxes.

User-Defined check box

When you type changes in the Header and Footer box, the User-Defined
check box is automatically selected as you are no longer using the
default values used in the report language resource file you selected for
your report. To revert to the default value, clear the User-Defined check
box. For more information about report language resource files, see the
“Using the Report Language Editor ““ chapter.

Removing the title of an item

You can remove the title of any item in your report in order to ease the
readability of the previewed and generated report. When previewing or

generating your report, the title of the item is skipped to only display the
content of the item.

The following illustration shows a portion of a report preview, with the Show
Title command selected:
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Busitiess Process Model BusinessProcesshodel |

1 Process Process_1

1.1 Card of process Process 1

Neme Process_1

Code Process_1

Comment

The following illustration shows a portion of a report preview, with the Show
Title command deselected:

Busitiess Process Model BusinessProcesshiode] 1

1 Process Process_1

MNeame Process_1
Code Process_1

Comment

The table of contents can also reflects your choice to show or not the title of
an item, depending on the depth level you have specified in the Format
dialog box of the table of contents.

=" For more information about the definition of depth levels in a table of
contents, see the ““Selecting text to format” on page 51 section.

< To remove the title of an item

1. Right-click an item in the Report Items pane and deselect the Show Title
command.

or

Double-click an item to open the Editor dialog box and clear the Show
Title check box, then click OK.

The title of the item is not displayed in the previewed or generated report.

87



Modifying Report Properties

Modifying Report Properties

You can modify a report’s properties from its property sheet. To open a
report property sheet, select Report » Report Properties from the Report
Editor window.

A report definition include the following properties:
¢ General

¢ Title Page

¢ RTF Format

¢ HTML Format

¢ Sections

¢ Version Info

The following sections detail the property sheet tabs that contain the
properties most commonly entered for reports.

s

=" For more information about the Sections tab, see the ““Report Sections’
on page 67" section.

=" For more information about the Version Info tab, see the “Displaying
Version information” section in the “Using the PowerDesigner interface”
chapter in the General Features Guide .

Report Property sheet General tab

The General tab contains the following properties:

Property Description

Name Name for the report. This name makes the report identifiable.
Code Reference name for the report.

Comment Descriptive label for the report.

Language Language of the report. Allows you to change the language

of the report. The Edit Report Language tool allows you
to edit the current report language in the Report Language
Editor. For more information see the “Using the Report

Language Editor” chapter.

No paragraph | When selected, hide section numbers in RTF and printed
numbering reports. Paragraph numbering does not apply to HTML
reports.
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Including a title page

A title page prints as the first page in a report. You include a title page once
for the entire report.

A title page can include any of the following information:

Information

Prints

Title
Author

Date

Version

Summary

Free text, by default the name of the current report.

Name of the report author, as indicated in the Version Info
tab of the model property sheet.

Date when the report is printed. This box is initialized with
the current date.

Version number of the report, as indicated in the model
property sheet.

Free text describing the report.

You can click the Format button to customize the title or the optional fields.

< To include a title page in a report

1. Select Report » Report Properties from the Report Editor window, and
click the Title Page tab.

or

Click the Title Page button in the Presentation Options page of the Report
Creation Wizard.

The Title Page dialog box is displayed. By default, the Include title page
radio button and all the optional fields are selected.
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k#i| Report Properties - BPM Report [EPM Report] =] E3

General Title Page | RTF Formatl HTHL Formatl Sectionsl

" Mo title page

—* |nclude titls page

Title: |F| eport

— O ptional field:
W #uther: — [DDM

¥ Date: |DaTEx

W ersion: IEI_IJ

I Summary:  [Cument view of the business' method for processing an
order

Farmat... |
Mare >3 | - oK I Cancel Apply Help

2. Select the check boxes corresponding to information to include in the title
page and type the appropriate text in each corresponding text box.

or

Clear the check boxes corresponding to information to remove from the
title page.

3. Click the Format button to customize the title or the optional fields.

The Format dialog box opens to the Font tab.
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Format

Available jtems: Fart IParagraphl Borderl Tabs |
Dptional Fioie Font: Font style: Size:
Jaial Bold J1o
_ AI Fegular . a
Avial Black talic n
Avrial M arrow 12 =
Bookman 0ld Style Bold Italic 14
Boakshelf Symbal 1 hd| =l e =
Effect
’7 ™ Strikeout ™ Urndering |
— Previe
Arial
Ok I Cancel Help

4. Select format options.

5. Click OK in each of the dialog boxes.

Title page excluded

For HTML reports, a home page is generated instead of a title page (see
“Managing HTML format” on page 95). Title pages are never generated
for RTF reports generated with a report template.

Managing RTF format

You can customize your report using an RTF presentation template that you
select from the RTF Format tab in the report property sheet.

From this tab, you can select or define an RTF presentation template file that
will be used during RTF report generation. Indeed, when generating an RTF
report with a defined RTF presentation template, the report is generated in an
RTF file then merged into the RTF presentation template file.

This tab also allows you to choose whether you want to use headers and

footers defined in each report section or those defined in the RTF
presentation template.

PowerDesigner ships with a set of predefined RTF presentation templates
that you can use to generate your RTF report or use them as a basis to create
your own presentation templates. These RTF presentation templates are
stored in the Resource Files\RTF Report Templates folder.
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Understanding RTF presentation template

92

An RTF presentation template file has an .RTF extension and allows you to
define:

¢ Header

¢ Footer

¢ Title page

¢ Table of contents

¢ Style (normal, heading 1 etc.)
¢ Numbering (in heading styles)

You can use pictures, page borders and variables in an RTF presentation
template.

Any RTF editor can allow you to create your own presentation templates.

When you apply an RTF presentation template to a report, the presentation
template also takes into account all the presentation options that are
dynamically generated from the model, for example variables defined in the
title page or the font applied to report items.

Beside, the table of contents report item is never generated because the table
of contents is already defined in the RTF presentation template to give you
greater style options.

Report saved with previous versions
If you open a report saved in a previous version, the RTF Template list is
set to <None>.

The RTF presentation template can include the following variables:

Variable Description

%DATE % Report date defined in report property sheet.
%TIME% Report generation time.
9%MODELNAME% Model name of a report section.
9%MODELCODE% Model code of a report section.

9% MODULE % Module name of a report section.

% APPNAME% Application name (PowerDesigner).
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Variable Description

%TITLE% Report title defined in report property sheet.

% AUTHOR % Report author defined in report property sheet.

9%VERSION% Report version defined in report property
sheet.

%SUMMARY % Report summary defined in report property
sheet.

%COMPANY % Company name (Sybase, Quest).

9%REPORTCONTENT % Report insertion point in the RTF presentation
template.

Caution

When the %REPORTCONTENT% variable is not defined, the report is
appended at the end of the RTF presentation template.

Modifying RTF report properties

The following properties are available in the RTF Format tab of the report

property sheet. If you do not want any RTF presentation template when
generating, select <None> in the Template list:

Property

Description

Template

Use sec-
tions
header and
footer

List of available RTF presentation template file names in the
RTF Report Templates folder. You can click the Open RTF
Presentation Template File tool to view and modify the RTF
presentation template file in your default RTF editor. You can
also click the Select RTF Report PresentationTemplates Folder
tool to browse for an RTF presentation template file in a folder
of another version of PowerDesigner

When selected, the RTF report uses the header and footer
defined in each report section. If you want to preserve the
header and footer of the title page and the one of the table of
contents page, you should add a section break after the table of
contents.

When deselected, the RTF report uses the default header and
footer defined in the RTF presentation template.

Header and footer in RTF It is recommended to select the Use sections header and footer check box for

multi-model reports an RTF multi-model report, otherwise all the pages of the RTF report will
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have the same header and footer.

< To modify RTF report properties
1. Select Report » Report Properties from the Report Editor window, and
click the RTF Format tab.
or
Select an RTF presentation template from the Presentation template list in
the Presentation Options page of the Report Creation Wizard.

2. Select or clear the Use sections header and footer check box depending
on whether you want to use the headers and footers defined in each
section of the RTF report or the default header and footer defined in the
RTF presentation template.

This option is not available from the Report Creation Wizard.
% Report Properties - Report 1 [REPORT_1) _ (O] x|

Generall Title Page RTF Format | HTHML Formatl Sectionsl

— RTF Prezentation Template

Template:

— Options

¥ Llse sections header and footer

Default | SetgsDefauItl

Mare >3 | - oK I Cancel Apply Help

3. Click OK to close the property sheet.

When you generate the RTF report, it reflects the properties you have
defined for the report.
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Default buttons

You can set as default the current property values for your RTF report by
clicking the Set As Default button. You can also return to the previously
saved values, by clicking the Default button.

Managing HTML format

From the HTML Format tab of the report property sheet, you can customize
HTML reports and define their presentation style (color, font, background,
header and footer) using:

¢ Template

+ Style sheet (CSS files)

¢ Headers and footers (HTML files)

¢ Home page (HTML files)

¢ Depth levels in table of contents

¢ Format for Graphic items associated with diagrams
¢ Format for list items

¢ Page breaks for top-level lists and cards

PowerDesigner ships with a set of predefined HTML presentation templates,
style sheets and header and footer files that you can use to generate your
HTML reports. Predefined HTML presentation templates can be used as a
basis to create your own HTML presentation templates in a text editor. All
these files are stored in the Resource Files\HTML Report Style Sheets folder.

Understanding HTML presentation template

An HTML presentation template file has an . HTMLTPL extension and
allows you to define the following properties:

¢ Style sheet

¢ Header (and header height)
¢ Footer (and footer height)
¢ Home page

When you apply an HTML presentation template to a report all the
corresponding properties defined in the presentation template are displayed
in their respective field in the Report property sheet. Beside, all the options
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you have defined before (ex: font) are no longer taken into account. The
styles defined in the presentation template file will be applied.

Report saved with previous versions

If you open a report saved in a previous version, the HTML presentation
template has the values of the default HTML presentation template if these
values are identical with the default ones. Otherwise, the Presentation
template box will be empty (<None> value).

The HTML presentation template can include the following variables:

Variable Description

%DATE % Report date defined in report property sheet.

%TIME% Report generation time.

9%MODELNAME% Model name of a report section.

9%MODELCODE% Model code of a report section.

9%MODULE% Module name of a report section.

% APPNAME% Application name (PowerDesigner).

% TITLE% Report title defined in report property sheet.

% AUTHOR % Report author defined in report property sheet.

%VERSION% Report version defined in report property
sheet.

%SUMMARY % Report summary defined in report property
sheet.

9%NEXT% URL of the Next page of the home page.

9%NEXTLABEL% Name of the Next page of the home page.

Style sheet structure The following table describes the use of classes name in the creation of

report style sheets:

Class names Description

BODY Defines the background styles for all report
pages, except the home page frame and the
browser frame page.

.BROWSERBODY Defines the background styles for the browser
page.
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Class names

Description

.HOMEBODY

.TEXT

.TITLE

TABLE

TD

Table.GRID
TABLE.GRID TD.-

HEADER

TABLE.GRID TD

TABLE.GRID TD TD2

Table. FORM

TABLE.FORM TD.-

HEADER

TABLE.FORM TD

Table. TEXT

TABLE.TEXT TD

Table. TITLE

TABLE.TITLE TD

Table. GRAPHICS

TABLE.GRAPHICS TD

Defines the background styles for the home
page.

Defines the default font styles for text blocks,
like description, annotation, etc.

Defines the default font styles for the title of
the home page.

Defines the default styles for tables.
Defines the default styles for table cells.
Defines the styles for object list tables.

Defines the styles for the header cells of object
list tables.

Defines the styles for the cells of object list
tables of even rows.

Defines the styles for the cells of object list
tables of odd rows.

Defines the styles for object card tables.

Defines the styles for the cell name of object
card tables.

Defines the styles for the cell value of object
card tables.

Defines the styles for the tables around the text
blocks.

Defines the styles for the cells of tables around
the text blocks.

Defines the styles for the tables around the
home page title.

Defines the styles for the cells of tables around
the home page title.

Defines the styles for the tables around graph-
ics.

Defines the styles for the cells of tables around
graphics.
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Class names

Description

H1 Defines the styles for level 1 headings.

H2 Defines the styles for level 2 headings.

H3 Defines the styles for level 3 headings.

HR Defines the styles for separator lines.

A:LINK Defines the default colors for non-visited
hyperlinks.

A: VISITED Defines the default colors for visited hyper-
links.

A: HOVER Defines the default colors for highlighted
hyperlinks.

.BROWSER Defines the default font styles for the browser.

A.BROWSER:LINK Defines the default colors for non-visited
hyperlinks of the browser.

A.BROWSER:VISITED Defines the default colors for visited hyper-
links of the browser.

A.BROWSER:HOVER Defines the default colors for highlighted
hyperlinks of the browser.

TABLE.NAVGROUP Defines the styles for the tables around the

TABLE. NAVGROUP TD

navigation buttons.

Defines the styles for the cells of tables around
the navigation buttons.

.NAVBUTTON Defines the default font styles for the naviga-
tion buttons.

A.NAVBUTTON:LINK Defines the default styles for non-visited hy-
perlinks of the navigation buttons.

A.- Defines the default styles for visited hyperlinks

NAVBUTTON:VISITED of the navigation buttons.

A.NAVBUTTON:HOVER

Defines the default styles for highlighted
hyperlinks of the navigation buttons.

In a style sheet, you can define font, color, background, size, margin, and
alignment for each class name.
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Modifying HTML report properties

The HTML Format page includes the following properties. Each property is
optional. If you do not want any HTML presentation template when
generating, select <None> in the Template list:

Property Description

Template List of available HTML presentation template file
names in the HTML Report Style Sheets folder.

You can click the Preview HTML Report Presentation
Template tool to view the current HTML presentation
template in your default browser.

You can click the Save HTML Report Presentation
Template File tool to save changes you have made in a
presentation template or to save a presentation template
you have created.

You can click the Delete HTML Report Presentation
Template File tool to delete a presentation template that
you no longer want.

You can click the Select HTML Report Style Sheets
tool to browse for an HTML presentation template in a
folder of another version of PowerDesigner.

Style sheet Absolute or relative path of the style sheet file (CSS
file). You can browse for a local or shared file (UNC),
or type a URL.

You can click the Open HTML Report Style Sheets
File tool to open the CSS file in your default text editor.
You can click the Browse for HTML Report Style
Sheets File tool to browse for a CSS file within the
folder you have selected for the presentation template.

Header Absolute or relative path of the header file (HTML
file). You can browse for a local file or shared file
(UNC), or type a URL.

Height in pixels of the upper header.

You can click the Open HTML Report Header File tool
to open the HTML file in your default editor.

Location

Height

You can click the Browse for HTML Report Header
File tool to browse for an HTML header file within the
folder you have selected for the presentation template.
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Reduce the size of the

Property

Description

Footer
Location

Height

Home page

TOC
Level
Width

Image Format
SVG
PNG
JPEG

List format
Number of rows
per page

Links to additional
results

Add page break for
top level list and
cards

Absolute or relative path of the footer file (HTML file).
You can browse for a local file or shared file (UNC), or
type a URL.

Height in pixels of the lower footer.

The tools beside the Footer box allow you to do the
same actions as the ones beside the Header box.

Absolute or relative path of the home page file (HTML
file). You can browse for a local file or shared file
(UNC), or type a URL.

The tools beside the Home page box allow you to do
the same actions as the ones beside the Header box.

Number of maximum depth levels to display in the
HTML table of contents (TOC). 3 is the default level.
Width of the table of content expressed as a percentage
of the total width of the report window.

Format for Graphic items associated with diagrams.
If your report contains large diagrams you should
select the SVG format that allows you to interact
with the graphics, see below for more details. During
compression to reduce the graphic size, the PNG format
(Portable Network Graphic) reduces the loss of quality
but is longer to generate than the JPEG format.

Format for Lists.

You can define the number of rows you want to display
in the list results.

You can also define the number of links to additional
results displayed below the list. Additional results are
numbers with hyperlinks to other pages containing the
next rows of the list.

Page breaks creation for each top level list and card to
avoid long HTML pages.

You can reduce the size of the HTML TOC using the following commands

HTML TOC from the contextual menu of a book item in the Report Items pane:

Show contents in HTML TOC When you deselect the Show contents in
HTML TOC command, you only display the title of the item without its
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Style sheets and
headers and footers
associated files

Location type dependent

Valid codepage

contents in the table of contents.

Show book title in HTML TOC When you deselect the Show book title in
HTML TOC command, you remove the title of the book item from the table
of contents. Note that the Show contents in HTML TOC option is also
automatically deselected.

When you generate an HTML report and want to keep the links associated
with your style sheets (CSS) or headers and footers files (HTML), we
recommend you to gather the linked files in a special folder named as the file
to which they are associated and located at the same level in your explorer.

For example, the header Header_Blue.html uses files that should be gathered
in folder Header Blue_files :

= a9 [C) |
D doc7x [C3 Header_Blue_files
E‘D i [E3 Header_vellow_files
ED Pd _ Blue_Theme.czs
E“a Fipt_C53 . B% Header_Blue himl
D Header_BIue_hIefs ﬁHeader_Yellow.html
{23 Header_‘rellow_filles HTML Help.css

This is to make sure that when generating the report, the content of the
associated folders is also copied and links associated to your style sheets and
headers and footers work properly.

Depending on their type of location (local or UNC paths, or URL), style
sheet files, header and footer files and home page files are used the following
way:

Location Use

Local path or UNC path The HTML or CSS file is copied into the
report generation folder.

URL The reference in the HTML report uses the
HTML or CSS file as it is.

By default, PowerDesigner generates in the HTML page a character set
(charset) built from the current language of the report. If this is not correct
for your needs, you can change the charset as follows:

% To change the charset

1. Right-click the report in the Browser, and select Properties from the
contextual menu to open its property sheet.

2. On the General tab, click the Properties button to the right of the
Language field to open the Report Language resource file in the Resource
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SVG graphic format

Default & Save as
Default buttons
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0,
0‘0

Editor.

3. Expand the Report Titles » Common Objects category, and set the
appropriate values for the CharSet and CodePage items.

You can find examples of HTML charset at :
http://www.w3.org/International/O-charset-lang.html.

Scalable Vector Graphics is an XML-based language for Web graphics from
the World Wide Web Consortium (W3C). If you choose the SVG graphic
format for the generation of images in your HTML report, you should use a
browser with an integrated SVG viewer.

You can install an SVG viewer if your browser does not have it already, see
http://www.w3.org/Graphics/SVG/SVG-Implementations.htm8 for more
information about SVG viewers for Internet Explorer and Netscape.

You can also use a browser with an embedded SVG viewer like Opera or
Firefox, in this case make sure the browser is running the correct SVG
viewer version.

An SVG viewer provides the following features:

¢ Zoom in and out while preserving symbol resolution and URL.
¢ Scroll within the diagram.

¢ Find text in the diagram.

¢ Standard contextual menus for editing, saving, and so on.

The Default button allows you to return to the previously saved format in the
registry.

The Save As Default button allows you to save the current format in the
registry. This format becomes the new default HTML format.

To modify HTML report properties

1. Select Report » Report Properties from the Report Editor window, and
click the HTML Format tab.

2. Select an HTML presentation template in the Model list.
or

Select an HTML presentation template from the Template list in the
Presentation Options page of the Report Creation Wizard.

The options that follow are not available from the Report Creation
Wizard.
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3. <optional> Browse for a .CSS file or type a URL in the Style Sheet box.

4. <optional> Browse for a local or shared HTML file, or type a URL in
the Header box.

5. <optional> Browse for a local or shared HTML file, or type a URL in
the Footer box.

6. <optional> Browse for a local or shared HTML file, or type a URL in
the Home page box.

7. <optional> Type a number in the Level box and a percentage in the
Width box of the Table of contents groupbox.

8. <optional> Select image format and type a number for list format.

9. Select the check box to Add page breaks for top level lists and cards.
i Report Properties - Report 1 [(REPORT_1] | [3] x|

General | Title Page | RTF Format HTML Format | Sections |
— HTKL Presentation Template

Template; I j IE

Style sheet.  [LightBlue_Theme.css

Header  [Header_LightBlue himl
Height [54 el

Footer. [Foater_LightBlue. htrl
Height [18 pisels

Hame page:  [Home:_LightBlue: himl

— Table of contents

Levsl |4 width: |25 %

—Image format—————————— List farmat
 S\WG Mumber of rows per page: ISD
&~ PNG ¢ JPEG Links to additional results: IEU

V¥ Add page break for top level lists and cards

Default | Set as Defaultl
More > | - 0k I Cancel Spply Help
10. Click OK.

When you generate the HTML report, it reflects the properties you have
defined for the report.
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Previous, Next, Home navigation buttons

You can translate the navigation buttons (Previous, Next, Home) generated
by default in your HTML report using HtmINext, HtmlPrevious and
HtmlHome items in the Report Titles\Common Objects category of the
Report Language Editor. For more information, see the “Using the Report
Language Editor” chapter.

Default buttons

You can set as default the current property values for your HTML report by
clicking the Set As Default button. You can also return to the previously
saved values, by clicking the Default button.
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Using Print Preview

From the Report Editor window, you can display a print preview, which
shows what a report will look like if printed. Different navigation tools help
you find parts of the report to preview.

You can also print a report or generate a report as an RTF or HTML file from
print preview.

Opening print preview

You open the Print Preview window from the Report Editor or from the End
page of the Report Creation Wizard.

< To open the Preview
1. Select Report » Print Preview.

or
Click the Preview tool in the End page of the Report Creation Wizard.

The Print Preview window displays the two first pages of the report if any.

:':=" PowerDesigner - [PhysicalD ataModel_1. Report - My First Heport]

|& B 8 [ 00D D] GG e

Fage 2/14 %

Print preview a report item

You can rapidly see what a report item will look like if printed. To do so,
right-click a report item in the Report Items pane and select Quick View.
The Print Preview window displays the report item.
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Navigating in print preview

In print preview, you can use tools to navigate through the pages in the
displayed report.

Tool Goes to preview

J One page at a time in report.

=]

11 Two pages at a time in report.

=

First page in report.

&

4 Previous page in report.

=

Next page in report.

(k] Last page in report.

< To navigate in print preview

1. Click a navigation tool in the Print Preview toolbar.

Finding an object in print preview

The print preview feature lets you find all references to an object. You can
then go directly to any topic that mentions the object in the current report.

In the case of a multi-model report, you can choose the model in which you
want to search objects.

+ To find an object in print preview
1. Click the Find tool.
2. The Find Objects dialog box is displayed.

3. (optional) Select the model you want to search in if you work on a
multi-model report.

4. Select an object type from the Object Type list.
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5. Select an object name from the Available Objects list.

Find Objects

1. Select the model to zearch in

IF'uinshing industry j

2. Select the ohject you want ta find
Object wpe:

|Table d

Available objects:
AUTHOR - Clear |
DISCOUMT
HISTORY -
ROV

FUBLISHER
ROWSCHED

SALE =

3. Click a topic, then click Digplay

R eport topic

Table PICTURE
Card of the table PICTURE

Ec||nstraint name of table PICTURE
4

Dizplay Cloze | Help |

Click the Find button.

The Report Topic box displays a list of topics that mention the object.

Select a topic in the list.

© ® =2

Click the Display button.

The topic you selected is displayed in the print preview window.
Zooming in print preview

You zoom in the preview by clicking inside the preview window. The cursor
becomes a zoom tool.

You toggle between the following two viewing scales:

Scale Description

Whole page Uses a scale that fits the entire page or multiple pages in the
print preview window.

Custom view | Displays the report in its actual size or in a scale you select.
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Printing a report from print preview

You can print a report from print preview.

< To print a report from print preview

1. Click the Print tool.
Generating an RTF or HTML file from print preview

You can generate a report file as an RTF or HTML file from print preview. If
you have selected an RTF or an HTML presentation template in the Report
property sheet it will be used during generation. For more information see
the ““Managing RTF format” on page 91” section or the ““Managing HTML
format” on page 95” section.

% To generate an RTF or HTML file from print preview
1. Click the Generate RTF or Generate HTML tool.

Closing print preview

% To close the print preview

1. Select File » Close.
or
Click the Close tool.

You return to the Report Editor window.
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Modifying a Model Report

You can use an existing model report to generate a modified model report.
You can select an existing report from the List of Reports if you need to:

¢ Generate for a different output
¢ Change selection of objects

¢ Add sections

< To modify a model report

1. Select Report » Reports from the model diagram window.

The List of Reports is displayed. It shows the alphabetical list of all
available reports saved in the model.

i X[ Qgm0

I‘ =noft
by new Report
by POM Report

Cloze I Help

2. Select the report you want to modify and click the Edit Report tool.
The structure of the selected report is displayed in the Report Editor
window.

3. Modify the report.

You can then generate it using the appropriate command in the Report
menu.

Quick model report generation from the List of Reports
If you want to quickly generate a report from an existing one without
modifying it, select a report in the List of Reports then click the Print
Report tool, or the Generate HTML or Generate RTF tool.
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Saving a Model Report

When you want to save a model report, you have to save the model. You can
then keep the report for a later use.

Model size saving When you save the model, you also save the reports it contains. To lower the
size of your model, you can create a multi-model report even for a single
report as a multi-model report is saved in a file external to the model. To do
s0, you have to create a template from the section of your report, then create
a multi-model report using the template that corresponds to the section of
your report for a model.

=" For more information about how to create a template from a section, see
“Creating a template from a report section” on page 78. For more
information about how to create a multi-model report using a template, see
“Creating a Multi-Model Report” in the Creating Model and Multi-Model
Reports chapter.

+ To save a model report

1. Select File » Save from the model diagram window.
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CHAPTER 4

Using the Report Language Editor

About this chapter This chapter describes how to use the Report Language Editor to create or
modify report language resource files in order to generate reports in any
other languages than English.

Contents Topic: page
Understanding the Report Language Editor 112
Opening the Report Language Editor 116
Translating a report language resource file 117
Attaching a language resource file to a report 127
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Understanding the Report Language Editor

Report language
resource file

List of Report Languages

112

The Report Language Editor is an independent module. You can open it
without any model opened in the workspace. It allows you to create and
modify language resource files for reports. Language resource files can be
attached to reports in order to generate reports in any other languages than
English.

A report language resource file is a file in XML format saved with the .XRL
extension. It contains all the printable texts of a report and their default
values. You use it when you create your report and later generate it whatever
the output. A report language resource file is stored in a central area and can
be shared by any report to guarantee data consistency and save time to the
user.

PowerDesigner ships with a series of report language resource files located
in the Resource Files directory.

Report V7 and higher
When you open a report from version 7 or higher, strings linked to objects
are displayed in English.

You access the Report Language Editor from the List of Report Languages.

The Report Language Editor is composed of two distinct parts: the language
tree view displayed on the left hand side to navigate through the language
categories and entries and their corresponding information displayed to the
right of the tree view.

The language tree view contains the following three categories:
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Category Description Used for translation of
Object At- Contains all the strings linked | Name of object proper-
tributes to objects (names of objects ties in cards, checks, and
properties, for example) per lists
module
Report Titles Contains all the strings linked | Titles of any report items
to report items (Organization | and titles of the Report
unit annotation, for example) Wizard
per module and the strings
linked to titles of the Report
Wizard
Values Mapping | Contains all the strings linked | Keywords in object prop-

to keywords used in property
values (Undefined or None for
example)

erty values in cards,
checks, and lists

=" For more information about object lists, see the “Formatting a list item”
section in the “Managing a Report” chapter.

=" For more information about object cards, see the “Selecting information
to display in a card” section the “Managing a Report” chapter.

The Report Language Editor looks as follows:

General I

& - 2 - [FRA

‘¥ Report Language Properties (For All Reports) [_[O] x]
o a-d- %%
Hame: |Franch EI
[-[L0 Conceplual Data Model || Goge: IFHA E

Categoties

F (3 Object Attibutes

+)- (2] Common Objects

[-[20 Object Orierted Mode!
(22 Free Made!

123 Infarmation Liquidity Mode
D erize Process Model

+ (22 Physical Data Model
-[23 Business Process Model
1L Requirements Model

(22 XML Model

File name: I

Comment;

\E]-D Repait Titles
\EID Values Mapping
D Farrmns
12 Lists
4 | hd
(1.9 I Cancel | Lpply | Help I

=" For more information about how to manipulate categories and entries in
the Report Language Editor, see “The Resource Editor” chapter in the
General Features Guide .

113



Understanding the Report Language Editor

Object Attributes and
Report Titles categories

Values Mapping category

114

The Object Attributes and Report Titles categories both contain a
sub-category per module of PowerDesigner together with a Common
Objects sub-category that contains objects common to all modules.

However the Report Wizard category is only available in the Report Titles
category.

=" For more information about how to translate the name of object
properties in cards, checks, and lists or to translate report titles, see the
““Translating a keyword in an object property value” on page 121" section.

The Values Mapping category contains two sub-categories that both contains
a Standard entry:

Category Used for translation of
Forms Keywords in object property values in cards and checks
Lists Keywords in object property values in lists

The Standard entry is displayed by default and contains a mapping table that
applies to all modules. It displays existing keyword names whatever the
model in the Name column and their replacing value in the Value column
that is used when the report is generated or previewed.

You can customize the default mapping tables. They are always used for all
modules unless you define a mapping table for a particular module.

A Standard mapping table looks as follows:

"i‘ Report Language Properties [For All Reports) M= E3
General |
S o IENG:VaIues MappingFormshStandard j Q - n - ?i’ ?-EB
[¥t Engish _
[:I Obiject Attributes Wagive: Sl
-0 Repot Titles Cormment -
I+ Values Mapping
E| (23 Forms
[ [T] Een
B[ Lists
----- [I] standard hd|
Walue:
B8] 4 BB X | #
Mame Walue =
1 «Embedded Files> <Embedded Files:
2 <Mones <MNone:
3 <UINDEF> <Undefined:> |—
4 <Undefined: <Undefined: -
5 <Unknowr <Unknowr: =
3 Emnpiy Ermpty =|
Fltle| 4[] (I

ak I Cancel Apply | Help |
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You can only define mappings for boolean values (Yes, No or True, False for
example) and predefined values (None or Undefined for example).

=" For more information about how to customize the default mapping
tables, see the ““Translating a keyword in an object property value” on
page 1217 section.
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Opening the Report Language Editor

You open the Report Language Editor when you need to create or modify a
report language resource file.

You can also modify a report language resource file directly from the Report
Editor by right-clicking an item in the Report Items pane.

=" For more information about how to modify a report language resource
file from the Report Editor, see the ““Translating a report language resource
file” on page 117" section.

< To open the Report Language Editor

1. Select Tools » Resources » Report Languages.

The List of Report Languages is displayed. It displays the alphabetical
list of all the report language resource files saved on your hard disk.

H OHdE@ Ok

Englizh

Frenich

German

Simplified Chinesze
Traditional Chirese

Cloze I Help

2. Select a report language.

3. Click the Properties tool.
The Report Language Editor window is displayed.

Opening the Report Language Editor from the Report Editor

You can also open the Report Language Editor from the Report property
sheet by selecting Report » Report Properties then click the Edit Current
Language tool beside the Language list.

=" For more information about the management tasks, you can perform
from the List of Report Languages, see “The Resource Editor” chapter in the
General Features Guide .
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Translating a report language resource file

In a report language resource file, you can translate:

¢ Name of objects properties in cards, checks, and lists using the Object
Attributes category

¢ Titles of any report item or Report Wizard using the Report Titles
category

¢ Keywords in object property values in cards, checks, and lists using the

Values Mapping category

Translating object property names and report titles

To translate object property names and report titles, you must open a report
language resource file and click each entry individually in the language tree
view to modify its corresponding value in the Value box.

The translations you perform in the report language resource file are visible
in the generated report.

Whatever the category you choose (Object Attributes or Report Titles), you
can apply translations to:

¢ Each module individually (for example Business process Model)

¢ All modules at a time (Common Objects)

Module Category to select Applies to

Unique Conceptual Data Model Each module individually
Object Oriented Data Model
Free Model

Information Liquidity Model
Physical Data Model
Business Process Model
Requirements Model

XML Model

Report Wizard

All Common objects All modules
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Example of a translation
in an object card
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% To translate object property names and report titles

1.
2.

Open the Report Language Editor.

Select the Objects Attributes category if you want to translate an object
property name.

or

Select the Report Titles category if you want to translate a report title.

Drill down to the entry you want to translate.
The name, comment and value for the entry appear to the right of the tree
view.

Type a translation in the Value box and click Apply to commit the
changes.

Click OK to close the Report Language Editor.

A confirmation box is displayed asking you if you want to save the
modified resource file.

The next time you open any report that uses the customized report
language resource file, the generated report will take these modifications
into account.

Performing translation directly from the Report Editor

You can also right-click an item in the Report items pane and select
the Edit command. In the Editor dialog box that is displayed, type
a translation and click OK. Note that the User-Defined check box is
automatically selected in the Editor dialog box, as you are no longer
using the default values used in the report language resource file you
have selected. To revert to the default value, deselect the User-Defined
check box.

You translate the following entry in the Report Language Editor:
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"* Report Language Properties [For All Reports)

General |

S oe o IENG::Dbiect AttributeshBusiness Process Model\Process\Responsible n - W ?-EB

123 Flow Marne: R esponzible

[E3 MessageFormat Comment; ﬂ

+ |23 Orgarization it

L_i_| D Process

[ ActionT ype

i Composzite

i) DrefaultDiagram LI

[ Duration

L] Irnplementer

5 Responsible

-] OrganizationU rit

it Sterectype

“e ] Timeout

]D ResourceFlow

o[ ProcessStar

71 Fesource

-1 Package

223 Report Titles

D Conceptual Data Model ;I
— e

Walue: Fiesponzable du processus

E
[
[
E

ak. I Cancel | Apply Help

How it is displayed in the generated report:

1.1 Card of the Process Sales

Name Sales
Code Sales
Parent <NModel~
Stereotype

F‘.esponsahle duprocessus <MNone>
Composite FALSE
Inplementer “None>

Example of a translation ~ You translate the following entry in the Report Language Editor:
in an object list
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"‘ Report Language Properties [For All Beports)

General |

& =T IENG::DbiectAllributes\Eusiness Process Model\ProcesshDuration n - ﬁ:B

% :[DDSBSSEM ﬂ Marne: Duration
[Z3 MessageFormat Camment; ;I
(23 Organizationl nit
B2 Process

----- [EEd] ActionT ype
----- [ Composite
----- [ DefaultDiagram

----- [EE0] Diwration LI
..... [EED] Implementer Wellyes |Durée{
----- [:kf Responsible

----- [55 Organizationlnit
----- [iLd] Sterectype

----- [EEd] Timeout

-2 FesourceFlow
=-[23 ProcessStart
-2 Resource

-2 Package

- Report Titles

[:l Conceptual Data Model ﬂ

0K I Cancel Apply Help

How it is displayed in the generated report:

4 Process list

Name Code [ Durée |
Sales Sales 20 days
Command Command 10 days
Order Order 5 days

Example of a translation ~ You translate the following entry in the Report Language Editor:
of a report title
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"‘ Report Language Properties [For All Reports)

General |

& =T IENG::HeportTitIes'\Business Froces: Maodel\DrganizationlnithDies n - ﬁ:B

D Conceptual Data kodel ﬂ
[Z3 Comman Objects
{23 Object Driented Model Camment: ;I
D Phyzical Data Model
E|D Business Process Model
D Diagram
EICI Qrganizationlnit
[T Annatation [
[ AttachedBules list
[EEc] Book tithe
[Ed] ChildOrganizations lis
[ Description
[ih7 EwterdedDependenc
. P OrganizationUnit carc
-3 MessageFormat
-2 Process
-2 ProcessStart
£
[+

Mame: Dezcription

Walue: Diescription de ['unité d'organisatior] %1TEM

7-27 ProcessEnd

1[0 Decision hd
1| | 3
Ok I Cancel Apply Help

How it is displayed in the generated report:

1.1 Description de I'unité d'organisation Sybase

An organization unit is an optional element that allows you to define which organization is reeponsible for which process. It can
tepresent a company, a system, a service, an organization, a user or arole.
An organization unit is assigned to a process.

Translating a keyword in an object property value
To translate a keyword in an object property value, you must open a report
language resource file and define mappings in a mapping table.
Mapping tables are made up of:

¢ A Name column, which contains the name of keywords in object property
values

¢ A Value column, which contains the value assigned to the keyword

The translations you perform in the report language resource file are visible
in the generated report.

The Values Mapping category allows you to define translations for keywords
in object property values for:

¢ All modules using the default Standard mapping tables in Forms and
Lists categories. You can customize these tables
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Standard mapping table
customization

Mapping table creation
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¢ Each module individually by creating a mapping table and assign it to a
particular module

You can customize the predefined Standard mapping table, which contains
keywords that apply to all modules:

¢ Click the Standard entry in the Forms or Lists category to display its

corresponding mapping table in the right pane of the report language
property sheet.

¢ Click the line that corresponds to the keyword value you want to translate
in the Value column.

¢ Type a translation and click Apply.

¢ The following example shows the translation of the <None> keyword:

"i‘ Report Language Properties [For All Reports)

I [=] B3
General |
S o IENG:VaIues MappingFormshStandard j Q - H T &: ?-EB
[¥t Engish )
+-(Z3] Object Athibutes ez Sl
(23 Repart Titles Comment =
E|Cl Yalues Mapping
ED Farms
[ [T] 'Standard
E1-[Z3 Lists
----- [ standard LI

alue:
B8] 4 BB X | #

I Mame I
Embedded Files:

alue |
i <Embedded Files>

g1

[<LNDEF>

-

<Undefined:

5 |

4 <Undefined: <Undefined: -

5 <Unknowr <Unknowr: =

3 Emnpiy Ermpty =l

LRI R EIEIRN (I
ak I Cancel | Lpply | Help |

In addition of using the Standard mapping table, you can create your own

mapping table that you can associate to a particular module afterwards. To
do so, you have to do the following:

¢ Create a new mapping table from the root of the Forms or Lists category

using the New » Map Item command from their respective contextual
menu

¢ Type keyword names and their corresponding values in the mapping table

The following example shows a new mapping table DisplayMap created
from the Lists category. You cannot use it until you assign it to a particular
module:
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Mapping table
assignment

"t Report Language Properties [For All Reports] | _ O] x|
General |
LIRS IENG:VaIues Mapping'Lists\DisplayMap j J-H- 75
== -
'i; English _ -
v (23 Object Attibutes Hame: Displaytap

[Z3 Repart Titles Cammeant —
=-[23 Yalues Mapping - j
EI[:I Formz
----- |I| Standard
B3 Lists
-2 Physical Data Model LI
Walue:

2,8 4 BB X | #

M ame Walue =
= |tue D
2 falze
-
=
T4 o] ¥[]2]4] I

Qg I Cancel | Apply | Help |

Once you have created a new mapping table, you can assign it to a particular
module.

To do so, you have to recreate the Object Attributes tree view in the Forms
or in the Lists category.

For example if you want to assign a mapping table for columns in a PDM,
you have to do the following:

¢ Create a new category from the Forms or Lists category contextual menu
using the Add » New category command and name it Physical Data
Model

¢ Create a new entry from the Physical Data Model category contextual
menu using the Add » Map Item command and name it Column

¢ Assign an existing mapping table to each property of the Column object
for which you want to translate keywords

The following example shows a mapping table in which each column object
property uses a different mapping table:
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"t Report Language Properties [For All Reports] | _ (O] x|
General |
S = IENG:VaIues M apping'Lists\Physical Data ModelhColumn j Q = n o ?2 ?-EB
[ Englsh e [
(23 Dbiject Atibutes e cmn
[Z3 Repoit Titles Cormnmet =
ED Walues Mapping
=3 Forms
----- |I| Standard
E1-[Z3 Lists
EID Phyzical Data Model LI
Value:
----- DizplayM ap ft== =]
£ X | 4
----- M andhMap " | & a8 |
..... PKMap M ame Yalug =
..... |I| Standard 1 Dizplayed Displapt ap
2 Primary PEMap
= |Mandatory Mandap
-
=
F4] e +]$]2]4] (I

0k I Cancel | Apply | Help |

< To translate a keyword in an object property value

1.
2.

Open the Report Language Editor.

Click the Values Mapping category in the Language tree view to display
its tree view.

. Click the Lists or the Forms category to display its tree view.
. Click a module category to display its tree view

. Drill down to the object for which you want to display the mapping table

to translate.

The corresponding mapping table is displayed to the right of the tree
view.

. Click a blank line in the Name column.
. Type a keyword value to translate.

. Click the corresponding line in the Value column and type the mapping

table name you want to use for the translation of the keyword value that
will display in the generated report.

Click OK.

Each time a mapping applies, the exact content of the keyword in the
Name column is evaluated (disregarding the case) and replaced with its
corresponding translation, which is defined in the mapping table that is
displayed in the Value column.
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Example of a translation
with a mapping table
assigned to a particular

You define the MandMap mapping table in the Report Language Editor that
will be used by another mapping table that you define afterwards:

#% Report Language Properties [For eports
R L P (For Al R ) M= E
module
General |
S o IENG:VaIues MappingtLists'td andid ap j A-H- T 45
[ Engich _
(23 Dbiect Attributes Wame Mandhtzp
(23 Report Titles Comment =~
- Values Mapping
ED Forms
[ [T] Standard
=12 Lists
[=1-(Z3 Physical Data Model =l
Calumn Walue:
- Diizplayhd ap Ne=f:=|
&) X | i
BMEER 1 andhap: =1k 8 x|
- P ap Mame Walue =
----- [ standard = |true M
2 false
CIEIEIRAEIEIEN [>T
oK I Cancel | Apply | Help |

You define the Column mapping table that uses the MandMap mapping
table you have previously defined:

"t FReport Language Properties [For All Reports)

=] E3
General |
S =T IENG:VaIues M apping'Lists\Physical D ata ModehColumn j Q - n - af '?.;’B
[ Englsh T
D Obiject Attributes LG oumn
: [Z3 Repoit Titles Comment -
ED Walues Mapping
=3 Forms
----- |I| Standard
E1-[Z3 Lists
EID Phyzical Data bModel LI
-] |Column Walue:
] Displasttap 0,0 % BB XA
- Mandap
..... PKMap M ame Yalug =
..... |I| Standard 1 Dizplayed Displaytd ap
2 PFrirary F¥.Map
-
lile[+]8]2 ¢ [
Qg I Cancel Apply | Help |

How it is displayed in the generated report:
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1 Table column list

Name

Code ol af F
i a r
5 bl H
¥l d m
i a 2
a i r
F o F
2 b
a1
AU_ID AU_ID o] i <
»
k
B
AU_LHAME AU_LNAME ] M
AU_FHAME AU_FNAME D M
AU_BIOGRAPH AU_BIOGRAFH D
AU_ADVANCE AU _ADVANCE D
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Attaching a language resource file to a report

When you create a report, you can select a report language. The selected
report language is a resource file that contains all the printable texts values
translated in a given language. These values will appear in the generated
report.

< To attach a language resource file to a report

1. Select Report » Reports from the model diagram window.

The List of Reports is displayed. It displays the alphabetical list of all
reports saved in the model. If there are no existing reports, all the tools in
the List of Reports dialog box are grayed, except for the New Report tool
and the Manage Report Templates tool.

HNa<x aaBRB| O

Cloze I Help

2. Select the New Report tool.

The New Report dialog box is displayed. It displays a default report
name.

i New Report
Report name:
Language: IEninsh j IEI

Report termplate: I <MNanes j @

Ok I Cancel | Help |

3. Type a report name in the Report Name box if you want to modify the
default name.
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Selecting a language in
the Report Creation
Wizard
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4. Select a language from the Language list. It displays the available report

languages. English is the default language in which the report is printed.

. Click OK.

Changing the language of a report
You can change at any time the language of a report from the Report
Editor by selecting Report » Report Properties.

The Report Editor window is displayed. If you add to the Report Items
pane an item, which is translated in the language resource file, the item
automatically is displayed translated in that pane.

Opening the report language property sheet

You can at any time edit a report language from the Report Editor
by selecting Report » Report Properties then click the Edit Current
Language tool beside the Language list.

When you create a report using the Report Creation Wizard, the Welcome
page of the wizard allows you to select a language for the title of report
items.

=" For more information about the report Creation Wizard, see the
“Creating a Report Using the Report Creation Wizard” section in the
“Managing a Report” chapter.
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table of contents
UNC path
URL
HTML TOC
reduce size
Show book title in HTML TOC
Show contents in HTML TOC

inch

indented paragraph

independent item
graph
page break
table of contents
text

item
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95

83

93
33,45
95

35
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95
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95

102
95

108
95
95
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102
95
95
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100
100
100

64
55

35
35
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add to report
multiple selection
remove title

Show Title command

J

JPEG
graphic format
justified paragraph

L

language
attach to a report
change in a report
in a report template
layout
card
card items
list item
list items
list
customize columns and filter
enable/disable filter
include external shortcuts
include sub-objects

include sub-objects using same namespace

item

list item
attribute
column
default
default order
extended attributes
format
layout
Layout menu

list report
create
definition
export file
generate .CSV
generate HTML
generate .RTF
generate . XML
import file
List Report Wizard
.LRT file
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49, 51
86
86

95
55

127
127
75

65

62,63

62,63
62,63

18

28
27
27
27
27
28
18
28

properties
result set
List Report Wizard

millimeter
model
report
select
modify
default column title
default title
report template
section
multi-model report
create
header and footer in RTF report
Multi-Model Report Editor
Available Items pane
Report items pane
Show All Items check box

N

navigate in preview
navigation option
home
next
previous
next

o

object
define ordered selection
report
report item
object-dependent item
modify
report item
open
preview
Report Language Editor

P

package
hierarchy
report item
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18

64

2,12,109, 110
75

39
39
79
70
2,14, 15
14
91
2
30
30
30
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95
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45
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page break

HTML
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page setup
paragraph

frame

indent

justify

numbered

tab space
percentage
PNG graphic format
position item in report
preview

close

display

navigate

open

print

quick access

report

report item

search
previous
print

preview

report

R

remove title item
report
add folder
add item
calculated collection
code
comment
copy item
create with List of Reports
define default font
delete item
dependent item
depth level
display preview
extended collection
filter criteria
font
format
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generate

generate HTML file
generate RTF file
generation folder
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global object selection
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HTML presentation template
include external shortcuts
language

mapping table

model

modify

modify default column title
modify default title
multi-model

multi-select items

name

no paragraph numbering
object selection in report items
outline

package tree view

page break

page setup

paragraph

position item

presentation template
preview

print

properties

quick generation

refine object selection
report model

report template

Report Wizard

RTF Format

RTF presentation template
save

save size

select object

sort criteria

summary

title page

toolbar

translate object property value
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49

42
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88
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select language
Report Editor
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organize
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Show All Items check box
report folder

object-dependent
report item

book

dependent

format

independent
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modify title

object

object list

object-dependent

package

quick preview

title

type
Report Items pane
report language

define

resource file

translate

translation examples
Report Language Editor
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translate resource file
Report menu

List Report Wizard
report template

create

language
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Report Template Editor
Report Wizard

templates
ReportWizard

calculated collection

extended collection
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30
30
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105
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resource file for report language 112,117, 127
result set
define 25
General tab 25,26
generate 26
preview 26
print 26
properties 25
RTF format 91
RTF Format tab 91
RTF presentation template 91
RTF report
customize 91
generate from preview 108
properties 93
table of contents 91
RTP
file 75,79
save 75,79
S
save
report 110
Save As Default in HTML report 95
save selection 42
search in preview 106
section
create 67
delete 74
header and footer 91
modify 70
numbered 83
organize Report Editor 67
rename 73
selection
confirm 42
save 42
type 42
set as default HTML format 102
shortcut
card 66
include in a report 42
Show All Items check box 30
Show book title in HTML TOC command 100
Show contents in HTML TOC command 100
Show levels to list 52
Show Title command 86
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associated files 101
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customize 95
HTML report 95
structure 96
summary
report 89
title page 89
SVG graphic format 95, 102
T
tab
alignment 59
format 59
position 59
tab space in paragraph 55
table
column 64
default 64
table of contents
HTML report 95
independent item 35
limit depth level 52,99
RTF report 91
template
apply default values 71
create from a report section 78
modify 79
re-apply default values 71
report 75
text
edit 61
font 54
format 51, 54, 55
independent item 35
title 38,51
title page 89
text paragraph 35
title
format 51
free text 38
modify default 39
removed from report 86
report item 38
text 38,51
title page
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report 89
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version 89
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customize columns and filter 42
deselect all 42
enable/disable filter 42
include external shortcuts 42
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include sub-objects using the same namespace 42
move selection to bottom 42
move selection to top 42
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toolbar
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report 30
translate report language 117
TXT file 35
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