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Workflow

Workflow

Sybase Unwired WorkSpace Visual Studio Edition tutorials explain how to develop, deploy, and run a mobile application.

Table 1. Visual Studio tutorials

Task

Goals

Tutorials required to achieve the goals

Getting Started

Install Sybase Unwired
Platform, start the server
and Unwired WorkSpace,
and create a project.

Installing Sybase Unwired Platform on page 7
Starting Unwired Serveron page 7

Connecting to Sybase Control Centeron page 7
Starting Sybase Unwired WorkSpace on page 9
(Optional) Learning the Basics on page 10
Creating a Mobile Application Project on page 11

Note: These tutorials are prerequisites for all the other tutorials. You
need to perform them only once.

Developing Database Mo-
bile Business Objects

Create two mobile business
objects, and deploy them to
Unwired Server.

Creating a Database Connection on page 15

Creating a Server Connection on page 18

Creating Database Mobile Business Objects on page 19

Creating a Relationship Between Mobile Business Objectson page
23

Deploying the Database Mobile Business Objects on page 25

Developing a Device Ap-
plication

Create a Windows device
applicationand runiitina
device emulator.

Generating Code for a Device Application on page 29
Installing Synchronization Software on page 32
Deploying and Running the Device Application on page 33
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Getting Started

Getting Started

Goal: Install and learn about Sybase Unwired Platform and its associated components.

The following tasks are required, unless otherwise noted, for all tutorials, but you need to perform them only once.

Installing Sybase Unwired Platform on page 7
Starting Unwired Serveron page 7

Connecting to Sybase Control Centeron page 7.
Starting Sybase Unwired WorkSpace on page 9
(Optional) Learning the Basics on page 10
Creating a Mobile Application Project on page 11

S O A

Installing Sybase Unwired Platform
Goal: Install Sybase Unwired Platform.

Install these Sybase Unwired Platform components:

e Unwired Server
e Sybase Unwired WorkSpace (Visual Studio Edition)
e Afaria

If Unwired Platform is already installed and any of these components are missing:

1. Start the Sybase Unwired Platform installer.
2. Follow the instructions in the installation wizard. When prompted, select Custom Install.
3. Select the required components, and complete the installation.

For complete installation instructions, see the Sybase Unwired Platform /nstallation Guide and Release Bulletin at
SyBooks Online.

Starting Unwired Server
Goal: Start the server.

In Windows, select Start > Programs > Sybase > SybaseUnwired Platform >Unwired Server > Start Unwired
Server .

The server starts. Icons for the MobiLink server and a consolidated SQL Anywhere database server appear in the
taskbar.

Connecting to Sybase Control Center

Goal: Open the Web-based Sybase Control Center administration console to manage Unwired Server and its components.

From Sybase Control Center, you can:

* View servers and their status

Getting Started Tutorial - Visual Studio Edition 7
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Getting Started

+ Start and stop a server

e View server logs

« Deploy a mobile application package
e Set role mappings

1. Select Start > Programs > Sybase > Sybase Control Center .

2. Click Unwired Platform.
Available servers display under Unwired Servers.

3. Select the server to which you want to connect, and log in using the default login:
e User Name — supAdmi n
e Password —s3pAdmi n

4. To perform any of these server-administration tasks, select the General tab:

e Start

e Stop

* Restart
* Ping

e Clean

Home Device Management  Unwired Platform

Walcome: supAdmin @ Logout from LDICKENS-VSYHM
Untdired Servers General Properties Pending Changes
¥ (=) SUP Server_1@ldickens-y
=log

Manzge an Unwired Server by checking the stabus of & server or chanping its runtime stats

e PR - | W Stp || (& Restart @Ping || . Clean |
(& Personalz ation Server Console
[ Subseriptions
i U=ers

® = Security

i Server Configuration

=ik Connecions

5. To view any of these server configuration properties, select the Propertiestab:

e Host

* Port

e Secure Port

e Synchronization Port

e \ersion

e Unwired Server Home

e Synchronization Protocol
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[2 A
B

Home

Device Management

Unwired Platform

Welcame: supadmin

| Unwired Servers

&) Logout from LDICKENS-YSYM |

General Properties Pending Changes

45 Log

¥ [=Packages
(&' Personalization
[i¥ subseriptions
i Uzers

» = Secunty

S Cannections

¥ (= SUP Server_1@ld icken |

W Server Corfiguration

Review configured Unwired Server properties.

| Properties Value

. Hast Idickens-vavm
Fort 4040
|| secure Port 4443
Synchronization Port 2439

ersion 1.2,20090217

Unwired Server Haome

CAsSybase\Unwiredplatform-1_2\Servers i

Starting Sybase Unwired WorkSpace

Goal: Start Unwired WorkSpace.

1.

In Windows, select Start > Programs > Sybase > Sybase Unwired Platform > Sybase Unwired Wor kSpace

(Visual Studio Edition) .

Sybase Unwired WorkSpace opens, and displays the tasks required to develop a mobile application.

1 SUP107 - Microsoft Yisual Studio

=0

)

=N 0 N

i

Fle Edi Wiew Pro@d Debug  Tools  Test  Window  Help

ke " TP " T ] e o R | -
al ..|_ e R A |

- [ seMenegedCient

T ] 2 ]

Tk s

-0 x| -

-

agms B

Saltin B, - 0 2

Cresting project SUFTutarisProject suwpref .. project creation successful.

{5 Mabile Application Disg... | |[ G0 i Vel Shuo ot paoe [7] Lowd the page during sarhun =
Kol o | o Soldien SLRLOL L
= Mabda Business Cbiect i E = Q) SUPTutorizlProl)
# Attrbue é/ [ SUPTutoridll
& Ogeration
& Relztonsin Getting Started with Sybase Unwired WorkSpace
.:| Fie Syhase Unvired WorkSpace hiles 1he oewvel nt of mabike applications tn exctend data from the
[ General ||| enterprisetothe frontine,
UEing Svbasa Urewired WorkS pace, dexelog @ mobila apelication, which s anendo-and application
thatincludes the mobile husiness obizct (MBD) definifion with i back-end data connection, atributes, :
operetinns, end relations hips | the generated semar-side eade, and the device applicat on. < Il |*
Sarvar Explorer > X oAkt [y s, |
E ! l_*% ! The Tolloewitg ta3 ks Huld e ol thiou Eh i deselop ment process. "l‘_—‘t‘
i . = |Henie fpak . w 3 X
H d Data Cornections Dewelop a Mobile Business Object: Dewelop a mohile business ohject o encapsulale business B
® JAP arnectins process Ingic and dats into & reusable unit Lising the biobile Application Disgram, creste ME0s with = e
7 servers oparefians and aftoutes and bind each ME0 (0 a deta Source whenyou are ready, Or dreg and dopa & [ Skt SHELTL
14 o Unwared Sarver Connecth data 50 ured 10 graate the B diresty o the dats souree viih dmmed iaba binding . R il
M Fy wen service ConnEctons ; 3
Package amd Deploy. Deploy the project, or alfematively packaoe and deploy MEDs, from the
developrmeant e rviranm ent 1o Unwire o Serer Then man age them using the administrative console.
Develnp a Device Application: Oenerste the clizrd code, develop the devics applicetion user inferface
and degloy the deviee application Tor esting on 3 mobi e devics eprlatar
R i Derdce: Applcation Trom a Mobile Desice: Log in, sy chianize data with Uiedna d Seraer and
create, updale, and delele dats records, all from the mohile device, smart phone, laptop, or notz book, B
Online Help. The Syhace Unkirad'WarkSpace online halp guidaeyou through thesa and other lasks. [pe
n m i e e e
QUL -0 %
Shaw oubpt Fram;. Canstrant aldation I e e 0 = i o] B
_:)I'-..-: Lt | =) Cutput @Md:ll... Py |I

|
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2. To read more about Sybase Unwired WorkSpace concepts and tasks, from the main menu bar, select Help >
Contents, and expand Sybase Unwired Work Space.

Learning the Basics

Goal: Learn about Sybase Unwired WorkSpace and how to access help.

1. Start Sybase Unwired WorkSpace on page 9.

The Getting Started page displays a brief description of the tasks you must perform to develop a mobile application.

2. To close this page, click the X.

You can reopen this page by selecting Help > Getting Started with Sybase Unwired Work Space.
3. Look at the windows that you will be working in to access, create, define, and update mobile business objects.

The following table provides a description of the windows.

Window

Description

Solution Explorer

This window displays open Visual Studio solutions, including their
projects. and project resources. In Sybase Unwired WorkSpace, a
project contains mobile business object definitions model files and
other application items.

You can select a project file, or item, in the Solution Explorer and then
perform item-management tasks. You can use an editor to change or
manage the item outside the context of a project.

Mobile Application Explorer

This window displays mobile business objects, roles, personalization
keys, relationships and connection references.

Use this window to review and modify mobile business object prop-
erties.

Server Explorer

A window that provides functionality to connect to various enterprise
back-end systems; for example, database servers, SAP servers, and
Sybase Unwired Server.

Toolbox

The Toolbox provides controls, such as a mobile business object,
attribute, operation, and relationship, that you can drag and drop onto
the mobile application diagram to create and define a mobile business
object.

Mobile Application Diagram

The mobile application diagram is a graphical editor where you create
and define mobile business objects.

Use the mobile application diagram to create a mobile business ob-

ject, then create and define its operations, attributes, and relationships
between other mobile business objects. You can create mobile busi-
ness objects in the mobile application diagram using its menus, or you
can drag items from the Toolbox and Server Explorer and drop them
onto the mobile application diagram to develop the mobile business
object.

Each new mobile application project generates an associated mobile
application diagram.

Properties

The Properties window displays the properties of the selected object.

Selectan object in either the mobile application diagram or the Mobile
Application Explorer to display and edit its properties in the Proper-
ties window.

4. To access the online help, select Help > Contents from the main menu bar.

10
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The Contents window opens.
5. Expand Sybase Unwired Work Space.

The online help provides tasks, concepts, and reference material to guide you through the development process.

Creating a Mobile Application Project

Goal: Create a Visual Studio solution and a mobile application project, understand the project metadata that is created,
and where it resides.

1. Select File > New > Project from the main menu bar.

“ Getting Started with Sybase Unwired WorkSpace - Mi
[File | Edit View Tools Test Window Help

New P | 2] Project... Ctri+Shift+N | |
Open P | @ | web Site... Shift+AILHN  w
Close (1| File... Ctri+h |
. 5 Project From Existing Code...

crl+s [ ] v

SINE SEIELIEO oM s Getting Started with Sybas
i@l | save all Ctrl+Shift+5

Sybase Unwired Work Space enables
t Template to the frontline.

The New Project wizard opens.
2. In the Project types pane, select Sybase Unwired Work Space.
By default, Mobile Application Project is selected in the Templates pane.
3. Set Nameto SUPTut ori al Proj ect .
4. Check Createdirectory for solution, then set Solution Name to SUP101.
5. Click OK.

The new solution and project display in the Solution Explorer. The project contains a SUPTutorialProject. mbofile that
stores mobile business object design-time metadata.

Getting Started Tutorial - Visual Studio Edition 11
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Solution Explorer - Solution 'SU... + 1 X

[54 Solution 'SUP101' (1 project)
= & SUPTutorialProject
| 24 /SUPT utorialProject. mbo!

3l Solution Explorer 2 Class View

6. Expand SUPTutorialProjectin the Mobile Application Explorer.

The Mobile Application Explorer displays the logical organization of the metadata defined in the .mbo file. By default,
two personalization keys, password and username, display. Personalization keys are described in the Implementing

Personalzation Keys tutorial.

Mobile Application Explorer v 1 X
= liSolution 'SUP101' (1 project) |
.4 SUPTutorialProject
[ Mobile Business Objects
—-[_1 Personalization Keys
M7 password
M7 username
[ Roles
[J Connection References
[ Relationships

7. Look at the Properties window.

By default, each project is assigned a package version. You can change the version in the Properties window. For this
tutorial, use the default version. Versions are used to deploy multiple versions of the same application (mostly in
production or test environments) and can be changed at deployment time as well.

12 Sybase Unwired Platform 1.2



 Properties + 1 x
SUPTutorialProject Project Properties -
Package Name SUPTutorialProject
Package Version 1.0
Project File SUPTutorialProject.suwpro
Project Folder C:\Documents and Settings\s
Package Version

The version number for all deployments made from this
project

|@ Mobile Application Explorer|§ Properties

Getting Started

Getting Started Tutorial - Visual Studio Edition
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Developing Database Mobile Business Objects

Developing Database Mobile Business Objects

Goal: Create two mobile business objects, each using a database object as its data source; create a relationship between
the two, and deploy them to Unwired Server.

Prerequisites
Complete Getting Started on page 7

Develop the database mobile business objects by:

Creating a Database Connection on page 15

Creating a Server Connection on page 18

Creating Database Mobile Business Objects on page 19

Creating a Relationship Between Mobile Business Objects on page 23
Deploying the Database Mobile Business Objects on page 25

o~ w DR

Creating a Database Connection

Goal: Create a connection to a database to provide a data source for one or more mobile business objects.

Prerequisites
Complete Getting Started on page 7

1. Inthe Server Explorer, right-click Data Connections, and select Add Connection.

Server Explorer >~ 1 x

B

Refresh
- 54 Serversg
p- alate
7 M g
5 B2 Unwire Add Connection...
- k= My U Create Mew SQL Server Database...
¥ Web Se —

2. Inthe Add Connection dialog, select Use Connection String, then click Build.

Getting Started Tutorial - Visual Studio Edition 15



Developing Database Mobile Business Objects

Add Connection E

Enter information to connect to the selected data source or click
"Change" to choose a different data source and/or provider.

Data source:

.MET Framewaork Data Provider for ODBC

Data source specification

() Use user or system data source name:

(*) Use connection string:

Login information
User name:

Password:

Advanced...

Test Connection K Cancel

3. To the right of DSN Name, click New.

N o g k&

Select Data Source ﬁ

File Data Source | Machine Data Source

Look in: |Data Sources [V]

DSMN Name:

Select the file data source that describes the driver that you wish to connect to.
You can use any file data source that refers to an ODBC driver which is installed
on your machine,

[ ok || cancel ][ Hep

In the list of database drivers, select SQL Anywhere 11, then click Next.

Enter sanpl edb as the data source name, then click Next.
Click Finish.
In the Connect to SQL Anywhere dialog, enter:

16
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Developing Database Mobile Business Objects

e User ID -dba.
e Password - sql

Connect to SQL Anywhere E

Login |ODBC Database | Metwork | Advanced

() Use integrated login
(%) Supply user 1D and password
Usger ID:

Password:

[] Encrypt password

[ ok |[ canced |[ Hep |

8. Click OK twice to return to the Add Connection dialog.
9. Click Test Connection. Click OK to close the message box that displays the test results.

Getting Started Tutorial - Visual Studio Edition 17
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Enter information to connect to the selected data source or click
"Change" to choose a different data source and/or provider.

Data source:

.NET Framework Data Provider for ODBC

Data source specification

() Use user or system data source name:

() Use connection string:
Driver=(sqL Anywhere | MiCrosoft Visual Studio E

Login information \lz) Test connection succeeded.

User name: dba

Password: e

Test Connection 0K H Cancel I

10. Click OK to close the Add Connection dialog.

In the Server Explorer, the database connection displays beneath the Data Connections node.

Creating a Server Connection

Goal: Create a connection to Unwired Server, so you can deploy mobile business objects and device applications to the
server.

Prerequisites
Complete Getting Started on page 7

1. Inthe Server Explorer, right-click Unwired Server Connections, and select Add Connection.
2. Enter the connection details for the local server, then click OK.

Field Enter these values

Name My Unwired Server

Host name <your host nanme>. <donai n>
Port Number 4040

User name sSupAdmi n

Password s3pAdni n

18 Sybase Unwired Platform 1.2



=) Add Sybase Unwired Server Connec...

=] %

Enter information to connect to the Sybase Unwired Server.

Mame: My Unwired Server

Description:

Host name:  |snigamup.sybase.com

Port number: 4040

Login information
supAdmin

—

User name:

Paszswaord:

ox

l [ Cancel

3. Click Test Connection to verify that the server is running.

4,

Developing Database Mobile Business Objects

A dialog displays the connection status. If successful, click OK; otherwise, verify that the server is running.

Click OK to finish adding the connection.

Creating Database Mobile Business Objects

Goal: Create two mobile business objects, each from a database object.

Prerequisites
Complete Creating a Database Connection on page 15 and Creating a Server Connection on page 18

1

Open the SUP101 solution if it is not already open:

a) In the Visual Studio main menu, select File > Open > Project/Solution .

b) Select the SUP101 folder, and click Open.
c) Select SUP101. sl n, and click Open.

In the Server Explorer, expand the database connection that you created, then expand the Tables folder.
Select the customertable, and drag it onto the Mobile Application Diagram.

Server Explorer ~ 1 x

EIRERRS |
= [JJ Data Connections A
= [ ODBC.UADB_SNIGAMXP l
- [d Tables
+- [ bonus
= call_track
1 contact

1 department

1 employee

= fin_code

= fin_data

= product A
1 sales_order el

e OO OO O ] O Y O

Getting Started Tutorial - Visual Studio Edition
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Developing Database Mobile Business Objects

The Mobile Business Object Creation wizard launches.
4. Inthe introductory page, click Next.

5. By default, the MBO is named the same as the database table; in this case, customer. Click Next.

The connection information matches the database connection that you created.

bbb bbb §=X
i L Specify Connection Information
= —

Enter connection information

(*} Define connection now

Connection type: | Database ' “J'

Connection name:  ODBC.UADB_SHIGAMXP || mew.. |[eroperts.. |

) Define connection later

6. Click Next.

7. On the Authentication Information page, select Use Default Authentication, and click Next.
8. On the Specify SQL Query page, click Next.

20 Sybase Unwired Platform 1.2
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Mobile Business Object Creation Wizard - @ﬁ
A Specify SQL Query
T Specify the SQL query. You can choose to automatically generate the SQL query or to define it using the
Visual SQL Designer. If you manually define the query and switch to defining it automatically, you will
lose the contents of your manually-defined query.
) Generate SQL query from the selection
& ~ O& ~
o= 0=
]| = ]| =
[ [ [ [E=|
=] Q&
o= 0=
[ [E=| ([
03 vl | =03 0
(&) Define the SQL query manually
SELECT id, -~
fname,
Iname,
address,
city, =
state,
zip,
phone,
company_name [vl
Validate Syntax ” Visual SQL... ” Preview Data... I
l < Previous ” Next = I [ Finish } l Cancel

9. On the Column Filters page, click Next.

10. On the attribute mapping page, the MBO attributes display on the left, and the database table columns display on the
right. The lines illustrate how the database columns map to the MBO attributes, as does the tabular view in the lower
half of the page. Click Next.

Getting Started Tutorial - Visual Studio Edition 21
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Mobile Business Object Creation Wizard @
ls & Specily Attributes and Map the Altributes 1o Columns
JiE
Object: 5 e Tabular View:
| = & customer = [ Columns
= [ Attributes — 3] id [Int]
4 id [Int] __,_._._--——""_#_._P =1 fname [String]
# fname [String] -‘—-f._r_____,__,_._r——-i- =] Iname [String]
# Iname [String] 17_“;___'___,.!—& =] address [String]
# address [String] 17‘_#!__;_,_...-—-—1- Z] ity [String]
# city [String] 4—-_#;—_‘___,..-—& 2] state [String]
4 state [String] 1——'__’_._—_______.-—-—& =1 zip [String]
# zip [String] *—f__r,__._._--——i- Z] phone [String]
# phone [String] 17{__4{__,,.#% =] company_name [String]
# company_name [String] +——
ez = R SR S ¢ 2
| : Name Data Type Map To | Data Type " |
r Tie It Lv lid: v it '
| friame | String |2 ]| fname || String
| Iname | String |3 | Iname v || String
iuddress | String V addrass | String
| city | String. [oe | city ¥ | string ,
| etate | Skrinn Ll etare » || Shrina Vl
| <previous || net> | rFmsh | [ concel |

11. On the parameter mapping page, click Next.
12. On the Operations page, click Finish.

Basic MBO operations are created automatically: Cr eat e, Del et e, and Updat e, and the customer MBO appears
in the Mobile Application Diagram.
S —

e

= Attributes
5 id : Ink

fname : String

Inarne : Skring

address : Skring

city : Skring

skate ! String

zip & 3tring

phone @ String
cormpany_name @ String

LCOLLLOLLIL

(=] Operations
o Create

% Update
' Delete

=) Parameters

i =l Roles

13. Create another MBO from the sales_ordertable:
a) Drag the sales ordertable from the Server Explorer, and drop it onto the Mobile Application Diagram.
b) Step through the wizard by clicking Next on each page.

c) Onthe SQL query page, click Preview Data to verify the results, then close the results dialog, and click Next in
the wizard.
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Developing Database Mobile Business Objects

d) On the attributes mapping page, review the mapping, then click Finish.

By custamer

= attributes

id ¢ Int

frame : String

Iname : String

address : String

city : Skring

skabe @ String

zip : Skring

phone : String
company_name : Skring

COULLLOLCTQ

-| Dperations

4 Create
#" Update
' Delete

Parameters

Roles

E3]

| Aktributes

v
v
]
]
]

]

id ¢ Int

cust_jd ; Ink
order_date : Date
fin_code_id : Skring
reqgion ¢ Skring
sales_rep : Int

| Operations

A" Create
2" Update
¥ Delete

|| = Parameters

| Roles

&

Next

Creating a Relationship Between Mobile Business Objects on page 23

Creating a Relationship Between Mobile Business Objects

Goal: Create a relationship between mobile business objects to associate related data and maintain data synchronization
on the device.

Prerequisites

Complete Creating Database Mobile Business Objects on page 19

In this tutorial, you create a relationship between the customerand sales_order mobile business objects (MBO).

1. Click Relationship in the Toolbox.

2. Select the customer MBO and keeping the mouse button pressed, drag the link to the sales order MBO to establish
the relationship link.

The Relationship Creation wizard opens.
3. Select the id attribute in the Sour ce object pane and cust_id in the Target object pane.

Getting Started Tutorial - Visual Studio Edition
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BEE

Relationship Creation Wizard
'k Create a new Relationship
To create a new relatonshp, enter the required relationship information.
MName:  [Reationshipl
Source: io.:strmer l]
Target: jsales_wda ﬂ
Mubphcty
* One to many ™ One to one
Source object: S| Target object:
= [ customer - = B sales_order
SEE | Am-bfubes =1 3 Atributes
i~ # iy ] L
# frame [Strng] » st fing]]
@ Iname [String) # order_date [Dats]
# address [String] » fin_code_id [String]
@ city [String] # region [Strng)
 statell [String] # saies_rep [In3]
@ 2ip [String] = J PArAMBLES
@ phone [Stang]
# company_name [String] ﬂ
| Fnish Caneel

4, 7

Click the Mapping button

A line connects the two attributes.
5. Enter cust oner _sal es_or der in the Name field for the name of this relationship.

Relationship Creation Yizard

l.&' Create & new Relationzhip
£ g To create a new relatonship enter the required relatonship information,
Mame: customer_sales_order| |
Source: customer w !
Target: sales_order s |
Muktiphcity
) One to many ) One to one
Saurce abject: L Target object;
'= 3 ﬁttnbm:s A ; = 5 sdles_order
3 = 3 Attribukes
3 fname [Steing] \ 3 id[1nt]
# Inzme [String] i N5t id [Int]
# address [String] # order_date [Dake)
# city [String] # fin_code_id [String]
# shate [Fring] # region [String]
@ =ip [String] # sales_rep [Int]
# phore [String] 4 Parameters
# company_mame [String] Z
[
I Firish | [ Cancel

6. Click Finish.
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The mobile application diagram now shows the link from the customer MBO to the sales_order MBO.

B customer E3] B sales_arder E3]
I=l Atkribukes I= Atkribukes
W id: Int W oid: Int
@ fname : String W cust_id: Ink
W Iname : String W order_date : Date
W address : String L.t @ fin_code_id : String
W city 1 String 5o W region : String
W state ! String i sales_rep : Int
W zip : 3tring [= Operations
¥ phone : Skring % Create
. [ cu:unl'upany_name : Skring P Update
= Operations ¥ Delete
¥ Create [=l Parameters
2% Update = Rales
' Delete
[= Parameters
1= Roles

7. Select File > Save.

Next
Deploying the Database Mobile Business Objects on page 25

Deploying the Database Mobile Business Objects

Goal: Deploy the project that contains the database mobile business objects to the server.

Prerequisites
Complete Creating Database Mobile Business Objects on page 19 and Creating a Server Connection on page 18

1. In the Solution Explorer, right-click SUPTutorialProject, and select Deploy to Unwired Server.

Solution Explorer - SUPT utorialProject ~ 0 X
2 |

Add 4
Add Reference...

Q}‘ Add BlackBerry Reference...

Set as StartUp Project

Debug »

View Mobile Application Explorer
View Mobile Application Diagram
Generate Client Code...

Deploy to Unwired Server...

& | Cut

X | Remove
n::iJSnIutiun E Rename
Mobile Appli Unload Project

= [ Solut] 2| Properties
A Qe
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. On the Introduction page, click Next. By default, the Introduction page displays only once. Unselect this option to
show the page again the next time you deploy.

. Select My Unwired Server, then click Test Connection. If the connection is successful, click Next; otherwise, verify
the connection parameters—see Creating a Server Connection on page 18.

. Onthe Mobile Business Object Selection page, verify that both the customerand the sales orderMBOs are selected,
then click Next.

. On the Confirm Package and Version page, accept the default values, and click Next. The package name
(SUPTutorialProject) and the version number (1.0) correspond to the name of the Unwired Server package, into which
you deploy the MBOs.

. On the Deployment Mode Selection page, accept the default value (Update), and click Next.
. On the Logical to Physical Role Mapping page, click Next.
. On the Server Connection Mapping page:

a) Expand My Unwired Server > Mappable Connection Profiles > Database, then select the active database
connection.

b) Map the design-time database connection to the server-side database connection by selecting sampledb as the
Server Connection Name.

c) Click Next.
Sybase Unwired Server Deployment Wizard ﬁ
'.kl'l Server Connection Mapping

The connection information that a mobile business object uses can be changed to
point to a server connection. A custom mapping means that the default
authentication information was overriden in the mobile business object.

Select a design time connection profile to map

= & My Unwired Server
= Mappable Connection Profiles
=1 Database
[J ODBC.UADB_SNIGAMXP
3 sAP
{1 Custom
[1 Mon Mappable Connection Profiles

Design Time Connection Name Server Connection Name

ODBC.UADB_SNIGAMXP v

<New>
FieldServiceDB.ffa

sampledb.sampledb
uaml

Connection profile ODBC.UADB_SMNIGAMXP is not ma

< Previous lext = Finish Cancel

9. On the Summary page, click Finish.

Deployment proceeds, and its progress displays.
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Sybase Unwired Server Deployment Wizard
' L Deployment Progress
=

- The results of the current deployment are shown below.

Status:  peployment succeeded. Please click the Close button to close this window.

Deployment started on Tuesday, September 23, 2008 at 3:50:08 PM
Deploying to server My Unwired Server

Starting to build deployment unit for package SUPTutorialProject

Created C:\Documents and Settings\snigam\My Documents\Visual Studio
2008\Projects\SUP101\SUPT utorialProject\Temp_Deployment_XML\Package_ XML\SUPT utor
ialProject_My Unwired Server.xml

Deploying to package SUPT utorialProject on server My Unwired Server using deployment
mode DeploymentModeUpdate

Deployment: SUCCEEDED
Finished deploying to server My Unwired Server
Deployment took 0 minutes and 2 seconds

10. After deployment completes, click Close.
11. In the Server Explorer, expand Unwired Server Connections, right-click My Unwired Server, and select Refresh.

The server package SUPTutorialProfectv1.0into which you deployed the MBOs appears in the Packages folder. The
two MBOs appear in the package's Mobile Business Objects folder.

Server Explorer +~ 1 X
EIREIRSS.
+- H SNIGAMXP
= lj_};i Unwired Server Connections
= k= My Unwired Server
= [ Packages
. (1A FieldServiceApp_1.0.0
¥ (% suP101_1.0.0
= I iSUPTutorialProjectvl.0 |
+- [ Logical Roles
+- [ Logical to Physical Role Mapp
= [ Mobile Business Objects
- [ customer
+ [ sales_order
¥ (% TEST101 1.0.0
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The deployment unit (metadata) is saved in a temporary directory on Unwired Server, in the SUPTutorialProjectv1.0
project. Using Sybase Control Center, administrators can deploy the MBQOs in the deployment unit to other servers.
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Developing a Device Application

Goal: Develop a Windows device application, and test its functionality.

Prerequisites
Complete Deploying the Database Mobile Business Objects on page 25

The device application communicates with the database mobile business objects that are deployed to Unwired Server.
Develop the device application by:

1. Opening the SUP101 solution if it is not already open:
a) In the Visual Studio main menu, select File > Open > Project/Solution .
b) Select the SUP101 folder, and click Open.
c) Select SUP101. sl n, and click Open.

2. Generating Code for a Device Application on page 29
3. Installing Synchronization Software on page 32
4. Deploying and Running the Device Application on page 33

Generating Code for a Device Application

Goal: Generate client code for a mobile application project, so you can develop the device application to run on a mobile
device.

Prerequisites
Complete Developing Database Mobile Business Objects on page 15

1. Inthe Solution Explorer, right-click SUPTutorialProject, and select Gener ate Client Code.

Solution Explarer - SUP101

[ Solution 'SUP101' (1 praject)

&dd »
Add Reference...

Set as Startlp Project

Debug 3
Wigw Mobile Application Explarer
Wiew Mobile Application Diagram
Generate Client Code. ..

Deploy to Unwired Server, .

& | Cut
>( Remaoyve
;,-:3’] Sol Fenarme
pr,.:,pe.: Unload Project

SUPL ._=| Properties
o et

2. On the Introduction page, click Next.
3. On the Specify Target Platform page:
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a) Select Windows Mobile 6.0 Classic or Professional as the Target Platform.
Note: Both the Windows Mobile 6 Standard SDK and the Windows Mobile 6 Professional SDK must be installed.
You can download them from the Microsoft Download Center.

b) Select Generate GUI Frontend from Template

c) For Configuration, enter dot net code, then click the save (disk) icon.
d) Click Next.

Client Code Generation Wizard

» L Specify Target Platform
e Specify the karget platform and its parameters

Code generation parameters

Target platform: | Windaws Mabile 6.0 Classic or Professianal :V.,
Language: C# v
Library version: | NET Compact Framework 3.5 V
MNamespace: Sybase. Mobile. App

Generate GUI Fronkend from kemplate

Configuration:  |dotnetcod "'v,. =3

[ Mext = ll Finish ][ Cancel l

4. On the Select Mobile Business Objects page:

a) Verify that both the customerand the sales order MBOs are selected.
b) Verify that My Unwired Serveris selected for Unwired Server.
c) Click Next.
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5. On the Specify Destination page, enter Devi ceAppl i cat i onPr oj ect 1 as the Project Name, then click

Client Code Generation Wizard

Specify Destination

A

(*) Generate in the same solution

Directory:

Solution name:

Specify the Visual Studio project

Project name:

Configuration:

dotnetcode]

Finish.

Specify where the code needs to be generated

Specify the destination directory and the Visual Studio solution

) Create a new solution

DeviceApplicationProjectl

[] Clean destination before code generation

< Previous

RIEIE

[ Finish

) (conea ]

6. When the code-generation process is complete, click Close.

Client Code Generation Wizard

Code Generation Progress

Ay

Skatus:

i The results of the current code generation are shown below,

Code generation succeeded, Click the Close buttan ko close this windaw,

SiiAnANANANANANANANANANANANANANAANNANANANRANAANRANANG]

Dekails:
Preparing to generate mobile business object proxies

Generating mobile business object proxies
Done generating mobile business object proxies
Adding generated data sources ko the project
Done generating data sources

Generating BOBs from mobile business objects
Done generating BOEs From mobile business objects
Generating Windovs Mobile GUI Fronkend

Done generating Windows Mobile GUT frontend
Cleaning up after code generation

Done cleaning up after code generation

Adding generated classes to the project

Done adding generated classes to the project
Done generating code

Done preparing to generate mobile business object proxies

Clase
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DeviceApplicationProjectl appears in the Solution Explorer.

| Solution Explorer - Solution 'SUP101" {2 projects)
RlACIERES
o Salukion 'SUP101' (2 projects)
= E DeviceApplicationProject1

._'.'.

i
i
i
i

=d| Properties

«j References

| DLLs

| @eneratedCode

|| Resources

=] Afaria.2577.CAB

%] Clientaprshim.di

j Forml.cs

E_I Setup_PPCZ005,5eedData.zip
%] uinet11.dI

= @ SUPTutorialProject

| Temp_Deplovment_xML

=k | Package_xML
2] SUPTutorialProject_My Unwired Server,xrl

I8 suPTutorialProject.mbo

* 0 X

The key client-artifacts are the MBO object code files Cust oner

| Solution Explarer - Solution "SUP101" (2 projects)
2 | [P EL
[ Solution 'SUP101' (2 projects)
= _,_.E DeviceApplicationProjectl

4
®
®

=d| Properties
=] References
[ DLLs
| GeneratedCode
] Customer.cs
#- [ZZ] FormFormCreateCustomer.cs
] FormFormCreateCustomerController . cs
#- |ZZ] FormFormCreateSales_order.cs
] FormFormCreateSales_orderController.cs
#- =] FormFormCustomer o5
] FormFormCustomerController. cs
- [ZZ] FormFormCustomerDetails. cs
] FormFormCustomerDetaisController.cs
#- [ZZ] FormFormSales_order.cs
] FormFormSales_orderController.cs
- [ZZ] FormFormSales_orderDetails.cs
] FormFormSales_orderDetailsController. s
#- [ZZ] FormFormTableOfContents. s
] FormFormTableOFContentsContraller. cs
- =] FormFormpdateCustomer. cs
] FormFormUpdateCustomerController.cs
+ :_'-.='|FnranrmUpdateSaIes_nrder.cs
‘ﬁ FormFarmUpdateSales_orderController.cs
] Tnit.cs
] PersonalizationInit.cs
] Program.cs
] Sales_order.cs

5| Sales orderSvnchronizationParameters.cs

,_-:350Iutinn Explorer 3_}'H'€Class Wiew

Next

-~ 1 X

Deploying and Running the Device Application on page 33

Installing Synchronization Software

.cs and Sal es_order. cs.

Goal: Install and configure Microsoft ActiveSync so you can deploy and run the device application on an emulator.

32
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1. Download Microsoft ActiveSync from the Windows Mobile Web site. Save it to your local machine. Windows XP
requires version 4.5.

2. In Windows Explorer, double-click set up. nsi to run the ActiveSync installer.
Restart your machine.

w

ActiveSync starts automatically, and its icon displays in the Windows toolbar.
Double-click the ActiveSync icon.

Select File > Connection Settings.

In the Connection Settings dialog, select all the check boxes.

Under Allow Connectionsto One of the Following, select DMA.

Under This Computer is Connected to, select Work Network.

© N o g M

12 Connection Settings i|

Waiting for device to connect

bl Connect...

[v Show status icon in taskbar

[v Allow USB connections

v Allow connections to one of the following:
\DMaA |

This computer is connected fo:
|W0rk Metwark LJ

v Open ActiveSync when my device connects

|v Allow wireless connection on device when connected to the desktop

Help OK Cancel

9. Click OK.

Deploying and Running the Device Application

Goal: Deploy the device application to a Windows Mobile 6 device emulator, and test its functionality.

Prerequisites

Complete /nstalling Synchronization Software on page 32

1. From the main Visual Studio menu, select Tools > Device Emulator Manager .
2. Select Windows Mobile 6.0 Classic Emulator, right-click, and choose Connect.
3. Right-click the same emulator, and choose Cradle.
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&7 Device Emulator Manager g@@

File Actions Help

=1 Windows Mobile 5.0 Pocket PC SDE || Refrash

US4 Windaws Mabile 5.0 Pocket PC RZ Emulat
US54 Windows Maobile 5.0 Packet PC R2 Square
=1 \Windows Mobile 5.0 Smartphone SDE
U5 Windows Mobile 5.0 Smartphane B2 QYEA
=1 Windows Mobile & Professional S0k
- EWindows Mobile & Classic Emulator!
wWindows Maohile 6 Professional Emulator
windows Mobile & Prafessional Square Emulatal
windows Mobile & Professional Square QWGA Er
Windows Mobile & Prafessional Square W&EA Emi
Windows Maobile 6 Professional WG4 Emulatar [,

2l @

ActiveSync connects to the device emulator.

& Microsoft ActiveSync g =
File Wiew Tools Help
Jule L_,\f’ Explore
= )
Connected \___/
Hide Details &
Information Twpe Status

4. In the ActiveSync Synchronization wizard, click Cancel.
5. Configure the way the device emulator connects to the Internet:

a) In the device emulator, select Start > Settings.

b) Select the Connectionstab, then click Connections.

c) Select the Advanced tab, then click Select Networks.

d) Under Programsthat Automatically Connect to the Internet Should Connect Using, select "My Work
Network," then click OK.

e) Click OK, then click X.
6. In the Visual Studio Solution Explorer, select DeviceApplicationProjectl, right-click, and select Build.
7. In the Visual Studio toolbar, click the green arrow to the left of Debug.

Window  Help
| f Debug -

The device application is deployed to the emulator, and runs in debug mode.
8. In the emulator, enter these credentials, then click L ogin:
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e Login-supAdmi n
e Password — s3pAdmi n

4] Windows Mobile 6 Classic M=%
File: Flash Help

Login: |supf-‘«dmin

Password: |*****w*

The Table of Contents for the SUP101 solution appears in the emulator.
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4] Windows Mobile 6 Classic =2Ed

File: Flash Help

9. Click sales order to see the table data.

Congratulations! You have successfully developed and run a mobile application.
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ActiveSync, installing and configuring 33
Afaria 7
applications

device, deploying 33

device, generating code for 29

B
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C

connecting to Sybase Control Center 7
connections

database, creating 15

Unwired Server, creating 18
creating

mobile application project 11

relationship between MBOs 23
creating MBOs

database 19

D

database connections
creating 15
database MBOs
creating 19
relationship, creating 23
deploying
configuing ActiveSync for 33
device applications 33
mobile business objects 25
device applications
deploying 33
generating code for 29
running 33
device emulators
deploying applications to 33

E
emulators

deploying device applications to 33
F

Frontline Management 7

G

generating
code for a device application 29
getting started

Index

Sybase Unwired Platform 7
Sybase Unwired WorkSpace 10

H

help, online 10

installing
Microsoft ActiveSync 33
Sybase Unwired Platform 7
synchronization software 33

M

MBOs
See also:mobile business objects 19
database, creating 19
Microsoft ActiveSync, installing and configuring 33
Mobile Application Diagram, defined 10
Mobile Application Explorer, defined 10
mobile application projects
creating 11
deploying 25
mobile applications
generating code for 29
mobile business objects
See also:MBOs 19
database, creating 19
deploying 25

o

online help, accessing 10

P

Properties window, defined 10

R

relationships between MBOs, creating 23

S

server connections

creating 18
Server Explorer, defined 10
Servers

MobiLink 7

SQL Anywhere database 7

Unwired Server, starting 7
Solution Explorer, defined 10
starting

Sybase Control Center 7
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Unwired Server 7

Sybase Control Center 7
connectingto 7

Sybase Unwired Platform
getting started 7
installing 7

Sybase Unwired WorkSpace
getting started 10
starting 9

synchronization software
installing 33

T
Toolbox, defined 10

U

Unwired Server 7
connections, creating 18
deploying MBOs to 25
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Visual Studio Edition
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