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Workflow

Workflow

Sybase Unwired WorkSpace Eclipse tutorials explain how to develop, deploy, and run a mobile application.

Note: To develop a simple database mobile application, complete these tasks.

Table 1. Unwired WorkSpace tutorial goals

Task

Goal

Tutorials required to complete the task

Getting Started with Un-
wired WorkSpace

Verify that:

All required WorkSpace components and
external resources are installed

Servers are started, connection profiles
created, and database data sources are
available

The Web-based administration console
(Sybase Control Center) is running and you
are connected

The Mobile Development perspective is
open, a Mobile Development project is
created, and you are familiar with the var-
ious views of the perspective along with the
Mobile Application Diagram, and Device
Application Designer

Installing Sybase Unwired Platform on page
7

Downloading the BlackBerry JDE and MDS Sim-
ulatoron page 7

Starting Unwired Serveron page 7

Connecting to Sybase Control Center on page
8

Starting Sybase Unwired WorkSpace on page
9

Learning the Basics on page 9

Note: Getting Started is required for all tutorials, but
needs to be performed only once. The other tutorials
require that:

Servers are started

Connection profiles are created

SUP101 Mobile Development project is created
Device Application Designer setup is complete

Developing a Database
Mobile Business Object

Develop two database mobile business objects,
create a relationship between them, and deploy
the project that contains them to Unwired Serv-

er.

Creating the SUP101 Mobile Application
Projecton page 11

Creating the sampledb Connection Profile on
page 11

Creating Database Mobile Business Objects on
page 11

Creating a Relationship Between Mobile Busi-
ness Objects on page 12

Deploying the Database Mobile Business Ob-
Jects on page 13

Developing a device ap-
plication

Create a BlackBerry device application and run
it on the BlackBerry Simulator

Creating the Device Application on page 15
Verifying and Generating Code for a Device Ap-
plication on page 17

Running the Device Application on the Black-
Berry Simulator on page 19

Getting Started Tutorial - Eclipse Edition
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Getting Started

Getting Started

Goal: Install and learn about Sybase Unwired Platform and its associated components.

The following tasks are required, unless otherwise noted, for all tutorials, but you need to perform them only once.

Installing Sybase Unwired Platform on page 7

Downloading the BlackBerry JDE and MDS Simulator on page 7
Starting Unwired Serveron page 7

Connecting to Sybase Control Center on page 8.

Starting Sybase Unwired WorkSpace on page 9

(optional) Learning the Basics on page 9

S O A

Installing Sybase Unwired Platform
Goal: Install Sybase Unwired Platform.

Install these Sybase Unwired Platform components:

e Unwired Server
* Sybase Unwired WorkSpace (Eclipse Edition)

If Unwired Platform is already installed and any of these components are missing:

1. Start the Sybase Unwired Platform installer.
2. Follow the instructions in the installation wizard.
3. Select the required components, and complete the installation.

For complete installation instructions, see the Sybase Unwired Platform /nstallation Guide and Release Bulletin.

Downloading the BlackBerry JDE and MDS Simulator

To generate and distribute device applications built with the Unwired WorkSpace Device Application Designer, download
the MDS simulator and the BlackBerry JDE 4.2.1 from the BlackBerry developers' Web site.

1. Gotothe BlackBerry Web site at /tip.//na.blackberry.com/eng/developers/javaappdev/javadevenv.jsp and download
and install the BlackBerry JDE 4.2.1.

2. Go to http.//na.blackberry.com/eng/developers/browserdev/devioolsdownloads.jspto download and install the MDS
simulator (Bl ackBerry_Enmai| _MDS 4. 1. 2. 17. exe).

Starting Unwired Server
Goal: Start the server.

In Windows, select Start > Programs > Sybase > SybaseUnwired Platform >Unwired Server > Start Unwired
Server .

The server starts. Icons for the MobiLink server and a consolidated SQL Anywhere database server appear in the
taskbar.

Getting Started Tutorial - Eclipse Edition 7
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Getting Started

Connecting to Sybase Control Center

Goal: Open the Web-based Sybase Control Center administration console to manage Unwired Server and its components.

From Sybase Control Center, you can:

*  View servers and their status
 Start and stop a server

e View server logs

« Deploy a mobile application package
e Set role mappings

1. Select Start > Programs > Sybase > Sybase Control Center .

2. Click Unwired Platform.
Available servers display under Unwired Servers.

3. Select the server to which you want to connect, and log in using the default login:
e User Name — supAdm n
e Password — s3pAdmi n

4. To perform any of these server-administration tasks, select the General tab:

e Start

« Stop

e Restart
e Ping

e Clean

SYBASE. Control IZZ:_--nlr

Home Device Management Unweired Platform

‘Walcome: supsdmin @ Logout from LOICKENS-VSYM

Untired Servers General FProperties Pending Changes
¥ ) SUP Server_1@ldickens-

Manage an Unwired Server by checking the status of a server or changing iks runtime stats
& Log

(s Pk gt - | ®mste || & Restart @ Ping || o clean |
(& Personakzation Server Console
il subseriptons
i Uzers

» = Security
g Server Configuration
=@ Connections

5. To view any of these server configuration properties, select the Properties tab:

¢ Host
* Port
« Secure Port

8 Sybase Unwired Platform 1.2



Getting Started

e Synchronization Port

e \ersion

e Unwired Server Home

* Synchronization Protocol

T ST

Home Device Management Unwired Platform

Welcome: supfdmin &) Logout from LDICKENS-VSYM | =

| Unwired Servers General Properties Pending Changes
¥ (= SUP Server_1@ldicken

Review configured Unwired Server properties.

i Log
» =Packages Properties Yalue
[ Personalization Hast Idickens-vsvm
[f subzeriptions Port 2040
W Users | | Secure Part 4443
» G Security Synchronization Port 2439
# Server Configuration Version 1.2.20090217
&k Caonnections Unwirad Server Home CASybase\Unwiredplatform-1_2\Servers
E
i L . —

Starting Sybase Unwired WorkSpace
Goal: Start Unwired WorkSpace.

1. In Windows, select Start > Programs > Sybase > Sybase Unwired Platform > Sybase Unwired WorkSpace
(Eclipse Edition) .

Sybase Unwired WorkSpace opens, and displays the tasks required to develop a mobile application.

2. To read more about Sybase Unwired WorkSpace concepts and tasks, from the main menu bar, select Help >
Contents, and expand Sybase Unwired Work Space.

Learning the Basics

Goal: Learn about Sybase Unwired WorkSpace and how to access help.

1. Starting Sybase Unwired WorkSpace on page 9.

The Getting Started page displays a brief description of the tasks you must perform to develop a mobile application.
2. To close this page, click the X.

You can reopen this page by selecting Help > Getting Started with Sybase Unwired Work Space.
3. Look at the windows that you will be working in to access, create, define, and update mobile business objects.

The following table provides a description of the windows.

Getting Started Tutorial - Eclipse Edition 9
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Window

Description

WorkSpace Navigator

This window displays mobile business objects, roles, personalization
keys, relationships and connection references.

Use this window to review and modify mobile business object prop-
erties.

Enterprise Explorer

A window that provides functionality to connect to various enterprise
back-end systems; for example, database servers, SAP servers, and
Sybase Unwired Server.

Palette

The Palette provides controls, such as a mobile business object, at-
tribute, operation, and relationship, that you can drag and drop onto
the mobile application diagram to create and define a mobile business
object.

Mobile Application Diagram

The mobile application diagram is a graphical editor where you create
and define mobile business objects.

Use the mobile application diagram to create a mobile business ob-

ject, then create and define its operations, attributes, and relationships
between other mobile business objects. You can create mobile busi-
ness objects in the mobile application diagram using its menus, or you
can drag items from the Palette and Enterprise Explorer and drop them
onto the mobile application diagram to develop the mobile business
object.

Each new mobile application project generates an associated mobile
application diagram.

Properties

The Properties window displays the properties of the selected object.

Select an object in the mobile application diagram to display and edit
its properties in the Properties window.

4. To access the online help, select Help > Contents from the main menu bar.

The Contents window opens.
5. Expand Sybase Unwired Wor k Space.

The online help provides tasks, concepts, and reference material to guide you through the development process.

10
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Developing Database Mobile Business Objects

Developing Database Mobile Business Objects

Goal: Create two mobile business objects, each using a database object as its data source; create a relationship between
the two, and deploy them to Unwired Server.

Prerequisites
Complete Getting Started on page 7.

Develop the database mobile business objects by:

Creating the SUP101 Mobile Application Profecton page 11

Creating the sampledb Connection Profile on page 11

Creating Database Mobile Business Objects on page 11

Creating a Relationship Between Mobile Business Objects on page 12
Deploying the Database Mobile Business Objects on page 13

o~ w DR

Creating the SUP101 Mobile Application Project

Goal: Create a Mobile Application project to store the mobile business objects and resources you are developing.

All tutorials use the SUP101 Mobile Application project to store mobile business objects.

1. Select File > New > Mobile Application Project to create the project.

2. Inthe New Mobile Application Project wizard, in Project Name, enter SUP101 and click Finish.
The project appears in the WorkSpace Navigator and the Mobile Application Diagram opens.

Creating the sampledb Connection Profile

Goal: Create a database connection profile.

From the Enterprise Explorer right-click the Databases folder and select New to open the Wizard Selection Page.
Select Sybase ASA and click Next.
In Name, enter sampledb and click Next.

Select Sybase ASA v11.x for Unwired Server Default as the driver and keep the default settings. Click Test
Connection.

Click Next.
From the Check for Multiple Database SQL Anywhere Servers window, click Check for multiple databases.
7. Select the sampledb database and click Finish.

Wb P

o o

Creating Database Mobile Business Objects

Goal: Create two mobile business objects, each from a database object.

Prerequisites

Complete Creating the sampledb Connection Profile on page 11and Creating the SUP101 Mobile Application Projecton
page 11.

1. Open the SUP101 mobile application project if it is not already open:

Getting Started Tutorial - Eclipse Edition 11



Developing Database Mobile Business Objects

In WorkSpace Navigator, right-click on the SUP101 folder and select , Open in Diagram Editor.
2. Inthe Enterprise Explorer, expand the Database folder, right-click on the sampledb you created, and select Connect.
3. Expand the sampledb, then expand the Tables folder.

4. Select the customertable, and drag it onto the Mobile Application Diagram.

Enterprise Explorer &3 . = 8
v
(& | 0 |

2% | Bl &

B i
= Databases =
# My Sample Database
-3 campledb, sampledb (SQL Anywhe
E-E3 sampledb
B[00 Tables
o1 fin_data (dba)
-E states (dba)
-E= fin_code (dba)
-E sales_order (dba)
-E2 sales_reqgions (dba)
-E contact ¢dba)
-E2] sales_order_jtems (db
-E so_rontact (dba) b
-2 so_company {dba)
-E bonus (dba)
-E= call_track (dba)
-E terminated_employvee
-2 department {dba)
-E employee {dba)

==

The Quick Create wizard launches.
5. In the Quick Create wizard, accept the defaults and click OK.
6. Create another MBO from the sales_ordertable:

a) Drag the sales ordertable from Enterprise Explorer, and drop it onto the Mobile Application Diagram.
b) In the Quick Create wizard, accept the defaults and click OK.

The customer and sales_order MBOs display in the Mobile Application Diagram.

Next

Creating a Relationship Between Mobile Business Objects on page 12

Creating a Relationship Between Mobile Business Objects

Goal: Create a relationship between mobile business objects to associate related data and maintain data synchronization
on the device.

Prerequisites
Complete Creating Database Mobile Business Objects on page 11.
In this tutorial, you create a relationship between the customerand sales_order mobile business objects (MBO).

1. In the Palette, click Relationship.

2. Select the customer MBO and, keeping the mouse button pressed, drag the link to the sales_order MBO to establish
the relationship link.

The Relationship Creation wizard opens.

12
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Developing Database Mobile Business Objects

3. Select the id attribute in the Source object pane and cust_id in the Target object pane.

—Mappings
Source Mobile Busin Target Mobile Business Object
E g customer B (5 sales_order
=[] Attributes =[] Abtributes
----- &) id[INT] I\\j £) id[INT]
----- &) Fname[STRING(15)] — i &) cust_id[INT]
----- &) Iname[STRING(Z0)] — 1O [ ) order_date[DATE]
----- &) address[STRING(35)] -~ O &) fin_code_id[STRING(Z)]
""" &) city[STRING(20)] —— O o ) region[STRING(7!]
----- £ state[STRING(2)] —— O ) sales_rep[INT]
----- &) zip[5TRING(10)] —— O [ Parameters
----- &) phone[STRING(12)] —HO
----- &) company_name[STRING O
----- [ Parameters
4| I B | | »

A line connects the two attributes.
4. Click Finish.

The mobile application diagram now shows the link from the customer MBO to the sales_order MBO.

*SUP101 - Mobile Application Diagram £3

IJ---|---1---|---2---|---3---|---4---|---5---|---E
=
g s
- Attributes (&) Attributes (90
cust_id: name :
) E_id  INT f STRIMNGI1S)
i &0 order_date : DATE ¢ cuslnmer_sales_nrder &0 Iname : STRING{ZO)
- & fin_code_id : STRING{Z) &0 address : STRIMG(3S)
region : city
. jon 1 STRING(?) ity 1 STRING(20)
sales_rep : state :
I INT tabe : STRING(2)
- +id: zip
id: INT ip : STRIMNG{10Y
- Operations (3) £ phone : STRING(12)
i &k update() &0 company _name : STRING{3S)
£ delete) B +id I
B 238 create() Operations (3)
ek update()
- £k deletel)
- 238 create()

5. Select File > Save.

Next
Deploying the Database Mobile Business Objects on page 13

Deploying the Database Mobile Business Objects

Goal: Deploy the project that contains the database mobile business objects to the server.

Prerequisites
After completing these tutorials, you can deploy the mobile business objects (MBOSs):
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Developing Database Mobile Business Objects

e Getting Started on page 7
Creating Database Mobile Business Objects on page 11

1. Right-click in the SUP101 Mobile Application Diagram , and select Deploy Proj ect.

2. In the first page of the Deploy Mobile Application Project, click Next.

3. In the Contents page, select the customer and sales order MBOs and click Next.

4. In the Target Server page, from the list of available servers, select My Unwired Server and click Next.

5. In the Server Connection Mapping page, select the sampledb server connection from the drop-down list and click

Finish.
< Deploy Mobile Application Project
Server Connection Mapping p—
Map connection profiles ko server connections |
Connection profile | Server conneckion
@sampledb.sampledb sampledb Rl
anil
clusterdb
sampledbl
=Mew Server Conneckion ... >
The deployment progress window displays.

6. In the Deployment status window, click OK.

7. After deployment completes, click File > Close.

8. In the Enterprise Explorer, expand Unwired Servers, right-click My Unwired Server, and select Refresh.

9. Expand the Packages folder. The server package SUP101_1.0.0into which you deployed the MBOs appears in the

Packages folder. The two MBOs appear in the Mobile Business Objects folder.

B8 Enterprise Explorer 53 =08

e

& | 0 | pyed

55| Bl &
F-[= Databases
----- == 1CA Connectors
""" [ Message Transparks
----- = SAP Servers
----- [= UDDI Registries
----- = Unsupporked
(= Unwired Servers
i e
Eg-j My Uniwired Server (Urmired Server v,
B[ Packages
- Eef sUPLz_1.0.0
- B sUPLOI_1.0.0

----- E] cuskomer
H - lal sales_order
i) Personalization keys =

&7 Rolas

The deployment unit (metadata) is saved in a temporary directory on Unwired Server, in the SUP101 project. Using
Sybase Control Center, administrators can deploy the MBOs in the deployment unit to other servers.
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Developing a Device Application

Developing a Device Application

Develop a BlackBerry device application, and test its functionality.

Prerequisites
Complete these tutorials:

*  Getting Started on page 7
e Developing Database Mobile Business Objects on page 11
*  Deploying the Database Mobile Business Objects on page 13

The device application communicates with the database mobile business objects that are deployed to Unwired Server.
Develop the device application:

1. Open the SUP101 Mobile Application Project if it is not already open:
In WorkSpace Navigator, right-click the SUP101 folder and select Open in Diagram Editor.
2. Creating the Device Application on page 15
3. Generating Code for a Device Application on page 17
4. Deploying and Running the Device Application

Creating the Device Application

Goal: Create the user interface for an application that runs on a BlackBerry mobile device, and accesses the database
mobile business objects.

Prerequisites

Verify that the Device Application Designer Preferences are set to the default settings:

1. Select Window > Preferences.
2. In Preferences, select Sybase, Inc. > Mobile Development > Device Application Designer .
3. (Optional) Click Restore Defaults. This is necessary only if you have changed the default settings.

1. Select File > New > Device Application Designer. .
2. In the New Device Application Designer wizard:
a) In Parent Folder, select SUP101.
b) In File Name, enter cust i nf 0. bob.
¢) In Platform Device, select BlackBerry/BlackBer ry8800.
d) From the Connection Profile drop-down list, select My Unwired Server.
e) Click Finish.
3. In the Device Application Designer Introduction page, click Flow Design.
4. InWorkSpace Navigator, under SUP101 > M abile Business Objects, locate the customer maobile business object
and drag and drop it onto the Flow Design page.

The Start icon is automatically connected to the first screen you place on the Flow Design page, in this case,
"customer." Screens for the mobile business object operations and relationships are automatically created if this option
is selected in the Device Application Designer Preferences (default settings).
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Developing a Device Application

@ *ystinfo,bob &3

B

Premdng Opmat .. Lo

T gt g Tt P T T g T Pt P Tt
L . cuM .

g g i
)

Con

Introduction | Flow Design | Screen Designl

5. Double-click on the "customer" screen to view the screen layout.

The blue menu on the right shows the context menu items for the screen. You can customize the screen layout, style,
menu items, controls, and so on. This tutorial uses the default style.

n

r@ custinfo.bob £3

Device Context Menu

| Uriwired Platform Context Menu

Pending Operations .

Value

Value

Pending 7 )
Pending ¥

Value

Value

= tiTwell

The decorators that display to the right of the menu items show that an action is assigned to the screen. Clicking the
decorator allows you to edit the assigned action.
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Device Conkext Menu

dit Save Conkext ackion
S Edit Connection ackion
i Remove Save Context action
Lrwired Platform - pemove Connection action
Remove all actions

6. Select File > Save.

Next

Verifying and Generating Code for a Device Application on page 17

Verifying and Generating Code for a Device Application

Developing a Device Application

Goal: Generate client code for a mobile application project, so you can develop the device application to run on a

BlackBerry device.

Prerequisites

After you complete Creating the Device Application on page 15 you can generate the client code.

L In the Device Application Designer toolbar, click the Verify icon & to verify the device application code.
If there are errors, they display in the Problems view. Errors must be fixed before generating the code.
2. Once you have verified the device application, in the Device Application Designer toolbar, click the Generate Device

Application icon 29

The Generate Device Application wizard launches.

1} New Device Application Designer Generation

Generate Device Application Wizard

Generate Device Application for the mobile device,

% EBlackBerry
" windows Mobile

¥ Locale

r Advanced

H—

(7) = Back I Mext = I

FEinish

Zancel |

3. Inthe Generate Device Application Wizard, accept the defaults and click Next.

Getting Started Tutorial - Eclipse Edition
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Developing a Device Application

4. In the second page of the Generate Device Application Wizard, accept the default settings and click Start MDS.

-> MNew Device Application Designer Generation

Generate BlackBerry Application Wizard

Generate BlackBerry Application For the RIM mobile devices.

{¥} Favorite Configurations

> Locations

v Copy to simulator location: | Zt\Program Files\Research In MotioniBlackBerry JDE 4.2, 1y simulakar Browse. ..

Iv start the ElackBerry simulator after copying  Start MDS

Iv Disable signing

I Copy to desktop location: |

I Copy to workspace location: |

AL

b Advanced

(7) = Back | Einish | Cancel |

The BlackBerry MDS server starts and you see a window similar to this:

WINDOWS' system32hcmd.exe

tarted, THREAD = SRPHListenForClientsPackets>

?qr 12, 2869 11:42:89 AM urg.apache.catalﬁpa.startup.CuntextCunfig defaultlehCon
ig

INFO: Ho default web.xml

<2009-03-12 11:42:10.83% MDT>:[391:<MDS-CS_MDE>:<DEBUG>:<{LAYER = SCHM. EUENT

e puszh zervice iz ready to receive reguests>

<2089-03-12 11:42:10.83% MDT>:[481:<MDS-CS_MDE>:<DEBUG>:<{LAYER = SCHM. EUENT

min. Taszk- pending push messages>

Mar 12, 2009 11:42:18 AM org.apache.catalina.core.fApplicationContext log

INFO: AdministrationController {Statusl:init

Mar 12, 2009 11:42:18 AM org.apache.catalina.core.fApplicationContext log

INFO: C:“Program Filesz“Research In Motion“BlackBerry Email and HMDE Services

lators 4.1.2“MDE

Mar 12, 2009 11:42:18 AM org.apache.catalina.core.fApplicationContext log

INFO: AdministrationController {Statistics>:init

Mar 12, 2009 11:42:18 AM org.apache.catalina.core.fApplicationContext log

INFO: C:“Program Filesz“Research In Motion“BlackBerry Email and HMDE Services

lators 4.1.2“MDE

Mar 12, 26009 11:42:18 AM org.apache.coyote _httpll HttpililBaszeProtocel init

INFO: Initializing Coyote HITP-1.1 on http—8BE8H

Mar 12, 2009 11:42:18 AM org.apache.coyote _httpll HttpllBazeProtocol start

INFO: Starting Coyote HITP-1.1 on http-BBEA

<§BB?—B§;12 11:42:18.837 HDT>:[411:<MDS-CE_MDE>:<{DEBUG>:<{LAYER = SCM. Web Server
tarte

5. Click Finish.
The BlackBerry Simulator launches. This may take a few moments. When it launches, it will take a few moments to
load the device application. You will see the progress screen.
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Developing a Device Application

B BlackBerry 8800 Simulator
File Edit Wwiew Simulate Tools Help

BlackBerry

Linking Tara

Next
Running the Device Application on the BlackBerry Simulatoron page 19

Running the Device Application on the BlackBerry Simulator

This tutorial shows you how to run the custinfo device application on the BlackBerry Simulator.

This tutorial shows the device application running on the BlackBerry 8800 Simulator. The navigation features of the
BlackBerry 8800 Simulator include:

Menu key Escape key

SN

C : 1 M :.:
9) A \s
Send key

End/Power key
Dpen the phaor End a call

Call thlightad Trackball LT

NOne 1 1l MO L 10 1round 3 (=4 Retu 1 1B HOME SCrEs
£ OFes (] Bl 1 1E&f
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Developing a Device Application

w NP

4.

The trackball functions as an Enter button. Use the scroll button to simulate rolling the trackwheel. If you do not have
a scroll button, use the up and down arrow keys on your keyboard to scroll.

Click on the menu key to access the applications screen.
The simulator automatically turns the LCD display off after a certain length of time. Keep the LCD display on by
selecting View >Keep LCD On.

When the simulator launches, you can run the Setup Wizard. Scroll to Don't Ask Me Again, and click the trackball.
Click the menu key to access the applications screen.
Scroll to locate the custinfo device application, and click the trackball to open it.

By default, the first time the device application is accessed on the simulator, an automatic synchronization is
performed.
When synchronization finishes, the customer list detail appears.

customer

address
Mchael  Devin 3114 Fiore.
laz Beth Reiser 1833 lhip. .
lias Ern Medringha... 1954 lind...
Tad Meghan  Mason 5o Dund .
TiA5 Laura McCarthy 1218 High..
4= Faul Philips 2000 Che
las Kely Coburn 15141 Uallc.;

Scroll down the customers list and then click the menu key to display the application menu.

The application menu shows the menu items that were shown when designing the device application in the Device
Application Designer and includes the Synchronize menu item that you added.

Scroll back up the menu items, and select sales order. Notice how Unwired Platform automatically associates data
based on the relationships between mobile business objects, and the screens are automatically created based on those
relationships.
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sales_order

d  |oustd  |order_da. [fin code
1996-83-... rl
165 1995-83-.. r
£4a6 (4= 1995-66-1/r1
£5/9 165 19958-83-.. rl
€033 (4= 1995-18-15 rl

7. Click the Escape key to return to the customer list.
8. Click the Menu key and select update customer.

sales_order
delete customer [IELEEINCEEs

Devin 2114 Pione...
customer Details | Reser 1833 Whip..

Search customer | Niedringha... 1990 kind...
JortonColumn | mason S50 0und.

Developing a Device Application

9. In the fname and Iname fields, change the name of the customer to Paul a Phil | i ps.

'Ename | McLarthy IR Hoh.
biiE - Fhilips 2006 Che..
address Coburn 18131 valkc...
rreate rnistnmes

frame: Faula

Iname: Phillip=]

address: Alld Fioneer Avenue

city Rutherford

state MJ

7ip @ra7e

phone: ZA1o05E96E0

company_name: The Power Group

i 4] -

10. Scroll down the customer record, then highlight and click Submit.

update customer

aooress: All4 FIoNeer Syvenue al
oty Rutherford
state: M
7ip @ra7e
phone: 21005960
company_name: The Power Group
[u 4]
Carcel -

11. You return to the main customer list screen. The updated record is highlighted and shown in red.

Getting Started Tutorial - Eclipse Edition
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customer

anress
E - As S Ame.

Az Beth Reiser 1433 Wlhip. .
liaa Ern Medringha... 1954 lind...
Tad Meghan  Mason 5o Dund .
Ti45 Laura McCarthy 1219 High..

7= Faul Philips 2000 Che
las Kely Coburn 15141 Uallc.;

12. To upload the name change to the back-end database (sampledb.sampledb), click the Menu key, and select
Synchronize from the menu.

You see the synchronization progress screen. The Submit button on the "update customer" screen is mapped to the
updat e operation of the "customer" mobile business object. When the application is synchronized, any pending
operations are uploaded to Unwired server, which then executes the UPDATE query defined for the updat e
operation of the "customer"” mabile business object.

13. When the synchronization is complete, you return to the customer screen. The changed record now looks the same as
all the other records.
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