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CHAPTER 1 Getting Started with XML
Modeling

An XML model (XSM) helps you analyze an XML Schema Definition (.XSD), Document
Type Definition (.DTD) or XML-Data Reduced (.XDR) file. You can model, reverse-
engineer, and generate each of these file formats.

XML (or eXtensible Markup Language) is increasingly used to hold application data because
it:

• describes and structures data, whereas HTML only displays data
• uses a self-describing and personalized syntax
• can be exchanged between incompatible systems, since data is stored in plain text format

Since XML structures can be very complex, it is much easier to visualize them through
comprehensive and explicit diagrams, than to read XML-coded pages. With its Browser tree
view and diagram, a PowerDesigner® XSM gives you a global and schematic view of all the
elements composing your XSD, DTD, or XDR:

Once you have created an XML diagram, you can generate an XSD, a DTD or an XDR file
from it for use in your application.

A PowerDesigner XSM allows you to generate and reverse engineer XSD, DTD and XDR
files and also generate an XML model from a Physical Data Model (PDM), Object Oriented
Model (OOM), or another XSM:
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DTD, XSD or XDR
The structure of an XSM is described by a DTD, an XSD or an XDR file:

• A DTD file is a basic way to describe the structure of an XML document. It is a raw list of
all the legal elements making up an XML document. An extract of a DTD file follows:

• An XSD file (or schema) is an elaborated way to describe the structure of an XML
document. It can support namespaces, derivations, keys, simple and complex user-defined
data types and a robust collection of predefined data types. An extract of an XSD file
follows:

CHAPTER 1: Getting Started with XML Modeling
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An XSD file always starts with the <schema> tag (root element). All objects created in the
model will appear in the XSD file between the schema start-tag and end-tag

• An XDR file is a simplified XSD file (or schema). It does not support simple and complex
user-defined data types. An extract of an XDR file follows:

An XDR file always starts with the <schema> tag (root element). All objects created in the
model will appear in the XDR file between the schema start-tag and end-tag

Suggested Bibliography

• W3C XML Recommendation – http://www.w3.org/TR/REC-xml
• W3C DTD Recommendation – http://www.w3.org/TR/REC-xml#dt-doctype
• W3C XML Schema Recommendation – http://www.w3.org/XML/Schema#dev
• W3C XML-Data Note – http://www.w3.org/TR/1998/NOTE-XML-data-0105/
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Creating an XSM
You create a new XML model by selecting File > New Model.

Note: In addition to creating an XSM from scratch with the following procedure, you can also
reverse-engineer a model from an existing XSD, a DTD or an XDR file (see Reverse
Engineering an XML Schema into an XSM on page 79).

The New Model dialog is highly configurable, and your administrator may hide options that
are not relevant for your work or provide templates or predefined models to guide you through
model creation. When you open the dialog, one or more of the following buttons will be
available on the left hand side:

• Categories - which provides a set of predefined models and diagrams sorted in a
configurable category structure.

• Model types - which provides the classic list of PowerDesigner model types and
diagrams.

• Template files - which provides a set of model templates sorted by model type.

CHAPTER 1: Getting Started with XML Modeling
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1. Select File > New Model to open the New Model dialog.

2. Click a button, and then select a category or model type ( XML Model ) in the left-hand
pane.

3. Select an item in the right-hand pane. Depending on how your New Model dialog is
configured, these items may be first diagrams or templates on which to base the creation of
your model.

Use the Views tool on the upper right hand side of the dialog to control the display of the
items.

4. Enter a model name.

The code of the model, which is used for script or code generation, is derived from this
name using the model naming conventions.

5. Select a target XML language , which customizes PowerDesigner's default modifying
environment with target-specific properties, objects, and generation templates.

By default, PowerDesigner creates a link in the model to the specified file. To copy the
contents of the resource and save it in your model file, click the Embed Resource in
Model button to the right of this field. Embedding a file in this way enables you to make
changes specific to your model without affecting any other models that reference the
shared resource.

6. [optional] Click the Select Extensions button and attach one or more extensions to your
model.

7. Click OK to create and open the XML model .

Note: Sample XSMs are available in the Example Directory.

XSM Properties
You open the model property sheet by right-clicking the model in the Browser and selecting
Properties.

Each XML model has the following model properties:

Property Description

Name/Code/Comment Identify the model. The name should clearly convey the model's purpose to
non-technical users, while the code, which is used for generating code or
scripts, may be abbreviated, and should not normally include spaces. You
can optionally add a comment to provide more detailed information about
the model. By default the code is auto-generated from the name by applying
the naming conventions specified in the model options. To decouple name-
code synchronization, click to release the = button to the right of the Code
field.

Filename Specifies the location of the model file. This box is empty if the model has
never been saved.

CHAPTER 1: Getting Started with XML Modeling
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Property Description

Author Specifies the author of the model. If you enter nothing, the Author field in
diagram title boxes displays the user name from the model property sheet
Version Info tab. If you enter a space, the Author field displays nothing.

Version Specifies the version of the model. You can use this box to display the
repository version or a user defined version of the model. This parameter is
defined in the display preferences of the Title node.

XML language Specifies the model target.

Default diagram Specifies the diagram displayed by default when you open the model.

Keywords Provide a way of loosely grouping objects through tagging. To enter mul-
tiple keywords, separate them with commas.

The following tabs are also available:

• Detail - [XSD only] Contains the following properties:

Property Description

Target Name-
space

Specifies a URI as the namespace for all the model objects. All the schema
elements with this prefix in their start-tag will be associated with the namespace.
For example: http://www.mycompany.com/myproduct/XMLmodel

Language Specifies the language used in the model. For example: en, en-GB, en-US, de,
fr

ID Specifies the ID of the model. Its value must be of type ID and unique within the
file containing the model. For example: XMOD1

Default Specifies defaults for the Form and Block and Final model object properties.

• Items - lists the model's global objects (which have no parent symbol in the diagram, and
are directly linked to the <schema> tag). The list reflects the order in which global objects
are declared in the schema. You can change the order of declaration by selecting an item in
the list and using the arrowed buttons, at the bottom-left corner of the tab, to move it in the
list. The following tools are available on this tab:

Tool Description

Add Element

Add Group

Add Attribute

CHAPTER 1: Getting Started with XML Modeling
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Tool Description

Add Attribute Group

Add Simple Type [XSD only]

Add Complex Type [XSD only]

Add Notation

Add Annotation [XSD only]

• External Schemas - [XSD only] Allows you to link to and reuse in your model global
objects from other schemas. The following tools are available on this tab:

Tool Description

Add Include

Add Import

Add Redefine

Add Annotation

• Namespaces - [XSD and XDR only] Lists the namespaces used to declare objects used in
the model.

• Preview - Displays a preview of the XSD, DTD or XDR file generated from the XSM.

CHAPTER 1: Getting Started with XML Modeling
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Previewing XML Code
Click the Preview tab in the property sheet of the model, elements, and various other model
objects in order to view the code that will be generated for it.

The following tools are available on the Preview tab toolbar:

CHAPTER 1: Getting Started with XML Modeling
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Tools Description

Editor Menu [Shift+F11] - Contains the following commands:

• New [Ctrl+N] - Reinitializes the field by removing all the existing content.
• Open... [Ctrl+O] - Replaces the content of the field with the content of the se-

lected file.
• Insert... [Ctrl+I] - Inserts the content of the selected file at the cursor.
• Save [Ctrl+S] - Saves the content of the field to the specified file.
• Save As... - Saves the content of the field to a new file.
• Select All [Ctrl+A] - Selects all the content of the field.
• Find... [Ctrl+F] - Opens a dialog to search for text in the field.
• Find Next... [F3] - Finds the next occurence of the searched for text.
• Find Previous... [Shift+F3] - Finds the previous occurence of the searched for

text.
• Replace... [Ctrl+H] - Opens a dialog to replace text in the field.
• Go To Line... [Ctrl+G] - Opens a dialog to go to the specified line.
• Toggle Bookmark [Ctrl+F2] Inserts or removes a bookmark (a blue box) at the

cursor position. Note that bookmarks are not printable and are lost if you refresh
the tab

• Next Bookmark [F2] - Jumps to the next bookmark.
• Previous Bookmark [Shift+F2] - Jumps to the previous bookmark.

Edit With [Ctrl+E] - Opens the previewed code in an external editor. Click the down
arrow to select a particular editor or Choose Program to specify a new editor. Editors
specified here are added to the list of editors available at Tools > General Options >
Editors.

Save [Ctrl+S] - Saves the content of the field to the specified file.

Print [Ctrl+P] - Prints the content of the field.

Find [Ctrl+F] - Opens a dialog to search for text.

 Cut [Ctrl+X], Copy [Ctrl+C], and Paste [Ctrl+V] - Perform the standard clipboard
actions.

 Undo [Ctrl+Z] and Redo [Ctrl+Y] - Move backward or forward through edits.

Refresh [F5] - Refreshes the Preview tab.

You can debug the GTL templates that generate the code shown in the Preview tab. To
do so, open the target or extension resource file, select the Enable Trace Mode option,
and click OK to return to your model. You may need to click the Refresh tool to
display the templates.

CHAPTER 1: Getting Started with XML Modeling
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Tools Description

Select Generation Targets [Ctrl+F6] - Lets you select additional generation targets
(defined in extensions), and adds a sub-tab for each selected target. For information
about generation targets, see Customizing and Extending PowerDesigner > Extension
Files > Extending Generation and Creating Separate Generation Targets.

Customizing your Modeling Environment
The PowerDesigner XML model provides various means for customizing and controlling
your modeling environment.

Setting Model Options
You can set XSM model options by selecting Tools > Model Options or right-clicking the
diagram background and selecting Model Options.

You can set the following options on the Model Settings page:

Option Description

Name/Code case
sensitive

Specifies that the names and codes for all objects are case sensitive, allowing you
to have two objects with identical names or codes but different cases in the same
model. If you change case sensitivity during the design process, we recommend
that you check your model to verify that your model does not contain any duplicate
objects.

Enable links to
requirements

Displays a Requirements tab in the property sheet of every object in the model,
which allows you to attach requirements to objects (see Requirements Model-
ing).

For information about controlling the naming conventions of your models, see Core Features
Guide > The PowerDesigner Interface > Objects > Object Properties > Naming
Conventions.

Setting XSM Display Preferences
PowerDesigner display preferences allow you to customize the format of object symbols, and
the information that is displayed on them. To set XML model display preferences, select Tools
> Display Preferences or right-click the diagram background and select Display Preferences
from the contextual menu.

For detailed information about customizing and controlling the attributes and collections
displayed on object symbols, see Core Features Guide > The PowerDesigner Interface >
Diagrams, Matrices, and Symbols > Display Preferences.

CHAPTER 1: Getting Started with XML Modeling
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Viewing and Editing the XML Language Definition File
Each XSM is linked to a definition file that extends the standard PowerDesigner metamodel to
provide objects, properties, data types, and generation parameters and templates specific to
the language being modeled. Definition files and other resource files are XML files located in
the Resource Files directory inside your installation directory, and can be opened and
edited in the PowerDesigner Resource Editor.

Warning! We strongly recommend that you make a back up of the resource files delivered
with PowerDesigner before editing them.

To open your model's definition file and review its extensions, select Language > Edit
Current Language.

For detailed information about the format of these files, see Customizing and Extending
PowerDesigner > Object, Process, and XML Language Definition Files.

Note: Some resource files are delivered with "Not Certified" in their names. Sybase® will
perform all possible validation checks, however Sybase does not maintain specific
environments to fully certify these resource files. Sybase will support the definition by
accepting bug reports and will provide fixes as per standard policy, with the exception that
there will be no final environmental validation of the fix. Users are invited to assist Sybase by
testing fixes of the definition provided by Sybase and report any continuing inconsistencies.

Changing the XML Language
You can change the XML language being modeled in your XSM at any time.

Simple types and complex types are only supported by XSDs (schemas). When changing an
XSD into a DTD or an XDR, simple types and global complex types (directly linked to the
<schema> tag) disappear from the diagram and the Browser tree view. Local complex types
(within an element) are expanded in the diagram, beneath their containing element. In this
example, HighDefinition is a global complex type, reused as data type for the deluxeTV
element:

• In the model with target XSD:

• The model target is changed to DTD or XDR:

CHAPTER 1: Getting Started with XML Modeling
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Note: You may be required to change the XML language if you open a model and the
associated definition file is unavailable.

1. Select Language > Change Current Language:

2. Select a XML language from the list.

By default, PowerDesigner creates a link in the model to the specified file. To copy the
contents of the resource and save it in your model file, click the Embed Resource in
Model button to the right of this field. Embedding a file in this way enables you to make
changes specific to your model without affecting any other models that reference the
shared resource.

3. Click OK.

A message box opens to tell you that the XML language has been changed.

4. Click OK to return to the model.

Extending your Modeling Environment
You can customize and extend PowerDesigner metaclasses, parameters, and file generation
with extensions, which can be stored as part of your model or in separate extension files
(*.xem) for reuse with other models.

To access extension defined in a *.xem file, simply attach the file to your model. You can do
this when creating a new model by clicking the Select Extensions button at the bottom of the
New Model dialog, or at any time by selecting Model > Extensions to open the List of
Extensions and clicking the Attach an Extension tool.

In each case, you arrive at the Select Extensions dialog, which lists the extensions available,
sorted on sub-tabs appropriate to the type of model you are working with:

CHAPTER 1: Getting Started with XML Modeling
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To get started extending objects, see Core Features Guide > The PowerDesigner Interface >
Objects > Extending Objects. For detailed information about working with extensions, see
Customizing and Extending PowerDesigner > Extension Files.

Linking Objects with Traceability Links
You can create traceability links to show any kind of relationship between two model objects
(including between objects in different models) via the Traceability Links tab of the object's
property sheet. These links are used for documentation purposes only, and are not interpreted
or checked by PowerDesigner.

For more information about traceability links, see Core Features Guide > Linking and
Synchronizing Models > Getting Started with Linking and Syncing > Creating Traceability
Links.

CHAPTER 1: Getting Started with XML Modeling
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CHAPTER 2 XML Diagrams

An XML diagram provides a graphical view of the elements that comprise an XML schema
definition in a tree format.

Note: To create an XML diagram in an existing XSM, right-click the model in the Browser
and select New > XML Model Diagram. To create a new model, select File > New Model,
choose XML Model as the model type and XML Model Diagram as the first diagram, and
then click OK.

With the user-friendly graphical interface of PowerDesigner XML Model, you can build an
XML diagram and then generate automatically an XSD, a DTD or an XDR file.

The following example shows the diagram of an XSM which models an XML schema for
Resume documents:

Right-click a symbol in an XML diagram and select one of these features:

• Expand - the hierarchy below a symbol is partially expanded (only the first level).
• Expand All - the hierarchy below a symbol is fully expanded (all levels).
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• Collapse - the hierarchy below a symbol is hidden.
• Arrange Symbols- the hierarchy below a symbol is properly displayed.

Note: The Symbol > Group Symbols feature is only available for free symbols in an XML
diagram.

If an XML model is too large or too complex, you can create several diagrams to have partial
views of the model and focus on certain objects.

For example, the original Resume diagram could be split into five diagrams, corresponding to
the five main objects of the model (Main, Contact, Achievement, Description and Address).

The following illustration shows the Achievement sub-diagram:

XML Diagram Objects
PowerDesigner supports all the objects necessary to build XML diagrams.

An XML model represents the structure of a potential or existing XSD, DTD, or XDR through
a tree structure of child elements attached to parent elements.

Elements are the basic describing items of an XML model. They can be made of other
elements combined in different ways through group particles. Elements are specified by
attributes and data types, which can be predefined or user-defined. Simple and complex data
types can be defined as global (directly linked to the <schema> tag) or local (embedded in an
element declaration).

Object Tool Symbol Description

Element The basic object of an XML model. An element can
contain other elements or attributes. See Elements
(XSM) on page 20.

CHAPTER 2: XML Diagrams
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Object Tool Symbol Description

Any Any type of object. Can only be attached to a sequence
or a choice group particle. See Any Elements (XSM) on
page 34.

Attribute N/A N/A Additional information about an element or a complex
type. Defined by a built-in data type or a simple data
type. See Attributes (XSM) on page 35.

Group A group of elements arranged by a group particle. De-
fined once and reused through references. See Groups
(XSM) on page 49.

Attribute
Group

N/A N/A A group of attributes, defined once and reused in the
model through references. See Attribute Groups (XSM)
on page 53.

Simple Type N/A N/A [XSD only] Used in the case of elements or attributes
with text-only content. See Simple Types (XSM) on
page 56.

Complex Type [XSD only] Used to introduce elements or attributes
within an element declaration. See Complex Types
(XSM) on page 57.

Sequence This group particle arranges a set of elements, where all
the elements must appear at least once in the order of
their declaration. See Group Particles (XSM) on page
29.

Choice This group particle arranges a set of elements, from
which one element must be chosen. See Group Particles
(XSM) on page 29.

All This group particle arranges a set of elements, where
each element can appear or not, in any order. See Group
Particles (XSM) on page 29.

Instruction N/A N/A An import, include, or redefine instruction. See Instruc-
tions: Import, Include and Redefine (XSM) on page
73

Derivation N/A N/A Extends or restricts the values of elements and simple
and complex types. See Derivations: Extensions, Re-
strictions, Lists and Unions (XSM) on page 62

Constraint N/A N/A [XSD only] Specifies uniqueness of element values.
See Constraints: Keys, Uniques, and KeyRefs (XSM)
on page 42

Annotation N/A N/A Provides documentation or application information.
See Annotations (XSM) on page 68

CHAPTER 2: XML Diagrams
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Object Tool Symbol Description

Entity N/A N/A [DTD only] Specifies a predefined value or external
XML or non-XML file. See Entities (XSM) on page
71.

Notation N/A N/A Defines and processes non-XML objects within an
XML model. See Notations (XSM) on page 70

Linking Objects in an XML Model
XML objects do not support standard link objects. To link a child object to a parent object, you
must click the child object tool in the Toolbox and then click the symbol of the parent object in
the diagram. This will automatically create a link between both objects.

The following tables list the allowed links:

Tool Element symbol Group symbol Complex type sym-
bol

 Any

No link No link No link

 All

Tool Sequence symbol Choice symbol All symbol

 Any No link

No link

No link No link No link

CHAPTER 2: XML Diagrams
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Tool Sequence symbol Choice symbol All symbol

No link

No link

 All No link No link No link

Warning! A group particle (sequence, choice, all) cannot be created from scratch in a
diagram. It must be the child element of an element, a group or a complex type.

For more information, see Link Child Objects to Elements on page 26, Adding a Child
Object to a Group Particle on page 33, Linking Child Objects to a Group on page 52, 
Linking a Child Object to a Complex Type on page 60.

External Shortcuts (through References and Data Types)
External shortcuts allow you to share objects between different models.

You can define external shortcuts in an XML model, but you cannot use them directly in the
model, except as substitution groups for elements (see Element Properties on page 22).

You can define external shortcuts for any global object (with no parent object in the diagram),
except for imports, includes, redefines and annotations .

Internal shortcuts allow you to share objects between packages of a same model. You cannot
define internal shortcuts since an XML model does not support packages.

External shortcuts are automatically generated in the following situations:

References
When you use the Reference property to define an element, an attribute, a group or an attribute
group, by reference to a similar object in another model opened in the workspace, a shortcut is
created between the referencing object and the target object.

The shortcut is displayed in the current model with a specific item in the Browser tree view and
the "(Shortcut)" expression in the reference symbol and item. The target object keeps track of
the referencing object in the Reference tab of the Dependencies tab of its property sheet.

Data Types
When you define the data type of an element by selecting a simple or a complex type from
another model (using the Browse tool beside the Type list), a shortcut is created between the
current element type and the target data type.

The shortcut is displayed in the current model with a specific item in the Browser tree view.

Example of shortcuts through a reference and a data type:

CHAPTER 2: XML Diagrams
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Elements (XSM)
Elements are the basic building blocks of an XML model.

An XML model is a tree structure of elements where child elements are attached to parent
elements. For example:

Generated schema:
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In a schema, elements are declared with <element> tags.

There are two broad kinds of elements:

• Global elements - have no parent element in a diagram, and are directly linked to the
<schema> tag (root element) in a schema. They can be reused in the model through
referencing elements (see "XML_declaration" in the example)

• Local elements - have a parent element in a diagram, and are unique within their parent
scope. They can be defined by reference to a global element (see the Reference property in
Element Properties on page 22).
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Note: In a model targeted with the XML-Data Reduced language, local elements are first
declared separately, like global elements (with the <ElementType> tag and a name attribute),
then within their parent element (with the <element> tag and a type attribute).

Extract of an XDR file:

Parent elements are linked to their child elements through group particles (sequence, choice or
all), which contain a group of child elements (see the Group type property in Element
Properties on page 22).

You can derive an XSD element data type to extend or restrict its values (see the Derivation
property in Element Properties on page 22).

Creating an Element
You can create an element from the Toolbox, Browser, or Model menu.

• Use the Element tool in the Toolbox.
• Select Model > Elements to access the List of Elements, and click the Add a Row tool.
• Right-click the model or package in the Browser, and select New > Element.

For general information about creating objects, see Core Features Guide > The
PowerDesigner Interface > Objects.

Element Properties
To view or edit an element's properties, double-click its diagram symbol or Browser or list
entry. The property sheet tabs and fields listed here are those available by default, before any
customization of the interface by you or an administrator.

The General tab of an XSD or DTD element property sheet displays the following properties
(for XDR element properties, see the subsequent table):

Property Description

Name/Code/
Comment

Identify the object. The name should clearly convey the object's purpose to non-
technical users, while the code, which is used for generating code or scripts, may be
abbreviated, and should not normally include spaces. Neither the name nor code
should contain colons. You can optionally add a comment to provide more detailed
information about the object. By default the code is generated from the name by
applying the naming conventions specified in the model options. To decouple name-
code synchronization, click to release the = button to the right of the Code field.

Stereotype Extends the semantics of the object. You can enter a stereotype directly in this field,
or add stereotypes to the list by specifying them in an extension file.
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Property Description

Reference Specifies a global element in this or another model to reuse. Disables all other
properties. Select an element in the current model from the list or click the Browse
tool to select an element from any model open in the workspace.

You can locate the referenced element in the diagram by right-clicking the refer-
encing element symbol and selecting Find Referenced Element.

Group type Specifies that the element has child elements, and how they are used (see Group
Particles (XSM) on page 29). You can choose between:

• all – All children may be present.

• choice – Only one child must be present.

• group – Reference to a predefined group (see Groups (XSM) on page 49)

• sequence – All children must be present in order.

Type Specifies the data type. Select a built-in data type from the list or click the Browse
tool to select a simple type defined in any model open in the workspace. For an XSD
element, selecting a data type will delete any group particle (and its child elements)
or attribute previously defined in the element property sheet. Do not select a data
type if you want to define attributes or child elements within the current element

Embedded
type

[XSD only] Specifies a locally defined data type, which applies to the current
element only. Automatically set to Complex if you define a derivation for the ele-
ment data type.

Content [XSD only] Specifies whether the content type of the element is Complex (and can
have child elements) or Simple (and cannot).

Derivation [XSD only] Specifies a derivation method for the data type to extend or restrict its
values. Resets the Type property to <None>. Click the Properties tool to further

define the derivation (see Derivations: Extensions, Restrictions, Lists and Unions
(XSM) on page 62).

Keywords Provide a way of loosely grouping objects through tagging. To enter multiple key-
words, separate them with commas.

Detail Tab
The Detail tab contains the following properties:

Property Description

Minimum Minimum number of times the element can occur. To specify that the element is
optional, set this attribute to zero.
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Property Description

Maximum Maximum number of times the element can occur. For an unlimited number of
times, select unbounded.

Substitution
group

Name of a global element for which the current element can be substituted. It must
have the same type or a derived type. Its value must be a qualified name.

Default Specifies a default value for the element. Mutually exclusive with the Fixed
property.

Fixed Specifies a fixed value for the element if its content is a simple type or text-only.
Mutually exclusive with the Default property.

Block Specifies that another element with the same type of derivation cannot be used in
place of the current element.

Final [global elements] Specifies that the element cannot undergo further derivations.

Form Specifies whether or not the element must be qualified by combining the target
namespace of the schema with the no-colon-name of the element.

ID Specifies the ID of the element, which must be unique within the model.

Abstract Specifies that the element cannot appear in the instance document.

Nillable Specifies that the element may be null.

Note: In the case of a model targeted with XDR, the Detail tab is only available for local
elements.

Mapping Tab
This tab lets you map the element and its attributes to PDM or OOM objects.

You associate one or more PDM or OOM objects to the element using the Add Objects tool on
the Element Sources sub-tab. You can associate PDM columns or OOM class attributes to the
element attributes using following tools on the Attributes Mapping tab:

Tool Description

Add Mapping - Selects the attributes in the current element that will be mapped to PDM
columns or OOM class attributes. Once you have selected the attributes, you can use the list
in the Mapped to column to select corresponding PDM columns or OOM class attributes.

Create from Sources - Copies PDM columns or OOM class attributes in the data source to
the current element attributes.
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Tool Description

Generate Mapping - Automatically generates a mapping between PDM columns or OOM
class attributes and element attributes with the same name or code in the data source and the
current model.

For more information on complex type mapping, see Core Features Guide > Linking and
Synchronizing Models > Object Mappings.

The following tabs are also available:

• Attributes - lists the attributes and attribute groups associated with the element (see 
Attributes (XSM) on page 35).

• Constraints - lists the constraints associated with the element (see Constraints: Keys,
Uniques, and KeyRefs (XSM) on page 42).

XDR Element Properties
In a model targeted with the XML-Data Reduced language, elements are defined as follows:

XDR Element
Attribute

Description

Model Specifies if an element can contain new local elements. Possible values are:

• closed – [default]

• open - if an "Any" element is attached to the element. See Any Elements
(XSM) on page 34

Content Specifies the content type. Possible values are:

• mixed - a group particle and a data type are defined

• eltOnly - a group particle is defined without a data type

• textOnly - a data type is defined without a group particle

• empty – neither group particle nor data type are defined

General tab: Group type/Type

Order Specifies how child elements are organized within a parent element. Possible
values are:

• seq - sequence group particle

• one - choice group particle

• many - all group particle

General tab: Group type
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XDR Element
Attribute

Description

dt:type Specifies a data type.

General tab: Type

dt:values Specifies a list of possible element values.

Values tab

type [local elements only] Specifies the name of a global element as reference for
the local element

General tab: Reference

minOccurs [local elements only] To specify the minimum number of occurrences for a
local element. Usually set to 0 or 1

Detail tab: Minimum

maxOccurs [local elements only] To specify the maximum number of occurrences for a
local element. Usually set to 1 or * (unbounded)

Detail tab: Maximum

Linking Child Objects to Elements
XML objects do not support standard PowerDesigner link objects. To link a child object to an
element, you must click the child object tool in the Toolbox and then click the element symbol
in the diagram. This will automatically create a link between both objects.

The following table lists the allowed links:

Tool Action

If you click a parent element symbol with the Element tool, a sequence group particle and
a child element symbol are created. You can modify the group particle via its property
sheet

If you click the upper part of a child element symbol with the Element tool, a brother
element symbol is displayed above the child element symbol

If you click the middle part of a child element symbol with the Element tool, a sequence
group particle and a grand child element symbol are created. You can modify the group
particle via its property sheet
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Tool Action

If you click the lower part of a child element symbol with the Element tool, a brother
element symbol is displayed below the child element symbol

If you click an element symbol with the Any tool, a sequence group particle and an any
symbol are created. You can modify the group particle via its property sheet

If you click an element symbol with the Group tool, a referencing group is created. You
must now select a group for the reference

If you click an element symbol with the Complex Type tool, a complex type symbol is
displayed superposed, but not linked, to the element symbol. A global complex type
cannot be the child of an element

If you click an element symbol with the Sequence tool, a sequence group particle is
displayed linked to the element symbol

If you click an element symbol with the Choice tool, a choice group particle is displayed
linked to the element symbol

If you click an element symbol with the All tool, an all group particle is displayed linked to
the element symbol

Note: When you cannot click a symbol or an empty space in a diagram, the Pointer displays a
forbidden sign. When there is a possibility to create a symbol above, below or next to another
one, the Pointer displays an arrow indicating the corresponding direction.

Manipulating XML Objects Graphically
The graphical interface of PowerDesigner allows you to manipulate your XML schema by
moving XML objects within the Browser, within the diagram, or by dragging them from the
Browser into the diagram or from the diagram into the Browser.

Note: Select Tools > General Options to make sure that Move is the Default action of the
Drag & Drop option.
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Global Objects
A global object is right under the model item in the Browser tree view. It has no parent symbol
in the diagram. You can move global objects within or between the Browser tree view and the
diagram window:

• Within Browser - You can move a global object within the Browser to convert it into a local
object (under a group particle item), but you cannot move a global object within its own
structure (as a child of itself).

• Within Diagram - You can move a global object within the diagram to convert it into a local
object. Just move the global object symbol to a group particle symbol.

• From Browser to Diagram - When you move a global object from the Browser to the
diagram, a synonym symbol is created in the diagram.

• From Diagram to Browser - You can move a global object from the diagram to the Browser,
and convert it into a local object (under a group particle item). If the new local object does
not appear in the diagram, double-click the Collapse node of the group particle symbol
under which the former global object has been attached.

Local Objects
A local object is under a group particle item in the Browser tree view. It has a parent symbol in
the diagram. You can move local objects within or between the Browser tree view and the
diagram window:

• Within Browser - You can move a local object within the Browser to convert it into a global
object. If the new global object does not appear in the diagram, select Symbol > Show
Symbols and click the corresponding tab to select the new global object

• Within Diagram - You can move a local object within the diagram to another group
particle. It remains a local object, but with a new parent object. You cannot move a local
object within the diagram to convert it into a global object. It remains attached to its group
particle.

• From Browser to Diagram - When you move a local object from the Browser to the
diagram, a synonym is created, attached to the same group particle as the original symbol.

• From Diagram to Browser - You can move a local object from the diagram to the Browser,
and convert it into a global object. If the new global object does not appear in the diagram,
select Symbol > Show Symbols and click the corresponding tab to select the new global
object

Example: Converting a Local Object into a Global Object
In the following example, Job is a child element of the Customer element and Nickname is the
attribute of the Name element:
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The Job entry in the Browser is selected and dragged and dropped onto the model element,
Customer Directory and the Nickname atttribute is similarly dragged and dropped onto the
model. Job becomes a global element, and Nickname becomes a global attribute:

Group Particles (XSM)
An element composed of other elements is a parent element with child elements.

Child elements are linked to their parent element through a group particle.

There are three kinds of group particles:
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Tool Symbol Description

Sequence - Child elements must appear at least once in the order of their
declaration

Choice - Only one child element can be linked to the parent element

All - Child elements can appear in any order and each of them once or not at
all

These particles translate to the following tags in each of the supported languages:

Group Par-
ticle

XSD XDR (order attribute) DTD (separator)

Sequence <sequence> seq , (comma)

Choice <choice> one | (bar)

All <all> many , (comma)

Creating a Group Particle
You can create a group particle from the Toolbox or from the property sheet of an element,
group, or complex type.

• Use the Sequence, Choice, or All tool in the Toolbox.
• Open the property sheet of an element, group, or complex type, and select a group particle

from the Group type list.

For general information about creating objects, see Core Features Guide > The
PowerDesigner Interface > Objects.

Creating a Group Particle from the Toolbox
You can create a group particle with the Group Particle tool in the Toolbox.

1. Select a group particle tool (Sequence, Choice, or All) in the Toolbox, and then click the
element symbol in the diagram.

A group particle is created and its symbol is displayed in the diagram, linked to the element
symbol.

2. Select the Element tool in the Toolbox and then click the group particle symbol to add an
element item. Click the symbol again to add additional elements.

The child elements appear one by one in the diagram, linked to the group particle symbol.
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3. Right-click in order to recover the Pointer.

Note: When you click an element symbol with the Element tool, a sequence symbol (by
default) is displayed in the diagram between the parent element and the child element. To add
other child elements, click the sequence symbol with the Element tool. To change the group
particle, double-click the sequence symbol to display its property sheet, then select another
group particle in the Type list and click OK.

Creating a Group Particle from the Property Sheet of an Element
You can create a group particle from the property sheet of an element.

1. Open the property sheet of the element, select a group particle from the Group type list, and
then click OK.

The element is displayed selected, with an Expand tab (+) on its right side:

2. Click an empty space in the diagram to deselect the element, and then click the Expand tab
(+) to reveal the group particle symbol (in this case, a sequence):

Note that you can click the Collapse tab (-), on the link in order to hide the group particle.

3. Double-click the group particle to open its property sheet, and then click the Items tab.

4. Click the Add Element tool for each child element you want to create in the list.

5. Click OK to return to the diagram.

The group particle is displayed selected, with an Expand tab on its right side.

6. Click an empty space in the diagram, to deselect the group particle symbol, and then click
the Expand tab to reveal the child element symbols.
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Note: Child elements are defined within the namespace of their parent element. Therefore,
there cannot be a conflict between a parent and a child name.

For more information on the namespace concept, see Core Features Guide > The
PowerDesigner Interface > The Browser > Packages > Controlling the Namespace of a
Package.

Group Particle Properties
To view or edit a group particle's properties, double-click its diagram symbol or Browser or list
entry. The property sheet tabs and fields listed here are those available by default, before any
customization of the interface by you or an administrator.

The General tab contains the following properties:

Property Description

Type Type of the group particle. You can change its type by selecting a value in the list and
clicking OK

Minimum Minimum number of times the group particle can occur. To specify that the group
particle is optional, set this property to zero

Maximum Maximum number of times the group particle can occur. For an unlimited number of
times, select unbounded

ID ID of the group particle. Its value must be of type ID and unique within the model
containing the group particle

Keywords Provide a way of loosely grouping objects through tagging. To enter multiple key-
words, separate them with commas.

Items Tab
This tab list the child elements associated with the group particle. You can add additional
children directly on this tab using the following tools:

Tool Description

Add Element - Adds an element to the list

Add Any - Adds an Any to the list. Only available with a choice or a sequence group particle
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Tool Description

Add Group Particle - Adds a group particle to the list

Add Reference to Element - Adds a referencing element to the list. Select a global element
for the reference in the Selection dialog box. To use this tool, you must have previously
defined a global element in the current model

Add Reference to Group - Adds a referencing group to the list. Select a group for the
reference in the Selection dialog box. To use this tool, you must have previously defined a
group in the current model

Adding a Child Object to a Group Particle
XML objects do not support standard link objects. To link a child object to a group particle,
you must click the child object tool in the Toolbox and then click the group particle symbol in
the diagram. This will automatically create a link between both objects.

The following table lists the allowed links:

Warning! A group particle cannot be created from scratch in a diagram. It must be the child
element of an element, a group or a complex type.

Tool Sequence symbol Choice symbol All symbol

 Any No link

A referencing group is cre-
ated. You must now select a
group for the reference

A referencing group is cre-
ated. You must now select a
group for the reference

No link

No link No link No link

No link

No link

 All No link No link No link

Note: When you cannot click a symbol or an empty space in a diagram, the Pointer displays a
forbidden sign. When there is a possibility to create a symbol above, below or next to another
one, the Pointer displays an arrow indicating the corresponding direction.
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Any Elements (XSM)
Any elements allow you to attach any type of object to a choice or a sequence group particle.

The following illustration shows an Any in a diagram:

• In an XSD file, Any is declared with the <any> tag:

• In a DTD file, Any is declared within an <!ELEMENT> tag with the keyword "ANY":

• In an XDR file, Any is declared through of an <ElementType> tag (resources in the
example) with its model attribute set to "open". Although it is displayed in a diagram, Any
is not considered as an object in an XDR file:

Creating an Any Element
You can create an Any element from the Toolbox of from a group particle property sheet.

• Use the Any tool in the Toolbox.
• Open the Items tab in the property sheet of a group particle, and click the Add Any tool.

For general information about creating objects, see Core Features Guide > The
PowerDesigner Interface > Objects.

CHAPTER 2: XML Diagrams

34 PowerDesigner



Any Element Properties
To view or edit an any element's properties, double-click its diagram symbol or Browser or list
entry. The property sheet tabs and fields listed here are those available by default, before any
customization of the interface by you or an administrator.

The General tab contains the following properties:

Property Description

Stereotype Extends the semantics of the object. You can enter a stereotype directly in this field,
or add stereotypes to the list by specifying them in an extension file.

Minimum Minimum number of times the Any can occur. To specify that the Any is optional, set
this attribute to zero

Maximum Maximum number of times the Any can occur. For an unlimited number of times,
select unbounded

ID [XSD only] ID of the Any. Its value must be of type ID and unique within the model
containing the Any.

Namespace [XSD only] Namespaces containing the objects that can be used. If you select ##any,
objects from any namespace can be used. If you select ##other, objects from any
namespace other than the target namespace of the schema can be used. If you select
##local, objects that are not qualified with a namespace can be used. If you select
##targetNamespace, objects from the target namespace of the schema can be used. If
you type a combination of URI references, ##targetNamespace and ##local, pro-
vided they are separated by a white space, objects from this combination can be
used.

Process con-
tents

[XSD only] Indicator of how an XML processor should handle validation of XML
documents containing the objects specified by the Any. If you select Strict, the XML
processor must obtain the schema and validate any object of the specified name-
spaces. If you select Lax, the XML processor will try to obtain the schema and
validate any object of the specified namespaces. If the schema cannot be found, no
error will occur. If you select Skip, the XML processor will not try to validate the
objects of the specified namespaces.

Keywords Provide a way of loosely grouping objects through tagging. To enter multiple key-
words, separate them with commas.

Attributes (XSM)
Attributes are used to give additional information about elements.

There are global and local attributes:
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• Global attributes are defined with the Model menu. In a schema, they are directly linked to
the <schema> tag (root element). They can be reused for any element in the model through
references (See "NUMBER" attribute in the generated schema)

• Local attributes only apply to the elements in which they are created. They can be defined
by reference to a global attribute (See Reference property)

Note: In a model targeted with the XML-Data Reduced language, local attributes are first
declared separately, like global attributes (with the <AttributeType> tag and a name attribute),
then within their parent element (with the <attribute> tag and a type attribute).

Extract of an XDR file:

You can derive an attribute data type to extend or restrict its values. (Only with a model
targeted with XSD)

For example:

Generated schema:

CHAPTER 2: XML Diagrams

36 PowerDesigner



In a schema, attributes are declared with <attribute> tags.

Creating an Attribute
You can create attributes (and attribute groups) on the Attributes tab of an element, complex
type, or attribute group property sheet.

The Attributes tab contains the following tools:

Tool Description

Add Attribute - Creates a local attribute

Add Undefined Reference to Attribute Group - Adds an attribute group with a reference to
an attribute group defined in the current model. Select a name in the Reference list. You can
also type a new name in the Reference column and then define a new attribute group in the
Attribute Groups list
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Tool Description

Add Reference to Attribute - Adds one or several attributes with a reference to global
attributes defined in the current model. Select one or several global attributes in the Se-
lection dialog box

Add Reference to Attribute Group - Adds a reference to an attribute group defined in the
current model. Select one or several attribute groups in the Selection dialog box

Any Attribute - Adds "any" attribute of a specified namespace. For more information, see
"Any" Attributes on page 40.

For general information about creating objects, see Core Features Guide > The
PowerDesigner Interface > Objects.

Attribute Properties
To view or edit an attribute's properties, double-click its diagram symbol or Browser or list
entry. The property sheet tabs and fields listed here are those available by default, before any
customization of the interface by you or an administrator.

The General tab contains the following properties:

Property Description

Name/Code/
Comment

Identify the object. The name should clearly convey the object's purpose to non-
technical users, while the code, which is used for generating code or scripts, may be
abbreviated, and should not normally include spaces. Neither the name nor code
should contain colons. You can optionally add a comment to provide more detailed
information about the object. By default the code is generated from the name by
applying the naming conventions specified in the model options. To decouple name-
code synchronization, click to release the = button to the right of the Code field.

Stereotype Extends the semantics of the object. You can enter a stereotype directly in this field,
or add stereotypes to the list by specifying them in an extension file.

Reference Specifies a global attribute in this or another model to reuse. Disables Name, Code,
Type, Default, and Fixed properties. Select a global attribute in the current model
from the list or click the Browse tool to select an attribute from any model open in the
workspace.

Type Specifies the data type, which must be a qualified name. Select a built-in data type
from the list or click the Browse tool to select a simple type defined in any model
open in the workspace.

Embedded
Type

[XSD only] Creates a <simple type> tag in the schema within the <at-
tribute> tag. Resets the Type property to <None>.
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Property Description

Derivation [XSD only] Specifies a derivation method for the data type to extend or restrict its
values. Resets the Type property to <None>. Click the Properties tool to further

define the derivation (see Derivations: Extensions, Restrictions, Lists and Unions
(XSM) on page 62).

Keywords Provide a way of loosely grouping objects through tagging. To enter multiple key-
words, separate them with commas.

Detail Tab
The Detail tab of an attribute property sheet displays the following properties:

Property Description

Default Specifies a default value for the attribute. Mutually exclusive with the Fixed property.

Fixed Specifies a fixed value for the attribute. Mutually exclusive with the Default property.

Use Specifies how the attribute can be used. Select from:

• Optional - the attribute is optional and may have any value.

• Prohibited - the attribute cannot be used. Use this value to prohibit the use

of an existing attribute in the restriction of another complex type.

• Required - the attribute must appear at least once and may have any value

matching its data type.

Form Specifies whether or not the attribute must be qualified by combining the target
namespace of the schema with the no-colon-name of the attribute.

ID Specifies the ID of the attribute, which must be unique within the model.

Attribute Property Sheet Values Tab
The Values tab of an attribute property sheet is only available in a model targeted with DTD or
XDR. You can set a list of predefined values for an attribute.

Note: In a model targeted with the XML-Data Reduced language, there is also a Values tab in
the element property sheet.

XDR Attribute Properties
In an XML-Data Reduced language model, attributes tags are defined as follows:
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XDR Attribute
Attribute

Description

name Specifies the name of the attribute.

General tab: Name

default Specifies a default value for the attribute.

Detail tab: Default

dt:type Specifies a type for the attribute.

General tab: Type

dt:values To specify a list of available values for a global attribute

Values tab

type Specifies the name of a global attribute as a reference for a local attribute.

General tab: Reference

Any Attributes
The "Any" attribute feature allows you to insert any attribute of specified namespaces into an
element, a complex type or an attribute group declaration. It is only available in a model
targeted with XSD.

In a schema, Any Attribute is declared with the <anyAttribute> tag.

For example:

Warning! Any Attribute only is displayed in a schema (see the Preview tab of a model
property sheet).

The Any Attribute feature is available via a check box in the bottom-left corner of an
Attributes tab.
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To display an Any Attribute property sheet, select the Any Attribute check box and then click
the Properties tool.

Any Attribute Property Sheet General Tab
To view or edit an "Any" attribute's properties, double-click its Browser or list entry. The
property sheet tabs and fields listed here are those available by default, before any
customization of the interface by you or an administrator.

The General tab contains the following properties:

Property Description

ID ID of the Any Attribute. Its value must be of type ID and unique within the model
containing the Any Attribute

Namespace Namespaces containing the attributes that can be used. If you select ##any, attributes
from any namespace can be used. If you select ##other, attributes from any name-
space other than the target namespace of the schema can be used. If you select
##local, attributes that are not qualified with a namespace can be used. If you select
##targetNamespace, attributes from the target namespace of the schema can be used.
If you type a white space delimited list with URI references, ##targetNamespace and
##local, attributes from this list can be used
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Property Description

Process con-
tents

Indicator of how an XML processor should handle validation of XML documents
containing the attributes specified by the Any Attribute. If you select Lax, the XML
processor will try to obtain the schema and validate any attribute of the specified
namespaces. If the schema cannot be found, no error will occur. If you select Skip,
the XML processor will not try to validate the attributes of the specified namespaces.
If you select Strict, the XML processor must obtain the schema and validate any
attribute of the specified namespaces

Constraints: Keys, Uniques, and KeyRefs (XSM)
Constraints indicate that element values must be unique within their specified scope.
Constraints are only available in a model targeted with XSD.

Each constraint has two specific attributes: selector and field.

In a schema, a constraint is declared with its corresponding tag: <unique>, <key> or
<keyRef>.

There are three kinds of identity constraints:

• A Unique constraint - specifies that an element or an attribute value (or set of values) must
be unique or null within a specified scope. For example:

Generated schema:
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The UNIQUENUM unique constraint, defined on the project element, specifies that the
numEmployee attribute must be unique or null within the employee element

• A Key constraint - specifies that an element or an attribute value (or set of values) must be a
key within a specified scope; the data must be unique, not null, and always present within a
specified scope. For example:

Generated schema:

The KEYCODE key constraint, defined on the project element, specifies that the code
attribute must be unique, not null and always present within the product element.

• A KeyRef constraint - specifies that an element or attribute value (or set of values)
corresponds to the value of a specified key or unique constraint. A keyRef is a reference to
a key or a unique constraint. For example:

Generated schema:
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The KEYREF_UNIGOLD keyRef, defined on the product element, by reference to the
UNIGOLD unique constraint, specifies that the gold attribute must be unique or null
within the component_2 element, as well as it must be unique or null within the
component_1 element (See UNIGOLD).

Creating a Constraint
You create a constraint on the Constraints tab of an element property sheet.

The Constraints tab contains the following tools:

Tool Description

Add Key Constraint - The element value must be a key within the specified scope. The scope
of a key is the containing element in an instance document. A key must be unique, not null,
and always present

Add Unique Constraint - The element value must be unique or null within the specified
scope

Add KeyRef Constraint - The element value corresponds to those of the specified key or
unique constraint
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For general information about creating objects, see Core Features Guide > The
PowerDesigner Interface > Objects.

Constraint Properties
To view or edit a constraint's properties, double-click its Browser or list entry. The property
sheet tabs and fields listed here are those available by default, before any customization of the
interface by you or an administrator.

The General tab contains the following properties:

Property Description

Name/Code/
Comment

Identify the object. The name should clearly convey the object's purpose to non-
technical users, while the code, which is used for generating code or scripts, may be
abbreviated, and should not normally include spaces. Neither the name nor code
should contain colons. You can optionally add a comment to provide more detailed
information about the object. By default the code is generated from the name by
applying the naming conventions specified in the model options. To decouple name-
code synchronization, click to release the = button to the right of the Code field.

Stereotype Extends the semantics of the object. You can enter a stereotype directly in this field, or
add stereotypes to the list by specifying them in an extension file.

ID ID of the constraint. Its value must be of type ID and unique within the model
containing the constraint.

Reference
[KeyRef on-
ly]

Name of a key or a unique constraint defined in the current model (or another model
with a specified namespace). The Reference value must be a qualified name.

Selector
(XPath)

An XML Path Language expression that selects a set of elements across which the
values specified in the Fields tab must be unique. There can only be one selector (see
Specifying a Constraint Selector on page 46)

Keywords Provide a way of loosely grouping objects through tagging. To enter multiple key-
words, separate them with commas.

Fields Tab
The Fields tab lists XPath expressions used to define the constraint (see XPath Abbreviated
Syntax on page 47). If more than one field is listed, the combination of fields must be unique
(see Specifying Constraint Fields on page 46).
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Specifying a Constraint Selector
A constraint selector specifies an XPath expression that selects a set of elements for a
constraint.

1. Open the property sheet of a constraint, and enter an XPath expression in the Selector
(XPath) field (see XPath abbreviated syntax on page 47).

2. Click Apply to make available the Properties tool to the right of the field.

3. Click the Properties tool to open the selector property sheet.

4. [optional] Enter additional properties for the selector, and then click OK to return to the
constraint.

Specifying Constraint Fields
Constraint fields are XPath expressions used to define a constraint (unique, key or keyRef).

1. Open the property sheet of a constraint and then click the Fields tab.

2. Click in the XPath column and enter an XPath expression (see XPath abbreviated syntax
on page 47).

3. Click the Properties tool to open the property sheet of the field:
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4. [optional] Enter additional properties for the selector, and then click OK to return to the
constraint.

XPath Abbreviated Syntax
An XPath expression allows you to locate a node (an element with its ramifications) in the
hierarchical tree structure of an XML document.

The XPath expressions permitted to define constraint selectors and fields are limited to a
subset of the full XPath language defined in the W3C Recommendation XML Path Language
1.0:

Syntax Description

/ Root node of the XML document. It is the root element with its
ramifications

. Selects the context node. It is the current element (on which an
identity constraint is defined) with its ramifications

.. Selects the context node parent

* Selects all the child elements of the context node

employee Selects all the employee child elements of the context node

s:employee Selects all the employee child elements of the context node,
defined in the namespace with the "s" prefix
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Syntax Description

@numEmployee Selects the numEmployee attribute of the context node

@* Selects all the attributes of the context node

../@numEmployee Selects the numEmployee attribute of the context node parent

employee[1] Selects the first employee child element of the context node

employee[last()] Selects the last employee child element of the context node

*/employee Selects all the employee grandchildren of the context node

//employee Selects all the employee descendants of the root node

.//employee Selects the employee descendants of the context node

company//employee Selects the employee descendants of the company child ele-
ments of the context node

//company/employee Selects all the employee elements with company as parent ele-
ment in the context node

/book/chapter[2]/section[3] Selects the third section in the second chapter of the book

employee[@dept="doc"] Selects all the employee child elements of the context node with
a dept attribute set to doc

employee[@dept="doc"][3] Selects the third employee child element of the context node
with a dept attribute set to doc

employee[3][@dept="doc"] Selects the third employee child element of the context node
only if it has a dept attribute set to doc

chapter[title] Selects the chapter child elements of the context node with at
least one title child element

chapter[title="About this book"] Selects the chapter child elements of the context node with at
least one title child element with a text content set to About this
book

employee[@numEmployee and
@dept]

Selects all the employee child elements of the context node with
the numEmployee and dept attributes

text() Selects all the child nodes of the text context node
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Selector and Field Property Sheet General Tab
The General tab of a selector or field property sheet contains the following properties:

Property Description

XPath For a selector: An XPath expression relative to the parent element being declared. It
identifies the child elements to which the identity applies

For a field: An XPath expression relative to each element selected by the selector of
the constraint. It identifies a single element (with a simple type) whose content or
value is used for the constraint

Stereotype Sub-classification used to extend the semantics of an object without changing its
structure. It can be predefined or user-defined

ID ID of the selector. Its value must be of type ID and unique within the model containing
the selector

Groups (XSM)
A group of elements is a set of elements arranged by a group particle (all, choice or sequence),
which is then referenced in the model by various elements.

• A group - is created independently, without a parent element, and can be reused multiple
times by elements, complex types or other global groups, through references. In a schema,
it is directly linked to the <schema> tag (root element). See Creating a group on page
51.

• A reference to a group - is created within an element, complex type or global group, and
makes the referenced group available to its parent. See Creating a reference to a group on
page 51.

For example:

The descriptionLines group is reused in the definition of the product element by clicking the
sequence group particle (S) with the Toolbox Group tool. The Reference property of the
referencing group property sheet is then set to descriptionLines.
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In the generated XSD file, the group is first declared with the <group> tag and then reused
through a reference (ref) set to descriptionLines:

• In the generated DTD file, the group is expanded directly within its parent element:

• In the generated XDR file, the group is declared through a <group> tag, within an
<ElementType> tag with its order attribute set to seq:

Note: In a model targeted with DTD or XDR language, there are no global or referencing
groups, although they appear on the diagram. Groups are expanded within their parent
element and their child elements are declared individually as global elements. (See generated
DTD and XDR files in Groups (XSM) on page 49)
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Creating a Group
A group is created independently in the diagram, and will be reused within other elements by
way of references.

For more information on references, see Creating a reference to a group on page 51.

You can create a group in any of the following ways:

• Select the Group tool in the Toolbox and click in an empty space in the diagram.
• Select Model > Groups to access the List of Groups, and click the Add a Row tool.
• Right-click the model or package in the Browser, and select New > Group.

For general information about creating objects, see Core Features Guide > The
PowerDesigner Interface > Objects.

Creating a Reference to a Group
A reference to a group is created as a child of an element, group or complex type, and makes
the referenced group available to its parent.

You can create a referencing group in any of the following ways:

• Select the Group tool in the Toolbox, and click on an element, group, or complex type
symbol.

• On the Items tab of the property sheet of a group particle, click the Add Reference to
Group tool (see Group Particle Properties on page 32).

For general information about creating objects, see Core Features Guide > The
PowerDesigner Interface > Objects.

Group Properties
To view or edit a group's properties, double-click its diagram symbol or Browser or list entry.
The property sheet tabs and fields listed here are those available by default, before any
customization of the interface by you or an administrator.

The General tab contains the following properties:

Property Description

Name/Code/
Comment

Identify the object. The name should clearly convey the object's purpose to non-
technical users, while the code, which is used for generating code or scripts, may be
abbreviated, and should not normally include spaces. Neither the name nor code
should contain colons. You can optionally add a comment to provide more detailed
information about the object. By default the code is generated from the name by
applying the naming conventions specified in the model options. To decouple name-
code synchronization, click to release the = button to the right of the Code field.

Name and Code are read-only for references to groups.
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Property Description

Stereotype Extends the semantics of the object. You can enter a stereotype directly in this field, or
add stereotypes to the list by specifying them in an extension file.

Reference [for references to groups only] Name of a group in the current model or another model
opened in the workspace, which must be a qualified name. A reference allows you to
reuse a group with all its properties without having to define it again. Use the list to
select a group in the current model. Use the Browse tool to select a group from any
model opened in the workspace. If you select a group from another model, a shortcut
is created with the referencing group. When a reference is defined, the name and code
are those of the target group, and the properties are grayed.

Once you have defined the reference of a referencing group, you can locate the
referenced group in the diagram by right-clicking the referencing group symbol and
selecting Find Referenced Group in the contextual menu. The referenced group is
displayed with handles in the diagram.

Group type [unavailable to references to groups] Specifies how child elements are to be used
within the group. You can choose between:

• all
• choice
• sequence

For more information, see Group Particles (XSM) on page 29.

Minimum Minimum number of times the group can occur. To specify that the group is optional,
set this attribute to zero.

Maximum Maximum number of times the group can occur. For an unlimited number of times,
select unbounded.

ID ID of the group. Its value must be of type ID and unique within the model containing
this group.

Keywords Provide a way of loosely grouping objects through tagging. To enter multiple key-
words, separate them with commas.

You can access the Preview tab of a group property sheet directly, by right-clicking the group
symbol in the diagram and selecting Preview.

Linking Child Objects to a Group
XML objects do not support standard link objects. To link a child object to a group, you must
click the child object tool in the Toolbox and then click the group symbol in the diagram. This
will automatically create a link between both objects.

The following table lists the allowed links:
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Tool Action

If you click a group symbol with the Element tool, a sequence group particle and a child
element symbol are created. You can modify the group particle via its property sheet

If you click a group symbol with the Any tool, a sequence group particle and an any symbol
are created. You can modify the group particle via its property sheet

If you click a group symbol with the Group tool, a sequence group particle and a refer-
encing group are created. You can modify the group particle via its property sheet. You
must now select a group for the reference

If you click a group symbol with the Complex Type tool, a complex type symbol is
displayed superposed, but not linked, to the group symbol. A global complex type cannot
be the child of a group

If you click a group symbol with the Sequence tool, a sequence group particle is displayed
linked to the group symbol

If you click a group symbol with the Choice tool, a choice group particle is displayed
linked to the group symbol

If you click a group symbol with the All tool, an all group particle is displayed linked to the
group symbol

Note: When you cannot click a symbol or an empty space in a diagram, the Pointer displays a
forbidden sign (See complex type in Tool column). When there is a possibility to create a
symbol above, below or next to another one, the Pointer displays an arrow indicating the
corresponding direction (See element in Tool column).

Attribute Groups (XSM)
Attribute groups are not supported by XDR.

An attribute group is a set of attributes, which is referenced in the model by various elements.
It is created independently, without a parent element, and can be reused multiple times by
elements, complex types or other global attribute groups, through references. In a schema, it is
directly linked to the <schema> tag (root element).

For example:
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The quality attribute group is composed of the guarantee and qualityStandards attributes. The
productA element reuses the quality attribute group via the Attributes tab of its property sheet.

• Generated XSD file:

In a schema, a group of attributes is declared with the <attributeGroup> tag. It can contain
the following tags: <attribute>, <attributeGroup> or <anyAttribute>.

• Generated DTD file:

Creating an Attribute Group
You can create an attribute group from the Browser or Model menu. You reuse attribute groups
within other elements by way of references.

You can create an attribute group in any of the following ways:

• Select Model > Attribute Groups to access the List of Attribute Groups, and click the
Add a Row tool.

• Right-click the model or package in the Browser, and select New > Attribute Group.

To reference an attribute group, open the property sheet of an element, complex type, or
attribute group, click the Attributes tab, and then click the Add Group with Reference to
Group tool (see Element Properties on page 22).
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For general information about creating objects, see Core Features Guide > The
PowerDesigner Interface > Objects.

Attribute Group Properties
To view or edit attribute group's properties, double-click its Browser or list entry. The property
sheet tabs and fields listed here are those available by default, before any customization of the
interface by you or an administrator.

The General tab contains the following properties:

Property Description

Name/Code/
Comment

Identify the object. The name should clearly convey the object's purpose to non-
technical users, while the code, which is used for generating code or scripts, may be
abbreviated, and should not normally include spaces. Neither the name nor code
should contain colons. You can optionally add a comment to provide more detailed
information about the object. By default the code is generated from the name by
applying the naming conventions specified in the model options. To decouple name-
code synchronization, click to release the = button to the right of the Code field.

Name and Code are read-only for references to attribute groups.

Stereotype Extends the semantics of the object. You can enter a stereotype directly in this field, or
add stereotypes to the list by specifying them in an extension file.

Reference [for references to attribute groups only] Name of an attribute group from the current
model or any model opened in the workspace, which must be a qualified name. If you
select an attribute group from another model, a shortcut is created with the refer-
encing attribute group. A reference allows you to reuse an attribute group with all its
properties without having to define it again. When a reference is defined, the name
and code properties are grayed. The name and code are those of the target attribute
group

ID ID of the attribute group. Its value must be of type ID and unique within the model
containing this attribute group

Keywords Provide a way of loosely grouping objects through tagging. To enter multiple key-
words, separate them with commas.

Attributes Tab
This tab lists the attributes and attribute groups associated with the attribute group. For
information about the tools available on this tab for adding attributes and attribute groups, see
Creating an Attribute on page 37.
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Simple Types (XSM)
You can only create simple types in a model targeted with XSD.

A simple type is a data type definition for elements or attributes with text-only content. It
cannot contain elements or attributes.

A simple type is defined by derivation of an existing simple type (built-in data type or derived
simple type).

There are three kinds of derivation for a simple type:

• List - contains a white space-separated list of values of an inherited simple type
• Restriction - has a range of values restricted to a subset of those of an inherited simple

type
• Union - contains a union of values of two or more inherited simple types

For more information on simple type derivations, see Derivations: Extensions, Restrictions,
Lists and Unions (XSM) on page 62.

Once defined in a model, a simple type can be reused in the definition of an attribute, an
element or a complex type.

Example of a simple type in a schema:

Creating a Simple Type
You can create a simple type from the Browser or Model menu..

• Select Model > Simple Types to access the List of Simple Types, and click the Add a Row
tool.

• Right-click the model or package in the Browser, and select New > Simple Type.

Warning! If the simple type symbol does not appear in the diagram, select Symbol > Show
Symbols, then click the Simple Type tab and select the simple type box to display its symbol in
the diagram.

For general information about creating objects, see Core Features Guide > The
PowerDesigner Interface > Objects.
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Simple Type Properties
To view or edit a simple type's properties, double-click its diagram symbol or Browser or list
entry. The property sheet tabs and fields listed here are those available by default, before any
customization of the interface by you or an administrator.

The General tab contains the following properties:

Property Description

Name/Code/
Comment

Identify the object. The name should clearly convey the object's purpose to non-
technical users, while the code, which is used for generating code or scripts, may be
abbreviated, and should not normally include spaces. Neither the name nor code
should contain colons. You can optionally add a comment to provide more detailed
information about the object. By default the code is generated from the name by
applying the naming conventions specified in the model options. To decouple name-
code synchronization, click to release the = button to the right of the Code field.

Names and codes must be unique among all simple and complex types.

Stereotype Extends the semantics of the object. You can enter a stereotype directly in this field,
or add stereotypes to the list by specifying them in an extension file.

Derivation Derivation method for the simple type. Enabled and required when the simple type is
defined.

Final Property to prevent derivation of the current simple type.

ID ID of the simple type. Its value must be of type ID and unique within the model
containing the simple type.

Keywords Provide a way of loosely grouping objects through tagging. To enter multiple key-
words, separate them with commas.

Complex Types (XSM)
You can only create complex types in a model targeted with XSD.

A complex type is a data type definition used to define attributes and child elements of a parent
element. It is a template for a data type definition that can be reused and derived by extension
or restriction.

A complex type has:

• a global scope when it has no parent element in the diagram and when it is directly linked to
the <schema> tag. It can then be reused or derived, by extension or restriction, in other
parts of the schema.

• a local scope when integrated into an <element> tag. It applies only to its containing
element.

The following illustration shows a diagram containing a complex type:
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In the example above, HighDefinition is a global complex type, reused as data type for the
deluxeTV element.

The generated schema is the following:

Warning! Global complex types appear in the model as objects, with their corresponding
symbol in the diagram. Local complex types only appear in the schema (see Preview tab of an
element property sheet).

Creating a Complex Type
You can create a complex type from the Toolbox, Browser, or Model menu.

• Use the Complex Type tool in the Toolbox.
• Select Model > Complex Types to access the List of Complex Types, and click the Add a

Row tool.
• Right-click the model or package in the Browser, and select New > Complex Type.

For general information about creating objects, see Core Features Guide > The
PowerDesigner Interface > Objects.

Complex Type Properties
To view or edit a complex type's properties, double-click its diagram symbol or Browser or list
entry. The property sheet tabs and fields listed here are those available by default, before any
customization of the interface by you or an administrator.

The General tab contains the following properties:
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Property Description

Name/Code/
Comment

Identify the object. The name should clearly convey the object's purpose to non-
technical users, while the code, which is used for generating code or scripts, may be
abbreviated, and should not normally include spaces. Neither the name nor code
should contain colons. You can optionally add a comment to provide more detailed
information about the object. By default the code is generated from the name by
applying the naming conventions specified in the model options. To decouple name-
code synchronization, click to release the = button to the right of the Code field.

Names and codes must be unique among all simple and complex types.

Stereotype Extends the semantics of the object. You can enter a stereotype directly in this field,
or add stereotypes to the list by specifying them in an extension file.

Group type Specifies that the complex type has child elements, and how they are used (see 
Group Particles (XSM) on page 29). You can choose between:

• all – All children may be present.

• choice – Only one child must be present.

• group – Reference to a predefined group (see Groups (XSM) on page 49)

• sequence – All children must be present in order.

Content Content type of the complex type (see Specifying the Type of Content of a Complex
Type on page 61).

Derivation Derivation method for the complex type. Once you have selected a derivation
method, you must define a base type. Click the Properties tool beside the derivation
box to display the derivation property sheet. In the General tab, select a base type in
the Base Type list.

Detail Tab
The Detail tab contains the following properties:

Property Description

Final Property to prevent derivation of the current complex type

Block Property to prevent another complex type with the specified type of derivation from
being used in place of the current complex type

Mixed If selected, this property indicates that character data is allowed to appear between
the child elements of the current complex type. Select Mixed only if the current
complex type has a complex content (See general properties)

Abstract If selected, this property indicates that the complex type can be used in the instance
document
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Property Description

ID ID of the complex type. Its value must be of type ID and unique within the model
containing this complex type

Keywords Provide a way of loosely grouping objects through tagging. To enter multiple key-
words, separate them with commas.

Mapping Tab
This tab lets you map the complex type to PDM or OOM objects.

You associate one or more PDM abstract data types or OOM classes to the complex type using
the Add Objects tool on the Complex Type Sources sub-tab. You can associate PDM abstract
data type attributes or OOM class attributes to the complex type attributes using following
tools on the Attributes Mapping tab:

Tool Description

Add Mapping - Selects the attributes in the current complex type that will be mapped to
PDM abstract data type attributes or OOM class attributes. Once you have selected the
attributes, you can use the list in the Mapped to column to select corresponding PDM
abstract data type attributes or OOM class attributes

Create from Sources - Copies PDM abstract data type attributes or OOM class attributes in
the data source to the current complex type attributes

Generate Mapping - Automatically generates a mapping between PDM abstract data type
attributes or OOM class attributes and complex type attributes with the same name or code
in the data source and the current model

For detailed information about mappings, see Core Features Guide > Linking and
Synchronizing Models > Object Mappings.

The following tabs are also available:

• Attributes - lists the attributes and attribute groups associated with the complex type (see
Attributes (XSM) on page 35).

Linking a Child Object to a Complex Type
XML objects do not support standard link objects. To link a child object to a complex type, you
must click the child object tool in the Toolbox and then click the complex type symbol in the
diagram. This will automatically create a link between both objects.

The following table lists the allowed links:
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Tool Action

If you click a complex type symbol with the Element tool, a sequence group particle and a
child element symbol are created. You can modify the group particle via its property
sheet

If you click a complex type symbol with the Any tool, a sequence group particle and an
any symbol are created. You can modify the group particle via its property sheet

If you click a complex type symbol with the Group tool, a referencing group is created.
You can modify the group particle via its property sheet. You must now select a group for
the reference

If you click a complex type symbol with the Complex Type tool, a second complex type
symbol is displayed superposed, but not linked, to the first complex type symbol. A
complex type cannot be the child of another complex type

If you click a complex type symbol with the Sequence tool, a sequence group particle is
displayed linked to the complex type symbol

If you click a complex type symbol with the Choice tool, a choice group particle is
displayed linked to the complex type symbol

If you click a complex type symbol with the All tool, an all group particle is displayed
linked to the complex type symbol

Note: When you cannot click a symbol or an empty space in a diagram, the Pointer displays a
forbidden sign. When there is a possibility to create a symbol above, below or next to another
one, the Pointer displays an arrow indicating the corresponding direction.

Specifying the Type of Content of a Complex Type
A complex type can contain either:

1. Open the property sheet of a complex type and select a type in the Content field:

• simple content – character data or a simple type (but no elements), or
• complex content – elements or elements and character data

2. Click Apply to make available the Properties tool to the right of the list.

3. [optional] Click the Properties tool to open the property sheet of the content, and specify
an ID and, in the case of complex content, whether the content can be mixed:
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Property Description

ID ID for the complex content. Its value must be of type ID and unique within the
model containing the complex content

Mixed [complex
content only]

Specifies that character data is allowed to appear between child elements of
the complex type.

4. Click OK to return to the diagram.

Derivations: Extensions, Restrictions, Lists and Unions
(XSM)

You can use derivations to extend or restrict the values of elements and of simple and complex
types.

An XML model allows you to derive:

• Elements by extension, restriction, list or union
• Simple types by restriction, list or union
• Complex types by extension or restriction

Note: When you define a derivation in an element property sheet, a simple or a complex type is
automatically created within the element declaration (See Preview tab). The Embedded type
property is automatically set to Simple or Complex, and the Content property to Simple or
Complex in the case of an embedded complex type.

Deriving by Extension
You can derive an element or complex type by extension to extend the values of its base type.

For example:

USaddress is a derivation by extension of the address complex type.
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The generated schema is the following:

1. Open the property sheet of an element or complex type and select Extension in the
Derivation list.

The Content field (and, in the case of an element, the Embedded type field) is set to
Complex.

2. Click the Properties tool to the right of the Derivation box to open the property sheet of the
extension and complete the following properties:

Property Description

ID ID of the extension. Its value must be of type ID and unique within the model
containing the extension

Base Type Data type on which the extension is based

3. Specify an ID, select a base type, and then click OK to return to the element or complex
type.

Deriving by Restriction
You can derive an element, simple type, or complex type by restriction to restrict the values of
their base type.

1. Open the property sheet of an element, simple type, or complex type, and select Restriction
in the Derivation list.
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For elements and complex types, the Content field (and, in the case of an element, the
Embedded type field) is set to Complex.

2. Click the Properties tool to the right of the Derivation field to open the restriction
property sheet, and complete the following fields on the General tab:

Property Description

ID ID of the simple type restriction. Its value must be of type ID and unique within
the model containing the simple type restriction

Base type Data type on which the restriction is based. Select a data type in the Base type
list or with the Browse tool

Embedded type
[simple types
only]

If selected, the base type disappears and a simple type is created in the schema
within the current simple type. Click Apply, and then the Properties tool beside
the Embedded type box, to define a derivation and a base type for the embedded
simple type.

3. [optional - simple type restrictions only] Click the Detail tab and enter appropriate facets
(constraints on the set of values of a simple type) for the restriction:

Icon Facet

Length - Exact number of characters or list items allowed. It must be equal to or greater
than zero
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Icon Facet

Whitespace - Way of handling white spaces. You can choose from the following:
• Preserve - white spaces are unchanged.
• Replace - Tabs, line feeds and carriage returns are replaced with spaces.
• Collapse - Contiguous sequences of spaces are collapsed to a single space. Leading

and trailing spaces are removed.

Minimum length - Minimum number of characters or list items allowed. It must be equal
to or greater than zero

Maximum length - Maximum number of characters or list items allowed. It must be
equal to or greater than zero

Minimum exclusive - Lower bound for numeric values. All values are greater than this
value

Maximum exclusive - Upper bound for numeric values. All values are lower than this
value

Minimum inclusive - Minimum value allowed for data type

Maximum inclusive - Maximum value allowed for data type

Total digits - Exact number of decimal digits allowed. It must be greater than zero

Fraction digits - Maximum number of decimal digits in the fractional part

You can optionally click the Properties tool to the right of each field to open the property
sheet of the facet and enter the following properties:

Property Description

ID ID of the facet. Its value must be of type ID and unique within the model con-
taining the facet

Value Value(s) of the facet

Fixed To prevent a modification of the facet value(s), select the Fixed property

4. [optional - simple type restrictions only] Click the Enumerations tab and enter a set of
acceptable values. Select the F[ixed] check box to prevent the modification of a value.

For example: the meetings simple type, based on the xs:gMonthDay data type, is restricted
to the following dates: 01/20, 03/20, 05/20 and 07/20.
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Generated schema:

5. [optional - simple type restrictions only] Click the Patterns tab and enter one or more
sequences of acceptable values. Select the F[ixed] check box to prevent the modification
of a value.

For example: the zipCode simple type, based on the xs:string data type, is restricted to the
following pattern: two uppercase letters, from A to Z, followed by a five-digit number,
each digit ranging from 0 to 9.
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Generated schema:

6. Click OK to close the restriction property sheet and return to the element, simple type, or
complex type.

Deriving by List
You can derive an element or simple type by list to define it as a list of values of a specified data
type.

1. Open the property sheet of an element or simple type, and select List in the Derivation
list.

For elements, the Embedded type field is set to Simple.

2. Click the Properties tool to the right of the Derivation box to open the list property sheet
and complete the following properties:

Property Description

ID ID of the simple type list. Its value must be of type ID and unique within the
model.
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Property Description

Type Data type for the list of values

Embedded
Type

If selected, the type disappears and a simple type is created in the schema within
the current simple type or element. Click Apply, and then the Properties tool
beside the Embedded type box, to define a derivation and a type for the embedded
simple type.

3. Click OK to close the list property sheet and return to the element or simple type.

Deriving by Union
You can derive an element or simple type by union to define it as a collection of built-in and
simple data types.

1. Open the property sheet of an element or simple type, and select Union in the Derivation
list.

For elements, the Embedded type field is set to Simple.

2. Click the Properties tool to the right of the Derivation box to open the union property sheet
and complete the following properties:

Property Description

ID ID of the simple type union. Its value must be of type ID and unique within
the model containing the simple type union.

Member Types White space separated list of built-in data types. Values must be qualified
names.

3. [optional] Click the Union Types tab and add appropriate simple types to the union.

4. Click OK to close the union property sheet and return to the element or simple type.

Annotations (XSM)
Annotations are only available in models targeted with XSD.

You define annotations when you want to add information about an XML model. There are
three kinds of annotations:

• Annotation - provides extra information on XML models or schemas. You can define
multiple annotations at this level, and each can contain multiple documentation and/or
application information tags.

• Documentation – is contained within an annotation and contains an URI reference or any
well-formed XML content that gives extra information about XML objects or documents

• Application Information - is contained within an annotation and contains an URI reference
or any well-formed XML content that is used by applications for processing instructions

Generated schema of a global annotation:
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This global annotation is composed of a documentation, with a well-formed XML content
(extract of a DTD file), and an application information.

Creating an Annotation
You can create an annotation at the global level from the model property sheet or from the
Browser.

• Open the Items or External Schemas tab in the property sheet of the model, and click the
Add Annotation tool.

• Right-click the model or package in the Browser, and select New > Annotation.

For general information about creating objects, see Core Features Guide > The
PowerDesigner Interface > Objects.

Annotation Properties
To view or edit an annotation's properties, double-click its Browser or list entry. The property
sheet tabs and fields listed here are those available by default, before any customization of the
interface by you or an administrator.

The General tab contains the following properties:

Property Description

ID Must be of type ID and unique within the model containing the annotation.
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Items Tab
This tab lists the documentation and application information tags contained within the
annotation. You can create a documentation or application information using the following
tools:

Tool Description

Add Documentation - Adds a comment or a document reference to be read by users

Add Application Information - Adds an information to be used by applications for
processing instructions

Note: These tools are also available on the Annotations tab of an element or other object
property sheet - to add content to an annotation at the global, schema level

Documentation and Application Information Properties
The General tab contains the following properties:

Property Description

Source Source of the content. It must be a URI reference

Language [documentation only] Language used in the documentation. For example: en, en-GB,
en-US, de, fr

The Content tab allows you to write or paste any well-formed XML content.

Notations (XSM)
Notations allow you to define and process non-XML objects within an XML model.

The following example shows the generated schema for a notation:

Notations are not available on models targeted with XDR.

Creating a Notation
You can create a notation from the Browser or Model menu.

• Select Model > Notations to access the List of Notations, and click the Add a Row tool.
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• Right-click the model or package in the Browser, and select New > Notation.

For general information about creating objects, see Core Features Guide > The
PowerDesigner Interface > Objects.

Notation Properties
To view or edit a notation's properties, double-click its Browser or list entry. The property
sheet tabs and fields listed here are those available by default, before any customization of the
interface by you or an administrator.

The General tab contains the following properties:

Property Description

Name/Code/
Comment

Identify the object. The name should clearly convey the object's purpose to non-
technical users, while the code, which is used for generating code or scripts, may be
abbreviated, and should not normally include spaces. Neither the name nor code
should contain colons. You can optionally add a comment to provide more detailed
information about the object. By default the code is generated from the name by
applying the naming conventions specified in the model options. To decouple name-
code synchronization, click to release the = button to the right of the Code field.

Stereotype Extends the semantics of the object. You can enter a stereotype directly in this field,
or add stereotypes to the list by specifying them in an extension file.

Public URI reference identifying the non-XML object. For example: pictures/gif.

System URI reference identifying the application that will process the non-XML object. For
example: user/local/pictureViewer.

ID ID of the notation. Its value must be of type ID and unique within the model con-
taining the notation.

Keywords Provide a way of loosely grouping objects through tagging. To enter multiple key-
words, separate them with commas.

Entities (XSM)
Entities enable you to include predefined values, external XML or non-XML files in an XML
model targeted with a DTD.

When an XML processor reads an entity reference in an XML document, it will replace this
entity reference by its value defined in the DTD file of the XML document.

An entity reference is the entity name preceded by an ampersand and followed by a semicolon.

For example: &furtherinfo; will be replaced by For further information,
see.

The W3C has predefined five entities for XML tags:

CHAPTER 2: XML Diagrams

XML Modeling 71



Entity name Reference Value

Less than &lt; <

Greater than &gt; >

Ampersand &amp; &

Apostrophe &apos; '

Quotation &quot; "

In an XML model, you just need to type the name and the value of an entity.

Creating an Entity
You can create an entity from the Browser or Model menu.

• Select Model > Entities to access the List of Entities, and click the Add a Row tool.
• Right-click the model or package in the Browser, and select New > Entity.

For general information about creating objects, see Core Features Guide > The
PowerDesigner Interface > Objects.

Entity Properties
To view or edit an entity's properties, double-click its diagram symbol or Browser or list entry.
The property sheet tabs and fields listed here are those available by default, before any
customization of the interface by you or an administrator.

The General tab contains the following properties:

Property Description

Name/Code/
Comment

Identify the object. The name should clearly convey the object's purpose to non-
technical users, while the code, which is used for generating code or scripts, may be
abbreviated, and should not normally include spaces. Neither the name nor code
should contain colons. You can optionally add a comment to provide more detailed
information about the object. By default the code is generated from the name by
applying the naming conventions specified in the model options. To decouple name-
code synchronization, click to release the = button to the right of the Code field.

Stereotype Extends the semantics of the object. You can enter a stereotype directly in this field,
or add stereotypes to the list by specifying them in an extension file.

Value Value of the entity. A string of characters in the case of a predefined value. A URI in
the case of an XML or a non-XML file. For example: http://something.com/pictures/
logo.gif.

Public URI reference identifying the non-XML object. For example: pictures/gif.
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Property Description

System URI reference identifying the application that will process the non-XML object. For
example: user/local/pictureViewer.

Notation Used to define and process non-XML objects within an XML model.

Parameter If selected, the entity is parsed within the DTD, and not within the XML document as
for a general entity. A parameter entity allows you to predefine a value within a
DTD. This predefined value can then be easily changed within the DTD.

Keywords Provide a way of loosely grouping objects through tagging. To enter multiple key-
words, separate them with commas.

Instructions: Import, Include and Redefine (XSM)
Import, Include and Redefine allow you to enrich your XML model with external namespaces,
schema files or schema components.

These instructions are only available in a model targeted with XSD.

Imports
An import identifies a namespace whose schema components are referenced by the current
schema, allowing you to use components from any schema with different target namespace
than the current schema.

In a schema, an import is declared with the <import> tag. For example:

Includes
An include allows you to include a specified schema file in the target namespace of the current
schema, allowing you to use components from any schema with the same target namespace as
the current schema or with no specified target namespace.

In a schema, an include is declared with the <include> tag. For example:
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Redefines
A redefine allows you to redefine simple and complex types, groups and attribute groups from
an external schema file in the current schema, allowing you to use components from any
schema with the same target namespace as the current schema or with no specified target
namespace.

In a schema, a redefine is declared with the <redefine> tag. For example:

Creating an Import, Include, or Redefine Instruction
You can create an import, include, or redefine instruction from the model property sheet or
from the Browser or Model menu.

• Select Model > Import, Include, or Redefine to access the relevant list, and click the Add
a Row tool.

• Open the External Schemas tab in the property sheet of the model, and click the Add
Import, Add Include, or Add Redefine tool.

• Right-click the model or package in the Browser, and select New > Import, Include, or
Redefine.

For general information about creating objects, see Core Features Guide > The
PowerDesigner Interface > Objects.

Import, Include, and Redefine Properties
To view or edit an instruction's properties, double-click its Browser or list entry. The property
sheet tabs and fields listed here are those available by default, before any customization of the
interface by you or an administrator.

The General tab contains the following properties:

Property Description

Schema loca-
tion

URI reference for the location of a schema file with an external namespace. You can
use the Browse tool beside the Properties tool to select a schema file among those
opened in the current workspace. For example: ORDER.xsd.
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Property Description

ID ID of the instruction. Its value must be of type ID and unique within the schema
containing the instruction.

Namespace [import only] URI reference for the namespace to import. For example: xml.order-
ing.

Comment Descriptive label of the instruction.

Stereotype Extends the semantics of the object. You can enter a stereotype directly in this field,
or add stereotypes to the list by specifying them in an extension file.

Items Tab
The Items tab, which is available for redefines only, lists the items to be redefined. The
following tools are available:

Tool Description

Add Group - Adds a group of elements to be redefined.

Add Attribute Group - Adds a group of attributes to be redefined.

Add Simple Type - Adds a simple type to be redefined.

Add Complex Type - Adds a complex type to be redefined.

Business Rules (XSM)
A business rule is a rule that your business follows. It is a written statement specifying what an
information system must do or how it must be structured. It could be a government-imposed
law, a customer requirement, or an internal guideline.

You can attach business rules to your model objects to guide and document the creation of your
model. For example, the rule "an employee belongs to only one division" can help you
graphically build the link between an employee and a division.

For more information, see Core Features Guide > The PowerDesigner Interface > Objects >
Business Rules.
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CHAPTER 3 Generating and Reverse
Engineering XML Schemas and
Other Models

PowerDesigner supports the generation and reverse-engineering of XML Schema Definition
files (.XSD), Document Type Definition files (.DTD) and XML-Data Reduced files (.XDR).
You can also generate a physical data model (PDM) from an XSM or generate an XSM from a
PDM

Generating XML Schema Files
PowerDesigner provides a standard interface for generating all the supported XML schemas.

Target Schema Generated file

XML Schema Definition 1.0 XSD

Document Type Definition 1.0 DTD

Note: Parameter entities are references to predefined values
within a DTD file (See Parameter property in entity property
sheet). During DTD generation, some object properties con-
taining inadvertently parameter values will be generated with
parameter references. If you are not satisfied with this default
use of parameter entities, you should clear the Parameter
property before generation.

XML-Data Reduced 1.0 XDR

You can preview the file to be generated by selecting the Preview tab of your XML model
property sheet (see Previewing XML Code on page 8).

Note: The PowerDesigner generation system is extremely customizable through the use of
extensions (see Extending your Modeling Environment on page 12). For detailed information
about customizing generation, including adding generation targets, options, and tasks, see
Customizing and Extending PowerDesigner > Extension Files.

1. Select Language > Generateschema File to open the Generation dialog:
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2. Enter a directory in which to generate the files and specify whether you want to perform a
model check. For more information about checking your model, see Chapter 4, Checking
an XSM  on page 85.

Note: When generating an XDR file, the Generation dialog contains an Options tab, where
you can specify whether or not to generate comments (within a <description> tag). This
option is enabled by default.

3. Click OK to begin generation.

A Progress box is displayed. The Result list displays the files that you can edit. The result is
also displayed in the Generation tab of the Output window, located in the bottom part of the
main window.

4. Click Edit to edit the XSD, DTD or XDR file in your associated editor:
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Reverse Engineering an XML Schema into an XSM
Reverse engineering is the process of extracting an XML structure from an XML schema file,
and using it to build or update an XSM.

Note: PowerDesigner uses a parser software for XML reverse engineering, developed by the
Apache Software Foundation (http://www.apache.org).

Reverse Engineering to a New XML Model
You can reverse engineer XML schema files to create a new XSM.

1. Select File > Reverse Engineer > XML Definition to open the New XML Model dialog
box.

2. Select an XML language and specify whether you want to share the resource file or copy it
to your model.

3. [optional] Click the Select Extensions tab, and select any extension files you want to
attach to the new model.

4. Click OK to go to the Reverse Engineering dialog:

5. On the Options tab, specify the file you want to reverse engineer, and select any
appropriate options:

CHAPTER 3: Generating and Reverse Engineering XML Schemas and Other Models

XML Modeling 79

http://www.apache.org/


Option Description

Show sym-
bols

Creates symbols for the reversed objects in the diagram. If you select to show
symbols, you can also specify to expand all the nodes, and to display elements,
groups, and complex and simple types.

Convert
unique refer-
ences to ele-
ments

Enables the display of shortcuts to XML structures in other models as expand-
able nodes, instead of simple shortcuts. Since global objects with a single ref-
erence in the model will be converted into child objects, you should not use this
option if you want to keep the global scope of some objects. You can subse-
quently perform this conversion by selecting Tools > Convert Unique Refer-
ences in the XML model.

6. [optional] Click the Target Models tab and specify any existing PowerDesigner models
which are referenced in the file being reverse engineered. These references will become
shortcuts in the reversed model.

7. Click OK to begin reverse engineering.

The XML file is reversed into an XML model and displayed in the diagram window and the
Browser. The result is also displayed in the Reverse page of the Output window.

Reverse Engineering to an Existing XML Model
You can reverse engineer XML schema files to add objects to an existing XSM.

1. Open the XML model you want to reverse into and then select Language > Reverse
Engineer schema File to open the Reverse Engineering dialog box.

2. Select the file to reverse, and specify any appropriate options.

3. [optional] Click the Target Models tab and specify any existing PowerDesigner models
which are referenced in the file being reverse engineered. These references will become
shortcuts in the reversed model.

4. Click OK to begin reverse engineering.

A message in the Output window confirms that the file has been reversed and the Merge
Models window opens:
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5. Review the objects that you will be importing, and the changes that they will make to the
model (see Core Features Guide > The PowerDesigner Interface > Comparing and
Merging Models).

6. Click OK to merge the selected changes into your model.

7. [optional] Select Symbol > Auto-Layout to organize the new symbols in your diagram.

Generating Other Models from an XSM
You can generate physical data models (PDMs) and other XSMs from an XSM.

1. Select Tools, and then one of the following commands to open the appropriate Model
Generation Options window:

• Generate Physical Data Model... Ctrl+Shift+P
• Generate XML Model... Ctrl+Shift+M

2. On the General tab, select a radio button to generate a new or update an existing model,
and complete the appropriate options.
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3. [optional] Click the Detail tab and set any appropriate options. We recommend that you
select the Check model checkbox to check the model for errors and warnings before
generation.

4. [optional] Click the Target Models tab and specify the target models for any generated
shortcuts.

5. [optional] Click the Selection tab and select or deselect objects to generate.

6. Click OK to begin generation.

Note: For detailed information about the model generation feature, see Core Features
Guide > Linking and Synchronizing Models > Generating Models and Model Objects.

The following table details how XSM objects are generated to PDM objects:

XSM PDM

Elements Tables or columns:

• Root elements - are generated as tables.

• Non-root elements with complex types - are generated as tables or
columns, depending on the option chosen in the Persistent group-
box on the Detail tab of the element property sheet.

• Non-root elements with primitive or simple types - are generated as
table columns.

Note: Root elements with a primitive or simple type are not generated
except where they are referenced by other elements or complex types.

If you have a single root element and want to generate its immediate
children as tables, select the Skip single root element option on the
PDM Generation Options window Detail tab.

Simple types Domains. The datatype of the domain depends on the derivation of the
simple type:

• simple types with a list derivation - varchar.

• simple types with a restriction derivation - the datatype of the base
type

• simple types with a union derivation - the most permissive of the
unioned types

Complex types Merged with their parent element.

If the complex type is the restriction or extension of a simple type it will
be generated as a column called Value linked to the domain generated

from the simple type.
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XSM PDM

Attributes Columns with datatypes determined by resolving any derivation. At-
tributes and attribute groups defined at the model level are not generated
except where they are referenced.

Business rules Business rules

Key constraints Keys

Unique constraints Indexes

Keyref constraints References (if the referenced constraint is a key)

IDs (DTD) Keys

Note: References, substitutions, imports, and includes are always resolved, and attributes and
attribute groups defined at the model level are generated only where they are used. Notations,
redefines, anys, and (for DTDs) entities, are not generated to PDMs.
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CHAPTER 4 Checking an XSM

The XML model is a very flexible tool, which allows you quickly to develop your model
without constraints. You can check the validity of your XSM at any time.

A valid XSM conforms to the following kinds of rules:

• Each complex type should have at least one attribute
• Each group must contain elements, groups, group particles and/or Any

Note: We recommend that you check your XML model before generating an XML document
or another model from it . If the check encounters errors, generation will be stopped. The
Check model option is enabled by default in the Generation dialog box.

You can check your model in any of the following ways:

• Press F4, or
• Select Tools > Check Model, or
• Right-click the diagram background and select Check Model from the contextual menu

The Check Model Parameters dialog opens, allowing you to specify the kinds of checks to
perform, and the objects to apply them to. The following sections document the XSM -specific
checks available by default. For information about checks made on generic objects available
in all model types and for detailed information about using the Check Model Parameters
dialog, see Core Features Guide > The PowerDesigner Interface > Objects > Checking
Models.

Group Particle Checks
PowerDesigner provides default model checks to verify the validity of group articles.

Check Description and Correction

Existence of par-
ticle

A group particle must contain elements, groups, group particles and/or Any.

• Manual correction: Add items to the group particle or delete it
• Automatic correction: None
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Check Description and Correction

Invalid cardinali-
ty

You should define a minimum (0 or 1) and a maximum cardinality (1 or un-
bounded) for a group particle occurrence.

This check is only available in a model targeted with XDR.

• Manual correction: Double-click the group particle symbol and type a value
for Minimum (0 or 1) and Maximum (1 or unbounded) properties

• Automatic correction: None

Model Checks
PowerDesigner provides default model checks to verify the validity of models built on a
schema.

Check Description and Correction

Identifier unique-
ness

Two or more objects cannot have the same identifier (ID).

• Manual correction: Give a unique identifier to each object
• Automatic correction: None

Undefined identi-
fier

You must define an identifier (ID) for each object in the model.

• Manual correction: Define an identifier for each object
• Automatic correction: None

Shortcut code
uniqueness

Two shortcuts with the same code cannot be in the same namespace.

• Manual correction: Change the code of one of the shortcuts
• Automatic correction: None

Undefined target
namespace

You should define a target namespace to your model.

• Manual correction: Type a URI for the Target Namespace property in the
Detail tab of the model property sheet

• Automatic correction: None

Missing name-
spaces

There should be at least one namespace defined for the model.

• Manual correction: Type a URI and a prefix in the Namespaces tab of the
model property sheet

• Automatic correction: Adds the target namespace URI and a prefix "ns"
followed by a number (e.g. "ns1")
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Data Source Checks
PowerDesigner provides default model checks to verify the validity of data sources.

Check Description and Correction

Name/Code con-
tains terms not in
glossary

[if glossary enabled] Names and codes must contain only approved terms drawn
from the glossary.

• Manual correction - Modify the name or code to contain only glossary terms.
• Automatic correction - None.

Name/Code con-
tains synonyms of
glossary terms

[if glossary enabled] Names and codes must not contain synonyms of glossary
terms.

• Manual correction - Modify the name or code to contain only glossary terms.
• Automatic correction - Replaces synonyms with their associated glossary

terms.

Name/Code
uniqueness

Object names must be unique in the namespace.

• Manual correction - Modify the duplicate name or code.
• Automatic correction - Appends a number to the duplicate name or code.

Existence of mod-
el

A data source must have at least one model in its definition.

• Manual correction: Add a model from the Models tab of the data source
property sheet

• Automatic correction: Deletes data source without a model

Data source con-
taining models
with different Ob-
ject Language or
DBMS types

The models in a data source represent a single set of information. This is why the
models in the data source should share the same DBMS or object language.

• Manual correction: Delete models with different DBMS or object language,
or modify the DBMS or object language of models in the data source

• Automatic correction: None
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Entity Checks
PowerDesigner provides default model checks to verify the validity of entities.

Check Description and Correction

Name/Code con-
tains terms not in
glossary

[if glossary enabled] Names and codes must contain only approved terms drawn
from the glossary.

• Manual correction - Modify the name or code to contain only glossary terms.
• Automatic correction - None.

Name/Code con-
tains synonyms of
glossary terms

[if glossary enabled] Names and codes must not contain synonyms of glossary
terms.

• Manual correction - Modify the name or code to contain only glossary terms.
• Automatic correction - Replaces synonyms with their associated glossary

terms.

Name/Code
uniqueness

Object names must be unique in the namespace.

• Manual correction - Modify the duplicate name or code.
• Automatic correction - Appends a number to the duplicate name or code.

Undefined entity You must define an entity. In the entity property sheet, you must either type a
value (string of characters or URI) in the Value box, or a URI in the Public or
System boxes.

• Manual correction: Type a value in the Value box or a URI in the Public or
System boxes

• Automatic correction: None

Include Checks
PowerDesigner provides default model checks to verify the validity of includes.

Check Description and Correction

Undefined sche-
ma location

You must define a schema location for an include.

• Manual correction: Define a URI or select a schema file for the schema
location. For example: proforma.xsd

• Automatic correction: None
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Simple Type Checks
PowerDesigner provides default model checks to verify the validity of simple types.

Check Description and Correction

Name/Code contains terms
not in glossary

[if glossary enabled] Names and codes must contain only approved
terms drawn from the glossary.

• Manual correction - Modify the name or code to contain only
glossary terms.

• Automatic correction - None.

Name/Code contains syno-
nyms of glossary terms

[if glossary enabled] Names and codes must not contain synonyms of
glossary terms.

• Manual correction - Modify the name or code to contain only
glossary terms.

• Automatic correction - Replaces synonyms with their associated
glossary terms.

Name/Code uniqueness Object names must be unique in the namespace.

• Manual correction - Modify the duplicate name or code.
• Automatic correction - Appends a number to the duplicate name

or code.

Complex Type Checks
PowerDesigner provides default model checks to verify the validity of complex types.

Check Description and Correction

Name/Code con-
tains terms not in
glossary

[if glossary enabled] Names and codes must contain only approved terms drawn
from the glossary.

• Manual correction - Modify the name or code to contain only glossary terms.
• Automatic correction - None.

Name/Code con-
tains synonyms of
glossary terms

[if glossary enabled] Names and codes must not contain synonyms of glossary
terms.

• Manual correction - Modify the name or code to contain only glossary terms.
• Automatic correction - Replaces synonyms with their associated glossary

terms.
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Check Description and Correction

Name/Code
uniqueness

Object names must be unique in the namespace.

• Manual correction - Modify the duplicate name or code.
• Automatic correction - Appends a number to the duplicate name or code.

Existence of at-
tribute

A complex type should have at least one attribute.

• Manual correction: Define an attribute for the complex type
• Automatic correction: None

Existence of par-
ticle

A complex type must contain elements, groups, group particles and/or Any.

• Manual correction: Add items to the complex type or delete complex type
• Automatic correction: None

Element Checks
PowerDesigner provides default model checks to verify the validity of elements.

Check Description and Correction

Name/Code con-
tains terms not in
glossary

[if glossary enabled] Names and codes must contain only approved terms drawn
from the glossary.

• Manual correction - Modify the name or code to contain only glossary terms.
• Automatic correction - None.

Name/Code con-
tains synonyms of
glossary terms

[if glossary enabled] Names and codes must not contain synonyms of glossary
terms.

• Manual correction - Modify the name or code to contain only glossary terms.
• Automatic correction - Replaces synonyms with their associated glossary

terms.

Name/Code
uniqueness

Object names must be unique in the namespace.

• Manual correction - Modify the duplicate name or code.
• Automatic correction - Appends a number to the duplicate name or code.

Undefined type An element without a reference should have a defined data type.

• Manual correction: In the element property sheet, define a data type with the
Type list or the Browse tool

• Automatic correction: None
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Check Description and Correction

Undefined refer-
ence

An element without a defined data type must have a reference.

• Manual correction: In the element property sheet, define a reference with the
Reference list or the Browse tool

• Automatic correction: None

Existence of at-
tribute

An element without a reference, a data type or a substitution group should have at
least one attribute.

• Manual correction: Define an attribute for the element
• Automatic correction: None

Existence of par-
ticle

An element with an embedded complex type must contain child elements,
groups, group particles and/or Any.

• Manual correction: Add items to complex element or delete complex element
• Automatic correction: None

Invalid cardinali-
ty

[only available for model targeted with XDR] You should define a minimum (0 or
1) and a maximum cardinality (1 or unbounded) for a group particle occurrence.

• Manual correction: Double-click the group particle symbol and type a value
for Minimum (0 or 1) and Maximum (1 or unbounded) properties

• Automatic correction: None

Group Checks
PowerDesigner provides default model checks to verify the validity of groups.

Check Description and Correction

Name/Code con-
tains terms not in
glossary

[if glossary enabled] Names and codes must contain only approved terms drawn
from the glossary.

• Manual correction - Modify the name or code to contain only glossary terms.
• Automatic correction - None.

Name/Code con-
tains synonyms of
glossary terms

[if glossary enabled] Names and codes must not contain synonyms of glossary
terms.

• Manual correction - Modify the name or code to contain only glossary terms.
• Automatic correction - Replaces synonyms with their associated glossary

terms.
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Check Description and Correction

Name/Code
uniqueness

Object names must be unique in the namespace.

• Manual correction - Modify the duplicate name or code.
• Automatic correction - Appends a number to the duplicate name or code.

Undefined refer-
ence

A group without a name or a code must have a reference.

• Manual correction: In the group property sheet, define a reference with the
Reference list or the Browse tool

• Automatic correction: None

Existence of
group particle

A group must contain elements, groups, group particles and/or Any.

• Manual correction: Add items to group or delete group
• Automatic correction: None

Invalid cardinali-
ty

[only available for model targeted with XDR] You should define a minimum (0 or
1) and a maximum cardinality (1 or unbounded) for a group particle occurrence.

• Manual correction: Double-click the group particle symbol and type a value
for Minimum (0 or 1) and Maximum (1 or unbounded) properties

• Automatic correction: None

Attribute Checks
PowerDesigner provides default model checks to verify the validity of attributes.

Check Description and Correction

Name/Code con-
tains terms not in
glossary

[if glossary enabled] Names and codes must contain only approved terms drawn
from the glossary.

• Manual correction - Modify the name or code to contain only glossary terms.
• Automatic correction - None.

Name/Code con-
tains synonyms of
glossary terms

[if glossary enabled] Names and codes must not contain synonyms of glossary
terms.

• Manual correction - Modify the name or code to contain only glossary terms.
• Automatic correction - Replaces synonyms with their associated glossary

terms.

Name/Code
uniqueness

Object names must be unique in the namespace.

• Manual correction - Modify the duplicate name or code.
• Automatic correction - Appends a number to the duplicate name or code.
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Check Description and Correction

Undefined refer-
ence

An attribute without a name or a code must have a reference.

• Manual correction: In the attribute property sheet, define a reference with the
Reference list or the Browse tool

• Automatic correction: None

Undefined type You must define a data type for an attribute.

• Manual correction: In the attribute property sheet, define a data type with the
Type list or the Browse tool

• Automatic correction: None

Notation Checks
PowerDesigner provides default model checks to verify the validity of notations.

Check Description and Correction

Name/Code con-
tains terms not in
glossary

[if glossary enabled] Names and codes must contain only approved terms drawn
from the glossary.

• Manual correction - Modify the name or code to contain only glossary terms.
• Automatic correction - None.

Name/Code con-
tains synonyms of
glossary terms

[if glossary enabled] Names and codes must not contain synonyms of glossary
terms.

• Manual correction - Modify the name or code to contain only glossary terms.
• Automatic correction - Replaces synonyms with their associated glossary

terms.

Name/Code
uniqueness

Object names must be unique in the namespace.

• Manual correction - Modify the duplicate name or code.
• Automatic correction - Appends a number to the duplicate name or code.

Undefined nota-
tion

A notation must have at least one URI defined for Public or System properties.

• Manual correction: In the notation property sheet, define a URI in the Public
or System boxes

• Automatic correction: None
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Attribute Group Checks
PowerDesigner provides default model checks to verify the validity of attribute groups.

Check Description and Correction

Name/Code con-
tains terms not in
glossary

[if glossary enabled] Names and codes must contain only approved terms drawn
from the glossary.

• Manual correction - Modify the name or code to contain only glossary terms.
• Automatic correction - None.

Name/Code con-
tains synonyms of
glossary terms

[if glossary enabled] Names and codes must not contain synonyms of glossary
terms.

• Manual correction - Modify the name or code to contain only glossary terms.
• Automatic correction - Replaces synonyms with their associated glossary

terms.

Name/Code
uniqueness

Object names must be unique in the namespace.

• Manual correction - Modify the duplicate name or code.
• Automatic correction - Appends a number to the duplicate name or code.

Undefined refer-
ence

An attribute group without a name or a code must have a reference.

• Manual correction: In the attribute group property sheet, define a reference
with the Reference list or the Browse tool

• Automatic correction: None

Existence of at-
tributes

An attribute group must contain at least one attribute.

• Manual correction: Add attributes to attribute group or delete attribute group
• Automatic correction: Deletes unassigned attribute group

Import Checks
PowerDesigner provides default model checks to verify the validity of imports.

Check Description and Correction

Undefined sche-
ma location and
namespace

An import must have at least a schema location or a namespace defined.

• Manual correction: In the import property sheet, define a URI for the schema
location and/or the namespace.

• Automatic correction: None
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Redefine Checks
PowerDesigner provides default model checks to verify the validity of redefines.

Check Description and Correction

Undefined sche-
ma location

You must define a schema location for a redefine.

• Manual correction: In the redefine property sheet, define a URI or select a
schema file for the schema location. For example: customers.xsd

• Automatic correction: None

Existence of com-
ponent

A redefine must contain at least one of the following items: simple type, complex
type, group or attribute group.

• Manual correction: Add items to the redefine
• Automatic correction: None

Key Checks
PowerDesigner provides default model checks to verify the validity of keys.

Check Description and Correction

Name/Code con-
tains terms not in
glossary

[if glossary enabled] Names and codes must contain only approved terms drawn
from the glossary.

• Manual correction - Modify the name or code to contain only glossary terms.
• Automatic correction - None.

Name/Code con-
tains synonyms of
glossary terms

[if glossary enabled] Names and codes must not contain synonyms of glossary
terms.

• Manual correction - Modify the name or code to contain only glossary terms.
• Automatic correction - Replaces synonyms with their associated glossary

terms.

Name/Code
uniqueness

Object names must be unique in the namespace.

• Manual correction - Modify the duplicate name or code.
• Automatic correction - Appends a number to the duplicate name or code.
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Check Description and Correction

Existence of
fields

A key must contain at least one field.

• Manual correction: Add at least one field to the key or delete the key. For
example: @numEmployee

• Automatic correction: Deletes unassigned key

For more information on fields, see Specifying Constraint Fields on page 46.

Undefined selec-
tor

You must define an XPath expression for a key selector attribute.

• Manual correction: In the key property sheet, define an XPath expression for
the selector attribute. For example: s:company/s:employee

• Automatic correction: None

For more information on XPath expressions, see Specifying a Constraint Selector
on page 46.

KeyRef Checks
PowerDesigner provides default model checks to verify the validity of KeyRefs.

Check Description and Correction

Name/Code con-
tains terms not in
glossary

[if glossary enabled] Names and codes must contain only approved terms drawn
from the glossary.

• Manual correction - Modify the name or code to contain only glossary terms.
• Automatic correction - None.

Name/Code con-
tains synonyms of
glossary terms

[if glossary enabled] Names and codes must not contain synonyms of glossary
terms.

• Manual correction - Modify the name or code to contain only glossary terms.
• Automatic correction - Replaces synonyms with their associated glossary

terms.

Name/Code
uniqueness

Object names must be unique in the namespace.

• Manual correction - Modify the duplicate name or code.
• Automatic correction - Appends a number to the duplicate name or code.

Undefined refer-
ence

A keyRef must contain a reference to a key or a unique constraint.

• Manual correction: In the keyRef property sheet, define a reference to a key
or a unique constraint with the Reference list.

• Automatic correction: None
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Check Description and Correction

Existence of
fields

A keyRef must contain at least one field.

• Manual correction: Add at least one field to the keyRef or delete the keyRef.
For example: @numEmployee.

• Automatic correction: Deletes unassigned keyRef.

For more information on fields, see Specifying Constraint Fields on page 46.

Undefined selec-
tor

You must define an XPath expression for a keyRef selector attribute.

• Manual correction: In the keyRef property sheet, define an XPath expression
for the selector attribute. For example: s:company/s:employee.

• Automatic correction: None

For more information on XPath expressions, see Specifying a Constraint Selector
on page 46.

Unique Checks
PowerDesigner provides default model checks to verify the validity of uniques.

Check Description and Correction

Name/Code con-
tains terms not in
glossary

[if glossary enabled] Names and codes must contain only approved terms drawn
from the glossary.

• Manual correction - Modify the name or code to contain only glossary terms.
• Automatic correction - None.

Name/Code con-
tains synonyms of
glossary terms

[if glossary enabled] Names and codes must not contain synonyms of glossary
terms.

• Manual correction - Modify the name or code to contain only glossary terms.
• Automatic correction - Replaces synonyms with their associated glossary

terms.

Name/Code
uniqueness

Object names must be unique in the namespace.

• Manual correction - Modify the duplicate name or code.
• Automatic correction - Appends a number to the duplicate name or code.

Existence of
fields

A unique constraint must contain at least one field.

• Manual correction: Add at least one field to the unique constraint or delete the
unique constraint. For example: @numEmployee.

• Automatic correction: Deletes unassigned unique constraint.

For more information on fields, see Specifying Constraint Fields on page 46.
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Check Description and Correction

Undefined Selec-
tor

You must define an XPath expression for a unique constraint selector attribute.

• Manual correction: In the unique constraint property sheet, define an XPath
expression for the unique constraint selector attribute. For example: s:com-
pany/s:employee.

• Automatic correction: None

For more information on XPath expressions, see Specifying a Constraint Selector
on page 46.

Extension Checks
PowerDesigner provides default model checks to verify the validity of extensions.

Check Description and Correction

Undefined base type You must define a base type when you derive a complex type by ex-
tension.

• Manual correction: In the complex type property sheet, click the
Properties tool beside the Derivation box to display the Extension
property sheet and select a base type with the Base type list or the
Browse tool

• Automatic correction: None

Restriction Checks
PowerDesigner provides default model checks to verify the validity of restrictions.

Check Description and Correction

Undefined base type You must define a base type when you derive a simple or a complex type
by restriction.

• Manual correction: In the simple or complex type property sheet,
click the Properties tool beside the Derivation box to display the
Extension property sheet and select a base type with the Base type
list or the Browse tool

• Automatic correction: None
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Check Description and Correction

Existence of facet A simple type restriction must have at least one facet defined. Facets are
defined in the Detail, Enumerations and Patterns tabs of a simple type
restriction property sheet.

• Manual correction: Define one or more facets in the simple type
restriction property sheet

• Automatic correction: None

Simple Type List Checks
PowerDesigner provides default model checks to verify the validity of simple types.

Check Description and Correction

Undefined base type You must define a base type when you derive a simple type by list.

• Manual correction: In the simple type property sheet, click the
Properties tool beside the Derivation box to display the simple
type list property sheet and select a data type with the Type list or
the Browse tool

• Automatic correction: None

Simple Type Union Checks
PowerDesigner provides default model checks to verify the validity of simple type unions.

Check Description and Correction

Undefined base type You must define at least two data types when you derive a simple type by
union.

• Manual correction: In the simple type property sheet, click the Prop-
erties tool beside the Derivation box to display the simple type union
property sheet and type a white space separated list of at least two data
types (qualified names) in the Member types box

• Automatic correction: None
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Annotation Checks
PowerDesigner provides default model checks to verify the validity of annotations.

Check Description and Correction

Existence of items An annotation must contain at least one URI for a Documentation or an
Application Information.

• Manual correction: Define a URI for a Documentation or an Appli-
cation Information

• Automatic correction: None
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CHAPTER 5 Working with XML and
Databases

Many relational databases now support XML so that you can store or retrieve data through
XML files. You can use an XML model to generate an annotated schema that will allow you to
store or retrieve data in such a database.

The following databases are available :

Database Mapped XML
model

Targeted XML lan-
guage

Required XEM
file

Microsoft SQL Server
2000 and higher

Yes XSD or XDR Microsoft SQL Server

Oracle 9i2 and higher No XSD Oracle 9i2

IBM DB2 v8.1 and
higher

Yes DTD IBM DB2 DAD

By attaching the SQL/XML extensions to an XML model mapped to a PDM, you can also
generate SQL/XML queries to retrieve data in an XML format, from relational databases
supporting SQL/XML.

Note: You can also generate PDM tables from an XML schema. For more information, see 
Generating Other Models from an XSM on page 81.

Mapping Database Objects to an XML Schema Via the XML
Builder Wizard

You can create an XSM to generate an annotated schema from a PDM via the XML Builder.

1. Open a PDM targeted with the appropriate DBMS, and select Tools > XML Builder
Wizard to open the XML Builder Wizard.

2. Specify whether to create a new XML model or work with an existing model, and then
click Next to go to the Tables and Views Selection page.

3. Select the tables and views from which you want to generate the schema, and then click
Next to go to the XML Hierarchy Design page.

4. Build your hierarchy by dragging and dropping tables and/or columns from the left pane to
the right pane or by using the tools above the panes:
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For detailed information about using the wizard, see Data Modeling > Working with Data
Models > Generating Other Models from a Data Model > Generating Other Models from a
PDM > Generating an XSM from a PDM via the XML Builder Wizard.

5. Click Finish to generate the XML model:

In the case of an existing XML model, the generated elements appear alongside the
existing elements.

Note: The SQL/XML extension file is automatically attached to the generated XML
model. You can optionally attach the XML Document extension file to generate a
simplified XML file that will help you understand the annotated schema (see Extending
your Modeling Environment on page 12).
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Generating an SQL/XML Query File
SQL/XML is an XML extension of the Structured Query Language, which allows you to
retrieve relational data using extended SQL syntax, and produce an XML result. You can
generate SQL/XML queries for global elements in your XSM, whatever the targeted XML
language (XSD, DTD or XDR).

SQL/XML has five main elements:

• XMLELEMENT - to edit an element with a name, a list of attributes (optional) and a list of
values (optional)

• XMLATTRIBUTES - to edit a list of attributes with names and values
• XMLAGG - to edit in multiple rows a concatenation of elements, from a single XML value

corresponding to a single column
• XMLCONCAT - to edit in the same row a concatenation of elements, from several XML

values corresponding to several columns
• XMLFOREST - to edit in the same row a concatenation of elements, from several SQL

values corresponding to several columns. The name and value of a column become the
name and value of an element

You can generate an SQL/XML query file from an XSM if you have attached the SQL/XML
extension file. These extensions are automatically linked to your XSM if you have created it
from a PDM via the XML Builder Wizard (see Mapping Database Objects to an XML Schema
Via the XML Builder Wizard on page 101). If need be, you can still modify the mapping
through the Mapping tab of elements and complex types property sheets.

To manually enable the SQL/XML extensions in your model, select Model > Extensions,
click the Import tool, select the SQL/XML file (on the General Purpose tab), and click OK to
attach it.

Warning! The following procedure assumes you have an XML model open in the workspace
and mapped to a PDM. Generated SQL/XML queries cannot be parameterized.

1. Select Tools > Generate SQL/XML Queries to open the Generation dialog box.

2. Specify the directory in which to generate the file.

3. Click the Selection tab and specify which of the global elements you want to generate
queries from. A separate file will be generated for each global element selected.

4. Click OK to begin the generation.

The Result dialog box is displayed with the path of the query file selected.

5. Click Edit to open the generated query file in your associated editor:
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Generating an Annotated Schema for Microsoft SQL Server
Microsoft SQL Server is an XML-enabled database server, which supports annotations that
can be used on XSD or XDR files, to map XML data to relational data.

An annotated schema is an XML file that allows you to store or retrieve data in an XML
format, from relational databases supporting XML. An XML model allows you to generate an
annotated schema (XSD or XDR) for SQL Server 2000.

1. Map an XSM to a PDM. You can do this manually or by generating an XSM from a PDM
(or a PDM from an XSM) but we recommend that you use the XML Builder Wizard (see
Mapping Database Objects to an XML Schema via the XML Builder Wizard on page
101)

2. [if you do not use the wizard] Attach the Microsoft SQL Server extension file. To enable
these extensions in your model, select Model > Extensions, click the Import tool, select
the Microsoft SQL Server file (on the XML in Database tab), and click OK to
attach it.

3. [optional] Reinforce the mappings of elements and attributes to tables and columns with
extended attributes:

Note: If the element and attribute names match the table and column names, you do not
need to define extended attributes for XML objects.

Annota-
tion

Description

encode When an XML element or attribute is mapped to a SQL Server BLOB column,
allows requesting a reference (URI) to be returned and used later to return BLOB
data.

Available for: Element, Attribute

field Maps an XML item to a database column.

Available for: Element, Attribute

hide Hides the element or attribute specified in the schema in the resulting XML
document.

Available for: Element, Attribute
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Annota-
tion

Description

is-constant Creates an XML element that does not map to any table. The element is displayed
in the query output.

Available for: Element

key-fields Allows specification of columns that uniquely identify the rows in a table.

Available for: Element

limit-field Allows limiting the values that are returned on the basis of a limiting value.

Available for: Element, Attribute

limit-value Allows limiting the values that are returned on the basis of a limiting value.

Available for: Element, Attribute

mapped Allows schema items to be excluded from the result.

Available for: Element, Attribute

max-depth Allows you to specify depth in recursive relationships that are specified in the
schema.

Available for: Element

overflow-
field

Identifies the database column that contains the overflow data.

Available for: Element

relation Maps an XML item to a database table.

Available for: Element

relationship-
child

Specifies an element as the child table in a reference (To define only in the child
element property sheet).

Available for: Element

relationship-
child-key

Specifies an attribute as the foreign key of a child table in a reference (To define
only in the child element property sheet).

Available for: Element

relationship-
parent

Specifies an element as the parent table in a reference (To define only in the child
element property sheet).

Available for: Element

relationship-
parent-key

Specifies an attribute as the primary key of a parent table in a reference (To define
only in the child element property sheet).

Available for: Element
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Annota-
tion

Description

use-cdata Allows specifying CDATA sections to be used for certain elements in the XML
document.

Available for: Element

prefix Creates valid XML ID, IDREF, and IDREFS. Prepends the values of ID, IDREF,
and IDREFS with a string.

Available for: Attribute

4. [optional] Click the Preview tab of the model property sheet, to preview the annotated
schema.

5. Generate the annotated schema (see Generating the SQL Server Annotated Schema File
on page 106).

Generating the SQL Server Annotated Schema File
You generate the annotated schema file by selecting it as an additional target for standard
schema generation.

1. Select Language > Generate  schemaFile to open the Generation dialog box.

2. Specify the directory in which to generate the file and select the XML in Database target on
the Targets tab.
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3. Click OK to begin the generation.

The Result dialog box is displayed with the path of the annotated schema file selected.

4. Click Edit to open the generated annotated schema in your associated editor:

Note the SQL namespace (with the sql prefix) and the SQL annotations for tables
(sql:relation), columns (sql:field) and reference (sql:relationship).

Generating an Annotated Schema for Oracle 9i2
Oracle 9i2 is a database server with a native XML storage and retrieval technology called
Oracle XML DB. There is no mapping between XML data and relational data. Tables,
columns and abstract data types (ADT) are created from annotated schemas (XSDs).
Annotated schemas are XML-coded files, targeted with an XML language and tagged with
specific DBMS annotations, that allow you to store or retrieve data in an XML format, from
relational databases supporting XML.

An XML model allows you to generate an annotated schema (XSD) for Oracle 9i2. Oracle 9i2
uses by default the name of the XML elements present in the annotated schema to generate
SQL objects. You can override the creation of SQL objects by defining extended attributes for
elements, complex types and the XML model.

To enable these extensions in your model, select Model > Extensions, click the Import tool,
select the Oracle XML DB (on the XML in Database tab), and click OK to attach it.
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Oracle Extended Attributes for Elements and Attributes
You can set extended attributes on various XSM objects to define mappings with an Oracle
database.

Element Extended Attributes
The following annotations can be specified on the Extended Attributes tab of the property
sheets of elements:

Annotation Description

beanClassname Can be used within element declarations. If the element is based on a global
complexType, this name must be identical to the beanClassname value
within the complexType declaration. If a name is specified by the user, the
bean generation will generate a bean class with this name, instead of gen-
erating a name from the element name

columnProps Specifies the column storage clause that is inserted into the default CREATE
TABLE statement. It is useful mainly for elements that are mapped to tables,
namely top-level element declarations and out-of-line element declarations

defaultTable Specifies the name of the table into which XML instances of this schema
should be stored. This is most useful in cases when the XML is being inserted
from APIs where table name is not specified (for example, FTP and HTTP)

javaClassname Used to specify the name of a Java class that is derived from the corre-
sponding bean class, to ensure that an object of this class is instantiated
during bean access. If a JavaClassname is not specified, Oracle XML DB will
instantiate an object of the bean class directly

maintainDOM If true, instances of this element are stored so that they retain DOM fidelity on
output. This implies that all comments, processing instructions, namespace
declarations, and so on, are retained in addition to the ordering of elements. If
false, the output need not be guaranteed to have the same DOM behavior as
the input

maintainOrder If true, the collection is mapped to a VARRAY. If false, the collection is
mapped to a NESTED TABLE

SQLCollSchema Name of the database user owning the type specified by SQLCollType

SQLCollType Specifies the name of the SQL collection type corresponding to this XML
element that has maxOccurs > 1

SQLInline If true this element is stored inline as an embedded attribute (or a collection if
maxOccurs > 1). If false, a REF (or collection of REFs if maxOccurs > 1) is
stored. This attribute will be forced to false in certain situations (like cyclic
references) where SQL will not support inlining
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Annotation Description

SQLName Specifies the name of the attribute within the SQL object that maps to this
XML element

SQLSchema Name of the database user owning the type specified by SQLType

SQLType Specifies the name of the SQL type corresponding to this XML element
declaration

tableProps Specifies the TABLE storage clause that is appended to the default CREATE
TABLE statement. This is meaningful mainly for global and out-of-line
elements

Complex Type Extended Attributes
The following annotations can be specified on the Extended Attributes tab of the property
sheets of complex types:

Annotation Description

beanClassname Can be used within element declarations. If the element is based on a global
complexType, this name must be identical to the beanClassname value
within the complexType declaration. If a name is specified by the user, the
bean generation will generate a bean class with this name, instead of gen-
erating a name from the element name

SQLSchema Name of the database user owning the type specified by SQLType

SQLType Specifies the name of the SQL type corresponding to this XML element
declaration

Model Extended Attributes
The following annotations can be specified on the Extended Attributes tab of the property
sheet of the model:

Annotation Description

mapUnboundedStringToLob If true, unbounded strings are mapped to CLOB by default.
Similarly, unbounded binary data get mapped to BLOB, by
default. If false, unbounded strings are mapped to VAR-
CHAR2(4000), and unbounded binary components are map-
ped to RAW(2000)

storeVarrayAsTable If true, the VARRAY is stored as a table (OCT). If false, the
VARRAY is stored in a LOB
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Generating the Oracle Annotated Schema File
You generate the annotated schema file by selecting it as an additional target for standard
schema generation.

1. Select Language > Générate schema File to open the Generation dialog box.

2. Specify the directory in which to generate the file and select the XML in Database target on
the Targets tab.

3. Click OK to begin the generation.

The Result dialog box is displayed with the path of the annotated schema file selected.

4. Click Edit to open the generated annotated schema in your associated editor:
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Note the Oracle namespace (with the sql prefix) and annotations for tables
(sql:SQLName) and ADTs (sql:SQLType)

Generating a DAD File for IBM DB2
IBM DB2 v8.1 (or higher) is a database server with an add-in for XML storage and retrieval
called IBM DB2 Extender. XML data (elements, attributes) are mapped to relational data
(tables, columns) through Document Access Definition files (.DAD).

There are three types of DAD files:

Storage Type Description

Xcolumn Column mapping - the Root element is mapped to a table, and its attributes or
child elements are mapped to columns identified by an XPath

Xcollection SQL mapping - the DAD file starts with a SQL statement for the table mapped to
the Root element, and each child element or attribute is mapped to a column or a
table name

Xcollection RDB mapping - a Relational Database node, with a table and a column name, is
associated with each attribute or child element of the Root element

An XML model targeted with DTD allows you to generate DAD files for IBM DB2.

1. Map an XSM to a PDM. You can do this manually or by generating an XSM from a PDM
(or a PDM from an XSM) but we recommend that you use the XML Builder Wizard (see
Mapping database objects to an XML schema via the XML Builder Wizard on page
101)

2. [if you do not use the wizard] Attach the IBM DB2 DAD extension file. To enable these
extensions in your model, select Model > Extensions, click the Import tool, select the
IBM DB2 DAD file (on the XML in Database tab), and click OK to attach it..

3. Further specify the mappings with extended attributes (see DB2 Extended Attributes for
Global Elements on page 112).

4. [optional] Click the Preview tab of the Root element property sheet, and select the
DB2XMLExtender.DAD File tab to preview the DAD file. If the DAD File tab is not
available, click the Select Generation Targets tool to select IBM DB2 DAD in the
Targets list and click OK.

5. Generate the annotated schema (see Generating a DB2 DAD file on page 112).
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DB2 Extended Attributes for Global Elements
You can set extended attributes on global elements to reinforce their mapping to tables and
columns, by opening their property sheets and clicking the Extended Attributes tab.

Extended attribute Description

Database Name of the database

DTDID ID added to the DTD_ref system table in DB2 XML Extender

Login Name of the logged-in user

MappingType Type of mapping for a collection

NamespaceNode Text zone where each line describes a namespace couple (name =
value). The separator character is '='

Password Password of the logged-in user

PathGeneration Generation path

ProcessInstruction A text zone that enables the user to enter some instruction

SideTableID Identifier of the side table (optional)

SideTableName Name of the side table

StorageName If StorageType is Xcolumn, then it is the name of the sidetable column

StorageType Type of storage (Xcollection or Xcolumn)

Generating a DB2 DAD File
You generate the DAD file by selecting it as an additional target for standard schema
generation.

1. Select Language > Generate  schemaFile to open the Generation dialog box.

2. Specify the directory in which to generate the file and select the XML in Database target on
the Targets tab.
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3. [optional] Click the Options tab, and set any appropriate generation options:

Option Description

Character ending an in-
struction

Character ending instructions in the SQL file for stored procedures

Generates procedures de-
ployment

Generation of a SQL script for stored procedures enabling XML data
storage and facilitating XML data retrieval

Path of DAD.dtd Path of the DTD file installed with IBM DB2 Extender and describing
the specific syntax of DAD files

Schema validation Validation tag in the DAD files to check the conformity of DAD files
with the DAD syntax

4. Click OK to begin the generation.

The Result dialog box is displayed with the path of the generated DAD, DTD and SQL
files.

5. Click Edit to open the generated DAD file in your associated editor:

• Extract of a DAD file defined with Xcollection as StorageType, and RDB as
MappingType:
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• DAD file defined with Xcolumn as StorageType:
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