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1 Gateway Management Cockpit

Gateway Management Cockpit is the central Ul for all administration tasks for Integration Gateway.

You can use Gateway Management Cockpit to:

® Manage destinations
® Manage service registrations
e Troubleshoot

This guide walks you through all the activities that can be performed on Gateway Management Cockpit. See
Integration Gateway PDF for information on enabling content as OData services: http://help.sap.com/mobile-
platform/.

Starting Gateway Management Cockpit

To start Gateway Management Cockpit, enter https://host _name:https_admin port/gateway/cockpit
in any supported browser. Log in using the administrator user name and password.

Creating a Security Profile at the Namespace Level

The security profile defines how the SAP Mobile Platform server authenticates the user during onboarding, and
request-response interactions. To prevent unauthorized individuals from accessing and reading the data, create
the security profile at the namespace level.
1 Note
Creating and assigning security profiles at the namespace level is optional. The first and the default security
configuration for any OData service is the one that is configured for the mobile application where the OData
service is consumed.

You can get the namspace of registered OData services from the Gateway Management Cockpit.

SAP Gateway Management Cockpit

SERVICES DESTINATIONS TROUBLESHOOTING

Registered Services

Register a New Senvice | Activate/Deactivate | Delste

]

Senvice Name Namespace Description Version Activation Status Default Destination Senvice Type Senvice Document
sap cusToM Open Senice Document
IWBEP BEP Open Senice Document
sap CUSTOM Open Senice Document
BEP Open Senvice Document

sap cusTom Open Senice Document

CSRRCSRN SRR SRR SRR

1
1
1
IWBEP 1
1
1

sap CUSTOM Open Senice Document

1 Note

The case-sensitive name of the security profile should match the namespace of the OData service.
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See Configuring Security Profiles at http://help.sap.com/mobile-platformiF* SAP Mobile Platform 3.0
Administrator # Application Administrator # Managing and Monitoring Applications # Managing Security

Profiles
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2 Creating a Destination on Gateway
Management Cockpit

Create destinations for the services to point to the datasource from which the data is fetched.

Log in to Gateway Management Cockpit.

2. Onthe DESTINATIONS tab, click Create a New Destination....
Enter the information that is appropriate to the type of datsource you want to connect to:
JDBC:

Field Description

<Destination Name> Enter the name for the destination.
<Destination Type> Select DATABASE.
<Destination URL> Enter the destination URL of the JDBC datasource

you are connecting to. For example,
jdbc:hsgldb:mem:com. sap.sample.

<Database Driver> Enter the JDBC driver that enables the processor to
connect to the database. For example,
org.hsqldb. jdbcDriver.

<Authentication Type> Select one of:

o No Authentication; if no authentication is
required to access the JDBC datasource.

o Basic Authentication; if user name and password
is required for to access the JDBC datasource.

<User Name> If you selected Basic Authentication type, enter the
user name to access the JDBC datasource.

<Password> Enter the password to access the JDBC datasource.
HTTP:

<Destination Name> Enter a name for the destination.

<Destination Type> Select HTTP.

<Destination URL> Enter the destination URL of the datasource you are

connecting to.

<Authentication Type> Select one of:

o No Authentication; if no authentication is
required to access the datsource.

o Basic Authentication; if a user name and
password is required to access the datasource.
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|
Field Description

o Client Certificate ; if client certificate is enabled
on the datasource.

o CSl Authentication ; if the outgoing call to the
destination will use the same authentication
mechanism as the incoming request to SAP
Mobile Platform.

<User Name> If you selected Basic Authentication type, enter the
user name to access the SAP system.

<Password> Enter the password to access the SAP system.

<TrustStore File> If you selected Client Certificate, enter the name of
the truststore file (which contains certificates from
external parties, or from certificate authorities that
are trusted to identify other parties); not the file

location.
<TrustStore Password> Enter the password to access the truststore file.
<KeyStore File> If you selected Client Certificate, enter the name of

the keystore file (which is a repository of public and
private keys, along with a corresponding certificate
alias used in authentication).

<KeyStore Password> Enter the password to access the keystore file.
JPA:

<Destination Name> Enter a name for the destination.
<Destination Type> Select JPA.

<Persistence Unit> Enter the name of the JPA persistence unit as

defined in the persistence.xml file (created in the
META-INF directory).

<Authentication Type> Select one of:

o No Authentication; if no authentication is
required to access the JPA datasource.

o Basic Authentication; if a user name and
password is required to access the JPA
datasource.

<User Name> If you selected Basic Authentication type, enter the
user name to access the JPA datasource.

<Password> Enter the password to access the JPA datasource.

4. Save the settings.

CUSTOMER Gateway Management Cockpit
6 © 2013 SAP AG or an SAP affiliate company. All rights reserved. Creating a Destination on Gateway Management Cockpit



3 Assighing and Removing Destinations

To access the service document URL of the registered service in the Gateway Management Cockpit, assign
destinations to them . Multiple destinations can be assigned for a service or entity sets. Before you assign
destinations to a service, make sure the service is registered.

1 Note

Assign destinations to either a service or entity sets but not both. To assign destinations to entity sets, remove
any existing destinations assigned for the service and vice versa.

1. Toassign destinations for the service:

a) Loginto Gateway Management Cockpit.
b) Onthe SERVICES tab, under Registered Services, click the service for which you want to assign a
destination.

SAP Gateway Management Cockpit

SERVICES DESTINATIONS TROUBLESHOOTING

Registered Services

Register a New Service || ActivatelDeactivate | | Delete &
Service Name Namespace Description Version Activation Status Defaut Destination Senvice Type Senice Document
l@nmsawme s3p ESPH RefSenvice for demo 1 ESPlIDest cusTON On: ce Document
sap 1 v cusTom Open Senice Document
sap 1 JPAREF cusTon
1

v cusTOM Open Senice Document

c) Onthe service overview screen, click Assign Destinations for the Service.
d) Click Add Destination.

SERVICE OVERVIEW
. RS SERVICE DETAILS SERVICE ACCESS
H Inactive
H
Senvice Description| ESPM Ref Senvice for demo Service Document
hitp: Jetewaylodataisap/EspmSenvicev=1
Version | 1
ABOUT Senice Type CUSTOM
Registerad By: Admin Service Namespace  sap
Registered On: 4(10/2013 Model 1D
Last Updated By: smpAdmin Model Provider
Last Updated On: 41102013 Data Provider

) Assign Destinations forthe Senvice Assign Destinations for EntitySats

Atatime destinations can either be assigned at Service level or EntitySets level;
Remaove existing destinations to change the level of assignment

| Add Destination || Remove Destination | | Setas Default

Destination .. Default

No data

e) Choose the destination from the list and click OK. The assigned destination appears in the
DESTINATIONS section.

f)  Select the assigned destination and click Set as Default.
2. To assign destinations for entity sets:
a) Loginto Gateway Management Cockpit.

b) Onthe SERVICES tab, under Registered Services, click the service for which you want to assign a
destination.

c) Onthe service overview screen, click Assign Destinations for EntitySets.
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d) Click Add Destination.

e) Enter the name of the entity set.

f)  Choose the destination from the list and click OK.

To remove assigned destinations:

a) Loginto Gateway Management Cockpit.

b) Onthe SERVICES tab, under Registered Services, click the service from which to remove the destinations.
c) Onthe service overview screen, under DESTINATIONS, select the destination, click Remove Destination.

CUSTOMER Gateway Management Cockpit
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4 Activating and Deactivating a Service

To activate or deactivate a registered service in Gateway Management Cockpit:

1. Loginto Gateway Management Cockpit.
2. Onthe Registered Services screen, choose the service to be activated or deactivated.
3. Click Activate/Deactivate.
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5 Registering an SAP Service on Gateway

Management Cockpit

You can use Gateway Management Cockpit to register SAP services.

1 Note

Deploy the 1w _BEP component to enable SAP back-end to consume OData services. See SAP note 1816779"%

1. Tocreate a destination for the SAP service:

a) Loginto Gateway Management Cockpit.

b) Onthe DESTINATIONS tab, click Create a New Destination....
c) Enter the following in the Create a New Destination screen.

Field Description

<Destination Name>

Enter a name for the destination. For example,
Test.

<Destination Type>

Select HTTP.

<Destination URL>

Enter the URL of the SAP back-end system
where service implementations are located.

The generic URLishttps://
<hostname>:<port>/sap/iwbep?sap-
client=<client number>

where hostname, port and client number are
system dependent.

To get the destination URL:

1. Loginto SAP back-end system.

2. Intransaction s1CF, choose Execute (F8) to
display the service tree hierarchy.

3. Expand the default host and navigate to the
node IWBEP (|> default_host > sap >
iwbep 1).

4. Inthe context menu of the iwbep node,
choose Test Service, click Allow. The URL in

the address bar of the browser is the
destination URL.

<Authentication Type>

CUSTOMER
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Select one of:

o No Authentication; if no authentication is
required to access the SAP system.

o Basic Authentication; if a user name and
password is required to access the SAP
system.

Gateway Management Cockpit
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|
Field Description

o Client Certificate ; if client certificate is
enabled on the SAP system.

o CSl Authentication ; if the outgoing call to
the destination will use the same
authentication mechanism as the incoming
request to SAP Mobile Platform.

d) Choose Save.
2. Toregister and activate an SAP service:
a) Loginto Gateway Management Cockpit.
b) Onthe SERVICES tab, click Register a New Service....
c) Choose a destination from the Select a Destination list.
d) Enter the service name, or a key word in the Search field to search for SAP services.
e) Select the service you want to register and click Register.
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Troubleshooting in Gateway Management

Cockpit

The Troubleshooting tab provides access to monitoring and error data.

The example below, which uses TEA_TEST APPLICATION service, explains how to use Gateway Management
Cockpit for troubleshooting.

1 Note

If you cannot analyze or solve the error, create a message in the Customer Service System (CSS) and append
the error log.

To get the back-end error information, register ERROR_LOG_SRV service in the Gateway Management Cockpit.

1. Skip to step 2 if you already have an error, otherwise, to simulate an error:

a)
b)

In Gateway Management Cockpit, create a destination.
Register the TEA_TEST APPLICATION service.

1 Note

To register services successfully, and to receive back-end error information, you must assign the
correct destination for the services you register. See Creating a Destination on Gateway Management
Cockpit [page 5]

2. Totroubleshoot:

a)
b)

9)
d)
e)
f)
g)

Open the service document of the TEA_TEST APPLICATION service.

Navigate to the ErrorCases and enter an URL for a single error case to simulate an exception. For
example, /odata/IWBEP/TEA TEST APPLICATION;;v=1/ErrorCases('BUSI')

On the Troubleshooting tab, choose Select Logs.

Click a Time stamp field to open the error details.

Choose the DETAILS tab for an overview of the error details.

Select the STACKTRACE tab for the Java error stacktrace.

Choose the BACKEND ERROR LOG tab for the error log information of the back-end system. If there is no
error in the back-end but only in the Java stack, BACKEND ERROR LOG is not displayed.

To see the error content information, select a LOGHEADER row.

Copy the Transaction ID.

Log in to your back-end system and use transaction /IWBEP/ERROR_LOG to open the back-end error log.
Filter for the copied Transaction ID.

Double-click the Transaction ID to display the Error Context section.

m) Click Call Stack to display the Call Stack screen.

12

From the Call Stack screen, you can navigate to the source code and set a breakpoint to see what went
wrong.
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