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Installing the Adapter

Install the Sybase® Aleri Adapter for Replication Server® software on the Sybase Aleri
Streaming Platform and Replication Server workstations.

Two files are included in the Sybase Aleri Adapter for Replication Server package:

AleriAdapterForRepserver-v2.0.0_RSAdapter-
Config

Contains the software for installation on the Syb-
ase Aleri Streaming Platform workstation

AleriAdapterForRepserver-v2.0.0_RepServer-
Config

Contains the software for installation on the Syb-
ase Replication Server workstation

The files for Windows machines have a .zip extension. The files for UNIX/Linux machines
have a .tgz extension.

1. Obtain the Sybase Aleri Adapter for Replication Server package for your operating
system. Go to the Sybase SPDC site and download it or order a CD.

The available packages are:

LINUX_AleriAdapterForRepServer-v2.0.0.tgz

Solx86_AleriAdapterForRepServer-v2.0.0.tgz

SPARC_AleriAdapterForRepServer-v2.0.0.tgz

Windows_AleriAdapterForRepServer-v2.0.0.zip

2. If you download the package, extract the contents of the zip file using Winzip (on
Windows) or gunzip (on Linux or Solaris).

3. Copy the AleriAdapterForRepserver-v2.0.0_RepServerConfig zip file
to the Sybase Replication Server workstation.

4. Go to the Sybase Aleri Streaming Platform workstation.

5. Start the Aleri Studio and click Help > About Aleri Studio to verify the version of the
Sybase Aleri Streaming Platform.
The Configuration Details screen should show version 3.2.1 and, more importantly, the
JAR file name should be com.aleri.vizualizer_3.2.1_b28192.jar to show
that EBF28192 has been applied.

6. Verify that JDK 1.6 is installed.

7. Verify that the PLATFORM_HOME and JAVA_HOME environment variables are set to
the locations where the Sybase Aleri Streaming Platform and JDK respectively are
installed.

8. Stop the Aleri Studio.
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9. Extract the AleriAdapterForRepserver-v2.0.0_RSAdapterConfig zip
file into the PLATFORM_HOME folder.

10. Verify that the following files have been extracted to the PLATFORM_HOME/lib folder:

aarsLogging.properties

AleriAdapterForRepServer.jar

jTDS3.jar

11. Verify that the following file has been extracted to the PLATFORM_HOME/lib/
connections folder:

AleriAdapterForRepServer.cnxml

12. Go to the Replication Server workstation.

13. Check the Replication Server log's startup messages to verify that Sybase Replication
Server 15.6 or 15.2 is installed.

14. Extract the AleriAdapterForRepserver-v2.0.0_RepServerConfig zip
file into a temporary directory.

The following files are extracted:

aars_funcstrings.sql

aars_errors.sql

aars_rs_errors.sql

15. Apply these scripts to the Replication Server.

a) isql -Usa -SSAMPLE_RS -P -i aars_funcstrings.sql

b) isql -Usa -SSAMPLE_RS -P -i aars_errors.sql

c) isql -Usa -SSAMPLE_RS -P -i aars_rs_errors.sql
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Configuring the Adapter On The Replication
Server Workstation

Set up the RepServer Adapter, schema and source location on the Replication Server
workstation.

1. Set up the replication system according to the Replication Server documentation.

2. Using the Sybase dsedit utility, add an entry to the interfaces (sql.ini) file with the
name of the Sybase Aleri Streaming Platform workstation name and the port used for the
RS Adapter connection. This entry will be used to specify the RSadapter data server
name and TDS Port in the RS Adapter configuration process. See the Sybase
documentation for more information on modifying the interface or sql.ini files. For
example, if the adapter and the Sybase Aleri Streaming Platform are on a workstation
named sierra and the connection is to be made on port 5100,
[RSadapter]
query=TCP,sierra,5100

3. If you haven't already done so, define the user name and password.
create user rsuser
set password rspassword
go

4. Create the connection from the replication server to the adapter. Use the same server name
you used in the previous step here (and later for the RS Adapter configuration). Log in to
the replication server to create the RS Adapter connection. For example,
create connection to RSadapter.RSadapter
set error class to aars_error_class
set function string class aars_function_class
set username rsuser
set password rspassword
set batch to “off”
with dsi_suspended
go
alter connection to RSadapter.RSadapter
set replication server error class to aars_rs_error_class
go

To turn off minimal columns,
alter connection to RSadapter.RSadapter
set replicate_minimal_columns to 'off'
go

Note: Minimal columns should also not be used in the repdef.

To enable batching,
alter connection to RSadapter.RSadapter
 set batch to 'on'
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alter connection to RSadapter.RSadapter
 set dsi_cmd_separator to ';'
go

The user name and password used for this connection must be defined within the
replication server. This user name must not be the same as that of the Adapter admin user.

5. Create the replication definitions. A replication definition specifies the schema and the
source location for a given table or stored procedure. Log into the replication server to
create the sample TEST replication definition.
For example, for a source table ‘TEST’ (create table TEST (ID int, FNAME
char(15)) that has been defined on a sourcedb database located on an ASE server
named ASEHOST.
create replication definition TESTrep
with primary at ASEHOST.sourcedb
with all tables named ‘TEST’
(ID int, FNAME char(15))
primary key (ID)
go

6. Mark the ASE source ‘TEST’ table for replication. Log in to the ASE server and locate the
source table ‘TEST’ and execute the following command:
sp_setreptable ‘TEST’, true
go

7. Define the subscriptions. Each subscription defines a target for the data changes coming
through the replication server. In the following example, the target is the RSadapter
connection for the RS Adapter located on the Sybase Aleri Streaming Platform
workstation. Log in to the replication server to create the sample TEST subscription:
create subscription TESTsub
for TESTrep
with replicate at RSadapter.RSadapter
without materialization
go
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Configuring the Adapter On A Sybase Aleri
Streaming Platform Workstation

Set up the RepServer Adapter, data model and data location on the Sybase Aleri Streaming
Platform workstation.

1. Start the Aleri Studio (to finish the configuration process using this interface):

Options Description

On Windows Click Start > All Programs > Aleri > AleriStudio

On UNIX/Linux Enter $PLATFORM_HOME/bin/sp_studio

2. Define a new data model (for example TESTmodel) using the Visual Editor. From within
the Aleri Studio, select File > New File > Data Modeling Using Visual Editor.

3. Define a Data Location for the RS Adapter.

a) Select the Data Location Explorer tab from the left pane of the data model (it looks like
a database cylinder).

b) Right click on the new Data Model folder (TESTmodel).
c) Select Create Data Location. The Edit Parameters panel is displayed.
d) Optionally, provide a data location Name.
e) Select the “…” button for the “Type” field. The “Select Connection” panel is

displayed.
f) Locate and select the “Replication Server Input Connector” from the connection Type

list.
g) Select the “Basic” tab and configure the data location parameters used to connect to the

RSSD and obtain metadata on tables and stored procedures as follows:

Parameter Description

RSSD host Specify the host name or IP address of the
RSSD server.

RSSD port Specify the port to use on the server containing
the RSSD database.

RSSD database name Specify the name of the RSSD database created
by the replication server to store replication in-
formation.
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Parameter Description

RSSD user name Specify the user name used to connect to the
RSSD server during Discovery. This user must
have permissions to run the RSSD Stored Pro-
cedures.

RSSD password Specify the password for the RSSD user.

RSadapter data server name Specify the data server name and database
name used to define the replication server con-
nection that points to the RS Adapter within the
Sybase Aleri Streaming Platform. This server
name is also used to define an entry in the rep-
lication server’s interfaces (sql.ini) file. This
value should be used for both the “data server”
and “database name” portions of the replication
server connection definition.

4. Select the “Advanced” tab and configure the data location parameters for runtime
processing and internal communications as follows:

Parameter Description

Stored proc stream operation Specify whether an insert or upsert operation is
performed with stored procedure replication.
Defaults to insert.

TDS Port Specify the port used by the Adapter. This is the
port to which the replication server connection
definition must connect. This port is defined
within the interfaces (sql.ini) file on the
replication server workstation to define con-
nectivity between the replication server and the
Adapter.

Adapter admin user Specify a user name for the Adapter to use for
internal communications. This user can be any-
thing except it must not match the user defined
within the replication server connection defini-
tion.

Adapter admin password Specify a password associated with the user
name the Adapter uses for internal communi-
cations.

Hot spare host Specify the backup host if using a high availa-
bility HA configuration.

Hot spare port Specify the port to use on the backup host if
using an HA configuration.

Configuring the Adapter On A Sybase Aleri Streaming Platform Workstation
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Parameter Description

Transactional Stream Operations Specify whether or not Aleri data changes are in
an Aleri transaction. Because this causes
changes to be committed to a log store imme-
diately after the transaction, this parameter
should be set to true when using a log store for a
persistent rs_lastcommit.

Batched stream operations Specify whether or not the RS Adapter sends
data to the Sybase Aleri Streaming Platform in
batches.

Batch size If the Batched Stream Operations parameter is
set to true, specify the number of rows in the
batch.

Publish when batch is full If set to true, the Adapter writes data to the
stream when the batch reaches Batch size. If set
to false, the Adapter waits for a commit to write
data to the stream.

Error on Missing Stream Column Set to true to send an error back to the replica-
tion server if a column in the repdef is not de-
fined within the stream. Setting this parameter
to false (to avoid frequent disconnections from
the replication server) is recommended.

5. Select OK to save the Data Location configuration.

6. Discover the source tables/procedures. The Discovery process establishes a connection to
the replication server RSSD database and reveals defined subscriptions that target the RS
Adapter. These subscriptions may include both tables and stored procedures.

a) Right click on the RSAdapter data location from the Data Location Explorer tab and
run Data Discovery. This will return a list of tables or stored procedures that have RS
Adapter subscriptions associated with them. It also returns the rs_lastcommit table.

b) Drag discovered “tables” to the visual panel on the right to create the source streams
and columns.

c) Define Primary Keys. Each table/stored procedure stream must contain at least one
primary key. It is recommended that this key match the primary key defined in the
replication definition. Locate the appropriate primary key column and click on the
toggle key to the left of it. The toggle key will change to an image of a key.

Discovery adds a special column named ‘ra_pkey’ to the stream definition for a stored
procedure. The ‘ra_pkey’ column must be set as the primary key and ‘Autogen’ set to
true for stored procedures.

d) Select File > Save to save the changes.

7. Test data movement to the Aleri stream. Use the Aleri Studio for the following steps unless
otherwise noted.

Configuring the Adapter On A Sybase Aleri Streaming Platform Workstation

Users Guide 7



a) Open the data model within the Aleri Studio.
b) Go to the Run-Test tab.
c) Click on the green Run arrow to start the model. A successful startup displays a

message similar to the following on the console.

Stream TEST is ready for RepServer connections.
d) Log in to the replication server and resume the RS Adapter connection as shown in the

example below:
resume connection to RSadapter.RSadapter
go

e) Insert sample data into the source table.
f) Verify the replicated data reaches the Aleri RS Adapter stream using the Aleri Studio

Streamviewer.

Configuring the Adapter On A Sybase Aleri Streaming Platform Workstation
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Defining a Persistent rs_lastcommit

By default, the rs_lastcommit table is non-persistent: it is held in memory and cleared when
the stream is shut down. This results in a full replay of all remaining items within the
replication server when the stream is restarted. We recommend making rs_lastcommit
persistent to minimize the replay of transactions following a stream restart.

1. Add a log store to the model.

a) Open the Palette tab of the model and expand Shared Components.
b) Select the Log Store component to add it to the model.
c) Set the Kind parameter to "log".
d) Set the File parameter to "rs_lastcommit".

2. Add rs_lastcommit to the model.

a) Open the Data Location Explorer tab.
b) Drag the rs_lastcommit table from the Data Discovery view into the model workspace.
c) Set the "origin" column as the primary key.

3. Configure rs_lastcommit to use the persistent log store.

a) Open the pop-up list for the store parameter.
b) Select the Log Store you just added to the model.

Defining a Persistent rs_lastcommit
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Performance Tips

Modify the system configuration to improve performance.

• Configure the Replication Server to use batches (terminator must be a semicolon).
• Configure the Replication Server to use larger packets: 4096 is probably a reasonable

setting.
• Run on a 64-bit machine.
• Set all log levels to info or lower in the aarslogging.properties file.

Performance Tips
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Supported Datatypes

Map ASE/Replication Server datatypes to Aleri datatypes.

Aleri Datatype ASE/Replication Server Datatypes

int32 smallint, tinyint, int, bit

timestamp datetime, time

date date, smalldatetime

int64 bigint, unsigned bigint, unsigned int, unsigned smallint

string binary, char, unichar, nchar, nvarchar, varbinary, univarchar, varchar, time-
stamp

double numeric, float, real

money money, smallmoney

Supported Datatypes
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