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About Sybase Control Center for Data
Assurance

Sybase® Control Center for Data Assurance (DA) is a Web-based tool for managing and
monitoring the DA server environment.

Sybase Control Center for Data Assurance provides availability, historical, and real-time
monitoring in a scalable Web application that is integrated with management modules for
other Sybase products. It offers shared, consolidated management of heterogenous resources
from any location, real-time notification of availability and performance, and intelligent tools
for spotting performance and usage trends, all via a thin-client, rich Internet application
delivered through your Web browser.

Sybase Control Center for Data Assurance supports data comparison from a primary database
to one or more replicate databases. The product also supports task scheduling, which allows
each comparison task to be run based on a schedule you have specified. It uses and deploys its
own SQL Anywhere database, which stores system and configuration settings, tasks, and task
history. An automatic reconciliation option identifies missing, orphaned, and inconsistent
rows when you create DA jobs.

You can monitor servers and agents using the DA monitor, topology view, heat chart, and
administration console. History reports for comparison tasks and statistics help you monitor
data discrepancies and identify common or recurring problems.

Sybase Control Center for Data Assurance is designed to be integrated with Replication
Server® to support comparison of large tables. When you use a Sybase Control Center wizard
to create a DA job based on a Replication Server system database (RSSD), the wizard is
populated automatically with replication definition and subscription information so you can
easily create a job with an optimal configuration.

About Sybase Control Center for Data Assurance
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New Features in Sybase Control Center for Data Assurance
A brief description for each new and enhanced feature, and links to associated topics.

Table 1. New and Enhanced Sybase Control Center for Data Assurance
Features

Feature Topics

Heterogeneous comparison – perform row and sche-
ma comparisons on these new supported databases:

• Oracle
• Sybase IQ
• HANA DB

Creating a Database Connection on page
107

See the Heterogeneous Comparison in the
Replication Server Data Assurance Option
Users Guide.

Data partitions – set partitions as part of job compar-
ison options for improved performance.

Creating a Row Comparison Job on page
114

Comparison and Column Options on page
116

Viewing Data Partition Boundaries on page
113

See the Data Partitions and Data Partition
Commands in the Replication Server Data
Assurance Option Users Guide.

Adaptive Server SSL configuration options – enter
JDBC properties to support SSL connections to Adap-
tive Server.

Creating a Database Connection on page
107

See the Adaptive Server and DA JDBC Com-
munication Using SSL in the Replication
Server Data Assurance Option Users Guide.

Trace levels – set the logging and audit trace levels for
a Data Assurance server.

Setting Logging and Audit Levels for Data
Assurance Servers on page 159

Column name case-sensitive compare – in the com-
pareset creation wizard, when a column name com-
parison happens between the primary and the target
databases, a case-sensitive match is performed by de-
fault. If a match is not found the comparison process is
performed again with a case-insensitive match.

-

AGENT_HASH as default – if all the database types
in a compareset are Adaptive Server, then the default
hash type is DATABASE_HASH, otherwise it is
AGENT_HASH.

See the Database Hash and Default Column
Compare Modes  in the Replication Server
Data Assurance Option Users Guide.

About Sybase Control Center for Data Assurance
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Feature Topics

Reconcile scripts – view three reconcile scripts for
insert, update, and delete statements.

-

Find a resource in the Administration Console – use
new search and filter tools to locate objects of interest.

Searching and Filtering Resources on page
131

User Interface Overview
This illustration labels important elements of the Sybase Control Center user interface so you
can identify them when they appear in other help topics.

Figure 1: Sybase Control Center User Interface

Toolbar Icons
Describes the icons in the Sybase Control Center toolbar for launching and managing views.

Table 2. Toolbar Icons

Icon Name Description

Show/Hide Perspective Resources
View

Displays or minimizes the Perspective Resour-
ces view, which lists registered resources in this
perspective.

About Sybase Control Center for Data Assurance
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Icon Name Description

Launch Resource Explorer Opens the resource explorer, which lists reach-
able resources (both registered and unregis-
tered).

Launch Heat Chart Opens the perspective heat chart, which gives a
status overview of the registered resources in
this perspective.

Close All Open Views Closes all open and minimized views.

Minimize All Open Views Minimizes all open views.

Restore All Minimized Views Returns all minimized views to their original
size.

Cascade All Open Views Arranges open views to overlap each other.

Tile All Open Views Vertically Arranges open views in a vertical manner.

Tile All Open Views Horizontally Arranges open views in a horizontal manner.

Status Icons
Sybase Control Center uses icons to indicate the status of resources and key performance
indicators (KPIs).

Resource Status Icons in the Perspective Resources View and Heat Chart
Resource status icons indicate the condition of each resource in the heat chart. In addition, they
are used as badges (small overlays) on server icons in both the heat chart and the Perspective
Resources view. The Perspective Resources view also has a Status column that displays the
same status as the badge in English text.

In the heat chart, hover the mouse over an icon in the Status column to display the status in
English text.

Table 3. Resource Status Icons

Icon Status Description

Running Resource is up and running

About Sybase Control Center for Data Assurance
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Icon Status Description

Pending State is changing—check again

Stopped Resource has been shut down

Warning Resource has encountered a potentially harmful situation

Error Resource has encountered a serious problem

Unknown Resource is unreachable—state cannot be determined

KPI Status Icons in the Heat Chart
The heat chart uses KPI status icons to indicate the health of the KPIs it displays.

Hover the mouse over a KPI icon in any column to the right of the Status column to display the
value of that KPI.

Table 4. KPI Status Icons

Icon Status Description

Normal Value of performance indicator is within the normal range

Warning Value of performance indicator is in the warning range

Critical Value of performance indicator is in the critical range

Common Display Options
Use data display features to view resource status and to sort, search by resource name and type,
and rearrange status information.

Column Options
The Perspective Resources view, Resource Explorer, Administration Console, Alert Monitor,
heat chart, and other views in Sybase Control Center—including those in product modules
—use a tabular grid format to display information about managed resources. You can use
options provided by the grid format to sort and organize displayed data.

About Sybase Control Center for Data Assurance
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Table 5. Column Sorting Options

Sorting Option Description

Simple column-based sorting Click a column name to sort the table based on that column in
ascending or descending order. The arrow in the column’s sorting
tab (to the right of the column name) points up when data is sorted
in ascending order or down when data is sorted in descending
order.

Reversing the order of a column-
based sort

Click a column’s sorting tab to reverse its sort from ascending to
descending order or vice versa.

Nested sorting based on multiple
columns

Click the column name for the primary sort. For subsidiary sorts,
click the column’s sorting tab. Choose the columns for subsidiary
sorts in the order you want to apply them. After you click a sorting
tab, it displays its sorting level (1 for the primary sort, 2 for the
secondary sort, and so on).

Rearranging columns Move columns by dragging and dropping them.

The figure below shows a table of servers sorted first by resource type; within type by software
version; and within version by server name. The Type and Name columns sort in ascending
order and the Version column sorts in descending order.

Figure 2: Resources sorted by type, version, and name

About Sybase Control Center for Data Assurance
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Filter by Column
The Administration Console provides a filtering field at the top of each column. Enter a
filtering term to narrow the range of objects displayed. For example:

• Enter the name of a resource at the top of the Name column to display only that server,
database, group, or other named object. The display reacts as you enter each character, so
you might not need to enter the entire name.

• Enter a version number at the top of the Version column to display only resources running
that software version.

You can filter on multiple columns; for example, in a listing of servers, use the Status column
to display only running servers, then use the Version column to display servers using the
desired software version. Delete the filtering terms to return to the original display. Filtering
terms are not case sensitive.

Full Screen Mode
To increase the screen area available in Sybase Control Center for views and perspectives,

click the  icon at the upper-right corner of the perspective area. Click the icon again to return
to the original screen configuration.

Tip: To increase the screen area available to SCC, press F11 to switch Internet Explorer or
Firefox to full screen mode. Press F11 again to return to the original browser configuration.

Maximize a Section of a View

Some areas within views have a square minimize/maximize icon ( ) in the upper-right
corner. Click the icon to expand that area to fill the entire view. Click the icon again to restore
the area to its former size.

View Menu
The Perspective Resources view, the Resource Explorer, the Alert Monitor, and the heat chart
each have a View menu. From the View menu, you can:

• Display the filtering tool for searches. (In the heat chart, the Filter option also displays the
column selection tool.)

• Toggle between an icon view and a detail view of your resources (Perspective Resources
view only)

• Refresh the display (Resource Explorer only)

Note: For these tasks, use the View menu in the view window, not the application-level View
menu at the top of the SCC window.

About Sybase Control Center for Data Assurance

Sybase Control Center for Data Assurance 7



Keyboard Shortcuts
Frequently used key sequences for the Sybase Control Center Web interface.

Key Sequence Action

Ctrl-Alt-F12 Pull down the first menu in the topmost view or in the SCC menu bar.
Repeat to toggle between the two first menus.

Ctrl-Alt-Shift-F12 Pull down the first menu (Application) in the SCC menu bar.

Space Select the highlighted option—equivalent to clicking the mouse.

Escape • Release a drop-down menu

• Exit an editable cell or field

• Close a window

Arrow keys • Highlight the next list item or menu option in the indicated di-
rection. For example, the down arrow highlights the next item
down in a menu; the right arrow highlights an item in the menu to
the right.

• In a tree hierarchy, the right arrow expands a node; the left arrow
collapses it.

Tab • In a view, highlight the next item in the tab order. (Tab order
progresses through the accessible fields in a left-to-right, top-to-
bottom fashion, starting at the upper left.)

• In a two-pane view, jump from the tree hierarchy in the left pane
to the right pane.

• In a view that includes a table or grid display, press Tab twice to
highlight the table, then press the down-arrow to enter it.

Shift-Tab • In a view, highlight the previous item in the tab order.

• In a two-pane view, jump from the right pane back to the tree
hierarchy in the left pane.

Home Highlight the first item in the active view (or the active section of a
view), for example the first row in a table.

End Highlight the last item in the active view (or the active section of a
view), for example the last row in a table.

About Sybase Control Center for Data Assurance
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Key Sequence Action

In the SCC menu bar, View >
Select > <your view>

Select an open view and bring it to the front.

Ctrl-Alt Arrow key Move the selected view in the indicated direction.

Ctrl-Alt + Increase the size of displayed text.

Ctrl-Alt - Decrease the size of displayed text.

F11 Enable or disable the browser’s full-screen mode.

In the SCC menu bar, Appli-
cation > Display > Full
Screen

Enable or disable Sybase Control Center’s full-screen mode.

Sybase Control Center is built on Adobe Flex. For complete information about Adobe Flex
keyboard shortcuts, see http://livedocs.adobe.com/flex/3/html/help.html?
content=accessible_5.html.

Displaying the Versions of SCC Components
View a list of components installed in Sybase Control Center and their versions.

Check the versions of the product modules in your SCC installation to determine whether your
installation is up to date. SCC release bulletins list supported product module versions. You
can find SCC release bulletins on the Product Documentation web site at http://
sybooks.sybase.com/sybooks/sybooks.xhtml?prodID=10680

1. Log in to SCC and select Help  > About Sybase Control Center.

2. Compare the versions of product modules (listed as management agent plug-ins) against
the versions published in the most recent Sybase Control Center Release Bulletin.

About Sybase Control Center for Data Assurance
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Style and Syntax Conventions
A reference to the fonts and special characters used to express command syntax and to
represent elements of system output and user input.

Table 6. Style Conventions

Key Definition

monospaced(fixed-
width)

• SQL and program code

• Commands to be entered exactly as shown

• File names

• Directory names

italic monospaced In SQL or program code snippets, placeholders for user-specified
values (see example below).

italic • File and variable names

• Cross-references to other topics or documents

• In text, placeholders for user-specified values (see example be-
low)

• Glossary terms in text

bold sans serif • Command, function, stored procedure, utility, class, and meth-
od names

• Glossary entries (in the Glossary)

• Menu option paths

• In numbered task or procedure steps, user-interface (UI) ele-
ments that you click, such as buttons, check boxes, icons, and so
on

A placeholder represents a system- or environment-specific value that you supply. For
example:
installation directory\start.bat

where installation directory is where the application is installed.

About Sybase Control Center for Data Assurance
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Table 7. Syntax Conventions

Key Definition

{ } Curly braces indicate that you must choose at least one of the enclosed options. Do
not type the braces when you enter the command.

[ ] Brackets mean that choosing one or more of the enclosed options is optional. Do
not type the brackets when you enter the command.

( ) Parentheses are to be typed as part of the command.

| The vertical bar means you can select only one of the options shown.

, The comma means you can choose as many of the options shown as you like,
separating your choices with commas that you type as part of the command.

... An ellipsis (three dots) means you may repeat the last unit as many times as you
need. Do not include ellipses in the command.

Accessibility Features
Accessibility ensures access to electronic information for all users, including those with
disabilities.

Documentation for Sybase products is available in an HTML version that is designed for
accessibility.

Vision impaired users can navigate through the online document with an adaptive technology
such as a screen reader, or view it with a screen enlarger.

Sybase HTML documentation has been tested for compliance with accessibility requirements
of Section 508 of the U.S Rehabilitation Act. Documents that comply with Section 508
generally also meet non-U.S. accessibility guidelines, such as the World Wide Web
Consortium (W3C) guidelines for Web sites.

Note: You may need to configure your accessibility tool for optimal use. Some screen readers
pronounce text based on its case; for example, they pronounce ALL UPPERCASE TEXT as
initials, and MixedCase Text as words. You might find it helpful to configure your tool to
announce syntax conventions. Consult the documentation for your tool.

For information about how Sybase supports accessibility, see the Sybase Accessibility site: 
http://www.sybase.com/products/accessibility. The site includes links to information about
Section 508 and W3C standards.

You may find additional information about accessibility features in the product
documentation.

About Sybase Control Center for Data Assurance
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Sybase Control Center Accessibility Information
Sybase Control Center uses the Adobe Flex application.

For the most current information about Adobe Flex keyboard shortcuts, see http://
livedocs.adobe.com/flex/3/html/help.html?content=accessible_5.html.

Note: To use Sybase Control Center effectively with versions of JAWS for Windows screen
reading software before version 11, download and install the appropriate Adobe scripts. See
http://www.adobe.com/accessibility/products/flex/jaws.html.

About Sybase Control Center for Data Assurance
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Get Started

Set up Sybase® Control Center.

Quick Start for an Evaluation
(Optional) Get started using Sybase Control Center quickly if you do not need the full set of
security features. This simplified process is suitable for a small-scale, temporary evaluation or
proof-of-concept project, or for checking your installation.

Prerequisites
Install Sybase Control Center.

Task

Use these tasks to start Sybase Control Center, log in, register and authenticate a server, and
monitor that server.

Note: After completing the tasks below and confirming that SCC is working, set up SCC for a
production environment if you intend to continue using it.

1. Registering the ODBC Driver in Windows

In Windows, run scc.bat with administrative privileges to register the ODBC driver.

2. Launching Sybase Control Center

Use the scc command to start Sybase Control Center.

3. Getting Started After Installing

Perform postinstallation testing and configuration.

4. Registering a Data Assurance Server

Register a resource (for example, a server that can be monitored) to make Sybase Control
Center aware of it and its connection information.

5. Authenticating a Login Account for a Managed Resource

Specify the login account and password Sybase Control Center will use when it connects
to your server or agent to collect monitoring data or manage the resource.

6. Displaying Resource Availability: the Heat Chart

Use the heat chart to view the status and availability of servers in the current perspective.

7. Viewing Data Assurance Server and Agent Status

The Data Assurance (DA) monitor shows high-level server and agent information.

Get Started
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See also
• Get Started in a Production Environment on page 19

Registering the ODBC Driver in Windows
In Windows, run scc.bat with administrative privileges to register the ODBC driver.

When Sybase Control Center starts for the first time on a Windows machine, it registers its
ODBC driver. Because the automatic registration of the ODBC driver edits the registry
settings, you must execute scc.bat using elevated administrative privileges. If you launch for
the first time without adequate privileges, Sybase Control Center generates an error and fails
to start.

In Windows Vista, Windows 2008, and Windows 7, you must use the Run as administrator
setting to launch Sybase Control Center even if you already have administrative privileges.
This process is described below.

In other versions of Windows, you must be logged in as an administrator to start Sybase
Control Center for the first time. You need not follow the steps below.

1. In Windows Vista, Windows 2008, or Windows 7, open the Command Prompt window
with administrative privileges:

• Select Start > All Programs > Accessories. Right-click Command Prompt and
select Run as administrator.

• Alternatively, enter cmd in the Start Menu search box and press Shift+Ctrl+Enter.

2. Run scc.bat.

Launching Sybase Control Center
Use the scc command to start Sybase Control Center.

Prerequisites

Install Adobe Flash Player in the browser you will use for Sybase Control Center.

Task

1. Start Sybase Control Center.

• Windows – navigate to <install_location>\SCC-3_2\bin and double-
click scc.bat.

• UNIX – execute scc.sh.

Messages on the progress of the launch appear in a command window. When Sybase
Control Center is running, the command window becomes the Sybase Control Center
console; you can issue commands to get status information on SCC and its ports, plug-ins,
and services.

Get Started
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2. Open a Web browser and enter https://<hostname>:8283/scc.

Getting Started After Installing
Perform postinstallation testing and configuration.

Prerequisites
Start Sybase Control Center.

Task

1. Install Adobe Flash Player 10.1 or later in the Web browser you will use to connect to
Sybase Control Center.

Flash Player is a free plug-in. You can download the latest version from http://
get.adobe.com/flashplayer/.

If Flash Player is already installed but you are not sure which version you have, go to the
Adobe test site at http://adobe.com/shockwave/welcome. Click the link that says Test
your Adobe Flash Player installation. The version information box on the next page that
appears displays your Flash Player version.

2. To connect to Sybase Control Center, direct your browser to:

https://<scc_server_hostname>:8283/scc
Note: If you changed the default HTTPS port during installation, use the new port number
instead of 8283.

3. If you see an error about the security certificate, add Sybase Control Center to your
browser’s trusted sites zone (Internet Explorer) or add a security exception (Firefox).

4. Log in.

Sybase Control Center provides a default login account, sccadmin, for initial
configuration and setting up permanent authentication. The password is set during
installation.

Note: The sccadmin account and the preconfigured user login module on which it is based
are not intended for use in a production environment. Sybase recommends that you pass
authentication responsibility to your operating system or to LDAP, as described in the
Sybase Control Center > Get Started > Setting Up Security section of the online help.

Sybase further recommends that you disable sccadmin as soon as you have set up and
tested authentication, and that you change the password on the sccadmin account if you do
not plan to set up and test authentication right away.

5. (Optional) Change the password or disable sccadmin—see the Sybase Control Center
Installation Guide for instructions.

Get Started
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Registering a Data Assurance Server
Register a resource (for example, a server that can be monitored) to make Sybase Control
Center aware of it and its connection information.

1. In the Resource Explorer, select Resources > Register.

2. Specify:

Field Description

Resource Name (Required) Name of the resource to register. Enter the actual
name of the managed server, using uppercase and lowercase
letters. If the name registered in Sybase Control Center does not
exactly match the server name, some monitoring functions, in-
cluding the topology view, do not work.

Resource Type Select a resource type:
• Data Assurance Server – monitor Data Assurance server.

Description A brief description to help you identify the resource.

3. Click Next.

4. Specify the connection information for your resource:

Field Description

Host Name Local host name

Port Number Local host port number

5. (Optional) Enter a user name and password that SCC can use to authenticate with this
resource to retrieve its software version. The credentials are used only for this purpose,
then discarded.

If you prefer not to authenticate now, click I do not want to supply authentication
information.

This step enables SCC to display the correct version information for the server before the
server is formally authenticated (later in the configuration process).

6. Click Next.

7. (Optional) Click Add this resource to the current perspective. You must add a resource
to a perspective (not necessarily the current perspective) before you can manage or
monitor it.

8. (Optional) Click Open the resource explorer to view this new resource. (This option is
not present when the Resource Explorer is open.)

9. Click Finish.

Get Started
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Authenticating a Login Account for a Managed Resource
Specify the login account and password Sybase Control Center will use when it connects to
your server or agent to collect monitoring data or manage the resource.

Perform this task for each resource registered with Sybase Control Center.

Note: You can also authenticate a server during administrative tasks like creating an alert or a
collection job.

1. Connect a browser to Sybase Control Center and log in.

2. If the Perspective Resources view is not open, click the Show/Hide Perspective
Resources View icon in the toolbar.

3. In the Perspective Resources view, select your resource and select Resource >
Authenticate from the view menu.

4. Select Use my current SCC login or Specify different credentials.

5. If you chose Specify different credentials, enter the login and password for Sybase
Control Center to use to connect to your resource.

6. If the selected resource is a Replication Server, also enter the RSSD user name and
password.

7. Click OK to save and exit the dialog.

Displaying Resource Availability: the Heat Chart
Use the heat chart to view the status and availability of servers in the current perspective.

The heat chart displays the state of resources in your perspective—whether the resources are
running, suspended, or down. In addition, the heat chart lists the type of each resource and
provides statistical data, including the start time of the last data collection.

You can filter the resources that you want to see and search and sort the results by column. You
can also select a resource and pull down its context menu to see monitoring and administrative
options that vary based on the resource type.

Heat chart data is collected directly from managed servers, tagged with the date and time when
it was collected, and stored in the Sybase Control Center repository.

1. From the application menu bar, select View > Open > Heat Chart.

2. (Optional) To display information about the status represented by an icon in the chart,
hover the mouse over the icon.

• Status column – icon tooltips describe the status of the resource (Running or Stopped,
for example).

• All columns to the right of Status – icon tooltips give the value of the KPI listed at the
top of the column.

3. (Optional) To display tools for filtering (narrowing the list of resources in the heat chart) or
changing the columns, select View > Filter from the Perspective Heat Chart menu bar.
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The Filter and Column tools appear in the left pane.

4. (Optional) To use filtering, select View > Filter from the view’s menu bar and enter a
search term in the Filter string field.

The search term can be any string that appears in the tabular portion of the heat chart, such
as the name, or part of the name, of a server or a resource type (ASE Server, for example).

5. (Optional) Select a filtering setting:

• Match case – search for resources whose displayed data includes the search term,
including uppercase and lowercase letters; or

• Exact match – search for resources whose displayed data includes an item identical to
the search term.

6. (Optional) Select a column from the Filter on list to restrict your search to that column.

7. (Optional) Click Columns to customize your heat chart.

8. (Optional) Unselect any column that should not appear in your heat chart.

9. (Optional) Click the sorting arrow in the column headers to sort the column values in either
ascending or descending order.

10. (Optional) Click the resource’s row and pull down the menu to the right of the resource
name to view options for the selected resource.

11. (Optional) To resize the Filter and Columns tools pane, move your mouse over the border
between the tools pane and the resource table. When the mouse cursor changes to a resize
icon, click and drag the border to the left or the right.

12. (Optional) To hide the Filter and Columns tools, unselect View > Filter.

Viewing Data Assurance Server and Agent Status
The Data Assurance (DA) monitor shows high-level server and agent information.

Prerequisites

• Register and add the server to be monitored to the Perspective Resources view.
• Authenticate the server.

Task

1. In the Perspective Resources view, select a DA server.

2. Select Resource  > Monitor.

Note: You can also view the server status through the status badges on the server icons in the
Perspective Resources, Heat Chart, Resource Explorer, and topology views.
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Get Started in a Production Environment
Perform a complete setup of Sybase Control Center, including configuration of user
authentication and other one-time set-up tasks.

Prerequisites
Install Sybase Control Center and complete the follow-up tasks described in the Sybase
Control Center Installation Guide.

1. Starting and Stopping Sybase Control Center in Windows
There are several ways to start and stop Sybase Control Center or the SCC agent. You can
start manually, which is useful for testing and troubleshooting, or set the service to start
automatically and to restart in case of failure.

2. Starting and Stopping Sybase Control Center in UNIX
You can start Sybase Control Center or the SCC agent manually, which is useful for testing
and troubleshooting, or you can set up a service to start automatically and to restart in case
of failure.

3. Configuring Memory Usage
(Optional) Determine whether you need to configure how much memory Sybase Control
Center uses, and if so which configuration method to use.

4. Logging in to Sybase Control Center
Enter the Sybase Control Center Web console.

5. Setting Up Security
Configure login authentication and map roles.

6. Configuring the Automatic Logout Timer
(Optional) Set Sybase Control Center to end login sessions when users are inactive for too
long.

7. User Authorization
The authorization mechanism in Sybase Control Center employs login accounts and task-
based roles.

8. Configure
Configure Sybase Control Center for Replication Server Data Assurance Option.

Starting and Stopping Sybase Control Center in Windows
There are several ways to start and stop Sybase Control Center or the SCC agent. You can start
manually, which is useful for testing and troubleshooting, or set the service to start
automatically and to restart in case of failure.

This topic applies to both Sybase Control Center (the server, which includes the management
UI) and the Sybase Control Center agent that runs on each product server managed by SCC.
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When you install SCC and the SCC agent in the same directory by selecting both options in the
installer, you start and stop them together—by executing a single command or controlling a
single service. This topic applies both to singleton installations (which do not use a shared
disk) and to instances of SCC agents and servers running from a shared disk.

If you run Sybase Control Center or the SCC agent manually, you must issue a command every
time you start or shut down. If you run as a service (which is recommended), you can configure
the service to start and restart automatically. These are the options:

• Use the scc.bat command to start Sybase Control Center or the SCC agent manually. The
command gives you access to the Sybase Control Center console, which you can use to
shut down and to display information about services, ports, system properties, and
environment variables. You can also use scc.bat to change the logging level for
troubleshooting purposes. Using scc.bat prevents you from taking advantage of the
automatic start and restart features available to services.

• Use the Services list under the Windows Control Panel to start, stop, and configure the
Sybase Control Center service for an SCC server or agent.

• Use the net start and net stop commands. This is another way to run Sybase Control
Center or the SCC agent as a service.

Note: To start an SCC agent or server as a service:
• In a singleton installation, you must have selected Yes in the installer to install the agent

or server as a service.
• In a shared disk installation, the agent or server must have been deployed using the -

service option of the sccinstance command.

In a singleton installation, the installer lets you start Sybase Control Center or the SCC agent
as a service and configures the service to restart automatically. Before starting, check the
Windows Services list for a Sybase Control Center service.

Here are the steps for each starting and stopping option:

• Start Sybase Control Center, the SCC agent, or both when they are installed
together:

a) (Skip this step for the SCC agent.) If you are starting Sybase Control Center for the first
time in Windows Vista, Windows 2008, or Windows 7, set the Run as Administrator
option on the command prompt so that Sybase Control Center can register its ODBC
driver. (This is necessary even if you are logged in as an administrator.)

b) Enter the scc command.

For a singleton installation:

%SYBASE%\SCC-3_2\bin\scc.bat
 
For an instance:

%SYBASE%\SCC-3_2\bin\scc.bat -instance <instance-name>
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You can omit the -instance option if the instance’s name is the same as its host name
(the default).

• Stop Sybase Control Center, the SCC agent, or both when they are installed together:

a) Enter the scc --stop command.

For a singleton installation:

%SYBASE%\SCC-3_2\bin\scc.bat --stop

For an instance:

%SYBASE%\SCC-3_2\bin\scc.bat --stop -instance <instance-
name>

You can omit the -instance option if the instance’s name is the same as its host name
(the default).

Note: You can also enter shutdown at the scc-console> prompt.

• Start or stop from the Windows Control Panel; configure automatic start and
restart:

a) Open the Windows Control Panel.
b) Select Administrative Tools > Services.
c) Locate “Sybase Control Center” in the Services list. It may be followed by a release

number; if the service is for an instance, it is also followed by the instance name.
Service names do not distinguish between agents and servers. If the service is running,
the Status column displays “Started.”

d) To start or stop the service, right-click the Sybase Control Center entry in the Services
list and choose Start or Stop.

e) To configure automatic starting, double-click the service.
f) To set the service to automatically start when the machine starts, change the Startup

type to Automatic.
g) To restart the service in case of failure, choose the Recovery tab and change the First,

Second, and Subsequent failures to Restart Service.
h) Click Apply to save the modifications and close the dialog.

• Start or stop the Sybase Control Center service (controlling Sybase Control Center,
the SCC agent, or both) from the Windows command line:

a) To start the service, enter the net start command.

For a singleton installation:

net start "sybase control center 3.2.8"
The Sybase Control Center 3.2.8 service is starting......
The Sybase Control Center 3.2.8 service was started 
successfully.
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For an instance, include the instance name (Boston-1 in this example) in parentheses:

net start "sybase control center 3.2.8 (Boston-1)"
The Sybase Control Center 3.2.8 (Boston-1) service is 
starting......
The Sybase Control Center 3.2.8 (Boston-1) service was 
started successfully.

b) To stop the service, enter the net stop command.

For a singleton installation:

net stop "sybase control center 3.2.8"
The Sybase Control Center 3.2.8 service is stopping.....
The Sybase Control Center 3.2.8 service was stopped 
successfully.
For an instance, include the instance name (Boston-1 in this example) in parentheses:

net stop "sybase control center 3.2.8 (Boston-1)"
The Sybase Control Center 3.2.8 (Boston-1) service is 
stopping.....
The Sybase Control Center 3.2.8 (Boston-1) service was 
stopped successfully.

Starting and Stopping Sybase Control Center in UNIX
You can start Sybase Control Center or the SCC agent manually, which is useful for testing and
troubleshooting, or you can set up a service to start automatically and to restart in case of
failure.

This topic applies to both Sybase Control Center (the server, which includes the management
UI) and the Sybase Control Center agent that runs on each product server managed by SCC..
When you install SCC and the SCC agent in the same directory by selecting both options in the
installer, you start and stop them together—by executing a single command or controlling a
single service. This topic applies to both singleton installations (which do not use a shared
disk) and instances of SCC agents and servers running from a shared disk.

If you start Sybase Control Center or the SCC agent manually, you must issue a command
every time you start or shut down. If you run as a service (which is recommended), you can
configure the service to start and restart automatically. These are the options:

• Use the scc.sh script to start Sybase Control Center or the SCC agent manually. You can
either:
• Run scc.sh in the foreground to get access to the Sybase Control Center console,

which you can use to shut down and to display information about services, ports,
system properties, and environment variables.

• Run scc.sh in the background to suppress the console.

Get Started

22



You can use scc.sh to run Sybase Control Center at a nondefault logging level for
troubleshooting. When you start manually with scc.sh, you cannot take advantage of the
automatic start and restart features available to services.

• Use the sccd script to configure a service that starts Sybase Control Center or the SCC
agent automatically.

Here are the steps for each starting and stopping option:

• Before you start Sybase Control Center or the SCC agent for the first time, set
environment variables. Do this only once.

a) Change to the Sybase directory (the parent of the Sybase Control Center installation
directory).

b) Execute one of the following to set environment variables.

Bourne shell:

. SYBASE.sh
C shell:

source SYBASE.csh
• Run Sybase Control Center or the SCC agent (or both, when they are installed

together) in the foreground.

Running in the foreground is a method of manually starting; you must issue commands to
stop and restart Sybase Control Center or the SCC agent.

a) To start Sybase Control Center or the SCC agent and drop into the console when the
start-up sequence is finished, enter the scc command.

For a singleton installation:

$SYBASE/SCC-3_2/bin/scc.sh
For an instance:

$SYBASE/SCC-3_2/bin/scc.sh -instance <instance-name>
You can omit the -instance option if the instance’s name is the same as its host name
(the default).

• Run Sybase Control Center or the SCC agent (or both, when they are installed
together) in the background.

You can use nohup, &, and > to run Sybase Control Center or the SCC agent in the
background, redirect output and system error to a file, and suppress the SCC console.
Running in the background is a method of manually starting; you must issue commands to
stop and restart Sybase Control Center or the SCC agent.

a) Execute a command similar to the sample below that matches your shell. Both sample
commands direct output to the file scc-console.out. If the output file already
exists, you might need to use additional shell operators to append to or truncate the
file.
Bourne shell (sh) or Bash
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For a singleton installation:
nohup ./scc.sh 2>&1 > scc-console.out &

For an instance:
nohup ./scc.sh -instance <instance-name> 2>&1 > scc-console-
your-instance.out &

You can omit the -instance option if the instance’s name is the same as its host name
(the default).

C shell

For a singleton installation:
nohup ./scc.sh >& scc-console.out &

For an instance:
nohup ./scc.sh -instance <instance-name> >& scc-console.out &

You can omit the -instance option if the instance’s name is the same as its host name
(the default).

• Shut down Sybase Control Center or the SCC agent (or both, when they are installed
together) .
a) To shut down from the scc-console> prompt, enter:

shutdown
Warning! Do not enter shutdown at a UNIX prompt; it shuts down the operating
system.

To shut down from the UNIX command line, enter the scc --stop command.

For a singleton installation:

$SYBASE/SCC-3_2/bin/scc.sh --stop
For an instance:

$SYBASE/SCC-3_2/bin/scc.sh --stop -instance <instance-
name>
You can omit the -instance option if the instance’s name is the same as its host name
(the default).

• Configure Sybase Control Center or the SCC agent to run as a service.
A UNIX service is a daemon process that starts automatically after the machine is started
and runs in the background. UNIX installations of Sybase Control Center include a shell
script, sccd, which you can use to configure the Sybase Control Center service. (Some
UNIX platforms supply tools that make service configuration easier; Linux chkconfig is
an example.)

Note: Sybase recommends that if you are not familiar with setting up services in UNIX,
you delegate this task to a system administrator or consult the system administration
documentation for your UNIX platform.
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a) Copy $SYBASE/SCC-3_2/bin/sccd into this directory:

• AIX (SCC agent only): /etc/rc.d/init.d
• HP-UX (SCC agent only): /sbin/init.d
• All other platforms: /etc/init.d

b) Open sccd and make these changes:

• Change the line that sets the SYBASE variable to the location of your Sybase
installation (that is, the parent of SCC-3_2, the Sybase Control Center installation
directory). By default, this directory is called Sybase.

• If you are not using shared-disk mode, or you are using shared-disk mode to run a
single instance whose name is the same as the host name, skip to step 5.c on page
25 or step 5.d on page 25.

• If you are using shared-disk mode to run a single instance whose name is not the
host name, or to run multiple instances on the same host, add the instance name to
the script name. Change:
SCRIPT_NAME=scc.sh

to:
SCRIPT_NAME="scc.sh -instance <instance-name>"

• If you are using shared-disk mode to run multiple instances on the same host,
append the instance name to the name of the ouput log file. Change:
./${SCRIPT_NAME} --start 2>&1 >> ${SCC_HOME}/log/scc-
service.out &

to:
./${SCRIPT_NAME} --start 2>&1 >> ${SCC_HOME}/log/scc-
service_<instance-name>.out &

• If you are using shared-disk mode to run multiple instances on the same host, save a
copy of the sccd script for each instance, giving each copy a unique name. In each
copy, add the instance name to the script name and append the instance name to the
output log file name as described above. Perform the remaining steps in this
procedure for each copy of sccd.

c) In Linux, configure the service to run in run levels 2, 3, 4, and 5:

/usr/sbin/chkconfig --add sccd
/usr/sbin/chkconfig --level 2345 sccd
You can test the sccd script with /usr/sbin/service sccd status. (The
service command accepts these options: start | stop | status | restart.)

d) On non-Linux platforms, locate this directory:

• AIX (SCC agent only): /etc/rc.d/rc<X>.d
• HP-UX (SCC agent only): /sbin/rc<X>.d
• Solaris: /etc/rc<X>.d
where <X> is the run level (for example, 3). Make two soft links in the directory for
your platform and set the links to point to:
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• AIX (SCC agent only):
/etc/rc.d/init.d/sccd: S90sccd and
/etc/rc.d/init.d/sccd: K10sccd

• HP-UX (SCC agent only):
/sbin/init.d/sccd: S90sccd and
/sbin/init.d/sccd: K10sccd

• Solaris:
/etc/init.d/sccd: S90sccd and
/etc/init.d/sccd: K10sccd

The S90sccd link starts the service and the K10sccd link stops the service. The
two-digit numbers in the links indicate the start and stop priorities of the service.

e) Use the S90sccd and K10sccd links to test starting and stopping the service. The
links are called automatically when the machine is started or shut down.

Configuring Memory Usage
(Optional) Determine whether you need to configure how much memory Sybase Control
Center uses, and if so which configuration method to use.

It is not usually necessary to configure memory usage for Sybase Control Center. This table
lists memory options you can set and circumstances under which you should consider
changing them.
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Modify this value When Guidelines

Maximum memory

• jvmopt=-Xmx – if

you are running Sybase
Control Center as a
Windows service

• SCC_MEM_MAX – if
you are running SCC as
a UNIX service

• SCC_MEM_MAX – if
you are starting SCC
from the command line

• You need to prevent Sybase Con-
trol Center from using more than a
given amount of memory

• Sybase Control Center fails to
start and may display an error:
Could not create the
Java Virtual ma-
chine.

• An OutOfMemory error says
Sybase Control Center is out of
heap space

• A warning message about system
memory appears during the start
process

• The machine where Sybase Con-
trol Center is installed has less
than 4GB of memory. (Starting
Sybase Control Center on a ma-
chine with less than 4GB of mem-
ory triggers the startup warning
message about system memory.)

On machines with less than 4GB of
memory, set maximum memory to
256MB or more.

Default value: none. (On machines
with 4GB or more of memory, maxi-
mum memory is set dynamically and
is effectively limited only by the
amount of system memory available.)

Permanent memory

• jvmopt=-
XX:MaxPerm-
Size – if you are run-

ning Sybase Control
Center as a Windows
service

• SCC_MEM_PERM –
if you are running SCC
as a UNIX service

• SCC_MEM_PERM –
if you are starting SCC
from the command line

An OutOfMemory error says Sybase
Control Center is out of permanent
generation space

Increase by 32MB increments. If you
reach a value equal to twice the de-
fault and still see the OutOfMemory
error, contact Sybase technical sup-
port.

Default value: 128MB

You can change memory options in two ways:

• For Sybase Control Center started from the command line – execute commands to set one
or more environment variables before executing the scc command to start Sybase Control
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Center. When you use this method, your changes to the memory options last only as long as
the current login session. This method is useful for testing new option values.

• For the Sybase Control Center service – modify a file used by the Sybase Control Center
service. When you use this method, your changes to the memory options persist—Sybase
Control Center uses them every time it starts as a service.

See also
• Logging in to Sybase Control Center on page 29

Changing a Memory Option on the Command Line
Before you start Sybase Control Center from the command line, you can issue a command to
change the value of a memory option temporarily.

Changes made using this method last only as long as the current login session. This method is
useful for testing new option values.

1. If Sybase Control Center is running, shut it down.

2. Set the environment variable. Specify a size in megabytes but do not indicate the units in
the command.

Windows example:
> set SCC_MEM_MAX=512

UNIX example:
bash$ export SCC_MEM_MAX=512

3. Use the scc command to start Sybase Control Center.

See also
• Changing a Memory Option for a Sybase Control Center Windows Service on page
28
• Changing a Memory Option for an SCC UNIX Service on page 29

Changing a Memory Option for a Sybase Control Center Windows Service
Add a jvmopt command to the scc.properties file to change a memory option (-Xmx or
-XX:MaxPermSize) for a Sybase Control Center Windows service.

When you use this method to set memory options, your changes are permanent—Sybase
Control Center uses them every time it starts as a service.

1. If Sybase Control Center is running, shut it down.

2. Open the Sybase Control Center properties file:
<Sybase Control Center-install-directory>\SCC-3_2\bin
\scc.properties

3. Add (or modify, if it already exists) a jvmopt line specifying the memory size in Java
format. Use m for megabytes or g for gigabytes.
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For example:
jvmopt=-Xmx512m

4. Save the file and start the Sybase Control Center Windows service.

See also
• Changing a Memory Option on the Command Line on page 28

• Changing a Memory Option for an SCC UNIX Service on page 29

Changing a Memory Option for an SCC UNIX Service
To change a memory setting for a Sybase Control Center UNIX service, add the appropriate
environment variable (SCC_MEM_MAX or SCC_MEM_PERM) to the sccd script.

When you use this method to set memory options, your changes are permanent—Sybase
Control Center uses them every time it starts as a service.

1. If Sybase Control Center is running, shut it down.

2. Open the sccd file: /etc/init.d/sccd
3. Add the environment variable at the top of the file (after the comments). Specify a size in

megabytes but do not indicate the units in the command.

For example:
SCC_MEM_MAX=512

4. Save the file and start the Sybase Control Center UNIX service.

See also
• Changing a Memory Option on the Command Line on page 28

• Changing a Memory Option for a Sybase Control Center Windows Service on page 28

Logging in to Sybase Control Center
Enter the Sybase Control Center Web console.

Prerequisites
Install Adobe Flash Player in the browser you will use for SCC. See the Sybase Control Center
Installation Guide.

Task

Sybase Control Center typically authenticates users through the operating system or an LDAP
directory service. Consult your SCC administrator if you are not sure which login account to
use for SCC.

Only one login session per account is permitted at a time; multiple users cannot be logged in to
the same account simultaneously.
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Note: When logging in to a newly installed Sybase Control Center for which secure
authentication has not been configured, use the sccadmin account—the password is set during
installation. For more information, see the Sybase Control Center Installation Guide.

1. Connect to the Sybase Control Center server. In your Web browser, enter: https://
scc-hostname:8283/scc.

2. Enter your user name and password, and click Login.

Tip: If you use a Windows account to log in to SCC, enter your user name in the format
username@domain. Omit top-level domain extensions such as .com or .net—for example,
enter fred@sap, not fred@sap.com.

See also
• Configuring Memory Usage on page 26

Setting Up Security
Configure login authentication and map roles.

Read about security and follow these procedures before you configure Sybase Control Center
product modules.

Note: These security topics are intended for use in a production environment. If you are
evaluating or testing SCC, see Quick Start for an Evaluation on page 13.

1. Security

Sybase Control Center can authenticate user logins through an LDAP server, through the
operating system, or both.

2. Configuring Authentication for Windows

Authentication through the Windows operating system is enabled by default.
Configuration is required only if you have upgraded from an older version of Sybase
Control Center and no longer want to use the older version’s authentication settings; if you
do not want to use Windows for authentication; or if you want to create login accounts
manually. Sybase recommends that you allow SCC to create accounts automatically.

3. Configuring a Pluggable Authentication Module (PAM) for UNIX

Set up Sybase Control Center to support username and password login using accounts on
the UNIX operating system.

4. Configuring an LDAP Authentication Module

Configure an LDAP authentication module for Sybase Control Center by editing the
security configuration file to point to the correct LDAP server.

5. Mapping Sybase Control Center Roles to LDAP or OS Groups

Get Started

30



To grant Sybase Control Center privileges to users who are authenticated through LDAP or
the operating system, associate roles used in Sybase Control Center with groups in LDAP
or the operating system.

6. Encrypting a Password

Use the passencrypt utility to encrypt passwords and other values that must be kept secure
while stored in text files.

7. Configuring Ports

(Optional) Use the scc --port command to assign Sybase Control Center services to new
ports.

See also
• Configuring the Automatic Logout Timer on page 49

Security
Sybase Control Center can authenticate user logins through an LDAP server, through the
operating system, or both.

• Sybase Control Center can be configured to authenticate through any LDAP server that
supports the inetOrgPerson (RFC 2798) schema.

• When Sybase Control Center authenticates through the operating system, it uses the
operating system of the Sybase Control Center server machine (not the client).

Although you can create native user accounts in Sybase Control Center, Sybase does not
recommend this approach to authentication. It is simpler and safer to configure Sybase
Control Center to authenticate using existing LDAP, Windows, or UNIX login accounts.

Sybase strongly recommends that you use a common authentication provider for all Sybase
products, including Sybase Control Center. A common authentication provider ensures that
single sign-on works for users of Sybase Control Center and its managed servers.

Sybase Control Center requires each authenticated login account to have a predefined role.
When a login is authenticated, roles for the login are retrieved by the security module and are
mapped to Sybase Control Center predefined roles. Authorization is resolved through the
mappings between the security module native roles and Sybase Control Center roles. You can
enable mappings by creating a “sybase” group in your operating system or LDAP server and
adding all Sybase Control Center users, or by modifying the Sybase Control Center role-
mapping.xml file to configure the mapping of native roles to Sybase Control Center roles.
The security module authenticates the logins and authorizes access to managed resources.

Sybase Control Center provides a set of predefined login modules for authentication. All login
modules are defined in the <install_location>/SCC-3_2/conf/
csi_config.xml file. The syntax is defined by the Sybase Common Security
Infrastructure (CSI) framework. You can configure the different login modules to customize
security strength. The login modules are:
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• Preconfigured user login – defines a user name, password, and a list of roles. The default
user name is sccadmin; its password is configured during installation and its native role is
SCC Administrator, which maps to sccAdminRole. You can create additional accounts by
adding preconfigured user login modules to csi_config.xml. However, Sybase does
not recommend the use of preconfigured user login modules for authentication in
production environments.

• NT proxy login – delegates authentication to the underlying Windows operating system.
When you log in to Sybase Control Center through an NT Proxy Login module, enter your
user name in the format username@nt-domain-name. For example, user@sybase.
Windows authentication is enabled by default, but it requires some configuration after an
upgrade from SCC 3.2.5 or earlier.

• UNIX proxy login – delegates authentication to the underlying UNIX or Linux operating
system using Pluggable Authentication Modules (PAM). When you log in to Sybase
Control Center through a UNIX PAM, enter your UNIX user name and password. UNIX
authentication is enabled by default, but it requires some configuration.

• LDAP login – delegates authentication to an LDAP server you specify. When you log in to
Sybase Control Center through an LDAP server, enter your LDAP user name and
password. LDAP authentication is not enabled by default; you must configure the login
module.

Configuring Authentication for Windows
Authentication through the Windows operating system is enabled by default. Configuration is
required only if you have upgraded from an older version of Sybase Control Center and no
longer want to use the older version’s authentication settings; if you do not want to use
Windows for authentication; or if you want to create login accounts manually. Sybase
recommends that you allow SCC to create accounts automatically.

This task is optional. However, if you choose not to create Sybase Control Center accounts
automatically, you must enter them manually. Even when SCC users authenticate through
LDAP or the local operating system, SCC needs the accounts for purposes of setting
authorization (user privileges).

1. Log in to Sybase Control Center using an account with administrative privileges. (The
login account or its group must have sccAdminRole.)

2. Select Application > Administration > Security.

3. Click to select or deselect the box labeled Automatically add SCC login records for
authenticated logins.

4. Click to select or deselect the box labeled Automatically grant sccUserRole to newly
created logins.

5. Click OK to close the Security dialog.

Next

There are two next steps:
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• If you opted not to automatically create Sybase Control Center login accounts, enter each
account into Sybase Control Center manually.

• Grant privileges to login accounts that require more than basic user access. You can grant
privileges by assigning Sybase Control Center roles directly to the login accounts, or by
assigning the login accounts to groups and mapping Sybase Control Center roles to the
groups. The group approach is generally more efficient.

Configuring a Pluggable Authentication Module (PAM) for UNIX
Set up Sybase Control Center to support username and password login using accounts on the
UNIX operating system.

1. Using a login account with root privileges, configure the pluggable authentication module
for your platform:

Platform Action

Solaris Append the contents of the <SCC-install-dir>/utility/<su-
nos>/pam.conf file (provided with Sybase Control Center) to the /
etc/pam.conf file on your Solaris platform.

Linux Copy the <SCC-install-dir>/utility/<linux>/sybase-
csi file (provided with Sybase Control Center) to the /etc/pam.d direc-
tory on your Linux platform.

Note: The sybase-csi file provided with Sybase Control Center is not
compatible with the most recent SUSE Linux versions. For SUSE 11 and later,
see the example at the end of this topic.

Note: In the table above, the portion of the path that indicates the operating system might
differ slightly from what is shown.

2. If the host UNIX system is not using a directory lookup for authentication (yp or NIS, for
example) and authentication is carried out against the local /etc/passwd file, change
the permissions on /etc/shadow to provide read access to the login account that
executes SCC.

3. (Skip if you configured a PAM before starting Sybase Control Center) Restart Sybase
Control Center.

4. (Optional) Change account creation options.

a) Log in to Sybase Control Center using an account with administrative privileges
(sccAdminRole).

b) Select Application > Administration > Security.
c) Click to select or deselect the box labeled Automatically add SCC login records for

authenticated logins. (By default, this option is enabled for SCC 3.2.6 and later.)
d) Click to select or deselect the box labeled Automatically grant sccUserRole to newly

created logins. (By default, this option is enabled for SCC 3.2.6 and later.)

Get Started

Sybase Control Center for Data Assurance 33



e) Click OK to close the Security dialog.

Example: PAM for SUSE Linux 11 and later

For SUSE 11 and later, do not use the sybase-csi file provided with Sybase Control
Center. Instead, in your /etc/pam.d directory, create a sybase-csi file that contains:

# sybase-csi PAM Configuration (SUSE style)
auth       include      common-auth
account    include      common-account
password   include      common-password
session    include      common-session

Next

There are two next steps:

• If you opted not to automatically create Sybase Control Center login accounts, enter each
account into Sybase Control Center manually. Sybase Control Center needs the accounts
for purposes of setting authorization (user privileges).

• Grant privileges to login accounts that require more than basic user access. You can grant
privileges by assigning Sybase Control Center roles directly to the login accounts, or by
assigning the login accounts to groups and mapping Sybase Control Center roles to the
groups. The group approach is generally more efficient.

Configuring an LDAP Authentication Module
Configure an LDAP authentication module for Sybase Control Center by editing the security
configuration file to point to the correct LDAP server.

1. Open the <SCC-install-dir>\conf\csi_config.xml file.

2. Uncomment the LDAP module in the configuration file by removing the surrounding
<!-- and --> characters (or, if necessary, add an LDAP module to the file). The sample
module below specifies the LDAP server that will provide user authentication.

The sample module shows the properties used for an OpenDS LDAP server. See the
example at the end of this task for values that work for ActiveDirectory. Configuration
properties you can use in the LDAP module are described in a subtopic.

<authenticationProvider controlFlag="sufficient" 
name="com.sybase.security.ldap.LDAPLoginModule">
    <options name="BindDN" value="cn=Directory Manager"/>
    <options name="BindPassword" value="secret"/>
    <options name="DefaultSearchBase" value="dc=example,dc=com"/>
    <options name="ProviderURL" value="ldap://localhost:10389"/>
    <options name="ServerType" value="openldap"/>
</authenticationProvider>
<provider name="com.sybase.security.ldap.LDAPAttributer" 
type="attributer"/>
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Note: Change only values shown in bold. If BindPassword is encrypted (which Sybase
recommends), the line that defines it must include encrypted="true". The line
should look similar to this:
<options name="BindPassword" encrypted="true" 
value="1snjikfwregfqr43hu5io..."/>

3. Save the file.

4. If your LDAP server’s SSL certificate is signed by a nonstandard certificate authority (for
example, if it is a self-signed certificate), use the keytool utility to configure your JVM or
JDK to trust the certificate. Execute a command similar to this:

Windows:

keytool -import -keystore %SYBASE_JRE7%\lib\security\cacerts -
file <your cert file and path> 
-alias ldapcert -storepass changeit

UNIX:

keytool -import -keystore $SYBASE_JRE7/lib/security/cacerts -file 
<your cert file and path> 
-alias ldapcert -storepass changeit

LDAP Configuration Values for ActiveDirectory

For an ActiveDirectory server, use these values for configuration properties in your LDAP
login module:
 
ServerType: msad2K
DefaultSearchBase: dc=<domainname>,dc=<tld> or o=<company 
name>,c=<country code>
                E.g. dc=sybase,dc=com or o=Sybase,c=us
ProviderUrl: ldaps://<hostname>:<port>
                E.g.:  ldaps://myserver:636
AuthenticationFilter: (&amp;(userPrincipalName={uid}) 
(objectclass=user))
BindDN: <User with read capability for all users>
BindPassword: <Password for BindDN user>
RoleFilter: (|(objectclass=groupofnames) (objectclass=group))
controlFlag: sufficient

Next
Map Sybase Control Center roles to LDAP groups.

See also
• Mapping Sybase Control Center Roles to LDAP or OS Groups on page 44
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LDAP Configuration Properties
Use these properties in your csi_config.xml file to control the Sybase Control Center
LDAP service.

Note: These characters have special meaning when they appear in a name in LDAP: ,
(comma), = (equals), + (plus), < (less than), > (greater than), # (number or hash sign), ;
(semicolon), \ (backslash), / (forward slash), LF (line feed), CR (carriage return), " (double
quotation mark), ' (single quotation mark), * (asterisk), ? (question mark), & (ampersand), and
a space at the beginning or end of a string. LDAP providers do not handle these special
characters in any of the names or DNs in any of the configuration properties. Additionally,
some of the properties, as identified below, cannot use these special characters in common
names.

Property Default Value Description

ServerType None Optional. The type of LDAP server you are con-
necting to:

• sunone5 -- SunOne 5.x OR iPlanet 5.x

• msad2k -- Microsoft Active Directory,

Windows 2000

• nsds4 -- Netscape Directory Server 4.x

• openldap -- OpenLDAP Directory Server

2.x

The value you choose establishes default values
for these other authentication properties:

• RoleFilter

• UserRoleMembership

• RoleMemberAttributes

• AuthenticationFilter

• DigestMD5Authentication

• UseUserAccountControl
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Property Default Value Description

ProviderURL ldap://local-
host:389

The URL used to connect to the LDAP server. Use
the default value if the server is:

• Located on the same machine as your product
that is enabled with the common security in-
frastructure.

• Configured to use the default port (389).

Otherwise, use this syntax for setting the value:

ldap://<hostname>:<port>
DefaultSearchBase None The LDAP search base that is used if no other

search base is specified for authentication, roles,
attribution, and self registration:

1. dc=<domainname>,dc=<tld>
For example, a machine in the sybase.com
domain would have a search base of dc=syb-
ase,dc=com.

2. o=<company name>,c=<coun-
try code>
For example, this might be o=Sybase,c=us for
a machine within the Sybase organization.

Note: When you use this property to authenticate
SCC:

• Do not use special characters, as listed above,
in common names or distinguished names in
the value of this property.

• Do not use Chinese or Japanese characters in
user names or passwords of this property.

SecurityProtocol None The protocol to be used when connecting to the
LDAP server.

To use an encrypted protocol, use ssl instead of

ldaps in the URL.
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Property Default Value Description

AuthenticationMethod Simple The authentication method to use for all authen-
tication requests into LDAP. Legal values are
generally the same as those of the java.naming.se-
curity.authentication JNDI property. Choose one
of:

• simple — For clear-text password authenti-
cation.

• DIGEST-MD5 — For more secure hashed
password authentication. This method re-
quires that the server use plain text password
storage and only works with JRE 1.4 or later.

AuthenticationFilter For most LDAP servers:
(&amp;
(uid={uid})(ob-
jectclass=per-
son))
or

For Active Directory e-
mail lookups: (&amp;
(userPrincipal-
Name={uid})
(object-
class=user))
[ActiveDirecto-
ry]
For Active Directory
Windows user name
lookups: (&amp;
(sAMAccount-
Name={uid})(ob-
ject-
class=user))

The filter to use when looking up the user.

When performing a user name based lookup, this
filter is used to determine the LDAP entry that
matches the supplied user name.

The string "{uid}" in the filter is replaced with the
supplied user name.

Note: When you use this property to authenticate
SCC:

• Do not use special characters, as listed above,
in common names or distinguished names in
the value of this property.

• Do not use Chinese or Japanese characters in
user names or passwords of this property.
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Property Default Value Description

AuthenticationScope onelevel The authentication search scope. The supported
values for this are:

• onelevel
• subtree
If you do not specify a value or if you specify an
invalid value, the default value is used.

AuthenticationSearchBase None The search base used to authenticate users. If this
property is not configured, the value for Default-
SearchBase is used.

Note: When you use this property to authenticate
SCC:

• Do not use special characters, as listed above,
in common names or distinguished names in
the value of this property.

• Do not use Chinese or Japanese characters in
user names or passwords of this property.

BindDN None The user DN to bind against when building the
initial LDAP connection.

In many cases, this user may need read permis-
sions on all user records. If you do not set a value,
anonymous binding is used. Anonymous binding
works on most servers without additional config-
uration.

However, the LDAP attributer may use this DN to
create users in the LDAP server. When the self-
registration feature is used, this user may need
permissions to create a user record. This behavior
may occur if you do not set useUserCredential-
sToBind to true. In this case, the LDAP attributer
uses this DN to update the user attributes.
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Property Default Value Description

BindPassword None The password for BindDN, which is used to au-
thenticate any user. BindDN and BindPassword
separate the LDAP connection into units.

The AuthenticationMethod property determines
the bind method used for this initial connection.

Sybase recommends that you encrypt passwords,
and provides a password encryption utility. If you
encrypt BindPassword, include encryp-
ted=true in the line that sets the option. For

example:

<options name="BindPassword" en-
crypted="true" value="1snjikf-
wregfqr43hu5io..."/>
If you do not encrypt BindPassword, the option
might look like this:

<options name="BindPassword" 
value="s3cr3T"/>

RoleSearchBase None The search base used to retrieve lists of roles. If
this property is not configured, LDAP uses the
value for DefaultSearchBase.

Note: When you use this property to authenticate
SCC:

• Do not use special characters, as listed above,
in common names or distinguished names in
the value of this property.

• Do not use Chinese or Japanese characters in
user names or passwords of this property.
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Property Default Value Description

RoleFilter For SunONE/iPlanet:
(&amp;(object-
class=ldapsuben-
try) (object-
class=nsrolede-
finition))
For Netscape Directory
Server: (|(object-
class=groupof-
names) (object-
class=groupofu-
niquenames))
For ActiveDirectory: (|
(object-
class=groupof-
names) (object-
class=group))

The role search filter. This filter should, when
combined with the role search base and role
scope, return a complete list of roles within the
LDAP server. There are several default values,
depending on the chosen server type. If the server
type is not chosen and this property is not initial-
ized, no roles are available.

Note: When you use this property to authenticate
SCC:

• Do not use special characters, as listed above,
in common names or distinguished names in
the value of this property.

• Do not use Chinese or Japanese characters in
user names or passwords of this property.

RoleMemberAttributes For Netscape Directory
Server and OpenLDAP
Server: member,unique-
member

A comma-separated list of role attributes from
which LDAP derives the DNs of users who have
this role.

These values are cross-referenced with the active
user to determine the user's role list. One example
of the use of this property is when using LDAP
groups as placeholders for roles. This property
has a default value only when the Netscape server
type is chosen.

RoleNameAttribute cn The attribute of the role entry used as the role
name. This is the role name displayed in the role
list or granted to the authenticated user.

RoleScope onelevel The role search scope. Supported values include:

• onelevel
• subtree
If you do not specify a value or if you specify an
invalid value, LDAP uses the default value.
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Property Default Value Description

SkipRoleLookup false Set this property to true to grant the roles looked
up using the attributes specified by the property
UserRoleMembershipAttributes without cross-
referencing them with the roles looked up using
the RoleSearchBase and RoleFilter.

LDAP configuration validation succeeds even
when an error is encountered when listing all the
available roles. The error is logged to the server
log during validation but not reported in SCC,
allowing the configuration to be saved. This has
an impact when listing the physical roles for role
mapping as well as in SCC. To successfully au-
thenticate the user, set the SkipRoleLookup prop-
erty to true.

UserRoleMembershipAttri-
butes

For iPlanet/SunONE:
nsRoleDN

For Active Directory:
memberOf

For all others: none

Defines a user attribute that contains the DNs of
all of the roles a user is a member of.

These comma-delimited values are cross-refer-
enced with the roles retrieved in the role search
base and search filter to generate a list of user's
roles.

If the SkipRoleSearch property is set to true, these
comma-delimited values are not cross-referenced
with the roles retrieved in the role search base and
role search filter. See SkipRoleLookup.

Note: If you use nested groups with Active Di-
rectory, you must set this property to to-
kenGroups.

UserFreeformRoleMem-
bershipAttributes

None The free-form role membership attribute list.
Users who have attributes in this comma-delimi-
ted list are automatically granted access to roles
whose names are equal to the attribute value. For
example, if the value of this property is depart-
ment and the department attribute in the user's
LDAP record has the values {sales, consulting},
the user is granted the roles sales and consulting.

Referral ignore The behavior when a referral is encountered. Val-
id values are dictated by LdapContext, but might
include follow, ignore, or throw.
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Property Default Value Description

DigestMD5Authentication-
Format

DN

For OpenLDAP: User
name

The DIGEST-MD5 bind authentication identity
format.

UseUserAccountContro-
lAttribute

For Active Directory:
true

When this property is set to true, the UserAc-
countControl attribute detects disabled user ac-
counts, account expirations, password expira-
tions, and so on. Active Directory also uses this
attribute to store the above information.

EnableLDAPConnection-
Trace

False Enables LDAP connection tracing. The output is
logged to a file in the temp directory. The loca-

tion of the file is logged to the server log.

ConnectTimeout 0 Specifies the timeout, in milliseconds, for at-
tempts to connect to the LDAP server. The prop-
erty value sets the JNDI com.sun.jndi.ldap.con-
nect.timeout property when attempting to estab-
lish a connection to a configured LDAP server. If
the LDAP provider cannot establish a connection
within the configured interval, it aborts the con-
nection attempt. An integer value less than or
equal to zero results in the use of the network
protocol's timeout value.

ReadTimeout 0 Controls the length of time, in milliseconds, the
client waits for the server to respond to a read
attempt after the initial connection to the server
has been established. The property values sets the
JNDI com.sun.jndi.ldap.read.timeout property
when attempting to establish a connection to a
configured LDAP server. If the LDAP provider
does not receive an LDAP response within the
configured interval, it aborts the read attempt. The
read timeout applies to the LDAP response from
the server after the initial connection is establish-
ed with the server. An integer value less than or
equal to zero indicates no read timeout is speci-
fied.
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Property Default Value Description

LDAPPoolMaxActive 8 Caps the number of concurrent LDAP connec-
tions to the LDAP server. A non-positive value
indicates no limit. If this option is set for multiple
LDAP providers, the value set by the first LDAP
provider loaded takes precedence over all the
others. When LDAPPoolMaxActive is reached,
any further attempts by the LDAP provider
classes to borrow LDAP connections from the
pool are blocked indefinitely until a new or idle
object becomes available in the pool. Connection
pooling improves the LDAP provider's perform-
ance and resource utilization by managing the
number of TCP connections established with
configured LDAP servers.

controlFlag optional When you configure multiple authentication pro-
viders, use controlFlag for each provider to con-
trol how the authentication providers are used in
the login sequence.

controlFlag is a generic login module option rath-
er than an LDAP configuration property.

Mapping Sybase Control Center Roles to LDAP or OS Groups
To grant Sybase Control Center privileges to users who are authenticated through LDAP or the
operating system, associate roles used in Sybase Control Center with groups in LDAP or the
operating system.

Prerequisites

• Required: Configure an LDAP authentication module.
• Optional: Create these LDAP groups and assign Sybase Control Center users to them:

• sybase – confers sccUserRole. Assign all SCC users to the sybase group.
• SCC Administrator – confers sccAdminRole. Assign only SCC administrators to this

group.

Task

You can configure Sybase Control Center to enable users to authenticate through their local
operating system or through an LDAP server. To make this type of authentication work, SCC
roles must be mapped to groups that exist in the system providing authentication (LDAP or the
operating system).

The sybase and SCC Administrator groups are convenient because they are predefined in
role-mapping.xml. If you add sybase and SCC Administrator groups to your LDAP
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system and populate them with SCC users and administrators, you can skip to the next task
—you do not need to complete the steps below.

The table lists default mappings of LDAP and OS groups to SCC roles. Login modules are
defined in csi_config.xml.

Login Module OS Group Sybase Control Center Roles

UNIX Proxy root uaAnonymous, uaAgentAdmin, uaOSAdmin

sybase uaAnonymous, uaPluginAdmin, sccUserRole

user uaAnonymous

guest uaAnonymous

NT Proxy Administrators uaAnonymous, uaAgentAdmin, uaOSAdmin

sybase uaAnonymous, uaPluginAdmin, sccUserRole

Users uaAnonymous

Guests uaAnonymous

LDAP sybase uaAnonymous, uaPluginAdmin, sccUserRole

SCC Administrator uaAnonymous, sccAdminRole

There are two ways to accomplish the mapping:

• (Recommended) Add a “sybase” group and an “SCC Administrator” group to the
operating system or LDAP server Sybase Control Center is using to authenticate users, and
add all users who need to access Sybase Control Center to one or both groups.

• Configure Sybase Control Center to use existing groups in LDAP or the operating system
by editing the role-mapping.xml file. This option is described here.

1. If Sybase Control Center is running, shut it down.

2. In a text editor, open:

<SCC-install-directory>/conf/role-mapping.xml
3. Locate the sccUserRole section of the file:

<Mapping>
    <LogicalName>sccUserRole</LogicalName>
    <MappedName>SCC Administrator</MappedName>
    <MappedName>SCC Agent Administrator</MappedName>
    <MappedName>sybase</MappedName>
</Mapping>    

4. Add a MappedName line for the LDAP or OS group you are using to authenticate SCC
users. The sccUserRole section should look similar to this:
<Mapping>
    <LogicalName>sccUserRole</LogicalName>
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    <MappedName>SCC Administrator</MappedName>
    <MappedName>SCC Agent Administrator</MappedName>
    <MappedName>sybase</MappedName>
    <MappedName>my_SCC_group</MappedName>
</Mapping>    

5. Locate the sccAdminRole section of the file:
<Mapping>
    <LogicalName>sccAdminRole</LogicalName>
    <MappedName>SCC Administrator</MappedName>
</Mapping>    

6. Add a MappedName line for the LDAP or OS group you are using to authenticate SCC
administrators. The sccAdminRole section should look similar to this:
<Mapping>
    <LogicalName>sccAdminRole</LogicalName>
    <MappedName>SCC Administrator</MappedName>
    <MappedName>my_SCC_admin_group</MappedName>
</Mapping>    

7. Save the file and exit.

8. (LDAP only) Ensure that the roles defined in the LDAP repository match the roles defined
in role-mapping.xml.

9. In the <SCC-install-dir>\conf\csi_config.xml file, set the BindPassword
and ProviderURL properties with values used in your deployment.

Sybase recommends that you encrypt sensitive values before saving them in
csi_config.xml.

10. Start Sybase Control Center.

See also
• Configuring an LDAP Authentication Module on page 34

Encrypting a Password
Use the passencrypt utility to encrypt passwords and other values that must be kept secure
while stored in text files.

You can safely store an encrypted password in a configuration file. Enter the password in clear
text (unencrypted) when you execute passencrypt and when you use the password to log in.

passencrypt, which is located in the Sybase Control Center bin directory, uses the SHA-256
hash algorithm for passwords used in the PreConfiguredLoginModule in
csi_config.xml.

1. Open a command window and change to the bin directory:

Windows: cd <SCC-install-directory>\bin
UNIX: cd <SCC-install-directory>/bin

2. To encrypt a password, enter passencrypt -csi. Enter your new password at the resulting
prompt.
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passencrypt encrypts the password you enter (which does not appear on the screen) and
displays the password in encrypted form.

3. Copy the encrypted password.

4. Paste the encrypted password where needed.

Configuring Ports
(Optional) Use the scc --port command to assign Sybase Control Center services to new
ports.

Prerequisites
Check for port conflicts between Sybase Control Center and other software running on the
same host.

Task

Sybase Control Center cannot function properly if other services use its ports. If you discover
a conflict with any port listed in the right column below, you can either reconfigure the other
service’s port or reconfigure Sybase Control Center as described here.

Port
Name

Description Service Names Property Names Default
Port

db Database port

Present on SCC server

SccSADataserver

Messaging

Alert

Scheduler

com.sybase.asa.server.port

messaging.db.port

alert.database.port

org.quartz.data-
Source.ASA.URL

3638

http Web HTTP port

Present on SCC server

EmbeddedWebCon-
tainer

http.port 8282

https Web HTTPS (secure
HTTP) port

Present on SCC server

EmbeddedWebCon-
tainer

https.port 8283

jiniHttp JINI HTTP server

Present on SCC server
and SCC agent

Jini httpPort 9092
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Port
Name

Description Service Names Property Names Default
Port

jiniR-
mid

JINI remote method in-
vocation daemon

Present on SCC server
and SCC agent

Jini rmidPort 9095

msg Messaging port

Present on SCC server

Messaging messaging.port 2000

rmi RMI port

Present on SCC server
and SCC agent

RMI port 9999

tds Tabular Data Stream™

port (used to communi-
cate with other Sybase
products)

Present on SCC server
and SCC agent

Tds tdsPort 9998

1. Shut down Sybase Control Center.

2. Execute scc --info ports to display a list of Sybase Control Center services, their
properties, and their assigned ports.

3. To reassign a port, enter a command in one of these formats:
scc --port port-name=port-number
scc --port service-name:property-name=port-number
Use the first, simpler format unless you want to configure the database services to use
different ports. (By default, they all use the same port.)

4. Start Sybase Control Center.

5. Execute scc --info ports again to confirm that the port has been reassigned.

Examples

Set all four database services (data server, messaging, database alert, and scheduler) to the
same port, 3639. (The database is SQL Anywhere®, used by the Sybase Control Center
internal repository.)

scc --port db=3639
Set only the database messaging service to port 3639.

scc --port Messaging:messaging.db.port=3639
Set the HTTP port to 9292.
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scc --port http=9292
Set the Jini RMI daemon to port 9696.

scc --port jiniRmid=9696
Set the main Sybase Control Center messaging service to port 2001.

scc --port msg=2001
Set the RMI port to 9991.

scc --port rmi=9991
Set the Tabular Data Stream port to 9997.

scc --port tds=9997
Note: scc commands that include a port-setting option (-p  or --port) do not start Sybase
Control Center. To start SCC, execute a separate scc command.

Configuring the Automatic Logout Timer
(Optional) Set Sybase Control Center to end login sessions when users are inactive for too
long.

Prerequisites
Launch Sybase Control Center and log in using an account with administrative privileges.
(The login account or its group must have sccAdminRole.)

Task

1. From the application’s menu bar, select Application > Administration.

2. Select General Settings.

3. Click the Auto-Logout tab.

4. Enter the number of minutes after which an idle user will be automatically logged out.

Enter 0 or leave the box empty to disable automatic logout.

5. Click OK (to apply the change and close the properties dialog) or Apply (to apply the
change and leave the dialog open).

See also
• Setting Up Security on page 30

User Authorization
The authorization mechanism in Sybase Control Center employs login accounts and task-
based roles.

Access to Sybase Control Center is controlled by login accounts. You grant permissions to a
login account by assigning predefined roles that control tasks the user can perform in Sybase
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Control Center, such as administration and monitoring of particular types of Sybase servers.
The roles can be assigned directly to login accounts or to groups; a login account inherits the
roles of any group to which it belongs. Component product modules assign some roles
automatically.

Sybase Control Center classifies roles as follows:

• System roles – define how a user can interact with Sybase Control Center.
• Product roles – define how a user can interact with a particular managed resource in Sybase

Control Center, for example the Replication Server named RepBoston01.

Note: The tools described here are for managing SCC-enabled login accounts; you cannot use
them to manage accounts and groups that are native to your managed resource.

See also
• Configure on page 53

Assigning a Role to a Login or a Group
Use the security configuration options to add one or more roles to a Sybase Control Center
login account or to a group. Roles enable users to perform tasks such as monitoring servers or
administering Sybase Control Center.

Prerequisites
You must have administrative privileges (sccAdminRole) to perform this task. To assign a
monitoring role for a server, first register the server.

Task
Assign the sccAdminRole to any login account that will perform administrative tasks in
Sybase Control Center.

1. From the application menu bar, select Application > Administration.

2. In the Sybase Control Center Properties dialog, expand the Security folder.

3. Click Logins or Groups.

4. In the table, select the login account or group to which you want to assign a role.

5. Click the Roles tab.

6. In the Available roles for resource list, select the role, then click Add. For example, to
grant administrative privileges, add the SCC Service:sccAdminRole. To grant monitoring
privileges, add the MonitorRole for the desired server and server type.

Note: Sybase Control Center product modules assign certain roles automatically, so you
might not need to add a MonitorRole.

If a role appears in the Has following roles list, this account or group has already been
configured with that role.
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7. Click OK.

See also
• Adding a Group on page 51

• Adding a Login Account to a Group on page 51

• Logins, Roles, and Groups on page 52

Adding a Group
Use the security configuration options to create a new group.

Prerequisites
You must have administrative privileges (sccAdminRole) to perform this task.

Task
Groups can make roles easier to manage. Rather than assigning roles to individual users,
assign roles to groups and add users to the groups or remove them as needed.

1. From the main menu bar, select Application > Administration.

2. In the Sybase Control Center Properties dialog, expand the Security folder.

3. Select Groups.

4. Click Create Group.

5. Enter a group name and a description.

6. Click Finish.

See also
• Assigning a Role to a Login or a Group on page 50

• Adding a Login Account to a Group on page 51

• Logins, Roles, and Groups on page 52

Adding a Login Account to a Group
Use the security configuration options to add one or more login accounts to a group.

Prerequisites
You must have administrative privileges (sccAdminRole) to perform this task.

Task

1. From the main menu bar, select Application > Administration.

2. In the Sybase Control Center Properties dialog, expand the Security folder.

3. Click Groups.
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4. Select the group to which you want to assign an account.

5. Click the Membership tab.

6. Select the account, then click Add.

7. Click OK.

See also
• Assigning a Role to a Login or a Group on page 50
• Adding a Group on page 51
• Logins, Roles, and Groups on page 52

Logins, Roles, and Groups
Sybase Control Center includes predefined login accounts and roles.

A login account identifies a user who can connect to Sybase Control Center. An account has
roles that control the tasks the user is allowed to perform. Users can be authenticated through
native SCC accounts, but a safer approach is to delegate authentication to the operating system
or to an LDAP directory service.

Sybase Control Center comes with a predefined login account. Sybase recommends using the
predefined account only for installing and setting up Sybase Control Center. This account is
not intended for use in a production environment.

Table 8. Predefined Login Account

Login Name Description

sccadmin Can use all the administration features in Sybase Control Center. Use for
configuration and test.

A role is a predefined profile that can be assigned to a login account or a group. Roles control
the access rights for login accounts. Sybase Control Center comes with predefined roles that
are intended for use in production environments.

Table 9. Predefined Roles

Role Description

sccUserRole Provides nonadministrative access to Sybase Control Center. Required
for all users and assigned automatically to every authenticated user.

sccAdminRole Provides administrative privileges for managing Sybase Control Center.

Monitoring privileges for SCC product modules are assigned automatically.

A group is made up of one or more login accounts; all the accounts in a group have the roles
granted to the group. In Sybase Control Center you can create groups to suit your business
requirements.
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See also
• Assigning a Role to a Login or a Group on page 50
• Adding a Group on page 51
• Adding a Login Account to a Group on page 51

Configure
Configure Sybase Control Center for Replication Server Data Assurance Option.

Note: Before configuring Sybase Control Center for use in a production environment,
complete the tasks in the Get Started section of the help. Setting up security is particularly
important.

1. Configuring Data Assurance Server for Monitoring

Authenticate a Data Assurance (DA) server to monitor using Sybase Control Center.
When a resource is authenticated, Sybase Control Center enables the DA server
monitoring option.

2. Registering a Data Assurance Server

Register a resource (for example, a server that can be monitored) to make Sybase Control
Center aware of it and its connection information.

3. Importing Resources for Batch Registration

(Optional) Import and register multiple servers from an interfaces or sql.ini file.

4. Authenticating a Login Account for a Managed Resource

Specify the login account and password Sybase Control Center will use when it connects
to your server or agent to collect monitoring data or manage the resource.

5. Setting Up Statistics Collection

Use the Properties view of your managed resource to create a data collection job and add a
schedule to the job.

6. Creating an Agent Connection

Create a Data Assurance (DA) agent connection required to create comparesets and
schema jobs.

7. Creating a Database Connection

Set up a primary and replicate database connection in a Data Assurance (DA) server.

8. Creating a Single or Cluster Connection from an Interface File

Import Data Assurance (DA) resources from an interface file.

9. Optional Configuration Steps

Perform additional configuration, including user authorization, alerts, data collection
scheduling, backups, and setting purging options for the repository.

See also
• User Authorization on page 49
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• Logins, Roles, and Groups on page 96

• Setting Up Security on page 69

• Assigning a Role to a Login or a Group on page 90

Launching Sybase Control Center
Use the scc command to start Sybase Control Center.

Prerequisites

Install Adobe Flash Player in the browser you will use for Sybase Control Center.

Task

1. Start Sybase Control Center.

• Windows – navigate to <install_location>\SCC-3_2\bin and double-
click scc.bat.

• UNIX – execute scc.sh.

Messages on the progress of the launch appear in a command window. When Sybase
Control Center is running, the command window becomes the Sybase Control Center
console; you can issue commands to get status information on SCC and its ports, plug-ins,
and services.

2. Open a Web browser and enter https://<hostname>:8283/scc.

See also
• Sybase Control Center Console on page 150

Registering the ODBC Driver in Windows
In Windows, run scc.bat with administrative privileges to register the ODBC driver.

When Sybase Control Center starts for the first time on a Windows machine, it registers its
ODBC driver. Because the automatic registration of the ODBC driver edits the registry
settings, you must execute scc.bat using elevated administrative privileges. If you launch for
the first time without adequate privileges, Sybase Control Center generates an error and fails
to start.

In Windows Vista, Windows 2008, and Windows 7, you must use the Run as administrator
setting to launch Sybase Control Center even if you already have administrative privileges.
This process is described below.

In other versions of Windows, you must be logged in as an administrator to start Sybase
Control Center for the first time. You need not follow the steps below.
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1. In Windows Vista, Windows 2008, or Windows 7, open the Command Prompt window
with administrative privileges:

• Select Start > All Programs > Accessories. Right-click Command Prompt and
select Run as administrator.

• Alternatively, enter cmd in the Start Menu search box and press Shift+Ctrl+Enter.

2. Run scc.bat.

Starting and Stopping Sybase Control Center in Windows
There are several ways to start and stop Sybase Control Center or the SCC agent. You can start
manually, which is useful for testing and troubleshooting, or set the service to start
automatically and to restart in case of failure.

This topic applies to both Sybase Control Center (the server, which includes the management
UI) and the Sybase Control Center agent that runs on each product server managed by SCC.
When you install SCC and the SCC agent in the same directory by selecting both options in the
installer, you start and stop them together—by executing a single command or controlling a
single service. This topic applies both to singleton installations (which do not use a shared
disk) and to instances of SCC agents and servers running from a shared disk.

If you run Sybase Control Center or the SCC agent manually, you must issue a command every
time you start or shut down. If you run as a service (which is recommended), you can configure
the service to start and restart automatically. These are the options:

• Use the scc.bat command to start Sybase Control Center or the SCC agent manually. The
command gives you access to the Sybase Control Center console, which you can use to
shut down and to display information about services, ports, system properties, and
environment variables. You can also use scc.bat to change the logging level for
troubleshooting purposes. Using scc.bat prevents you from taking advantage of the
automatic start and restart features available to services.

• Use the Services list under the Windows Control Panel to start, stop, and configure the
Sybase Control Center service for an SCC server or agent.

• Use the net start and net stop commands. This is another way to run Sybase Control
Center or the SCC agent as a service.

Note: To start an SCC agent or server as a service:
• In a singleton installation, you must have selected Yes in the installer to install the agent

or server as a service.
• In a shared disk installation, the agent or server must have been deployed using the -

service option of the sccinstance command.

In a singleton installation, the installer lets you start Sybase Control Center or the SCC agent
as a service and configures the service to restart automatically. Before starting, check the
Windows Services list for a Sybase Control Center service.

Here are the steps for each starting and stopping option:
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• Start Sybase Control Center, the SCC agent, or both when they are installed
together:

a) (Skip this step for the SCC agent.) If you are starting Sybase Control Center for the first
time in Windows Vista, Windows 2008, or Windows 7, set the Run as Administrator
option on the command prompt so that Sybase Control Center can register its ODBC
driver. (This is necessary even if you are logged in as an administrator.)

b) Enter the scc command.

For a singleton installation:

%SYBASE%\SCC-3_2\bin\scc.bat
 
For an instance:

%SYBASE%\SCC-3_2\bin\scc.bat -instance <instance-name>
 
You can omit the -instance option if the instance’s name is the same as its host name
(the default).

• Stop Sybase Control Center, the SCC agent, or both when they are installed together:

a) Enter the scc --stop command.

For a singleton installation:

%SYBASE%\SCC-3_2\bin\scc.bat --stop

For an instance:

%SYBASE%\SCC-3_2\bin\scc.bat --stop -instance <instance-
name>

You can omit the -instance option if the instance’s name is the same as its host name
(the default).

Note: You can also enter shutdown at the scc-console> prompt.

• Start or stop from the Windows Control Panel; configure automatic start and
restart:

a) Open the Windows Control Panel.
b) Select Administrative Tools > Services.
c) Locate “Sybase Control Center” in the Services list. It may be followed by a release

number; if the service is for an instance, it is also followed by the instance name.
Service names do not distinguish between agents and servers. If the service is running,
the Status column displays “Started.”

d) To start or stop the service, right-click the Sybase Control Center entry in the Services
list and choose Start or Stop.

e) To configure automatic starting, double-click the service.
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f) To set the service to automatically start when the machine starts, change the Startup
type to Automatic.

g) To restart the service in case of failure, choose the Recovery tab and change the First,
Second, and Subsequent failures to Restart Service.

h) Click Apply to save the modifications and close the dialog.
• Start or stop the Sybase Control Center service (controlling Sybase Control Center,

the SCC agent, or both) from the Windows command line:
a) To start the service, enter the net start command.

For a singleton installation:

net start "sybase control center 3.2.8"
The Sybase Control Center 3.2.8 service is starting......
The Sybase Control Center 3.2.8 service was started 
successfully.

For an instance, include the instance name (Boston-1 in this example) in parentheses:

net start "sybase control center 3.2.8 (Boston-1)"
The Sybase Control Center 3.2.8 (Boston-1) service is 
starting......
The Sybase Control Center 3.2.8 (Boston-1) service was 
started successfully.

b) To stop the service, enter the net stop command.
For a singleton installation:

net stop "sybase control center 3.2.8"
The Sybase Control Center 3.2.8 service is stopping.....
The Sybase Control Center 3.2.8 service was stopped 
successfully.
For an instance, include the instance name (Boston-1 in this example) in parentheses:

net stop "sybase control center 3.2.8 (Boston-1)"
The Sybase Control Center 3.2.8 (Boston-1) service is 
stopping.....
The Sybase Control Center 3.2.8 (Boston-1) service was 
stopped successfully.

Starting and Stopping Sybase Control Center in UNIX
You can start Sybase Control Center or the SCC agent manually, which is useful for testing and
troubleshooting, or you can set up a service to start automatically and to restart in case of
failure.

This topic applies to both Sybase Control Center (the server, which includes the management
UI) and the Sybase Control Center agent that runs on each product server managed by SCC..
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When you install SCC and the SCC agent in the same directory by selecting both options in the
installer, you start and stop them together—by executing a single command or controlling a
single service. This topic applies to both singleton installations (which do not use a shared
disk) and instances of SCC agents and servers running from a shared disk.

If you start Sybase Control Center or the SCC agent manually, you must issue a command
every time you start or shut down. If you run as a service (which is recommended), you can
configure the service to start and restart automatically. These are the options:

• Use the scc.sh script to start Sybase Control Center or the SCC agent manually. You can
either:
• Run scc.sh in the foreground to get access to the Sybase Control Center console,

which you can use to shut down and to display information about services, ports,
system properties, and environment variables.

• Run scc.sh in the background to suppress the console.
You can use scc.sh to run Sybase Control Center at a nondefault logging level for
troubleshooting. When you start manually with scc.sh, you cannot take advantage of the
automatic start and restart features available to services.

• Use the sccd script to configure a service that starts Sybase Control Center or the SCC
agent automatically.

Here are the steps for each starting and stopping option:

• Before you start Sybase Control Center or the SCC agent for the first time, set
environment variables. Do this only once.

a) Change to the Sybase directory (the parent of the Sybase Control Center installation
directory).

b) Execute one of the following to set environment variables.

Bourne shell:

. SYBASE.sh
C shell:

source SYBASE.csh
• Run Sybase Control Center or the SCC agent (or both, when they are installed

together) in the foreground.

Running in the foreground is a method of manually starting; you must issue commands to
stop and restart Sybase Control Center or the SCC agent.

a) To start Sybase Control Center or the SCC agent and drop into the console when the
start-up sequence is finished, enter the scc command.

For a singleton installation:

$SYBASE/SCC-3_2/bin/scc.sh
For an instance:

$SYBASE/SCC-3_2/bin/scc.sh -instance <instance-name>
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You can omit the -instance option if the instance’s name is the same as its host name
(the default).

• Run Sybase Control Center or the SCC agent (or both, when they are installed
together) in the background.
You can use nohup, &, and > to run Sybase Control Center or the SCC agent in the
background, redirect output and system error to a file, and suppress the SCC console.
Running in the background is a method of manually starting; you must issue commands to
stop and restart Sybase Control Center or the SCC agent.

a) Execute a command similar to the sample below that matches your shell. Both sample
commands direct output to the file scc-console.out. If the output file already
exists, you might need to use additional shell operators to append to or truncate the
file.
Bourne shell (sh) or Bash

For a singleton installation:
nohup ./scc.sh 2>&1 > scc-console.out &

For an instance:
nohup ./scc.sh -instance <instance-name> 2>&1 > scc-console-
your-instance.out &

You can omit the -instance option if the instance’s name is the same as its host name
(the default).

C shell

For a singleton installation:
nohup ./scc.sh >& scc-console.out &

For an instance:
nohup ./scc.sh -instance <instance-name> >& scc-console.out &

You can omit the -instance option if the instance’s name is the same as its host name
(the default).

• Shut down Sybase Control Center or the SCC agent (or both, when they are installed
together) .
a) To shut down from the scc-console> prompt, enter:

shutdown
Warning! Do not enter shutdown at a UNIX prompt; it shuts down the operating
system.

To shut down from the UNIX command line, enter the scc --stop command.

For a singleton installation:

$SYBASE/SCC-3_2/bin/scc.sh --stop
For an instance:
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$SYBASE/SCC-3_2/bin/scc.sh --stop -instance <instance-
name>
You can omit the -instance option if the instance’s name is the same as its host name
(the default).

• Configure Sybase Control Center or the SCC agent to run as a service.
A UNIX service is a daemon process that starts automatically after the machine is started
and runs in the background. UNIX installations of Sybase Control Center include a shell
script, sccd, which you can use to configure the Sybase Control Center service. (Some
UNIX platforms supply tools that make service configuration easier; Linux chkconfig is
an example.)

Note: Sybase recommends that if you are not familiar with setting up services in UNIX,
you delegate this task to a system administrator or consult the system administration
documentation for your UNIX platform.

a) Copy $SYBASE/SCC-3_2/bin/sccd into this directory:

• AIX (SCC agent only): /etc/rc.d/init.d
• HP-UX (SCC agent only): /sbin/init.d
• All other platforms: /etc/init.d

b) Open sccd and make these changes:

• Change the line that sets the SYBASE variable to the location of your Sybase
installation (that is, the parent of SCC-3_2, the Sybase Control Center installation
directory). By default, this directory is called Sybase.

• If you are not using shared-disk mode, or you are using shared-disk mode to run a
single instance whose name is the same as the host name, skip to step 5.c on page
61 or step 5.d on page 61.

• If you are using shared-disk mode to run a single instance whose name is not the
host name, or to run multiple instances on the same host, add the instance name to
the script name. Change:
SCRIPT_NAME=scc.sh

to:
SCRIPT_NAME="scc.sh -instance <instance-name>"

• If you are using shared-disk mode to run multiple instances on the same host,
append the instance name to the name of the ouput log file. Change:
./${SCRIPT_NAME} --start 2>&1 >> ${SCC_HOME}/log/scc-
service.out &

to:
./${SCRIPT_NAME} --start 2>&1 >> ${SCC_HOME}/log/scc-
service_<instance-name>.out &

• If you are using shared-disk mode to run multiple instances on the same host, save a
copy of the sccd script for each instance, giving each copy a unique name. In each
copy, add the instance name to the script name and append the instance name to the
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output log file name as described above. Perform the remaining steps in this
procedure for each copy of sccd.

c) In Linux, configure the service to run in run levels 2, 3, 4, and 5:

/usr/sbin/chkconfig --add sccd
/usr/sbin/chkconfig --level 2345 sccd
You can test the sccd script with /usr/sbin/service sccd status. (The
service command accepts these options: start | stop | status | restart.)

d) On non-Linux platforms, locate this directory:

• AIX (SCC agent only): /etc/rc.d/rc<X>.d
• HP-UX (SCC agent only): /sbin/rc<X>.d
• Solaris: /etc/rc<X>.d
where <X> is the run level (for example, 3). Make two soft links in the directory for
your platform and set the links to point to:

• AIX (SCC agent only):
/etc/rc.d/init.d/sccd: S90sccd and
/etc/rc.d/init.d/sccd: K10sccd

• HP-UX (SCC agent only):
/sbin/init.d/sccd: S90sccd and
/sbin/init.d/sccd: K10sccd

• Solaris:
/etc/init.d/sccd: S90sccd and
/etc/init.d/sccd: K10sccd

The S90sccd link starts the service and the K10sccd link stops the service. The
two-digit numbers in the links indicate the start and stop priorities of the service.

e) Use the S90sccd and K10sccd links to test starting and stopping the service. The
links are called automatically when the machine is started or shut down.

Configuring Memory Usage
(Optional) Determine whether you need to configure how much memory Sybase Control
Center uses, and if so which configuration method to use.

It is not usually necessary to configure memory usage for Sybase Control Center. This table
lists memory options you can set and circumstances under which you should consider
changing them.
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Modify this value When Guidelines

Maximum memory

• jvmopt=-Xmx – if

you are running Sybase
Control Center as a
Windows service

• SCC_MEM_MAX – if
you are running SCC as
a UNIX service

• SCC_MEM_MAX – if
you are starting SCC
from the command line

• You need to prevent Sybase Con-
trol Center from using more than a
given amount of memory

• Sybase Control Center fails to
start and may display an error:
Could not create the
Java Virtual ma-
chine.

• An OutOfMemory error says
Sybase Control Center is out of
heap space

• A warning message about system
memory appears during the start
process

• The machine where Sybase Con-
trol Center is installed has less
than 4GB of memory. (Starting
Sybase Control Center on a ma-
chine with less than 4GB of mem-
ory triggers the startup warning
message about system memory.)

On machines with less than 4GB of
memory, set maximum memory to
256MB or more.

Default value: none. (On machines
with 4GB or more of memory, maxi-
mum memory is set dynamically and
is effectively limited only by the
amount of system memory available.)

Permanent memory

• jvmopt=-
XX:MaxPerm-
Size – if you are run-

ning Sybase Control
Center as a Windows
service

• SCC_MEM_PERM –
if you are running SCC
as a UNIX service

• SCC_MEM_PERM –
if you are starting SCC
from the command line

An OutOfMemory error says Sybase
Control Center is out of permanent
generation space

Increase by 32MB increments. If you
reach a value equal to twice the de-
fault and still see the OutOfMemory
error, contact Sybase technical sup-
port.

Default value: 128MB

You can change memory options in two ways:

• For Sybase Control Center started from the command line – execute commands to set one
or more environment variables before executing the scc command to start Sybase Control
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Center. When you use this method, your changes to the memory options last only as long as
the current login session. This method is useful for testing new option values.

• For the Sybase Control Center service – modify a file used by the Sybase Control Center
service. When you use this method, your changes to the memory options persist—Sybase
Control Center uses them every time it starts as a service.

Changing a Memory Option on the Command Line
Before you start Sybase Control Center from the command line, you can issue a command to
change the value of a memory option temporarily.

Changes made using this method last only as long as the current login session. This method is
useful for testing new option values.

1. If Sybase Control Center is running, shut it down.

2. Set the environment variable. Specify a size in megabytes but do not indicate the units in
the command.

Windows example:
> set SCC_MEM_MAX=512

UNIX example:
bash$ export SCC_MEM_MAX=512

3. Use the scc command to start Sybase Control Center.

See also
• Starting and Stopping Sybase Control Center in Windows on page 55

• Starting and Stopping Sybase Control Center in UNIX on page 57

• scc Command on page 64

Changing a Memory Option for a Sybase Control Center Windows Service
Add a jvmopt command to the scc.properties file to change a memory option (-Xmx or
-XX:MaxPermSize) for a Sybase Control Center Windows service.

When you use this method to set memory options, your changes are permanent—Sybase
Control Center uses them every time it starts as a service.

1. If Sybase Control Center is running, shut it down.

2. Open the Sybase Control Center properties file:

<Sybase Control Center-install-directory>\SCC-3_2\bin
\scc.properties

3. Add (or modify, if it already exists) a jvmopt line specifying the memory size in Java
format. Use m for megabytes or g for gigabytes.

For example:
jvmopt=-Xmx512m
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4. Save the file and start the Sybase Control Center Windows service.

See also
• Starting and Stopping Sybase Control Center in Windows on page 55

Changing a Memory Option for an SCC UNIX Service
To change a memory setting for a Sybase Control Center UNIX service, add the appropriate
environment variable (SCC_MEM_MAX or SCC_MEM_PERM) to the sccd script.

When you use this method to set memory options, your changes are permanent—Sybase
Control Center uses them every time it starts as a service.

1. If Sybase Control Center is running, shut it down.

2. Open the sccd file: /etc/init.d/sccd
3. Add the environment variable at the top of the file (after the comments). Specify a size in

megabytes but do not indicate the units in the command.

For example:
SCC_MEM_MAX=512

4. Save the file and start the Sybase Control Center UNIX service.

See also
• Starting and Stopping Sybase Control Center in UNIX on page 57

scc Command
Use scc.bat (Windows) or scc.sh (UNIX) to start and stop Sybase Control Center agents and
servers and to perform administrative tasks like configuring ports and enabling and disabling
services.

Syntax
scc[.bat | .sh] [-a | --address RMI-service-address] 
[-b | --bitwidth] 
[--dbpassword]
[-disable | --disable service-name,service-name...] 
[-enable | --enable service-name,service-name...]
[-h | --help] 
[-I | --info [information-category]]
[-instance [instance-name]] 
[-m | --message message-level] 
[-password | --password password] 

[-p | --port {port-name=port-number | 
    service-name:property-name=port-number}]
[{-start | --start} | {-stop | --stop}] 
[-status | --status] 
[-user | --user login-name] 
[-v | -version | --version]
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Parameters

• -a | --address RMI-service-address – the address for the RMI service to use; must be an IP
address on this machine or the name of this machine (which is the default).

• -b | --bitwidth – returns a string identifying the bit width (32 or 64) of the underlying
platform; Sybase Control Center uses this option to determine which libraries to use for its
internal database. If you use this option, the scc command does not start Sybase Control
Center.

• --dbpassword – changes the password of the default dba account provided for the
repository database. It prompts you for the new password, validates it, and starts the
Sybase Control Center server. This option does not work if you start Sybase Control
Center in the background—the server fails to start if there is no console.

• -disable | --disable service-name,service-name... – disable the specified Sybase Control
Center services. This option does not work while Sybase Control Center is running or as
part of a command that starts SCC. To use it, shut down SCC, execute scc --disable,
then restart. See under --ports for service names; separate each service from the next with a
comma.

• -enable | --enable service-name,service-name... – enable the specified Sybase Control
Center services. See under --ports for service names; separate each service from the next
with a comma. When you use this option, scc does not start Sybase Control Center—use a
separate command to start SCC.

• -h | --help – display help and usage information for the scc command. If you use this
option, scc does not start Sybase Control Center.

• -I | --info [information-category] – display the specified categories of information about
Sybase Control Center. Separate each category from the next with a comma. The
information categories are:

• all – returns all the information provided by the sys, ports, and services categories.
Default option.

• sys – returns general information about this instance of Sybase Control Center,
including the version, the home (installation) directory, the host machine’s name and
IP address, the RMI port number, the messaging level, and details about the platform
and Java installation.

• ports – lists all the ports on which the Sybase Control Center agent and its services
listen, indicates whether each port is in use, and shows the service running on each
port.

• services – lists all the services known to the Sybase Control Center agent, indicates
whether each service is enabled, and lists other services on which each service
depends.

• sysprop – lists all the Java system properties known the Java VM and their values.
• env – lists the complete Java VM process environment.
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• -instance [instance-name] – use with other options (-start and -stop, for example) to
specify a Sybase Control Center instance in a shared disk deployment. If you do not enter a
name for the instance, it defaults to the host name.

• -m | --message message-level – set the amount of detail recorded in system logs; also
known as the logging level. Valid values are OFF, FATAL, ERROR, WARN, INFO,
DEBUG, and ALL. WARN is the default.

• -password | --password – specify the password of the user account Sybase Control Center
will use to stop servers or query them for status. Use this option with --user. When you
enter a command with --user but without --password, the console prompts you to enter a
password.

• -p | --port {port-name=port-number | service-name:property-name=port-number} –
configure the specified service to run on the specified port. Changing ports is useful if you
discover a port conflict between Sybase Control Center and other software on the same
system. When you use this option, scc does not start Sybase Control Center—use a
separate command to start SCC.

Valid port names, service names and property names are:

Port
Name

Description Service Names Property Names Default
Port

db Database port

Present on SCC server

SccSADataserver

Messaging

Alert

Scheduler

com.sybase.asa.server.port

messaging.db.port

alert.database.port

org.quartz.data-
Source.ASA.URL

3638

http Web HTTP port

Present on SCC server

EmbeddedWebCon-
tainer

http.port 8282

https Web HTTPS (secure
HTTP) port

Present on SCC server

EmbeddedWebCon-
tainer

https.port 8283

jiniHttp JINI HTTP server

Present on SCC server
and SCC agent

Jini httpPort 9092

jiniR-
mid

JINI remote method in-
vocation daemon

Present on SCC server
and SCC agent

Jini rmidPort 9095

msg Messaging port

Present on SCC server

Messaging messaging.port 2000
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Port
Name

Description Service Names Property Names Default
Port

rmi RMI port

Present on SCC server
and SCC agent

RMI port 9999

tds Tabular Data Stream™

port (used to communi-
cate with other Sybase
products)

Present on SCC server
and SCC agent

Tds tdsPort 9998

You can also execute scc --info ports to display service names and associated
property names; they appear in the first two columns of the output.

• -start | --start – start the Sybase Control Center server. This is the default option—if you
execute scc with no options, it starts SCC. This option cannot be combined in the same
command with options that set ports or enable or disable services; use a separate scc
command to start SCC.

• -status | --status – display a status message indicating whether the Sybase Control Center
server is running.

• -stop | --stop – shut down the Sybase Control Center server if it is running.
• -user | --user [login-name] – specify the user account Sybase Control Center will use to

stop managed servers or query them for status. Use this option with --password. If you do
not enter a login name, the console prompts you to enter one.

• -v | -version | --version – display the version of Sybase Control Center software running
on this server. If you use this option, scc does not start Sybase Control Center.

Examples

• Set the RMI port – each of these commands sets the RMI port to 9999 (the default). The
first command illustrates the port name syntax; the second illustrates the service
name:property name syntax.

scc --port rmi=9999
scc --port RMI:port=9999

• Set the RMI port and start SCC – these commands set the RMI port to 9996, then start
SCC. Two commands (separated by a semicolon here) are needed because scc does not
start Sybase Control Center when it includes any of the port-setting options.

scc -p rmi=9996; scc
• Set all database ports – this command sets all four of the SQL Anywhere database ports

(data server, messaging, database alert, and scheduler) to 3638. (SQL Anywhere is the
Sybase Control Center internal repository.)
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scc --port db=3638
• Set the TDS port – this command sets the TDS port to 9998 (the default):

scc --port Tds:tdsPort=9998
• Enable a service and start SCC – the first scc command enables the TDS service; the

second starts SCC. (The two commands are separated by a semicolon.) The second
command is needed because scc does not start Sybase Control Center when it includes the
-enable option.

scc -enable Tds; scc
• Start an SCC instance – this command starts the SCC instance called kalamazoo. -start is

optional because it is the default.

scc -start -instance kalamazoo

Permissions

scc permission defaults to all users. No permission is required to use it.

See also
• Configuring Ports on page 87

• Logging or Message Levels on page 148

Logging in to Sybase Control Center
Enter the Sybase Control Center Web console.

Prerequisites
Install Adobe Flash Player in the browser you will use for SCC. See the Sybase Control Center
Installation Guide.

Task

Sybase Control Center typically authenticates users through the operating system or an LDAP
directory service. Consult your SCC administrator if you are not sure which login account to
use for SCC.

Only one login session per account is permitted at a time; multiple users cannot be logged in to
the same account simultaneously.

Note: When logging in to a newly installed Sybase Control Center for which secure
authentication has not been configured, use the sccadmin account—the password is set during
installation. For more information, see the Sybase Control Center Installation Guide.
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1. Connect to the Sybase Control Center server. In your Web browser, enter: https://
scc-hostname:8283/scc.

2. Enter your user name and password, and click Login.

Tip: If you use a Windows account to log in to SCC, enter your user name in the format
username@domain. Omit top-level domain extensions such as .com or .net—for example,
enter fred@sap, not fred@sap.com.

Logging out of Sybase Control Center
When you finish working in Sybase Control Center, end your login session.

From the main menu bar, select Application > Log Out.

Alternatively, click Log Out in the upper-right corner of the window.

Note: If an administrator has configured the automatic logout feature, Sybase Control Center
logs you out if your session is idle (no typing or mouse movement) for longer than the timeout
period, which is set by the administrator.

If no automatic logout period is configured,

• A login session left open on a screen that refreshes (a monitor screen or a data collection
job screen, for example) remains open indefinitely.

• A login session left open on a screen that does not change expires after 30 minutes. The
next time you make a request of the server, SCC logs you out.

Setting Up Security
Configure login authentication and map roles.

Read about security and follow these procedures before you configure Sybase Control Center
product modules.

Note: These security topics are intended for use in a production environment. If you are
evaluating or testing SCC, see Quick Start for an Evaluation on page 13.

1. Security

Sybase Control Center can authenticate user logins through an LDAP server, through the
operating system, or both.

2. Configuring Authentication for Windows

Authentication through the Windows operating system is enabled by default.
Configuration is required only if you have upgraded from an older version of Sybase
Control Center and no longer want to use the older version’s authentication settings; if you
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do not want to use Windows for authentication; or if you want to create login accounts
manually. Sybase recommends that you allow SCC to create accounts automatically.

3. Configuring a Pluggable Authentication Module (PAM) for UNIX

Set up Sybase Control Center to support username and password login using accounts on
the UNIX operating system.

4. Configuring an LDAP Authentication Module

Configure an LDAP authentication module for Sybase Control Center by editing the
security configuration file to point to the correct LDAP server.

5. Mapping Sybase Control Center Roles to LDAP or OS Groups

To grant Sybase Control Center privileges to users who are authenticated through LDAP or
the operating system, associate roles used in Sybase Control Center with groups in LDAP
or the operating system.

6. Encrypting a Password

Use the passencrypt utility to encrypt passwords and other values that must be kept secure
while stored in text files.

7. Configuring Ports

(Optional) Use the scc --port command to assign Sybase Control Center services to new
ports.

8. Configuring Sybase Control Center

For configuration instructions, see the Configure section of the help for your Sybase
Control Center product module.

Security
Sybase Control Center can authenticate user logins through an LDAP server, through the
operating system, or both.

• Sybase Control Center can be configured to authenticate through any LDAP server that
supports the inetOrgPerson (RFC 2798) schema.

• When Sybase Control Center authenticates through the operating system, it uses the
operating system of the Sybase Control Center server machine (not the client).

Although you can create native user accounts in Sybase Control Center, Sybase does not
recommend this approach to authentication. It is simpler and safer to configure Sybase
Control Center to authenticate using existing LDAP, Windows, or UNIX login accounts.

Sybase strongly recommends that you use a common authentication provider for all Sybase
products, including Sybase Control Center. A common authentication provider ensures that
single sign-on works for users of Sybase Control Center and its managed servers.

Sybase Control Center requires each authenticated login account to have a predefined role.
When a login is authenticated, roles for the login are retrieved by the security module and are
mapped to Sybase Control Center predefined roles. Authorization is resolved through the
mappings between the security module native roles and Sybase Control Center roles. You can
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enable mappings by creating a “sybase” group in your operating system or LDAP server and
adding all Sybase Control Center users, or by modifying the Sybase Control Center role-
mapping.xml file to configure the mapping of native roles to Sybase Control Center roles.
The security module authenticates the logins and authorizes access to managed resources.

Sybase Control Center provides a set of predefined login modules for authentication. All login
modules are defined in the <install_location>/SCC-3_2/conf/
csi_config.xml file. The syntax is defined by the Sybase Common Security
Infrastructure (CSI) framework. You can configure the different login modules to customize
security strength. The login modules are:

• Preconfigured user login – defines a user name, password, and a list of roles. The default
user name is sccadmin; its password is configured during installation and its native role is
SCC Administrator, which maps to sccAdminRole. You can create additional accounts by
adding preconfigured user login modules to csi_config.xml. However, Sybase does
not recommend the use of preconfigured user login modules for authentication in
production environments.

• NT proxy login – delegates authentication to the underlying Windows operating system.
When you log in to Sybase Control Center through an NT Proxy Login module, enter your
user name in the format username@nt-domain-name. For example, user@sybase.
Windows authentication is enabled by default, but it requires some configuration after an
upgrade from SCC 3.2.5 or earlier.

• UNIX proxy login – delegates authentication to the underlying UNIX or Linux operating
system using Pluggable Authentication Modules (PAM). When you log in to Sybase
Control Center through a UNIX PAM, enter your UNIX user name and password. UNIX
authentication is enabled by default, but it requires some configuration.

• LDAP login – delegates authentication to an LDAP server you specify. When you log in to
Sybase Control Center through an LDAP server, enter your LDAP user name and
password. LDAP authentication is not enabled by default; you must configure the login
module.

Configuring Authentication for Windows
Authentication through the Windows operating system is enabled by default. Configuration is
required only if you have upgraded from an older version of Sybase Control Center and no
longer want to use the older version’s authentication settings; if you do not want to use
Windows for authentication; or if you want to create login accounts manually. Sybase
recommends that you allow SCC to create accounts automatically.

This task is optional. However, if you choose not to create Sybase Control Center accounts
automatically, you must enter them manually. Even when SCC users authenticate through
LDAP or the local operating system, SCC needs the accounts for purposes of setting
authorization (user privileges).

1. Log in to Sybase Control Center using an account with administrative privileges. (The
login account or its group must have sccAdminRole.)
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2. Select Application > Administration > Security.

3. Click to select or deselect the box labeled Automatically add SCC login records for
authenticated logins.

4. Click to select or deselect the box labeled Automatically grant sccUserRole to newly
created logins.

5. Click OK to close the Security dialog.

Next

There are two next steps:

• If you opted not to automatically create Sybase Control Center login accounts, enter each
account into Sybase Control Center manually.

• Grant privileges to login accounts that require more than basic user access. You can grant
privileges by assigning Sybase Control Center roles directly to the login accounts, or by
assigning the login accounts to groups and mapping Sybase Control Center roles to the
groups. The group approach is generally more efficient.

See also
• Mapping Sybase Control Center Roles to LDAP or OS Groups on page 84

• Adding a Login Account to the System on page 94

Configuring a Pluggable Authentication Module (PAM) for UNIX
Set up Sybase Control Center to support username and password login using accounts on the
UNIX operating system.

1. Using a login account with root privileges, configure the pluggable authentication module
for your platform:

Platform Action

Solaris Append the contents of the <SCC-install-dir>/utility/<su-
nos>/pam.conf file (provided with Sybase Control Center) to the /
etc/pam.conf file on your Solaris platform.

Linux Copy the <SCC-install-dir>/utility/<linux>/sybase-
csi file (provided with Sybase Control Center) to the /etc/pam.d direc-
tory on your Linux platform.

Note: The sybase-csi file provided with Sybase Control Center is not
compatible with the most recent SUSE Linux versions. For SUSE 11 and later,
see the example at the end of this topic.

Note: In the table above, the portion of the path that indicates the operating system might
differ slightly from what is shown.
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2. If the host UNIX system is not using a directory lookup for authentication (yp or NIS, for
example) and authentication is carried out against the local /etc/passwd file, change
the permissions on /etc/shadow to provide read access to the login account that
executes SCC.

3. (Skip if you configured a PAM before starting Sybase Control Center) Restart Sybase
Control Center.

4. (Optional) Change account creation options.

a) Log in to Sybase Control Center using an account with administrative privileges
(sccAdminRole).

b) Select Application > Administration > Security.
c) Click to select or deselect the box labeled Automatically add SCC login records for

authenticated logins. (By default, this option is enabled for SCC 3.2.6 and later.)
d) Click to select or deselect the box labeled Automatically grant sccUserRole to newly

created logins. (By default, this option is enabled for SCC 3.2.6 and later.)
e) Click OK to close the Security dialog.

Example: PAM for SUSE Linux 11 and later

For SUSE 11 and later, do not use the sybase-csi file provided with Sybase Control
Center. Instead, in your /etc/pam.d directory, create a sybase-csi file that contains:

# sybase-csi PAM Configuration (SUSE style)
auth       include      common-auth
account    include      common-account
password   include      common-password
session    include      common-session

Next

There are two next steps:

• If you opted not to automatically create Sybase Control Center login accounts, enter each
account into Sybase Control Center manually. Sybase Control Center needs the accounts
for purposes of setting authorization (user privileges).

• Grant privileges to login accounts that require more than basic user access. You can grant
privileges by assigning Sybase Control Center roles directly to the login accounts, or by
assigning the login accounts to groups and mapping Sybase Control Center roles to the
groups. The group approach is generally more efficient.

See also
• Mapping Sybase Control Center Roles to LDAP or OS Groups on page 84

• Adding a Login Account to the System on page 94
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Configuring an LDAP Authentication Module
Configure an LDAP authentication module for Sybase Control Center by editing the security
configuration file to point to the correct LDAP server.

1. Open the <SCC-install-dir>\conf\csi_config.xml file.

2. Uncomment the LDAP module in the configuration file by removing the surrounding
<!-- and --> characters (or, if necessary, add an LDAP module to the file). The sample
module below specifies the LDAP server that will provide user authentication.

The sample module shows the properties used for an OpenDS LDAP server. See the
example at the end of this task for values that work for ActiveDirectory. Configuration
properties you can use in the LDAP module are described in a subtopic.

<authenticationProvider controlFlag="sufficient" 
name="com.sybase.security.ldap.LDAPLoginModule">
    <options name="BindDN" value="cn=Directory Manager"/>
    <options name="BindPassword" value="secret"/>
    <options name="DefaultSearchBase" value="dc=example,dc=com"/>
    <options name="ProviderURL" value="ldap://localhost:10389"/>
    <options name="ServerType" value="openldap"/>
</authenticationProvider>
<provider name="com.sybase.security.ldap.LDAPAttributer" 
type="attributer"/>

Note: Change only values shown in bold. If BindPassword is encrypted (which Sybase
recommends), the line that defines it must include encrypted="true". The line
should look similar to this:
<options name="BindPassword" encrypted="true" 
value="1snjikfwregfqr43hu5io..."/>

3. Save the file.

4. If your LDAP server’s SSL certificate is signed by a nonstandard certificate authority (for
example, if it is a self-signed certificate), use the keytool utility to configure your JVM or
JDK to trust the certificate. Execute a command similar to this:

Windows:

keytool -import -keystore %SYBASE_JRE7%\lib\security\cacerts -
file <your cert file and path> 
-alias ldapcert -storepass changeit

UNIX:

keytool -import -keystore $SYBASE_JRE7/lib/security/cacerts -file 
<your cert file and path> 
-alias ldapcert -storepass changeit
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LDAP Configuration Values for ActiveDirectory

For an ActiveDirectory server, use these values for configuration properties in your LDAP
login module:
 
ServerType: msad2K
DefaultSearchBase: dc=<domainname>,dc=<tld> or o=<company 
name>,c=<country code>
                E.g. dc=sybase,dc=com or o=Sybase,c=us
ProviderUrl: ldaps://<hostname>:<port>
                E.g.:  ldaps://myserver:636
AuthenticationFilter: (&amp;(userPrincipalName={uid}) 
(objectclass=user))
BindDN: <User with read capability for all users>
BindPassword: <Password for BindDN user>
RoleFilter: (|(objectclass=groupofnames) (objectclass=group))
controlFlag: sufficient

Next
Map Sybase Control Center roles to LDAP groups.

See also
• Mapping Sybase Control Center Roles to LDAP or OS Groups on page 84

LDAP Configuration Properties
Use these properties in your csi_config.xml file to control the Sybase Control Center
LDAP service.

Note: These characters have special meaning when they appear in a name in LDAP: ,
(comma), = (equals), + (plus), < (less than), > (greater than), # (number or hash sign), ;
(semicolon), \ (backslash), / (forward slash), LF (line feed), CR (carriage return), " (double
quotation mark), ' (single quotation mark), * (asterisk), ? (question mark), & (ampersand), and
a space at the beginning or end of a string. LDAP providers do not handle these special
characters in any of the names or DNs in any of the configuration properties. Additionally,
some of the properties, as identified below, cannot use these special characters in common
names.
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Property Default Value Description

ServerType None Optional. The type of LDAP server you are con-
necting to:

• sunone5 -- SunOne 5.x OR iPlanet 5.x

• msad2k -- Microsoft Active Directory,

Windows 2000

• nsds4 -- Netscape Directory Server 4.x

• openldap -- OpenLDAP Directory Server

2.x

The value you choose establishes default values
for these other authentication properties:

• RoleFilter

• UserRoleMembership

• RoleMemberAttributes

• AuthenticationFilter

• DigestMD5Authentication

• UseUserAccountControl

ProviderURL ldap://local-
host:389

The URL used to connect to the LDAP server. Use
the default value if the server is:

• Located on the same machine as your product
that is enabled with the common security in-
frastructure.

• Configured to use the default port (389).

Otherwise, use this syntax for setting the value:

ldap://<hostname>:<port>

Get Started

76



Property Default Value Description

DefaultSearchBase None The LDAP search base that is used if no other
search base is specified for authentication, roles,
attribution, and self registration:

1. dc=<domainname>,dc=<tld>
For example, a machine in the sybase.com
domain would have a search base of dc=syb-
ase,dc=com.

2. o=<company name>,c=<coun-
try code>
For example, this might be o=Sybase,c=us for
a machine within the Sybase organization.

Note: When you use this property to authenticate
SCC:

• Do not use special characters, as listed above,
in common names or distinguished names in
the value of this property.

• Do not use Chinese or Japanese characters in
user names or passwords of this property.

SecurityProtocol None The protocol to be used when connecting to the
LDAP server.

To use an encrypted protocol, use ssl instead of

ldaps in the URL.

AuthenticationMethod Simple The authentication method to use for all authen-
tication requests into LDAP. Legal values are
generally the same as those of the java.naming.se-
curity.authentication JNDI property. Choose one
of:

• simple — For clear-text password authenti-
cation.

• DIGEST-MD5 — For more secure hashed
password authentication. This method re-
quires that the server use plain text password
storage and only works with JRE 1.4 or later.
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Property Default Value Description

AuthenticationFilter For most LDAP servers:
(&amp;
(uid={uid})(ob-
jectclass=per-
son))
or

For Active Directory e-
mail lookups: (&amp;
(userPrincipal-
Name={uid})
(object-
class=user))
[ActiveDirecto-
ry]
For Active Directory
Windows user name
lookups: (&amp;
(sAMAccount-
Name={uid})(ob-
ject-
class=user))

The filter to use when looking up the user.

When performing a user name based lookup, this
filter is used to determine the LDAP entry that
matches the supplied user name.

The string "{uid}" in the filter is replaced with the
supplied user name.

Note: When you use this property to authenticate
SCC:

• Do not use special characters, as listed above,
in common names or distinguished names in
the value of this property.

• Do not use Chinese or Japanese characters in
user names or passwords of this property.

AuthenticationScope onelevel The authentication search scope. The supported
values for this are:

• onelevel
• subtree
If you do not specify a value or if you specify an
invalid value, the default value is used.

Get Started

78



Property Default Value Description

AuthenticationSearchBase None The search base used to authenticate users. If this
property is not configured, the value for Default-
SearchBase is used.

Note: When you use this property to authenticate
SCC:

• Do not use special characters, as listed above,
in common names or distinguished names in
the value of this property.

• Do not use Chinese or Japanese characters in
user names or passwords of this property.

BindDN None The user DN to bind against when building the
initial LDAP connection.

In many cases, this user may need read permis-
sions on all user records. If you do not set a value,
anonymous binding is used. Anonymous binding
works on most servers without additional config-
uration.

However, the LDAP attributer may use this DN to
create users in the LDAP server. When the self-
registration feature is used, this user may need
permissions to create a user record. This behavior
may occur if you do not set useUserCredential-
sToBind to true. In this case, the LDAP attributer
uses this DN to update the user attributes.
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Property Default Value Description

BindPassword None The password for BindDN, which is used to au-
thenticate any user. BindDN and BindPassword
separate the LDAP connection into units.

The AuthenticationMethod property determines
the bind method used for this initial connection.

Sybase recommends that you encrypt passwords,
and provides a password encryption utility. If you
encrypt BindPassword, include encryp-
ted=true in the line that sets the option. For

example:

<options name="BindPassword" en-
crypted="true" value="1snjikf-
wregfqr43hu5io..."/>
If you do not encrypt BindPassword, the option
might look like this:

<options name="BindPassword" 
value="s3cr3T"/>

RoleSearchBase None The search base used to retrieve lists of roles. If
this property is not configured, LDAP uses the
value for DefaultSearchBase.

Note: When you use this property to authenticate
SCC:

• Do not use special characters, as listed above,
in common names or distinguished names in
the value of this property.

• Do not use Chinese or Japanese characters in
user names or passwords of this property.
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Property Default Value Description

RoleFilter For SunONE/iPlanet:
(&amp;(object-
class=ldapsuben-
try) (object-
class=nsrolede-
finition))
For Netscape Directory
Server: (|(object-
class=groupof-
names) (object-
class=groupofu-
niquenames))
For ActiveDirectory: (|
(object-
class=groupof-
names) (object-
class=group))

The role search filter. This filter should, when
combined with the role search base and role
scope, return a complete list of roles within the
LDAP server. There are several default values,
depending on the chosen server type. If the server
type is not chosen and this property is not initial-
ized, no roles are available.

Note: When you use this property to authenticate
SCC:

• Do not use special characters, as listed above,
in common names or distinguished names in
the value of this property.

• Do not use Chinese or Japanese characters in
user names or passwords of this property.

RoleMemberAttributes For Netscape Directory
Server and OpenLDAP
Server: member,unique-
member

A comma-separated list of role attributes from
which LDAP derives the DNs of users who have
this role.

These values are cross-referenced with the active
user to determine the user's role list. One example
of the use of this property is when using LDAP
groups as placeholders for roles. This property
has a default value only when the Netscape server
type is chosen.

RoleNameAttribute cn The attribute of the role entry used as the role
name. This is the role name displayed in the role
list or granted to the authenticated user.

RoleScope onelevel The role search scope. Supported values include:

• onelevel
• subtree
If you do not specify a value or if you specify an
invalid value, LDAP uses the default value.
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Property Default Value Description

SkipRoleLookup false Set this property to true to grant the roles looked
up using the attributes specified by the property
UserRoleMembershipAttributes without cross-
referencing them with the roles looked up using
the RoleSearchBase and RoleFilter.

LDAP configuration validation succeeds even
when an error is encountered when listing all the
available roles. The error is logged to the server
log during validation but not reported in SCC,
allowing the configuration to be saved. This has
an impact when listing the physical roles for role
mapping as well as in SCC. To successfully au-
thenticate the user, set the SkipRoleLookup prop-
erty to true.

UserRoleMembershipAttri-
butes

For iPlanet/SunONE:
nsRoleDN

For Active Directory:
memberOf

For all others: none

Defines a user attribute that contains the DNs of
all of the roles a user is a member of.

These comma-delimited values are cross-refer-
enced with the roles retrieved in the role search
base and search filter to generate a list of user's
roles.

If the SkipRoleSearch property is set to true, these
comma-delimited values are not cross-referenced
with the roles retrieved in the role search base and
role search filter. See SkipRoleLookup.

Note: If you use nested groups with Active Di-
rectory, you must set this property to to-
kenGroups.

UserFreeformRoleMem-
bershipAttributes

None The free-form role membership attribute list.
Users who have attributes in this comma-delimi-
ted list are automatically granted access to roles
whose names are equal to the attribute value. For
example, if the value of this property is depart-
ment and the department attribute in the user's
LDAP record has the values {sales, consulting},
the user is granted the roles sales and consulting.

Referral ignore The behavior when a referral is encountered. Val-
id values are dictated by LdapContext, but might
include follow, ignore, or throw.
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Property Default Value Description

DigestMD5Authentication-
Format

DN

For OpenLDAP: User
name

The DIGEST-MD5 bind authentication identity
format.

UseUserAccountContro-
lAttribute

For Active Directory:
true

When this property is set to true, the UserAc-
countControl attribute detects disabled user ac-
counts, account expirations, password expira-
tions, and so on. Active Directory also uses this
attribute to store the above information.

EnableLDAPConnection-
Trace

False Enables LDAP connection tracing. The output is
logged to a file in the temp directory. The loca-

tion of the file is logged to the server log.

ConnectTimeout 0 Specifies the timeout, in milliseconds, for at-
tempts to connect to the LDAP server. The prop-
erty value sets the JNDI com.sun.jndi.ldap.con-
nect.timeout property when attempting to estab-
lish a connection to a configured LDAP server. If
the LDAP provider cannot establish a connection
within the configured interval, it aborts the con-
nection attempt. An integer value less than or
equal to zero results in the use of the network
protocol's timeout value.

ReadTimeout 0 Controls the length of time, in milliseconds, the
client waits for the server to respond to a read
attempt after the initial connection to the server
has been established. The property values sets the
JNDI com.sun.jndi.ldap.read.timeout property
when attempting to establish a connection to a
configured LDAP server. If the LDAP provider
does not receive an LDAP response within the
configured interval, it aborts the read attempt. The
read timeout applies to the LDAP response from
the server after the initial connection is establish-
ed with the server. An integer value less than or
equal to zero indicates no read timeout is speci-
fied.
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Property Default Value Description

LDAPPoolMaxActive 8 Caps the number of concurrent LDAP connec-
tions to the LDAP server. A non-positive value
indicates no limit. If this option is set for multiple
LDAP providers, the value set by the first LDAP
provider loaded takes precedence over all the
others. When LDAPPoolMaxActive is reached,
any further attempts by the LDAP provider
classes to borrow LDAP connections from the
pool are blocked indefinitely until a new or idle
object becomes available in the pool. Connection
pooling improves the LDAP provider's perform-
ance and resource utilization by managing the
number of TCP connections established with
configured LDAP servers.

controlFlag optional When you configure multiple authentication pro-
viders, use controlFlag for each provider to con-
trol how the authentication providers are used in
the login sequence.

controlFlag is a generic login module option rath-
er than an LDAP configuration property.

Mapping Sybase Control Center Roles to LDAP or OS Groups
To grant Sybase Control Center privileges to users who are authenticated through LDAP or the
operating system, associate roles used in Sybase Control Center with groups in LDAP or the
operating system.

Prerequisites

• Required: Configure an LDAP authentication module.
• Optional: Create these LDAP groups and assign Sybase Control Center users to them:

• sybase – confers sccUserRole. Assign all SCC users to the sybase group.
• SCC Administrator – confers sccAdminRole. Assign only SCC administrators to this

group.

Task

You can configure Sybase Control Center to enable users to authenticate through their local
operating system or through an LDAP server. To make this type of authentication work, SCC
roles must be mapped to groups that exist in the system providing authentication (LDAP or the
operating system).

The sybase and SCC Administrator groups are convenient because they are predefined in
role-mapping.xml. If you add sybase and SCC Administrator groups to your LDAP
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system and populate them with SCC users and administrators, you can skip to the next task
—you do not need to complete the steps below.

The table lists default mappings of LDAP and OS groups to SCC roles. Login modules are
defined in csi_config.xml.

Login Module OS Group Sybase Control Center Roles

UNIX Proxy root uaAnonymous, uaAgentAdmin, uaOSAdmin

sybase uaAnonymous, uaPluginAdmin, sccUserRole

user uaAnonymous

guest uaAnonymous

NT Proxy Administrators uaAnonymous, uaAgentAdmin, uaOSAdmin

sybase uaAnonymous, uaPluginAdmin, sccUserRole

Users uaAnonymous

Guests uaAnonymous

LDAP sybase uaAnonymous, uaPluginAdmin, sccUserRole

SCC Administrator uaAnonymous, sccAdminRole

There are two ways to accomplish the mapping:

• (Recommended) Add a “sybase” group and an “SCC Administrator” group to the
operating system or LDAP server Sybase Control Center is using to authenticate users, and
add all users who need to access Sybase Control Center to one or both groups.

• Configure Sybase Control Center to use existing groups in LDAP or the operating system
by editing the role-mapping.xml file. This option is described here.

1. If Sybase Control Center is running, shut it down.

2. In a text editor, open:

<SCC-install-directory>/conf/role-mapping.xml
3. Locate the sccUserRole section of the file:

<Mapping>
    <LogicalName>sccUserRole</LogicalName>
    <MappedName>SCC Administrator</MappedName>
    <MappedName>SCC Agent Administrator</MappedName>
    <MappedName>sybase</MappedName>
</Mapping>    

4. Add a MappedName line for the LDAP or OS group you are using to authenticate SCC
users. The sccUserRole section should look similar to this:
<Mapping>
    <LogicalName>sccUserRole</LogicalName>
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    <MappedName>SCC Administrator</MappedName>
    <MappedName>SCC Agent Administrator</MappedName>
    <MappedName>sybase</MappedName>
    <MappedName>my_SCC_group</MappedName>
</Mapping>    

5. Locate the sccAdminRole section of the file:
<Mapping>
    <LogicalName>sccAdminRole</LogicalName>
    <MappedName>SCC Administrator</MappedName>
</Mapping>    

6. Add a MappedName line for the LDAP or OS group you are using to authenticate SCC
administrators. The sccAdminRole section should look similar to this:
<Mapping>
    <LogicalName>sccAdminRole</LogicalName>
    <MappedName>SCC Administrator</MappedName>
    <MappedName>my_SCC_admin_group</MappedName>
</Mapping>    

7. Save the file and exit.

8. (LDAP only) Ensure that the roles defined in the LDAP repository match the roles defined
in role-mapping.xml.

9. In the <SCC-install-dir>\conf\csi_config.xml file, set the BindPassword
and ProviderURL properties with values used in your deployment.

Sybase recommends that you encrypt sensitive values before saving them in
csi_config.xml.

10. Start Sybase Control Center.

See also
• Configuring an LDAP Authentication Module on page 74

Encrypting a Password
Use the passencrypt utility to encrypt passwords and other values that must be kept secure
while stored in text files.

You can safely store an encrypted password in a configuration file. Enter the password in clear
text (unencrypted) when you execute passencrypt and when you use the password to log in.

passencrypt, which is located in the Sybase Control Center bin directory, uses the SHA-256
hash algorithm for passwords used in the PreConfiguredLoginModule in
csi_config.xml.

1. Open a command window and change to the bin directory:

Windows: cd <SCC-install-directory>\bin
UNIX: cd <SCC-install-directory>/bin
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2. To encrypt a password, enter passencrypt -csi. Enter your new password at the resulting
prompt.
passencrypt encrypts the password you enter (which does not appear on the screen) and
displays the password in encrypted form.

3. Copy the encrypted password.

4. Paste the encrypted password where needed.

Configuring Ports
(Optional) Use the scc --port command to assign Sybase Control Center services to new
ports.

Prerequisites
Check for port conflicts between Sybase Control Center and other software running on the
same host.

Task

Sybase Control Center cannot function properly if other services use its ports. If you discover
a conflict with any port listed in the right column below, you can either reconfigure the other
service’s port or reconfigure Sybase Control Center as described here.

Port
Name

Description Service Names Property Names Default
Port

db Database port

Present on SCC server

SccSADataserver

Messaging

Alert

Scheduler

com.sybase.asa.server.port

messaging.db.port

alert.database.port

org.quartz.data-
Source.ASA.URL

3638

http Web HTTP port

Present on SCC server

EmbeddedWebCon-
tainer

http.port 8282

https Web HTTPS (secure
HTTP) port

Present on SCC server

EmbeddedWebCon-
tainer

https.port 8283

jiniHttp JINI HTTP server

Present on SCC server
and SCC agent

Jini httpPort 9092
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Port
Name

Description Service Names Property Names Default
Port

jiniR-
mid

JINI remote method in-
vocation daemon

Present on SCC server
and SCC agent

Jini rmidPort 9095

msg Messaging port

Present on SCC server

Messaging messaging.port 2000

rmi RMI port

Present on SCC server
and SCC agent

RMI port 9999

tds Tabular Data Stream™

port (used to communi-
cate with other Sybase
products)

Present on SCC server
and SCC agent

Tds tdsPort 9998

1. Shut down Sybase Control Center.

2. Execute scc --info ports to display a list of Sybase Control Center services, their
properties, and their assigned ports.

3. To reassign a port, enter a command in one of these formats:
scc --port port-name=port-number
scc --port service-name:property-name=port-number
Use the first, simpler format unless you want to configure the database services to use
different ports. (By default, they all use the same port.)

4. Start Sybase Control Center.

5. Execute scc --info ports again to confirm that the port has been reassigned.

Examples

Set all four database services (data server, messaging, database alert, and scheduler) to the
same port, 3639. (The database is SQL Anywhere®, used by the Sybase Control Center
internal repository.)

scc --port db=3639
Set only the database messaging service to port 3639.

scc --port Messaging:messaging.db.port=3639
Set the HTTP port to 9292.
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scc --port http=9292
Set the Jini RMI daemon to port 9696.

scc --port jiniRmid=9696
Set the main Sybase Control Center messaging service to port 2001.

scc --port msg=2001
Set the RMI port to 9991.

scc --port rmi=9991
Set the Tabular Data Stream port to 9997.

scc --port tds=9997
Note: scc commands that include a port-setting option (-p  or --port) do not start Sybase
Control Center. To start SCC, execute a separate scc command.

See also
• scc Command on page 64

Configuring Sybase Control Center
For configuration instructions, see the Configure section of the help for your Sybase Control
Center product module.
If you have more than one product module installed, follow the configuration instructions for
each module.

Configuring the Automatic Logout Timer
(Optional) Set Sybase Control Center to end login sessions when users are inactive for too
long.

Prerequisites
Launch Sybase Control Center and log in using an account with administrative privileges.
(The login account or its group must have sccAdminRole.)

Task

1. From the application’s menu bar, select Application > Administration.

2. Select General Settings.

3. Click the Auto-Logout tab.

4. Enter the number of minutes after which an idle user will be automatically logged out.

Enter 0 or leave the box empty to disable automatic logout.
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5. Click OK (to apply the change and close the properties dialog) or Apply (to apply the
change and leave the dialog open).

See also
• Launching Sybase Control Center on page 54

• Logging in to Sybase Control Center on page 68

User Authorization
The authorization mechanism in Sybase Control Center employs login accounts and task-
based roles.

Access to Sybase Control Center is controlled by login accounts. You grant permissions to a
login account by assigning predefined roles that control tasks the user can perform in Sybase
Control Center, such as administration and monitoring of particular types of Sybase servers.
The roles can be assigned directly to login accounts or to groups; a login account inherits the
roles of any group to which it belongs. Component product modules assign some roles
automatically.

Sybase Control Center classifies roles as follows:

• System roles – define how a user can interact with Sybase Control Center.
• Product roles – define how a user can interact with a particular managed resource in Sybase

Control Center, for example the Replication Server named RepBoston01.

Note: The tools described here are for managing SCC-enabled login accounts; you cannot use
them to manage accounts and groups that are native to your managed resource.

See also
• Authenticating a Login Account for a Managed Resource on page 102

Assigning a Role to a Login or a Group
Use the security configuration options to add one or more roles to a Sybase Control Center
login account or to a group. Roles enable users to perform tasks such as monitoring servers or
administering Sybase Control Center.

Prerequisites
You must have administrative privileges (sccAdminRole) to perform this task. To assign a
monitoring role for a server, first register the server.

Task
Assign the sccAdminRole to any login account that will perform administrative tasks in
Sybase Control Center.
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1. From the application menu bar, select Application > Administration.

2. In the Sybase Control Center Properties dialog, expand the Security folder.

3. Click Logins or Groups.

4. In the table, select the login account or group to which you want to assign a role.

5. Click the Roles tab.

6. In the Available roles for resource list, select the role, then click Add. For example, to
grant administrative privileges, add the SCC Service:sccAdminRole. To grant monitoring
privileges, add the MonitorRole for the desired server and server type.

Note: Sybase Control Center product modules assign certain roles automatically, so you
might not need to add a MonitorRole.

If a role appears in the Has following roles list, this account or group has already been
configured with that role.

7. Click OK.

See also
• Removing a Role from a Login or a Group on page 91

Removing a Role from a Login or a Group
Use the security configuration options to remove one or more roles from a Sybase Control
Center login acount or from a group.

Prerequisites
You must have administrative privileges to perform this task.

Task

1. From the menu bar, select Application > Administration.

2. In the Sybase Control Center Properties dialog, expand the Security folder.

3. Click Logins or Groups.

4. Select the login account or group from which you want to remove a role.

5. Click the Roles tab.

6. Select the role, then click Remove.

7. Click OK.

See also
• Assigning a Role to a Login or a Group on page 90
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Adding a Group
Use the security configuration options to create a new group.

Prerequisites
You must have administrative privileges (sccAdminRole) to perform this task.

Task
Groups can make roles easier to manage. Rather than assigning roles to individual users,
assign roles to groups and add users to the groups or remove them as needed.

1. From the main menu bar, select Application > Administration.

2. In the Sybase Control Center Properties dialog, expand the Security folder.

3. Select Groups.

4. Click Create Group.

5. Enter a group name and a description.

6. Click Finish.

See also
• Removing a Group on page 92
• Adding a Login Account to a Group on page 93
• Removing a Login Account from a Group on page 93

Removing a Group
Use the security configuration options to remove a group.

Prerequisites
You must have administrative privileges (sccAdminRole) to perform this task.

Task

1. From the main menu bar, select Application > Administration.

2. In the Sybase Control Center Properties dialog, expand the Security folder.

3. Select Groups.

4. Select the group to remove.

5. Click Delete.

6. Click OK to confirm the deletion.

See also
• Adding a Group on page 92
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• Adding a Login Account to a Group on page 93

• Removing a Login Account from a Group on page 93

Adding a Login Account to a Group
Use the security configuration options to add one or more login accounts to a group.

Prerequisites
You must have administrative privileges (sccAdminRole) to perform this task.

Task

1. From the main menu bar, select Application > Administration.

2. In the Sybase Control Center Properties dialog, expand the Security folder.

3. Click Groups.

4. Select the group to which you want to assign an account.

5. Click the Membership tab.

6. Select the account, then click Add.

7. Click OK.

See also
• Adding a Group on page 92

• Removing a Group on page 92

• Removing a Login Account from a Group on page 93

Removing a Login Account from a Group
Use the security configuration options to remove one or more login accounts from a group.

Prerequisites
You must have administrative privileges (sccAdminRole) to perform this task.

Task

1. From the main menu bar, select Application > Administration.

2. In the Sybase Control Center Properties, expand the Security folder.

3. Select Groups.

4. Select the group from which to remove members.

5. Click the Membership tab.

6. Select the login, then click Remove.

7. Click OK.
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See also
• Adding a Group on page 92

• Removing a Group on page 92

• Adding a Login Account to a Group on page 93

Adding a Login Account to the System
Use the security configuration options to create a native login account in Sybase Control
Center.

Prerequisites

• You must have administrative privileges (sccAdminRole) to perform this task.
• If you intend to use LDAP or the operating system to authenticate users, configure the

appropriate authentication module.

Task

Note: Sybase does not recommend that you manually create a native login account for every
Sybase Control Center user. It is more efficient to configure Sybase Control Center to
authenticate users through their user accounts in LDAP or the operating system. When you do
that, SCC automatically creates a native account for every authenticated user.

1. From the main menu bar, select Application > Administration.

2. In the Sybase Control Center Properties dialog, expand the Security folder.

3. Select Logins.

4. Click Create Login.

5. Enter a login name and expiration for the new account. Expiration is optional.

6. Click Next.

7. Select Specify new user information.

8. Enter details about the user:

• Title
• First name*
• M.I. (middle initial)
• Last name*
• Suffix
• E-mail address*
• Phone
• Ext.
• Fax
• Mobile
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• Supports text messaging (checkbox)

*You must fill in the First Name, Last Name, and E-mail Address fields.

9. Click Finish.

Next
Grant privileges to the new login account. You can grant privileges by assigning Sybase
Control Center roles directly to the login accounts, or by assigning the login accounts to
groups and mapping Sybase Control Center roles to the groups. The group approach is
generally more efficient.

Removing a Login Account from the System
Use the security configuration options to delete a Sybase Control Center login account.

Prerequisites
You must have administrative privileges (sccAdminRole) to perform this task.

Task

1. From the main menu bar, select Application > Administration.

2. In the Sybase Control Center Properties dialog, expand the Security folder.

3. Select Logins.

4. Select the login to delete.

5. Click Delete.

6. Click OK to confirm the deletion.

Modifying a User Profile
Use the security configuration options to suspend a login account, impose an expiration date,
or modify the account’s user information.

Prerequisites
You must have administrative privileges (sccAdminRole) to perform this task.

Task

1. From the main menu bar, select Application > Administration.

2. In the Sybase Control Center Properties dialog, expand the Security folder.

3. Select Logins.

4. Select the login account to modify.

5. Click the General tab.
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6. To suspend this account, click Login disabled.

7. To set the date on which this account will stop working, click the calendar icon next to the
Expiration field and select a data.

8. Click Apply.

9. Click the User Info tab.

10. Edit the user information.

When this user configures e-mail alert subscriptions, Sybase Control Center automatically
populates the subscription dialog with the e-mail address you enter here.

11. Click Apply.

Logins, Roles, and Groups
Sybase Control Center includes predefined login accounts and roles.

A login account identifies a user who can connect to Sybase Control Center. An account has
roles that control the tasks the user is allowed to perform. Users can be authenticated through
native SCC accounts, but a safer approach is to delegate authentication to the operating system
or to an LDAP directory service.

Sybase Control Center comes with a predefined login account. Sybase recommends using the
predefined account only for installing and setting up Sybase Control Center. This account is
not intended for use in a production environment.

Table 10. Predefined Login Account

Login Name Description

sccadmin Can use all the administration features in Sybase Control Center. Use for
configuration and test.

A role is a predefined profile that can be assigned to a login account or a group. Roles control
the access rights for login accounts. Sybase Control Center comes with predefined roles that
are intended for use in production environments.

Table 11. Predefined Roles

Role Description

sccUserRole Provides nonadministrative access to Sybase Control Center. Required
for all users and assigned automatically to every authenticated user.

sccAdminRole Provides administrative privileges for managing Sybase Control Center.

Monitoring privileges for SCC product modules are assigned automatically.
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A group is made up of one or more login accounts; all the accounts in a group have the roles
granted to the group. In Sybase Control Center you can create groups to suit your business
requirements.
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Configure

Configure Sybase Control Center for Replication Server Data Assurance Option.

Note: Before configuring Sybase Control Center for use in a production environment,
complete the tasks in the Get Started section of the help. Setting up security is particularly
important.

1. Configuring Data Assurance Server for Monitoring

Authenticate a Data Assurance (DA) server to monitor using Sybase Control Center.
When a resource is authenticated, Sybase Control Center enables the DA server
monitoring option.

2. Registering a Data Assurance Server

Register a resource (for example, a server that can be monitored) to make Sybase Control
Center aware of it and its connection information.

3. Importing Resources for Batch Registration

(Optional) Import and register multiple servers from an interfaces or sql.ini file.

4. Authenticating a Login Account for a Managed Resource

Specify the login account and password Sybase Control Center will use when it connects
to your server or agent to collect monitoring data or manage the resource.

5. Setting Up Statistics Collection

Use the Properties view of your managed resource to create a data collection job and add a
schedule to the job.

6. Creating an Agent Connection

Create a Data Assurance (DA) agent connection required to create comparesets and
schema jobs.

7. Creating a Database Connection

Set up a primary and replicate database connection in a Data Assurance (DA) server.

8. Creating a Single or Cluster Connection from an Interface File

Import Data Assurance (DA) resources from an interface file.

9. Optional Configuration Steps

Perform additional configuration, including user authorization, alerts, data collection
scheduling, backups, and setting purging options for the repository.

See also
• User Authorization on page 49
• Logins, Roles, and Groups on page 96
• Setting Up Security on page 69
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• Assigning a Role to a Login or a Group on page 90

Configuring Data Assurance Server for Monitoring
Authenticate a Data Assurance (DA) server to monitor using Sybase Control Center. When a
resource is authenticated, Sybase Control Center enables the DA server monitoring option.

Registering a Data Assurance Server
Register a resource (for example, a server that can be monitored) to make Sybase Control
Center aware of it and its connection information.

1. In the Resource Explorer, select Resources > Register.

2. Specify:

Field Description

Resource Name (Required) Name of the resource to register. Enter the actual
name of the managed server, using uppercase and lowercase
letters. If the name registered in Sybase Control Center does not
exactly match the server name, some monitoring functions, in-
cluding the topology view, do not work.

Resource Type Select a resource type:
• Data Assurance Server – monitor Data Assurance server.

Description A brief description to help you identify the resource.

3. Click Next.

4. Specify the connection information for your resource:

Field Description

Host Name Local host name

Port Number Local host port number

5. (Optional) Enter a user name and password that SCC can use to authenticate with this
resource to retrieve its software version. The credentials are used only for this purpose,
then discarded.

If you prefer not to authenticate now, click I do not want to supply authentication
information.

This step enables SCC to display the correct version information for the server before the
server is formally authenticated (later in the configuration process).
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6. Click Next.

7. (Optional) Click Add this resource to the current perspective. You must add a resource
to a perspective (not necessarily the current perspective) before you can manage or
monitor it.

8. (Optional) Click Open the resource explorer to view this new resource. (This option is
not present when the Resource Explorer is open.)

9. Click Finish.

See also
• Common Display Options on page 5

• Resources on page 135

• Unregistering a Resource on page 136

Importing Resources for Batch Registration
(Optional) Import and register multiple servers from an interfaces or sql.ini file.

Prerequisites
Copy the interfaces or sql.ini file to a location on or accessible from the machine that
hosts your Web browser.

Task

An interfaces (UNIX) or sql.ini file (Windows) is a list of Sybase servers and their
ports; it may contain other connection information as well. The file is created during the
installation of a Sybase server:

• Windows: %SYBASE%\ini\sql.ini
• Unix: $SYBASE/interfaces
For more information on interfaces files, see the appendix on configuration files in
Configuration Guide Open Client and Open Server 15.0 for UNIX.

For more information on sql.ini files, see the chapter on network communications using
sql.ini in the Adaptive Server Enterprise 15.0 Configuration Guide for Windows.

Note: The Import Resources wizard imports servers in batches of a single type (Adaptive
Server, SAP® Sybase® IQ, or Replication Server, for example). If your interfaces or
sql.ini file includes resources of more than one type, you must perform this procedure for
each resource type.

1. In the application menu, select View > Open > Resource Explorer.

2. In the Resource Explorer, select Resources > Import.
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The Import Resources wizard opens; Interfaces file is already selected.

3. Click Next.
The Directory Service Connection page appears.

4. Click Browse and navigate to the interfaces file you want to import from.

You cannot type in the File name field.

5. Click Next.

6. On the Import Resource Type page, select the type of server you want to import.

7. On the Resource Selection page, click to select the servers you want to import.

Select only servers of the type you chose on the Import Resource Type page. If you import
servers with incorrect types, Sybase Control Center will not be able to monitor or manage
them properly.

8. Resources of your chosen type may require connection parameters in addition to those
present in the file—RSSD host name and port for Replication Server, for example, or
character set and language for Adaptive Server. Enter any required connection parameters.

9. Click Next.

10. (Optional) Click Add these resources to the current perspective. You must add a
resource to a perspective (not necessarily the current perspective) before you can manage
or monitor it.

11. Click Next.
The Confirmation page displays a list of the resources you have selected.

12. Click Finish if you are ready to import, or click Back to return to the previous screens and
change your selections.
When you click Finish, Sybase Control Center imports and registers the resources and
displays a summary page.

13. Click Close to finish the wizard.

The newly imported resources appear in the Resource Explorer. If you elected to add them to
the current perspective, the resources also appear in the Perspective Resources view.

See also
• Resources on page 135

• Unregistering a Resource on page 136

Authenticating a Login Account for a Managed Resource
Specify the login account and password Sybase Control Center will use when it connects to
your server or agent to collect monitoring data or manage the resource.

Perform this task for each resource registered with Sybase Control Center.
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Note: You can also authenticate a server during administrative tasks like creating an alert or a
collection job.

1. Connect a browser to Sybase Control Center and log in.

2. If the Perspective Resources view is not open, click the Show/Hide Perspective
Resources View icon in the toolbar.

3. In the Perspective Resources view, select your resource and select Resource >
Authenticate from the view menu.

4. Select Use my current SCC login or Specify different credentials.

5. If you chose Specify different credentials, enter the login and password for Sybase
Control Center to use to connect to your resource.

6. If the selected resource is a Replication Server, also enter the RSSD user name and
password.

7. Click OK to save and exit the dialog.

See also
• User Authorization on page 90

Setting Up Statistics Collection
Use the Properties view of your managed resource to create a data collection job and add a
schedule to the job.

Statistics gathering consumes system resources intensively; the more collection jobs you run,
the greater the burden on your server. For best performance, Sybase recommends these
guidelines for scheduling data collection jobs:

• Schedule only one collection job for each collection.
• Set the collection interval to 5 minutes or more. (The default is 5 minutes.)

Data collections for a managed resource do not run until the resource is authenticated.

1. In the Perspective Resources view, select a resource, click its drop-down arrow, and select
Resource > Properties.

2. Select Collection Jobs.

3. Click Create Job.

4. If this resource has not yet been authenticated, you see the Authentication page. Enter a
user name and password that Sybase Control Center can use to log in to the resource. Click
Authenticate to verify your credentials. Data collections can run only on an authenticated
resource.

5. On the Collection Information page, select the data collection that this job will run.
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6. (Optional) If you do not want SCC to save data collected for this job in the repository,
unselect Save data collected from this job.

If you choose not to save collection data, SCC updates any open views (the heat chart or a
resource monitor, for example) when the job runs. If the job runs when no views are open,
the data is not captured.

This option cannot be modified once the job is created. If you need to change it, drop the
data collections and add it again.

7. Click Next.

8. (Optional) If you do not want to create a schedule yet, unselect Create a schedule for this
job.

9. Specify details for the new schedule:

Field Description

Name A name for this schedule

Description A description of this schedule

10. Choose to start the job Now or Later. If you choose Later, specify the start date and time.

11. Specify the duration of this schedule. The job can run:

• Once
• Repetitively at an interval you specify

Field Description

Repeat interval Time period (in seconds, minutes, hours, or days) between job
executions

• Until a stop date that you specify, at an interval you specify

Field Description

Repeat interval Time period (in seconds, minutes, hours, or days) between job
executions

Stop date Date and time the job should stop running

Note: Enter dates and times using your local time. Sybase Control Center converts
your times for remote time zones if necessary.

You cannot change the duration of a schedule (the once/repetitively/until setting) after you
create it. To change the schedule duration, delete and recreate the schedule.

12. Click Finish.

See also
• Creating an Agent Connection on page 106
• Job Scheduling on page 132
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• Viewing or Deleting a Schedule on page 134

About Statistics
Understand availability and performance statistics in Sybase Control Center.

The statistics you work with in Sybase Control Center can be divided into two types:

• Availability statistics are concerned with present conditions; they help you determine
whether a resource you are monitoring (a server or an agent, for example) is running and
functioning properly.

• Performance statistics are concerned with behavior of the same resources over time. They
describe the flow of data through your environment. You can use performance statistics to
spot trends, identify problems like resource bottlenecks, and make plans.

Sybase Control Center includes predefined key performance indicators (KPIs) for each
product module; these KPIs are grouped into collections. KPIs such as server status, which
serves as an availability statistic when it is fresh, have long-term value as historical
performance statistics.

Availability statistics appear on the heat chart and on resource monitoring screens in each
product module.

Performance statistics appear on the statistics chart and on resource monitoring screens in
each product module.

Some KPIs are included in the default collection for each product module. To make other KPIs
available to the heat chart, statistics chart, and resource monitoring views, you must set up
collection jobs in the scheduler. See the data collections help topic for information on data
collections and the KPIs contained in them.

Several configuration options affect the collection and display of data in Sybase Control
Center:

• Collection repeat interval—The frequency of data collection. Set this on the collection job
in the scheduler.

• Screen refresh interval—The period between screen refreshes. Refreshing the screen
redraws it with the newest available data. Set the screen refresh interval in the product
module. (May not be settable in all product modules.)

• Chart trend period—The period over which data is displayed in historical charts. Set the
trend period in the product module. (May not be settable in all product modules.)

Data Collections for Replication Server Data Assurance Option
Data collection for Sybase Control Center for Data Assurance (DA) collects high-level server
and agent information.

You may schedule collection of DA data through either a default or predefined data collection.
Sybase Control Center sets up a default data collection called collection_da_overview when a
DA server is authenticated.
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See also
• Job Scheduling on page 132

Key Performance Indicators for Data Assurance
Key performance indicators (KPIs) provide the statistics that appear on Data Assurance (DA)
server dashboards and charts in Sybase Control Center.

The KPIs used in the Data Assurance default data collection, collection_da_overview
include:

KPI Description

Server CPU Utilization The server's overall CPU usage, which is presented in percentages.

Server Memory Utilization The server's overall memory usage, which is presented in percen-
tages.

Agent CPU Utilization The agent's overall CPU usage, which is presented in percentages.

Resource State The state of the resource, which includes Running, Stopped, and
Unknown.

Agent Memory Utilization The agent's overall memory usage, which is presented in percen-
tages.

States for Data Assurance Server, Agents, and Database Connection
States are used on the dashboards, heat chart, and topology icons.

State Description

Running The DA object is in Active state.

Stopped DA object has been stopped.

Unknown The state of the DA object cannot be determined.

Creating an Agent Connection
Create a Data Assurance (DA) agent connection required to create comparesets and schema
jobs.

1. In the Perspective Resources view, select a DA server.

2. Select Resource  > Administration Console.

3. Expand Data Assurance Server, then select Data Assurance Agent Connections.

4. Either:
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• Select Folder > Create Agent Connection, or,
• Click the button that appears when you select Data Assurance Agent Connections, then

select Create Agent Connection.

5. Specify the agent connection information:

Field Description

Data Assurance server (Required) Name of the DA server from the drop-down list.

Name (Required) Name of the agent connection. Space is not allowed.

Host (Required) Name of the server where the DA agent is installed.

Port (Required) Port number of the DA agent.

Username (Required) DA agent username.

Password (Required) DA agent password.

Description A brief description to help you identify the agent connection.

6. (Optional) Click Test to verify if the provided agent connection information is correct.

7. Click OK.

The new agent connection profile appears in the Data Assurance Agent Connections table.

See also
• Setting Up Statistics Collection on page 103

• Data Assurance Agents on page 153

• Editing an Agent Connection on page 153

• Deleting an Agent Connection on page 154

• Viewing All Agent Connection on page 154

• Testing an Agent Connection on page 154

Creating a Database Connection
Set up a primary and replicate database connection in a Data Assurance (DA) server.

1. In the Perspective Resources view, select a DA server.

2. Select Resource  > Administration Console.

3. Expand Data Assurance Server, then select Database Connections.

4. Either:

• Select Folder > Create Database Connection, or,
• Click the button that appears when you select Database Connections, then select

Create Database Connection.
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5. Specify the database connection information:

Field Description

Data Assurance server (Required) Name of the DA server from the drop-down list.

Name (Required) Name of the database connection. Space is not al-
lowed.

Description A brief description to help you identify the database connection.

Type (Required) Database type, which includes Adaptive Server En-
terprise (ASE), ASE Cluster, Replication Server System Data-
base (RSSD), Oracle, IQ, and HANADB

Agent (Required) The DA agent to use in connecting to the database. It
can be a local agent that comes with the DA server installation, a
remote agent that is defined in the Data Assurance Agent Con-
nections, or a new remote agent that has yet to be defined.

Database (Required) Name of the database to connect to.

Host (Required) Name of the server where the database is residing.

Port (Required) Port number of the database.

Username (Required) database username.

Password Database password.

Properties The properties for JDBC connection.

Note: Enter a number of extra JDBC properties to support SSL
connections to Adaptive Server.

6. (Optional) Click Test to verify if you have specified the correct database information.

7. Click OK.

The new database connection appears in the Database Connections table.

See also
• Database Connections on page 155

• Editing a Database Connection on page 155

• Deleting a Database Connection on page 156

• Viewing All the Database Connection Profiles on page 157

• Testing a Database Connection on page 157
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Creating a Single or Cluster Connection from an Interface
File

Import Data Assurance (DA) resources from an interface file.

1. In the Perspective Resources view, select a DA server.

2. Select Resource  > Administration Console.

3. Expand Data Assurance Server, then select Database Connections.

4. Either:

• Select Folder > Import Connection, or,
• Click the button that appears when you select Database Connections, then select

Import Connection.

5. Browse through your local drive, select an interface or sql.ini file, then click Next or
Import Resource Type.

6. Specify the DA server and resource type to use, then click Next or Resource Selection.

7. Select the resources to import and the agent that this connection is using, specify the
username and password to connect to the selected agent, then click Next or Confirm.

Note: The password field is not required.

8. Click Finish.

See also
• Database Connections on page 155

• Editing a Database Connection on page 155

• Deleting a Database Connection on page 156

• Viewing All the Database Connection Profiles on page 157

• Testing a Database Connection on page 157

Optional Configuration Steps
Perform additional configuration, including user authorization, alerts, data collection
scheduling, backups, and setting purging options for the repository.
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Table 12. Configuration areas

Configuration area Description Topic

User authorization Set up groups of users or assign roles.
Make sure there are users with adminis-
trative privileges (sccAdminRole).

User Authorization on page
90

Authentication Add authentication modules to allow
Windows, UNIX, and LDAP users to log
in to Sybase Control Center.

Setting up Security on page
69

Data collection Modify collection intervals and sched-
ules, suspend and resume the schedule,
and delete collection jobs.

Job Scheduling on page 132

Resources Unregister resources, add them to per-
spectives, or remove them.

Resources on page 135

Perspectives Create, remove, and rename perspectives. Perspectives on page 138

Repository Set purging options and schedule backups
of the repository database.

Repository on page 141
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Compare Data Rows and Schemas

Compare row data and schema between two or more Adaptive Server databases, and view
discrepancies.

Comparesets
Comparesets, which consist of sets of tables and columns, define the data being compared in a
particular job.

A compareset includes:

• Tables to compare
• Key columns that uniquely define a row
• Columns to compare
• A WHERE clause that defines which rows to compare

Source and target tables and columns need not use the same name in a compareset. Each
compareset must have one source and one or more targets, and can be used by any number of
jobs.

Creating a Compareset
Create a compareset, which includes the database connection profile, and the source and target
tables to be compared.

Prerequisites
Verify that you have created an agent connection.

Task

1. In the Perspective Resources view, select a Data Assurance server.

2. Select Resource  > Administration Console.

3. Expand Data Assurance Server, then select Data Assurance Comparesets.

4. Either:

• Select Folder > Create Compareset, or,
• Click the button that appears when you select Data Assurance Comparesets, then click

Create Compareset.

5. Specify the compareset basic information, and click Next or Source Table.
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Field Description

Data Assurance server (Required) Name of the DA server from the drop-down list.

Name (Required) Name of the compareset.

Description A brief description to help you identify the compareset.

6. Select from existing database connections or click New to create a new one.

7. Select a schema and a database table.

8. Select the columns to compare.

9. (Optional) Specify contraints to control the comparison job.

10. Click Next or Target Table(s).

11. Repeat the same steps performed for the source table.

12. (Optional) Click Add Target to define a new target table to compare with the source table.

Note: You can compare a source table to one or more target table.

13. Click Finish.

See also
• Data Assurance Agents on page 153

• Creating an Agent Connection on page 106

• Creating a Database Connection on page 107

• Creating a Row Comparison Job on page 114

Editing a Compareset
Modify the details of an existing compareset.

Prerequisites
Verify that the compareset you are modifying is not being used in an executing job.

Task

1. In the Perspective Resources view, select a Data Assurance server.

2. Select Resource  > Administration Console.

3. Expand Data Assurance Server, then select Data Assurance Comparesets.

4. Select a compareset, then either:

• Select Resource > Properties, or,
• Click the button that appears when you select a compareset, then select Properties.

5. Modify the source and the target tables' details as required.
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You also have the option to map the source table to another target table.

6. Click Apply, then click OK.

See also
• Creating a Database Connection on page 107

• Creating a Row Comparison Job on page 114

• Viewing a Data Assurance Job Status and Report on page 125

Deleting a Compareset
Remove a compareset from the list.

Prerequisites
Verify that the compareset you are deleting is not being used in an executing job.

Task

1. In the Perspective Resources view, select a Data Assurance server.

2. Select Resource  > Administration Console.

3. Expand Data Assurance Server, then select Data Assurance Comparesets.

4. Select a compareset, then either:

• Select Resource > Delete, or,
• Click the button that appears when you select a compareset, then select Delete.

5. Click OK.

See also
• Viewing a Data Assurance Job Status and Report on page 125

Viewing All Comparesets
Display all Data Assurance (DA) server comparesets.

1. In the Perspective Resources view , select a DA server.

2. Select Resource  > Administration Console.

3. Expand Data Assurance Server, then select Data Assurance Comparesets.

Viewing Data Partition Boundaries
Display the data partition boundaries, which Data Assurance stored for each comparesets.

1. In the Perspective Resources view, select a DA server.

2. Select Resource  > Administration Console.
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3. Expand Data Assurance Server, then select Data Assurance Comparesets.

4. Select a compareset.

5. Click the button that appears when you select a compareset, then select Boundaries....

Data Assurance Jobs
A Data Assurance (DA) job can be a row comparison or a schema comparison.

When creating a row comparison job you specify the compareset to use and set the schedule
for running the job. You can set to run a row comparison job based on days, weeks, or months,
or you can run it manually. The schema comparison job is run manually and cannot be
scheduled.

You can also create a row comparison job based on Replication Server system database
(RSSD) by importing table-level replication definition and subscription from an RSSD in a
Replication Server.

See the Replication Server Data Assurance Option Users Guide > Replication Server Data
Assurance Option > Jobs and Comparisons.

Row Comparison Jobs
A row comparison sorts rows by a primary or a unique key, from all participating database
tables and compares them one by one. A comparison summary is stored in the Data Assurance
System Database (DASD). Detailed text or XML reports showing the row differences are
stored in the data directory.

In a row job, you create a comparison object, then add a compareset to that particular
comparison, set the various comparison parameters, and set the time when the comparison
must take place.

Creating a Row Comparison Job
Set up a row comparison job.

Prerequisites
Verify that you have created a compareset.

Task

1. In the Perspective Resources view, select a Data Assurance server.

2. Select Resource  > Administration Console.

3. Expand Data Assurance Server, then select Data Assurance Jobs.

4. Either:

• Select Folder > Create Job, or,
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• Click the button that appears when you select Database Assurance Jobs, then select
Create Job.

5. Specify the row comparison job basic information:

Field Description

Data Assurance server (Required) Name of the DA server from the drop-down list.

Name (Required) Name of the row comparison job.

Active Indicates that the row job can be run if selected.

Description A brief description to help you identify the row comparison job.

6. Click Next or Option.

7. Enter the value for the maximum concurrent jobs.

This is the maximum number of jobs you want to run at the same time.

8. Click Next or Comparison.

9. Specify the general information for the current comparison you are setting up.

Field Description

Name (Required) Name of the comparison in a row comparison job.

Active Indicates that the comparison job can be run if selected.

Description A brief description to help you identify the comparison.

Priority Priority level for the comparison.

Compareset Name of the predefined compareset, which has the source and
target tables to compare.

Note: You can create more than one comparison to a row comparison job, but doing so may
result in slow performance. To do this, click Add Comparison.

10. (Optional) In the Comparison Options tab, modify or accept the default value for the
comparison options.

11. (Optional) In the Column Options tab, modify or accept the default values on the column
options for each column from the compareset.

12. (Optional) Click Next or Schedule.

13. (Optional) Click With Schedule (s) to set the schedule for this row comparison job. Or you
can set the schedule later or run it manually.

14. Click Finish.

See also
• Comparesets on page 111
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Comparison and Column Options
Be familiar with the comparison and column options provided for creating a row job.

Table 13. Comparison Options

Field Description

Abort condition (rows): Aborts row comparison if the difference count exceeds
the specified value.

Valid values: 1 to 9223372036854775807.

Default value:1000.

Abort row count mismatch: Determines whether to abort row comparison if table
row counts do not match.

Valid values: true or false.

Default value: false.

Auto reconciliation: Indicates whether to automatically apply the reconci-
liation script.

Valid values: true or false.

Default value: false.

Note: To enable AUTO_RECONCILE, set CRE-

ATE_COL_LOG to true.

Compare mode: Specifies the row comparison mode.

• row_compare – compares all table rows.

• key_compare – compares the primary key

columns.

• row_count – compress row count.

Default value: row_compare.

Compress row data: Compresses the row data between the agent and the
server.

Valid values: true or false.

Default value: false.
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Field Description

Create column log: Generates a column differences log, which lists all
missing, orphaned, and inconsistent row values (keys
and columns). Create a column log if you want to:

• Generate a reconciliation script

• Perform automatic reconciliation

• Generate a detailed report

Valid values: true or false.

Default value: false.

Create reconciliation script: Generates a reconciliation script. To use this parame-
ter, you must also set CREATE_COL_LOG to true.

Valid values: true or false.

Default value: false.

Enable row count: Determines whether or not to count source and target
table rows before they are compared. DA server uses
the row count to estimate the comparison progress and
end time.

Note: DA server counts rows if COMPARE_MODE is
row_count. Use ENABLE_ROW_COUNT only if COM-

PARE_MODE is a value other than row_count.

Valid values: true or false.

Default value: true.

External sort: Sorts rows on the agent, thereby reducing the impact of
processing the ORDER BY clause in the databases.

Valid values: true or false.

Default value: false.
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Field Description

Hash type: Specifies the hash type for the comparison.

• database_hash – use the hash function pro-

vided by the database.

• agent_hash – use the hash function provided

by Replication Server Data Assurance Option.

Note: Set the hash type comparison option to
agent_hash for heterogeneous comparison. The

database_hash comparison option is used only

for Adaptive Server-to-Adaptive Server comparisons.

Maximum retry: Specifies the total number of recomparison for rows
that have differences resulting from a previous com-
parison.

Valid values: 0 to 100.

Default value: 3.

Partitions: Specifies the number of partitions for a table.

Note: This number of partitions needs to be greater
than 0 and cannot be set higher than the maximum
value of 1024.

Default value: 1

Retry option: Specifies the retry option.

• never – no recompare.

• wait_and_retry – run recompare based on

RETRY_MAX and RETRY_DELAY_SEC settings.

Default value: never.

Retry delay (seconds): Specifies the number of seconds delay for each recom-
parison.

Valid values: 0 to 86400.

Default value: 10.
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Table 14. Column Comparison Option

Column Option Value

Compare mode: Specifies for how each column is compared.

• column_hash – compares using column hash
value.

• row_hash – compares all columns with this
option together with a whole hash value.

• literal – compares using column literal value.

Editing a Row Comparison Job
Modify details of a Data Assurance (DA) row comparison job.

1. In the Perspective Resources view, select a DA server.

2. Select Resource  > Administration Console.

3. Expand Data Assurance Server, then select Data Assurance Job.

4. Select a row comparison job, then either:

• Select Resource > Properties, or,
• Click the button that appears when you select a row comparison job, then select

Properties.

5. Modify the job information on the General, Comparisons, Options, and Schedules tabs as
required.

To modify details in Comparisons tab:

a) Select a comparison, click the button that appears, then select Properties.
b) Modify the comparison information on the General, CompareSet, and Options tabs as

required.

Click Apply after every modifications in each tab in the Comparisons tab, then click
OK.

6. Click Apply, then click OK.

Scheduling a Row Comparison Job
Schedule a Data Assurance (DA) row comparison job.

1. In the Perspective Resources view, select a DA server.

2. Select Resource  > Administration Console.

3. Expand Data Assurance Server, then select Data Assurance Jobs.

4. Select a row comparison job, then either:

• Select Resource > Properties, or,
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• Click the button that appears when you select a row comparison job, then select
Properties.

5. Select Schedules, click the button that appears, then click Create Schedule.

6. Set the time and day to run this job.

7. Click Apply, then click OK.

Creating a Job Based on Replication Server System Database
Create a Data Assurance (DA) job based on an existing table-level replication definition and
subscription in a Replication Server.

Prerequisites
Verify that you have created a Replication Server system database (RSSD) connection.

Task

1. In the Perspective Resources view, select a DA server.

2. Select Resource  > Administration Console.

3. Expand Data Assurance Server, then select Data Assurance Jobs.

4. Either:

• Select Folder > Import Job from RSSD, or,
• Click the button that appears when you select Database Assurance Jobs, then select

Import Job from RSSD.

5. Specify the job's basic information.

Field Description

Data Assurance server (Required) Name of the DA server from the drop-down list.

Name (Required) Name of the RSSD job.

RSSD connection (Required) RSSD connection that you want to use, created on
the Database Connection.

To choose a Replication Server system database (RSSD) con-
nection, click Select.

Description A brief description to help you identify the job based on RSSD.

Maximum concurrent jobs Maximum number of RSSD jobs that you want to run at the same
time.

Priority for comparison(s) Priority level.

6. Click Next or Source DB Mappping.

7. Select the source database information in RSSD and database connection in DA server.
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Note: The Selected check box filters the comparison generation. Only the replication
definition whose primary database argument is in the selected database set will be used to
generate a comparison.

8. Click Next or Target DB Mapping.

9. Select the target database information in RSSD and database connection in DA server.

Note: The Selected check box filters the comparison generation. Only the subscription
whose replicate database argument is in the selected database set will be used to generate
target argument in the auto-generated comparison.

10. Click Next or Comparisons Options.

11. Specify the comparison options.

12. (Optional) Click Next or Schedule.

13. Click Finish.

See also
• Comparison and Column Options on page 116

• Creating a Database Connection on page 107

Schema Comparison Jobs
Schema comparison lets you compare the schema of one primary database against one or more
replicate databases. You can compare an entire database schema using automatic table name
mapping, or you can compare specific tables using table name mapping.

Creating a Schema Comparison Job
Set up a schema comparison job to compare database- and table-level objects in Data
Assurance (DA) server.

Prerequisites
Verify that you have created an agent connection.

Task

1. In the Perspective Resources view, select a DA server.

2. Select Resource  > Administration Console.

3. Expand Data Assurance Server, then select Data Assurance Jobs.

4. Either:

• Select Folder > Create Schema Job, or,
• Click the button that appears when you select Data Assurance Jobs, then select Create

Schema Job.
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5. Specify the schema job basic and option information.

Field Description

Data Assurance server (Required) Name of the DA server from the drop-down list.

Name (Required) Name of the schema comparison job.

Description A brief description to help you identify the schema comparison
job.

Maximum concurrent jobs (Required) Maximum number of schema comparison jobs that
you want to run at the same time.

6. Click Next or Comparisons.

7. Click Create to specify the comparisons for the schema job.

8. Provide the comparison's basic information.

9. Click Next or Data Sources.

10. Click Select Source.

11. Select a database connection profile for the source data, then click OK.

12. Click Add Target.

Note: You can add multiple target databases.

13. Select a database connection profile for the target data, then click OK.

14. Click Next or Include All Tables.

15. Select Include all tables.

16. (Optional) Click Add Table to be excluded from the schema comparison.

17. Click Next or Map Tables.

18. (Optional) Click Add Mapping to specify the source and target table mapping for the
schema comparison.

Note: Set at least one attribute—include-all or table mapping—for one schema
comparison. Table mapping allows you to compare schema of tables with different name.

19. Click Finish twice.

See also
• Data Assurance Agents on page 153
• Comparison and Column Options on page 116
• Deleting a Data Assurance Job on page 124
• Running a Data Assurance Job on page 123
• Viewing All Data Assurance Jobs on page 124
• Viewing a Data Assurance Job Status and Report on page 125
• Creating an Agent Connection on page 106
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Editing a Schema Comparison Job
Modify a Data Assurance (DA) schema comparison job details.

1. In the Perspective Resources view, select a DA server.

2. Select Resource  > Administration Console.

3. Expand Data Assurance Server, then select Data Assurance Jobs.

4. Select a schema comparison job, then either:

• Select Resource > Properties, or,
• Click the button that appears when you select a schema comparison job, then select

Properties.

5. Modify the schema job information on the General, Comparisons, and Options tabs as
required.

To modify details in Comparisons tab:

a) Select a schema comparison, click the button that appears, then select Properties.
b) Modify the schema comparison information on the General, Data Source, Include All

Tables, and Map Tables tabs as required.

Click Apply after every modifications in each tab, then click OK.

6. Click OK.

See also
• Comparison and Column Options on page 116

• Deleting a Data Assurance Job on page 124

• Running a Data Assurance Job on page 123

• Viewing All Data Assurance Jobs on page 124

• Viewing a Data Assurance Job Status and Report on page 125

Manage and Run Data Assurance Jobs
Run Data Assurance jobs and view reports, job status and job history.

Running a Data Assurance Job
Run a Data Assurance (DA) row comparison or a schema comparison job.

1. In the Perspective Resources view, select a DA server.

2. Select Resource  > Administration Console.

3. Expand Data Assurance Server, then select Data Assurance Jobs.

4. Select a row or schema comparison job, then either:

Compare Data Rows and Schemas

Sybase Control Center for Data Assurance 123



• Select Resource > Run, or,
• Click the button that appears when you select a row or schema comparison job, then

select Run.

Deleting a Data Assurance Job
Remove a Data Assurance (DA) row comparison or a schema comparison job.

1. In the Perspective Resources view, select a DA server.

2. Select Resource  > Administration Console.

3. Expand Data Assurance Server, then select Database Assurance Jobs.

4. Select a row comparison or a schema comparison job, then either:

• Select Resource > Delete, or,
• Click the button that appears when you select a row comparison or schema comparison

job, then select Delete.

5. Click OK.

Deleting a Comparison in Data Assurance Job
Delete a comparison in a row or schema comparison job.

1. In the Perspective Resources view, select a DA server.

2. Select Resource  > Administration Console.

3. Expand Data Assurance Server, then select Database Assurance Jobs.

4. Select a row comparison or a schema comparison job, then either:

• Select Resource > Properties, or,
• Click the button that appears when you select a row comparison or schema comparison

job, then select Properties.

5. Select Comparisons.

6. Select a comparison, click the button that appears, then click Delete Comparison.

Viewing All Data Assurance Jobs
Display a list of all the Data Assurance (DA) row comparison and schema comparison jobs.

1. In the Perspective Resources view, select a DA server.

2. Select Resource  > Administration Console.

3. Expand Data Assurance Server, then select Data Assurance Jobs.
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Viewing a Data Assurance Job Status and Report
Check if a Data Assurance (DA) job is running, pending, finished or aborted, and show report
for missing, orphaned, and inconsistent data.

1. In the Perspective Resources view, select a DA server.

2. Select Resource > Monitor.

3. In the Data Assurance Monitor, select Job Status.

4. (Optional) Click Abort to stop a running job.

Data Assurance Job History
Data Assurance (DA) job history includes a list of executed jobs with the corresponding time
they were submitted and completed.

You can also view a report of these jobs, which you can save as text or XML format.

Viewing a Job History Report
View the list of completed Data Assurance (DA) jobs, and display their corresponding report.

1. In the Perspective Resources view, select a DA server.

2. Select Resource  > Administration Console.

3. Select Data Assurance Job Histories.

4. Select a DA job, click the button that appears, then select Report.

Deleting a Job History
Remove a job history to clear server space.

1. In the Perspective Resources view, select a Data Assurance (DA) server.

2. Select Resource  > Administration Console.

3. Select Data Assurance Job Histories.

4. Select a DA job, then either:

• Select Resource > Delete, or,
• Click the button that appears when you select a DA job, then select Delete.

5. Click OK.
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Manage and Monitor

Sybase Control Center allows you to manage and monitor resource availability and view
statistics information.

Heat Chart
The heat chart displays status and availability statistics for managed resources in the current
perspective.

The heat chart displays the state of resources in your perspective—whether the resources are
running, suspended, or down. In addition, the heat chart lists the type of each resource and
provides statistical data, including the start time of the last data collection.

In the Perspective Heat Chart view, you can filter the resources that you want to see and search
and sort the results by column. You can also select a resource and pull down its context menu to
see monitoring and administrative options that vary based on the resource type.

Heat chart data is collected directly from managed servers, tagged with the date and time when
it was collected, and stored in the Sybase Control Center repository.

Displaying Resource Availability: the Heat Chart
Use the heat chart to view the status and availability of servers in the current perspective.

The heat chart displays the state of resources in your perspective—whether the resources are
running, suspended, or down. In addition, the heat chart lists the type of each resource and
provides statistical data, including the start time of the last data collection.

You can filter the resources that you want to see and search and sort the results by column. You
can also select a resource and pull down its context menu to see monitoring and administrative
options that vary based on the resource type.

Heat chart data is collected directly from managed servers, tagged with the date and time when
it was collected, and stored in the Sybase Control Center repository.

1. From the application menu bar, select View > Open > Heat Chart.

2. (Optional) To display information about the status represented by an icon in the chart,
hover the mouse over the icon.

• Status column – icon tooltips describe the status of the resource (Running or Stopped,
for example).

• All columns to the right of Status – icon tooltips give the value of the KPI listed at the
top of the column.
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3. (Optional) To display tools for filtering (narrowing the list of resources in the heat chart) or
changing the columns, select View > Filter from the Perspective Heat Chart menu bar.
The Filter and Column tools appear in the left pane.

4. (Optional) To use filtering, select View > Filter from the view’s menu bar and enter a
search term in the Filter string field.

The search term can be any string that appears in the tabular portion of the heat chart, such
as the name, or part of the name, of a server or a resource type (ASE Server, for example).

5. (Optional) Select a filtering setting:

• Match case – search for resources whose displayed data includes the search term,
including uppercase and lowercase letters; or

• Exact match – search for resources whose displayed data includes an item identical to
the search term.

6. (Optional) Select a column from the Filter on list to restrict your search to that column.

7. (Optional) Click Columns to customize your heat chart.

8. (Optional) Unselect any column that should not appear in your heat chart.

9. (Optional) Click the sorting arrow in the column headers to sort the column values in either
ascending or descending order.

10. (Optional) Click the resource’s row and pull down the menu to the right of the resource
name to view options for the selected resource.

11. (Optional) To resize the Filter and Columns tools pane, move your mouse over the border
between the tools pane and the resource table. When the mouse cursor changes to a resize
icon, click and drag the border to the left or the right.

12. (Optional) To hide the Filter and Columns tools, unselect View > Filter.

Historical Performance Monitoring
Monitor performance data to determine whether your environment is working efficiently.

Obtain detailed information about the status of the resources in your environment. You can
create performance graphs that illustrate resource performance over a specified period of
time.

Graphing Performance Counters: the Statistics Chart
To show performance trends, generate a graph for any set of performance counters over a
specified period of time.

Prerequisites
Verify that statistical data to be graphed has been collected. To verify data collection, go to the
Collection Jobs page of the Resource Properties view and check the History tab for a
collection job. You can also look at the resource monitor: if data appears there, data is being
collected.
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Task

Tip: Data collections start running when a resource is authenticated. A recently authenticated
resource might not have accumulated enough data to make a useful graph.

1. In the Perspective Resources view, click a resource and select Resource > Statistics
Chart in the view menu bar.

2. Expand the folders in the Statistics tab and select the key performance indicator (KPI) you
want to graph.

3. Click Graph Statistic or drag the KPI onto the Chart tab.
The Chart tab displays the graphed data, while the KPI with its corresponding value and
the date and time it was collected appear in the Data tab.

4. (Optional) Repeat to add KPIs to the graph.

5. (Optional) Use the slider at the bottom of the Chart tab to control the amount of time
covered by the graph, ranging from a minute to a year.

6. (Optional) Use <<, <, >, and >> to move the displayed graph to an earlier or later time.
Increments depend on how the slider is set.

Tip: The statistics chart displays data covering a fixed period of time, and that period does
not change automatically. If you are viewing the most recent statistics and want to keep the
graph current, adjust the displayed time period as new statistics are collected.

7. (Optional) You can click the date/time labels that appear above the slider. Use these to
change the start and end time and the chart time span.

8. (Optional) Click Clear Graph to remove all the graphed statistics and start anew.

Note: You can graph a maximum of five statistics with no more than two distinct units of
measure. By default, only 24 hours of statistics are available; change the repository purge
options to save statistics for a longer period.

See also
• Configuring Repository Purging on page 145

Manage Sybase Control Center
Manage and monitor Sybase Control Center for Data Assurance through statistical
information and activity logs.

Administration Console
Use the Administration Console to browse and manage the selected resources in a perspective.
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Browsing and Managing Resources
Create new resources or browse and manage existing resources.

Prerequisites
If you want to view or manage existing resources, register at least one resource and add it to a
perspective.

Task

The Administration Console enables you to view and manage both servers and resources
below the server level, such as processes, databases, and devices.

1. Launch the Administration Console.

• To populate the Administration Console with information on one or more resources: in
the Perspective Resources view, select the resources and select Resource >
Administration Console. This method is the most efficient because it displays only
selected resources.

• To populate the Administration Console with information on all the resources in the
current perspective: from the main menu bar, select View > Open > Administration
Console. If you are monitoring a large number of resources, the Administration
Console may take a few minutes to load.

2. To explore the hierarchy of object types, select Navigation > Browse in the left pane.
Expand an object type by clicking its arrow icon.

3. Select an object type (any server type, for example) in the hierarchy.

In the right pane, the Administration Console displays a list of resources of that type.

Note: Message rows in the right pane are placeholders for:
• Failed requests – to retry, select the message row and click the drop-down arrow that

appears to the right. Select Retry.
• Slow-responding requests – SCC replaces these rows with real data as soon as it

arrives.
• Large result sets – to display, select the message row and click the drop-down arrow

that appears to the right. Select Expand. The results might take a minute to appear.
Hover the mouse over a message row to see a tooltip with more information.

4. (Optional) To create an object of the type now selected, click Folder > Create or Folder >
New.

5. (Optional) To refresh the view, select Folder > Refresh.

6. In either the right or the left pane, select an object.
A dropdown arrow appears to the right of the name. If the selected object is in the right
pane, the Resource menu becomes active.
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7. Click the dropdown arrow to display a menu of actions you can perform on that object. If
the selected object is in the right pane, use the Resource menu to display the same actions.

Note: Some managed objects have no actions.

Searching and Filtering Resources
Use the Administration Console’s search and filter tools to quickly find the resources or
objects within resources that interest you.

1. Launch the Administration Console.

• To populate the Administration Console with information on one or more resources: in
the Perspective Resources view, select the resources and select Resource >
Administration Console. This method is the most efficient because it displays only
selected resources.

• To populate the Administration Console with information on all the resources in the
current perspective: from the main menu bar, select View > Open > Administration
Console. If you are monitoring a large number of resources, the Administration
Console may take a few minutes to load.

2. (Optional) You can use the Administration Console’s tools to control which resources it
displays:

a) In the left pane, click Resource Selection.
b) SCC refreshes the list of resources in the right pane with each selection you make in

this pane. If you are making multiple selection changes, unselect Automatically
refresh details to turn the refresh feature off.

c) Select or unselect resources to include or eliminate them from Administration Console
displays.

3. To find a resource without navigating the hierarchy:

a) In the left pane, select Navigation > Search.
b) (Required) On the Search tab, select the resource type and object type of the resource

you want to find.
c) Enter a search string.

The search string can be the full or partial name of a resource.
d) (Optional) Select Exact match to find only the resource whose name is identical to the

search string.
e) Click Search.

Results appear in the right pane.

Note: Message rows in the right pane are placeholders for:
• Failed requests – to retry, select the message row and click the drop-down arrow

that appears to the right. Select Retry.
• Slow-responding requests – SCC replaces these rows with real data as soon as it

arrives.
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• Large result sets – to display, select the message row and click the drop-down arrow
that appears to the right. Select Expand. The results might take a minute to appear.

Hover the mouse over a message row to see a tooltip with more information.

f) To further narrow your search, enter a filter string in the field at the top of any column of
search results. For example, in a search for databases, enter wilma above the Device
column to display only results associated with the device wilma.

Job Scheduling
A schedule defines a data collection job and specifies how often the job executes in your
system.

In Sybase Control Center, collection jobs provide the data that appears on monitoring screens
and charts. A collection is a set of key performance indicators (KPIs). When the scheduler runs
a collection job, it gathers the value of each KPI in the collection and tags the data with the date
and time it was gathered. The data is stored in the repository and displayed. Each product
module has predefined collections that you can schedule.

You can define schedules as one-time or repeating. You can modify the schedule for a job
based on a number of attributes such as:

• Repeat interval
• Date
• Time

The job history displays the status of jobs executed each day.

See also
• Setting Up Statistics Collection on page 103

• Data Collections for Replication Server Data Assurance Option on page 105

Executing and Stopping a Data Collection Job
Use the Properties view to execute or stop a data collection job.

Most of the time, data collection jobs should run on a schedule; you should rarely need to start
or stop a job manually.

1. In the Perspective Resources view, select the resource associated with the job and select
Resource > Properties.

2. Select Collection Jobs.

3. Select the job and:

• To execute a job immediately, click Execute.

• To stop a job, click Stop, then click Yes to confirm.
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Deleting a Data Collection Job
Use the Properties view for a resource to delete one or more data collection jobs.

1. In the Perspective Resources view, select the resource associated with the job and select
Resource > Properties.

2. Select Collection Jobs.

3. Select the job and click Delete.

4. Click OK to confirm the deletion.

Resuming and Suspending a Data Collection Job
Use the Properties view for a resource to resume or suspend a data collection job.

1. In the Perspective Resources view, select the resource associated with the job and select
Resource > Properties.

2. Select Collection Jobs.

3. Select the job (a top-level item in the Collection Jobs table). On the General tab:

• To resume a job, click Resume.
• To suspend a job, click Suspend, then click Yes to confirm the suspension.

Tip: If the General tab is grayed out, you have selected a schedule (child) rather than a job
(parent) in the Collection Jobs table. Select the parent job to display the General tab.

Adding a New Schedule to a Job
Use the Properties view for a resource to add schedules to a data collection job.

1. In the Perspective Resources view, select the resource associated with the job and select
Resource > Properties.

2. Select Collection Jobs.

3. Select the job.

4. Click Add Schedule.

5. Specify details for the new schedule:

Field Description

Name A name for this schedule

Description A description of this schedule

6. Choose to start the job Now or Later. If you choose Later, specify the start date and time.

7. Specify the duration of this schedule. The job can run:

• Once
• Repetitively at an interval you specify
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Field Description

Repeat interval Time period (in seconds, minutes, hours, or days) between job
executions

• Until a stop date that you specify, at an interval you specify

Field Description

Repeat interval Time period (in seconds, minutes, hours, or days) between job
executions

Stop date Date and time the job should stop running

Note: Enter dates and times using your local time. Sybase Control Center converts
your times for remote time zones if necessary.

You cannot change the duration of a schedule (the once/repetitively/until setting) after you
create it. To change the schedule duration, delete and recreate the schedule.

8. Click Finish to save the schedule.

9. Click OK.

Viewing or Deleting a Schedule
Display schedule details or remove a schedule from a data collection job.

1. In the Perspective Resources view, select the resource associated with the job and select
Resource > Properties.

2. Select Collection Jobs.

3. To display the schedules for a collection job, expand the job by clicking the arrow to the left
of the job’s name.

If there is no arrow to the left of the job’s name, this job has no schedules.

4. Select a schedule.
The name, description, start and end dates, and repeat interval appear on the Schedule tab.

5. (Optional) To remove the selected schedule, click Delete.

6. Click OK.

See also
• Setting Up Statistics Collection on page 103

Modifying the Data Collection Interval for a Job
Use the Properties view for a managed resource to modify the data collection schedule.

1. In the Perspective Resources view, select a server (or other resource).

2. In the view’s menu bar, select Resource > Properties.
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3. Select Collection Jobs.

4. Expand a job folder and select a schedule.

5. On the Schedule tab, modify the Repeat interval field.

6. Click Apply.

Resuming and Suspending the Scheduler
Use the scheduler settings to resume or suspend all scheduled jobs.

Prerequisites
You must have administrative privileges (sccAdminRole) to perform this task.

Task

1. From the main menu bar, select Application > Administration.

2. In the Sybase Control Center Properties dialog, select Scheduler.

3. Do one of the following:

• To resume the scheduler, click Resume.
• To suspend the scheduler, click Suspend.

4. Click OK.

Viewing the Job Execution History
Use the Properties view to display a data collection job’s execution history.

1. In the Perspective Resources view, select the resource associated with the job and select
Resource > Properties.

2. Select Collection Jobs.

3. Select a job.

4. Click the History tab.

Resources
In Sybase Control Center, a resource is a unique Sybase product component or subcomponent.
A server is the most common managed resource.

Sybase products comprise many components, including servers, agents, databases, devices,
and processes. A managed resource is a product component or subcomponent that Sybase
Control Center lets you monitor and administer. Two important tools for resource
management are the Resource Explorer and the Perspective Resources view.

• The Resource Explorer lists resources that are registered with Sybase Control Center. The
list may include resources that you have not yet added to a perspective. Registration
enables Sybase Control Center to connect to the resource, log in, retrieve monitoring data,
and issue commands. Resources are registered at the server or agent level, and registering a
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server or agent also makes Sybase Control Center aware of any subcomponents. You can
register resources individually or register several at once by importing them in a batch.

• The Perspective Resources view lists registered resources that you have added to the
current perspective. You must add a resource to a perspective to manage and monitor its
availability and performance.

See also
• Registering a Data Assurance Server on page 100

• Importing Resources for Batch Registration on page 101

Unregistering a Resource
Remove one or more servers or other resources from Sybase Control Center.

1. From the Sybase Control Center toolbar, click the Launch Resource Explorer icon.

2. In the Resource Explorer, select the resources you want to unregister. Use Shift+click or
Control+click to select multiple resources.

3. Select Resources  > Unregister.

4. Click Yes to confirm the removal.

See also
• Registering a Data Assurance Server on page 100

• Importing Resources for Batch Registration on page 101

Adding a Resource to a Perspective
Add one or more resources to the current perspective.

Prerequisites
Register the resources.

Task
Add servers or other resources to a perspective so you can monitor and manage them along
with other resources in the same perspective.

1. From the Sybase Control Center toolbar, click the Launch Resource Explorer icon.

2. Select the resources to add to your perspective. Use Shift-click or Control-click to select
multiple resources.

3. Perform one of these actions:

• Select  Resources > Add Resources to Perspective.
• Drag and drop resources from the Resource Explorer onto the Perspective Resources

view. You can select and drag multiple resources.
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See also
• Removing a Resource from a Perspective on page 137

• Resources on page 135

• Registering a Data Assurance Server on page 100

• Importing Resources for Batch Registration on page 101

Removing a Resource from a Perspective
Remove one or more resources from the current perspective.

Removing a resource from a perspective does not unregister the resource; it remains in any
other perspectives to which it has been added, and remains accessible in the Resource
Explorer.

1. Before removing a resource, make sure it is not in use by an open view.

• Close any views that display the resource.
• If you prefer not to close the Administration Console, unselect the resource:

a) In the left pane of the Administration Console, click Resource Selection.
b) Locate the resource in the list and click the box to unselect it.

2. If the Perspective Resources view is not open, click the Show/Hide Perspective
Resources View icon in the perspective toolbar.

3. In the Perspective Resources view, select the resources to remove. Use Shift-click or
Control-click to select multiple resources.

4. Select Resource > Remove.

5. Click Yes to confirm the removal.

See also
• Adding a Resource to a Perspective on page 136

Modifying a Resource’s Name and Connection Properties
Change the properties of a resource registered with Sybase Control Center.

1. In the Perspective Resources view, select a resource and select Resource  >
Properties .

2. (Optional) On the General Properties page, modify the name or description of the
resource.

Enter the actual name of the managed server, using uppercase and lowercase letters. If the
name registered in Sybase Control Center does not exactly match the server name, some
monitoring functions, including the topology view, do not work.

3. (Optional) On the Connection Information page, modify:

• the host name
• the port number
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• other options for the managed resource

4. Click OK (to apply the changes and close the properties dialog) or Apply (to apply the
changes and leave the dialog open).

Searching for Resources in the Resource Explorer
Search for all your managed resources or narrow your search for a particular resource.

1. Click the Launch Resource Explorer icon.

2. If the Filter pane is not visible in the Resource Explorer window, select View > Filter from
the view’s menu bar.

3. Enter your search term in the Filter string field.

The search term can be any string that appears in the tabular portion of the Resource
Explorer, such as the name, or part of the name, of a server or a resource type (ASE Server,
for example).

4. (Optional) Select a filtering setting:

• Match case – search for resources whose displayed data includes the search term,
including uppercase and lowercase letters; or

• Exact match – search for resources whose displayed data includes an item identical to
the search term.

5. (Optional) Select a column from the Filter on list to restrict your search to that column.

Perspectives
A perspective is a named container for a set of one or more managed resources. You can
customize perspectives to provide the information you need about your environment.

As the main workspaces in the Sybase Control Center window, perspectives let you organize
managed resources. You might assign resources to perspectives based on where the resources
are located (continents, states, or time zones, for example), what they are used for, which
group owns them, or which administrator manages them. Perspectives appear as tabs in the
main window.

Every perspective includes a Perspective Resources view, which lists the resources in that
perspective and provides high-level status and descriptive information. Use the View menu to
switch from detail view to icon view and back.

You can open additional views —the heat chart, statistics chart, or alert monitor, for example
— as needed to manage the perspective’s resources. The views in a perspective display
information only about resources in that perspective.

One resource can appear in many perspectives.
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Creating a Perspective
Create a perspective in which you can add and manage resources.

1. From the application menu bar, select Perspective > Create.

2. Enter a name for your perspective. The name can contain up to 255 characters.

3. Click OK.

Removing a Perspective
Delete a perspective window.

1. Select the perspective tab you want to delete.

2. In the main menu bar, select Perspective > Delete.
The selected perspective disappears. If there are other perspectives, Sybase Control Center
displays one.

Renaming a Perspective
Change the name of your perspective.

1. Select the perspective tab you want to rename.

2. From the main menu bar, select Perspective > Rename..

3. Enter the new name for your perspective.

4. Click OK.

Views
Use views to manage one or more resources within a perspective.

In Sybase Control Center, views are the windows you use to monitor and manage a
perspective’s resources. You can re-arrange, tile, cascade, minimize, maximize, and generally
control the display of the views in your perspective.

Each perspective includes these views:

• Perspective Resources
• Administration Console
• Heat chart
• Alert monitor
• Component log viewer
• Views that exist for each managed resource. These vary by resource type, but typically

include the statistics chart, the properties view, and a monitoring view.

Note: Sybase Control Center views are not related to database views; they serve a completely
different purpose.
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Managing a View
Open, close, minimize, maximize, or restore a view in the current perspective.

You can:

Task Action

Open a view Do one of the following:

• In the Perspective Resources view, select a resource, click the drop-
down arrow to the right of the resource name, and select the view to
open.

• In the application menu bar, select View > Open and choose a view.

Close a view Select the view to close. In the application menu bar, select View > Close.
You can also click the X in the view’s upper right corner.

Maximize a view Click the box in the view’s upper right corner. The view enlarges to fill the
entire perspective window. Click the box again to return the view to its
former size.

Minimize a view Click the _ in the view’s upper right corner. The view shrinks to a small
tab at the bottom of the perspective window.

Minimize all views In the application menu bar, select View > Minimize All Views.

Restore a view Click the box on the minimized tab to maximize the view. Click the box
again to return the view to its former (smaller) size so you can see other
views at the same time.

Bring a view to the front In the application menu bar, select View > Select and choose the view you
want from the submenu.

Arranging View Layout in a Perspective
Use the view layout options to manage your perspective space.

Click one of these icons in the Sybase Control Center toolbar:

Icon Action

Close All Open Views

Minimize All Open Views

Restore All Minimized Views

Manage and Monitor

140



Icon Action

Cascade All Open Views

Tile All Open Views Vertically

Tile All Open Views Horizontally

In a cascade, views overlap; in tiling arrangements, they do not.

Alternatively, you can arrange view layouts from the Sybase Control Center menu bar. From
the menu bar, select Perspective > Arrange and select your view layout.

Repository
The Sybase Control Center embedded repository stores information related to managed
resources, as well as user preference data, operational data, and statistics.

You can back up the repository database on demand, schedule automatic backups, restore the
repository from backups, and configure repository purging options. Full and incremental
backups are available. A full backup copies the entire repository. An incremental backup
copies the transaction log, capturing any changes since the last full or incremental backup.

By default, Sybase Control Center saves backups as follows:

• Each full backup is stored in its own subdirectory in SCC-3_2/backup.

• Each incremental backup is stored in a file in SCC-3_2/backup/incremental.

Sybase recommends that you periodically move backup files to a secondary storage location
to prevent the installation directory from becoming too large.

Scheduling Backups of the Repository
Configure full and incremental backups of the repository to occur automatically.

Prerequisites
Determine your backup strategy, including when to perform full backups and incremental
backups. For example, you might schedule incremental backups every day and a full backup
every Saturday.

You must have administrative privileges (sccAdminRole) to perform this task.

Task

A full backup copies the entire repository. An incremental backup copies the transaction log,
capturing any changes since the last full or incremental backup.
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1. From the main menu, select Application > Administration.

2. In the left pane, select Repository.

3. Click the Full Backup tab.

4. (Optional) To change the directory in which backups will be stored, click Browse and
navigate to the desired directory.

5. Select Schedule a Regular Backup.

6. Specify the day you want scheduled backups to begin. Enter a Start date or click the
calendar and select a date.

7. (Optional) Use the Time and AM/PM controls to specify the time at which backups occur.

8. Specify how often backups occur by setting the Repeat interval and selecting hours, days,
or weeks.

9. (Optional) To purge the repository after each backup, select Run a repository purge after
the backup completes.

10. If you include purging in the backup schedule, go to the Size Management tab and
unselect Automatically purge the repository periodically to disable automatic purging.

11. Click Apply to save the schedule.

12. Click the Incremental Backup tab and repeat the steps above to schedule incremental
backups to occur between full backups.

Next
Set purging options on the Size Management tab.

Modifying the Backup Schedule
Suspend or resume repository backups or change the backup schedule.

Prerequisites
You must have administrative privileges (sccAdminRole) to perform this task.

Task

1. From the main menu, select Application > Administration.

2. In the left pane, select Repository.

3. Choose the type of backup to modify:

• Click the Full Backup tab, or
• Click the Incremental Backup tab.

4. (Optional) To suspend or resume the backup schedule, select or unselect Schedule a
Regular Backup.
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When you unselect (uncheck) this option, the scheduling area is grayed out and scheduled
backups no longer occur. However, the schedule is preserved and you can reinstate it at any
time.

5. To change the backup schedule, edit the Start date, Time, Repeat interval, or units. You
can also select or unselect Run a repository purge after the backup completes.

6. Click Apply to save the schedule.

Forcing an Immediate Backup
Perform an unscheduled full or incremental backup of the repository.

Prerequisites
You must have administrative privileges (sccAdminRole) to perform this task.

Task

1. From the main menu, select Application > Administration.

2. In the left pane, select Repository.

3. Choose the type of backup to run:

• Click the Full Backup tab, or
• Click the Incremental Backup tab.

4. Click Back up Now.

Sybase Control Center saves the backup to the directory shown in the Location field.

Restoring the Repository from Backups
Load backup files into the repository database to revert undesirable changes or to recover from
a catastrophic failure.

If you configured Sybase Control Center to store backups somewhere other than the default
location, change the source directory in the copy commands in this procedure.

1. Shut down Sybase Control Center.

2. Copy the most recent full backup from SCC-3_2/backup/
<generated_directory_name> to SCC-3_2/services/Repository. For
example:

Windows:
copy C:\sybase\SCC-3_2\backup\repository.
270110161105\scc_repository.db 
C:\sybase\SCC-3_2\services\Repository

UNIX:
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cp /opt/sybase/SCC-3_2/backup/repository.270110161105/
scc_repository.db 
/opt/sybase/SCC-3_2/services/Repository

3. If you have no incremental backups to load,

a) Also copy the log file from SCC-3_2/backup/
<generated_directory_name> to SCC-3_2/services/Repository.
For example:

Windows:
copy C:\sybase\SCC-3_2\backup\repository.
270110161105\scc_repository.log 
C:\sybase\SCC-3_2\services\Repository

UNIX:
cp /opt/sybase/SCC-3_2/backup/repository.270110161105/
scc_repository.log 
/opt/sybase/SCC-3_2/services/Repository

b) Skip to step 5 on page 144.

4. (Optional) To load incremental backups, start the repository database using the -ad option,
which directs it to load transaction logs (incremental backups) from the incremental
directory. (The database loads full backups automatically.) For example:

Windows:
cd sybase\SCC-3_2\services\Repository

..\..\bin\sa\bin_<platform>\dbsrv11.exe scc_repository -ad 
sybase\SCC-3_2\backup\incremental

UNIX:
cd /opt/sybase/SCC-3_2/services/Repository

../../bin/sa/bin_<platform>/dbsrv11 scc_repository -ad 
/opt/sybase/SCC-3_2/backup/incremental

The repository database loads the full backup and any subsequent incremental backups
present in the incremental directory. Incremental backups are loaded in date order.
After loading and saving, the database shuts down.

5. Start Sybase Control Center.
If you loaded incremental backups, Sybase Control Center starts normally (that is, no
further recovery occurs). If you copied a full backup to the Repository directory, the
database recovers the repository from the full backup.

Example: Loading incremental backups into the repository database

These commands start SQL Anywhere® on a 32-bit Windows machine:

% cd C:\sybase\SCC-3_2\services\Repository
% ..\..\bin\sa\bin_windows32\dbsrv11.exe scc_repository -ad  
C:\sybase\SCC-3_2\backup\incremental

Manage and Monitor

144



These commands start SQL Anywhere on a 64-bit machine running Solaris:

$ cd /opt/sybase/SCC-3_2/services/Repository
$ ../../bin/sa/bin_sunsparc64/dbsrv11 scc_repository -ad 
/opt/sybase/SCC-3_2/backup/incremental

Configuring Repository Purging
Change repository purging options.

Prerequisites
You must have administrative privileges (sccAdminRole) to perform this task.

Task

As you decide how to purge your repository, consider that:

• Purging keeps the repository from absorbing too much disk space.
• By default, purging is enabled. It occurs once a day and purges data older than one day.
• Statistics and alert history can help you detect trends in server performance and user

behavior. The Sybase Control Center statistics chart can graph performance data over a
period of a year or more if the data is available. If you have enough disk space, consider
saving data for a longer period of time or disabling the purging of statistics or alert history.

• Changing the purge frequency and other options might affect Sybase Control Center
performance.

Note: If you configure purging as part of a scheduled backup of the repository, disable
automatic purging on the Size Management tab.

1. From the main menu bar, select Application > Administration.

2. Select Repository.

3. Click the Size Management tab.

4. To turn automatic purging on or off, click Automatically purge the repository
periodically.

Turn this option off if purging is configured as part of your scheduled full or incremental
backups.

5. Click purge options to turn them on or off:

• Purge statistics
• Purge alert history

6. In Purge data older than, enter the number of days after which to purge repository data.

7. Click Apply, then OK.
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Logging
Logging helps Sybase Control Center administrators identify and track errors and other
system events by recording messages about the events in log files.

Sybase Control Center maintains these logs:

• The client log – captures messages about activities in the browser-based client
components. These messages are generated by the component product modules to display
information that is pertinent to the user but not critical enough to warrant a pop-up. Sybase
also uses the client log to trace client browser operations.

• Server logs – capture messages about activities during the initialization sequence, such as
starting services; auditing messages recording logins and logouts; errors such as missed
scheduled events; and other events on the server. Server logs include:
• Component logs, which record only events concerning individual product modules
• The SCC agent log, which is a composite log. In an SCC server, the agent log records

events in all product modules and in the Sybase Control Center framework. In an SCC
agent, the agent log records events in the agent.

• The repository log – captures information about inserts and updates that have occurred in
the Sybase Control Center repository, a SQL Anywhere database. This log is in
SCC-3_2\log\repository.log.

• The alert services log – captures information about alert service status and events,
including execution of alert-triggered scripts (start time, end time, and status and exit
codes). This log is in SCC-3_2\log\alert-server.log.

Viewing the Data Assurance Component Log
View event logs for Sybase Control Center for Data Assurance.

The log files are in:

• Windows – %SYBASE%\SCC-3_2\plugins\DAMAP\log\damap.log
• UNIX – $SYBASE/SCC-3_2/plugins/DAMAP/log/damap.log

1. Use a log viewer or text editor to look at log files.

2. Look for entries of interest, such as login attempts or the failure of a service to start.

Editing the Data Assurance Log Configuration
Change the log level or logging configuration settings for Data Assurance (DA).

1. Navigate to %SYBASE%\SCC-3_2\plugins\DAMAP.

2. Open the logging.properties file, and modify the settings as needed.

3. Save and close the logging.properties file.

4. Restart the SCC server.

Manage and Monitor

146



SCC for Data Assurance messages are recorded in the console and the damap.log file. The
damap.log file is located at %SYBASE%\SCC-3_2\plugins\DAMAP\log.

Viewing Sybase Control Center Server Logs
View event logs for the Sybase Control Center server.

Sybase Control Center logs events to several places:

• The console from which Sybase Control Center is launched.
• The Sybase Control Center agent log: <SCC-install-directory>/log/

agent.log
• The repository log: <SCC-install-directory>/log/repository.log
• The component log for each installed Sybase Control Center product module. The path to

the component log takes this form: <SCC-install-directory>/plugins/
<component>/log/<component>.log

1. Display one of the log files using a log viewer or a method of your choice.

2. Look for entries of interest such as login attempts or the failure of a service to start.

On the console and in the Sybase Control Center agent log file, some components prepend
the component name to log entries.

Viewing the Sybase Control Center Client Log
Display the event log for the current session of your Sybase Control Center browser client.

In the perspective tab window (the main window), do either of the following to display the
client log:

• Enter Ctrl+Alt+L.
• Select View > Open > Log Window.

Note: The client log reader displays the 100 most recent log messages for the current login
session.

Changing the Logging Level
Adjust the logging level that determines which events Sybase Control Center records in the
server logs. This task requires you to restart Sybase Control Center.

If you are having a problem with Sybase Control Center, you might be able to discover the
cause of the problem by changing the server logging level so that more events are recorded.

1. Shut down Sybase Control Center.

2. Restart Sybase Control Center using the -m option to change the logging level. In <SCC-
installation-dir>/bin, enter:

scc -m <logging-level>
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The logging levels are OFF (logs nothing), FATAL (logs only the most severe events),
ERROR, WARN, INFO, DEBUG, and ALL (logs everything).

3. Examine the server log for clues about what might be causing the problem.

4. When you have resolved the problem, set the logging level back to WARN, the default.
Your log may become unmanageably large if you leave it at the DEBUG or ALL level.

Example

These commands, which must be executed in the installation directory, start Sybase Control
Center with the logging level set to debug:

Windows: bin\scc -m DEBUG
UNIX: bin/scc -m DEBUG

See also
• Starting and Stopping Sybase Control Center in Windows on page 55

• Starting and Stopping Sybase Control Center in UNIX on page 57

Logging or Message Levels
Describes values you can use to control the types of events that are logged by Sybase Control
Center.

These are the logging levels, from highest to lowest. The higher the level, the more serious an
event must be to be logged. Each level includes all the levels above it—for example, if you set
the logging level to WARN, you log events for the WARN, ERROR, and FATAL levels.

OFF Nothing is logged. This is the highest level.

FATAL Logs only very severe error events that lead the server to abort. This is the
highest level at which events are logged.

ERROR Logs error events that might allow the server to continue running.

WARN Logs potentially harmful situations. WARN is the default logging level
during normal operation (that is, after system initialization).

INFO Logs informational messages that track the progress of the server in a coarse-
grained fashion. INFO is the default logging level during the system initi-
alization process.

DEBUG Logs a larger set of events that provides a finer-grained picture of how the
server is operating. This level is recommended for troubleshooting.

ALL Logs all loggable events. This is the lowest level.

See also
• scc Command on page 64
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Changing Logging Configuration
Edit the logging configuration file, log4j.properties, to modify Sybase Control Center
logging.

You can change the names, locations, or maximum size of the log files as well as the number of
log files backed up.

Options for the scc command let you change the overall Sybase Control Center log message
level when you start SCC, but if you choose the DEBUG level, the large volume of log
messages generated may be inconvenient. Editing the log properties file gives you finer
control; you can set logging levels for each Sybase Control Center component separately.
Sybase recommends making such changes only if you are familiar with log4j and you are
working with Sybase technical support; DEBUG-level log messages are not likely to be
meaningful to you. (If you have not used log4j before, a good place to start is http://
logging.apache.org/log4j/1.2/manual.html.)

1. Shut down Sybase Control Center.

2. Make a backup copy of the log4j.properties file located in <SCC-
installation-directory>/conf.

3. Open the log4j.properties file for editing.

4. Change values in the file to suit your needs. For example:

To Modify

Change the name or location of a
log file

• Agent log – log4j.appender.agent.File
• Repository log – log4j.appender.repository.File
• Collection statistics log – log4j.appender.collection-

stats.File
• Alert server log – log4j.appender.alert.File
• Gateway log – log4j.appender.gateway.File

Change the maximum size that a
log file can reach before Sybase
Control Center creates a new file

• Agent log – log4j.appender.agent.MaxFileSize
• Repository log – log4j.appender.repository.MaxFileSize
• Collection statistics log – log4j.appender.collection-

stats.MaxFileSize
• Alert server log – log4j.appender.alert.MaxFileSize
• Gateway log – log4j.appender.gateway.MaxFileSize

Change the number of log files
Sybase Control Center backs up
before deleting the oldest file

• Agent log – log4j.appender.agent.MaxBackupIndex
• Repository log – log4j.appender.repository.MaxBacku-

pIndex
• Collection statistics log – log4j.appender.collection-

stats.MaxBackupIndex
• Alert server log – log4j.appender.alert.MaxBackupIndex
• Gateway log – log4j.appender.gateway.MaxBackupIndex
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5. Save and exit the file.

6. Start Sybase Control Center to make the logging changes take effect.

See also
• Starting and Stopping Sybase Control Center in Windows on page 55

• Starting and Stopping Sybase Control Center in UNIX on page 57

Sybase Control Center Console
The console is a command-line interface for displaying details about the status of the Sybase
Control Center server and its subsystems.

When you use the scc command to start Sybase Control Center, it displays start-up messages
and then displays the console prompt.

Note: The console prompt does not appear if you start Sybase Control Center as a service, if
you direct the output of scc to a file, or if you start Sybase Control Center in the background.

See also
• Launching Sybase Control Center on page 54

Console Commands
Use the Sybase Control Center console to get status information on Sybase Control Center and
its ports, plug-ins, and services.

help Command
Display syntax information for one or more Sybase Control Center console commands.

Syntax
help [command_name] 

Parameters

• command_name – optional. status, info, or shutdown. If you omit command_name, help
returns information on all the console commands.

Examples

• Example 1 – returns information on the status command:

help status

Permissions

help permission defaults to all users. No permission is required to use it.
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info Command
Display information about specified parts of the Sybase Control Center server.

If you enter info with no parameters, it returns information for every parameter.

Syntax
info [-a | --sys] 
[-D | --sysprop [system-property]] 
[-e | --env [environment-variable]]
[-h | --help]
[-m | --mem]
[-p | --ports]
[-s | --services]

Parameters

• -a | --sys – optional. List all the services known to Sybase Control Center, indicate whether
each service is enabled, and list other services on which each service depends.

• -D | --sysprop [system-property] – optional. Display information about the specified Java
system property. Omit the system-property argument to return a list of all Java system
properties and their values.

• -e | --env [environment-variable] – optional. List all the environment variables in the
Sybase Control Center Java VM process environment. Omit the environment-variable
argument to return a list of environment variables and their values.

• -h | --help – optional. Display information about the info command.
• -m | --mem – optional. Display information about the server’s memory resources.
• -p | --ports – optional. List all the ports on which the Sybase Control Center agent and its

services listen, indicate whether each port is in use, and show the service running on each
port.

• -s | --services – optional. List all Sybase Control Center services, indicate whether each
service is enabled, and list other services on which each service depends.

Examples

• Example 1 – displays information about ports on this Sybase Control Center server:

info -p

Permissions

info permission defaults to all users. No permission is required to use it.

shutdown command
Stop the Sybase Control Center server if it is running.
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Syntax
shutdown

Examples

• Example 1 – shuts down Sybase Control Center:

shutdown

Permissions

shutdown permission defaults to all users. No permission is required to use it.

status Command
Display the status of the Sybase Control Center agent, plug-in, or service components of
Sybase Control Center.

Syntax
status [-a | --agent] 
[-h | --help] 
[-p | --plugin [plugin-name]] 
[-s | --service [service-name]]  
    

Parameters

• -a | --agent – display the status of the Sybase Control Center agent component.
• -h | --help – display information about the info command.
• -p | --plugin [plugin-name] – display the status of the specified Sybase Control Center

plug-in (for example, ASEMap, the Adaptive Server® management module). Omit the
plugin-name argument to return a list of plug-ins.

• -s | --service [service-name] – display the status of the specified Sybase Control Center
service (for example, the Alert service or the Messaging service). Omit the service-name
argument to return a list of services.

Examples

• Example 1 – displays status information on the Repository service:

status --service Repository

Permissions

status permission defaults to all users. No permission is required to use it.
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Manage and Monitor the Data Assurance Environment
Manage and monitor Data Assurance server and agents.

Data Assurance Agents
Data Assurance (DA) agents fetch and compress data from databases into the DA server.

There are two types of agents: the embedded local agent in DA server, and standalone (remote)
agents, which DA server can use to improve job performance.

A DA agent opens a Java Database Connectivity (JDBC) connection to one or more databases,
and reads the row data used for comparison. If there are no standalone DA agents, you must
use the embedded local agent.

Based on the DA server request, a DA agent:

• Compresses rows for precomparison, if configured to do so
• Fetches rows for comparison
• Hashes rows for precomparison, if configured to do so
• Sorts rows for precomparison, if configured to do so
• Runs insert/delete/update statements on databases, if configured to do so

Editing an Agent Connection
Modify the details of a Data Assurance (DA) agent connection profile.

1. In the Perspective Resources view, select a DA server.

2. Select Resource  > Administration Console.

3. Expand Data Assurance Server, then select Data Assurance Agent Connections.

4. Select a DA agent connection.

5. Either:

• Select Resource > Properties, or,
• Click the button that appears when you select a DA agent connection, then select

Properties.

6. Modify the agent connection information as required, then click Apply.

Field Description

Host (Required) Name of the server where the DA agent is installed.

Port (Required) Port number of the DA agent.

Username (Required) DA agent username.
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Field Description

Password (Required) DA agent password.

Description A brief description to help you identify the agent connection.

7. (Optional) Click Test to verify if the modified agent connection information is correct.

8. Click OK.

See also
• Creating an Agent Connection on page 106

Deleting an Agent Connection
Remove a Data Assurance (DA) agent connection profile.

1. In the Perspective Resources view, select a DA server.

2. Select Resource  > Administration Console.

3. Expand Data Assurance Server, then select Data Assurance Agent Connections.

4. Select a DA agent connection.

5. Either:

• Select Resource > Delete, or,
• Click the button that appears when you select a DA agent connection, then select

Delete.

6. Click OK.

See also
• Creating an Agent Connection on page 106

Viewing All Agent Connection
Display the connection profiles of all the Data Assurance (DA) agents.

1. In the Perspective Resources view, select a DA server.

2. Select Resource  > Administration Console.

3. Expand Data Assurance Server, then select Data Assurance Agent Connections.

See also
• Creating an Agent Connection on page 106

Testing an Agent Connection
Verify that you have properly configured a Data Assurance (DA) agent connection.

1. In the Perspective Resources view, select a DA server.
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2. Select Resource  > Administration Console.

3. Expand Data Assurance Server, then select Data Assurance Agent Connections.

4. Select a DA agent connection.

5. Either:

• Select Resource > Properties, or,
• Click the button that appears when you select a DA agent connection, then select

Properties.

6. Click Test.

See also
• Creating an Agent Connection on page 106

Database Connections
In Sybase Control Center for Replication Server Data Assurance (DA) Option, you need to
create a database connection profile, which contains the information required to establish a
database connection to allow comparison of data data between the primary and replicate
databases.

See also
• Creating a Database Connection on page 107

• Creating a Single or Cluster Connection from an Interface File on page 109

Editing a Database Connection
Modify the details of a database connection in a Data Assurance (DA) server.

1. In the Perspective Resources view, select a DA server.

2. Select Resource  > Administration Console.

3. Expand Data Assurance Server, then select Database Connections.

4. Select a database connection, then either:

• Select Resource > Properties, or,
• Click the button that appears when you select a database connection, then select

Properties.

5. Modify the database connection information as required, then click Apply.

Field Description

Description A brief description to help you identify the database connection.
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Field Description

Agent (Required) The DA agent to use in connecting to the database. It
can be a local agent that comes with the DA server installation, a
remote agent that is defined in the Data Assurance Agent Con-
nections, or a new remote agent that has yet to be defined.

Database (Required) Name of the database to connect to.

Host (Required) Name of the server where the database is residing.

Port (Required) Port number of the database.

Username (Required) database username.

Password Database password.

Properties The properties for JBDC connection.

6. (Optional) Click Test to verify if the modified database connection information is correct.

7. Click OK.

See also
• Creating a Database Connection on page 107

• Creating a Single or Cluster Connection from an Interface File on page 109

Deleting a Database Connection
Remove a database connection from the Data Assurance (DA) server.

1. In the Perspective Resources view, select a DA server.

2. Select Resource  > Administration Console.

3. Expand Data Assurance Server, then select Database Connections.

4. Select a database connection, then either:

• Select Resource > Delete, or,
• Click the button that appears when you select a database connection, then select

Delete.

5. Click OK.

See also
• Creating a Database Connection on page 107

• Creating a Single or Cluster Connection from an Interface File on page 109
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Viewing All the Database Connection Profiles
Display all the database connection profiles in a Data Assurance (DA) server.

1. In the Perspective Resources view, select a DA server.

2. Select Resource  > Administration Console.

3. Expand Data Assurance Server, then select Database Connections.

See also
• Creating a Database Connection on page 107

• Creating a Single or Cluster Connection from an Interface File on page 109

Testing a Database Connection
Verify that you have properly configured a database connection.

1. In the Perspective Resources view, select a DA server.

2. Select Resource  > Administration Console.

3. Expand Data Assurance Server, then select Database Connections.

4. Select a database connection, then either:

• Select Resource > Properties, or,
• Click the button that appears when you select a database connection, then select

Properties.

5. Click Test.

See also
• Creating a Database Connection on page 107

• Creating a Single or Cluster Connection from an Interface File on page 109

Data Assurance Servers
Gather usage statistics—CPU, memory and cache memory to monitor the availability and
state of Data Assurance (DA) servers and agents.

You can monitor the availability and state of objects using the topology and the DA monitor.
The topology is a graphical representation of the DA system objects, which include the DA
server, agents, and databases.

The monitor includes these views:

• Overview – displays high-level information, such as the server name, version number of
the server, the server time at last refresh, server status, and memory and CPU usage
displayed through chart. You can select to monitor or shutdown a DA server or DA agents
using this view.
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• Job Current Status – displays a list of jobs with their status and other related information,
and a list of comparisons, both in a table form. You can choose to abort existing jobs using
this view.

• Settings – lets you to change the value for the screen refresh interval.

See also
• Authenticating a Login Account for a Managed Resource on page 102

Displaying the System Topology
The Data Assurance (DA) system topology graphically monitors the DA server and agent
availability.

Prerequisites

• Add the server to be monitored to the Perspective Resources view.
• Authenticate the server.

Task

1. In the Perspective Resources view, select a DA server.

2. Select Resource > Topology.
The topology view opens, displaying the selected DA server and its associated agents and
databases.

3. (Optional) Use the View Controls and Details tabs for additional help in viewing the
topology.

Viewing Data Assurance Server and Agent Status
The Data Assurance (DA) monitor shows high-level server and agent information.

Prerequisites

• Register and add the server to be monitored to the Perspective Resources view.
• Authenticate the server.

Task

1. In the Perspective Resources view, select a DA server.

2. Select Resource  > Monitor.

Note: You can also view the server status through the status badges on the server icons in the
Perspective Resources, Heat Chart, Resource Explorer, and topology views.
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Configuring Data Assurance Server Parameters
Improve Data Assurance (DA) server performance by editing server system configuration.

Prerequisites

• Add the server to be monitored to the Perspective Resources view.
• Authenticate the server.

Task

1. In the Perspective Resources, select a DA server.

2. Select Resource > Administration Console.

3. Select Data Assurance Server.

4. Select a DA server, then either:

• Select Resource > System Configuration , or,
• Click the button that appears when you select a DA server, then click System

Configuration.

5. In the Run Value column, modify the current values of the server parameters.

6. (Optional) Click Restore to Default to undo modifications that have not been applied.

7. Click Apply.

See the Replication Server Data Assurance Option Users Guide > Performance and Tuning.

Setting Logging and Audit Levels for Data Assurance Server
Set the logging and audit trace levels for Data Assurance server.

1. In the Perspective Resources view, select a DA server.

2. Select Resource  > Administration Console.

3. On the Browse tab, select Data Assurance Servers, then select a DA server.

4. Click the button that appears when you select a DA server, then select Logging
Configuration....

5. Select the audit trace and logging levels.

6. Click Apply, then OK.
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Troubleshoot Sybase Control Center for Data
Assurance

Troubleshoot problems that occur in Sybase Control Center for Data Assurance.

Comparison Fails to Record an Inconsistency
Problem: Job comparison results are not recording inconsistencies in database hash column
comparisons.

Solution 1: Increase LOB Fetch Size
The inconsistency might exist in a large object (LOB) column, such as image. By default, DA
server compares only the first 1024 bytes of LOB columns, so some sections of LOB values
are not compared.

To solve this problem, increase the lob_fetch_size value.

Solution 2: Increase LOB Fetch Size
The source and target column values might produce the same MD5/SHA/CRC32 hash value.

To solve this problem, use the literal option to recompare the rows.

See also
• Configuring Data Assurance Server Parameters on page 159

External Sort Option Configuration
Problem: You have configured DA agent to perform external sort, but the database is still
performing the sort operation.

The enable sort option is not activated because the number of rows in the table is less than the
external_sort_activate_size value, which by default is 10 million.

Solution: Decrease the external_sort_activate_size to a value less than the number of rows in
the source and target tables.

See also
• Configuring Data Assurance Server Parameters on page 159
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DA Server Out of Memory Errors
Problem: DA server runs out of memory space and exhibits performance issues.

Solution 1: Decrease Comparer Max Concurrent Threads
During a comparison, DA server receives row data from DA agents at different rates, so at any
given time, the server may be buffering tens or hundreds of rows for each source or target. If
individual rows are large (user-database-table-dependent) and the number of comparisons is
sufficiently high (configured by the user), this buffering might cause DA server to run out of
memory.

To solve this problem, set comparer_max_concurrent_threads to a lower value.

Solution 2: Decrease LOB Fetch Size
The configuration parameter lob_fetch_size may be set to a high value.

To solve this problem, set lob_fetch_size to a lower value.

Solution 3: Decrease External Sort Max Size
The external sort option uses a large amount of memory. By default, the external sort keeps
thousands of rows in memory. While this is not usually a problem, it depends on the size of
each row and the simultaneous activity occurring within the same Java Virtual Machine
(JVM). For instance, if there are five concurrent comparisons using the DA agent, the memory
requirement increases fivefold. Or if the “localagent” is being used, the source and target
agents and the compare function are sharing the same JVM memory allocation.

To solve this problem, decrease the number of rows the DA agent stores in the memory by
changing the external_sort_max_size configuration parameter value.

Solution 4: Increase the Memory Available to DA Server
Global solution: You can address all of the possible causes for out of memory issues described
above by configuring DA server to start with more memory. By default, the JVM where the
DA server runs uses 512 MB. Increase the value (dependent on the platform and the amount of
system memory available) by editing the DA server’s RUN_<instance>.bat file.

See also
• Configuring Data Assurance Server Parameters on page 159

Problems with Basic Sybase Control Center Functionality
Troubleshoot problems that involve basic features like starting and stopping, authentication,
alerts, and scheduling.
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Sybase Control Center Fails to Start
Problem: The Sybase Control Center server does not start.

Solution 1: Port conflict
Solution: SCC might be using one or more ports that are also being used by another server or
application on this machine. To check for port conflicts:

1. Execute this command:
scc --info ports

The command lists all the ports on which Sybase Control Center and its services listen,
indicates whether each port is in use, and shows the service running on each port. If SCC is
not running, any port shown to be in use represents a conflict.

2. If you discover a conflict, use scc --port to change the port used by the Sybase Control
Center service.

Solution 2: Insufficient memory
You might see this error why you try to start: Could not create the Java Virtual
machine. Increase the maximum memory setting.

See also
• Configuring Ports on page 87

Cannot Log In
Problem: Cannot log in to Sybase Control Center Web console.

Solution: Make sure that Sybase Control Center has been configured:

• To allow logins through the operating system
• To grant appropriate roles to your login account

Ask the Sybase Control Center administrator to help you check.

See also
• User Authorization on page 90

• Setting Up Security on page 69

Browser Refresh (F5) Causes Logout
Problem: Pressing the F5 key to refresh your browser logs you out of Sybase Control Center.

Solution: Do not use F5 when you are logged in to Sybase Control Center. Browser refresh
does not refresh data inside Sybase Control Center, but refreshes the loaded application or
pages in the browser—in this case, the Adobe Flash on which Sybase Control Center is built.
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Consequently, pressing F5 logs you out of any servers you are currently logged in to, including
Sybase Control Center.

Performance Statistics Do Not Cover Enough Time
Problem: I want to graph performance counters over a long period of time but the statistics
chart displays only very recent data.

Solution: Ask your Sybase Control Center administrator to change the repository purging
options to keep statistical data available for as long as you need it. By default, statistics are
purged frequently to conserve disk space.

See also
• Configuring Repository Purging on page 145

• Graphing Performance Counters: the Statistics Chart on page 128

Resetting the Online Help
Problem: Sybase Control Center online help is corrupted or cannot be found (404 error).

Solution: Clear online help files to force SCC to build new ones.

1. Shut down Sybase Control Center.
2. Remove this directory:

<SCC-installation-directory>\SCC-3_2\services
\EmbeddedWebContainer\container\Jetty-6.1.22\work
\Jetty_0_0_0_0_8282_help.war__help__.smpe97
Tip: In Windows, you might see a deletion error. Regardless of what the errors says, it
might be caused by the length of the path. If deletion fails, rename the
Jetty_0_0_0_0_8282_help.war__help__.smpe97 folder to something very
short, such as J. Then delete the renamed folder.

3. Remove these files:
<SCC-installation-directory>\SCC-3_2\services
\EmbeddedWebContainer\container\Jetty-6.1.22\contexts
\_help.xml
<SCC-installation-directory>\SCC-3_2\services
\SybaseControlCenter\help\com.sybase.infocenter.scc.zip
<SCC-installation-directory>\SCC-3_2\services
\SybaseControlCenter\help\help.war
<SCC-installation-directory>\SCC-3_2\services
\SybaseControlCenter\help\help_info.xml

4. Start SCC. After the server comes up it rebuilds the help, which takes a few minutes.
5. To display the help, go to  https://<your-SCC-host>:8283/help/

index.jsp.

Troubleshoot Sybase Control Center for Data Assurance

164



Note: If you try to display the help too soon after restarting, you get a file not found error.
Wait a minute or two and try again.

Data Collections Fail to Complete
Problem: A collection frequently times out or generates errors citing the
REJECT_DUPLICATE_RESOURCE_AND_COLLECTION policy, but no problems with
the monitored resources are evident.

The errors appear in the log and on the collection history screen.

Solution: Try to determine why the collection is taking so long. For example, are network
delays slowing down traffic between Sybase Control Center and the monitored server?

In the case of network delays and other resource-related problems, the interval between
collections might be shorter than the time needed to finish the collection. To fix this problem,
increase the time between collections.

See also
• Modifying the Data Collection Interval for a Job on page 134

Memory Warnings at Startup
Problem: When Sybase Control Center starts, you see warnings about system memory or heap
memory allocation.

Solution: Increase the maximum memory setting (SCC_MEM_MAX or jvmopt=-Xmx).

See also
• Configuring Memory Usage on page 61

SCC Out of Memory Errors
Problem: Sybase Control Center generates OutOfMemory errors.

Solution:

• If the OutOfMemory error says that Sybase Control Center is out of heap space, increase
the maximum memory setting (SCC_MEM_MAX or jvmopt=-Xmx).

• If the OutOfMemory error says that Sybase Control Center is out of permanent
generation space, increase the permanent memory setting (SCC_MEM_PERM or
jvmopt=-XX:MaxPermSize).

• Repeated OutOfMemory errors may indicate a memory leak. OutOfMemory errors
generate heap dumps:
• When Sybase Control Center runs as a service in Windows:

C:/windows/system32
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• When Sybase Control Center runs as a service in UNIX:
<SCC-install-directory>/SCC-3_2/bin

Send the heap dump files to Sybase technical support for analysis.

See also
• Configuring Memory Usage on page 61
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Glossary: Sybase Control Center for Data
Assurance

Definitions of Sybase Control Center terms related to Replication Server Data Assurance
(DA) Option.

availability –  indicates whether a resource is accessible and responsive.

collection –  a named, predefined set of key performance indicators for which values are
collected from monitored servers at the same time. Collections supply the performance and
availability data shown on Sybase Control Center screens and charts. Use the scheduler to
view a list of collections and to control which collections run, how often they run, and the
length of time for which they run.

connection profile –  information required to establish a database connection.

database –  a set of related data tables and other objects that are organized and presented to
serve a specific purpose.

Data Assurance job –  a row comparison or a schema comparison job that defines how a
compareset is compared and when.

Data Assurance system database (DASD) – the DA server database that stores system and
configuration settings.

Data Transfer Stream (DTS) – an application protocol used by DA agent during a
comparison to stream data.

event –  an activity in the system, such as a user logging in, a service starting or stopping, or a
condition changing. Use the alerts feature to detect and notify you about system events.

heat chart –  a graphical view of resource availability and selected performance and status
metrics for all the registered resources in the current perspective.

inconsistent row –  a table row that is present both in primary and replicate databases, but has
different values for one or more of the columns being compared.

Java Database Connectivity (JDBC) – an application program interface (API) that allows
Java applications to access multiple database management systems using Structured Query
Language (SQL).

jConnect –  the Sybase high-performance JDBC driver.

job –  a task performed by the scheduler in Sybase Control Center.

key performance indicator (KPI) –  a single metric used to evaluate the status or
performance of a monitored resource. A KPI value can be a state (such as running, error, or
stopped) or a numerical value. KPIs are grouped into collections (and also, for some product
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modules, into key performance areas, or KPAs). KPI values are collected by scheduled
collection jobs and appear on monitoring screens and in the statistics and heat charts.
Examples of KPIs are resource state and CPU usage.

managed resource – see resource.

missing row –  a table row that is present in the primary, but not in the replicate database.

orphaned row –  a table row that is present in the replicate, but not in the primary database.

perspective –  a named tab in Sybase Control Center that displays information related to a
collection of managed resources (such as servers) and a set of views associated with those
resources. The views in a perspective are chosen by users of the perspective. You can create as
many perspectives as you need, and customize them to monitor and manage your resources.
Perspectives allow you to group resources in ways that make sense in your environment—for
example by location, department, or project.

primary key – a set of table columns that uniquely identifies each row.

product module –  a plug-in component of Sybase Control Center that manages and monitors
a particular Sybase product. SCC product modules are available for Adaptive Server, Data
Assurance (a Replication Server option), replication (Replication Server, Replication Agent,
and Mirror Replication Agent), Sybase Event Stream Processor, and Sybase IQ.

replication –  a process by which the changes to the data in one database—including creation,
updating, and deletion of records—are also applied to the corresponding records in another
database.

repository –  a database in Sybase Control Center that stores information related to managed
resources, along with user preference data, operational data, and performance statistics.

resource –  a server, agent, or other entity that can be monitored or administered by Sybase
Control Center. Resources SCC can manage include Adaptive Server, Data Assurance Server,
Replication Server, Replication Agent, Mirror Replication Agent, Sybase Event Stream
Processor, Sybase IQ, and certain subcomponents.

Replication Server Data Assurance (DA) Option – the Sybase server program that
compares row data and schema between two or more Adaptive Server databases and reports
discrepancies. In Sybase Control Center, the product module that monitors and manages the
Replication Server DA Option is called SCC for DA.

Replication Server system database (RSSD) – the Adaptive Server database containing
Replication Server system tables. You can choose whether to store Replication Server system
tables on the RSSD or the SQL Anywhere (SA) ERSSD.

Remote Method Invocation (RMI) – a remote procedure call used for communication
between DA server and DA agents.

SCC agent –  a remote command and control agent for Sybase Control Center that runs on a
managed server. The SCC agent is installed automatically as part of the Sybase server.
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SCC-enabled login account –  a user account that has been granted privileges in Sybase
Control Center by mapping appropriate Sybase Control Center roles. (Roles are typically
mapped to a group to which the account belongs rather than to the account itself.) The user
account and group can be native to Sybase Control Center or created in the operating system or
the LDAP directory service to which Sybase Control Center authentication is delegated. You
must use an SCC-enabled account to log in to Sybase Control Center.

schedule –  the definition of a task (such as the collection of a set of statistics) and the time
interval at which Sybase Control Center executes the task.

schema – the structure of the database.

Tabular Data Stream (TDS) – an application protocol by which Open Clients and Open
Servers exchange information.

topology –  a graphical representation of how the servers in an environment are connected to
each other. It is a network diagram that provides a visual map of the availability of the
environment.

view (SCC) –  a window in a Sybase Control Center perspective that displays information
about one or more managed resources. Some views also let you interact with managed
resources or with SCC itself. For example, the Perspective Resources view lists all the
resources managed by the current perspective. Other views allow you to configure alerts, view
the topology of a replication environment, and graph performance statistics.
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