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Introduction to Localizing Mobile Workflow
Packages

This tutorial shows you how to use the Mobile Workflow Forms Editor to localize Mobile
Workflow Packages.

All the localizable strings in the Mobile Workflow Forms Editor XML model work as resource
keys in the localization properties file. All the localization properties files are in the same
directory as the Mobile Workflow packages (.xbw files).

Resource keys are divided into these categories, which include all the elements of the Mobile
Workflow Forms Editor XML model:

• Menus
• Controls
• Screens

Localization consists of two levels of localization—the Mobile Workflow Forms Editor XML
model localization and the Mobile Workflow client localization.

Note: Localization is not currently supported for the iPhone or iPad simulators.

Introduction to Localizing Mobile Workflow Packages
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Task Flow

This tutorial shows you how to localize Mobile Workflow packages.

1. Complete the tasks in Getting Started on page 5.
2. Complete the Purchase Order Sample on http://www.sybase.com/products/

mobileenterprise/sybaseunwiredplatform?htab=USE.
3. Complete the tasks in Localizing a Mobile Workflow Package on page 11.

Task Flow
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Getting Started

Goal: Install and learn about Sybase® Unwired Platform and its components.

Prerequisites
Before beginning this tutorial, complete the Tutorial: Mobile Business Object Development
(Eclipse).

Task

The following tasks are required, unless otherwise noted, for all tutorials, but you need to
perform them only once.

1. Installing Sybase Unwired Platform on page 5

2. Starting Unwired Server on page 7

3. (Optional) Connecting to Sybase Control Center on page 6.

4. Starting Sybase Unwired WorkSpace on page 7

5. (Optional) Learning the Basics on page 8

Installing Sybase Unwired Platform
Goal: Install Sybase Unwired Platform.

Install these Sybase Unwired Platform components:

• Unwired Server
• Sybase Unwired WorkSpace

• Mobile Business Object Developer Tools
• Device Application Developer Tools

If the Unwired Platform is already installed and any of these components are missing:

1. Start the Sybase Unwired Platform installer.
2. Follow the instructions in the installation wizard. When prompted, select Custom Install.
3. Select the required components, and complete the installation.

For complete installation instructions, see the Sybase Unwired Platform Installation Guide
and Release Bulletin on Product Manuals. Access http://sybooks.sybase.com/nav/base.do,
and navigate to Sybase Unwired Platform.

Getting Started
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Connecting to Sybase Control Center
Goal: Open the Web-based Sybase Control Center administration console to manage
Unwired Server and its components.

From Sybase Control Center, you can:

• View servers and their status
• Start and stop a server
• View server logs
• Deploy a mobile application package
• Set role mappings

1. Select Start > Programs > Sybase > Sybase Control Center.

Note: If Sybase Control Center does not launch, make sure that the Sybase Unified Agent
service is started. See the Installation Guide for details.

2. Log in using the default login:

• User Name – supAdmin

• Password – s3pAdmin

Logging in to Sybase Control Center (SCC) allows you access to Unwired Platform
administration features that you have been authorized to use. Administrators of any
Sybase product can log into SCC. However, only users assigned to the Super
Administrator or Domain Administrator roles for Unwired Platform can log in to Unwired
Server from Sybase Control Center.

Logging in to SCC only allows you access to the SCC interface. If Unwired Server has not
been authenticated, you will not be able to see or administer any resources.

3. Select Help > Online Documentation  for additional information on configuring,
managing, and monitoring Unwired Server.

Installing Microsoft ActiveSync
Goal: Install and configure Microsoft ActiveSync so you can deploy and run a mobile
application on a Windows Mobile emulator.

Note: Microsoft ActiveSync is for Windows XP. If you are using Windows Vista, Windows 7,
or Windows 2008, install Virtual PC 2007 SP1 and Windows Mobile Device Center to manage
synchronization settings. Download the Windows Mobile Device Center from http://
www.microsoft.com/windowsmobile/en-us/downloads/microsoft/device-center-
download.mspx.

Getting Started
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1. Download Microsoft ActiveSync from http://www.microsoft.com/windowsmobile/en-
us/help/synchronize/device-synch.mspx. Save it to your local machine. Windows XP
requires ActiveSync version 4.5.

2. In Windows Explorer, double-click setup.msi.

3. When installation is complete, restart your machine.

ActiveSync starts automatically, and its icon appears in the Windows toolbar.

4. Double-click the ActiveSync icon.

5. Select File > Connection Settings.

6. Select Allow Connections to One of the Following, then select DMA.

7. Under This Computer is Connected to, select Work Network.

8. Click OK.

Starting Unwired Platform Services
Goal: Start Unwired Server and the sample database.

In Windows, select Start > Programs > Sybase > Unwired Platform<version>  > Start
Unwired Platform Services .

Starting Sybase Unwired WorkSpace
Goal: Start Unwired WorkSpace.

1. In Windows, select Start > Programs > Sybase > Unwired Platform<version> >
Unwired WorkSpace.

Getting Started
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Sybase Unwired WorkSpace opens, and displays the Welcome page with links to product
information, and to the product.

2. To read more about Sybase Unwired WorkSpace concepts and tasks, select Help > Help
Contents from the main menu.

Learning the Basics
Goal: Learn about Sybase Unwired WorkSpace and how to access help.

Prerequisites
Start Unwired WorkSpace.

Task

1. From the Welcome page, select any of the links to familiarize yourself with the Unwired
WorkSpace environment.

To close this page, click the X. You can reopen this page by selecting Help > Welcome.

2. Select Start Development  to access the Sybase Unwired WorkSpace development
environment. Look at the area (window or view) that you will be working in to access,
create, define, and update mobile business objects (MBOs).

View Description

WorkSpace Navigator This view displays mobile application project fold-
ers, each of which contains all project-related re-
sources in subfolders, including MBOs, data source
references to which the MBOs are bound, personal-
ization keys, and so on.

Use this view to review and modify MBO-related
properties.

Enterprise Explorer A window that provides functionality to connect to
various enterprise back-end systems; for example,
database servers, SAP servers, and Sybase Unwired
Server.

Getting Started
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View Description

Mobile Application Diagram A graphical editor where you create and define mo-
bile business objects.

Use the Mobile Application Diagram to create
MBOs (including attributes and operations), then
define relationships with other MBOs. You can:

• Create MBOs in the Mobile Application Dia-
gram using Palette icons and menu selections –
either bind or defer binding to a data source,
when creating an MBO. For example, you may
want to model your MBOs before creating the
data sources to which they bind. This is some-
times called the top-down approach.

• Drag items from Enterprise Explorer and drop
them onto the Mobile Application Diagram to
create the MBO – quickly creates the operations
and attributes automatically based on the data
source being dropped on the Mobile Application
Diagram. This is sometimes called the bottom-
up approach.

Each new mobile application project generates an
associated Mobile Application Diagram.

Palette Access the Palette from the Mobile Application Di-
agram. It provides controls, such as the ability to
create MBOs, add attributes and operations, and de-
fine relationships, by dragging and dropping the
corresponding icon onto the Mobile Application Di-
agram or existing MBO.

Properties view Select an object in the Mobile Application Diagram
to display and edit its properties in the Properties
view. You cannot create an MBO from the Properties
view, but generally, most development and configu-
ration is performed here.

Outline view Displays an outline of the file that is currently open in
the editor area, and lists structural elements. The
contents are editor-specific.

Problem view Displays problems, errors, or warnings that you may
encounter.

3. To access the online help, select Help  > Help Contents from the main menu bar.

Getting Started
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4. Expand any of the documents that appear in the left pane. Some documents are for Sybase
Unwired Platform, while others are for the Eclipse development environment.

Getting Started
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Localizing a Mobile Workflow Package

Use the Mobile Workflow Forms Editor to complete these tasks to localize Mobile Workflow
packages (.xbw files).

Changing the Encoding Type
Goal: Change the encoding type in Preferences.

The localization file is encoded in standard ISO-8859-1. All non-ASCII character values are
converted to escaped Unicode hexadecimal values before they are written to the properties
files. Before translating the localization file, select the correct file encoding option, for
example UTF-8.

1. In Sybase Unwired Platform, select Window > Preferences.

2. Expand General > Content Types.

3. In the right pane, select, Text > Java Properties File.

4. In the File Associations list, select *.properties(locked).

5. In the Default encoding field, change ISO-8859-1 to UTF-8, and click Update.

Localizing a Mobile Workflow Package
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Creating and Validating a New Locale Properties File
Goal: Create a locale properties file as the default locale.

Prerequisites
You must have an existing Mobile Workflow package before you create the locale properties
file. This tutorial uses the Purchase Order sample located at http://www.sybase.com/products/
mobileenterprise/sybaseunwiredplatform?htab=USE as an example.

If you use the PurchaseOrderSample for this tutorial, set up the PurchaseOrder.db:

1. Copy the PurchaseOrder.db and PurchaseOrder.log files to
<UnwiredPlatform_InstallDir>\UnwiredPlatform\Servers
\UnwiredServer\data.

2. In the PurchaseOrderSample > DB folder, right-click run.bat and select Open With
> System Editor to start the database.

Task

1. In WorkSpace Navigator, double-click the PurchaseOrder.xbw to open the Mobile
Workflow Forms Editor.

2. Click the Flow Design tab.

3. Right-click in a blank area on the Flow Design page, and select Show Properties View.

4. In the Properties view, on the left, click the Localization tab.

Localizing a Mobile Workflow Package
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5. In the right pane, click New.

6. Select or enter the information for the new locale, select Automatically create default
locale, and click Finish.

For example:
• Language – select French.
• Country – select France.
• Variant – enter a value to make this locale file unique from others, for example, WM for

Windows Mobile.

Localizing a Mobile Workflow Package
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This locale file is now the default locale file, and will be used when the regional setting of
the device does not match that of any supplied locale file.

7. In the Properties view, in the Localization page, select the file to validate and click
Validate.

The properties file is scanned and if there are any errors, a dialog appears. Click Yes to
correct the errors automatically; click No to see the errors in the Problems view.

Editing the Locale Properties File
Goal: Edit the locale properties file.

1. In WorkSpace Navigator, under the Generated Code folder, right-click the locale
properties file you created, and select Open With > Properties File Editor.

2. You can make and save changes to the file in the Properties File editor, for example, you
can replace all the values of the resource keys with Chinese characters.

3. Select File > Save.

The next time you open the locale properties file, notice that all of the ASCII characters
have been changed.

4. In the Localization pane, select the localization file you edited, and click Load.

The elements of the application in the editor are translated into the language you specified
if the localization file passes the loading validation.

Deploying the Mobile Application Project
Goal: Deploy the mobile business objects to Unwired Server.

Prerequisites
Unwired Server must be running.

Localizing a Mobile Workflow Package
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Task

This tutorial uses the Purchase Order sample located at http://www.sybase.com/products/
mobileenterprise/sybaseunwiredplatform?htab=USE as an example. You can use this
procedure to deploy any mobile application project you are using. The Purchase Order sample
contains three mobile business objects, which must be deployed to Unwired Server—
PurchaseOrder, PurchaseOrderApprover, and PurchaseOrderLineItem.

1. In WorkSpace Navigator, right-click the PurchaseOrderSample folder, and select
Deploy Project.

2. In the Deploy Mobile Application Project wizard, select:

• Update as the deploy mode.
• Message-based.

Localizing a Mobile Workflow Package
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3. Click Next.

4. In the Contents page, select all the mobile business objects (MBOs) and click Finish.

5. In the Deployment status window, click OK.

6. When the deployment completes, click File > Close.

Generating the Mobile Workflow Package
Goal: Generate the package for the localized Mobile Workflow.

Prerequisites

For Windows Mobile:

• If Microsoft ActiveSync is not running, start it now. (Windows XP)
• If Windows Mobile Device Center is not running, start it now. (Windows Vista)

Localizing a Mobile Workflow Package
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Task

1. In the Mobile Workflow Forms Editor, click the code generation icon .

2. In the New Mobile Workflow Package Generation wizard, select the options that are
appropriate for your environment:

Option Description

Favorite configurations (Optional) Select a configuration.

Code Generation and Deployment

Generation folder Select the folder in which to save the .zip file

containing the Mobile Workflow package and
its generated files.

Deploy to an Unwired Server Deploy the Mobile Workflow package to an
Unwired Server.

Unwired Server profile Select the Unwired Server profile with which to
associate the Mobile Workflow package and, if
you are using static authentication, extract the
user name and password credentials.

Deploy the Sybase messaging client to a con-
nected Microsoft Windows Mobile device or
emulator

For Windows Mobile, deploy the Sybase mes-
saging client to the Windows Mobile emulator.

Note: This option requires Microsoft Active-
Sync 4.5 (if you are using Windows XP) or
Windows Mobile Device Center (if you are us-
ing Windows Vista).

Windows Mobile device type Select the Windows Mobile device type.

Perform silent install Perform the deployment on the device without
necessitating user input.

Deployment timeout (minutes) Enter the number of minutes allowed before the
deployment times out.

Start Device Emulator Manager (Windows Mobile) Start the Device Emulator
Manager, which connects and cradles the se-
lected device.

3. (Optional for Windows Mobile) Click Start Device Emulator Manager.

4. (Optional for Windows Mobile) Once the Device Emulator Manager starts, right-click the
device you want to use for testing and select Connect.

5. (Optional for Windows Mobile) Once the emulator launches, in the Device Emulator
Manager, right-click the connected device and select Cradle.

Localizing a Mobile Workflow Package
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Once you cradle the device, it connects to ActiveSync or Windows Mobile Device Center.

6. (Optional for Windows Mobile) Ensure the device is connected in Microsoft ActiveSync
or Windows Mobile Device Center and click OK.

7. In the Mobile Workflow Package Generation wizard, click Finish.

The files for the Mobile Workflow package are generated and stored in the specified
location as a .zip file.

The Mobile Workflow package appears in the Workflows folder under Unwired Server,
and the results of the file generation appear in the Console tab.

Configuring the Device for Localization
Goal: Configure the device.

1. For Windows Mobile:

a) Go to Settings > System > Regional Settings.
b) Click Region.
c) Change the region to the desired locale, for example, French (France) or Chinese

(China).

Localizing a Mobile Workflow Package
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Note: The locales that appear in the Regional Settings depend on what you have
installed on your device.

2. For iPhone devices:

a) Go to Settings > General > International > Language.
b) Change the Language setting to the desired language, for example, Francais, and click

OK.

Localizing a Mobile Workflow Package
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Note: Localization is not supported on the iPhone simulator.

Localizing a Mobile Workflow Package
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Mobile Workflow Package Internationalization

The internationalization feature depends on the internationalization setting on the operating
system where Sybase Unwired Platform Mobile Workflow is running.

In the Mobile Workflow Forms Editor, you can use international data in:

• Matching rules for notifications.

• Key names – you can create keys with names in other languages and map them to mobile
business object parameters.

Mobile Workflow Package Internationalization
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• Generated Code folder – you can include languages other than English in the code
generation path based on the name of the selected language.

Mobile Workflow Package Internationalization
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Internationalization on the Device

On the device, e-mail messages and data can include languages other than English.

The internationalization feature depends on the internationalization setting on the device
where the Mobile Workflow client running.

E-mail messages can be sent and received using Chinese, for example, which can then be used
to extract the parameter. You can also create and update records in using international data,
such as Chinese. For example:

Internationalization on the Device
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Internationalization on the Device
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