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Introduction to Getting Started Tutorials

Introduction to Getting Started Tutorials

Getting started tutorials enable users of all levels to try Sybase® Unwired Platform with
minimal setup. You can also use the tutorials to demonstrate system functionality and train
users.

Overview of Getting Started Tutorials

The getting started tutorials demonstrate how to develop, deploy, and test mobile business
objects, device applications, and message-based mobile workflow packages.

« Learn mobile business object (MBO) basics, and create a mobile device application:
o Tutorial: Mobile Business Object Development
» Tutorial: BlackBerry Application Development using Device Application Designer

e Tutorial: Windows Mobile Device Application Development using Device
Application Designer

« Create native mobile device applications:

o Tutorial: BlackBerry Application Development using Custom Development

»  Tutorial: iPhone Application Development using Custom Development

o Tutorial: Windows Mobile Application Development using Custom Development
« Create a mobile workflow package:

o Tutorial: Mobile Workflow Package Development

The getting started tutorials demonstrate a cross section of basic functionality, which includes
creating MBOs that can be used in replication-based or message-based synchronization; and
using various Sybase Unwired WorkSpace development tools, independent development
environments, and device types.

Table 1. Tutorial summary

Tutorials Mobile Synchroni- |Development | Device
business |zation types [tools types
objects
(MBOs)

Tutorial: Mobile Business Ob- | Create new | Replication- Sybase Unwired | N/A

ject Development MBOs based WorkSpace

Tutorial: BlackBerry Applica- | Reuse Replication- Device Applica- | BlackBerry

tion Development using De- | MBOs based tion Designer

vice Application Designer

Tutorial: Windows Mobile Application Development using

Custom Development
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Tutorials Mobile Synchroni- |Development | Device
business |zation types |tools types
objects
(MBOs)

Tutorial: BlackBerry Applica- | Create new | Replication- Sybase Unwired | BlackBerry

tion Development using Cus- | MBOs based WorkSpace

tom Development

Tutorial: iPhone Application | Create new | Message-based | Sybase Unwired | iPhone

Development using Custom MBOs WorkSpace

Development

Tutorial: Windows Mobile Reuse Replication- Device Applica- | Windows

Application Development us- | MBOs based tion Designer Mobile

ing Device Application De-

signer

Tutorial: Windows Mobile Create new | Message-based | Sybase Unwired | Windows

Device Application Develop- | MBOs WorkSpace Mobile

ment using Custom Develop-

ment

Tutorial: Mobile Workflow Create new | Message-based | Mobile Workflow | Windows

Package Development MBOs Forms Editor Mobile

Understanding the Unwired Platform Development
Environment

Learn more from the getting started tutorials by understanding basic development
environment concepts. Sybase Unwired Platform provides an Eclipse development

environment.

Development in Eclipse

Sybase Unwired WorkSpace is a plug-in to your Eclipse development environment that
provides tools for creating mobile applications.

Unwired WorkSpace includes back-end integration tools that connect Unwired Server to
enterprise data sources, allowing you to create mobile business objects (MBOs) from the
back-end business data model.

Developers can perform MBO code generation at any time and use this MBO model code
along with the user interface code that users write in a native integrated development
environment (IDE). This makes the code available to transition from the Unwired WorkSpace
MBO development tool to the fully extensible and open development environment provided
for device platforms from third-party vendors. Optionally, use the Device Application

Sybase Unwired Platform
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Designer to create prototype device applications for BlackBerry and Windows Mobile
devices.

Developers can use the Mobile Workflow Forms Editor to develop message-based mobile
workflow packages for Windows Mobile and iOS devices.

Understanding Fundamental Mobile Development
Concepts

Learn more from the getting started tutorials by understanding basic mobile development
concepts.

Learn more about these concepts:

»  Fundamentals
o Sybase Unwired WorkSpace — Mobile Business Object Development

Mobile Business Objects
Mobile business objects help form the business logic for mobile applications.

A mobile business object (MBO) is derived from a data source (such as a database server, Web
service, or SAP® server). MBOs are deployed to Unwired Server, and accessed from mobile
device application clients. MBOs include:

* Implementation-level details — metadata columns that include information about the data
from a data source.

« Abstract-level details — attributes that correspond to instance-level properties of a
programmable object in the mobile client, and map to data source output columns.
Parameters correspond to synchronization parameters on the mobile client, and map to
data source arguments. For example, output of a SQL SELECT query are mapped as
attributes, and the arguments in the WHERE clause are mapped as synchronization
parameters, so that the client can pass input to the query.

MBO operations include parameters that map to data source input arguments. Operation
parameters determine information a client passes to the enterprise information system
(EIS).

* Relationships —defined between MBOs by linking attributes and parameters in one MBO,

to attributes and parameters in another MBO.

You can define MBOs using either a top-down approach—first designing attributes and
parameters, then binding them to a data source; or a bottom-up approach—first specifying a
data source, then automatically generating attributes and parameters from it.

A mobile application package includes MBOs, roles, and data source connection mappings,
and other artifacts that are delivered to the Unwired Server during package deployment.

Tutorial: Windows Mobile Application Development using 3
Custom Development
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Synchronization Methods

Developers can use either replication-based or message-based synchronization to move data
and transactions between device application clients and Unwired Server.

The choice depends on the target device platform, application requirements, target platform,
and the nature of data changes and activity between Unwired Server and clients, for example,
mobile workflow forms always use message-based synchronization.

Unwired Server manages and maintains data freshness between multiple data sources and
device application clients through synchronization.

Application Types

Sybase Unwired Platform supports two choices for application type. First is the native
application type, and the other is the container-based business workflow type.

The native application model enables the developer to write custom code (C#, Java, or
Objective-C, depending on the platform) to create a device application. The native application
model is supported on BlackBerry, iOS, Windows Mobile, and Windows platforms. The
choice depends on the functionality desired in the application, and the need to access third-
party and platform-provided APIs. Optionally, use the Device Application Designer to create
prototype device applications for BlackBerry and Windows Mobile devices.

The business workflow model offers a fast and simple way to build applications that support
simple business workflows, such as approvals and requests. The workflow model is supported
on iOS, Windows Mobile, and Windows platforms.

Data Sources

A data source is the enterprise information system where data is retrieved from and
transactions are executed. A connection profile is a design-time connection to a data source.
Connection profiles are created to specific data source by providing connection information
such as host, port, login, and password among others. The connection profiles are used to
define MBOs and operations, and mapped to existing, or used to create new, server
connections when the package is deployed to Unwired Server..

Unwired Platform hides the interaction complexity with datasource-specific protocols, such
as JDBC™ for database and SOAP for Web services.

Unwired Platform currently supports multiple EIS connection types. See Supported Third-
Party Software and Hardware for information.

Switching Between Developer Profiles
Switch between basic and advanced developer profiles in the Mobile Application Diagram.

If you do not see an Unwired WorkSpace feature (wizard, property, or WorkSpace Navigator
item) that you expect or need, switch to the advanced developer profile, or modify developer

4 Sybase Unwired Platform
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profile settings. To use backend data sources other than those supplied by Sybase Unwired
Platform, you must switch to the advanced developer profile to see the Server Connection
Mapping page when deploying the Mobile Business Object package.

1. Right-click in the Mobile Application Diagram and select Switch Developer Profile >
Basic/Advanced.

2. You can also select Window > Preferences > Sybase, I nc. > Mobile Development >
Developer Profile to directly view or modify the developer profile preference settings.
Basic is the default developer profile.

Tutorial: Windows Mobile Application Development using 5
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Task Flow

Sybase Unwired WorkSpace Eclipse tutorials explain how to develop, deploy, and run a

mobile application.

Table 2. Eclipse tutorials

Task

Goals

Steps required to complete the
task

Getting Started

 Install all required WorkSpace
components and external re-
sources.

» Start Unwired Server, then use
Sybase Control Center to con-
nect to the server.

*  Open the Mobile Development
perspective, and become famil-
iar with the views of the per-
spective, the Mobile Applica-
tion Diagram, and the Device
Application Designer.

» Installing Sybase Unwired Platform
on page 9

o Installing Microsoft ActiveSync on
page 9

e Starting Unwired Platform Services
on page 10

e Starting Sybase Unwired Work-
Space on page 10

e Connecting to Sybase Control Cen-
teron page 11

o Learning the Basics on page 11

Note: These steps are prerequisites for
the rest of this tutorial. You need to per-
form them only once.

Developing Data-
base Mobile Busi-
ness Objects

» Create a mobile application
project and a connection to the
database.

» Create two mobile business ob-
jects, and create a relationship
between them.

« Deploy the mobile business ob-
jects to Unwired Server.

Complete the Tutorial: Mobile Business
Object Development.

Tutorial: Windows Mobile Application Development using 7
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Task Goals Steps required to complete the
task

Developing a Win-

» Generate code for the Windows | «  Deploying the Database Mobile
dows Mobile De-

- o Mobile platform, code a Win- Business Objects on page 15
vice Application dows Mobile device applica- | «  Generating C# Object API Code on
tion, and run it on an emulator. page 17

»  Creating the User Interface for the
Windows Mobile Device Applica-
tion on page 19

» Installing Sybase Messaging Run-
time on page 30

»  Registering the Emulator in Sybase
Control Centeron page 30

»  Configuring Connection Settings on
page 32

»  Deploying and Running the Device
Application on page 32

8 Sybase Unwired Platform
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Getting Started

Goal: Install and learn about Sybase Unwired Platform and its associated components.

The following tasks are required, unless otherwise noted, for all tutorials, but you need to
perform them only once.

1. Installing Sybase Unwired Platform on page 9
2. Starting Unwired Platform Services on page 10
3. Starting Sybase Unwired WorkSpace on page 10
4. (optional) Learning the Basicson page 11

Installing Sybase Unwired Platform
Goal: Install Sybase Unwired Platform.

Install these Sybase Unwired Platform components:

o Data Tier

e Unwired Server

e Unwired WorkSpace

» Device Application Designer

« Windows Mobile .NET components (for developing device applications in Visual Studio)

If Unwired Platform is already installed and any of these components are missing:

1. Start the Sybase Unwired Platform installer.
2. Follow the instructions in the installation wizard.
3. Select the required components, and complete the installation.

For complete installation instructions, see the Sybase Unwired Platform Installation Guide
and Release Bulletin.

Installing Microsoft ActiveSync

Goal: Install and configure Microsoft ActiveSync so you can deploy and run a mobile
application on a Windows Mobile emulator.

Note: Microsoft ActiveSync is for Windows XP. If you are using Windows Vista, Windows 7,
or Windows 2008, install Virtual PC 2007 SP1 and Windows Mobile Device Center to manage
synchronization settings. Download the Windows Mabile Device Center from Attp.//
www.microsoft.com/windowsmobile/en-us/downloads/microsoft/device-center-
download.mspx.

Tutorial: Windows Mobile Application Development using 9
Custom Development
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Getting Started

1. Download Microsoft ActiveSync from http.//www.microsoft.com/windowsmobile/en-
us/help/synchronize/device-synch.mspx. Save it to your local machine. Windows XP
requires ActiveSync version 4.5.

2. In Windows Explorer, double-click setup.msi.

3. When installation is complete, restart your machine.
ActiveSync starts automatically, and its icon appears in the Windows toolbar.
4. Double-click the ActiveSync icon.
5. Select File> Connection Settings.
6. Select Allow Connectionsto One of the Following, then select DMA.
7. Under This Computer is Connected to, select Work Network.
@) Connection Settings
Device connected
@ Connect, .. |
[+ Showe skakus icon in taskbar
[~ allow USE connections
[+ &llow connections ko one of the Fallowing:
foma =]
This computer is connected to:
IWork Mebwark ﬂ
¥ ©Open ActiveSync when my device connects
v allow wireless connection on device when connected to the desktop
Help | a4 I Zancel
8. Click OK.

Starting Unwired Platform Services

Goal: Start Unwired Server and the sample database.

In Windows, select Start > Programs > Sybase > Unwired Platform<version> > Start
Unwired Platform Services.

Starting Sybase Unwired WorkSpace
Goal: Start Unwired WorkSpace.

1. In Windows, select Start > Programs > Sybase > Unwired Platfor m<version> >
Unwired Wor k Space.

10 Sybase Unwired Platform
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Getting Started

Sybase Unwired WorkSpace opens, and displays the Welcome page with links to product
information, and to the product.

2. To read more about Sybase Unwired WorkSpace concepts and tasks, select Help > Help
Contents from the main menu.

Connecting to Sybase Control Center

Goal: Open the Web-based Sybase Control Center administration console to manage
Unwired Server and its components.

From Sybase Control Center, you can:

« View servers and their status

» Start and stop a server

* View server logs

« Deploy a mobile application package
« Set role mappings

1. Select Start > Programs > Sybase > Sybase Control Center.

Note: If Sybase Control Center does not launch, make sure that the Sybase Unified Agent
service is started. See the Installation Guide for details.

2. Log in using the default login:
e User Name — supAdm n
e Password — s3pAdmi n

Logging in to Sybase Control Center (SCC) allows you access to Unwired Platform
administration features that you have been authorized to use. Administrators of any
Sybase product can log into SCC. However, only users assigned to the Super
Administrator or Domain Administrator roles for Unwired Platform can log in to Unwired
Server from Sybase Control Center.

Logging into SCC only allows you access to the SCC interface. If Unwired Server has not
been authenticated, you will not be able to see or administer any resources.

3. Select Help > Online Documentation for additional information on configuring,
managing, and monitoring Unwired Server.

Learning the Basics

Goal: Learn about Sybase Unwired WorkSpace and how to access help.

Prerequisites
Start Unwired WorkSpace.

Tutorial: Windows Mobile Application Development using 11
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Task

1. From the Welcome page, select any of the links to familiarize yourself with the Unwired

WorkSpace environment.

To close this page, click the X. You can reopen this page by selecting Help > Welcome.

2. Select Start Development to access the Sybase Unwired WorkSpace development
environment. Look at the area (window or view) that you will be working in to access,
create, define, and update mobile business objects (MBOS).

View

Description

WorkSpace Navigator

This view displays mobile application project fold-
ers, each of which contains all project-related re-
sources in subfolders, including MBOs, data source
references to which the MBOs are bound, personal-
ization keys, and so on.

Use this view to review and modify MBO-related
properties.

Enterprise Explorer

A window that provides functionality to connect to
various enterprise back-end systems; for example,
database servers, SAP servers, and Sybase Unwired
Server.

12
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View Description

Mobile Application Diagram A graphical editor where you create and define mo-
bile business objects.

Use the Mobile Application Diagram to create
MBOs (including attributes and operations), then
define relationships with other MBOs. You can:

¢ Create MBOs in the Mobile Application Dia-
gram using Palette icons and menu selections —
either bind or defer binding to a data source,
when creating an MBO. For example, you may
want to model your MBOs before creating the
data sources to which they bind. This is some-
times called the top-down approach.

« Drag items from Enterprise Explorer and drop
them onto the Mobile Application Diagram to
create the MBO — quickly creates the operations
and attributes automatically based on the data
source being dropped on the Mobile Application
Diagram. This is sometimes called the bottom-
up approach.

Each new mobile application project generates an
associated Mobile Application Diagram.

Palette Access the Palette from the Mobile Application Di-
agram. It provides controls, such as the ability to
create MBOs, add attributes and operations, and de-
fine relationships, by dragging and dropping the
corresponding icon onto the Mobile Application Di-
agram or existing MBO.

Properties view Select an object in the Mobile Application Diagram
to display and edit its properties in the Properties
view. You cannot create an MBO from the Properties
view, but generally, most development and configu-
ration is performed here.

Outline view Displays an outline of the file that is currently openin
the editor area, and lists structural elements. The
contents are editor-specific.

Problem view Displays problems, errors, or warnings that you may
encounter.

3. To access the online help, select Help > Help Contents from the main menu bar.

Tutorial: Windows Mobile Application Development using 13
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4. Expand any of the documents that appear in the left pane. Some documents are for Sybase
Unwired Platform, while others are for the Eclipse development environment.

14 Sybase Unwired Platform



Developing a Windows Mobile Device Application

Developing a Windows Mobile Device
Application

Generate code for the Windows Mobile platform, develop a Windows Mobile device
application with code, and test its functionality.

Prerequisites
Complete these tasks:

e Getting Started on page 9

» Finish the Tutorial: Developing Database Mobile Business Objects.
» Install Windows Mobile 6 Professional SDK.

« Install Microsoft NET Compact Framework 3.5

» The Sybase Unwired Platform Windows Mobile .NET components must be installed. See
Installing Sybase Unwired Platform on page 9.

* Visual Studio 2008 must be installed.

Task

Complete these tasks to develop the device application:

1. Open the SUP101 Mobile Application Project if it is not already open:

In WorkSpace Navigator, right-click the SUP101 folder and select Open in Diagram
Editor.

Deploying the Database Mobile Business Objects on page 15

Generating C# Object API Code on page 17

Creating the User Interface for the Windows Mobile Device Application on page 19
Installing Sybase Messaging Runtime on page 30

Registering the Emulator in Sybase Control Centeron page 30

Configuring Connection Settings on page 32

Deploying and Running the Device Application on page 32

© N o OO wWwD

Deploying the Database Mobile Business Objects

Goal: Deploy the project that contains the database mobile business objects to the server.

Prerequisites
Finishthe Tutorial: Developing Database Mobile Business Objects. You must be connected to
both the sampledb database and Unwired Server.

Tutorial: Windows Mobile Application Development using 15
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Task

1. Right-click in the SUP101 Mobile Application Diagram , and select Deploy Project.

2. On the first page of the Deploy Mobile Application Project, accept the defaults, select
M essage-based, and click Next.

+ 4 Deploy Mobile Application Project

Deploy Mode and Target Yersion

Specify deploy mode and target version for the deployment, The package name is case-insensitive in server,

—Deploy Mode
* Update
Updates the target package with updated ohjects. After deployment, objects in the
target server"s package with the same name as those being deploved are updated.
' No Overwrite

Deploys the package only if there are no objects in the target server's package that
have the same name as any of the objects being deployed.

" Replace

Replaces any of the target objects with those in the package. After deployment, the
server"s package contains only the objects being deployed.
 Werify

Do not deploy, only return errars, if any, Used ko determine the effect of a
deployment using the Update setting.

Target version: | 1.0

Package name: I SUP101

" Replication-based ¥ Message-based

oy
'\‘?,' < Back Mext = Firish | Cancel |
L\%

3. On the Contents page, select the customer and sales order MBOs and click Next.
4., On the Package Jars page, click Next.

Note: This window appears only if you are using the Advanced developer profile.
5. On the Target Server page, from the list of available servers, select My Unwired Server
and click Refresh (or connect to the server, if not already connected).

Once connected, accept the default Domain and Security configuration settings, and click
Next.

6. If you have multiple server connections, you see the Server Connection Mapping page.
Select the sampledb server connection and click Finish.

16 Sybase Unwired Platform
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“> Deploy Mobile Application Project

Server Connection Mapping —

Map connection profiles ko server connections

Connection profile | Server conneckion

@sampledb.sampledb sampledb Rl
anil
clusterdb

sampledbl
=Mew Server Conneckion ... >

7. When the Deployment status window shows the deployment was successful, click OK.
8. Connect to Unwired Server and view the deployed project.
a) In the Enterprise Explorer, click My Unwired Server.

My Unwired Server is a default Unwired Server connection profile that provides
access to Unwired Server, which you started in a previous step.

b) Expand Domains> default > Packages. The server package suyp101:1.0, into which
you deployed the MBOs, appears in the Packages folder. The two MBQOs appear in the
Mobi | e Busi ness bj ect s folder.

Generating C# Object APl Code

Generate Object API code for Windows Mobile devices.

Prerequisites
You must be connected to both the sampledb database and Unwired Server.

Task

1. InWorkSpace Navigator, right-click the SUP101 project folder and select Gener ate Code
to launch the Code Generation wizard.

2. Select Continue without a configuration and click Next.

Note: This page of the code generation wizard is seen only if you are using the Advanced
developer profile.

3. In Select Mobile Objects, select the customer and sales order MBOs in the SUP101
mobile application project.

Tutorial: Windows Mobile Application Development using 17
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Dependent MBOs are automatically added (or removed) from the Dependencies section
depending on your selections.

Note: Code generation fails if the server-side (run-time) enterprise information system
(EIS) data sources referenced by the MBOs in the project are not running and available to
connect to when you generate object API code.

4. Click Next.
5. Enter the information for these configuration options:

Option Description

Language Select C#.

Platform Select NET Compact Framework 3.5 for
Windows M obile.

Unwired Server Select the My Unwired Server connection
profile.

Server domain Select default.

Page size Leave blank. This will be a message-based ap-

plication, and the page size option is not ena-
bled for message-based applications.

Namespace Enter SUP101.

Destination Specify the destination of the generated device
client files, \ SUP101. Select Clean up des-
tination before code generation to clean up
the destination folder before generating the de-
vice client files.

Replication-based Unselect this option. This tutorial uses the
M essage-based synchronization option.

Message-based Select this option to use message-based syn-
chronization.

Backward compatible This option is disabled.

6. Select Generate metadata to generate metadata for the attributes and operations of each
generated client object.

7. Click Finish.

18 Sybase Unwired Platform
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Creating the User Interface for the Windows Mobile Device
Application

Goal: Create the user interface for an application that runs on a Windows Mobile device, and
accesses the database mobile business objects.

Note: This procedure includes code snippets you can copy and paste for your project. Click
SUP_WM_Custom_Dev_Tutorial _code.zipto access the text files that include the code
snippets for the Cust oner Sanpl e, Cust oner Li st , and Cust oner Sanpl eScr een
CH files.

If you are viewing this guide as a PDF, you can locate the referenced document at Attp.//
infocenter.sybase.com/. Go to Sybase Unwired Platform 1.5.5 > Tutorial: Windows Mobile
Application Development using Custom Developmentto launch this PDF.

1. Open the generated Visual Studio solution in Visual Studio 2008.

2. In the Solution Explorer, right-click the SampleApp project and select Add > Windows
Form.

3. Inthe Add New Item dialog, select Windows For m from the Categories and Templates,
enter Cust oner s as the form name, and click Add.

Add Mew Item - SampleApp E

Categaries! Templates:

¥isual Studio installed templates

4 5earch Online Templates. .,

Data [ Inherited Form | Inherited User Contral
. General rﬁ_’l Component Class ﬁCustom Control
----- Web & Design-Time Attribute File (3] User Control
----- Windows Forms =] Windows Form
My Templates

I & blank Windows Form

MName: Customersl s

Add

Cancel

An empty form, Customer s, displays on the Customer.cs[Design] tab.
4. Repeat Step 2 to add another Windows Form to the SampleApp project, and hame this one

Custoner Details.

Tutorial: Windows Mobile Application Development using

Custom Development
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Developing a Windows Mobile Device Application

5. Click the Customers.cs[Design] tab to go back to the Customers form.

6. From the Toolbox, drag and drop four buttons from SUP Device Controls onto the
form.
7. Select each button, and in the Properties view, change the Text of the buttons to:
* buttonl — Subscri be
e button2 — Ref r esh
e button3 — Updat e
* button4 — Send

8. In the Toolbox, select ListView from Common Device Controls, and drag and drop it
onto the Customers form.

Toolbox ~ 1 x
=¥ ImageList -

A Label

A LinkLabel

=3 ListBox J

137 ListvView

= MainMenu

- MessageQueue

[ MonthCalendar

Notification

(¥ NumericUpDown -

:Tﬂ OnenFieDialon ﬂ
9. Inthe Toolbox, select Textbox from Common Device Controls, and drag and drop it onto

the Customers form.

10. Inthe Customer sform, click the ListView, then in the Properties pane, set FullRowSelect
to True.
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Properties + 1 %
listView1 System.Windows.Forms.ListView &
=2t |8] 7
B Ap = -
BackColor [ ] window
CheckBoxes False
B Font Tahoma, 9pt
ForeColor Bl windowText
FulRowSelect True| -
View Largelcon
(=R
Activation Standard
Columns (Collection)
ContextMenu (none)
Enabled True
_ _I-Eeade_rSt_ylg Clickable ﬂ
FullRowSelect

Indicates whether all SubItems are highlighted alo...

11. In Customers, select the Textbox, then in the Properties pane, set these properties:
e Scrollbars — Vertical
e Read-only — True
e Multi-line — True

Properties

Location 3, 202 -
Locked Falze
MaxLength 3ZTET
Modifiers Private
Tultiline True ;I
PasswordChar
Readinly True
ScrollBars Yertical

Size 234,21 -
TabIndex 5
Tab3top True % -

12. Arrange the controls on the Customers form so they look like this:
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Customers

I Update SErC l

13. Save the Cust oner s. cs form.
14. Click the Customer Details.cs[Design] tab.

15. From the Toolbox, drag and drop three labels onto the Customer Details form. Align them
on the left side of the form. In the Properties view, in the Text field, rename the labels Cust
ID, First Name, and Last Name.

16. From the Toolbox, drag and drop three text boxes onto the Customer Details form and
align them to the right of each of the three labels.

17. Select the textbox next to Cust ID and, in the Properties view, change the Read-only
property to True.

18. From the Toolbox, drag and drop a button from SUP Device Controlsonto the Customer
Details form below the labels and text boxes, and in the Properties view, in the Text field,
rename the button to Submit.

The form will look like this:

Customer_Details

Cust ID
First Mame

Last Mame

Subrmit
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19. In the Solution Explorer, right-click Pr ogr am cs, and select View Code.
20. Add the following code:

/1] <summary>

/1] The main entry point for the application.

/1] </summary>private static Customers _fornl = new Formil();
usi ng System

usi ng Sanpl eApp;
usi ng System W ndows. For ns;

nanespace Sanpl eApp

static class Program
{
private static Custoners _forml = new Custoners();
private static Custoner_Details _forn2 = new
Cust oner_Detai | s();
private static string _custid;

public static string getCustoner()

{
return _custid;
}
public static void setCustomer(string custid)
{
_custid = custid;
}
public static Custonmers getFornil()
{
return _formi;
}
public static Custoner_Details getForn2()
{
return forng;
}

static void Main(string[] args)

Application. Run(_forml);

}

21. In Solution Explorer, in the SampleApp project, right-click Customer s.csand select View

Code.

22. Add the following code:

usi ng System

usi ng System Col | ecti ons. Generi c;
usi ng Syst em Conponent Model ;

usi ng System Dat a;
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usi ng System Dr awi ng;

usi ng System Text;

usi ng System W ndows. For ns;
usi ng SUP101;

nanespace Sanpl eApp

publ i c del egate voi d Del egat eAddString(String s);
public partial class Custoners : Form

Del egat eAddSt ri ng m Del egat eAddSt ri ng;
publ i c Customers()
{
InitializeConponent();
m Del egat eAddSt ri ng = new
Del egat eAddStri ng(this. AddStri ng);
}

private void AddString(String s)

{
text Box1. Text +=s + "\r\n";
t ext Box1. Sel ectionStart = textBoxl. Text. Length;
t ext Box1. Scrol | ToCaret ();
t ext Box1. Refresh();
}

private void Subscribe_Cick(object sender, EventArgs e)

/1 This checkes to see if the database exists, then
deletes it if it does.
i f (SUP101DB. Dat abaseExi sts())

SUP101DB. Del et eDat abase() ;
AddStri ng(" Dat abase del eted");

}

el se

/1 This creates the database.
SUP101DB. Cr eat eDat abase() ;

/1 To receive call backs, you nmust register a
Cal | BackHandl er

/1w th the generated database class, the entity cl ass,
or both. This

//code creates and registers a handler to receive
cal | backs.

MyCal | backHandl er cal | back new MyCal | backHandl er () ;
MyCal | backHandl er . t ext Box1 = text Box1;
SUP101DB. Regi st er Cal | backHandl er ( cal | back) ;
/1 This operation starts background synchroni zati on for
t he dat abase cl ass.
SUP101DB. St art Backgr oundSynchr oni zati on() ;
AddStri ng(" Background synchroni zation started");

try
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/1 This calls SUP101, the package dat abase, user name
and password to connect to the Unwired Server.
SUP101DB. Logi nToSync( " supAdni n", "s3pAdm n");

catch (Exception ex)

Li st <LogRecordlnpl > |rs =

LogRecor dl npl . Fi ndW t hQuer y( new Sybase. Persi st ence. Query());
AddString("log record count=" + |rs. Count);
for (int i =0; i < Irs.Count; i++)

AddString(lrs[i].Message);
}

/I For message-based replication, before you can
synchroni ze MBO changes with the server, you nust subscribe to
t he
[/ mobi | e application package depl oyed on the server by
cal li ng Sanpl eAppDB. subscri be(). This al so downl oads certain data
/1to devices for those that have default values. otify
the server of your subscription to a specific package.
//1f you are not subscribed to the SUP101 package, a
message will tell you to subscribe first.
SUP101DB. Subscri be();
AddString("Subscribe request sent");
AddLi st Vi ew() ;

}

private void refresh_Cick(object sender, EventArgs e)

i f (SUP101DB. | sSubscri bed())

{
Cursor. Current = Cursors.WitCursor;
AddString("Refresh data");
AddDat aToLi st Vi ew() ;
Cursor.Current = Cursors. Defaul t;
}
el se
AddString("Pl ease Subscribe first");
}

}
private void AddLi stView)

this.listViewl.d ear();

I'istViewl. Col ums. Add("I1d", listViewl. Wdth / 4,
Hori zont al Al i gnnment . Left);
i stViewl. Col ums. Add("First Nane", |istViewl. Wdth /
3, Horizontal Alignment. Center);
I'istViewl. Col ums. Add("Last Name", listViewl. Wdth / 3,

Hori zont al Al i gnnent . Ri ght) ;
listViewl. View = View Details;
|'i stVi ewl. Ful | RowSel ect = true;
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private void AddDat aTolLi st Vi ew)

this.listViewl. d ear();

|'istViewl.Col ums. Add("Id", listViewl. Wdth / 4,
Hori zont al Al'i gnnent . Left);
listViewl. Col ums. Add("First Name", listViewl. Wdth /
3, Horizontal Alignnment. Center);
l'istViewl. Col ums. Add("Last Narme", listViewl. Wdth / 3,

Hori zont al Al i gnnent . Ri ght) ;
listViewl.View = View. Details;
|'i st Vi ewl. Ful | RowSel ect = true;

Li st <Custonmer> c¢ = Custoner. FindAl | ();
if (c.Count > 0)

for (int i =0; i < c.Count; i++)
ListViewltemitem = new
ListViewmtem(c[i].ld. ToString());
i tem Subltens. Add(c[i].Fnane);

item Subltens. Add(c[i].Lnane);
listViewl.|tens. Add(item;

}

private void update_Cick(object sender, EventArgs e)

if (listViewl. Focusedlitem!= null)

{
Pr ogram set Cust omer (| i st Vi ewl. Focusedl t em Text);
Program get Forn2(). Visible = true;
Program get Fornil(). Visi ble = fal se;
}
el se
MessageBox. Show( " Pl ease select a row');
}
private void Send_Click(object sender, EventArgs e)
{
Cust oner. Submi t Pendi ngOper ati ons() ;
}

public class MyCal | backHandl er
Sybase. Per si st ence. Def aul t Cal | backHandl er

{
public static TextBox textBoxl = new Text Box();

private void invokeDel egate(string s)

Custoners f = Program get For mL();
f.lnvoke(f.mDel egat eAddString, new Object[] { s });

}
/1 Called when login fails.
public override void OnLogi nFail ure()
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i nvokeDel egate("Login failed");

/1 Called when a replay request succeeds.
public override void OnRepl aySuccess(object o)

{

i nvokeDel egat e(" Operation replay successful ");

}
//Called when a replay request fails.
public override void OnRepl ayFai |l ure(object o)

{

i nvokeDel egat e(" Operati on Replay failed");

}
//Call ed when the | ast

i mport

nmessage i s successfully

processed regardi ng the subscribe request.
public override void Onlnport Success()

{

i nvokeDel egat e(" I nport successful");

}

}

23. Click the Customers.cs[Design] tab to go back to the Customers form design view.

24. Add the event handlers to the buttons:

a) Click the Subscribe button on the form, and in the Properties view for the button, click
the Event icon (lightning bolt), then next to the Click databinding, select

Subscribe Click from the list.

Properties

buttonl Svbase,UriwiredPlatform, Windows, Forms, Bukbon

=2 a7l

(DataBindings)
Subscribe_Click

Doubleclick
EnabledChanged
GotFocus
HelpRequested
KeyDown
KevPress

Keyllp
LostFocus
MauseDawn
MauseMaowve

Fonsel In

Click
Oceurs when the conkral is clicked,

a) Repeat this step for each button, selecting these events for each Click databinding:

Tutorial: Windows Mobile Application Development using
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* Refresh —refresh_Click
* Update — update Click
* Send - Send_Click

25. In Solution Explorer, in the SampleApp project, right-click Customer Details.csand
select View Code.

26. Add the following code:
usi ng System

usi ng System Col | ections. Generi c;
usi ng Syst em Conponent Model ;

usi ng System Dat a;

usi ng System Dr awi ng;

usi ng System Text;

usi ng System W ndows. For ns;

usi ng SUP101;
nanespace Sanpl eApp

public partial class Custoner Details : Form

{
Cust orrer t hi sCust oner ;
publ i c Customer_Detail s()

{
}

private void submit_Cick(object sender, EventArgs e)

InitializeConponent();

t hi sCust omer . Fname = t ext Box2. Text ;
t hi sCust oner . Lnane = t ext Box3. Text;

/I When cal | ed, the Save nmet hod determines, internally, if

it should

/linsert or update data to the client database.
t hi sCust omer . Save() ;
Program get Forni(). Visi bl e
Pr ogram get Forn2(). Visi bl e

true;
f al se;

}
private void AddDat aToFor m()

t ext Box1. Text = Program get Custoner();

int id = Int32. Parse(Program get Custoner());
//Retrieves data fromthe | ocal database.

t hi sCust omer = Custoner. Fi ndByPri maryKey(id);

t ext Box2. Text = thi sCustoner. Fnane;

t ext Box3. Text = thi sCustoner. Lnane;

}

private void Custoner_Details_Load(object sender, EventArgs

AddDat aToFor () ;
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private void Custoner_Detail s_paint(obj ect sender,
Pai nt Event Args e)

AddDat aToFor () ;

27.Inthe Customer_Details.cs[Design] view, click the Submit button and in the Properties
view for the button, add the submit_Click event to the Submit button.

28.Add events to the Cust oner Detail s. cs:
a) Click the Customer Details.cs[Design] tab
b) In the Properties view for Customer_Details.cs, click the Events icon (lightning bolt).
¢) InLoad, add the Customer_Details L oad event.
d) In Paint, add the Customer_Details paint event.

Properties

Customer_Details Syster,\Windows,Forms,Farm -

=HAE
EnablediChanged -~

GotFocus
HelpRequested

KeyDawn

KeyPress

KeyUp

Load Customer_Details_Load
LostFocus

MauseDown

MouseMove b
Mousellp

TR o _Detais_paint - |
-

Parenthanned

Paint
Occurs when a control needs repainting.

29. In the main menu, select File > Save All.

30. Add the generated C# object API project (from the previous section) into the SampleApp
solution. This helps ensure the project includes DLL references needed for compilation.

31. Build the project by pressing Cont r ol +Shi f t +B.
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Installing Sybase Messaging Runtime

Start the Device Emulator Manager and install Sybase Messaging Runtime.

Prerequisites
Installing Microsoft ActiveSync on page 9

Task

. In Visual Studio, select Tools > Device Emulator Manager.
. Fromthe list of devices, right-click WindowsM obile 6 Professional Emulator and select

Connect.

. Right-click again on Windows M abile 6 Professional Emulator and select Cradle.

Microsoft ActiveSync appears.

. If the Microsoft ActiveSync configuration window appears, click Cancel.
. In Microsoft ActiveSync, click Explore.
. In the Mobile Device window, double-click My Windows M obile-based Device.

The device's file system root folder opens.

. Navigate to <Unwi r edPl at form_I nstal | Di r >\ Unwi r edPl at f orm

\ Server s\ Unwi redServer\ d i ent APl \ MoMessagi ng\ wmand copy the
SUPMessagi ng_Pr o. cab file to the device's My Documents folder.

. Use File Explorer on the device emulator to browse to the MyDocumnent s

\ SUPMessagi ng_Pr o. cab file.

. Click on SUPMessagi ng_Pr o. cab once to start the installation.

Registering the Emulator in Sybase Control Center

Goal: Use Sybase Control Center to register the emulator.

Prerequisites
Complete Connecting to Sybase Control Centeron page 11.

Task

1. Log in to Sybase Control Center using the supAdni n/ s3pAdni n user name and

password.
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2. In Sybase Control Center, select View > Select > Unwired Server Cluster M anagement
View.
3. Select Device Users.
4. In the right pane, click Devices.
5. Click Register.
6. In the Register Device window, enter the required information:
e User name
e Server name
e Port
e Farm ID - set to 0 (zero).
» Activation code
Register Device
Select the user name and template for the device registration.
select the user name and template for the device registration.
User name: uzerl
Ternplate: | Default A
Custornize the following activation fields:
Server name: localhost, sybase, com
Fort: SO0l
Farm ID: Farml
Activation code length:
Activation expiration (hours): 77
|¥] specify activation code: 123
fig cancel |
Note: The information should match the input on the client and "localhost.sybase.com™
should be the actual name of your machine and domain.
7. Click OK.
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Configuring Connection Settings

Goal: Configure the connection settings on the emulator.

Note: This tutorial used a Windows Mobile 6.0 Professional Edition emulator. If you use a
different emulator version, user interface will vary slightly from this tutorial.

1. On the emulator, select Start > Programs.
2. Double-click Sybase Settings.
3. Inthe Sybase Settings screen, click Connection.

4. In the Connection screen, enter the connection settings. These settings should match the
values you used when you registered the device in Sybase Control Center.

» Server Name — the machine and domain where Unwired Server is running, for
example, | ocal host . sybase. com

e Server Port-5001

e Farm ID - Far mlL

e Username —-userl

e Activation Code — 123

Note: "localhost.sybase.com" should be the name of the machine where Unwired Server is
running.

5. Click Done.

Deploying and Running the Device Application

Goal: Deploy the device application to a Windows Mobile 6 device emulator, and test its
functionality.

1. In the Visual Studio Solution Explorer, right-click the SampleApp project, and select
Build.

2. In the Visual Studio toolbar, click the green arrow to the left of Debug, select Windows
M obile 6 Professional Emulator in the Target Device combobox and click Deploy.

Window  Help

| f Debug -

The device application is deployed to the emulator and runs in debug mode.
3. In the device emulator, click Subscribe.
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"

L date

When you are successfully subscribed, a message appears in the text box saying the
subscription request was sent.

4. When you see the "Refresh data" message, click Refresh to populate the Customers table
data in the list view.

vy Customers

First Marme | Last Mame |

Refresh data
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"y | Customers

"SUbscribe

Id First Marme | Last Marmne

101 Michaels Davin =]
102 Beth Raeizer
103 Etin Miedringh. ..

104 Meghan Masan
105 Laura McCarthy
106 Paul Philllips
107 Kelly Calburn
102 Matthesw Goforth
109 Jessie Gagliardo

4]

Irmport successful

l | L date l

You see an "Import successful” message. If you see the message but do not see the
customer list, click Refresh again.

5. Select the customer record, Beth Reiser, with the Id 102 from the customer list and click
Update.

6. In the customer details screen, change the customer's First Name to SUP and click
Submit.

7. In the Customers screen, click Refresh.

The changed record appears at the bottom of the customer list because the change has not
yet been sent to the server.

8. Click Send.
9. After you see the "Operation Reply successful” message, click Refresh.
The updated record shows in the customer list.

D
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Learn More about Sybase Unwired Platform

Once you have finished, try some of the other samples or tutorials, or refer to other
development documents in the Sybase Unwired Platform documentation set.

Getting Started Tutorials
Try out some of the other getting started tutorials to get a broad view of the development tools
available to you.

Advanced Tutorials
Tutorials are available that demonstrate how to use some of Sybase Unwired Platform
advanced features.

Check the Sybase Product Documentation Web site regularly for updates: Attp.//
infocenter.sybase.com/help/index.jsp?topic=/com.sybase.infocenter.pubs.docset-
SUP-1.5.5/doc/htmi/title.html.

Samples
Sample applications are fully developed, working applications that demonstrate the features
and capabilities of Sybase Unwired Platform.

Check the Sybase Web site regularly for updates. Navigate to the Sybase Web site, then select
Products > Sybase Unwired Platform > Use tab. http.//www.sybase.com/products/
mobileenterprise/sybaseunwireaplatform?htab=USE.

Online Help
See the online help that is installed with the product, or the Product Manuals Web site.

Check the Sybase Product Documentation Web site regularly for updates: Attp.//
infocenter.sybase.com/help/index.jsp?topic=/com.sybase.infocenter.pubs.docset-
SUP-1.5.5/doc/htmi/title. html.

Developer References
See the Developer References to learn about using the API to custom code device applications
using the API.

»  Developer Reference for BlackBerry

» Developer Reference for iOS

» Developer Reference for Mobile Workflow Packages

o Developer Reference for Windows and Windows Mobile

Check the Sybase Product Documentation Web site regularly for updates: Attp.//
infocenter.sybase.com/help/index.jsp ?topic=/com.sybase.infocenter.pubs.docset-
SUP-1.5.5/doc/htmi/title. html.
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Javadocs are also available in the installation directory.

Programmer References

See the Programmer References to learn how to use the Administration API and Server API to
extend functionality.

e Reference: Administration APIs — integrate your own administrative tools with Unwired
Platform to monitor and manage Unwired Platform.

» Reference.: Custom Development for Unwired Server — customize some Unwired Server
features.

Check the Sybase Product Documentation Web site regularly for updates: Atp.//
infocenter.sybase.com/help/index.jsp?topic=/com.sybase.infocenter.pubs.docset-
SUP-1.5.5/doc/htmi/title. html.

Javadocs are also available in the installation directory.
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