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Introduction to Developer Reference for
Mobile Workflow Package

This developer reference provides information about using Sybase® Unwired Platform
features to create Mobile Workflow packages. The audience is Mobile Workflow developers.

This guide describes requirements for developing a Mobile Workflow package, how to
generate Mobile Workflow package code, and how to deploy the Mobile Workflow package to
the device or simulator.

Companion guides include:

• Sybase Unwired WorkSpace – Mobile Business Object
• Sybase Unwired WorkSpace – Device Application Development
• Tutorial: Mobile Workflow Package Development
• Troubleshooting for Sybase Unwired Platform

Documentation Road Map for Unwired Platform
Learn more about Sybase® Unwired Platform documentation.

Table 1. Unwired Platform documentation

Document Description

Sybase Unwired Platform Installation Guide Describes how to install or upgrade Sybase Un-
wired Platform. Check the Sybase Unwired Plat-
form Release Bulletin for additional information
and corrections.

Audience: IT installation team, training team,
system administrators involved in planning, and
any user installing the system.

Use: during the planning and installation phase.

Sybase Unwired Platform Release Bulletin Provides information about known issues, and
updates. The document is updated periodically.

Audience: IT installation team, training team,
system administrators involved in planning, and
any user who needs up-to-date information.

Use: during the planning and installation phase,
and throughout the product life cycle.

Introduction to Developer Reference for Mobile Workflow Package
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Document Description

New Features Describes new or updated features.

Audience: all users.

Use: any time to learn what is available.

Fundamentals Describes basic mobility concepts and how Syb-
ase Unwired Platform enables you design mobi-
lity solutions.

Audience: all users.

Use: during the planning and installation phase,
or any time for reference.

System Administration Describes how to plan, configure, manage, and
monitor Sybase Unwired Platform. Use with the
Sybase Control Center for Sybase Unwired Plat-
form online documentation.

Audience: installation team, test team, system
administrators responsible for managing and
monitoring Sybase Unwired Platform, and for
provisioning device clients.

Use: during the installation phase, implementa-
tion phase, and for ongoing operation, mainte-
nance, and administration of Sybase Unwired
Platform.

Sybase Control Center for Sybase Unwired Plat-
form

Describes how to use the Sybase Control Center
administration console to configure, manage and
monitor Sybase Unwired Platform. The online
documentation is available when you launch the
console (Start > Sybase > Sybase Control Cen-
ter, and select the question mark symbol in the
top right quadrant of the screen).

Audience: system administrators responsible for
managing and monitoring Sybase Unwired Plat-
form, and system administrators responsible for
provisioning device clients.

Use: for ongoing operation, administration, and
maintenance of the system.

Introduction to Developer Reference for Mobile Workflow Package
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Document Description

Troubleshooting Provides information for troubleshooting, solv-
ing, or reporting problems.

Audience: IT staff responsible for keeping Syb-
ase Unwired Platform running, developers, and
system administrators.

Use: during installation and implementation, de-
velopment and deployment, and ongoing main-
tenance.

Getting started tutorials Tutorials for trying out basic development func-
tionality.

Audience: new developers, or any interested user.

Use: after installation.

• Learn mobile business object (MBO) basics,
and create a mobile device application:
• Tutorial: Mobile Business Object Devel-

opment
• Tutorial: BlackBerry Application Devel-

opment using Device Application De-
signer

• Tutorial: Windows Mobile Device Ap-
plication Development using Device Ap-
plication Designer

• Create native mobile device applications:
• Tutorial: BlackBerry Application Devel-

opment using Custom Development
• Tutorial: iPhone Application Develop-

ment using Custom Development
• Tutorial: Windows Mobile Application

Development using Custom Develop-
ment

• Create a mobile workflow package:
• Tutorial: Mobile Workflow Package De-

velopment

Sybase Unwired WorkSpace – Mobile Business
Object Development

Online help for developing MBOs.

Audience: new and experienced developers.

Use: after system installation.

Introduction to Developer Reference for Mobile Workflow Package
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Document Description

Sybase Unwired WorkSpace – Device Applica-
tion Development

Online help for developing device applications.

Audience: new and experienced developers.

Use: after system installation.

Developer references for device application cus-
tomization

Information for client-side custom coding using
the Client Object API.

Audience: experienced developers.

Use: to custom code client-side applications.

• Developer Reference for BlackBerry
• Developer Reference for iPhone
• Developer Reference for Mobile Workflow

Packages
• Developer Reference for Windows and Win-

dows Mobile

Developer reference for Unwired Server side
customization – Reference: Custom Develop-
ment for Unwired Server

Information for custom coding using the Server
API.

Audience: experienced developers.

Use: to customize and automate server-side im-
plementations for device applications, and ad-
ministration, such as data handling.

Dependencies: Use with Fundamentals and Syb-
ase Unwired WorkSpace – Mobile Business Ob-
ject Development.

Developer reference for system administration
customization – Reference: Administration APIs

Information for custom coding using administra-
tion APIs.

Audience: experienced developers.

Use: to customize and automate administration at
a coding level.

Dependencies: Use with Fundamentals and Sys-
tem Administration.

Introduction to Developer Reference for Mobile Workflow Package

  4 Sybase Unwired Platform  



Mobile Workflow Development

Mobile workflow forms allow the user to update, delete, or create data even when they are not
connected to the network. When they are connected, the data is automatically sent and
received.

When designing mobile workflow forms using the Mobile Workflow Application Designer,
the data source for the application is supplied by mobile business objects that are designated as
messaging mobile business objects when deployed to the server. Using the Mobile Workflow
Application Designer allows you to develop mobile workflow screens that can call on the
create, update, and delete operations, as well as object queries, of a mobile business object.

The Mobile Workflow package is a lightweight form container consisting of XML files that
reference an MBO package, an MBO in that package, and the operation or object query to call
along with a mapping of which key values map to parameter values. This enables the creation
or modification of MBO data on multiple different device platforms without requiring custom
development. Workflow packages are .zip files, which can easily be moved between
installations.

On Windows Mobile platforms, Mobile Workflow packages are integrated with the Outlook
Mail inbox, and on Symbian devices they are integrated with the Global/SMS Inbox.

Mobile Workflow packages are deployed through the Mobile Workflow Forms Editor and
managed through the Sybase Control Center console—no device interaction is required from
the administrator. Once a mobile workflow package is deployed into an existing installation,
the administrator can configure the mobile workflow package and assign it to any active user
in the system.

Architectural Overview
Sybase Unwired Platform is a solution architecture that includes multiple components:

• Sybase Unwired Server: Sybase Unwired Server allows users to package and deploy
mobile applications. The runtime server handles enterprise data source and application
access, communication between the back-end data source and the mobile device, security,
transaction processing, and scheduling.

• Sybase Control Center: Sybase Control Center (SCC) for Unwired Server is a Web-based
console used to configure and manage Unwired Server and its components. Because it is a
Web console, multiple administrators can access different components from a single
access point.

• Sybase Unwired WorkSpace: Sybase Unwired WorkSpace is a development environment
designed specifically for mobile application development, testing, and deployment to
assist developers in rapidly moving from development to deployment. You can use

Mobile Workflow Development
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Unwired WorkSpace to mobilize data, applications, services, and processes, with support
for both online and offline access. Unwired WorkSpace works like a plug-in to your
Eclipse development environment, providing the tools you need to create mobile
applications.
Experienced developers will already be familiar with WorkSpace's consistent use of
Windows, Explorers, Views, Wizards, and Preferences specific to their development
environment. Developers new to Eclipse can use online help cheat sheets (Eclipse edition
only), samples, and tutorials to quickly becomes familiar.

Workflow Package Overview
These are the basic components of a Workflow package.

Starting points
There are four kinds of starting points:

• Start – initiated manually by the user when they open a Workflow form from the Workflow
menu on the device.

• E-mail Subscription – initiated when the user opens an e-mail on the device in which the
e-mail fields’ contents meet the conditions specified in the Workflow packages' matching
rules.

• Credential Request – sent by the server when it needs authentication information for
Unwired Platform.

• Activate – initiated when the Workflow package is used for the first time on the user’s
device.

Mobile Workflow Development
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Screens and navigations
Navigations represent transitions from a starting point to a screen, or from one screen to
another.

New screens are opened when the user clicks on a menu item or a row in a listview control.
Screens can also be opened upon success or failure of an operation.

Series of screens are designed from a starting point. Screens appear one at a time on the device.
Screens are opened on a stack, and closed in the reverse of the order in which they were added.
Each screen contains one or more controls.

Controls and keys
There are seven types of controls—Checkbox, EditBox, Choice, Slider, Signature, HtmlView
and Listview.

HtmlView and Listview controls, if present on a screen, must be the only control on that
screen.

EditBox controls have a logical type—Text, Numeric, Date, DateTime or Time. Depending on
which logical type is chosen, the control at runtime may behave differently, for example, for
Date, a datepicker control is available to the user.

Mobile Workflow Development
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The contents of the controls are bound to keys. When the screen is opened, the value
associated with that key determines what appears in that control. When the control’s contents
are updated, the value associated with that key change accordingly.

For starting points initiated by the server, such as an e-mail subscription, you can specify
where the value associated with a given key will come from, for example, as an MBO attribute.

When a menu item is bound to an MBO operation or object query, each parameter of the
operation or object query is bound to a key. When the operation or object query is invoked, the
value passed into each parameter is the value associated with the corresponding key.

Menu items
There are seven types of menu items:

• Save – closes the current screen, validates the current input and, if validation succeeds,
saves it.

• Cancel – discards any changes on the current screen and closes it. No validation occurs.
• Close – discards any changes on any open screens and closes all open screens. No

validation occurs.
• Open – opens a different screen.
• Add – opens a different screen, where you can add a new row to a listview.
• Submit – validates the entered data on open screens and sends it to the server. There, the

server invokes the specified MBO operation or object query. If the Submit is
asynchronous, the client application closes once the request is sent. If the Submit is
synchronous, the client application stays open.

• Add/Update/Delete Listview Row – specifies the MBO operation that is associated with
the appropriate action on the listview. These operations will not be invoked immediately,
but will instead be invoked when a Submit is made on the parent MBO to which this MBO
is related. It can be added only to screens that are navigated to as the result of a Listview
Details navigation, for example, by clicking on a row in a listview.

Mobile Workflow Development
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Mobile Workflow Development Lifecycle

1. Open or import a mobile application project with pre-created mobile business objects
(MBOs).

2. Connect to Unwired Server.
3. Create a new Mobile Workflow Package using the Mobile Workflow Forms Editor.
4. Generate screens by dragging and dropping MBOs and/or MBO operations from

WorkSpace Navigator to the Flow Design page.
5. Manually create, delete and/or edit screens, controls, menus, screen navigations, and so

on.
6. Generate the Mobile Workflow package and deploy it to Unwired Server.
7. Assign the Mobile Workflow package to the user in Sybase Control Center.
8. Run, test and debug the Mobile Workflow package on the device.

Server-initiated Versus Client-initiated Mobile Workflows
The server-initiated and client-initiated workflow models can co-exist within one workflow
package.

A server-initiated workflow is always initiated by an e-mail notification. Unwired Server
receives e-mail notifications from a master account and, in turn, delivers a workflow message

Mobile Workflow Development Lifecycle
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to an individual device based on configured distribution and mobile business object (MBO)
extraction rules.

With the client, or device-initiated workflow, the user can open the workflow form on his or
her mobile device and create an MBO, which is then replayed against the linked server MBO
package.

Identify a Business Process for Workflow Development
The first step is identifying whether a workflow package can implement a decision point in a
particular business process.

Workflow packages enable a decision step or triggering of a business process, essentially
mobilizing a small decision window in a business process. While some business processes
require a thick application with business logic and access to reference data, some others do
not. Sometimes a business process can be made mobile simply by providing the ability to
capture a single "Yes" or "No" from a user, or by providing the ability to send data in structured
form into the existing backend systems.

A typical Workflow package allows creating a mobile business object (MBO) and sending it to
the Unwired Server, or retrieving an MBO from the Unwired Server and displaying that
information in a decision step. A more complex Workflow package could involve an
application that uses synchronous Submit menu items to invoke various create, update, or
delete operations and/or object queries all in the same flow. Keep in mind that with workflow
packages, there is no local data persistence.

An example of a business process that would be a suitable mobile workflow would be the
ability of an employee to use a mobile device to submit an expense report while out of office,
or to report on their project activities.

Define Mobile Business Objects
Define and develop the mobile business objects to use in the Mobile Workflow package.

Mobile Business Objects
Mobile business objects help form the business logic for mobile applications.

A mobile business object (MBO) is derived from a data source (such as a database server, Web
service, or SAP® server). MBOs are deployed to Unwired Server, and accessed from mobile
device application clients. MBOs include:

• Implementation-level details – metadata columns that include information about the data
from a data source.

• Abstract-level details – attributes that correspond to instance-level properties of a
programmable object in the mobile client, and map to data source output columns.

Mobile Workflow Development Lifecycle
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Parameters correspond to synchronization parameters on the mobile client, and map to
data source arguments. For example, output of a SQL SELECT query are mapped as
attributes, and the arguments in the WHERE clause are mapped as synchronization
parameters, so that the client can pass input to the query.
MBO operations include parameters that map to data source input arguments. Operation
parameters determine information a client passes to the enterprise information system
(EIS).

• Relationships – defined between MBOs by linking attributes and parameters in one MBO,
to attributes and parameters in another MBO.

You can define MBOs using either a top-down approach—first designing attributes and
parameters, then binding them to a data source; or a bottom-up approach—first specifying a
data source, then automatically generating attributes and parameters from it.

A mobile application package includes MBOs, roles. and data source connection mappings,
and other artifacts that are delivered to the Unwired Server during package deployment.

MBO Deployment Requirements
When developing a workflow package, the mobile business object must be deployed as a
messaging MBO in a Mobile Application project to the Unwired Server.

For more information on the message-based synchronization model, refer to the Sybase
Unwired Platform Fundamentals Guide.

Performing Server-side Development
This describes creating the server-side code for a mobile application, including creating
mobile business objects and binding to a data source.

You can follow similar workflows to create mobile applications using a variety of data sources
(like a Web service, database, SAP®, Remedy, or document).

1. Creating a Data Source Connection Profile on page 12Creating a Data Source
Connection Profi: A connection profile contains the connection property information
needed to connect to a server in your enterprise.

2. Creating a Sybase Unwired Server Connection Profile on page 12: Create a new Sybase
Unwired Server connection profile to supply runtime connection information.

3. Creating a Mobile Application Project on page 13: A mobile application project is the
container for the mobile business objects that forms the business logic of mobile
applications.

4. Creating a Mobile Business Object by Dragging and Dropping a Data Source on page
14: Create a mobile business object (MBO), define the attributes and operations, and bind
directly to the data source by dragging and dropping the data source onto the Mobile
Application Diagram.

Mobile Workflow Development Lifecycle
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5. Deploying a Mobile Application Project on page 14: Deploy a Mobile Application
project directly to an Unwired Server, and optionally create a reusable deployment
profile.
On completing these procedures, the server-side development is complete. You can
continue development by creating the workflow package for the client device as described
in Develop a Mobile Workflow Package on page 17.

Creating a Data Source Connection Profile
A connection profile contains the connection property information needed to connect to a
server in your enterprise.

1. In the Enterprise Explorer, right-click one of the following connection categories and
select New.

• Database Connections
• SAP Servers
• Web Services
• Rest Web Services

2. Follow the instructions on the wizard pages to create the selected connection.

Creating a Sybase Unwired Server Connection Profile
Create a new Sybase Unwired Server connection profile to supply runtime connection
information.

1. In Enterprise Explorer, right-click Unwired Servers and select New.

2. Enter a name and optional description of the connection profile and click Next.

3. Complete the following information on the wizard pages:

Table 2. Specify Connection Details page

Field Description

Host The host name on which the server resides. The
default is the machine name.

IP domain (Optional) The domain name. The default is the
Windows domain of the local machine.

Port The port to which you are connecting. The de-
fault port is 2000, use 2001 for HTTPS.

User Name Enter the name for the server login. The default
user name is supAdmin.

Password Enter the password for the server login, if re-
quired. For example, s3pAdmin.

Mobile Workflow Development Lifecycle
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Field Description

Save Password Select the checkbox to save the password.

Secure Select the checkbox to enable a secure connec-
tion with the server, which is different than an
HTTPS connection.

To establish an HTTPS session with Unwired
Server, you must:
1. Enable Secure management port on Un-

wired Server's administration listener. See
the Sybase Control Center help topic for
information.

2. Enter 2001 as the Port.
3. Add the certificate file path to the <Un-

wired_Plaform_In-
stall_Dir>\Eclipse\Unwir-
edWorkSpace.bat file.

Note: Unless the Unwired Server adminis-
tration listener certificate is signed by a
trusted certificate authority, or the certifi-
cate is imported into the %JAVA_HOME%
\jre\lib\cacerts trust store, you
see an error message when testing the Un-
wired Server connection: "unable to find
valid certification path to requested target".

Cluster information The read-only properties for this Server's clus-
ter displays Relay Server information, or, if no
relay server is set, displays non-cluster Un-
wired Server connection information.

Relay Server connection information includes
host, port, and URL suffix for messaging-based
and replication-based synchronization.

4. Click Next to review a summary of this connection profile, or Finish to create the
connection profile. The connection profile displays under Unwired Servers in the
Enterprise Explorer.

Creating a Mobile Application Project
A mobile application project is the container for the mobile business objects that forms the
business logic of mobile applications.

You must create a mobile application project before you can create mobile business objects.

1. Select File > New > Mobile Application Project from the main menu bar.

Mobile Workflow Development Lifecycle
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2. Enter a:

• Name
• Location (if other than the default).

3. Click Finish.

An empty Mobile Application Diagram opens.

Creating a Mobile Business Object by Dragging and Dropping a Data Source
Create a mobile business object (MBO), define the attributes and operations, and bind directly
to the data source by dragging and dropping the data source onto the Mobile Application
Diagram.

Deploying a Mobile Application Project
Deploy a Mobile Application project directly to an Unwired Server, and optionally create a
reusable deployment profile.

Prerequisites

A connection profile to at least one Unwired Server must be available before you deploy a
Mobile Application project to a server.

Task

1. Right-click the Mobile Application project and select Deploy Project.

Alternatively, you can launch the deployment wizard, which automatically sets the
Unwired Server portion of the wizard, by dragging a Mobile Application project folder
from Workspace Navigator and dropping it on the Unwired Server in Enterprise Explorer
to which you are deploying.

Note: As an option, you can press F9 when your cursor is in the Mobile Application
Diagram to launch the Deployment wizard for the corresponding project. If a deployment
profile exists for the project, F9 performs quick deployment of the project according to the
profile.

2. Enter the deployment mode, target version, Package namespace, and click Next.

3. Select the contents to be deployed and click Next.

4. Select a target server for the project and click Next.

If a server connection has been open a long time without activity (a day or two for
example), the connection may time out without your knowledge. While you may still be
able to select the target server, deployment fails. Verify you have a working connection by
pinging the server. If necessary, reconnect to the Unwired Server to which you are
deploying from Enterprise Explorer.

5. Map connection profile to server connections – You must map design-time connection
profiles to server-side (run-time) enterprise information system (EIS) data sources

Mobile Workflow Development Lifecycle
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referenced by the MBOs in the project. Deployment fails if the EIS data sources are not
running and available to connect to. To map the connection profile to a server connection,
select the connection profile from the list of available connection profiles then select the
corresponding server connection to which it maps.

Contact the system administrator in cases where your development environment permits
access to systems that the Unwired Server prohibits.

Note: You can also modify server connection properties (Web service connections only).

6. If a logical role is defined in your MBO, map logical roles to physical roles. If there are no
logical roles defined, this page is skipped. Click Next.

7. (Optional) Specify the name and location for the new deployment profile:

• Save the deployment settings as a deployment profile – if you do not save your settings
to a deployment profile, they are lost when you exit the Deploy wizard.

• Enter or select the parent folder – by default, Deployment is the folder in which the
deployment profile is saved.

• File name – the name of this deployment profile. The deployment profile is assigned
a .deploy extension.

8. Click Finish to deploy the project to the Unwired Server's Packages folder.

Mobile Workflow Development Lifecycle
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Develop a Mobile Workflow Package

Sybase Mobile Workflow Forms Editor enables the creation or modification of mobile
business objects on different device platforms without requiring custom device development.

Mobile workflow are useful for supporting the occasionally connected user and solving the
replication and synchronization issues the occasionally connected user presents for the back-
end system. The user can update, delete, or create data even when they are not connected to the
network. When they are connected, the data is automatically sent and received.

A Mobile Workflow application requires an integration module on the server side. This
module is responsible for processing the e-mail messages identified by matching rules
configured for the e-mail subscription starting point and processing the responses sent to the
server from the device. The Mobile Workflow Forms Editor allows you to create the forms that
can be assigned to the devices that have the Sybase Mobile Workflow application installed
through Sybase Control Center.

When designing mobile workflow forms using the Mobile Workflow Forms Editor, the data
source for the application is supplied by mobile business objects that are designated as
messaging mobile business objects when deployed to the server. Using the Mobile Workflow
Forms Editor allows you to develop mobile workflow screens that can call on the Create,
Update, and Delete operations as well as object queries of a mobile business object.

You can generate a mobile workflow form that works on these platforms:

• Apple iPhone and iPod Touch
• Windows Mobile
• Nokia Symbian

See the Sybase Unwired Platform Installation Guide for supported version levels.

When designing the user interface for mobile workflow forms for mobile devices, the goal is
to keep it simple. The mobile workflow form should deliver clear, concise content with
minimal navigation menus. The mobile workflow should be compatible with a wide variety of
devices and should support both horizontal and vertical screen layouts. Keep in mind the
limitations of mobile devices when designing a mobile workflow form.

The Mobile Workflow Forms Editor
Use the Mobile Workflow Forms Editor to develop mobile workflow forms.

The Mobile Workflow Forms Editor contains these pages:

Introduction

Develop a Mobile Workflow Package
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Create a new mobile workflow or double-click an existing one, to open the Introduction page
of the Mobile Workflow Forms Editor. This page is the starting point for designing your
mobile workflow form. You can access help from this page.

Flow Design

The Flow Design page displays an empty canvas if you did not choose any of starting points in
the New Mobile Workflow Forms Editor. If you selected a starting point when creating the
new mobile workflow form, the selected starting point appears.

Use this page to specify how starting points and screens link together. The Palette view on the
right shows available starting points, screens, and connections. You can drag and drop items
from the Palette to the canvas. Screens and starting points that you drag to the Flow Design
canvas appear as icons. Double-click a screen to open the Screen Design page.

Right-click anywhere in the Flow Design page to open a context menu.

Screen Design

Use this page to design the screen of your mobile workflow form. The Palette view shows the
menu items and controls you can use to design a new screen. Drag controls to design the user
interface.

Creating a New Mobile Workflow Form
Access the Sybase Mobile Workflow Forms Editor.

Prerequisites
You must have an existing project in which to create the mobile workflow form.

Task

1. In the Mobile Development perspective, select File > New > Mobile Workflow Forms
Editor.

2. Follow the instructions in the New Mobile Workflow Forms Editor wizard:

Field Description

Enter or select the parent folder Select the mobile application project in which
to create the mobile workflow form.

File name Enter a name for the mobile workflow form.
The extension for mobile workflow forms
is .xbw.

Advanced Link the mobile workflow form to an existing
file in the file system.
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Field Description

Link to file in the file system Click Browse to locate the file to which to link
the mobile workflow form. Linked resources
are files or folders that are stored in the file
system outside of the project's location. If you
link a resource to an editor, when you select the
editor, the resource is selected in the Work-
Space Navigator. Conversely, when you select
the resource in the WorkSpace Navigator, the
editor is selected.

3. In the Starting Points page, select the ways the mobile workflow will start:

• Can be started on demand from the client – allows the user to start the mobile
workflow on the device and submit data to the server.

• Responds to server-driven e-mail notifications – when an e-mail message that
matches the defined matching rules arrives in the master inbox, it is then sent as a
workflow e-mail message to the devices that match those matching rules. When you
select this option, you will set up the e-mail subscription starting point in the next
screens of the wizard. Follow the procedure for Creating an E-mail Subscription
Starting Point.

• Has setup options that need to be set when the client application is first activated –
the first time the workflow is launched, the screen pointed to by the Activation screen is
shown.

• Credentials (authentication) may be requested dynamically from the client
application – select to create a credential request starting point with pre-defined
username and password keys.

4. (Optional) If you selected the Responds to server-driven e-mail notifications option in
the previous step, follow the procedure in Creating an E-Mail Subscription Starting
Point.

5. Click Finish.

6. In the Mobile Workflow Forms Editor, click Flow Design to start designing the mobile
workflow form.

Flow Design Page Properties
These are the Flow Design page properties shown in the Properties view when no objects in the
Flow Design page are selected.

General

Property Description

Module name The name of the module.
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Property Description

Module version The version of the module.

Module description Enter a description for the module.

Module display name Enter the name that appears on the workflow ap-
plication when it is viewed on the client.

Delete message after processing Select to delete the message after it is processed.

Mark message as processed after processing Select to mark the message as processed after it is
processed.

Client icon Select the icon that appears on the client.

Rulers and grid

Property Description

Display • Show ruler

• Show grid

• Grid in front

Measurement • Ruler units

• Grid spacing

Grid line • Color

• Style

Snap to grid Automatically align objects to the grid lines on
the canvas.

Snap to shapes Position objects to grid lines that go through the
vertical and horizontal edges of other objects.

Localization

Property Description

New Launch the New Locale wizard and create a new
locale file for the mobile workflow application.

Update Update the currently loaded locale file.

Load Load a locale properties file to the Mobile Work-
flow Designer.

Develop a Mobile Workflow Package

  20 Sybase Unwired Platform  



Property Description

Validate Select a locale properties file and click to validate.

Edit Select the locale properties file, then click to edit
the locale properties file.

Remove Select the locale properties file to remove, then
click to remove.

Matching rules
Any existing matching rules appear in the matching rules Properties view. Matching rules
determine how e-mail messages are redirected at runtime.

Property Description

New Create a new matching rule.

Delete Select a matching rule and click to delete.

Edit Select a matching rule and click to edit.

Authentication

Property Description

Use static credentials Select when the authentication field is the same
for all users accessing the resource.

Use SUP server connection profile authentication Use properties from the connection profile to
supply credential data for authentication. This is
similar to hard-coded credentials but the creden-
tials are taken from the specified server connec-
tion profile instead of being specified in the Mo-
bile Workflow Forms Editor.

Use hard-coded credentials Specify a user name/password combination for
authentication.

User name This field is editable only if you selected the hard-
coded credentials option. Enter the user name to
use for authentication.

Password This field is editable only if you selected the hard-
coded credentials option. Enter the password to
use for authentication.
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Property Description

Unwired Server domain Optionally specify the Sybase Unwired Platform
domain to use. If specified, a context variable is
created in the application for which the initial
value is set to this domain. At runtime, when de-
termining authentication, @<domain> is added
to the user name, thus allowing the user access to
that domain.

Flow Design Palette Options
Use the items in the Mobile Workflow Forms Editor Flow Design palette to configure the
screens and connections for the mobile workflow application.

Connections

Connection Description

Go to Specifies which screen the user goes to upon
completing an action on the current screen, such
as clicking OK or Next.

Operation success Specifies which screen the user automatically
goes to upon successful completion of an opera-
tion.

Operation error Specifies the screen that the user goes to auto-
matically when an error occurs while attempting
to complete an operation.

Listview details Specifies which screen to open when a row in a
listview is clicked. Once on the details screen,
you can add, update, or delete rows from the list-
view.

Listview add Specifies a screen that can be directly navigated
to in order to add a new row to the listview.

Screen

Select the screen  and click the Flow Design page to create a new empty screen.
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Starting points

Starting point Description

Activate The Activate starting point indicates a screen that
is displayed to the user the only the first time they
open the application. It is not displayed the sec-
ond and subsequent times the application is
opened. For example, you might want to use an
Activate starting pint to show usage instructions
for the application to the user the first time they
open the application.

Credential request Provide the credentials for authentication. During
execution, authentication credentials are evalu-
ated in this order:

1. User-defined user name and password keys

2. Credential cache

3. Specified generic credential pair

E-mail subscription Use this starting point to define the matching
rules for the widget and to specify how to extract
values from e-mail messages and map them to
mobile business object read and search parame-
ters.

Start The mobile business object referencing starting
point.

Screen Design Page Properties
These are the Screen Design page properties shown in the Properties view when no objects in
the Screen Design page are selected.

General
These are the general properties for the screen.

Property Description

Name The name of the screen.

Key The key associated with the screen.
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Property Description

Background color Click Color picker to choose a background color
for the screen.

You can also enter the value manually. The pos-
sible values are black, blue, brown, gray, green,
orange, pink, purple, red, white, yellow, any
string with the format #rrggbb, where rr, gg

and bb are the hexadecimal values, in the range 0
to ff(255), for the red, green and blue.

Note: The background color for screens can be
set only for Windows Mobile devices. It is not
supported for Symbian or Apple devices.

OK action Select the action that will be performed when the
user clicks OK on the screen.

Rulers and grid
The ruler and grid properties are applied to the Screen Design page, or canvas.

Property Description

Display • Show ruler

• Show grid

• Grid in front

Measurement • Ruler units

• Grid spacing

Grid line • Color

• Style

Snap to grid Automatically align objects to the grid lines on
the canvas.

Snap to shapes Position objects to grid lines that go through the
vertical and horizontal edges of other objects.
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Screen Design Palette Options
Use the items on the palette to design the screen for the mobile workflow application.

Option Description

Menu item Use to provide additional options for the top-level
menu on the screen.

Checkbox Displays a true/false (or yes/no) option on the
screen.

Editbox Select the logical type for the edit box, then enter
text and assign values to strings, dates, decimals,
integers, and so on.

Choice Display a collection of items on the screen as a
drop-down list from which the user can choose.

Slider Represent numeric values within a range.

Signature Add a signature box to the screen. The value is a
list of points that, combined, make up the signa-
ture that gets or is drawn to the control, for ex-
ample, -1x-1,5x7,5x8,-1x-1, where -1x-1 is in-
terpreted as an interruption of a line drawn to the
screen.
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Option Description

HtmlView Allows text with HTML markup to display on the
screen. For example, this code:

<H2>Travel Request App 1.0</H2> 
This application enables vaca-
tion requests to be 
sent for approval.<br>Contact 
Dan at extension 1234 
for technical support.

displays like this on the device:

Note: The HtmlView control fills the entire
screen of a workflow form, so no other controls
can be placed on a screen that hosts an HtmlView
control.

Develop a Mobile Workflow Package

  26 Sybase Unwired Platform  



Option Description

ListView Displays lines that can be clicked on to show fur-
ther details of the selected line. This facilitates the
navigation for a one-to-many mobile business
object relationship. For example, the listview
could contain the items of a sales order. When a
line in the sales order is clicked on, a details
screen for that sales order appears.

Note: The ListView control fills the entire screen
of a workflow form, so no other controls can be
placed on a screen that hosts a ListView control.

Mobile Workflow Forms Editor Context Menus
Right-click in any of the pages (except the Introduction page) of the Mobile Workflow Forms
Editor to display a context menu and perform these actions.

Option Description

Edit Edit the selected object.

Delete Delete the selected object.

Mobile Business Object References Shows current mobile business object references
and allows you to create new mobile business
object references and edit or delete existing mo-
bile business object references.

Note: This menu item appears only on the Flow
Design page.

Generate Mobile Workflow Package Generate the mobile workflow form code.

Send an E-mail Send an e-mail from the Mobile Workflow Forms
Editor to a device user. This can be used to quick-
ly test e-mail triggered applications. The test e-
mail bypasses the Notification Mailbox.

Note: The Cc and Bcc fields are used only for
matching rules. An e-mail is not sent to the users
entered in these fields.
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Option Description

Select Select:

• All – selects all objects on the page.

• All shapes – selects all shapes on the page.

• All connections – selects all connections on
the page.

Arrange All Arranges the shapes on the page.

View View:

• Grid

• Rulers

• Page breaks

• Recalculate page breaks

• Snap to grid

Zoom Select from the zoom options.

Show Properties View Shows the Properties view for the selected object.

Sending a Test E-mail
Send a test e-mail from the Mobile Workflow Forms Editor to a device user to test e-mail
triggered workflow forms.

1. Right-click in the Flow Design or Screen Design page of the Mobile Workflow Forms
Editor and select Send an e-mail.

2. Fill out the e-mail form and click Send.

Note: The Cc and Bcc fields are used only for matching rules. An e-mail is not sent to the
users entered in these fields.

The e-mail bypasses the Notification Mailbox.

3. (Optional) Click Get Device Users to bring up a list of registered device users to which
you can send the e-mail.

Starting Points
Starting points specify which screen on the workflow application a user sees when they
perform a certain action.

Starting points include:
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• Start – this starting point is activated when the user opens the application using the Widgets
menu.

• Activate – this is the starting point that is activated when the user first opens the workflow
application. It does not activate on the second and subsequent times the workflow
application is started.

• Credential request – this starting point is activated when the workflow application requires
a user name and password and the program does not have one in its cache, or the values in
the cache are no longer valid.

• E-mail subscription – this starting point is activated when an e-mail message is sent to the
device that matches the matching rules specified in the workflow application.

Each starting point has a list of keys with which it is associated. View the keys associated with
the starting point in the Properties view for the starting point.

Adding a Starting Point Manually
Every screen must be part of a flow that connects to a starting point.

1. From the palette on the Flow Design page, select a starting point, then click on the Flow
Design canvas.

2. Add a screen to the starting point by either:

• Dragging and dropping a data source, for example, a mobile business object or mobile
business object operation, onto the Flow Design canvas, or

• Selecting an empty screen from the Flow Design palette, then clicking on the Flow
Design page.

3. Add a connection between the starting point and the screen.

4. Select File > Save.

You can also automatically create starting points based on selections you make in the New
Mobile Workflow Form wizard when you create a new Mobile Workflow form.

Creating an E-mail Subscription Starting Point
Create an e-mail subscription starting point.

Note: Each Mobile Workflow Forms Editor can have only one e-mail subscription starting
point.

1. In the Mobile Development perspective, select File > New > Mobile Workflow Forms
Editor.

2. Follow the instructions in the New Mobile Workflow Forms Editor wizard:

Field Description

Enter or select the parent folder Select the mobile application project in which
to create the mobile workflow form.
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Field Description

File name Enter a name for the mobile workflow form.
The extension for mobile workflow forms
is .xbw.

Advanced Link the mobile workflow form to an existing
file in the file system.

Link to file in the file system Click Browse to locate the file to which to link
the mobile workflow form. Linked resources
are files or folders that are stored in the file
system outside of the project's location. If you
link a resource to an editor, when you select the
editor, the resource is selected in the Work-
Space Navigator. Conversely, when you select
the resource in the WorkSpace Navigator, the
editor is selected.

3. In the Starting Points page, select Responds to server-driven e-mail notifications.

4. In the E-mail Processing wizard, click Search to locate the mobile business object with
which to associate the e-mail starting point.

5. In the Search for Mobile Business Object wizard, click Search.

6. Select the mobile business object from the list, and click OK.

7. In the E-mail Processing wizard, select an Object query and click Next.

Note: Object queries that return result sets are not supported.

8. Enter the contents for a sample e-mail message, and click Next.

9. Select the text that will serve as the matching rule, right-click and select Select as
Matching Rule and click Next.

10. From Parameters, select each parameter for which there is a matching rule, and specify
from where the parameter receives data in the Parameter Properties.

Note: The supported syntax for the regular expression is that used by the C# Match()
methods(s) of the class System.Text.RegularExpressions.Regex.

Property Description

Field Select the field from the e-mail message from
which the parameter receives data, for example,
Subject. Selecting Subject indicates that the
parameter receives data from the subject line of
the e-mail message.

Start tag Enter or select the text for the start tag regular
expression, for example, "Approval Re-
quest\(".
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Property Description

End tag Enter or select the text for the end tag regular
expression, for example, "\)was sent".

Format Supports locale-specific parameter extraction.
For example, you can indicate that a given date
parameter will be in the form of YYYY-MM-
DD in the e-mail, and another date parameter
will be in the form of YYYY-DD-MM. This
applies to the DateTime type.

Sample e-mail field contents The value of the field previously chosen as the
matching rule in the Specify Matching Rules
page of the wizard.

Value extracted from sample e-mail field con-
tents

The value the start tag and end tag matching
rules would arrive at given the sample field
value.

11. Click Finish.

E-mail Subscription Properties
View and configure the E-mail Subscription starting point properties.

Select the E-mail Subscription starting point in the Flow Design page to view and configure its
properties.

Table 3. General properties for the E-mail Subscription starting point

Property Description

Mobile business object The mobile business object with which the e-mail
subscription starting point is associated.

Object query When you define an object query in the mobile
business object associated with the mobile work-
flow form, the object query returns the specified
instances of the mobile business object. For ex-
ample, if a travel request to Hawaii is submitted,
the object query returns an instance of that mobile
business object so the approver can review the
travel request details then modify the status and
comment fields for that mobile business object.

Object queries that return multiple instances are
supported, as well as object queries that return
only one instance.

Error screen Select the screen to go to if the operation fails.
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Property Description

Jumpstart Launch the E-mail Processing wizard, where you
can compose a sample e-mail message from
which to specify parameter value extractin rules
and matching rules.

E-mail transformation rules Shows the e-mail message transformation rules
for the e-mail subscription starting point. Select a
rule and click Edit to change the transformation
rule.

Click Keys in the left pane of the Properties view to see the keys that are associated with the
e-mail subscription starting point.

Table 4. Keys

Property Description

Key name The name of the associated key.

Type The type of the associated key, for example,
string.

Data binding Shows the data source to which the key is bound:

• Mobile business object attribute

• Mobile business object relationship

• MBO object query results

If you select an object query that returns mul-
tiple MBO instances, you can bind the result
set to a Listview control using a key that is of
the list type.

• User-defined

Click New to create a new key.

Select any key and click Edit to edit the infor-
mation for an existing key.

Select a key and click Remove to remove an ex-
isting key.

E-mail Transformation Rules
E-mail transformation rules are used to extract parameter values from an e-mail message.

Transformation rules include a regular expression that determines from where in the e-mail
message the parameter value starts and another regular expression that determines from where
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in the e-mail message the parameter value ends. Define the e-mail message transformation
rules when you create an e-mail subscription starting point.

Editing E-mail Transformation Rules
Edit e-mail message transformation rules in the E-mail Subscription starting point General
properties.

1. On the Flow Design page, select the E-mail Subscription starting point.

2. In the General Properties view, select the e-mail transformation rule to edit and click
Edit.

3. In the Edit E-mail Transformation Rule dialog:

Property Description

MBO search parameter Enter the search parameters for the mobile
business object.

Field type Select the field in the e-mail message from
which the parameter value is extracted, for ex-
ample, , which indicates the parameter value is
extracted from the subject line of the e-mail
message.

Tag before parameter Enter the tag to indicate what to extract from the
beginning of the field's contents, for example,
"Approval Request\(".

Tag after parameter Enter the tag that indicates what to extract from
the end of the field's contents, for example,
"\)was sent".

Note: The supported syntax for the regular expression is that used by the C# Match()
methods(s) of the class System.Text.RegularExpressions.Regex.

4. Click OK.

Editing the E-mail Subscription Starting Point
Edit the E-mail Subscription starting point.

1. In the Flow Design page, right-click the E-mail Subscription starting point to edit and
select Edit E-mail Subscription starting point.

2. Make your changes in the E-mail Processing wizard and click Finish.

3. From the main menu, select File > Save.
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Adding Matching Rules
Matching rules determine how e-mail messages are redirected at runtime.

To see the Matching Rules section of the Properties view, verify there are no objects selected
on the Flow Design page.

1. In the Properties view, click Matching Rules.

2. Click Add.

3. In the matching rules dialog, specify the type and regular expression for the matching rule,
and click OK.

Credentials
You can use either dynamic or static credentials in a mobile workflow form.

The user name and password values are required when the mobile workflow application
invokes a mobile business object operation. These authentication values can be provided
statically (at design time), or dynamically (by the user at runtime).

Dynamic credentials mean that the user sets the user name and password on a screen that is
pointed to by the credential request starting point. The text fields must have the corresponding
Credential Cache User Name and Password checkbox checked to indicate the value is to be
used to provide the user name and password on the client. When the user logs in, the
credentials are authenticated using the stored credentials.

Note: If an e-mail triggered workflow form has dynamic cached credentials, the cached
credentials are not cached between invocations of the workflow form through an email trigger.

Static credentials mean that everyone who has access to the resource uses the same user name
and password. By default, static credentials are used. The static credential user name and
password for the mobile workflow application can be extracted from the selected Sybase
Unwired Platform profile user name and password when the mobile workflow application is
generated, or they can be hard-coded using the Properties view. After deployment, you can
change static credentials in the Sybase Control Center.

The application can also have a credential screen (Credential Request) that appears if the
mobile workflow application detects that the cached credentials are empty or incorrect.

Setting Up Static Authentication
With static authentication, everyone who has access to the resource uses the same user name
and password.

Set up static credentials in the Authentication section of the Properties tab. To see the
Properties page, verify there are no objects selected on the Flow Design page.

1. In the Properties view, click Authentication.

2. Select Use static credentials.
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3. Select from these options:

• Use SUP Server connection profile authentication – selected by default. When the code
is generated for the mobile workflow application, the user name and password
associated with the SUP connection profile are used.

• Use hard-coded credentials – sets the user name and password. When you select this
option, the User name and Password fields are activated.

4. (Optional) If you selected the Use hard-coded credentials option in the previous step,
enter the User name and Password that are to be used for authentication.

5. Select File > Save.

Setting Up Dynamic Authentication
Use dynamic authentication when you want the user to set the name and password on the
client.

You can create the Credential Request starting point with a Credential screen automatically
when you initially create a new mobile workflow, or you can create the Credential Request
starting point and associated screen manually. This procedure shows how to create the
Credential Request starting point automatically when you create a new mobile workflow.

1. In the Mobile Development perspective, select File > New > Mobile Workflow Forms
Editor.

2. Follow the instructions in the New Mobile Workflow Forms Editor wizard:

Field Description

Enter or select the parent folder Select the mobile application project in which
to create the mobile workflow form.

File name Enter a name for the mobile workflow form.
The extension for mobile workflow forms
is .xbw.

Advanced Link the mobile workflow form to an existing
file in the file system.

Link to file in the file system Click Browse to locate the file to which to link
the mobile workflow form. Linked resources
are files or folders that are stored in the file
system outside of the project's location. If you
link a resource to an editor, when you select the
editor, the resource is selected in the Work-
Space Navigator. Conversely, when you select
the resource in the WorkSpace Navigator, the
editor is selected.

3. In the Starting Points page, select Credentials (authentication) may be requested
dynamically from the client application.
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4. Continue with the New Mobile Workflow wizard as appropriate to create the type of
mobile workflow application you want to create. Click Finish.

5. When the Mobile Workflow Forms Editor opens, click Flow Design.

The Credential Request starting point and its associated Credential Request screen appear
on the Flow Design page.

Select the Credential Request starting point. You will see the two pre-defined keys
(cc_username and cc_password) in the Properties view.

6. Double-click the Credential Request screen to go to the Screen Design page.

Two editbox controls, which are bound to the pre-defined cc_username and cc_password
keys appear on the screen.

7. Select the Username editbox, then click Advanced on the left side of the Properties view.

The Username editbox has the Credential cache username checkbox selected. Select the
Password editbox and note that is has the Credential cache password checkbox checked.

If you create a Credential Request starting point and screen manually, you must add the
editbox controls, create the keys for the username and password, and check the
corresponding Credential cache username or password box.

8. Select File > Save.

The first time the mobile workflow is started following deployment, the credential screen
is shown. The username and password values are then cached in the credential cache.

Note: If an e-mail triggered workflow form has dynamic cached credentials, the cached
credentials are not cached between invocations of the workflow form through an email
trigger.

Creating Keys
Create new keys that can be bound to controls.

1. On the Screen Design page, select the control to which you want to bind the new key.

2. In General Properties, in the Input Data Binding section, click New key.

3. In the Key dialog, enter:

Property Description

Name Enter a name for the key.

Type Select the key type.

Sent by server Select this checkbox to input data binding for
the key.

Input Data Binding
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Property Description

MBO attribute Select to bind the key to a mobile business ob-
ject (MBO) attribute:
• Name
• Convert to UTC

MBO relationship Bind the key to an MBO relationship.

MBO object query results Bind the key to MBO object query results.

User defined Bind the key to user-defined data.

4. Click OK.

Keys
Keys are unique identifiers within the scope of a workflow application, used when setting or
retrieving a value.

Keys can be bound to the mobile business object (MBO), whether it is to an MBO attribute, an
MBO parameter, an MBO operation parameter, a subscription parameter, an object query, or
an MBO relationship (list type keys only).

Keys can be of the following types:

• string
• int
• double
• decimal
• bool
• DateTime
• list – can be bound only to relationships, or nothing. Keys of other types cannot be bound to

relationships. List type keys have one or more child keys to which they are bound.

This example of an .xml file shows how keys are used in a workflow application. In this
example, the keys associated with the editbox control are bound to the parameters of the
mobile business object's (TravelRequest) create operation.

<screens default="TravelRequestcreate">
    <screen key="TravelRequestcreate" text="TravelRequest_create" >
      <actions>
        <action key="Submit" type="submit" text="Create" />
        <action key="Cancel" type="cancel" text="Cancel" />
      </actions>   
      <controls>
        <datepicker  key="TravelRequest_create_trvl_date_paramKey" 
value="" label="Trvl date:" labelpos="LEFT" maxlength="32767" />
        <editbox  key="TravelRequest_create_trvl_location_paramKey" 
value="" label="Trvl location:" labelpos="LEFT" maxlength="20" />
        <editbox  key="TravelRequest_create_est_cost_paramKey" 
value="" label="Est cost:" labelpos="LEFT" numeric="true" 

Develop a Mobile Workflow Package

Developer Reference for Mobile Workflow Packages    37



maxlength="32767" />
        <editbox  key="TravelRequest_create_purpose_paramKey" 
value="" label="Purpose:" labelpos="LEFT" maxlength="200" />
      </controls>
    </screen>
</screens>

Binding Controls to Keys
Use the Properties view to bind keys to controls.

1. On the Screen Design page, select the control to which you want to bind the key.

2. In General Properties, in the Input Data Binding section, select the key with which to bind
the control from the drop-down list.

3. (Optional) In Default Value, enter a default value for the key.

4. Select File > Save.

Mobile Business Object Relationships
When you are using two mobile business objects with a one to many or one to one composite
relationship defined, use the listview control on the mobile workflow application to show the
list of related objects.

The listview control allows you to navigate the one to many or one to one relationship between
the two mobile business objects. The one to one cascade relationships use regular controls or
keys that bind to the related mobile business object's attributes.

When you create the relationship between the two mobile business objects, you must select the
One to many or One to one and Composite options.

Note: Structured mobile business objects and complex parameters are not supported in mobile
workflow forms.

Creating Screens Automatically by Dragging and Dropping a
Data Source

Drag and drop a data source, for example a mobile business object (MBO) or operation onto
the Flow Design page to create screens, controls, keys, menus, and navigations automatically.

Note: Mobile business objects used as the data source must be contained in a deployed mobile
application package that is identified as "messaging."

When you use an MBO operation, a screen is created with a menu item that invokes that
operation. Controls bound to keys that are bound to that operation’s parameters are also
created.
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When you use an MBO as the data source, screens for the operations are created, along with a
details screen for the MBO itself, and also screens for any related MBOs and their operations.

1. From the Flow Design page palette, select a starting point and drag and drop it onto the
Flow Design page.

2. From WorkSpace Navigator, expand the project that contains the data source you want to
use.

3. Select the data source, for example, a mobile business object, and drag and drop it onto the
Flow Design page.

If the mobile business object you are using as the data source has relationships with other
mobile business objects defined, all of the screens and connections between screens for the
initial mobile business object and its relationships are automatically created. You can
change the order of the screens and create your own connections manually.

Note: Structured mobile business objects and complex parameters are not supported in
mobile workflow forms.

Adding Controls to the Screen
Use the Screen Design palette to add controls to the mobile workflow screen.

1. In the Mobile Workflow Forms Editor, select Screen Design > Palette > Controls, then
select the control you want to add to the screen and click on the screen.

2. Click the control to select it, then use the Properties page to configure it.

Mobile Workflow Controls
Controls are objects that users can interact with to view, enter, or manipulate data

Supported controls are determined by the selected device. The set of supported controls
depends on the target device platform.

Control Supported Platform

Checkbox • Apple iPhone and iPod Touch (operating sys-
tem 3.0 and later)

• Windows Mobile Standard
• Windows Mobile Professional
• Symbian Series 60, Third Edition and Series

60 Fifth Edition only
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Control Supported Platform

Editbox • Apple iPhone and iPod Touch (operating sys-
tem 3.0 and later)

• Windows Mobile Standard
• Windows Mobile Professional
• Symbian Series 60, Third Edition and Series

60 Fifth Edition only

Choice • Apple iPhone and iPod Touch (operating sys-
tem 3.0 and later)

• Windows Mobile Standard
• Windows Mobile Professional
• Symbian Series 60, Third Edition and Series

60 Fifth Edition only

Slider • Apple iPhone and iPod Touch (operating sys-
tem 3.0 and later)

• Windows Mobile Standard
• Windows Mobile Professional
• Symbian Series 60, Third Edition and Series

60 Fifth Edition only

Signature • Windows Mobile Standard
• Windows Mobile Professional
• Symbian Series 60, Third Edition and Series

60 Fifth Edition only

HtmlView • Apple iPhone and iPod Touch (operating sys-
tem 3.0 and later)

• Windows Mobile Standard
• Windows Mobile Professional
• Symbian Series 60, Third Edition and Series

60 Fifth Edition only

Listview • Apple iPhone and iPod Touch (operating sys-
tem 3.0 and later)

• Windows Mobile Standard
• Windows Mobile Professional
• Symbian Series 60, Third Edition and Series

60 Fifth Edition only
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Adding a Menu Item
Add a menu item to the menu.

1. On the Screen Design page, from Palette, select Menuitem, then click the Menu box.

2. Select the menu item to configure the properties in the Properties view.

Menu Items
Menu items function as actions and are associated with mobile business object operations.

Menu items can be one of these types:

• Open – must be associated with another screen. The open menu item is created
automatically when a Go To connection is created on the Flow Design page.

• Save – allows the user to close the current open screen and save the input made to the
collection of response values to be sent to the server using the submit action. Using the save
menu item, a user can navigate back one single screen at a time.

• Cancel – allows the user to close the current open screen without performing any data
validation. The cancel action type immediately navigates the user back to the underlying
screen.

• Submit (synchronous) – the submit menu item on a screen must be associated with a
mobile business object operation or an object query. If the user has multiple screens open
during the submit execution, and one of the underlying screens fails validation, the user is
prompted with the configured warning message and the submit process stops.

• Submit (asynchronous) – the submit menu item on a screen must be associated with a
mobile business object operation.

• Close – allows the user to leave the client-side component no matter which screen the
client-side component currently shows.

• Listview – includes AddListView Row, Delete ListView Row, UpdateListView Row,
which allows the user to add, delete, or update a listview row. The AddListView Row menu
type allows you to navigate directly from the listview details screen and perform an add
from the subsequent screen.

• Add – available for ListView controls. The Add menu item type allows you to navigate
directly from the listview itself and perform an add from the subsequent screen.
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Menu Item Properties
Select the menu item on the Screen Design page to view and configure its properties using the
Properties page.

General

Property Description

Name Enter a valid name for the menu item.

Key Select the key with which to bind the menu item.

Default Select to display the menu item prominently on
the screen.
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Property Description

Type Select the type of action the menu item will per-
form when selected:

• Save – allows the user to close the current
open screen and save the input made to the
collection of response values to be sent to the
server.

• Close – allows the user to leave the client-side
component no matter which screen the client-
side component currently shows.

• Cancel – allows the user to close the current
open screen without performing any data val-
idation. The cancel action type immediately
navigates the user back to the underlying
screen.

• Open – indicates the screen to be opened with
a GoTo connection. The Open type menu
item must be associated with a screen on the
Flow Design.

• Submit – Closes the client application and
invokes a mobile business object method us-
ing the values of the current flow.

• The Listview actions can be invoked only
within the context of a Listview, for example,
on a screen that is arrived at after navigating
from a listview. It does not immediately exe-
cute the MBO create operation in question,
but rather stores it so that later, when the pa-
rent MBO is submitted, this, and other, MBO
operations will be invoked.

• Add Listview Row

• Update Listview Row

• Delete Listview Row

Details You can configure menu item actions in the De-
tails section. The properties available depend on
the action type. See the topics for configuring the
different menu item types for information about
configuring these properties.
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Parameter Mappings
Use the Parameter Mapping section to defing which keys to map to which parameters.

Communication Style

Property Description

Asynchronous Validates the data input on all open screens,
closes the application, and sends the data to the
server. Enter the confirmation message to submit
to the server.

Synchronous Validates the data input on all open screens, saves
it, send it to the server and waits for a response
from the server before continuing. Enter:

• Submit error message – enter the message the
user sees if there is an error.

• Timeout – enter the allowed amount of time
to wait for the server to respond before timing
out and giving an error message.

• Success screen – select the screen to go to
upon successful communication with the
server.

• Error screen – select the screen to go to if
there is an error when submitting the data to
the server.

Creating a Save, Open, Close, or Cancel Menu Item
Create a menu item that performs a save, open, close, or cancel action on the device
application screens.

Note: The first screen in each mobile workflow form should have a Close or Cancel menu
action assigned to it so that the user can exit from the mobile workflow form on the device. On
a Windows Mobile device, the user can exit by clicking the OK button, but not all devices have
that function.

1. On the Screen Design page, from Palette, click Menuitem, then click the Menu box.

2. Select the menu item to configure the properties in the Properties view.

3. In the Properties view:

Property Description

Name Enter a valid name for the menu item.
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Property Description

Key Select the key with which to bind the menu
item.

Default Select to display the menu item prominently on
the screen.

Type Select the type of action the menu item will
perform when selected:
• Save – allows the user to close the current

open screen and save the input made to the
collection of response values to be sent to
the server.

• Close – allows the user to leave the client-
side component no matter which screen the
client-side component currently shows.

• Cancel – allows the user to close the current
open screen without performing any data
validation. The cancel action type immedi-
ately navigates the user back to the under-
lying screen.

• Open – indicates the screen to be opened
with a GoTo connection. The Open type
menu item must be associated with a screen
on the Flow Design.

Screen This field appears in the Details section only if
the menu item type is Open. Select the screen
that will open from the GoTo connection.

4. Select File > Save.

Creating a Submit Menu Item
Create a "submit" menu item.

The submit menu item of the first screen in a mobile workflow form must be associated with a
mobile business object operation or an object query.

If the user has multiple screens open at the time of the submit execution, and one of the
underlying screens fails validation, the user is prompted with the configured warning message
and the submit process stops.

1. From the palette on the Screen Design page, click Menuitem, then click the Menu box.

2. Select the menu item to configure the properties in the Properties view.

3. In the Properties view, configure the properties for the submit menu item:
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Property Description

Name Enter a valid name for the menu item.

Key Select the key with which to bind the submit
menu item.

Default Select to display the menu item prominently on
the screen.

Type Select Submit from the drop-down list.

4. If the menu item is an operation associated with a mobile business object, you can
configure these properties in Details:

Property Description

Mobile business object The mobile business object with which the
menu item is associated. Click Search to locate
the mobile business object with which to asso-
ciate the menu item.

Invoke parent update No changes are made to the parent MBO, but
the appropriate operations (create, update, de-
lete) are performed on its descendants.

Invoke operation Invoke the selected mobile business object op-
eration with which the menu item is associated.

Select the operation from the drop-down list.
The list is populated when you select the mobile
business object.

Invoke object query Invoke the object query from the menu item.

Note: The menu item must be the Submit type
menu item and the communication style must
be synchronous.

Configure these properties in Advanced:

Property Description

Flow-specific username key User name with which to connect when invok-
ing this operation.

Flow-specific password key User password with which to connect when in-
voking this operation.

5. Select File > Save.
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Configuring Communication Style
Choose whether to make the submit action for the menu item synchronous or asynchronous.

1. In the Properties view for the menu item, select the Communication Style tab.

2. Select from the options:

Property Description

Asynchronous Validates the data input on all open screens,
closes the application, and sends the data to the
server. Enter the confirmation message to sub-
mit to the server.

Synchronous Validates the data input on all open screens,
saves it, send it to the server and waits for a
response from the server before continuing.
Enter:
• Submit error message – enter the message

the user sees if there is an error.
When an operation is invoked, the user can
receive any error messages that may occur
on the client application. The error mes-
sages are a single key of the list type with a
single key of the string type as its child.
Each of the child instances corresponds to
an error message.

• Timeout – enter the allowed amount of time
to wait for the server to respond before tim-
ing out and giving an error message.

• Success screen – select the screen to go to
upon successful communication with the
server.

• Error screen – select the screen to go to if
there is an error when submitting the data to
the server.

Click Generate Error Screen to generate error
screens automatically.

3. Select File > Save.

Creating a ListView Menu Item
Create and configure a Listview menu item.

1. In the Screen Design page, from the palette, click Menuitem, then click the Menu box.

2. Click the menu item to select it and configure the properties in the Properties view.

3. In the Properties view:
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Property Description

Name Enter a valid name for the menu item.

Key Select the key with which to bind the Listview
menu item.

Default Select to display the menu item prominently on
the screen.

Type Select one of these types:
• Add Listview Row
• Update Listview Row
• Delete Listview Row

4. If the menu item is an operation associated with a mobile business object, configure these
properties in Details.

Property Description

Mobile business object The mobile business object with which the
menu item is associated. Click Search to locate
the mobile business object with which to asso-
ciate the menu item.

Operation The mobile business object operation with
which the menu item is associated. Select the
operation from the list, which is populated
when you select the mobile business object.

Parameter mapping Parameter mapping for the selected operation is
shown. Click Edit to edit the parameter map-
ping for the operation.

ListView Select the Listview from the drop-down list.

5. Select File > Save.

Configuring Parameter Mappings
Configure mapping between parameters and keys.

Parameter mapping for the selected operation is shown in the Properties view.

1. In the Properties view for the menu item, select the Parameters Mapping tab.

2. Click Add to map a key to a parameter.

3. Select a key, and click Edit to edit mapping between a parameter and a key.

4. Select a key and click Delete to delete existing mapping between a key and a parameter.
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Configuring Control Properties
Use the Properties page of any control to configure control properties.

1. On the Screen Design page, select the control for which to configure the properties.
The configurable properties for the selected control appear in the Properties view.

2. Configure the properties for the control and select File > Save.

Checkbox Properties
Select the checkbox on the Screen Design page to view and configure its properties.

General control properties
These are general properties for most controls.

Property Description

Label This property applies to all controls except
HtmlView and Listview.

• Label – enter the text that describes the con-
trol on the user interface.

• Label position – the position of the label in
relation to the control it describes.

Note: This attribute is not supported on Sym-
bian devices.

Input data binding • Key – the unique identifier within the scope
of the widget, used when setting or retrieving
a value.

Click New key to create a new key for the
control.

• Default value – default value for the control.

Read only This property applies to all controls except
HtmlView and Listview. Select to make the con-
trol read-only.

Advanced
These are the advanced validation properties for the checkbox control.
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Property Description

Required Specifies that submission is possible only when
the checkbox is selected. A submission must have
a value.

Validation message Specifies the error message that appears to the
user in case the input validation criteria do not
match.

Editbox Properties
Select Editbox on the Screen Design page to view and configure its properties.

General control properties
These are general properties for most controls.

Property Description

Label This property applies to all controls except
HtmlView and Listview.

• Label – enter the text that describes the con-
trol on the user interface.

• Label position – the position of the label in
relation to the control it describes.

Note: This attribute is not supported on Sym-
bian devices.

Input data binding • Key – the unique identifier within the scope
of the widget, used when setting or retrieving
a value.

Click New key to create a new key for the
control.

• Default value – default value for the control.

Read only This property applies to all controls except
HtmlView and Listview. Select to make the con-
trol read-only.

Editbox general properties
These are the general properties that apply to the editbox control.
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Property Description

Password If selected (set to true), text entered in the editbox
is replaced with asterisks. The default is false.

Logical type Select the logical type for the editbox:

• TEXT

• NUMERIC

• DATE – uses absolute values or values rela-
tive to the current day using simple calcula-
tions in days, for example,
“2008-05-24” "today" "today+1" "today-1."
All values are expected to be in UTC.

• DATETIME – uses absolute values or values
relative to the current time or day using sim-
ple calculations in seconds, for example,
"2008-05-24" or
"2008-05-24T14:30:15" "today" "today
+86400" or "today-86400." In "today+nnn,"
the nnn means seconds and "today" is inter-
preted as the current date time 12:00PM.

• TIME – uses only absolute values, for exam-
ple, "14:30" or "14:30:15." Valid values are
00:00:00 to 23.59:59.

Note: The properties that you can configure de-
pend on the logical type set for the editbox con-
trol. Some properties apply only to the numeric
type, some apply only to the text type, and so on.

Advanced
These are the advanced properties that apply to the editbox.
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Property Description

Content size • Maximum length – specify the maximum
number of characters allowed for the control.

• Number of lines – specify the number of lines
for the control.

• Number of decimals – specify the number of
decimals (the number of digits after the dec-
imal point—valid range is 0 – 28) for a num-
ber. Valid only in conjunction with numeric
attributes. The default is zero.

Validation • Minimum value – specify the minimal value
for numeric input. Valid only in conjunction
with numeric attributes.

• Maximum value – specify the maximum val-
ue for numeric input. Valid only in conjunc-
tion with numeric attributes.

• Required – specify if user input is required. A
value is required for submission.

• Validation regular expression – if the user
enters text in the control, the input has to
comply to the provided regular expression.

• Validation message – enter the error message
the user sees in case the input validation cri-
teria do not match.

Time precision Specifies the precision of the time portion dis-
played to the user and calculations.

Note: This property is used only if the editbox
logical type is datetime or time.

Credential cache username If the widget supports cached credentials, select
to specify that the editbox be treated as a user
name.

Credential cache password If the widget supports cached credentials, select
to specify that the editbox be treated as a pass-
word.

Choice Properties
Select the choice control on the Screen Design page to view and configure its properties.
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General control properties
These are general properties for most controls.

Property Description

Label This property applies to all controls except
HtmlView and Listview.

• Label – enter the text that describes the con-
trol on the user interface.

• Label position – the position of the label in
relation to the control it describes.

Note: This attribute is not supported on Sym-
bian devices.

Input data binding • Key – the unique identifier within the scope
of the widget, used when setting or retrieving
a value.

Click New key to create a new key for the
control.

• Default value – default value for the control.

Read only This property applies to all controls except
HtmlView and Listview. Select to make the con-
trol read-only.

Choice general properties
These are the general properties that apply to the choice control.

Property Description

Logical type Select the logical type for the edit box from the
drop-down list. Logical types include:

• TEXT

• NUMERIC

Note: The properties that you can configure de-
pend on the logical type set for the control. Some
properties only apply to the numeric type and
some only apply to the text type.
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Property Description

Options • Static – the choice contents are static. Click
Add to assign a display name and value pair
to the choice item.

• Dynamic – the choice contents are dynamic.

Advanced
These are the advanced properties that apply to the choice control.

Property Description

Content size Number of decimals – specify the number of
decimals (the number of digits after the decimal
point—valid range is 0 to 28) for a number. Only
valid in conjunction with the numeric attributes.
The default is zero.

Note: This property is used only if the logical
type for the choice control is set to numeric.

Validation required • Required – specify if user input is required. A
submission without a value is not possible.

• Validation message – enter the error message
displayed to the user in case the input valida-
tion criteria do not match.

Adding Choice Items to the Choice Control
Add choice items to the choice control.

1. In the General Properties view for the choice control, click Add.

2. In the Choice Option Item dialog, enter the Display Name and Value for the choice item,
and click OK.

Property Description

Display Name Enter the name for the choice item as it will
appear on the user interface.

Value Enter the value for the choice item.

Editing Choice Items
Edit choice items for the choice control.
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1. In the General Properties view for the choice control, select the choice control item to edit
and click Edit.

2. In the Choice Option Item dialog, make the changes and click OK.

Property Description

Display Name Enter the name for the choice item as it will
appear on the user interface.

Value Enter the value for the choice item.

Deleting Choice Items
Delete choice items from the choice control.

1. In the General Properties view for the choice control, select the choice control item to
delete.

2. Click Delete.

Creating Dynamic Contents for the Choice Control
Specify contents of the choice control dynamically.

1. In the Screen Design page, select the Choice item from Palette > Controls and drag it onto
the screen.

2. In the General Properties view for the choice control, from the Options section, select
Dynamic.

3. In Value key, enter the value for the key.

4. In Display name key, enter the value that the user will see on the device interface.

Note: The display name key and the value name key can be different or the same. The two
keys must be children of a key that is a list type.

Slider Properties
Select the slider control on the Screen Design page to view and configure its properties.

General control properties
These are general properties for most controls.
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Property Description

Label This property applies to all controls except
HtmlView and Listview.

• Label – enter the text that describes the con-
trol on the user interface.

• Label position – the position of the label in
relation to the control it describes.

Note: This attribute is not supported on Sym-
bian devices.

Input data binding • Key – the unique identifier within the scope
of the widget, used when setting or retrieving
a value.

Click New key to create a new key for the
control.

• Default value – default value for the control.

Read only This property applies to all controls except
HtmlView and Listview. Select to make the con-
trol read-only.

Slider control general properties
These are the general properties that apply to the slider control.

Table 5. Value constraints

Property Description

Minimum value Specify the minimum value.

Maximum value Specify the maximum value.

Advanced
These are the advanced properties that apply to the slider control.

Property Description

Validation message Specifies the error message displayed to the user
in case the input validation criteria do not match.

Signature Properties
Select the signature control on the Screen Design page to view and configure its properties.

Note: The signature control is not supported on Apple devices.
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General control properties
These are general properties for most controls.

Property Description

Label This property applies to all controls except
HtmlView and Listview.

• Label – enter the text that describes the con-
trol on the user interface.

• Label position – the position of the label in
relation to the control it describes.

Note: This attribute is not supported on Sym-
bian devices.

Input data binding • Key – the unique identifier within the scope
of the widget, used when setting or retrieving
a value.

Click New key to create a new key for the
control.

• Default value – default value for the control.

Read only This property applies to all controls except
HtmlView and Listview. Select to make the con-
trol read-only.

Advanced
These are the advanced properties that apply to the signature control.

Property Description

Validation Required • Required – specify if user input is required. A
submission without a value is not possible.

• Validation message – enter the error message
displayed to the user in case the input valida-
tion criteria do not match.

HtmlView Properties
Select the HtmlView control on the Screen Design page to view and configure its properties.

The HtmlView control fills the entire screen of a workflow form, so no other controls can be
placed on a screen that hosts an HtmlView control.
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Table 6. HtmlView control properties

Property Description

Input data binding • Key – the unique identifier within the scope
of the workflow form, used when setting or
retrieving a value.

Click New key to create a new key for the
control.

• Default value – default value for the control.

Listview Properties
Select Listview on the Screen Design page to view and configure its properties.

General Listview properties

Property Description

Input data binding Select the key with which to bind the Listview
control from the drop-down, or click New key to
create a new key.

Alternate row color Click Color Picker to select the color for the
alternate rows in the list.

You can also manually enter the value. The pos-
sible values are black, blue, brown, gray, green,
orange, pink, purple, red, white, yellow, any
string with the format #rrggbb, where rr, gg

and bb are the hexadecimal values, in the range 0
to ff(255), for the red, green and blue.

Note: The alternate row color attribute is suppor-
ted on Windows Mobile devices only.

On empty list The text that appears on the screen when the List-
view is empty.

Listview details screen Select the screen that will be opened when the
user clicks a row.
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Cells

Property Description

Cell lines The lines that appear in each row of the control.
Click Add to add a new line. Select an existing
line and click Delete to remove a line from the
row.

Fields for Click Add to create a new field.

Click Edit to edit an existing field.

Click Delete to delete an existing field.

Adding a Listview Field to a Line
Use the Properties view to add fields to Listview lines.

1. Select the Listview control to see the Properties view.

2. In Properties, in the left pane, click Lines.

3. In Listview lines, select the line for which to add the field.

4. In Fields for click Add.

5. In the Listview Field dialog:

Option Description

Key Select the key with which to associate the field.

Field width Enter the field width. This value is a percentage,
so the values entered should be between 1 – 100
and add up to 100.

Font options Select the appearance of the font:
• Bold
• Italics

Field format Enter the field format. A standard format string
contains a format specifier, which is an alpha-
betic character, for example, G, that defines the
string that represents the object to which it is
applied.

Note: This attribute is supported only on Win-
dows Mobile Platforms.

6. Click OK.
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Editing a ListView Field
Edit ListView control fields in the Properties view.

1. Select the ListView control to see the Properties view.

2. In Properties, in the left pane, click Lines.

3. In Fields for ListView Line, select the line for which to edit the field and click Edit.

4. In the ListView Field dialog, make your changes and click OK.

Adding Connections to Screens

The Start icon  appears on the Flow Design page, and its connection is attached to the first
screen you add to the Flow Design. You can change the target to any screen in the Flow
Design.

1. From the Flow Design Palette, select the connection you want to use:

Note: Some connections cannot be explicitly created; they can only be implicitly created
when creating or editing menu item properties.

Connection Description

Go to Specifies which screen the user goes to upon
completing an action on the current screen,
such as clicking OK or Next.

Operation success Specifies which screen the user goes to upon
successful completion of an operation.

Operation error Specifies the screen that the user goes to auto-
matically when an operation fails to execute.

Listview details Specifies which screen to open when a row in a
listview is clicked. Once on the details screen
you can add, update, or delete rows from the
listview.

Listview add Specifies a screen that can be directly navigated
to in order to add a new row to the listview.

2. In the Flow Design canvas, click the source screen and drag to connect it to the target
screen.
The connection line appears between the two screens.
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Connections
Use connections to connect screens with actions in the Flow Design.

Connection actions describe the navigation direction the screen should go after the user
performs an action, cancels an action, or uses a control. Alert actions use actions defined in the
Flow Design.

Note: You can use only one connection of each type from a given source screen, except for the
GoTo connection type. You can have as many GoTo connection types as you want to on a
source screen.

Connection Properties
Use the Properties view for connections to configure the connection properties.

Select the connection on the Flow Design page to view its properties.

Property Description

Routing When a new connection is created, it uses the
default style defined in the preferences settings.
You can change the style of the connection line
individually in the Properties view.

• Styles:

• Oblique – connection lines are not
aligned with the horizontal or vertical
axis, and you can create breakpoints any-
where on the connection line. If you drag
the connection line, a new breakpoint is
created at the drag point and two lines are
created.

• Rectilinear – the connection line always
remains either horizontal or vertical.

• Tree – arranges the connection lines on
the Flow Design in a tree structure.

• Avoid obstructions – connection lines go
around objects.

• Closest distance – connection lines pass
through objects to shorten the distance of the
connection line.

Lines and arrows
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Property Description

Smoothness • None

• Less

• Normal

• More

Jump links • Status:

• None

• Below

• All

• Above

• Type:

• Semicircle

• Chamfered

• Square

• Reverse jump links

Localization
You can localize different objects in the Mobile Workflow Forms Editor, such as the names of
screen controls, screens, and mobile business objects.

You can localize the mobile workflow by creating locale properties files. You can then load,
update, and generate localized device applications.

You can create or update resource bundles for the Mobile Workflow Forms Editor using the
resource keys in the locale properties file. The values for the resource keys are defined by the
corresponding elements in the current Mobile Workflow Forms Editor. You can also upload
specific locale resource bundles into the Mobile Workflow Forms Editor.

Some restrictions for the locale properties files apply:

• When you specify a country for the language, the basic language locale must also be
available. For example, if you create a locale and specify English as the language and the
United States as the country, then a locale for English (the basic language) must also be
available.

• If you create a locale that specifies language, country, and variant, the locale for the basic
language and the locale for the basic language and the country must be available. For
example, if you create a locale and specify English as the language, United States as the
country, and WIN as the variant, then English (United States) and English locales must
also be available.
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• The language code must be a 2-letter code, and the country code can be either a 2-letter or
3-letter code.

• If you specify a variant, the country code must be a 2-letter code.

All locale properties files are saved in the same directory as the device application.

When localizing the Mobile Workflow Forms Editor:

• Mobile workflow applications that have names that begin with numbers or special
characters cannot be localized; you will receive an error when you generate the code. Make
sure that any mobile workflow you want to localize does not have a file name that begins
with a number or special character.

• If you manually localize the locale properties file using an external editor, you must make
sure the file is encoded in ASCII, so that the content can be correctly read and converted to
Unicode.

Creating a New Locale
Create a new locale with resource keys and values extracted from localizable strings in the
current device application file.

When you create a new locale, keep in mind:

• When you specify a country for the language, the basic language locale must also be
available. For example, if you create a locale and specify English as the language, then
there must also be a locale for English (the basic language).

• If you create a locale that specifies language, country, and variant, the locale for the basic
language and the locale for the basic language and the country must be available. For
example, if you create a locale and specify English as the language, United States as the
country, and WIN as the variant, then English (United States) and English locales must
also be available.

1. In the Properties view, click Localization in the left pane.

2. In the Localization page, click New.

3. In the New Locale wizard:

Option Description

Language Select the language.

Country Select the country.
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Option Description

Variant Enter the variant, which is the vendor or brows-
er-specific code. For example, enter "WIN" for
Windows, "MAC" for Macintosh and "POSIX"
for POSIX. If there are two variants, separate
them with an underscore, and put the most im-
portant one first. For example, a Traditional
Spanish collation might construct a locale with
parameters for language, country, and variant
as: "es", "ES", "Traditional_WIN".

Overwrite existing file Overwrite an existing localization file.

Automatically create default locale Automatically create the default locale proper-
ties file. For example, if you specify the lan-
guage as "English" and the country as the
"United States" for a device application called
test, then both test_en_uS.prop-
erties and test.properties files
are created.

Note: BlackBerry devices require a default lo-
cale.

4. Click Finish.
The properties file is created in the same directory as the device application file.

Editing a Locale Properties File
Use the Properties File Editor to edit the localization properties file.

1. In the Screen Design page Properties view, click Localization.

2. Select the locale to edit and click Edit.

Note: If you use an external editor to manually edit the locale properties file, make sure the
file is encoded in ASCII so that the content can be correctly read and converted to Unicode.

3. Make the changes to the file.

4. Select File > Save.

Updating the Current Locale
Update the currently loaded locale properties file with the resource keys from the current
Mobile Workflow Designer.

If the locale properties file does not already exist, it is created. If the current locale is not
defined in the mobile workflow application file, the updated locale is used as the default, and
the file name is {device_application}.properties. Otherwise, the locale defined in the mobile
workflow application file is updated.
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1. In the Screen Design page Properties view, click Localization.

2. Click Update.

Removing a Locale
Remove locale properties files.

1. In the Screen Design page Properties view, click Localization.

2. Select the locale to remove and click Remove.

3. Click Yes to confirm the deletion.

Loading a Locale Properties File
Load a locale properties file.

1. In the Screen Design page Properties view, click Localization.

2. Select the locale properties to load and click Load.
You see a message if there are missing resource keys.

3. (Optional) Click Yes to automatically fix the properties file.
If you choose to not fix the locale properties file, loading does not continue.

Loading the locale property file updates the current locale of the device application file.

Validating the Locale Properties Files
Validate locale properties files.

Validation verifies that all the resource keys for the current mobile workflow application file
exist in the locale properties file.

1. In the Flow Design Properties view, click Localization.

2. Select the locale for which to validate the properties file, and click Validate.
You see a message if there are missing resource keys.

3. (Optional) Click Yes to automatically fix the properties file.

Generating the Files For a Mobile Workflow Package
Use the Mobile Workflow Package Generation wizard to generate the files for the mobile
workflow form, optionally deploy the generated workflow package files to the server, and
assign it to one or more users' devices.

1. Right-click in either the Flow Design or Screen Design page of the Mobile Workflow
Forms Editor and select Generate Mobile Workflow Package, or click the code
generation icon  on the toolbar.
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2. In the Mobile Workflow Package Generation wizard, enter or select:

Option Description

Favorite configurations (Optional) Select a configuration.

Code Generation and Deployment

Generation folder Select the folder in which to save the .zip file
containing the application and its generated
files.

Deploy to an Unwired Server Select to deploy the mobile workflow applica-
tion to an Unwired Server.

Unwired Server Profile Select the Unwired Server profile with which to
associate the mobile workflow application and
extract the username and password credentials
if you are using static authentication.

Assign workflow to user(s) The mobile workflow must be assigned to a
device user before the mobile workflow is visi-
ble on the user's device. It can be assigned to
multiple users. Separate multiple users with a
comma. Device users must be registered in
Sybase Control Center.

Click Get Users to select device users from the
list.

Deploy the Sybase messaging client to a con-
nected Microsoft Windows Mobile device or
emulator

Select to deploy the mobile workflow applica-
tion to a Windows Mobile connected device or
emulator.

Note: This option requires Microsoft Active-
Sync 4.5 (if you are using Windows XP) or
Windows Mobile Device Center (Windows
Vista) to be installed and connected.

Windows Mobile device type Select the Mobile Windows device type from
the drop-down list.
• Windows Mobile Professional
• Windows Mobile Standard

Perform silent install Select to perform the deployment on the device
without requiring user input.

Deployment timeout (minutes) Enter the number of minutes allowed before the
deployment times out.

Start Device Emulator Manager Start the Device Emulator Manager. The De-
vice Emulator Manager is used to connect and
cradle the selected device.
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3. (Optional) Click Start Device Emulator Manager to launch the Emulator Manager so
you can connect to different Windows Mobile device types.

4. Click Finish.

A .zip file containing the application and its generated files is created and placed in the
specified location.
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Configuring the Workflow Package in Sybase
Control Center

After developing and generating the Workflow package, you can use Sybase Control Center to
deploy the Workflow package, and to perform the configuration tasks required to make it
available to application users on a messaging device.

The Workflow node in Sybase Control Center allows administrators to view deployed
Workflow packages, including Workflow display name, module name, and module version.
Administrators deploy Workflow packages into the Unwired Platform cluster through this
node, as well as manage e-mail settings configuration.

Refer to the identified sections in Sybase Control Center online help to perform the following
tasks:

• Deploying a Workflow Package: use the Deploy wizard to make workflow packages
available on the Unwired Server. See Sybase Control Center online help: Sybase Control
Center > Configure > Configuring Unwired Platform > Workflows > Deploying a
Workflow Package.

• Configuring a Workflow Package (Optional): configure the package if you want the
deployed package to have a different set of properties in a production environment. See
Sybase Control Center online help: Sybase Control Center > Configure > Configuring
Unwired Platform > Workflows > Configuring a Workflow Package.

• Registering and Setting Up Messaging Devices: You must manually register application
users to messaging devices. Performing this configuration triggers the registration and
device activation process, which thereby allows messaging MBOs to handle messages
belonging to different datasources. See Sybase Control Center online help: Sybase
Control Center > Configure > Configuring Unwired Platform > Users > Devices >
Messaging Devices >Registering and Setting Up Messaging Devices.

• Assigning the Workflow Package to a User: You must assign the deployed Workflow
package to a user. See Sybase Control Center online help: Sybase Control Center >
Configure > Configuring Unwired Platform > Workflows > Configuring a Workflow
Package > Assigning and Unassigning Device Users.

• Enabling and Configuring E-mail Settings: Configure the properties that allow Unwired
Server to transform e-mail messages into Workflow notifications. See Sybase Control
Center online help: Sybase Control Center > Configure > Configuring Unwired Platform >
Workflows > Enabling and Configuring E-mail Settings.
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Preparing Devices

To enable deploying Workflow packages to a device, you must download, install, and
configure a Workflow container on the device.

Refer to the appropriate procedure for your device type.

Preparing iPhone Devices for the Workflow Package
Install the Mobile Workflow package on the device using the App Store, or use the sample
Workflow container to deploy to the iPhone simulator from the Xcode project.

Installing the Mobile Workflow Package on the Device Using the Mobile
Workflow Container Downloaded From App Store

Install the Mobile Workflow container from the iPhone App Store.

1. On the iPhone home page, tap App Store.

2. Search for Sybase.

3. When the Sybase Mobile Sales & Workflow application appears, tap Free.

4. Tap Free again on the Mobile Sales information page.

5. Tap Install to download the application.

6. In Settings > Sybase, for Connection Info, enter:

a) In Connection Info, enter:

• Server Name – your unwiredserver.company.com or your
relayserver.company.com

• Server Port – 5001 your Unwired Server port or relay server port
• Farm ID – company ID, or Farm ID registered in the relay server
• User name – the user name you entered for the device in Sybase Control Center
• Activation Code – the activation code for the device

b) In Sybase Features, turn the Mobile Workflow option to On and the Mobile Sales
option to Off.
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7. Scroll to the page that contains the Sybase icon, then tap to launch.
The Workflows page appears.

8. To view the inbox e-mails, click the Messages Tab bar, then tap Messages to view the
Workflows.

Deploying the Mobile Workflow Package to the iPhone Simulator
Deploy the Mobile Workflow package to an iPhone simulator for testing.

Prerequisites

• You must have a registered device user in Sybase Control Center to which to assign the
mobile workflow. See the Sybase Control Center online help topic Configure >
Configuring Unwired Platform > Device Users > Devices > Messaging Devices.

• You must have a Mac with iPhone SDK 3.1.3 installed.
• Generate the Mobile Workflow package.

The Workflow Container referenced in this procedure is a sample container. You can use
Xcode to build your own customized user interface and configure other resources.
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Task

1. Log into Sybase Control Center and assign the mobile workflow package to registered
device users.

See the Sybase Control Center online help topic Configure > Configuring Unwired
Platform > Mobile Workflows > Configuring a Mobile Workflow Package.

2. Copy these directories from your Sybase Unwired Platform installation %Sybase%
\UnwiredPlatform\Servers\UnwiredServer\ClientAPI
\ObjectiveC to a location on your Mac:

• includes

• libs

• images

• strings

• WorkflowContainer

You can copy these files into whatever location you choose, but they should all be at the
same directory level.

3. In the WorkflowContainer folder, unzip WorkflowContainer-iPhone.zip
into the same directory level in which you copied the other folders.

This creates a SUPWorkflows folder.

4. In the images folder unzip the WorkflowImages.zip file in its current location.

It unzips as a workflowimages folder.

5. In the SUPWorkflowContainer folder, double-click SUPWorkFlows.xcodeproj so that it
opens in the XCode IDE.

6. In XCode, select Build > Build.

The project builds and the iPhone simulator starts.

7. In the Settings for the iPhone simulator, choose SUPWorkflows and verify the connection
settings.

The ServerNameSetting should be the name of the machine on which the mobile workflow
package is deployed to Unwired Server.
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8. In the iPhone applications screen, open the SUPWorkFlows applications.
The deployed workflow package is shown in the SUPWorkFlows menu.

Preparing Windows Mobile Devices for the Mobile Workflow
Package

Install and configure the container required to prepare a Windows Mobile device to run
Mobile Workflow packages.

1. Navigate to <UnwiredPlatform_InstallDir>\UnwiredPlatform
\Servers\UnwiredServer\ClientAPI\MoMessaging\wm .

2. Copy the appropriate Windows Mobile device file to the device's  My Documents
folder:

• SUPMessaging_Pro.cab – for Pocket PC devices

• SUPMessaging_Std.cab – for Smartphone devices

3. Cradle the Windows Mobile device.

4. Connect a USB cable between the PC and device, and transfer the .cab file.
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5. Open the .cab file from the Windows Mobile device. This installs the container.

6. In the Connection screen, enter the connection settings. These settings should match the
values you used when you registered the device in Sybase Control Center.

• Name/IP Address – your unwiredserver.company.com or your
relayserver.company.com

• Host Port – 5001 your Unwired Server port or relay server port
• CompanyID –company ID, or Farm ID registered in the relay server
• User name – the user name you entered for the device in Sybase Control Center
• Activation Code – the activation code for the device

Note: Select the right arrow icon ( ) to view the container log. This is useful for checking
the connection, or retrieving other debugging information.

7. Access your Microsoft Outlook inbox on the device. For example:

• On Windows Mobile Touch Screen devices, tap Start > Messaging, and then scroll to
and tap Outlook Inbox.

• On Windows Mobile Non-touch Screen devices, click Start > Messaging on the
Home screen. Scroll to a Outlook Inbox and press ENTER.
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8. Select Menu > Workflows.
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9. Select a workflow package from the list of available packages.

Preparing Devices

Developer Reference for Mobile Workflow Packages    77



Preparing Symbian Devices for the Mobile Workflow Package
Install and configure the container required to prepare a Symbian device to run Mobile
Workflow packages.

Prerequisites
You must have Nokia PC Suite or Nokia Ovi Suite installed on your computer. You can
download both from http://www.nokia.com.

Preparing Devices

  78 Sybase Unwired Platform  

http://www.nokia.com


Task

1. Connect your Symbian device to your computer through a USB cable.

Verify that the DataCable setting is set to “PC Suite.”

2. Open Nokia PC or Ovi Suite.

3. In the Sybase Unwired Platform installation, navigate to the directory containing the
Symbian . By default, that directory is <UnwiredPlatform_InstallDir>
\Servers\UnwiredServer\ClientAPI\MoMessaging\symbian.

4. Drag and drop SybaseMessaging.sis into Nokia PC Suite. This copies the file to the
device for installation.

5. To set up the Mobile Workflow container on Symbian, open Sybase Settings and select
Prefs > Connection.

6. Enter these connection settings:

• Name/IP Address – your unwiredserver.company.com or your
relayserver.company.com

• Host Port – 5001 your Unwired Server port or relay server port
• CompanyID –company ID, or farm ID registered in the relay server
• Connection – your WiFi connection or GPRS provider
• User Name –device registered name with the Unwired Server
• Activation Code – code entered when the device registers with Unwired Server.

Note: Select the right arrow icon ( ) to view the container log. This is useful for checking
the connection, or retrieving other debugging information.

7. Select Applications > Mobile Workflow to view and select an available Mobile
Workflow package.

Note: To view a Mobile Workflow package with an e-mail subscription, select Messaging
> Inbox.
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Testing Mobile Workflow Packages

To test a Mobile Workflow package:

1. Launch and/or connect to the mobile device or emulator.
2. Deploy the Mobile Workflow package to the device.
3. Establish the connection to the server on the device.
4. For user-initiated Mobile Workflow packages, go to the Workflows menu of the e-mail

inbox and click on the appropriate Workflow package.
5. For e-mail subscription Mobile Workflow packages, send the e-mail to the device, either

automatically, for example, database trigger, or manually, through the Send E-mail dialog;
then open that e-mail on the device.

6. Enter data and execute menu items appropriately.
7. Verify that the backend is updated correctly.
8. Check the logs.
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Troubleshoot

Use troubleshooting tips to isolate and resolve common issues.

See Troubleshooting Sybase Unwired Platform for information about troubleshooting issues
for Workflow package and other Sybase Unwired Platform components.
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