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Sybase Unwired Platform Tutorials

The Sybase® Unwired Platform tutorials demonstrate how to develop, deploy, and test mobile
business objects, device applications, and mobile workflow packages. You can also use the
tutorials to demonstrate system functionality and train users.

• Learn mobile business object (MBO) basics, and create a mobile device application:
• Tutorial: Mobile Business Object Development

• Create native mobile device applications:
• Tutorial: BlackBerry Application Development
• Tutorial: iOS Application Development
• Tutorial: Windows Mobile Application Development

• Create a mobile workflow package:
• Tutorial: Mobile Workflow Package Development

The tutorials demonstrate a cross section of basic functionality, which includes creating
MBOs, and using various Sybase Unwired WorkSpace development tools, independent
development environments, and device types. Tutorial projects are available if you want the
finished tutorial without going through the steps.

Sybase Unwired Platform Tutorials
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Task Flow

Use this tutorial to develop a BlackBerry device application using replication-based
synchronization and custom coding. Test the application on a simulator.

Table 1. Eclipse tutorials

Task Goals Steps required to complete the
task

Getting Started • Install all required Unwired
WorkSpace components and
external resources.

• Start Unwired Server and other
platform services, if not already
started.

• Open the Mobile Development
perspective, and become famil-
iar with the views of the per-
spective, and the Mobile Appli-
cation Diagram.

• Installing Sybase Unwired Platform
on page 5

• Starting Sybase Unwired Work-
Space on page 5

• (Optional) Learning the Basics on
page 6

Note: These steps are prerequisites for
the rest of this tutorial. You need to per-
form them only once.

Developing Data-
base Mobile Busi-
ness Objects

• Create a mobile application
project and a connection to the
database.

• Create a mobile business object
and deploy it to Unwired Serv-
er.

Complete the Tutorial: Mobile Business
Object Development.

Note: This tutorial is a prerequisite for
the remaining steps. You need to perform
it only once.

Task Flow
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Task Goals Steps required to complete the
task

Developing a
BlackBerry Appli-
cation

Generate Java code for the Black-
Berry platform, create the user in-
terface for the application, and run
it on the simulator.

• Installing the BlackBerry Java Plug-
in for Eclipse on page 9

• Generating Java Object API Code on
page 9

• Creating the BlackBerry Project on
page 11

• Creating the User Interface on page
13

• Creating a Launch Configuration for
the Project on page 18

• Testing the Device Application on
the BlackBerry Simulator on page
19

Task Flow
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Getting Started

Install and learn about Sybase Unwired Platform and its associated components.

Complete the following tasks for all tutorials, but you need to perform them only once.

Installing Sybase Unwired Platform
Install Sybase Unwired Platform.

Before starting this tutorial, be sure you have all the requisite Unwired Platform components
installed. For complete installation instructions, see:

• Release Bulletin for Sybase Mobile SDK
• Installation Guide for Sybase Mobile SDK
• Release Bulletin for Runtime
• Installation Guide for Runtime

• Install Sybase Mobile SDK, which includes:
• Development support for Native Object API applications, HTML5/JS Hybrid (Mobile

Workflow) applications, and OData SDK applications.
• Sybase Unwired WorkSpace, the Eclipse-based development environment for MBOs

and Mobile Workflows.
• Install Unwired Platform Runtime:

• Data Tier (included with single-server installation)
• Unwired Server

Starting Sybase Unwired WorkSpace
Start Unwired WorkSpace.
Select Start > Programs > Sybase > Unwired Platform > Unwired WorkSpace.

The Sybase Unwired Workspace opens in the Mobile Development perspective. The
Welcome page displays links to product information, and to the product.

Next
To read more about Sybase Unwired WorkSpace concepts and tasks, select Help > Help
Contents from the main menu.

Getting Started

Tutorial: BlackBerry Application Development 5



Learning the Basics
Learn about Sybase Unwired WorkSpace and how to access help (optional).

Prerequisites
Start Unwired WorkSpace.

Task

1. In the Welcome page, click any of the links to explore the Unwired WorkSpace
environment.

2. To enter the Sybase Unwired WorkSpace development environment, click Start
Development  or close the Welcome tab.

The default Mobile Development perspective provides ready access to most of the tools
you need to create, update, and manage mobile business objects (MBOs). This table
describes the main windows and views of the Mobile Development perspective. Note that
not all the views are open initially; some views become available only after you begin
developing your MBOs:

View or Window Description

WorkSpace Navigator A view of mobile application projects. Each project folder includes
resources and data source references to which the MBOs are
bound, personalization keys, and so on.

Use this view to review and modify MBO-related properties.

Enterprise Explorer A view of enterprise back-end resources, such as database servers,
SAP® servers, and Sybase Unwired Server.

Getting Started
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View or Window Description

Mobile Application Dia-
gram

A graphical editor for designing mobile business objects. A Mobile
Application Diagrem is associated with each project.

Use the Mobile Application Diagram to create MBOs (including
attributes and operations), then define relationships with other
MBOs. You can:

• Create MBOs in the Mobile Application Diagram using Palette
icons and menu selections. Either bind to a data source now or
or defer binding. For example, using a top-down approach, you
might model your MBOs before creating the data sources to
which they bind.

• Drag items from Enterprise Explorer and drop them onto the
Mobile Application Diagram to create the MBO – quickly
creates the operations and attributes automatically based on the
data source of the items.

Palette A view from which you can drag controls onto an open Mobile
Application Diagram and define their attributes, operations, and
relationships to your application.

Properties A view that shows the properties of the object currently selected in
the Mobile Application Diagram, and lets you edit them. You can-
not create an MBO from the Properties view, but generally, most
development and configuration is performed here.

Outline An outline of the file that is currently open in an editor, listing
structural elements. The contents are editor-specific.

Error Log The error log captures Eclipse warnings and errors, including stack
traces.

Problem A view that displays problems, errors, or warnings.

3. To access the online help, click Help  > Help Contents in the main menu bar.

4. Expand any of the documents that appear in the left pane.

Some documents are for Sybase Unwired Platform, while others are for the Eclipse
development environment.

Getting Started
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Developing a BlackBerry Application

Generate code for the BlackBerry platform, develop a BlackBerry device application with
code, and test its functionality.

Prerequisites
Complete these tasks:

• Install Sybase Unwired Platform Mobile SDK and Runtime as indicated in Getting Started
on page 5.

• Complete Tutorial: Mobile Business Object Development, which provides the foundation
tasks for this tutorial:

Task
The device application communicates with the database mobile business objects that are
deployed to Unwired Server.

Installing the BlackBerry Java Plug-in for Eclipse
The BlackBerry Java Plug-in for Eclipse enables you to finish developing the BlackBerry
application using BlackBerry smartphone-specific development, debugging, and simulation
tools.

1. Download the BlackBerry Java Plug-in for Eclipse (full installer) from http://
us.blackberry.com/developers/javaappdev/.

2. Run the downloaded installer and follow the instructions to install the BlackBerry Java
Plug-in for Eclipse. Accept the default installation folder: do not specify the Unwired
WorkSpace Eclipse directory.

Generating Java Object API Code
Generate object API code for the SUP101 mobile application project.

Prerequisites
You must be connected to both My Sample Database and My Unwired Server. Code
generation fails if the server-side (run-time) enterprise information system (EIS) data sources
referenced by the MBOs in the project are not running and available to connect to when you
generate object API code.

Developing a BlackBerry Application
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Task

1. In Unwired WorkSpace, open the SUP101 mobile application project.

In WorkSpace Navigator, right-click the SUP101 folder and select Open in Diagram
Editor.

Note: If you do not see the SUP101 project in Workspace Navigator, you must first
complete the Tutorial: Developing Mobile Business Objects, which is a prerequisite for
this tutorial.

2. If you are performing other tutorials, optionally add a new folder to the project in which to
generate code for each device platform.
For example, in WorkSpace Navigator, expand SUP101 and add a RIM folder under
Generated Code.

3. Right-click the SUP101 Mobile Application Diagram and select Generate Code.

4. Click Next to continue without a configuration.

5. Make sure the Customer MBO is selected, then click Next.

6. Specify the following configuration options:

Option Description

Language Select Java.

Platform Select Java ME for BlackBerry.

Unwired Server Select My Unwired Server.

Server domain Select default.

Page size Select 1024.

Package Optionally enter a unique name for the Java
package.

Destination /SUP101/Generated Code, or anoth-

er folder that you created for this device plat-
form in Step 3.

Generate JavaDoc Unselect for this tutorial.

7. Click Finish.
You can ignore the error icons that appear in WorkSpace Navigator under Generated Code/
src/SUP101, and the error, net cannot be resolved, in the Problems view.

The error occurs because the package java file called by SUP101DB.jar is not yet in the
project build path. The errors will be resolved later, when you build the application in the
BlackBerry Java Plug-in for Eclipse.

8. Click OK in the Success dialog.

Developing a BlackBerry Application
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Creating the BlackBerry Project
Create a new BlackBerry project in the BlackBerry Java Plug-in for Eclipse, where you add
functionality and finish developing the application.

Prerequisites
Install the BlackBerry Java Plug-in for Eclipse.

Task

1. Start the BlackBerry Java Plug-in for Eclipse.

Note: When the Eclipse Workspace Launcher prompts you to select a workspace, do not
choose one that you are using with Unwired WorkSpace. If necessary, select or create a
new workspace.

2. Click File > New > BlackBerry Project.

3. In the New BlackBerry Project wizard, use these values and click Next.

• Name – enter SUP101Sample

• Use a project specific JRE – select BlackBerry JRE 6.0.0

Developing a BlackBerry Application
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4. In the Java Settings page, modify the build path to point to the correct location for
sup_client_rim.jar and UltraLiteJ.jar.

a) Click the Libraries tab.
b) Click Add External Jars.
c) Browse to <UnwiredPlatform_InstallDir\UnwiredPlatform

\ClientAPI\RBS\BB.

d) Select all the JAR files (for example, by pressing Ctrl + A), then click Open.
e) Click Finish.

Developing a BlackBerry Application
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Configuring BlackBerry Application Properties
Indicate the general BlackBerry properties used in this application.

1. In the BlackBerry Java Plug-in for Eclipse, open the SUP101Sample diagram editor.

2. In the Title, enter SUP101Sample.

3. (Optional) Enter a Version, Vendor, or Description.

4. Click File > Save to save the SUP101Sample descriptor file.

Copy Unwired Platform Files to Sample Project
Copy Unwired Platform BlackBerry runtime files and generated object API code to the
SUP101Sample project.

1. In Windows Explorer, browse to <UnwiredPlatform_InstallDir>
\UnwiredPlatform\ClientAPI\RBS\BB.

2. Copy the CommonClient.cod, sup_client_rim.cod, and UltraLiteJ.cod
files.

3. Paste the copied COD files into the BlackBerry Java Plug-in simulator directory, located in
<BlackBerry_Eclipse_InstallDir>\plugins
\net.rim.ejde.componentpackversion\components\simulator.

4. In the workspace folder that you are using for Sybase Unwired WorkSpace, copy the src
folder containing the files that you generated for the SUP101 mobile application
project.
For example, C:\Documents and Settings\user1\SUP-wksp
\SUP101\Generated Code\RIM\src.

5. Paste the copied folder into the SUP101Sample project folder in your BlackBerry
Application Development workspace.
For example, C:\Documents and Settings\user1\BB-wksp
\SUP101Sample.
In the BlackBerry Java Plug-in for Eclipse Package Explorer, the SUP101 and
SUP101.intrnl folders are listed under the src folder.

If the copied folders are not listed, click Refresh or press F5

Creating the User Interface
Create the user interface for the SUP101Sample application.

Prerequisites
Obtain the text files that contain the code snippets you need to build the user interface from the
SUP_BB_Custom_Dev_Tutorial_code.zip file. The code snippets are used to

Developing a BlackBerry Application
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create these classes: CustomerSample, CustomerList, and
CustomerSampleScreen.

• If you are viewing this guide online from the Sybase Product Documention web site, click
SUP_BB_Custom_Dev_Tutorial_code.zip to access the zip archive containing the text
files.

• If you are viewing this guide as a PDF, go to the Sybase Product Documentation Web site at
http://sybooks.sybase.com/nav/summary.do?prod=1289&lang=en&submit=%A0Go
%A0&prodName=Sybase+Unwired+Platform&archive=0. Click the link for the Sybase
Unwired Platform version that you want. Then, navigate to this topic in the tutorial, and
click the link for the zip file to access the text files.

Task

1. In Package Explorer, right-click SUP101Sample, and select New  > Package.

2. For the Name, enter com.sybase.sup.samples.objectapi and click Finish.

3. Right-click the com.sybase.sup.samples.objectapi package and select New > Class.

4. For the Name, enter CustomerSample, and click Finish.

Developing a BlackBerry Application
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5. In the CustomerSample.java file, copy and paste the code from the provided
CustomerSample.java text file.

Overwrite any existing contents. The provided code creates the main Customer
application.

Developing a BlackBerry Application
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6. Save the CustomerSample.java file.
The package contains errors until you create the two other classes. Ignore these errors and
continue.

7. Right-click the com.sybase.sup.samples.objectapi package, and select New  > Class.

8. For Name, enter CustomerList, and click Finish.

9. In the CustomerList.java file, copy and paste the code from the provided
CustomerList.java text file.

Overwrite any existing contents.

Developing a BlackBerry Application

16 Sybase Unwired Platform



10. Save the CustomerList.java file.
Ignore the errors, which resolve once you create the next class.

11. Right-click the com.sybase.sup.samples.objectapi package, and select New  > Class.

12. For Name, enter CustomerSampleScreen, and click Finish.

13. In the CustomerSampleScreen.java file, copy and paste the code from the
provided CustomerSampleScreen.java text file.

Overwrite any existing contents.

Developing a BlackBerry Application
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14. Save the CustomerSampleScreen.java file.
Notice that the compilation errors in other java files are resolved.

Creating a Launch Configuration for the Project
Create and configure a new launch configuration for the SUP101Sample project.

1. In Package Explorer, right-click the SUP101Sample project, and select Run-as > Run
Configurations.

2. Select BlackBerry Simulator in the left pane, click the new launch configuration icon,
and select the SUP101Sample project in the right pane.

3. In Name, enter SUP101Sample.

4. In the JRE tab, select the JRE to use, in this case, BlackBerry JRE 6.0.0.

5. In the Simulator tab, select Launch Mobile Data System Connection Service (MDS-
CS) with simulator, then select BlackBerry-SDK - 9800 as the device.

Developing a BlackBerry Application
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6. Click Apply, then Close.

Testing the Device Application on the BlackBerry Simulator
Run and test the SUP101Sample application on the BlackBerry simulator.

1. In Package Explorer, right-click the SUP101Sample project and select Run As >
BlackBerry Simulator.
If this is the first time running the simulator, cancel the setup screen.

Developing a BlackBerry Application
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2. On the main window, click All to access the applications screen, then scroll until you see
the SUP101Sample application.

3. Click to launch the SUP101Sample application.

4. Click the BlackBerry menu button, then select Synchronize.
The customer list appears.

Developing a BlackBerry Application
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5. Focus on the customer list and enter dal in the Search bar.
The customer list is filtered and only customers with a first or last name beginning with
'dal' are shown, in this case, Daljit Sinnot.

6. Select the customer, Daljit Sinnot, and click the trackball.
The detail screen for Daljit Sinnot appears.

Developing a BlackBerry Application
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7. In the customer detail screen, change the first name of the customer to abc and click
Submit.

The Submit button on the Customer Detail screen is mapped to the update operation of the
customer mobile business object. When the application is synchronized, any pending
operations are uploaded to Unwired Server.

8. To upload the new record to the back-end database sampledb, click the Menu key, and
select Synchronize.

Developing a BlackBerry Application
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Learn More about Sybase Unwired Platform

Once you have finished, try some of the other samples or tutorials, or refer to other
development documents in the Sybase Unwired Platform documentation set.

Check the Sybase Product Documentation Web site regularly for updates: access http://
sybooks.sybase.com/nav/summary.do?prod=1289, then navigate to the most current version.

Tutorials
Try out some of the other getting started tutorials available on Product Documentation to get a
broad view of the development tools available to you.

Tutorial Projects
Tutorial projects are available for download, if you want the finished tutorial without going
through the steps. Download tutorial projects from: http://www.sdn.sap.com/irj/sdn/mobile?
rid=/webcontent/uuid/40ea4956-b95c-2e10-11b3-e68c73b2280e.

Samples
Sample applications are fully developed, working applications that demonstrate the features
and capabilities of Sybase Unwired Platform.

Check the SAP® Development Network (SDN) Web site regularly for new and updated
samples: https://cw.sdn.sap.com/cw/groups/sup-apps.

Online Help
See the online help that is installed with the product, or the Product Documentation Web site.

Developer Guides
Learn about using the API to create device applications:

• Developer Guide: BlackBerry Native Applications
• Developer Guide: iOS Native Applications
• Developer Guide: Windows and Windows Mobile Native Applications
• Developer Guide: Mobile Workflow Packages

Customize and automate:

• Developer Guide for Unwired Server Management API  – customize and automate system
administration features.

• Developer Guide: Unwired Server – customize and automate server-side implementations
for device applications, and administration, such as data handling.

Javadoc and HeaderDoc are also available in the installation directory.

Learn More about Sybase Unwired Platform
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