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Sybase Unwired Platform Tutorials

The Sybase® Unwired Platform tutorials demonstrate how to develop, deploy, and test mobile
business objects, device applications, and mobile workflow packages. You can also use the
tutorials to demonstrate system functionality and train users.

Tip: If you want to see the final outcome of a tutorial without performing the steps, the
associated example project is available on SAP® SDN: http://www.sdn.sap.com/irj/sdn/
mobile?rid=/webcontent/uuid/40ea4956-b95c-2e10-11b3-e68c73b2280e.

• Learn mobile business object (MBO) basics, and use this tutorial as a foundation for the
Object API application development tutorials:
• Tutorial: Mobile Business Object Development

• Create native Object API mobile device applications:
• Tutorial: Android Object API Application Development
• Tutorial: BlackBerry Object API Application Development
• Tutorial: iOS Object API Application Development
• Tutorial: Windows Mobile Object API Application Development

• Create a mobile business object, then develop a mobile workflow package that uses it:
• Tutorial: Mobile Workflow Package Development

Sybase Unwired Platform Tutorials
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Task Flow

Use this tutorial to develop, deploy, and run a Mobile Workflow package on an emulator or a
simulator.

Task Goals Steps

Getting started Install Sybase Unwired Platform,
create a connection profile, start the
server and Unwired WorkSpace, and
create a Mobile Workflow Applica-
tion project.

• Installing Sybase Unwired Plat-
form

• Starting Unwired Platform
Services

• Starting Sybase Unwired Work-
Space

• Connecting to Sybase Control
Center

• (Optional) Learning Unwired
WorkSpace Basics

These steps are prerequisites for the
rest of this tutorial. You need to per-
form them only once.

Developing a database
mobile business object

Create and deploy a database mobile
object.

• Creating the TravelRequest Ta-
ble

• Creating the TravelRequest Mo-
bile Business Object

• Deploying the Workflow101
Mobile Application Project

Developing the Mobile
Workflow package

Create a mobile workflow form,
generate the files, register the device
in Sybase Control Center, assign the
Mobile Workflow package to a user,
and view the mobile workflow form
on the emulator or simulator.

• Creating a Mobile Workflow
Form

• Installing the Mobile Workflow
Package

• Running the Mobile Workflow
Package

• Verifying the Data on the Back-
end Database

Task Flow
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Getting Started with Unwired Platform

Install and learn about Sybase Unwired Platform and its associated components.

Complete the following tasks for all tutorials, but you need to perform them only once.

1. Installing Sybase Unwired Platform

Install Sybase Mobile SDK and Sybase Unwired Platform Runtime.

2. Starting Sybase Unwired Platform Services

Start Unwired Server, Sybase Control Center, the sample database, the cache database
(CDB), and other essential services.

3. Starting Sybase Unwired WorkSpace

Start the development environment, where you can perform tasks that include creating
mobile business objects (MBOs), managing database and server connections, developing
Mobile Workflow applications, and generating Object API code.

4. Connecting to Sybase Control Center

Open the Sybase Control Center administration console to manage Unwired Server and its
components.

5. Learning Unwired WorkSpace Basics

Sybase Unwired WorkSpace features are well integrated in the Eclipse IDE. If you are not
familiar with Eclipse, you can quickly learn the basic layout of Unwired WorkSpace and
the location of online help.

Installing Sybase Unwired Platform
Install Sybase Mobile SDK and Sybase Unwired Platform Runtime.

Before starting this tutorial, be sure you have all the requisite Unwired Platform components
installed. For complete installation instructions, see the Sybase Unwired Platform
documentation at http://sybooks.sybase.com/nav/summary.do?prod=1289:

• Release Bulletin for Sybase Mobile SDK
• Installation Guide for Sybase Mobile SDK
• Release Bulletin for Runtime
• Installation Guide for Runtime

1. Install these Unwired Platform Runtime components:

• Data Tier (included with single-server installation)
• Unwired Server

2. Install Mobile SDK, which includes:

Getting Started with Unwired Platform
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• Development support for Native Object API applications, HTML5/JS Hybrid (Mobile
Workflow) applications, and OData SDK applications.

• Sybase Unwired WorkSpace, the Eclipse-based development environment for MBOs
and mobile workflows.

Starting Sybase Unwired Platform Services
Start Unwired Server, Sybase Control Center, the sample database, the cache database (CDB),
and other essential services.

How you start Unwired Platform services depend on the options you selected during
installation. In some cases, you may need to manually start Unwired Platform services.
Select Start > Programs > Sybase > Unwired Platform  > Start Unwired Platform
Services.
The Unwired Server services enable you to access the Unwired Platform runtime components
and resources.

Starting Sybase Unwired WorkSpace
Start the development environment, where you can perform tasks that include creating mobile
business objects (MBOs), managing database and server connections, developing Mobile
Workflow applications, and generating Object API code.
Select Start > Programs > Sybase > Unwired Platform > Unwired WorkSpace.
The Sybase Unwired WorkSpace opens in the Mobile Development perspective. The
Welcome page displays links to the product and information.

Next
To read more about Unwired WorkSpace concepts and tasks, select Help > Help Contents.

Connecting to Sybase Control Center
Open the Sybase Control Center administration console to manage Unwired Server and its
components.

From Sybase Control Center, you can:

• View servers and their status
• Start and stop a server
• View server logs
• Deploy a mobile application package
• Register application connections
• Set role mappings

Getting Started with Unwired Platform
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For information on configuring, managing, and monitoring Unwired Server, click Help >
Online Documentation.

1. Select Start > Programs > Sybase > Sybase Control Center.

Note: If the Sybase Control Center service does not open, make sure that the service is
started. See the Installation Guide for Runtime.

2. In Sybase Control Center, log in by entering the credentials set during installation.

Sybase Control Center gives you access to the Unwired Platform administration features
that you are authorized to use.

Learning Unwired WorkSpace Basics
Sybase Unwired WorkSpace features are well integrated in the Eclipse IDE. If you are not
familiar with Eclipse, you can quickly learn the basic layout of Unwired WorkSpace and the
location of online help.

• To access the online help, select Help  > Help Contents. Some documents are for Sybase
Unwired Platform, while others are for the Eclipse development environment.

• The Welcome page provides links to useful information to get you up and running.
• Reopen the Welcome page by selecting Help > Welcome.
• To close the Welcome page, click X.
• To learn about tasks you must perform, select the Development Process icon.

• In Unwired WorkSpace, look at the area (window or view) that you will use to access,
create, define, and update mobile business objects (MBOs).

Window Description

WorkSpace Navigator view Use this view to create Mobile Application projects,
and review and modify MBO-related properties.

This view displays mobile application project fold-
ers, each of which contains all project-related re-
sources in subfolders, including MBOs, datasource
references to which the MBOs are bound, personal-
ization keys, and so on.

Enterprise Explorer view A view that provides functionality to connect to var-
ious enterprise information systems (EIS), such as
database servers, SAP® back ends, and Unwired
Server.

Getting Started with Unwired Platform
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Window Description

Mobile Application Diagram The Mobile Application Diagram is a graphical ed-
itor where you create and define mobile business
objects.

Use the Mobile Application Diagram to create
MBOs (including attributes and operations), then
define relationships with other MBOs. You can:

• Create MBOs in the Mobile Application Dia-
gram using Palette icons and menu selections –
either bind or defer binding to a data source,
when creating an MBO. For example, you may
want to model your MBOs before creating the
data sources to which they bind. This MBO de-
velopment method is sometimes referred to as
the top-down approach.

• Drag items from Enterprise Explorer and drop
them (drag and drop) onto the Mobile Applica-
tion Diagram to create the MBO – quickly cre-
ates the operations and attributes automatically
based on the datasource artifact being dropped
on the Mobile Application Diagram.

Each new mobile application project generates an
associated mobile application diagram.

Palette The Palette is accessed from the Mobile Application
Diagram and provides controls, such as the ability to
create MBOs, add attributes and operations, and de-
fine relationships, by dragging-and-dropping the
corresponding icon onto the Mobile Application Di-
agram or existing MBO.

Properties view Select an object in the Mobile Application Diagram
to display and edit its properties in the Properties
view. While you cannot create an MBO from the
Properties view, most development and configura-
tion is performed here.

Outline view Displays an outline of the active file and lists struc-
tural elements. The contents are editor-specific.

Problems view Displays problems, errors, or warnings that you may
encounter. This is a valuable source for collecting
troubleshooting information.

Getting Started with Unwired Platform
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Window Description

Error Log view Displays error log information. This is a valuable
source for collecting troubleshooting information.

Getting Started with Unwired Platform
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Developing a Database Mobile Business
Object

Create a database mobile business object and deploy it to Unwired Server.

Develop the database mobile business object by:

1. Creating the Mobile Workflow 101 Mobile Application Project

A mobile application project is the container for the mobile business objects that form the
business logic of mobile applications.

2. Creating the TravelRequest Database Table

Create the database table to be used by the Travel Request mobile business object.

3. Creating the TravelRequest Mobile Business Object

Use the TravelRequest database table to create a mobile business object.

4. Deploying the WorkFlow101 Mobile Application Project

Deploy the project that contains the TravelRequest mobile business object to the server.

Creating the Mobile Workflow 101 Mobile Application
Project

A mobile application project is the container for the mobile business objects that form the
business logic of mobile applications.

Create a mobile application project before creating its mobile business objects.

1. In the Unwired WorkSpace menu, click File > New > Mobile Application Project.

2. Enter MobileWorkflow101 as the name.

3. Click Finish.

Creating the TravelRequest Database Table
Create the database table to be used by the Travel Request mobile business object.

In this task, create a SQL file that you can use to create the database table for the mobile
business object.

1. From the main menu, select File > New > Other.

2. Select SQL Development > SQL File, and click Next.

Developing a Database Mobile Business Object
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3. Enter or select the values shown, then click Finish:

Field Value

Parent folder Select the MobileWorkflow101 project.

File name Enter TravelRequest.

Database server type Select Sybase_ASA_12.x.

Connection profile name Select My Sample Database.

Database name Select sampledb.

Developing a Database Mobile Business Object

12 Sybase Unwired Platform



4. In the TravelRequest.sql editor, copy and paste this code:

CREATE TABLE TravelRequest (
    trvl_Id                      integer NOT NULL DEFAULT 
autoincrement 
   ,trvl_Date                    date NULL 
   ,trvl_Loc                     varchar(20) NULL
   ,est_Cost                     float NULL
   ,purpose                      varchar(200) NULL
   ,trvl_Status                  varchar(20) NULL 
   ,st_Cmmnt                     varchar(200) NULL 
   ,PRIMARY KEY CLUSTERED (trvl_Id) 

Developing a Database Mobile Business Object
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);

5. Save TravelRequest.sql and close the editor.
Unwired Workspace adds TravelRequest.sql to the MobileWorkFlow101 project.

6. In the WorkSpace Navigator, expand MobileWorkflow101. Right-click
TravelRequest.sql and select Execute SQL Files.

Unwired Workspace creates a table called TravelRequest in the sampledb database.

7. In the Enterprise Explorer, expand sampledb, expand the Tables folder, and verify that the
new TravelRequest table is added.

If the table is not visible, right-click the Tables folder and select Refresh.

Creating the TravelRequest Mobile Business Object
Use the TravelRequest database table to create a mobile business object.

Prerequisites
Complete Creating the TravelRequest Database Table on page 11.

Task

1. In the Enterprise Explorer, expand the sampledb database, then expand the Tables
folder.

2. Drag the TravelRequest table from the Enterprise Explorer onto the MobileWorkflow101
Mobile Application Diagram.

3. In the Quick Create wizard, accept the default settings and click OK.
An MBO is created in the Mobile Application Diagram.

4. Save the diagram.

Deploying the WorkFlow101 Mobile Application Project
Deploy the project that contains the TravelRequest mobile business object to the server.

1. Right-click in the MobileWorkflow101 Mobile Application Diagram, and select Deploy
Project.

2. In the first page of the Deploy Mobile Application Project wizard, accept the default
options and click Next.

Developing a Database Mobile Business Object
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3. In the Contents page, select the TravelRequest mobile business object, and click Next.

4. In the Package User-defined Classes page, click Next.

Note: The Package User-defined Classes window appears by default in the advanced
developer profile.

5. In the Target Server page, select My Unwired Server in the list of available servers. If the
Next button is not enabled, click Connect to connect to the server. Then, click Next.

6. In the Deploy Application to Server page, click Next.

7. In the Server Connection Mapping page, click My Sample Database under Connection
profile. Then, choose sampledb under Server connection.

8. Click Finish.

9. When the Executing Deployment window closes, click OK to dismiss the Deployment
Status window.

Developing a Database Mobile Business Object

Tutorial: Mobile Workflow Package Development 15



10. In Enterprise Explorer, open Unwired Servers\My Unwired Server
\Domains\default\Packages\mobileworkflow101:1.0. Verify that the
Mobile Business Objects folder contains the TravelRequest MBO that you deployed.

Developing a Database Mobile Business Object
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Developing the Mobile Workflow Package

Develop and deploy a mobile workflow package.

1. Registering Application Connections in Sybase Control Center

Register a connection for each device or emulator that you want to use.

2. Creating a Mobile Workflow Form

Create a mobile workflow form using the TravelRequest mobile business object.

3. Generating Code for a Mobile Workflow Package

Generate a Mobile Workflow package and deploy it to Unwired Server to make it available
to device clients.

4. Running the Mobile Workflow Application on the Windows Mobile Emulator

Install and configure the Windows Mobile synchronization software and emulator, and use
it to run the Mobile Workflow application.

5. Running the MobileWorkflow Application on the Android Emulator

Install and configure the Android Simulator software and use it to run the Mobile
Workflow application.

6. Running the MobileWorkflow Application on the iPhone Simulator

Build a sample Mobile Workflow container in the XCode IDE, and run the travelrequest
Mobile Workflow application on an iPhone simulator.

7. Running the MobileWorkflow Application on the BlackBerry Simulator

Install and configure the BlackBerry simulator, and use it to run the Mobile Workflow
application.

8. Verifying the Data on the Backend Database

After submitting a travel request in an emulator, verify that the information is updated in
the database.

Registering Application Connections in Sybase Control
Center

Register a connection for each device or emulator that you want to use.

1. Log in to Sybase Control Center using the supAdmin user name and the current password.

2. In Sybase Control Center, select View > Select > Unwired Server Cluster Management
View.

Developing the Mobile Workflow Package
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3. Click Applications in the left pane. In the right pane, open the Application Connections
tab.

4. Register an application connection for each device that you will test in the tutorial:

a) Click Register.
b) In the Register Application Connection window, specify the following options:

• User name – enter the name of the user that will activate and register the Mobile
Workflow application. For this tutorial, where we test several different emulators,
enter a unique user name for each device.

• Template – accept the default template name.
• Server name – the machine and domain of the host server where the mobile

application project is deployed.
• Port – accept the default value for the port used for messaging connections between

the device and Unwired Server. If you use Relay Server, this is the Relay Server
port.

• Farm ID – enter 0.

• Application ID – select HWC.
• Security configuration – accept the default value.
• Domain – accept the default blank field.
• Activation code length – accept the default value.
• Activation expiration (hours) – optionally, change the default value (for example,

to enable the connection for longer than 72 hours).
• Specify Activation Code – enter a value (using the specified length) that is sent to

the user in an activation e-mail. If you do not specify an activation code, one is
generated automatically. The user must enter the activation code when logging in to
the application. The value can contain letters A - Z (uppercase or lowercase),
numbers 0 - 9, or a combination of both.

c) Click OK.

The connection is added to the Application Connections table. The following example
shows three registered connections, each for a different device. The connection in the
second line has no Device Type or Device ID yet because the device is not currently
connected: these fields are automatically loaded when the specified user accesses the
connection.

Developing the Mobile Workflow Package
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Creating a Mobile Workflow Form
Create a mobile workflow form using the TravelRequest mobile business object.

Prerequisites
Complete Deploying the WorkFlow101 Mobile Application Project on page 14.

Task

1. In the Sybase Unwired WorkSpace menu, click File > New > Mobile Workflow Forms
Editor.

2. Select the MobileWorkflow101 folder and enter travelrequest.xbw as the file
name.

3. Click Next.

4. In the Starting Points page, select Can be started, on demand, from the client, and click
Finish.

5. In the Mobile Workflow Forms editor, click the Flow Design tab.
The new flow diagram contains a Client-initiated screen, connected to a Start Screen.

Developing the Mobile Workflow Package
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6. In Workspace Navigator, expand MobileWorkflow101 > Mobile Business Objects >
TravelRequest > Operations.

7. Drag the create operation onto the flow diagram.

The TravelRequest_create screen is added.

Developing the Mobile Workflow Package
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8. Add a GoTo connection from the Start Screen to the TravelRequest_create screen:

a) In the Palette, click GoTo.
b) Click the Start Screen, and while holding the mouse down, drag the connection to the

TravelRequest_create screen.

A line with an arrow connects the two screens.

Developing the Mobile Workflow Package
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9. Double-click the Start screen to open its Screen Design page.

10. In the Palette, select the HtmlView control and click the Start screen.
The HtmlView control is added to the Start screen design.

Developing the Mobile Workflow Package
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11. Click Flow Design.

12. In the Flow Design, select the Client-initiated starting point.

The Properties view shows all of the keys that were automatically created for each
parameter in the create method of the TravelRequest mobile business object. If the
Properties view does not open, right-click the Client-initiated screen and select Show
Properties View.

13. Create a new key:

a) In the Client-initiated Properties view, click New.
b) Enter these values:

Developing the Mobile Workflow Package
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• Name – IntroKey

• Type – string

Note: In the tutorial this key doesn't do anything, and the name and type are not
important; we are simply demonstrating how to add a new key.

c) Click OK.

The new key, IntroKey, is added to the list of keys in the Properties view.

14. Define the default value for the new key:

a) In the Mobile Workflow Forms editor, click the Screen Design tab.
b) If the Start Screen is not selected, select Start Screen in the screen selection control

above the Screen Design.

c) In the Start Screen, select the HtmlView control to display its properties.
d) In Properties view, click the Key control and select IntroKey.
e) In Default value, enter the message code:

<H2>Travel Request App</H2>This application enables vacation 
requests to be sent for approval<br>.

Developing the Mobile Workflow Package
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15. View the current parameter settings of the TravelRequest screen:

a) In the screen selection control above the Screen Design page, change the screen to
TravelRequest_create.

b) In the menu, select the Create operation to display its properties.
c) In Properties, click Parameter Mappings.

The parameter mapping table shows the mobile business object parameters for the
operation and their keys.

16. Save the travelrequest workflow form.

Generating Code for a Mobile Workflow Package
Generate a Mobile Workflow package and deploy it to Unwired Server to make it available to
device clients.

Prerequisites
Complete these tasks:

• Registering the Device in Sybase Control Center on page 17 for each device that you want
to enable to connect to the package.

Developing the Mobile Workflow Package
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• Complete Developing a Database Mobile Business Object on page 11.
• Complete Creating a Mobile Workflow Form on page 19.
• For Windows Mobile devices, start the synchronization software if it is not already

running:
• On Windows XP, start Microsoft ActiveSync.
• Windows Vista, Windows 7, or Windows 2008, start Windows Mobile Device Center.

Task
Use the Mobile Workflow Package Generation wizard to generate files for the mobile
workflow package, optionally deploy the generated package files to the server, and assign the
package to one or more devices.

1. Open Sybase Unwired Workspace.

2. In the WorkSpace Navigator, expand MobileWorkflow101 and double-click
travelrequest.xbw.
The package file opens in the Mobile Workflow Forms Editor.

3. In the Sybase Unwired Workspace toolbar, click the  Mobile Workflow package wizard
button.

4. In the New Mobile Workflow Package Generation wizard, select these options:

Option Description

Update generated code Select Generate into the project.

Unwired Server Profile Select My Unwired Server as the profile to
associate with the mobile workflow package.

Deploy to an Unwired Server Select this option.

Assign workflow to users Select this option and click Get Users to choose
one or more registered users for whom you
want to deploy the package. Multiple users are
separated by commas.

Developing the Mobile Workflow Package
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5. Click Finish.

The WorkSpace assigns the TravelRequest application to the user and generates the files
for the mobile workflow package in a zip archive on the server. You can see the files in your
project in the Workspace Navigator:

Developing the Mobile Workflow Package
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If the package is not displayed initially, double-click the server to refresh the display.

The mobile workflow package is added to the Enterprise Explorer under the Unwired
Servers/Workflows folder.

Developing the Mobile Workflow Package
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6. Save your emulator settings.
For example, click File > Save State and Exit.

Running the Mobile Workflow Application on the Windows
Mobile Emulator

Install and configure the Windows Mobile synchronization software and emulator, and use it
to run the Mobile Workflow application.

1. Installing Microsoft Synchronization Software

Install and configure Microsoft synchronization software so you can deploy and run a
mobile application on a Windows Mobile emulator.

2. Configuring the Windows Mobile Emulator

Follow these steps to configure the Windows Mobile emulator for the Mobile Workflow
package deployment.

3. Running the Mobile Workflow Form on the Windows Mobile Emulator

Run the travelrequest mobile workflow form on the Windows Mobile emulator.

Developing the Mobile Workflow Package
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See also
• Running the MobileWorkflow Application on the Android Emulator on page 43

Installing Microsoft Synchronization Software
Install and configure Microsoft synchronization software so you can deploy and run a mobile
application on a Windows Mobile emulator.

Note: These instructions describe installing Microsoft ActiveSync for Windows XP. If you are
using Windows Vista, Windows 7, or Windows 2008, install Virtual PC 2007 SP1 and
Windows Mobile Device Center to manage synchronization settings. Download the Windows
Mobile Device Center from http://www.microsoft.com/windowsmobile/en-us/downloads/
microsoft/device-center-download.mspx and follow Microsoft instructions for installing and
using that software instead of this procedure.

1. Download Microsoft ActiveSync:

a) In a Web browser, open the Windows Phone page at http://www.microsoft.com/
windowsmobile/en-us/help/synchronize/device-synch.mspx.

b) Follow the instructions to select and download the sync software for the system's
operating system. Windows XP requires ActiveSync version 4.5.

c) In the Windows Phone downloads page, click the ActiveSync button.
d) In the ActiveSync page, download the ActiveSync install file and save it to your local

system.

2. Run the downloaded install file.
For example, double-click setup.msi in Windows Explorer.

3. When the installation is complete, restart the system.

4. Start ActiveSync if it does not start automatically.
For example, click Start > Programs > ActiveSync.

5. In ActiveSync, click File > Connection Settings.

6. Select Allow connections to one of the following, then select DMA.

7. For the option, This computer is connected to, select Work Network.

Developing the Mobile Workflow Package
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8. Click OK.

Configuring the Windows Mobile Emulator
Follow these steps to configure the Windows Mobile emulator for the Mobile Workflow
package deployment.

Prerequisites

• Complete Installing Microsoft Synchronization Software on page 30.
• Install Windows Mobile Professional emulator images on which to test and run the sample

application. Emulator images are available individually, and some are installed with
Visual Studio and Windows Mobile SDK. For example, the emulator used for this tutorial
is included in the Windows Mobile 6.5.3 Developer Tool Kit, available for download in the
Microsoft Download Center (http://www.microsoft.com/download)

• Install the Microsoft Device Emulator, if it is not already installed (for example, as part of
Visual Studio or the Windows Mobile SDK). Go to the Microsoft Download Center at
http://www.microsoft.com/download, search for “Device Emulator”, and follow the links
to download and install the Standalone Release of the Microsoft Device Emulator.

• Download the Microsoft .NET Compact Framework Redistributable (for example,
NETCFSetupv35.msi) from http://www.microsoft.com/download/ to
your system. See Supported Hardware and Software for the most current version
information for mobile device platforms and third-party development environments.

Task
This tutorial uses examples based on one of the supported emulators. The screens and steps for
configuring other supported emulators might be different. See Supported Hardware and
Software for the most current version information for mobile device platforms and third-party
development environments.
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1. Installing the Hybrid Web Container on the Windows Mobile Emulator

Install Sybase Messaging Runtime software on your emulator.

2. Configuring Connection Settings on Windows Mobile

Configure the connection settings on the Windows Mobile emulator.

See also
• Running the Mobile Workflow Form on the Windows Mobile Emulator on page 38

Installing the Hybrid Web Container on the Windows Mobile Emulator
Install Sybase Messaging Runtime software on your emulator.

1. Start the synchronization software.
For example, on Windows XP, start Microsoft ActiveSync. On Windows Vista, Windows
7, or Windows 2008, start the Windows Mobile Device Center.

2. Start the Device Emulator Manager and select an emulator to run.
For example:
1. Double-click C:\Program Files\Microsoft Device Emulator

\1.0\dvcemumanager.exe.

2. In the Device Emulator Manager, right-click the device you want to run and choose
Connect to open the emulator. For example.

3. In the Device Emulator Manager, right-click the device again and click Cradle.

3. The synchronization software runs and connects to your device. If the Setup Wizard opens,
accept the default options for each step and click Finish.
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4. Run the downloaded Microsoft .NET Compact Framework Redistributable file to install
the .NET Compact Framework on your running emulator. Follow the setup wizard
instructions, and click Finish to close the wizard when you are done.

5. Go to UnwiredPlatform_InstallDir\UnwiredPlatform\MobileSDK
\HybridWeb\WM and copy the SybaseMobileWorkflow.cab file to a folder on
mobile device folder on your system.
For example:
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6. On the device emulator, open File Explorer and browse to the folder to which you copied
the CAB file. Click the file once to install the Sybase mobile workflow client on your
emulator.
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Configuring Connection Settings on Windows Mobile
Configure the connection settings on the Windows Mobile emulator.

Prerequisites
Complete Installing the Hybrid Web Container on the Windows Mobile Emulator on page
32.

Task

1. On the emulator, open Workflow Settings.
For example, open the Start screen and click Workflow Settings.
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2. In Workflow Settings screen, click Connection.

3. In the Connection screen, enter the connection settings.

For example:
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• Server Name – the machine and domain of the host server where the mobile application
project is deployed, or the input server IP address.

• Server Port – accept the default Unwired Server port number, 5001.
• Farm ID or Company ID – accept the default value, 0.
• User Name: the user name registered for the device in Sybase Control Center
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• Activation Code – an optional activation code for the user to enter.

4. Click Done.

Running the Mobile Workflow Form on the Windows Mobile Emulator
Run the travelrequest mobile workflow form on the Windows Mobile emulator.

1. In the emulator, open Sybase Mobile Workflows.
For example, open the Start screen and click the Sybase Mobile Workflows icon.
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2. In Sybase Workflow, click the travelrequest workflow:
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3. In the travelrequest Start Screen, click Open.
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4. In the application, enter your travel request information.
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5. Click Create.
The emulator closes the mobile workflow form and updates the TravelRequest database
table on the back end.

See also
• Configuring the Windows Mobile Emulator on page 31
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Running the MobileWorkflow Application on the Android
Emulator

Install and configure the Android Simulator software and use it to run the Mobile Workflow
application.

1. Configuring the Android Emulator

Configure an Android emulator for testing a Sybase Mobile Workflow package.

2. Configuring Connection Settings on the Android Emulator

Configure the connection settings on the Android emulator.

3. Running the Mobile Workflow Form on the Android Simulator

Run the travelrequest mobile workflow form on the Android simulator.

See also
• Running the Mobile Workflow Application on the Windows Mobile Emulator on page
29

• Running the MobileWorkflow Application on the iPhone Simulator on page 53

Configuring the Android Emulator
Configure an Android emulator for testing a Sybase Mobile Workflow package.

Note: The steps or interface may be different depending on which Android SDK version you
are using.

1. Install the Android SDK.

Go to http://developer.android.com/sdk/ to download and install the Android SDK.
Follow the instructions on the Android page, with these exceptions:
• See Supported Hardware and Software for the most current version information for

mobile device platforms and third-party development environments.
• When specifying the install location, consider choosing a path that does not contain

spaces, such as C:\Android\android-sdk. Some versions of the Android SDK
do not work correctly when installed in the default drive:\ Program Files
location.

• If the Android installer stops with a message that the required Java JDK is not found on
your system (even when the JDK is installed), try clicking Back and then Next, one or
more times, until the installer detects the JDK.

2. Click Start Programs > Android SDK Tooks > AVD Manager.
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3. Add a device:

a) In the Android AVD Manager, click New.
b) In the Create new Android Virtual Device window, enter a name.
c) For the target, select a supported Android version.
d) Set any other available options you want, then click Create AVD.
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4. Select the new virtual device and click Start.

5. In Launch Options, optionally modify the default display scaling, then click Launch.
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6. When the Android screen finishes loading, install the Sybase container files to the
emulator:

a) Open a command prompt.
b) In the command prompt, run the Android_InstallDir\android-sdk

\platform-tools\adb.exe commmand to install the
SybaseDataProvider.apk package file.

The apk files are located in UnwiredPlatform_InstallDir\MobileSDK
\HybridWeb\Android

For example:
C:\Android\android-sdk\platform-tools\adb install ^
C:\Sybase\UnwiredPlatform\MobileSDK\HybridWeb\Android
\SybaseDataProvider.apk

c) Run the same command to install Workflow.apk.
For example:
C:\Android\android-sdk\platform-tools\adb install ^
C:\Sybase\UnwiredPlatform\MobileSDK\HybridWeb\Android
\Workflow.apk

Configuring Connection Settings on the Android Emulator
Configure the connection settings on the Android emulator.

1. On the emulator home page, click Menu.

2. Click the launcher icon.
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3.

In the launcher, find and click the Sybase Mobile Workflow icon.
For example:
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4. In the Sybase Mobile Workflow screen, enter the Unwired Server password and click
OK.

5. Click Menu. In the menu, click Settings.
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6. In Sybase Settings, enter the connection settings for your application.
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7. Click Menu. In the menu, click Save to save your settings. Then click Restart Engine.
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Running the Mobile Workflow Form on the Android Simulator
Run the travelrequest mobile workflow form on the Android simulator.

1. Start your emulator instance if it is not already running:

a) Click Start > Programs > Android SDK Tools > SDK Manager.
b) Select the new virtual device and click Start.
c) In Launch Options, optionally modify the default display scaling, then click

Launch.

2. In the emulator, click Menu.

3. In the launcher, click the Sybase Mobile Workflow icon.

4. In the Sybase Mobile Workflow, enter the Unwired Server password and click OK.

5. Click Menu. In the menu, click Workflows.
Sybase Workflows lists the travelrequest workflow:

6. Click travelrequest to open the workflow start screen.
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7. Click Menu again, and choose Open TravelRequest_create.

8. Enter your travel request information in the workflow form.

9. Click Menu and choose Create.
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The mobile workflow form closes and the TravelRequest database table on the server is
updated.

Running the MobileWorkflow Application on the iPhone
Simulator

Build a sample Mobile Workflow container in the XCode IDE, and run the travelrequest
Mobile Workflow application on an iPhone simulator.

1. Building the Mobile Workflow Container Using the Provided iOS Source Code

The mobile workflow container referenced is a sample container. You can use the provided
source code in Xcode to build your own customized user interface and configure other
resources.

2. Configuring iPhone Connection Settings
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Configure settings for the Mobile Workflow application.

3. Running the Mobile Workflow Form on the iPhone Simulator

Run the travelrequest mobile workflow form on the iPhone simulator.

See also
• Running the MobileWorkflow Application on the Android Emulator on page 43

• Running the MobileWorkflow Application on the BlackBerry Simulator on page 57

Building the Mobile Workflow Container Using the Provided iOS
Source Code

The mobile workflow container referenced is a sample container. You can use the provided
source code in Xcode to build your own customized user interface and configure other
resources.

Prerequisites

• Register the device in Sybase Control Center.
• Have access to a Mac with a supported version of Xcode and the iOS SDK.

See Supported Hardware and Software for the most current version information for mobile
device platforms and third-party development environments.

Task

1. On your Mac, connect to the Microsoft Windows machine where Sybase Unwired
Platform is installed:

a) In the Apple menu, click Go > Connect to Server.
b) Enter the name or IP address of the machine.

For example, smb://<machine DNS name or smb://IP Address.

2. Copy the MobileWorkflow<version>.tar archive from
UnwiredPlatform_InstallDir\UnwiredPlatform\MobileSDK
\HybridWeb\iOS\ to a location on your Mac.

In the archive file name, <version> is the current Unwired Platform version number. For
example, MobileWorkflow-2.1.2.tar.

3. Unpack MobileWorkflow<version>.tar.
The extraction creates a Workflow directory.

4. In the Workflow directory, double-click WorkFlow.xcodeproj to open it in the Xcode
IDE.

5. If necessary, select Project > Edit Active Target > ProjectName > General to add these
from the SDK to the project:

• Security.framework
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• AddressBook.framework

• QuartzCore.framework

• CoreFoundation.framework

• libicucore.A.dylib

• libz.1.2.5.dylib

• libstdc++.dylib

6. In Xcode, select Build > Build to build the project.

Configuring iPhone Connection Settings
Configure settings for the Mobile Workflow application.

1. When the iPhone simulator runs, the TravelRequest workflow application opens. Close
the Assigned Workflows screen.

2. In the iPhone simulator Settings window, click WorkFlows.

3. Enter these settings for the SUP Mobile Workflow application:

• Server Name – the machine that hosts the server where the mobile application project
is deployed.

• Server Port – Unwired Server port number. The default is 5001.
• Company ID – the company ID you entered when you registered the device in Sybase

Control Center, in this case, 0 (zero).
• User Name – the user you registered in Sybase Control Center.
• Activation Code – the optional user activation code.

Running the Mobile Workflow Form on the iPhone Simulator
Run the travelrequest mobile workflow form on the iPhone simulator.

1. Click Workflows.

2. In Workflows, click travelrequest.
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3. In the introduction page, click Open TravelRequest.

4. Fill out the information for the travel request, and click Create.

Developing the Mobile Workflow Package

56 Sybase Unwired Platform



The simulator closes the mobile workflow form. The TravelRequest database table is
updated on the backend.

Running the MobileWorkflow Application on the BlackBerry
Simulator

Install and configure the BlackBerry simulator, and use it to run the Mobile Workflow
application.

1. Configuring the BlackBerry Simulator
Follow these steps to configure a BlackBerry simulator for the Mobile Workflow package
deployment.

2. Running the Mobile Workflow Form on the BlackBerry Simulator
Run the travelrequest mobile workflow form on the BlackBerry simulator.

See also
• Running the MobileWorkflow Application on the iPhone Simulator on page 53
• Verifying the Data on the Backend Database on page 65

Developing the Mobile Workflow Package

Tutorial: Mobile Workflow Package Development 57



Configuring the BlackBerry Simulator
Follow these steps to configure a BlackBerry simulator for the Mobile Workflow package
deployment.

This tutorial was developed using one of the supported BlackBerry simulators. If you use a
different version, the interface might differ in some details. See Supported Hardware and
Software for the most current version information for mobile device platforms and third-party
development environments.

1. Downloading the BlackBerry JDE

To generate and distribute BlackBerry device applications, download BlackBerry JDE and
its prerequisites from the BlackBerry Web site.

2. Configuring the Mobile Workflow in the BlackBerry Simulator

Start the BlackBerry simulator and configure it to connect to the Workflow application.

See also
• Running the Mobile Workflow Form on the BlackBerry Simulator on page 63

Downloading the BlackBerry JDE
To generate and distribute BlackBerry device applications, download BlackBerry JDE and its
prerequisites from the BlackBerry Web site.

Prerequisites
You must have a BlackBerry developer account to download the BlackBerry JDE. You may be
required to register if you do not already have an account. Before you download the JDE,
ensure the 32-bit JDK has already been installed, even for 64-bit operating systems;
otherwise, MDS will not start.

Task
Go to the BlackBerry Web site at http://us.blackberry.com/developers/javaappdev/
javadevenv.jsp to download and install the BlackBerry JDE.
The MDS-CS simulator is installed with the BlackBerry JDE.

Configuring the Mobile Workflow in the BlackBerry Simulator
Start the BlackBerry simulator and configure it to connect to the Workflow application.

1. Start the Mobile Data System Connection Service (MDS-CS): click Start >  Programs >
Research In Motion > BlackBerry JDE version > MDS-CS.
MCS-CS runs in a Command window and waits for a BlackBerry device to send data.

2. Start the BlackBerry simulator.
For example, click Start > Programs > Research In Motion > BlackBerry JDE version
> Device Simulator.
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3. Click through any introductory screens:

• In the end-user license agreement, scroll to the end and click OK to accept it.
• In the Setup screen, click Escape and then Exit.
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4. In your Windows file system, copy the Sybase Workflow client files to your BlackBerry
simulator.
For example, copy C:\Sybase\UnwiredPlatform\MobileSDK\HybridWeb
\BB\*.* to C:\Program Files\Research In Motion\BlackBerry JDE
6.0.0\simulator.

5. Restart the simulator.

6. In the BlackBerry simulator, configure connection settings for the Mobile Workflow
application:

a) In the main window, click All to access the applications screen, then scroll until you see
the Workflow application.

b) Double-click the Workflow application to open its settings.
c) Enter these connection settings:

Developing the Mobile Workflow Package

Tutorial: Mobile Workflow Package Development 61



• Server Name: the server name registered for the device in Sybase Control Center
• Server Port: 5001
• Farm ID: 0
• User Name: the user name registered for the device in Sybase Control Center
• Activation Code: the activation code if registered for the device in Sybase Control

Center
d) Click the similator Menu control. In the menu, click Save. Press the simulator Return

control, and save the configuration when prompted.
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7. Click the similator Menu control. In the menu, click Save. Press the simulator Return
control, and save the configuration when prompted.

Running the Mobile Workflow Form on the BlackBerry Simulator
Run the travelrequest mobile workflow form on the BlackBerry simulator.

Note: This tutorial was developed using a supported version of the BlackBerry simulator. If
you use a different version, the interface might differ in some details.

1. Start your BlackBerry simulator instance if it is not already running:

2. In the emulator, click All.

3.

Open the  Sybase Mobile Workflow.

4. Start travelrequest and create a new record.
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5. Enter your travel request information in the workflow form, and click Submit.
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The mobile workflow form closes and the TravelRequest database table on the server is
updated.

See also
• Configuring the BlackBerry Simulator on page 58

Verifying the Data on the Backend Database
After submitting a travel request in an emulator, verify that the information is updated in the
database.

1. In Unwired WorkSpace, expand the sample database in Enterprise Explorer.

2. In the Tables folder, right-click the TravelRequest table and select Edit Data.
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3. In the Table Data Filter dialog, accept the default settings and click OK.
The TravelRequest table opens, displaying the new row.

See also
• Running the MobileWorkflow Application on the BlackBerry Simulator on page 57
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Learn More About Sybase Unwired Platform

Once you have finished, try some of the other samples or tutorials, or refer to other
development documents in the Sybase Unwired Platform documentation set.

Check the Sybase Product Documentation Web site regularly for updates: http://
sybooks.sybase.com/nav/summary.do?prod=1289, then navigate to the most current version.

Tutorials
Try out some of the other getting started tutorials available on Product Documentation to get a
broad view of the development tools available to you.

Example Projects
Example projects are available for download, if you want the finished tutorial without going
through the steps. Download example projects from: http://www.sdn.sap.com/irj/sdn/mobile?
rid=/webcontent/uuid/40ea4956-b95c-2e10-11b3-e68c73b2280e.

Samples
Sample applications are fully developed, working applications that demonstrate the features
and capabilities of Sybase Unwired Platform.

Check the SAP® Development Network (SDN) Web site regularly for new and updated
samples: https://cw.sdn.sap.com/cw/groups/sup-apps.

Online Help
See the online help that is installed with the product, or the Product Documentation Web site.

Developer Guides
Learn best practices for architecting and building device applications:

• Mobile Data Models: Using Data Orchestration Engine – provides information about
using Sybase Unwired Platform features to create DOE-based applications.

• Mobile Data Models: Using Mobile Business Objects – provides information about how to
develop mobile business objects (MBOs) to fully maximize their potential.

Learn about using the API to create device applications:

• Developer Guide: Android Object API Applications
• Developer Guide: BlackBerry Object API Applications
• Developer Guide: iOS Object API Applications
• Developer Guide: Windows and Windows Mobile Object API Applications
• Developer Guide: Mobile Workflow Packages

Customize and automate:
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• Developer Guide: Unwired Server Management API  – customize and automate system
administration features.

Javadoc and HeaderDoc are also available in the installation directory.

Learn More About Sybase Unwired Platform

68 Sybase Unwired Platform



Index
A

ActiveSync, installing and configuring 30
Android 43
Android emulator

connection settings 46
applications

generating code for device 25

B

BlackBerry JDE, download 58
BlackBerry MDS Simulator, download 58
BlackBerry simulator

connection settings 58
BlackBerry Simulator 58

C

create operation 19
creating a new key 19

D

deploying
mobile business objects 14

device applications
generating code for 25

download 58

E

emulator connection settings, configuring 35, 46
emulator, registering 17
example projects 1

F

Flow Design page 19

G

generating
code for a device application 25

H

HtmlView control 19

K

key
creating a new 19
defining default value for 19

M

Microsoft ActiveSync, installing and configuring
30

mobile application projects
deploying 14

mobile applications
generating code for 25

mobile business object
operation 19
TravelRequest 19

mobile business object tutorial 1
mobile business objects

deploying 14
Mobile Workflow Container

building using source code 54
mobile workflow form

adding an operation 19
creating 19
designing the screen for 19

mobile workflow form, running on emulator 38, 51,
63

Mobile Workflow package tutorial 1

O

Object API tutorials 1

R

registering the emulator in SCC 17

Index

Tutorial: Mobile Workflow Package Development 69



S
samples, how to download 67
Screen Design page 19
Start

icon 19
screen 19

SUPMessaging_Pro.cab 32
Sybase Control Center

register device 17
registering the emulator 17
status 17

Sybase Control Center, connecting to 6
Sybase Mobile SDK

installing 5
Sybase Unwired Platform

documentation resources 67
getting started 5
installing 5

Sybase Unwired WorkSpace
basics 7
how to access online help 7
starting 6

synchronization software 30

T
task flow 3

TravelRequest database table 38, 51, 63
troubleshooting information 7
tutorial

configuring the Android emulator 43
configuring the BlackBerry simulator 58
running the Android simulator 51
running the BlackBerry simulator 63

tutorials 1
tutorials, how to download 67

U

Unwired Platform Runtime
installing 5

Unwired Platform services 6
Unwired Server

deploying MBOs to 14
Unwired WorkSpace basics 7

W

Windows emulator
connection settings 35

Index

70 Sybase Unwired Platform


	Tutorial: Mobile Workflow Package Development
	Contents
	Sybase Unwired Platform Tutorials
	Task Flow
	Getting Started with Unwired Platform
	Installing Sybase Unwired Platform
	Starting Sybase Unwired Platform Services
	Starting Sybase Unwired WorkSpace
	Connecting to Sybase Control Center
	Learning Unwired WorkSpace Basics

	Developing a Database Mobile Business Object
	Creating the Mobile Workflow 101 Mobile Application Project
	Creating the TravelRequest Database Table
	Creating the TravelRequest Mobile Business Object
	Deploying the WorkFlow101 Mobile Application Project

	Developing the Mobile Workflow Package
	Registering Application Connections in Sybase Control Center
	Creating a Mobile Workflow Form
	Generating Code for a Mobile Workflow Package
	Running the Mobile Workflow Application on the Windows Mobile Emulator
	Installing Microsoft Synchronization Software
	Configuring the Windows Mobile Emulator
	Installing the Hybrid Web Container on the Windows Mobile Emulator
	Configuring Connection Settings on Windows Mobile

	Running the Mobile Workflow Form on the Windows Mobile Emulator

	Running the MobileWorkflow Application on the Android Emulator
	Configuring the Android Emulator
	Configuring Connection Settings on the Android Emulator
	Running the Mobile Workflow Form on the Android Simulator

	Running the MobileWorkflow Application on the iPhone Simulator
	Building the Mobile Workflow Container Using the Provided iOS Source Code
	Configuring iPhone Connection Settings
	Running the Mobile Workflow Form on the iPhone Simulator

	Running the MobileWorkflow Application on the BlackBerry Simulator
	Configuring the BlackBerry Simulator
	Downloading the BlackBerry JDE
	Configuring the Mobile Workflow in the BlackBerry Simulator

	Running the Mobile Workflow Form on the BlackBerry Simulator

	Verifying the Data on the Backend Database

	Learn More About Sybase Unwired Platform
	Index


