Tutorial: Mobile Workflow Package Development

Sybase Unwired Platform 2.1
Contents

Sybase Unwired Platform Tutorials ........................................1
Task Flow ................................................................................ 3
Getting Started ....................................................................... 5

Installing Sybase Unwired Platform ..................................5
Installing Microsoft Synchronization Software .................6
Starting Unwired Platform Services ..................................7
Starting Sybase Unwired WorkSpace ..................................7
Connecting to Sybase Control Center ...............................8
Registering the Device in Sybase Control Center ............8
Learning the Basics ................................................................10
Connecting to the Sample Database .................................12
Creating the Mobile Workflow 101 Mobile Application

Project ................................................................................13

Developing a Database Mobile Business Object ..........15

Creating the TravelRequest Database Table ............15
Creating the TravelRequest Mobile Business Object ...17
Deploying the Workflow101 Mobile Application

Project .............................................................................17

Switching Between Developer Profiles ......................19

Developing the Mobile Workflow Package ..................21

Creating a Mobile Workflow Form .................................21
Installing the Mobile Workflow Package ......................27

Configuring the Android Emulator ..............................27
Configuring the Windows Mobile Emulator ...........31
Building the Mobile Workflow Container Using

the Provided Source Code ..............................................35
Generating Code for a Mobile Workflow

Package ............................................................................36

Viewing and Running the Mobile Workflow Package ....40

Running the Mobile Workflow Form on the

Android Simulator ............................................................41
Contents

Viewing and Running the Mobile Workflow Form on the Windows Mobile Emulator .................44
Viewing and Running the Mobile Workflow Form on the iPhone Simulator ..........................46
Verifying the Data on the Backend Database .................................................................48
Learn More about Sybase Unwired Platform ............................................................51
Index ...............................................................................................................................53
The Sybase® Unwired Platform tutorials demonstrate how to develop, deploy, and test mobile business objects, device applications, and mobile workflow packages. You can also use the tutorials to demonstrate system functionality and train users.

- Learn mobile business object (MBO) basics, and create a mobile device application:
  - Tutorial: Mobile Business Object Development
- Create native mobile device applications:
  - Tutorial: BlackBerry Application Development
  - Tutorial: iOS Application Development
  - Tutorial: Windows Mobile Application Development
- Create a mobile workflow package:
  - Tutorial: Mobile Workflow Package Development

The tutorials demonstrate a cross section of basic functionality, which includes creating MBOs, and using various Sybase Unwired WorkSpace development tools, independent development environments, and device types. Tutorial projects are available if you want the finished tutorial without going through the steps.
The Sybase Mobile Workflow tutorial explains how to develop, deploy, and run a mobile workflow package on an emulator or a simulator.

### Task Flow

#### Getting Started
- Install Sybase Unwired Platform, create a connection profile, start the server and Unwired Workspace, and create a Mobile Workflow Application project.
  - Installing Sybase Unwired Platform on page 5
  - Installing Microsoft Synchronization Software on page 6
  - Starting Unwired Platform Services on page 7
  - Starting Sybase Unwired Workspace on page 7
  - Connecting to Sybase Control Center on page 8
  - Learning the Basics on page 10 (Optional)
  - Connecting to the Sample Database on page 12
  - Creating the Mobile Workflow 101 Mobile Application Project on page 13

**Note:** These procedures are prerequisites for all the other tutorials. Perform them only once.

#### Developing a Database Mobile Business Object
- Create and deploy a database mobile object.
  - Creating the TravelRequest Database Table on page 15
  - Creating the TravelRequest Mobile Business Object on page 17
  - Deploying the Workflow 101 Mobile Application Project on page 17
<table>
<thead>
<tr>
<th>Task</th>
<th>Goals</th>
<th>Procedures required to achieve the goals</th>
</tr>
</thead>
</table>
| Developing the Mobile Workflow Package | Create a mobile workflow form, generate the files, register the device in Sybase Control Center (SCC), assign the mobile workflow package to a user, and view the mobile workflow form on the emulator. | • *Creating a Mobile Workflow Form* on page 21  
  • *Installing the Mobile Workflow Package* on page 27  
  • *Viewing and Running the Mobile Workflow Package* on page 40  
  • *Verifying the Data on the Backend Database* on page 48 |
Getting Started

Install and learn about Sybase Unwired Platform and its components.

Some of the tasks in this section are also required for other tutorials. You can omit any tasks that you already performed.

1. **Installing Sybase Unwired Platform**
   Install Sybase Unwired Platform.

2. **Installing Microsoft Synchronization Software**
   Install and configure Microsoft synchronization software so you can deploy and run a mobile application on a Windows Mobile emulator.

3. **Starting Unwired Platform Services**
   Start Unwired Server and the sample database.

4. **Starting Sybase Unwired WorkSpace**
   Start Unwired WorkSpace.

5. **Connecting to Sybase Control Center**
   Open the Web-based Sybase Control Center administration console to manage Unwired Server and its components.

6. **Registering the Device in Sybase Control Center**
   Registering a connection makes an application available on a specific device.

7. **Learning the Basics**
   Learn about Sybase Unwired WorkSpace and how to access help (optional).

8. **Connecting to the Sample Database**
   Use the default database connection profile to test and connect to the sample database.

9. **Creating the Mobile Workflow 101 Mobile Application Project**
   A mobile application project is the container for the mobile business objects that form the business logic of mobile applications.

---

**Installing Sybase Unwired Platform**

Install Sybase Unwired Platform. Install these Sybase Unwired Platform components:

- Data Tier
- Unwired Server
- Unwired WorkSpace
If Unwired Platform is already installed and any of these components is missing:

1. Start the Sybase Unwired Platform installer.
2. Follow the instructions in the installation wizard. When prompted, select Custom Install.
3. Select the required components, and complete the installation.


---

**Installing Microsoft Synchronization Software**

Install and configure Microsoft synchronization software so you can deploy and run a mobile application on a Windows Mobile emulator.

**Note:** This tutorial shows how to install Microsoft ActiveSync for Windows XP. If you are using Windows Vista, Windows 7, or Windows 2008, install Virtual PC 2007 SP1 and Windows Mobile Device Center to manage synchronization settings. Download the Windows Mobile Device Center from http://www.microsoft.com/windowsmobile/en-us/downloads/microsoft/device-center-download.mspx and follow Microsoft instructions for installing and using that software instead of this procedure.

1. Download Microsoft ActiveSync:
   b) In the Windows Phone page, follow the instructions to select and download the sync software for your computer's operating system. Windows XP requires ActiveSync version 4.5.
   c) In the Windows Phone downloads page, click the ActiveSync button.
   d) In the ActivSync page, download the ActiveSync install file and save it to your local system.

2. Run the downloaded install file.
   For example, double-click setup.msi in Windows Explorer.

3. When the installation is complete, restart your machine.

4. Start ActiveSync if it does not start automatically.
   For example, click Start > Programs > ActiveSync.

5. In ActiveSync, click File > Connection Settings.

6. Select Allow connections to one of the following, then select DMA.

7. For the option, This computer is connected to, select Work Network.
8. Click OK.

Starting Unwired Platform Services

Start Unwired Server and the sample database.

Click Start > Programs > Sybase > Unwired Platform > Start Unwired Platform Services.

The Unwired Server services enable you to access the Unwired Platform components and resources.

Starting Sybase Unwired WorkSpace

Start Unwired WorkSpace.

Select Start > Programs > Sybase > Unwired Platform > Unwired WorkSpace.

The Sybase Unwired Workspace opens in the Mobile Development perspective. The Welcome page displays links to product information, and to the product.

Next

To read more about Sybase Unwired WorkSpace concepts and tasks, select Help > Help Contents from the main menu.
Connecting to Sybase Control Center

Open the Web-based Sybase Control Center administration console to manage Unwired Server and its components.

From Sybase Control Center, you can:

- View servers and their status
- Start and stop a server
- View server logs
- Deploy a mobile application package
- Register devices
- Set role mappings

For information on configuring, managing, and monitoring Unwired Server, select Help > Online Documentation.

1. Select Start > Programs > Sybase > Sybase Control Center.

   **Note:** If the Sybase Control Center service does not open, make sure that the Sybase Unified Agent service is started. See the *Installation Guide for Runtime.*

2. In the Sybase Control Center Authentication window, log in by entering the supAdmin user name and the password that was specified during the Unwired Server installation.

   Logging in to Sybase Control Center allows you access to Unwired Platform administration features that you are authorized to use.

Registering the Device in Sybase Control Center

Registering a connection makes an application available on a specific device.

Register a connection for each device or emulator that you want to use.

1. Log in to Sybase Control Center using the supAdmin user name and the current password.
2. In Sybase Control Center, select View > Select > Unwired Server Cluster Management View.
3. Click Applications in the left pane. In the right pane, open the Application Connections tab.
4. Register an application connection for each device that you will test in the tutorial:
   a) Click Register.
   b) In the Register Application Connection window, specify the following options:
• User name – enter the name of the user that will activate and register the Mobile Workflow application. For this tutorial, where we test several different emulators, enter a unique user name for each device.
• Template – accept the default template name.
• Server name – the machine and domain of the host server where the mobile application project is deployed.
• Port – accept the default value for the port used for messaging connections between the device and Unwired Server. If you use Relay Server, this is the Relay Server port.
• Farm ID – enter 0.
• Application ID – select HWC.
• Security configuration – accept the default value.
• Activation code length – accept the default value.
• Activation expiration (hours) – optionally, change the default value (for example, to enable the connection for longer than 72 hours).
• Specify activation Code – optionally, enter a three-character value that is sent to the user in an activation e-mail. If you enable this option, the user must enter the activation code when logging in to the application. The value can contain letters A-Z (uppercase or lowercase), numbers 0-9, or a combination of both.

The connection is added to the Application Connections table. In the example, notice that the new connection (in the second line) has no Device Type or Device ID yet. These fields are automatically loaded later, when the specified user accesses the connection. The first line in the example shows such a connection from a different device.
Learning the Basics

Learn about Sybase Unwired WorkSpace and how to access help (optional).

Prerequisites
Start Unwired WorkSpace.

Task

1. In the Welcome page, click any of the links to explore the Unwired WorkSpace environment.

2. To enter the Sybase Unwired WorkSpace development environment, click **Start Development** or close the Welcome tab.

The default Mobile Development perspective provides ready access to most of the tools you need to create, update, and manage mobile business objects (MBOs). This table describes the main windows and views of the Mobile Development perspective. Note that not all the views are open initially; some views become available only after you begin developing your MBOs:
<table>
<thead>
<tr>
<th>View or Window</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>WorkSpace Navigator</td>
<td>A view of mobile application projects. Each project folder includes resources and data source references to which the MBOs are bound, personalization keys, and so on. Use this view to review and modify MBO-related properties.</td>
</tr>
<tr>
<td>Enterprise Explorer</td>
<td>A view of enterprise back-end resources, such as database servers, SAP® servers, and Sybase Unwired Server.</td>
</tr>
</tbody>
</table>
| Mobile Application Diagram | A graphical editor for designing mobile business objects. A Mobile Application Diagram is associated with each project. Use the Mobile Application Diagram to create MBOs (including attributes and operations), then define relationships with other MBOs. You can:  
  • Create MBOs in the Mobile Application Diagram using Palette icons and menu selections. Either bind to a data source now or defer binding. For example, using a top-down approach, you might model your MBOs before creating the data sources to which they bind.  
  • Drag items from Enterprise Explorer and drop them onto the Mobile Application Diagram to create the MBO – quickly creates the operations and attributes automatically based on the data source of the items. This is sometimes called a bottom-up approach. |
| Palette             | A view from which you can drag controls onto an open Mobile Application Diagram and define their attributes, operations, and relationships to your application.                                               |
| Properties          | A view that shows the properties of the object currently selected in the Mobile Application Diagram, and lets you edit them. You cannot create an MBO from the Properties view, but generally, most development and configuration is performed here. |
| Outline             | An outline of the file that is currently open in an editor, listing structural elements. The contents are editor-specific.                                                                                     |
| Problem             | A view that displays problems, errors, or warnings.                                                                                                                                                        |

3. To access the online help, click **Help > Help Contents** in the main menu bar.

4. Expand any of the documents that appear in the left pane. Some documents are for Sybase Unwired Platform, while others are for the Eclipse development environment.
Connecting to the Sample Database

Use the default database connection profile to test and connect to the sample database.

Installing Sybase Unwired Platform also installs a sample database, sampledb, which you can use to create and test mobile business objects (MBOs). A default connection profile (My Sample Database), included with the installation, is configured to access the sampledb database.

Sybase Unwired Platform Services can start the database automatically, depending on your license type: Sybase Unwired Platform Development Edition normally starts the database automatically. However, if you are running Deployment Edition, you must start the database manually.

Sybase Unwired Platform development edition servers normally start the database automatically. However, the Personal Edition requires you to start the database manually.

In this task you connect to the sample database using the default connection profile, after starting the database, if necessary. This task is required for all tutorials, but you need to perform it only once.

1. In the Enterprise Explorer, expand **Database Connections**.
2. Right-click **My Sample Database** and select **Ping**.
   - If the ping fails, go the next step to correct the problem.
   - If the ping succeeds, click **OK** and go to Step 4.

   Ping confirms whether the sample profile can connect to the sample database.

3. If the ping fails, verify that Unwired Platform Services, including the Sybase Unwired sample database, are running:
   a) On your Windows desktop, open the Services window.
      For example (using the Windows XP Classic View), click **Start > Settings > Control Panel**. In the Control Panel, double-click **Administrative Tools**, then double-click **Services**.
      Your installation options (for example, license type, whether or not you installed a cluster, and so on) determine which Sybase services are running.
b) In the Services window, check the Status column of the Sybase Unwired SampleDB service. If the status is not Started, right-click the service and select **Start**.

c) Go back to Step 2.

4. Right-click **My Sample Database** and select **Connect**.

   In Enterprise Explorer, the Database Connections folder contains the **sampledb** database.

---

**Creating the Mobile Workflow 101 Mobile Application Project**

A mobile application project is the container for the mobile business objects that form the business logic of mobile applications.

Create a mobile application project before creating its mobile business objects.

1. In the Unwired WorkSpace menu, click **File > New > Mobile Application Project**.
2. Enter **MobileWorkflow101** as the name.
3. Click **Finish**.
Developing a Database Mobile Business Object

Create a database mobile business object and deploy it to Unwired Server.

Develop the database mobile business object by:

1. **Creating the TravelRequest Database Table**
   Create the database table to be used by the Travel Request mobile business object.

2. **Creating the TravelRequest Mobile Business Object**
   Use the TravelRequest database table to create a mobile business object.

3. **Deploying the WorkFlow101 Mobile Application Project**
   Deploy the project that contains the TravelRequest mobile business object to the server.

---

**Creating the TravelRequest Database Table**

Create the database table to be used by the Travel Request mobile business object.

In this task, create a SQL file that you can use to create the database table for the mobile business object.

1. From the main menu, select **File > New > Other**.
2. Select **SQL Development > SQL File**, and click **Next**.
3. Enter or select the values shown, then click **Finish**:

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Parent folder</td>
<td>Select the MobileWorkflow101 project.</td>
</tr>
<tr>
<td>File name</td>
<td>Enter TravelRequest.</td>
</tr>
<tr>
<td>Database server type</td>
<td>Select SybaseASA_12.x.</td>
</tr>
<tr>
<td>Connection profile name</td>
<td>Select My Sample Database.</td>
</tr>
<tr>
<td>Database name</td>
<td>Select sampledb.</td>
</tr>
</tbody>
</table>
4. In the `TravelRequest.sql` editor, copy and paste this code:

```sql
CREATE TABLE TravelRequest (  
  trvl_Id INTEGER NOT NULL DEFAULT autoincrement,  
  trvl_Date DATE NULL,  
  trvl_Loc VARCHAR(20) NULL,  
  est_Cost FLOAT NULL,  
  purpose VARCHAR(200) NULL,  
  trvl_Status VARCHAR(20) NULL,  
  st_Cmmnt VARCHAR(200) NULL  
, PRIMARY KEY CLUSTERED (trvl_Id)
) 
```
5. Save TravelRequest.sql and close the editor.
   Unwired Workspace adds TravelRequest.sql to the MobileWorkFlow101 project.

6. In the WorkSpace Navigator, expand MobileWorkflow101. Right-click TravelRequest.sql and select Execute SQL Files.
   Unwired Workspace creates a table called TravelRequest in the sampledb database.

7. In the Enterprise Explorer, expand sampledb, expand the Tables folder, and verify that the new TravelRequest table is added.
   If the table is not visible, right-click the Tables folder and select Refresh.

---

**Creating the TravelRequest Mobile Business Object**

Use the TravelRequest database table to create a mobile business object.

**Prerequisites**
Complete Creating the TravelRequest Database Table on page 15.

**Task**

1. In the Enterprise Explorer, expand the sampledb database, then expand the Tables folder.
2. Drag the TravelRequest table from the Enterprise Explorer onto the MobileWorkflow101 Mobile Application Diagram.
3. In the Quick Create wizard, accept the default settings and click OK.
   The Mobile Application Diagram displays the table.
4. Save the diagram.

---

**Deploying the WorkFlow101 Mobile Application Project**

Deploy the project that contains the TravelRequest mobile business object to the server.

1. Right-click in the MobileWorkflow101 Mobile Application Diagram, and select Deploy Project.
2. In the first page of the Deploy Mobile Application Project wizard, select Message-based, accept the defaults for the other options, then click Next.
3. In the Contents page, select the TravelRequest mobile business object, and click Next.
4. In the Package Jars window, click Next.

Note: The Package Jars window appears by default in the advanced developer profile, as described in Switching Between Developer Profiles on page 19.

5. In the Target Server page, select My Unwired Server in the list of available servers. If the Next button is not enabled, click Connect to connect to the server. Then, click Next.
6. In the Server Connection Mapping page, select the My Sample Database Connection profile and the sampledb Server connection.
7. Click **Finish**.

8. When the Executing Deployment window closes, click **OK** to dismiss the Deployment Status window.

9. In Enterprise Explorer, expand **Unwired Servers** > **My Unwired Server** > **Domains** > **default** > **Packages**. The server package *mobileworkflow101:1.0* into which you deployed the MBOs appears in the Packages folder. Under the package, the TravelRequest mobile business object appears in the Mobile Business Objects folder.

**Switching Between Developer Profiles**

Switch between basic and advanced developer profiles in the Mobile Application Diagram.

Unwired WorkSpace provides two developer profiles, basic and advanced. Basic is the default profile. The advanced developer profile provides additional features.

Switch to the advanced profile if you need an Unwired WorkSpace feature that is not in the basic profile, such as a wizard, property, or WorkSpace Navigator item. For example, with the advanced developer profile, the Deploy Mobile Application Project wizard displays the Server Connection Mapping page, where you can specify backend data sources other than those supplied by Sybase Unwired Platform.

If you want to use the advanced profile by default, modify your developer profile preference settings.

- To switch between developer profiles, right-click in the Mobile Application Diagram, select **Switch Developer Profile**, then select either **Basic** or **Advanced**.
- To view or modify your preference settings for the developer profile, click **Window > Preferences > Sybase, Inc. > Mobile Development > Developer Profile**.
Developing a Database Mobile Business Object
Developing the Mobile Workflow Package

Develop and deploy a mobile workflow package.

1. **Creating a Mobile Workflow Form**
   Create a mobile workflow form using the TravelRequest mobile business object.

2. **Installing the Mobile Workflow Package**
   Configure the emulator or simulator, install the Mobile Workflow package, and generate the Mobile Workflow package files.

3. **Viewing and Running the Mobile Workflow Package**
   After generating the Mobile Workflow package files and deploying it to Unwired Server, you can view and run the Mobile Workflow application.

4. **Verifying the Data on the Backend Database**
   After submitting a travel request in an emulator, verify that the information is updated in the database.

**Creating a Mobile Workflow Form**

Create a mobile workflow form using the TravelRequest mobile business object.

**Prerequisites**
Complete *Deploying the WorkFlow101 Mobile Application Project* on page 17.

**Task**

1. In the Sybase Unwired WorkSpace menu, click **File > New > Mobile Workflow Forms Editor**.
2. Select the MobileWorkflow101 folder and enter `travelrequest.xbw` as the file name.
3. Click **Next**.
4. Select **Can be started, on demand, from the client**, and click **Finish**.
5. In the Mobile Workflow Forms editor, click the **Flow Design** tab.
   The new flow diagram contains a Client-initiated screen, connected to a Start Screen.
6. In Workspace Navigator, expand **MobileWorkflow101 > Mobile Business Objects > TravelRequest > Operations**.

7. Drag the **create** operation onto the flow diagram.
   The TravelRequest_create screen is added.
8. Add a **GoTo** connection from the Start Screen to the TravelRequest_create screen:
   a) In the Palette, click **GoTo**.
   b) Click the **Start Screen**, and while holding the mouse down, drag the connection to the **TravelRequest_create** screen.

   A line with an arrow connects the two screens.
9. Double-click the **Start** screen to open its Screen Design page.

10. In the Palette, select the **HtmlView** control and click the Start screen. The HtmlView control is added to the Start screen design.
11. Click **Flow Design**.

12. In the Flow Design, select the Client-initiated screen.

   The Properties view shows all of the keys that were automatically created for each parameter in the `create` method of the TravelRequest mobile business object. If the Properties view does not open, right-click the Client-initiated screen and select **Show Properties View**.

13. In the Properties view, create a new key for the Start screen:
   a) In the Properties view, in **Keys**, click **New**.
   b) Enter these values:
• Name – IntroKey
• Type – string
c) Click OK.
The new key, IntroKey, is added to the list of keys in the Properties view.

14. Define the default value for the new key:
   a) In the Mobile Workflow Forms editor, click the Screen Design tab.
   b) If the Start Screen is not selected, select Start Screen in the screen selection control above the Screen Design.
   c) In the Start Screen, select the HtmlView control to display its properties.
   d) In Properties view, click the Key control and select IntroKey.
   e) In Default value, enter the message code:

   <H2>Travel Request App</H2>This application enables vacation requests to be sent for approval<br>.
15. View the current parameter settings of the TravelRequest screen:

a) In the screen selection control above the Screen Design page, change the screen to TravelRequest_create.

b) In the menu, select the Create operation to display its properties.

c) In Properties, click Parameter Mappings.

The parameter mapping table shows the mobile business object parameters for the operation and their keys.

<table>
<thead>
<tr>
<th>Parameter Mapping</th>
<th>Parameter Name</th>
<th>Parameter Type</th>
<th>Mapping Type</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>frod_code</td>
<td>string</td>
<td>Key</td>
<td>TravelRequest_create_frod_code_parameter</td>
</tr>
<tr>
<td></td>
<td>est_cost</td>
<td>float</td>
<td>Key</td>
<td>TravelRequest_create_est_cost_parameter</td>
</tr>
<tr>
<td></td>
<td>purpose</td>
<td>string</td>
<td>Key</td>
<td>TravelRequest_create_purpose_parameter</td>
</tr>
<tr>
<td></td>
<td>frod_status</td>
<td>string</td>
<td>Key</td>
<td>TravelRequest_create_frod_status_parameter</td>
</tr>
<tr>
<td></td>
<td>est_comment</td>
<td>string</td>
<td>Key</td>
<td>TravelRequest_create_est_comment_parameter</td>
</tr>
</tbody>
</table>

16. Save the travelrequest workflow form.

**Installing the Mobile Workflow Package**

Configure the emulator or simulator, install the Mobile Workflow package, and generate the Mobile Workflow package files.

**See also**

- Viewing and Running the Mobile Workflow Package on page 40

**Configuring the Android Emulator**

Configure an Android emulator for testing a Sybase Mobile Workflow package.

**Note:** This tutorial was developed using one of the supported Android SDK versions. If you use a different version, the interface might differ in some details.

1. Install the Android SDK.

   Go to [http://developer.android.com/sdk/](http://developer.android.com/sdk/) to download and install the Android SDK.

    Follow the instructions on the Android page, with these exceptions:

**Notes:**
Developing the Mobile Workflow Package

- See *Supported Hardware and Software* for the most current version information for mobile device platforms and third-party development environments.
- Do not install the ADT plugin for Eclipse.
- When specifying the install location, consider choosing a path that does not contain spaces, such as `C:\Android\android-sdk`. Some versions of the Android SDK do not work correctly when installed in the default `drive:\ Program Files` location.
- If the Android installer stops with a message that the required Java JDK is not found on your system (even when the JDK is installed), try clicking **Back** and then **Next**, one or more times, until the installer detects the JDK.

2. Click **Start Programs > Android SDK Tools > SDK Manager**.

![Android SDK and AVD Manager](image)

3. Add a device:
   a) In the Android SDK and AVD Manager, click **Virtual devices**, then click **New**.
   b) In the Create new Android Virtual Device window, enter a name.
   c) For the target, select a supported Android version.
   d) Set any other available options you want, then click **Create AVD**.
4. Select the new virtual device and click **Start**.

5. In Launch Options, optionally modify the default display scaling, then click **Launch**.
6. When the Android screen finishes loading, open a command prompt and run the `adb` command to install the Sybase application package files. `SybaseDataProvider.apk` and `Workflow.apk` to the virtual device. Install the located in `<UnwiredPlatform_InstallDir>\UnwiredPlatform\ClientAPI\Workflow\Android`.

   The `adb.exe` program is located in `<Android_InstallDir>\android-sdk\platform-tools`, and the `apk` files are located in `<UnwiredPlatform_InstallDir>\ClientAPI\Workflow\Android`.

   For example:
   ```sh
   C:\Android\android-sdk\platform-tools\adb install ^
   C:\Sybase\UnwiredPlatform\ClientAPI\Workflow\Android\SybaseDataProvider.apk
   C:\Android\android-sdk\platform-tools\adb install ^
   C:\Sybase\UnwiredPlatform\ClientAPI\Workflow\Android\Workflow.apk
   ```

   The Sybase Mobile Workflow package is available in the emulator.

**See also**

- *Configuring the Windows Mobile Emulator* on page 31
- *Building the Mobile Workflow Container Using the Provided Source Code* on page 35
- *Generating Code for a Mobile Workflow Package* on page 36
**Configuring the Windows Mobile Emulator**

Follow these steps to configure the Windows Mobile emulator for the Mobile Workflow package deployment.

**Prerequisites**

- Install Windows Mobile Professional emulator images on which to test and run the sample application. This tutorial uses Windows Mobile 6.5 Professional.

**Task**

See *Supported Hardware and Software* for the most current version information for mobile device platforms and third-party development environments.

**See also**

- *Configuring the Android Emulator* on page 27
- *Building the Mobile Workflow Container Using the Provided Source Code* on page 35
- *Generating Code for a Mobile Workflow Package* on page 36

**Installing Sybase Messaging Runtime**

Install Sybase Messaging Runtime software on your emulator.

**Prerequisites**

Download the Microsoft .NET Compact Framework Redistributable (for example, NETCFSetupv35.msi) from http://www.microsoft.com/download/ to your system. See *Supported Hardware and Software* for the most current version information for mobile device platforms and third-party development environments.

**Task**

1. Start the synchronization software.
   For example, on Windows XP, start Microsoft ActiveSync. On Windows Vista, Windows 7, or Windows 2008, start the Windows Mobile Device Center.
2. Start the Device Emulator Manager and select an emulator to run.
   For example:
   1. a. Double-click C:\Program Files\Microsoft Device Emulator \1.0\dvcemumanager.exe.
   2. In the Device Emulator Manager, expand **Datastore > Windows Mobile 5.0 Pocket PC SDK**. Right-click **USA Windows Mobile 5.0 Pocket PC R2 Emulator** and select **Connect**.
3. Right-click the device again and click **Cradle**. The synchronization software runs.

3. Step through the Synchronization Setup Wizard, accepting or changing the default options. Click **Finish**.

4. Run the downloaded Microsoft .NET Compact Framework Redistributable file to install the .NET Compact Framework on your emulator. Follow the setup wizard instructions, and click Finish to close the wizard when you are done.

5. Copy the CAB file that is installed in `<UnwiredPlatform_InstallDir>\ClientAPI\Workflow\WM\` to a subfolder under your system's Mobile Device folder. For example, in Windows Explore, copy `C:\Sybase\UnwiredPlatform\ClientAPI\Workflow\WM\SybaseMobileWorkflow.cab` to this folder:

   ![Folder structure]

6. On the device emulator, use File Explorer to browse to the folder to which you copied the CAB file. Click the file once to install the Sybase mobile workflow client on your emulator.

**Configuring Connection Settings on Windows Mobile**

Configure the connection settings on the Windows Mobile emulator.

**Prerequisites**


**Task**

**Note:** This tutorial was developed using one of the supported Windows Mobile emulator versions. If you use a different version, the interface might differ in some details.

1. On the emulator, select **Start > Programs > Workflow Settings**.
2. In the Sybase Settings screen, click **Connection**.
3. In the Connection screen, enter the connection settings:
   - Server Name – the machine and domain of the host server where the mobile application project is deployed.
Developing the Mobile Workflow Package

- Server Port – accept the default Unwired Server port number.
- Farm ID or Company ID – accept the default value.
- User Name – the name of the user who will activate and register the Mobile Workflow application.

**Note:** Specify a unique user name for each device that you configure.

- Activation Code – an optional activation code for the user to enter.
Developing the Mobile Workflow Package

Pocket PC - WM 5.0

Workflow Settings: 10:52

Connection

Server Name: wmdev.acme.com
Server Port: 5001
Farm ID: 0
User Name: user1
Activation Code: 123
Registration Password: 

[ ] Enable Automatic Registration

Done  Cancel

Sybase Unwired Platform
4. Click Done.

Building the Mobile Workflow Container Using the Provided Source Code

The mobile workflow container referenced in this procedure is a sample container. You can use the provided source code in Xcode to build your own customized user interface and configure other resources.

Prerequisites

- Register the device in Sybase Control Center.
- You must have a Mac with the iOS SDK installed.
- Install the Xcode.

See Supported Hardware and Software for the most current version information for mobile device platforms and third-party development environments.

Task

1. On your Mac, connect to the Microsoft Windows machine where Sybase Unwired Platform is installed:
   a) In the Apple menu, click Go > Connect to Server.
   b) Enter the name or IP address of the machine.
      For example, smb://<machine DNS name> or smb://IP Address.
2. Copy the MobileWorkflow<version>.tar.gz archive from <UnwiredPlatform_InstallDir>\UnwiredPlatform\ClientAPI\Workflow\ios\ to a location on your Mac.
   In the archive file name, <version> is the current Unwired Platform version number. For example, MobileWorkflow-2.1.0.tar.gz.
   The extraction creates a Workflow directory.
4. In the Workflow directory, double-click WorkFlow.xcodeproj to open it in the XCode IDE.
5. If necessary, select Project > Edit Active Target > ProjectName > General to add the following frameworks from the SDK to the project:
   - Security.framework
   - AddressBook.framework
   - QuartzCore.framework
   - CoreFoundation.framework
   - libicucore.A.dylib
   - libz.1.2.3.dylib
Developing the Mobile Workflow Package

- libstdc++.dylib

6. In XCode, select **Build > Build** to build the project.

**See also**
- *Configuring the Android Emulator* on page 27
- *Configuring the Windows Mobile Emulator* on page 31
- *Generating Code for a Mobile Workflow Package* on page 36

**Configuring iPhone Connection Settings**
Configure settings for the Mobile Workflow application.

1. When the iPhone simulator runs, the TravelRequest workflow application opens. Close the Assigned Workflows screen.
2. In the iPhone simulator Settings window, click **WorkFlows**.
3. Enter these settings for the SUP Mobile Workflow application:
   - Server Name – the machine that hosts the server where the mobile application project is deployed.
   - Server Port – Unwired Server port number. The default is 5001.
   - Company ID – the company ID you entered when you registered the device in Sybase Control Center, in this case, 0 (zero).
   - User Name – the user you registered in Sybase Control Center.
   - Activation Code – the optional user activation code.

**Generating Code for a Mobile Workflow Package**
Generate a Mobile Workflow package and deploy it to Unwired Server to make it available to device clients.

**Prerequisites**
Complete these tasks:

- *Registering the Device in Sybase Control Center* on page 8 for each device that you want to enable to connect to the package.
- Complete *Developing a Database Mobile Business Object* on page 15.
- Complete *Creating a Mobile Workflow Form* on page 21.
- For Windows Mobile devices, start the synchronization software if it is not already running:
  - On Windows XP, start Microsoft ActiveSync.
**Task**

Use the Mobile Workflow Package Generation wizard to generate files for the mobile workflow package, optionally deploy the generated package files to the server, and assign the package to one or more devices.

1. Open Sybase Unwired Workspace.
2. In the WorkSpace Navigator, expand `MobileWorkflow101` and double-click `travelrequest.xbw`. The package file opens in the Mobile Workflow Forms Editor.
3. In the Sybase Unwired Workspace toolbar, click the Mobile Workflow package wizard button.
4. In the New Mobile Workflow Package Generation wizard, select these options:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Favorite configurations</td>
<td>(Optional) Select a configuration.</td>
</tr>
<tr>
<td><strong>Package Generation and Deployment</strong></td>
<td></td>
</tr>
<tr>
<td>Generate</td>
<td>Select <em>Generate into the project</em>.</td>
</tr>
<tr>
<td>Unwired Server Profile</td>
<td>Select My Unwired Server as the profile to associate with the mobile workflow package.</td>
</tr>
<tr>
<td>Deploy to an Unwired Server</td>
<td>Deploy the mobile workflow package to an Unwired Server.</td>
</tr>
<tr>
<td>Assign workflow to users</td>
<td>Select this option and click <em>Get Users</em>. Then enter or more users (separated with commas) for whom devices have been registered.</td>
</tr>
</tbody>
</table>
5. Click Finish.

The WorkSpace assigns the TravelRequest application to the user and generates the files for the mobile workflow package in a zip archive on the server. You can see the files in your project the Workspace Navigator:
If the package is not displayed initially, double-click the server to refresh the display. The mobile workflow package is added to the Enterprise Explorer under the Unwired Servers/Workflows folder.
Viewing and Running the Mobile Workflow Package

After generating the Mobile Workflow package files and deploying it to Unwired Server, you can view and run the Mobile Workflow application.

See also

- *Installing the Mobile Workflow Package* on page 27
- *Verifying the Data on the Backend Database* on page 48
Running the Mobile Workflow Form on the Android Simulator

Run the travelrequest mobile workflow form on the Android simulator.

Note: This tutorial was developed using one of the supported Android SDK versions. If you use a different version, the interface might differ in some details.

1. Start your emulator instance if it is not already running:
   a) Click Start > Programs > Android SDK Tools > SDK Manager.
   b) Select the new virtual device and click Start.
   c) In Launch Options, optionally modify the default display scaling, then click Launch.

2. In the emulator, unlock the screen. For example, drag the padlock to the right side of the screen.

3. Click the Launcher.
4. Click the Sybase Workflows button.

Note: The location of the Workflow button might vary depending on your emulator version and type. For example, you might find the Workflows button in the Apps screen menu.

5. Enter the password. If prompted, enter the activation code.
The Sybase Mobile Workflow screen opens and displays the text, No messages.

6. Open the Android menu, then click Workflows.
7. Click **travelrequest** to open the workflow start screen.
8. Open the Android menu again, and select **Open TravelRequest_create**.
9. Enter your travel request information in the workflow form.
10. Click the Android **Menu** button and select **Create**.

The mobile workflow form closes and the **TravelRequest** database table on the server is updated.

**See also**

- **Viewing and Running the Mobile Workflow Form on the Windows Mobile Emulator** on page 44
- **Viewing and Running the Mobile Workflow Form on the iPhone Simulator** on page 46

**Viewing and Running the Mobile Workflow Form on the Windows Mobile Emulator**

Run the travelrequest mobile workflow form on the Windows Mobile emulator.

1. In the emulator, click **Programs** and select **Workflows**.
2. Click the **travelrequest** icon.

3. Click **Open TravelRequest**.
   
Enter your travel request information.
4. Click **Create**.

The emulator closes the mobile workflow form. The TravelRequest database table is updated on the back end.

**See also**
- *Running the Mobile Workflow Form on the Android Simulator* on page 41
- *Viewing and Running the Mobile Workflow Form on the iPhone Simulator* on page 46

**Viewing and Running the Mobile Workflow Form on the iPhone Simulator**

Run the travelrequest mobile workflow form on the iPhone simulator.

1. Click **Workflows**.
2. In Workflows, click **travelrequest**.
3. In the introduction page, click **Open TravelRequest**.

4. Fill out the information for the travel request, and click **Create**.
The simulator closes the mobile workflow form. The TravelRequest database table is updated on the backend.

See also
- Running the Mobile Workflow Form on the Android Simulator on page 41
- Viewing and Running the Mobile Workflow Form on the Windows Mobile Emulator on page 44

Verifying the Data on the Backend Database

After submitting a travel request in an emulator, verify that the information is updated in the database.

1. In Unwired WorkSpace, expand the sample database in Enterprise Explorer.
2. In the Tables folder, right-click the TravelRequest table and select Edit Data.
3. In the Table Data Filter dialog, accept the default settings and click **OK**. The TravelRequest table opens, displaying the new row.

**See also**

- *Viewing and Running the Mobile Workflow Package* on page 40
Developing the Mobile Workflow Package
Learn More about Sybase Unwired Platform

Once you have finished, try some of the other samples or tutorials, or refer to other development documents in the Sybase Unwired Platform documentation set.

Check the Sybase Product Documentation Web site regularly for updates: access http://sybooks.sybase.com/nav/summary.do?prod=1289, then navigate to the most current version.

Tutorials
Try out some of the other getting started tutorials available on Product Documentation to get a broad view of the development tools available to you.

Tutorial Projects
Tutorial projects are available for download, if you want the finished tutorial without going through the steps. Download tutorial projects from: http://www.sdn.sap.com/irj/sdn/mobile?rid=/webcontent/uuid/40ea4956-b95c-2e10-11b3-e68c73b2280e.

Samples
Sample applications are fully developed, working applications that demonstrate the features and capabilities of Sybase Unwired Platform.

Check the SAP Development Network (SDN) Web site regularly for new and updated samples: https://cw.sdn.sap.com/cw/groups/sup-apps.

Online Help
See the online help that is installed with the product, or the Product Documentation Web site.

Developer Guides
Learn about using the API to create device applications:

- Developer Guide: BlackBerry Native Applications
- Developer Guide: iOS Native Applications
- Developer Guide: Windows and Windows Mobile Native Applications
- Developer Guide: Mobile Workflow Packages

Customize and automate:

- Developer Guide for Unwired Server Management API – customize and automate system administration features.
- Developer Guide: Unwired Server – customize and automate server-side implementations for device applications, and administration, such as data handling.

Javadoc and HeaderDoc are also available in the installation directory.
Learn More about Sybase Unwired Platform
Index

A
ActiveSync, installing and configuring 6
Android 27
applications
  generating code for device 36
articles 51

B
basics, learning 10
BlackBerry 1

C
connecting to Sybase Control Center 8
create operation 21
creating
  database connection profile 12
  sampledb 12
  creating a new key 21

D
deploying
  configuring ActiveSync for 6
  mobile business objects 17
developer profile
  switching 19
device applications
  generating code for 36

E
Eclipse Studio Edition
  Sybase Unwired WorkSpace 7
emulator connection settings, configuring 32
emulator, registering 8
Enterprise Explorer, defined 10

F
Flow Design page 21

G
generating
  code for a device application 36
  getting started 5
  Sybase Unwired WorkSpace 10
tutorial projects 1
tutorials 1

H
help, online 10
HtmlView control 21

I
installing
  Microsoft ActiveSync 6
  Sybase Unwired Platform 5
  synchronization software 6
iOS 1

K
key
  creating a new 21
  defining default value for 21

M
Microsoft ActiveSync, installing and configuring 6
Mobile Application Diagram, defined 10
mobile application projects
  deploying 17
mobile applications
  generating code for 36
mobile business object
  operation 21
  TravelRequest 21
mobile business objects
  deploying 17
mobile workflow form
  adding an operation 21
  creating 21
  designing the screen for 21
mobile workflow form, running on emulator 41, 44
Index

O
online help, accessing 10

P
Palette, defined 10
Properties view, defined 10

R
registering the emulator in SCC 8

S
samples 51
Screen Design page 21
servers
  Unwired Server, starting 7
Simulator 27
Start
  icon 21
  screen 21
starting
  Sybase Control Center 8
  Sybase Unwired WorkSpace 7
  Unwired Server 7
SUPMessaging_Pro.cab 31
Sybase Control Center 8
  connecting to 8
  register device 8
  registering the emulator 8
  status 8
Sybase Mobile Workflow 27
Sybase Unwired Platform
  getting started 5
  installing 5
  learning more about 51
Sybase Unwired WorkSpace
  getting started 10
  starting 7
synchronization software
  installing 6

T
task flow 3
TravelRequest database table 41, 44
tutorial
  configuring the Android simulator 27
  running the Android simulator 41
tutorial projects 51
tutorials 51

U
Unwired Server 7
  deploying MBOs to 17

W
Windows emulator
  connection settings 32
Windows Mobile 1
WorkSpace Navigator, defined 10