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Sybase Unwired Platform Tutorials

The Sybase® Unwired Platform tutorials demonstrate how to develop, deploy, and test mobile
business objects, device applications, and mobile workflow packages. You can also use the
tutorials to demonstrate system functionality and train users.

• Learn mobile business object (MBO) basics, and create a mobile device application:
• Tutorial: Mobile Business Object Development

• Create native mobile device applications:
• Tutorial: BlackBerry Application Development
• Tutorial: iOS Application Development

• Create a mobile workflow package:
• Tutorial: Mobile Workflow Package Development

The tutorials demonstrate a cross section of basic functionality, which includes creating
MBOs that can be used in replication-based or message-based synchronization; and using
various Sybase Unwired WorkSpace development tools, independent development
environments, and device types.

Table 1. Tutorial summary

Tutorials Mobile
business
objects
(MBOs)

Synchroni-
zation types

Development
tools

Device
types

Tutorial: Mobile Business Ob-
ject Development

Create new
MBOs

Replication-
based

Sybase Unwired
WorkSpace

N/A

Tutorial: BlackBerry Applica-
tion Development

Create new
MBOs

Replication-
based

Sybase Unwired
WorkSpace

BlackBerry

Tutorial: iOS Application De-
velopment

Create new
MBOs

Message-based Sybase Unwired
WorkSpace

iPhone

Tutorial: Mobile Workflow
Package Development

Create new
MBOs

Message-based Mobile Workflow
Forms Editor

Windows
Mobile

iPhone
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Task Flow

Use this tutorial to develop a mobile workflow package using message-based
synchronization. You can deploy and run the mobile workflow package on a Windows Mobile
emulator, or an iPhone simulator.

Task Goals Procedures required to achieve the goals

Getting Started Install Sybase Un-
wired Platform, cre-
ate a connection pro-
file, start the server
and Unwired Work-
Space, and create a
Mobile Workflow
Application project.

• Getting Started on page 5

• Installing Sybase Unwired Platform on page
5

• Installing Microsoft Synchronization Software on
page 5

• Starting Unwired Platform Services on page
6

• Starting Sybase Unwired WorkSpace on page
7

• Connecting to Sybase Control Center on page
7

• Registering the Device in Sybase Control Center
on page 8

• (Optional) Learning the Basics on page 9

• Creating the sampledb Connection Profile on page
11

• Creating the Mobile Workflow 101 Mobile Ap-
plication Project on page 14

Developing a Data-
base Mobile Busi-
ness Object

Create and deploy a
database mobile ob-
ject.

• Creating the TravelRequest Database Table on
page 15

• Creating the TravelRequest Mobile Business Ob-
ject on page 17

• Deploying the WorkFlow101 Mobile Application
Project on page 17

Task Flow
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Task Goals Procedures required to achieve the goals

Developing a Mo-
bile Workflow Ap-
plication

Create a mobile
workflow form, gen-
erate the files, assign
the mobile workflow
package to a user,
and view the mobile
workflow form on
the emulator or sim-
ulator.

• Creating a Mobile Workflow Form on page 21

• Installing the Mobile Workflow Package on page
27

• Viewing and Running the Mobile Workflow Pack-
age on page 37

• Verifying the Data on the Backend Database on
page 43

Task Flow
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Getting Started

Goal: Install and learn about Sybase Unwired Platform and its components.

These tasks are required, unless otherwise noted, for all tutorials, but you need to perform
them only once.

1. Installing Sybase Unwired Platform on page 5

2. Starting Unwired Server on page 6

3. Connecting to Sybase Control Center on page 7

4. Starting Sybase Unwired WorkSpace on page 7

5. (Optional) Learning the Basics on page 9

6. Creating the sampledb Connection Profile on page 11

Installing Sybase Unwired Platform
Goal: Install Sybase Unwired Platform.

Install these Sybase Unwired Platform components:

• Data Tier
• Unwired Server
• Unwired WorkSpace

If Unwired Platform is already installed and any of these components are missing:

1. Start the Sybase Unwired Platform installer.
2. Follow the instructions in the installation wizard. When prompted, select Custom

Install.
3. Select the required components, and complete the installation.

For complete installation instructions, see the Sybase Unwired Platform Installation Guide
and Release Bulletin at http://sybooks.sybase.com/nav/base.do.

Installing Microsoft Synchronization Software
Install and configure Microsoft synchronization software so you can deploy and run a mobile
application on a Windows Mobile emulator.

Note: Microsoft ActiveSync is for Windows XP. If you are using Windows Vista, Windows 7,
or Windows 2008, install Virtual PC 2007 SP1 and Windows Mobile Device Center to manage
synchronization settings. Download the Windows Mobile Device Center from http://

Getting Started
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www.microsoft.com/windowsmobile/en-us/downloads/microsoft/device-center-
download.mspx.

1. Download Microsoft ActiveSync from http://www.microsoft.com/windowsmobile/en-
us/help/synchronize/device-synch.mspx. Save it to your local machine. Windows XP
requires ActiveSync version 4.5.

2. In Windows Explorer, double-click setup.msi.

3. When installation is complete, restart your machine.

ActiveSync starts automatically, and its icon appears in the Windows toolbar.

4. Double-click the ActiveSync icon.

5. Select File > Connection Settings.

6. Select Allow Connections to One of the Following, then select DMA.

7. Under This Computer is Connected to, select Work Network.

8. Click OK.

Starting Unwired Platform Services
Goal: Start Unwired Server and the sample database.

Select Start > Programs > Sybase > Unwired Platform  > Start Unwired Platform
Services.

Getting Started
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Starting Sybase Unwired WorkSpace
Goal: Start Unwired WorkSpace.

1. Select Start > Programs > Sybase > Unwired Platform > Unwired WorkSpace.

The Welcome page displays links to product information, and to the product.

2. To read more about Sybase Unwired WorkSpace concepts and tasks, select Help > Help
Contents from the main menu.

Connecting to Sybase Control Center
Goal: Open the Web-based Sybase Control Center administration console to manage
Unwired Server and its components.

From Sybase Control Center, you can:

• View servers and their status
• Start and stop a server
• View server logs
• Deploy a mobile application package
• Register devices
• Set role mappings

For information on configuring, managing, and monitoring Unwired Server, select Help >
Online Documentation.

1. Select Start > Programs > Sybase > Sybase Control Center.

Note: If Sybase Control Center does not launch, make sure that the Sybase Unified Agent
service is started. See the Installation Guide for details.

2. Log in using the default login:

• User name – supAdmin

• Password – s3pAdmin

Logging in to Sybase Control Center allows you access to Unwired Platform
administration features that you are authorized to use.

Getting Started
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Registering the Device in Sybase Control Center
Use Sybase Control Center to register the device.

Prerequisites
You must be logged in to Sybase Control Center.

Task

1. Log in to Sybase Control Center using the supAdmin/s3pAdmin user name and password.

2. In Sybase Control Center, select View > Select > Unwired Server Cluster Management
View.

3. Expand the Servers folder in the left pane, and select Device Users.

4. In the right pane, click Devices.

5. Click Register.

6. In the Register Device window, enter the required information:

• Activation user name – enter a user name, such as user1.
• Server name – the DNS name or IP address of the primary Unwired Server, such as

"myserver.mycompany.com". If using Relay Server, the server name is the IP address
or fully qualified name of the Relay Server host.

• Port – the port used for messaging connections between the device and Unwired
Server. If using Relay Server, this is the Relay Server port. Default: 5001

• Farm ID – a string associated with the Relay Server farm ID. Can contain only letters A
– Z (uppercase or lowercase), numbers 0 – 9, or a combination of both. Default: 0

• Activation code length – the number of characters in the activation code. If you are
reregistering or cloning a device, this value cannot be changed.

• Activation expiration (hours) – the number of hours the activation code is valid.
• (Optional) Select the check box adjacent to Specify activation Code to enter the code

sent to the user in the activation e-mail. This value can contain letters A – Z (uppercase
or lowercase), numbers 0 – 9, or a combination of both. Acceptable range: 1 to 10
characters.

Getting Started
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Note: <server_name> should be the actual name of your machine.

Learning the Basics
Goal: Learn about Sybase Unwired WorkSpace and how to access help.

Prerequisites
Start Unwired WorkSpace.

Task

1. From the Welcome page, select any of the links to familiarize yourself with the Unwired
WorkSpace environment.

To close this page, click the X. You can reopen this page by selecting Help > Welcome.

2. Select Start Development  to access the Sybase Unwired WorkSpace development
environment.

Look at the area (window or view) that you will be working in to access, create, define, and
update mobile business objects (MBOs).

Getting Started
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View Description

WorkSpace Navigator This view displays mobile application project fold-
ers, each of which contains all project-related re-
sources in subfolders, including MBOs, data source
references to which the MBOs are bound, personal-
ization keys, and so on.

Use this view to review and modify MBO-related
properties.

Enterprise Explorer A window that provides functionality to connect to
various enterprise back-end systems; for example,
database servers, SAP® servers, and Sybase Un-
wired Server.

Mobile Application Diagram A graphical editor where you create and define mo-
bile business objects.

Use the Mobile Application Diagram to create
MBOs (including attributes and operations), then
define relationships with other MBOs. You can:

• Create MBOs in the Mobile Application Dia-
gram using Palette icons and menu selections –
either bind or defer binding to a data source,
when creating an MBO. For example, you may
want to model your MBOs before creating the
data sources to which they bind. This is some-
times called the top-down approach.

• Drag items from Enterprise Explorer and drop
them onto the Mobile Application Diagram to
create the MBO – quickly creates the operations
and attributes automatically based on the data
source being dropped on the Mobile Application
Diagram. This is sometimes called the bottom-
up approach.

Each new mobile application project generates an
associated Mobile Application Diagram.

Palette Access the Palette from the Mobile Application Di-
agram. It provides controls, such as the ability to
create MBOs, add attributes and operations, and de-
fine relationships, by dragging and dropping the
corresponding icon onto the Mobile Application Di-
agram or existing MBO.

Getting Started
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View Description

Properties view Select an object in the Mobile Application Diagram
to display and edit its properties in the Properties
view. You cannot create an MBO from the Properties
view, but generally, most development and configu-
ration is performed here.

Outline view Displays an outline of the file that is currently open in
the editor area, and lists structural elements. The
contents are editor-specific.

Problem view Displays problems, errors, or warnings that you may
encounter.

3. To access the online help, select Help  > Help Contents from the main menu bar.

4. Expand any of the documents that appear in the left pane.

Some documents are for Sybase Unwired Platform, while others are for the Eclipse
development environment.

Creating the sampledb Connection Profile
Goal: Create a database connection profile and test the sample database connection.

Installing Sybase Unwired Platform also installs a sample database sampledb, which you
can use to create and test mobile business objects (MBOs). Starting Sybase Unwired Platform
Services automatically starts the database, depending on your license type. A default
connection profile (My Sample Database) is included with the installation, and provides
access to the sampledb database. This tutorial shows you how to create and use a new
connection profile named sampledb.

This task is required for all tutorials, but you need to perform it only once. If the sampledb
connection profile already exists, you do need not perform this task.

1. From the Enterprise Explorer, right-click the Database Connections folder and select
New to open the Wizard Selection Page.

2. Select Sybase ASA, enter sampledb as the name, and click Next.

3. Select Sybase ASA v11.x for Unwired Server Default as the driver and keep the default
settings, including dba as the User name and SQL as the Password. Select Save
Password.

Getting Started

Tutorial: Mobile Workflow Package Development 11



4. Click Test Connection.

If Test Connection fails, verify Unwired Platform Services, including the sampledb
database, are running.

a) Select the Windows Start > Settings > Control Panel menu.
b) Select Administrative Tools, then select Services.
c) Depending on your installation options (for example, license type, whether or not you

installed a cluster, and so on) determines which Sybase services are running.

Getting Started
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Note: If the sampledb database is not running, you can install and start it from the
command line. To install it, use the command sampledb install auto/manual. For
example:
C:\Sybase\UnwiredPlatform\Servers\UnwiredServer\bin> sampledb 
install auto

To start it from the command line, run the command sampledb start. For example:
C:\Sybase\UnwiredPlatform\Servers\UnwiredServer\bin> sampledb 
start

5. In the Ping Succeeded message, click OK.

6. Click Finish.

View the sampledb connection profile from Enterprise Explorer by expanding the Database
Connections folder.

Getting Started
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Creating the Mobile Workflow 101 Mobile Application
Project

A mobile application project is the container for the mobile business objects that form the
business logic of mobile applications.

Before you can create mobile business objects, you must create a mobile application project.

1. From the main menu bar, select File > New > Mobile Application Project.

2. Enter MobileWorkflow101 as the name.

3. Click Finish.

Getting Started
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Developing a Database Mobile Business
Object

Goal: Create a database mobile business object and deploy it to Unwired Server.

Develop the database mobile business object by:

1. Creating the TravelRequest Database Table on page 15.

2. Creating the TravelRequest Mobile Business Object on page 17.

3. Deploying the WorkFlow101 Mobile Application Project on page 17.

Creating the TravelRequest Database Table
Goal: Create the database table that will be used to create a Travel Request mobile business
object.

Prerequisites
Complete Creating the sampledb Connection Profile on page 11.

Task
This task shows you how to create a SQL file that you can use to create a new database table,
which is then used to create a mobile business object.

1. From the main menu, select File > New > Other.

2. Select SQL Development > SQL File, and click Next.

3. Enter or select the values shown and click Finish:

Field Value

Parent folder Select the MobileWorkflow101 project.

File name Enter TravelRequest.

Database server type Select Sybase_ASA_11.x.

Connection profile name Select sampledb.

Database name Select sampledb.

Developing a Database Mobile Business Object
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4. In the TravelRequest.sql editor, copy and paste this code:

CREATE TABLE TravelRequest (
    trvl_Id                      integer NOT NULL DEFAULT 
autoincrement 
   ,trvl_Date                    date NULL 
   ,trvl_Loc                     varchar(20) NULL
   ,est_Cost                     float NULL
   ,purpose                      varchar(200) NULL
   ,trvl_Status                  varchar(20) NULL 
   ,st_Cmmnt                     varchar(200) NULL 
   ,PRIMARY KEY CLUSTERED (trvl_Id) 
);

Developing a Database Mobile Business Object
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5. Select File > Save.

6. Close the TravelRequest.sql file.

7. In the MobileWorkflow101 project, right-click the TravelRequest.sql file you
created and select Execute SQL Files.

This creates a database table called TravelRequest.

8. Expand the sampledb database you created, then expand the Tables folder.

You should see the new TravelRequest table. If you do not see it, right-click the Tables
folder and select Refresh.

Creating the TravelRequest Mobile Business Object
Goal: Use the TravelRequest database table to create a mobile business object.

Prerequisites
Complete Creating the TravelRequest Database Table on page 15.

Task

1. Expand the sampledb database, then expand the Tables folder.

2. Drag and drop the TravelRequest table onto the MobileWorkflow101 Mobile Application
Diagram.

3. In the Quick Create wizard, accept the defaults and click OK.

4. Select File > Save.

Deploying the WorkFlow101 Mobile Application Project
Goal: Deploy the project that contains the TravelRequest mobile business object to the server.

1. Right-click in the MobileWorkflow101 Mobile Application Diagram, and select Deploy
Project.

2. In the first page of the Deploy Mobile Application Project wizard, select Message-based,
accept the defaults for the other options, then click Next.

Developing a Database Mobile Business Object
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3. In the Contents page, select the TravelRequest mobile business object, and click Next.

4. In the Package Jars window, click Next.

Note: You see the Package Jars window only if you are using the Advanced developer
profile. See Switching Between Developer Profiles on page 19 for information.

5. In the Target Server page, from the list of available servers, select My Unwired Server and
click Next.

6. In the Server Connection Mapping page, select the My Sample Database connection
profile, then from Server connection, select the localhost version of sampledb.

Developing a Database Mobile Business Object
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7. Click Finish.

8. In the Deployment status window, click OK.

9. When the deployment completes, click File > Close.

10. In Enterprise Explorer, expand Unwired Servers > My Unwired Server > Domains >
default > Packages. The server package mobileworkflow101:1.0 into which you
deployed the MBOs appears in the Packages folder. The TravelRequest mobile business
object appears in the Mobile Business Objects folder.

Switching Between Developer Profiles
Switch between basic and advanced developer profiles in the Mobile Application Diagram.

If you do not see an Unwired WorkSpace feature (wizard, property, or WorkSpace Navigator
item) that you expect or need, switch to the advanced developer profile, or modify developer
profile settings. To use backend data sources other than those supplied by Sybase Unwired
Platform, you must switch to the advanced developer profile to see the Server Connection
Mapping page when deploying the Mobile Business Object package.

1. Right-click in the Mobile Application Diagram and select Switch Developer Profile >
Basic/Advanced.

2. You can also select Window > Preferences > Sybase, Inc. > Mobile Development >
Developer Profile to directly view or modify the developer profile preference settings.
Basic is the default developer profile.

Developing a Database Mobile Business Object
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Developing the Mobile Workflow Package

Goal: Develop and deploy a mobile workflow package.

Creating a Mobile Workflow Form
Goal: Create a mobile workflow form using the TravelRequest mobile business object.

Prerequisites
Complete Deploying the WorkFlow101 Mobile Application Project on page 17.

Task

1. From the main menu, select File > New > Mobile Workflow Forms Editor.

2. Select MobileWorkflow101 as the parent folder and enter travelrequest.xbw as
the file name.

3. Click Next.

4. Select Can be started, on demand, from the client. and click Finish.

5. In the Mobile Workflow Forms editor, click Flow Design.
You see the Client-initiated start icon with the Start Screen connected to it.

6. In Workspace Navigator, expand MobileWorkflow101 > Mobile Business Objects >
TraveRequest > Operations.

7. Drag and drop the create operation onto the Flow Design page.

A TravelRequest_create screen is automatically created.

Developing the Mobile Workflow Package
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8. Add a GoTo connection from the Start Screen to the TravelRequest_create screen:

a) In the Palette, click GoTo.
b) Click the Start Screen, and while holding the mouse down, drag the connection to the

TravelRequest_create screen.

9. Double-click the Start screen to open the Screen Design page.

10. From the Palette, select the HtmlView control and click the Start screen.

11. Click Flow Design to return to the Flow Design page.

12. Click the Client-initiated starting point so you can view its properties in the Properties
view.

If the Properties view does not appear, right-click the Flow Design page and select Show
Properties View.

13. The Properties view shows all of the keys that were automatically created for each
parameter in the create method of the TravelRequest mobile business object.

14. Create a new key for the Start screen:

a) In the Properties view, in Keys, click New.

Developing the Mobile Workflow Package
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b) Enter these values:

• Name – IntroKey
• Type – string

c) Click OK.

The new key, IntroKey, appears in the list of keys in the Properties view.

15. Define the default value for the new key:

a) Click the Screen Design tab.
b) If necessary, select Start Screen.

c) Select the HtmlView control to view the properties in the Properties view.
d) In Input Data Binding, from Key, select IntroKey.
e) In Default value, enter: <H2>Travel Request App</H2>This

application enables vacation requests to be sent for
approval<br>.

Developing the Mobile Workflow Package
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16. Select TravelRequest_create.

17. On the Menu, select the Create operation to view its properties.

18. In Properties, click Parameter Mappings.

The parameter mapping table shows the mobile business object parameters for the
operation and the keys that are used for those parameters.

Developing the Mobile Workflow Package
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19. Select File > Save.

Developing the Mobile Workflow Package
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Installing the Mobile Workflow Package

Configure the emulator or simulator, install the Mobile Workflow package, and generate the
Mobile Workflow package files.

Configuring the Android Simulator
Configure the Android simulator.

Prerequisites
Install the Android SDK and run the SDK Manager to install SDK Platform Android version
2.2 or higher, Android SDK Platform-tools, and Android SDK Tools.

Task

1. Run the Android SDK Manager and select Virtual devices. Click New, provide a name,
and select 2.2 or higher for the target.

2. In the Android Simulator, start the newly created virtual device.

3. (Optional) Select Wipe User Data.

4. Run platform-tools\adb and install SybaseDataProvider.apk and
Workflow.apk, which are located in \UnwiredPlatform\ClientAPI
\Workflow\Android.

The Sybase Mobile Workflow application should now appear in the simulator.

Configuring the Windows Mobile Emulator
Follow these steps to configure the Windows Mobile emulator for the Mobile Workflow
package deployment.

Prerequisites
Installing Microsoft Synchronization Software on page 5

Task
This tutorial uses a Windows Mobile 6.0 Professional Edition emulator. If you use a different
emulator version, the user interface will vary slightly from this tutorial.

1. Installing Sybase Messaging Runtime on page 28

Installing the Mobile Workflow Package
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2. Configuring Connection Settings on page 28

Installing Sybase Messaging Runtime
Start the Device Emulator Manager and your synchronization software, cradle the device, and
install Sybase Messaging Runtime.

Prerequisites

1. The Sybase Messaging runtime client requires that you have Microsoft .NET Compact
Framework 3.5 Redistributable installed.

2. The synchronization software must be running and the device must be connected and
cradled.

Task

1. Start the Device Emulator Manager.

2. From the list of devices, right-click the device you want to use, and select Connect.

3. Right-click on the device again and select Cradle.
The synchronization software appears.

4. Go to <UnwiredPlatform_InstallDir>\UnwiredPlatform\ClientAPI
\Workflow\WM\ and copy the SUPMessaging_Pro.cab file to a folder on your mobile
device, for example:

5. Use File Explorer on the device emulator to browse to the SUPMessaging_Pro.cab
file.

6. Click on SUPMessaging_Pro.cab once to start the installation.

Configuring Connection Settings on Windows Mobile
Goal: Configure the connection settings on the Windows Mobile emulator.

Prerequisites
Complete Installing Sybase Messaging Runtime on page 28.

Installing the Mobile Workflow Package

28 Sybase Unwired Platform



Task

Note: This tutorial uses a Windows Mobile 6.0 Professional Edition emulator. If you use a
different emulator version, the user interface will vary slightly from this tutorial.

1. On the emulator, select Start > Programs > Sybase Settings.

2. In the Sybase Settings screen, click Connection.

3. In the Connection screen, enter the connection settings:

• Server Name – the machine that hosts the server where the mobile application project
is deployed.

• Server Port – Unwired Server port number. The default is 5001.
• Farm/Company ID – the farm or company ID you entered when you registered the

device in Sybase Control Center, in this case, 0 (zero).
• User Name – the user you registered in Sybase Control Center, user1

• Activation Code – the activation code for the user, 123.

Note: "localhost" should be the name of your machine.

4. Click Done.

Installing the Mobile Workflow Package
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Installing the Mobile Workflow Container Using the
Provided Source Code

The mobile workflow container referenced in this procedure is a sample container. You can
use the provided source code in Xcode to build your own customized user interface and
configure other resources.

Prerequisites

• Register the device in Sybase Control Center
• You must have a Mac with iOS SDK 4.3 installed.
• Xcode 3.2.6 or higher.

Task

1. From your Mac, connect to the Microsoft Windows machine where Sybase Unwired
Platform is installed:

a) From the Apple menu, select Go > Connect to Server.
b) Enter the name or IP address of the machine, for example, smb://<machine DNS

name> or smb://<IP Address>.

2. Copy the MobileWorkflow-2.0.1.tar.gz from your Sybase Unwired Platform
installation <UnwiredPlatform_InstallDir>\UnwiredPlatform
\ClientAPI\Workflow\ios\ to a location on your Mac:

3. Unarchive the MobileWorkflow-2.0.1.tar.gz.

This creates a Workflow folder.

4. Copy over the libraries from <UnwiredPlatform_InstallDir>
\UnwiredPlatform\ClientAPI\MBS\ObjectiveC\libs into the Workflow
directory on your Mac.

5. In the Workflow folder, double-click WorkFlow.xcodeproj so that it opens in the XCode
IDE.

6. If necessary, add these frameworks from the SDK to the project by selecting Project >
Edit Active Target <ProjectName> > General:

• Security.framework

• AddressBook.framework

• QuartzCore.framework

• CoreFoundation.framework

• libicucore.A.dylib

• libz.1.2.3.dylib
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• libstdc++.dylib

7. In XCode, select Build > Build.

The project builds.

Configuring iPhone Connection Settings
Goal: Configure the settings for the Mobile Workflow application.

1. When the iPhone simulator launches, the TravelRequest workflow application appears.
Cancel out of the Assigned Workflows screen.

2. Go to your iPhone simulator Settings and click WorkFlows.

3. Enter the settings for the SUP Mobile Workflow application:

• Server Name – the machine that hosts the server where the mobile application project
is deployed.

• Server Port – Unwired Server port number. The default is 5001.
• Company ID – the company ID you entered when you registered the device in Sybase

Control Center, in this case, 0 (zero).
• User Name – the user you registered in Sybase Control Center, user1

• Activation Code – the activation code for the user, 123.

Generating Code for a Mobile Workflow Package
Goal: Generate the files for the Mobile Workflow package and deploy them to the Unwired
Server.

Prerequisites
Complete these tasks:

• Registering the Device in Sybase Control Center on page 8
• Complete Developing a Database Mobile Business Object on page 15.
• Complete Creating a Mobile Workflow Form on page 21.
• If Microsoft ActiveSync is not running, start it now. (Windows XP)
• If Windows Mobile Device Center is not running, start it now. (Windows Vista, Windows

7, Windows 2008)

Task

1. In the Mobile Workflow Application Designer, click .

2. In the New Mobile Workflow Package Generation wizard, select:
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Option Description

Favorite configurations (Optional) Select a configuration.

PackageGeneration and Deployment

Generate Select Generate into the project.

Unwired Server Profile Select My Unwired Server as the profile with
which to associate the mobile workflow pack-
age.

Deploy to an Unwired Server Deploy the mobile workflow package to an
Unwired Server.

Assign workflow to users Select this option, and click Get Users. Select
user1.
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3. In the Mobile Workflow Package Generation wizard, click Finish.

The files for the mobile workflow package are generated and stored in the specified
location as a .zip file.
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The mobile workflow package appears in Enterprise Explorer in the Workflows folder
under Unwired Server.
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Viewing and Running the Mobile Workflow
Package

After generating the Mobile Workflow package files and deploying it to Unwired Server, you
can view and run the Mobile Workflow application.

Running the Mobile Workflow Form on the Android
Simulator

Goal: Run the travelrequest mobile workflow form on the Android simulator.

1. Click Menu and select Workflow.

2. Click the travelrequest icon.

3. Click Open TravelRequest and enter your travel request information.

4. Click Create.

The mobile workflow form closes on the emulator, and the TravelRequest database
table is updated on the back end.

Viewing and Running the Mobile Workflow Form on the
Windows Mobile Emulator

Goal: Run the travelrequest mobile workflow form on the Windows Mobile emulator.

1. In the Outlook e-mail inbox, click Menu and select Workflows.
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2. Click the travelrequest icon.
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3. Click Open TravelRequest.

Enter your travel request information.
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4. Click Create.

The mobile workflow form closes on the emulator, and the TravelRequest database table is
updated on the backend.

Viewing and Running the Mobile Workflow Form on the
iPhone Simulator

Goal: Run the travelrequest mobile workflow form on the iPhone simulator.

1. Click the Workflows icon to open the Workflows.

2. Click travelrequest to open the travelrequest Mobile Workflow.
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3. In the introduction page, click Open TravelRequest.

4. Fill out the information for the travel request, and click Create.
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The mobile workflow form closes on the simulator, and the TravelRequest database table
is updated on the backend.
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Verifying the Data on the Backend Database

Goal: After you submit the travel request, verify that the information was updated in the
database.

1. Go to Unwired WorkSpace and in Enterprise Explorer, expand the sample database, then
expand the Tables folder.

2. In Tables, right-click the TravelRequest table and select Edit Data.

3. In the Table Data Filter dialog, accept the defaults and click OK.

The TravelRequest table opens and you see the new row.
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Learn More about Sybase Unwired Platform

Once you have finished, try some of the other samples or tutorials, or refer to other
development documents in the Sybase Unwired Platform documentation set.

Check the Sybase Product Documentation Web site regularly for updates: http://
infocenter.sybase.com/help/index.jsp?topic=/com.sybase.infocenter.pubs.docset-
SUP-2.0.0/doc/html/title.html.

Tutorials
Try out some of the other getting started tutorials to get a broad view of the development tools
available to you.

Samples
Sample applications are fully developed, working applications that demonstrate the features
and capabilities of Sybase Unwired Platform.

Check the SAP Development Network (SDN) Web site regularly for updates: http://
www.sdn.sap.com/irj/sdn/mobile. Click on Sybase Unwired Platform and navigate to
Samples.

Online Help
See the online help that is installed with the product, or the Product Documentation Web site.

Developer Guides
Learn about using the API to create device applications:

• Developer Guide for BlackBerry
• Developer Guide for iOS
• Developer Guide for Mobile Workflow Packages
• Developer Guide for Windows and Windows Mobile

Customize and automate:

• Developer Guide for Unwired Server Management API  – customize and automate system
administration features.

• Developer Guide for Unwired Server – customize and automate server-side
implementations for device applications, and administration, such as data handling.

Javadoc and HeaderDoc are also available in the installation directory.
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