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Introduction to Getting Started Tutorials

Getting started tutorials enable users of all levels to try Sybase® Unwired Platform with
minimal setup. You can also use the tutorials to demonstrate system functionality and train
users.

Overview of Getting Started Tutorials
The getting started tutorials demonstrate how to develop, deploy, and test mobile business
objects, device applications, and message-based mobile workflow packages.

• Learn mobile business object (MBO) basics, and create a mobile device application:
• Tutorial: Mobile Business Object Development
• Tutorial: BlackBerry Application Development using Device Application Designer
• Tutorial: Windows Mobile Device Application Development using Device

Application Designer
• Create native mobile device applications:

• Tutorial: BlackBerry Application Development using Custom Development
• Tutorial: iPhone Application Development using Custom Development
• Tutorial: Windows Mobile Application Development using Custom Development

• Create a mobile workflow package:
• Tutorial: Mobile Workflow Package Development

The getting started tutorials demonstrate a cross section of basic functionality, which includes
creating MBOs that can be used in replication-based or message-based synchronization; and
using various Sybase Unwired WorkSpace development tools, independent development
environments, and device types.

Table 1. Tutorial summary

Tutorials Mobile
business
objects
(MBOs)

Synchroni‐
zation types

Development
tools

Device
types

Tutorial: Mobile Business Ob-
ject Development

Create new
MBOs

Replication-
based

Sybase Unwired
WorkSpace

N/A

Tutorial: BlackBerry Applica-
tion Development using De-
vice Application Designer

Reuse
MBOs

Replication-
based

Device Applica-
tion Designer

BlackBerry
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Tutorials Mobile
business
objects
(MBOs)

Synchroni‐
zation types

Development
tools

Device
types

Tutorial: BlackBerry Applica-
tion Development using Cus-
tom Development

Create new
MBOs

Replication-
based

Sybase Unwired
WorkSpace

BlackBerry

Tutorial: iPhone Application
Development using Custom
Development

Create new
MBOs

Message-based Sybase Unwired
WorkSpace

iPhone

Tutorial: Windows Mobile
Application Development us-
ing Device Application De-
signer

Reuse
MBOs

Replication-
based

Device Applica-
tion Designer

Windows
Mobile

Tutorial: Windows Mobile
Device Application Develop-
ment using Custom Develop-
ment

Create new
MBOs

Message-based Sybase Unwired
WorkSpace

Windows
Mobile

Tutorial: Mobile Workflow
Package Development

Create new
MBOs

Message-based Mobile Workflow
Forms Editor

Windows
Mobile

Understanding the Unwired Platform Development
Environment

Learn more from the getting started tutorials by understanding basic development
environment concepts. Sybase Unwired Platform provides an Eclipse development
environment.

Development in Eclipse
Sybase Unwired WorkSpace is a plug-in to your Eclipse development environment that
provides tools for creating mobile applications.

Unwired WorkSpace includes back-end integration tools that connect Unwired Server to
enterprise data sources, allowing you to create mobile business objects (MBOs) from the
back-end business data model.

Developers can perform MBO code generation at any time and use this MBO model code
along with the user interface code in a native IDE. This makes the code available to transition
from the rapid application development (RAD) model to the fully extensible and open
development environment provided for device platforms from third-party vendors.

Introduction to Getting Started Tutorials
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Optionally you can use the Device Application Designer to develop user interfaces for
BlackBerry, Windows Mobile, and Windows devices. And you can use the Mobile Workflow
Forms Editor to develop message-based workflow packages for Windows Mobile, iPhone,
and Symbian devices.

Understanding Fundamental Mobile Development Concepts
Learn more from the getting started tutorials by understanding basic mobile development
concepts.

Learn more about these concepts:

• Fundamentals
• Sybase Unwired WorkSpace – Mobile Business Object Development

Mobile Business Objects
Mobile business objects help form the business logic for mobile applications.

A mobile business object (MBO) is derived from a data source (such as a database server, Web
service, or SAP® server). MBOs are deployed to Unwired Server, and accessed from mobile
device application clients. MBOs include:

• Implementation-level details – metadata columns that include information about the data
from a data source.

• Abstract-level details – attributes that correspond to instance-level properties of a
programmable object in the mobile client, and map to data source output columns.
Parameters correspond to synchronization parameters on the mobile client, and map to
data source arguments. For example, output of a SQL SELECT query are mapped as
attributes, and the arguments in the WHERE clause are mapped as synchronization
parameters, so that the client can pass input to the query.
MBO operations include parameters that map to data source input arguments. Operation
parameters determine information a client passes to the enterprise information system
(EIS).

• Relationships – defined between MBOs by linking attributes and parameters in one MBO,
to attributes and parameters in another MBO.

You can define MBOs using either a top-down approach—first designing attributes and
parameters, then binding them to a data source; or a bottom-up approach—first specifying a
data source, then automatically generating attributes and parameters from it.

A mobile application package includes MBOs, roles. and data source connection mappings,
and other artifacts that are delivered to the Unwired Server during package deployment.

Introduction to Getting Started Tutorials
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Synchronization Methods
Developers can use either replication-based or message-based synchronization to move data
and transactions between device application clients and Unwired Server.

The choice depends on the target device platform, application requirements, target platform,
and the nature of data changes and activity between Unwired Server and clients, for example,
mobile workflow forms always use message-based synchronization.

Unwired Server manages and maintains data freshness between multiple data sources and
device application through synchronization.

Application Types
Sybase Unwired Platform supports two choices for application type. First is the native
application type, and the other is the container-based business workflow type.

The native application model enables the developer to write custom code (C#, Java, or
Objective-C, depending on the platform), or to use the Device Application Designer to
generate the user interface. The native application model is supported on BlackBerry, Apple,
Windows Mobile, and Windows platforms. The choice depends on the functionality desired in
the application, and the need to access third-party and platform-provided APIs.

The business workflow model offers a fast and simple way to build applications that support
simple business workflows, such as approvals and requests. The workflow model is supported
on iPhone, Windows Mobile, Windows, and Symbian platforms.

Data Sources
A data source is the enterprise information system where data is retrieved from and
transactions are executed. A connection profile is a design-time connection to a data source.
Connection profiles are created to specific data source by providing connection information
such as host, port, login, and password among others. The connection profiles are used to
define MBOs and operations, and mapped to existing, or used to create new, server
connections when the package is deployed to Unwired Server..

Unwired Platform hides the interaction complexity with datasource-specific protocols, such
as JDBC for database and SOAP for Web services.

Unwired Platform currently supports these EIS connection types:

• Major databases:
• Sybase® Adaptive Server® Enterprise
• Sybase SQL Anywhere®

• Microsoft® SQL Server®

• Oracle®

• IBM® DB2®

• SAP® and SAP ECC

Introduction to Getting Started Tutorials
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• Web services – connect to SOAP and REST Web services in your EIS, and to supported
enterprise applications, such as Remedy.

See the Sybase Unwired Platform Installation Guide for supported version levels.

Switching Between Developer Profiles
Switch between basic and advanced developer profiles in the Mobile Application Diagram.

If you do not see an Unwired WorkSpace feature (wizard, property, or WorkSpace Navigator
item) that you expect or need, switch to the advanced developer profile, or modify developer
profile settings. To use backend data sources other than those supplied by Sybase Unwired
Platform, you must switch to the advanced developer profile to see the Server Connection
Mapping page when deploying the Mobile Business Object package.

1. Right-click in the Mobile Application Diagram and select  > Basic/Advanced.

2. You can also select Window > Preferences > Sybase, Inc. > Mobile Development >
Developer Profile to directly view or modify the developer profile preference settings.
Basic is the default developer profile.

Introduction to Getting Started Tutorials
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Task Flow

The Sybase Mobile Workflow tutorial explains how to develop, deploy, and run a mobile
workflow package on a Windows Mobile emulator.

Task Goals Procedures required to achieve the goals

Getting Started Install Sybase Un-
wired Platform, cre-
ate a connection pro-
file, start the server
and Unwired Work-
Space, and create a
Mobile Workflow
Application project.

• Getting Started on page 9

• Installing Sybase Unwired Platform on page
9

• Installing Synchronization Software on page
9

• Adding E-mail Users on page 10

• Starting Unwired Server on page 12

• Connecting to Sybase Control Center on page
12

• Starting Sybase Unwired WorkSpace on page
12

• (Optional) Learning the Basics on page 13

• Creating the sampledb Connection Profile on page
15

• Creating the Mobile Workflow 101 Mobile Ap-
plication Project on page 18

Note: These procedures are prerequisites for all the
other tutorials. Perform them only once.

Developing a Data-
base Mobile Busi-
ness Object

Create and deploy a
database mobile ob-
ject.

• Creating the TravelRequest Database Table on
page 21

• Creating the TravelRequest Mobile Business Ob-
ject on page 23

• Deploying the WorkFlow101 Mobile Application
Project on page 23

Task Flow
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Task Goals Procedures required to achieve the goals

Developing a Mo-
bile Workflow Ap-
plication

Create a mobile
workflow form, gen-
erate the files, regis-
ter the device in Syb-
ase Control Center
(SCC), assign the
mobile workflow
package to a user,
and view the mobile
workflow form on
the emulator.

• Creating a Mobile Workflow Form on page 27

• Generating Code for a Mobile Workflow Package
on page 32

• Configuring Connection Settings on page 35

• Registering the Device in Sybase Control Center
on page 34

• Assigning the Mobile Workflow Package to a User
on page 36

• Setting Up a New E-mail Account on the Emulator
on page 38

• Viewing and Running the Mobile Workflow Form
on the Emulator on page 39

Task Flow
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Getting Started

Goal: Install and learn about Sybase Unwired Platform and its components.

These tasks are required, unless otherwise noted, for all tutorials, but you need to perform
them only once.

1. Installing Sybase Unwired Platform on page 9

2. Starting Unwired Server on page 12

3. Connecting to Sybase Control Center on page 12

4. Starting Sybase Unwired WorkSpace on page 12

5. (Optional) Learning the Basics on page 13

6. Creating the sampledb Connection Profile on page 15

Installing Sybase Unwired Platform
Goal: Install Sybase Unwired Platform.

Install these Sybase Unwired Platform components:

• Data Tier
• Unwired Server
• Mobile Business Object Development Environment
• Device Application Designer

If Unwired Platform is already installed and any of these components are missing:

1. Start the Sybase Unwired Platform installer.
2. Follow the instructions in the installation wizard. When prompted, select Custom

Install.
3. Select the required components, and complete the installation.

For complete installation instructions, see the Sybase Unwired Platform Installation Guide
and Release Bulletin at http://sybooks.sybase.com/nav/base.do.

Installing Microsoft ActiveSync
Goal: Install and configure Microsoft ActiveSync so you can deploy and run a mobile
application on a Windows Mobile emulator.

Note: Microsoft ActiveSync is for Windows XP. If you are using Windows Vista or Windows
2008, you must install Virtual PC 2007 SP1 and Windows Mobile Device Center to manage

Getting Started
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synchronization settings. You can download the Windows Mobile Device Center from http://
www.microsoft.com/windowsmobile/en-us/downloads/microsoft/device-center-
download.mspx.

1. Download Microsoft ActiveSync from the http://www.microsoft.com/windowsmobile/
en-us/help/synchronize/device-synch.mspx. Save it to your local machine. Windows XP
requires version 4.5.

2. In Windows Explorer, double-click setup.msi to run the ActiveSync installer.

3. When installation is complete, restart your machine.

ActiveSync starts automatically, and its icon appears in the Windows toolbar.

4. In the toolbar, double-click the ActiveSync icon.

5. Select File > Connection Settings.

6. Under Allow Connections to One of the Following, select DMA.

7. Under This Computer is Connected to, select Work Network.

8. Click OK.

Adding E‐mail Users
Goal: Set up e-mail user accounts so you can test the mobile workflow on the emulator.

Prerequisites
The James Mail Server requires a Java Runtime Environment of Java version 1.4 or higher
installed to run the James application. A JRE must be downloaded and installed before James
can run. In addition, the environment variable JAVA_HOME must be set to the JRE home
directory before running James.

Getting Started
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This procedure uses an open source POP3 e-mail server called James Mail Server, but you can
use any e-mail server.

Task

1. Go to http://james.apache.org/.

2. Download the james-binary-2.3.2.zip file.

3. Unzip the file, for example, to C:\james.

4. Go to C:\james\james-2.3.2\bin and execute run.bat.

You see the James Mail Server window.

Note: The IIS default SMTP server might be occupying the port to which James connects.
If you have trouble connecting to the James Mail Server, shut down the IIS SMTP server.

5. Launch a command prompt window and, at the C: prompt, enter: telnet localhost
4555.

6. In the James Remote Administration window, enter:

• Login ID: root

• Password: root

7. Add the e-mail users using the adduser command, for example:

adduser user1 pass123

adduser manager1 pass1234

adduser multiplexer pass12345

8. Enter quit when you are finished adding e-mail users.

Getting Started
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Starting Unwired Platform Services
Goal: Start Unwired Server and the sample database.

In Windows, select Start > Programs > Sybase > Unwired Platform<version>  > Start
Unwired Platform Services .

Starting Sybase Unwired WorkSpace
Goal: Start Unwired WorkSpace.

1. In Windows, select Start > Programs > Sybase > Unwired Platform<version> >
Unwired WorkSpace.

Sybase Unwired WorkSpace opens, and displays the Welcome page with links to product
information, and to the product.

2. To read more about Sybase Unwired WorkSpace concepts and tasks, select Help > Help
Contents from the main menu.

Connecting to Sybase Control Center
Goal: Open the Web-based Sybase Control Center administration console to manage
Unwired Server and its components.

From Sybase Control Center, you can:

• View servers and their status
• Start and stop a server
• View server logs
• Deploy a mobile application package
• Set role mappings

1. Select Start > Programs > Sybase > Sybase Control Center.

Note: If Sybase Control Center does not launch, make sure that the Sybase Unified Agent
service is started. See the Installation Guide for details.

2. Log in using the default login:

• User Name – supAdmin
• Password – s3pAdmin

Logging in to Sybase Control Center (SCC) allows you access to Unwired Platform
administration features that you have been authorized to use. Administrators of any
Sybase product can log into SCC. However, only users assigned to the Super

Getting Started
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Administrator or Domain Administrator roles for Unwired Platform can log in to Unwired
Server from Sybase Control Center.

Logging in to SCC only allows you access to the SCC interface. If Unwired Server has not
been authenticated, you will not be able to see or administer any resources.

3. Select Help > Online Documentation  for additional information on configuring,
managing, and monitoring Unwired Server.

Learning the Basics
Goal: Learn about Sybase Unwired WorkSpace and how to access help.

Prerequisites
Start Unwired WorkSpace.

Task

1. From the Welcome page, select any of the links to familiarize yourself with the Unwired
WorkSpace environment.

To close this page, click the X. You can reopen this page by selecting Help > Welcome.

2. Select Start Development  to access the Sybase Unwired WorkSpace development
environment. Look at the area (window or view) that you will be working in to access,
create, define, and update mobile business objects (MBOs).

View Description

WorkSpace Navigator This view displays mobile application project fold-
ers, each of which contains all project-related re-
sources in subfolders, including MBOs, data source
references to which the MBOs are bound, personal-
ization keys, and so on.

Use this view to review and modify MBO-related
properties.

Enterprise Explorer A window that provides functionality to connect to
various enterprise back-end systems; for example,
database servers, SAP servers, and Sybase Unwired
Server.

Getting Started
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View Description

Mobile Application Diagram A graphical editor where you create and define mo-
bile business objects.

Use the Mobile Application Diagram to create
MBOs (including attributes and operations), then
define relationships with other MBOs. You can:

• Create MBOs in the Mobile Application Dia-
gram using Palette icons and menu selections –
either bind or defer binding to a data source,
when creating an MBO. For example, you may
want to model your MBOs before creating the
data sources to which they bind. This is some-
times called the top-down approach.

• Drag items from Enterprise Explorer and drop
them onto the Mobile Application Diagram to
create the MBO – quickly creates the operations
and attributes automatically based on the data
source being dropped on the Mobile Application
Diagram. This is sometimes called the bottom-
up approach.

Each new mobile application project generates an
associated Mobile Application Diagram.

Palette Access the Palette from the Mobile Application Di-
agram. It provides controls, such as the ability to
create MBOs, add attributes and operations, and de-
fine relationships, by dragging and dropping the
corresponding icon onto the Mobile Application Di-
agram or existing MBO.

Properties view Select an object in the Mobile Application Diagram
to display and edit its properties in the Properties
view. You cannot create an MBO from the Properties
view, but generally, most development and configu-
ration is performed here.

Outline view Displays an outline of the file that is currently open in
the editor area, and lists structural elements. The
contents are editor-specific.

Problem view Displays problems, errors, or warnings that you may
encounter.

3. To access the online help, select Help  > Help Contents from the main menu bar.

Getting Started
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4. Expand any of the documents that appear in the left pane. Some documents are for Sybase
Unwired Platform, while others are for the Eclipse development environment.

Creating the sampledb Connection Profile
Goal: Create a database connection profile and test the sample database connection.

Installing Sybase Unwired Platform also installs a sample database sampledb, which you
can use to create and test mobile business objects (MBOs). Starting Sybase Unwired Platform
Services automatically starts the database, depending on your license type. A default
connection profile (My Sample Database) is included with the installation, and provides
access to the sampledb database. This tutorial shows you how to create and use a new
connection profile named sampledb.

This task is required for all tutorials, but you need to perform it only once. If the sampledb
connection profile already exists, you do need not perform this task.

1. From the Enterprise Explorer, right-click the Database Connections folder and select
New to open the Wizard Selection Page.

2. Select Sybase ASA, enter sampledb as the name, and click Next.

3. Select Sybase ASA v11.x for Unwired Server Default as the driver and keep the default
settings, including dba as the User name and SQL as the Password. Select Save
Password.

Getting Started
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4. Click Test Connection.

If Test Connection fails, verify Unwired Platform Services, including the sampledb
database, are running.

a) Select the Windows Start > Settings > Control Panel menu.
b) Select Administrative Tools, then select Services.
c) Depending on your installation options (for example, license type, whether or not you

installed a cluster, and so on) determines which Sybase services are running.

Getting Started
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Note: If the sampledb database is not running, you can install and start it from the
command line. To install it, use the command sampledb install auto/manual. For
example:
C:\Sybase\UnwiredPlatform\Servers\UnwiredServer\bin> sampledb 
install auto

To start it from the command line, run the command sampledb start. For example:
C:\Sybase\UnwiredPlatform\Servers\UnwiredServer\bin> sampledb 
start

5. In the Ping Succeeded message, click OK.

6. Click Finish.

View the sampledb connection profile from Enterprise Explorer by expanding the Database
Connections folder.

Getting Started
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Creating the Mobile Workflow 101 Mobile Application
Project

A mobile application project is the container for the mobile business objects that form the
business logic of mobile applications.

Before you can create mobile business objects, you must create a mobile application project.

1. From the main menu bar, select File > New > Mobile Application Project.

Getting Started
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2. Enter MobileWorkflow101 as the name.

3. Click Finish.

Getting Started
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Developing a Database Mobile Business Object

Goal: Create a database mobile business object and deploy it to Unwired Server.

Develop the database mobile business object by:

1. Creating the TravelRequest Database Table on page 21.

2. Creating the TravelRequest Mobile Business Object on page 23.

3. Deploying the WorkFlow101 Mobile Application Project on page 23.

Creating the TravelRequest Database Table
Goal: Create the database table that will be used to create a Travel Request mobile business
object.

Prerequisites
Complete Creating the sampledb Connection Profile on page 15.

This task shows you how to create a SQL file that you can use to create a new database table,
which is then used to create a mobile business object.

Task

1. From the main menu, select File > New > Other.

2. Select SQL Development > SQL File, and click Next.

3. Enter or select the values shown and click Finish:

Field Value

Parent folder Select the MobileWorkflow101 project.

File name Enter TravelRequest.

Database server type Select Sybase_ASA_11.x.

Connection profile name Select sampledb.

Database name Select sampledb.

Developing a Database Mobile Business Object
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4. In the TravelRequest.sql editor, copy and paste this code:

CREATE TABLE TravelRequest (
    trvl_Id                      integer NOT NULL DEFAULT 
autoincrement 
   ,trvl_Date                    date NULL 
   ,trvl_Loc                     varchar(20) NULL
   ,est_Cost                     float NULL
   ,purpose                      varchar(200) NULL
   ,trvl_Status                  varchar(20) NULL 
   ,st_Cmmnt                     varchar(200) NULL 
   ,PRIMARY KEY CLUSTERED (trvl_Id) 
);

Developing a Database Mobile Business Object
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5. Select File > Save.

6. Close the TravelRequest.sql file.

7. In the MobileWorkflow101 project, right-click the TravelRequest.sql file you
created and select Execute SQL Files.

This creates a database table called TravelRequest.

8. Expand the sampledb database you created, then expand the Tables folder.

You should see the new TravelRequest table. If you do not see it, right-click the Tables
folder and select Refresh.

Creating the TravelRequest Mobile Business Object
Goal: Use the TravelRequest database table to create a mobile business object.

Prerequisites
Complete Creating the TravelRequest Database Table on page 21.

Task

1. Expand the sampledb database, then expand the Tables folder.

2. Drag and drop the TravelRequest table onto the MobileWorkflow101 Mobile Application
Diagram.

3. In the Quick Create wizard, accept the defaults and click OK.

4. Select File > Save.

Deploying the WorkFlow101 Mobile Application Project
Goal: Deploy the project that contains the TravelRequest mobile business object to the server.

1. Right-click in the MobileWorkflow101 Mobile Application Diagram, and select Deploy
Project.

2. In the first page of the Deploy Mobile Application Project wizard, select Message-based,
accept the defaults for the other options, then click Next.

Developing a Database Mobile Business Object
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3. In the Contents page, select the TravelRequest mobile business object, and click Next.

4. In the Package Jars window, click Next.

Note: You see the Package Jars window only if you are using the Advanced developer
profile. See Switching Between Developer Profiles on page 5 for information.

5. In the Target Server page, from the list of available servers, select My Unwired Server and
click Connect.

Once connected, accept the default domain and security configuration settings, and click
Next.

6. In the Server Connection Mapping page, click Finish.

7. In the Deployment status window, click OK.

8. When the deployment completes, click File > Close.

Developing a Database Mobile Business Object
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9. In the Enterprise Explorer, expand Unwired Servers, right-click My Unwired Server, and
select Refresh.

10. Expand Domains > default > Packages. The server package MobileWorkflow101 into
which you deployed the MBOs appears in the Packages folder. The TravelRequest mobile
business object appears in the Mobile Business Objects folder.

Developing a Database Mobile Business Object
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Developing the Mobile Workflow Package

Goal: Develop and deploy a mobile workflow package.

1. Creating a Mobile Workflow Form on page 27.

2. Generating Code for a Mobile Workflow Device Application on page 32.

3. Registering the Device in Sybase Control Center on page 34.

4. Configuring Connection Settings on page 35.

5. Assigning the Mobile Workflow Package to a User on page 36.

6. Setting Up a New E-mail Account on the Emulator on page 38.

7. Viewing and Running the Mobile Workflow Application on the Emulator on page 39.

Creating a Mobile Workflow Form
Goal: Create a mobile workflow form using the TravelRequest mobile business object.

Prerequisites
Complete Deploying the WorkFlow101 Mobile Application Project on page 23.

Task

1. From the main menu, select New > Mobile Workflow Forms Editor.

2. Select MobileWorkflow101 as the parent folder and enter travelrequest.xbw as
the file name.

3. Click Next.

4. Select Can be started on demand from the client and click Finish.

5. In the Mobile Workflow Forms editor, click Flow Design.
You see the Start icon with the Start Screen connected to it.

6. In Workspace Navigator, expand MobileWorkflow101 > Mobile Business Objects >
TraveRequest > Operations.

7. Drag and drop the create operation onto the Flow Design page.

A TravelRequest_create screen is automatically created.
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8. Add a GoTo connection from the Start Screen to the TravelRequest_create screen:

a) In the Palette, click GoTo.
b) Click the Start Screen, and while holding the mouse down, drag the connection to the

TravelRequest_create screen.

9. Double-click the Start screen, which opens the Screen Design page.

10. From the Palette, select the HtmlView control and drop it onto the Start screen.

11. Click Flow Design to return to the Flow Design page.

12. Click the Start icon so you can view its properties in the Properties view.

If the Properties view does not appear, right-click the Flow Design page and select Show
Properties View.

13. The Properties view shows all of the keys that were automatically created for each
parameter in the create method of the TravelRequest mobile business object.
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14. Create a new key for the Start screen:

a) In the Properties view, in Keys, click New.
b) Enter these values:

• Name – IntroKey
• Type – string
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c) Click OK.

The new key, IntroKey, appears in the list of keys in the Properties view.

15. Define the default value for the new key:

a) Click the Screen Design tab.
b) If necessary, select Start Screen.

c) Select the HtmlView control to view the properties in the Properties view.
d) In Input Data Binding, from Key, select IntroKey.
e) In Default value, enter: <H2>Travel Request App</H2>This

application enables vacation requests to be sent for
approval.
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16. Select TravelRequest_create.

17. On the Menu, select the Create operation to view its properties.

18. In Properties, click Parameter Mappings.

The parameter mapping table shows the mobile business object parameters for the
operation and the keys that are used for those parameters.
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19. Select File > Save.

Generating Code for a Mobile Workflow Package
Goal: Generate the files for the Mobile Workflow package and deploy them to the Unwired
Server.

Prerequisites

• Complete Developing a Database Mobile Business Object on page 21.
• Complete Creating a Mobile Workflow Form on page 27.
• If Microsoft ActiveSync is not running, start it now. (Windows XP)
• If Windows Mobile Device Center is not running, start it now. (Windows Vista)

Task

1. In the Mobile Workflow Application Designer, click .

2. In the New Mobile Workflow Package Generation wizard, enter:

Option Description

Favorite configurations (Optional) Select a configuration.

Code Generation and Deployment

Generation folder Select the folder in which to save the .zip file

containing the mobile workflow package and
its generated files.

Deploy to an Unwired Server Deploy the mobile workflow package to an
Unwired Server.
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Option Description

Unwired Server Profile Select the Unwired Server profile with which to
associate the mobile workflow package and, if
you are using static authentication, extract the
user name and password credentials.

Deploy the Sybase messaging client to a con-
nected Microsoft Windows Mobile device or
emulator

Deploy the Sybase messaging client to the
Windows Mobile emulator.

Note: This option requires Microsoft Active-
Sync 4.5 (if you are using Windows XP) or
Windows Mobile Device Center (if you are us-
ing Windows Vista) to be installed and connec-
ted.

Windows Mobile device type Select Windows Mobile Professional.

Perform silent install Perform the deployment on the device without
necessitating user input.

Deployment timeout (minutes) Enter the number of minutes allowed before the
deployment times out.

Start Device Emulator Manager Start the Device Emulator Manager, which is
used to connect and cradle the selected device.

3. Click Start Device Emulator Manager.

4. Once the Device Emulator Manager starts, right-click the device you want to use for
testing and select Connect.

5. Once the emulator launches, in the Device Emulator Manager, right-click the connected
device and select Cradle.

Once you cradle the device, it will connect to ActiveSync or Windows Mobile Device
Center.

6. Ensure the device is connected in Microsoft ActiveSync or Windows Mobile Device
Center and click OK.
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7. In the Mobile Workflow Package Generation wizard, click Finish.

The files for the mobile workflow package are generated and stored in the specified
location as a .zip file.

The mobile workflow package appears in the Workflows folder under Unwired Server.

Registering the Emulator in Sybase Control Center
Goal: Use Sybase Control Center to register the emulator.

Prerequisites
Complete Connecting to Sybase Control Center on page 12.

Task

1. Log in to Sybase Control Center using the supAdmin/s3pAdmin user name and password.

2. In Sybase Control Center, select View > Select > Unwired Server Cluster Management
View.

3. Expand the Servers folder in the left pane, and select Device Users.

4. In the right pane, click Devices.

5. Click Register.

6. In the Register Device window, enter the required information:

• User name
• Server name
• Port
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Note: "localhost" should be the actual name of your machine.

After a moment, in Status, the emulator should appear as "online." Click Refresh if the
Status does not update.

Configuring Connection Settings
Goal: Configure the connection settings on the emulator.

Note: This tutorial uses a Windows Mobile 6.0 Professional Edition emulator. If you use a
different emulator version, user interface will vary slightly from this tutorial.

1. On the emulator, select Start > Programs > Sybase Settings.

2. In the Sybase Settings screen, click Connection.

3. In the Connection screen, enter the connection settings:
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Note: "localhost" should be the name of your machine.

4. Click Done.

Assigning the Mobile Workflow Package to a User
Goal: Use Sybase Control Center to register the travelrequest mobile workflow to user1.

Prerequisites
Complete Registering the Emulator in Sybase Control Center on page 34

Task

1. In Sybase Control Center, in the SUP Cluster Management View, under Workflows, select
travelrequest, then select Devices.

Developing the Mobile Workflow Package

  36 Sybase Unwired Platform  



2. Select Assign Workflow.

3. Under "Search devices to assign workflow to," enter user1 as the user name and click
Go.

4. Select user1, and click OK.

You see an Assign Successful message.
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Setting Up a New E‐mail Account on the Emulator
Goal: Set up an e-mail account on the emulator for user1.

1. In the main screen of the device emulator, click No unread messages.

2. Select New E-mail Account

3. Enter the e-mail address for user1.

4. Enter the password you used when you set up the e-mail account for user1.

5. Click Finish.

6. From the menu, select Send/Receive.

a) If a connection cannot be established, click the Settings link.
b) Click the Advanced folder.
c) In Select Networks, choose My Work Network.
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7. In the Outlook e-mail inbox, click Menu and select Workflows.

Viewing and Running the Mobile Workflow Form on the
Emulator

Goal: Run the travelrequest mobile workflow form on the emulator.

1. In the Outlook e-mail inbox, click Menu and select Workflows.

2. Click the travelrequest icon.
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3. Click Open TravelRequest.

Enter your travel request information.
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4. Click Create.

The mobile workflow form closes on the emulator, and the TravelRequest database table is
updated on the backend.

5. Go to Unwired WorkSpace and in Enterprise Explorer, expand the sample database, then
expand the Tables folder.

6. In Tables, right-click the TravelRequest table and select Edit Data.
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7. In the Table Data Filter dialog, accept the defaults and click OK.

The TravelRequest table opens and you can see the new row.
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Learn More about Sybase Unwired Platform

Once you have finished, try some of the other samples or tutorials, or refer to other
development documents in the Sybase Unwired Platform documentation set.

Getting Started Tutorials
Try out some of the other getting started tutorials to get a broad view of the development tools
available to you.

Advanced Tutorials
Tutorials are available that demonstrate how to use some of Sybase Unwired Platform
advanced features.

Check the Sybase Product Manuals Web site regularly for updates: http://
infocenter.sybase.com/help/index.jsp?topic=/com.sybase.infocenter.pubs.docset-
SUP-1.5.2/doc/html/title.html.

Samples
Sample applications are fully developed, working applications that demonstrate the features
and capabilities of Sybase Unwired Platform.

Check the Sybase Web site regularly for updates. Navigate to the Sybase Web site, then select
Products > Sybase Unwired Platform > Use tab: http://www.sybase.com/products/
mobileenterprise/sybaseunwiredplatform?htab=USE.

Online Help
See the online help that is installed with the product, or the Product Manuals Web site.

Check the Sybase Product Manuals Web site regularly for updates: http://
infocenter.sybase.com/help/index.jsp?topic=/com.sybase.infocenter.pubs.docset-
SUP-1.5.2/doc/html/title.html.

Developer References
See the Developer References to learn about using the API to custom code device applications
using the API.

• Developer Reference for BlackBerry
• Developer Reference for iPhone
• Developer Reference for Mobile Workflow Packages
• Developer Reference for Windows and Windows Mobile

Javadocs are also available in the installation directory.
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Check the Sybase Product Manuals Web site regularly for updates: http://
infocenter.sybase.com/help/index.jsp?topic=/com.sybase.infocenter.pubs.docset-
SUP-1.5.2/doc/html/title.html.

Programmer References
See the Programmer References to learn how to use the Administration API and Server API to
extend functionality.

• Reference: Administration APIs  – integrate your own administrative tools with Unwired
Platform to monitor and manage Unwired Platform.

• Reference: Custom Development for Unwired Server  – customize some Unwired Server
features.

Check the Sybase Product Manuals Web site regularly for updates: http://
infocenter.sybase.com/help/index.jsp?topic=/com.sybase.infocenter.pubs.docset-
SUP-1.5.2/doc/html/title.html.

Javadocs are also available in the installation directory.
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