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Introduction to Getting Started Tutorials

Getting started tutorials enable users of all levels to try Sybase® Unwired Platform with
minimal setup. You can also use the tutorials to demonstrate system functionality and train
users.

Overview of Getting Started Tutorials
The getting started tutorials demonstrate how to develop, deploy, and test mobile business
objects, device applications, and message-based mobile workflow packages.

• Learn mobile business object (MBO) basics, and create a mobile device application:
• Tutorial: Mobile Business Object Development
• Tutorial: BlackBerry Application Development using Device Application Designer
• Tutorial: Windows Mobile Device Application Development using Device

Application Designer
• Create native mobile device applications:

• Tutorial: BlackBerry Application Development using Custom Development
• Tutorial: iPhone Application Development using Custom Development
• Tutorial: Windows Mobile Application Development using Custom Development

• Create a mobile workflow package:
• Tutorial: Mobile Workflow Package Development

The getting started tutorials demonstrate a cross section of basic functionality, which includes
creating MBOs that can be used in replication-based or message-based synchronization; and
using various Sybase Unwired WorkSpace development tools, independent development
environments, and device types.

Table 1. Tutorial summary

Tutorials Mobile
business
objects
(MBOs)

Synchroni-
zation types

Development
tools

Device
types

Tutorial: Mobile Business Ob-
ject Development

Create new
MBOs

Replication-
based

Sybase Unwired
WorkSpace

N/A

Tutorial: BlackBerry Applica-
tion Development using De-
vice Application Designer

Reuse
MBOs

Replication-
based

Device Applica-
tion Designer

BlackBerry
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Tutorials Mobile
business
objects
(MBOs)

Synchroni-
zation types

Development
tools

Device
types

Tutorial: BlackBerry Applica-
tion Development using Cus-
tom Development

Create new
MBOs

Replication-
based

Sybase Unwired
WorkSpace

BlackBerry

Tutorial: iPhone Application
Development using Custom
Development

Create new
MBOs

Message-based Sybase Unwired
WorkSpace

iPhone

Tutorial: Windows Mobile
Application Development us-
ing Device Application De-
signer

Reuse
MBOs

Replication-
based

Device Applica-
tion Designer

Windows
Mobile

Tutorial: Windows Mobile
Device Application Develop-
ment using Custom Develop-
ment

Create new
MBOs

Message-based Sybase Unwired
WorkSpace

Windows
Mobile

Tutorial: Mobile Workflow
Package Development

Create new
MBOs

Message-based Mobile Workflow
Forms Editor

Windows
Mobile

Understanding the Unwired Platform Development
Environment

Learn more from the getting started tutorials by understanding basic development
environment concepts. Sybase Unwired Platform provides an Eclipse development
environment.

Development in Eclipse
Sybase Unwired WorkSpace is a plug-in to your Eclipse development environment that
provides tools for creating mobile applications.

Unwired WorkSpace includes back-end integration tools that connect Unwired Server to
enterprise data sources, allowing you to create mobile business objects (MBOs) from the
back-end business data model.

Developers can perform MBO code generation at any time and use this MBO model code
along with the user interface code that users write in a native integrated development
environment (IDE). This makes the code available to transition from the Unwired WorkSpace
MBO development tool to the fully extensible and open development environment provided
for device platforms from third-party vendors. Optionally, use the Device Application
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Designer to create prototype device applications for BlackBerry and Windows Mobile
devices.

Developers can use the Mobile Workflow Forms Editor to develop message-based mobile
workflow packages for Windows Mobile and iOS devices.

Understanding Fundamental Mobile Development
Concepts

Learn more from the getting started tutorials by understanding basic mobile development
concepts.

Learn more about these concepts:

• Fundamentals
• Sybase Unwired WorkSpace – Mobile Business Object Development

Mobile Business Objects
Mobile business objects help form the business logic for mobile applications.

A mobile business object (MBO) is derived from a data source (such as a database server, Web
service, or SAP® server). MBOs are deployed to Unwired Server, and accessed from mobile
device application clients. MBOs include:

• Implementation-level details – metadata columns that include information about the data
from a data source.

• Abstract-level details – attributes that correspond to instance-level properties of a
programmable object in the mobile client, and map to data source output columns.
Parameters correspond to synchronization parameters on the mobile client, and map to
data source arguments. For example, output of a SQL SELECT query are mapped as
attributes, and the arguments in the WHERE clause are mapped as synchronization
parameters, so that the client can pass input to the query.
MBO operations include parameters that map to data source input arguments. Operation
parameters determine information a client passes to the enterprise information system
(EIS).

• Relationships – defined between MBOs by linking attributes and parameters in one MBO,
to attributes and parameters in another MBO.

You can define MBOs using either a top-down approach—first designing attributes and
parameters, then binding them to a data source; or a bottom-up approach—first specifying a
data source, then automatically generating attributes and parameters from it.

A mobile application package includes MBOs, roles, and data source connection mappings,
and other artifacts that are delivered to the Unwired Server during package deployment.

Introduction to Getting Started Tutorials
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Synchronization Methods
Developers can use either replication-based or message-based synchronization to move data
and transactions between device application clients and Unwired Server.

The choice depends on the target device platform, application requirements, target platform,
and the nature of data changes and activity between Unwired Server and clients, for example,
mobile workflow forms always use message-based synchronization.

Unwired Server manages and maintains data freshness between multiple data sources and
device application clients through synchronization.

Application Types
Sybase Unwired Platform supports two choices for application type. First is the native
application type, and the other is the container-based business workflow type.

The native application model enables the developer to write custom code (C#, Java, or
Objective-C, depending on the platform) to create a device application. The native application
model is supported on BlackBerry, iOS, Windows Mobile, and Windows platforms. The
choice depends on the functionality desired in the application, and the need to access third-
party and platform-provided APIs. Optionally, use the Device Application Designer to create
prototype device applications for BlackBerry and Windows Mobile devices.

The business workflow model offers a fast and simple way to build applications that support
simple business workflows, such as approvals and requests. The workflow model is supported
on iOS, Windows Mobile, and Windows platforms.

Data Sources
A data source is the enterprise information system where data is retrieved from and
transactions are executed. A connection profile is a design-time connection to a data source.
Connection profiles are created to specific data source by providing connection information
such as host, port, login, and password among others. The connection profiles are used to
define MBOs and operations, and mapped to existing, or used to create new, server
connections when the package is deployed to Unwired Server..

Unwired Platform hides the interaction complexity with datasource-specific protocols, such
as JDBC™ for database and SOAP for Web services.

Unwired Platform currently supports multiple EIS connection types. See Supported Third-
Party Software and Hardware for information.

Switching Between Developer Profiles
Switch between basic and advanced developer profiles in the Mobile Application Diagram.

If you do not see an Unwired WorkSpace feature (wizard, property, or WorkSpace Navigator
item) that you expect or need, switch to the advanced developer profile, or modify developer
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profile settings. To use backend data sources other than those supplied by Sybase Unwired
Platform, you must switch to the advanced developer profile to see the Server Connection
Mapping page when deploying the Mobile Business Object package.

1. Right-click in the Mobile Application Diagram and select Switch Developer Profile >
Basic/Advanced.

2. You can also select Window > Preferences > Sybase, Inc. > Mobile Development >
Developer Profile to directly view or modify the developer profile preference settings.
Basic is the default developer profile.

Introduction to Getting Started Tutorials
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Task Flow

This tutorial shows you how to use the Device Application Designer to create a device
application prototype for a Windows Mobile device.

Task Goals Steps required to achieve the goals

Getting Started Install Sybase Un-
wired Platform, start
the Unwired Server
and Unwired Work-
Space, and create a
project.

• Installing Sybase Unwired Platform on page
9

• Installing Microsoft ActiveSync on page 10

• Starting Unwired Server on page 11

• Connecting to Sybase Control Center on page
11

• Starting Sybase Unwired WorkSpace on page
11

• (Optional) Learning the Basics on page 12

Note: These tutorials are prerequisites for all the other
tutorials. You need to perform them only once.

Developing a Device
Application Proto-
type

Create a Windows
device application
prototype and test it
in a device emulator.

• Creating the Device Application Prototype on
page 15

• Verifying and Generating Code for a Device Ap-
plication on page 17

• Running the Device Application on the Windows
Emulator on page 20

Task Flow
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Getting Started

Goal: Install and learn about Sybase Unwired Platform and its components.

Prerequisites
Before beginning this tutorial, complete the Tutorial: Mobile Business Object Development
(Eclipse).

Task

The following tasks are required, unless otherwise noted, for all tutorials, but you need to
perform them only once.

1. Installing Sybase Unwired Platform on page 9

2. Starting Unwired Server on page 11

3. (Optional) Connecting to Sybase Control Center on page 11.

4. Starting Sybase Unwired WorkSpace on page 11

5. (Optional) Learning the Basics on page 12

Installing Sybase Unwired Platform
Goal: Install Sybase Unwired Platform.

Install these Sybase Unwired Platform components:

• Unwired Server
• Sybase Unwired WorkSpace

• Mobile Business Object Developer Tools
• Device Application Developer Tools

If the Unwired Platform is already installed and any of these components are missing:

1. Start the Sybase Unwired Platform installer.
2. Follow the instructions in the installation wizard. When prompted, select Custom Install.
3. Select the required components, and complete the installation.

For complete installation instructions, see the Sybase Unwired Platform Installation Guide
and Release Bulletin on Product Manuals. Access http://sybooks.sybase.com/nav/base.do,
and navigate to Sybase Unwired Platform.

Getting Started
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Installing Microsoft ActiveSync
Goal: Install and configure Microsoft ActiveSync so you can deploy and run a mobile
application on a Windows Mobile emulator.

Note: Microsoft ActiveSync is for Windows XP. If you are using Windows Vista, Windows 7,
or Windows 2008, install Virtual PC 2007 SP1 and Windows Mobile Device Center to manage
synchronization settings. Download the Windows Mobile Device Center from http://
www.microsoft.com/windowsmobile/en-us/downloads/microsoft/device-center-
download.mspx.

1. Download Microsoft ActiveSync from http://www.microsoft.com/windowsmobile/en-
us/help/synchronize/device-synch.mspx. Save it to your local machine. Windows XP
requires ActiveSync version 4.5.

2. In Windows Explorer, double-click setup.msi.

3. When installation is complete, restart your machine.

ActiveSync starts automatically, and its icon appears in the Windows toolbar.

4. Double-click the ActiveSync icon.

5. Select File > Connection Settings.

6. Select Allow Connections to One of the Following, then select DMA.

7. Under This Computer is Connected to, select Work Network.

8. Click OK.

Getting Started
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Starting Unwired Platform Services
Goal: Start Unwired Server and the sample database.

In Windows, select Start > Programs > Sybase > Unwired Platform<version>  > Start
Unwired Platform Services .

Connecting to Sybase Control Center
Goal: Open the Web-based Sybase Control Center administration console to manage
Unwired Server and its components.

From Sybase Control Center, you can:

• View servers and their status
• Start and stop a server
• View server logs
• Deploy a mobile application package
• Set role mappings

1. Select Start > Programs > Sybase > Sybase Control Center.

Note: If Sybase Control Center does not launch, make sure that the Sybase Unified Agent
service is started. See the Installation Guide for details.

2. Log in using the default login:

• User Name – supAdmin

• Password – s3pAdmin

Logging in to Sybase Control Center (SCC) allows you access to Unwired Platform
administration features that you have been authorized to use. Administrators of any
Sybase product can log into SCC. However, only users assigned to the Super
Administrator or Domain Administrator roles for Unwired Platform can log in to Unwired
Server from Sybase Control Center.

Logging in to SCC only allows you access to the SCC interface. If Unwired Server has not
been authenticated, you will not be able to see or administer any resources.

3. Select Help > Online Documentation  for additional information on configuring,
managing, and monitoring Unwired Server.

Starting Sybase Unwired WorkSpace
Goal: Start Unwired WorkSpace.

Getting Started
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1. In Windows, select Start > Programs > Sybase > Unwired Platform<version> >
Unwired WorkSpace.

Sybase Unwired WorkSpace opens, and displays the Welcome page with links to product
information, and to the product.

2. To read more about Sybase Unwired WorkSpace concepts and tasks, select Help > Help
Contents from the main menu.

Learning the Basics
Goal: Learn about Sybase Unwired WorkSpace and how to access help.

Prerequisites
Start Unwired WorkSpace.

Task

1. From the Welcome page, select any of the links to familiarize yourself with the Unwired
WorkSpace environment.

To close this page, click the X. You can reopen this page by selecting Help > Welcome.

2. Select Start Development  to access the Sybase Unwired WorkSpace development
environment. Look at the area (window or view) that you will be working in to access,
create, define, and update mobile business objects (MBOs).

View Description

WorkSpace Navigator This view displays mobile application project fold-
ers, each of which contains all project-related re-
sources in subfolders, including MBOs, data source
references to which the MBOs are bound, personal-
ization keys, and so on.

Use this view to review and modify MBO-related
properties.

Enterprise Explorer A window that provides functionality to connect to
various enterprise back-end systems; for example,
database servers, SAP servers, and Sybase Unwired
Server.

Getting Started
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View Description

Mobile Application Diagram A graphical editor where you create and define mo-
bile business objects.

Use the Mobile Application Diagram to create
MBOs (including attributes and operations), then
define relationships with other MBOs. You can:

• Create MBOs in the Mobile Application Dia-
gram using Palette icons and menu selections –
either bind or defer binding to a data source,
when creating an MBO. For example, you may
want to model your MBOs before creating the
data sources to which they bind. This is some-
times called the top-down approach.

• Drag items from Enterprise Explorer and drop
them onto the Mobile Application Diagram to
create the MBO – quickly creates the operations
and attributes automatically based on the data
source being dropped on the Mobile Application
Diagram. This is sometimes called the bottom-
up approach.

Each new mobile application project generates an
associated Mobile Application Diagram.

Palette Access the Palette from the Mobile Application Di-
agram. It provides controls, such as the ability to
create MBOs, add attributes and operations, and de-
fine relationships, by dragging and dropping the
corresponding icon onto the Mobile Application Di-
agram or existing MBO.

Properties view Select an object in the Mobile Application Diagram
to display and edit its properties in the Properties
view. You cannot create an MBO from the Properties
view, but generally, most development and configu-
ration is performed here.

Outline view Displays an outline of the file that is currently open in
the editor area, and lists structural elements. The
contents are editor-specific.

Problem view Displays problems, errors, or warnings that you may
encounter.

3. To access the online help, select Help  > Help Contents from the main menu bar.

Getting Started
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4. Expand any of the documents that appear in the left pane. Some documents are for Sybase
Unwired Platform, while others are for the Eclipse development environment.

Getting Started
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Developing a Device Application Prototype

Goal: Develop a Windows device application prototype, and test its functionality.

Prerequisites

• Complete Tutorial: Mobile Business Object Development.
• Both the Windows Mobile 6 Standard SDK and the Windows Mobile 6 Professional SDK

must be installed if you want to use the Mobile Windows 6.0 Standard or Professional
Edition Emulator. You can download them from the http://www.microsoft.com/
downloads/details.aspx?familyid=06111A3A-
A651-4745-88EF-3D48091A390B&displaylang=en#AdditionalInfo.

• Install Microsoft synchronization software. If you are using Windows Vista, Windows
2008, or Windows 7, use the Windows Mobile Device Center to manage synchronization
settings. Microsoft ActiveSync is for Windows XP.

Task

A device application can communicate with mobile business objects that have been deployed
to Unwired Server.

1. Open the SUP101 mobile application project if it is not already open:

In WorkSpace Navigator, right-click the SUP101 folder and select Open in Diagram
Editor.

2. Creating the Device Application Prototype on page 15.

3. Verifying and Generating Code for a Device Application on page 17.

4. Running the Device Application on the Windows Emulator on page 20.

Creating the Device Application Prototype
Goal: Create the user interface for a prototype application that runs on a Windows Mobile
device, and accesses database mobile business objects.

Prerequisites

Complete the Tutorial: Mobile Business Object Development.

Task

1. Verify that the Device Application Designer Preferences are set to the default settings.

Developing a Device Application Prototype
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a) From the main menu, select Window > Preferences.
The Preferences window appears.

b) Select Sybase, Inc. > Mobile Development > Device Application Designer.
c) (Optional) If the default settings were changed, click Restore Defaults.
d) Click OK.

2. In WorkSpace Navigator, right-click the SUP101 Mobile Application Project folder you
created in Tutorial: Mobile Business Object Development (Eclipse) and select Create
Device Application Designer.
The New Device Application Designer wizard appears.

3. Complete the following:

a) In Parent Folder, select SUP101.
b) In File Name, enter custinfo.bob.

c) In Platform Device, select Windows Mobile/Windows Mobile Professional.
d) From the Connection Profile drop-down list, select My Unwired Server.
e) Click Finish.

The Device Application Designer opens and creates the device application screens and
connections.

The Start icon is connected to the first screen (Login) and the screens for the mobile
business object operations and relationships are automatically created.

Developing a Device Application Prototype
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4. Double-click the customer screen to view the screen layout.

The Menu and Table Context on the right shows the table context and menu items for the
screen. You can customize the screen layout, style, menu items, controls, and so on. This
tutorial uses the default style.

The decorators that display to the right of the menu items show that an action is assigned to
the menu item. Clicking the decorator allows you to edit or remove the assigned action.

5. Select File > Save.

Verifying and Generating Code for a Device Application
Goal: Generate client code for the mobile application project, so you can develop the device
application and test it on a Windows Mobile emulator.

1. In the Device Application Designer toolbar, click the Verify icon  to verify the device
application code.

If there are errors, they display in the Problems view. Errors must be fixed before
generating the code.

2. Once you have verified the device application, in the Device Application Designer toolbar,

click the Generate Device Application icon .

The Generate Device Application Wizard launches.

3. Accept the defaults and click Next.

4. In the second page of the Generate Device Application Wizard, in Target Device, select
Windows Mobile 5.0 Pocket PC SDK, and keep the defaults for the rest of the Code
Generation settings.

5. Expand the Advanced section and select Deploy to an Activesync connected device or
emulator and accept the default entries for the other settings.

The Create a shortcut in Programs option is selected by default, and the shortcut name is
automatically filled in.

6. Click Start Device Emulator Manager if it is not already running.

Developing a Device Application Prototype
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7. In the Device Emulator Manager, right-click Windows Mobile 5.0 Pocket PC R2
Emulator, and select Connect.

8. Right-click the same emulator, and select Cradle.

Developing a Device Application Prototype
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The Synchronization Setup Wizard appears.

9. In the Synchronization Setup Wizard, click Cancel.

ActiveSync connects to the device emulator.

10. Configure the way the device emulator connects to the Internet:

a) In the device emulator, select Start > Settings.
b) Select the Connections tab, then click Connections.
c) Select the Advanced tab, then click Select Networks.
d) Under "Programs that automatically connect to the Internet should connect using,"

select My Work Network, then click OK.
e) Click OK, then click X.

Developing a Device Application Prototype
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11. In the device application code generation wizard, click Finish.
The code generation wizard verifies the code, checks for a connected device, and compiles
the code in the specified location.

Running the Device Application on the Windows Emulator
Goal: Run the custinfo device application on the Windows Emulator.

1. Click the Start menu and select custinfo from the list.

2. In the Login screen, enter the login information and click Login in the lower right corner of
the emulator screen. Enter:

• Login – supAdmin

• Password – s3pAdmin

The initial screen for the custinfo application appears.

3. Click Synchronize.

4. In the Synchronizaton Group page, select default.

5. Click Menu and select Synchronize All.

Developing a Device Application Prototype
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6. When synchronization is complete, click Close.

7. Click Customer to see the customer information.

8. In the lower right corner of the emulator screen, click Menu.

The application menu shows the menu items that were shown when designing the device
application in the Device Application Designer and includes the Synchronize menu item
that you added.

9. Click sales_order. Notice how Unwired Platform automatically associates data based on
the relationships between mobile business objects, and the screens are automatically
created based on those relationships.

10. Click Back to return to the customer list.

11. Click the Menu key and select Update Customer.

12. In the fname and lname fields, change the name of the customer to Paula
Phillips.

Developing a Device Application Prototype
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13. In the lower right corner of the emulator screen, click Menu, then click Submit.

You return to the main customer list screen. Scroll down the customer list. The updated
record is shown at the bottom of the list.

14. To upload the name change to the back-end databasesampledb.sampledb, click the
Menu key, and select Synchronize Customer from the menu.

The Synchronization progress screen appears.

The Submit button on the update customer screen is mapped to the update operation of the
customer mobile business object. When the application is synchronized, any pending
operations are uploaded to Unwired Server, which then executes the UPDATE query
defined for the update operation of the customer mobile business object.

15. When the synchronization is complete, you return to the customer screen.

Developing a Device Application Prototype
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Learn More about Sybase Unwired Platform

Once you have finished, try some of the other samples or tutorials, or refer to other
development documents in the Sybase Unwired Platform documentation set.

Getting Started Tutorials
Try out some of the other getting started tutorials to get a broad view of the development tools
available to you.

Advanced Tutorials
Tutorials are available that demonstrate how to use some of Sybase Unwired Platform
advanced features.

Check the Sybase Web site regularly for updates. Navigate to Support > Product
Documentation > Sybase Unwired Platform, then select the most current version of the
document.

Samples
Sample applications are fully developed, working applications that demonstrate the features
and capabilities of Sybase Unwired Platform.

Check the Sybase Web site regularly for updates. Navigate to the Sybase Web site, then select
Products > Sybase Unwired Platform > Use tab: http://www.sybase.com/products/
mobileenterprise/sybaseunwiredplatform?htab=USE.

Online Help
See the online help that is installed with the product, or the Product Documentation Web site.

Check the Sybase Web site regularly for updates. Navigate to Support > Product
Documentation > Sybase Unwired Platform, then select the most current version of the
document.

Developer References
See the Developer References to learn about using the API to custom code device applications
using the API.

• Developer Reference for BlackBerry
• Developer Reference for iOS
• Developer Reference for Mobile Workflow Packages
• Developer Reference for Windows and Windows Mobile

Check the Sybase Web site regularly for updates. Navigate to Support > Product
Documentation > Sybase Unwired Platform, then select the most current version of the
document.

Learn More about Sybase Unwired Platform
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Javadocs are also available in the installation directory.

Programmer References
See the Programmer References to learn how to use the Administration API and Server API to
extend functionality.

• Reference: Administration APIs  – integrate your own administrative tools with Unwired
Platform to monitor and manage Unwired Platform.

• Reference: Custom Development for Unwired Server  – customize some Unwired Server
features.

Check the Sybase Web site regularly for updates. Navigate to Support > Product
Documentation > Sybase Unwired Platform, then select the most current version of the
document.

Javadocs are also available in the installation directory.

Learn More about Sybase Unwired Platform
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