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Introduction to Getting Started Tutorials

Getting started tutorials enable users of all levels to try Sybase® Unwired Platform with
minimal setup. You can also use the tutorials to demonstrate system functionality and train
users.

Overview of Getting Started Tutorials
The getting started tutorials demonstrate how to develop, deploy, and test mobile business
objects, device applications, and message-based mobile workflow packages.

• Learn mobile business object (MBO) basics, and create a mobile device application:
• Tutorial: Mobile Business Object Development
• Tutorial: BlackBerry Application Development using Device Application Designer
• Tutorial: Windows Mobile Device Application Development using Device

Application Designer
• Create native mobile device applications:

• Tutorial: BlackBerry Application Development using Custom Development
• Tutorial: iPhone Application Development using Custom Development
• Tutorial: Windows Mobile Application Development using Custom Development

• Create a mobile workflow package:
• Tutorial: Mobile Workflow Package Development

The getting started tutorials demonstrate a cross section of basic functionality, which includes
creating MBOs that can be used in replication-based or message-based synchronization; and
using various Sybase Unwired WorkSpace development tools, independent development
environments, and device types.

Table 1. Tutorial summary

Tutorials Mobile
business
objects
(MBOs)

Synchroni-
zation types

Development
tools

Device
types

Tutorial: Mobile Business Ob-
ject Development

Create new
MBOs

Replication-
based

Sybase Unwired
WorkSpace

N/A

Tutorial: BlackBerry Applica-
tion Development using De-
vice Application Designer

Reuse
MBOs

Replication-
based

Device Applica-
tion Designer

BlackBerry
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Tutorials Mobile
business
objects
(MBOs)

Synchroni-
zation types

Development
tools

Device
types

Tutorial: BlackBerry Applica-
tion Development using Cus-
tom Development

Create new
MBOs

Replication-
based

Sybase Unwired
WorkSpace

BlackBerry

Tutorial: iPhone Application
Development using Custom
Development

Create new
MBOs

Message-based Sybase Unwired
WorkSpace

iPhone

Tutorial: Windows Mobile
Application Development us-
ing Device Application De-
signer

Reuse
MBOs

Replication-
based

Device Applica-
tion Designer

Windows
Mobile

Tutorial: Windows Mobile
Device Application Develop-
ment using Custom Develop-
ment

Create new
MBOs

Message-based Sybase Unwired
WorkSpace

Windows
Mobile

Tutorial: Mobile Workflow
Package Development

Create new
MBOs

Message-based Mobile Workflow
Forms Editor

Windows
Mobile

Understanding the Unwired Platform Development
Environment

Learn more from the getting started tutorials by understanding basic development
environment concepts. Sybase Unwired Platform provides an Eclipse development
environment.

Development in Eclipse
Sybase Unwired WorkSpace is a plug-in to your Eclipse development environment that
provides tools for creating mobile applications.

Unwired WorkSpace includes back-end integration tools that connect Unwired Server to
enterprise data sources, allowing you to create mobile business objects (MBOs) from the
back-end business data model.

Developers can perform MBO code generation at any time and use this MBO model code
along with the user interface code that users write in a native integrated development
environment (IDE). This makes the code available to transition from the Unwired WorkSpace
MBO development tool to the fully extensible and open development environment provided
for device platforms from third-party vendors. Optionally, use the Device Application

Introduction to Getting Started Tutorials

  2 Sybase Unwired Platform  



Designer to create prototype device applications for BlackBerry and Windows Mobile
devices.

Developers can use the Mobile Workflow Forms Editor to develop message-based mobile
workflow packages for Windows Mobile and iOS devices.

Understanding Fundamental Mobile Development
Concepts

Learn more from the getting started tutorials by understanding basic mobile development
concepts.

Learn more about these concepts:

• Fundamentals
• Sybase Unwired WorkSpace – Mobile Business Object Development

Mobile Business Objects
Mobile business objects help form the business logic for mobile applications.

A mobile business object (MBO) is derived from a data source (such as a database server, Web
service, or SAP® server). MBOs are deployed to Unwired Server, and accessed from mobile
device application clients. MBOs include:

• Implementation-level details – metadata columns that include information about the data
from a data source.

• Abstract-level details – attributes that correspond to instance-level properties of a
programmable object in the mobile client, and map to data source output columns.
Parameters correspond to synchronization parameters on the mobile client, and map to
data source arguments. For example, output of a SQL SELECT query are mapped as
attributes, and the arguments in the WHERE clause are mapped as synchronization
parameters, so that the client can pass input to the query.
MBO operations include parameters that map to data source input arguments. Operation
parameters determine information a client passes to the enterprise information system
(EIS).

• Relationships – defined between MBOs by linking attributes and parameters in one MBO,
to attributes and parameters in another MBO.

You can define MBOs using either a top-down approach—first designing attributes and
parameters, then binding them to a data source; or a bottom-up approach—first specifying a
data source, then automatically generating attributes and parameters from it.

A mobile application package includes MBOs, roles, and data source connection mappings,
and other artifacts that are delivered to the Unwired Server during package deployment.

Introduction to Getting Started Tutorials
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Synchronization Methods
Developers can use either replication-based or message-based synchronization to move data
and transactions between device application clients and Unwired Server.

The choice depends on the target device platform, application requirements, target platform,
and the nature of data changes and activity between Unwired Server and clients, for example,
mobile workflow forms always use message-based synchronization.

Unwired Server manages and maintains data freshness between multiple data sources and
device application clients through synchronization.

Application Types
Sybase Unwired Platform supports two choices for application type. First is the native
application type, and the other is the container-based business workflow type.

The native application model enables the developer to write custom code (C#, Java, or
Objective-C, depending on the platform) to create a device application. The native application
model is supported on BlackBerry, iOS, Windows Mobile, and Windows platforms. The
choice depends on the functionality desired in the application, and the need to access third-
party and platform-provided APIs. Optionally, use the Device Application Designer to create
prototype device applications for BlackBerry and Windows Mobile devices.

The business workflow model offers a fast and simple way to build applications that support
simple business workflows, such as approvals and requests. The workflow model is supported
on iOS, Windows Mobile, and Windows platforms.

Data Sources
A data source is the enterprise information system where data is retrieved from and
transactions are executed. A connection profile is a design-time connection to a data source.
Connection profiles are created to specific data source by providing connection information
such as host, port, login, and password among others. The connection profiles are used to
define MBOs and operations, and mapped to existing, or used to create new, server
connections when the package is deployed to Unwired Server..

Unwired Platform hides the interaction complexity with datasource-specific protocols, such
as JDBC™ for database and SOAP for Web services.

Unwired Platform currently supports multiple EIS connection types. See Supported Third-
Party Software and Hardware for information.

Switching Between Developer Profiles
Switch between basic and advanced developer profiles in the Mobile Application Diagram.

If you do not see an Unwired WorkSpace feature (wizard, property, or WorkSpace Navigator
item) that you expect or need, switch to the advanced developer profile, or modify developer
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profile settings. To use backend data sources other than those supplied by Sybase Unwired
Platform, you must switch to the advanced developer profile to see the Server Connection
Mapping page when deploying the Mobile Business Object package.

1. Right-click in the Mobile Application Diagram and select Switch Developer Profile >
Basic/Advanced.

2. You can also select Window > Preferences > Sybase, Inc. > Mobile Development >
Developer Profile to directly view or modify the developer profile preference settings.
Basic is the default developer profile.

Introduction to Getting Started Tutorials
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Task Flow

This tutorial shows you how to use the Device Application Designer to create a device
application prototype for a BlackBerry device.

Table 2. Eclipse tutorials

Task Goals Steps required to complete the
task

Getting Started • Install all required WorkSpace
components and external re-
sources.

• Start Unwired Server.

• Open the Mobile Development
perspective, and become famil-
iar with the views of the per-
spective, the Mobile Applica-
tion Diagram, and the Device
Application Designer.

• Installing Sybase Unwired Platform
on page 9

• Starting Unwired Server on page
9

• Starting Sybase Unwired Work-
Space on page 10

• Learning the Basics on page 10

Note: These tasks are prerequisites for
all the other tutorials. You need to per-
form them only once.

Developing a De-
vice Application
Prototype

• Create a BlackBerry device ap-
plication prototype, and test it
on the BlackBerry Simulator.

• Installing the BlackBerry Java Plug-
in for Eclipse on page 13

• Creating the BlackBerry Device Ap-
plication Prototype on page 14

• Verifying and Generating Code for a
Device Application on page 17

• Adding Custom Code to the Gener-
ated Code on page 23

• Testing the Device Application on
the BlackBerry Simulator on page
24

Task Flow
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Getting Started

Goal: Install and learn about Sybase Unwired Platform and its associated components.

The following tasks are required, unless otherwise noted, for all tutorials, but you need to
perform them only once.

1. Installing Sybase Unwired Platform on page 9

2. Starting Unwired Platform Services on page 9

3. Starting Sybase Unwired WorkSpace on page 10

4. (optional) Learning the Basics on page 10

Installing Sybase Unwired Platform
Goal: Install Sybase Unwired Platform.

Install these Sybase Unwired Platform components:

• Data Tier
• Unwired Server
• Unwired WorkSpace
• Device Application Designer
• Windows Mobile .NET components (for developing device applications in Visual Studio)

If Unwired Platform is already installed and any of these components are missing:

1. Start the Sybase Unwired Platform installer.
2. Follow the instructions in the installation wizard.
3. Select the required components, and complete the installation.

For complete installation instructions, see the Sybase Unwired Platform Installation Guide
and Release Bulletin.

Starting Unwired Platform Services
Goal: Start Unwired Server and the sample database.

In Windows, select Start > Programs > Sybase > Unwired Platform<version>  > Start
Unwired Platform Services .

Getting Started
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Starting Sybase Unwired WorkSpace
Goal: Start Unwired WorkSpace.

1. In Windows, select Start > Programs > Sybase > Unwired Platform<version> >
Unwired WorkSpace.

Sybase Unwired WorkSpace opens, and displays the Welcome page with links to product
information, and to the product.

2. To read more about Sybase Unwired WorkSpace concepts and tasks, select Help > Help
Contents from the main menu.

Learning the Basics
Goal: Learn about Sybase Unwired WorkSpace and how to access help.

Prerequisites
Start Unwired WorkSpace.

Task

1. From the Welcome page, select any of the links to familiarize yourself with the Unwired
WorkSpace environment.

To close this page, click the X. You can reopen this page by selecting Help > Welcome.

2. Select Start Development  to access the Sybase Unwired WorkSpace development
environment. Look at the area (window or view) that you will be working in to access,
create, define, and update mobile business objects (MBOs).

View Description

WorkSpace Navigator This view displays mobile application project fold-
ers, each of which contains all project-related re-
sources in subfolders, including MBOs, data source
references to which the MBOs are bound, personal-
ization keys, and so on.

Use this view to review and modify MBO-related
properties.

Getting Started
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View Description

Enterprise Explorer A window that provides functionality to connect to
various enterprise back-end systems; for example,
database servers, SAP servers, and Sybase Unwired
Server.

Mobile Application Diagram A graphical editor where you create and define mo-
bile business objects.

Use the Mobile Application Diagram to create
MBOs (including attributes and operations), then
define relationships with other MBOs. You can:

• Create MBOs in the Mobile Application Dia-
gram using Palette icons and menu selections –
either bind or defer binding to a data source,
when creating an MBO. For example, you may
want to model your MBOs before creating the
data sources to which they bind. This is some-
times called the top-down approach.

• Drag items from Enterprise Explorer and drop
them onto the Mobile Application Diagram to
create the MBO – quickly creates the operations
and attributes automatically based on the data
source being dropped on the Mobile Application
Diagram. This is sometimes called the bottom-
up approach.

Each new mobile application project generates an
associated Mobile Application Diagram.

Palette Access the Palette from the Mobile Application Di-
agram. It provides controls, such as the ability to
create MBOs, add attributes and operations, and de-
fine relationships, by dragging and dropping the
corresponding icon onto the Mobile Application Di-
agram or existing MBO.

Properties view Select an object in the Mobile Application Diagram
to display and edit its properties in the Properties
view. You cannot create an MBO from the Properties
view, but generally, most development and configu-
ration is performed here.

Getting Started
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View Description

Outline view Displays an outline of the file that is currently open in
the editor area, and lists structural elements. The
contents are editor-specific.

Problem view Displays problems, errors, or warnings that you may
encounter.

3. To access the online help, select Help  > Help Contents from the main menu bar.

4. Expand any of the documents that appear in the left pane. Some documents are for Sybase
Unwired Platform, while others are for the Eclipse development environment.

Getting Started
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Developing a BlackBerry Device Application
Prototype

Develop a BlackBerry device application prototype, and test its functionality.

Prerequisites
Complete the Tutorial: Mobile Business Object Development.

Task

The device application communicates with the database mobile business objects that are
deployed to Unwired Server.

1. If the SUP101 Mobile Application Project is not already open, in WorkSpace Navigator,
right-click the SUP101 folder and select Open in Diagram Editor.

2. Install the BlackBerry Java Plug-in for Eclipse.

3. Create the BlackBerry device application as described in Creating the BlackBerry Device
Application Prototype on page 14.

4. Verify the device application and generate the code as shown in Verifying and Generating
Code for a Device Application on page 17.

5. Add custom code to the generated file as shown in Adding Custom Code to the Generated
Code on page 23.

6. Run and test the application on the BlackBerry Simulator as shown in Testing the Device
Application on the BlackBerry Simulator on page 24.

Installing the BlackBerry Java Plug-in for Eclipse
The Device Application Designer supports the BlackBerry Java Plug-in for Eclipse, which
allows you to generate the device application code using the Device Application Designer
code generation wizard, then debug the generated code.

Prerequisites
You must have a BlackBerry developer account to download the BlackBerry Java Plug-in for
Eclipse. You may be required to register if you do not already have an account.

Task

Note: To ensure that you are using the supported version of the BlackBerry Java Plug-in for
Eclipse, see the topic Sybase Unwired Platform 1.5.5 > New Features > Supported Hardware
and Software.

Developing a BlackBerry Device Application Prototype
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1. Shut down Unwired WorkSpace.

2. Go to http://us.blackberry.com/developers/javaappdev/ and download the BlackBerry
Java Plug-in for Eclipse (full installer) to a temporary folder.

3. Double-click the setup application file.

4. On the Introduction page, click Next.

5. Accept or decline the terms of the license agreement and click Next.

6. Choose <UnwiredPlatform_InstallDir>\UnwiredPlatform\Eclipse
as the installation directory and click Next.

7. Review the information on the Pre-installation Summary screen and click Install.

8. Click Done.

Creating the BlackBerry Device Application Prototype
Goal: Create the user interface for a prototype application that runs on a BlackBerry device,
and accesses database mobile business objects.

Prerequisites

Create the SUP101 Mobile Application Project by completing the Tutorial: Mobile Business
Object Development.

Task

1. Verify that the Device Application Designer Preferences are set to the default settings.

a) From the main menu, select Window > Preferences.
b) Select Sybase, Inc. > Mobile Development > Device Application Designer.
c) If the default settings have been changed, click Restore Defaults.
d) Click OK.

2. In WorkSpace Navigator, right-click the SUP101 Mobile Application Project folder and
select Create Device Application Designer.

3. In the New Device Application Designer wizard, complete these fields:

a) In Parent Folder, select SUP101.
b) In File Name, enter custinfo.

c) In Platform Device, select the BlackBerry device for which you are developing the
application.

d) Select My Unwired Server as the connection profile.
e) Click Finish.

The Device Application Designer opens and creates the device application screens and
connections.

Developing a BlackBerry Device Application Prototype
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The Start icon is connected to the first screen (Login) and the screens for the mobile
business object operations and relationships are automatically created.

4. Double-click the Create Customer screen under the Customer screen.

The Screen Design page appears. The Menu on the right shows the context menu items for
the screen. In the Screen Design page, you can customize the screen layout, style, menu
items, controls, and so on. This tutorial uses the default style.

The decorators to the right of the menu items show that an action is assigned to the menu
item. Clicking the decorator allows you to edit the assigned action.

Developing a BlackBerry Device Application Prototype
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5. In the Properties view, click Display > Platform-specific.

If the Properties view is not open, right-click in the Screen Design page, and select Show
Properties View.

6. Select Generate a custom coding subclass to make the value true.

7. On the Create Customer screen, click on the phone edit box to select it.

Developing a BlackBerry Device Application Prototype
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8. In the Properties view, click Edit Box, then click the Coding tab.

9. In Base name, enter phoneNumber.

10. Select File > Save.

Verifying and Generating Code for a Device Application
Goal: Generate code for the BlackBerry device application, then debug it in Eclipse.

Prerequisites
Installing the BlackBerry Java Plug-in for Eclipse on page 13

Task

1. In the Device Application Designer toolbar, click the Verify icon  to verify the device
application design.

Developing a BlackBerry Device Application Prototype

Tutorial: BlackBerry Application Development using Device
Application Designer  

  17



If any errors appear, you must fix them before you can generate the code.

2. Once you have verified the device application, in the Device Application Designer toolbar,

click the Generate Device Application icon .

3. Accept the defaults by clicking Next.

4. In the second page of the Generate Device Application wizard, select Debug the
BlackBerry application with BlackBerry Java plug-in.

5. Next to Client project, click New.

6. In the New BlackBerry Project wizard:

a) Enter: SUP101_bb_client as the project name.

b) Select Use a project specific JRE, then choose BlackBerry JRE 4.5.0 from the list.

In this tutorial, you select BlackBerry JRE 4.5.0 because that is the JRE that contains
the files for the BlackBerry 8800 Simulator the tutorial uses. The JRE specified should
be one that contains the BlackBerry Simulator you want to use for your project.

Developing a BlackBerry Device Application Prototype
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c) Click Finish.
You are returned to the Generate BlackBerry Application wizard.

7. Next to Options project, click New.

8. In the New BlackBerry Project wizard:

a) Enter: SUP101_bb_options as the project name.

b) Select Use a project specific JRE, then choose BlackBerry JRE 4.5.0 from the list.

In this tutorial, you select BlackBerry JRE 4.5.0 because that is the JRE that contains
the files for the BlackBerry 8800 Simulator the tutorial uses. The JRE specified should
be one that contains the BlackBerry Simulator you want to use for your project.

c) Click Finish.

9. Select Launch the BlackBerry project and click Configure.
The Debug Configurations dialog opens.

Developing a BlackBerry Device Application Prototype
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10. In the left pane, right-click BlackBerry Simulator and select New.

11. Enter SUP101_launch as the launch configuration name.

12. In the Projects tab, select the SUP101_client and SUP101_options projects.

13. Click the Simulator tab.

14. Select Launch Mobile Data System Connection Service (MDS-CS) with simulator
and select BlackBerry-SDK-8800 as the device.

Developing a BlackBerry Device Application Prototype
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15. Click Apply.

16. Click Close.

17. In the New Device Application Designer Generation wizard, click Finish.

Developing a BlackBerry Device Application Prototype

Tutorial: BlackBerry Application Development using Device
Application Designer  

  21



After clicking Finish:
• The Launch window appears and shows the progress.
• The Console view opens.
• The MDS starts.
• The BlackBerry Simulator launches.

18. Close the BlackBerry Simulator.

19. Close the custinfo application.

Developing a BlackBerry Device Application Prototype
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Adding Custom Code to the Generated Code
Goal: Add a simple custom coded event and debug the code using the BlackBerry Java Plug-in
for Eclipse.

Prerequisites
Complete Verifying and Generating Code for a Device Application on page 17.

Task

1. Open the Java perspective:

a) From the main menu select Window > Open Perspective > Other.
b) Select Java and click OK.

2. In Package Explorer, expand the SUP101_bb_client folder, then expand the custom
folder.

3. Open the BOBScreenCreate_CustomerCustom.java file and add this code in
the method protected void configureControlById(int ID):

Developing a BlackBerry Device Application Prototype
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case BOBPHONENUMBER:
  //Lets do some custom code here..
  //We'll add a validator. This validator is just checking that the 
string applies
  //a pattern match and passing in a REGULAR Expression
  Vector phoneNumValidatorVector = new Vector();
  phoneNumValidatorVector.addElement(
    new Validator(Validator.VALIDATION_TYPE_PATTERN_MATCH,
    Validator.PATTERN_MATCH_SUBTYPE_MATCHES_REGULAR_EXPRESSION,
      "[0-9][0-9][0-9]-[0-9][0-9][0-9]-[0-9][0-9][0-9][0-9]",
      "Enter a valid value of type 111-111-1111"));
  bobphoneNumber.setValidators(phoneNumValidatorVector);
  super.configureControlById(ID);
  break;

This custom code validates that input in the phone number field is in the ###-###-####
format.

4. Select File > Save.

Testing the Device Application on the BlackBerry Simulator
Goal: Run and test the custinfo device application on the BlackBerry 8800 Simulator.

This tutorial shows the device application running on the BlackBerry 8800 Simulator. The
navigation features of the BlackBerry 8800 Simulator include:

• The trackball functions as an Enter button. Use the scroll button to simulate rolling the
trackwheel. If you do not have a scroll button, use the up and down arrow keys on your
keyboard to scroll.

• Click the menu key to access the applications screen.
• The simulator automatically turns the LCD display off after a certain length of time. Keep

the LCD display on by selecting View > Keep LCD On.

1. In the Java perspective, select Run > sup101_launch.

2. When the simulator launches, you can run the Setup Wizard, or scroll to Don't Ask Me
Again, and click the trackball.

3. Click the menu key to access the applications screen.

4. Scroll to locate the custinfo device application, and click the trackball to open it.

Developing a BlackBerry Device Application Prototype
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5. In the Login screen, enter:

• Login – supAdmin

• Password – s3pAdmin

6. Click Login.

The table of contents appears.

7. Scroll to Synchronize and click the trackball to open the Synchronize screen.

8. In the Synchronize screen, select the SUP101 package, click the simulator menu key, and
select Synchronize Package.

Developing a BlackBerry Device Application Prototype
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9. Click the Escape key on the simulator to return to the table of contents.

10. From the table of contents, select Customer and click the trackball.

11. Select a row in the Customer table, and click the simulator menu key.

The application menu shows the menu items that were shown when designing the device
application in the Device Application Designer.

12. Scroll down the menu items, and select sales_order. Notice how Unwired Platform
automatically associates data based on the relationships between mobile business objects,
and the screens are automatically created based on those relationships.

13. Click the Escape key to return to the customer list.

14. Click the simulator menu key, and from the "Sort on column" menu, select id and click the
trackball.

Now the customer list is arranged to show customers in ID order.

15. Select a row in the table, click the simulator menu key and scroll down to select Create
Customer and click the trackball.

16. In the Create Customer screen, enter:

• id: 999915

• fname: Benny

• lname: Olsson

• Enter an address, city, state, and zip.
• phone: abc

17. Leave the cursor in the phone edit box, and use the arrow keys on your keyboard to scroll
down the customer record.

You receive an error that tells you to enter the phone number using a valid value format.

18. Reenter the phone number in the correct format: 201-555-8966, and scroll down using
the arrows on your keyboard.

There is no error now.

19. Click the simulator menu key, select Submit, and click the trackball.

Developing a BlackBerry Device Application Prototype
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You return to the main customer list screen. The new record is shown at the bottom of the
list.

20. To upload the new record to the back-end database sampledb, click the Menu key, and
select Synchronize Customer from the menu.

The Submit button on the Create Customer screen is mapped to the create operation of the
customer mobile business object. When the application is synchronized, any pending
operations are uploaded to Unwired Server, which then executes the CREATE query
defined for the create operation of the customer mobile business object.

When the synchronization is complete, you return to the customer screen.

Developing a BlackBerry Device Application Prototype
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Learn More about Sybase Unwired Platform

Once you have finished, try some of the other samples or tutorials, or refer to other
development documents in the Sybase Unwired Platform documentation set.

Getting Started Tutorials
Try out some of the other getting started tutorials to get a broad view of the development tools
available to you.

Advanced Tutorials
Tutorials are available that demonstrate how to use some of Sybase Unwired Platform
advanced features.

Check the Sybase Web site regularly for updates. Navigate to Support > Product
Documentation > Sybase Unwired Platform, then select the most current version of the
document.

Samples
Sample applications are fully developed, working applications that demonstrate the features
and capabilities of Sybase Unwired Platform.

Check the Sybase Web site regularly for updates. Navigate to the Sybase Web site, then select
Products > Sybase Unwired Platform > Use tab: http://www.sybase.com/products/
mobileenterprise/sybaseunwiredplatform?htab=USE.

Online Help
See the online help that is installed with the product, or the Product Documentation Web site.

Check the Sybase Web site regularly for updates. Navigate to Support > Product
Documentation > Sybase Unwired Platform, then select the most current version of the
document.

Developer References
See the Developer References to learn about using the API to custom code device applications
using the API.

• Developer Reference for BlackBerry
• Developer Reference for iOS
• Developer Reference for Mobile Workflow Packages
• Developer Reference for Windows and Windows Mobile

Check the Sybase Web site regularly for updates. Navigate to Support > Product
Documentation > Sybase Unwired Platform, then select the most current version of the
document.

Learn More about Sybase Unwired Platform
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Javadocs are also available in the installation directory.

Programmer References
See the Programmer References to learn how to use the Administration API and Server API to
extend functionality.

• Reference: Administration APIs  – integrate your own administrative tools with Unwired
Platform to monitor and manage Unwired Platform.

• Reference: Custom Development for Unwired Server  – customize some Unwired Server
features.

Check the Sybase Web site regularly for updates. Navigate to Support > Product
Documentation > Sybase Unwired Platform, then select the most current version of the
document.

Javadocs are also available in the installation directory.

Learn More about Sybase Unwired Platform
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