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Sybase Unwired Platform Tutorials

The Sybase® tutorials demonstrate how to develop, deploy, and test mobile business objects,
device applications, online mobile applications (native OData and REST services based), and
Hybrid App packages. You can also use the tutorials to demonstrate system functionality and
train users.

• Learn mobile business object (MBO) basics, and use this tutorial as a foundation for the
Object API application development tutorials:
• Tutorial: Mobile Business Object Development

Note: For all Object API tutorials, if you opt to use the Mobile Business Object
example project instead of performing the Mobile Business Object Tutorial, you must
deploy the mobile application project to Unwired Server as a prerequisite.

• Create native Object API mobile device applications:
• Tutorial: Android Object API Application Development
• Tutorial: BlackBerry Object API Application Development
• Tutorial: iOS Object API Application Development
• Tutorial: Windows Object API Application Development
• Tutorial: Windows Mobile Object API Application Development

• Create a mobile business object, then develop a hybrid app package that uses it:
• Tutorial: Hybrid App Package Development

• Create an OData mobile application with REST Services
• Tutorial: Android OData Application Development with REST Services
• Tutorial: iOS OData Application Development with REST Services

Sybase Unwired Platform Tutorials
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Getting Started with Unwired Platform

Install and learn about Sybase Unwired Platform and its associated components.

Complete the following tasks for all tutorials, but you need to perform them only once.

1. Installing Sybase Unwired Platform

Install Sybase Mobile SDK and Unwired Platform Runtime.

2. Starting Sybase Unwired Platform Services

Start Unwired Server, Sybase Control Center, the sample database, the cache database
(CDB), and other essential services.

3. Starting Sybase Unwired WorkSpace

Start the development environment, where you can create mobile business objects
(MBOs), manage enterprise information system (EIS) datasources and Unwired Server
connections, develop Hybrid App applications (Hybrid Apps), and generate Object API
code.

4. Connecting to Sybase Control Center

Open Sybase Control Center to manage Unwired Server and its components.

5. Learning Sybase Unwired WorkSpace Basics

Sybase Unwired WorkSpace features are well integrated in the Eclipse IDE. If you are
unfamiliar with Eclipse, you can quickly learn the basic layout of Sybase Unwired
WorkSpace and the location of online help.

Installing Sybase Unwired Platform
Install Sybase Mobile SDK and Unwired Platform Runtime.

Before starting this tutorial, install all the requisite Unwired Platform components. See the
Sybase Unwired Platform documentation at http://sybooks.sybase.com:

• Release Bulletin
• Installation Guide for Sybase Mobile SDK
• Installation Guide for Runtime

1. Install these Unwired Platform Runtime components:

• Data Tier (included with single-server installation)
• Unwired Server

2. Install Mobile SDK, which includes:

Getting Started with Unwired Platform
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• Development support for native Object API applications, HTML5/JS Hybrid Apps,
and native OData SDK applications.

• Sybase Unwired WorkSpace, the Eclipse-based development environment for MBOs
and Hybrid Apps.

Starting Sybase Unwired Platform Services
Start Unwired Server, Sybase Control Center, the sample database, the cache database (CDB),
and other essential services.

The way in which you start Unwired Platform Services depends on the options you selected
during installation. You may need to manually start Unwired Platform Services.
Select Start > (All) Programs > Sybase > Unwired Platform > Start Unwired Platform
Services.
The following services will be started:
• Sybase Control Center <Version>
• Sybase Unwired Cache DB
• Sybase Unwired SampleDB
• Sybase Unwired Server
Unwired Platform Services enable you to access the Unwired Platform runtime components
and resources.

Note: The Unwired Platform installer creates the Windows service (Unwired Platform
Sample DB) that runs the sampledb server only when you install Unwired Server with a
Personal or Enterprise Development license. If you installed Unwired Server with an
Enterprise Server (production) license, you must create this service using the
sampledb.bat command line utility. See Create or Remove the Windows Service for
sampledb Server (sampledb) Utility in System Administration for more information about
using this command line utility.

Starting Sybase Unwired WorkSpace
Start the development environment, where you can create mobile business objects (MBOs),
manage enterprise information system (EIS) datasources and Unwired Server connections,
develop Hybrid App applications (Hybrid Apps), and generate Object API code.
Select Start > Programs > Sybase > Unwired Platform > Sybase Unwired WorkSpace.
The Sybase Unwired WorkSpace opens in the Mobile Development perspective. The
Welcome page displays links to the product and information.

Next
To read more about Sybase Unwired WorkSpace concepts and tasks, select Help > Help
Contents.
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Connecting to Sybase Control Center
Open Sybase Control Center to manage Unwired Server and its components.

From Sybase Control Center, you can:

• View servers and their status
• Start and stop a server
• View server logs
• Deploy a mobile application package
• Register application connections
• Set role mappings
• Assign/Unassign a hybrid application to a device

For information on configuring, managing, and monitoring Unwired Server, click Help >
Online Documentation.

1. Select Start > Programs > Sybase > Sybase Control Center.

Note: If Sybase Control Center does not launch, make sure that the Sybase Control Center
service is started in the Windows Services dialog.

2. Log in by entering the credentials set during installation.

Sybase Control Center gives you access to the Unwired Platform administration features
that you are authorized to use.

Learning Sybase Unwired WorkSpace Basics
Sybase Unwired WorkSpace features are well integrated in the Eclipse IDE. If you are
unfamiliar with Eclipse, you can quickly learn the basic layout of Sybase Unwired WorkSpace
and the location of online help.

• To access the online help, select Help  > Help Contents. Some documents are for Sybase
Unwired Platform, while others are for the Eclipse development environment.

• The Welcome page provides links to useful information to get you started.
• To close the Welcome page, click X.
• Reopen the Welcome page by selecting Help > Welcome.
• To learn about tasks you must perform, select the Development Process icon.

• In Sybase Unwired WorkSpace, look at the area (window or view) that you will use to
access, create, define, and update mobile business objects (MBOs).

Getting Started with Unwired Platform
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Window Description

WorkSpace Navigator view Use this view to create Mobile Application projects,
and review and modify MBO-related properties.

This view displays mobile application project fold-
ers, each of which contains all project-related re-
sources in subfolders, including MBOs, datasource
references to which the MBOs are bound, personal-
ization keys, and so on.

Enterprise Explorer view A view that provides functionality to connect to var-
ious enterprise information systems (EIS), such as
database servers, SAP® back ends, and Unwired
Server.

Mobile Application Diagram The Mobile Application Diagram is a graphical ed-
itor where you create and define mobile business
objects.

Use the Mobile Application Diagram to create
MBOs (including attributes and operations), then
define relationships with other MBOs. You can:

• Create MBOs in the Mobile Application Dia-
gram using Palette icons and menu selections –
either bind or defer binding to a datasource,
when creating an MBO. For example, you may
want to model your MBOs before creating the
datasources to which they bind. This MBO de-
velopment method is sometimes referred to as
the top-down approach.

• Drag and drop items from Enterprise Explorer to
the Mobile Application Diagram to create the
MBO – quickly creates the operations and at-
tributes automatically based on the datasource
artifact being dropped on the Mobile Applica-
tion Diagram.

Each new mobile application project generates an
associated mobile application diagram.

Getting Started with Unwired Platform
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Window Description

Palette The Palette is accessed from the Mobile Application
Diagram and provides controls, such as the ability to
create MBOs, add attributes and operations, and de-
fine relationships, by dragging and dropping the
corresponding icon onto the Mobile Application Di-
agram or existing MBO.

Properties view Select an object in the Mobile Application Diagram
to display and edit its properties in the Properties
view. While you cannot create an MBO from the
Properties view, most development and configura-
tion is performed here.

Outline view Displays an outline of the active file and lists struc-
tural elements. The contents are editor-specific.

Problems view Displays validation errors or warnings that you may
encounter in addition to errors in the Diagram editor
and Properties view. Follow warning and error mes-
sages to adjust MBO properties and configurations
to avoid problems, and use as a valuable source for
collecting troubleshooting information when report-
ing issues to Customer Service and Support.

Error Log view Displays error log information. This is a valuable
source for collecting troubleshooting information.

Getting Started with Unwired Platform
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Developing Database Mobile Business
Objects

Develop two samples of mobile business objects to see how they form the business logic for
mobile applications. Create two mobile business objects, each using a database as its
datasource, create a relationship between the two MBOs, and deploy them to Unwired Server.
Use the deployed project in the Object API application development tutorials.

Prerequisites

Note: This tutorial was created using Sybase Unwired Platform 2.2 SP02. If you are using a
version of Unwired Platform other than 2.2 SP02, the steps and results in this tutorial may
vary.

• Complete the tasks in Getting Started with Unwired Platform.
• (Optional) To use as a reference and copy source code when completing this tutorial,

download the MBO SUP101 example project (complete project files) for the MBO tutorial
from the SAP® Community Network: http://scn.sap.com/docs/DOC-8803

Important: When you complete this tutorial, save the MBO project; you need it to complete
the Object API tutorials.

Task
Develop the database mobile business objects by completing the following tasks, in order.
Each task has its own section with descriptions and detailed steps for you to create and deploy
a project.

1. Connecting to the Sample Database

Use the default database connection profile to test and connect to the sample database.

2. Creating the SUP101 Mobile Application Project

Create a mobile application project to store the mobile business objects and resources you
are developing.

3. Creating Database Mobile Business Objects

Create two mobile business objects from the sampledb datasource.

4. Creating a Relationship Between Mobile Business Objects

Create a relationship between mobile business objects to associate related data and
maintain data synchronization on the application device.

5. Deploying the Database Mobile Business Objects

Deploy the project that contains the database mobile business objects to the Unwired
Server.

Developing Database Mobile Business Objects
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Connecting to the Sample Database
Use the default database connection profile to test and connect to the sample database.

Prerequisites
Start Sybase Unwired WorkSpace.

Task
The Sybase Unwired Platform installation includes a sample database, sampledb, which
you can use to create and test mobile business objects (MBOs). A default connection profile
(My Sample Database), also included in the installation, is configured to access the sample
database (sampledb).

Starting Sybase Unwired Platform Services normally starts the sample database
automatically; however, if you are running the Deployment Edition or Personal Edition, you
must start the database manually.

In this task, you start the database, if necessary, then connect to the sample database using the
default connection profile. This task is required for all tutorials, but you need to perform it only
once.

1. In Enterprise Explorer, expand Database Connections.

2. Right-click My Sample Database and select Ping to confirm that the connection profile
can connect to the sample database.

• If the ping succeeds, click OK and go to step 4.
• If the ping fails, go to step 3.

3. If the ping fails, verify that Unwired Platform Services, including the Sybase Unwired
SampleDB, are running:

a) On your Windows desktop, open the Services window.
For example (using the Windows XP Classic View), select Start > Settings > Control
Panel. In the Control Panel, double-click Administrative Tools, then double-click
Services.

Your installation options (for example, license type, whether or not you installed a
cluster, and so on) determine which Sybase services are running.

b) In the Services window, check the Status column of the Sybase Unwired SampleDB
service. If the status is not Started, right-click the service and select Start.

Developing Database Mobile Business Objects
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c) Return to step 2.

4. Right-click My Sample Database and select Connect.
In Enterprise Explorer, the sampledb database appears under the My Sample Database
connection profile.

5. Expand the sampledb database folder.

Creating the SUP101 Mobile Application Project
Create a mobile application project to store the mobile business objects and resources you are
developing.

Several of the Object API application development tutorials use the objects created in this
SUP101 mobile application project.

1. Select File > New > Mobile Application Project to create the project.

2. In the New Mobile Application Project wizard, enter SUP101 as the Project Name and
click Finish.
The SUP101 project is added to the WorkSpace Navigator and opens in the Mobile
Application Diagram.

Developing Database Mobile Business Objects
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3. Right-click in the Mobile Application Diagram and verify the Switch Developer Profile is
set to Advanced (the default). If the profile is set to Basic, select Advanced and click
Yes.

Sybase Unwired WorkSpace provides two developer profiles: Basic and Advanced. The
Basic profile provides most of the development features you need access to; however, the
tutorial requires additional features, such as configuring code generation, that the
Advanced profile provides.

Creating Database Mobile Business Objects
Create two mobile business objects from the sampledb datasource.

Prerequisites

• Connecting to the Sample Database on page 10
• Creating the SUP101 Mobile Application Project on page 11

Task

1. Open the SUP101 mobile application project if it is not already open:

In WorkSpace Navigator, right-click the SUP101 folder and select Open in Diagram
Editor.

2. In Enterprise Explorer, expand Database Connections > My Sample Database. If My
Sample Database is not connected, right-click My Sample Database and select
Connect. Enter SQL as the password if prompted.

3. Expand sampledb > Tables.

4. Drag the customer table from the Enterprise Explorer to the Mobile Application
Diagram.

Developing Database Mobile Business Objects
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5. In the Quick Create wizard, accept the defaults and click OK.
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6. Create another MBO from the sales_order table:

a) Drag the sales_order table from Enterprise Explorer to the Mobile Application
Diagram.

b) In the Quick Create wizard, accept the defaults and click OK.

The Mobile Application Diagram displays the Customer and Sales_order MBOs.

Developing Database Mobile Business Objects
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7. Select File > Save.

Creating a Relationship Between Mobile Business Objects
Create a relationship between mobile business objects to associate related data and maintain
data synchronization on the application device.

Prerequisites
Creating Database Mobile Business Objects on page 12

Task
Create a relationship between the Customer and Sales_order MBOs.

1. Create a link between the two MBOs:

a) In the Palette, select Relationship.

When you hover over any part of the Mobile Application Diagram, the cursor changes
to a relationship arrow.

Developing Database Mobile Business Objects
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b) In the Mobile Application Diagram, drag the mouse from the Customer MBO to the
Sales_order MBO to draw a relationship link.

2. In the New Relationship wizard, define the relationship between the MBOs:

a) In the General section, accept the default settings and select Composite.
b) In the Mappings section, drag the mouse to draw a line from the id attribute in the

Source Mobile Business Object to the cust_id attribute in the Target Mobile Business
Object.

Alternatively, click each attribute in turn to draw the line.

Developing Database Mobile Business Objects
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3. Click Finish to close the New Relationship wizard.
In the Mobile Application Diagram, a line connects the Customer and Sales_order MBOs
to show they are related objects. Different types of arrows show different relationship
types, in this case, one-to-many and bidirectional relationships. You can click the objects
and select the Attributes tab to see the Attributes in the Properties view.

Developing Database Mobile Business Objects
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4. Select File > Save.

Deploying the Database Mobile Business Objects
Deploy the project that contains the database mobile business objects to the Unwired Server.

Prerequisites

• Verify that Unwired Server and related services are started and running. If they are not, see
Starting Sybase Unwired Platform Services.

• Creating Database Mobile Business Objects on page 12.
• Creating a Relationship Between Mobile Business Objects on page 15.

Task

1. Right-click in the SUP101 Mobile Application Diagram and select Deploy Project.

2. In the Deploy Mobile Application Project wizard, accept the defaults and click Next.

3. In the Contents page, verify that the Customer and Sales_order MBOs are selected. Click
Next.

4. In the Package User-Defined Classes page, click Next.

5. In the Target Server page, select My Unwired Server from the list of available servers, and
if not already connected, click Connect.

6. Accept the default Domain and Security configuration settings, and click Next.

Developing Database Mobile Business Objects
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7. In the Assign Package to Applications page, accept the default application ID and click
Next.

8. In the Server Connection Mapping page, choose a Server connection for the My Sample
Database Connection profile:

• If the runtime database connection is on your local machine, select My Sample
Database then sampledb.

• If the runtime database connection is on a remote machine, select My Sample
Database then New Server Connection, which allows you to create a connection
from an existing template.

9. Click Finish .
The Executing Deployment window closes when the deployment finishes.

10. In the Deployment Status dialog, click OK.

11. In Enterprise Explorer, you can see the deployed project in Unwired Servers > My
Unwired Server > Domains > default > Packages > sup101:1.0. The two MBOs you
deployed are in the Mobile Business Objects subfolder.

Developing Database Mobile Business Objects
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The MBOs are now available for access by device applications. You will use this project in
other Object API application development tutorials.

Developing Database Mobile Business Objects
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Learn More About Sybase Unwired Platform

Once you have finished, try some of the other samples or tutorials, or refer to other
development documents in the Sybase Unwired Platform documentation set.

Check the Product Documentation Web site regularly for updates: http://sybooks.sybase.com/
sybooks/sybooks.xhtml?id=1289&amp;c=firsttab&amp;a=0&amp;p=categories, then
navigate to the most current version.

Tutorials
Try out some of the other getting started tutorials available on the Product Documentation
Web site to get a broad view of the development tools available to you.

Example Projects
An example project contains source code for its associated tutorial. It does not contain the
completed tutorial project. Download example projects from the SAP® Community Network
(SCN) at http://scn.sap.com/docs/DOC-8803.

Samples
Sample applications are fully developed, working applications that demonstrate the features
and capabilities of Sybase Unwired Platform.

Check the SAP® Development Network (SDN) Web site regularly for new and updated
samples: https://cw.sdn.sap.com/cw/groups/sup-apps.

Online Help
See the online help that is installed with the product, or available from the Product
Documentation Web site.

Developer Guides
Learn best practices for architecting and building device applications:

• Mobile Data Models: Using Data Orchestration Engine – provides information about
using Sybase Unwired Platform features to create DOE-based applications.

• Mobile Data Models: Using Mobile Business Objects – provides information about
developing mobile business objects (MBOs) to fully maximize their potential.

• SAP Mobile WorkSpace: Mobile Business Object Development – provides information
about using SAP Mobile Platform to develop MBOs and generate Object API code that
can be used to create native device applications and Hybrid Apps.

Use the appropriate API to create device applications:

• Developer Guide: Android Object API Applications
• Developer Guide: BlackBerry Object API Applications

Learn More About Sybase Unwired Platform
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• Developer Guide: iOS Object API Applications
• Developer Guide: Windows and Windows Mobile Object API Applications
• Developer Guide: Hybrid Apps
• Developer Guide: OData SDK
• Developer Guide: REST API Applications

Customize and automate:

• Developer Guide: Unwired Server Runtime > Management API  – customize and
automate system administration features.

Javadoc and HeaderDoc are also available in the installation directory.
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