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Sybase Unwired Platform Tutorials

The Sybase® Unwired Platform tutorials demonstrate how to develop, deploy, and test mobile
business objects, device applications, and mobile workflow packages. You can also use the
tutorials to demonstrate system functionality and train users.

Tip: If you want to see the final outcome of a tutorial without performing the steps, the
associated example project is available on SAP® SDN: http://www.sdn.sap.com/irj/sdn/
mobile?rid=/webcontent/uuid/40ea4956-b95c-2e10-11b3-e68c73b2280e.

• Learn mobile business object (MBO) basics, and use this tutorial as a foundation for the
Object API application development tutorials:
• Tutorial: Mobile Business Object Development

• Create native Object API mobile device applications:
• Tutorial: Android Object API Application Development
• Tutorial: BlackBerry Object API Application Development
• Tutorial: iOS Object API Application Development
• Tutorial: Windows Mobile Object API Application Development

• Create a mobile business object, then develop a mobile workflow package that uses it:
• Tutorial: Mobile Workflow Package Development

Sybase Unwired Platform Tutorials
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Task Flow

Use this tutorial to develop and deploy mobile business objects (MBOs). You can then use
these MBOs to complete the Object API application development tutorials.

Task Goals Steps

Getting started • Install Sybase Mobile SDK and
Sybase Unwired Platform Run-
time.

• Start Unwired Server and other
platform services, if not already
started.

• Start Sybase Control Center.

• Start Sybase Unwired Work-
Space, open the Mobile Devel-
opment perspective, and be-
come familiar with the views of
the perspective and the Mobile
Application Diagram.

• Installing Sybase Unwired Plat-
form

• Starting Unwired Platform
Services

• Starting Sybase Unwired Work-
Space

• (Optional) Connecting to Syb-
ase Control Center

• (Optional) Learning Unwired
WorkSpace Basics

Developing database
mobile business ob-
jects

• Create a mobile application
project and a connection to the
database.

• Create two mobile business ob-
jects, and create a relationship
between them.

• Deploy the mobile business ob-
jects to Unwired Server.

• Connecting to the Sample Data-
base

• Creating the SUP101 Mobile
Application Project

• Creating Database Mobile Busi-
ness Objects

• Creating a Relationship Be-
tween Mobile Business Objects

• Deploying the Database Mobile
Business Objects

Task Flow
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Getting Started with Unwired Platform

Install and learn about Sybase Unwired Platform and its associated components.

Complete the following tasks for all tutorials, but you need to perform them only once.

1. Installing Sybase Unwired Platform

Install Sybase Mobile SDK and Sybase Unwired Platform Runtime.

2. Starting Sybase Unwired Platform Services

Start Unwired Server, Sybase Control Center, the sample database, the cache database
(CDB), and other essential services.

3. Starting Sybase Unwired WorkSpace

Start the development environment, where you can perform tasks that include creating
mobile business objects (MBOs), managing database and server connections, developing
Mobile Workflow applications, and generating Object API code.

4. Connecting to Sybase Control Center

Open the Sybase Control Center administration console to manage Unwired Server and its
components.

5. Learning Unwired WorkSpace Basics

Sybase Unwired WorkSpace features are well integrated in the Eclipse IDE. If you are not
familiar with Eclipse, you can quickly learn the basic layout of Unwired WorkSpace and
the location of online help.

Installing Sybase Unwired Platform
Install Sybase Mobile SDK and Sybase Unwired Platform Runtime.

Before starting this tutorial, be sure you have all the requisite Unwired Platform components
installed. For complete installation instructions, see the Sybase Unwired Platform
documentation at http://sybooks.sybase.com/nav/summary.do?prod=1289:

• Release Bulletin for Sybase Mobile SDK
• Installation Guide for Sybase Mobile SDK
• Release Bulletin for Runtime
• Installation Guide for Runtime

1. Install these Unwired Platform Runtime components:

• Data Tier (included with single-server installation)
• Unwired Server

2. Install Mobile SDK, which includes:

Getting Started with Unwired Platform
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• Development support for Native Object API applications, HTML5/JS Hybrid (Mobile
Workflow) applications, and OData SDK applications.

• Sybase Unwired WorkSpace, the Eclipse-based development environment for MBOs
and mobile workflows.

Starting Sybase Unwired Platform Services
Start Unwired Server, Sybase Control Center, the sample database, the cache database (CDB),
and other essential services.

How you start Unwired Platform services depend on the options you selected during
installation. In some cases, you may need to manually start Unwired Platform services.
Select Start > Programs > Sybase > Unwired Platform  > Start Unwired Platform
Services.
The Unwired Server services enable you to access the Unwired Platform runtime components
and resources.

Starting Sybase Unwired WorkSpace
Start the development environment, where you can perform tasks that include creating mobile
business objects (MBOs), managing database and server connections, developing Mobile
Workflow applications, and generating Object API code.
Select Start > Programs > Sybase > Unwired Platform > Unwired WorkSpace.
The Sybase Unwired WorkSpace opens in the Mobile Development perspective. The
Welcome page displays links to the product and information.

Next
To read more about Unwired WorkSpace concepts and tasks, select Help > Help Contents.

Connecting to Sybase Control Center
Open the Sybase Control Center administration console to manage Unwired Server and its
components.

From Sybase Control Center, you can:

• View servers and their status
• Start and stop a server
• View server logs
• Deploy a mobile application package
• Register application connections
• Set role mappings

Getting Started with Unwired Platform
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For information on configuring, managing, and monitoring Unwired Server, click Help >
Online Documentation.

1. Select Start > Programs > Sybase > Sybase Control Center.

Note: If the Sybase Control Center service does not open, make sure that the service is
started. See the Installation Guide for Runtime.

2. In Sybase Control Center, log in by entering the credentials set during installation.

Sybase Control Center gives you access to the Unwired Platform administration features
that you are authorized to use.

Learning Unwired WorkSpace Basics
Sybase Unwired WorkSpace features are well integrated in the Eclipse IDE. If you are not
familiar with Eclipse, you can quickly learn the basic layout of Unwired WorkSpace and the
location of online help.

• To access the online help, select Help  > Help Contents. Some documents are for Sybase
Unwired Platform, while others are for the Eclipse development environment.

• The Welcome page provides links to useful information to get you up and running.
• Reopen the Welcome page by selecting Help > Welcome.
• To close the Welcome page, click X.
• To learn about tasks you must perform, select the Development Process icon.

• In Unwired WorkSpace, look at the area (window or view) that you will use to access,
create, define, and update mobile business objects (MBOs).

Window Description

WorkSpace Navigator view Use this view to create Mobile Application projects,
and review and modify MBO-related properties.

This view displays mobile application project fold-
ers, each of which contains all project-related re-
sources in subfolders, including MBOs, datasource
references to which the MBOs are bound, personal-
ization keys, and so on.

Enterprise Explorer view A view that provides functionality to connect to var-
ious enterprise information systems (EIS), such as
database servers, SAP® back ends, and Unwired
Server.

Getting Started with Unwired Platform
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Window Description

Mobile Application Diagram The Mobile Application Diagram is a graphical ed-
itor where you create and define mobile business
objects.

Use the Mobile Application Diagram to create
MBOs (including attributes and operations), then
define relationships with other MBOs. You can:

• Create MBOs in the Mobile Application Dia-
gram using Palette icons and menu selections –
either bind or defer binding to a data source,
when creating an MBO. For example, you may
want to model your MBOs before creating the
data sources to which they bind. This MBO de-
velopment method is sometimes referred to as
the top-down approach.

• Drag items from Enterprise Explorer and drop
them (drag and drop) onto the Mobile Applica-
tion Diagram to create the MBO – quickly cre-
ates the operations and attributes automatically
based on the datasource artifact being dropped
on the Mobile Application Diagram.

Each new mobile application project generates an
associated mobile application diagram.

Palette The Palette is accessed from the Mobile Application
Diagram and provides controls, such as the ability to
create MBOs, add attributes and operations, and de-
fine relationships, by dragging-and-dropping the
corresponding icon onto the Mobile Application Di-
agram or existing MBO.

Properties view Select an object in the Mobile Application Diagram
to display and edit its properties in the Properties
view. While you cannot create an MBO from the
Properties view, most development and configura-
tion is performed here.

Outline view Displays an outline of the active file and lists struc-
tural elements. The contents are editor-specific.

Problems view Displays problems, errors, or warnings that you may
encounter. This is a valuable source for collecting
troubleshooting information.

Getting Started with Unwired Platform
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Window Description

Error Log view Displays error log information. This is a valuable
source for collecting troubleshooting information.

Getting Started with Unwired Platform
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Developing Database Mobile Business
Objects

You will develop two samples of mobile business objects to see how they form the business
logic for mobile applications. You create two mobile business objects, each using a database
as its datasource, create a relationship between the two MBOs, and deploy them to Unwired
Server. You also use the deployed project in the Object API application development tutorials.

Prerequisites
Complete the tasks in Getting Started.

Task
Develop the database mobile business objects by completing the following tasks, in order.
Each task has its own section with descriptions and detailed steps for you to create and deploy
a project.

1. Connecting to the Sample Database
Use the default database connection profile to test and connect to the sample database.

2. Creating the SUP101 Mobile Application Project
Create a mobile application project to store the mobile business objects and resources you
are developing.

3. Creating Database Mobile Business Objects
Create two mobile business objects, each from a database object.

4. Creating a Relationship Between Mobile Business Objects
Create a relationship between mobile business objects to associate related data and
maintain data synchronization on the application device.

5. Deploying the Database Mobile Business Objects
Deploy the project that contains the database mobile business objects to the Unwired
Server.

Connecting to the Sample Database
Use the default database connection profile to test and connect to the sample database.

Installing Sybase Unwired Platform also installs a sample database, sampledb, which you
can use to create and test mobile business objects (MBOs). A default connection profile (My
Sample Database), included with the installation, is configured to access the Sample database
(sampledb).

Sybase Unwired Platform Services can start the database automatically, depending on your
license type: the Sybase Unwired Platform Development Edition normally starts the database

Developing Database Mobile Business Objects
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automatically; however, if you are running Deployment Edition or Personal Edition, you must
start the database manually.

In this task you start the database, if necessary, then connect to the sample database using the
default connection profile. This task is required for all tutorials, but you need to perform it only
once.

1. Select Start > Programs > Sybase > Unwired Platform > Unwired WorkSpace.

2. In Enterprise Explorer, expand Database Connections.

3. Right-click My Sample Database and select Ping.

• If the ping succeeds, click OK and go to Step 4.
• If the ping fails, go to the next step to correct the problem.

Note: Ping confirms whether the sample profile can connect to the sample database.

4. If the ping fails, verify that Unwired Platform Services, including the Sybase Unwired
SampleDB, are running:

a) On your Windows desktop, open the Services window.
For example (using the the Windows XP Classic View), select Start > Settings >
Control Panel. In the Control Panel, double-click Administrative Tools, then double-
click Services.

Your installation options (for example, license type, whether or not you installed a
cluster, and so on) determine which Sybase services are running.

b) In the Services window, check the Status column of the Sybase Unwired SampleDB
service. If the status is not Started, right-click the service and select Start.

c) Go back to Step 2.

5. Right-click My Sample Database and select Connect.
In Enterprise Explorer, the My Sample Database folder contains the sampledb database.

Developing Database Mobile Business Objects
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Creating the SUP101 Mobile Application Project
Create a mobile application project to store the mobile business objects and resources you are
developing.

Several of the Object API application development tutorials use the objects created in this
SUP101 mobile application project.

1. Select File > New > Mobile Application Project to create the project.

2. In the New Mobile Application Project wizard, enter SUP101 as the Project Name and
click Finish.
The SUP101 project is added to the WorkSpace Navigator and opens in the Mobile
Application Diagram.

3. Right-click in the Mobile Application Diagram and verify the Switch Developer Profile is
set to Advanced. If the profile was set to Basic, select Advanced and click Yes.

Unwired WorkSpace provides two developer profiles: Basic and Advanced. The default
Basic profile provides most of the features you need; however, the tutorial requires

Developing Database Mobile Business Objects
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additional features, such as configuring code generation, that the Advanced profile
provides.

Creating Database Mobile Business Objects
Create two mobile business objects, each from a database object.

Prerequisites

• Connecting to the Sample Database on page 11
• Creating the SUP101 Mobile Application Project on page 13

Task

1. Open the SUP101 mobile application project if it is not already open:

In WorkSpace Navigator, right-click the SUP101 folder and select Open in Diagram
Editor.

2. In Enterprise Explorer, expand Database Connections\My Sample
Database. If the sampledb database folder is not listed, right-click My Sample
Database and select Connect. Enter SQL as the password if prompted.

3. Expand sampledb\Tables.

4. Drag the customer table from the Enterprise Explorer to the Mobile Application
Diagram.

5. In the Quick Create wizard, accept the defaults and click OK.

Developing Database Mobile Business Objects
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6. Create another MBO from the sales_order table:

a) Drag the sales_order table from Enterprise Explorer to the Mobile Application
Diagram.

b) In the Quick Create wizard, accept the defaults and click OK.

The Mobile Application Diagram displays the Customer and Sales_order MBOs.

Developing Database Mobile Business Objects
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7. Select File > Save.

Creating a Relationship Between Mobile Business Objects
Create a relationship between mobile business objects to associate related data and maintain
data synchronization on the application device.

Prerequisites
Creating Database Mobile Business Objects on page 14

Task
You create a relationship between the Customer and Sales_order MBOs.

1. Create a link between the two MBOs:

a) In the Palette, select Relationship.

When you hover over any part of the Mobile Application Diagram, the cursor changes
to a relationship arrow. If the cursor does not change, select Relationship again.

Developing Database Mobile Business Objects
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b) In the Mobile Application Diagram, drag the mouse from the Customer MBO to the
Sales_order MBO to draw a relationship link.

2. In the New Relationship wizard, define the relationship between the MBOs:

a) In the General section, accept the default settings.
b) In the Mappings section, drag the mouse to draw a line from the id attribute in the

Source Mobile Business Object to the cust_id attribute in the Target Mobile Business
Object.

Alternatively, click each attribute in turn to draw the line.

Developing Database Mobile Business Objects
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3. Click Finish to close the New Relationship wizard.
In the Mobile Application Diagram, a line connects the Customer and Sales_order MBOs
to show they are related objects. Different types of arrows show different relationship
types, in this case, one-to-many and bi-directional relationships. You can double-click the
objects to see the Attributes in the Properties view.

Developing Database Mobile Business Objects
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4. Select File > Save.

Deploying the Database Mobile Business Objects
Deploy the project that contains the database mobile business objects to the Unwired Server.

Prerequisites

• Unwired Server and related services must be started and running. If they are not, see 
Getting Started on page 5

• Creating Database Mobile Business Objects on page 14

Task

1. Right-click in the SUP101 Mobile Application Diagram and select Deploy Project.

2. In the Deploy Mobile Application Project wizard, accept the defaults and click Next.

3. In the Contents window, verify the Customer and Sales_order MBOs are selected. Click
Next.

4. In the Package User-defined Classes window, click Next.

5. In the Target Server window, select My Unwired Server from the list of available servers,
then click Connect.

6. Accept the default Domain and Security configuration settings, and click Next.

7. In the Deploy Application to Server window, accept the default application ID and click
Next.

Developing Database Mobile Business Objects
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8. In the Server Connection Mapping window, choose a Server connection for the My
Sample Database Connection profile:

• If the runtime database connection is on your local machine, select My Sample
Database then sampledb.

• If the runtime database connection is on a remote machine, select My Sample
Database then New Server Connection, which allows you to create a connection
from an existing template.

9. Click Next.

10. In the Save as a Deployment Profile, accept the default settings and click Finish to close
the Deploy Mobile Application Project wizard.
The Executing Deployment window closes when the deployment finishes.

11. In the Deployment Status window, click OK.

12. In Enterprise Explorer, you can see the deployed project in Unwired Servers > My
Unwired Server > Domains > default > Packages > sup101:1.0. The two MBOs you
deployed are in the Mobile Business Objects subfolder.

Developing Database Mobile Business Objects
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The MBOs are now available for access by device applications or for deploying in a
production environment. You will use this project in other Object API application
development tutorials.

Developing Database Mobile Business Objects
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Learn More About Sybase Unwired Platform

Once you have finished, try some of the other samples or tutorials, or refer to other
development documents in the Sybase Unwired Platform documentation set.

Check the Sybase Product Documentation Web site regularly for updates: http://
sybooks.sybase.com/nav/summary.do?prod=1289, then navigate to the most current version.

Tutorials
Try out some of the other getting started tutorials available on Product Documentation to get a
broad view of the development tools available to you.

Example Projects
Example projects are available for download, if you want the finished tutorial without going
through the steps. Download example projects from: http://www.sdn.sap.com/irj/sdn/mobile?
rid=/webcontent/uuid/40ea4956-b95c-2e10-11b3-e68c73b2280e.

Samples
Sample applications are fully developed, working applications that demonstrate the features
and capabilities of Sybase Unwired Platform.

Check the SAP® Development Network (SDN) Web site regularly for new and updated
samples: https://cw.sdn.sap.com/cw/groups/sup-apps.

Online Help
See the online help that is installed with the product, or the Product Documentation Web site.

Developer Guides
Learn best practices for architecting and building device applications:

• Mobile Data Models: Using Data Orchestration Engine – provides information about
using Sybase Unwired Platform features to create DOE-based applications.

• Mobile Data Models: Using Mobile Business Objects – provides information about how to
develop mobile business objects (MBOs) to fully maximize their potential.

Learn about using the API to create device applications:

• Developer Guide: Android Object API Applications
• Developer Guide: BlackBerry Object API Applications
• Developer Guide: iOS Object API Applications
• Developer Guide: Windows and Windows Mobile Object API Applications
• Developer Guide: Mobile Workflow Packages

Customize and automate:

Learn More About Sybase Unwired Platform

Tutorial: Mobile Business Object Development 23

http://sybooks.sybase.com/nav/summary.do?prod=1289
http://sybooks.sybase.com/nav/summary.do?prod=1289
http://www.sdn.sap.com/irj/sdn/mobile?rid=/webcontent/uuid/40ea4956-b95c-2e10-11b3-e68c73b2280e
http://www.sdn.sap.com/irj/sdn/mobile?rid=/webcontent/uuid/40ea4956-b95c-2e10-11b3-e68c73b2280e
https://cw.sdn.sap.com/cw/groups/sup-apps


• Developer Guide: Unwired Server Management API  – customize and automate system
administration features.

Javadoc and HeaderDoc are also available in the installation directory.
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