Tutorial: Mobile Business Object Development

Sybase Unwired Platform 2.0
## Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sybase Unwired Platform Tutorials</td>
<td>1</td>
</tr>
<tr>
<td>Task Flow</td>
<td>3</td>
</tr>
<tr>
<td><strong>Getting Started</strong></td>
<td>5</td>
</tr>
<tr>
<td>Installing Sybase Unwired Platform</td>
<td>5</td>
</tr>
<tr>
<td>Starting Unwired Platform Services</td>
<td>5</td>
</tr>
<tr>
<td>Starting Sybase Unwired WorkSpace</td>
<td>6</td>
</tr>
<tr>
<td>Connecting to Sybase Control Center</td>
<td>6</td>
</tr>
<tr>
<td>Learning the Basics</td>
<td>7</td>
</tr>
<tr>
<td><strong>Developing Database Mobile Business Objects</strong></td>
<td>11</td>
</tr>
<tr>
<td>Creating the SUP101 Mobile Application Project</td>
<td>11</td>
</tr>
<tr>
<td>Creating the sampledb Connection Profile</td>
<td>13</td>
</tr>
<tr>
<td>Creating Database Mobile Business Objects</td>
<td>16</td>
</tr>
<tr>
<td>Creating a Relationship Between Mobile Business</td>
<td>19</td>
</tr>
<tr>
<td>Objects</td>
<td></td>
</tr>
<tr>
<td>Deploying the Database Mobile Business Objects</td>
<td>22</td>
</tr>
<tr>
<td><strong>Learn More about Sybase Unwired Platform</strong></td>
<td>27</td>
</tr>
<tr>
<td><strong>Index</strong></td>
<td>29</td>
</tr>
</tbody>
</table>
Sybase Unwired Platform Tutorials

The Sybase® Unwired Platform tutorials demonstrate how to develop, deploy, and test mobile business objects, device applications, and mobile workflow packages. You can also use the tutorials to demonstrate system functionality and train users.

- Learn mobile business object (MBO) basics, and create a mobile device application:
  - *Tutorial: Mobile Business Object Development*
- Create native mobile device applications:
  - *Tutorial: BlackBerry Application Development*
  - *Tutorial: iOS Application Development*
- Create a mobile workflow package:
  - *Tutorial: Mobile Workflow Package Development*

The tutorials demonstrate a cross section of basic functionality, which includes creating MBOs that can be used in replication-based or message-based synchronization; and using various Sybase Unwired WorkSpace development tools, independent development environments, and device types.

<table>
<thead>
<tr>
<th>Tutorials</th>
<th>Mobile business objects (MBOs)</th>
<th>Synchronization types</th>
<th>Development tools</th>
<th>Device types</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tutorial: Mobile Business Object Development</td>
<td>Create new MBOs</td>
<td>Replication-based</td>
<td>Sybase Unwired WorkSpace</td>
<td>N/A</td>
</tr>
<tr>
<td>Tutorial: BlackBerry Application Development</td>
<td>Create new MBOs</td>
<td>Replication-based</td>
<td>Sybase Unwired WorkSpace</td>
<td>BlackBerry</td>
</tr>
<tr>
<td>Tutorial: iOS Application Development</td>
<td>Create new MBOs</td>
<td>Message-based</td>
<td>Sybase Unwired WorkSpace</td>
<td>iPhone</td>
</tr>
<tr>
<td>Tutorial: Mobile Workflow Package Development</td>
<td>Create new MBOs</td>
<td>Message-based</td>
<td>Mobile Workflow Forms Editor</td>
<td>Windows Mobile iPhone</td>
</tr>
</tbody>
</table>
Task Flow

Use this tutorial to develop two Mobile Business Objects with a relationship in Sybase Unwired WorkSpace. This tutorial is a pre-requisite for other Sybase Unwired Platform tutorials.

Table 2. Eclipse tutorials

<table>
<thead>
<tr>
<th>Task</th>
<th>Goals</th>
<th>Steps required to complete the task</th>
</tr>
</thead>
<tbody>
<tr>
<td>Getting Started</td>
<td>• Install all required WorkSpace components and external resources.</td>
<td>• Installing Sybase Unwired Platform on page 5</td>
</tr>
<tr>
<td></td>
<td>• Start Unwired Server.</td>
<td>• Starting Unwired Server on page 5</td>
</tr>
<tr>
<td></td>
<td>• Open the Mobile Development perspective, and become familiar with</td>
<td>• Starting Sybase Unwired WorkSpace on page 6</td>
</tr>
<tr>
<td></td>
<td>the views of the perspective and the Mobile Application Diagram.</td>
<td>• Learning the Basics on page 7</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Note: These tasks are prerequisites for all the other tutorials. You</td>
</tr>
<tr>
<td></td>
<td></td>
<td>need to perform them only once.</td>
</tr>
<tr>
<td>Developing Database Mobile Business</td>
<td>• Create a mobile application project and a connection to the</td>
<td>• Creating the SUP101 Mobile Application Project on page 11</td>
</tr>
<tr>
<td>Objects</td>
<td>database.</td>
<td>• Creating the sampledb Connection Profile on page 13</td>
</tr>
<tr>
<td></td>
<td>• Create two mobile business objects, and create a relationship</td>
<td>• Creating Database Mobile Business Objects on page 16</td>
</tr>
<tr>
<td></td>
<td>between them.</td>
<td>• Creating a Relationship Between Mobile Business Objects on page 19</td>
</tr>
<tr>
<td></td>
<td>• Deploy the mobile business objects to Unwired Server.</td>
<td>• Deploying the Database Mobile Business Objects on page 22</td>
</tr>
</tbody>
</table>
Task Flow
Getting Started

**Goal:** Install and learn about Sybase Unwired Platform and its associated components.

The following tasks are required, unless otherwise noted, for all tutorials, but you need to perform them only once.

1. *Installing Sybase Unwired Platform* on page 5
2. *Starting Unwired Platform Services* on page 5
3. *Starting Sybase Unwired WorkSpace* on page 6
4. *Connecting to Sybase Control Center* on page 6
5. (optional) *Learning the Basics* on page 7

---

### Installing Sybase Unwired Platform

**Goal:** Install Sybase Unwired Platform.

Install these Sybase Unwired Platform components:

- Data Tier
- Unwired Server
- Unwired WorkSpace

If Unwired Platform is already installed and any of these components are missing:

1. Start the Sybase Unwired Platform installer.
2. Follow the instructions in the installation wizard.
3. Select the required components, and complete the installation.

For complete installation instructions, see the *Sybase Unwired Platform Installation Guide* and *Release Bulletin*.

---

### Starting Unwired Platform Services

**Goal:** Start Unwired Server and the sample database.

Select **Start > Programs > Sybase > Unwired Platform > Start Unwired Platform Services**.
Starting Sybase Unwired WorkSpace

Goal: Start Unwired WorkSpace.

1. Select Start > Programs > Sybase > Unwired Platform > Unwired WorkSpace.
   The Welcome page displays links to product information, and to the product.
2. To read more about Sybase Unwired WorkSpace concepts and tasks, select Help > Help Contents from the main menu.

Connecting to Sybase Control Center

Goal: Open the Web-based Sybase Control Center administration console to manage Unwired Server and its components.

From Sybase Control Center, you can:

• View servers and their status
• Start and stop a server
• View server logs
• Deploy a mobile application package
• Register devices
• Set role mappings

For information on configuring, managing, and monitoring Unwired Server, select Help > Online Documentation.

1. Select Start > Programs > Sybase > Sybase Control Center.
   Note: If Sybase Control Center does not launch, make sure that the Sybase Unified Agent service is started. See the Installation Guide for details.

2. Log in using the default login:
   • User name – supAdmin
   • Password – s3pAdmin

   Logging in to Sybase Control Center allows you access to Unwired Platform administration features that you are authorized to use.
Learning the Basics

Goal: Learn about Sybase Unwired WorkSpace and how to access help.

Prerequisites
Start Unwired WorkSpace.

Task

1. From the Welcome page, select any of the links to familiarize yourself with the Unwired WorkSpace environment.
   To close this page, click the X. You can reopen this page by selecting Help > Welcome.
2. Select Start Development to access the Sybase Unwired WorkSpace development environment.
   Look at the area (window or view) that you will be working in to access, create, define, and update mobile business objects (MBOs).

<table>
<thead>
<tr>
<th>View</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>WorkSpace Navigator</td>
<td>This view displays mobile application project folders, each of which contains all project-related resources in subfolders, including MBOs, data source references to which the MBOs are bound, personalization keys, and so on. Use this view to review and modify MBO-related properties.</td>
</tr>
<tr>
<td>Enterprise Explorer</td>
<td>A window that provides functionality to connect to various enterprise back-end systems; for example, database servers, SAP® servers, and Sybase Unwired Server.</td>
</tr>
<tr>
<td>View</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
</tbody>
</table>
| Mobile Application Diagram | A graphical editor where you create and define mobile business objects. Use the Mobile Application Diagram to create MBOs (including attributes and operations), then define relationships with other MBOs. You can:  
• Create MBOs in the Mobile Application Diagram using Palette icons and menu selections – either bind or defer binding to a data source, when creating an MBO. For example, you may want to model your MBOs before creating the data sources to which they bind. This is sometimes called the top-down approach.  
• Drag items from Enterprise Explorer and drop them onto the Mobile Application Diagram to create the MBO – quickly creates the operations and attributes automatically based on the data source being dropped on the Mobile Application Diagram. This is sometimes called the bottom-up approach.  
Each new mobile application project generates an associated Mobile Application Diagram. |
| Palette             | Access the Palette from the Mobile Application Diagram. It provides controls, such as the ability to create MBOs, add attributes and operations, and define relationships, by dragging and dropping the corresponding icon onto the Mobile Application Diagram or existing MBO. |
| Properties view     | Select an object in the Mobile Application Diagram to display and edit its properties in the Properties view. You cannot create an MBO from the Properties view, but generally, most development and configuration is performed here. |
| Outline view        | Displays an outline of the file that is currently open in the editor area, and lists structural elements. The contents are editor-specific. |
| Problem view        | Displays problems, errors, or warnings that you may encounter. |

3. To access the online help, select Help > Help Contents from the main menu bar.
4. Expand any of the documents that appear in the left pane. Some documents are for Sybase Unwired Platform, while others are for the Eclipse development environment.
Developing Database Mobile Business Objects

**Goal:** Create two mobile business objects, each using a database as its data source; create a relationship between the two, and deploy them to Unwired Server.

**Prerequisites**
Complete *Getting Started* on page 5.

**Task**
Develop the database mobile business objects by completing the following tutorials, in order.

1. *Creating the SUP101 Mobile Application Project* on page 11
2. *Creating the sampledb Connection Profile* on page 13
3. *Creating Database Mobile Business Objects* on page 16
4. *Creating a Relationship Between Mobile Business Objects* on page 19
5. *Deploying the Database Mobile Business Objects* on page 22

---

**Creating the SUP101 Mobile Application Project**

**Goal:** Create a Mobile Application project to store the mobile business objects and resources you are developing.

Several tutorials use the SUP101 Mobile Application project to store mobile business objects.

1. Select **File > New > Mobile Application Project** to create the project. If you do not find the Mobile Application Project, then select: **File > New > Other > Sybase > Mobile Development > Mobile Application Project**.
2. The New Mobile Application Project wizard appears. For Project Name, enter **SUP101** and click **Finish**.
   The project appears in the WorkSpace Navigator and the Mobile Application Diagram opens.
3. Right-click in the Mobile Application Diagram Panel and select **Switch developer profile > Advanced**.

Unwired WorkSpace provides two developer profiles (basic and advanced). You should be able to complete the tutorial using the basic profile. However, as you explore Unwired WorkSpace features you may want to work in the Advanced profile.
Creating the sampledb Connection Profile

**Goal:** Create a database connection profile and test the sample database connection.

Installing Sybase Unwired Platform also installs a sample database `sampledb`, which you can use to create and test mobile business objects (MBOs). Starting Sybase Unwired Platform Services automatically starts the database, depending on your license type. A default connection profile (My Sample Database) is included with the installation, and provides access to the `sampledb` database. This tutorial shows you how to create and use a new connection profile named `sampledb`.

This task is required for all tutorials, but you need to perform it only once. If the sampledb connection profile already exists, you do not need to perform this task.

1. From the Enterprise Explorer, right-click the **Database Connections** folder and select **New** to open the Wizard Selection Page.
2. Select **Sybase ASA**, enter `sampledb` as the name, and click **Next**.
3. Select **Sybase ASA v11.x for Unwired Server Default** as the driver and keep the default settings, including `dba` as the **User name** and `SQL` as the **Password**. Select **Save Password**.
4. Click **Test Connection**.

If Test Connection fails, verify Unwired Platform Services, including the sampledb database, are running.

a) Select the Windows **Start > Settings > Control Panel** menu.

b) Select **Administrative Tools**, then select **Services**.

c) Depending on your installation options (for example, license type, whether or not you installed a cluster, and so on) determines which Sybase services are running.
Note: If the sampledb database is not running, you can install and start it from the command line. To install it, use the command `sampledb install auto/manual`. For example:

```
C:\Sybase\UnwiredPlatform\Servers\UnwiredServer\bin> sampledb install auto
```

To start it from the command line, run the command `sampledb start`. For example:

```
C:\Sybase\UnwiredPlatform\Servers\UnwiredServer\bin> sampledb start
```

5. In the Ping Succeeded message, click **OK**.
6. Click **Finish**.

View the sampledb connection profile from Enterprise Explorer by expanding the **Database Connections** folder.
Creating Database Mobile Business Objects

**Goal:** Create two mobile business objects, each from a database object.

**Prerequisites**

Complete *Creating the sampledb Connection Profile* on page 13 and *Creating the SUP101 Mobile Application Project* on page 11.

**Task**

1. Open the SUP101 mobile application project if it is not already open:
   - In WorkSpace Navigator, right-click on the SUP101 folder and select **Open in Diagram Editor**.

2. In the Enterprise Explorer, expand the Database folder, right-click **sampledb**, and select **Connect**, if not already connected. Enter **SQL** as the password if prompted.

3. Expand the sampledb database, then expand the **Tables** folder.

4. Select the customer table, while holding the mouse button drag the customer table onto the **Mobile Application Diagram.**
The Quick Create wizard launches.

5. In the Quick Create wizard, accept the defaults and click OK.
6. Create another MBO from the sales_order table:
   a) Drag the sales_order table from Enterprise Explorer, and drop it onto the Mobile Application Diagram.
   b) In the Quick Create wizard, accept the defaults and click OK.
      The customer and sales_order MBOs display on the Mobile Application Diagram.
7. Select File > Save.

Creating a Relationship Between Mobile Business Objects

**Goal:** Create a relationship between mobile business objects to associate related data and maintain data synchronization on the device.

**Prerequisites**

Complete *Creating Database Mobile Business Objects* on page 16.

**Task**

In this tutorial, you create a relationship between the *customer* and *sales_order* mobile business objects (MBO).

1. In the Palette, click **Relationship**.
2. Select the `customer` MBO and, keeping the mouse button pressed, drag the Relationship link to the `sales_order` MBO to establish the relationship link.

The Relationship Creation wizard opens.

3. Accept the General default settings. In the Mappings section, select the `id` attribute in the **Source object** pane and `cust_id` in the **Target object** pane, or drag `id` from the Source Object to `cust_id` in the Target Object.
A line connects the two attributes.

4. Click **Finish**.

The mobile application diagram now shows the link from the customer MBO to the sales_order MBO.
5. Select File > Save.

Deploying the Database Mobile Business Objects

**Goal:** Deploy the project that contains the database mobile business objects to the server.

**Prerequisites**
- *Getting Started* on page 5
- *Creating Database Mobile Business Objects* on page 16

**Task**
1. Right-click in the SUP101 Mobile Application Diagram, and select **Deploy Project**. The Deploy Mobile Application Project wizard appears.
2. Accept the defaults (including Replication-based), and click Next. The Contents page appears.

3. Select the customer and sales_order MBOs and click Next. The Package Jars page appears.

4. Click Next. The Target Server page appears.

5. Select My Unwired Server from the list of available servers, then select Refresh or Connect. Accept the default Domain and Security configuration settings, and click Next.

6. If you have multiple server connections, the Server Connection Mapping page appears. Select the sampledb server connection from the drop-down list and click Finish.
If the runtime database connection were on a remote machine, you would select **New Server Connection**, which allows you to create a connection from an existing template.

The deployment progress window appears.

7. Click **OK** when the deployment status window appears.

A status window indicates progress and a successful deployment.

8. Connect to Unwired Server and view the deployed project, by expanding **Domains > default > Packages**. The server package `SUP101:1.0` into which you deployed the MBOs appears in the Packages folder. The two MBOs, appear in the Mobile Business Objects folder.
The MBOs are now available for access by device applications or for deploying in a production environment. You will use this project in other getting started tutorials.
Learn More about Sybase Unwired Platform

Once you have finished, try some of the other samples or tutorials, or refer to other development documents in the Sybase Unwired Platform documentation set.


Tutorials
Try out some of the other getting started tutorials to get a broad view of the development tools available to you.

Samples
Sample applications are fully developed, working applications that demonstrate the features and capabilities of Sybase Unwired Platform.


Online Help
See the online help that is installed with the product, or the Product Documentation Web site.

Developer Guides
Learn about using the API to create device applications:

- Developer Guide for BlackBerry
- Developer Guide for iOS
- Developer Guide for Mobile Workflow Packages
- Developer Guide for Windows and Windows Mobile

Customize and automate:

- Developer Guide for Unwired Server Management API – customize and automate system administration features.
- Developer Guide for Unwired Server – customize and automate server-side implementations for device applications, and administration, such as data handling.

Javadoc and HeaderDoc are also available in the installation directory.
Index

B
basics, learning 7

C
changing developer profile 11
connecting to Sybase Control Center 6
creating
database connection profile 13
database connection profile, creating 13
Mobile Application Diagram 11
mobile application project 11
New Mobile Application Project wizard 11
relationship between MBOs 19
sampledb 13
creating MBOs
database 16

D
database MBOs
creating 16
relationship, creating 19
database mobile business object 11
deploying
mobile business objects 22
developer profile
advanced 11
basic 11

E
Eclipse Studio Edition
Sybase Unwired WorkSpace 6
Enterprise Explorer, defined 7

G
getting started
Sybase Unwired Platform 5
Sybase Unwired WorkSpace 7
tutorials 1
goals 3

H
help, online 7

I
installing
Sybase Unwired Platform 5

M
MBOs
See also: mobile business objects 16
database, creating 16
Mobile Application Diagram, defined 7
mobile application project, creating 11
mobile application projects
deploying 22
mobile business object, developing 11
mobile business objects
See also: MBOs 16
database, creating 16
deploying 22

O
online help, accessing 7

P
Palette, defined 7
Properties view, defined 7

R
relationships between MBOs, creating 19

S
servers
Unwired Server, starting 5
starting
Sybase Control Center 6
Sybase Unwired WorkSpace 6
Unwired Server 5
Sybase Control Center 6
connecting to 6
Index

Sybase Unwired Platform
  getting started 5
  installing 5
Sybase Unwired WorkSpace
  getting started 7
  starting 6

T
  task flow 3

U
  Unwired Server 5
    changing developer profile 22
    deploying MBOs to 22
    developer advance profile 22

W
  WorkSpace Navigator, defined 7