
Tutorial: Mobile Business Object
Development

Sybase Unwired Platform 1.5.2



DOCUMENT ID: DC01208-01-0152-02
LAST REVISED: February 2011
Copyright © 2011 by Sybase, Inc. All rights reserved.
This publication pertains to Sybase software and to any subsequent release until otherwise indicated in new editions or
technical notes. Information in this document is subject to change without notice. The software described herein is furnished
under a license agreement, and it may be used or copied only in accordance with the terms of that agreement.
To order additional documents, U.S. and Canadian customers should call Customer Fulfillment at (800) 685-8225, fax (617)
229-9845.
Customers in other countries with a U.S. license agreement may contact Customer Fulfillment via the above fax number. All
other international customers should contact their Sybase subsidiary or local distributor. Upgrades are provided only at
regularly scheduled software release dates. No part of this publication may be reproduced, transmitted, or translated in any
form or by any means, electronic, mechanical, manual, optical, or otherwise, without the prior written permission of Sybase,
Inc.
Sybase trademarks can be viewed at the Sybase trademarks page at http://www.sybase.com/detail?id=1011207. Sybase and
the marks listed are trademarks of Sybase, Inc. ® indicates registration in the United States of America.
SAP and other SAP products and services mentioned herein as well as their respective logos are trademarks or registered
trademarks of SAP AG in Germany and in several other countries all over the world.
Java and all Java-based marks are trademarks or registered trademarks of Sun Microsystems, Inc. in the U.S. and other
countries.
Unicode and the Unicode Logo are registered trademarks of Unicode, Inc.
All other company and product names mentioned may be trademarks of the respective companies with which they are
associated.
Use, duplication, or disclosure by the government is subject to the restrictions set forth in subparagraph (c)(1)(ii) of DFARS
52.227-7013 for the DOD and as set forth in FAR 52.227-19(a)-(d) for civilian agencies.
Sybase, Inc., One Sybase Drive, Dublin, CA 94568.

http://www.sybase.com/detail?id=1011207


Contents

Introduction to Getting Started Tutorials ............................1
Overview of Getting Started Tutorials .............................1
Understanding the Unwired Platform Development

Environment ...............................................................2
Development in Eclipse .........................................2

Understanding Fundamental Mobile Development
Concepts ....................................................................3

Mobile Business Objects .......................................3
Synchronization Methods ......................................4
Application Types ...................................................4
Data Sources .........................................................4
Switching Between Developer Profiles ..................4

Task Flow ................................................................................7
Getting Started .......................................................................9

Installing Sybase Unwired Platform ................................9
Starting Unwired Platform Services ................................9
Starting Sybase Unwired WorkSpace ..........................10
Learning the Basics ......................................................10

Developing Database Mobile Business Objects ...............13
Creating the SUP101 Mobile Application Project .........13
Creating the sampledb Connection Profile ...................15
Creating Database Mobile Business Objects ...............17
Creating a Relationship Between Mobile Business

Objects .....................................................................20
Deploying the Database Mobile Business Objects .......23

Learn More about Sybase Unwired Platform ....................27
Index ..................................................................................29

Tutorial: Mobile Business Object Development    iii



Contents

  iv Sybase Unwired Platform  



Introduction to Getting Started Tutorials

Getting started tutorials enable users of all levels to try Sybase® Unwired Platform with
minimal setup. You can also use the tutorials to demonstrate system functionality and train
users.

Overview of Getting Started Tutorials
The getting started tutorials demonstrate how to develop, deploy, and test mobile business
objects, device applications, and message-based mobile workflow packages.

• Learn mobile business object (MBO) basics, and create a mobile device application:
• Tutorial: Mobile Business Object Development
• Tutorial: BlackBerry Application Development using Device Application Designer
• Tutorial: Windows Mobile Device Application Development using Device

Application Designer
• Create native mobile device applications:

• Tutorial: BlackBerry Application Development using Custom Development
• Tutorial: iPhone Application Development using Custom Development
• Tutorial: Windows Mobile Application Development using Custom Development

• Create a mobile workflow package:
• Tutorial: Mobile Workflow Package Development

The getting started tutorials demonstrate a cross section of basic functionality, which includes
creating MBOs that can be used in replication-based or message-based synchronization; and
using various Sybase Unwired WorkSpace development tools, independent development
environments, and device types.

Table 1. Tutorial summary

Tutorials Mobile
business
objects
(MBOs)

Synchroni-
zation types

Development
tools

Device
types

Tutorial: Mobile Business Ob-
ject Development

Create new
MBOs

Replication-
based

Sybase Unwired
WorkSpace

N/A

Tutorial: BlackBerry Applica-
tion Development using De-
vice Application Designer

Reuse
MBOs

Replication-
based

Device Applica-
tion Designer

BlackBerry
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Tutorials Mobile
business
objects
(MBOs)

Synchroni-
zation types

Development
tools

Device
types

Tutorial: BlackBerry Applica-
tion Development using Cus-
tom Development

Create new
MBOs

Replication-
based

Sybase Unwired
WorkSpace

BlackBerry

Tutorial: iPhone Application
Development using Custom
Development

Create new
MBOs

Message-based Sybase Unwired
WorkSpace

iPhone

Tutorial: Windows Mobile
Application Development us-
ing Device Application De-
signer

Reuse
MBOs

Replication-
based

Device Applica-
tion Designer

Windows
Mobile

Tutorial: Windows Mobile
Device Application Develop-
ment using Custom Develop-
ment

Create new
MBOs

Message-based Sybase Unwired
WorkSpace

Windows
Mobile

Tutorial: Mobile Workflow
Package Development

Create new
MBOs

Message-based Mobile Workflow
Forms Editor

Windows
Mobile

Understanding the Unwired Platform Development
Environment

Learn more from the getting started tutorials by understanding basic development
environment concepts. Sybase Unwired Platform provides an Eclipse development
environment.

Development in Eclipse
Sybase Unwired WorkSpace is a plug-in to your Eclipse development environment that
provides tools for creating mobile applications.

Unwired WorkSpace includes back-end integration tools that connect Unwired Server to
enterprise data sources, allowing you to create mobile business objects (MBOs) from the
back-end business data model.

Developers can perform MBO code generation at any time and use this MBO model code
along with the user interface code that users write in a native integrated development
environment (IDE). This makes the code available to transition from the Unwired WorkSpace
MBO development tool to the fully extensible and open development environment provided
for device platforms from third-party vendors. Optionally, use the Device Application
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Designer to create prototype device applications for BlackBerry and Windows Mobile
devices.

Developers can use the Mobile Workflow Forms Editor to develop message-based mobile
workflow packages for Windows Mobile and iOS devices.

Understanding Fundamental Mobile Development
Concepts

Learn more from the getting started tutorials by understanding basic mobile development
concepts.

Learn more about these concepts:

• Fundamentals
• Sybase Unwired WorkSpace – Mobile Business Object Development

Mobile Business Objects
Mobile business objects help form the business logic for mobile applications.

A mobile business object (MBO) is derived from a data source (such as a database server, Web
service, or SAP® server). MBOs are deployed to Unwired Server, and accessed from mobile
device application clients. MBOs include:

• Implementation-level details – metadata columns that include information about the data
from a data source.

• Abstract-level details – attributes that correspond to instance-level properties of a
programmable object in the mobile client, and map to data source output columns.
Parameters correspond to synchronization parameters on the mobile client, and map to
data source arguments. For example, output of a SQL SELECT query are mapped as
attributes, and the arguments in the WHERE clause are mapped as synchronization
parameters, so that the client can pass input to the query.
MBO operations include parameters that map to data source input arguments. Operation
parameters determine information a client passes to the enterprise information system
(EIS).

• Relationships – defined between MBOs by linking attributes and parameters in one MBO,
to attributes and parameters in another MBO.

You can define MBOs using either a top-down approach—first designing attributes and
parameters, then binding them to a data source; or a bottom-up approach—first specifying a
data source, then automatically generating attributes and parameters from it.

A mobile application package includes MBOs, roles, and data source connection mappings,
and other artifacts that are delivered to the Unwired Server during package deployment.

Introduction to Getting Started Tutorials

Tutorial: Mobile Business Object Development    3



Synchronization Methods
Developers can use either replication-based or message-based synchronization to move data
and transactions between device application clients and Unwired Server.

The choice depends on the target device platform, application requirements, target platform,
and the nature of data changes and activity between Unwired Server and clients, for example,
mobile workflow forms always use message-based synchronization.

Unwired Server manages and maintains data freshness between multiple data sources and
device application clients through synchronization.

Application Types
Sybase Unwired Platform supports two choices for application type. First is the native
application type, and the other is the container-based business workflow type.

The native application model enables the developer to write custom code (C#, Java, or
Objective-C, depending on the platform) to create a device application. The native application
model is supported on BlackBerry, iOS, Windows Mobile, and Windows platforms. The
choice depends on the functionality desired in the application, and the need to access third-
party and platform-provided APIs. Optionally, use the Device Application Designer to create
prototype device applications for BlackBerry and Windows Mobile devices.

The business workflow model offers a fast and simple way to build applications that support
simple business workflows, such as approvals and requests. The workflow model is supported
on iOS, Windows Mobile, and Windows platforms.

Data Sources
A data source is the enterprise information system where data is retrieved from and
transactions are executed. A connection profile is a design-time connection to a data source.
Connection profiles are created to specific data source by providing connection information
such as host, port, login, and password among others. The connection profiles are used to
define MBOs and operations, and mapped to existing, or used to create new, server
connections when the package is deployed to Unwired Server..

Unwired Platform hides the interaction complexity with datasource-specific protocols, such
as JDBC™ for database and SOAP for Web services.

Unwired Platform currently supports multiple EIS connection types. See Supported Third-
Party Software and Hardware for information.

Switching Between Developer Profiles
Switch between basic and advanced developer profiles in the Mobile Application Diagram.

If you do not see an Unwired WorkSpace feature (wizard, property, or WorkSpace Navigator
item) that you expect or need, switch to the advanced developer profile, or modify developer
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profile settings. To use backend data sources other than those supplied by Sybase Unwired
Platform, you must switch to the advanced developer profile to see the Server Connection
Mapping page when deploying the Mobile Business Object package.

1. Right-click in the Mobile Application Diagram and select Switch Developer Profile >
Basic/Advanced.

2. You can also select Window > Preferences > Sybase, Inc. > Mobile Development >
Developer Profile to directly view or modify the developer profile preference settings.
Basic is the default developer profile.

Introduction to Getting Started Tutorials
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Task Flow

Sybase Unwired WorkSpace Eclipse tutorials explain how to develop, deploy, and run a
mobile application.

Table 2. Eclipse tutorials

Task Goals Steps required to complete the
task

Getting Started • Install all required WorkSpace
components and external re-
sources.

• Start Unwired Server.

• Open the Mobile Development
perspective, and become famil-
iar with the views of the per-
spective, the Mobile Applica-
tion Diagram, and the Device
Application Designer.

• Installing Sybase Unwired Platform
on page 9

• Starting Unwired Server on page
9

• Starting Sybase Unwired Work-
Space on page 10

• Learning the Basics on page 10

Note: These tasks are prerequisites for
all the other tutorials. You need to per-
form them only once.

Developing Data-
base Mobile Busi-
ness Objects

• Create a mobile application
project and a connection to the
database.

• Create two mobile business ob-
jects, and create a relationship
between them.

• Deploy the mobile business ob-
jects to Unwired Server.

• Creating the SUP101 Mobile Appli-
cation Project on page 13

• Creating the sampledb Connection
Profile on page 15

• Creating Database Mobile Business
Objects on page 17

• Creating a Relationship Between
Mobile Business Objects on page
20

• Deploying the Database Mobile
Business Objects on page 23

Task Flow
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Getting Started

Goal: Install and learn about Sybase Unwired Platform and its associated components.

The following tasks are required, unless otherwise noted, for all tutorials, but you need to
perform them only once.

1. Installing Sybase Unwired Platform on page 9

2. Starting Unwired Platform Services on page 9

3. Starting Sybase Unwired WorkSpace on page 10

4. (optional) Learning the Basics on page 10

Installing Sybase Unwired Platform
Goal: Install Sybase Unwired Platform.

Install these Sybase Unwired Platform components:

• Data Tier
• Unwired Server
• Unwired WorkSpace
• Device Application Designer
• Windows Mobile .NET components (for developing device applications in Visual Studio)

If Unwired Platform is already installed and any of these components are missing:

1. Start the Sybase Unwired Platform installer.
2. Follow the instructions in the installation wizard.
3. Select the required components, and complete the installation.

For complete installation instructions, see the Sybase Unwired Platform Installation Guide
and Release Bulletin.

Starting Unwired Platform Services
Goal: Start Unwired Server and the sample database.

In Windows, select Start > Programs > Sybase > Unwired Platform<version>  > Start
Unwired Platform Services .

Getting Started
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Starting Sybase Unwired WorkSpace
Goal: Start Unwired WorkSpace.

1. In Windows, select Start > Programs > Sybase > Unwired Platform<version> >
Unwired WorkSpace.

Sybase Unwired WorkSpace opens, and displays the Welcome page with links to product
information, and to the product.

2. To read more about Sybase Unwired WorkSpace concepts and tasks, select Help > Help
Contents from the main menu.

Learning the Basics
Goal: Learn about Sybase Unwired WorkSpace and how to access help.

Prerequisites
Start Unwired WorkSpace.

Task

1. From the Welcome page, select any of the links to familiarize yourself with the Unwired
WorkSpace environment.

To close this page, click the X. You can reopen this page by selecting Help > Welcome.

2. Select Start Development  to access the Sybase Unwired WorkSpace development
environment. Look at the area (window or view) that you will be working in to access,
create, define, and update mobile business objects (MBOs).

View Description

WorkSpace Navigator This view displays mobile application project fold-
ers, each of which contains all project-related re-
sources in subfolders, including MBOs, data source
references to which the MBOs are bound, personal-
ization keys, and so on.

Use this view to review and modify MBO-related
properties.

Getting Started
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View Description

Enterprise Explorer A window that provides functionality to connect to
various enterprise back-end systems; for example,
database servers, SAP servers, and Sybase Unwired
Server.

Mobile Application Diagram A graphical editor where you create and define mo-
bile business objects.

Use the Mobile Application Diagram to create
MBOs (including attributes and operations), then
define relationships with other MBOs. You can:

• Create MBOs in the Mobile Application Dia-
gram using Palette icons and menu selections –
either bind or defer binding to a data source,
when creating an MBO. For example, you may
want to model your MBOs before creating the
data sources to which they bind. This is some-
times called the top-down approach.

• Drag items from Enterprise Explorer and drop
them onto the Mobile Application Diagram to
create the MBO – quickly creates the operations
and attributes automatically based on the data
source being dropped on the Mobile Application
Diagram. This is sometimes called the bottom-
up approach.

Each new mobile application project generates an
associated Mobile Application Diagram.

Palette Access the Palette from the Mobile Application Di-
agram. It provides controls, such as the ability to
create MBOs, add attributes and operations, and de-
fine relationships, by dragging and dropping the
corresponding icon onto the Mobile Application Di-
agram or existing MBO.

Properties view Select an object in the Mobile Application Diagram
to display and edit its properties in the Properties
view. You cannot create an MBO from the Properties
view, but generally, most development and configu-
ration is performed here.

Getting Started
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View Description

Outline view Displays an outline of the file that is currently open in
the editor area, and lists structural elements. The
contents are editor-specific.

Problem view Displays problems, errors, or warnings that you may
encounter.

3. To access the online help, select Help  > Help Contents from the main menu bar.

4. Expand any of the documents that appear in the left pane. Some documents are for Sybase
Unwired Platform, while others are for the Eclipse development environment.

Getting Started
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Developing Database Mobile Business
Objects

Goal: Create two mobile business objects, each using a database as its data source; create a
relationship between the two, and deploy them to Unwired Server.

Prerequisites

Complete Getting Started on page 9.

Task

Develop the database mobile business objects by completing the following tutorials, in order.

1. Creating the SUP101 Mobile Application Project on page 13

2. Creating the sampledb Connection Profile on page 15

3. Creating Database Mobile Business Objects on page 17

4. Creating a Relationship Between Mobile Business Objects on page 20

5. Deploying the Database Mobile Business Objects on page 23

Creating the SUP101 Mobile Application Project
Goal: Create a Mobile Application project to store the mobile business objects and resources
you are developing.

Several tutorials use the SUP101 Mobile Application project to store mobile business objects.

1. Select File > New > Mobile Application Project to create the project. If you do not find
the Mobile Application Project, then select: File >New >Other >Sybase >Mobile
Development >Mobile Application Project.

2. The New Mobile Application Project wizard appears. For Project Name, enter SUP101
and click Finish.
The project appears in the WorkSpace Navigator and the Mobile Application Diagram
opens.

Developing Database Mobile Business Objects
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3. Right-click in the Mobile Application Diagram Panel and select Switch developer profile
> Advanced.

Unwired WorkSpace provides two developer profiles (basic and advanced). You should be
able to complete the tutorial using the basic profile. However, as you explore Unwired
WorkSpace features you may want to work in the Advanced profile.

Developing Database Mobile Business Objects
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Creating the sampledb Connection Profile
Goal: Create a database connection profile and test the sample database connection.

Installing Sybase Unwired Platform also installs a sample database sampledb, which you
can use to create and test mobile business objects (MBOs). Starting Sybase Unwired Platform
Services automatically starts the database, depending on your license type. A default
connection profile (My Sample Database) is included with the installation, and provides
access to the sampledb database. This tutorial shows you how to create and use a new
connection profile named sampledb.

This task is required for all tutorials, but you need to perform it only once. If the sampledb
connection profile already exists, you do need not perform this task.

1. From the Enterprise Explorer, right-click the Database Connections folder and select
New to open the Wizard Selection Page.

2. Select Sybase ASA, enter sampledb as the name, and click Next.

3. Select Sybase ASA v11.x for Unwired Server Default as the driver and keep the default
settings, including dba as the User name and SQL as the Password. Select Save
Password.

Developing Database Mobile Business Objects
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4. Click Test Connection.

If Test Connection fails, verify Unwired Platform Services, including the sampledb
database, are running.

a) Select the Windows Start > Settings > Control Panel menu.
b) Select Administrative Tools, then select Services.
c) Depending on your installation options (for example, license type, whether or not you

installed a cluster, and so on) determines which Sybase services are running.

Developing Database Mobile Business Objects
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Note: If the sampledb database is not running, you can install and start it from the
command line. To install it, use the command sampledb install auto/manual. For
example:
C:\Sybase\UnwiredPlatform\Servers\UnwiredServer\bin> sampledb 
install auto

To start it from the command line, run the command sampledb start. For example:
C:\Sybase\UnwiredPlatform\Servers\UnwiredServer\bin> sampledb 
start

5. In the Ping Succeeded message, click OK.

6. Click Finish.

View the sampledb connection profile from Enterprise Explorer by expanding the Database
Connections folder.

Creating Database Mobile Business Objects
Goal: Create two mobile business objects, each from a database object.

Prerequisites

Complete Creating the sampledb Connection Profile on page 15and Creating the SUP101
Mobile Application Project on page 13.

Task

1. Open the SUP101 mobile application project if it is not already open:

In WorkSpace Navigator, right-click on the SUP101 folder and select Open in Diagram
Editor.

2. In the Enterprise Explorer, expand the Database folder, right-click sampledb, and select
Connect, if not already connected. Enter SQL as the password if prompted.

3. Expand the sampledb database, then expand the Tables folder.

4. Select the customer table, while holding the mouse button drag the customer table onto the
Mobile Application Diagram.

Developing Database Mobile Business Objects
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The Quick Create wizard launches.

5. In the Quick Create wizard, accept the defaults and click OK.

Developing Database Mobile Business Objects
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6. Create another MBO from the sales_order table:

a) Drag the sales_order table from Enterprise Explorer, and drop it onto the Mobile
Application Diagram.

b) In the Quick Create wizard, accept the defaults and click OK.

The customer and sales_order MBOs display on the Mobile Application Diagram.

Developing Database Mobile Business Objects
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7. Select File > Save.

Creating a Relationship Between Mobile Business Objects
Goal: Create a relationship between mobile business objects to associate related data and
maintain data synchronization on the device.

Prerequisites

Complete Creating Database Mobile Business Objects on page 17.

Task

In this tutorial, you create a relationship between the customer and sales_order mobile
business objects (MBO).

1. In the Palette, click Relationship.

Developing Database Mobile Business Objects
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2. Select the customer MBO and, keeping the mouse button pressed, drag the Relationship
link to the sales_order  MBO to establish the relationship link.

The Relationship Creation wizard opens.

3. Accept the General default settings. In the Mappings section, select the id attribute in the
Source object pane and cust_id in the Target object pane, or drag id from the Source
Object to cust_id in the Target Object.

Developing Database Mobile Business Objects
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A line connects the two attributes.

4. Click Finish.

The mobile application diagram now shows the link from the customer MBO to the
sales_order MBO.

Developing Database Mobile Business Objects
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5. Select File > Save.

Deploying the Database Mobile Business Objects
Goal: Deploy the project that contains the database mobile business objects to the server.

Prerequisites

• Getting Started on page 9
• Creating Database Mobile Business Objects on page 17

Task

1. Right-click in the SUP101 Mobile Application Diagram , and select Deploy Project.
The Deploy Mobile Application Project wizard appears.

Developing Database Mobile Business Objects
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2. Accept the defaults (including Replication-based), and click Next.
The Contents page appears.

3. Select the customer and sales_order MBOs and click Next.
The Package Jars page appears.

4. Click Next.
The Target Server page appears.

5. Select My Unwired Server from the list of available servers, then select Refreshor
Connect.

Accept the default Domain and Security configuration settings, and click Next.

Developing Database Mobile Business Objects
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6. If you have multiple server connections, the Server Connection Mapping page appears.
Select the sampledb server connection from the drop-down list and click Finish.

If the runtime database connection were on a remote machine, you would select New
Server Connection, which allows you to create a connection from an existing template.

The deployment progress window appears.

7. Click OK when the deployment status window appears.

A status window indicates progress and a successful deployment.

8. Connect to Unwired Server and view the deployed project, by expanding Domains >
default > Packages. The server package SUP101:1.0 into which you deployed the MBOs
appears in the Packages folder. The two MBOs, appear in the Mobile Business Objects
folder.

Developing Database Mobile Business Objects
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The MBOs are now available for access by device applications or for deploying in a
production environment. You will use this project in other getting started tutorials.

Developing Database Mobile Business Objects
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Learn More about Sybase Unwired Platform

Once you have finished, try some of the other samples or tutorials, or refer to other
development documents in the Sybase Unwired Platform documentation set.

Getting Started Tutorials
Try out some of the other getting started tutorials to get a broad view of the development tools
available to you.

Advanced Tutorials
Tutorials are available that demonstrate how to use some of Sybase Unwired Platform
advanced features.

Check the Sybase Web site regularly for updates. Navigate to Support > Product
Documentation > Sybase Unwired Platform, then select the most current version of the
document.

Samples
Sample applications are fully developed, working applications that demonstrate the features
and capabilities of Sybase Unwired Platform.

Check the Sybase Web site regularly for updates. Navigate to the Sybase Web site, then select
Products > Sybase Unwired Platform > Use tab: http://www.sybase.com/products/
mobileenterprise/sybaseunwiredplatform?htab=USE.

Online Help
See the online help that is installed with the product, or the Product Documentation Web site.

Check the Sybase Web site regularly for updates. Navigate to Support > Product
Documentation > Sybase Unwired Platform, then select the most current version of the
document.

Developer References
See the Developer References to learn about using the API to custom code device applications
using the API.

• Developer Reference for BlackBerry
• Developer Reference for iOS
• Developer Reference for Mobile Workflow Packages
• Developer Reference for Windows and Windows Mobile

Check the Sybase Web site regularly for updates. Navigate to Support > Product
Documentation > Sybase Unwired Platform, then select the most current version of the
document.

Learn More about Sybase Unwired Platform
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Javadocs are also available in the installation directory.

Programmer References
See the Programmer References to learn how to use the Administration API and Server API to
extend functionality.

• Reference: Administration APIs  – integrate your own administrative tools with Unwired
Platform to monitor and manage Unwired Platform.

• Reference: Custom Development for Unwired Server  – customize some Unwired Server
features.

Check the Sybase Web site regularly for updates. Navigate to Support > Product
Documentation > Sybase Unwired Platform, then select the most current version of the
document.

Javadocs are also available in the installation directory.

Learn More about Sybase Unwired Platform
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