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About this Release Bulletin

This release bulletin discusses known issues, workarounds, as well as late-breaking
documentation updates for Sybase® Unwired Platform version 1.5.5.

This release bulletin is a companion document for the Sybase Unwired Platform 1.5.5 Cover
Letter and New Features documents:

• For a list of previous issues that have been fixed in this release, read the Cover Letter
included with the EBF archive file you downloaded.

• For information about new features of this release, see the Sybase Unwired Platform 1.5.5
New Features guide.

Note: This release bulletin is cumulative, and includes some information from EBFs or
Maintenance Releases. See the cover letters included with EBF archive files for additional
information.

EBF and Maintenance Release Changes

Describes cumulative changes added to 1.5.5 by way of EBF or Maintenance releases. See the
cover letter with the archive download for additional information.

EBF 18422: 1.5.5 Patch Changes

CR # Description

652784 iOS and Xcode version changes for 1.5.5

These versions changes were made for 1.5.5:

• Xcode version 3.2.5 is supported.

• iOS SDK version 4.2 is supported. Previous versions of the SDK are no longer sup-
ported with the EBF 18422: 1.5.5 patch.

• The <UnwiredPlatform_InstallDir>\UnwiredPlatform
\Servers\UnwiredServer\ClientAPI\ObjectiveC
\libs.iPad directory is removed from 1.5.5, and the libs directory is now used

for both iPhone and iPad.

This changes how you set up the Xcode development environment to work with generated
iPhone code from Sybase Unwired Platform. See Importing Libraries and Code into the
Xcode IDE on page 2.
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Release Bulletin 1



Importing Libraries and Code into the Xcode IDE
Import the generated MBO code and associated libraries into the iOS development
environment.

Note: For more information on Xcode, refer to the Apple Developer Connection: http://
developer.apple.com/tools/Xcode/.

1. In the Xcode IDE, create a new Xcode project.

2. Select the General tab, and set Base SDK for All Configurations to iOS 4.2. If your
code needs to run on a device with an earlier version of the OS (such as 3.2 for iPad, or 3.1.3
for iPhone), this can be changed by setting the iPhone OS Deployment Target on the Build
tab.

3. Copy the generated code from your Microsoft Windows environment to a location on your
Mac (for example, your Home directory).

4. Copy over the include files from<unwired server install>\ClientAPI
\ObjectiveC\includes and the libraries from <unwired server install>
\ClientAPI\ObjectiveC\libs to a directory on your Mac (for example, your
Home directory). The libs directory includes libraries for both iPhone and iPad.

EBF and Maintenance Release Changes
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a) After copying the directories into a local directory on your Mac, open Finder and
locate the <unwired server install>\ClientAPI\ObjectiveC
\includes folder.

b) Drag the <unwired server install>\ClientAPI\ObjectiveC
\includes\internal and <unwired server install>\ClientAPI
\ObjectiveC\includes\public subfolders into Groups & Files, under the
project name.

c) If prompted to copy existing items into the destination group’s folder, ensure Copy
items into destination group’s folder (if needed) is selected and then click Add to
copy the include\internal and include\public directories into your
project’s folder.

5. Add the generated *.h and *.m files to the project:
a) In the Xcode Groups & Files pane, right-click <Project Name>, and create a new

group in your project.
b) Import the generated code into the new group by selecting Add, then Existing

Files.
c) Navigate to the directory that contains the generated code.
d) Select both the includes and src folders for the generated code. Click Add.
e) If prompted to copy existing items into the destination group’s folder, ensure Copy

items into destination group’s folder (if needed) is selected and then click Add to
copy the Generated Code folder into your project’s folder. This step ensures that
all .h and .m files are added to the project’s search path.

6. Add libclientrt.a, libSUPObj.a, and libMO.a to your project.

a) In the Xcode Groups & Files pane, select and right-click <Project Name> and select
Add, then Existing Files.

b) Navigate to the directory where you copied the libraries.
c) Select the libclientrt.a, libSUPObj.a, and libMO.a libraries in Finder.

Drag the libraries into Xcode under your project's name.
d) Select Copy items into destination group’s folder (if needed), then click Add.

Note: The library version should correspond to the configuration you are building. For
example, if you are building for a debug version of the simulator, navigate to libs/
Debug-iphonesimulator/ to add the libraries.

7. Add Settings.bundle to the Xcode project:

a) Select and right-click <Resources>, and select Add, then Existing Files.
b) Navigate to the includes directory, select Settings.bundle, and add it.
c) Select Copy items into destination group’s folder (if needed), then click Add.

Note: This allows the device client user to use the Settings application to input their user
preference information, such as server name, server port, user name, and activation code.

8. Add the following frameworks from the SDK to the project by selecting Project > Edit
Active Target <ProjectName> > General.
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• Security.framework
• AddressBook.framework
• QuartzCore.framework
• CoreFoundation.framework
• libicucore.A.dylib
• libz.1.2.3.dylib
• libstdc++.dylib

9. Edit the Xcode project Library Search Paths by selecting Project > Edit Active Target
<ProjectName> > Build > Search Paths > Library Search Paths. Specify the path to the
location where you copied the libraries in step 6. Remove any libstdc++ paths (such as
usr/lib/arm-apple-darwin10/4.2.1) from the library search path.

a) Edit the Header Search Paths to include the include\internal and include
\public directories.

10. For debug device builds, check Build Active Architecture Only on the Build tab, and make
sure that the armv6 architecture is selected. If the build is for iPad, then make sure iPhone/
iPad is selected as the Targeted Device Family.

11. Write your application code to reference the generated MBO code. See the Developer
Reference for iOS for information about referencing the iOS Client Object API.

EBF and Maintenance Release Changes
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Known Issues with Installing, Uninstalling,
and Upgrading

Learn about known security, installation, uninstallation, and upgrade issues and workarounds.

Security Alert

CR # Description

664906 Oracle issues a security advisory for JDK 1.6 Update 24

Oracle has announced a critical patch update for JDK 1.6 on Windows, and other JDK/JRE
versions on other platforms. Due to successful security attacks, Oracle advises all users to
update their JDK/JRE installation to JDK 1.6 Update 24 immediately.

This impacts Sybase Unwired Platform installations, since JDK 1.6 is distributed with the
product.

To learn more about the Sun/Oracle critical patch advisory:

• http://www.oracle.com/technetwork/topics/security/javacpufeb2011-304611.html

• http://www.oracle.com/technetwork/java/javase/overview/index.html

Workaround: To keep your Sybase Unwired Platform installation secure, download and
apply the JDK 1.6 Update 24 patch as described in Updating JDK 1.6 for Sybase Unwired
Platform on page 5.

Updating JDK 1.6 for Sybase Unwired Platform
Download the JDK 1.6 patch from the Oracle Web site, and update your Sybase Unwired
Platform 1.5.5 environment. Since Unwired Platform uses the JDK in several places, you will
need to update the JDK PATH in several files, and recreate the Unwired Server service to use
the new JDK PATH.

Follow these procedures for each node in your Sybase Unwired Platform environment:

1. Navigate to the Oracle site: http://www.oracle.com/technetwork/java/javase/downloads/
index.html.

2. Select the appropriate JDK 1.6 patch level 24, and download it. You may have to search the
Web site archives for Update 24.

3. Follow the Oracle self-extracting instructions for the download you selected (for example
32 bit or 64 bit). Extract the files to the appropriate location:

Known Issues with Installing, Uninstalling, and Upgrading
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• 32-bit OS: <UnwiredPlatform_InstallDir>\UnwiredPlatform
\JDK1.6.0_xx

• 64-bit OS: <UnwiredPlatform_InstallDir>\UnwiredPlatform
\JDK1.6.0_xx-x64

4. Update all instances of the JDK path (for example, change JDK1.6.0_16 to
JDK1.6.0_24) in these batch files:

• UnwiredWorkSpace.bat, located in:
<UnwiredPlatform_InstallDir>\UnwiredPlatform\Eclipse\

• set-java-home.bat, located in:
<UnwiredPlatform_InstallDir>\UnwiredPlatform\Servers
\UnwiredServer\bin\

Note: This file is set with 64-bit JDK path on 64-bit OS.

• set-java-home.bat, located in:
<UnwiredPlatform_InstallDir>\UnwiredPlatform\Servers
\UnwiredServer\OpenDS\lib\

• myenvClient.bat and myenv.bat, located in:
<UnwiredPlatform_InstallDir>\SCC-3_0\bin\

5. Run the sup-server-service.bat batch file from the command prompt.

• sup-server-service.bat is located in:
<UnwiredPlatform_InstallDir>\UnwiredPlatform\Servers
\UnwiredServer\bin\

UnwiredServer\bin\sup-server-service.bat remove

UnwiredServer\bin\sup-server-service.bat install manual[auto]

This re-creates the Unwired Server service with the updated JDK path.

6. Restart Unwired Server.

Known Issues with Installing, Uninstalling, and Upgrading
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Known Issues for Unwired Server

Learn about known issues and apply workarounds for Unwired Server.

CR # Description

631466 When you use "asadbservice.bat stop" to stop a server service, you may encounter an
error where the server service stops, but the database service keeps running.

This may occur because the default timeout for a Windows service is 20 seconds, which
does not give the database service enough time stop.

Workaround: Run reconfigure-mms.bat, then use Windows Services to manually stop the
database service. For details, see System Administration of the Unwired Platform > System
Reference.

628914 If you are already using a messaging application with one relay server, you cannot
switch to another relay server in the same application during runtime.

Workaround: Uninstall, then reinstall, the current messaging application on the device.
Before you use the messaging application after the reinstallation, change the relay server
information in the Profile screen.

576726 The full range of valid values is not supported if the attribute uses the default datatype
(int) for an Adaptive Server® Anywhere database column of type unsigned
int.

Workaround: To support the full range of valid values for an unsigned int attribute,
set the datatype for the attribute as long.

Known Issues for Sybase Control Center

Learn about known issues and apply workarounds for Sybase Control Center.

CR # Description

651517 Package import fails in clustered environments.

The import/export feature in Sybase Control Center used for staging packages from de-
velopment to production cluster environments does not replicate packages correctly.

Workaround: Avoid the import/export feature and deploy the package archive instead (for
example, Sybase Control Center package deployment or the deploy command).

625108 An administrator cannot search the Device Notification domain log by user.

Workaround: Use other criteria, such as device or package, to perform a search.

Known Issues for Unwired Server
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Known Issues for Sybase Unwired WorkSpace
– Mobile Business Object Development

Learn about known issues and apply workarounds for Unwired WorkSpace and mobile
business object (MBO) development.

CR # Description

648243 SAP data type string (variable length) is detected as STRING(8)

The SAP data types STRING and XSTRING (both without length restriction) are dis-
covered in Unwired WorkSpace as STRING(8) and XSTRING(8) respectively.

Workaround: Modify the discovered length of the generated parameter or attribute to a
length that suits your needs. In the current implementation, any specified length larger than
32767 automatically causes a column of unrestricted length to be generated in the device
database.

621243 The deployment and code generation of a mobile business object fails if you name it
with one of these words that is a Java datatype or C# value type: binary, boolean, byte,
char, date, datetime, time, decimal, double, float, object, int, integer, long, short,
string.

Workaround: Do not use these words as part of the MBO name.

617546 An update operation fails if set maxlength for the attribute is less than the length in the
enterprise information (EIS) database column.

If rtrim is not used in these cases, the update operation fails with this exception:

com.sybase.vader.da.jdbc.MinCheckAffected
  RowCountException.null

Workaround: Use the rtrim function in the SQL statement to update operations for char
datatype columns, such as:

SELECT dept_id,
rtrim(dept_name) as dept_name,
dept_head_id FROM sampledb.dba.department

613403 When generating MBO attributes from an Adaptive Server Enterprise table, Visual
SQL may display a SQLSTATE=42000 error message.

Because Unwired WorkSpace cannot retrieve the datatype of the parameter in the where
clause when you access Visual SQL, the datatype is set to String by default, which can
lead to a type conversion error.

Workaround: Ignore the warning message. The MBO is created successfully.

Known Issues for Sybase Unwired WorkSpace – Mobile Business Object Development
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CR # Description

611864 When you drag and drop a stored procedure that uses one of several datatypes as a
parameter or returns a resultset with a column of one of these types to a new MBO, the
resultset contains only the RETURN_VALUE row.

The affected datatypes are: long varbit, varbit, uniqueidentifier,
xml, long nvarchar, nchar, and nvarchar.

Workaround: None.

594744 The correct Date/Datetime/Time datatype cannot be retrieved when you cre-
ate an MBO; the datatype is incorrectly set to string.

When you edit an MBO definition you see Data source or definition has
changed. Do you want to refresh and remap?. If you select yes, an
error message similar to The metadata is not in sync with the
backend data source appears. This error is caused by a JDBC driver limitation.

Workaround:

1. Click OK in the error dialog.
2. In the Properties view, select Attributes > Load Parameters tab.
3. Change the datatype of the parameter and datasource type to DATE/DATETIME/

TIME to match the column type of the datasource.

4. Specify the Propagate to column to match the datasource column to which it is being
propagated.

5. Refresh the definition to clear the error.

584645 Use the rtrim function in relationships between two string attributes that map from a
char field.

When the enterprise information system (EIS) is a SQL Anywhere database and you create a
relationship between two string attributes that map from a char field, and the nullability
setting for the char field in the parent table is not null, the char field in child table is nullable.
The relationship does not work.

Workaround: Manually update the query statement for the parent MBO to apply the rtrim()
function to the char field in the column list.

For example, if the original query for the parent MBO is:

select region from sampledb.dbo.sales_regions

update the SQL statement to:

select rtrim(region) as region from sampledb.dbo.sales_re-
gions

Known Issues for Sybase Unwired WorkSpace – Mobile Business Object Development
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CR # Description

642942 Cannot generate code with Javadoc option enabled to a folder containing Chinese
characters

When using the code generation wizard, if you enable the option to generate javadoc, you
cannot generate the code to a folder containing Chinese characters without first changing
the Language for non-uniode programs to Chinese.

Workaround:

1. From the Start menu, select Settings > Control Panel.
2. Double-click Regional and Language Options, then click the Advanced tab.
3. From the drop-down list, select Chinese, and click Apply.
4. Click OK.

Known Issues for Sybase Unwired WorkSpace
– Device Application Development

Learn about known issues and apply workarounds for Unwired WorkSpace and device
application development.

Code Generation
Describes known issues when using Sybase Unwired WorkSpace to generate mobile
application code for BlackBerry, Windows, Windows Mobile, or Apple applications.

CR Description

649216 Visual Studio generated target path cannot contain Chinese characters on Windows7.

In Windows7, if the generated project target path contains non-ASCII characters, the com-
pilation fails. This issue occurs because the default character encoding of Windows 7 is
INconsistent with Java default String encoding.

Workaround: Either:

• Use only ASCII characters in the path and solution name, or,

• Open the generated project in Visual Studio, then compile and immediately deploy it to
a device.

Device Application Designer
Describes known issues when using Device Application Designer to create BlackBerry or
Windows Mobile applications, or generating code using Device Application Designer.

Known Issues for Sybase Unwired WorkSpace – Device Application Development
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CR # Description

648922 StackOverflowException when application includes both a radio group and

table control on some devices.

This issue occurs when the region control takes up only one column.

Workaround: Set the region's horizontal span to 2 in the Device Application Designer.

Known Issues for Sybase Unwired WorkSpace – Device Application Development
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CR # Description

648280 Argument exception thrown when local MBO for all data types is updated.

If an update form contains a binary text box, then the form cannot be opened in the Visual
Studio Form Designer and an error appears:

Events cannot be set on the object passed to the event bind-
ing service because a site associated with the object could 
not be located.

This error occurs because of the default behaviour of Visual Studio. In Visual Studio
designer code, the default data binding event handle cannot be changed, and this is why the
error appears.

Workaround: Move the statement of change data binding format event handle to the
constructor of the form.

For example, locate this code:

private void InitializeComponent()
 {
.........
      System.Windows.Forms.Binding localobjectattribute12Ed-
itboxBinding=new
        System.Windows.Forms.Binding("Text", this.LocalOb-
jectBindingSource, "Attribute12",
        true, System.Windows.Forms.DataSourceUpdateMode.Nev-
er);
     localobjectattribute12EditboxBinding.Format += new 
   System.Windows.Forms.ConvertEventHandler(Localobjectat-
tribute12EditboxBinding_Format);
this.localobjectattribute12Editbox.DataBindings.Add(local-
objectattribute12EditboxBinding);
........
 }

And change it to:

private void InitializeComponent()
 {
.........
      System.Windows.Forms.Binding localobjectattribute12Ed-
itboxBinding=new
        System.Windows.Forms.Binding("Text", this.LocalOb-
jectBindingSource, "Attribute12",
        true, System.Windows.Forms.DataSourceUpdateMode.Nev-
er);
     // comment the below line
     // localobjectattribute12EditboxBinding.Format += new 
System.Windows.Forms.ConvertEventHandler(Localobjectattri-
bute12EditboxBinding_Format);                       this.lo-
calobjectattribute12Editbox.DataBindings.Add(localobjectat-
tribute12EditboxBinding);

Known Issues for Sybase Unwired WorkSpace – Device Application Development
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CR # Description

........
 }

Then add this code to the constructor:

public FormUpdateLocalobject()
{
   Cursor.Current = Cursors.WaitCursor;
   InitializeComponent();
   if (this.localobjectattribute12Editbox.DataBindings != 
null && 
      this.localobjectattribute12Editbox.DataBind-
ings.Count != 0)
         {
             this.localobjectattribute12Editbox.DataBind-
ings[0].Format += new 
                System.Windows.Forms.ConvertEventHandler(Lo-
calobjectattribute12EditboxBinding_Format);
         }
............
}

648103 When navigating from a grid table screen to a create screen and back again, the grid
table becomes shorter.

As a result, you cannot scroll to the bottom of the table.

Workaround: Refresh the screen.

647955 Device controls in Visual Studio Forms Designer do not work.

After the controls are added to the form, there are some compilation errors:

The type or namespace name 'Drawing' does not exist in the 
namespace 'Sybase.UnwiredPlatform.Windows'.

Workaround: Add C:\UnwiredPlatform\Unwired_WorkSpace\Vis-
ualStudio\ComponentLibrary\PocketPC\Sybase.Unwired-
Platform.Windows.dll to project reference before you add the Sybase controls

through the form designer.

646823 Datetime type of EditBox missing validation.

In the Device Application Designer, if the generated BlackBerry screens have input fields
that expect a Datetime type, and if a device user then enters invalid Datetime values (for
example, "2010-1111-01T1111"), no validation error dialog appears.

Workaround: Use the datetime picker to ensure the value is entered correctly.

Known Issues for Sybase Unwired WorkSpace – Device Application Development
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CR # Description

645593 Composite deletes for child MBOs generates an error.

When synchronizing a child MBO to submit a composite delete for a child MBO, an error
message appears: com.sybase.up.bobclient.data.MobileAppEx-
ception:com.sybase.persistence.OjbectNotFoundExcep-
tion. This error occurs because the parent has been deleted for that specific child, and

therefore the operation cannot be successfully submitted.

Workaround: Do not synchronize the child MBO.

638549 ObjectNotFoundException thrown while deleting a new pending row.

When you update or delete a pending new object, and configure the Device Application
Designer to submit the operation immediately, you get an ObjectNotFoundEx-
ception.

Workaround: Ensure all create, update, delete operations are configured identically, either
with a pending state or not; do not mix them.

632216 When two MBOs have multiple one-to-one relationships, the generated Device Ap-
plication Designer may miss menu items that use these relationships.

Workaround:

1. On the Flow Design page, select the detail screen of the parent MBO.

2. Go to the Screen Design page.

3. Drag and drop a menu item onto the Menu area.

4. Enter a menu item name.

5. Add a Save Context action to the menu item:

• Control – List Detail on Display.

• Relationship – select the relationship that the Device Application Designer missed.

6. Add a Connection action to the same menu item with these values:

• Connection – Goto

• Screen – the detail screen where the relationship should take the user to.

629782 A Windows Mobile or BlackBerry device throws an exception with SQLE_NOT_IM-
PLEMENTED.

Workaround: If the device client database throws this exception in a JOIN query, verify join
fields to ensure they are the same type.

Known Issues for Sybase Unwired WorkSpace – Device Application Development
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CR # Description

627602 When you try to install a generated message-based synchronization application on the
Windows Mobile Emulator using a storage card, you see an error message similar to
Some kind of disk I/O error occurred when you start the applica-

tion.

This problem is restricted to the emulator, and does not occur in the device itself. The error is
caused by the SQLite library, which handles applications installed on external storage
memory differently than those installed in the main storage area.

Workaround: Install the application in the main storage memory of emulator, or test the
application using an actual Windows Mobile device instead of the emulator.

586955 Failed to compile BlackBerry device application if the items of choice have large
amounts of data.

If the BlackBerry device application (custom code or generated code from Device Appli-
cation Designer) contains too many String literals, they are propagated into the generated
Java classes. This propagation can cause compiling errors like Data contribution
too large. Although RIM gives a suggestion at http://www.blackberry.com/knowl-
edgecenterpublic/livelink.exe/fetch/2000/348583/800901/Support_-_Error_cod_da-
ta_section_too_large.html?nodeid=800816&vernum=0, the same error still occurs when
the length of string literal exceeds 12315.

Workaround: Do not use long String literals.

Mobile Workflow Forms Editor
Describes known issues when using Mobile Workflow Forms Editor to create message-based
mobile workflows.

CR # Description

649091 Cannot customize child parameter mappings for list type.

Currently, for workflow form operations that list parameters generated by dragging and
dropping, the child parameter mapping appears to not work and cannot be changed.

Workaround: Manually edit the generated .xml file.

648247 In the screen after the server-initiated starting point, you cannot select list keys with
the dynamic choice control.

Workaround: Select the list keys from the list control instead.

Known Issues for Sybase Unwired WorkSpace – Device Application Development
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CR # Description

646973 Workflow Extraction Rules do not support double quotes ("") to delimit parameter
values.

For example, if you want to extract the receiver's name John Smith from the To field of the
mail, and you use double quote tags, the rule fails:

Tag Before Parameter: "
Tag After Parameter: " <jsmith@google.com>

Workaround: Use single quotes (' ') to tag parameters:

Tag Before Parameter: '
Tag After Parameter: ' <jsmith@google.com>

646957 The DateReceived extraction rule type is not supported.

Workaround: Do not use this rule.

645864 Incorrect error description for workflow screens.

If you have a parameter that is not mapped to a key, an error appears:

"The screen 'Department_create' has a menu item 'Create' 
which is trying to invoke the operation 'create' on the 'De-
partment' MBO without having an instance of that MBO."

This message does not accurately reflect the issue.

Workaround:  Either the parameter is:

• Capable of being filled by an attribute, but the user has no MBO instance available to it,
or,

• Unmapped, and has no default value, or,

• Mapped to a personalization key.

Resolve any of these issues and the error disappears.

Known Issues for Sybase Unwired WorkSpace – Device Application Development
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CR # Description

639179 Avoid unnecessary data refresh of MBOs in workflow packages that are not bound to
data sources.

If you have MBOs that are not bound to any data source, but have operations, create a
"dummy" MBO so you can search for it within the workflow MBO search dialog.

Workaround: Create a data source with no data to create an MBO without a real data
source. For example:

1. Create a staged BAPI function inside the SAP system, or create a staged table in the
backend database system.

2. Use Unwired WorkSpace to generate the MBO by mapping to that staged BAPI func-
tion or staged table.

3. Create a separate cache policy and separate synchronization group for this MBO.

4. Set the cache policy to DCN. This prevents data refresh of the MBO during runtime.

638607 Overlap between email list key and object query resultset key.

If you have both an email starting point that invokes an object query and a menu item that
triggers an object query on the same MBO, they each use different keys (for example,
MyMBO and MyMBO_findAll_resultSetKey), regardless of whether the user needs to use
the same key.

Workaround: Revise the implementation to use different keys and screens for any screen
that follows the:

• email starting point

• menu item that triggers a query

636248 Matching rules that are defined in the Workflow wizard or the Notification Processing
wizard cannot be removed.

Workaround: Use the Flow Design page > Properties view > Matching Rules tab to
remove these rules.

628826 Copying and pasting an issue with multiple objects.

Workaround: Copy and paste only one Listview or Htmlview at a time.

596195 Mobile Workflow applications do not support NULL values.

You cannot send NULL values from the client to the server. If you attempt to retrieve NULL
values from the server, the attempt fails.

Workaround: Do not use NULL values.

Known Issues for Sybase Unwired WorkSpace – Device Application Development
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Known Issues for Device Clients and
Applications

Learn about known issues and apply workarounds for device applications.

Common Issues for Multiple Device Types

CR # Description

651389 Windows Mobile and BlackBerry client applications may leak database connections.

For these types of applications, each thread is allocated a database connection when doing
CRUD operation on the package MBO. The connection remains on the thread and is not
closed unless you explicitly call closeConnection. If the application spawns a

thread, performs any operation then throws the thread away, the connection remains open
until the application exits.

Workaround:Explicitly call closeConnection before destroying threads.

649551 If user credentials are changed in the backend SAP system, applications can still access
SAP content.

This connection remains open, because Unwired Server pools open connections that were
originally created with credentials that are now invalid. Because SAP JCo client connec-
tions do not support reauthentication, the same session remains active despite using expired
credentials.

Workaround: Update the SAP credentials used in Sybase Control Center. Then clear the
existing connection currently pooled by stopping and restarting Unwired Server.

649083 Sort works incorrectly device applications when child MBOs that have multiple pri-
mary keys.

For Blackberry and Windows applications, object queries and dynamic queries do not work
properly in this case:

When a query includes a similar SELECT statement:

SELECT * FROM MBO WHERE attribute1 = something ORDER BY at-
tribute2

and when this same SELECT statement sets attribute1 or attribute2 as primary keys or part
of a named query's WHERE clause, the query fails.

Workaround: Remove the named query that contains the where clause of attribute1 or
attribute2, and instead use a dynamic query for that named query, including the one shown in
the SELECT statement.

Known Issues for Device Clients and Applications
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CR # Description

648305 Sync screen hangs when an MBO does an initial sync.

When an MBO contains many attributes, the default client database page size might not be
appropriate. Consequently, the generated application takes a long time to synchronize the
MBO.

Workaround: Manually increase the page size for the database client on the device.

629818 Passing null values for user name/password personalization keys is not supported.

Workaround: None.

594804 When performing a search with "equals" and "ends with" search criteria, you see an
Unable to find... message.

When performing a search with "does not end with" search criteria, all the rows are shown.

Workaround: If your table includes the char column, you can use SQL with rtrim(column

name) as the column name in the MBO definition. For example:

SELECT   dept_id,
           rtrim(dept_name) as dept_name,
           dept_head_id 
  FROM sampledb.dba.department

Known Issues for BlackBerry
Learn about known issues and apply workarounds specific to the BlackBerry.

CR # Description

628249 Cannot see details of photos taken by in-device camera on BlackBerry 8220 and 9000.

When you try to display a photo taken by the device's camera in an MBO details screen or
pending operation screen, you cannot see the image in detail, and the pending screen cannot
focus on the column.

Workaround: Use a non-bitmap image instead of a photo.

641424 BlackBerry application incorrectly displays "Previous instance still active" message.

When you perform the following actions on OS 5.0, you might get a Previous in-
stance still active message:

1. From the application, press Back button to exit.

2. Re-open the application and press Back button to exit again.

Workaround: None. Ignore the message.

Known Issues for Device Clients and Applications
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CR # Description

623504 You see unexpected errors when you shut down a BlackBerry Mobile Data System
during synchronization.

Workaround: Restart MDS. For more information on this known BlackBerry issue, see the
BlackBerry Issue Tracker page at https://www.blackberry.com/jira/browse/JAVAAPI-1131
(login required).

619983 On BlackBerry devices, you cannot input Chinese characters into the password
field.

Protected personalization keys and passwords use the same user interface component on
RIM, which does not allow Chinese characters.

Workaround:  None.

612195 Cannot import memo to the device application when performing a Read Memo PIM
action by focusing on the memo in the memo list.

This applies to:

• BlackBerry 8900, version 4.6.1

• BlackBerry 9000, version 4.6.0

• BlackBerry 9530, version 4.7.0

• BlackBerry 8220, version 4.6.0

Workaround:

1. Open the memo in the memo list.

2. Perform the import.

567841 Extra icon appears on BlackBerry device application.

If you generate code using the Device Application Designer Code Generation wizard with
the Debug the BlackBerry application with the BlackBerry Java Plug-in option, then
run the application using the BlackBerry Java pug-in for Eclipse, an extra icon appears on
the device screen.

Workaround: None. You can ignore the extra icon. It does not affect application use.

Known Issues for Windows and Windows Mobile
Learn about known issues and apply workarounds specific to Windows and Windows Mobile.

Known Issues for Device Clients and Applications
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CR # Description

641760 When the device user selects a date using the time picker control, the Control screen
freezes.

This happens when Datetime field does not have focus.

Workaround: Give the Datetime field focus before using the time picker.

622391 Double-byte characters are not supported for Windows Mobile device ribbon names.

If the Windows Mobile device ribbon name contains double-byte characters in Device
Application Designer, you receive a compile error or generate Windows Mobile CAB error
after code generation.

Workaround: None.

617045 On some Windows Mobile devices, the editbox control properties Show Border and
vertical and horizontal spans do not show properly on the device.

Workaround: None.

Known Issues for APIs and Custom
Development

Learn about known issues and apply workarounds for APIs and custom development.

CR # Description

651359 DynamicQuery API calls from MBOs fail.

Invoking FindWithQuery with this query causes a NullPointerExcep-
tion:

Query query = new Query();
            Object valueObject = null;
            query.TestCriteria = AttributeTest.Equal("PHASE", 
valueObject);

Workaround: To query for null fields, use the IS_NULL operator:

Query query = new Query();
            query.TestCriteria = AttributeTest.Is-
Null("PHASE");

Known Issues for APIs and Custom Development
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CR # Description

620706 You cannot insert DEFAULT in the timestamp column when the API is accessing SQL
Server.

Workaround: DEFAULT is a Microsoft SQL keyword, and cannot be set by the client.
Instead, use this create operation:

insert into sql_date (c_datetime, c_smalldt) val-
ues(:dt1, :dt2)

Documentation Issues and Updates

Read about updates, corrections, and clarifications to the documentation released with Sybase
Unwired Platform 1.5.5.

CR # Description

649885 Incorrect navigation paths in the documentation. Through the course of documentation
enhancements, these navigation paths have shifted. These navigation issues will be cor-
rected in a future version.

Workaround: Use the document title to locate the topic and search on the topic title listed.

Installation
The following issues were identified in this document. This document was not updated with
this release.

Title Summary

Performing
a Cluster
Installation
of Deploy-
ment Edi-
tion

When performing the data tier installation of Unwired Platform and selecting the
Install Data Tier into high availability environment option, it may be unclear what
information to enter into the Enter a path to Microsoft cluster setup field.

Enter the path to the shared cluster storage resource that will house the data tier
database files. The path must use a drive letter mapped on each data tier host. It cannot
be a UNC path. The path must point to an empty directory, or a new directory to be
created by the installer, in the shared cluster storage resource.

Documentation Issues and Updates
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Title Summary

Postinstal-
lation Tasks

The documentation of Unwired Sever says that for the deployment edition, you should
configure security for LDAP. However, this information should be more precise. Un-
wired Platform is installed with no-authentication security by default. Consequently
all applications authenticate everyone successfully unless the default is changed. Any
supported provider can be used, not just LDAP.

Ensure you configure Unwired Server in Sybase Control Center to use a third-party
security provider. Do not leave the default no-authentication security mode enabled as
your production configuration.

Sybase Unwired WorkSpace - Device Application
Development

The following issues were identified in this document. These issues could not be corrected in
time for publication.

Title Summary

Adding Con-
trols to Con-
tainers

Screen capture is not updated for 1.5.5.

Disregard the screen capture in this topic. The interface in Unwired WorkSpace
uses correct versions.

Mobile Busi-
ness Object Re-
lationships

Creating a single child on composite relationship does not work.

When one child screen has two or more relationships with a parent, and a create
operation is submitted through a composite relationship, then the user subsequently
drills down through the other relationship to the child to perform a create operation,
both fail to upload to server.

A failed create, update, delete on a composite relationship child causes the parent
to be in pending status and the user sees that in the pending operation screen, but
because its status is not create, update, or delete, it appears as "other."

Information in this section should clarify that when you are using a composite MBO
relationship as a datasource, and performing an operation on a child screen, you
must always go through the parent screen, or the operation fails.

Configuring the BlackBerry Java Plug-in for Eclipse Standalone
Environment

If the supported version of the BlackBerry Java Plug-in for Eclipse is unavailable for the
version of Sybase Unwired Platform you are using, this is an alternative way to develop
BlackBerry applications using the BlackBerry Java Plug-in for Eclipse.

Prerequisites
Generate the code for the Device Application Designer. See Sybase Unwired Platform 1.5.5 >
Sybase Unwired WorkSpace - Device Application Development Documentation >

Documentation Issues and Updates
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Prototyping a Device Application Using the Designer > Prototyping a Device Application
Using the Device Application Designer > Generating Device Application Code > Generating
Code for a BlackBerry Device Application. In the Device Application Designer code
generation wizard, in the Locations options, select Generate code only.

Task

1. Download the BlackBerry Java Plug-in for Eclipse (full installer) from http://
us.blackberry.com/developers/javaappdev/. Follow the installation instructions provided
with the download and install it in its own location (not in the Sybase Unwired Platform
Eclipse directory).

2. Open the standalone BlackBerry Java Plug-in for Eclipse.

3. To use the generated code from the Device Application Designer, you must create two new
BlackBerry projects—a client project and an option project. Create the client project:

a) Select File > New > BlackBerry Project.
b) In the New BlackBerry Project wizard, enter a project name, for example,

DeptDemoClient, and click Next.
c) In Java Settings, click Next.
d) On the Templates page, select Empty Application and click Finish.
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4. Create the option project:

a) Select File > New > BlackBerry Project.
b) In the New BlackBerry Project wizard, enter a project name, for example,

DeptDemoOption, and click Next.
c) In Java Settings, click Next.
d) On the Templates page, select Empty Library and click Finish.

5. Delete all of the automatically created files in the src and res folders for each project.

6. Open the BlackBerry_App_Descriptor.xml file for each project and delete the
application icons.

7. Add build paths for the projects:

a) Right-click the DeptDemoClient project and select Build Path > Configure Build
Path.

b) On the Properties page, select Java Build Path in the left pane, and click Add
External Jars.

c) Navigate to <UnwiredPlatform_InstallDir>\UnwiredPlatform
\Unwired_WorkSpace\Eclipse\sybase_workspace\mobile
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\eclipse\plugins\com.sybase.uep.bob.rim_<version>
\generate\blackberry\build-<BlackBerry_OS_version> and
double-click BOBFramework.jar to add it to the build path.

d) Expand the BOBFramework.jar file and select Javadoc location, then click
Edit .

e) Set the location to <UnwiredPlatform_InstallDir>\UnwiredPlatform
\Unwired_WorkSpace\Eclipse\sybase_workspace\mobile
\eclipse\plugins\com.sybase.uep.bob.rim_<version>
\generate\blackberry\BOBFrameworkJavadoc.zip and click OK.

f) Repeat these steps to add the BOBFramework.jar file to the build path for the
DeptDemoOption project.

g) Add the UltraLiteJ.jar file to the build path for DeptDemoOption by navigating
to <UnwiredPlatform_InstallDir>\UnwiredPlatform
\Unwired_WorkSpace\Eclipse\sybase_workspace\mobile
\eclipse\plugins\com.sybase.uep.bob.rim_<version>
\generate\blackberry.
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8. Copy the generated files from the Device Application Designer to the DeptDemoClient
project.
By default, the generated files are in the DAD Generated Code
\<application_name>.bob\Blackberry folder in the Mobile Application
project that contains the Device Application Designer file.
a) From DAD Generated Code\<application_name>.bob\Blackberry

\generated, copy the application folder to the DeptDemoClient project's
<root path>\generated (not the src folder).

These files contain the generated UI classes, custom screen and action classes, the
image resources used by custom screens and actions, the extra source for custom
screens and actions, and the BOBUIController.java file.

b) From DAD Generated Code\<application_name>.bob\Blackberry
\generated, copy the images folder to the DeptDemoClient project's <root
path>\generated.

These files contain the images used on the application UI.
c) If the application uses SubClasses or WidgetEvents, there is a custom folder under

DAD Generated Code\<application_name>\Blackberry. Copy it to
DeptDemoClient project's root path.

d) Copy the build_version.txt, build-shared.xml, and run-
simulator.xml files to the DeptDemoClient root path.
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9. Copy the generated files from the Device Application Designer to the DeptDemoOption
project.

a) From DAD Generated Code\<application_name>.bob\Blackberry
\generated, copy the option folder to the DeptDemoOption project's <root
path>\generated.

These files contain the generated classes of setting screens, styles, and the
OptionsMain.java file.

b) From DAD Generated Code\<application_name>.bob\Blackberry
\generated, copy the images folder to the DeptDemoOption project's <root
path>\generated.

These files contains the images used on the application UI.
c) From DAD Generated Code\<application_name>.bob\Blackberry,

copy the object_api folder to the DeptDemoOption project's root path.

d) From DAD Generated Code\<application_name>.bob\Blackberry,
copy the temp_afx folder to the DeptDemoOption project's root path.
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10. Add the files to the DeptDemoClient project source.

a) Right-click the client project and select Build Path > Configure Build Path.
b) Click the Source tab and click Add Folder.
c) Select the generated\application, generated\images, and custom\application

folders (if applicable) and click OK.
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d) Click the Projects tab and click Add.
e) Select the DeptDemoOption project and click OK.
f) Click OK.

11. Add the files to the DeptDemoOption project source.

a) Right-click the option project and select Build Path > Configure Build Path.
b) Click the Source tab and click Add Folder.
c) Select the generated\option, generated\images, and object_api\genfiles\java\src

folders and click OK.
d) Click OK.

12. Open the BlackBerry_App_Descriptor.xml file for DeptDemoClient, and set
the values for title, version, vendor, and description. Add an application icon by selecting
the ribbon image from generated\images.

13. Go to the Build page of BlackBerry_App_Descriptor.xml for DeptDemoClient.
For example, if the project is for BlackBerry OS 5.0.0, add VER_5_0_0 to Preprocessor
Directives, and set it to active.
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14. Open the BlackBerry_App_Descriptor.xml file for the DeptDemoOption
project and set the values for version, vendor, and description. Select Auto-run on
startup.

15. Set up the simulator environment:

a) From <UnwiredPlatform_InstallDir>\UnwiredPlatform
\Unwired_WorkSpace\Eclipse\sybase_workspace\mobile
\eclipse\plugins\com.sybase.uep.bob.rim_<version>
\generate\blackberry, copy the UltraLiteJ.cod and
UltraLiteJ.alx files to the plugins
\net.rim.ejde.componentpack<BlackBerry_OS_version>
\components\simulator directory of the standalone BlackBerry Java Plug-in
for Eclipse.

b) From <UnwiredPlatform_InstallDir>\UnwiredPlatform
\Unwired_WorkSpace\Eclipse\sybase_workspace\mobile
\eclipse\plugins\com.sybase.uep.bob.rim_<version>
\generate\blackberry\build-<BlackBerry_OS_version>, copy
SUPPushListener.cod, SUPPushListener.alx, BOBFramework.cod,
BOBFramework.alx, BOBFramework.debug, and BOBFramework-
n.debug files to the plugins
\net.rim.ejde.componentpack<BlackBerry_OS_version>
\components\simulator directory of the standalone BlackBerry Java Plug-in
for Eclipse.

c) (Optional) If custom coding uses any third party jar files, copy all those related files to
the Simulator location as well (.jar files, .cod files, and so on).

16. Right-click DeptDemoClient and select Run As > BlackBerry Simulator.
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System Administration
The following issues were identified in this document. These issues could not be corrected in
time for publication.

Title Summary

Setting Up
Data Tier
Nodes

Step three in the Setting Up Data Tier Nodes topic refers to the 1.5.2 Installation Guide
topic, Installing the Data Tier on a Separate Host for a Deployment Installation. This
topic is now called Installing the Data Tier on its Own Host for a Deployment Instal-
lation.

Note: For cluster setup information, see 1.5.5 System Administration starting with the
topic Implementing an N+2-node Cluster for Optimal Redundancy.

Backing
Up System
Data

Default locations for Unwired Server and Sybase Control Center database and trans-
action log files have been added to Backing Up System Data.

This information would also be useful for:

• System Administration > Introduction to Sybase Unwired Platform > Platform
Components > Runtime Databases

• System Administration > Systems Maintenance and Monitoring > Backup and
Recovery > Backing Up System Data > Backing Up a SQL Anywhere Database >
Validating and Backing Up Platform Data

Managing
Backup
Transac-
tion Logs

Sybase recommends that you manage the size of transaction logs as part of your backup
and restore policy. See Managing Transaction Logs for information.

Server Per-
formance
Tuning

A new property was added to support messaging performance. The message size lim-
itation can be changed by modifying an internal Unwired Server property,
sub.msg.mzx_content_size. If you feel the 20KB value should be
changed, work with your Sybase representative.

The current message size limit for Unwired Server is 20KB. In general, enlarging the
message size results in a lower number of messages, and higher efficiency.

Performance also depends on the device environment. A message that is too large
stresses the device, and negates efficiency. Device factors include memory and size of
the object graph being sent. In some cases, a larger message size terminates message
processing. When the Unwired Server message size exceeds the limit, the message is
immediately sent to the client side.
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Title Summary

Apple Pro-
visioning
for iOS

A new 2048-bit Entrust certificate needed for Apple Push Notification Service (APNS)
push to work, because APNS push functionality stops working on 22 December 2010.

Apple now uses a 2048-bit root certificate from Entrust, which provides a more secure
connection between Unwired Server and APNS. This certificate comes with the Win-
dows OS, and is upgraded automatically with Windows Update, if it is enabled. This
information is not part of the procedure that documents APNS support.

If Windows Update is disabled, you must manually download and install the certificate.
Go to: https://www.entrust.net/downloads/binary/entrust_2048_ca.cer. For help on in-
stalling the certificate, see http://www.entrust.net/knowledge-base/technote.cfm?
tn=8282.

Managing Transaction Logs
Manage the size of transaction logs to prevent the log files from growing indefinitely.

You could use the SQL Anywhere dbbackup utility, with the -xo flag. The -xo flag deletes the
current transaction log file, once it has been backed up successfully, and creates a new one. See
SQL Anywhere® Server – Database Administration for information.

You could also use a variant of the SQL Anywhere BACKUP DATABASE command. See the
SQL Anywhere Server – SQL Reference for BACKUP DATABASE command options. This
example performs daily backups automatically from within the database server:

CREATE EVENT NightlyBackup
SCHEDULE
START TIME '23:00' EVERY 24 HOURS
HANDLER
BEGIN
   DECLARE dest LONG VARCHAR;
   DECLARE day_name CHAR(20);
   
   SET day_name = DATENAME( WEEKDAY, CURRENT DATE );
   SET dest = 'd:\\backups\\' || day_name;
           BACKUP DATABASE DIRECTORY dest
   TRANSACTION LOG RENAME;
END;

Backing Up System Data
For platform data, back up Unwired Server runtime databases and Sybase Control Center
(SCC) repositories using the process described for SQL Anywhere databases. Messaging
database requires its own process.
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Table 1. Runtime Database Default File Locations

Runtime Databa-
ses

Default File Locations

Unwired Server For a Developer Edition installation, database files and transaction logs are
installed:

<UnwiredPlatform_InstallDir>\UnwiredPlat-
form\Servers\UnwiredServer\data

• Consolidated database:

• Database file: default.db

• Transaction log: default.log

• Cluster database:

• Database file: clusterdb.db

• Transaction log: clusterdb.log

• Monitor database:

• Database file: monitordb.db

• Transaction log: monitordb.log

For a separate Data-tier node, these database files and transaction logs are
installed:

• With a Microsoft cluster, in the Microsoft cluster folder you created:

<Microsoft_cluster_folder>\CDB

• With no Microsoft cluster:

<UnwiredPlatform_InstallDir>\UnwiredPlat-
form\Data\CDB

Sybase Control Center Database files and transaction logs on each Unwired Server node:

<UnwiredPlatform_InstallDir>\SCC-3_0\serv-
ices\Repository

• Database file: scc_repository.db

• Transaction log: scc_repository.log

Note: When you make a backup, decide where to store the backup files: on the Unwired Server
host or on some other computer or third-party hardware/software package used for backup
purposes.
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Sybase Control Center Online Help
The following issues were identified in this document. These issues could not be corrected in
time for publication.

Title Summary

Protecting the
LDAP Login
Module Bind-
Password Prop-
erty

A new topic is added that describes how to encrypt an LDAP bind password in the
Sybase Unwired Platform LDAP Login Module. This procedure uses the csi-
tool.jar. See Protecting the LDAP Login Module BindPassword Property
on page 35.

Note: For other login modules, you can continue to use the procedure in En-
crypting a Password, which uses the passencrypt utility.

Protecting the LDAP Login Module BindPassword Property
Encrypt an LDAP Server bind password that must be kept secure while stored in the Sybase
Control Center csi.properties file.

Prerequisites

• Sybase Unwired Platform (version 1.5.2, 1.5.3, or 1.5.5) must be installed.
• Sybase Control Center must be started via Microsoft Windows service.

Task

This procedure assumes that Sybase Unwired Platform and Sybase Control Center are
installed at the default location, typically C:\Sybase\UnwiredPlatform for Sybase
Unwired Platform, and C:\Sybase\SCC-3_0 for Sybase Control Center.

1. Use Microsoft Windows service to stop Sybase Unified Agent 3.0.

2. Modify the registry:

a) Run regedt32.exe to open the registry editor.

Note: This step should be performed by a knowledgeable system administrator.

b) Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\SYBASE\Unified Agent
3.0.

c) Create a String value named jvmopt6, and set its value to:

–Dcom.sybase.security.BootstrapConfigurationURL=file:///C:/
Sybase/UnwiredPlatform/Servers/UnwiredServer/Repository/CSI/
csibootstrap.properties

Note: If jvmopt6 already exists, use jvmopt7, or a similar name.
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3. Copy C:\Sybase\UnwiredPlatform\Servers\UnwiredServer
\Repository\CSI\csikeystore.jceks to C:\Sybase\SCC-3_0.

4. Encrypt the password by running:
java -jar C:\Sybase\UnwiredPlatform\Servers\UnwiredServer\lib\ext
\csi-tool.jar csi.encmessage @C:\Sybase\UnwiredPlatform\Servers
\UnwiredServer\Repository\CSI\csibootstrap.properties --text 
secret

Note: This example encrypts the password secret, which is the default value of bind
password for the OpenDS LDAP Server installed by Unwired Server (Developer Edition
installation only).

5. Navigate to C:\Sybase\SCC-3_0\conf\csi.properties, and update
csi.properties with the encrypted password string generated in the previous step, as
follows:
CSI.loginModule.
8.options.AuthenticationSearchBase=ou=users,dc=example,dc=com
CSI.loginModule.8.options.BindDN=cn=Directory Manager
CSI.loginModule.8.options.BindPassword.e=1-
AAAAEgQQVbvdEKVgXU6uEeFauCtmwqP3745Y6j5Q1fbwupIxXUe0HUBsnyFcHpXMl
fmCG3jGm1fhUcm4E5PdwUqtJaSlvQ==
CSI.loginModule.8.options.DefaultSearchBase=dc=example,dc=com
CSI.loginModule.8.options.ProviderURL=ldap://helxp-vm1:10389
CSI.loginModule.
8.options.RoleSearchBase=ou=groups,dc=example,dc=com
CSI.loginModule.8.options.ServerType=openldap
CSI.loginModule.8.options.moduleName=SUP LDAP Login Module
CSI.loginModule.
8.provider=com.sybase.ua.services.security.ldap.LDAPWithRoleLogin
Module
CSI.loginModule.8.controlFlag=sufficient

6. Use Microsoft Windows service to restart Sybase Unified Agent 3.0.

Reference: Administration APIs
The following issues were identified in this document. These issues could not be corrected in
time for publication.

Title Summary

Deploying a Pack-
age through the
SUPDomain inter-
face

Code example describes a parameter by an incorrect file type

The code example for the deployPackage method describes the file
name parameter as a deployment unit (DU). The file name should be the jar
archive generated using "Sybase Unwired WorkSpace - Mobile Business Ob-
ject Development tooling" for MBO package deployment.
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Troubleshooting
The following issues were identified in this document. These issues could not be corrected in
time for publication.

Title Summary

Attempt to
Upgrade
Unwired
Server Fails

Problem: When attempting to upgrade Unwired Server with an EBF, in a cluster, the
upgrade process fails. The failure occurs when upgrading the messaging service.

Explanation: This occurs if the user account does not have read and write permissions
to the shared data folder on the consolidated database (CDB) node. The user account
used to upgrade to 1.5.5 must have read and write permissions to the shared data folder,
otherwise, the upgrade fails, indicating that the messaging server failed to upgrade.

Solution:

1. If necessary, uninstall anything that has been installed successfully.
2. Log on with a user account with the appropriate permissions.

Obtaining Help and Additional Information

Use the Sybase Getting Started CD, Product Documentation site, and online help to learn
more about this product release.

• The Getting Started CD (or download) – contains release bulletins and installation guides
in PDF format, and may contain other documents or updated information.

• Product Documentation at http://sybooks.sybase.com/ – is an online version of Sybase
documentation that you can access using a standard Web browser. You can browse
documents online, or download them as PDFs. In addition to product documentation, the
Web site also has links to EBFs/Maintenance, Technical Documents, Case Management,
Solved Cases, Community Forums/Newsgroups, and other resources.

• Online help in the product, if available.

To read or print PDF documents, you need Adobe Acrobat Reader, which is available as a free
download from the Adobe Web site.

Note: A more recent release bulletin, with critical product or document information added
after the product release, may be available from the Product Documentation Web site.

Obtaining Help and Additional Information
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Technical Support
Get support for Sybase products.

If your organization has purchased a support contract for this product, then one or more of
your colleagues is designated as an authorized support contact. If you have any questions, or if
you need assistance during the installation process, ask a designated person to contact Sybase
Technical Support or the Sybase subsidiary in your area.

Downloading Sybase EBFs and Maintenance Reports
Get EBFs and maintenance reports from the Sybase Web site.

1. Point your Web browser to http://www.sybase.com/support.

2. From the menu bar or the slide-out menu, under Support, choose EBFs/Maintenance.

3. If prompted, enter your MySybase user name and password.

4. (Optional) Select a filter from the Display drop-down list, select a time frame, and click
Go.

5. Select a product.

Padlock icons indicate that you do not have download authorization for certain EBF/
Maintenance releases because you are not registered as an authorized support contact. If
you have not registered, but have valid information provided by your Sybase
representative or through your support contract, click My Account to add the “Technical
Support Contact” role to your MySybase profile.

6. Click the Info icon to display the EBF/Maintenance report, or click the product description
to download the software.

Sybase Product and Component Certifications
Certification reports verify Sybase product performance on a particular platform.

To find the latest information about certifications:

• For partner product certifications, go to http://www.sybase.com/detail_list?id=9784
• For platform certifications, go to http://certification.sybase.com/ucr/search.do

Obtaining Help and Additional Information
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Creating a MySybase Profile
MySybase is a free service that allows you to create a personalized view of Sybase Web pages.

1. Go to http://www.sybase.com/mysybase.

2. Click Register Now.

Accessibility Features
Accessibility ensures access to electronic information for all users, including those with
disabilities.

Documentation for Sybase products is available in an HTML version that is designed for
accessibility.

Vision impaired users can navigate through the online document with an adaptive technology
such as a screen reader, or view it with a screen enlarger.

Sybase HTML documentation has been tested for compliance with accessibility requirements
of Section 508 of the U.S Rehabilitation Act. Documents that comply with Section 508
generally also meet non-U.S. accessibility guidelines, such as the World Wide Web
Consortium (W3C) guidelines for Web sites.

Note: You may need to configure your accessibility tool for optimal use. Some screen readers
pronounce text based on its case; for example, they pronounce ALL UPPERCASE TEXT as
initials, and MixedCase Text as words. You might find it helpful to configure your tool to
announce syntax conventions. Consult the documentation for your tool.

For information about how Sybase supports accessibility, see the Sybase Accessibility site: 
http://www.sybase.com/products/accessibility. The site includes links to information about
Section 508 and W3C standards.

You may find additional information about accessibility features in the product
documentation.
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